__builtin__.object

Home Trees Index Help

wxPython

Module __builtin__ :: Class object
[frames | no frames]

Type object

Known Subclasses:
AcceleratorEntry, ArrowHead, ArtProvider, BusyCursor, CalendarDateAttr, Caret, ClipboardLocker, ConfigBase, ConfigPathChanger, Constraint, ConstraintType, CPPFileSystemHandler, DataFormat, DataObject, DateSpan, DateTime, Diagram, Display, DrawOp, DropSource, DropTarget, EventLoop, FileType, FileTypeInfo, FontEnumerator, FontMapper, GBPosition, GBSpan, GridCellAttr, GridCellAttrProvider, GridCellCoords, GridCellEditor, GridCellRenderer, GridTableMessage, HelpProvider, HtmlBookRecord, HtmlContentsItem, HtmlHelpData, HtmlRenderingInfo, HtmlRenderingState, HtmlRenderingStyle, HtmlSearchStatus, HtmlSelection, IconBundle, IconLocation, ImageHistogram, InputStream, ItemContainer, Joystick, LanguageInfo, ListItemAttr, Locale, Log, LogNull, MimeTypesManager, MutexGuiLocker, NativeEncodingInfo, NativeFontInfo, Object, OutputStream, Point, Point2D, PropagateOnce, PropagationDisabler, PseudoMetaFile, PyEventBinder, Quantize, RealPoint, Rect, ShapeEvtHandler, ShapeRegion, ShapeTextLine, SingleInstanceChecker, Size, Sound, StandardPaths, StopWatch, SystemSettings, TextAttr, TimerRunner, TimeSpan, TipProvider, TreeItemData, TreeItemId, type, VideoMode, VisualAttributes, WindowDisabler, XmlNode, XmlProperty, XmlSubclassFactory

The most base type

Method Summary
__init__(...)
x.__init__(...) initializes x; see x.__class__.__doc__ for signature
__delattr__(...)
x.__delattr__('name') <==> del x.name
__getattribute__(...)
x.__getattribute__('name') <==> x.name
__hash__(x)
Return hash(x)...
__new__(T, S, ...)
Return a new object with type S, a subtype of T...
__reduce__(...)
helper for pickle
__reduce_ex__(...)
helper for pickle
__repr__(x)
Return repr(x)...
__setattr__(...)
x.__setattr__('name', value) <==> x.name = value
__str__(x)
Return str(x)...

Class Variable Summary
type __class__ = __builtin__.type

Method Details

__init__(...)
(Constructor)

x.__init__(...) initializes x; see x.__class__.__doc__ for signature

__delattr__(...)

x.__delattr__('name') <==> del x.name

__getattribute__(...)

x.__getattribute__('name') <==> x.name

__reduce__(...)

helper for pickle

__reduce_ex__(...)

helper for pickle

__setattr__(...)

x.__setattr__('name', value) <==> x.name = value

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:10:48 2005 http://epydoc.sf.net


__builtin__.type

Module __builtin__ :: Class type
[frames | no frames]

Type type

object --+
         |
        type

type(object) -> the object's type type(name, bases, dict) -> a new type

Method Summary
__call__(x, ...)
Return x(...)...
__cmp__(x, y)
Return cmp(x,y)...
__delattr__(...)
x.__delattr__('name') <==> del x.name
__getattribute__(...)
x.__getattribute__('name') <==> x.name
__hash__(x)
Return hash(x)...
__new__(T, S, ...)
Return a new object with type S, a subtype of T...
__repr__(x)
Return repr(x)...
__setattr__(...)
x.__setattr__('name', value) <==> x.name = value
list of immediate subclasses __subclasses__()
list mro()
return a type's method resolution order

Class Variable Summary
type | __base__ = __builtin__.object
tuple | __bases__ = (<type 'object'>,)
int | __basicsize__ = 420
int | __dictoffset__ = 132
int | __flags__ = 21995
int | __itemsize__ = 20
tuple | __mro__ = (<type 'type'>, <type 'object'>)
str | __name__ = 'type'
int | __weakrefoffset__ = 184

Method Details

__delattr__(...)

x.__delattr__('name') <==> del x.name

Overrides:
__builtin__.object.__delattr__

__getattribute__(...)

x.__getattribute__('name') <==> x.name

Overrides:
__builtin__.object.__getattribute__

__setattr__(...)

x.__setattr__('name', value) <==> x.name = value

Overrides:
__builtin__.object.__setattr__

mro()

return a type's method resolution order

Returns:
list

Class Variable Details

__bases__

Type:
tuple
Value:
(<type 'object'>,)

__basicsize__

Type:
int
Value:
420

__dictoffset__

Type:
int
Value:
132

__flags__

Type:
int
Value:
21995

__itemsize__

Type:
int
Value:
20

__mro__

Type:
tuple
Value:
(<type 'type'>, <type 'object'>)

__name__

Type:
str
Value:
'type'

__weakrefoffset__

Type:
int
Value:
184

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:10:49 2005 http://epydoc.sf.net


code.InteractiveInterpreter

Module code :: Class InteractiveInterpreter

Class InteractiveInterpreter

Known Subclasses:
Interpreter, PyShellWindow

Base class for InteractiveConsole.

This class deals with parsing and interpreter state (the user's namespace); it doesn't deal with input buffering or prompting or input file naming (the filename is always passed in explicitly).

Method Summary
 | __init__(self, locals) Constructor.
 | runcode(self, code) Execute a code object.
 | runsource(self, source, filename, symbol) Compile and run some source in the interpreter.
 | showsyntaxerror(self, filename) Display the syntax error that just occurred.
 | showtraceback(self) Display the exception that just occurred.
 | write(self, data) Write a string.

Method Details

__init__(self, locals=None)
(Constructor)

Constructor.

The optional 'locals' argument specifies the dictionary in which code will be executed; it defaults to a newly created dictionary with key "__name__" set to "__console__" and key "__doc__" set to None.

runcode(self, code)

Execute a code object.

When an exception occurs, self.showtraceback() is called to display a traceback. All exceptions are caught except SystemExit, which is reraised.

A note about KeyboardInterrupt: this exception may occur elsewhere in this code, and may not always be caught. The caller should be prepared to deal with it.

runsource(self, source, filename='<input>', symbol='single')

Compile and run some source in the interpreter.

Arguments are as for compile_command().

One several things can happen:

1) The input is incorrect; compile_command() raised an exception (SyntaxError or OverflowError). A syntax traceback will be printed by calling the showsyntaxerror() method.

2) The input is incomplete, and more input is required; compile_command() returned None. Nothing happens.

3) The input is complete; compile_command() returned a code object. The code is executed by calling self.runcode() (which also handles run-time exceptions, except for SystemExit).

The return value is True in case 2, False in the other cases (unless an exception is raised). The return value can be used to decide whether to use sys.ps1 or sys.ps2 to prompt the next line.

showsyntaxerror(self, filename=None)

Display the syntax error that just occurred.

This doesn't display a stack trace because there isn't one.

If a filename is given, it is stuffed in the exception instead of what was there before (because Python's parser always uses "<string>" when reading from a string).

The output is written by self.write(), below.

showtraceback(self)

Display the exception that just occurred.

We remove the first stack item because it is our own code.

The output is written by self.write(), below.

write(self, data)

Write a string.

The base implementation writes to sys.stderr; a subclass may replace this with a different implementation.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:51 2005 http://epydoc.sf.net


distutils.cmd.Command

Package distutils :: Module cmd :: Class Command

Class Command

Known Subclasses:
clean, install, install_data, install_headers

Abstract base class for defining command classes, the "worker bees" of the Distutils. A useful analogy for command classes is to think of them as subroutines with local variables called "options". The options are "declared" in 'initialize_options()' and "defined" (given their final values, aka "finalized") in 'finalize_options()', both of which must be defined by every command class. The distinction between the two is necessary because option values might come from the outside world (command line, config file, ...), and any options dependent on other options must be computed after these outside influences have been processed -- hence 'finalize_options()'. The "body" of the subroutine, where it does all its work based on the values of its options, is the 'run()' method, which must also be implemented by every command class.

Method Summary
__init__(self, dist)
Create and initialize a new Command object.
__getattr__(self, attr)
announce(self, msg, level)
If the current verbosity level is of greater than or equal to 'level' print 'msg' to stdout.
copy_file(self, infile, outfile, preserve_mode, preserve_times, link, level)
Copy a file respecting verbose, dry-run and force flags.
copy_tree(self, infile, outfile, preserve_mode, preserve_times, preserve_symlinks, level)
Copy an entire directory tree respecting verbose, dry-run, and force flags.
debug_print(self, msg)
Print 'msg' to stdout if the global DEBUG (taken from the DISTUTILS_DEBUG environment variable) flag is true.
dump_options(self, header, indent)
ensure_dirname(self, option)
ensure_filename(self, option)
Ensure that 'option' is the name of an existing file.
ensure_finalized(self)
ensure_string(self, option, default)
Ensure that 'option' is a string; if not defined, set it to 'default'.
ensure_string_list(self, option)
Ensure that 'option' is a list of strings.
execute(self, func, args, msg, level)
finalize_options(self)
Set final values for all the options that this command supports.
get_command_name(self)
get_finalized_command(self, command, create)
Wrapper around Distribution's 'get_command_obj()' method: find (create if necessary and 'create' is true) the command object for 'command', call its 'ensure_finalized()' method, and return the finalized command object.
get_sub_commands(self)
Determine the sub-commands that are relevant in the current distribution (ie., that need to be run).
initialize_options(self)
Set default values for all the options that this command supports.
make_archive(self, base_name, format, root_dir, base_dir)
make_file(self, infiles, outfile, func, args, exec_msg, skip_msg, level)
Special case of 'execute()' for operations that process one or more input files and generate one output file.
mkpath(self, name, mode)
move_file(self, src, dst, level)
Move a file respectin dry-run flag.
reinitialize_command(self, command, reinit_subcommands)
run(self)
A command's raison d'etre: carry out the action it exists to perform, controlled by the options initialized in 'initialize_options()', customized by other commands, the setup script, the command-line, and config files, and finalized in 'finalize_options()'.
run_command(self, command)
Run some other command: uses the 'run_command()' method of Distribution, which creates and finalizes the command object if necessary and then invokes its 'run()' method.
set_undefined_options(self, src_cmd, *option_pairs)
Set the values of any "undefined" options from corresponding option values in some other command object.
spawn(self, cmd, search_path, level)
Spawn an external command respecting dry-run flag.
warn(self, msg)

Class Variable Summary
list sub_commands = []

Method Details

__init__(self, dist)
(Constructor)

Create and initialize a new Command object. Most importantly, invokes the 'initialize_options()' method, which is the real initializer and depends on the actual command being instantiated.

announce(self, msg, level=1)

If the current verbosity level is of greater than or equal to 'level' print 'msg' to stdout.

copy_file(self, infile, outfile, preserve_mode=1, preserve_times=1, link=None, level=1)

Copy a file respecting verbose, dry-run and force flags. (The former two default to whatever is in the Distribution object, and the latter defaults to false for commands that don't define it.)

copy_tree(self, infile, outfile, preserve_mode=1, preserve_times=1, preserve_symlinks=0, level=1)

Copy an entire directory tree respecting verbose, dry-run, and force flags.

debug_print(self, msg)

Print 'msg' to stdout if the global DEBUG (taken from the DISTUTILS_DEBUG environment variable) flag is true.

ensure_filename(self, option)

Ensure that 'option' is the name of an existing file.

ensure_string(self, option, default=None)

Ensure that 'option' is a string; if not defined, set it to 'default'.

ensure_string_list(self, option)

Ensure that 'option' is a list of strings. If 'option' is currently a string, we split it either on /,s*/ or /s+/, so "foo bar baz", "foo,bar,baz", and "foo, bar baz" all become ["foo", "bar", "baz"].

finalize_options(self)

Set final values for all the options that this command supports. This is always called as late as possible, ie. after any option assignments from the command-line or from other commands have been done. Thus, this is the place to code option dependencies: if 'foo' depends on 'bar', then it is safe to set 'foo' from 'bar' as long as 'foo' still has the same value it was assigned in 'initialize_options()'.

This method must be implemented by all command classes.

get_finalized_command(self, command, create=1)

Wrapper around Distribution's 'get_command_obj()' method: find (create if necessary and 'create' is true) the command object for 'command', call its 'ensure_finalized()' method, and return the finalized command object.

get_sub_commands(self)

Determine the sub-commands that are relevant in the current distribution (ie., that need to be run). This is based on the 'sub_commands' class attribute: each tuple in that list may include a method that we call to determine if the subcommand needs to be run for the current distribution. Return a list of command names.

initialize_options(self)

Set default values for all the options that this command supports. Note that these defaults may be overridden by other commands, by the setup script, by config files, or by the command-line. Thus, this is not the place to code dependencies between options; generally, 'initialize_options()' implementations are just a bunch of "self.foo = None" assignments.

This method must be implemented by all command classes.

make_file(self, infiles, outfile, func, args, exec_msg=None, skip_msg=None, level=1)

Special case of 'execute()' for operations that process one or more input files and generate one output file. Works just like 'execute()', except the operation is skipped and a different message printed if 'outfile' already exists and is newer than all files listed in 'infiles'. If the command defined 'self.force', and it is true, then the command is unconditionally run -- does no timestamp checks.

move_file(self, src, dst, level=1)

Move a file respectin dry-run flag.

run(self)

A command's raison d'etre: carry out the action it exists to perform, controlled by the options initialized in 'initialize_options()', customized by other commands, the setup script, the command-line, and config files, and finalized in 'finalize_options()'. All terminal output and filesystem interaction should be done by 'run()'.

This method must be implemented by all command classes.

run_command(self, command)

Run some other command: uses the 'run_command()' method of Distribution, which creates and finalizes the command object if necessary and then invokes its 'run()' method.

set_undefined_options(self, src_cmd, *option_pairs)

Set the values of any "undefined" options from corresponding option values in some other command object. "Undefined" here means "is None", which is the convention used to indicate that an option has not been changed between 'initialize_options()' and 'finalize_options()'. Usually called from 'finalize_options()' for options that depend on some other command rather than another option of the same command. 'src_cmd' is the other command from which option values will be taken (a command object will be created for it if necessary); the remaining arguments are '(src_option,dst_option)' tuples which mean "take the value of 'src_option' in the 'src_cmd' command object, and copy it to 'dst_option' in the current command object".

spawn(self, cmd, search_path=1, level=1)

Spawn an external command respecting dry-run flag.

Class Variable Details

sub_commands

Type:
list
Value:
[]

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:08 2005 http://epydoc.sf.net


distutils.command.clean.clean

Package distutils :: Package command :: Module clean :: Class clean
[frames | no frames]

Class clean

Command --+
          |
         clean

Method Summary
 | finalize_options(self) Set final values for all the options that this command supports.
 | initialize_options(self) Set default values for all the options that this command supports.
 | run(self) A command's raison d'etre: carry out the action it exists to perform, controlled by the options initialized in 'initialize_options()', customized by other commands, the setup script, the command-line, and config files, and finalized in 'finalize_options()'.

Class Variable Summary
list | boolean_options = ['all']
str | description = "clean up output of 'build' command"
list | user_options = [('build-base=', 'b', "base build directo...

Method Details

finalize_options(self)

Set final values for all the options that this command supports. This is always called as late as possible, ie. after any option assignments from the command-line or from other commands have been done. Thus, this is the place to code option dependencies: if 'foo' depends on 'bar', then it is safe to set 'foo' from 'bar' as long as 'foo' still has the same value it was assigned in 'initialize_options()'.

This method must be implemented by all command classes.

Overrides:
distutils.cmd.Command.finalize_options (inherited documentation)

initialize_options(self)

Set default values for all the options that this command supports. Note that these defaults may be overridden by other commands, by the setup script, by config files, or by the command-line. Thus, this is not the place to code dependencies between options; generally, 'initialize_options()' implementations are just a bunch of "self.foo = None" assignments.

This method must be implemented by all command classes.

Overrides:
distutils.cmd.Command.initialize_options (inherited documentation)

run(self)

A command's raison d'etre: carry out the action it exists to perform, controlled by the options initialized in 'initialize_options()', customized by other commands, the setup script, the command-line, and config files, and finalized in 'finalize_options()'. All terminal output and filesystem interaction should be done by 'run()'.

This method must be implemented by all command classes.

Overrides:
distutils.cmd.Command.run (inherited documentation)

Class Variable Details

boolean_options

Type:
list
Value:
['all']

description

Type:
str
Value:
"clean up output of 'build' command"

user_options

Type:
list
Value:
[('build-base=', 'b', "base build directory (default: 'build.build-bas\
e')"),
 ('build-lib=',
  None,
  "build directory for all modules (default: 'build.build-lib')"),
 ('build-temp=',
  't',
  "temporary build directory (default: 'build.build-temp')"),
...

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:44 2005 http://epydoc.sf.net


distutils.command.install.install

Package distutils :: Package command :: Module install :: Class install
[frames | no frames]

Class install

Command --+
          |
         install

Method Summary
 | change_roots(self, *names)
 | convert_paths(self, *names)
 | create_path_file(self)
 | dump_dirs(self, msg)
 | expand_basedirs(self)
 | expand_dirs(self)
 | finalize_options(self) Set final values for all the options that this command supports.
 | finalize_other(self)
 | finalize_unix(self)
 | get_inputs(self)
 | get_outputs(self)
 | handle_extra_path(self)
 | has_data(self)
 | has_headers(self)
 | has_lib(self) Return true if the current distribution has any Python modules to install.
 | has_scripts(self)
 | initialize_options(self) Set default values for all the options that this command supports.
 | run(self) A command's raison d'etre: carry out the action it exists to perform, controlled by the options initialized in 'initialize_options()', customized by other commands, the setup script, the command-line, and config files, and finalized in 'finalize_options()'.
 | select_scheme(self, name)

Class Variable Summary
list | boolean_options = ['compile', 'force', 'skip-build']
str | description = 'install everything from build directory'
dict | negative_opt = {'no-compile': 'compile'}
list | sub_commands = [('install_lib', <function has_lib at 0xb...
list | user_options = [('prefix=', None, 'installation prefix')...

Method Details

finalize_options(self)

Set final values for all the options that this command supports. This is always called as late as possible, ie. after any option assignments from the command-line or from other commands have been done. Thus, this is the place to code option dependencies: if 'foo' depends on 'bar', then it is safe to set 'foo' from 'bar' as long as 'foo' still has the same value it was assigned in 'initialize_options()'.

This method must be implemented by all command classes.

Overrides:
distutils.cmd.Command.finalize_options (inherited documentation)

has_lib(self)

Return true if the current distribution has any Python modules to install.

initialize_options(self)

Set default values for all the options that this command supports. Note that these defaults may be overridden by other commands, by the setup script, by config files, or by the command-line. Thus, this is not the place to code dependencies between options; generally, 'initialize_options()' implementations are just a bunch of "self.foo = None" assignments.

This method must be implemented by all command classes.

Overrides:
distutils.cmd.Command.initialize_options (inherited documentation)

run(self)

A command's raison d'etre: carry out the action it exists to perform, controlled by the options initialized in 'initialize_options()', customized by other commands, the setup script, the command-line, and config files, and finalized in 'finalize_options()'. All terminal output and filesystem interaction should be done by 'run()'.

This method must be implemented by all command classes.

Overrides:
distutils.cmd.Command.run (inherited documentation)

Class Variable Details

boolean_options

Type:
list
Value:
['compile', 'force', 'skip-build']

description

Type:
str
Value:
'install everything from build directory'

negative_opt

Type:
dict
Value:
{'no-compile': 'compile'}

sub_commands

Type:
list
Value:
[('install_lib', <function has_lib at 0xb7a5c33c>),
 ('install_headers', <function has_headers at 0xb7a5c374>),
 ('install_scripts', <function has_scripts at 0xb7a5c3ac>),
 ('install_data', <function has_data at 0xb7a5c3e4>)]

user_options

Type:
list
Value:
[('prefix=', None, 'installation prefix'),
 ('exec-prefix=', None, '(Unix only) prefix for platform-specific file\
s'),
 ('home=', None, '(Unix only) home directory to install under'),
 ('install-base=',
  None,
  'base installation directory (instead of --prefix or --home)'),
 ('install-platbase=',
...

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:45 2005 http://epydoc.sf.net


distutils.command.install_data.install_data

Package distutils :: Package command :: Module install_data :: Class install_data
[frames | no frames]

Class install_data

Command --+
          |
         install_data

Method Summary
 | finalize_options(self) Set final values for all the options that this command supports.
 | get_inputs(self)
 | get_outputs(self)
 | initialize_options(self) Set default values for all the options that this command supports.
 | run(self) A command's raison d'etre: carry out the action it exists to perform, controlled by the options initialized in 'initialize_options()', customized by other commands, the setup script, the command-line, and config files, and finalized in 'finalize_options()'.

Class Variable Summary
list | boolean_options = ['force']
str | description = 'install data files'
list | user_options = [('install-dir=', 'd', 'base directory fo...

Method Details

finalize_options(self)

Set final values for all the options that this command supports. This is always called as late as possible, ie. after any option assignments from the command-line or from other commands have been done. Thus, this is the place to code option dependencies: if 'foo' depends on 'bar', then it is safe to set 'foo' from 'bar' as long as 'foo' still has the same value it was assigned in 'initialize_options()'.

This method must be implemented by all command classes.

Overrides:
distutils.cmd.Command.finalize_options (inherited documentation)

initialize_options(self)

Set default values for all the options that this command supports. Note that these defaults may be overridden by other commands, by the setup script, by config files, or by the command-line. Thus, this is not the place to code dependencies between options; generally, 'initialize_options()' implementations are just a bunch of "self.foo = None" assignments.

This method must be implemented by all command classes.

Overrides:
distutils.cmd.Command.initialize_options (inherited documentation)

run(self)

A command's raison d'etre: carry out the action it exists to perform, controlled by the options initialized in 'initialize_options()', customized by other commands, the setup script, the command-line, and config files, and finalized in 'finalize_options()'. All terminal output and filesystem interaction should be done by 'run()'.

This method must be implemented by all command classes.

Overrides:
distutils.cmd.Command.run (inherited documentation)

Class Variable Details

boolean_options

Type:
list
Value:
['force']

description

Type:
str
Value:
'install data files'

user_options

Type:
list
Value:
[('install-dir=',
  'd',
  'base directory for installing data files (default: installation bas\
e dir)'),
 ('root=',
  None,
  'install everything relative to this alternate root directory'),
 ('force', 'f', 'force installation (overwrite existing files)')]

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:52 2005 http://epydoc.sf.net


distutils.command.install_headers.install_headers

Package distutils :: Package command :: Module install_headers :: Class install_headers
[frames | no frames]

Class install_headers

Command --+
          |
         install_headers

Method Summary
 | finalize_options(self) Set final values for all the options that this command supports.
 | get_inputs(self)
 | get_outputs(self)
 | initialize_options(self) Set default values for all the options that this command supports.
 | run(self) A command's raison d'etre: carry out the action it exists to perform, controlled by the options initialized in 'initialize_options()', customized by other commands, the setup script, the command-line, and config files, and finalized in 'finalize_options()'.

Class Variable Summary
list | boolean_options = ['force']
str | description = 'install C/C++ header files'
list | user_options = [('install-dir=', 'd', 'directory to inst...

Method Details

finalize_options(self)

Set final values for all the options that this command supports. This is always called as late as possible, ie. after any option assignments from the command-line or from other commands have been done. Thus, this is the place to code option dependencies: if 'foo' depends on 'bar', then it is safe to set 'foo' from 'bar' as long as 'foo' still has the same value it was assigned in 'initialize_options()'.

This method must be implemented by all command classes.

Overrides:
distutils.cmd.Command.finalize_options (inherited documentation)

initialize_options(self)

Set default values for all the options that this command supports. Note that these defaults may be overridden by other commands, by the setup script, by config files, or by the command-line. Thus, this is not the place to code dependencies between options; generally, 'initialize_options()' implementations are just a bunch of "self.foo = None" assignments.

This method must be implemented by all command classes.

Overrides:
distutils.cmd.Command.initialize_options (inherited documentation)

run(self)

A command's raison d'etre: carry out the action it exists to perform, controlled by the options initialized in 'initialize_options()', customized by other commands, the setup script, the command-line, and config files, and finalized in 'finalize_options()'. All terminal output and filesystem interaction should be done by 'run()'.

This method must be implemented by all command classes.

Overrides:
distutils.cmd.Command.run (inherited documentation)

Class Variable Details

boolean_options

Type:
list
Value:
['force']

description

Type:
str
Value:
'install C/C++ header files'

user_options

Type:
list
Value:
[('install-dir=', 'd', 'directory to install header files to'),
 ('force', 'f', 'force installation (overwrite existing files)')]

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:10:55 2005 http://epydoc.sf.net


exceptions.AssertionError

Module exceptions :: Class AssertionError

Class AssertionError

Exception --+
            |
StandardError --+
                |
               AssertionError

Known Subclasses:
PyAssertionError

Assertion failed.

Method Summary

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:17 2005 http://epydoc.sf.net


exceptions.AttributeError

Module exceptions :: Class AttributeError

Class AttributeError

Exception --+
            |
StandardError --+
                |
               AttributeError

Known Subclasses:
PyDeadObjectError, PyUnbornObjectError

Attribute not found.

Method Summary

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:13 2005 http://epydoc.sf.net


exceptions.Exception

Module exceptions :: Class Exception

Class Exception

Known Subclasses:
DispatcherError, FloatCanvasError, StandardError, VersionError

Common base class for all exceptions.

Method Summary
 | __init__(...)
 | __getitem__(...)
 | __str__(...)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:11 2005 http://epydoc.sf.net


exceptions.RuntimeError

Module exceptions :: Class RuntimeError

Class RuntimeError

Exception --+
            |
StandardError --+
                |
               RuntimeError

Known Subclasses:
PyNoAppError

Unspecified run-time error.

Method Summary

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:12 2005 http://epydoc.sf.net


exceptions.StandardError

Module exceptions :: Class StandardError

Class StandardError

Exception --+
            |
           StandardError

Known Subclasses:
AssertionError, AttributeError, RuntimeError

Base class for all standard Python exceptions.

Method Summary

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:09 2005 http://epydoc.sf.net


Help

API Documentation

This document contains the API (Application Programming Interface) documentation for wxPython. Documentation for the Python objects defined by the project is divided into separate pages for each package, module, and class. The API documentation also includes two pages containing information about the project as a whole: a trees page, and an index page.

Object Documentation

Each Package Documentation page contains:

  • A description of the package.
  • A list of the modules and sub-packages contained by the package.
  • A summary of the classes defined by the package.
  • A summary of the functions defined by the package.
  • A summary of the variables defined by the package.
  • A detailed description of each function defined by the package.
  • A detailed description of each variable defined by the package.

Each Module Documentation page contains:

  • A description of the module.
  • A summary of the classes defined by the module.
  • A summary of the functions defined by the module.
  • A summary of the variables defined by the module.
  • A detailed description of each function defined by the module.
  • A detailed description of each variable defined by the module.

Each Class Documentation page contains:

  • A class inheritance diagram.
  • A list of known subclasses.
  • A description of the class.
  • A summary of the methods defined by the class.
  • A summary of the instance variables defined by the class.
  • A summary of the class (static) variables defined by the class.
  • A detailed description of each method defined by the class.
  • A detailed description of each instance variable defined by the class.
  • A detailed description of each class (static) variable defined by the class.

Project Documentation

The Trees page contains the module and class hierarchies:

  • The module hierarchy lists every package and module, with modules grouped into packages. At the top level, and within each package, modules and sub-packages are listed alphabetically.
  • The class hierarchy lists every class, grouped by base class. If a class has more than one base class, then it will be listed under each base class. At the top level, and under each base class, classes are listed alphabetically.

The Index page contains indices of terms and identifiers:

  • The term index lists every term indexed by any object's documentation. For each term, the index provides links to each place where the term is indexed.
  • The identifier index lists the (short) name of every package, module, class, method, function, variable, and parameter. For each identifier, the index provides a short description, and a link to its documentation.

The Table of Contents

The table of contents occupies the two frames on the left side of the window. The upper-left frame displays the project contents, and the lower-left frame displays the module contents:

Project
Contents
... 		API
Documentation
Frame
Module
Contents

...

The project contents frame contains a list of all packages and modules that are defined by the project. Clicking on an entry will display its contents in the module contents frame. Clicking on a special entry, labeled "Everything," will display the contents of the entire project.

The module contents frame contains a list of every submodule, class, type, exception, function, and variable defined by a module or package. Clicking on an entry will display its documentation in the API documentation frame. Clicking on the name of the module, at the top of the frame, will display the documentation for the module itself.

The "frames" and "no frames" buttons below the top navigation bar can be used to control whether the table of contents is displayed or not.

The Navigation Bar

A navigation bar is located at the top and bottom of every page. It indicates what type of page you are currently viewing, and allows you to go to related pages. The following table describes the labels on the navigation bar. Note that not some labels (such as [Parent]) are not displayed on all pages.

Label | Highlighted when... | Links to...
[Parent] | (never highlighted) | the parent of the current package
[Package] | viewing a package | the package containing the current object
[Module] | viewing a module | the module containing the current object
[Class] | viewing a class | the class containing the current object
[Trees] | viewing the trees page | the trees page
[Index] | viewing the index page | the index page
[Help] | viewing the help page | the help page

The "show private" and "hide private" buttons below the top navigation bar can be used to control whether documentation for private objects is displayed. Private objects are usually defined as objects whose (short) names begin with a single underscore, but do not end with an underscore. For example, "_x", "__pprint", and "epydoc.epytext._tokenize" are private objects; but "re.sub", "__init__", and "type_" are not. However, if a module defines the "__all__" variable, then its contents are used to decide which objects are private.

A timestamp below the bottom navigation bar indicates when each page was last updated.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:42 2005 http://epydoc.sf.net


Index

Home

Trees

Index

Help

wxPython

[frames | no frames]

Identifier Index

__add__

Method in class wx.DateSpan

__add__

Method in class wx.DateTime

__add__

Method in class wx.Point

__add__

Method in class wx.RealPoint

__add__

Method in class wx.Rect

__add__

Method in class wx.Size

__add__

Method in class wx.TimeSpan

__author__

Variable in module wx.lib.newevent

__author__

Variable in module wx.py.PyAlaCarte

__author__

Variable in module wx.py.PyAlaMode

__author__

Variable in module wx.py.PyAlaModeTest

__author__

Variable in module wx.py.PyCrust

__author__

Variable in module wx.py.PyFilling

__author__

Variable in module wx.py.PyShell

__author__

Variable in module wx.py.PyWrap

__author__

Variable in package wx.py

__author__

Variable in module wx.py.buffer

__author__

Variable in module wx.py.crust

__author__

Variable in module wx.py.dispatcher

__author__

Variable in module wx.py.document

__author__

Variable in module wx.py.editor

__author__

Variable in module wx.py.editwindow

__author__

Variable in module wx.py.filling

__author__

Variable in module wx.py.frame

__author__

Variable in module wx.py.images

__author__

Variable in module wx.py.interpreter

__author__

Variable in module wx.py.introspect

__author__

Variable in module wx.py.pseudo

__author__

Variable in module wx.py.shell

__author__

Variable in module wx.py.version

object

Class in module __builtin__

__bases__

Variable in class __builtin__.type

__basicsize__

Variable in class __builtin__.type

__call__

Method in class __builtin__.type

__call__

Method in class wx.PyEventBinder

__call__

Method in class wx.lib.infoframe.Dummy_PyInformationalMessagesFrame

__call__

Method in class wx.lib.infoframe.PyInformationalMessagesFrame

__call__

Method in class wx.py.dispatcher.BoundMethodWeakref

__call__

Method in class wx.py.pseudo.PseudoKeyword

type

Class in module __builtin__

__cmp__

Method in class __builtin__.type

__cvsid__

Variable in module wx.py.PyAlaCarte

__cvsid__

Variable in module wx.py.PyAlaMode

__cvsid__

Variable in module wx.py.PyAlaModeTest

__cvsid__

Variable in module wx.py.PyCrust

__cvsid__

Variable in module wx.py.PyFilling

__cvsid__

Variable in module wx.py.PyShell

__cvsid__

Variable in module wx.py.PyWrap

__cvsid__

Variable in package wx.py

__cvsid__

Variable in module wx.py.buffer

__cvsid__

Variable in module wx.py.crust

__cvsid__

Variable in module wx.py.dispatcher

__cvsid__

Variable in module wx.py.document

__cvsid__

Variable in module wx.py.editor

__cvsid__

Variable in module wx.py.editwindow

__cvsid__

Variable in module wx.py.filling

__cvsid__

Variable in module wx.py.frame

__cvsid__

Variable in module wx.py.images

__cvsid__

Variable in module wx.py.interpreter

__cvsid__

Variable in module wx.py.introspect

__cvsid__

Variable in module wx.py.pseudo

__cvsid__

Variable in module wx.py.shell

__cvsid__

Variable in module wx.py.version

__del__

Method in class wx.AcceleratorEntry

__del__

Method in class wx.AcceleratorTable

__del__

Method in class wx.App

__del__

Method in class wx.Bitmap

__del__

Method in class wx.Brush

__del__

Method in class wx.BufferedDC

__del__

Method in class wx.BusyCursor

__del__

Method in class wx.BusyInfo

__del__

Method in class wx.Clipboard

__del__

Method in class wx.ClipboardLocker

__del__

Method in class wx.Colour

__del__

Method in class wx.ColourData

__del__

Method in class wx.ColourDatabase

__del__

Method in class wx.Config

__del__

Method in class wx.ConfigBase

__del__

Method in class wx.ConfigPathChanger

__del__

Method in class wx.ContextHelp

__del__

Method in class wx.Cursor

__del__

Method in class wx.DC

__del__

Method in class wx.DataFormat

__del__

Method in class wx.DataObject

__del__

Method in class wx.DateSpan

__del__

Method in class wx.DateTime

__del__

Method in class wx.Display

__del__

Method in class wx.DragImage

__del__

Method in class wx.DropSource

__del__

Method in class wx.DropTarget

__del__

Method in class wx.EncodingConverter

__del__

Method in class wx.Event

__del__

Method in class wx.EventLoop

__del__

Method in class wx.FSFile

__del__

Method in class wx.FileConfig

__del__

Method in class wx.FileHistory

__del__

Method in class wx.FileSystem

__del__

Method in class wx.FileType

__del__

Method in class wx.FindReplaceData

__del__

Method in class wx.Font

__del__

Method in class wx.FontData

__del__

Method in class wx.FontEnumerator

__del__

Method in class wx.FontMapper

__del__

Method in class wx.FutureCall

__del__

Method in class wx.GDIObject

__del__

Method in class wx.Icon

__del__

Method in class wx.IconBundle

__del__

Method in class wx.IconLocation

__del__

Method in class wx.Image

__del__

Method in class wx.ImageList

__del__

Method in class wx.InputStream

__del__

Method in class wx.Joystick

__del__

Method in class wx.LayoutAlgorithm

__del__

Method in class wx.ListItem

__del__

Method in class wx.Locale

__del__

Method in class wx.LogNull

__del__

Method in class wx.MimeTypesManager

__del__

Method in class wx.MutexGuiLocker

__del__

Method in class wx.NativeEncodingInfo

__del__

Method in class wx.NativeFontInfo

__del__

Method in class wx.PageSetupDialogData

__del__

Method in class wx.Palette

__del__

Method in class wx.Pen

__del__

Method in class wx.Point

__del__

Method in class wx.PrintData

__del__

Method in class wx.PrintDialogData

__del__

Method in class wx.Printer

__del__

Method in class wx.PropagateOnce

__del__

Method in class wx.PropagationDisabler

__del__

Method in class wx.PyApp

__del__

Method in class wx.PyCommandEvent

__del__

Method in class wx.PyEvent

__del__

Method in class wx.RealPoint

__del__

Method in class wx.Rect

__del__

Method in class wx.Region

__del__

Method in class wx.RegionIterator

__del__

Method in class wx.SingleInstanceChecker

__del__

Method in class wx.Size

__del__

Method in class wx.Sound

__del__

Method in class wx.TextAttr

__del__

Method in class wx.TimeSpan

__del__

Method in class wx.Timer

__del__

Method in class wx.TimerRunner

__del__

Method in class wx.TipProvider

__del__

Method in class wx.TreeItemId

__del__

Method in class wx.VideoMode

__del__

Method in class wx.VisualAttributes

__del__

Method in class wx.WindowDisabler

__del__

Method in class wx.animate.AnimationBase

__del__

Method in class wx.animate.AnimationPlayer

__del__

Method in class wx.animate.GIFAnimation

__del__

Method in class wx.glcanvas.GLContext

__del__

Method in class wx.grid.GridCellCoords

__del__

Method in class wx.grid.GridTableMessage

__del__

Method in class wx.html.HtmlDCRenderer

__del__

Method in class wx.html.HtmlEasyPrinting

__del__

Method in class wx.html.HtmlHelpController

__del__

Method in class wx.html.HtmlHelpData

__del__

Method in class wx.html.HtmlRenderingInfo

__del__

Method in class wx.html.HtmlRenderingState

__del__

Method in class wx.html.HtmlSelection

__del__

Method in class wx.lib.ogl.LineShape

__del__

Method in class wx.lib.ogl.Shape

__del__

Method in class wx.lib.ogl.ShapeEvtHandler

__del__

Method in class wx.stc.StyledTextEvent

__del__

Method in class wx.xrc.XmlDocument

__del__

Method in class wx.xrc.XmlNode

__del__

Method in class wx.xrc.XmlResource

__delattr__

Method in class __builtin__.object

__delattr__

Method in class __builtin__.type

__dictoffset__

Variable in class __builtin__.type

__eq__

Method in class wx.Bitmap

__eq__

Method in class wx.Colour

__eq__

Method in class wx.DataFormat

__eq__

Method in class wx.DateSpan

__eq__

Method in class wx.DateTime

__eq__

Method in class wx.Font

__eq__

Method in class wx.GBPosition

__eq__

Method in class wx.GBSpan

__eq__

Method in class wx.Pen

__eq__

Method in class wx.Point

__eq__

Method in class wx.Point2D

__eq__

Method in class wx.RealPoint

__eq__

Method in class wx.Rect

__eq__

Method in class wx.Size

__eq__

Method in class wx.TimeSpan

__eq__

Method in class wx.TreeItemId

__eq__

Method in class wx.VideoMode

__eq__

Method in class wx.grid.GridCellCoords

__flags__

Variable in class __builtin__.type

__ge__

Method in class wx.DateTime

__ge__

Method in class wx.TimeSpan

__getattr__

Method in class distutils.cmd.Command

__getattr__

Method in class wx.lib.floatcanvas.NavCanvas.NavCanvas

__getattr__

Method in class wx.py.shell.ShellFacade

__getattribute__

Method in class __builtin__.object

__getattribute__

Method in class __builtin__.type

__getitem__

Method in class exceptions.Exception

__getitem__

Method in class wx.GBPosition

__getitem__

Method in class wx.GBSpan

__getitem__

Method in class wx.Point

__getitem__

Method in class wx.Point2D

__getitem__

Method in class wx.RealPoint

__getitem__

Method in class wx.Rect

__getitem__

Method in class wx.Size

__getitem__

Method in class wx.grid.GridCellCoords

__getitem__

Method in class wx.lib.mvctree.Rect

__getitem__

Method in class wx.lib.plot.PlotGraphics

__getitem__

Method in class wx.lib.wxPlotCanvas.PlotGraphics

__gt__

Method in class wx.DateTime

__gt__

Method in class wx.TimeSpan

__hash__

Method in class __builtin__.object

__hash__

Method in class __builtin__.type

__iadd__

Method in class wx.DateSpan

__iadd__

Method in class wx.DateTime

__iadd__

Method in class wx.Point

__iadd__

Method in class wx.Point2D

__iadd__

Method in class wx.Rect

__iadd__

Method in class wx.TimeSpan

__idiv__

Method in class wx.Point2D

__imul__

Method in class wx.DateSpan

__imul__

Method in class wx.Point2D

__imul__

Method in class wx.TimeSpan

__init__

Method in class __builtin__.object

__init__

Method in class code.InteractiveInterpreter

__init__

Method in class distutils.cmd.Command

__init__

Method in class exceptions.Exception

__init__

Method in class wx.ANIHandler

__init__

Method in class wx.AcceleratorEntry

__init__

Method in class wx.AcceleratorTable

__init__

Method in class wx.ActivateEvent

__init__

Method in class wx.App

__init__

Method in class wx.ArtProvider

__init__

Method in class wx.BMPHandler

__init__

Method in class wx.Bitmap

__init__

Method in class wx.BitmapButton

__init__

Method in class wx.BitmapDataObject

__init__

Method in class wx.BookCtrlBase

__init__

Method in class wx.BookCtrlBaseEvent

__init__

Method in class wx.BoxSizer

__init__

Method in class wx.Brush

__init__

Method in class wx.BrushList

__init__

Method in class wx.BufferedDC

__init__

Method in class wx.BufferedPaintDC

__init__

Method in class wx.BusyCursor

__init__

Method in class wx.BusyInfo

__init__

Method in class wx.Button

__init__

Method in class wx.CPPFileSystemHandler

__init__

Method in class wx.CURHandler

__init__

Method in class wx.CalculateLayoutEvent

__init__

Method in class wx.Caret

__init__

Method in class wx.CheckBox

__init__

Method in class wx.CheckListBox

__init__

Method in class wx.ChildFocusEvent

__init__

Method in class wx.Choice

__init__

Method in class wx.Choicebook

__init__

Method in class wx.ChoicebookEvent

__init__

Method in class wx.ClientDC

__init__

Method in class wx.Clipboard

__init__

Method in class wx.ClipboardLocker

__init__

Method in class wx.CloseEvent

__init__

Method in class wx.Colour

__init__

Method in class wx.ColourData

__init__

Method in class wx.ColourDatabase

__init__

Method in class wx.ColourDialog

__init__

Method in class wx.ComboBox

__init__

Method in class wx.CommandEvent

__init__

Method in class wx.Config

__init__

Method in class wx.ConfigBase

__init__

Method in class wx.ConfigPathChanger

__init__

Method in class wx.ContextHelp

__init__

Method in class wx.ContextHelpButton

__init__

Method in class wx.ContextMenuEvent

__init__

Method in class wx.Control

__init__

Method in class wx.ControlWithItems

__init__

Method in class wx.Cursor

__init__

Method in class wx.CustomDataObject

__init__

Method in class wx.DC

__init__

Method in class wx.DataFormat

__init__

Method in class wx.DataObject

__init__

Method in class wx.DataObjectComposite

__init__

Method in class wx.DataObjectSimple

__init__

Method in class wx.DateEvent

__init__

Method in class wx.DatePickerCtrl

__init__

Method in class wx.DateSpan

__init__

Method in class wx.DateTime

__init__

Method in class wx.Dialog

__init__

Method in class wx.DirDialog

__init__

Method in class wx.DirFilterListCtrl

__init__

Method in class wx.Display

__init__

Method in class wx.DisplayChangedEvent

__init__

Method in class wx.DragImage

__init__

Method in class wx.DropFilesEvent

__init__

Method in class wx.DropSource

__init__

Method in class wx.DropTarget

__init__

Method in class wx.Effects

__init__

Method in class wx.EncodingConverter

__init__

Method in class wx.EraseEvent

__init__

Method in class wx.Event

__init__

Method in class wx.EventLoop

__init__

Method in class wx.EvtHandler

__init__

Method in class wx.FSFile

__init__

Method in class wx.FileConfig

__init__

Method in class wx.FileDataObject

__init__

Method in class wx.FileDialog

__init__

Method in class wx.FileDropTarget

__init__

Method in class wx.FileHistory

__init__

Method in class wx.FileSystem

__init__

Method in class wx.FileSystemHandler

__init__

Method in class wx.FileType

__init__

Method in class wx.FileTypeInfo

__init__

Method in class wx.FindDialogEvent

__init__

Method in class wx.FindReplaceData

__init__

Method in class wx.FindReplaceDialog

__init__

Method in class wx.FlexGridSizer

__init__

Method in class wx.FocusEvent

__init__

Method in class wx.Font

__init__

Method in class wx.FontData

__init__

Method in class wx.FontDialog

__init__

Method in class wx.FontEnumerator

__init__

Method in class wx.FontList

__init__

Method in class wx.FontMapper

__init__

Method in class wx.Frame

__init__

Method in class wx.FutureCall

__init__

Method in class wx.GBPosition

__init__

Method in class wx.GBSizerItem

__init__

Method in class wx.GBSpan

__init__

Method in class wx.GDIObject

__init__

Method in class wx.GIFHandler

__init__

Method in class wx.Gauge

__init__

Method in class wx.GenericDirCtrl

__init__

Method in class wx.GridBagSizer

__init__

Method in class wx.GridSizer

__init__

Method in class wx.HelpEvent

__init__

Method in class wx.HelpProvider

__init__

Method in class wx.HtmlListBox

__init__

Method in class wx.ICOHandler

__init__

Method in class wx.Icon

__init__

Method in class wx.IconBundle

__init__

Method in class wx.IconLocation

__init__

Method in class wx.IconizeEvent

__init__

Method in class wx.IdleEvent

__init__

Method in class wx.Image

__init__

Method in class wx.ImageHandler

__init__

Method in class wx.ImageHistogram

__init__

Method in class wx.ImageList

__init__

Method in class wx.IndividualLayoutConstraint

__init__

Method in class wx.InitDialogEvent

__init__

Method in class wx.InputStream

__init__

Method in class wx.InternetFSHandler

__init__

Method in class wx.ItemContainer

__init__

Method in class wx.JPEGHandler

__init__

Method in class wx.Joystick

__init__

Method in class wx.JoystickEvent

__init__

Method in class wx.KeyEvent

__init__

Method in class wx.LanguageInfo

__init__

Method in class wx.LayoutAlgorithm

__init__

Method in class wx.LayoutConstraints

__init__

Method in class wx.ListBox

__init__

Method in class wx.ListCtrl

__init__

Method in class wx.ListEvent

__init__

Method in class wx.ListItem

__init__

Method in class wx.ListItemAttr

__init__

Method in class wx.ListView

__init__

Method in class wx.Listbook

__init__

Method in class wx.ListbookEvent

__init__

Method in class wx.Locale

__init__

Method in class wx.Log

__init__

Method in class wx.LogChain

__init__

Method in class wx.LogGui

__init__

Method in class wx.LogNull

__init__

Method in class wx.LogStderr

__init__

Method in class wx.LogTextCtrl

__init__

Method in class wx.LogWindow

__init__

Method in class wx.MDIChildFrame

__init__

Method in class wx.MDIClientWindow

__init__

Method in class wx.MDIParentFrame

__init__

Method in class wx.Mask

__init__

Method in class wx.MaximizeEvent

__init__

Method in class wx.MemoryDC

__init__

Method in class wx.MemoryFSHandler

__init__

Method in class wx.Menu

__init__

Method in class wx.MenuBar

__init__

Method in class wx.MenuEvent

__init__

Method in class wx.MenuItem

__init__

Method in class wx.MessageDialog

__init__

Method in class wx.MetaFile

__init__

Method in class wx.MetaFileDC

__init__

Method in class wx.MetafileDataObject

__init__

Method in class wx.MimeTypesManager

__init__

Method in class wx.MiniFrame

__init__

Method in class wx.MirrorDC

__init__

Method in class wx.MouseCaptureChangedEvent

__init__

Method in class wx.MouseEvent

__init__

Method in class wx.MoveEvent

__init__

Method in class wx.MultiChoiceDialog

__init__

Method in class wx.MutexGuiLocker

__init__

Method in class wx.NativeEncodingInfo

__init__

Method in class wx.NativeFontInfo

__init__

Method in class wx.NavigationKeyEvent

__init__

Method in class wx.NcPaintEvent

__init__

Method in class wx.Notebook

__init__

Method in class wx.NotebookEvent

__init__

Method in class wx.NotebookPage

__init__

Method in class wx.NotifyEvent

__init__

Method in class wx.Object

__init__

Method in class wx.OutputStream

__init__

Method in class wx.PCXHandler

__init__

Method in class wx.PNGHandler

__init__

Method in class wx.PNMHandler

__init__

Method in class wx.PageSetupDialog

__init__

Method in class wx.PageSetupDialogData

__init__

Method in class wx.PaintDC

__init__

Method in class wx.PaintEvent

__init__

Method in class wx.Palette

__init__

Method in class wx.PaletteChangedEvent

__init__

Method in class wx.Panel

__init__

Method in class wx.PasswordEntryDialog

__init__

Method in class wx.Pen

__init__

Method in class wx.PenList

__init__

Method in class wx.Point

__init__

Method in class wx.Point2D

__init__

Method in class wx.PopupTransientWindow

__init__

Method in class wx.PopupWindow

__init__

Method in class wx.PostScriptDC

__init__

Method in class wx.PreviewCanvas

__init__

Method in class wx.PreviewControlBar

__init__

Method in class wx.PreviewFrame

__init__

Method in class wx.PrintData

__init__

Method in class wx.PrintDialog

__init__

Method in class wx.PrintDialogData

__init__

Method in class wx.PrintPreview

__init__

Method in class wx.Printer

__init__

Method in class wx.PrinterDC

__init__

Method in class wx.Printout

__init__

Method in class wx.Process

__init__

Method in class wx.ProcessEvent

__init__

Method in class wx.ProgressDialog

__init__

Method in class wx.PropagateOnce

__init__

Method in class wx.PropagationDisabler

__init__

Method in class wx.PyApp

__init__

Method in class wx.PyBitmapDataObject

__init__

Method in class wx.PyCommandEvent

__init__

Method in class wx.PyControl

__init__

Method in class wx.PyDataObjectSimple

__init__

Method in class wx.PyEvent

__init__

Method in class wx.PyEventBinder

__init__

Method in class wx.PyLog

__init__

Method in class wx.PyOnDemandOutputWindow

__init__

Method in class wx.PyPanel

__init__

Method in class wx.PyPreviewControlBar

__init__

Method in class wx.PyPreviewFrame

__init__

Method in class wx.PyPrintPreview

__init__

Method in class wx.PyScrolledWindow

__init__

Method in class wx.PySimpleApp

__init__

Method in class wx.PySizer

__init__

Method in class wx.PyTextDataObject

__init__

Method in class wx.PyTimer

__init__

Method in class wx.PyTipProvider

__init__

Method in class wx.PyValidator

__init__

Method in class wx.PyWidgetTester

__init__

Method in class wx.PyWindow

__init__

Method in class wx.Quantize

__init__

Method in class wx.QueryLayoutInfoEvent

__init__

Method in class wx.QueryNewPaletteEvent

__init__

Method in class wx.RadioBox

__init__

Method in class wx.RadioButton

__init__

Method in class wx.RealPoint

__init__

Method in class wx.Rect

__init__

Method in class wx.Region

__init__

Method in class wx.RegionIterator

__init__

Method in class wx.SashEvent

__init__

Method in class wx.SashLayoutWindow

__init__

Method in class wx.SashWindow

__init__

Method in class wx.ScreenDC

__init__

Method in class wx.ScrollBar

__init__

Method in class wx.ScrollEvent

__init__

Method in class wx.ScrollWinEvent

__init__

Method in class wx.ScrolledWindow

__init__

Method in class wx.SetCursorEvent

__init__

Method in class wx.ShowEvent

__init__

Method in class wx.SimpleHelpProvider

__init__

Method in class wx.SingleChoiceDialog

__init__

Method in class wx.SingleInstanceChecker

__init__

Method in class wx.Size

__init__

Method in class wx.SizeEvent

__init__

Method in class wx.Sizer

__init__

Method in class wx.SizerItem

__init__

Method in class wx.Slider

__init__

Method in class wx.Sound

__init__

Method in class wx.SpinButton

__init__

Method in class wx.SpinCtrl

__init__

Method in class wx.SpinEvent

__init__

Method in class wx.SplashScreen

__init__

Method in class wx.SplashScreenWindow

__init__

Method in class wx.SplitterEvent

__init__

Method in class wx.SplitterWindow

__init__

Method in class wx.StandardPaths

__init__

Method in class wx.StaticBitmap

__init__

Method in class wx.StaticBox

__init__

Method in class wx.StaticBoxSizer

__init__

Method in class wx.StaticLine

__init__

Method in class wx.StaticText

__init__

Method in class wx.StatusBar

__init__

Method in class wx.StdDialogButtonSizer

__init__

Method in class wx.StopWatch

__init__

Method in class wx.SysColourChangedEvent

__init__

Method in class wx.SystemOptions

__init__

Method in class wx.SystemSettings

__init__

Method in class wx.TIFFHandler

__init__

Method in class wx.TaskBarIcon

__init__

Method in class wx.TaskBarIconEvent

__init__

Method in class wx.TextAttr

__init__

Method in class wx.TextCtrl

__init__

Method in class wx.TextDataObject

__init__

Method in class wx.TextDropTarget

__init__

Method in class wx.TextEntryDialog

__init__

Method in class wx.TextUrlEvent

__init__

Method in class wx.TimeSpan

__init__

Method in class wx.Timer

__init__

Method in class wx.TimerEvent

__init__

Method in class wx.TimerRunner

__init__

Method in class wx.TipProvider

__init__

Method in class wx.TipWindow

__init__

Method in class wx.ToggleButton

__init__

Method in class wx.ToolBar

__init__

Method in class wx.ToolBarBase

__init__

Method in class wx.ToolBarToolBase

__init__

Method in class wx.ToolTip

__init__

Method in class wx.TopLevelWindow

__init__

Method in class wx.TreeCtrl

__init__

Method in class wx.TreeEvent

__init__

Method in class wx.TreeItemData

__init__

Method in class wx.TreeItemId

__init__

Method in class wx.URLDataObject

__init__

Method in class wx.UpdateUIEvent

__init__

Method in class wx.VListBox

__init__

Method in class wx.VScrolledWindow

__init__

Method in class wx.Validator

__init__

Method in class wx.VideoMode

__init__

Method in class wx.VisualAttributes

__init__

Method in class wx.Window

__init__

Method in class wx.WindowCreateEvent

__init__

Method in class wx.WindowDC

__init__

Method in class wx.WindowDestroyEvent

__init__

Method in class wx.WindowDisabler

__init__

Method in class wx.XPMHandler

__init__

Method in class wx.ZipFSHandler

__init__

Method in class wx.animate.AnimationBase

__init__

Method in class wx.animate.AnimationPlayer

__init__

Method in class wx.animate.GIFAnimation

__init__

Method in class wx.animate.GIFAnimationCtrl

__init__

Method in class wx.calendar.CalendarCtrl

__init__

Method in class wx.calendar.CalendarDateAttr

__init__

Method in class wx.calendar.CalendarEvent

__init__

Method in class wx.gizmos.DynamicSashSplitEvent

__init__

Method in class wx.gizmos.DynamicSashUnifyEvent

__init__

Method in class wx.gizmos.DynamicSashWindow

__init__

Method in class wx.gizmos.EditableListBox

__init__

Method in class wx.gizmos.LEDNumberCtrl

__init__

Method in class wx.gizmos.RemotelyScrolledTreeCtrl

__init__

Method in class wx.gizmos.SplitterScrolledWindow

__init__

Method in class wx.gizmos.StaticPicture

__init__

Method in class wx.gizmos.ThinSplitterWindow

__init__

Method in class wx.gizmos.TreeCompanionWindow

__init__

Method in class wx.gizmos.TreeListColumnInfo

__init__

Method in class wx.gizmos.TreeListCtrl

__init__

Method in class wx.glcanvas.GLCanvas

__init__

Method in class wx.glcanvas.GLContext

__init__

Method in class wx.grid.Grid

__init__

Method in class wx.grid.GridCellAttr

__init__

Method in class wx.grid.GridCellAttrProvider

__init__

Method in class wx.grid.GridCellAutoWrapStringEditor

__init__

Method in class wx.grid.GridCellAutoWrapStringRenderer

__init__

Method in class wx.grid.GridCellBoolEditor

__init__

Method in class wx.grid.GridCellBoolRenderer

__init__

Method in class wx.grid.GridCellChoiceEditor

__init__

Method in class wx.grid.GridCellCoords

__init__

Method in class wx.grid.GridCellDateTimeRenderer

__init__

Method in class wx.grid.GridCellEditor

__init__

Method in class wx.grid.GridCellEnumEditor

__init__

Method in class wx.grid.GridCellEnumRenderer

__init__

Method in class wx.grid.GridCellFloatEditor

__init__

Method in class wx.grid.GridCellFloatRenderer

__init__

Method in class wx.grid.GridCellNumberEditor

__init__

Method in class wx.grid.GridCellNumberRenderer

__init__

Method in class wx.grid.GridCellRenderer

__init__

Method in class wx.grid.GridCellStringRenderer

__init__

Method in class wx.grid.GridCellTextEditor

__init__

Method in class wx.grid.GridEditorCreatedEvent

__init__

Method in class wx.grid.GridEvent

__init__

Method in class wx.grid.GridRangeSelectEvent

__init__

Method in class wx.grid.GridSizeEvent

__init__

Method in class wx.grid.GridStringTable

__init__

Method in class wx.grid.GridTableBase

__init__

Method in class wx.grid.GridTableMessage

__init__

Method in class wx.grid.PyGridCellAttrProvider

__init__

Method in class wx.grid.PyGridCellEditor

__init__

Method in class wx.grid.PyGridCellRenderer

__init__

Method in class wx.grid.PyGridTableBase

__init__

Method in class wx.html.DefaultHtmlRenderingStyle

__init__

Method in class wx.html.HtmlBookRecord

__init__

Method in class wx.html.HtmlCell

__init__

Method in class wx.html.HtmlColourCell

__init__

Method in class wx.html.HtmlContainerCell

__init__

Method in class wx.html.HtmlContentsItem

__init__

Method in class wx.html.HtmlDCRenderer

__init__

Method in class wx.html.HtmlEasyPrinting

__init__

Method in class wx.html.HtmlFilter

__init__

Method in class wx.html.HtmlFontCell

__init__

Method in class wx.html.HtmlHelpController

__init__

Method in class wx.html.HtmlHelpData

__init__

Method in class wx.html.HtmlHelpFrame

__init__

Method in class wx.html.HtmlLinkInfo

__init__

Method in class wx.html.HtmlParser

__init__

Method in class wx.html.HtmlPrintout

__init__

Method in class wx.html.HtmlRenderingInfo

__init__

Method in class wx.html.HtmlRenderingState

__init__

Method in class wx.html.HtmlRenderingStyle

__init__

Method in class wx.html.HtmlSearchStatus

__init__

Method in class wx.html.HtmlSelection

__init__

Method in class wx.html.HtmlTag

__init__

Method in class wx.html.HtmlTagHandler

__init__

Method in class wx.html.HtmlWidgetCell

__init__

Method in class wx.html.HtmlWinParser

__init__

Method in class wx.html.HtmlWinTagHandler

__init__

Method in class wx.html.HtmlWindow

__init__

Method in class wx.html.HtmlWordCell

__init__

Method in class wx.lib.CDate.Date

__init__

Method in class wx.lib.CDate.now

__init__

Method in class wx.lib.ClickableHtmlWindow.PyClickableHtmlWindow

__init__

Method in class wx.lib.analogclock.AnalogClockWindow

__init__

Method in class wx.lib.analogclockopts.ACCustomizationFrame

__init__

Method in class wx.lib.anchors.LayoutAnchors

__init__

Method in class wx.lib.buttons.GenBitmapButton

__init__

Method in class wx.lib.buttons.GenBitmapTextButton

__init__

Method in class wx.lib.buttons.GenButton

__init__

Method in class wx.lib.buttons.GenButtonEvent

__init__

Method in class wx.lib.calendar.CalDraw

__init__

Method in class wx.lib.calendar.CalenDlg

__init__

Method in class wx.lib.calendar.Calendar

__init__

Method in class wx.lib.colourchooser.canvas.BitmapBuffer

__init__

Method in class wx.lib.colourchooser.canvas.Canvas

__init__

Method in class wx.lib.colourchooser.pycolourbox.PyColourBox

__init__

Method in class wx.lib.colourchooser.pycolourchooser.PyColourChooser

__init__

Method in class wx.lib.colourchooser.pycolourslider.PyColourSlider

__init__

Method in class wx.lib.colourchooser.pypalette.PyPalette

__init__

Method in class wx.lib.colourselect.ColourSelect

__init__

Method in class wx.lib.colourselect.ColourSelectEvent

__init__

Method in class wx.lib.dialogs.DialogResults

__init__

Method in class wx.lib.dialogs.MultipleChoiceDialog

__init__

Method in class wx.lib.dialogs.ScrolledMessageDialog

__init__

Method in class wx.lib.docview.Command

__init__

Method in class wx.lib.docview.CommandProcessor

__init__

Method in class wx.lib.docview.DocChildFrame

__init__

Method in class wx.lib.docview.DocMDIChildFrame

__init__

Method in class wx.lib.docview.DocMDIParentFrame

__init__

Method in class wx.lib.docview.DocManager

__init__

Method in class wx.lib.docview.DocParentFrame

__init__

Method in class wx.lib.docview.DocPrintout

__init__

Method in class wx.lib.docview.DocTemplate

__init__

Method in class wx.lib.docview.Document

__init__

Method in class wx.lib.docview.View

__init__

Method in class wx.lib.editor.editor.Editor

__init__

Method in class wx.lib.editor.editor.Scroller

__init__

Method in class wx.lib.evtmgr.EventAdapter

__init__

Method in class wx.lib.evtmgr.EventMacroInfo

__init__

Method in class wx.lib.evtmgr.EventManager

__init__

Method in class wx.lib.evtmgr.FakeWindow

__init__

Method in class wx.lib.evtmgr.MessageAdapter

__init__

Method in class wx.lib.fancytext.StaticFancyText

__init__

Method in class wx.lib.filebrowsebutton.DirBrowseButton

__init__

Method in class wx.lib.filebrowsebutton.FileBrowseButton

__init__

Method in class wx.lib.filebrowsebutton.FileBrowseButtonWithHistory

__init__

Method in class wx.lib.floatbar.FloatBar

__init__

Method in class wx.lib.floatcanvas.FloatCanvas.Arrow

__init__

Method in class wx.lib.floatcanvas.FloatCanvas.Circle

__init__

Method in class wx.lib.floatcanvas.FloatCanvas.DrawObject

__init__

Method in class wx.lib.floatcanvas.FloatCanvas.FloatCanvas

__init__

Method in class wx.lib.floatcanvas.FloatCanvas.Line

__init__

Method in class wx.lib.floatcanvas.FloatCanvas.Point

__init__

Method in class wx.lib.floatcanvas.FloatCanvas.PointSet

__init__

Method in class wx.lib.floatcanvas.FloatCanvas.Polygon

__init__

Method in class wx.lib.floatcanvas.FloatCanvas.RectEllipse

__init__

Method in class wx.lib.floatcanvas.FloatCanvas.ScaledText

__init__

Method in class wx.lib.floatcanvas.FloatCanvas.Text

__init__

Method in class wx.lib.floatcanvas.NavCanvas.NavCanvas

__init__

Method in class wx.lib.foldmenu.FoldOutMenu

__init__

Method in class wx.lib.foldmenu.FoldOutWindow

__init__

Method in class wx.lib.foldpanelbar.CaptionBar

__init__

Method in class wx.lib.foldpanelbar.CaptionBarEvent

__init__

Method in class wx.lib.foldpanelbar.CaptionBarStyle

__init__

Method in class wx.lib.foldpanelbar.FoldPanelBar

__init__

Method in class wx.lib.foldpanelbar.FoldPanelItem

__init__

Method in class wx.lib.foldpanelbar.FoldWindowItem

__init__

Method in class wx.lib.gestures.MouseGestures

__init__

Method in class wx.lib.gridmovers.ColDragWindow

__init__

Method in class wx.lib.gridmovers.GridColMoveEvent

__init__

Method in class wx.lib.gridmovers.GridColMover

__init__

Method in class wx.lib.gridmovers.GridRowMoveEvent

__init__

Method in class wx.lib.gridmovers.GridRowMover

__init__

Method in class wx.lib.gridmovers.RowDragWindow

__init__

Method in class wx.lib.grids.PyFlexGridSizer

__init__

Method in class wx.lib.grids.PyGridSizer

__init__

Method in class wx.lib.hyperlink.HyperLinkCtrl

__init__

Method in class wx.lib.hyperlink.HyperLinkEvent

__init__

Method in class wx.lib.imagebrowser.FindFiles

__init__

Method in class wx.lib.imagebrowser.ImageDialog

__init__

Method in class wx.lib.imagebrowser.ImageView

__init__

Method in class wx.lib.infoframe.Dummy_PyInformationalMessagesFrame

__init__

Method in class wx.lib.infoframe.PyInformationalMessagesFrame

__init__

Method in class wx.lib.intctrl.IntCtrl

__init__

Method in class wx.lib.intctrl.IntUpdatedEvent

__init__

Method in class wx.lib.intctrl.IntValidator

__init__

Method in class wx.lib.layoutf.Layoutf

__init__

Method in class wx.lib.masked.combobox.BaseMaskedComboBox

__init__

Method in class wx.lib.masked.combobox.MaskedComboBoxSelectEvent

__init__

Method in class wx.lib.masked.combobox.PreMaskedComboBox

__init__

Method in class wx.lib.masked.ipaddrctrl.IpAddrCtrl

__init__

Method in class wx.lib.masked.maskededit.Field

__init__

Method in class wx.lib.masked.maskededit.MaskedEditMixin

__init__

Method in class wx.lib.masked.numctrl.NumCtrl

__init__

Method in class wx.lib.masked.numctrl.NumberUpdatedEvent

__init__

Method in class wx.lib.masked.textctrl.BaseMaskedTextCtrl

__init__

Method in class wx.lib.masked.textctrl.PreMaskedTextCtrl

__init__

Method in class wx.lib.masked.timectrl.TimeCtrl

__init__

Method in class wx.lib.masked.timectrl.TimeUpdatedEvent

__init__

Method in class wx.lib.mixins.grid.GridAutoEditMixin

__init__

Method in class wx.lib.mixins.listctrl.ColumnSorterMixin

__init__

Method in class wx.lib.mixins.listctrl.ListCtrlAutoWidthMixin

__init__

Method in class wx.lib.mixins.listctrl.ListCtrlSelectionManagerMix

__init__

Method in class wx.lib.mixins.listctrl.TextEditMixin

__init__

Method in class wx.lib.mixins.rubberband.RubberBand

__init__

Method in class wx.lib.multisash.EmptyChild

__init__

Method in class wx.lib.multisash.MultiClient

__init__

Method in class wx.lib.multisash.MultiCloser

__init__

Method in class wx.lib.multisash.MultiCreator

__init__

Method in class wx.lib.multisash.MultiSash

__init__

Method in class wx.lib.multisash.MultiSizer

__init__

Method in class wx.lib.multisash.MultiSplit

__init__

Method in class wx.lib.multisash.MultiViewLeaf

__init__

Method in class wx.lib.mvctree.BasicTreeModel

__init__

Method in class wx.lib.mvctree.Editor

__init__

Method in class wx.lib.mvctree.FSTreeModel

__init__

Method in class wx.lib.mvctree.FileWrapper

__init__

Method in class wx.lib.mvctree.LateFSTreeModel

__init__

Method in class wx.lib.mvctree.LayoutEngine

__init__

Method in class wx.lib.mvctree.LinePainter

__init__

Method in class wx.lib.mvctree.MVCTree

__init__

Method in class wx.lib.mvctree.MVCTreeEvent

__init__

Method in class wx.lib.mvctree.MVCTreeNode

__init__

Method in class wx.lib.mvctree.MVCTreeNotifyEvent

__init__

Method in class wx.lib.mvctree.NodePainter

__init__

Method in class wx.lib.mvctree.Painter

__init__

Method in class wx.lib.mvctree.Rect

__init__

Method in class wx.lib.mvctree.TextConverter

__init__

Method in class wx.lib.mvctree.Transform

__init__

Method in class wx.lib.mvctree.TreeLayout

__init__

Method in class wx.lib.mvctree.TreePainter

__init__

Method in class wx.lib.ogl.ArrowHead

__init__

Method in class wx.lib.ogl.BitmapShape

__init__

Method in class wx.lib.ogl.CircleShape

__init__

Method in class wx.lib.ogl.CompositeShape

__init__

Method in class wx.lib.ogl.Constraint

__init__

Method in class wx.lib.ogl.ConstraintType

__init__

Method in class wx.lib.ogl.ControlPoint

__init__

Method in class wx.lib.ogl.Diagram

__init__

Method in class wx.lib.ogl.DividedShape

__init__

Method in class wx.lib.ogl.DividedShapeControlPoint

__init__

Method in class wx.lib.ogl.DivisionControlPoint

__init__

Method in class wx.lib.ogl.DivisionShape

__init__

Method in class wx.lib.ogl.DrawOp

__init__

Method in class wx.lib.ogl.DrawnShape

__init__

Method in class wx.lib.ogl.EllipseShape

__init__

Method in class wx.lib.ogl.LabelShape

__init__

Method in class wx.lib.ogl.LineControlPoint

__init__

Method in class wx.lib.ogl.LineShape

__init__

Method in class wx.lib.ogl.OpDraw

__init__

Method in class wx.lib.ogl.OpPolyDraw

__init__

Method in class wx.lib.ogl.OpSetClipping

__init__

Method in class wx.lib.ogl.OpSetGDI

__init__

Method in class wx.lib.ogl.PolygonControlPoint

__init__

Method in class wx.lib.ogl.PolygonShape

__init__

Method in class wx.lib.ogl.PopupDivisionMenu

__init__

Method in class wx.lib.ogl.PseudoMetaFile

__init__

Method in class wx.lib.ogl.RectangleShape

__init__

Method in class wx.lib.ogl.Shape

__init__

Method in class wx.lib.ogl.ShapeCanvas

__init__

Method in class wx.lib.ogl.ShapeEvtHandler

__init__

Method in class wx.lib.ogl.ShapeRegion

__init__

Method in class wx.lib.ogl.ShapeTextLine

__init__

Method in class wx.lib.ogl.TextShape

__init__

Method in class wx.lib.plot.PlotCanvas

__init__

Method in class wx.lib.plot.PlotGraphics

__init__

Method in class wx.lib.plot.PlotPrintout

__init__

Method in class wx.lib.plot.PolyLine

__init__

Method in class wx.lib.plot.PolyMarker

__init__

Method in class wx.lib.plot.PolyPoints

__init__

Method in class wx.lib.plot.TestFrame

__init__

Method in class wx.lib.popupctl.PopButton

__init__

Method in class wx.lib.popupctl.PopupControl

__init__

Method in class wx.lib.popupctl.PopupDialog

__init__

Method in class wx.lib.printout.PrintGrid

__init__

Method in class wx.lib.printout.PrintTable

__init__

Method in class wx.lib.printout.PrintTableDraw

__init__

Method in class wx.lib.printout.SetPrintout

__init__

Method in class wx.lib.pubsub.Message

__init__

Method in class wx.lib.pydocview.AboutDialog

__init__

Method in class wx.lib.pydocview.AboutService

__init__

Method in class wx.lib.pydocview.ChildDocTemplate

__init__

Method in class wx.lib.pydocview.DocMDIChildFrame

__init__

Method in class wx.lib.pydocview.DocMDIParentFrame

__init__

Method in class wx.lib.pydocview.DocOptionsService

__init__

Method in class wx.lib.pydocview.DocSDIFrame

__init__

Method in class wx.lib.pydocview.DocService

__init__

Method in class wx.lib.pydocview.DocTabbedChildFrame

__init__

Method in class wx.lib.pydocview.DocTabbedParentFrame

__init__

Method in class wx.lib.pydocview.FilePropertiesDialog

__init__

Method in class wx.lib.pydocview.FilePropertiesService

__init__

Method in class wx.lib.pydocview.GeneralOptionsPanel

__init__

Method in class wx.lib.pydocview.OptionsDialog

__init__

Method in class wx.lib.pydocview.WindowMenuService

__init__

Method in class wx.lib.pyshell.FauxFile

__init__

Method in class wx.lib.pyshell.PyShellWindow

__init__

Method in class wx.lib.rcsizer.RowColSizer

__init__

Method in class wx.lib.rightalign.RightTextCtrl

__init__

Method in class wx.lib.scrolledpanel.ScrolledPanel

__init__

Method in class wx.lib.sheet.CCellEditor

__init__

Method in class wx.lib.sheet.CSheet

__init__

Method in class wx.lib.sheet.CTextCellEditor

__init__

Method in class wx.lib.shell.PyShell

__init__

Method in class wx.lib.shell.PyShellInput

__init__

Method in class wx.lib.shell.PyShellOutput

__init__

Method in class wx.lib.splashscreen.SplashScreen

__init__

Method in class wx.lib.statbmp.GenStaticBitmap

__init__

Method in class wx.lib.stattext.GenStaticText

__init__

Method in class wx.lib.throbber.Throbber

__init__

Method in class wx.lib.throbber.UpdateThrobberEvent

__init__

Method in class wx.lib.ticker.Ticker

__init__

Method in class wx.lib.ticker_xrc.wxTickerXmlHandler

__init__

Method in class wx.lib.wxPlotCanvas.PlotCanvas

__init__

Method in class wx.lib.wxPlotCanvas.PlotGraphics

__init__

Method in class wx.lib.wxPlotCanvas.PolyLine

__init__

Method in class wx.lib.wxPlotCanvas.PolyMarker

__init__

Method in class wx.lib.wxPlotCanvas.PolyPoints

__init__

Method in class wx.lib.wxpTag.wxpTagHandler

__init__

Method in class wx.media.MediaCtrl

__init__

Method in class wx.media.MediaEvent

__init__

Method in class wx.py.PyAlaCarte.App

__init__

Method in class wx.py.PyAlaMode.App

__init__

Method in class wx.py.PyAlaModeTest.App

__init__

Method in class wx.py.buffer.Buffer

__init__

Method in class wx.py.crust.Calltip

__init__

Method in class wx.py.crust.Crust

__init__

Method in class wx.py.crust.CrustFrame

__init__

Method in class wx.py.crust.DispatcherListing

__init__

Method in class wx.py.crust.Display

__init__

Method in class wx.py.crust.SessionListing

__init__

Method in class wx.py.dispatcher.BoundMethodWeakref

__init__

Method in class wx.py.dispatcher.DispatcherError

__init__

Method in class wx.py.document.Document

__init__

Method in class wx.py.editor.DialogResults

__init__

Method in class wx.py.editor.EditWindow

__init__

Method in class wx.py.editor.Editor

__init__

Method in class wx.py.editor.EditorFrame

__init__

Method in class wx.py.editor.EditorNotebook

__init__

Method in class wx.py.editor.EditorNotebookFrame

__init__

Method in class wx.py.editor.EditorShellNotebook

__init__

Method in class wx.py.editor.EditorShellNotebookFrame

__init__

Method in class wx.py.editwindow.EditWindow

__init__

Method in class wx.py.filling.Filling

__init__

Method in class wx.py.filling.FillingFrame

__init__

Method in class wx.py.filling.FillingText

__init__

Method in class wx.py.filling.FillingTree

__init__

Method in class wx.py.frame.Frame

__init__

Method in class wx.py.interpreter.Interpreter

__init__

Method in class wx.py.interpreter.InterpreterAlaCarte

__init__

Method in class wx.py.pseudo.PseudoFile

__init__

Method in class wx.py.pseudo.PseudoFileErr

__init__

Method in class wx.py.pseudo.PseudoFileIn

__init__

Method in class wx.py.pseudo.PseudoFileOut

__init__

Method in class wx.py.pseudo.PseudoKeyword

__init__

Method in class wx.py.shell.Shell

__init__

Method in class wx.py.shell.ShellFacade

__init__

Method in class wx.py.shell.ShellFrame

__init__

Method in class wx.stc.StyledTextCtrl

__init__

Method in class wx.stc.StyledTextEvent

__init__

Method in class wx.tools.dbg.Logger

__init__

Method in class wx.webkit.WebKitCtrl

__init__

Method in class wx.webkit.WebKitStateChangedEvent

__init__

Method in class wx.wizard.PyWizardPage

__init__

Method in class wx.wizard.Wizard

__init__

Method in class wx.wizard.WizardEvent

__init__

Method in class wx.wizard.WizardPage

__init__

Method in class wx.wizard.WizardPageSimple

__init__

Method in class wx.xrc.XmlDocument

__init__

Method in class wx.xrc.XmlNode

__init__

Method in class wx.xrc.XmlProperty

__init__

Method in class wx.xrc.XmlResource

__init__

Method in class wx.xrc.XmlResourceHandler

__init__

Method in class wx.xrc.XmlSubclassFactory

__init__

Method in class wx.xrc.XmlSubclassFactory_Python

__isub__

Method in class wx.DateSpan

__isub__

Method in class wx.DateTime

__isub__

Method in class wx.Point

__isub__

Method in class wx.Point2D

__isub__

Method in class wx.TimeSpan

__itemsize__

Variable in class __builtin__.type

__le__

Method in class wx.DateTime

__le__

Method in class wx.TimeSpan

__len__

Method in class wx.GBPosition

__len__

Method in class wx.GBSpan

__len__

Method in class wx.Point

__len__

Method in class wx.Point2D

__len__

Method in class wx.RealPoint

__len__

Method in class wx.Rect

__len__

Method in class wx.Size

__len__

Method in class wx.grid.GridCellCoords

__len__

Method in class wx.lib.plot.PlotGraphics

__len__

Method in class wx.lib.wxPlotCanvas.PlotGraphics

__lt__

Method in class wx.DateTime

__lt__

Method in class wx.TimeSpan

__mro__

Variable in class __builtin__.type

__mul__

Method in class wx.DateSpan

__mul__

Method in class wx.TimeSpan

__name__

Variable in class __builtin__.type

__ne__

Method in class wx.Bitmap

__ne__

Method in class wx.Colour

__ne__

Method in class wx.DataFormat

__ne__

Method in class wx.DateSpan

__ne__

Method in class wx.DateTime

__ne__

Method in class wx.Font

__ne__

Method in class wx.GBPosition

__ne__

Method in class wx.GBSpan

__ne__

Method in class wx.Pen

__ne__

Method in class wx.Point

__ne__

Method in class wx.Point2D

__ne__

Method in class wx.RealPoint

__ne__

Method in class wx.Rect

__ne__

Method in class wx.Size

__ne__

Method in class wx.TimeSpan

__ne__

Method in class wx.TreeItemId

__ne__

Method in class wx.VideoMode

__ne__

Method in class wx.grid.GridCellCoords

__neg__

Method in class wx.DateSpan

__neg__

Method in class wx.Point2D

__neg__

Method in class wx.TimeSpan

__new__

Method in class __builtin__.object

__new__

Method in class __builtin__.type

__nonzero__

Method in class wx.Bitmap

__nonzero__

Method in class wx.Brush

__nonzero__

Method in class wx.Caret

__nonzero__

Method in class wx.ClipboardLocker

__nonzero__

Method in class wx.Colour

__nonzero__

Method in class wx.Cursor

__nonzero__

Method in class wx.DC

__nonzero__

Method in class wx.DateTime

__nonzero__

Method in class wx.Display

__nonzero__

Method in class wx.EncodingConverter

__nonzero__

Method in class wx.Font

__nonzero__

Method in class wx.GBPosition

__nonzero__

Method in class wx.GBSpan

__nonzero__

Method in class wx.Icon

__nonzero__

Method in class wx.IconLocation

__nonzero__

Method in class wx.Image

__nonzero__

Method in class wx.Joystick

__nonzero__

Method in class wx.Locale

__nonzero__

Method in class wx.PageSetupDialogData

__nonzero__

Method in class wx.Palette

__nonzero__

Method in class wx.Pen

__nonzero__

Method in class wx.Point

__nonzero__

Method in class wx.Point2D

__nonzero__

Method in class wx.PrintData

__nonzero__

Method in class wx.PrintDialogData

__nonzero__

Method in class wx.PrintPreview

__nonzero__

Method in class wx.RealPoint

__nonzero__

Method in class wx.Rect

__nonzero__

Method in class wx.RegionIterator

__nonzero__

Method in class wx.Size

__nonzero__

Method in class wx.Sound

__nonzero__

Method in class wx.TaskBarIcon

__nonzero__

Method in class wx.TreeItemId

__nonzero__

Method in class wx.VideoMode

__reduce__

Method in class __builtin__.object

__reduce__

Method in class wx.Colour

__reduce__

Method in class wx.GBPosition

__reduce__

Method in class wx.GBSpan

__reduce__

Method in class wx.Point

__reduce__

Method in class wx.Point2D

__reduce__

Method in class wx.RealPoint

__reduce__

Method in class wx.Rect

__reduce__

Method in class wx.Size

__reduce_ex__

Method in class __builtin__.object

__repr__

Method in class __builtin__.object

__repr__

Method in class __builtin__.type

__repr__

Method in class wx.ANIHandler

__repr__

Method in class wx.AcceleratorEntry

__repr__

Method in class wx.AcceleratorTable

__repr__

Method in class wx.ActivateEvent

__repr__

Method in class wx.ArtProvider

__repr__

Method in class wx.BMPHandler

__repr__

Method in class wx.Bitmap

__repr__

Method in class wx.BitmapButton

__repr__

Method in class wx.BitmapDataObject

__repr__

Method in class wx.BookCtrlBase

__repr__

Method in class wx.BookCtrlBaseEvent

__repr__

Method in class wx.BookCtrlSizer

__repr__

Method in class wx.BoxSizer

__repr__

Method in class wx.Brush

__repr__

Method in class wx.BrushList

__repr__

Method in class wx.BufferedDC

__repr__

Method in class wx.BufferedPaintDC

__repr__

Method in class wx.BusyCursor

__repr__

Method in class wx.BusyInfo

__repr__

Method in class wx.Button

__repr__

Method in class wx.CPPFileSystemHandler

__repr__

Method in class wx.CURHandler

__repr__

Method in class wx.CalculateLayoutEvent

__repr__

Method in class wx.Caret

__repr__

Method in class wx.CheckBox

__repr__

Method in class wx.CheckListBox

__repr__

Method in class wx.ChildFocusEvent

__repr__

Method in class wx.Choice

__repr__

Method in class wx.Choicebook

__repr__

Method in class wx.ChoicebookEvent

__repr__

Method in class wx.ClientDC

__repr__

Method in class wx.Clipboard

__repr__

Method in class wx.ClipboardLocker

__repr__

Method in class wx.CloseEvent

__repr__

Method in class wx.Colour

__repr__

Method in class wx.ColourData

__repr__

Method in class wx.ColourDatabase

__repr__

Method in class wx.ColourDialog

__repr__

Method in class wx.ComboBox

__repr__

Method in class wx.CommandEvent

__repr__

Method in class wx.Config

__repr__

Method in class wx.ConfigBase

__repr__

Method in class wx.ConfigPathChanger

__repr__

Method in class wx.ContextHelp

__repr__

Method in class wx.ContextHelpButton

__repr__

Method in class wx.ContextMenuEvent

__repr__

Method in class wx.Control

__repr__

Method in class wx.ControlWithItems

__repr__

Method in class wx.Cursor

__repr__

Method in class wx.CustomDataObject

__repr__

Method in class wx.DC

__repr__

Method in class wx.DataFormat

__repr__

Method in class wx.DataObject

__repr__

Method in class wx.DataObjectComposite

__repr__

Method in class wx.DataObjectSimple

__repr__

Method in class wx.DateEvent

__repr__

Method in class wx.DatePickerCtrl

__repr__

Method in class wx.DateSpan

__repr__

Method in class wx.DateTime

__repr__

Method in class wx.Dialog

__repr__

Method in class wx.DirDialog

__repr__

Method in class wx.DirFilterListCtrl

__repr__

Method in class wx.Display

__repr__

Method in class wx.DisplayChangedEvent

__repr__

Method in class wx.DragImage

__repr__

Method in class wx.DropFilesEvent

__repr__

Method in class wx.DropSource

__repr__

Method in class wx.DropTarget

__repr__

Method in class wx.Effects

__repr__

Method in class wx.EncodingConverter

__repr__

Method in class wx.EraseEvent

__repr__

Method in class wx.Event

__repr__

Method in class wx.EventLoop

__repr__

Method in class wx.EvtHandler

__repr__

Method in class wx.FSFile

__repr__

Method in class wx.FileConfig

__repr__

Method in class wx.FileDataObject

__repr__

Method in class wx.FileDialog

__repr__

Method in class wx.FileDropTarget

__repr__

Method in class wx.FileHistory

__repr__

Method in class wx.FileSystem

__repr__

Method in class wx.FileSystemHandler

__repr__

Method in class wx.FileType

__repr__

Method in class wx.FileTypeInfo

__repr__

Method in class wx.FindDialogEvent

__repr__

Method in class wx.FindReplaceData

__repr__

Method in class wx.FindReplaceDialog

__repr__

Method in class wx.FlexGridSizer

__repr__

Method in class wx.FocusEvent

__repr__

Method in class wx.Font

__repr__

Method in class wx.FontData

__repr__

Method in class wx.FontDialog

__repr__

Method in class wx.FontEnumerator

__repr__

Method in class wx.FontList

__repr__

Method in class wx.FontMapper

__repr__

Method in class wx.Frame

__repr__

Method in class wx.GBPosition

__repr__

Method in class wx.GBSizerItem

__repr__

Method in class wx.GBSpan

__repr__

Method in class wx.GDIObject

__repr__

Method in class wx.GIFHandler

__repr__

Method in class wx.Gauge

__repr__

Method in class wx.GenericDirCtrl

__repr__

Method in class wx.GridBagSizer

__repr__

Method in class wx.GridSizer

__repr__

Method in class wx.HelpEvent

__repr__

Method in class wx.HelpProvider

__repr__

Method in class wx.HtmlListBox

__repr__

Method in class wx.ICOHandler

__repr__

Method in class wx.Icon

__repr__

Method in class wx.IconBundle

__repr__

Method in class wx.IconLocation

__repr__

Method in class wx.IconizeEvent

__repr__

Method in class wx.IdleEvent

__repr__

Method in class wx.Image

__repr__

Method in class wx.ImageHandler

__repr__

Method in class wx.ImageHistogram

__repr__

Method in class wx.ImageList

__repr__

Method in class wx.IndividualLayoutConstraint

__repr__

Method in class wx.InitDialogEvent

__repr__

Method in class wx.InputStream

__repr__

Method in class wx.InternetFSHandler

__repr__

Method in class wx.ItemContainer

__repr__

Method in class wx.JPEGHandler

__repr__

Method in class wx.Joystick

__repr__

Method in class wx.JoystickEvent

__repr__

Method in class wx.KeyEvent

__repr__

Method in class wx.LanguageInfo

__repr__

Method in class wx.LayoutAlgorithm

__repr__

Method in class wx.LayoutConstraints

__repr__

Method in class wx.ListBox

__repr__

Method in class wx.ListCtrl

__repr__

Method in class wx.ListEvent

__repr__

Method in class wx.ListItem

__repr__

Method in class wx.ListItemAttr

__repr__

Method in class wx.ListView

__repr__

Method in class wx.Listbook

__repr__

Method in class wx.ListbookEvent

__repr__

Method in class wx.Locale

__repr__

Method in class wx.Log

__repr__

Method in class wx.LogChain

__repr__

Method in class wx.LogGui

__repr__

Method in class wx.LogNull

__repr__

Method in class wx.LogStderr

__repr__

Method in class wx.LogTextCtrl

__repr__

Method in class wx.LogWindow

__repr__

Method in class wx.MDIChildFrame

__repr__

Method in class wx.MDIClientWindow

__repr__

Method in class wx.MDIParentFrame

__repr__

Method in class wx.Mask

__repr__

Method in class wx.MaximizeEvent

__repr__

Method in class wx.MemoryDC

__repr__

Method in class wx.MemoryFSHandler

__repr__

Method in class wx.Menu

__repr__

Method in class wx.MenuBar

__repr__

Method in class wx.MenuEvent

__repr__

Method in class wx.MenuItem

__repr__

Method in class wx.MessageDialog

__repr__

Method in class wx.MetaFile

__repr__

Method in class wx.MetaFileDC

__repr__

Method in class wx.MetafileDataObject

__repr__

Method in class wx.MimeTypesManager

__repr__

Method in class wx.MiniFrame

__repr__

Method in class wx.MirrorDC

__repr__

Method in class wx.MouseCaptureChangedEvent

__repr__

Method in class wx.MouseEvent

__repr__

Method in class wx.MoveEvent

__repr__

Method in class wx.MultiChoiceDialog

__repr__

Method in class wx.MutexGuiLocker

__repr__

Method in class wx.NativeEncodingInfo

__repr__

Method in class wx.NativeFontInfo

__repr__

Method in class wx.NavigationKeyEvent

__repr__

Method in class wx.NcPaintEvent

__repr__

Method in class wx.Notebook

__repr__

Method in class wx.NotebookEvent

__repr__

Method in class wx.NotebookSizer

__repr__

Method in class wx.NotifyEvent

__repr__

Method in class wx.Object

__repr__

Method in class wx.OutputStream

__repr__

Method in class wx.PCXHandler

__repr__

Method in class wx.PNGHandler

__repr__

Method in class wx.PNMHandler

__repr__

Method in class wx.PageSetupDialog

__repr__

Method in class wx.PageSetupDialogData

__repr__

Method in class wx.PaintDC

__repr__

Method in class wx.PaintEvent

__repr__

Method in class wx.Palette

__repr__

Method in class wx.PaletteChangedEvent

__repr__

Method in class wx.Panel

__repr__

Method in class wx.PasswordEntryDialog

__repr__

Method in class wx.Pen

__repr__

Method in class wx.PenList

__repr__

Method in class wx.Point

__repr__

Method in class wx.Point2D

__repr__

Method in class wx.PopupTransientWindow

__repr__

Method in class wx.PopupWindow

__repr__

Method in class wx.PostScriptDC

__repr__

Method in class wx.PreviewCanvas

__repr__

Method in class wx.PreviewControlBar

__repr__

Method in class wx.PreviewFrame

__repr__

Method in class wx.PrintData

__repr__

Method in class wx.PrintDialog

__repr__

Method in class wx.PrintDialogData

__repr__

Method in class wx.PrintPreview

__repr__

Method in class wx.Printer

__repr__

Method in class wx.PrinterDC

__repr__

Method in class wx.Printout

__repr__

Method in class wx.Process

__repr__

Method in class wx.ProcessEvent

__repr__

Method in class wx.ProgressDialog

__repr__

Method in class wx.PropagateOnce

__repr__

Method in class wx.PropagationDisabler

__repr__

Method in class wx.PyApp

__repr__

Method in class wx.PyBitmapDataObject

__repr__

Method in class wx.PyCommandEvent

__repr__

Method in class wx.PyControl

__repr__

Method in class wx.PyDataObjectSimple

__repr__

Method in class wx.PyEvent

__repr__

Method in class wx.PyLog

__repr__

Method in class wx.PyPanel

__repr__

Method in class wx.PyPreviewControlBar

__repr__

Method in class wx.PyPreviewFrame

__repr__

Method in class wx.PyPrintPreview

__repr__

Method in class wx.PyScrolledWindow

__repr__

Method in class wx.PySizer

__repr__

Method in class wx.PyTextDataObject

__repr__

Method in class wx.PyTipProvider

__repr__

Method in class wx.PyValidator

__repr__

Method in class wx.PyWindow

__repr__

Method in class wx.Quantize

__repr__

Method in class wx.QueryLayoutInfoEvent

__repr__

Method in class wx.QueryNewPaletteEvent

__repr__

Method in class wx.RadioBox

__repr__

Method in class wx.RadioButton

__repr__

Method in class wx.RealPoint

__repr__

Method in class wx.Rect

__repr__

Method in class wx.Region

__repr__

Method in class wx.RegionIterator

__repr__

Method in class wx.SashEvent

__repr__

Method in class wx.SashLayoutWindow

__repr__

Method in class wx.SashWindow

__repr__

Method in class wx.ScreenDC

__repr__

Method in class wx.ScrollBar

__repr__

Method in class wx.ScrollEvent

__repr__

Method in class wx.ScrollWinEvent

__repr__

Method in class wx.ScrolledWindow

__repr__

Method in class wx.SetCursorEvent

__repr__

Method in class wx.ShowEvent

__repr__

Method in class wx.SimpleHelpProvider

__repr__

Method in class wx.SingleChoiceDialog

__repr__

Method in class wx.SingleInstanceChecker

__repr__

Method in class wx.Size

__repr__

Method in class wx.SizeEvent

__repr__

Method in class wx.Sizer

__repr__

Method in class wx.SizerItem

__repr__

Method in class wx.Slider

__repr__

Method in class wx.Sound

__repr__

Method in class wx.SpinButton

__repr__

Method in class wx.SpinCtrl

__repr__

Method in class wx.SpinEvent

__repr__

Method in class wx.SplashScreen

__repr__

Method in class wx.SplashScreenWindow

__repr__

Method in class wx.SplitterEvent

__repr__

Method in class wx.SplitterWindow

__repr__

Method in class wx.StandardPaths

__repr__

Method in class wx.StaticBitmap

__repr__

Method in class wx.StaticBox

__repr__

Method in class wx.StaticBoxSizer

__repr__

Method in class wx.StaticLine

__repr__

Method in class wx.StaticText

__repr__

Method in class wx.StatusBar

__repr__

Method in class wx.StdDialogButtonSizer

__repr__

Method in class wx.StopWatch

__repr__

Method in class wx.SysColourChangedEvent

__repr__

Method in class wx.SystemOptions

__repr__

Method in class wx.SystemSettings

__repr__

Method in class wx.TIFFHandler

__repr__

Method in class wx.TaskBarIcon

__repr__

Method in class wx.TaskBarIconEvent

__repr__

Method in class wx.TextAttr

__repr__

Method in class wx.TextCtrl

__repr__

Method in class wx.TextDataObject

__repr__

Method in class wx.TextDropTarget

__repr__

Method in class wx.TextEntryDialog

__repr__

Method in class wx.TextUrlEvent

__repr__

Method in class wx.TimeSpan

__repr__

Method in class wx.Timer

__repr__

Method in class wx.TimerEvent

__repr__

Method in class wx.TimerRunner

__repr__

Method in class wx.TipProvider

__repr__

Method in class wx.TipWindow

__repr__

Method in class wx.ToggleButton

__repr__

Method in class wx.ToolBar

__repr__

Method in class wx.ToolBarBase

__repr__

Method in class wx.ToolBarToolBase

__repr__

Method in class wx.ToolTip

__repr__

Method in class wx.TopLevelWindow

__repr__

Method in class wx.TreeCtrl

__repr__

Method in class wx.TreeEvent

__repr__

Method in class wx.TreeItemData

__repr__

Method in class wx.TreeItemId

__repr__

Method in class wx.URLDataObject

__repr__

Method in class wx.UpdateUIEvent

__repr__

Method in class wx.VListBox

__repr__

Method in class wx.VScrolledWindow

__repr__

Method in class wx.Validator

__repr__

Method in class wx.VideoMode

__repr__

Method in class wx.VisualAttributes

__repr__

Method in class wx.Window

__repr__

Method in class wx.WindowCreateEvent

__repr__

Method in class wx.WindowDC

__repr__

Method in class wx.WindowDestroyEvent

__repr__

Method in class wx.WindowDisabler

__repr__

Method in class wx.XPMHandler

__repr__

Method in class wx.ZipFSHandler

__repr__

Method in class wx.animate.AnimationBase

__repr__

Method in class wx.animate.AnimationPlayer

__repr__

Method in class wx.animate.GIFAnimation

__repr__

Method in class wx.animate.GIFAnimationCtrl

__repr__

Method in class wx.calendar.CalendarCtrl

__repr__

Method in class wx.calendar.CalendarDateAttr

__repr__

Method in class wx.calendar.CalendarEvent

__repr__

Method in class wx.gizmos.DynamicSashSplitEvent

__repr__

Method in class wx.gizmos.DynamicSashUnifyEvent

__repr__

Method in class wx.gizmos.DynamicSashWindow

__repr__

Method in class wx.gizmos.EditableListBox

__repr__

Method in class wx.gizmos.LEDNumberCtrl

__repr__

Method in class wx.gizmos.RemotelyScrolledTreeCtrl

__repr__

Method in class wx.gizmos.SplitterScrolledWindow

__repr__

Method in class wx.gizmos.StaticPicture

__repr__

Method in class wx.gizmos.ThinSplitterWindow

__repr__

Method in class wx.gizmos.TreeCompanionWindow

__repr__

Method in class wx.gizmos.TreeListColumnInfo

__repr__

Method in class wx.gizmos.TreeListCtrl

__repr__

Method in class wx.glcanvas.GLCanvas

__repr__

Method in class wx.glcanvas.GLContext

__repr__

Method in class wx.grid.Grid

__repr__

Method in class wx.grid.GridCellAttr

__repr__

Method in class wx.grid.GridCellAttrProvider

__repr__

Method in class wx.grid.GridCellAutoWrapStringEditor

__repr__

Method in class wx.grid.GridCellAutoWrapStringRenderer

__repr__

Method in class wx.grid.GridCellBoolEditor

__repr__

Method in class wx.grid.GridCellBoolRenderer

__repr__

Method in class wx.grid.GridCellChoiceEditor

__repr__

Method in class wx.grid.GridCellCoords

__repr__

Method in class wx.grid.GridCellDateTimeRenderer

__repr__

Method in class wx.grid.GridCellEditor

__repr__

Method in class wx.grid.GridCellEnumEditor

__repr__

Method in class wx.grid.GridCellEnumRenderer

__repr__

Method in class wx.grid.GridCellFloatEditor

__repr__

Method in class wx.grid.GridCellFloatRenderer

__repr__

Method in class wx.grid.GridCellNumberEditor

__repr__

Method in class wx.grid.GridCellNumberRenderer

__repr__

Method in class wx.grid.GridCellRenderer

__repr__

Method in class wx.grid.GridCellStringRenderer

__repr__

Method in class wx.grid.GridCellTextEditor

__repr__

Method in class wx.grid.GridEditorCreatedEvent

__repr__

Method in class wx.grid.GridEvent

__repr__

Method in class wx.grid.GridRangeSelectEvent

__repr__

Method in class wx.grid.GridSizeEvent

__repr__

Method in class wx.grid.GridStringTable

__repr__

Method in class wx.grid.GridTableBase

__repr__

Method in class wx.grid.GridTableMessage

__repr__

Method in class wx.grid.PyGridCellAttrProvider

__repr__

Method in class wx.grid.PyGridCellEditor

__repr__

Method in class wx.grid.PyGridCellRenderer

__repr__

Method in class wx.grid.PyGridTableBase

__repr__

Method in class wx.html.DefaultHtmlRenderingStyle

__repr__

Method in class wx.html.HtmlBookRecord

__repr__

Method in class wx.html.HtmlCell

__repr__

Method in class wx.html.HtmlColourCell

__repr__

Method in class wx.html.HtmlContainerCell

__repr__

Method in class wx.html.HtmlContentsItem

__repr__

Method in class wx.html.HtmlDCRenderer

__repr__

Method in class wx.html.HtmlEasyPrinting

__repr__

Method in class wx.html.HtmlFilter

__repr__

Method in class wx.html.HtmlFontCell

__repr__

Method in class wx.html.HtmlHelpController

__repr__

Method in class wx.html.HtmlHelpData

__repr__

Method in class wx.html.HtmlHelpFrame

__repr__

Method in class wx.html.HtmlLinkInfo

__repr__

Method in class wx.html.HtmlParser

__repr__

Method in class wx.html.HtmlPrintout

__repr__

Method in class wx.html.HtmlRenderingInfo

__repr__

Method in class wx.html.HtmlRenderingState

__repr__

Method in class wx.html.HtmlRenderingStyle

__repr__

Method in class wx.html.HtmlSearchStatus

__repr__

Method in class wx.html.HtmlSelection

__repr__

Method in class wx.html.HtmlTag

__repr__

Method in class wx.html.HtmlTagHandler

__repr__

Method in class wx.html.HtmlWidgetCell

__repr__

Method in class wx.html.HtmlWinParser

__repr__

Method in class wx.html.HtmlWinTagHandler

__repr__

Method in class wx.html.HtmlWindow

__repr__

Method in class wx.html.HtmlWordCell

__repr__

Method in class wx.lib.dialogs.DialogResults

__repr__

Method in class wx.lib.masked.combobox.BaseMaskedComboBox

__repr__

Method in class wx.lib.masked.textctrl.BaseMaskedTextCtrl

__repr__

Method in class wx.lib.masked.timectrl.TimeCtrl

__repr__

Method in class wx.lib.mvctree.MVCTree

__repr__

Method in class wx.lib.mvctree.MVCTreeNode

__repr__

Method in class wx.lib.ogl.Constraint

__repr__

Method in class wx.media.MediaCtrl

__repr__

Method in class wx.media.MediaEvent

__repr__

Method in class wx.py.dispatcher.BoundMethodWeakref

__repr__

Method in class wx.py.dispatcher.Parameter

__repr__

Method in class wx.py.editor.DialogResults

__repr__

Method in class wx.py.pseudo.PseudoKeyword

__repr__

Method in class wx.stc.StyledTextCtrl

__repr__

Method in class wx.stc.StyledTextEvent

__repr__

Method in class wx.webkit.WebKitCtrl

__repr__

Method in class wx.webkit.WebKitStateChangedEvent

__repr__

Method in class wx.wizard.PyWizardPage

__repr__

Method in class wx.wizard.Wizard

__repr__

Method in class wx.wizard.WizardEvent

__repr__

Method in class wx.wizard.WizardPage

__repr__

Method in class wx.wizard.WizardPageSimple

__repr__

Method in class wx.xrc.XmlDocument

__repr__

Method in class wx.xrc.XmlNode

__repr__

Method in class wx.xrc.XmlProperty

__repr__

Method in class wx.xrc.XmlResource

__repr__

Method in class wx.xrc.XmlResourceHandler

__repr__

Method in class wx.xrc.XmlSubclassFactory

__revision__

Variable in module wx.py.PyAlaCarte

__revision__

Variable in module wx.py.PyAlaMode

__revision__

Variable in module wx.py.PyAlaModeTest

__revision__

Variable in module wx.py.PyCrust

__revision__

Variable in module wx.py.PyFilling

__revision__

Variable in module wx.py.PyShell

__revision__

Variable in module wx.py.PyWrap

__revision__

Variable in package wx.py

__revision__

Variable in module wx.py.buffer

__revision__

Variable in module wx.py.crust

__revision__

Variable in module wx.py.dispatcher

__revision__

Variable in module wx.py.document

__revision__

Variable in module wx.py.editor

__revision__

Variable in module wx.py.editwindow

__revision__

Variable in module wx.py.filling

__revision__

Variable in module wx.py.frame

__revision__

Variable in module wx.py.images

__revision__

Variable in module wx.py.interpreter

__revision__

Variable in module wx.py.introspect

__revision__

Variable in module wx.py.pseudo

__revision__

Variable in module wx.py.shell

__revision__

Variable in module wx.py.version

__rmul__

Method in class wx.DateSpan

__rmul__

Method in class wx.TimeSpan

__safe_for_unpickling__

Variable in class wx.Colour

__safe_for_unpickling__

Variable in class wx.Colour

__safe_for_unpickling__

Variable in class wx.GBPosition

__safe_for_unpickling__

Variable in class wx.GBPosition

__safe_for_unpickling__

Variable in class wx.GBSpan

__safe_for_unpickling__

Variable in class wx.GBSpan

__safe_for_unpickling__

Variable in class wx.Point

__safe_for_unpickling__

Variable in class wx.Point

__safe_for_unpickling__

Variable in class wx.Point2D

__safe_for_unpickling__

Variable in class wx.Point2D

__safe_for_unpickling__

Variable in class wx.RealPoint

__safe_for_unpickling__

Variable in class wx.RealPoint

__safe_for_unpickling__

Variable in class wx.Rect

__safe_for_unpickling__

Variable in class wx.Rect

__safe_for_unpickling__

Variable in class wx.Size

__safe_for_unpickling__

Variable in class wx.Size

__setattr__

Method in class __builtin__.object

__setattr__

Method in class __builtin__.type

__setattr__

Method in class wx.py.shell.ShellFacade

__setitem__

Method in class wx.GBPosition

__setitem__

Method in class wx.GBSpan

__setitem__

Method in class wx.Point

__setitem__

Method in class wx.Point2D

__setitem__

Method in class wx.RealPoint

__setitem__

Method in class wx.Rect

__setitem__

Method in class wx.Size

__setitem__

Method in class wx.grid.GridCellCoords

__setitem__

Method in class wx.lib.mvctree.Rect

__str__

Method in class __builtin__.object

__str__

Method in class exceptions.Exception

__str__

Method in class wx.Colour

__str__

Method in class wx.DateTime

__str__

Method in class wx.GBPosition

__str__

Method in class wx.GBSpan

__str__

Method in class wx.NativeFontInfo

__str__

Method in class wx.Point

__str__

Method in class wx.Point2D

__str__

Method in class wx.RealPoint

__str__

Method in class wx.Rect

__str__

Method in class wx.Size

__str__

Method in class wx.TimeSpan

__str__

Method in class wx.grid.GridCellCoords

__str__

Method in class wx.lib.mvctree.FileWrapper

__str__

Method in class wx.lib.mvctree.MVCTree

__str__

Method in class wx.lib.mvctree.MVCTreeNode

__str__

Method in class wx.lib.mvctree.Rect

__str__

Method in class wx.lib.ogl.Shape

__str__

Method in class wx.lib.pubsub.Message

__sub__

Method in class wx.DateSpan

__sub__

Method in class wx.DateTime

__sub__

Method in class wx.Point

__sub__

Method in class wx.RealPoint

__sub__

Method in class wx.Size

__sub__

Method in class wx.TimeSpan

__subclasses__

Method in class __builtin__.type

__version__

Variable in package wx.lib.floatcanvas

__version__

Variable in module wx.lib.shell

__weakrefoffset__

Variable in class __builtin__.type

A_CST

Variable in class wx.DateTime

A_CST

Variable in class wx.DateTime

A_ESST

Variable in class wx.DateTime

A_ESST

Variable in class wx.DateTime

A_EST

Variable in class wx.DateTime

A_EST

Variable in class wx.DateTime

A_WST

Variable in class wx.DateTime

A_WST

Variable in class wx.DateTime

about

Method in class wx.py.shell.Shell

AboutDialog

Class in module wx.lib.pydocview

AboutService

Class in module wx.lib.pydocview

Above

Method in class wx.IndividualLayoutConstraint

AboveScreen

Method in class wx.lib.editor.editor.Editor

AbrWeekday

Variable in module wx.lib.calendar

Abs

Method in class wx.TimeSpan

Absolute

Method in class wx.IndividualLayoutConstraint

AcceleratorEntry

Class in package wx

AcceleratorTable

Class in package wx

AcceptsFocus

Method in class wx.Window

AcceptsFocus

Method in class wx.lib.buttons.GenButton

AcceptsFocus

Method in class wx.lib.calendar.Calendar

AcceptsFocus

Method in class wx.lib.statbmp.GenStaticBitmap

AcceptsFocus

Method in class wx.lib.stattext.GenStaticText

AcceptsFocus

Method in class wx.lib.ticker.Ticker

AcceptsFocusFromKeyboard

Method in class wx.Window

ACCustomizationFrame

Class in module wx.lib.analogclockopts

Activate

Method in class wx.MDIChildFrame

Activate

Method in class wx.lib.docview.DocMDIChildFrame

Activate

Method in class wx.lib.docview.View

Activate

Method in class wx.lib.pydocview.DocMDIChildFrame

Activate

Method in class wx.lib.pydocview.DocTabbedChildFrame

ActivateEvent

Class in package wx

ActivateNext

Method in class wx.MDIParentFrame

ActivateNotebookPage

Method in class wx.lib.pydocview.DocTabbedParentFrame

ActivatePrevious

Method in class wx.MDIParentFrame

ActivateView

Method in class wx.lib.docview.DocManager

Add

Method in class wx.DataObjectComposite

Add

Method in class wx.DateSpan

Add

Method in class wx.GridBagSizer

Add

Method in class wx.ImageList

Add

Method in class wx.Sizer

Add

Method in class wx.TimeSpan

Add

Method in class wx.lib.mvctree.MVCTreeNode

Add

Method in class wx.lib.rcsizer.RowColSizer

AddArrow

Method in class wx.lib.ogl.LineShape

AddArrowOrdered

Method in class wx.lib.ogl.LineShape

AddBook

Method in class wx.html.HtmlHelpController

AddBook

Method in class wx.html.HtmlHelpData

AddBrush

Method in class wx.BrushList

AddButton

Method in class wx.StdDialogButtonSizer

AddButton

Method in class wx.lib.foldmenu.FoldOutMenu

AddButton

Method in class wx.lib.foldmenu.FoldOutWindow

AddCatalog

Method in class wx.Locale

AddCatalogLookupPathPrefix

Method in class wx.Locale

AddCheckLabelTool

Method in class wx.ToolBarBase

AddCheckTool

Method in class wx.ToolBarBase

AddChild

Method in class wx.Window

AddChild

Method in class wx.lib.mvctree.BasicTreeModel

AddChild

Method in class wx.lib.mvctree.TreeModel

AddChild

Method in class wx.lib.ogl.CompositeShape

AddChild

Method in class wx.xrc.XmlNode

addChildren

Method in class wx.py.filling.FillingTree

AddColour

Method in class wx.ColourDatabase

AddColumn

Method in class wx.gizmos.TreeListCtrl

AddColumnInfo

Method in class wx.gizmos.TreeListCtrl

AddConstraint

Method in class wx.lib.ogl.CompositeShape

AddControl

Method in class wx.ToolBarBase

AddCustomEventHandler

Method in class wx.lib.pydocview.FilePropertiesService

AddData

Method in class wx.Clipboard

AddDocument

Method in class wx.lib.docview.DocManager

AddDS

Method in class wx.DateTime

AddEditor

Method in class wx.lib.mvctree.MVCTree

addEditor

Method in class wx.py.buffer.Buffer

AddFallback

Method in class wx.MimeTypesManager

AddFile

Method in class wx.FileDataObject

AddFile

Method in class wx.MemoryFSHandler

AddFilesToMenu

Method in class wx.FileHistory

AddFilesToThisMenu

Method in class wx.FileHistory

AddFileToHistory

Method in class wx.FileHistory

AddFileToHistory

Method in class wx.lib.docview.DocManager

AddFilter

Method in class wx.html.HtmlPrintout

AddFilter

Method in class wx.html.HtmlWindow

AddFoldPanel

Method in class wx.lib.foldpanelbar.FoldPanelBar

AddFoldPanelSeparator

Method in class wx.lib.foldpanelbar.FoldPanelBar

AddFoldPanelWindow

Method in class wx.lib.foldpanelbar.FoldPanelBar

AddFont

Method in class wx.FontList

AddGesture

Method in class wx.lib.gestures.MouseGestures

AddGrowableCol

Method in class wx.FlexGridSizer

AddGrowableCol

Method in class wx.lib.grids.PyFlexGridSizer

AddGrowableCol

Method in class wx.lib.rcsizer.RowColSizer

AddGrowableRow

Method in class wx.FlexGridSizer

AddGrowableRow

Method in class wx.lib.grids.PyFlexGridSizer

AddGrowableRow

Method in class wx.lib.rcsizer.RowColSizer

AddHandler

Method in class wx.FileSystem

AddHandler

Method in class wx.Image

AddHandler

Method in class wx.xrc.XmlResource

AddHelp

Method in class wx.HelpProvider

AddHelpById

Method in class wx.HelpProvider

addHistory

Method in class wx.py.shell.Shell

AddIcon

Method in class wx.IconBundle

AddIcon

Method in class wx.ImageList

AddIcon

Method in class wx.lib.mixins.imagelist.MagicImageList

AddIconFromFile

Method in class wx.IconBundle

AddItem

Method in class wx.GridBagSizer

AddItem

Method in class wx.Sizer

AddLabelTool

Method in class wx.ToolBarBase

AddLanguage

Method in class wx.Locale

AddLeaf

Method in class wx.lib.multisash.MultiSplit

AddLeaf

Method in class wx.lib.multisash.MultiViewLeaf

AddLine

Method in class wx.lib.ogl.Shape

AddMany

Method in class wx.Sizer

AddNotebookPage

Method in class wx.lib.pydocview.DocTabbedParentFrame

AddObject

Method in class wx.lib.floatcanvas.FloatCanvas.FloatCanvas

AddOptionsPanel

Method in class wx.lib.pydocview.DocOptionsService

AddPage

Method in class wx.BookCtrlBase

AddPen

Method in class wx.PenList

AddPendingEvent

Method in class wx.EvtHandler

AddPolygonPoint

Method in class wx.lib.ogl.PolygonShape

AddProperty

Method in class wx.xrc.XmlNode

AddPropertyName

Method in class wx.xrc.XmlNode

AddRadioLabelTool

Method in class wx.ToolBarBase

AddRadioTool

Method in class wx.ToolBarBase

AddRefDocument

Method in class wx.stc.StyledTextCtrl

AddRegion

Method in class wx.lib.ogl.Shape

AddRoot

Method in class wx.TreeCtrl

AddRoot

Method in class wx.gizmos.TreeListCtrl

AddSelect

Method in class wx.lib.calendar.CalDraw

AddSelect

Method in class wx.lib.calendar.Calendar

AddSeparator

Method in class wx.ToolBarBase

AddSeparator

Method in class wx.lib.foldpanelbar.FoldPanelItem

addshape

Method in class wx.lib.floatcanvas.FloatCanvas.FloatCanvas

addshape

Method in class wx.lib.floatcanvas.FloatCanvas.FloatCanvas

addshape

Method in class wx.lib.floatcanvas.FloatCanvas.FloatCanvas

addshape

Method in class wx.lib.floatcanvas.FloatCanvas.FloatCanvas

addshape

Method in class wx.lib.floatcanvas.FloatCanvas.FloatCanvas

addshape

Method in class wx.lib.floatcanvas.FloatCanvas.FloatCanvas

addshape

Method in class wx.lib.floatcanvas.FloatCanvas.FloatCanvas

addshape

Method in class wx.lib.floatcanvas.FloatCanvas.FloatCanvas

addshape

Method in class wx.lib.floatcanvas.FloatCanvas.FloatCanvas

addshape

Method in class wx.lib.floatcanvas.FloatCanvas.FloatCanvas

AddShape

Method in class wx.lib.ogl.Diagram

AddShape

Method in class wx.lib.ogl.ShapeCanvas

AddSimpleConstraint

Method in class wx.lib.ogl.CompositeShape

AddSimpleTool

Method in class wx.ToolBarBase

AddSizer

Method in class wx.Sizer

AddSpacer

Method in class wx.Sizer

AddSpacer

Method in class wx.lib.rcsizer.RowColSizer

AddStyle

Method in class wx.xrc.XmlResourceHandler

AddStyledText

Method in class wx.stc.StyledTextCtrl

AddSubclassFactory

Method in class wx.xrc.XmlResource

AddTagHandler

Method in class wx.html.HtmlParser

AddText

Method in class wx.lib.ogl.Shape

AddText

Method in class wx.lib.shell.PyShellOutput

AddText

Method in class wx.stc.StyledTextCtrl

AddTextRaw

Method in class wx.stc.StyledTextCtrl

AddTextUTF8

Method in class wx.stc.StyledTextCtrl

AddToCanvas

Method in class wx.lib.ogl.Shape

AddTool

Method in class wx.ToolBarBase

AddToolItem

Method in class wx.ToolBarBase

AddToSelection

Method in class wx.lib.mvctree.MVCTree

AddTraceMask

Method in class wx.Log

AddTS

Method in class wx.DateTime

AddView

Method in class wx.lib.docview.Document

AddWindow

Method in class wx.Sizer

AddWindow

Method in class wx.lib.foldpanelbar.FoldPanelItem

AddWindowStyles

Method in class wx.xrc.XmlResourceHandler

AddWithColourMask

Method in class wx.ImageList

AdjustLeft

Method in class wx.lib.ogl.DivisionShape

AdjustPagebreak

Method in class wx.html.HtmlCell

AdjustRemoteScrollbars

Method in class wx.gizmos.RemotelyScrolledTreeCtrl

AdjustRight

Method in class wx.lib.ogl.DivisionShape

AdjustScrollbars

Method in class wx.PrintPreview

AdjustScrollbars

Method in class wx.ScrolledWindow

AdjustScrollbars

Method in class wx.lib.editor.editor.Editor

AdjustTop

Method in class wx.lib.ogl.DivisionShape

AdjustValues

Method in class wx.lib.printout.PrintTableDraw

ADT

Variable in class wx.DateTime

ADT

Variable in class wx.DateTime

AdvanceSelection

Method in class wx.BookCtrlBase

afterPopupMenu

Method in class wx.lib.mixins.listctrl.ListCtrlSelectionManagerMix

AKDT

Variable in class wx.DateTime

AKDT

Variable in class wx.DateTime

AKST

Variable in class wx.DateTime

AKST

Variable in class wx.DateTime

alertDialog

Function in module wx.lib.dialogs

ALL_TOPICS

Variable in module wx.lib.pubsub

Allocate

Method in class wx.stc.StyledTextCtrl

Allow

Method in class wx.NotifyEvent

AltDown

Method in class wx.KeyEvent

AltDown

Method in class wx.MouseEvent

AltDown

Method in class wx.grid.GridEvent

AltDown

Method in class wx.grid.GridRangeSelectEvent

AltDown

Method in class wx.grid.GridSizeEvent

AltKey

Method in class wx.lib.editor.editor.Editor

am_pm_exclude

Variable in module wx.lib.masked.maskededit

analogclock

Module in package wx.lib

analogclockopts

Module in package wx.lib

AnalogClockWindow

Class in module wx.lib.analogclock

AncestorSelected

Method in class wx.lib.ogl.Shape

anchors

Module in package wx.lib

ANIHandler

Class in package wx

animate

Module in package wx

AnimationBase

Class in module wx.animate

AnimationPlayer

Class in module wx.animate

announce

Method in class distutils.cmd.Command

Anonymous

Variable in module wx.py.dispatcher

ansichars

Variable in module wx.lib.masked.maskededit

Any

Variable in class wx.grid.GridCellAttr

Any

Variable in module wx.py.dispatcher

App

Class in package wx

App

Class in module wx.py.PyAlaCarte

App

Class in module wx.py.PyAlaMode

App

Class in module wx.py.PyAlaModeTest

App

Class in module wx.py.PyCrust

App

Class in module wx.py.PyFilling

app

Variable in module wx.py.PyFilling

App

Class in module wx.py.PyShell

App

Class in module wx.py.filling

App_CleanUp

Function in package wx

Append

Method in class wx.ColourDatabase

Append

Method in class wx.ItemContainer

Append

Method in class wx.ListCtrl

Append

Method in class wx.Menu

Append

Method in class wx.MenuBar

Append

Method in class wx.lib.masked.combobox.BaseMaskedComboBox

AppendAndEnsureVisible

Method in class wx.ListBox

AppendCheckItem

Method in class wx.Menu

AppendCols

Method in class wx.grid.Grid

AppendCols

Method in class wx.grid.GridTableBase

AppendItem

Method in class wx.Menu

AppendItem

Method in class wx.TreeCtrl

AppendItem

Method in class wx.gizmos.TreeListCtrl

AppendItems

Method in class wx.ItemContainer

AppendItems

Method in class wx.lib.masked.combobox.BaseMaskedComboBox

AppendMenu

Method in class wx.Menu

AppendRadioItem

Method in class wx.Menu

AppendRows

Method in class wx.grid.Grid

AppendRows

Method in class wx.grid.GridTableBase

AppendSeparator

Method in class wx.Menu

AppendText

Method in class wx.TextCtrl

AppendText

Method in class wx.stc.StyledTextCtrl

AppendTextRaw

Method in class wx.stc.StyledTextCtrl

AppendTextUTF8

Method in class wx.stc.StyledTextCtrl

AppendToPage

Method in class wx.html.HtmlWindow

ApplyAttachmentOrdering

Method in class wx.lib.ogl.Shape

ApplyCaptionStyle

Method in class wx.lib.foldpanelbar.CaptionBar

ApplyCaptionStyle

Method in class wx.lib.foldpanelbar.FoldPanelBar

ApplyCaptionStyle

Method in class wx.lib.foldpanelbar.FoldPanelItem

ApplyCaptionStyleAll

Method in class wx.lib.foldpanelbar.FoldPanelBar

Apr

Variable in class wx.DateTime

Apr

Variable in class wx.DateTime

AreSatisfied

Method in class wx.LayoutConstraints

Arrange

Method in class wx.ListCtrl

ArrangeIcons

Method in class wx.MDIParentFrame

Arrow

Class in module wx.lib.floatcanvas.FloatCanvas

ArrowHead

Class in package wx.lib.ogl

ArtProvider

Class in package wx

ArtProvider_GetBitmap

Function in package wx

ArtProvider_GetIcon

Function in package wx

ArtProvider_GetSizeHint

Function in package wx

ArtProvider_PopProvider

Function in package wx

ArtProvider_PushProvider

Function in package wx

ArtProvider_RemoveProvider

Function in package wx

AsIs

Method in class wx.IndividualLayoutConstraint

ask

Method in class wx.py.shell.Shell

AssertionError

Class in module exceptions

AssignButtonsImageList

Method in class wx.gizmos.TreeListCtrl

AssignImageList

Method in class wx.BookCtrlBase

AssignImageList

Method in class wx.ListCtrl

AssignImageList

Method in class wx.TreeCtrl

AssignImageList

Method in class wx.gizmos.TreeListCtrl

AssignNewIds

Method in class wx.lib.ogl.Shape

AssignStateImageList

Method in class wx.TreeCtrl

AssignStateImageList

Method in class wx.gizmos.TreeListCtrl

Associate

Method in class wx.MimeTypesManager

AssociateHandle

Method in class wx.Window

AssociateTemplate

Method in class wx.lib.docview.DocManager

AST

Variable in class wx.DateTime

AST

Variable in class wx.DateTime

Attach

Method in class wx.Menu

Attach

Method in class wx.MenuBar

Attach

Method in class wx.ToolBarToolBase

Attach

Method in class wx.lib.ogl.Shape

AttachmentIsValid

Method in class wx.lib.ogl.DividedShape

AttachmentIsValid

Method in class wx.lib.ogl.PolygonShape

AttachmentIsValid

Method in class wx.lib.ogl.Shape

AttachmentSortTest

Method in class wx.lib.ogl.Shape

AttachUnknownControl

Method in class wx.xrc.XmlResource

attr_d

Variable in class wx.lib.layoutf.Layoutf

AttributeError

Class in module exceptions

Aug

Variable in class wx.DateTime

Aug

Variable in class wx.DateTime

AutoBrowse

Method in class wx.lib.hyperlink.HyperLinkCtrl

autoCallTipShow

Method in class wx.py.editor.Editor

autoCallTipShow

Method in class wx.py.shell.Shell

AutoCompActive

Method in class wx.stc.StyledTextCtrl

AutoCompCancel

Method in class wx.stc.StyledTextCtrl

AutoCompComplete

Method in class wx.stc.StyledTextCtrl

AutoCompGetAutoHide

Method in class wx.stc.StyledTextCtrl

AutoCompGetCancelAtStart

Method in class wx.stc.StyledTextCtrl

AutoCompGetChooseSingle

Method in class wx.stc.StyledTextCtrl

AutoCompGetCurrent

Method in class wx.stc.StyledTextCtrl

AutoCompGetDropRestOfWord

Method in class wx.stc.StyledTextCtrl

AutoCompGetIgnoreCase

Method in class wx.stc.StyledTextCtrl

AutoCompGetSeparator

Method in class wx.stc.StyledTextCtrl

AutoCompGetTypeSeparator

Method in class wx.stc.StyledTextCtrl

autoCompleteShow

Method in class wx.py.editor.Editor

autoCompleteShow

Method in class wx.py.shell.Shell

AutoCompPosStart

Method in class wx.stc.StyledTextCtrl

AutoCompSelect

Method in class wx.stc.StyledTextCtrl

AutoCompSetAutoHide

Method in class wx.stc.StyledTextCtrl

AutoCompSetCancelAtStart

Method in class wx.stc.StyledTextCtrl

AutoCompSetChooseSingle

Method in class wx.stc.StyledTextCtrl

AutoCompSetDropRestOfWord

Method in class wx.stc.StyledTextCtrl

AutoCompSetFillUps

Method in class wx.stc.StyledTextCtrl

AutoCompSetIgnoreCase

Method in class wx.stc.StyledTextCtrl

AutoCompSetSeparator

Method in class wx.stc.StyledTextCtrl

AutoCompSetTypeSeparator

Method in class wx.stc.StyledTextCtrl

AutoCompShow

Method in class wx.stc.StyledTextCtrl

AutoCompStops

Method in class wx.stc.StyledTextCtrl

autoformats

Variable in module wx.lib.masked.maskededit

AutoSize

Method in class wx.grid.Grid

AutoSizeColLabelSize

Method in class wx.grid.Grid

AutoSizeColumn

Method in class wx.grid.Grid

AutoSizeColumns

Method in class wx.grid.Grid

AutoSizeRow

Method in class wx.grid.Grid

AutoSizeRowLabelSize

Method in class wx.grid.Grid

AutoSizeRows

Method in class wx.grid.Grid

BackSpace

Method in class wx.lib.editor.editor.Editor

BackTab

Method in class wx.stc.StyledTextCtrl

base_AcceptsFocus

Method in class wx.PyControl

base_AcceptsFocus

Method in class wx.PyPanel

base_AcceptsFocus

Method in class wx.PyScrolledWindow

base_AcceptsFocus

Method in class wx.PyWindow

base_AcceptsFocus

Method in class wx.wizard.PyWizardPage

base_AcceptsFocusFromKeyboard

Method in class wx.PyControl

base_AcceptsFocusFromKeyboard

Method in class wx.PyPanel

base_AcceptsFocusFromKeyboard

Method in class wx.PyScrolledWindow

base_AcceptsFocusFromKeyboard

Method in class wx.PyWindow

base_AcceptsFocusFromKeyboard

Method in class wx.wizard.PyWizardPage

base_AddChild

Method in class wx.PyControl

base_AddChild

Method in class wx.PyPanel

base_AddChild

Method in class wx.PyScrolledWindow

base_AddChild

Method in class wx.PyWindow

base_AddChild

Method in class wx.wizard.PyWizardPage

base_AppendCols

Method in class wx.grid.PyGridTableBase

base_AppendRows

Method in class wx.grid.PyGridTableBase

base_CanGetValueAs

Method in class wx.grid.PyGridTableBase

base_CanHaveAttributes

Method in class wx.grid.PyGridTableBase

base_CanSetValueAs

Method in class wx.grid.PyGridTableBase

base_Clear

Method in class wx.grid.PyGridTableBase

base_CreateButtons

Method in class wx.PyPreviewControlBar

base_CreateCanvas

Method in class wx.PyPreviewFrame

base_CreateControlBar

Method in class wx.PyPreviewFrame

base_DeleteCols

Method in class wx.grid.PyGridTableBase

base_DeleteRows

Method in class wx.grid.PyGridTableBase

base_Destroy

Method in class wx.grid.PyGridCellEditor

base_DetermineScaling

Method in class wx.PyPrintPreview

base_DoGetBestSize

Method in class wx.PyControl

base_DoGetBestSize

Method in class wx.PyPanel

base_DoGetBestSize

Method in class wx.PyScrolledWindow

base_DoGetBestSize

Method in class wx.PyWindow

base_DoGetBestSize

Method in class wx.wizard.PyWizardPage

base_DoGetClientSize

Method in class wx.PyControl

base_DoGetClientSize

Method in class wx.PyPanel

base_DoGetClientSize

Method in class wx.PyScrolledWindow

base_DoGetClientSize

Method in class wx.PyWindow

base_DoGetClientSize

Method in class wx.wizard.PyWizardPage

base_DoGetPosition

Method in class wx.PyControl

base_DoGetPosition

Method in class wx.PyPanel

base_DoGetPosition

Method in class wx.PyScrolledWindow

base_DoGetPosition

Method in class wx.PyWindow

base_DoGetPosition

Method in class wx.wizard.PyWizardPage

base_DoGetSize

Method in class wx.PyControl

base_DoGetSize

Method in class wx.PyPanel

base_DoGetSize

Method in class wx.PyScrolledWindow

base_DoGetSize

Method in class wx.PyWindow

base_DoGetSize

Method in class wx.wizard.PyWizardPage

base_DoGetVirtualSize

Method in class wx.PyControl

base_DoGetVirtualSize

Method in class wx.PyPanel

base_DoGetVirtualSize

Method in class wx.PyScrolledWindow

base_DoGetVirtualSize

Method in class wx.PyWindow

base_DoGetVirtualSize

Method in class wx.wizard.PyWizardPage

base_DoMoveWindow

Method in class wx.PyControl

base_DoMoveWindow

Method in class wx.PyPanel

base_DoMoveWindow

Method in class wx.PyScrolledWindow

base_DoMoveWindow

Method in class wx.PyWindow

base_DoMoveWindow

Method in class wx.wizard.PyWizardPage

base_DoSetClientSize

Method in class wx.PyControl

base_DoSetClientSize

Method in class wx.PyPanel

base_DoSetClientSize

Method in class wx.PyScrolledWindow

base_DoSetClientSize

Method in class wx.PyWindow

base_DoSetClientSize

Method in class wx.wizard.PyWizardPage

base_DoSetSize

Method in class wx.PyControl

base_DoSetSize

Method in class wx.PyPanel

base_DoSetSize

Method in class wx.PyScrolledWindow

base_DoSetSize

Method in class wx.PyWindow

base_DoSetSize

Method in class wx.wizard.PyWizardPage

base_DoSetVirtualSize

Method in class wx.PyControl

base_DoSetVirtualSize

Method in class wx.PyPanel

base_DoSetVirtualSize

Method in class wx.PyScrolledWindow

base_DoSetVirtualSize

Method in class wx.PyWindow

base_DoSetVirtualSize

Method in class wx.wizard.PyWizardPage

base_DrawBlankPage

Method in class wx.PyPrintPreview

base_GetAttr

Method in class wx.grid.PyGridCellAttrProvider

base_GetAttr

Method in class wx.grid.PyGridTableBase

base_GetColLabelValue

Method in class wx.grid.PyGridTableBase

base_GetDefaultAttributes

Method in class wx.PyControl

base_GetDefaultAttributes

Method in class wx.PyPanel

base_GetDefaultAttributes

Method in class wx.PyScrolledWindow

base_GetDefaultAttributes

Method in class wx.PyWindow

base_GetMaxSize

Method in class wx.PyControl

base_GetMaxSize

Method in class wx.PyPanel

base_GetMaxSize

Method in class wx.PyScrolledWindow

base_GetMaxSize

Method in class wx.PyWindow

base_GetMaxSize

Method in class wx.wizard.PyWizardPage

base_GetPageInfo

Method in class wx.Printout

base_GetRowLabelValue

Method in class wx.grid.PyGridTableBase

base_GetTypeName

Method in class wx.grid.PyGridTableBase

base_GiveFeedback

Method in class wx.DropSource

base_HandleReturn

Method in class wx.grid.PyGridCellEditor

base_HasPage

Method in class wx.Printout

base_InitDialog

Method in class wx.PyControl

base_InitDialog

Method in class wx.PyPanel

base_InitDialog

Method in class wx.PyScrolledWindow

base_InitDialog

Method in class wx.PyWindow

base_InitDialog

Method in class wx.wizard.PyWizardPage

base_Initialize

Method in class wx.PyPreviewFrame

base_InsertCols

Method in class wx.grid.PyGridTableBase

base_InsertRows

Method in class wx.grid.PyGridTableBase

base_IsAcceptedKey

Method in class wx.grid.PyGridCellEditor

base_OnBeginDocument

Method in class wx.Printout

base_OnBeginPrinting

Method in class wx.Printout

base_OnCellClicked

Method in class wx.html.HtmlWindow

base_OnCellMouseHover

Method in class wx.html.HtmlWindow

base_OnData

Method in class wx.FileDropTarget

base_OnData

Method in class wx.TextDropTarget

base_OnDragOver

Method in class wx.DropTarget

base_OnDragOver

Method in class wx.FileDropTarget

base_OnDragOver

Method in class wx.TextDropTarget

base_OnDrop

Method in class wx.DropTarget

base_OnDrop

Method in class wx.FileDropTarget

base_OnDrop

Method in class wx.TextDropTarget

base_OnEndDocument

Method in class wx.Printout

base_OnEndPrinting

Method in class wx.Printout

base_OnEnter

Method in class wx.DropTarget

base_OnEnter

Method in class wx.FileDropTarget

base_OnEnter

Method in class wx.TextDropTarget

base_OnLeave

Method in class wx.DropTarget

base_OnLeave

Method in class wx.FileDropTarget

base_OnLeave

Method in class wx.TextDropTarget

base_OnLinkClicked

Method in class wx.html.HtmlWindow

base_OnPreparePrinting

Method in class wx.Printout

base_OnSetTitle

Method in class wx.html.HtmlWindow

base_OnTerminate

Method in class wx.Process

base_PaintBackground

Method in class wx.grid.PyGridCellEditor

base_PaintPage

Method in class wx.PyPrintPreview

base_Print

Method in class wx.PyPrintPreview

base_RemoveChild

Method in class wx.PyControl

base_RemoveChild

Method in class wx.PyPanel

base_RemoveChild

Method in class wx.PyScrolledWindow

base_RemoveChild

Method in class wx.PyWindow

base_RemoveChild

Method in class wx.wizard.PyWizardPage

base_RenderPage

Method in class wx.PyPrintPreview

base_SetAttr

Method in class wx.grid.PyGridCellAttrProvider

base_SetAttr

Method in class wx.grid.PyGridTableBase

base_SetColAttr

Method in class wx.grid.PyGridCellAttrProvider

base_SetColAttr

Method in class wx.grid.PyGridTableBase

base_SetColLabelValue

Method in class wx.grid.PyGridTableBase

base_SetCurrentPage

Method in class wx.PyPrintPreview

base_SetParameters

Method in class wx.grid.PyGridCellEditor

base_SetParameters

Method in class wx.grid.PyGridCellRenderer

base_SetRowAttr

Method in class wx.grid.PyGridCellAttrProvider

base_SetRowAttr

Method in class wx.grid.PyGridTableBase

base_SetRowLabelValue

Method in class wx.grid.PyGridTableBase

base_SetSize

Method in class wx.grid.PyGridCellEditor

base_SetZoom

Method in class wx.PyPrintPreview

base_SetZoomControl

Method in class wx.PyPreviewControlBar

base_ShouldInheritColours

Method in class wx.PyControl

base_ShouldInheritColours

Method in class wx.PyPanel

base_ShouldInheritColours

Method in class wx.PyScrolledWindow

base_ShouldInheritColours

Method in class wx.PyWindow

base_Show

Method in class wx.grid.PyGridCellEditor

base_StartingClick

Method in class wx.grid.PyGridCellEditor

base_StartingKey

Method in class wx.grid.PyGridCellEditor

base_TransferDataFromWindow

Method in class wx.PyControl

base_TransferDataFromWindow

Method in class wx.PyPanel

base_TransferDataFromWindow

Method in class wx.PyScrolledWindow

base_TransferDataFromWindow

Method in class wx.PyWindow

base_TransferDataFromWindow

Method in class wx.wizard.PyWizardPage

base_TransferDataToWindow

Method in class wx.PyControl

base_TransferDataToWindow

Method in class wx.PyPanel

base_TransferDataToWindow

Method in class wx.PyScrolledWindow

base_TransferDataToWindow

Method in class wx.PyWindow

base_TransferDataToWindow

Method in class wx.wizard.PyWizardPage

base_Validate

Method in class wx.PyControl

base_Validate

Method in class wx.PyPanel

base_Validate

Method in class wx.PyScrolledWindow

base_Validate

Method in class wx.PyWindow

base_Validate

Method in class wx.wizard.PyWizardPage

BaseMaskedComboBox

Class in module wx.lib.masked.combobox

BaseMaskedTextCtrl

Class in module wx.lib.masked.textctrl

BasicTreeModel

Class in module wx.lib.mvctree

BeginBatch

Method in class wx.grid.Grid

BeginBatch

Method in class wx.lib.shell.PyShellOutput

BeginBusyCursor

Function in package wx

BeginContextHelp

Method in class wx.ContextHelp

BeginDrag

Method in class wx.DragImage

BeginDragBounded

Method in class wx.DragImage

BeginDrawing

Method in class wx.DC

BeginEdit

Method in class wx.grid.GridCellEditor

BeginEdit

Method in class wx.lib.sheet.CCellEditor

BeginUndoAction

Method in class wx.stc.StyledTextCtrl

Bell

Function in package wx

Below

Method in class wx.IndividualLayoutConstraint

BelowScreen

Method in class wx.lib.editor.editor.Editor

Bind

Method in class wx.EvtHandler

Bind

Method in class wx.PyEventBinder

Bind

Method in class wx.lib.floatcanvas.FloatCanvas.DrawObject

BindSpinButton

Method in class wx.lib.masked.timectrl.TimeCtrl

Bitmap

Class in package wx

BitmapBuffer

Class in module wx.lib.colourchooser.canvas

BitmapButton

Class in package wx

BitmapDataObject

Class in package wx

BitmapFromBits

Function in package wx

BitmapFromIcon

Function in package wx

BitmapFromImage

Function in package wx

BitmapFromXPMData

Function in package wx

BitmapShape

Class in package wx.lib.ogl

Blit

Method in class wx.DC

Blit

Method in class wx.lib.colourchooser.canvas.Canvas

BlitPointSize

Method in class wx.DC

BlockToDeviceRect

Method in class wx.grid.Grid

Blue

Method in class wx.Colour

BMPHandler

Class in package wx

BookCtrlBase

Class in package wx

BookCtrlBase_GetClassDefaultAttributes

Function in package wx

BookCtrlBaseEvent

Class in package wx

BookCtrlSizer

Class in package wx

boolean_options

Variable in class distutils.command.clean.clean

boolean_options

Variable in class distutils.command.clean.clean

boolean_options

Variable in class distutils.command.install.install

boolean_options

Variable in class distutils.command.install.install

boolean_options

Variable in class distutils.command.install_data.install_data

boolean_options

Variable in class distutils.command.install_data.install_data

boolean_options

Variable in class distutils.command.install_headers.install_headers

boolean_options

Variable in class distutils.command.install_headers.install_headers

Both

Variable in class wx.DataObject

Both

Variable in class wx.DataObject

Both

Variable in class wx.DataObject

Both

Variable in class wx.DataObject

Both

Variable in class wx.DataObject

Both

Variable in class wx.DataObject

Both

Variable in class wx.DataObject

Both

Variable in class wx.DataObject

Both

Variable in class wx.DataObject

Both

Variable in class wx.DataObject

Both

Variable in class wx.DataObject

Both

Variable in class wx.DataObject

Both

Variable in class wx.DataObject

Both

Variable in class wx.DataObject

Both

Variable in class wx.DataObject

Both

Variable in class wx.DataObject

Both

Variable in class wx.DataObject

Both

Variable in class wx.DataObject

Both

Variable in class wx.DataObject

Both

Variable in class wx.DataObject

Both

Variable in class wx.DataObject

Both

Variable in class wx.DataObject

Both

Variable in class wx.DataObject

Both

Variable in class wx.DataObject

bottom

Variable in module wx._core in class wx.LayoutConstraints

bottom

Variable in module wx._core in class wx.LayoutConstraints in class wx.Rect

boundingBox

Method in class wx.lib.plot.PlotGraphics

boundingBox

Method in class wx.lib.plot.PolyPoints

boundingBox

Method in class wx.lib.wxPlotCanvas.PlotGraphics

boundingBox

Method in class wx.lib.wxPlotCanvas.PolyPoints

BoundMethodWeakref

Class in module wx.py.dispatcher

BoxSizer

Class in package wx

boxToExtent

Function in module wx.lib.mixins.rubberband

bpp

Function in module wx.lib.mixins.rubberband in class wx.VideoMode

BraceBadLight

Method in class wx.stc.StyledTextCtrl

BraceHighlight

Method in class wx.stc.StyledTextCtrl

BraceMatch

Method in class wx.stc.StyledTextCtrl

Break

Method in class wx.Menu

BreakLine

Method in class wx.lib.editor.editor.Editor

Brush

Class in package wx

BrushFromBitmap

Function in package wx

BrushList

Class in package wx

BrushList

Variable in class wx.lib.floatcanvas.FloatCanvas.DrawObject

BrushList

Variable in class wx.lib.floatcanvas.FloatCanvas.DrawObject

BrushList

Variable in class wx.lib.floatcanvas.FloatCanvas.DrawObject

BrushList

Variable in class wx.lib.floatcanvas.FloatCanvas.DrawObject

BrushList

Variable in class wx.lib.floatcanvas.FloatCanvas.DrawObject

BrushList

Variable in class wx.lib.floatcanvas.FloatCanvas.DrawObject

BrushList

Variable in class wx.lib.floatcanvas.FloatCanvas.DrawObject

BrushList

Variable in class wx.lib.floatcanvas.FloatCanvas.DrawObject

BrushList

Variable in class wx.lib.floatcanvas.FloatCanvas.DrawObject

BrushList

Variable in class wx.lib.floatcanvas.FloatCanvas.DrawObject

BrushList

Variable in class wx.lib.floatcanvas.FloatCanvas.DrawObject

BrushList

Variable in class wx.lib.floatcanvas.FloatCanvas.DrawObject

buffer

Module in package wx.py

Buffer

Class in module wx.py.buffer

bufferClose

Method in class wx.py.editor.EditorFrame

bufferCreate

Method in class wx.py.editor.EditorFrame

bufferCreate

Method in class wx.py.editor.EditorNotebookFrame

bufferCreate

Method in class wx.py.editor.EditorShellNotebookFrame

bufferDestroy

Method in class wx.py.editor.EditorFrame

bufferDestroy

Method in class wx.py.editor.EditorNotebookFrame

bufferDestroy

Method in class wx.py.editor.EditorShellNotebookFrame

BufferedDC

Class in package wx

BufferedPaintDC

Class in package wx

bufferHasChanged

Method in class wx.py.editor.EditorFrame

bufferNew

Method in class wx.py.editor.EditorFrame

bufferNew

Method in class wx.py.editor.EditorNotebookFrame

bufferNew

Method in class wx.py.editor.EditorShellNotebookFrame

bufferOpen

Method in class wx.py.editor.EditorFrame

bufferOpen

Method in class wx.py.editor.EditorNotebookFrame

bufferOpen

Method in class wx.py.editor.EditorShellNotebookFrame

bufferSave

Method in class wx.py.editor.EditorFrame

bufferSaveAs

Method in class wx.py.editor.EditorFrame

bufferSuggestSave

Method in class wx.py.editor.EditorFrame

BufferWasTouched

Method in class wx.lib.editor.editor.Editor

Build

Method in class wx.animate.AnimationPlayer

build

Package in package wx

BuildToolbar

Method in class wx.lib.floatcanvas.NavCanvas.NavCanvas

BuildWindowMenu

Method in class wx.lib.pydocview.WindowMenuService

BusCalDays

Variable in module wx.lib.calendar

BusyCursor

Class in package wx

BusyInfo

Class in package wx

Button

Class in package wx

Button

Method in class wx.MouseEvent

Button_GetClassDefaultAttributes

Function in package wx

Button_GetDefaultSize

Function in package wx

ButtonDClick

Method in class wx.MouseEvent

ButtonDown

Method in class wx.JoystickEvent

ButtonDown

Method in class wx.MouseEvent

ButtonIsDown

Method in class wx.JoystickEvent

ButtonIsDown

Method in class wx.MouseEvent

buttons

Module in package wx.lib

ButtonUp

Method in class wx.JoystickEvent

ButtonUp

Method in class wx.MouseEvent

CacheBestSize

Method in class wx.Window

CalcArrowPoints

Method in class wx.lib.floatcanvas.FloatCanvas.Arrow

CalcBoundingBox

Method in class wx.DC

CalcBoundingBox

Method in class wx.lib.floatcanvas.FloatCanvas.PointsObjectMixin

CalcBoundingBox

Method in class wx.lib.floatcanvas.FloatCanvas.RectEllipse

CalcBoundingBox

Method in class wx.lib.floatcanvas.FloatCanvas.ScaledText

CalcBoundingBox

Method in class wx.lib.floatcanvas.FloatCanvas.XYObjectMixin

CalcBoundingBoxPoint

Method in class wx.DC

CalcMaxLineLen

Method in class wx.lib.editor.editor.Editor

CalcMin

Method in class wx.BookCtrlSizer

CalcMin

Method in class wx.NotebookSizer

CalcMin

Method in class wx.Sizer

CalcMin

Method in class wx.SizerItem

CalcMin

Method in class wx.lib.grids.PyFlexGridSizer

CalcMin

Method in class wx.lib.grids.PyGridSizer

CalcMin

Method in class wx.lib.rcsizer.RowColSizer

CalcScrolledPosition

Method in class wx.ScrolledWindow

CalcScrollInc

Method in class wx.ScrolledWindow

CalcSimpleAttachment

Method in class wx.lib.ogl.Shape

CalcSize

Method in class wx.lib.multisash.MultiClient

CalcSizeFromPage

Method in class wx.BookCtrlBase

CalcSizeFromPage

Method in class wx.Notebook

CalcSizePos

Method in class wx.lib.multisash.MultiCloser

CalcSizePos

Method in class wx.lib.multisash.MultiCreator

CalcSizePos

Method in class wx.lib.multisash.MultiSizer

CalculateBoundingBox

Method in class wx.lib.ogl.PolygonShape

CalculateIdFromPaperSize

Method in class wx.PageSetupDialogData

CalculateLayoutEvent

Class in package wx

CalculateNewSize

Method in class wx.lib.ogl.PolygonControlPoint

CalculatePaperSizeFromId

Method in class wx.PageSetupDialogData

CalculatePolygonCentre

Method in class wx.lib.ogl.PolygonShape

CalculateSize

Method in class wx.lib.ogl.CompositeShape

CalculateSize

Method in class wx.lib.ogl.DivisionShape

CalculateSize

Method in class wx.lib.ogl.DrawnShape

CalculateSize

Method in class wx.lib.ogl.PseudoMetaFile

CalcUnscrolledPosition

Method in class wx.ScrolledWindow

CalDays

Variable in module wx.lib.calendar

CalDraw

Class in module wx.lib.calendar

calendar

Module in package wx

calendar

Module in package wx.lib

Calendar

Class in module wx.lib.calendar

CalendarCtrl

Class in module wx.calendar

CalendarCtrl_GetClassDefaultAttributes

Function in module wx.calendar

CalendarDateAttr

Class in module wx.calendar

CalendarEvent

Class in module wx.calendar

CalenDlg

Class in module wx.lib.calendar

CallAfter

Function in package wx

Calltip

Class in module wx.py.crust

CallTipActive

Method in class wx.stc.StyledTextCtrl

CallTipCancel

Method in class wx.stc.StyledTextCtrl

CallTipPosAtStart

Method in class wx.stc.StyledTextCtrl

CallTipSetBackground

Method in class wx.stc.StyledTextCtrl

CallTipSetForeground

Method in class wx.stc.StyledTextCtrl

CallTipSetForegroundHighlight

Method in class wx.stc.StyledTextCtrl

CallTipSetHighlight

Method in class wx.stc.StyledTextCtrl

CallTipShow

Method in class wx.stc.StyledTextCtrl

CanBeToggled

Method in class wx.ToolBarToolBase

Cancel

Method in class wx.stc.StyledTextCtrl

CanConvert

Method in class wx.EncodingConverter

CanCopy

Method in class wx.ComboBox

CanCopy

Method in class wx.TextCtrl

CanCopy

Method in class wx.py.editwindow.EditWindow

CanCut

Method in class wx.ComboBox

CanCut

Method in class wx.TextCtrl

CanCut

Method in class wx.py.editwindow.EditWindow

CanCut

Method in class wx.py.shell.Shell

CanDragCell

Method in class wx.grid.Grid

CanDragColSize

Method in class wx.grid.Grid

CanDragGridSize

Method in class wx.grid.Grid

CanDragRowSize

Method in class wx.grid.Grid

CanDrawBitmap

Method in class wx.DC

CanEdit

Method in class wx.lib.mvctree.Editor

CanEdit

Method in class wx.lib.mvctree.FileEditor

CanEdit

Method in class wx.py.editwindow.EditWindow

CanEdit

Method in class wx.py.shell.Shell

CanEnableCellControl

Method in class wx.grid.Grid

CanGetPageSource

Method in class wx.webkit.WebKitCtrl

CanGetTextExtent

Method in class wx.DC

CanGetValueAs

Method in class wx.grid.GridTableBase

CanGoBack

Method in class wx.webkit.WebKitCtrl

CanGoForward

Method in class wx.webkit.WebKitCtrl

CanHandle

Method in class wx.lib.ticker_xrc.wxTickerXmlHandler

CanHaveAttributes

Method in class wx.grid.GridTableBase

CanonicalName

Method in class wx.grid.GridTableBase in class wx.LanguageInfo

CanOpen

Method in class wx.FileSystemHandler

CanOpen

Method in class wx.InternetFSHandler

CanOpen

Method in class wx.MemoryFSHandler

CanOpen

Method in class wx.ZipFSHandler

CanPaste

Method in class wx.ComboBox

CanPaste

Method in class wx.TextCtrl

CanPaste

Method in class wx.py.editwindow.EditWindow

CanPaste

Method in class wx.py.shell.Shell

CanPaste

Method in class wx.stc.StyledTextCtrl

CanRead

Method in class wx.Image

CanRead

Method in class wx.ImageHandler

CanRead

Method in class wx.InputStream

CanReadStream

Method in class wx.Image

CanRedo

Method in class wx.ComboBox

CanRedo

Method in class wx.TextCtrl

CanRedo

Method in class wx.lib.docview.CommandProcessor

CanRedo

Method in class wx.stc.StyledTextCtrl

CanScroll

Method in class wx.lib.editor.editor.Editor

CanSend

Method in class wx.IdleEvent

CanSetValueAs

Method in class wx.grid.GridTableBase

CanSize

Method in class wx.lib.multisash.MultiSplit

CanSize

Method in class wx.lib.multisash.MultiViewLeaf

CanUndo

Method in class wx.ComboBox

CanUndo

Method in class wx.TextCtrl

CanUndo

Method in class wx.lib.docview.Command

CanUndo

Method in class wx.lib.docview.CommandProcessor

CanUndo

Method in class wx.stc.StyledTextCtrl

CanUpdate

Method in class wx.UpdateUIEvent

canvas

Module in package wx.lib.colourchooser

Canvas

Class in module wx.lib.colourchooser.canvas

CanVeto

Method in class wx.CloseEvent

CaptionBar

Class in module wx.lib.foldpanelbar

CAPTIONBAR_FILLED_RECTANGLE

Variable in module wx.lib.foldpanelbar

CAPTIONBAR_GRADIENT_H

Variable in module wx.lib.foldpanelbar

CAPTIONBAR_GRADIENT_V

Variable in module wx.lib.foldpanelbar

CAPTIONBAR_NOSTYLE

Variable in module wx.lib.foldpanelbar

CAPTIONBAR_RECTANGLE

Variable in module wx.lib.foldpanelbar

CAPTIONBAR_SINGLE

Variable in module wx.lib.foldpanelbar

CaptionBarEvent

Class in module wx.lib.foldpanelbar

CaptionBarStyle

Class in module wx.lib.foldpanelbar

CaptionColourUsed

Method in class wx.lib.foldpanelbar.CaptionBarStyle

CaptionFontUsed

Method in class wx.lib.foldpanelbar.CaptionBarStyle

CaptionStyleUsed

Method in class wx.lib.foldpanelbar.CaptionBarStyle

CaptureMouse

Method in class wx.Window

Caret

Class in package wx

Caret_GetBlinkTime

Function in package wx

Caret_SetBlinkTime

Function in package wx

Cascade

Method in class wx.MDIParentFrame

CCellEditor

Class in module wx.lib.sheet

CDate

Module in package wx.lib

CDT

Variable in class wx.DateTime

CDT

Variable in class wx.DateTime

Cell

Variable in class wx.grid.GridCellAttr

CellToRect

Method in class wx.grid.Grid

Center

Method in class wx.Window

Center

Method in class wx.lib.calendar.CalDraw

CenterOnParent

Method in class wx.Window

CenterOnScreen

Method in class wx.Window

CentreText

Function in package wx.lib.ogl

centreX

Function in package wx.lib.ogl in class wx.LayoutConstraints

centreY

Variable in module wx._core in class wx.LayoutConstraints

CEST

Variable in class wx.DateTime

CEST

Variable in class wx.DateTime

CET

Variable in class wx.DateTime

CET

Variable in class wx.DateTime

Chain

Method in class wx.wizard.WizardPageSimple

change_roots

Method in class distutils.command.install.install

ChangeMode

Method in class wx.Display

ChangePathTo

Method in class wx.FileSystem

CharLeft

Method in class wx.stc.StyledTextCtrl

CharLeftExtend

Method in class wx.stc.StyledTextCtrl

CharLeftRectExtend

Method in class wx.stc.StyledTextCtrl

charmonths

Variable in module wx.lib.masked.maskededit

charmonths_dict

Variable in module wx.lib.masked.maskededit

CharRight

Method in class wx.stc.StyledTextCtrl

CharRightExtend

Method in class wx.stc.StyledTextCtrl

CharRightRectExtend

Method in class wx.stc.StyledTextCtrl

CharsetToEncoding

Method in class wx.FontMapper

Check

Method in class wx.CheckListBox

Check

Method in class wx.Menu

Check

Method in class wx.MenuBar

Check

Method in class wx.MenuItem

Check

Method in class wx.UpdateUIEvent

CheckBox

Class in package wx

CheckBox_GetClassDefaultAttributes

Function in package wx

CheckForIntersection

Method in class wx.GridBagSizer

CheckForIntersectionPos

Method in class wx.GridBagSizer

checkInstalled

Function in module wxversion

CheckLineIntersection

Function in package wx.lib.ogl

CheckListBox

Class in package wx

ChildDocTemplate

Class in module wx.lib.pydocview

ChildDocument

Class in module wx.lib.pydocview

ChildFocusEvent

Class in package wx

Choice

Class in package wx

Choice_GetClassDefaultAttributes

Function in package wx

Choicebook

Class in package wx

ChoicebookEvent

Class in package wx

ChooseCaretX

Method in class wx.stc.StyledTextCtrl

chopPath

Method in class wx.lib.pydocview.FilePropertiesService

cHoriz

Method in class wx.lib.editor.editor.Editor

Circle

Class in module wx.lib.floatcanvas.FloatCanvas

CircleShape

Class in package wx.lib.ogl

clean

Class in module distutils.command.clean

CleanUpHandlers

Method in class wx.FileSystem

CleanUpStatics

Method in class wx.html.HtmlPrintout

Clear

Method in class wx.Clipboard

Clear

Method in class wx.DC

Clear

Method in class wx.ItemContainer

Clear

Method in class wx.ListItem

Clear

Method in class wx.Region

Clear

Method in class wx.Sizer

Clear

Method in class wx.TextCtrl

Clear

Method in class wx.VListBox

Clear

Method in class wx.grid.GridTableBase

Clear

Method in class wx.lib.docview.DocManager

Clear

Method in class wx.lib.masked.combobox.BaseMaskedComboBox

Clear

Method in class wx.lib.masked.textctrl.BaseMaskedTextCtrl

Clear

Method in class wx.lib.multisash.MultiSash

Clear

Method in class wx.lib.ogl.Diagram

Clear

Method in class wx.lib.ogl.PseudoMetaFile

Clear

Method in class wx.lib.plot.PlotCanvas

Clear

Method in class wx.lib.sheet.CSheet

Clear

Method in class wx.lib.shell.PyShellInput

clear

Method in class wx.lib.wxPlotCanvas.PlotCanvas

clear

Method in class wx.py.shell.Shell

Clear

Method in class wx.stc.StyledTextCtrl

ClearAll

Method in class wx.ListCtrl

ClearAll

Method in class wx.lib.floatcanvas.FloatCanvas.FloatCanvas

clearAll

Method in class wx.py.editor.Editor

ClearAll

Method in class wx.stc.StyledTextCtrl

ClearArrow

Method in class wx.lib.ogl.LineShape

ClearArrowsAtPosition

Method in class wx.lib.ogl.LineShape

ClearAttachments

Method in class wx.lib.ogl.Shape

ClearAttributes

Method in class wx.ListItem

ClearBackground

Method in class wx.Window

ClearBuffer

Method in class wx.lib.mvctree.Painter

ClearCache

Method in class wx.animate.AnimationPlayer

ClearColumnImage

Method in class wx.ListCtrl

ClearColumnImage

Method in class wx.ListView

clearCommand

Method in class wx.py.shell.Shell

ClearCommands

Method in class wx.lib.docview.CommandProcessor

ClearData

Method in class wx.MimeTypesManager

ClearDocumentStyle

Method in class wx.stc.StyledTextCtrl

ClearDsp

Method in class wx.lib.calendar.Calendar

ClearGrid

Method in class wx.grid.Grid

ClearHandlers

Method in class wx.xrc.XmlResource

ClearOptionsPanels

Method in class wx.lib.pydocview.DocOptionsService

ClearPoints

Method in class wx.lib.ogl.PolygonShape

ClearPrivPos

Method in class wx.html.HtmlSelection

ClearRegions

Method in class wx.lib.ogl.Shape

ClearRegisteredImages

Method in class wx.stc.StyledTextCtrl

ClearSel

Method in class wx.Slider

ClearSelection

Method in class wx.grid.Grid

ClearText

Method in class wx.lib.ogl.Shape

ClearText

Method in class wx.lib.ogl.ShapeRegion

ClearTicks

Method in class wx.Slider

ClearTools

Method in class wx.ToolBarBase

ClearTraceMasks

Method in class wx.Log

ClearValue

Method in class wx.lib.masked.maskededit.MaskedEditMixin

click

Method in class wx.lib.foldmenu.FoldOutMenu

ClickableHtmlWindow

Module in package wx.lib

ClientDC

Class in package wx

ClientDisplayRect

Function in package wx

ClientToScreen

Method in class wx.Window

ClientToScreenXY

Method in class wx.Window

Clipboard

Class in package wx

Clipboard_Get

Function in package wx

ClipboardLocker

Class in package wx

Clone

Method in class wx.CommandEvent

Clone

Method in class wx.Event

Clone

Method in class wx.Validator

Clone

Method in class wx.grid.GridCellAttr

Clone

Method in class wx.grid.GridCellEditor

Clone

Method in class wx.grid.GridCellRenderer

Clone

Method in class wx.lib.intctrl.IntValidator

Clone

Method in class wx.lib.sheet.CCellEditor

Clone

Method in class wx.stc.StyledTextEvent

Close

Method in class wx.Clipboard

close

Method in class wx.InputStream

close

Method in class wx.PyOnDemandOutputWindow

Close

Method in class wx.TipWindow

Close

Method in class wx.Window

Close

Method in class wx.lib.docview.Document

Close

Method in class wx.lib.docview.View

close

Method in class wx.lib.infoframe.Dummy_PyInformationalMessagesFrame

close

Method in class wx.lib.infoframe.PyInformationalMessagesFrame

CloseChildDocuments

Method in class wx.lib.pydocview.DocApp

CloseContainer

Method in class wx.html.HtmlWinParser

CloseDocument

Method in class wx.lib.docview.DocManager

CloseDocuments

Method in class wx.lib.docview.DocManager

CloseEditor

Method in class wx.lib.mixins.listctrl.TextEditMixin

CloseEvent

Class in package wx

CloseFile

Method in class wx.lib.infoframe.PyInformationalMessagesFrame

CloseOutput

Method in class wx.Process

CloseSplash

Method in class wx.lib.pydocview.DocApp

CmdDown

Method in class wx.KeyEvent

CmdDown

Method in class wx.MouseEvent

CmdKeyAssign

Method in class wx.stc.StyledTextCtrl

CmdKeyClear

Method in class wx.stc.StyledTextCtrl

CmdKeyClearAll

Method in class wx.stc.StyledTextCtrl

CmdKeyExecute

Method in class wx.stc.StyledTextCtrl

cmp_d

Variable in class wx.lib.layoutf.Layoutf

col

Variable in class wx.lib.layoutf.Layoutf in class wx.GBPosition

Col

Variable in class wx.grid.GridCellAttr

col_w

Variable in class wx.lib.rcsizer.RowColSizer

colBg

Variable in class wx.lib.rcsizer.RowColSizer in class wx.VisualAttributes

ColDragWindow

Class in module wx.lib.gridmovers

colFg

Class in module wx.lib.gridmovers in class wx.VisualAttributes

Collapse

Method in class wx.TreeCtrl

Collapse

Method in class wx.gizmos.TreeListCtrl

Collapse

Method in class wx.lib.foldpanelbar.CaptionBar

Collapse

Method in class wx.lib.foldpanelbar.FoldPanelBar

Collapse

Method in class wx.lib.foldpanelbar.FoldPanelItem

CollapseAndReset

Method in class wx.TreeCtrl

CollapseAndReset

Method in class wx.gizmos.TreeListCtrl

COLOR_3D_DARK

Variable in module wx.lib.calendar

COLOR_3D_LIGHT

Variable in module wx.lib.calendar

COLOR_BACKGROUND

Variable in module wx.lib.calendar

COLOR_BORDER

Variable in module wx.lib.calendar

COLOR_FONT

Variable in module wx.lib.calendar

COLOR_GRID_LINES

Variable in module wx.lib.calendar

COLOR_HEADER_BACKGROUND

Variable in module wx.lib.calendar

COLOR_HEADER_FONT

Variable in module wx.lib.calendar

COLOR_HIGHLIGHT_BACKGROUND

Variable in module wx.lib.calendar

COLOR_HIGHLIGHT_FONT

Variable in module wx.lib.calendar

COLOR_SELECTION_BACKGROUND

Variable in module wx.lib.calendar

COLOR_SELECTION_FONT

Variable in module wx.lib.calendar

COLOR_WEEKEND_BACKGROUND

Variable in module wx.lib.calendar

COLOR_WEEKEND_FONT

Variable in module wx.lib.calendar

colorDialog

Function in module wx.lib.dialogs

ColorOnlyMixin

Class in module wx.lib.floatcanvas.FloatCanvas

Colour

Class in package wx

colour_names

Variable in class wx.lib.colourchooser.pycolourchooser.PyColourChooser

colourchooser

Package in package wx.lib

ColourData

Class in package wx

ColourDatabase

Class in package wx

colourdb

Module in package wx.lib

ColourDialog

Class in package wx

colourDialog

Function in module wx.lib.dialogs

ColourDisplay

Function in package wx

Colourise

Method in class wx.stc.StyledTextCtrl

ColourRGB

Function in package wx

ColourRowCells

Method in class wx.lib.printout.PrintTableDraw

colourselect

Module in package wx.lib

ColourSelect

Class in module wx.lib.colourselect

ColourSelectEvent

Class in module wx.lib.colourselect

colspan

Class in module wx.lib.colourselect in class wx.GBSpan

ColumnSorterMixin

Class in module wx.lib.mixins.listctrl

Combine

Method in class wx.TextAttr

COMBO

Variable in module wx.lib.masked.ctrl

COMBO

Variable in class wx.lib.masked.ctrl.controlTypes

ComboBox

Class in package wx

combobox

Module in package wx.lib.masked

ComboBox

Class in module wx.lib.masked.combobox

ComboBox_GetClassDefaultAttributes

Function in package wx

Command

Class in module distutils.cmd

Command

Method in class wx.Control

Command

Class in module wx.lib.docview

CommandEvent

Class in package wx

CommandProcessor

Class in module wx.lib.docview

COMMONTYPES

Variable in module wx.py.filling

CompareVersion

Method in class wx.xrc.XmlResource

CompositeShape

Class in package wx.lib.ogl

ComputeHistogram

Method in class wx.Image

ComputeScaleAndOrigin

Method in class wx.DC

Config

Class in package wx

ConfigBase

Class in package wx

ConfigBase_Create

Function in package wx

ConfigBase_DontCreateOnDemand

Function in package wx

ConfigBase_Get

Function in package wx

ConfigBase_Set

Function in package wx

ConfigPathChanger

Class in package wx

Connect

Method in class wx.EvtHandler

Connect

Method in class wx.lib.evtmgr.FakeWindow

connect

Function in module wx.py.dispatcher

connections

Variable in module wx.py.dispatcher

Constrain

Method in class wx.lib.ogl.CompositeShape

Constraint

Class in package wx.lib.ogl

ConstraintType

Class in package wx.lib.ogl

Contains

Method in class wx.Region

Contains

Method in class wx.lib.mvctree.Rect

ContainsDivision

Method in class wx.lib.ogl.CompositeShape

ContainsPoint

Method in class wx.Region

ContainsRect

Method in class wx.Region

ContainsRectDim

Method in class wx.Region

ContextHelp

Class in package wx

ContextHelpButton

Class in package wx

ContextMenuEvent

Class in package wx

Control

Class in package wx

control

Variable in module wx.lib.masked.maskededit

Control_GetClassDefaultAttributes

Function in package wx

ControlDown

Method in class wx.KeyEvent

ControlDown

Method in class wx.MouseEvent

ControlDown

Method in class wx.grid.GridEvent

ControlDown

Method in class wx.grid.GridRangeSelectEvent

ControlDown

Method in class wx.grid.GridSizeEvent

ControlKey

Method in class wx.lib.editor.editor.Editor

ControlPoint

Class in package wx.lib.ogl

controlTypes

Class in module wx.lib.masked.ctrl

ControlWithItems

Class in package wx

Convert

Method in class wx.EncodingConverter

Convert

Method in class wx.lib.mvctree.StrTextConverter

Convert

Method in class wx.lib.mvctree.TextConverter

convert

Function in module wx.tools.img2img

convert_paths

Method in class distutils.command.install.install

ConvertAlphaToMask

Method in class wx.Image

ConvertBMP

Function in module wx.lib.imagebrowser

ConvertColourToAlpha

Method in class wx.Image

ConvertDialogPointToPixels

Method in class wx.Window

ConvertDialogSizeToPixels

Method in class wx.Window

ConvertEOLs

Method in class wx.stc.StyledTextCtrl

ConvertPixelPointToDialog

Method in class wx.Window

ConvertPixelSizeToDialog

Method in class wx.Window

ConvertToBitmap

Method in class wx.Image

ConvertToBitmap

Method in class wx.Region

ConvertToImage

Method in class wx.Bitmap

ConvertToMono

Method in class wx.Image

ConvertToMonoBitmap

Method in class wx.Image

ConvertToText

Method in class wx.html.HtmlCell

ConvertYearToBC

Method in class wx.DateTime

Copy

Method in class wx.ComboBox

Copy

Method in class wx.Image

Copy

Method in class wx.TextCtrl

Copy

Method in class wx.lib.sheet.CSheet

Copy

Method in class wx.py.shell.Shell

Copy

Method in class wx.stc.StyledTextCtrl

copy_file

Method in class distutils.cmd.Command

copy_tree

Method in class distutils.cmd.Command

CopyFromBitmap

Method in class wx.Icon

CopyFromIcon

Method in class wx.Bitmap

CopyRange

Method in class wx.stc.StyledTextCtrl

CopySelection

Method in class wx.lib.editor.editor.Editor

CopyText

Method in class wx.stc.StyledTextCtrl

CopyToClipboard

Method in class wx.lib.editor.editor.Editor

CopyWithPrompts

Method in class wx.py.shell.Shell

CopyWithPromptsPrefixed

Method in class wx.py.shell.Shell

CountColours

Method in class wx.Image

Country_Default

Variable in class wx.DateTime

Country_Default

Variable in class wx.DateTime

Country_EEC

Variable in class wx.DateTime

Country_EEC

Variable in class wx.DateTime

Country_Unknown

Variable in class wx.DateTime

Country_Unknown

Variable in class wx.DateTime

Country_WesternEurope_End

Variable in class wx.DateTime

Country_WesternEurope_End

Variable in class wx.DateTime

Country_WesternEurope_Start

Variable in class wx.DateTime

Country_WesternEurope_Start

Variable in class wx.DateTime

CPPFileSystemHandler

Class in package wx

CR_SIZE

Variable in module wx.lib.multisash

Create

Method in class wx.BitmapButton

Create

Method in class wx.Button

Create

Method in class wx.CheckBox

Create

Method in class wx.CheckListBox

Create

Method in class wx.Choice

Create

Method in class wx.Choicebook

Create

Method in class wx.ComboBox

Create

Method in class wx.ConfigBase

Create

Method in class wx.Control

Create

Method in class wx.DatePickerCtrl

Create

Method in class wx.Dialog

Create

Method in class wx.DirFilterListCtrl

Create

Method in class wx.FindReplaceDialog

Create

Method in class wx.Frame

Create

Method in class wx.Gauge

Create

Method in class wx.GenericDirCtrl

Create

Method in class wx.HtmlListBox

Create

Method in class wx.Image

Create

Method in class wx.ListBox

Create

Method in class wx.ListCtrl

Create

Method in class wx.ListView

Create

Method in class wx.Listbook

Create

Method in class wx.MDIChildFrame

Create

Method in class wx.MDIClientWindow

Create

Method in class wx.MDIParentFrame

Create

Method in class wx.MiniFrame

Create

Method in class wx.Notebook

Create

Method in class wx.Panel

Create

Method in class wx.PopupWindow

Create

Method in class wx.RadioBox

Create

Method in class wx.RadioButton

Create

Method in class wx.SashLayoutWindow

Create

Method in class wx.SashWindow

Create

Method in class wx.ScrollBar

Create

Method in class wx.ScrolledWindow

Create

Method in class wx.SingleInstanceChecker

Create

Method in class wx.Slider

Create

Method in class wx.Sound

Create

Method in class wx.SpinButton

Create

Method in class wx.SpinCtrl

Create

Method in class wx.SplitterWindow

Create

Method in class wx.StaticBitmap

Create

Method in class wx.StaticBox

Create

Method in class wx.StaticLine

Create

Method in class wx.StaticText

Create

Method in class wx.StatusBar

Create

Method in class wx.TextCtrl

Create

Method in class wx.ToggleButton

Create

Method in class wx.ToolBar

Create

Method in class wx.TreeCtrl

Create

Method in class wx.VListBox

Create

Method in class wx.VScrolledWindow

Create

Method in class wx.Window

Create

Method in class wx.animate.GIFAnimationCtrl

Create

Method in class wx.calendar.CalendarCtrl

Create

Method in class wx.gizmos.DynamicSashWindow

Create

Method in class wx.gizmos.LEDNumberCtrl

Create

Method in class wx.gizmos.StaticPicture

Create

Method in class wx.gizmos.TreeListCtrl

Create

Method in class wx.grid.Grid

Create

Method in class wx.grid.GridCellEditor

Create

Method in class wx.html.HtmlWindow

Create

Method in class wx.lib.ogl.PolygonShape

Create

Method in class wx.lib.sheet.CCellEditor

Create

Method in class wx.media.MediaCtrl

Create

Method in class wx.stc.StyledTextCtrl

Create

Method in class wx.webkit.WebKitCtrl

Create

Method in class wx.wizard.PyWizardPage

Create

Method in class wx.wizard.Wizard

Create

Method in class wx.wizard.WizardPage

Create

Method in class wx.wizard.WizardPageSimple

Create

Method in class wx.xrc.XmlSubclassFactory_Python

create_path_file

Method in class distutils.command.install.install

CreateAbortWindow

Method in class wx.Printer

createBrowseButton

Method in class wx.lib.filebrowsebutton.FileBrowseButton

CreateButtonSizer

Method in class wx.Dialog

CreateCanvas

Method in class wx.PreviewFrame

CreateChildDocument

Method in class wx.lib.pydocview.DocApp

CreateChildren

Method in class wx.xrc.XmlResourceHandler

CreateChildrenPrivately

Method in class wx.xrc.XmlResourceHandler

CreateControlBar

Method in class wx.PreviewFrame

CreateCurrentFont

Method in class wx.html.HtmlWinParser

CreateDefaultMenuBar

Method in class wx.lib.pydocview.DocFrameMixIn

CreateDefaultPalette

Method in class wx.glcanvas.GLContext

CreateDefaultStatusBar

Method in class wx.lib.pydocview.DocFrameMixIn

CreateDefaultToolBar

Method in class wx.lib.pydocview.DocFrameMixIn

createDialog

Method in class wx.lib.filebrowsebutton.FileBrowseButton

CreateDocument

Method in class wx.lib.docview.DocManager

CreateDocument

Method in class wx.lib.docview.DocTemplate

CreateDocument

Method in class wx.lib.pydocview.ChildDocTemplate

CreateDocument

Method in class wx.stc.StyledTextCtrl

CreateDocumentFrame

Method in class wx.lib.pydocview.DocApp

CreateEmbeddedWindows

Method in class wx.lib.pydocview.DocMDIParentFrameMixIn

CreateFileTipProvider

Function in package wx

CreateFromData

Method in class wx.Sound

CreateGrid

Method in class wx.grid.Grid

createLabel

Method in class wx.lib.filebrowsebutton.FileBrowseButton

CreateMDIDocumentFrame

Method in class wx.lib.pydocview.DocApp

CreateNotebook

Method in class wx.lib.pydocview.DocTabbedParentFrame

CreateOutputWindow

Method in class wx.PyOnDemandOutputWindow

CreateResFromNode

Method in class wx.xrc.XmlResourceHandler

CreateResource

Method in class wx.xrc.XmlResourceHandler

CreateSDIDocumentFrame

Method in class wx.lib.pydocview.DocApp

CreateStatusBar

Method in class wx.Frame

CreateStdDialogButtonSizer

Method in class wx.Dialog

CreateTabbedDocumentFrame

Method in class wx.lib.pydocview.DocApp

createTextControl

Method in class wx.lib.filebrowsebutton.FileBrowseButton

createTextControl

Method in class wx.lib.filebrowsebutton.FileBrowseButtonWithHistory

CreateTextSizer

Method in class wx.Dialog

CreateToolBar

Method in class wx.Frame

CreateView

Method in class wx.lib.docview.DocManager

CreateView

Method in class wx.lib.docview.DocTemplate

CrossHair

Method in class wx.DC

CrossHairPoint

Method in class wx.DC

crunch_data

Function in module wx.tools.img2py

crust

Module in package wx.py

Crust

Class in module wx.py.crust

CrustFrame

Class in module wx.py.crust

CSheet

Class in module wx.lib.sheet

CST

Variable in class wx.DateTime

CST

Variable in class wx.DateTime

CTextCellEditor

Class in module wx.lib.sheet

ctrl

Module in package wx.lib.masked

Ctrl

Function in module wx.lib.masked.ctrl

CURHandler

Class in package wx

CurrentLineLength

Method in class wx.lib.editor.editor.Editor

Cursor

Class in package wx

CursorFromImage

Function in package wx

custom_colours

Variable in class wx.lib.colourchooser.pycolourchooser.PyColourChooser

CustomDataFormat

Function in package wx

CustomDataObject

Class in package wx

Cut

Method in class wx.ComboBox

Cut

Method in class wx.TextCtrl

Cut

Method in class wx.lib.intctrl.IntCtrl

Cut

Method in class wx.lib.masked.combobox.BaseMaskedComboBox

Cut

Method in class wx.lib.masked.textctrl.BaseMaskedTextCtrl

Cut

Method in class wx.py.shell.Shell

Cut

Method in class wx.stc.StyledTextCtrl

cVert

Method in class wx.lib.editor.editor.Editor

DataFormat

Class in package wx

DataObject

Class in package wx

DataObjectComposite

Class in package wx

DataObjectSimple

Class in package wx

Date

Class in module wx.lib.CDate

DateEvent

Class in package wx

DatePickerCtrl

Class in package wx

DateSpan

Class in package wx

DateSpan_Day

Function in package wx

DateSpan_Days

Function in package wx

DateSpan_Month

Function in package wx

DateSpan_Months

Function in package wx

DateSpan_Week

Function in package wx

DateSpan_Weeks

Function in package wx

DateSpan_Year

Function in package wx

DateSpan_Years

Function in package wx

DateTime

Class in package wx

DateTime_ConvertYearToBC

Function in package wx

DateTime_GetAmPmStrings

Function in package wx

DateTime_GetBeginDST

Function in package wx

DateTime_GetCentury

Function in package wx

DateTime_GetCountry

Function in package wx

DateTime_GetCurrentMonth

Function in package wx

DateTime_GetCurrentYear

Function in package wx

DateTime_GetEndDST

Function in package wx

DateTime_GetMonthName

Function in package wx

DateTime_GetNumberOfDaysInMonth

Function in package wx

DateTime_GetNumberOfDaysinYear

Function in package wx

DateTime_GetWeekDayName

Function in package wx

DateTime_IsDSTApplicable

Function in package wx

DateTime_IsLeapYear

Function in package wx

DateTime_IsWestEuropeanCountry

Function in package wx

DateTime_Now

Function in package wx

DateTime_SetCountry

Function in package wx

DateTime_SetToWeekOfYear

Function in package wx

DateTime_Today

Function in package wx

DateTime_UNow

Function in package wx

DateTimeFromDMY

Function in package wx

DateTimeFromHMS

Function in package wx

DateTimeFromJDN

Function in package wx

DateTimeFromTimeT

Function in package wx

Day

Method in class wx.DateSpan

Day

Method in class wx.TimeSpan

day_abbr

Variable in module wx.lib.CDate

day_name

Variable in module wx.lib.CDate

dayOfWeek

Function in module wx.lib.CDate

Days

Method in class wx.DateSpan

Days

Method in class wx.TimeSpan

days

Variable in module wx.lib.masked.maskededit

daysPerMonth

Function in module wx.lib.CDate

dbg

Variable in module wx.lib.masked.numctrl

dbg

Variable in module wx.lib.masked.timectrl

dbg

Module in package wx.tools

DC

Class in package wx

debug_pack

Method in class wx.lib.layoutf.Layoutf

debug_print

Method in class distutils.cmd.Command

Dec

Variable in class wx.DateTime

Dec

Variable in class wx.DateTime

DecMonth

Method in class wx.lib.calendar.Calendar

DecRef

Method in class wx.grid.GridCellAttr

DecRef

Method in class wx.grid.GridCellEditor

DecRef

Method in class wx.grid.GridCellRenderer

DecTo

Method in class wx.Size

DecYear

Method in class wx.lib.calendar.Calendar

Default

Variable in class wx.grid.GridCellAttr

DEFAULT_DOCMAN_FLAGS

Variable in module wx.lib.docview

Default_First

Variable in class wx.DateTime

Default_First

Variable in class wx.DateTime

DEFAULT_TEMPLATE_FLAGS

Variable in module wx.lib.docview

DefaultChildChanged

Method in class wx.lib.multisash.MultiSplit

DefaultChildChanged

Method in class wx.lib.multisash.MultiViewLeaf

DefaultColors

Function in module wx.lib.calendar

DefaultHtmlRenderingStyle

Class in module wx.html

DEFAULTICONSIZE

Variable in class wx.lib.mixins.imagelist.MagicImageList

Deflate

Method in class wx.Rect

DefParms

Method in class wx.lib.calendar.CalDraw

Delete

Method in class wx.ItemContainer

Delete

Method in class wx.Menu

Delete

Method in class wx.TreeCtrl

Delete

Method in class wx.gizmos.TreeListCtrl

Delete

Method in class wx.lib.editor.editor.Editor

Delete

Method in class wx.lib.ogl.Shape

DeleteAll

Method in class wx.ConfigBase

DeleteAllColumns

Method in class wx.ListCtrl

DeleteAllItems

Method in class wx.ListCtrl

DeleteAllItems

Method in class wx.TreeCtrl

DeleteAllItems

Method in class wx.gizmos.TreeListCtrl

DeleteAllPages

Method in class wx.BookCtrlBase

DeleteAllPages

Method in class wx.Choicebook

DeleteAllShapes

Method in class wx.lib.ogl.Diagram

DeleteAllViews

Method in class wx.lib.docview.Document

DeleteArrowHead

Method in class wx.lib.ogl.LineShape

DeleteArrowHeadId

Method in class wx.lib.ogl.LineShape

DeleteBack

Method in class wx.stc.StyledTextCtrl

DeleteBackNotLine

Method in class wx.stc.StyledTextCtrl

DeleteChar

Method in class wx.lib.editor.editor.Editor

DeleteChildren

Method in class wx.TreeCtrl

DeleteChildren

Method in class wx.gizmos.TreeListCtrl

DeleteCols

Method in class wx.grid.Grid

DeleteCols

Method in class wx.grid.GridTableBase

DeleteColumn

Method in class wx.ListCtrl

DeleteConstraint

Method in class wx.lib.ogl.CompositeShape

DeleteConstraintsInvolvingChild

Method in class wx.lib.ogl.CompositeShape

DeleteContents

Method in class wx.lib.docview.Document

DeleteControlPoints

Method in class wx.lib.ogl.Shape

DeleteEntry

Method in class wx.ConfigBase

DeleteGroup

Method in class wx.ConfigBase

DeleteItem

Method in class wx.ListCtrl

DeleteItem

Method in class wx.Menu

DeleteLineControlPoint

Method in class wx.lib.ogl.LineShape

DeletePage

Method in class wx.BookCtrlBase

DeletePolygonPoint

Method in class wx.lib.ogl.PolygonShape

DeleteProperty

Method in class wx.xrc.XmlNode

DeleteRows

Method in class wx.grid.Grid

DeleteRows

Method in class wx.grid.GridTableBase

DeleteTemplate

Method in class wx.lib.docview.DocManager

DeleteTool

Method in class wx.ToolBarBase

DeleteToolByPos

Method in class wx.ToolBarBase

DeleteWindows

Method in class wx.Sizer

DeleteWindows

Method in class wx.SizerItem

deliverEvent

Method in class wx.lib.evtmgr.MessageAdapter

DelLineLeft

Method in class wx.stc.StyledTextCtrl

DelLineRight

Method in class wx.stc.StyledTextCtrl

DelWordLeft

Method in class wx.stc.StyledTextCtrl

DelWordRight

Method in class wx.stc.StyledTextCtrl

deprecatedWrapper

Method in class wx.BookCtrlSizer

deprecatedWrapper

Method in class wx.Colour

deprecatedWrapper

Method in class wx.DC

deprecatedWrapper

Method in class wx.DC

deprecatedWrapper

Method in class wx.DateTime

deprecatedWrapper

Method in class wx.DateTime

deprecatedWrapper

Method in class wx.GBPosition

deprecatedWrapper

Method in class wx.GBSpan

deprecatedWrapper

Method in class wx.NotebookSizer

deprecatedWrapper

Method in class wx.Point

deprecatedWrapper

Method in class wx.Point2D

deprecatedWrapper

Method in class wx.RealPoint

deprecatedWrapper

Method in class wx.Rect

deprecatedWrapper

Method in class wx.Size

deprecatedWrapper

Method in class wx.SizerItem

deprecatedWrapper

Method in class wx.SizerItem

deprecatedWrapper

Function in package wx

deprecatedWrapper

Function in package wx

deprecatedWrapper

Method in class wx.grid.GridCellCoords

deprecatedWrapper

Function in package wx.lib.ogl

DeregisterDeadTopics

Method in class wx.lib.evtmgr.EventManager

DeregisterListener

Method in class wx.lib.evtmgr.EventManager

DeregisterWindow

Method in class wx.lib.evtmgr.EventManager

description

Variable in class distutils.command.clean.clean

description

Variable in class distutils.command.clean.clean

description

Variable in class distutils.command.install.install

description

Variable in class distutils.command.install.install

description

Variable in class distutils.command.install_data.install_data

description

Variable in class distutils.command.install_data.install_data

description

Variable in class distutils.command.install_headers.install_headers

description

Variable in class distutils.command.install_headers.install_headers

Description

Variable in class distutils.command.install_headers.install_headers in class wx.LanguageInfo

Deselect

Method in class wx.ListBox

DeselectAll

Method in class wx.ListBox

DeselectAll

Method in class wx.VListBox

DeselectCell

Method in class wx.grid.Grid

DeselectCol

Method in class wx.grid.Grid

DeselectRow

Method in class wx.grid.Grid

Destroy

Method in class wx.App

Destroy

Method in class wx.ArtProvider

Destroy

Method in class wx.Caret

Destroy

Method in class wx.HelpProvider

Destroy

Method in class wx.Image

Destroy

Method in class wx.ListItemAttr

Destroy

Method in class wx.Log

Destroy

Method in class wx.Menu

Destroy

Method in class wx.Object

Destroy

Method in class wx.TaskBarIcon

Destroy

Method in class wx.Timer

Destroy

Method in class wx.TreeItemData

Destroy

Method in class wx.Window

Destroy

Method in class wx.grid.GridCellEditor

Destroy

Method in class wx.grid.PyGridTableBase

Destroy

Method in class wx.lib.docview.DocManager

Destroy

Method in class wx.lib.docview.Document

Destroy

Method in class wx.lib.docview.View

Destroy

Method in class wx.lib.evtmgr.EventAdapter

Destroy

Method in class wx.lib.evtmgr.MessageAdapter

Destroy

Method in class wx.lib.pydocview.DocTabbedChildFrame

Destroy

Method in class wx.lib.sheet.CCellEditor

destroy

Method in class wx.py.editor.Editor

destroy

Method in class wx.py.shell.Shell

DestroyChildren

Method in class wx.Window

DestroyClippingRect

Method in class wx.lib.ogl.DrawnShape

DestroyClippingRect

Method in class wx.lib.ogl.PseudoMetaFile

DestroyClippingRegion

Method in class wx.DC

DestroyId

Method in class wx.Menu

DestroyItem

Method in class wx.Menu

DestroyLeaf

Method in class wx.lib.multisash.MultiSplit

DestroyLeaf

Method in class wx.lib.multisash.MultiViewLeaf

Detach

Method in class wx.Menu

Detach

Method in class wx.MenuBar

Detach

Method in class wx.Process

Detach

Method in class wx.Sizer

Detach

Method in class wx.ToolBarToolBase

Detach

Method in class wx.lib.ogl.Shape

DetachSizer

Method in class wx.SizerItem

DetermineMetaFile

Method in class wx.lib.ogl.DrawnShape

DetermineScaling

Method in class wx.PrintPreview

DeviceToLogicalX

Method in class wx.DC

DeviceToLogicalXRel

Method in class wx.DC

DeviceToLogicalY

Method in class wx.DC

DeviceToLogicalYRel

Method in class wx.DC

Diagram

Class in package wx.lib.ogl

Dialog

Class in package wx

Dialog_GetClassDefaultAttributes

Function in package wx

DialogResults

Class in module wx.lib.dialogs

DialogResults

Class in module wx.py.editor

dialogs

Module in package wx.lib

dir_path

Variable in module wx.lib.imagebrowser

DirBrowseButton

Class in module wx.lib.filebrowsebutton

DirDialog

Class in package wx

dirDialog

Function in module wx.lib.dialogs

directory

Function in module wx.py.editor

DirFilterListCtrl

Class in package wx

DirSelector

Function in package wx

Disable

Method in class wx.Window

DisableCellEditControl

Method in class wx.grid.Grid

DisableDragCell

Method in class wx.grid.Grid

DisableDragColSize

Method in class wx.grid.Grid

DisableDragGridSize

Method in class wx.grid.Grid

DisableDragRowSize

Method in class wx.grid.Grid

DisableOutput

Method in class wx.lib.infoframe.Dummy_PyInformationalMessagesFrame

DisableOutput

Method in class wx.lib.infoframe.PyInformationalMessagesFrame

DisassociateTemplate

Method in class wx.lib.docview.DocManager

DiscardEdits

Method in class wx.TextCtrl

Disconnect

Method in class wx.EvtHandler

disconnect

Method in class wx.lib.evtmgr.EventAdapter

disconnect

Function in module wx.py.dispatcher

Dismiss

Method in class wx.PopupTransientWindow

Dispatch

Method in class wx.EventLoop

Dispatch

Method in class wx.PyApp

Dispatch

Method in class wx.lib.editor.editor.Editor

dispatcher

Module in package wx.py

DispatcherError

Class in module wx.py.dispatcher

DispatcherListing

Class in module wx.py.crust

Display

Class in package wx

Display

Method in class wx.html.HtmlHelpController

Display

Method in class wx.html.HtmlHelpFrame

Display

Method in class wx.lib.popupctl.PopupDialog

display

Method in class wx.py.crust.Calltip

Display

Class in module wx.py.crust

display

Method in class wx.py.filling.FillingTree

Display_GetCount

Function in package wx

Display_GetFromPoint

Function in package wx

Display_GetFromWindow

Function in package wx

DisplayAt

Method in class wx.lib.gridmovers.ColDragWindow

DisplayAt

Method in class wx.lib.gridmovers.RowDragWindow

DisplayChangedEvent

Class in package wx

DisplayContents

Method in class wx.html.HtmlHelpController

DisplayContents

Method in class wx.html.HtmlHelpFrame

DisplayDepth

Function in package wx

DisplayDir

Method in class wx.lib.imagebrowser.ImageDialog

DisplayError

Method in class wx.lib.hyperlink.HyperLinkCtrl

DisplayID

Method in class wx.html.HtmlHelpController

DisplayID

Method in class wx.html.HtmlHelpFrame

DisplayIndex

Method in class wx.html.HtmlHelpController

DisplayIndex

Method in class wx.html.HtmlHelpFrame

DisplaySize

Function in package wx

DisplaySizeMM

Function in package wx

DissociateHandle

Method in class wx.Window

Divide

Method in class wx.lib.ogl.DivisionShape

DividedShape

Class in package wx.lib.ogl

DividedShapeControlPoint

Class in package wx.lib.ogl

DivisionControlPoint

Class in package wx.lib.ogl

DivisionShape

Class in package wx.lib.ogl

DLG_PNT

Function in package wx

DLG_PNT

Method in class wx.Window

DLG_SZE

Function in package wx

DLG_SZE

Method in class wx.Window

Do

Method in class wx.lib.docview.Command

Do

Method in class wx.lib.ogl.OpDraw

Do

Method in class wx.lib.ogl.OpPolyDraw

Do

Method in class wx.lib.ogl.OpSetClipping

Do

Method in class wx.lib.ogl.OpSetGDI

DoAction

Method in class wx.lib.gestures.MouseGestures

DoAddTool

Method in class wx.ToolBarBase

DoBackgroundListenAndLoad

Method in class wx.lib.pydocview.DocApp

DOC_MDI

Variable in module wx.lib.docview

DOC_NEW

Variable in module wx.lib.docview

DOC_OPEN_ONCE

Variable in module wx.lib.docview

DOC_SDI

Variable in module wx.lib.docview

DOC_SILENT

Variable in module wx.lib.docview

DocApp

Class in module wx.lib.pydocview

DocChildFrame

Class in module wx.lib.docview

DocFrameMixIn

Class in module wx.lib.pydocview

DocLineFromVisible

Method in class wx.stc.StyledTextCtrl

DocManager

Class in module wx.lib.docview

DocMDIChildFrame

Class in module wx.lib.docview

DocMDIChildFrame

Class in module wx.lib.pydocview

DocMDIParentFrame

Class in module wx.lib.docview

DocMDIParentFrame

Class in module wx.lib.pydocview

DocMDIParentFrameMixIn

Class in module wx.lib.pydocview

DocOptionsService

Class in module wx.lib.pydocview

DocParentFrame

Class in module wx.lib.docview

DocPrintout

Class in module wx.lib.docview

DoCreateResource

Method in class wx.lib.ticker_xrc.wxTickerXmlHandler

DocSDIFrame

Class in module wx.lib.pydocview

DocService

Class in module wx.lib.pydocview

DocTabbedChildFrame

Class in module wx.lib.pydocview

DocTabbedParentFrame

Class in module wx.lib.pydocview

DocTemplate

Class in module wx.lib.docview

DOCTYPES

Variable in module wx.py.filling

Document

Class in module wx.lib.docview

document

Module in package wx.py

Document

Class in module wx.py.document

DocumentEnd

Method in class wx.stc.StyledTextCtrl

DocumentEndExtend

Method in class wx.stc.StyledTextCtrl

DocumentStart

Method in class wx.stc.StyledTextCtrl

DocumentStartExtend

Method in class wx.stc.StyledTextCtrl

docview

Module in package wx.lib

DoDragDrop

Method in class wx.DropSource

DoDragOver

Method in class wx.stc.StyledTextCtrl

DoDrawImage

Method in class wx.DragImage

DoDrawing

Method in class wx.lib.calendar.Calendar

DoDrawing

Method in class wx.lib.printout.PrintTable

DoDrawing

Method in class wx.lib.printout.PrintTableDraw

DoDropText

Method in class wx.stc.StyledTextCtrl

DoEraseBackground

Method in class wx.PyControl

DoEraseBackground

Method in class wx.PyPanel

DoEraseBackground

Method in class wx.PyScrolledWindow

DoEraseBackground

Method in class wx.PyWindow

DoGetBestSize

Method in class wx.lib.analogclock.AnalogClockWindow

DoGetBestSize

Method in class wx.lib.buttons.GenButton

DoGetBestSize

Method in class wx.lib.foldpanelbar.CaptionBar

DoGetBestSize

Method in class wx.lib.statbmp.GenStaticBitmap

DoGetBestSize

Method in class wx.lib.stattext.GenStaticText

DoGetBestSize

Method in class wx.lib.throbber.Throbber

DoGetBestSize

Method in class wx.lib.ticker.Ticker

DoGiveHelp

Method in class wx.Frame

DoInsertTool

Method in class wx.ToolBarBase

DoMenuUpdates

Method in class wx.Frame

DoneParser

Method in class wx.html.HtmlParser

DontCreateOnDemand

Method in class wx.ConfigBase

DontCreateOnDemand

Method in class wx.Log

doPaletteClick

Method in class wx.lib.colourchooser.pycolourchooser.PyColourChooser

DoParsing

Method in class wx.html.HtmlParser

DoPopup

Method in class wx.lib.hyperlink.HyperLinkCtrl

DoPrepareDC

Method in class wx.ScrolledWindow

DoRefresh

Method in class wx.lib.pydocview.OptionsDialog

DoResize

Method in class wx.GenericDirCtrl

DragAcceptFiles

Method in class wx.Window

Draggable

Method in class wx.lib.ogl.LineShape

Draggable

Method in class wx.lib.ogl.Shape

Dragging

Method in class wx.MouseEvent

DragIcon

Function in package wx

DragImage

Class in package wx

DragListItem

Function in package wx

DragString

Function in package wx

DragTreeItem

Function in package wx

Draw

Method in class wx.ImageList

Draw

Method in class wx.animate.AnimationPlayer

Draw

Method in class wx.grid.GridCellRenderer

Draw

Method in class wx.html.HtmlCell

Draw

Method in class wx.lib.docview.Document

Draw

Method in class wx.lib.editor.editor.Editor

Draw

Method in class wx.lib.floatcanvas.FloatCanvas.FloatCanvas

Draw

Method in class wx.lib.ogl.PseudoMetaFile

Draw

Method in class wx.lib.ogl.Shape

Draw

Method in class wx.lib.plot.PlotCanvas

draw

Method in class wx.lib.plot.PlotGraphics

draw

Method in class wx.lib.plot.PolyLine

draw

Method in class wx.lib.plot.PolyMarker

Draw

Method in class wx.lib.throbber.Throbber

draw

Method in class wx.lib.wxPlotCanvas.PlotCanvas

draw

Method in class wx.lib.wxPlotCanvas.PlotGraphics

draw

Method in class wx.lib.wxPlotCanvas.PolyLine

draw

Method in class wx.lib.wxPlotCanvas.PolyMarker

DrawArc

Method in class wx.DC

DrawArc

Method in class wx.lib.ogl.DrawnShape

DrawArc

Method in class wx.lib.ogl.PseudoMetaFile

DrawArcPoint

Method in class wx.DC

DrawArcToEllipse

Function in package wx.lib.ogl

DrawArrow

Method in class wx.lib.ogl.LineShape

DrawArrow

Method in class wx.lib.popupctl.PopButton

DrawArrows

Method in class wx.lib.ogl.LineShape

DrawAtAngle

Method in class wx.lib.ogl.DrawnShape

DrawBackground

Method in class wx.animate.AnimationPlayer

DrawBezel

Method in class wx.lib.buttons.GenButton

DrawBezel

Method in class wx.lib.popupctl.PopButton

DrawBitmap

Method in class wx.DC

DrawBitmapPoint

Method in class wx.DC

DrawBlankPage

Method in class wx.PrintPreview

DrawBorder

Method in class wx.lib.calendar.CalDraw

DrawBorder

Method in class wx.lib.imagebrowser.ImageView

DrawBuffer

Method in class wx.lib.colourchooser.canvas.Canvas

DrawBuffer

Method in class wx.lib.colourchooser.pycolourslider.PyColourSlider

DrawBuffer

Method in class wx.lib.colourchooser.pypalette.PyPalette

DrawCal

Method in class wx.lib.calendar.CalDraw

DrawCellHighlight

Method in class wx.grid.Grid

DrawCheckMark

Method in class wx.DC

DrawCheckMarkRect

Method in class wx.DC

DrawCircle

Method in class wx.DC

DrawCirclePoint

Method in class wx.DC

DrawColumns

Method in class wx.lib.printout.PrintTableDraw

DrawContents

Method in class wx.lib.ogl.Shape

DrawCursor

Method in class wx.lib.editor.editor.Editor

DrawD2

Method in class wx.lib.floatcanvas.FloatCanvas.PointSet

DrawDayText

Method in class wx.lib.calendar.CalDraw

DrawEditText

Method in class wx.lib.editor.editor.Editor

DrawEllipse

Method in class wx.DC

DrawEllipse

Method in class wx.lib.ogl.DrawnShape

DrawEllipse

Method in class wx.lib.ogl.PseudoMetaFile

DrawEllipseList

Method in class wx.DC

DrawEllipsePointSize

Method in class wx.DC

DrawEllipseRect

Method in class wx.DC

DrawEllipticArc

Method in class wx.DC

DrawEllipticArc

Method in class wx.lib.ogl.DrawnShape

DrawEllipticArc

Method in class wx.lib.ogl.PseudoMetaFile

DrawEllipticArcPointSize

Method in class wx.DC

DrawEofMarker

Method in class wx.lib.editor.editor.Editor

DrawFocusIndicator

Method in class wx.lib.buttons.GenButton

DrawFocusIndicator

Method in class wx.lib.calendar.CalDraw

DrawFocusIndicator

Method in class wx.lib.calendar.Calendar

DrawFormattedText

Function in package wx.lib.ogl

DrawFrame

Method in class wx.animate.AnimationPlayer

DrawGrid

Method in class wx.lib.calendar.CalDraw

DrawGridLine

Method in class wx.lib.printout.PrintTableDraw

DrawHorizontalGradient

Method in class wx.lib.foldpanelbar.CaptionBar

DrawIcon

Method in class wx.DC

DrawIconPoint

Method in class wx.DC

DrawImage

Method in class wx.lib.imagebrowser.ImageView

DrawImageLabel

Method in class wx.DC

DrawInvisible

Method in class wx.html.HtmlCell

DrawLabel

Method in class wx.DC

DrawLabel

Method in class wx.lib.buttons.GenBitmapButton

DrawLabel

Method in class wx.lib.buttons.GenBitmapTextButton

DrawLabel

Method in class wx.lib.buttons.GenButton

DrawLine

Method in class wx.DC

DrawLine

Method in class wx.lib.editor.editor.Editor

DrawLine

Method in class wx.lib.ogl.DrawnShape

DrawLine

Method in class wx.lib.ogl.PseudoMetaFile

DrawLineList

Method in class wx.DC

DrawLinePoint

Method in class wx.DC

DrawLines

Method in class wx.DC

DrawLines

Method in class wx.lib.ogl.DrawnShape

DrawLines

Method in class wx.lib.ogl.PseudoMetaFile

DrawLinks

Method in class wx.lib.ogl.Shape

DrawMonth

Method in class wx.lib.calendar.CalDraw

DrawnShape

Class in package wx.lib.ogl

DrawNum

Method in class wx.lib.calendar.CalDraw

DrawNumVal

Method in class wx.lib.calendar.CalDraw

DrawObject

Class in module wx.lib.floatcanvas.FloatCanvas

DrawOp

Class in package wx.lib.ogl

DrawOutline

Method in class wx.lib.ogl.Diagram

DrawPoint

Method in class wx.DC

DrawPoint

Method in class wx.lib.ogl.DrawnShape

DrawPoint

Method in class wx.lib.ogl.PseudoMetaFile

DrawPointLabel

Method in class wx.lib.plot.TestFrame

DrawPointList

Method in class wx.DC

DrawPointPoint

Method in class wx.DC

DrawPolygon

Method in class wx.DC

DrawPolygon

Method in class wx.lib.ogl.DrawnShape

DrawPolygon

Method in class wx.lib.ogl.PseudoMetaFile

DrawPolygonList

Method in class wx.DC

DrawRect

Method in class wx.lib.calendar.Calendar

DrawRectangle

Method in class wx.DC

DrawRectangle

Method in class wx.lib.ogl.DrawnShape

DrawRectangle

Method in class wx.lib.ogl.PseudoMetaFile

DrawRectangleList

Method in class wx.DC

DrawRectanglePointSize

Method in class wx.DC

DrawRectangleRect

Method in class wx.DC

DrawRectOrg

Method in class wx.lib.calendar.Calendar

DrawRegion

Method in class wx.lib.ogl.LineShape

DrawRotatedText

Method in class wx.DC

DrawRotatedTextPoint

Method in class wx.DC

DrawRoundedRectangle

Method in class wx.DC

DrawRoundedRectangle

Method in class wx.lib.ogl.DrawnShape

DrawRoundedRectangle

Method in class wx.lib.ogl.PseudoMetaFile

DrawRoundedRectanglePointSize

Method in class wx.DC

DrawRoundedRectangleRect

Method in class wx.DC

DrawSash

Function in module wx.lib.multisash

DrawSel

Method in class wx.lib.calendar.CalDraw

DrawSimpleCursor

Method in class wx.lib.editor.editor.Editor

DrawSingleColour

Method in class wx.lib.foldpanelbar.CaptionBar

DrawSingleRectangle

Method in class wx.lib.foldpanelbar.CaptionBar

DrawSpline

Method in class wx.DC

DrawSpline

Method in class wx.lib.ogl.DrawnShape

DrawSpline

Method in class wx.lib.ogl.PseudoMetaFile

DrawSunkenEdge

Method in class wx.Effects

DrawText

Method in class wx.DC

DrawText

Method in class wx.lib.ogl.DrawnShape

DrawText

Method in class wx.lib.ogl.PseudoMetaFile

DrawText

Method in class wx.lib.printout.PrintTableDraw

DrawText

Method in class wx.lib.ticker.Ticker

DrawTextList

Method in class wx.DC

DrawTextPoint

Method in class wx.DC

DrawTextRectangle

Method in class wx.grid.Grid

DrawVerticalGradient

Method in class wx.lib.foldpanelbar.CaptionBar

DrawWeek

Method in class wx.lib.calendar.CalDraw

DrawWindowOnDC

Function in package wx

DROP_ICON

Function in package wx

DropFilesEvent

Class in package wx

DropSource

Class in package wx

DropTarget

Class in package wx

Dummy_PyInformationalMessagesFrame

Class in module wx.lib.infoframe

dump_dirs

Method in class distutils.command.install.install

dump_options

Method in class distutils.cmd.Command

DynamicSashSplitEvent

Class in module wx.gizmos

DynamicSashUnifyEvent

Class in module wx.gizmos

DynamicSashWindow

Class in module wx.gizmos

Edit

Method in class wx.gizmos.TreeListCtrl

Edit

Method in class wx.lib.mvctree.Editor

Edit

Method in class wx.lib.mvctree.FileEditor

Edit

Method in class wx.lib.mvctree.MVCTree

EditableListBox

Class in module wx.gizmos

EditEdge

Method in class wx.lib.ogl.DivisionShape

EditLabel

Method in class wx.ListCtrl

EditLabel

Method in class wx.TreeCtrl

EditLabel

Method in class wx.gizmos.TreeListCtrl

editor

Package in package wx.lib

editor

Module in package wx.lib.editor

Editor

Class in module wx.lib.editor.editor

Editor

Class in module wx.lib.mvctree

editor

Module in package wx.py

Editor

Class in module wx.py.editor

editorBgColour

Variable in class wx.lib.mixins.listctrl.TextEditMixin

editorFgColour

Variable in class wx.lib.mixins.listctrl.TextEditMixin

EditorFrame

Class in module wx.py.editor

EditorNotebook

Class in module wx.py.editor

EditorNotebookFrame

Class in module wx.py.editor

EditorShellNotebook

Class in module wx.py.editor

EditorShellNotebookFrame

Class in module wx.py.editor

EditRegions

Method in class wx.lib.ogl.DividedShape

EditToggleOvertype

Method in class wx.stc.StyledTextCtrl

EditWindow

Class in module wx.py.editor

editwindow

Module in package wx.py

EditWindow

Class in module wx.py.editwindow

EDT

Variable in class wx.DateTime

EDT

Variable in class wx.DateTime

EEST

Variable in class wx.DateTime

EEST

Variable in class wx.DateTime

EET

Variable in class wx.DateTime

EET

Variable in class wx.DateTime

Effects

Class in package wx

Ellipse

Class in module wx.lib.floatcanvas.FloatCanvas

EllipseShape

Class in package wx.lib.ogl

EMBEDDED_WINDOW_ALL

Variable in module wx.lib.pydocview

EMBEDDED_WINDOW_BOTTOM

Variable in module wx.lib.pydocview

EMBEDDED_WINDOW_BOTTOMLEFT

Variable in module wx.lib.pydocview

EMBEDDED_WINDOW_BOTTOMRIGHT

Variable in module wx.lib.pydocview

EMBEDDED_WINDOW_LEFT

Variable in module wx.lib.pydocview

EMBEDDED_WINDOW_RIGHT

Variable in module wx.lib.pydocview

EMBEDDED_WINDOW_TOP

Variable in module wx.lib.pydocview

EMBEDDED_WINDOW_TOPLEFT

Variable in module wx.lib.pydocview

EMBEDDED_WINDOW_TOPRIGHT

Variable in module wx.lib.pydocview

EmptyBitmap

Function in package wx

EmptyCaptionBarStyle

Variable in class wx.lib.foldpanelbar.CaptionBar

EmptyCaptionBarStyle

Variable in class wx.lib.foldpanelbar.FoldPanelBar

EmptyCaptionBarStyle

Variable in class wx.lib.foldpanelbar.FoldPanelItem

EmptyChild

Class in module wx.lib.multisash

EmptyIcon

Function in package wx

EmptyImage

Function in package wx

emptyUndoBuffer

Method in class wx.py.editor.Editor

EmptyUndoBuffer

Method in class wx.stc.StyledTextCtrl

EmptyXmlDocument

Function in module wx.xrc

EmptyXmlResource

Function in module wx.xrc

EmulateKeyPress

Method in class wx.TextCtrl

Enable

Method in class wx.Menu

Enable

Method in class wx.MenuBar

Enable

Method in class wx.MenuItem

Enable

Method in class wx.ToolBarToolBase

Enable

Method in class wx.ToolTip

Enable

Method in class wx.UpdateUIEvent

Enable

Method in class wx.Window

Enable

Method in class wx.lib.buttons.GenButton

Enable

Method in class wx.lib.filebrowsebutton.FileBrowseButton

Enable

Method in class wx.lib.popupctl.PopupControl

EnableCellEditControl

Method in class wx.grid.Grid

Enabled

Variable in class wx.lib.infoframe.PyInformationalMessagesFrame

enabled

Variable in class wx.lib.infoframe.PyInformationalMessagesFrame in class wx.lib.mixins.rubberband.RubberBand

EnableDragCell

Method in class wx.grid.Grid

EnableDragColSize

Method in class wx.grid.Grid

EnableDragGridSize

Method in class wx.grid.Grid

EnableDragRowSize

Method in class wx.grid.Grid

EnableEditing

Method in class wx.grid.Grid

EnableEffects

Method in class wx.FontData

EnableGridLines

Method in class wx.grid.Grid

EnableHelp

Method in class wx.PageSetupDialogData

EnableHelp

Method in class wx.PrintDialogData

EnableHolidayDisplay

Method in class wx.calendar.CalendarCtrl

EnableItem

Method in class wx.RadioBox

EnableLogging

Method in class wx.Log

EnableMargins

Method in class wx.PageSetupDialogData

EnableMonthChange

Method in class wx.calendar.CalendarCtrl

EnableOrientation

Method in class wx.PageSetupDialogData

EnableOutput

Method in class wx.lib.infoframe.Dummy_PyInformationalMessagesFrame

EnableOutput

Method in class wx.lib.infoframe.PyInformationalMessagesFrame

EnablePageNumbers

Method in class wx.PrintDialogData

EnablePaper

Method in class wx.PageSetupDialogData

EnablePrinter

Method in class wx.PageSetupDialogData

EnablePrintToFile

Method in class wx.PrintDialogData

EnableRollover

Method in class wx.lib.hyperlink.HyperLinkCtrl

EnableScrolling

Method in class wx.ScrolledWindow

EnableSelection

Method in class wx.PrintDialogData

EnableTool

Method in class wx.ToolBarBase

EnableTop

Method in class wx.MenuBar

EnableTopLevelWindows

Function in package wx

EnableYearChange

Method in class wx.calendar.CalendarCtrl

encoding

Variable in class _xmlplus.dom.minidom.Document in class wx.NativeEncodingInfo

EncodingConverter

Class in package wx

EncodingConverter_CanConvert

Function in package wx

EncodingConverter_GetAllEquivalents

Function in package wx

EncodingConverter_GetPlatformEquivalents

Function in package wx

End

Method in class wx.lib.gestures.MouseGestures

EndBatch

Method in class wx.grid.Grid

EndBatch

Method in class wx.lib.shell.PyShellOutput

EndBusyCursor

Function in package wx

EndContextHelp

Method in class wx.ContextHelp

EndDoc

Method in class wx.DC

EndDrag

Method in class wx.DragImage

EndDrawing

Method in class wx.DC

EndDrawingOnTop

Method in class wx.ScreenDC

EndEdit

Method in class wx.grid.GridCellEditor

EndEdit

Method in class wx.lib.mvctree.Editor

EndEdit

Method in class wx.lib.mvctree.FileEditor

EndEdit

Method in class wx.lib.mvctree.MVCTree

EndEdit

Method in class wx.lib.sheet.CCellEditor

EndModal

Method in class wx.Dialog

EndPage

Method in class wx.DC

EndUndoAction

Method in class wx.stc.StyledTextCtrl

ensure_dirname

Method in class distutils.cmd.Command

ensure_filename

Method in class distutils.cmd.Command

ensure_finalized

Method in class distutils.cmd.Command

ensure_string

Method in class distutils.cmd.Command

ensure_string_list

Method in class distutils.cmd.Command

EnsureCaretVisible

Method in class wx.stc.StyledTextCtrl

ensureMinimal

Function in module wxversion

EnsureVisible

Method in class wx.ListBox

EnsureVisible

Method in class wx.ListCtrl

EnsureVisible

Method in class wx.TreeCtrl

EnsureVisible

Method in class wx.gizmos.TreeListCtrl

EnsureVisible

Method in class wx.stc.StyledTextCtrl

EnsureVisibleEnforcePolicy

Method in class wx.stc.StyledTextCtrl

Entering

Method in class wx.MouseEvent

EnumAllFileTypes

Method in class wx.MimeTypesManager

EnumerateEncodings

Method in class wx.FontEnumerator

EnumerateFacenames

Method in class wx.FontEnumerator

Eof

Method in class wx.InputStream

eof

Method in class wx.InputStream

EofImageData

Variable in module wx.lib.editor.images

Equals

Method in class wx.lib.ogl.Constraint

Erase

Method in class wx.lib.ogl.Shape

EraseContents

Method in class wx.lib.ogl.Shape

EraseEvent

Class in package wx

EraseLinks

Method in class wx.lib.ogl.Shape

EraseRegion

Method in class wx.lib.ogl.LineShape

erefs

Variable in class wx.lib.shell.PyShellOutput

Escape

Method in class wx.lib.editor.editor.Editor

EST

Variable in class wx.DateTime

EST

Variable in class wx.DateTime

Evaluate

Method in class wx.lib.ogl.Constraint

Event

Class in package wx

EventAdapter

Class in module wx.lib.evtmgr

evEnter

Method in class wx.lib.foldmenu.FoldOutWindow

eventIsA

Method in class wx.lib.evtmgr.EventMacroInfo

EventLoop

Class in package wx

EventLoop_GetActive

Function in package wx

EventLoop_SetActive

Function in package wx

EventMacroInfo

Class in module wx.lib.evtmgr

EventManager

Class in module wx.lib.evtmgr

eventManager

Variable in module wx.lib.evtmgr

evLeave

Method in class wx.lib.foldmenu.FoldOutWindow

EVT_CALENDAR

Variable in module wx.lib.calendar

EVT_CAPTIONBAR

Variable in module wx.lib.foldpanelbar

EVT_COLOURSELECT

Variable in module wx.lib.colourselect

EVT_DOPOPUPMENU

Variable in module wx.lib.mixins.listctrl

EVT_FC_ENTER_OBJECT

Variable in module wx.lib.floatcanvas.FloatCanvas

EVT_FC_LEAVE_OBJECT

Variable in module wx.lib.floatcanvas.FloatCanvas

EVT_FC_LEFT_DCLICK

Variable in module wx.lib.floatcanvas.FloatCanvas

EVT_FC_LEFT_DOWN

Variable in module wx.lib.floatcanvas.FloatCanvas

EVT_FC_LEFT_UP

Variable in module wx.lib.floatcanvas.FloatCanvas

EVT_FC_MIDDLE_DCLICK

Variable in module wx.lib.floatcanvas.FloatCanvas

EVT_FC_MIDDLE_DOWN

Variable in module wx.lib.floatcanvas.FloatCanvas

EVT_FC_MIDDLE_UP

Variable in module wx.lib.floatcanvas.FloatCanvas

EVT_FC_MOTION

Variable in module wx.lib.floatcanvas.FloatCanvas

EVT_FC_MOUSEWHEEL

Variable in module wx.lib.floatcanvas.FloatCanvas

EVT_FC_RIGHT_DCLICK

Variable in module wx.lib.floatcanvas.FloatCanvas

EVT_FC_RIGHT_DOWN

Variable in module wx.lib.floatcanvas.FloatCanvas

EVT_FC_RIGHT_UP

Variable in module wx.lib.floatcanvas.FloatCanvas

EVT_GRID_COL_MOVE

Variable in module wx.lib.gridmovers

EVT_GRID_ROW_MOVE

Variable in module wx.lib.gridmovers

EVT_HYPERLINK_LEFT

Variable in module wx.lib.hyperlink

EVT_HYPERLINK_MIDDLE

Variable in module wx.lib.hyperlink

EVT_HYPERLINK_RIGHT

Variable in module wx.lib.hyperlink

EVT_INT

Variable in module wx.lib.intctrl

EVT_LEFT_DCLICK

Function in module wx.lib.floatcanvas.FloatCanvas

EVT_LEFT_DOWN

Function in module wx.lib.floatcanvas.FloatCanvas

EVT_LEFT_UP

Function in module wx.lib.floatcanvas.FloatCanvas

EVT_MIDDLE_DCLICK

Function in module wx.lib.floatcanvas.FloatCanvas

EVT_MIDDLE_DOWN

Function in module wx.lib.floatcanvas.FloatCanvas

EVT_MIDDLE_UP

Function in module wx.lib.floatcanvas.FloatCanvas

EVT_MOTION

Function in module wx.lib.floatcanvas.FloatCanvas

EVT_MOUSEWHEEL

Function in module wx.lib.floatcanvas.FloatCanvas

EVT_MVCTREE_ADD_ITEM

Variable in module wx.lib.mvctree

EVT_MVCTREE_DELETE_ITEM

Variable in module wx.lib.mvctree

EVT_MVCTREE_ITEM_COLLAPSED

Variable in module wx.lib.mvctree

EVT_MVCTREE_ITEM_COLLAPSING

Variable in module wx.lib.mvctree

EVT_MVCTREE_ITEM_EXPANDED

Variable in module wx.lib.mvctree

EVT_MVCTREE_ITEM_EXPANDING

Variable in module wx.lib.mvctree

EVT_MVCTREE_KEY_DOWN

Variable in module wx.lib.mvctree

EVT_MVCTREE_SEL_CHANGED

Variable in module wx.lib.mvctree

EVT_MVCTREE_SEL_CHANGING

Variable in module wx.lib.mvctree

EVT_NUM

Variable in module wx.lib.masked.numctrl

EVT_RIGHT_DCLICK

Function in module wx.lib.floatcanvas.FloatCanvas

EVT_RIGHT_DOWN

Function in module wx.lib.floatcanvas.FloatCanvas

EVT_RIGHT_UP

Function in module wx.lib.floatcanvas.FloatCanvas

EVT_TIMEUPDATE

Variable in module wx.lib.masked.timectrl

EVT_UPDATE_THROBBER

Variable in module wx.lib.throbber

EvtComboBox

Method in class wx.lib.calendar.CalenDlg

EvtHandler

Class in package wx

evtmgr

Module in package wx.lib

exc_style

Variable in class wx.lib.shell.PyShellOutput

Exception

Class in module exceptions

execStartupScript

Method in class wx.py.shell.Shell

execute

Method in class distutils.cmd.Command

Execute

Function in package wx

Exists

Method in class wx.ConfigBase

Exists

Method in class wx.Process

Exit

Method in class wx.EventLoop

Exit

Function in package wx

Exit

Method in class wx.PyApp

ExitMainLoop

Method in class wx.PyApp

Expand

Method in class wx.TreeCtrl

Expand

Method in class wx.gizmos.TreeListCtrl

Expand

Method in class wx.lib.foldpanelbar.CaptionBar

Expand

Method in class wx.lib.foldpanelbar.FoldPanelBar

Expand

Method in class wx.lib.foldpanelbar.FoldPanelItem

expand_basedirs

Method in class distutils.command.install.install

expand_dirs

Method in class distutils.command.install.install

ExpandAll

Method in class wx.gizmos.TreeListCtrl

ExpandCommand

Method in class wx.FileType

ExpandEnvVars

Method in class wx.ConfigBase

ExpandEnvVars

Function in package wx

ExpandPath

Method in class wx.GenericDirCtrl

exposed_basectrl_params

Variable in class wx.lib.masked.ipaddrctrl.IpAddrCtrlAccessorsMixin

exposed_basectrl_params

Variable in class wx.lib.masked.ipaddrctrl.IpAddrCtrlAccessorsMixin

exposed_basectrl_params

Variable in class wx.lib.masked.maskededit.MaskedEditAccessorsMixin

exposed_basectrl_params

Variable in class wx.lib.masked.maskededit.MaskedEditAccessorsMixin

exposed_basectrl_params

Variable in class wx.lib.masked.maskededit.MaskedEditAccessorsMixin

exposed_basectrl_params

Variable in class wx.lib.masked.maskededit.MaskedEditAccessorsMixin

exposed_basectrl_params

Variable in class wx.lib.masked.maskededit.MaskedEditAccessorsMixin

exposed_basectrl_params

Variable in class wx.lib.masked.numctrl.NumCtrlAccessorsMixin

exposed_basectrl_params

Variable in class wx.lib.masked.numctrl.NumCtrlAccessorsMixin

exposed_basectrl_params

Variable in class wx.lib.masked.timectrl.TimeCtrlAccessorsMixin

f

Variable in class wx.lib.infoframe.PyInformationalMessagesFrame

facename

Variable in class wx.lib.infoframe.PyInformationalMessagesFrame in class wx.NativeEncodingInfo

FakeWindow

Class in module wx.lib.evtmgr

fancytext

Module in package wx.lib

FauxFile

Class in module wx.lib.pyshell

Feb

Variable in class wx.DateTime

Feb

Variable in class wx.DateTime

FFont

Function in package wx

FFontFromPixelSize

Function in package wx

Field

Class in module wx.lib.masked.maskededit

filebrowsebutton

Module in package wx.lib

FileBrowseButton

Class in module wx.lib.filebrowsebutton

FileBrowseButtonWithHistory

Class in module wx.lib.filebrowsebutton

FileConfig

Class in package wx

FileDataObject

Class in package wx

FileDialog

Class in package wx

fileDialog

Function in module wx.lib.dialogs

fileDialog

Function in module wx.py.editor

FileDropTarget

Class in package wx

FileEditor

Class in module wx.lib.mvctree

FileExists

Function in module wx.lib.docview

FileHistory

Class in package wx

FileHistoryAddFilesToMenu

Method in class wx.lib.docview.DocManager

FileHistoryLoad

Method in class wx.lib.docview.DocManager

FileHistoryRemoveMenu

Method in class wx.lib.docview.DocManager

FileHistorySave

Method in class wx.lib.docview.DocManager

FileHistoryUseMenu

Method in class wx.lib.docview.DocManager

FileMatchesTemplate

Method in class wx.lib.docview.DocTemplate

FileNameFromPath

Function in module wx.lib.docview

FileNameToURL

Method in class wx.FileSystem

FilePropertiesDialog

Class in module wx.lib.pydocview

FilePropertiesService

Class in module wx.lib.pydocview

FileSelector

Function in package wx

FileSystem

Class in package wx

FileSystem_AddHandler

Function in package wx

FileSystem_CleanUpHandlers

Function in package wx

FileSystem_FileNameToURL

Function in package wx

FileSystem_URLToFileName

Function in package wx

FileSystemHandler

Class in package wx

FileType

Class in package wx

FileType_ExpandCommand

Function in package wx

FileTypeInfo

Class in package wx

FileTypeInfoSequence

Function in package wx

FileWrapper

Class in module wx.lib.mvctree

FillCaptionBackground

Method in class wx.lib.foldpanelbar.CaptionBar

FillDate

Function in module wx.lib.CDate

FillFilterList

Method in class wx.DirFilterListCtrl

filling

Module in package wx.py

Filling

Class in module wx.py.filling

FillingFrame

Class in module wx.py.filling

FillingText

Class in module wx.py.filling

FillingTree

Class in module wx.py.filling

FillStyleList

Variable in class wx.lib.floatcanvas.FloatCanvas.DrawObject

FillStyleList

Variable in class wx.lib.floatcanvas.FloatCanvas.DrawObject

FillStyleList

Variable in class wx.lib.floatcanvas.FloatCanvas.DrawObject

FillStyleList

Variable in class wx.lib.floatcanvas.FloatCanvas.DrawObject

FillStyleList

Variable in class wx.lib.floatcanvas.FloatCanvas.DrawObject

FillStyleList

Variable in class wx.lib.floatcanvas.FloatCanvas.DrawObject

FillStyleList

Variable in class wx.lib.floatcanvas.FloatCanvas.DrawObject

FillStyleList

Variable in class wx.lib.floatcanvas.FloatCanvas.DrawObject

FillStyleList

Variable in class wx.lib.floatcanvas.FloatCanvas.DrawObject

FillStyleList

Variable in class wx.lib.floatcanvas.FloatCanvas.DrawObject

FillStyleList

Variable in class wx.lib.floatcanvas.FloatCanvas.DrawObject

FillStyleList

Variable in class wx.lib.floatcanvas.FloatCanvas.DrawObject

finalize_options

Method in class distutils.cmd.Command

finalize_options

Method in class distutils.command.clean.clean

finalize_options

Method in class distutils.command.install.install

finalize_options

Method in class distutils.command.install_data.install_data

finalize_options

Method in class distutils.command.install_headers.install_headers

finalize_other

Method in class distutils.command.install.install

finalize_unix

Method in class distutils.command.install.install

Find

Method in class wx.ColourDatabase

Find

Method in class wx.html.HtmlCell

FindArrowHead

Method in class wx.lib.ogl.LineShape

FindArrowHeadId

Method in class wx.lib.ogl.LineShape

FindById

Method in class wx.ToolBarBase

FindCellByPos

Method in class wx.html.HtmlCell

FindChild

Method in class wx.GenericDirCtrl

FindClosestPoint

Method in class wx.lib.floatcanvas.FloatCanvas.PointSet

FindColumn

Method in class wx.stc.StyledTextCtrl

FindConstraint

Method in class wx.lib.ogl.CompositeShape

FindContainerImage

Method in class wx.lib.ogl.CompositeShape

FindControl

Method in class wx.ToolBarBase

findDialog

Function in module wx.lib.dialogs

FindDialogEvent

Class in package wx

FindEndForBox

Function in package wx.lib.ogl

FindEndForCircle

Function in package wx.lib.ogl

FindEndForPolyline

Function in package wx.lib.ogl

FindExtension

Function in module wx.lib.docview

FindFiles

Class in module wx.lib.imagebrowser

FindFirst

Method in class wx.FileSystem

FindFirst

Method in class wx.FileSystemHandler

FindFirst

Method in class wx.MemoryFSHandler

FindFirst

Method in class wx.ZipFSHandler

FindFirstUnusedColour

Method in class wx.Image

FindFirstUnusedColour

Method in class wx.ImageHistogram

FindFocus

Method in class wx.Window

FindItem

Method in class wx.GridBagSizer

FindItem

Method in class wx.ListCtrl

FindItem

Method in class wx.Menu

FindItem

Method in class wx.gizmos.TreeListCtrl

FindItemAtPoint

Method in class wx.GridBagSizer

FindItemAtPos

Method in class wx.ListCtrl

FindItemAtPosition

Method in class wx.GridBagSizer

FindItemById

Method in class wx.Menu

FindItemById

Method in class wx.MenuBar

FindItemByPosition

Method in class wx.Menu

FindItemData

Method in class wx.ListCtrl

FindLanguageInfo

Method in class wx.Locale

FindLineEndPoints

Method in class wx.lib.ogl.LineShape

FindLinePosition

Method in class wx.lib.ogl.LineShape

FindMenu

Method in class wx.MenuBar

FindMenuItem

Method in class wx.MenuBar

FindMinimumWidth

Method in class wx.lib.ogl.LineShape

FindName

Method in class wx.ColourDatabase

FindNext

Method in class wx.FileSystem

FindNext

Method in class wx.FileSystemHandler

FindNext

Method in class wx.MemoryFSHandler

FindNext

Method in class wx.ZipFSHandler

FindNth

Method in class wx.lib.ogl.LineShape

FindOrCreateBrush

Method in class wx.BrushList

FindOrCreateFont

Method in class wx.FontList

FindOrCreatePen

Method in class wx.PenList

FindPageById

Method in class wx.html.HtmlHelpData

FindPageByName

Method in class wx.html.HtmlHelpData

FindRegion

Method in class wx.lib.ogl.Shape

FindRegionNames

Method in class wx.lib.ogl.Shape

FindReplaceData

Class in package wx

FindReplaceDialog

Class in package wx

FindSelection

Method in class wx.lib.editor.editor.Editor

FindShape

Method in class wx.lib.ogl.Diagram

FindShape

Method in class wx.lib.ogl.ShapeCanvas

FindString

Method in class wx.ItemContainer

FindString

Method in class wx.RadioBox

FindSuitableParent

Method in class wx.lib.docview.DocManager

FindTemplateForPath

Method in class wx.lib.docview.DocManager

FindText

Method in class wx.stc.StyledTextCtrl

FindToolForPosition

Method in class wx.ToolBar

FindToolForPosition

Method in class wx.ToolBarBase

FindWindowAtPoint

Function in package wx

FindWindowById

Function in package wx

FindWindowById

Method in class wx.Window

FindWindowByLabel

Function in package wx

FindWindowByName

Function in package wx

FindWindowByName

Method in class wx.Window

FinishDraw

Method in class wx.lib.printout.PrintTableDraw

FirstColourUsed

Method in class wx.lib.foldpanelbar.CaptionBarStyle

Fit

Method in class wx.Sizer

Fit

Method in class wx.Window

FitInside

Method in class wx.Sizer

FitInside

Method in class wx.Window

FitToAnimation

Method in class wx.animate.GIFAnimationCtrl

FitToPage

Method in class wx.wizard.Wizard

fixLineEndings

Method in class wx.py.shell.Shell

Flash

Method in class wx.lib.ogl.Shape

FlatEarthProjection

Method in class wx.lib.floatcanvas.FloatCanvas.FloatCanvas

FlexGridSizer

Class in package wx

floatbar

Module in package wx.lib

FloatBar

Class in module wx.lib.floatbar

floatcanvas

Package in package wx.lib

FloatCanvas

Module in package wx.lib.floatcanvas

FloatCanvas

Class in module wx.lib.floatcanvas.FloatCanvas

FloatCanvasError

Class in module wx.lib.floatcanvas.FloatCanvas

FloodFill

Method in class wx.DC

FloodFillPoint

Method in class wx.DC

Flush

Method in class wx.Clipboard

Flush

Method in class wx.ConfigBase

flush

Method in class wx.InputStream

Flush

Method in class wx.Log

flush

Method in class wx.PyOnDemandOutputWindow

flush

Method in class wx.lib.infoframe.Dummy_PyInformationalMessagesFrame

flush

Method in class wx.lib.infoframe.PyInformationalMessagesFrame

flush

Method in class wx.lib.pyshell.FauxFile

flush

Method in class wx.lib.shell.PyShellOutput

flush

Method in class wx.py.pseudo.PseudoFile

FlushActive

Method in class wx.Log

FlushDoc

Method in class wx.lib.docview.DocManager

Focus

Method in class wx.ListCtrl

Focus

Method in class wx.ListView

FocusEvent

Class in package wx

foldmenu

Module in package wx.lib

FoldOutMenu

Class in module wx.lib.foldmenu

FoldOutWindow

Class in module wx.lib.foldmenu

foldpanelbar

Module in package wx.lib

FoldPanelBar

Class in module wx.lib.foldpanelbar

FoldPanelItem

Class in module wx.lib.foldpanelbar

FoldWindowItem

Class in module wx.lib.foldpanelbar

Font

Class in package wx

font

Class in package wx in class wx.VisualAttributes

Font_GetDefaultEncoding

Function in package wx

Font_SetDefaultEncoding

Function in package wx

FontData

Class in package wx

FontDialog

Class in package wx

fontDialog

Function in module wx.lib.dialogs

FontEnumerator

Class in package wx

FontFromNativeInfo

Function in package wx

FontFromNativeInfoString

Function in package wx

FontFromPixelSize

Function in package wx

FontList

Class in package wx

FontList

Variable in class wx.lib.floatcanvas.FloatCanvas.TextObjectMixin

FontList

Variable in class wx.lib.floatcanvas.FloatCanvas.TextObjectMixin

FontList

Variable in class wx.lib.floatcanvas.FloatCanvas.TextObjectMixin

FontMapper

Class in package wx

FontMapper_Get

Function in package wx

FontMapper_GetDefaultConfigPath

Function in package wx

FontMapper_GetEncoding

Function in package wx

FontMapper_GetEncodingDescription

Function in package wx

FontMapper_GetEncodingFromName

Function in package wx

FontMapper_GetEncodingName

Function in package wx

FontMapper_GetSupportedEncodingsCount

Function in package wx

FontMapper_Set

Function in package wx

ForceBetween

Function in module wx.lib.editor.editor

ForceRefresh

Method in class wx.grid.Grid

Format

Method in class wx.DateTime

Format

Method in class wx.TimeSpan

FormatContent

Method in class wx.lib.popupctl.PopupControl

FormatDate

Method in class wx.DateTime

FormatDay

Function in module wx.lib.CDate

FormatISODate

Method in class wx.DateTime

FormatISOTime

Method in class wx.DateTime

FormatRange

Method in class wx.stc.StyledTextCtrl

FormatText

Function in package wx.lib.ogl

FormatText

Method in class wx.lib.ogl.LineShape

FormatText

Method in class wx.lib.ogl.Shape

FormatTime

Method in class wx.DateTime

FormFeed

Method in class wx.stc.StyledTextCtrl

FPB_ALIGN_LEFT

Variable in module wx.lib.foldpanelbar

FPB_ALIGN_WIDTH

Variable in module wx.lib.foldpanelbar

FPB_BMP_RIGHTSPACE

Variable in module wx.lib.foldpanelbar

FPB_COLLAPSE_TO_BOTTOM

Variable in module wx.lib.foldpanelbar

FPB_DEFAULT_EXTRASTYLE

Variable in module wx.lib.foldpanelbar

FPB_DEFAULT_LEFTLINESPACING

Variable in module wx.lib.foldpanelbar

FPB_DEFAULT_LEFTSPACING

Variable in module wx.lib.foldpanelbar

FPB_DEFAULT_RIGHTLINESPACING

Variable in module wx.lib.foldpanelbar

FPB_DEFAULT_RIGHTSPACING

Variable in module wx.lib.foldpanelbar

FPB_DEFAULT_SPACING

Variable in module wx.lib.foldpanelbar

FPB_DEFAULT_STYLE

Variable in module wx.lib.foldpanelbar

FPB_EXCLUSIVE_FOLD

Variable in module wx.lib.foldpanelbar

FPB_EXTRA_X

Variable in module wx.lib.foldpanelbar

FPB_EXTRA_Y

Variable in module wx.lib.foldpanelbar

FPB_HORIZONTAL

Variable in module wx.lib.foldpanelbar

FPB_SINGLE_FOLD

Variable in module wx.lib.foldpanelbar

FPB_VERTICAL

Variable in module wx.lib.foldpanelbar

Frame

Class in package wx

frame

Module in package wx.py

Frame

Class in module wx.py.frame

Frame_GetClassDefaultAttributes

Function in package wx

France

Variable in class wx.DateTime

France

Variable in class wx.DateTime

Freeze

Method in class wx.Window

Fri

Variable in class wx.DateTime

Fri

Variable in class wx.DateTime

FromJulian

Function in module wx.lib.CDate

FromString

Method in class wx.NativeEncodingInfo

FromString

Method in class wx.NativeFontInfo

FromTab

Variable in class wx.NavigationKeyEvent

FromTab

Variable in class wx.NavigationKeyEvent

FromUserString

Method in class wx.NativeFontInfo

FSFile

Class in package wx

FSTreeModel

Class in module wx.lib.mvctree

FutureCall

Class in package wx

Gauge

Class in package wx

Gauge_GetClassDefaultAttributes

Function in package wx

GBPosition

Class in package wx

GBSizerItem

Class in package wx

GBSizerItemSizer

Function in package wx

GBSizerItemSpacer

Function in package wx

GBSizerItemWindow

Function in package wx

GBSpan

Class in package wx

GDIObject

Class in package wx

GenBitmapButton

Class in module wx.lib.buttons

GenBitmapTextButton

Class in module wx.lib.buttons

GenBitmapTextToggleButton

Class in module wx.lib.buttons

GenBitmapToggleButton

Class in module wx.lib.buttons

GenButton

Class in module wx.lib.buttons

GenButtonEvent

Class in module wx.lib.buttons

GeneralOptionsPanel

Class in module wx.lib.pydocview

GeneratePaletteBMP

Method in class wx.lib.colourchooser.pypalette.PyPalette

GenericDirCtrl

Class in package wx

GenericFindWindowAtPoint

Function in package wx

GenStaticBitmap

Class in module wx.lib.statbmp

GenStaticText

Class in module wx.lib.stattext

GenToggleButton

Class in module wx.lib.buttons

Germany

Variable in class wx.DateTime

Germany

Variable in class wx.DateTime

gestures

Module in package wx.lib

Get

Method in class wx.Clipboard

Get

Method in class wx.Colour

Get

Method in class wx.ConfigBase

Get

Variable in class wx.DataObject

Get

Variable in class wx.DataObject

Get

Variable in class wx.DataObject

Get

Variable in class wx.DataObject

Get

Variable in class wx.DataObject

Get

Variable in class wx.DataObject

Get

Variable in class wx.DataObject

Get

Variable in class wx.DataObject

Get

Variable in class wx.DataObject

Get

Variable in class wx.DataObject

Get

Variable in class wx.DataObject

Get

Variable in class wx.DataObject

Get

Variable in class wx.DataObject

Get

Variable in class wx.DataObject

Get

Variable in class wx.DataObject

Get

Variable in class wx.DataObject

Get

Variable in class wx.DataObject

Get

Variable in class wx.DataObject

Get

Variable in class wx.DataObject

Get

Variable in class wx.DataObject

Get

Variable in class wx.DataObject

Get

Variable in class wx.DataObject

Get

Variable in class wx.DataObject

Get

Variable in class wx.DataObject

Get

Method in class wx.FontMapper

Get

Method in class wx.GBPosition

Get

Method in class wx.GBSpan

Get

Method in class wx.HelpProvider

Get

Method in class wx.Point

Get

Method in class wx.Point2D

Get

Method in class wx.RealPoint

Get

Method in class wx.Rect

Get

Method in class wx.Size

Get

Method in class wx.StandardPaths

Get

Method in class wx.grid.GridCellCoords

Get

Method in class wx.xrc.XmlResource

Get3StateValue

Method in class wx.CheckBox

get_command_name

Method in class distutils.cmd.Command

get_finalized_command

Method in class distutils.cmd.Command

get_inputs

Method in class distutils.command.install.install

get_inputs

Method in class distutils.command.install_data.install_data

get_inputs

Method in class distutils.command.install_headers.install_headers

get_outputs

Method in class distutils.command.install.install

get_outputs

Method in class distutils.command.install_data.install_data

get_outputs

Method in class distutils.command.install_headers.install_headers

get_sub_commands

Method in class distutils.cmd.Command

GetAbort

Method in class wx.Printer

GetAbsPos

Method in class wx.html.HtmlCell

GetAccel

Method in class wx.MenuItem

GetAcceleratorTable

Method in class wx.Window

GetAccelFromString

Function in package wx

GetActive

Method in class wx.ActivateEvent

GetActive

Method in class wx.EventLoop

GetActiveChild

Method in class wx.MDIParentFrame

GetActiveChild

Method in class wx.lib.pydocview.DocTabbedParentFrame

GetActiveTarget

Method in class wx.Log

GetActiveWindow

Function in package wx

GetActualColor

Method in class wx.html.HtmlWinParser

GetActualColourObject

Method in class wx.lib.ogl.ShapeRegion

GetActualPen

Method in class wx.lib.ogl.ShapeRegion

GetAddress

Method in class wx.lib.masked.ipaddrctrl.IpAddrCtrl

GetAdjustedBestSize

Method in class wx.Window

GetAffirmativeButton

Method in class wx.StdDialogButtonSizer

GetAlign

Method in class wx.ListItem

GetAlign

Method in class wx.html.HtmlWinParser

GetAlignHor

Method in class wx.html.HtmlContainerCell

GetAlignment

Method in class wx.QueryLayoutInfoEvent

GetAlignment

Method in class wx.SashLayoutWindow

GetAlignment

Method in class wx.TextAttr

GetAlignment

Method in class wx.gizmos.LEDNumberCtrl

GetAlignment

Method in class wx.gizmos.StaticPicture

GetAlignment

Method in class wx.gizmos.TreeListColumnInfo

GetAlignment

Method in class wx.grid.GridCellAttr

GetAlignmentEnd

Method in class wx.lib.ogl.LineShape

GetAlignmentOrientation

Method in class wx.lib.ogl.LineShape

GetAlignmentStart

Method in class wx.lib.ogl.LineShape

GetAlignmentType

Method in class wx.lib.ogl.LineShape

GetAlignVer

Method in class wx.html.HtmlContainerCell

getAllAttributeNames

Function in module wx.py.introspect

GetAllCommands

Method in class wx.FileType

GetAllEquivalents

Method in class wx.EncodingConverter

GetAllFormats

Method in class wx.DataObject

GetAllowNegative

Method in class wx.lib.masked.numctrl.NumCtrl

GetAllowNone

Method in class wx.lib.masked.numctrl.NumCtrl

GetAllowSymbols

Method in class wx.FontData

GetAllPages

Method in class wx.PrintDialogData

GetAllParams

Method in class wx.html.HtmlTag

GetAlpha

Method in class wx.Image

GetAlphaBuffer

Method in class wx.Image

GetAlphaData

Method in class wx.Image

GetAlt

Method in class wx.stc.StyledTextEvent

GetAltForEncoding

Method in class wx.FontMapper

GetAmPmStrings

Method in class wx.DateTime

GetAnchor

Method in class wx.FSFile

GetAnchor

Method in class wx.FileSystemHandler

GetAnchor

Method in class wx.stc.StyledTextCtrl

GetAngle

Method in class wx.lib.ogl.DrawnShape

GetAnimation

Method in class wx.animate.AnimationPlayer

GetAnimation

Method in class wx.animate.GIFAnimationCtrl

GetApp

Function in package wx

GetApplyButton

Method in class wx.StdDialogButtonSizer

GetAppName

Method in class wx.ConfigBase

GetAppName

Method in class wx.PyApp

GetArrowEnd

Method in class wx.lib.ogl.ArrowHead

GetArrowPoints

Function in package wx.lib.ogl

GetArrows

Method in class wx.lib.ogl.LineShape

GetArrowSize

Method in class wx.lib.ogl.ArrowHead

GetAssertMode

Method in class wx.PyApp

GetAssumeChildren

Method in class wx.lib.mvctree.MVCTree

GetAttachmentFrom

Method in class wx.lib.ogl.LineShape

GetAttachmentLineCount

Method in class wx.lib.ogl.Shape

GetAttachmentMode

Method in class wx.lib.ogl.Shape

GetAttachmentPosition

Method in class wx.lib.ogl.ControlPoint

GetAttachmentPosition

Method in class wx.lib.ogl.DividedShape

GetAttachmentPosition

Method in class wx.lib.ogl.EllipseShape

GetAttachmentPosition

Method in class wx.lib.ogl.PolygonShape

GetAttachmentPosition

Method in class wx.lib.ogl.Shape

GetAttachmentPositionEdge

Method in class wx.lib.ogl.Shape

GetAttachmentTo

Method in class wx.lib.ogl.LineShape

GetAttr

Method in class wx.calendar.CalendarCtrl

GetAttr

Method in class wx.grid.GridCellAttrProvider

GetAttr

Method in class wx.grid.GridTableBase

getAttributeNames

Function in module wx.py.introspect

GetAttributes

Method in class wx.ListItem

GetAttrProvider

Method in class wx.grid.GridTableBase

GetAutoCompleteKeycodes

Method in class wx.lib.masked.maskededit.MaskedEditAccessorsMixin

getAutoCompleteKeys

Method in class wx.py.interpreter.Interpreter

getAutoCompleteList

Method in class wx.py.interpreter.Interpreter

getAutoCompleteList

Function in module wx.py.introspect

GetAutoformat

Method in class wx.lib.masked.maskededit.MaskedEditAccessorsMixin

GetAutoLayout

Method in class wx.Window

GetAutoSelect

Method in class wx.lib.masked.maskededit.MaskedEditAccessorsMixin

GetAutoSize

Method in class wx.lib.masked.numctrl.NumCtrl

GetAutoSize

Method in class wx.lib.masked.numctrl.NumCtrlAccessorsMixin

GetBackground

Method in class wx.DC

GetBackgroundBrush

Method in class wx.lib.mvctree.Painter

GetBackgroundBrush

Method in class wx.lib.ogl.Shape

GetBackgroundColour

Method in class wx.ListItem

GetBackgroundColour

Method in class wx.ListItemAttr

GetBackgroundColour

Method in class wx.MenuItem

GetBackgroundColour

Method in class wx.TextAttr

GetBackgroundColour

Method in class wx.Window

GetBackgroundColour

Method in class wx.animate.AnimationBase

GetBackgroundColour

Method in class wx.animate.AnimationPlayer

GetBackgroundColour

Method in class wx.animate.GIFAnimation

GetBackgroundColour

Method in class wx.calendar.CalendarDateAttr

GetBackgroundColour

Method in class wx.grid.GridCellAttr

GetBackgroundColour

Method in class wx.html.HtmlContainerCell

GetBackgroundColour

Method in class wx.lib.mvctree.MVCTree

GetBackgroundColour

Method in class wx.lib.mvctree.Painter

GetBackgroundMode

Method in class wx.DC

GetBackgroundPen

Method in class wx.lib.mvctree.Painter

GetBackgroundPen

Method in class wx.lib.ogl.Shape

GetBackgroundStyle

Method in class wx.Window

GetBackingStore

Method in class wx.animate.AnimationPlayer

GetBackSpaceUnIndents

Method in class wx.stc.StyledTextCtrl

GetBar

Method in class wx.lib.foldpanelbar.CaptionBarEvent

GetBaseColour

Method in class wx.lib.colourchooser.pycolourslider.PyColourSlider

getBaseObject

Function in module wx.py.introspect

GetBasePath

Method in class wx.html.HtmlBookRecord

GetBatchCount

Method in class wx.grid.Grid

GetBeforeColumn

Method in class wx.lib.gridmovers.GridColMoveEvent

GetBeforeRow

Method in class wx.lib.gridmovers.GridRowMoveEvent

GetBeginDST

Method in class wx.DateTime

GetBeginPos

Method in class wx.html.HtmlTag

GetBestFittingSize

Method in class wx.Window

GetBestSize

Method in class wx.Window

GetBestSize

Method in class wx.grid.GridCellRenderer

GetBestSizeTuple

Method in class wx.Window

GetBestVirtualSize

Method in class wx.Window

GetBezelFace

Method in class wx.Gauge

GetBezelWidth

Method in class wx.lib.buttons.GenButton

GetBgColour

Method in class wx.html.HtmlRenderingState

GetBin

Method in class wx.PrintData

GetBitmap

Method in class wx.ArtProvider

GetBitmap

Method in class wx.BitmapDataObject

GetBitmap

Method in class wx.ImageList

GetBitmap

Method in class wx.MenuItem

GetBitmap

Method in class wx.SplashScreenWindow

GetBitmap

Method in class wx.StaticBitmap

GetBitmap

Method in class wx.ToolBarToolBase

GetBitmap

Method in class wx.gizmos.StaticPicture

GetBitmap

Method in class wx.lib.colourchooser.canvas.BitmapBuffer

getBitmap

Function in module wx.lib.colourchooser.pypalette

GetBitmap

Function in module wx.lib.editor.images

GetBitmap

Method in class wx.lib.ogl.BitmapShape

GetBitmap

Method in class wx.lib.statbmp.GenStaticBitmap

GetBitmap

Method in class wx.wizard.WizardPage

GetBitmap

Method in class wx.xrc.XmlResourceHandler

GetBitmapDisabled

Method in class wx.BitmapButton

GetBitmapDisabled

Method in class wx.lib.buttons.GenBitmapButton

GetBitmapFocus

Method in class wx.BitmapButton

GetBitmapFocus

Method in class wx.lib.buttons.GenBitmapButton

GetBitmapLabel

Method in class wx.BitmapButton

GetBitmapLabel

Method in class wx.lib.buttons.GenBitmapButton

GetBitmapSelected

Method in class wx.BitmapButton

GetBitmapSelected

Method in class wx.lib.buttons.GenBitmapButton

getBlankBitmap

Function in module wx.lib.pydocview

getBlankData

Function in module wx.lib.pydocview

getBlankIcon

Function in module wx.lib.pydocview

getBlankImage

Function in module wx.lib.pydocview

GetBlinkTime

Method in class wx.Caret

GetBlue

Method in class wx.Image

GetBold

Method in class wx.lib.hyperlink.HyperLinkCtrl

GetBook

Method in class wx.html.HtmlContentsItem

GetBookFile

Method in class wx.html.HtmlBookRecord

GetBookRecArray

Method in class wx.html.HtmlHelpData

GetBool

Method in class wx.xrc.XmlResourceHandler

GetBorder

Method in class wx.SizerItem

GetBorder

Method in class wx.Window

GetBorder

Method in class wx.calendar.CalendarDateAttr

GetBorderColour

Method in class wx.calendar.CalendarDateAttr

GetBorderSize

Method in class wx.SplitterWindow

GetBorderX

Method in class wx.StatusBar

GetBorderY

Method in class wx.StatusBar

GetBottom

Method in class wx.Rect

GetBottomRight

Method in class wx.Rect

GetBottomRightCoords

Method in class wx.grid.GridRangeSelectEvent

GetBottomRow

Method in class wx.grid.GridRangeSelectEvent

GetBottomSide

Method in class wx.lib.ogl.DivisionShape

GetBoundingBox

Method in class wx.DC

GetBoundingBoxMax

Method in class wx.lib.ogl.Shape

GetBoundingBoxMin

Method in class wx.lib.ogl.EllipseShape

GetBoundingBoxMin

Method in class wx.lib.ogl.LineShape

GetBoundingBoxMin

Method in class wx.lib.ogl.PolygonShape

GetBoundingBoxMin

Method in class wx.lib.ogl.RectangleShape

GetBoundingBoxMin

Method in class wx.lib.ogl.Shape

GetBoundingRect

Method in class wx.TreeCtrl

GetBoundingRect

Method in class wx.gizmos.TreeListCtrl

GetBoundingRect

Method in class wx.lib.colourchooser.canvas.Canvas

GetBounds

Method in class wx.lib.intctrl.IntCtrl

GetBounds

Method in class wx.lib.masked.numctrl.NumCtrl

GetBounds

Method in class wx.lib.masked.timectrl.TimeCtrl

GetBounds

Method in class wx.lib.ogl.PseudoMetaFile

GetBox

Method in class wx.Region

GetBranchingAttachmentInfo

Method in class wx.lib.ogl.Shape

GetBranchingAttachmentPoint

Method in class wx.lib.ogl.Shape

GetBranchingAttachmentRoot

Method in class wx.lib.ogl.Shape

GetBranchStyle

Method in class wx.lib.ogl.Shape

GetBrush

Method in class wx.DC

GetBrush

Method in class wx.lib.ogl.Shape

GetBuffer

Method in class wx.lib.mvctree.Painter

GetBufferedDraw

Method in class wx.stc.StyledTextCtrl

GetButton

Method in class wx.MouseEvent

GetButtonChange

Method in class wx.JoystickEvent

GetButtonObj

Method in class wx.lib.buttons.GenButtonEvent

GetButtonsImageList

Method in class wx.gizmos.TreeListCtrl

GetButtonState

Method in class wx.Joystick

GetButtonState

Method in class wx.JoystickEvent

GetC

Method in class wx.InputStream

GetCacheFrom

Method in class wx.ListEvent

GetCacheTo

Method in class wx.ListEvent

GetCal

Method in class wx.lib.calendar.CalDraw

getCallTip

Method in class wx.py.interpreter.Interpreter

getCallTip

Function in module wx.py.introspect

GetCancelButton

Method in class wx.StdDialogButtonSizer

GetCanonicalName

Method in class wx.Locale

GetCanvas

Method in class wx.PrintPreview

GetCanvas

Method in class wx.lib.ogl.Diagram

GetCanvas

Method in class wx.lib.ogl.Shape

GetCap

Method in class wx.Pen

GetCaptionColour

Method in class wx.lib.foldpanelbar.CaptionBarStyle

GetCaptionFont

Method in class wx.lib.foldpanelbar.CaptionBarStyle

GetCaptionLength

Method in class wx.lib.foldpanelbar.FoldPanelItem

GetCaptionStyle

Method in class wx.lib.foldpanelbar.CaptionBar

GetCaptionStyle

Method in class wx.lib.foldpanelbar.CaptionBarStyle

GetCaptionStyle

Method in class wx.lib.foldpanelbar.FoldPanelBar

GetCaptionStyle

Method in class wx.lib.foldpanelbar.FoldPanelItem

GetCapture

Method in class wx.Window

GetCapturedWindow

Method in class wx.MouseCaptureChangedEvent

GetCaret

Method in class wx.Window

GetCaretForeground

Method in class wx.stc.StyledTextCtrl

GetCaretLineBack

Method in class wx.stc.StyledTextCtrl

GetCaretLineVisible

Method in class wx.stc.StyledTextCtrl

GetCaretPeriod

Method in class wx.stc.StyledTextCtrl

GetCaretWidth

Method in class wx.stc.StyledTextCtrl

GetCellAlignment

Method in class wx.grid.Grid

GetCellAttr

Method in class wx.grid.GridCellEditor

GetCellBackgroundColour

Method in class wx.grid.Grid

GetCellColour

Method in class wx.lib.printout.PrintTableDraw

GetCellDiff

Method in class wx.lib.printout.PrintBase

GetCellEditor

Method in class wx.grid.Grid

GetCellFont

Method in class wx.grid.Grid

GetCellHighlightColour

Method in class wx.grid.Grid

GetCellHighlightPenWidth

Method in class wx.grid.Grid

GetCellHighlightROPenWidth

Method in class wx.grid.Grid

GetCellOverflow

Method in class wx.grid.Grid

GetCellRenderer

Method in class wx.grid.Grid

GetCellSize

Method in class wx.GridBagSizer

GetCellSize

Method in class wx.grid.Grid

GetCellText

Method in class wx.lib.printout.PrintTableDraw

GetCellTextColour

Method in class wx.grid.Grid

GetCellValue

Method in class wx.grid.Grid

GetCentredTextExtent

Function in package wx.lib.ogl

GetCentreResize

Method in class wx.lib.ogl.Shape

GetCentury

Method in class wx.DateTime

GetChangedWindow

Method in class wx.PaletteChangedEvent

GetCharAt

Method in class wx.stc.StyledTextCtrl

GetCharHeight

Method in class wx.DC

GetCharHeight

Method in class wx.Window

GetCharHeight

Method in class wx.html.HtmlWinParser

GetCharWidth

Method in class wx.DC

GetCharWidth

Method in class wx.Window

GetCharWidth

Method in class wx.html.HtmlWinParser

GetChecked

Method in class wx.UpdateUIEvent

GetChildAt

Method in class wx.lib.mvctree.BasicTreeModel

GetChildAt

Method in class wx.lib.mvctree.TreeModel

GetChildCount

Method in class wx.lib.mvctree.BasicTreeModel

GetChildCount

Method in class wx.lib.mvctree.LateFSTreeModel

GetChildCount

Method in class wx.lib.mvctree.TreeModel

GetChildren

Method in class wx.Sizer

GetChildren

Method in class wx.Window

GetChildren

Method in class wx.lib.mvctree.MVCTreeNode

GetChildren

Method in class wx.lib.ogl.Shape

GetChildren

Method in class wx.xrc.XmlNode

GetChildrenCount

Method in class wx.TreeCtrl

GetChildrenCount

Method in class wx.gizmos.TreeListCtrl

GetChoiceCtrl

Method in class wx.Choicebook

GetChoiceRequired

Method in class wx.lib.masked.maskededit.MaskedEditAccessorsMixin

GetChoices

Method in class wx.lib.masked.maskededit.MaskedEditAccessorsMixin

GetChooseFull

Method in class wx.ColourData

GetChosenFont

Method in class wx.FontData

GetClass

Method in class wx.xrc.XmlResourceHandler

GetClassDefaultAttributes

Method in class wx.BookCtrlBase

GetClassDefaultAttributes

Method in class wx.Button

GetClassDefaultAttributes

Method in class wx.CheckBox

GetClassDefaultAttributes

Method in class wx.Choice

GetClassDefaultAttributes

Method in class wx.ComboBox

GetClassDefaultAttributes

Method in class wx.Control

GetClassDefaultAttributes

Method in class wx.Dialog

GetClassDefaultAttributes

Method in class wx.Frame

GetClassDefaultAttributes

Method in class wx.Gauge

GetClassDefaultAttributes

Method in class wx.ListBox

GetClassDefaultAttributes

Method in class wx.ListCtrl

GetClassDefaultAttributes

Method in class wx.Notebook

GetClassDefaultAttributes

Method in class wx.Panel

GetClassDefaultAttributes

Method in class wx.RadioBox

GetClassDefaultAttributes

Method in class wx.RadioButton

GetClassDefaultAttributes

Method in class wx.ScrollBar

GetClassDefaultAttributes

Method in class wx.ScrolledWindow

GetClassDefaultAttributes

Method in class wx.Slider

GetClassDefaultAttributes

Method in class wx.SpinButton

GetClassDefaultAttributes

Method in class wx.SpinCtrl

GetClassDefaultAttributes

Method in class wx.SplitterWindow

GetClassDefaultAttributes

Method in class wx.StaticBitmap

GetClassDefaultAttributes

Method in class wx.StaticBox

GetClassDefaultAttributes

Method in class wx.StaticLine

GetClassDefaultAttributes

Method in class wx.StaticText

GetClassDefaultAttributes

Method in class wx.StatusBar

GetClassDefaultAttributes

Method in class wx.TextCtrl

GetClassDefaultAttributes

Method in class wx.ToggleButton

GetClassDefaultAttributes

Method in class wx.ToolBar

GetClassDefaultAttributes

Method in class wx.TreeCtrl

GetClassDefaultAttributes

Method in class wx.Window

GetClassDefaultAttributes

Method in class wx.calendar.CalendarCtrl

GetClassDefaultAttributes

Method in class wx.grid.Grid

GetClassDefaultAttributes

Method in class wx.html.HtmlWindow

GetClassName

Method in class wx.Object

GetClassName

Method in class wx.PyApp

GetClassName

Method in class wx.lib.ogl.Shape

GetClientAreaOrigin

Method in class wx.Frame

GetClientAreaOrigin

Method in class wx.Window

GetClientData

Method in class wx.ItemContainer

GetClientData

Method in class wx.ToolBarToolBase

GetClientData

Method in class wx.lib.ogl.PopupDivisionMenu

GetClientDisplayRect

Function in package wx

GetClientRect

Method in class wx.Window

GetClientSize

Method in class wx.Window

GetClientSizeTuple

Method in class wx.Window

GetClientWindow

Method in class wx.MDIParentFrame

GetClippingBox

Method in class wx.DC

GetClippingRect

Method in class wx.DC

getClosestPoint

Method in class wx.lib.plot.PolyPoints

GetClosestPoints

Method in class wx.lib.plot.PlotCanvas

GetClosetPoint

Method in class wx.lib.plot.PlotCanvas

GetCodePage

Method in class wx.stc.StyledTextCtrl

GetCol

Method in class wx.GBPosition

GetCol

Method in class wx.grid.GridCellCoords

GetCol

Method in class wx.grid.GridEditorCreatedEvent

GetCol

Method in class wx.grid.GridEvent

GetColLabelAlignment

Method in class wx.grid.Grid

GetColLabelSize

Method in class wx.grid.Grid

GetColLabelTextOrientation

Method in class wx.grid.Grid

GetColLabelValue

Method in class wx.grid.Grid

GetColLabelValue

Method in class wx.grid.GridTableBase

GetCollapsedIconBitmap

Function in module wx.lib.foldpanelbar

GetCollapsedIconData

Function in module wx.lib.foldpanelbar

GetCollapsedIconImage

Function in module wx.lib.foldpanelbar

GetCollate

Method in class wx.PrintData

GetCollate

Method in class wx.PrintDialogData

GetColMinimalAcceptableWidth

Method in class wx.grid.Grid

GetColor

Method in class wx.lib.calendar.CalDraw

GetColor

Method in class wx.lib.calendar.Calendar

GetColors

Method in class wx.lib.intctrl.IntCtrl

GetColour

Method in class wx.Brush

GetColour

Method in class wx.ColourData

GetColour

Method in class wx.FontData

GetColour

Method in class wx.Pen

GetColour

Method in class wx.PrintData

GetColour

Method in class wx.SystemSettings

GetColour

Method in class wx.lib.colourchooser.pycolourbox.PyColourBox

GetColour

Method in class wx.lib.colourselect.ColourSelect

GetColour

Method in class wx.lib.ogl.ShapeRegion

GetColour

Method in class wx.lib.printout.PrintTable

GetColour

Method in class wx.xrc.XmlResourceHandler

GetColourBox

Method in class wx.lib.colourchooser.pycolourbox.PyColourBox

GetColourData

Method in class wx.ColourDialog

getColourInfoList

Function in module wx.lib.colourdb

getColourList

Function in module wx.lib.colourdb

GetColours

Method in class wx.lib.hyperlink.HyperLinkCtrl

GetColoursCount

Method in class wx.Palette

GetCols

Method in class wx.GridSizer

GetColSize

Method in class wx.grid.Grid

GetColspan

Method in class wx.GBSpan

GetColumn

Method in class wx.ListCtrl

GetColumn

Method in class wx.ListEvent

GetColumn

Method in class wx.ListItem

GetColumn

Method in class wx.gizmos.TreeListCtrl

GetColumn

Method in class wx.stc.StyledTextCtrl

GetColumnAlignment

Method in class wx.gizmos.TreeListCtrl

GetColumnCount

Method in class wx.ListCtrl

GetColumnCount

Method in class wx.RadioBox

GetColumnCount

Method in class wx.gizmos.TreeListCtrl

GetColumnImage

Method in class wx.gizmos.TreeListCtrl

GetColumns

Method in class wx.lib.grids.PyGridSizer

GetColumnSorter

Method in class wx.lib.mixins.listctrl.ColumnSorterMixin

GetColumnText

Method in class wx.gizmos.TreeListCtrl

GetColumnWidth

Method in class wx.ListCtrl

GetColumnWidth

Method in class wx.gizmos.TreeListCtrl

GetColumnWidths

Method in class wx.lib.mixins.listctrl.ColumnSorterMixin

GetColWidths

Method in class wx.FlexGridSizer

GetComCtl32Version

Method in class wx.PyApp

GetCommand

Method in class wx.AcceleratorEntry

getCommand

Method in class wx.py.shell.Shell

GetCommandInt

Method in class wx.grid.GridTableMessage

GetCommandInt2

Method in class wx.grid.GridTableMessage

GetCommandProcessor

Method in class wx.lib.docview.Document

GetCommands

Method in class wx.lib.docview.CommandProcessor

GetCompanionWindow

Method in class wx.gizmos.RemotelyScrolledTreeCtrl

GetCompareNoCase

Method in class wx.lib.masked.maskededit.MaskedEditAccessorsMixin

GetConfigDir

Method in class wx.StandardPaths

GetConstraints

Method in class wx.Window

GetConstraints

Method in class wx.lib.ogl.CompositeShape

getConstructor

Function in module wx.py.introspect

GetContainer

Method in class wx.html.HtmlWinParser

GetContainingSizer

Method in class wx.Window

GetContent

Method in class wx.xrc.XmlNode

GetContents

Method in class wx.html.HtmlHelpData

GetContentsCnt

Method in class wx.html.HtmlHelpData

GetContentsEnd

Method in class wx.html.HtmlBookRecord

GetContentsItem

Method in class wx.html.HtmlSearchStatus

GetContentsStart

Method in class wx.html.HtmlBookRecord

GetContext

Method in class wx.glcanvas.GLCanvas

GetControl

Method in class wx.BookCtrlSizer

GetControl

Method in class wx.ToolBarToolBase

GetControl

Method in class wx.grid.GridCellEditor

GetControl

Method in class wx.grid.GridEditorCreatedEvent

GetControl

Method in class wx.stc.StyledTextEvent

GetControlBar

Method in class wx.PreviewFrame

GetControlCharSymbol

Method in class wx.stc.StyledTextCtrl

getCopyBitmap

Function in module wx.lib.pydocview

getCopyData

Function in module wx.lib.pydocview

getCopyImage

Function in module wx.lib.pydocview

GetCornerRadius

Method in class wx.lib.ogl.RectangleShape

GetCount

Method in class wx.BrushList

GetCount

Method in class wx.Display

GetCount

Method in class wx.FileHistory

GetCount

Method in class wx.FontList

GetCount

Method in class wx.ImageHistogram

GetCount

Method in class wx.ItemContainer

GetCount

Method in class wx.PenList

GetCount

Method in class wx.RadioBox

GetCount

Method in class wx.TreeCtrl

GetCount

Method in class wx.gizmos.TreeListCtrl

GetCount

Method in class wx.lib.foldpanelbar.FoldPanelBar

GetCount

Method in class wx.lib.ogl.Diagram

GetCountColour

Method in class wx.ImageHistogram

GetCountPerPage

Method in class wx.ListCtrl

GetCountRGB

Method in class wx.ImageHistogram

GetCountry

Method in class wx.DateTime

GetCrossProduct

Method in class wx.Point2D

GetCtrlParameter

Method in class wx.lib.masked.maskededit.MaskedEditMixin

GetCurFileSystem

Method in class wx.xrc.XmlResourceHandler

GetCurIndex

Method in class wx.html.HtmlSearchStatus

GetCurLine

Method in class wx.stc.StyledTextCtrl

GetCurLineRaw

Method in class wx.stc.StyledTextCtrl

GetCurLineUTF8

Method in class wx.stc.StyledTextCtrl

GetCurrentDocument

Method in class wx.lib.docview.DocManager

getCurrentExtent

Method in class wx.lib.mixins.rubberband.RubberBand

GetCurrentFocus

Method in class wx.NavigationKeyEvent

GetCurrentFrame

Method in class wx.animate.AnimationPlayer

GetCurrentId

Function in package wx

GetCurrentLine

Method in class wx.stc.StyledTextCtrl

GetCurrentMode

Method in class wx.Display

GetCurrentMonth

Method in class wx.DateTime

GetCurrentPage

Method in class wx.BookCtrlBase

GetCurrentPage

Method in class wx.PrintPreview

GetCurrentPage

Method in class wx.wizard.Wizard

GetCurrentPos

Method in class wx.stc.StyledTextCtrl

GetCurrentRoot

Method in class wx.lib.mvctree.MVCTree

GetCurrentTime

Function in package wx

GetCurrentTip

Method in class wx.TipProvider

GetCurrentView

Method in class wx.lib.docview.DocManager

GetCurrentYear

Method in class wx.DateTime

GetCursor

Method in class wx.SetCursorEvent

GetCursor

Method in class wx.Window

GetCursor

Method in class wx.html.HtmlCell

getCursorPosition

Function in module wx.lib.mixins.rubberband

GetCustomBackgroundColour

Method in class wx.animate.AnimationPlayer

GetCustomColour

Method in class wx.ColourData

GetCustomEventHandlers

Method in class wx.lib.pydocview.FilePropertiesService

GetCustomScale

Method in class wx.gizmos.StaticPicture

getCutBitmap

Function in module wx.lib.pydocview

getCutData

Function in module wx.lib.pydocview

getCutImage

Function in module wx.lib.pydocview

GetDarkShadow

Method in class wx.Effects

GetDashCount

Method in class wx.Pen

GetDashes

Method in class wx.Pen

GetDashPen

Method in class wx.lib.mvctree.TreePainter

GetData

Method in class wx.Clipboard

GetData

Method in class wx.CustomDataObject

GetData

Method in class wx.DropTarget

GetData

Method in class wx.FindReplaceDialog

GetData

Method in class wx.Image

GetData

Method in class wx.ListEvent

GetData

Method in class wx.ListItem

GetData

Method in class wx.TreeItemData

GetData

Method in class wx.html.HtmlHelpFrame

getData

Function in module wx.lib.colourchooser.pypalette

GetData

Method in class wx.lib.pydocview.ChildDocument

GetDataBuffer

Method in class wx.Image

GetDataDir

Method in class wx.StandardPaths

GetDataHere

Method in class wx.DataObject

GetDataHere

Method in class wx.DataObjectSimple

GetDataObject

Method in class wx.DropSource

GetDataObject

Method in class wx.DropTarget

GetDataSize

Method in class wx.DataObject

GetDataSize

Method in class wx.DataObjectSimple

GetDate

Method in class wx.DateEvent

GetDate

Method in class wx.calendar.CalendarCtrl

GetDate

Method in class wx.lib.calendar.Calendar

GetDate

Method in class wx.lib.printout.PrintBase

GetDatestyle

Method in class wx.lib.masked.maskededit.MaskedEditAccessorsMixin

GetDateTime

Method in class wx.lib.printout.PrintBase

GetDay

Method in class wx.DateTime

GetDay

Method in class wx.lib.calendar.Calendar

GetDayHit

Method in class wx.lib.calendar.Calendar

GetDayOfYear

Method in class wx.DateTime

GetDays

Method in class wx.DateSpan

GetDays

Method in class wx.TimeSpan

GetDC

Method in class wx.EraseEvent

GetDC

Method in class wx.Printout

GetDC

Method in class wx.html.HtmlWinParser

GetDeadTopics

Method in class wx.lib.evtmgr.EventManager

GetDebug

Method in class wx.lib.pydocview.DocApp

GetDecimalChar

Method in class wx.lib.masked.maskededit.MaskedEditAccessorsMixin

GetDecimalChar

Method in class wx.lib.masked.numctrl.NumCtrl

GetDecimalChar

Method in class wx.lib.masked.numctrl.NumCtrlAccessorsMixin

GetDefaultAction

Method in class wx.DropTarget

GetDefaultAttributes

Method in class wx.Window

GetDefaultAttributes

Method in class wx.lib.buttons.GenButton

GetDefaultAttributes

Method in class wx.lib.statbmp.GenStaticBitmap

GetDefaultAttributes

Method in class wx.lib.stattext.GenStaticText

GetDefaultBorderSize

Method in class wx.SashWindow

GetDefaultCellAlignment

Method in class wx.grid.Grid

GetDefaultCellBackgroundColour

Method in class wx.grid.Grid

GetDefaultCellFont

Method in class wx.grid.Grid

GetDefaultCellOverflow

Method in class wx.grid.Grid

GetDefaultCellTextColour

Method in class wx.grid.Grid

GetDefaultColLabelSize

Method in class wx.grid.Grid

GetDefaultColSize

Method in class wx.grid.Grid

GetDefaultConfigPath

Method in class wx.FontMapper

GetDefaultDocManagerFlags

Method in class wx.lib.pydocview.DocApp

GetDefaultEditor

Method in class wx.grid.Grid

GetDefaultEditorForCell

Method in class wx.grid.Grid

GetDefaultEditorForType

Method in class wx.grid.Grid

GetDefaultEncoding

Method in class wx.Font

GetDefaultEncoding

Method in class wx.lib.masked.maskededit.MaskedEditAccessorsMixin

GetDefaultExtension

Method in class wx.lib.docview.DocTemplate

GetDefaultIcon

Method in class wx.lib.pydocview.DocApp

GetDefaultInfo

Method in class wx.PageSetupDialogData

GetDefaultItem

Method in class wx.Window

GetDefaultMarginWidth

Method in class wx.MenuItem

GetDefaultMinMargins

Method in class wx.PageSetupDialogData

GetDefaultPath

Method in class wx.GenericDirCtrl

GetDefaultPyEncoding

Function in package wx

GetDefaultRenderer

Method in class wx.grid.Grid

GetDefaultRendererForCell

Method in class wx.grid.Grid

GetDefaultRendererForType

Method in class wx.grid.Grid

GetDefaultRowLabelSize

Method in class wx.grid.Grid

GetDefaultRowSize

Method in class wx.grid.Grid

GetDefaultSize

Method in class wx.Button

GetDefaultSize

Method in class wx.StaticLine

GetDefaultStyle

Method in class wx.TextCtrl

GetDefaultValue

Method in class wx.lib.masked.ipaddrctrl.IpAddrCtrlAccessorsMixin

GetDefaultValue

Method in class wx.lib.masked.maskededit.MaskedEditAccessorsMixin

GetDefaultValue

Method in class wx.lib.masked.numctrl.NumCtrlAccessorsMixin

GetDefaultValue

Method in class wx.lib.masked.timectrl.TimeCtrlAccessorsMixin

GetDelay

Method in class wx.animate.AnimationBase

GetDelay

Method in class wx.animate.AnimationPlayer

GetDelay

Method in class wx.animate.GIFAnimation

GetDelButton

Method in class wx.gizmos.EditableListBox

GetDemo

Method in class wx.lib.masked.maskededit.MaskedEditAccessorsMixin

GetDepth

Method in class wx.Bitmap

GetDepth

Method in class wx.DC

GetDepth

Method in class wx.Icon

GetDepth

Method in class wx.VideoMode

GetDepth

Method in class wx.html.HtmlCell

GetDescent

Method in class wx.html.HtmlCell

GetDescription

Method in class wx.FileType

GetDescription

Method in class wx.FileTypeInfo

GetDescription

Method in class wx.lib.docview.DocTemplate

GetDescription

Method in class wx.lib.masked.ipaddrctrl.IpAddrCtrlAccessorsMixin

GetDescription

Method in class wx.lib.masked.maskededit.MaskedEditAccessorsMixin

GetDescription

Method in class wx.lib.masked.numctrl.NumCtrlAccessorsMixin

GetDescription

Method in class wx.lib.masked.timectrl.TimeCtrlAccessorsMixin

GetDestroyAnimation

Method in class wx.animate.AnimationPlayer

GetDeviceOrigin

Method in class wx.DC

GetDeviceOriginTuple

Method in class wx.DC

GetDiagram

Method in class wx.lib.ogl.ShapeCanvas

GetDialog

Method in class wx.FindDialogEvent

GetDimension

Method in class wx.xrc.XmlResourceHandler

GetDirection

Method in class wx.NavigationKeyEvent

GetDirection

Method in class wx.lib.gestures.MouseGestures

GetDirection

Method in class wx.lib.ticker.Ticker

GetDirection

Method in class wx.wizard.WizardEvent

GetDirectory

Method in class wx.FileDialog

GetDirectory

Method in class wx.lib.docview.DocTemplate

GetDirectory

Method in class wx.lib.imagebrowser.ImageDialog

GetDisabledBitmap

Method in class wx.MenuItem

GetDisabledBitmap

Method in class wx.ToolBarToolBase

GetDisableLabel

Method in class wx.lib.ogl.Shape

GetDisplayDepth

Function in package wx

GetDisplaySize

Function in package wx

GetDisplaySizeMM

Function in package wx

GetDisplayText

Method in class wx.lib.mvctree.MVCTree

GetDisposalMethod

Method in class wx.animate.AnimationBase

GetDisposalMethod

Method in class wx.animate.AnimationPlayer

GetDisposalMethod

Method in class wx.animate.GIFAnimation

GetDistance

Method in class wx.Point2D

GetDistanceSquare

Method in class wx.Point2D

GetDivisions

Method in class wx.lib.ogl.CompositeShape

GetDocManager

Method in class wx.lib.pydocview.OptionsDialog

GetDocPointer

Method in class wx.stc.StyledTextCtrl

GetDocument

Method in class wx.lib.docview.DocChildFrame

GetDocument

Method in class wx.lib.docview.DocMDIChildFrame

GetDocument

Method in class wx.lib.docview.View

GetDocument

Method in class wx.lib.pydocview.DocMDIChildFrame

GetDocument

Method in class wx.lib.pydocview.DocTabbedChildFrame

GetDocumentManager

Method in class wx.lib.docview.DocTemplate

GetDocumentManager

Method in class wx.lib.docview.Document

GetDocumentManager

Method in class wx.lib.docview.View

GetDocumentManager

Method in class wx.lib.pydocview.DocApp

GetDocumentManager

Method in class wx.lib.pydocview.DocFrameMixIn

GetDocumentManager

Method in class wx.lib.pydocview.DocService

GetDocumentModificationDate

Method in class wx.lib.docview.Document

GetDocumentName

Method in class wx.lib.docview.DocTemplate

GetDocumentName

Method in class wx.lib.docview.Document

GetDocuments

Method in class wx.lib.docview.DocManager

GetDocumentSaved

Method in class wx.lib.docview.Document

GetDocumentTemplate

Method in class wx.lib.docview.Document

GetDocumentType

Method in class wx.lib.docview.DocTemplate

GetDocumentWindow

Method in class wx.lib.docview.Document

GetDone

Method in class wx.IndividualLayoutConstraint

GetDotProduct

Method in class wx.Point2D

GetDownButton

Method in class wx.gizmos.EditableListBox

GetDragAllowMove

Method in class wx.stc.StyledTextEvent

GetDragRect

Method in class wx.SashEvent

GetDragResult

Method in class wx.stc.StyledTextEvent

GetDragStatus

Method in class wx.SashEvent

GetDragText

Method in class wx.stc.StyledTextEvent

GetDrawFaded

Method in class wx.gizmos.LEDNumberCtrl

GetDrawHandles

Method in class wx.lib.ogl.Shape

GetDropTarget

Method in class wx.Window

GetDuplex

Method in class wx.PrintData

GetEdge

Method in class wx.IndividualLayoutConstraint

GetEdge

Method in class wx.SashEvent

GetEdgeColour

Method in class wx.stc.StyledTextCtrl

GetEdgeColumn

Method in class wx.stc.StyledTextCtrl

GetEdgeMargin

Method in class wx.SashWindow

GetEdgeMode

Method in class wx.stc.StyledTextCtrl

GetEditButton

Method in class wx.gizmos.EditableListBox

GetEditControl

Method in class wx.TreeCtrl

GetEditMenu

Method in class wx.lib.docview.CommandProcessor

GetEditMenu

Method in class wx.lib.pydocview.DocApp

GetEditor

Method in class wx.grid.GridCellAttr

GetElapsedTime

Function in package wx

GetEmailAddress

Function in package wx

GetEmbeddedWindow

Method in class wx.lib.pydocview.DocMDIParentFrameMixIn

GetEmptyBackgroundColour

Method in class wx.lib.masked.ipaddrctrl.IpAddrCtrlAccessorsMixin

GetEmptyBackgroundColour

Method in class wx.lib.masked.maskededit.MaskedEditAccessorsMixin

GetEmptyBackgroundColour

Method in class wx.lib.masked.numctrl.NumCtrlAccessorsMixin

GetEmptyBackgroundColour

Method in class wx.lib.masked.timectrl.TimeCtrlAccessorsMixin

GetEmptyCellSize

Method in class wx.GridBagSizer

GetEmptyInvalid

Method in class wx.lib.masked.ipaddrctrl.IpAddrCtrlAccessorsMixin

GetEmptyInvalid

Method in class wx.lib.masked.maskededit.MaskedEditAccessorsMixin

GetEmptyInvalid

Method in class wx.lib.masked.numctrl.NumCtrlAccessorsMixin

GetEnabled

Method in class wx.UpdateUIEvent

GetEnableEffects

Method in class wx.FontData

GetEnableGrid

Method in class wx.lib.plot.PlotCanvas

GetEnableHelp

Method in class wx.PageSetupDialogData

GetEnableHelp

Method in class wx.PrintDialogData

GetEnableLegend

Method in class wx.lib.plot.PlotCanvas

GetEnableMargins

Method in class wx.PageSetupDialogData

GetEnableOrientation

Method in class wx.PageSetupDialogData

GetEnablePageNumbers

Method in class wx.PrintDialogData

GetEnablePaper

Method in class wx.PageSetupDialogData

GetEnablePointLabel

Method in class wx.lib.plot.PlotCanvas

GetEnablePrinter

Method in class wx.PageSetupDialogData

GetEnablePrintToFile

Method in class wx.PrintDialogData

GetEnableSelection

Method in class wx.PrintDialogData

GetEnableZoom

Method in class wx.lib.plot.PlotCanvas

GetEncoding

Method in class wx.Font

GetEncoding

Method in class wx.FontMapper

GetEncoding

Method in class wx.NativeFontInfo

GetEncodingDescription

Method in class wx.FontMapper

GetEncodingFromName

Method in class wx.FontMapper

GetEncodingName

Method in class wx.FontMapper

GetEncodings

Method in class wx.FontEnumerator

GetEndAtLastLine

Method in class wx.stc.StyledTextCtrl

GetEndDST

Method in class wx.DateTime

GetEndPos

Method in class wx.GBSizerItem

GetEndPos1

Method in class wx.html.HtmlTag

GetEndPos2

Method in class wx.html.HtmlTag

GetEnds

Method in class wx.lib.ogl.LineShape

GetEndStyled

Method in class wx.stc.StyledTextCtrl

GetEntryType

Method in class wx.ConfigBase

GetEOLMode

Method in class wx.stc.StyledTextCtrl

GetErrorStream

Method in class wx.Process

GetEvent

Method in class wx.html.HtmlLinkInfo

GetEventHandler

Method in class wx.Menu

GetEventHandler

Method in class wx.Window

GetEventHandler

Method in class wx.lib.ogl.Shape

GetEventObject

Method in class wx.Event

GetEventType

Method in class wx.Event

getEventTypes

Method in class wx.lib.evtmgr.EventMacroInfo

GetEvtHandlerEnabled

Method in class wx.EvtHandler

GetExcludeChars

Method in class wx.lib.masked.maskededit.MaskedEditAccessorsMixin

GetExitCode

Method in class wx.ProcessEvent

GetExitOnFrameDelete

Method in class wx.PyApp

GetExpandedIconBitmap

Function in module wx.lib.foldpanelbar

GetExpandedIconData

Function in module wx.lib.foldpanelbar

GetExpandedIconImage

Function in module wx.lib.foldpanelbar

GetExtension

Method in class wx.ImageHandler

GetExtensions

Method in class wx.FileType

GetExtensions

Method in class wx.FileTypeInfo

GetExtensionsCount

Method in class wx.FileTypeInfo

GetExtent

Function in module wx.lib.fancytext

GetExtraBorderSize

Method in class wx.SashWindow

GetExtraLong

Method in class wx.CommandEvent

GetExtraStyle

Method in class wx.Window

GetFaceColour

Method in class wx.Effects

GetFaceName

Method in class wx.Font

GetFaceName

Method in class wx.NativeFontInfo

GetFacenames

Method in class wx.FontEnumerator

GetFamily

Method in class wx.Font

GetFamily

Method in class wx.NativeFontInfo

GetFamilyString

Method in class wx.Font

GetFgColour

Method in class wx.html.HtmlRenderingState

GetFieldParameter

Method in class wx.lib.masked.maskededit.MaskedEditMixin

GetFieldRect

Method in class wx.StatusBar

GetFields

Method in class wx.lib.masked.ipaddrctrl.IpAddrCtrlAccessorsMixin

GetFields

Method in class wx.lib.masked.maskededit.MaskedEditAccessorsMixin

GetFieldsCount

Method in class wx.StatusBar

GetFile

Method in class wx.lib.imagebrowser.ImageDialog

GetFileEncoding

Method in class wx.xrc.XmlDocument

GetFileFilter

Method in class wx.lib.docview.DocTemplate

GetFileHistory

Method in class wx.lib.docview.DocManager

GetFilename

Method in class wx.FileDialog

GetFileName

Method in class wx.IconLocation

GetFilename

Method in class wx.PrintData

GetFilename

Method in class wx.animate.GIFAnimationCtrl

GetFilename

Method in class wx.lib.docview.Document

GetFilename

Method in class wx.lib.ogl.BitmapShape

GetFilenames

Method in class wx.FileDataObject

GetFilenames

Method in class wx.FileDialog

GetFilePath

Method in class wx.GenericDirCtrl

GetFiles

Method in class wx.DropFilesEvent

GetFiles

Method in class wx.lib.imagebrowser.ImageDialog

GetFileSystem

Method in class wx.HtmlListBox

GetFileTypeFromExtension

Method in class wx.MimeTypesManager

GetFileTypeFromMimeType

Method in class wx.MimeTypesManager

GetFillBrush

Method in class wx.lib.ogl.PseudoMetaFile

GetFillChar

Method in class wx.lib.masked.ipaddrctrl.IpAddrCtrlAccessorsMixin

GetFillChar

Method in class wx.lib.masked.maskededit.MaskedEditAccessorsMixin

GetFillColours

Method in class wx.lib.ogl.PseudoMetaFile

GetFilter

Method in class wx.GenericDirCtrl

GetFilterIndex

Method in class wx.FileDialog

GetFilterIndex

Method in class wx.GenericDirCtrl

GetFilterListCtrl

Method in class wx.GenericDirCtrl

GetFindString

Method in class wx.FindDialogEvent

GetFindString

Method in class wx.FindReplaceData

GetFirstChild

Method in class wx.TreeCtrl

GetFirstChild

Method in class wx.gizmos.TreeListCtrl

GetFirstChild

Method in class wx.html.HtmlCell

GetFirstChild

Method in class wx.html.HtmlContainerCell

GetFirstColour

Method in class wx.lib.foldpanelbar.CaptionBarStyle

GetFirstEntry

Method in class wx.ConfigBase

GetFirstGroup

Method in class wx.ConfigBase

GetFirstSelected

Method in class wx.ListCtrl

GetFirstSelected

Method in class wx.ListView

GetFirstSelected

Method in class wx.VListBox

GetFirstTerminal

Method in class wx.html.HtmlCell

GetFirstView

Method in class wx.lib.docview.Document

GetFirstVisibleItem

Method in class wx.TreeCtrl

GetFirstVisibleItem

Method in class wx.gizmos.TreeListCtrl

GetFirstVisibleLine

Method in class wx.VScrolledWindow

GetFirstVisibleLine

Method in class wx.stc.StyledTextCtrl

GetFixedHeight

Method in class wx.lib.ogl.Shape

GetFixedSize

Method in class wx.lib.ogl.Shape

GetFixedWidth

Method in class wx.lib.ogl.Shape

GetFlag

Method in class wx.SizerItem

GetFlags

Method in class wx.AcceleratorEntry

GetFlags

Method in class wx.CalculateLayoutEvent

GetFlags

Method in class wx.FindDialogEvent

GetFlags

Method in class wx.FindReplaceData

GetFlags

Method in class wx.QueryLayoutInfoEvent

GetFlags

Method in class wx.TextAttr

GetFlags

Method in class wx.lib.docview.DocManager

GetFlags

Method in class wx.lib.docview.DocTemplate

GetFlags

Method in class wx.xrc.XmlResource

GetFlexibleDirection

Method in class wx.FlexGridSizer

GetFloor

Method in class wx.Point2D

GetFocusedItem

Method in class wx.ListCtrl

GetFocusedItem

Method in class wx.ListView

GetFoldExpanded

Method in class wx.stc.StyledTextCtrl

GetFoldLevel

Method in class wx.stc.StyledTextCtrl

GetFoldLevelNow

Method in class wx.stc.StyledTextEvent

GetFoldLevelPrev

Method in class wx.stc.StyledTextEvent

GetFoldPanel

Method in class wx.lib.foldpanelbar.FoldPanelBar

GetFoldParent

Method in class wx.stc.StyledTextCtrl

GetFoldStatus

Method in class wx.lib.foldpanelbar.CaptionBarEvent

GetFont

Method in class wx.DC

GetFont

Method in class wx.ListItem

GetFont

Method in class wx.ListItemAttr

GetFont

Method in class wx.MenuItem

GetFont

Method in class wx.SystemSettings

GetFont

Method in class wx.TextAttr

GetFont

Method in class wx.Window

GetFont

Method in class wx.calendar.CalendarDateAttr

GetFont

Method in class wx.grid.GridCellAttr

GetFont

Method in class wx.lib.mvctree.MVCTree

GetFont

Method in class wx.lib.mvctree.Painter

GetFont

Method in class wx.lib.ogl.Shape

GetFont

Method in class wx.lib.ogl.ShapeRegion

GetFont

Method in class wx.xrc.XmlResourceHandler

GetFontBold

Method in class wx.html.HtmlWinParser

GetFontColour

Method in class wx.lib.printout.PrintBase

GetFontData

Method in class wx.FontDialog

GetFontFixed

Method in class wx.html.HtmlWinParser

GetFontItalic

Method in class wx.html.HtmlWinParser

GetFontMetricPath

Method in class wx.PrintData

GetFontSize

Method in class wx.html.HtmlWinParser

GetFontSizeAxis

Method in class wx.lib.plot.PlotCanvas

GetFontSizeLegend

Method in class wx.lib.plot.PlotCanvas

GetFontSizeTitle

Method in class wx.lib.plot.PlotCanvas

GetFontUnderlined

Method in class wx.html.HtmlWinParser

GetForegroundBrush

Method in class wx.lib.mvctree.Painter

GetForegroundColour

Method in class wx.Window

GetForegroundColour

Method in class wx.lib.mvctree.MVCTree

GetForegroundColour

Method in class wx.lib.mvctree.Painter

GetForegroundPen

Method in class wx.lib.mvctree.Painter

GetFormat

Method in class wx.DataObjectSimple

GetFormat

Method in class wx.lib.masked.timectrl.TimeCtrl

GetFormatcodes

Method in class wx.lib.masked.ipaddrctrl.IpAddrCtrlAccessorsMixin

GetFormatcodes

Method in class wx.lib.masked.maskededit.MaskedEditAccessorsMixin

GetFormatCount

Method in class wx.DataObject

GetFormatMode

Method in class wx.lib.ogl.Shape

GetFormatMode

Method in class wx.lib.ogl.ShapeRegion

GetFormattedText

Method in class wx.lib.ogl.ShapeRegion

GetFPS

Method in class wx.lib.ticker.Ticker

GetFraction

Method in class wx.lib.masked.numctrl.NumCtrl

GetFractionWidth

Method in class wx.lib.masked.numctrl.NumCtrl

GetFrame

Method in class wx.LogWindow

GetFrame

Method in class wx.MenuBar

GetFrame

Method in class wx.PrintPreview

GetFrame

Method in class wx.animate.AnimationBase

GetFrame

Method in class wx.animate.AnimationPlayer

GetFrame

Method in class wx.animate.GIFAnimation

GetFrame

Method in class wx.html.HtmlHelpController

GetFrame

Method in class wx.lib.docview.View

GetFrameCount

Method in class wx.animate.AnimationBase

GetFrameCount

Method in class wx.animate.AnimationPlayer

GetFrameCount

Method in class wx.animate.GIFAnimation

GetFrameRect

Method in class wx.animate.AnimationBase

GetFrameRect

Method in class wx.animate.AnimationPlayer

GetFrameRect

Method in class wx.animate.GIFAnimation

GetFreeMemory

Function in package wx

GetFrom

Method in class wx.lib.ogl.LineShape

GetFromCell

Method in class wx.html.HtmlSelection

GetFromPage

Method in class wx.PrintDialogData

GetFromPoint

Method in class wx.Display

GetFromPos

Method in class wx.html.HtmlSelection

GetFromPrivPos

Method in class wx.html.HtmlSelection

GetFromWindow

Method in class wx.Display

GetFS

Method in class wx.html.HtmlParser

GetFullExtent

Function in module wx.lib.fancytext

GetFullHostName

Function in package wx

getFullName

Method in class wx.py.filling.FillingTree

GetFullPath

Method in class wx.html.HtmlBookRecord

GetFullTextExtent

Method in class wx.DC

GetFullTextExtent

Method in class wx.Window

GetGBSizer

Method in class wx.GBSizerItem

GetGeometry

Method in class wx.Display

GetGrandParent

Method in class wx.Window

GetGreen

Method in class wx.Image

GetGridColLabelWindow

Method in class wx.grid.Grid

GetGridCornerLabelWindow

Method in class wx.grid.Grid

GetGridCursorCol

Method in class wx.grid.Grid

GetGridCursorRow

Method in class wx.grid.Grid

GetGridLineColour

Method in class wx.grid.Grid

GetGridRowLabelWindow

Method in class wx.grid.Grid

GetGridSpacing

Method in class wx.lib.ogl.Diagram

GetGridWindow

Method in class wx.grid.Grid

GetGroupChar

Method in class wx.lib.masked.maskededit.MaskedEditAccessorsMixin

GetGroupChar

Method in class wx.lib.masked.numctrl.NumCtrl

GetGroupChar

Method in class wx.lib.masked.numctrl.NumCtrlAccessorsMixin

GetGroupDigits

Method in class wx.lib.masked.numctrl.NumCtrl

GetH

Method in class wx.RegionIterator

GetHandBitmap

Function in module wx.lib.floatcanvas.Resources

GetHandData

Function in module wx.lib.floatcanvas.Resources

GetHandle

Method in class wx.Window

GetHandleSide

Method in class wx.lib.ogl.DivisionShape

GetHeaderColourBg

Method in class wx.calendar.CalendarCtrl

GetHeaderColourFg

Method in class wx.calendar.CalendarCtrl

GetHeaderWindow

Method in class wx.gizmos.TreeListCtrl

GetHeight

Method in class wx.Bitmap

GetHeight

Method in class wx.Icon

GetHeight

Method in class wx.Image

GetHeight

Method in class wx.Rect

GetHeight

Method in class wx.RegionIterator

GetHeight

Method in class wx.Size

GetHeight

Method in class wx.VideoMode

GetHeight

Method in class wx.html.HtmlCell

GetHeight

Method in class wx.lib.ogl.EllipseShape

GetHeight

Method in class wx.lib.ogl.RectangleShape

GetHeight

Method in class wx.lib.ogl.ShapeRegion

getHeight

Method in class wx.lib.printout.PrintBase

GetHelp

Method in class wx.HelpProvider

GetHelp

Method in class wx.MenuItem

GetHelpButton

Method in class wx.StdDialogButtonSizer

GetHelpString

Method in class wx.Menu

GetHelpString

Method in class wx.MenuBar

GetHelpText

Method in class wx.Window

GetHGap

Method in class wx.GridSizer

GetHgap

Method in class wx.lib.grids.PyGridSizer

GetHighlightColour

Method in class wx.Effects

GetHighlightColourBg

Method in class wx.calendar.CalendarCtrl

GetHighlightColourFg

Method in class wx.calendar.CalendarCtrl

GetHighlightGuide

Method in class wx.stc.StyledTextCtrl

GetHistory

Method in class wx.lib.filebrowsebutton.FileBrowseButtonWithHistory

GetHistoryControl

Method in class wx.lib.filebrowsebutton.FileBrowseButtonWithHistory

GetHistoryFile

Method in class wx.FileHistory

GetHistoryFile

Method in class wx.lib.docview.DocManager

GetHistoryFilesCount

Method in class wx.lib.docview.DocManager

GetHolidayColourBg

Method in class wx.calendar.CalendarCtrl

GetHolidayColourFg

Method in class wx.calendar.CalendarCtrl

GetHomeDir

Function in package wx

GetHostName

Function in package wx

GetHour

Method in class wx.DateTime

GetHours

Method in class wx.TimeSpan

GetHref

Method in class wx.html.HtmlLinkInfo

GetHScrollBar

Method in class wx.gizmos.DynamicSashWindow

GetHtmlCell

Method in class wx.html.HtmlLinkInfo

GetIcon

Method in class wx.ArtProvider

GetIcon

Method in class wx.FileType

GetIcon

Method in class wx.IconBundle

GetIcon

Method in class wx.ImageList

GetIcon

Method in class wx.TopLevelWindow

GetIcon

Method in class wx.gizmos.StaticPicture

GetIcon

Method in class wx.lib.docview.DocTemplate

GetIcon

Method in class wx.lib.mixins.imagelist.MagicImageList

GetIcon

Method in class wx.lib.pydocview.DocTabbedChildFrame

GetIcon

Method in class wx.xrc.XmlResourceHandler

GetIconFile

Method in class wx.FileTypeInfo

GetIconIndex

Method in class wx.FileTypeInfo

GetIconInfo

Method in class wx.FileType

GetIcons

Method in class wx.lib.mixins.imagelist.MagicImageList

GetId

Method in class wx.DataFormat

GetId

Method in class wx.Event

GetId

Method in class wx.ListItem

GetId

Method in class wx.MenuItem

GetId

Method in class wx.Timer

GetId

Method in class wx.ToolBarToolBase

GetId

Method in class wx.TreeItemData

GetId

Method in class wx.Window

GetId

Method in class wx.grid.GridTableMessage

GetId

Method in class wx.html.HtmlCell

GetID

Method in class wx.html.HtmlContentsItem

GetId

Method in class wx.lib.ogl.ArrowHead

GetId

Method in class wx.lib.ogl.Shape

GetID

Method in class wx.xrc.XmlResourceHandler

GetImage

Method in class wx.ListEvent

GetImage

Method in class wx.ListItem

GetImage

Method in class wx.gizmos.TreeListColumnInfo

getImage

Function in module wx.lib.colourchooser.pypalette

GetImage

Function in module wx.lib.editor.images

GetImageCount

Method in class wx.Image

GetImageCount

Method in class wx.ImageList

GetImageExtWildcard

Method in class wx.Image

GetImageList

Method in class wx.BookCtrlBase

GetImageList

Method in class wx.ListCtrl

GetImageList

Method in class wx.TreeCtrl

GetImageList

Method in class wx.gizmos.TreeListCtrl

GetImageRect

Method in class wx.DragImage

GetIncludeChars

Method in class wx.lib.masked.maskededit.MaskedEditAccessorsMixin

GetIndent

Method in class wx.TreeCtrl

GetIndent

Method in class wx.gizmos.TreeListCtrl

GetIndent

Method in class wx.html.HtmlContainerCell

GetIndent

Method in class wx.stc.StyledTextCtrl

GetIndentationGuides

Method in class wx.stc.StyledTextCtrl

GetIndentUnits

Method in class wx.html.HtmlContainerCell

GetIndex

Method in class wx.IconLocation

GetIndex

Method in class wx.ListEvent

GetIndex

Method in class wx.html.HtmlHelpData

GetIndexCnt

Method in class wx.html.HtmlHelpData

GetInitialFont

Method in class wx.FontData

GetInputStream

Method in class wx.Process

GetInsertionColumn

Method in class wx.lib.gridmovers.ColDragWindow

GetInsertionPoint

Method in class wx.ComboBox

GetInsertionPoint

Method in class wx.TextCtrl

GetInsertionPos

Method in class wx.lib.gridmovers.ColDragWindow

GetInsertionPos

Method in class wx.lib.gridmovers.RowDragWindow

GetInsertionRow

Method in class wx.lib.gridmovers.RowDragWindow

getInstalled

Function in module wxversion

GetInstallPrefix

Method in class wx.StandardPaths

GetInstance

Method in class wx.xrc.XmlResourceHandler

GetInt

Method in class wx.CommandEvent

GetIntegerWidth

Method in class wx.lib.masked.numctrl.NumCtrl

GetInternalRepresentation

Method in class wx.html.HtmlWindow

GetInterval

Method in class wx.FutureCall

GetInterval

Method in class wx.Timer

GetInterval

Method in class wx.TimerEvent

GetInvalidBackgroundColour

Method in class wx.lib.masked.ipaddrctrl.IpAddrCtrlAccessorsMixin

GetInvalidBackgroundColour

Method in class wx.lib.masked.maskededit.MaskedEditAccessorsMixin

GetInvalidBackgroundColour

Method in class wx.lib.masked.numctrl.NumCtrlAccessorsMixin

GetInvalidBackgroundColour

Method in class wx.lib.masked.timectrl.TimeCtrlAccessorsMixin

GetInvokingWindow

Method in class wx.Menu

GetIsDown

Method in class wx.lib.buttons.GenButtonEvent

GetItem

Method in class wx.ListCtrl

GetItem

Method in class wx.ListEvent

GetItem

Method in class wx.Sizer

GetItem

Method in class wx.TreeEvent

GetItemBackgroundColour

Method in class wx.ListCtrl

GetItemBackgroundColour

Method in class wx.TreeCtrl

GetItemBackgroundColour

Method in class wx.gizmos.TreeListCtrl

GetItemBold

Method in class wx.gizmos.TreeListCtrl

GetItemCount

Method in class wx.ListCtrl

GetItemCount

Method in class wx.VListBox

GetItemData

Method in class wx.ListCtrl

GetItemData

Method in class wx.TreeCtrl

GetItemData

Method in class wx.gizmos.TreeListCtrl

GetItemFont

Method in class wx.TreeCtrl

GetItemFont

Method in class wx.gizmos.TreeListCtrl

GetItemHeight

Method in class wx.CheckListBox

GetItemImage

Method in class wx.TreeCtrl

GetItemImage

Method in class wx.gizmos.TreeListCtrl

GetItemParent

Method in class wx.TreeCtrl

GetItemParent

Method in class wx.gizmos.TreeListCtrl

GetItemPos

Method in class wx.lib.foldpanelbar.FoldPanelItem

GetItemPosition

Method in class wx.GridBagSizer

GetItemPosition

Method in class wx.ListCtrl

GetItemPyData

Method in class wx.TreeCtrl

GetItemPyData

Method in class wx.gizmos.TreeListCtrl

GetItemRect

Method in class wx.ListCtrl

GetItemSpacing

Method in class wx.ListCtrl

GetItemSpan

Method in class wx.GridBagSizer

GetItemState

Method in class wx.ListCtrl

GetItemText

Method in class wx.ListCtrl

GetItemText

Method in class wx.TreeCtrl

GetItemText

Method in class wx.gizmos.TreeListCtrl

GetItemTextColour

Method in class wx.ListCtrl

GetItemTextColour

Method in class wx.TreeCtrl

GetItemTextColour

Method in class wx.gizmos.TreeListCtrl

GetJDN

Method in class wx.DateTime

GetJoin

Method in class wx.Pen

GetJoystick

Method in class wx.JoystickEvent

GetJulianDayNumber

Method in class wx.DateTime

GetKey

Method in class wx.stc.StyledTextEvent

GetKeyCode

Method in class wx.AcceleratorEntry

GetKeyCode

Method in class wx.KeyEvent

GetKeyCode

Method in class wx.ListEvent

GetKeyCode

Method in class wx.TreeEvent

GetKeyEvent

Method in class wx.TreeEvent

getKeyEvent

Method in class wx.lib.mvctree.MVCTreeEvent

GetKeyState

Function in package wx

GetKind

Method in class wx.MenuItem

GetKind

Method in class wx.ToolBarToolBase

GetKind

Method in class wx.grid.GridCellAttr

GetLabel

Method in class wx.Control

GetLabel

Method in class wx.ListEvent

GetLabel

Method in class wx.Menu

GetLabel

Method in class wx.MenuBar

GetLabel

Method in class wx.MenuItem

GetLabel

Method in class wx.ToolBarToolBase

GetLabel

Method in class wx.TreeEvent

GetLabel

Method in class wx.Window

GetLabel

Method in class wx.lib.colourselect.ColourSelect

GetLabel

Method in class wx.lib.filebrowsebutton.FileBrowseButton

GetLabelBackgroundColour

Method in class wx.grid.Grid

GetLabelFont

Method in class wx.grid.Grid

GetLabelFromText

Method in class wx.MenuItem

GetLabelPosition

Method in class wx.lib.ogl.LineShape

GetLabelTextColour

Method in class wx.grid.Grid

GetLabelTop

Method in class wx.MenuBar

GetLanguage

Method in class wx.Locale

GetLanguageInfo

Method in class wx.Locale

GetLanguageName

Method in class wx.Locale

GetLastActiveView

Method in class wx.lib.docview.DocManager

GetLastChild

Method in class wx.TreeCtrl

GetLastChild

Method in class wx.gizmos.TreeListCtrl

GetLastChild

Method in class wx.stc.StyledTextCtrl

GetLastError

Method in class wx.Printer

GetLastKeydownProcessed

Method in class wx.stc.StyledTextCtrl

GetLastMonthDay

Method in class wx.DateTime

GetLastPosition

Method in class wx.ComboBox

GetLastPosition

Method in class wx.TextCtrl

GetLastTerminal

Method in class wx.html.HtmlCell

GetLastVisibleLine

Method in class wx.VScrolledWindow

GetLastWeekDay

Method in class wx.DateTime

GetLayoutCache

Method in class wx.stc.StyledTextCtrl

GetLayoutEngine

Method in class wx.lib.mvctree.MVCTree

GetLeft

Method in class wx.Rect

GetLeftCol

Method in class wx.grid.GridRangeSelectEvent

GetLeftIndent

Method in class wx.TextAttr

GetLeftLocation

Method in class wx.FileSystemHandler

GetLeftSide

Method in class wx.lib.ogl.DivisionShape

GetLeftSideColour

Method in class wx.lib.ogl.DivisionShape

GetLeftSidePen

Method in class wx.lib.ogl.DivisionShape

GetLeftSideStyle

Method in class wx.lib.ogl.DivisionShape

GetLeftSpacing

Method in class wx.lib.foldpanelbar.FoldWindowItem

GetLeftSubIndent

Method in class wx.TextAttr

getLegend

Method in class wx.lib.plot.PolyPoints

getLegendNames

Method in class wx.lib.plot.PlotGraphics

GetLength

Method in class wx.stc.StyledTextCtrl

GetLength

Method in class wx.stc.StyledTextEvent

GetLevel

Method in class wx.html.HtmlContentsItem

GetLexer

Method in class wx.stc.StyledTextCtrl

GetLightShadow

Method in class wx.Effects

GetLimited

Method in class wx.lib.masked.numctrl.NumCtrl

GetLine

Method in class wx.stc.StyledTextCtrl

GetLine

Method in class wx.stc.StyledTextEvent

GetLineBrush

Method in class wx.lib.mvctree.Painter

GetLineColour

Method in class wx.lib.foldpanelbar.FoldWindowItem

GetLineColour

Method in class wx.lib.mvctree.Painter

GetLineControlPoints

Method in class wx.lib.ogl.LineShape

GetLineCount

Method in class wx.VScrolledWindow

GetLineCount

Method in class wx.stc.StyledTextCtrl

GetLineEndPosition

Method in class wx.stc.StyledTextCtrl

GetLineIndentation

Method in class wx.stc.StyledTextCtrl

GetLineIndentPosition

Method in class wx.stc.StyledTextCtrl

GetLineLength

Method in class wx.TextCtrl

GetLineLength

Method in class wx.lib.foldpanelbar.FoldWindowItem

GetLinePen

Method in class wx.lib.mvctree.Painter

GetLinePosition

Method in class wx.lib.ogl.Shape

GetLineRaw

Method in class wx.stc.StyledTextCtrl

GetLines

Method in class wx.lib.ogl.Shape

GetLinesAdded

Method in class wx.stc.StyledTextEvent

GetLineSelEndPosition

Method in class wx.stc.StyledTextCtrl

GetLineSelStartPosition

Method in class wx.stc.StyledTextCtrl

GetLineSize

Method in class wx.Slider

GetLineSpacing

Method in class wx.gizmos.TreeListCtrl

GetLinesPerAction

Method in class wx.MouseEvent

GetLineState

Method in class wx.stc.StyledTextCtrl

GetLineText

Method in class wx.TextCtrl

GetLineUTF8

Method in class wx.stc.StyledTextCtrl

GetLineVisible

Method in class wx.stc.StyledTextCtrl

GetLineY

Method in class wx.lib.foldpanelbar.FoldWindowItem

GetLink

Method in class wx.HelpEvent

GetLink

Method in class wx.html.HtmlCell

GetLink

Method in class wx.html.HtmlWinParser

GetLinkColor

Method in class wx.html.HtmlWinParser

GetLinkCursor

Method in class wx.lib.hyperlink.HyperLinkCtrl

GetListCtrl

Method in class wx.gizmos.EditableListBox

getListCtrlSelection

Function in module wx.lib.mixins.listctrl

GetListType

Method in class wx.stc.StyledTextEvent

GetListView

Method in class wx.Listbook

GetLocalDataDir

Method in class wx.StandardPaths

GetLocale

Function in package wx

GetLocale

Method in class wx.Locale

GetLocals

Method in class wx.lib.pyshell.PyShellWindow

GetLocalTime

Function in package wx

GetLocalTimeMillis

Function in package wx

GetLocation

Method in class wx.FSFile

GetLoggingOff

Method in class wx.CloseEvent

GetLogicalFunction

Method in class wx.DC

GetLogicalOrigin

Method in class wx.DC

GetLogicalOriginTuple

Method in class wx.DC

GetLogicalPosition

Method in class wx.MouseEvent

GetLogicalScale

Method in class wx.DC

GetLogicalScreenSize

Method in class wx.animate.AnimationBase

GetLogicalScreenSize

Method in class wx.animate.AnimationPlayer

GetLogicalScreenSize

Method in class wx.animate.GIFAnimation

GetLogLevel

Method in class wx.Log

GetLong

Method in class wx.xrc.XmlResourceHandler

GetLongHelp

Method in class wx.ToolBarToolBase

GetLooped

Method in class wx.animate.AnimationPlayer

GetLowerDateLimit

Method in class wx.calendar.CalendarCtrl

GetLowerLimit

Method in class wx.DatePickerCtrl

GetLParam

Method in class wx.stc.StyledTextEvent

GetMacAboutMenuItemId

Method in class wx.PyApp

GetMacExitMenuItemId

Method in class wx.PyApp

GetMacHelpMenuTitleName

Method in class wx.PyApp

GetMacPreferencesMenuItemId

Method in class wx.PyApp

GetMacSupportPCMenuShortcuts

Method in class wx.PyApp

GetMainColumn

Method in class wx.gizmos.TreeListCtrl

GetMaintainAspectRatio

Method in class wx.lib.ogl.Shape

GetMainWindow

Method in class wx.ListCtrl

GetMainWindow

Method in class wx.gizmos.TreeListCtrl

GetManufacturerId

Method in class wx.Joystick

GetMapMode

Method in class wx.DC

GetMargin

Method in class wx.IndividualLayoutConstraint

GetMargin

Method in class wx.stc.StyledTextEvent

GetMarginBottomRight

Method in class wx.PageSetupDialogData

GetMarginLeft

Method in class wx.stc.StyledTextCtrl

GetMarginMask

Method in class wx.stc.StyledTextCtrl

GetMarginRight

Method in class wx.stc.StyledTextCtrl

GetMargins

Method in class wx.ToolBarBase

GetMargins

Method in class wx.VListBox

GetMarginSensitive

Method in class wx.stc.StyledTextCtrl

GetMarginTopLeft

Method in class wx.PageSetupDialogData

GetMarginType

Method in class wx.stc.StyledTextCtrl

GetMarginWidth

Method in class wx.MenuItem

GetMarginWidth

Method in class wx.stc.StyledTextCtrl

GetMarginX

Method in class wx.BitmapButton

GetMarginY

Method in class wx.BitmapButton

GetMark

Method in class wx.ComboBox

GetMark

Method in class wx.lib.masked.combobox.BaseMaskedComboBox

GetMask

Method in class wx.Bitmap

GetMask

Method in class wx.ListEvent

GetMask

Method in class wx.ListItem

GetMask

Method in class wx.lib.masked.maskededit.MaskedEditAccessorsMixin

GetMaskBlue

Method in class wx.Image

GetMaskGreen

Method in class wx.Image

GetMaskParameter

Method in class wx.lib.masked.maskededit.MaskedEditMixin

GetMaskRed

Method in class wx.Image

GetMax

Method in class wx.Slider

GetMax

Method in class wx.SpinButton

GetMax

Method in class wx.SpinCtrl

GetMax

Method in class wx.lib.intctrl.IntCtrl

GetMax

Method in class wx.lib.masked.numctrl.NumCtrl

GetMax

Method in class wx.lib.masked.timectrl.TimeCtrl

GetMaxAxes

Method in class wx.Joystick

GetMaxButtons

Method in class wx.Joystick

GetMaxCols

Method in class wx.ToolBarBase

GetMaxCommands

Method in class wx.lib.docview.CommandProcessor

GetMaxDocsOpen

Method in class wx.lib.docview.DocManager

GetMaxFiles

Method in class wx.FileHistory

GetMaxHeight

Method in class wx.Window

GetMaximumSizeX

Method in class wx.SashWindow

GetMaximumSizeY

Method in class wx.SashWindow

GetMaxIndex

Method in class wx.html.HtmlSearchStatus

GetMaxLineState

Method in class wx.stc.StyledTextCtrl

GetMaxPage

Method in class wx.PrintDialogData

GetMaxPage

Method in class wx.PrintPreview

GetMaxRows

Method in class wx.ToolBarBase

GetMaxSize

Method in class wx.Window

GetMaxTotalWidth

Method in class wx.html.HtmlCell

GetMaxWidth

Method in class wx.Window

GetMediumShadow

Method in class wx.Effects

GetMenu

Method in class wx.MenuBar

GetMenu

Method in class wx.MenuEvent

GetMenu

Method in class wx.MenuItem

GetMenuBar

Method in class wx.Frame

GetMenuBar

Method in class wx.Menu

GetMenuCount

Method in class wx.MenuBar

GetMenuId

Method in class wx.MenuEvent

GetMenuItemCount

Method in class wx.Menu

GetMenuItemPos

Method in class wx.lib.pydocview.DocService

GetMenuItems

Method in class wx.Menu

GetMessage

Method in class wx.DirDialog

GetMessage

Method in class wx.FileDialog

GetMessage

Method in class wx.stc.StyledTextEvent

GetMetaFile

Method in class wx.lib.ogl.ArrowHead

GetMetaFile

Method in class wx.lib.ogl.DrawnShape

GetMetric

Method in class wx.SystemSettings

GetMillisecond

Method in class wx.DateTime

GetMilliseconds

Method in class wx.TimeSpan

GetMimeType

Method in class wx.FSFile

GetMimeType

Method in class wx.FileType

GetMimeType

Method in class wx.FileTypeInfo

GetMimeType

Method in class wx.ImageHandler

GetMimeTypeFromExt

Method in class wx.FileSystemHandler

GetMimeTypes

Method in class wx.FileType

GetMin

Method in class wx.Slider

GetMin

Method in class wx.SpinButton

GetMin

Method in class wx.SpinCtrl

GetMin

Method in class wx.lib.intctrl.IntCtrl

GetMin

Method in class wx.lib.masked.numctrl.NumCtrl

GetMin

Method in class wx.lib.masked.timectrl.TimeCtrl

GetMinHeight

Method in class wx.Window

GetMinimumPaneSize

Method in class wx.SplitterWindow

GetMinimumSizeX

Method in class wx.SashWindow

GetMinimumSizeY

Method in class wx.SashWindow

GetMinMarginBottomRight

Method in class wx.PageSetupDialogData

GetMinMarginTopLeft

Method in class wx.PageSetupDialogData

GetMinPage

Method in class wx.PrintDialogData

GetMinPage

Method in class wx.PrintPreview

GetMinSize

Method in class wx.Sizer

GetMinSize

Method in class wx.SizerItem

GetMinSize

Method in class wx.Window

GetMinSize

Method in class wx.lib.ogl.ShapeRegion

GetMinSizeTuple

Method in class wx.Sizer

GetMinSizeWithBorder

Method in class wx.SizerItem

GetMinusBitmap

Function in module wx.lib.floatcanvas.Resources

GetMinusData

Function in module wx.lib.floatcanvas.Resources

GetMinute

Method in class wx.DateTime

GetMinutes

Method in class wx.TimeSpan

GetMinWidth

Method in class wx.Window

GetMJD

Method in class wx.DateTime

GetMode

Method in class wx.IdleEvent

GetMode

Method in class wx.UpdateUIEvent

GetModel

Method in class wx.lib.mvctree.MVCTree

GetModes

Method in class wx.Display

GetModEventMask

Method in class wx.stc.StyledTextCtrl

GetModificationTime

Method in class wx.FSFile

GetModificationType

Method in class wx.stc.StyledTextEvent

GetModifiedJulianDayNumber

Method in class wx.DateTime

GetModifiers

Method in class wx.stc.StyledTextEvent

GetModify

Method in class wx.stc.StyledTextCtrl

GetMonth

Method in class wx.DateTime

GetMonth

Method in class wx.lib.calendar.Calendar

GetMonthControl

Method in class wx.calendar.CalendarCtrl

GetMonthList

Function in module wx.lib.calendar

GetMonthName

Method in class wx.DateTime

GetMonths

Method in class wx.DateSpan

GetMouseDownCaptures

Method in class wx.stc.StyledTextCtrl

GetMouseDwellTime

Method in class wx.stc.StyledTextCtrl

GetMouseEvent

Method in class wx.TextUrlEvent

GetMousePosition

Function in package wx

GetMouseTolerance

Method in class wx.lib.ogl.Diagram

GetMoveColumn

Method in class wx.lib.gridmovers.ColDragWindow

GetMoveColumn

Method in class wx.lib.gridmovers.GridColMoveEvent

GetMovementThreshold

Method in class wx.Joystick

GetMoveRow

Method in class wx.lib.gridmovers.GridRowMoveEvent

GetMoveRow

Method in class wx.lib.gridmovers.RowDragWindow

getMultilineCommand

Method in class wx.py.shell.Shell

GetMultiLineTextExtent

Method in class wx.DC

GetMxDateTime

Method in class wx.lib.masked.timectrl.TimeCtrl

GetMyEdge

Method in class wx.IndividualLayoutConstraint

GetName

Method in class wx.Display

GetName

Method in class wx.ImageHandler

GetName

Method in class wx.Locale

GetName

Method in class wx.Window

GetName

Method in class wx.html.HtmlContentsItem

GetName

Method in class wx.html.HtmlSearchStatus

GetName

Method in class wx.html.HtmlTag

GetName

Method in class wx.lib.docview.Command

GetName

Method in class wx.lib.ogl.ArrowHead

GetName

Method in class wx.lib.ogl.ShapeRegion

GetName

Method in class wx.xrc.XmlNode

GetName

Method in class wx.xrc.XmlProperty

GetName

Method in class wx.xrc.XmlResourceHandler

GetNativeFontEncoding

Function in package wx

GetNativeFontInfo

Method in class wx.Font

GetNativeFontInfoDesc

Method in class wx.Font

GetNativeFontInfoUserDesc

Method in class wx.Font

GetNeedUpdating

Method in class wx.SplitterWindow

GetNegativeButton

Method in class wx.StdDialogButtonSizer

getNewBitmap

Function in module wx.lib.pydocview

GetNewButton

Method in class wx.gizmos.EditableListBox

getNewData

Function in module wx.lib.pydocview

getNewImage

Function in module wx.lib.pydocview

GetNewSize

Method in class wx.lib.ogl.PolygonControlPoint

GetNext

Method in class wx.gizmos.TreeListCtrl

GetNext

Method in class wx.html.HtmlCell

GetNext

Method in class wx.wizard.WizardPage

GetNext

Method in class wx.xrc.XmlNode

GetNext

Method in class wx.xrc.XmlProperty

GetNextChild

Method in class wx.TreeCtrl

GetNextChild

Method in class wx.gizmos.TreeListCtrl

GetNextControlPoint

Method in class wx.lib.ogl.LineShape

GetNextEntry

Method in class wx.ConfigBase

GetNextGroup

Method in class wx.ConfigBase

GetNextHandler

Method in class wx.EvtHandler

GetNextItem

Method in class wx.ListCtrl

GetNextItem

Method in class wx.RadioBox

GetNextSelected

Method in class wx.ListCtrl

GetNextSelected

Method in class wx.ListView

GetNextSelected

Method in class wx.VListBox

GetNextSibling

Method in class wx.TreeCtrl

GetNextSibling

Method in class wx.gizmos.TreeListCtrl

GetNextVisible

Method in class wx.TreeCtrl

GetNextVisible

Method in class wx.gizmos.TreeListCtrl

GetNextWeekDay

Method in class wx.DateTime

GetNoAntiAliasing

Method in class wx.Font

GetNoCopies

Method in class wx.PrintData

GetNoCopies

Method in class wx.PrintDialogData

GetNode

Method in class wx.lib.mvctree.MVCTreeEvent

GetNode

Method in class wx.xrc.XmlResourceHandler

GetNodeContent

Method in class wx.xrc.XmlResourceHandler

GetNodeList

Method in class wx.lib.mvctree.LayoutEngine

GetNodeList

Method in class wx.lib.mvctree.TreeLayout

GetNodes

Method in class wx.lib.mvctree.MVCTreeEvent

GetNonFlexibleGrowMode

Method in class wx.FlexGridSizer

GetNormalBitmap

Method in class wx.ToolBarToolBase

GetNotebook

Method in class wx.NotebookSizer

GetNotebook

Method in class wx.lib.pydocview.DocTabbedParentFrame

GetNotebookPageIndex

Method in class wx.lib.pydocview.DocTabbedParentFrame

GetNotebookPageTitle

Method in class wx.lib.pydocview.DocTabbedParentFrame

getNotifyEvent

Method in class wx.lib.mvctree.MVCTreeNotifyEvent

GetNow

Method in class wx.lib.printout.PrintBase

GetNumberAxes

Method in class wx.Joystick

GetNumberButtons

Method in class wx.Joystick

GetNumberCols

Method in class wx.grid.Grid

GetNumberCols

Method in class wx.grid.GridTableBase

GetNumberFromUser

Function in package wx

GetNumberJoysticks

Method in class wx.Joystick

GetNumberOfAttachments

Method in class wx.lib.ogl.ControlPoint

GetNumberOfAttachments

Method in class wx.lib.ogl.DividedShape

GetNumberOfAttachments

Method in class wx.lib.ogl.EllipseShape

GetNumberOfAttachments

Method in class wx.lib.ogl.PolygonShape

GetNumberOfAttachments

Method in class wx.lib.ogl.Shape

GetNumberOfDaysInMonth

Method in class wx.DateTime

GetNumberOfDaysinYear

Method in class wx.DateTime

GetNumberOfEntries

Method in class wx.ConfigBase

GetNumberOfFiles

Method in class wx.DropFilesEvent

GetNumberOfGroups

Method in class wx.ConfigBase

GetNumberOfLines

Method in class wx.TextCtrl

GetNumberOfTextRegions

Method in class wx.lib.ogl.Shape

GetNumberRows

Method in class wx.grid.Grid

GetNumberRows

Method in class wx.grid.GridTableBase

GetOffset

Method in class wx.lib.calendar.CalDraw

GetOldItem

Method in class wx.TreeEvent

GetOldLog

Method in class wx.LogChain

GetOldLog

Method in class wx.LogWindow

GetOldSelection

Method in class wx.BookCtrlBaseEvent

GetOp

Method in class wx.lib.ogl.DrawOp

getOpenBitmap

Function in module wx.lib.pydocview

GetOpenCommand

Method in class wx.FileType

GetOpenCommand

Method in class wx.FileTypeInfo

getOpenData

Function in module wx.lib.pydocview

GetOpenedAnchor

Method in class wx.html.HtmlWindow

GetOpenedPage

Method in class wx.html.HtmlWindow

GetOpenedPageTitle

Method in class wx.html.HtmlWindow

getOpenImage

Function in module wx.lib.pydocview

GetOps

Method in class wx.lib.ogl.PseudoMetaFile

GetOption

Method in class wx.Image

GetOption

Method in class wx.SystemOptions

GetOptionInt

Method in class wx.Image

GetOptionInt

Method in class wx.SystemOptions

GetOrCreateCellAttr

Method in class wx.grid.Grid

GetOrFindMaskColour

Method in class wx.Image

GetOrientation

Method in class wx.BoxSizer

GetOrientation

Method in class wx.PrintData

GetOrientation

Method in class wx.QueryLayoutInfoEvent

GetOrientation

Method in class wx.SashLayoutWindow

GetOrientation

Method in class wx.ScrollEvent

GetOrientation

Method in class wx.ScrollWinEvent

GetOriginalHeight

Method in class wx.lib.ogl.PolygonShape

GetOriginalPoints

Method in class wx.lib.ogl.PolygonShape

GetOriginalWidth

Method in class wx.lib.ogl.PolygonShape

GetOsDescription

Function in package wx

GetOsVersion

Function in package wx

GetOtherEdge

Method in class wx.IndividualLayoutConstraint

GetOtherWindow

Method in class wx.IndividualLayoutConstraint

GetOutlineColours

Method in class wx.lib.ogl.PseudoMetaFile

GetOutlineOp

Method in class wx.lib.ogl.PseudoMetaFile

GetOutlinePen

Method in class wx.lib.ogl.PseudoMetaFile

GetOutputStream

Method in class wx.Process

GetOverflow

Method in class wx.grid.GridCellAttr

GetOvertype

Method in class wx.stc.StyledTextCtrl

GetOwner

Method in class wx.Timer

GetPage

Method in class wx.BookCtrlBase

GetPage

Method in class wx.html.HtmlContentsItem

GetPage

Method in class wx.wizard.WizardEvent

GetPageAreaSizer

Method in class wx.wizard.Wizard

GetPageCount

Method in class wx.BookCtrlBase

GetPageImage

Method in class wx.BookCtrlBase

GetPageInfo

Method in class wx.lib.docview.DocPrintout

GetPageInfo

Method in class wx.lib.plot.PlotPrintout

GetPageInfo

Method in class wx.lib.printout.SetPrintout

GetPageSetupData

Method in class wx.PageSetupDialog

GetPageSetupData

Method in class wx.html.HtmlEasyPrinting

GetPageSetupDialogData

Method in class wx.PageSetupDialog

GetPageSize

Method in class wx.ScrollBar

GetPageSize

Method in class wx.Slider

GetPageSize

Method in class wx.wizard.Wizard

GetPageSizeMM

Method in class wx.Printout

GetPageSizePixels

Method in class wx.Printout

GetPageSource

Method in class wx.webkit.WebKitCtrl

GetPageText

Method in class wx.BookCtrlBase

GetPageTitle

Method in class wx.webkit.WebKitCtrl

GetPageURL

Method in class wx.webkit.WebKitCtrl

GetPainter

Method in class wx.lib.mvctree.MVCTree

GetPalette

Method in class wx.Bitmap

GetPalette

Method in class wx.glcanvas.GLContext

GetPaletteRealized

Method in class wx.QueryNewPaletteEvent

GetPanelLength

Method in class wx.lib.foldpanelbar.FoldPanelItem

GetPanelsLength

Method in class wx.lib.foldpanelbar.FoldPanelBar

GetPaperId

Method in class wx.PageSetupDialogData

GetPaperId

Method in class wx.PrintData

GetPaperSize

Method in class wx.PageSetupDialogData

GetPaperSize

Method in class wx.PrintData

GetParam

Method in class wx.html.HtmlTag

GetParamNode

Method in class wx.xrc.XmlResourceHandler

GetParamValue

Method in class wx.xrc.XmlResourceHandler

GetParent

Method in class wx.Menu

GetParent

Method in class wx.Window

GetParent

Method in class wx.html.HtmlCell

GetParent

Method in class wx.lib.mvctree.BasicTreeModel

GetParent

Method in class wx.lib.mvctree.MVCTreeNode

GetParent

Method in class wx.lib.mvctree.TreeModel

GetParent

Method in class wx.lib.ogl.Shape

GetParent

Method in class wx.xrc.XmlNode

GetParent

Method in class wx.xrc.XmlResourceHandler

GetParentAsWindow

Method in class wx.xrc.XmlResourceHandler

GetParentDocument

Method in class wx.lib.pydocview.ChildDocument

GetParser

Method in class wx.html.HtmlTagHandler

GetParser

Method in class wx.html.HtmlWinTagHandler

GetParser

Method in class wx.html.HtmlWindow

GetPartialTextExtents

Method in class wx.DC

GetPasswordFromUser

Function in package wx

getPasteBitmap

Function in module wx.lib.pydocview

getPasteData

Function in module wx.lib.pydocview

getPasteImage

Function in module wx.lib.pydocview

GetPath

Method in class wx.ConfigBase

GetPath

Method in class wx.DirDialog

GetPath

Method in class wx.FileDialog

GetPath

Method in class wx.FileSystem

GetPath

Method in class wx.GenericDirCtrl

GetPaths

Method in class wx.FileDialog

GetPen

Method in class wx.DC

GetPen

Method in class wx.lib.ogl.Shape

GetPenColour

Method in class wx.lib.ogl.ShapeRegion

GetPenStyle

Method in class wx.lib.ogl.ShapeRegion

GetPercent

Method in class wx.IndividualLayoutConstraint

GetPerimeterPoint

Method in class wx.lib.ogl.CircleShape

GetPerimeterPoint

Method in class wx.lib.ogl.DrawOp

GetPerimeterPoint

Method in class wx.lib.ogl.DrawnShape

GetPerimeterPoint

Method in class wx.lib.ogl.EllipseShape

GetPerimeterPoint

Method in class wx.lib.ogl.OpPolyDraw

GetPerimeterPoint

Method in class wx.lib.ogl.PolygonShape

GetPerimeterPoint

Method in class wx.lib.ogl.RectangleShape

GetPerimeterPoint

Method in class wx.lib.ogl.Shape

GetPid

Method in class wx.ProcessEvent

GetPixel

Method in class wx.Colour

GetPixel

Method in class wx.DC

GetPixel

Method in class wx.Palette

GetPixelPoint

Method in class wx.DC

GetPixelSize

Method in class wx.Font

GetPlainValue

Method in class wx.lib.masked.maskededit.MaskedEditMixin

GetPlatformEquivalents

Method in class wx.EncodingConverter

GetPlaybackRate

Method in class wx.media.MediaCtrl

GetPlayer

Method in class wx.animate.GIFAnimationCtrl

GetPluginsDir

Method in class wx.StandardPaths

GetPlusBitmap

Function in module wx.lib.floatcanvas.Resources

GetPlusData

Function in module wx.lib.floatcanvas.Resources

GetPoint

Method in class wx.ListEvent

GetPoint

Method in class wx.TreeEvent

GetPointerBitmap

Function in module wx.lib.floatcanvas.Resources

GetPointerData

Function in module wx.lib.floatcanvas.Resources

GetPointerImage

Function in module wx.lib.floatcanvas.Resources

GetPointLabelFunc

Method in class wx.lib.plot.PlotCanvas

GetPointOnLine

Function in package wx.lib.ogl

GetPoints

Method in class wx.lib.ogl.PolygonShape

GetPointSize

Method in class wx.Font

GetPointSize

Method in class wx.NativeFontInfo

GetPollingMax

Method in class wx.Joystick

GetPollingMin

Method in class wx.Joystick

getPopupMenu

Method in class wx.lib.mixins.listctrl.ListCtrlSelectionManagerMix

GetPos

Method in class wx.GBSizerItem

GetPosition

Method in class wx.Caret

GetPosition

Method in class wx.ContextMenuEvent

GetPosition

Method in class wx.DropFilesEvent

GetPosition

Method in class wx.HelpEvent

GetPosition

Method in class wx.Joystick

GetPosition

Method in class wx.JoystickEvent

GetPosition

Method in class wx.KeyEvent

GetPosition

Method in class wx.MouseEvent

GetPosition

Method in class wx.MoveEvent

GetPosition

Method in class wx.Rect

GetPosition

Method in class wx.ScrollEvent

GetPosition

Method in class wx.ScrollWinEvent

GetPosition

Method in class wx.Sizer

GetPosition

Method in class wx.SizerItem

GetPosition

Method in class wx.SpinEvent

GetPosition

Method in class wx.Window

GetPosition

Method in class wx.animate.AnimationPlayer

GetPosition

Method in class wx.grid.GridEvent

GetPosition

Method in class wx.grid.GridSizeEvent

GetPosition

Method in class wx.lib.hyperlink.HyperLinkEvent

GetPosition

Method in class wx.lib.ogl.ArrowHead

GetPosition

Method in class wx.lib.ogl.ShapeRegion

GetPosition

Method in class wx.stc.StyledTextEvent

GetPosition

Method in class wx.xrc.XmlResourceHandler

GetPositionTuple

Method in class wx.Caret

GetPositionTuple

Method in class wx.KeyEvent

GetPositionTuple

Method in class wx.MouseEvent

GetPositionTuple

Method in class wx.Sizer

GetPositionTuple

Method in class wx.Window

GetPosTuple

Method in class wx.GBSizerItem

GetPosX

Method in class wx.html.HtmlCell

GetPosY

Method in class wx.html.HtmlCell

GetPOVCTSPosition

Method in class wx.Joystick

GetPOVPosition

Method in class wx.Joystick

GetPPF

Method in class wx.lib.ticker.Ticker

GetPPI

Method in class wx.DC

GetPPIPrinter

Method in class wx.Printout

GetPPIScreen

Method in class wx.Printout

GetPrecision

Method in class wx.grid.GridCellFloatRenderer

GetPreferredFormat

Method in class wx.DataObject

GetPrev

Method in class wx.wizard.WizardPage

GetPreviewCommand

Method in class wx.PrintData

GetPreviousHandler

Method in class wx.EvtHandler

GetPreviousHandler

Method in class wx.lib.ogl.ShapeEvtHandler

GetPrevSibling

Method in class wx.TreeCtrl

GetPrevSibling

Method in class wx.gizmos.TreeListCtrl

GetPrevVisible

Method in class wx.TreeCtrl

GetPrevVisible

Method in class wx.gizmos.TreeListCtrl

GetPrevWeekDay

Method in class wx.DateTime

GetPrintableName

Method in class wx.lib.docview.Document

getPrintBitmap

Function in module wx.lib.pydocview

GetPrintColourMode

Method in class wx.stc.StyledTextCtrl

GetPrintCommand

Method in class wx.FileType

GetPrintCommand

Method in class wx.FileTypeInfo

GetPrintData

Method in class wx.PageSetupDialogData

GetPrintData

Method in class wx.PostScriptDC

GetPrintData

Method in class wx.PrintDialog

GetPrintData

Method in class wx.PrintDialogData

GetPrintData

Method in class wx.html.HtmlEasyPrinting

getPrintData

Function in module wx.lib.pydocview

GetPrintDC

Method in class wx.PrintDialog

GetPrintDialogData

Method in class wx.PrintDialog

GetPrintDialogData

Method in class wx.PrintPreview

GetPrintDialogData

Method in class wx.Printer

GetPrinterCommand

Method in class wx.PrintData

GetPrinterName

Method in class wx.PrintData

GetPrinterOptions

Method in class wx.PrintData

GetPrinterScaleX

Method in class wx.PrintData

GetPrinterScaleY

Method in class wx.PrintData

GetPrinterTranslateX

Method in class wx.PrintData

GetPrinterTranslateY

Method in class wx.PrintData

getPrintImage

Function in module wx.lib.pydocview

GetPrintMagnification

Method in class wx.stc.StyledTextCtrl

GetPrintMode

Method in class wx.PrintData

GetPrintMode

Method in class wx.PyApp

GetPrintout

Method in class wx.PrintPreview

GetPrintoutForPrinting

Method in class wx.PrintPreview

GetPrintPreview

Method in class wx.PreviewControlBar

getPrintPreviewBitmap

Function in module wx.lib.pydocview

getPrintPreviewData

Function in module wx.lib.pydocview

getPrintPreviewImage

Function in module wx.lib.pydocview

GetPrintToFile

Method in class wx.PrintDialogData

GetPrintWrapMode

Method in class wx.stc.StyledTextCtrl

GetPrivData

Method in class wx.PrintData

GetProcessId

Function in package wx

GetProductId

Method in class wx.Joystick

GetProductName

Method in class wx.Joystick

GetProperties

Method in class wx.lib.pyshell.PyShellWindow

GetProperties

Method in class wx.xrc.XmlNode

GetProportion

Method in class wx.SizerItem

GetProportion

Method in class wx.lib.ogl.ShapeRegion

GetPropVal

Method in class wx.xrc.XmlNode

GetProtocol

Method in class wx.FileSystemHandler

getPyBitmap

Function in module wx.py.images

getPyData

Function in module wx.py.images

getPyIcon

Function in module wx.py.images

getPyImage

Function in module wx.py.images

GetQuality

Method in class wx.PrintData

GetQuickEditMode

Method in class wx.lib.ogl.Diagram

GetQuickEditMode

Method in class wx.lib.ogl.ShapeCanvas

GetRange

Method in class wx.Gauge

GetRange

Method in class wx.ScrollBar

GetRange

Method in class wx.TextCtrl

GetRataDie

Method in class wx.DateTime

GetRatio

Method in class wx.SizerItem

GetRawKeyCode

Method in class wx.KeyEvent

GetRawKeyFlags

Method in class wx.KeyEvent

GetReadOnly

Method in class wx.stc.StyledTextCtrl

GetRecording

Method in class wx.lib.gestures.MouseGestures

GetRect

Method in class wx.CalculateLayoutEvent

GetRect

Method in class wx.MoveEvent

GetRect

Method in class wx.RegionIterator

GetRect

Method in class wx.SizeEvent

GetRect

Method in class wx.SizerItem

GetRect

Method in class wx.Window

GetRect

Method in class wx.lib.calendar.CalDraw

GetRed

Method in class wx.Image

GetRedoAccelerator

Method in class wx.lib.docview.CommandProcessor

getRedoBitmap

Function in module wx.lib.pydocview

getRedoData

Function in module wx.lib.pydocview

getRedoImage

Function in module wx.lib.pydocview

GetRegionId

Method in class wx.lib.ogl.Shape

GetRegionName

Method in class wx.lib.ogl.Shape

GetRegions

Method in class wx.lib.ogl.Shape

GetRelatedFrame

Method in class wx.html.HtmlWindow

GetRelationship

Method in class wx.IndividualLayoutConstraint

GetRenderer

Method in class wx.grid.GridCellAttr

GetReplaceString

Method in class wx.FindDialogEvent

GetReplaceString

Method in class wx.FindReplaceData

GetRequestedLength

Method in class wx.QueryLayoutInfoEvent

GetResolution

Method in class wx.PostScriptDC

GetResource

Method in class wx.xrc.XmlResourceHandler

GetResult

Method in class wx.FutureCall

GetRetainFieldValidation

Method in class wx.lib.masked.ipaddrctrl.IpAddrCtrlAccessorsMixin

GetRetainFieldValidation

Method in class wx.lib.masked.maskededit.MaskedEditAccessorsMixin

GetReturnCode

Method in class wx.Dialog

GetRGB

Method in class wx.Colour

GetRGB

Method in class wx.Palette

GetRight

Method in class wx.Rect

GetRightCol

Method in class wx.grid.GridRangeSelectEvent

GetRightIndent

Method in class wx.TextAttr

GetRightLocation

Method in class wx.FileSystemHandler

GetRightSide

Method in class wx.lib.ogl.DivisionShape

GetRightSpacing

Method in class wx.lib.foldpanelbar.FoldWindowItem

GetRoot

Method in class wx.lib.mvctree.BasicTreeModel

GetRoot

Method in class wx.lib.mvctree.TreeModel

getRoot

Function in module wx.py.introspect

GetRoot

Method in class wx.xrc.XmlDocument

GetRootId

Method in class wx.GenericDirCtrl

GetRootItem

Method in class wx.TreeCtrl

GetRootItem

Method in class wx.gizmos.TreeListCtrl

GetRotateable

Method in class wx.lib.ogl.PseudoMetaFile

GetRotation

Method in class wx.lib.ogl.DrawnShape

GetRotation

Method in class wx.lib.ogl.Shape

GetRounded

Method in class wx.Point2D

GetRow

Method in class wx.GBPosition

GetRow

Method in class wx.grid.GridCellCoords

GetRow

Method in class wx.grid.GridEditorCreatedEvent

GetRow

Method in class wx.grid.GridEvent

GetRowCount

Method in class wx.Notebook

GetRowCount

Method in class wx.RadioBox

GetRowHeights

Method in class wx.FlexGridSizer

GetRowLabelAlignment

Method in class wx.grid.Grid

GetRowLabelSize

Method in class wx.grid.Grid

GetRowLabelValue

Method in class wx.grid.Grid

GetRowLabelValue

Method in class wx.grid.GridTableBase

GetRowMinimalAcceptableHeight

Method in class wx.grid.Grid

GetRowOrCol

Method in class wx.grid.GridSizeEvent

GetRows

Method in class wx.GridSizer

GetRows

Method in class wx.lib.grids.PyGridSizer

GetRowSize

Method in class wx.grid.Grid

GetRowspan

Method in class wx.GBSpan

GetRudderMax

Method in class wx.Joystick

GetRudderMin

Method in class wx.Joystick

GetRudderPosition

Method in class wx.Joystick

GetSashGravity

Method in class wx.SplitterWindow

GetSashPosition

Method in class wx.SplitterEvent

GetSashPosition

Method in class wx.SplitterWindow

GetSashSize

Method in class wx.SplitterWindow

GetSashVisible

Method in class wx.SashWindow

getSaveAllBitmap

Function in module wx.lib.pydocview

getSaveAllData

Function in module wx.lib.pydocview

getSaveAllImage

Function in module wx.lib.pydocview

getSaveBitmap

Function in module wx.lib.pydocview

GetSaveData

Method in class wx.lib.multisash.MultiSash

GetSaveData

Method in class wx.lib.multisash.MultiSplit

GetSaveData

Method in class wx.lib.multisash.MultiViewLeaf

getSaveData

Function in module wx.lib.pydocview

getSaveImage

Function in module wx.lib.pydocview

GetScale

Method in class wx.gizmos.StaticPicture

GetScaleX

Method in class wx.ScrolledWindow

GetScaleY

Method in class wx.ScrolledWindow

GetScreenType

Method in class wx.SystemSettings

GetScrolledWindow

Method in class wx.gizmos.RemotelyScrolledTreeCtrl

GetScrollLineX

Method in class wx.grid.Grid

GetScrollLineY

Method in class wx.grid.Grid

GetScrollPageSize

Method in class wx.ScrolledWindow

GetScrollPixelsPerUnit

Method in class wx.ScrolledWindow

GetScrollPos

Method in class wx.Window

GetScrollRange

Method in class wx.Window

GetScrollThumb

Method in class wx.Window

GetScrollWidth

Method in class wx.stc.StyledTextCtrl

GetScrollX

Method in class wx.grid.Grid

GetScrollY

Method in class wx.grid.Grid

GetSearchFlags

Method in class wx.stc.StyledTextCtrl

GetSecond

Method in class wx.DateTime

GetSecondarySortValues

Method in class wx.lib.mixins.listctrl.ColumnSorterMixin

GetSecondColour

Method in class wx.lib.foldpanelbar.CaptionBarStyle

GetSeconds

Method in class wx.TimeSpan

GetSelectedCells

Method in class wx.grid.Grid

GetSelectedCols

Method in class wx.grid.Grid

GetSelectedCount

Method in class wx.VListBox

GetSelectedImage

Method in class wx.gizmos.TreeListColumnInfo

GetSelectedItemCount

Method in class wx.ListCtrl

GetSelectedRows

Method in class wx.grid.Grid

GetSelectedText

Method in class wx.stc.StyledTextCtrl

GetSelectedTextBgColour

Method in class wx.html.DefaultHtmlRenderingStyle

GetSelectedTextBgColour

Method in class wx.html.HtmlRenderingStyle

GetSelectedTextColour

Method in class wx.html.DefaultHtmlRenderingStyle

GetSelectedTextColour

Method in class wx.html.HtmlRenderingStyle

GetSelectedTextRaw

Method in class wx.stc.StyledTextCtrl

GetSelectedTextUTF8

Method in class wx.stc.StyledTextCtrl

GetSelection

Method in class wx.BookCtrlBase

GetSelection

Method in class wx.BookCtrlBaseEvent

GetSelection

Method in class wx.CommandEvent

GetSelection

Method in class wx.ItemContainer

GetSelection

Method in class wx.PrintDialogData

GetSelection

Method in class wx.RadioBox

GetSelection

Method in class wx.SingleChoiceDialog

GetSelection

Method in class wx.TextCtrl

GetSelection

Method in class wx.TreeCtrl

GetSelection

Method in class wx.VListBox

GetSelection

Method in class wx.gizmos.TreeListCtrl

GetSelection

Method in class wx.html.HtmlRenderingInfo

GetSelection

Method in class wx.lib.masked.combobox.MaskedComboBoxSelectEvent

getSelection

Method in class wx.lib.mixins.listctrl.ListCtrlSelectionManagerMix

GetSelection

Method in class wx.lib.mvctree.MVCTree

GetSelection

Method in class wx.stc.StyledTextCtrl

GetSelectionBackground

Method in class wx.VListBox

GetSelectionBackground

Method in class wx.grid.Grid

GetSelectionBlockBottomRight

Method in class wx.grid.Grid

GetSelectionBlockTopLeft

Method in class wx.grid.Grid

GetSelectionEnd

Method in class wx.stc.StyledTextCtrl

GetSelectionForeground

Method in class wx.grid.Grid

GetSelectionMode

Method in class wx.grid.Grid

GetSelectionMode

Method in class wx.stc.StyledTextCtrl

GetSelections

Method in class wx.ListBox

GetSelections

Method in class wx.MultiChoiceDialog

GetSelections

Method in class wx.TreeCtrl

GetSelections

Method in class wx.gizmos.TreeListCtrl

GetSelectionStart

Method in class wx.stc.StyledTextCtrl

GetSelectionState

Method in class wx.html.HtmlRenderingState

GetSelectOnEntry

Method in class wx.lib.masked.numctrl.NumCtrl

GetSelEnd

Method in class wx.Slider

GetSelStart

Method in class wx.Slider

GetSensitivityFilter

Method in class wx.lib.ogl.Shape

GetService

Method in class wx.lib.pydocview.DocApp

GetServices

Method in class wx.lib.pydocview.DocApp

GetSetChecked

Method in class wx.UpdateUIEvent

GetSetEnabled

Method in class wx.UpdateUIEvent

GetSetText

Method in class wx.UpdateUIEvent

GetSetupDialog

Method in class wx.PrintDialogData

GetShadowMode

Method in class wx.lib.ogl.Shape

GetShadowWidth

Method in class wx.Gauge

GetShape

Method in class wx.lib.ogl.ShapeEvtHandler

GetShapeList

Method in class wx.lib.ogl.Diagram

GetShift

Method in class wx.stc.StyledTextEvent

GetShiftDecimalChar

Method in class wx.lib.masked.maskededit.MaskedEditAccessorsMixin

GetShiftDecimalChar

Method in class wx.lib.masked.numctrl.NumCtrlAccessorsMixin

GetShortDesc

Method in class wx.FileTypeInfo

GetShortHelp

Method in class wx.ToolBarToolBase

GetShow

Method in class wx.ShowEvent

GetShowHelp

Method in class wx.FontData

GetShowHidden

Method in class wx.GenericDirCtrl

GetShown

Method in class wx.gizmos.TreeListColumnInfo

GetSignedForegroundColour

Method in class wx.lib.masked.ipaddrctrl.IpAddrCtrlAccessorsMixin

GetSignedForegroundColour

Method in class wx.lib.masked.maskededit.MaskedEditAccessorsMixin

GetSignedForegroundColour

Method in class wx.lib.masked.numctrl.NumCtrlAccessorsMixin

GetSingleChoice

Function in package wx

GetSingleChoiceIndex

Function in package wx

GetSingleInstance

Method in class wx.lib.pydocview.DocApp

GetSize

Method in class wx.Bitmap

GetSize

Method in class wx.Caret

GetSize

Method in class wx.CustomDataObject

GetSize

Method in class wx.DC

GetSize

Method in class wx.Image

GetSize

Method in class wx.ImageList

GetSize

Method in class wx.QueryLayoutInfoEvent

GetSize

Method in class wx.Rect

GetSize

Method in class wx.SizeEvent

GetSize

Method in class wx.Sizer

GetSize

Method in class wx.SizerItem

GetSize

Method in class wx.Window

GetSize

Method in class wx.grid.GridCellAttr

GetSize

Function in module wx.lib.imagebrowser

GetSize

Method in class wx.lib.mvctree.NullTransform

GetSize

Method in class wx.lib.mvctree.Transform

GetSize

Method in class wx.lib.ogl.ArrowHead

GetSize

Method in class wx.lib.ogl.ShapeRegion

GetSize

Method in class wx.lib.printout.SetPrintout

GetSize

Method in class wx.xrc.XmlResourceHandler

GetSizeHint

Method in class wx.ArtProvider

GetSizeMM

Method in class wx.DC

GetSizeMMTuple

Method in class wx.DC

GetSizer

Method in class wx.SizerItem

GetSizer

Method in class wx.Window

GetSizeTuple

Method in class wx.Caret

GetSizeTuple

Method in class wx.DC

GetSizeTuple

Method in class wx.Sizer

GetSizeTuple

Method in class wx.Window

GetSkipped

Method in class wx.Event

GetSnapToGrid

Method in class wx.lib.ogl.Diagram

GetSortImages

Method in class wx.lib.mixins.listctrl.ColumnSorterMixin

GetSource

Method in class wx.html.HtmlParser

GetSpaceAttachments

Method in class wx.lib.ogl.Shape

GetSpacer

Method in class wx.SizerItem

GetSpacing

Method in class wx.TreeCtrl

GetSpacing

Method in class wx.lib.foldpanelbar.FoldWindowItem

GetSpacing

Method in class wx.lib.ogl.ArrowHead

GetSpan

Method in class wx.GBSizerItem

GetSpanTuple

Method in class wx.GBSizerItem

GetSplashStyle

Method in class wx.SplashScreen

GetSplashWindow

Method in class wx.SplashScreen

GetSplitMode

Method in class wx.SplitterWindow

GetStart

Method in class wx.html.HtmlBookRecord

GetState

Method in class wx.ListItem

GetState

Method in class wx.html.HtmlRenderingInfo

GetState

Method in class wx.media.MediaCtrl

GetState

Method in class wx.webkit.WebKitStateChangedEvent

GetStateImageList

Method in class wx.TreeCtrl

GetStateImageList

Method in class wx.gizmos.TreeListCtrl

GetStaticBox

Method in class wx.StaticBoxSizer

GetStats

Method in class wx.lib.evtmgr.EventManager

getStatus

Method in class wx.py.editor.Editor

GetStatus

Method in class wx.stc.StyledTextCtrl

GetStatusBar

Method in class wx.Frame

GetStatusBarPane

Method in class wx.Frame

GetStatusText

Method in class wx.StatusBar

GetSTCCursor

Method in class wx.stc.StyledTextCtrl

GetSTCFocus

Method in class wx.stc.StyledTextCtrl

GetStipple

Method in class wx.Brush

GetStockLabel

Function in package wx

getStrAllTopics

Function in module wx.lib.pubsub

GetStream

Method in class wx.FSFile

GetString

Method in class wx.CommandEvent

GetString

Method in class wx.ItemContainer

GetString

Method in class wx.Locale

GetString

Method in class wx.RadioBox

GetString

Method in class wx.TextCtrl

GetStrings

Method in class wx.ItemContainer

GetStrings

Method in class wx.gizmos.EditableListBox

GetStringSelection

Method in class wx.ItemContainer

GetStringSelection

Method in class wx.RadioBox

GetStringSelection

Method in class wx.SingleChoiceDialog

GetStringSelection

Method in class wx.TextCtrl

GetStyle

Method in class wx.Brush

GetStyle

Method in class wx.ConfigBase

GetStyle

Method in class wx.DirDialog

GetStyle

Method in class wx.FileDialog

GetStyle

Method in class wx.Font

GetStyle

Method in class wx.Menu

GetStyle

Method in class wx.NativeFontInfo

GetStyle

Method in class wx.Pen

GetStyle

Method in class wx.TextCtrl

GetStyle

Method in class wx.ToolBarToolBase

GetStyle

Method in class wx.html.HtmlRenderingInfo

GetStyle

Method in class wx.xrc.XmlResourceHandler

GetStyleAt

Method in class wx.stc.StyledTextCtrl

GetStyleBits

Method in class wx.stc.StyledTextCtrl

GetStyledText

Method in class wx.stc.StyledTextCtrl

GetStyleString

Method in class wx.Font

GetSubBitmap

Method in class wx.Bitmap

GetSubImage

Method in class wx.Image

GetSubMenu

Method in class wx.MenuItem

GetSupportedEncodingsCount

Method in class wx.FontMapper

GetSupportedModes

Method in class wx.lib.pydocview.DocOptionsService

GetSupportedTags

Method in class wx.lib.wxpTag.wxpTagHandler

getSymExtent

Method in class wx.lib.plot.PlotGraphics

getSymExtent

Method in class wx.lib.plot.PolyLine

getSymExtent

Method in class wx.lib.plot.PolyMarker

GetSysName

Method in class wx.Locale

GetSystemEncoding

Method in class wx.Locale

GetSystemEncodingName

Method in class wx.Locale

GetSystemLanguage

Method in class wx.Locale

GetTabIndents

Method in class wx.stc.StyledTextCtrl

GetTable

Method in class wx.grid.Grid

GetTable

Method in class wx.lib.printout.PrintGrid

GetTableObject

Method in class wx.grid.GridTableMessage

GetTabs

Method in class wx.TextAttr

GetTabWidth

Method in class wx.stc.StyledTextCtrl

GetTag

Method in class wx.lib.foldpanelbar.CaptionBarEvent

GetTarget

Method in class wx.HelpEvent

GetTarget

Method in class wx.html.HtmlLinkInfo

GetTargetEnd

Method in class wx.stc.StyledTextCtrl

GetTargetStart

Method in class wx.stc.StyledTextCtrl

GetTargetWindow

Method in class wx.ScrolledWindow

GetTemplates

Method in class wx.lib.docview.DocManager

GetText

Method in class wx.ListEvent

GetText

Method in class wx.ListItem

GetText

Method in class wx.MenuItem

GetText

Method in class wx.TextDataObject

GetText

Method in class wx.UpdateUIEvent

GetText

Method in class wx.gizmos.TreeListColumnInfo

GetText

Method in class wx.lib.editor.editor.Editor

GetText

Method in class wx.lib.ogl.ShapeRegion

GetText

Method in class wx.lib.ogl.ShapeTextLine

GetText

Method in class wx.lib.ticker.Ticker

getText

Method in class wx.py.editor.Editor

GetText

Method in class wx.stc.StyledTextCtrl

GetText

Method in class wx.stc.StyledTextEvent

GetText

Method in class wx.xrc.XmlResourceHandler

GetTextBackground

Method in class wx.DC

GetTextBoxSize

Method in class wx.grid.Grid

GetTextBrush

Method in class wx.lib.mvctree.Painter

GetTextColour

Method in class wx.ListCtrl

GetTextColour

Method in class wx.ListItem

GetTextColour

Method in class wx.ListItemAttr

GetTextColour

Method in class wx.MenuItem

GetTextColour

Method in class wx.TextAttr

GetTextColour

Method in class wx.calendar.CalendarDateAttr

GetTextColour

Method in class wx.grid.GridCellAttr

GetTextColour

Method in class wx.lib.mvctree.Painter

GetTextColour

Method in class wx.lib.ogl.Shape

GetTextExtent

Method in class wx.DC

GetTextExtent

Method in class wx.Window

GetTextForeground

Method in class wx.DC

GetTextFromUser

Function in package wx

GetTextLength

Method in class wx.TextDataObject

GetTextLength

Method in class wx.stc.StyledTextCtrl

GetTextLine

Method in class wx.lib.editor.editor.Editor

GetTextPen

Method in class wx.lib.mvctree.Painter

GetTextRange

Method in class wx.stc.StyledTextCtrl

GetTextRangeRaw

Method in class wx.stc.StyledTextCtrl

GetTextRangeUTF8

Method in class wx.stc.StyledTextCtrl

GetTextRaw

Method in class wx.stc.StyledTextCtrl

GetTextUTF8

Method in class wx.stc.StyledTextCtrl

GetThemeBackgroundColour

Method in class wx.Notebook

GetThemeEnabled

Method in class wx.Window

GetThumbLength

Method in class wx.Slider

GetThumbPosition

Method in class wx.ScrollBar

GetThumbSize

Method in class wx.ScrollBar

GetTickFreq

Method in class wx.Slider

GetTicks

Method in class wx.DateTime

GetTimeout

Method in class wx.SplashScreen

GetTimestamp

Method in class wx.Event

GetTimestamp

Method in class wx.Log

GetTip

Method in class wx.TipProvider

GetTip

Method in class wx.ToolTip

GetTitle

Method in class wx.Menu

GetTitle

Method in class wx.Printout

GetTitle

Method in class wx.TopLevelWindow

GetTitle

Method in class wx.Window

GetTitle

Method in class wx.html.HtmlBookRecord

GetTitle

Method in class wx.lib.docview.Document

GetTitle

Method in class wx.lib.floatbar.FloatBar

getTitle

Method in class wx.lib.plot.PlotGraphics

GetTitle

Method in class wx.lib.pydocview.DocTabbedChildFrame

GetTo

Method in class wx.lib.ogl.LineShape

GetToCell

Method in class wx.html.HtmlSelection

getTokens

Function in module wx.py.introspect

GetToolBar

Method in class wx.Frame

GetToolBar

Method in class wx.MDIParentFrame

GetToolBar

Method in class wx.ToolBarToolBase

GetToolBitmapSize

Method in class wx.ToolBarBase

GetToolClientData

Method in class wx.ToolBarBase

GetToolEnabled

Method in class wx.ToolBarBase

GetToolLongHelp

Method in class wx.ToolBarBase

GetToolMargins

Method in class wx.ToolBarBase

GetToolPacking

Method in class wx.ToolBarBase

GetToolPos

Method in class wx.ToolBarBase

GetToolSeparation

Method in class wx.ToolBarBase

GetToolShortHelp

Method in class wx.ToolBarBase

GetToolSize

Method in class wx.ToolBarBase

GetToolState

Method in class wx.ToolBarBase

GetToolTip

Method in class wx.TreeEvent

GetToolTip

Method in class wx.Window

GetTop

Method in class wx.Rect

GetToPage

Method in class wx.PrintDialogData

GetTopAncestor

Method in class wx.lib.ogl.Shape

GetTopItem

Method in class wx.ListCtrl

GetTopLeft

Method in class wx.Rect

GetTopLeftCoords

Method in class wx.grid.GridRangeSelectEvent

GetTopLevelParent

Function in package wx

GetTopLevelWindows

Function in package wx

GetToPos

Method in class wx.html.HtmlSelection

GetToPrivPos

Method in class wx.html.HtmlSelection

GetTopRow

Method in class wx.grid.GridRangeSelectEvent

GetTopSide

Method in class wx.lib.ogl.DivisionShape

GetTopSideColour

Method in class wx.lib.ogl.DivisionShape

GetTopSidePen

Method in class wx.lib.ogl.DivisionShape

GetTopSideStyle

Method in class wx.lib.ogl.DivisionShape

GetTopWindow

Method in class wx.PyApp

GetTotalDays

Method in class wx.DateSpan

GetTotalHeight

Method in class wx.html.HtmlDCRenderer

GetTotalPages

Method in class wx.lib.printout.PrintTable

GetTotalPages

Method in class wx.lib.printout.PrintTableDraw

GetTotalSize

Method in class wx.lib.printout.SetPrintout

GetTraceMask

Method in class wx.Log

GetTraceMasks

Method in class wx.Log

GetTraits

Method in class wx.PyApp

GetTransform

Method in class wx.lib.mvctree.MVCTree

GetTranslation

Function in package wx

GetTransparentColour

Method in class wx.animate.AnimationBase

GetTransparentColour

Method in class wx.animate.AnimationPlayer

GetTransparentColour

Method in class wx.animate.GIFAnimation

GetTreeCtrl

Method in class wx.GenericDirCtrl

GetTreeCtrl

Method in class wx.gizmos.TreeCompanionWindow

GetTreeString

Method in class wx.lib.mvctree.MVCTreeNode

GetTwoPhaseDraw

Method in class wx.stc.StyledTextCtrl

GetType

Method in class wx.DataFormat

GetType

Method in class wx.ImageHandler

GetType

Method in class wx.lib.foldpanelbar.FoldWindowItem

GetType

Method in class wx.xrc.XmlNode

GetTypeName

Method in class wx.grid.GridTableBase

GetUMax

Method in class wx.Joystick

GetUMin

Method in class wx.Joystick

GetUnderlined

Method in class wx.Font

GetUnderlined

Method in class wx.NativeFontInfo

GetUnderlines

Method in class wx.lib.hyperlink.HyperLinkCtrl

GetUndoAccelerator

Method in class wx.lib.docview.CommandProcessor

getUndoBitmap

Function in module wx.lib.pydocview

GetUndoCollection

Method in class wx.stc.StyledTextCtrl

getUndoData

Function in module wx.lib.pydocview

getUndoImage

Function in module wx.lib.pydocview

GetUnicodeKey

Method in class wx.KeyEvent

GetUpButton

Method in class wx.gizmos.EditableListBox

GetUpdateClientRect

Method in class wx.Window

GetUpdateInterval

Method in class wx.UpdateUIEvent

GetUpdateRegion

Method in class wx.Window

GetUPosition

Method in class wx.Joystick

GetUpperDateLimit

Method in class wx.calendar.CalendarCtrl

GetUpperLimit

Method in class wx.DatePickerCtrl

GetURL

Method in class wx.URLDataObject

GetURL

Method in class wx.lib.hyperlink.HyperLinkCtrl

GetURL

Method in class wx.webkit.WebKitStateChangedEvent

GetURLEnd

Method in class wx.TextUrlEvent

GetURLStart

Method in class wx.TextUrlEvent

GetUseAntiAliasing

Method in class wx.stc.StyledTextCtrl

GetUseBestVisual

Method in class wx.PyApp

GetUseFixedWidthFont

Method in class wx.lib.masked.ipaddrctrl.IpAddrCtrlAccessorsMixin

GetUseFixedWidthFont

Method in class wx.lib.masked.maskededit.MaskedEditAccessorsMixin

GetUseFixedWidthFont

Method in class wx.lib.masked.numctrl.NumCtrlAccessorsMixin

GetUseFixedWidthFont

Method in class wx.lib.masked.timectrl.TimeCtrlAccessorsMixin

GetUseFocusIndicator

Method in class wx.lib.buttons.GenButton

GetUseHorizontalScrollBar

Method in class wx.stc.StyledTextCtrl

GetUseParensForNegatives

Method in class wx.lib.masked.maskededit.MaskedEditAccessorsMixin

GetUseParensForNegatives

Method in class wx.lib.masked.numctrl.NumCtrlAccessorsMixin

GetUserConfigDir

Method in class wx.StandardPaths

GetUserData

Method in class wx.SizerItem

GetUserDataDir

Method in class wx.StandardPaths

GetUserHome

Function in package wx

GetUserId

Function in package wx

GetUserLocalDataDir

Method in class wx.StandardPaths

GetUserName

Function in package wx

GetUserScale

Method in class wx.DC

GetUseTabbedMDI

Method in class wx.lib.pydocview.DocApp

GetUseTabs

Method in class wx.stc.StyledTextCtrl

GetUseVerticalScrollBar

Method in class wx.stc.StyledTextCtrl

GetUTCTime

Function in package wx

GetValidator

Method in class wx.Window

GetValidBackgroundColour

Method in class wx.lib.masked.ipaddrctrl.IpAddrCtrlAccessorsMixin

GetValidBackgroundColour

Method in class wx.lib.masked.maskededit.MaskedEditAccessorsMixin

GetValidBackgroundColour

Method in class wx.lib.masked.numctrl.NumCtrlAccessorsMixin

GetValidBackgroundColour

Method in class wx.lib.masked.timectrl.TimeCtrlAccessorsMixin

GetValidFunc

Method in class wx.lib.masked.ipaddrctrl.IpAddrCtrlAccessorsMixin

GetValidFunc

Method in class wx.lib.masked.maskededit.MaskedEditAccessorsMixin

GetValidFunc

Method in class wx.lib.masked.numctrl.NumCtrlAccessorsMixin

GetValidFunc

Method in class wx.lib.masked.timectrl.TimeCtrlAccessorsMixin

GetValidRange

Method in class wx.lib.masked.maskededit.MaskedEditAccessorsMixin

GetValidRegex

Method in class wx.lib.masked.maskededit.MaskedEditAccessorsMixin

GetValidRequired

Method in class wx.lib.masked.ipaddrctrl.IpAddrCtrlAccessorsMixin

GetValidRequired

Method in class wx.lib.masked.maskededit.MaskedEditAccessorsMixin

GetValidRequired

Method in class wx.lib.masked.numctrl.NumCtrlAccessorsMixin

GetValidRequired

Method in class wx.lib.masked.timectrl.TimeCtrlAccessorsMixin

GetValue

Method in class wx.CheckBox

GetValue

Method in class wx.ComboBox

GetValue

Method in class wx.DatePickerCtrl

GetValue

Method in class wx.Gauge

GetValue

Method in class wx.IndividualLayoutConstraint

GetValue

Method in class wx.RadioButton

GetValue

Method in class wx.Slider

GetValue

Method in class wx.SpinButton

GetValue

Method in class wx.SpinCtrl

GetValue

Method in class wx.TextCtrl

GetValue

Method in class wx.TextEntryDialog

GetValue

Method in class wx.ToggleButton

GetValue

Method in class wx.gizmos.LEDNumberCtrl

GetValue

Method in class wx.grid.GridCellAutoWrapStringEditor

GetValue

Method in class wx.grid.GridCellBoolEditor

GetValue

Method in class wx.grid.GridCellChoiceEditor

GetValue

Method in class wx.grid.GridCellEnumEditor

GetValue

Method in class wx.grid.GridCellFloatEditor

GetValue

Method in class wx.grid.GridCellNumberEditor

GetValue

Method in class wx.grid.GridCellTextEditor

GetValue

Method in class wx.grid.GridTableBase

GetValue

Method in class wx.lib.colourchooser.pycolourchooser.PyColourChooser

GetValue

Method in class wx.lib.colourchooser.pycolourslider.PyColourSlider

GetValue

Method in class wx.lib.colourchooser.pypalette.PyPalette

GetValue

Method in class wx.lib.colourselect.ColourSelect

GetValue

Method in class wx.lib.colourselect.ColourSelectEvent

GetValue

Method in class wx.lib.dialogs.MultipleChoiceDialog

GetValue

Method in class wx.lib.filebrowsebutton.FileBrowseButton

GetValue

Method in class wx.lib.intctrl.IntCtrl

GetValue

Method in class wx.lib.intctrl.IntUpdatedEvent

GetValue

Method in class wx.lib.masked.numctrl.NumCtrl

GetValue

Method in class wx.lib.masked.numctrl.NumberUpdatedEvent

GetValue

Method in class wx.lib.masked.timectrl.TimeCtrl

GetValue

Method in class wx.lib.masked.timectrl.TimeUpdatedEvent

GetValue

Method in class wx.lib.popupctl.PopupControl

GetValue

Method in class wx.xrc.XmlProperty

GetValueAsBool

Method in class wx.grid.GridTableBase

GetValueAsDouble

Method in class wx.grid.GridTableBase

GetValueAsLong

Method in class wx.grid.GridTableBase

GetValueString

Method in class wx.lib.dialogs.MultipleChoiceDialog

GetVectorAngle

Method in class wx.Point2D

GetVectorLength

Method in class wx.Point2D

GetVendorName

Method in class wx.ConfigBase

GetVendorName

Method in class wx.PyApp

GetVerbose

Method in class wx.Log

GetVersion

Method in class wx.xrc.XmlDocument

GetVersion

Method in class wx.xrc.XmlResource

GetVeto

Method in class wx.CloseEvent

GetVGap

Method in class wx.GridSizer

GetVgap

Method in class wx.lib.grids.PyGridSizer

GetView

Method in class wx.grid.GridTableBase

GetView

Method in class wx.lib.docview.DocChildFrame

GetView

Method in class wx.lib.docview.DocMDIChildFrame

GetView

Method in class wx.lib.docview.DocPrintout

GetView

Method in class wx.lib.pydocview.DocMDIChildFrame

GetView

Method in class wx.lib.pydocview.DocService

GetView

Method in class wx.lib.pydocview.DocTabbedChildFrame

GetViewEOL

Method in class wx.stc.StyledTextCtrl

GetViewName

Method in class wx.lib.docview.DocTemplate

GetViewName

Method in class wx.lib.docview.View

GetViewRect

Method in class wx.ListCtrl

GetViews

Method in class wx.lib.docview.Document

GetViewStart

Method in class wx.ScrolledWindow

GetViewType

Method in class wx.lib.docview.DocTemplate

GetViewWhiteSpace

Method in class wx.stc.StyledTextCtrl

GetVirtualSize

Method in class wx.Window

GetVirtualSizeTuple

Method in class wx.Window

GetVisible

Method in class wx.GDIObject

GetVisibleBegin

Method in class wx.VScrolledWindow

GetVisibleEnd

Method in class wx.VScrolledWindow

GetVisited

Method in class wx.lib.hyperlink.HyperLinkCtrl

GetVMax

Method in class wx.Joystick

GetVMin

Method in class wx.Joystick

GetVolume

Method in class wx.media.MediaCtrl

GetVPosition

Method in class wx.Joystick

GetVScrollBar

Method in class wx.gizmos.DynamicSashWindow

GetW

Method in class wx.RegionIterator

GetWeekDay

Method in class wx.DateTime

GetWeekDay

Method in class wx.calendar.CalendarEvent

GetWeekDayInSameWeek

Method in class wx.DateTime

GetWeekDayName

Method in class wx.DateTime

GetWeekOfMonth

Method in class wx.DateTime

GetWeekOfYear

Method in class wx.DateTime

GetWeeks

Method in class wx.DateSpan

GetWeeks

Method in class wx.TimeSpan

GetWeight

Method in class wx.Font

GetWeight

Method in class wx.NativeFontInfo

GetWeightString

Method in class wx.Font

GetWheelDelta

Method in class wx.MouseEvent

GetWheelRotation

Method in class wx.MouseEvent

GetWidth

Method in class wx.Bitmap

GetWidth

Method in class wx.Icon

GetWidth

Method in class wx.Image

GetWidth

Method in class wx.ListItem

GetWidth

Method in class wx.Pen

GetWidth

Method in class wx.Rect

GetWidth

Method in class wx.RegionIterator

GetWidth

Method in class wx.Size

GetWidth

Method in class wx.VideoMode

GetWidth

Method in class wx.gizmos.TreeListColumnInfo

GetWidth

Method in class wx.grid.GridCellFloatRenderer

GetWidth

Method in class wx.html.HtmlCell

GetWidth

Method in class wx.lib.ogl.EllipseShape

GetWidth

Method in class wx.lib.ogl.RectangleShape

GetWidth

Method in class wx.lib.ogl.ShapeRegion

getWidth

Method in class wx.lib.printout.PrintBase

GetWildcard

Method in class wx.FileDialog

GetWindow

Method in class wx.Caret

GetWindow

Method in class wx.ChildFocusEvent

GetWindow

Method in class wx.FocusEvent

GetWindow

Method in class wx.SizerItem

GetWindow

Method in class wx.ToolTip

GetWindow

Method in class wx.Validator

GetWindow

Method in class wx.WindowCreateEvent

GetWindow

Method in class wx.WindowDestroyEvent

GetWindow

Method in class wx.animate.AnimationPlayer

GetWindow

Method in class wx.glcanvas.GLContext

GetWindow

Method in class wx.html.HtmlWinParser

GetWindow1

Method in class wx.SplitterWindow

GetWindow2

Method in class wx.SplitterWindow

GetWindowBeingRemoved

Method in class wx.SplitterEvent

GetWindowLength

Method in class wx.lib.foldpanelbar.FoldWindowItem

GetWindowStyleFlag

Method in class wx.Window

GetWindowVariant

Method in class wx.Window

GetWParam

Method in class wx.stc.StyledTextEvent

GetWrapMode

Method in class wx.stc.StyledTextCtrl

GetWrapStartIndent

Method in class wx.stc.StyledTextCtrl

GetWrapVisualFlags

Method in class wx.stc.StyledTextCtrl

GetWrapVisualFlagsLocation

Method in class wx.stc.StyledTextCtrl

GetWriteable

Method in class wx.lib.docview.Document

GetWxDateTime

Method in class wx.lib.masked.timectrl.TimeCtrl

GetX

Method in class wx.KeyEvent

GetX

Method in class wx.MouseEvent

GetX

Method in class wx.Rect

GetX

Method in class wx.RegionIterator

GetX

Method in class wx.SetCursorEvent

GetX

Method in class wx.SplitterEvent

GetX

Method in class wx.lib.ogl.Shape

GetX

Method in class wx.lib.ogl.ShapeTextLine

GetX

Method in class wx.stc.StyledTextEvent

GetXCurrentRange

Method in class wx.lib.plot.PlotCanvas

GetXDisplay

Function in package wx

getXLabel

Method in class wx.lib.plot.PlotGraphics

GetXMax

Method in class wx.Joystick

GetXMaxRange

Method in class wx.lib.plot.PlotCanvas

GetXMin

Method in class wx.Joystick

GetXOffset

Method in class wx.lib.ogl.ArrowHead

GetXOffset

Method in class wx.stc.StyledTextCtrl

GetXRCID

Method in class wx.xrc.XmlResource

GetXSpec

Method in class wx.lib.plot.PlotCanvas

GetXY

Method in class wx.lib.plot.PlotCanvas

GetY

Method in class wx.KeyEvent

GetY

Method in class wx.MouseEvent

GetY

Method in class wx.Rect

GetY

Method in class wx.RegionIterator

GetY

Method in class wx.SetCursorEvent

GetY

Method in class wx.SplitterEvent

GetY

Method in class wx.lib.ogl.Shape

GetY

Method in class wx.lib.ogl.ShapeTextLine

GetY

Method in class wx.stc.StyledTextEvent

GetYCurrentRange

Method in class wx.lib.plot.PlotCanvas

GetYear

Method in class wx.DateTime

GetYear

Method in class wx.lib.calendar.Calendar

GetYearControl

Method in class wx.calendar.CalendarCtrl

GetYearDay

Method in class wx.DateTime

GetYears

Method in class wx.DateSpan

getYLabel

Method in class wx.lib.plot.PlotGraphics

GetYMax

Method in class wx.Joystick

GetYMaxRange

Method in class wx.lib.plot.PlotCanvas

GetYMin

Method in class wx.Joystick

GetYOffset

Method in class wx.lib.ogl.ArrowHead

GetYSpec

Method in class wx.lib.plot.PlotCanvas

GetZMax

Method in class wx.Joystick

GetZMin

Method in class wx.Joystick

GetZoom

Method in class wx.PrintPreview

GetZoom

Method in class wx.stc.StyledTextCtrl

GetZoomControl

Method in class wx.PreviewControlBar

GetZPosition

Method in class wx.Joystick

GetZPosition

Method in class wx.JoystickEvent

gfid

Method in class wx.lib.analogclockopts.ACCustomizationFrame

GIFAnimation

Class in module wx.animate

GIFAnimationCtrl

Class in module wx.animate

GIFHandler

Class in package wx

gizmos

Module in package wx

glcanvas

Module in package wx

GLCanvas

Class in module wx.glcanvas

GLCanvasWithContext

Function in module wx.glcanvas

GLContext

Class in module wx.glcanvas

GMT0

Variable in class wx.DateTime

GMT0

Variable in class wx.DateTime

GMT1

Variable in class wx.DateTime

GMT1

Variable in class wx.DateTime

GMT10

Variable in class wx.DateTime

GMT10

Variable in class wx.DateTime

GMT11

Variable in class wx.DateTime

GMT11

Variable in class wx.DateTime

GMT12

Variable in class wx.DateTime

GMT12

Variable in class wx.DateTime

GMT2

Variable in class wx.DateTime

GMT2

Variable in class wx.DateTime

GMT3

Variable in class wx.DateTime

GMT3

Variable in class wx.DateTime

GMT4

Variable in class wx.DateTime

GMT4

Variable in class wx.DateTime

GMT5

Variable in class wx.DateTime

GMT5

Variable in class wx.DateTime

GMT6

Variable in class wx.DateTime

GMT6

Variable in class wx.DateTime

GMT7

Variable in class wx.DateTime

GMT7

Variable in class wx.DateTime

GMT8

Variable in class wx.DateTime

GMT8

Variable in class wx.DateTime

GMT9

Variable in class wx.DateTime

GMT9

Variable in class wx.DateTime

GMT_1

Variable in class wx.DateTime

GMT_1

Variable in class wx.DateTime

GMT_10

Variable in class wx.DateTime

GMT_10

Variable in class wx.DateTime

GMT_11

Variable in class wx.DateTime

GMT_11

Variable in class wx.DateTime

GMT_12

Variable in class wx.DateTime

GMT_12

Variable in class wx.DateTime

GMT_2

Variable in class wx.DateTime

GMT_2

Variable in class wx.DateTime

GMT_3

Variable in class wx.DateTime

GMT_3

Variable in class wx.DateTime

GMT_4

Variable in class wx.DateTime

GMT_4

Variable in class wx.DateTime

GMT_5

Variable in class wx.DateTime

GMT_5

Variable in class wx.DateTime

GMT_6

Variable in class wx.DateTime

GMT_6

Variable in class wx.DateTime

GMT_7

Variable in class wx.DateTime

GMT_7

Variable in class wx.DateTime

GMT_8

Variable in class wx.DateTime

GMT_8

Variable in class wx.DateTime

GMT_9

Variable in class wx.DateTime

GMT_9

Variable in class wx.DateTime

GoBack

Method in class wx.webkit.WebKitCtrl

GoForward

Method in class wx.webkit.WebKitCtrl

GotoLine

Method in class wx.stc.StyledTextCtrl

GotoPos

Method in class wx.stc.StyledTextCtrl

GotoURL

Method in class wx.lib.hyperlink.HyperLinkCtrl

Gr_Alaska

Variable in class wx.DateTime

Gr_Alaska

Variable in class wx.DateTime

Gr_Albania

Variable in class wx.DateTime

Gr_Albania

Variable in class wx.DateTime

Gr_Austria

Variable in class wx.DateTime

Gr_Austria

Variable in class wx.DateTime

Gr_Austria_Brixen

Variable in class wx.DateTime

Gr_Austria_Brixen

Variable in class wx.DateTime

Gr_Austria_Carinthia

Variable in class wx.DateTime

Gr_Austria_Carinthia

Variable in class wx.DateTime

Gr_Austria_Salzburg

Variable in class wx.DateTime

Gr_Austria_Salzburg

Variable in class wx.DateTime

Gr_Austria_Styria

Variable in class wx.DateTime

Gr_Austria_Styria

Variable in class wx.DateTime

Gr_Austria_Tyrol

Variable in class wx.DateTime

Gr_Austria_Tyrol

Variable in class wx.DateTime

Gr_Belgium

Variable in class wx.DateTime

Gr_Belgium

Variable in class wx.DateTime

Gr_Bulgaria

Variable in class wx.DateTime

Gr_Bulgaria

Variable in class wx.DateTime

Gr_Bulgaria_1

Variable in class wx.DateTime

Gr_Bulgaria_1

Variable in class wx.DateTime

Gr_Bulgaria_2

Variable in class wx.DateTime

Gr_Bulgaria_2

Variable in class wx.DateTime

Gr_Bulgaria_3

Variable in class wx.DateTime

Gr_Bulgaria_3

Variable in class wx.DateTime

Gr_Canada

Variable in class wx.DateTime

Gr_Canada

Variable in class wx.DateTime

Gr_China

Variable in class wx.DateTime

Gr_China

Variable in class wx.DateTime

Gr_China_1

Variable in class wx.DateTime

Gr_China_1

Variable in class wx.DateTime

Gr_China_2

Variable in class wx.DateTime

Gr_China_2

Variable in class wx.DateTime

Gr_Czechoslovakia

Variable in class wx.DateTime

Gr_Czechoslovakia

Variable in class wx.DateTime

Gr_Denmark

Variable in class wx.DateTime

Gr_Denmark

Variable in class wx.DateTime

Gr_Egypt

Variable in class wx.DateTime

Gr_Egypt

Variable in class wx.DateTime

Gr_Estonia

Variable in class wx.DateTime

Gr_Estonia

Variable in class wx.DateTime

Gr_Finland

Variable in class wx.DateTime

Gr_Finland

Variable in class wx.DateTime

Gr_France

Variable in class wx.DateTime

Gr_France

Variable in class wx.DateTime

Gr_France_Alsace

Variable in class wx.DateTime

Gr_France_Alsace

Variable in class wx.DateTime

Gr_France_Lorraine

Variable in class wx.DateTime

Gr_France_Lorraine

Variable in class wx.DateTime

Gr_France_Strasbourg

Variable in class wx.DateTime

Gr_France_Strasbourg

Variable in class wx.DateTime

Gr_Germany

Variable in class wx.DateTime

Gr_Germany

Variable in class wx.DateTime

Gr_Germany_Catholic

Variable in class wx.DateTime

Gr_Germany_Catholic

Variable in class wx.DateTime

Gr_Germany_Protestant

Variable in class wx.DateTime

Gr_Germany_Protestant

Variable in class wx.DateTime

Gr_Germany_Prussia

Variable in class wx.DateTime

Gr_Germany_Prussia

Variable in class wx.DateTime

Gr_GreatBritain

Variable in class wx.DateTime

Gr_GreatBritain

Variable in class wx.DateTime

Gr_Greece

Variable in class wx.DateTime

Gr_Greece

Variable in class wx.DateTime

Gr_Hungary

Variable in class wx.DateTime

Gr_Hungary

Variable in class wx.DateTime

Gr_Ireland

Variable in class wx.DateTime

Gr_Ireland

Variable in class wx.DateTime

Gr_Italy

Variable in class wx.DateTime

Gr_Italy

Variable in class wx.DateTime

Gr_Japan

Variable in class wx.DateTime

Gr_Japan

Variable in class wx.DateTime

Gr_Japan_1

Variable in class wx.DateTime

Gr_Japan_1

Variable in class wx.DateTime

Gr_Japan_2

Variable in class wx.DateTime

Gr_Japan_2

Variable in class wx.DateTime

Gr_Japan_3

Variable in class wx.DateTime

Gr_Japan_3

Variable in class wx.DateTime

Gr_Latvia

Variable in class wx.DateTime

Gr_Latvia

Variable in class wx.DateTime

Gr_Lithuania

Variable in class wx.DateTime

Gr_Lithuania

Variable in class wx.DateTime

Gr_Luxemburg

Variable in class wx.DateTime

Gr_Luxemburg

Variable in class wx.DateTime

Gr_Netherlands

Variable in class wx.DateTime

Gr_Netherlands

Variable in class wx.DateTime

Gr_Netherlands_Friesland

Variable in class wx.DateTime

Gr_Netherlands_Friesland

Variable in class wx.DateTime

Gr_Netherlands_Gelderland

Variable in class wx.DateTime

Gr_Netherlands_Gelderland

Variable in class wx.DateTime

Gr_Netherlands_Groningen

Variable in class wx.DateTime

Gr_Netherlands_Groningen

Variable in class wx.DateTime

Gr_Netherlands_Utrecht

Variable in class wx.DateTime

Gr_Netherlands_Utrecht

Variable in class wx.DateTime

Gr_Norway

Variable in class wx.DateTime

Gr_Norway

Variable in class wx.DateTime

Gr_Poland

Variable in class wx.DateTime

Gr_Poland

Variable in class wx.DateTime

Gr_Portugal

Variable in class wx.DateTime

Gr_Portugal

Variable in class wx.DateTime

Gr_Romania

Variable in class wx.DateTime

Gr_Romania

Variable in class wx.DateTime

Gr_Russia

Variable in class wx.DateTime

Gr_Russia

Variable in class wx.DateTime

Gr_Scotland

Variable in class wx.DateTime

Gr_Scotland

Variable in class wx.DateTime

Gr_Spain

Variable in class wx.DateTime

Gr_Spain

Variable in class wx.DateTime

Gr_Standard

Variable in class wx.DateTime

Gr_Standard

Variable in class wx.DateTime

Gr_Sweden

Variable in class wx.DateTime

Gr_Sweden

Variable in class wx.DateTime

Gr_Switzerland

Variable in class wx.DateTime

Gr_Switzerland

Variable in class wx.DateTime

Gr_Switzerland_Catholic

Variable in class wx.DateTime

Gr_Switzerland_Catholic

Variable in class wx.DateTime

Gr_Switzerland_Protestant

Variable in class wx.DateTime

Gr_Switzerland_Protestant

Variable in class wx.DateTime

Gr_Turkey

Variable in class wx.DateTime

Gr_Turkey

Variable in class wx.DateTime

Gr_Unknown

Variable in class wx.DateTime

Gr_Unknown

Variable in class wx.DateTime

Gr_USA

Variable in class wx.DateTime

Gr_USA

Variable in class wx.DateTime

Gr_Wales

Variable in class wx.DateTime

Gr_Wales

Variable in class wx.DateTime

Gr_Yugoslavia

Variable in class wx.DateTime

Gr_Yugoslavia

Variable in class wx.DateTime

GraphicsInSizeToContents

Variable in class wx.lib.ogl.Shape

GraphicsInSizeToContents

Variable in class wx.lib.ogl.Shape

GraphicsInSizeToContents

Variable in class wx.lib.ogl.Shape

GraphicsInSizeToContents

Variable in class wx.lib.ogl.Shape

GraphicsInSizeToContents

Variable in class wx.lib.ogl.Shape

GraphicsInSizeToContents

Variable in class wx.lib.ogl.Shape

GraphicsInSizeToContents

Variable in class wx.lib.ogl.Shape

GraphicsInSizeToContents

Variable in class wx.lib.ogl.Shape

GraphicsInSizeToContents

Variable in class wx.lib.ogl.Shape

GraphicsInSizeToContents

Variable in class wx.lib.ogl.Shape

GraphicsInSizeToContents

Variable in class wx.lib.ogl.Shape

GraphicsInSizeToContents

Variable in class wx.lib.ogl.Shape

GraphicsInSizeToContents

Variable in class wx.lib.ogl.Shape

GraphicsInSizeToContents

Variable in class wx.lib.ogl.Shape

GraphicsInSizeToContents

Variable in class wx.lib.ogl.Shape

GraphicsInSizeToContents

Variable in class wx.lib.ogl.Shape

GraphicsInSizeToContents

Variable in class wx.lib.ogl.Shape

GraphicsInSizeToContents

Variable in class wx.lib.ogl.Shape

GraphicsStraightenLine

Function in package wx.lib.ogl

grayOut

Function in module wx.lib.imageutils

Green

Method in class wx.Colour

Gregorian

Variable in class wx.DateTime

Gregorian

Variable in class wx.DateTime

grid

Module in package wx

Grid

Class in module wx.grid

grid

Module in package wx.lib.mixins

Grid_GetClassDefaultAttributes

Function in module wx.grid

GridAutoEditMixin

Class in module wx.lib.mixins.grid

GridBagSizer

Class in package wx

GridCellAttr

Class in module wx.grid

GridCellAttrProvider

Class in module wx.grid

GridCellAutoWrapStringEditor

Class in module wx.grid

GridCellAutoWrapStringRenderer

Class in module wx.grid

GridCellBoolEditor

Class in module wx.grid

GridCellBoolRenderer

Class in module wx.grid

GridCellChoiceEditor

Class in module wx.grid

GridCellCoords

Class in module wx.grid

GridCellDateTimeRenderer

Class in module wx.grid

GridCellEditor

Class in module wx.grid

GridCellEnumEditor

Class in module wx.grid

GridCellEnumRenderer

Class in module wx.grid

GridCellFloatEditor

Class in module wx.grid

GridCellFloatRenderer

Class in module wx.grid

GridCellNumberEditor

Class in module wx.grid

GridCellNumberRenderer

Class in module wx.grid

GridCellRenderer

Class in module wx.grid

GridCellStringRenderer

Class in module wx.grid

GridCellTextEditor

Class in module wx.grid

GridColMoveEvent

Class in module wx.lib.gridmovers

GridColMover

Class in module wx.lib.gridmovers

GridEditorCreatedEvent

Class in module wx.grid

GridEvent

Class in module wx.grid

GridLinesEnabled

Method in class wx.grid.Grid

gridmovers

Module in package wx.lib

GridRangeSelectEvent

Class in module wx.grid

GridRowMoveEvent

Class in module wx.lib.gridmovers

GridRowMover

Class in module wx.lib.gridmovers

grids

Module in package wx.lib

GridSizeEvent

Class in module wx.grid

GridSizer

Class in package wx

GridStringTable

Class in module wx.grid

GridTableBase

Class in module wx.grid

GridTableMessage

Class in module wx.grid

h

Variable in module wx._core in class wx.VideoMode

handle_extra_path

Method in class distutils.command.install.install

HandleAboveScreen

Method in class wx.lib.editor.editor.Editor

HandleBelowScreen

Method in class wx.lib.editor.editor.Editor

handleEvent

Method in class wx.lib.evtmgr.EventAdapter

HandleLeftOfScreen

Method in class wx.lib.editor.editor.Editor

HandleParamTag

Method in class wx.lib.wxpTag.wxpTagHandler

HandleReturn

Method in class wx.grid.GridCellEditor

HandleRightOfScreen

Method in class wx.lib.editor.editor.Editor

HandleTag

Method in class wx.lib.wxpTag.wxpTagHandler

HandleWxpTag

Method in class wx.lib.wxpTag.wxpTagHandler

has_data

Method in class distutils.command.install.install

has_headers

Method in class distutils.command.install.install

has_lib

Method in class distutils.command.install.install

has_scripts

Method in class distutils.command.install.install

HasAlignment

Method in class wx.TextAttr

HasAlignment

Method in class wx.grid.GridCellAttr

HasAlpha

Method in class wx.Image

HasAnchor

Method in class wx.html.HtmlWindow

HasAnimation

Method in class wx.animate.AnimationPlayer

hasattrAlwaysReturnsTrue

Function in module wx.py.introspect

HasAttributes

Method in class wx.ListItem

HasBackgroundColour

Method in class wx.ListItemAttr

HasBackgroundColour

Method in class wx.TextAttr

HasBackgroundColour

Method in class wx.calendar.CalendarDateAttr

HasBackgroundColour

Method in class wx.grid.GridCellAttr

HasBorder

Method in class wx.SashWindow

HasBorder

Method in class wx.calendar.CalendarDateAttr

HasBorderColour

Method in class wx.calendar.CalendarDateAttr

hasBuffer

Method in class wx.py.editor.EditorFrame

HasCapture

Method in class wx.Window

hasChanged

Method in class wx.py.buffer.Buffer

hasChanged

Method in class wx.py.editor.Editor

HasCursor

Method in class wx.SetCursorEvent

HasDescendant

Method in class wx.lib.ogl.Shape

HasEditor

Method in class wx.grid.GridCellAttr

HasEnding

Method in class wx.html.HtmlTag

HasEntry

Method in class wx.ConfigBase

HasFeature

Method in class wx.SystemSettings

HasFlag

Method in class wx.TextAttr

HasFlag

Method in class wx.Window

HasFont

Method in class wx.ListItemAttr

HasFont

Method in class wx.TextAttr

HasFont

Method in class wx.calendar.CalendarDateAttr

HasFont

Method in class wx.grid.GridCellAttr

HasGroup

Method in class wx.ConfigBase

HasLeftIndent

Method in class wx.TextAttr

HasMask

Method in class wx.Image

HasModifiers

Method in class wx.KeyEvent

HasMultipleSelection

Method in class wx.VListBox

HasNextPage

Method in class wx.wizard.Wizard

HasOption

Method in class wx.Image

HasOption

Method in class wx.SystemOptions

HasOverflowMode

Method in class wx.grid.GridCellAttr

HasPage

Method in class wx.lib.docview.DocPrintout

HasPage

Method in class wx.lib.plot.PlotPrintout

HasPage

Method in class wx.lib.printout.PrintTable

HasPage

Method in class wx.lib.printout.SetPrintout

HasParam

Method in class wx.html.HtmlTag

HasParam

Method in class wx.xrc.XmlResourceHandler

HasPOV

Method in class wx.Joystick

HasPOV4Dir

Method in class wx.Joystick

HasPOVCTS

Method in class wx.Joystick

HasPrevPage

Method in class wx.wizard.Wizard

HasProp

Method in class wx.xrc.XmlNode

HasReadWriteMode

Method in class wx.grid.GridCellAttr

HasRenderer

Method in class wx.grid.GridCellAttr

HasRightIndent

Method in class wx.TextAttr

HasRudder

Method in class wx.Joystick

HasRun

Method in class wx.FutureCall

HasScrollbar

Method in class wx.Window

HasTabs

Method in class wx.TextAttr

HasTextColour

Method in class wx.ListItemAttr

HasTextColour

Method in class wx.TextAttr

HasTextColour

Method in class wx.calendar.CalendarDateAttr

HasTextColour

Method in class wx.grid.GridCellAttr

HasTransparentBackground

Method in class wx.Window

HasU

Method in class wx.Joystick

HasV

Method in class wx.Joystick

HasZ

Method in class wx.Joystick

HaveRects

Method in class wx.RegionIterator

height

Method in class wx.RegionIterator in class wx.LayoutConstraints

height

Method in class wx.RegionIterator in class wx.LayoutConstraints in class wx.Rect

height

Method in class wx.RegionIterator in class wx.LayoutConstraints in class wx.Rect in class wx.Size

HEIGHT

Variable in class wx.lib.colourchooser.pycolourslider.PyColourSlider

help

Method in class wx.py.shell.ShellFacade

HelpEvent

Class in package wx

HelpProvider

Class in package wx

HelpProvider_Get

Function in package wx

HelpProvider_Set

Function in package wx

helpviewer

Module in package wx.tools

Hide

Method in class wx.Caret

Hide

Method in class wx.DragImage

Hide

Method in class wx.Sizer

Hide

Method in class wx.Window

HideCellEditControl

Method in class wx.grid.Grid

HideEmbeddedWindow

Method in class wx.lib.pydocview.DocMDIParentFrameMixIn

HideGrid

Method in class wx.lib.calendar.Calendar

HideLines

Method in class wx.stc.StyledTextCtrl

HideSelection

Method in class wx.stc.StyledTextCtrl

HideTitle

Method in class wx.lib.calendar.Calendar

HideVScrollbar

Method in class wx.gizmos.RemotelyScrolledTreeCtrl

HighlightPoint

Method in class wx.lib.colourchooser.pypalette.PyPalette

HistoryBack

Method in class wx.html.HtmlWindow

HistoryCanBack

Method in class wx.html.HtmlWindow

HistoryCanForward

Method in class wx.html.HtmlWindow

HistoryClear

Method in class wx.html.HtmlWindow

HistoryForward

Method in class wx.html.HtmlWindow

HitTest

Method in class wx.CheckListBox

HitTest

Method in class wx.ListCtrl

HitTest

Method in class wx.Notebook

HitTest

Method in class wx.TextCtrl

HitTest

Method in class wx.TreeCtrl

HitTest

Method in class wx.VScrolledWindow

HitTest

Method in class wx.Window

HitTest

Method in class wx.calendar.CalendarCtrl

HitTest

Method in class wx.gizmos.TreeListCtrl

HitTest

Method in class wx.lib.floatcanvas.FloatCanvas.FloatCanvas

HitTest

Method in class wx.lib.ogl.LineShape

HitTest

Method in class wx.lib.ogl.PolygonShape

HitTest

Method in class wx.lib.ogl.Shape

HitTestPos

Method in class wx.TextCtrl

HitTestXY

Method in class wx.CheckListBox

HitTestXY

Method in class wx.VScrolledWindow

HitTestXY

Method in class wx.Window

Home

Method in class wx.stc.StyledTextCtrl

HomeDisplay

Method in class wx.stc.StyledTextCtrl

HomeDisplayExtend

Method in class wx.stc.StyledTextCtrl

HomeExtend

Method in class wx.stc.StyledTextCtrl

HomeRectExtend

Method in class wx.stc.StyledTextCtrl

HomeWrap

Method in class wx.stc.StyledTextCtrl

HomeWrapExtend

Method in class wx.stc.StyledTextCtrl

HorizBoundaries

Method in class wx.lib.editor.editor.Editor

HORIZONTAL_STEP

Variable in class wx.lib.colourchooser.pypalette.PyPalette

HorizScroll

Method in class wx.lib.editor.editor.Editor

Hour

Method in class wx.TimeSpan

Hours

Method in class wx.TimeSpan

hours

Variable in module wx.lib.masked.maskededit

HST

Variable in class wx.DateTime

HST

Variable in class wx.DateTime

html

Module in package wx

html_debug

Variable in class wx.lib.shell.PyShellOutput

HtmlBookRecord

Class in module wx.html

HtmlCell

Class in module wx.html

HtmlColourCell

Class in module wx.html

HtmlContainerCell

Class in module wx.html

HtmlContentsItem

Class in module wx.html

HtmlDCRenderer

Class in module wx.html

HtmlEasyPrinting

Class in module wx.html

HtmlFilter

Class in module wx.html

HtmlFontCell

Class in module wx.html

HtmlHelpController

Class in module wx.html

HtmlHelpData

Class in module wx.html

HtmlHelpFrame

Class in module wx.html

HtmlLinkInfo

Class in module wx.html

HtmlListBox

Class in package wx

HtmlParser

Class in module wx.html

HtmlPrintout

Class in module wx.html

HtmlPrintout_AddFilter

Function in module wx.html

HtmlPrintout_CleanUpStatics

Function in module wx.html

HtmlRenderingInfo

Class in module wx.html

HtmlRenderingState

Class in module wx.html

HtmlRenderingStyle

Class in module wx.html

HtmlSearchStatus

Class in module wx.html

HtmlSelection

Class in module wx.html

HtmlTag

Class in module wx.html

HtmlTagHandler

Class in module wx.html

HtmlWidgetCell

Class in module wx.html

HtmlWindow

Class in module wx.html

HtmlWindow_AddFilter

Function in module wx.html

HtmlWindow_GetClassDefaultAttributes

Function in module wx.html

HtmlWinParser

Class in module wx.html

HtmlWinParser_AddTagHandler

Function in module wx.html

HtmlWinTagHandler

Class in module wx.html

HtmlWordCell

Class in module wx.html

hyperlink

Module in package wx.lib

HyperLinkCtrl

Class in module wx.lib.hyperlink

HyperLinkEvent

Class in module wx.lib.hyperlink

ICOHandler

Class in package wx

Icon

Class in package wx

IconBundle

Class in package wx

IconBundleFromFile

Function in package wx

IconBundleFromIcon

Function in package wx

IconFromBitmap

Function in package wx

IconFromLocation

Function in package wx

IconFromXPMData

Function in package wx

Iconize

Method in class wx.TopLevelWindow

Iconized

Method in class wx.IconizeEvent

IconizeEvent

Class in package wx

IconLocation

Class in package wx

id

Variable in class wx.py.buffer.Buffer

ID_ABOUT

Variable in module wx.py.frame

ID_AUTOCOMP

Variable in module wx.py.frame

ID_AUTOCOMP_DOUBLE

Variable in module wx.py.frame

ID_AUTOCOMP_MAGIC

Variable in module wx.py.frame

ID_AUTOCOMP_SHOW

Variable in module wx.py.frame

ID_AUTOCOMP_SINGLE

Variable in module wx.py.frame

ID_CALLTIPS

Variable in module wx.py.frame

ID_CALLTIPS_SHOW

Variable in module wx.py.frame

ID_CLEAR

Variable in module wx.py.frame

ID_CLOSE

Variable in module wx.py.frame

ID_COPY

Variable in module wx.py.frame

ID_COPY_PLUS

Variable in module wx.py.frame

ID_CUT

Variable in module wx.py.frame

ID_EXIT

Variable in module wx.py.frame

ID_MOVE_MODE_BUTTON

Variable in module wx.lib.floatcanvas.NavCanvas

ID_NAMESPACE

Variable in module wx.py.frame

ID_NEW

Variable in module wx.py.frame

ID_OPEN

Variable in module wx.py.frame

ID_PASTE

Variable in module wx.py.frame

ID_PASTE_PLUS

Variable in module wx.py.frame

ID_POINTER_BUTTON

Variable in module wx.lib.floatcanvas.NavCanvas

ID_PRINT

Variable in module wx.py.frame

ID_REDO

Variable in module wx.py.frame

ID_REVERT

Variable in module wx.py.frame

ID_SAVE

Variable in module wx.py.frame

ID_SAVEAS

Variable in module wx.py.frame

ID_SELECTALL

Variable in module wx.py.frame

ID_UNDO

Variable in module wx.py.frame

ID_USEAA

Variable in module wx.py.frame

ID_WRAP

Variable in module wx.py.frame

ID_ZOOM_IN_BUTTON

Variable in module wx.lib.floatcanvas.NavCanvas

ID_ZOOM_OUT_BUTTON

Variable in module wx.lib.floatcanvas.NavCanvas

ID_ZOOM_TO_FIT_BUTTON

Variable in module wx.lib.floatcanvas.NavCanvas

idADD_CUSTOM

Variable in class wx.lib.colourchooser.pycolourchooser.PyColourChooser

IdleEvent

Class in package wx

IdleEvent_CanSend

Function in package wx

IdleEvent_GetMode

Function in package wx

IdleEvent_SetMode

Function in package wx

idSCROLL

Variable in class wx.lib.colourchooser.pycolourchooser.PyColourChooser

Image

Class in package wx

Image_AddHandler

Function in package wx

Image_CanRead

Function in package wx

Image_CanReadStream

Function in package wx

Image_GetImageCount

Function in package wx

Image_GetImageExtWildcard

Function in package wx

Image_InsertHandler

Function in package wx

Image_RemoveHandler

Function in package wx

imagebrowser

Module in package wx.lib

ImageDialog

Class in module wx.lib.imagebrowser

ImageFromBitmap

Function in package wx

ImageFromData

Function in package wx

ImageFromDataWithAlpha

Function in package wx

ImageFromMime

Function in package wx

ImageFromStream

Function in package wx

ImageFromStreamMime

Function in package wx

ImageHandler

Class in package wx

ImageHistogram

Class in package wx

ImageHistogram_MakeKey

Function in package wx

ImageList

Class in package wx

imagelist

Module in package wx.lib.mixins

images

Module in package wx.lib.editor

images

Module in package wx.py

imageutils

Module in package wx.lib

ImageView

Class in module wx.lib.imagebrowser

img2img

Module in package wx.tools

img2png

Module in package wx.tools

img2py

Module in package wx.tools

img2xpm

Module in package wx.tools

in_style

Variable in class wx.lib.shell.PyShellOutput

IncMonth

Method in class wx.lib.calendar.Calendar

IncRef

Method in class wx.grid.GridCellAttr

IncRef

Method in class wx.grid.GridCellEditor

IncRef

Method in class wx.grid.GridCellRenderer

IncTo

Method in class wx.Size

IncYear

Method in class wx.lib.calendar.Calendar

IndicatorGetForeground

Method in class wx.stc.StyledTextCtrl

IndicatorGetStyle

Method in class wx.stc.StyledTextCtrl

IndicatorSetForeground

Method in class wx.stc.StyledTextCtrl

IndicatorSetStyle

Method in class wx.stc.StyledTextCtrl

IndividualLayoutConstraint

Class in package wx

Inflate

Method in class wx.Rect

infoframe

Module in package wx.lib

InheritAttributes

Method in class wx.Window

InheritsBackgroundColour

Method in class wx.Window

Init

Method in class wx.EncodingConverter

Init

Method in class wx.Locale

Init

Method in class wx.NativeFontInfo

Init

Method in class wx.TextAttr

Init

Method in class wx.wizard.Wizard

Init1

Method in class wx.Locale

Init2

Method in class wx.Locale

InitAllHandlers

Method in class wx.xrc.XmlResource

InitAllImageHandlers

Function in package wx

InitAlpha

Method in class wx.Image

InitColors

Method in class wx.lib.foldmenu.FoldOutWindow

InitColours

Method in class wx.lib.buttons.GenButton

InitColours

Method in class wx.lib.colourchooser.pycolourchooser.PyColourChooser

InitColours

Method in class wx.lib.popupctl.PopButton

InitCoords

Method in class wx.lib.editor.editor.Editor

InitDialog

Method in class wx.Panel

InitDialog

Method in class wx.Window

InitDialogEvent

Class in package wx

InitDoubleBuffering

Method in class wx.lib.editor.editor.Editor

InitFonts

Method in class wx.lib.editor.editor.Editor

InitFromFont

Method in class wx.NativeFontInfo

Initialise

Method in class wx.lib.ogl.LineShape

Initialize

Method in class wx.MimeTypesManager

Initialize

Method in class wx.PreviewFrame

Initialize

Method in class wx.SplitterWindow

Initialize

Method in class wx.lib.docview.DocManager

initialize_options

Method in class distutils.cmd.Command

initialize_options

Method in class distutils.command.clean.clean

initialize_options

Method in class distutils.command.install.install

initialize_options

Method in class distutils.command.install_data.install_data

initialize_options

Method in class distutils.command.install_headers.install_headers

InitializePrintData

Method in class wx.lib.pydocview.DocFrameMixIn

InitParser

Method in class wx.html.HtmlParser

InitScale

Method in class wx.lib.calendar.CalDraw

InitScrolling

Method in class wx.lib.editor.editor.Editor

InitValues

Method in class wx.lib.calendar.CalDraw

InitValues

Method in class wx.lib.calendar.PrtCalDraw

InputStream

Class in package wx

InReportView

Method in class wx.ListCtrl

Insert

Method in class wx.ItemContainer

Insert

Method in class wx.ListBox

Insert

Method in class wx.Menu

Insert

Method in class wx.MenuBar

Insert

Method in class wx.Sizer

InsertCell

Method in class wx.html.HtmlContainerCell

InsertChar

Method in class wx.lib.editor.editor.Editor

InsertCheckItem

Method in class wx.Menu

InsertChild

Method in class wx.lib.mvctree.BasicTreeModel

InsertChild

Method in class wx.lib.mvctree.TreeModel

InsertChild

Method in class wx.xrc.XmlNode

InsertCols

Method in class wx.grid.Grid

InsertCols

Method in class wx.grid.GridTableBase

InsertColumn

Method in class wx.ListCtrl

InsertColumn

Method in class wx.gizmos.TreeListCtrl

InsertColumnInfo

Method in class wx.gizmos.TreeListCtrl

InsertColumnItem

Method in class wx.ListCtrl

InsertControl

Method in class wx.ToolBarBase

InsertHandler

Method in class wx.Image

InsertHandler

Method in class wx.xrc.XmlResource

InsertImageItem

Method in class wx.ListCtrl

InsertImageStringItem

Method in class wx.ListCtrl

InsertInCanvas

Method in class wx.lib.ogl.Shape

InsertItem

Method in class wx.ListCtrl

InsertItem

Method in class wx.Menu

InsertItem

Method in class wx.Sizer

InsertItem

Method in class wx.TreeCtrl

InsertItem

Method in class wx.gizmos.TreeListCtrl

InsertItemBefore

Method in class wx.TreeCtrl

InsertItemBefore

Method in class wx.gizmos.TreeListCtrl

InsertItems

Method in class wx.ListBox

InsertLabelTool

Method in class wx.ToolBarBase

insertLineBreak

Method in class wx.py.shell.Shell

InsertLineControlPoint

Method in class wx.lib.ogl.LineShape

InsertMenu

Method in class wx.Menu

InsertPage

Method in class wx.BookCtrlBase

InsertRadioItem

Method in class wx.Menu

InsertRows

Method in class wx.grid.Grid

InsertRows

Method in class wx.grid.GridTableBase

InsertSeparator

Method in class wx.Menu

InsertSeparator

Method in class wx.ToolBarBase

InsertShape

Method in class wx.lib.ogl.Diagram

InsertShape

Method in class wx.lib.ogl.ShapeCanvas

InsertSimpleTool

Method in class wx.ToolBarBase

InsertSizer

Method in class wx.Sizer

InsertSpacer

Method in class wx.Sizer

InsertStringItem

Method in class wx.ListCtrl

InsertText

Method in class wx.stc.StyledTextCtrl

InsertTextRaw

Method in class wx.stc.StyledTextCtrl

InsertTextUTF8

Method in class wx.stc.StyledTextCtrl

InsertTool

Method in class wx.ToolBarBase

InsertToolItem

Method in class wx.ToolBarBase

InsertWindow

Method in class wx.Sizer

Inside

Method in class wx.Rect

InsideXY

Method in class wx.Rect

install

Class in module distutils.command.install

install_data

Class in module distutils.command.install_data

install_headers

Class in module distutils.command.install_headers

InstallControls

Method in class wx.lib.pydocview.DocOptionsService

InstallControls

Method in class wx.lib.pydocview.DocService

InstallControls

Method in class wx.lib.pydocview.FilePropertiesService

InstallControls

Method in class wx.lib.pydocview.WindowMenuService

InstallService

Method in class wx.lib.pydocview.DocApp

intctrl

Module in package wx.lib

IntCtrl

Class in module wx.lib.intctrl

InteractiveInterpreter

Class in module code

InternetFSHandler

Class in package wx

interpreter

Module in package wx.py

Interpreter

Class in module wx.py.interpreter

InterpreterAlaCarte

Class in module wx.py.interpreter

Intersect

Method in class wx.Rect

Intersect

Method in class wx.Region

IntersectRect

Function in package wx

IntersectRect

Method in class wx.Region

IntersectRegion

Method in class wx.Region

Intersects

Method in class wx.GBSizerItem

Intersects

Method in class wx.Rect

IntersectsPos

Method in class wx.GBSizerItem

intro

Variable in class wx.lib.shell.PyShellOutput

introspect

Module in package wx.py

IntUpdatedEvent

Class in module wx.lib.intctrl

IntValidator

Class in module wx.lib.intctrl

Inv_Month

Variable in class wx.DateTime

Inv_Month

Variable in class wx.DateTime

Inv_WeekDay

Variable in class wx.DateTime

Inv_WeekDay

Variable in class wx.DateTime

Inv_Year

Variable in class wx.DateTime

Inv_Year

Variable in class wx.DateTime

InvalidateBestSize

Method in class wx.Window

IPADDR

Variable in module wx.lib.masked.ctrl

IPADDR

Variable in class wx.lib.masked.ctrl.controlTypes

ipaddrctrl

Module in package wx.lib.masked

IpAddrCtrl

Class in module wx.lib.masked.ipaddrctrl

IpAddrCtrlAccessorsMixin

Class in module wx.lib.masked.ipaddrctrl

Is3rdStateAllowedForUser

Method in class wx.CheckBox

Is3State

Method in class wx.CheckBox

IsAcceptedKey

Method in class wx.grid.GridCellEditor

IsAcceptedKey

Method in class wx.lib.sheet.CCellEditor

IsActive

Method in class wx.PyApp

IsActive

Method in class wx.TopLevelWindow

IsActive

Method in class wx.html.HtmlSearchStatus

IsAllowed

Method in class wx.NotifyEvent

IsAllowedTraceMask

Method in class wx.Log

IsAnotherRunning

Method in class wx.SingleInstanceChecker

IsAttached

Method in class wx.Menu

IsAttached

Method in class wx.MenuBar

isatty

Method in class wx.py.pseudo.PseudoFile

isatty

Method in class wx.py.pseudo.PseudoFileErr

isatty

Method in class wx.py.pseudo.PseudoFileIn

isatty

Method in class wx.py.pseudo.PseudoFileOut

IsBackward

Variable in class wx.NavigationKeyEvent

IsBackward

Variable in class wx.NavigationKeyEvent

IsBefore

Method in class wx.html.HtmlCell

IsBeingDeleted

Method in class wx.Window

IsBetween

Method in class wx.DateTime

IsBold

Method in class wx.TreeCtrl

IsBold

Method in class wx.gizmos.TreeListCtrl

IsBusy

Function in package wx

IsButton

Method in class wx.JoystickEvent

IsButton

Method in class wx.MouseEvent

IsButton

Method in class wx.ToolBarToolBase

IsCellEditControlEnabled

Method in class wx.grid.Grid

IsCellEditControlShown

Method in class wx.grid.Grid

IsCheckable

Method in class wx.MenuItem

IsChecked

Method in class wx.CheckBox

IsChecked

Method in class wx.CheckListBox

IsChecked

Method in class wx.CommandEvent

IsChecked

Method in class wx.Menu

IsChecked

Method in class wx.MenuBar

IsChecked

Method in class wx.MenuItem

IsCollapsed

Method in class wx.lib.foldpanelbar.CaptionBar

IsColumnShown

Method in class wx.gizmos.TreeListCtrl

IsCommandEvent

Method in class wx.Event

IsControl

Method in class wx.ToolBarToolBase

IsCreated

Method in class wx.grid.GridCellEditor

IsCurrent

Method in class wx.VListBox

IsCurrentCellReadOnly

Method in class wx.grid.Grid

IsDayInWeekend

Method in class wx.lib.calendar.Calendar

IsDefault

Method in class wx.TextAttr

IsDefault

Method in class wx.lib.masked.maskededit.MaskedEditMixin

IsDoubleBuffered

Method in class wx.lib.mvctree.MVCTree

IsDragResultOk

Function in package wx

IsDST

Method in class wx.DateTime

IsDSTApplicable

Method in class wx.DateTime

IsEarlierThan

Method in class wx.DateTime

IsEditable

Method in class wx.ComboBox

IsEditable

Method in class wx.TextCtrl

IsEditable

Method in class wx.grid.Grid

IsEditable

Method in class wx.lib.mvctree.BasicTreeModel

IsEditable

Method in class wx.lib.mvctree.FSTreeModel

IsEditable

Method in class wx.lib.mvctree.TreeModel

IsEditCancelled

Method in class wx.ListEvent

IsEditCancelled

Method in class wx.TreeEvent

IsEmpty

Method in class wx.ItemContainer

IsEmpty

Method in class wx.Rect

IsEmpty

Method in class wx.Region

IsEmpty

Method in class wx.html.HtmlSelection

IsEmpty

Method in class wx.lib.masked.maskededit.Field

IsEmpty

Method in class wx.lib.masked.maskededit.MaskedEditMixin

IsEmptyCell

Method in class wx.grid.GridTableBase

IsEnabled

Method in class wx.Log

IsEnabled

Method in class wx.Menu

IsEnabled

Method in class wx.MenuBar

IsEnabled

Method in class wx.MenuItem

IsEnabled

Method in class wx.ToolBarToolBase

IsEnabled

Method in class wx.Window

IsEnabled

Method in class wx.tools.dbg.Logger

IsEnabledTop

Method in class wx.MenuBar

IsEncodingAvailable

Method in class wx.FontMapper

IsEnd

Method in class wx.lib.ogl.LineShape

IsEqualTo

Method in class wx.DateTime

IsEqualTo

Method in class wx.TimeSpan

IsEqualUpTo

Method in class wx.DateTime

IsErrorAvailable

Method in class wx.Process

IsExpanded

Method in class wx.TreeCtrl

IsExpanded

Method in class wx.gizmos.TreeListCtrl

IsExpanded

Method in class wx.lib.foldpanelbar.FoldPanelItem

IsExpanded

Method in class wx.lib.mvctree.MVCTree

IsExpandingEnvVars

Method in class wx.ConfigBase

IsExposed

Method in class wx.Window

IsExposedPoint

Method in class wx.Window

IsExposedRect

Method in class wx.Window

IsFalse

Method in class wx.SystemOptions

IsFixedWidth

Method in class wx.Font

IsFloating

Method in class wx.lib.floatbar.FloatBar

IsFormattingCell

Method in class wx.html.HtmlCell

IsForward

Variable in class wx.NavigationKeyEvent

IsForward

Variable in class wx.NavigationKeyEvent

IsFromTab

Method in class wx.NavigationKeyEvent

IsFullScreen

Method in class wx.TopLevelWindow

IsFullySpecified

Method in class wx.Size

IsGroupingAllowed

Method in class wx.lib.masked.numctrl.NumCtrl

IsHatch

Method in class wx.Brush

IsHighlighted

Method in class wx.lib.ogl.Shape

IsHoliday

Method in class wx.calendar.CalendarDateAttr

IsIconInstalled

Method in class wx.TaskBarIcon

IsIconized

Method in class wx.TopLevelWindow

IsInBounds

Method in class wx.lib.intctrl.IntCtrl

IsInBounds

Method in class wx.lib.masked.numctrl.NumCtrl

IsInBounds

Method in class wx.lib.masked.timectrl.TimeCtrl

IsInputAvailable

Method in class wx.Process

IsInputOpened

Method in class wx.Process

IsInSelection

Method in class wx.grid.Grid

IsLaterThan

Method in class wx.DateTime

IsLeaf

Method in class wx.lib.mvctree.BasicTreeModel

IsLeaf

Method in class wx.lib.mvctree.LateFSTreeModel

IsLeaf

Method in class wx.lib.mvctree.TreeModel

isleap

Function in module wx.lib.CDate

IsLeapYear

Method in class wx.DateTime

IsLimited

Method in class wx.lib.intctrl.IntCtrl

IsLimited

Method in class wx.lib.masked.numctrl.NumCtrl

IsLimited

Method in class wx.lib.masked.timectrl.TimeCtrl

IsLine

Method in class wx.lib.editor.editor.Editor

IsLinebreakAllowed

Method in class wx.html.HtmlCell

IsLoaded

Method in class wx.Locale

IsLongAllowed

Method in class wx.lib.intctrl.IntCtrl

IsLongerThan

Method in class wx.TimeSpan

IsMainLoopRunning

Method in class wx.PyApp

IsMaximized

Method in class wx.TopLevelWindow

IsMDI

Method in class wx.lib.pydocview.DocApp

IsModal

Method in class wx.Dialog

IsModified

Method in class wx.TextCtrl

IsModified

Method in class wx.lib.docview.Document

IsModified

Method in class wx.lib.masked.textctrl.BaseMaskedTextCtrl

IsMove

Method in class wx.JoystickEvent

isMultiEvent

Method in class wx.lib.evtmgr.EventMacroInfo

IsMultiLine

Method in class wx.TextCtrl

IsMultiSelect

Method in class wx.lib.mvctree.MVCTree

IsNegative

Method in class wx.TimeSpan

isNegative

Function in module wx.lib.mixins.rubberband

IsNegativeAllowed

Method in class wx.lib.masked.numctrl.NumCtrl

IsNoneAllowed

Method in class wx.lib.intctrl.IntCtrl

IsNoneAllowed

Method in class wx.lib.masked.numctrl.NumCtrl

IsNull

Method in class wx.GDIObject

IsNull

Method in class wx.TimeSpan

IsOfClass

Method in class wx.xrc.XmlResourceHandler

IsOfType

Method in class wx.MimeTypesManager

IsOk

Method in class wx.Caret

IsOk

Method in class wx.Display

IsOk

Method in class wx.IconLocation

IsOk

Method in class wx.Joystick

IsOk

Method in class wx.Locale

IsOk

Method in class wx.Sound

IsOk

Method in class wx.TaskBarIcon

IsOk

Method in class wx.TreeItemId

IsOk

Method in class wx.VideoMode

IsOk

Method in class wx.xrc.XmlDocument

IsOneShot

Method in class wx.Timer

IsOpened

Method in class wx.Clipboard

IsOwnerDrawn

Method in class wx.MenuItem

IsPageScroll

Method in class wx.MouseEvent

IsPassingMessages

Method in class wx.LogChain

IsPassingMessages

Method in class wx.LogWindow

IsPlaying

Method in class wx.animate.AnimationPlayer

IsPlaying

Method in class wx.animate.GIFAnimationCtrl

IsPopup

Method in class wx.MenuEvent

IsPositive

Method in class wx.TimeSpan

IsPreview

Method in class wx.Printout

IsPrimary

Method in class wx.Display

IsReadOnly

Method in class wx.grid.Grid

IsReadOnly

Method in class wx.grid.GridCellAttr

IsRecordingDefaults

Method in class wx.ConfigBase

IsRedirected

Method in class wx.Process

IsRetained

Method in class wx.Window

IsRunning

Method in class wx.EventLoop

IsRunning

Method in class wx.FutureCall

IsRunning

Method in class wx.Timer

IsRunning

Method in class wx.wizard.Wizard

IsSameDate

Method in class wx.DateTime

IsSameTime

Method in class wx.DateTime

IsSDI

Method in class wx.lib.pydocview.DocApp

IsSelected

Method in class wx.ListBox

IsSelected

Method in class wx.ListCtrl

IsSelected

Method in class wx.ListView

IsSelected

Method in class wx.TreeCtrl

IsSelected

Method in class wx.VListBox

IsSelected

Method in class wx.gizmos.TreeListCtrl

IsSelected

Method in class wx.lib.mvctree.MVCTree

IsSelection

Method in class wx.CommandEvent

IsSelection

Method in class wx.grid.Grid

IsSeparator

Method in class wx.MenuItem

IsSeparator

Method in class wx.ToolBarToolBase

IsShorterThan

Method in class wx.TimeSpan

IsShown

Method in class wx.Sizer

IsShown

Method in class wx.SizerItem

IsShown

Method in class wx.Window

IsShown

Method in class wx.lib.ogl.Shape

IsSilent

Method in class wx.Validator

IsSingleLine

Method in class wx.TextCtrl

IsSizer

Method in class wx.SizerItem

IsSorted

Method in class wx.ListBox

IsSpacer

Method in class wx.SizerItem

IsSpline

Method in class wx.lib.ogl.LineShape

IsSplit

Method in class wx.SplitterWindow

IsStockID

Function in package wx

IsStockLabel

Function in package wx

IsStrictlyBetween

Method in class wx.DateTime

IsSubMenu

Method in class wx.MenuItem

IsSupported

Method in class wx.Clipboard

IsSupported

Method in class wx.DataObject

IsSuspended

Method in class wx.tools.dbg.Logger

IsTerminalCell

Method in class wx.html.HtmlCell

IsTicking

Method in class wx.lib.ticker.Ticker

IsToggled

Method in class wx.ToolBarToolBase

IsTopLevel

Method in class wx.Window

IsTransparent

Method in class wx.Image

IsUsingSizeInPixels

Method in class wx.Font

IsValid

Method in class wx.DateTime

IsValid

Method in class wx.FileTypeInfo

IsValid

Method in class wx.animate.AnimationBase

IsValid

Method in class wx.animate.GIFAnimation

IsValid

Method in class wx.lib.masked.maskededit.Field

IsValid

Method in class wx.lib.masked.maskededit.MaskedEditMixin

IsValid

Method in class wx.lib.masked.timectrl.TimeCtrl

IsValid

Method in class wx.lib.ogl.PseudoMetaFile

IsVertical

Method in class wx.Choicebook

IsVertical

Method in class wx.Gauge

IsVertical

Method in class wx.Listbook

IsVertical

Method in class wx.ScrollBar

IsVertical

Method in class wx.SpinButton

IsVertical

Method in class wx.StaticLine

IsVertical

Method in class wx.ToolBarBase

IsVertical

Method in class wx.lib.foldpanelbar.CaptionBar

IsVertical

Method in class wx.lib.foldpanelbar.FoldPanelBar

IsVertical

Method in class wx.lib.foldpanelbar.FoldPanelItem

IsVirtual

Method in class wx.ListCtrl

IsVisible

Method in class wx.Caret

IsVisible

Method in class wx.TreeCtrl

IsVisible

Method in class wx.VScrolledWindow

IsVisible

Method in class wx.gizmos.TreeListCtrl

IsVisible

Method in class wx.grid.Grid

IsVisible

Method in class wx.lib.docview.DocTemplate

IsWestEuropeanCountry

Method in class wx.DateTime

IsWindow

Method in class wx.SizerItem

IsWindowChange

Method in class wx.NavigationKeyEvent

IsWorkDay

Method in class wx.DateTime

IsZMove

Method in class wx.JoystickEvent

ItemContainer

Class in package wx

ItemHasChildren

Method in class wx.TreeCtrl

ItemHasChildren

Method in class wx.gizmos.TreeListCtrl

Jan

Variable in class wx.DateTime

Jan

Variable in class wx.DateTime

JoinLines

Method in class wx.lib.editor.editor.Editor

Joystick

Class in package wx

JoystickEvent

Class in package wx

JPEGHandler

Class in package wx

Jul

Variable in class wx.DateTime

Jul

Variable in class wx.DateTime

Julian

Variable in class wx.DateTime

Julian

Variable in class wx.DateTime

julianDay

Function in module wx.lib.CDate

Jun

Variable in class wx.DateTime

Jun

Variable in class wx.DateTime

KeepCursorOnScreen

Method in class wx.lib.editor.editor.Editor

KeyEvent

Class in package wx

KeywordSearch

Method in class wx.html.HtmlHelpController

KeywordSearch

Method in class wx.html.HtmlHelpFrame

Kill

Function in package wx

Kill

Method in class wx.Process

LabelColorRow

Method in class wx.lib.printout.PrintTableDraw

labelDelta

Variable in class wx.lib.buttons.GenButton

labelDelta

Variable in class wx.lib.buttons.GenButton

labelDelta

Variable in class wx.lib.buttons.GenButton

labelDelta

Variable in class wx.lib.buttons.GenButton

labelDelta

Variable in class wx.lib.buttons.GenButton

labelDelta

Variable in class wx.lib.buttons.GenButton

labelDelta

Variable in class wx.lib.statbmp.GenStaticBitmap

labelDelta

Variable in class wx.lib.stattext.GenStaticText

labelDelta

Variable in class wx.lib.stattext.GenStaticText

LabelShape

Class in package wx.lib.ogl

Language

Variable in module wx._core in class wx.LanguageInfo

LanguageInfo

Class in package wx

last_custom

Variable in class wx.lib.colourchooser.pycolourchooser.PyColourChooser

LastRead

Method in class wx.InputStream

LateFSTreeModel

Class in module wx.lib.mvctree

LaunchDefaultBrowser

Function in package wx

Layout

Method in class wx.Sizer

Layout

Method in class wx.Window

Layout

Method in class wx.html.HtmlCell

Layout

Method in class wx.lib.mvctree.LayoutEngine

Layout

Method in class wx.lib.mvctree.TreeLayout

LayoutAlgorithm

Class in package wx

LayoutAnchors

Class in module wx.lib.anchors

LayoutConstraints

Class in package wx

LayoutEngine

Class in module wx.lib.mvctree

layoutf

Module in package wx.lib

Layoutf

Class in module wx.lib.layoutf

LayoutFrame

Method in class wx.LayoutAlgorithm

LayoutMDIFrame

Method in class wx.LayoutAlgorithm

layoutwalk

Method in class wx.lib.mvctree.TreeLayout

LayoutWindow

Method in class wx.LayoutAlgorithm

leapdays

Function in module wx.lib.CDate

Leaving

Method in class wx.MouseEvent

LEDNumberCtrl

Class in module wx.gizmos

left

Class in module wx.gizmos in class wx.LayoutConstraints

left

Class in module wx.gizmos in class wx.LayoutConstraints in class wx.Rect

LeftDClick

Method in class wx.MouseEvent

LeftDoubleClickEvent

Method in class wx.lib.floatcanvas.FloatCanvas.FloatCanvas

LeftDown

Method in class wx.MouseEvent

LeftDownEvent

Method in class wx.lib.floatcanvas.FloatCanvas.FloatCanvas

LeftIsDown

Method in class wx.MouseEvent

LeftOf

Method in class wx.IndividualLayoutConstraint

LeftOfScreen

Method in class wx.lib.editor.editor.Editor

LeftUp

Method in class wx.MouseEvent

LeftUpEvent

Method in class wx.lib.floatcanvas.FloatCanvas.FloatCanvas

Length

Method in class wx.media.MediaCtrl

lib

Package in package wx

Line

Class in module wx.lib.floatcanvas.FloatCanvas

LineAndFillMixin

Class in module wx.lib.floatcanvas.FloatCanvas

LineControlPoint

Class in package wx.lib.ogl

LineCopy

Method in class wx.stc.StyledTextCtrl

LineCut

Method in class wx.stc.StyledTextCtrl

LineDelete

Method in class wx.stc.StyledTextCtrl

LineDown

Method in class wx.Window

LineDown

Method in class wx.stc.StyledTextCtrl

LineDownExtend

Method in class wx.stc.StyledTextCtrl

LineDownRectExtend

Method in class wx.stc.StyledTextCtrl

LineDuplicate

Method in class wx.stc.StyledTextCtrl

LineEnd

Method in class wx.stc.StyledTextCtrl

LineEndDisplay

Method in class wx.stc.StyledTextCtrl

LineEndDisplayExtend

Method in class wx.stc.StyledTextCtrl

LineEndExtend

Method in class wx.stc.StyledTextCtrl

LineEndRectExtend

Method in class wx.stc.StyledTextCtrl

LineEndWrap

Method in class wx.stc.StyledTextCtrl

LineEndWrapExtend

Method in class wx.stc.StyledTextCtrl

LineFromPosition

Method in class wx.stc.StyledTextCtrl

LineLength

Method in class wx.stc.StyledTextCtrl

LineOnlyMixin

Class in module wx.lib.floatcanvas.FloatCanvas

LinePainter

Class in module wx.lib.mvctree

LineScroll

Method in class wx.stc.StyledTextCtrl

LineScrollDown

Method in class wx.stc.StyledTextCtrl

LineScrollUp

Method in class wx.stc.StyledTextCtrl

LineShape

Class in package wx.lib.ogl

LinesInFile

Method in class wx.lib.editor.editor.Editor

LinesJoin

Method in class wx.stc.StyledTextCtrl

LinesOnScreen

Method in class wx.stc.StyledTextCtrl

LineSplitter

Function in module wx.lib.editor.editor

LinesSplit

Method in class wx.stc.StyledTextCtrl

LineStyleList

Variable in class wx.lib.floatcanvas.FloatCanvas.DrawObject

LineStyleList

Variable in class wx.lib.floatcanvas.FloatCanvas.DrawObject

LineStyleList

Variable in class wx.lib.floatcanvas.FloatCanvas.DrawObject

LineStyleList

Variable in class wx.lib.floatcanvas.FloatCanvas.DrawObject

LineStyleList

Variable in class wx.lib.floatcanvas.FloatCanvas.DrawObject

LineStyleList

Variable in class wx.lib.floatcanvas.FloatCanvas.DrawObject

LineStyleList

Variable in class wx.lib.floatcanvas.FloatCanvas.DrawObject

LineStyleList

Variable in class wx.lib.floatcanvas.FloatCanvas.DrawObject

LineStyleList

Variable in class wx.lib.floatcanvas.FloatCanvas.DrawObject

LineStyleList

Variable in class wx.lib.floatcanvas.FloatCanvas.DrawObject

LineStyleList

Variable in class wx.lib.floatcanvas.FloatCanvas.DrawObject

LineStyleList

Variable in class wx.lib.floatcanvas.FloatCanvas.DrawObject

LineTranspose

Method in class wx.stc.StyledTextCtrl

LineTrimmer

Function in module wx.lib.editor.editor

LineUp

Method in class wx.Window

LineUp

Method in class wx.stc.StyledTextCtrl

LineUpExtend

Method in class wx.stc.StyledTextCtrl

LineUpRectExtend

Method in class wx.stc.StyledTextCtrl

Listbook

Class in package wx

ListbookEvent

Class in package wx

ListBox

Class in package wx

ListBox_GetClassDefaultAttributes

Function in package wx

ListCtrl

Class in package wx

listctrl

Module in package wx.lib.mixins

ListCtrl_GetClassDefaultAttributes

Function in package wx

ListCtrlAutoWidthMixin

Class in module wx.lib.mixins.listctrl

ListCtrlSelectionManagerMix

Class in module wx.lib.mixins.listctrl

ListEvent

Class in package wx

ListItem

Class in package wx

ListItemAttr

Class in package wx

ListView

Class in package wx

Load

Method in class wx.FileHistory

Load

Method in class wx.media.MediaCtrl

Load

Method in class wx.xrc.XmlDocument

Load

Method in class wx.xrc.XmlResource

LoadBitmap

Method in class wx.xrc.XmlResource

LoadChildren

Method in class wx.lib.mvctree.MVCTree

LoadDialog

Method in class wx.xrc.XmlResource

LoadFile

Method in class wx.Bitmap

LoadFile

Method in class wx.Icon

LoadFile

Method in class wx.Image

LoadFile

Method in class wx.TextCtrl

LoadFile

Method in class wx.animate.AnimationBase

LoadFile

Method in class wx.animate.GIFAnimation

LoadFile

Method in class wx.animate.GIFAnimationCtrl

LoadFile

Method in class wx.html.HtmlWindow

LoadFile

Method in class wx.stc.StyledTextCtrl

LoadFileSelector

Function in package wx

LoadFrame

Method in class wx.xrc.XmlResource

LoadFromMetaFile

Method in class wx.lib.ogl.DrawnShape

LoadFromMetaFile

Method in class wx.lib.ogl.PseudoMetaFile

LoadFromStream

Method in class wx.xrc.XmlDocument

LoadFromString

Method in class wx.xrc.XmlResource

LoadFromURI

Method in class wx.media.MediaCtrl

LoadIcon

Method in class wx.xrc.XmlResource

LoadImages

Method in class wx.lib.editor.editor.Editor

LoadMenu

Method in class wx.xrc.XmlResource

LoadMenuBar

Method in class wx.xrc.XmlResource

LoadMenuBarOnFrame

Method in class wx.xrc.XmlResource

LoadMimeFile

Method in class wx.Image

LoadMimeStream

Method in class wx.Image

LoadObject

Method in class wx.lib.docview.Document

LoadObject

Method in class wx.xrc.XmlResource

LoadOnDialog

Method in class wx.xrc.XmlResource

LoadOnFrame

Method in class wx.xrc.XmlResource

LoadOnObject

Method in class wx.xrc.XmlResource

LoadOnPanel

Method in class wx.xrc.XmlResource

LoadPage

Method in class wx.html.HtmlWindow

LoadPanel

Method in class wx.xrc.XmlResource

LoadStream

Method in class wx.Image

LoadToolBar

Method in class wx.xrc.XmlResource

LoadURL

Method in class wx.webkit.WebKitCtrl

Local

Variable in class wx.DateTime

Local

Variable in class wx.DateTime

Locale

Class in package wx

Locale_AddCatalogLookupPathPrefix

Function in package wx

Locale_AddLanguage

Function in package wx

Locale_FindLanguageInfo

Function in package wx

Locale_GetLanguageInfo

Function in package wx

Locale_GetLanguageName

Function in package wx

Locale_GetSystemEncoding

Function in package wx

Locale_GetSystemEncodingName

Function in package wx

Locale_GetSystemLanguage

Function in package wx

Log

Class in package wx

log

Method in class wx.tools.dbg.Logger

Log_AddTraceMask

Function in package wx

Log_ClearTraceMasks

Function in package wx

Log_DontCreateOnDemand

Function in package wx

Log_EnableLogging

Function in package wx

Log_FlushActive

Function in package wx

Log_GetActiveTarget

Function in package wx

Log_GetLogLevel

Function in package wx

Log_GetTimestamp

Function in package wx

Log_GetTraceMask

Function in package wx

Log_GetTraceMasks

Function in package wx

Log_GetVerbose

Function in package wx

Log_IsAllowedTraceMask

Function in package wx

Log_IsEnabled

Function in package wx

Log_OnLog

Function in package wx

Log_RemoveTraceMask

Function in package wx

Log_Resume

Function in package wx

Log_SetActiveTarget

Function in package wx

Log_SetLogLevel

Function in package wx

Log_SetTimestamp

Function in package wx

Log_SetTraceMask

Function in package wx

Log_SetVerbose

Function in package wx

Log_Suspend

Function in package wx

Log_TimeStamp

Function in package wx

LogChain

Class in package wx

LogDebug

Function in package wx

LogError

Function in package wx

LogFatalError

Function in package wx

LogGeneric

Function in package wx

Logger

Class in module wx.tools.dbg

LogGui

Class in package wx

LogicalToDeviceX

Method in class wx.DC

LogicalToDeviceXRel

Method in class wx.DC

LogicalToDeviceY

Method in class wx.DC

LogicalToDeviceYRel

Method in class wx.DC

LogicalToPhysicalAttachment

Method in class wx.lib.ogl.Shape

LogInfo

Function in package wx

LogMessage

Function in package wx

LogNull

Class in package wx

LogStatus

Function in package wx

LogStatusFrame

Function in package wx

LogStderr

Class in package wx

LogSysError

Function in package wx

LogTextCtrl

Class in package wx

LogTrace

Function in package wx

LogVerbose

Function in package wx

LogWarning

Function in package wx

LogWindow

Class in package wx

Lower

Method in class wx.Window

LowerCase

Method in class wx.stc.StyledTextCtrl

lstripPrompt

Method in class wx.py.shell.Shell

m_altDown

Method in class wx.py.shell.Shell in class wx.KeyEvent

m_altDown

Method in class wx.py.shell.Shell in class wx.KeyEvent in class wx.MouseEvent

m_buttonChange

Method in class wx.py.shell.Shell in class wx.KeyEvent in class wx.MouseEvent in class wx.JoystickEvent

m_buttonState

Method in class wx.py.shell.Shell in class wx.KeyEvent in class wx.MouseEvent in class wx.JoystickEvent in class wx.JoystickEvent

m_code

Method in class wx.py.shell.Shell in class wx.KeyEvent in class wx.MouseEvent in class wx.JoystickEvent in class wx.JoystickEvent in class wx.ListEvent

m_col

Method in class wx.py.shell.Shell in class wx.KeyEvent in class wx.MouseEvent in class wx.JoystickEvent in class wx.JoystickEvent in class wx.ListEvent in class wx.ListEvent

m_col

Method in class wx.py.shell.Shell in class wx.KeyEvent in class wx.MouseEvent in class wx.JoystickEvent in class wx.JoystickEvent in class wx.ListEvent in class wx.ListEvent in class wx.ListItem

m_controlDown

Method in class wx.py.shell.Shell in class wx.KeyEvent in class wx.MouseEvent in class wx.JoystickEvent in class wx.JoystickEvent in class wx.ListEvent in class wx.ListEvent in class wx.ListItem in class wx.KeyEvent

m_controlDown

Method in class wx.py.shell.Shell in class wx.KeyEvent in class wx.MouseEvent in class wx.JoystickEvent in class wx.JoystickEvent in class wx.ListEvent in class wx.ListEvent in class wx.ListItem in class wx.KeyEvent in class wx.MouseEvent

m_data

Method in class wx.py.shell.Shell in class wx.KeyEvent in class wx.MouseEvent in class wx.JoystickEvent in class wx.JoystickEvent in class wx.ListEvent in class wx.ListEvent in class wx.ListItem in class wx.KeyEvent in class wx.MouseEvent in class wx.ListItem

m_exitcode

Method in class wx.py.shell.Shell in class wx.KeyEvent in class wx.MouseEvent in class wx.JoystickEvent in class wx.JoystickEvent in class wx.ListEvent in class wx.ListEvent in class wx.ListItem in class wx.KeyEvent in class wx.MouseEvent in class wx.ListItem in class wx.ProcessEvent

m_format

Method in class wx.py.shell.Shell in class wx.KeyEvent in class wx.MouseEvent in class wx.JoystickEvent in class wx.JoystickEvent in class wx.ListEvent in class wx.ListEvent in class wx.ListItem in class wx.KeyEvent in class wx.MouseEvent in class wx.ListItem in class wx.ProcessEvent in class wx.ListItem

m_image

Method in class wx.py.shell.Shell in class wx.KeyEvent in class wx.MouseEvent in class wx.JoystickEvent in class wx.JoystickEvent in class wx.ListEvent in class wx.ListEvent in class wx.ListItem in class wx.KeyEvent in class wx.MouseEvent in class wx.ListItem in class wx.ProcessEvent in class wx.ListItem in class wx.ListItem

m_item

Method in class wx.py.shell.Shell in class wx.KeyEvent in class wx.MouseEvent in class wx.JoystickEvent in class wx.JoystickEvent in class wx.ListEvent in class wx.ListEvent in class wx.ListItem in class wx.KeyEvent in class wx.MouseEvent in class wx.ListItem in class wx.ProcessEvent in class wx.ListItem in class wx.ListItem in class wx.ListEvent

m_itemId

Method in class wx.py.shell.Shell in class wx.KeyEvent in class wx.MouseEvent in class wx.JoystickEvent in class wx.JoystickEvent in class wx.ListEvent in class wx.ListEvent in class wx.ListItem in class wx.KeyEvent in class wx.MouseEvent in class wx.ListItem in class wx.ProcessEvent in class wx.ListItem in class wx.ListItem in class wx.ListEvent in class wx.ListItem

m_itemIndex

Method in class wx.py.shell.Shell in class wx.KeyEvent in class wx.MouseEvent in class wx.JoystickEvent in class wx.JoystickEvent in class wx.ListEvent in class wx.ListEvent in class wx.ListItem in class wx.KeyEvent in class wx.MouseEvent in class wx.ListItem in class wx.ProcessEvent in class wx.ListItem in class wx.ListItem in class wx.ListEvent in class wx.ListItem in class wx.ListEvent

m_joyStick

Method in class wx.py.shell.Shell in class wx.KeyEvent in class wx.MouseEvent in class wx.JoystickEvent in class wx.JoystickEvent in class wx.ListEvent in class wx.ListEvent in class wx.ListItem in class wx.KeyEvent in class wx.MouseEvent in class wx.ListItem in class wx.ProcessEvent in class wx.ListItem in class wx.ListItem in class wx.ListEvent in class wx.ListItem in class wx.ListEvent in class wx.JoystickEvent

m_keyCode

Method in class wx.py.shell.Shell in class wx.KeyEvent in class wx.MouseEvent in class wx.JoystickEvent in class wx.JoystickEvent in class wx.ListEvent in class wx.ListEvent in class wx.ListItem in class wx.KeyEvent in class wx.MouseEvent in class wx.ListItem in class wx.ProcessEvent in class wx.ListItem in class wx.ListItem in class wx.ListEvent in class wx.ListItem in class wx.ListEvent in class wx.JoystickEvent in class wx.KeyEvent

m_leftDown

Method in class wx.py.shell.Shell in class wx.KeyEvent in class wx.MouseEvent in class wx.JoystickEvent in class wx.JoystickEvent in class wx.ListEvent in class wx.ListEvent in class wx.ListItem in class wx.KeyEvent in class wx.MouseEvent in class wx.ListItem in class wx.ProcessEvent in class wx.ListItem in class wx.ListItem in class wx.ListEvent in class wx.ListItem in class wx.ListEvent in class wx.JoystickEvent in class wx.KeyEvent in class wx.MouseEvent

m_linesPerAction

Method in class wx.py.shell.Shell in class wx.KeyEvent in class wx.MouseEvent in class wx.JoystickEvent in class wx.JoystickEvent in class wx.ListEvent in class wx.ListEvent in class wx.ListItem in class wx.KeyEvent in class wx.MouseEvent in class wx.ListItem in class wx.ProcessEvent in class wx.ListItem in class wx.ListItem in class wx.ListEvent in class wx.ListItem in class wx.ListEvent in class wx.JoystickEvent in class wx.KeyEvent in class wx.MouseEvent in class wx.MouseEvent

m_mask

Method in class wx.py.shell.Shell in class wx.KeyEvent in class wx.MouseEvent in class wx.JoystickEvent in class wx.JoystickEvent in class wx.ListEvent in class wx.ListEvent in class wx.ListItem in class wx.KeyEvent in class wx.MouseEvent in class wx.ListItem in class wx.ProcessEvent in class wx.ListItem in class wx.ListItem in class wx.ListEvent in class wx.ListItem in class wx.ListEvent in class wx.JoystickEvent in class wx.KeyEvent in class wx.MouseEvent in class wx.MouseEvent in class wx.ListItem

m_metaDown

Method in class wx.py.shell.Shell in class wx.KeyEvent in class wx.MouseEvent in class wx.JoystickEvent in class wx.JoystickEvent in class wx.ListEvent in class wx.ListEvent in class wx.ListItem in class wx.KeyEvent in class wx.MouseEvent in class wx.ListItem in class wx.ProcessEvent in class wx.ListItem in class wx.ListItem in class wx.ListEvent in class wx.ListItem in class wx.ListEvent in class wx.JoystickEvent in class wx.KeyEvent in class wx.MouseEvent in class wx.MouseEvent in class wx.ListItem in class wx.KeyEvent

m_metaDown

Method in class wx.py.shell.Shell in class wx.KeyEvent in class wx.MouseEvent in class wx.JoystickEvent in class wx.JoystickEvent in class wx.ListEvent in class wx.ListEvent in class wx.ListItem in class wx.KeyEvent in class wx.MouseEvent in class wx.ListItem in class wx.ProcessEvent in class wx.ListItem in class wx.ListItem in class wx.ListEvent in class wx.ListItem in class wx.ListEvent in class wx.JoystickEvent in class wx.KeyEvent in class wx.MouseEvent in class wx.MouseEvent in class wx.ListItem in class wx.KeyEvent in class wx.MouseEvent

m_middleDown

Method in class wx.py.shell.Shell in class wx.KeyEvent in class wx.MouseEvent in class wx.JoystickEvent in class wx.JoystickEvent in class wx.ListEvent in class wx.ListEvent in class wx.ListItem in class wx.KeyEvent in class wx.MouseEvent in class wx.ListItem in class wx.ProcessEvent in class wx.ListItem in class wx.ListItem in class wx.ListEvent in class wx.ListItem in class wx.ListEvent in class wx.JoystickEvent in class wx.KeyEvent in class wx.MouseEvent in class wx.MouseEvent in class wx.ListItem in class wx.KeyEvent in class wx.MouseEvent in class wx.MouseEvent

m_oldItemIndex

Method in class wx.py.shell.Shell in class wx.KeyEvent in class wx.MouseEvent in class wx.JoystickEvent in class wx.JoystickEvent in class wx.ListEvent in class wx.ListEvent in class wx.ListItem in class wx.KeyEvent in class wx.MouseEvent in class wx.ListItem in class wx.ProcessEvent in class wx.ListItem in class wx.ListItem in class wx.ListEvent in class wx.ListItem in class wx.ListEvent in class wx.JoystickEvent in class wx.KeyEvent in class wx.MouseEvent in class wx.MouseEvent in class wx.ListItem in class wx.KeyEvent in class wx.MouseEvent in class wx.MouseEvent in class wx.ListEvent

m_pid

Method in class wx.py.shell.Shell in class wx.KeyEvent in class wx.MouseEvent in class wx.JoystickEvent in class wx.JoystickEvent in class wx.ListEvent in class wx.ListEvent in class wx.ListItem in class wx.KeyEvent in class wx.MouseEvent in class wx.ListItem in class wx.ProcessEvent in class wx.ListItem in class wx.ListItem in class wx.ListEvent in class wx.ListItem in class wx.ListEvent in class wx.JoystickEvent in class wx.KeyEvent in class wx.MouseEvent in class wx.MouseEvent in class wx.ListItem in class wx.KeyEvent in class wx.MouseEvent in class wx.MouseEvent in class wx.ListEvent in class wx.ProcessEvent

m_pItem

Method in class wx.py.shell.Shell in class wx.KeyEvent in class wx.MouseEvent in class wx.JoystickEvent in class wx.JoystickEvent in class wx.ListEvent in class wx.ListEvent in class wx.ListItem in class wx.KeyEvent in class wx.MouseEvent in class wx.ListItem in class wx.ProcessEvent in class wx.ListItem in class wx.ListItem in class wx.ListEvent in class wx.ListItem in class wx.ListEvent in class wx.JoystickEvent in class wx.KeyEvent in class wx.MouseEvent in class wx.MouseEvent in class wx.ListItem in class wx.KeyEvent in class wx.MouseEvent in class wx.MouseEvent in class wx.ListEvent in class wx.ProcessEvent in class wx.TreeItemId

m_pointDrag

Method in class wx.py.shell.Shell in class wx.KeyEvent in class wx.MouseEvent in class wx.JoystickEvent in class wx.JoystickEvent in class wx.ListEvent in class wx.ListEvent in class wx.ListItem in class wx.KeyEvent in class wx.MouseEvent in class wx.ListItem in class wx.ProcessEvent in class wx.ListItem in class wx.ListItem in class wx.ListEvent in class wx.ListItem in class wx.ListEvent in class wx.JoystickEvent in class wx.KeyEvent in class wx.MouseEvent in class wx.MouseEvent in class wx.ListItem in class wx.KeyEvent in class wx.MouseEvent in class wx.MouseEvent in class wx.ListEvent in class wx.ProcessEvent in class wx.TreeItemId in class wx.ListEvent

m_pos

Method in class wx.py.shell.Shell in class wx.KeyEvent in class wx.MouseEvent in class wx.JoystickEvent in class wx.JoystickEvent in class wx.ListEvent in class wx.ListEvent in class wx.ListItem in class wx.KeyEvent in class wx.MouseEvent in class wx.ListItem in class wx.ProcessEvent in class wx.ListItem in class wx.ListItem in class wx.ListEvent in class wx.ListItem in class wx.ListEvent in class wx.JoystickEvent in class wx.KeyEvent in class wx.MouseEvent in class wx.MouseEvent in class wx.ListItem in class wx.KeyEvent in class wx.MouseEvent in class wx.MouseEvent in class wx.ListEvent in class wx.ProcessEvent in class wx.TreeItemId in class wx.ListEvent in class wx.JoystickEvent

m_pos

Method in class wx.py.shell.Shell in class wx.KeyEvent in class wx.MouseEvent in class wx.JoystickEvent in class wx.JoystickEvent in class wx.ListEvent in class wx.ListEvent in class wx.ListItem in class wx.KeyEvent in class wx.MouseEvent in class wx.ListItem in class wx.ProcessEvent in class wx.ListItem in class wx.ListItem in class wx.ListEvent in class wx.ListItem in class wx.ListEvent in class wx.JoystickEvent in class wx.KeyEvent in class wx.MouseEvent in class wx.MouseEvent in class wx.ListItem in class wx.KeyEvent in class wx.MouseEvent in class wx.MouseEvent in class wx.ListEvent in class wx.ProcessEvent in class wx.TreeItemId in class wx.ListEvent in class wx.JoystickEvent in class wx.MoveEvent

m_rawCode

Method in class wx.py.shell.Shell in class wx.KeyEvent in class wx.MouseEvent in class wx.JoystickEvent in class wx.JoystickEvent in class wx.ListEvent in class wx.ListEvent in class wx.ListItem in class wx.KeyEvent in class wx.MouseEvent in class wx.ListItem in class wx.ProcessEvent in class wx.ListItem in class wx.ListItem in class wx.ListEvent in class wx.ListItem in class wx.ListEvent in class wx.JoystickEvent in class wx.KeyEvent in class wx.MouseEvent in class wx.MouseEvent in class wx.ListItem in class wx.KeyEvent in class wx.MouseEvent in class wx.MouseEvent in class wx.ListEvent in class wx.ProcessEvent in class wx.TreeItemId in class wx.ListEvent in class wx.JoystickEvent in class wx.MoveEvent in class wx.KeyEvent

m_rawFlags

Method in class wx.py.shell.Shell in class wx.KeyEvent in class wx.MouseEvent in class wx.JoystickEvent in class wx.JoystickEvent in class wx.ListEvent in class wx.ListEvent in class wx.ListItem in class wx.KeyEvent in class wx.MouseEvent in class wx.ListItem in class wx.ProcessEvent in class wx.ListItem in class wx.ListItem in class wx.ListEvent in class wx.ListItem in class wx.ListEvent in class wx.JoystickEvent in class wx.KeyEvent in class wx.MouseEvent in class wx.MouseEvent in class wx.ListItem in class wx.KeyEvent in class wx.MouseEvent in class wx.MouseEvent in class wx.ListEvent in class wx.ProcessEvent in class wx.TreeItemId in class wx.ListEvent in class wx.JoystickEvent in class wx.MoveEvent in class wx.KeyEvent in class wx.KeyEvent

m_rect

Method in class wx.py.shell.Shell in class wx.KeyEvent in class wx.MouseEvent in class wx.JoystickEvent in class wx.JoystickEvent in class wx.ListEvent in class wx.ListEvent in class wx.ListItem in class wx.KeyEvent in class wx.MouseEvent in class wx.ListItem in class wx.ProcessEvent in class wx.ListItem in class wx.ListItem in class wx.ListEvent in class wx.ListItem in class wx.ListEvent in class wx.JoystickEvent in class wx.KeyEvent in class wx.MouseEvent in class wx.MouseEvent in class wx.ListItem in class wx.KeyEvent in class wx.MouseEvent in class wx.MouseEvent in class wx.ListEvent in class wx.ProcessEvent in class wx.TreeItemId in class wx.ListEvent in class wx.JoystickEvent in class wx.MoveEvent in class wx.KeyEvent in class wx.KeyEvent in class wx.MoveEvent

m_rect

Method in class wx.py.shell.Shell in class wx.KeyEvent in class wx.MouseEvent in class wx.JoystickEvent in class wx.JoystickEvent in class wx.ListEvent in class wx.ListEvent in class wx.ListItem in class wx.KeyEvent in class wx.MouseEvent in class wx.ListItem in class wx.ProcessEvent in class wx.ListItem in class wx.ListItem in class wx.ListEvent in class wx.ListItem in class wx.ListEvent in class wx.JoystickEvent in class wx.KeyEvent in class wx.MouseEvent in class wx.MouseEvent in class wx.ListItem in class wx.KeyEvent in class wx.MouseEvent in class wx.MouseEvent in class wx.ListEvent in class wx.ProcessEvent in class wx.TreeItemId in class wx.ListEvent in class wx.JoystickEvent in class wx.MoveEvent in class wx.KeyEvent in class wx.KeyEvent in class wx.MoveEvent in class wx.SizeEvent

m_rightDown

Method in class wx.py.shell.Shell in class wx.KeyEvent in class wx.MouseEvent in class wx.JoystickEvent in class wx.JoystickEvent in class wx.ListEvent in class wx.ListEvent in class wx.ListItem in class wx.KeyEvent in class wx.MouseEvent in class wx.ListItem in class wx.ProcessEvent in class wx.ListItem in class wx.ListItem in class wx.ListEvent in class wx.ListItem in class wx.ListEvent in class wx.JoystickEvent in class wx.KeyEvent in class wx.MouseEvent in class wx.MouseEvent in class wx.ListItem in class wx.KeyEvent in class wx.MouseEvent in class wx.MouseEvent in class wx.ListEvent in class wx.ProcessEvent in class wx.TreeItemId in class wx.ListEvent in class wx.JoystickEvent in class wx.MoveEvent in class wx.KeyEvent in class wx.KeyEvent in class wx.MoveEvent in class wx.SizeEvent in class wx.MouseEvent

m_scanCode

Method in class wx.py.shell.Shell in class wx.KeyEvent in class wx.MouseEvent in class wx.JoystickEvent in class wx.JoystickEvent in class wx.ListEvent in class wx.ListEvent in class wx.ListItem in class wx.KeyEvent in class wx.MouseEvent in class wx.ListItem in class wx.ProcessEvent in class wx.ListItem in class wx.ListItem in class wx.ListEvent in class wx.ListItem in class wx.ListEvent in class wx.JoystickEvent in class wx.KeyEvent in class wx.MouseEvent in class wx.MouseEvent in class wx.ListItem in class wx.KeyEvent in class wx.MouseEvent in class wx.MouseEvent in class wx.ListEvent in class wx.ProcessEvent in class wx.TreeItemId in class wx.ListEvent in class wx.JoystickEvent in class wx.MoveEvent in class wx.KeyEvent in class wx.KeyEvent in class wx.MoveEvent in class wx.SizeEvent in class wx.MouseEvent in class wx.KeyEvent

m_shiftDown

Method in class wx.py.shell.Shell in class wx.KeyEvent in class wx.MouseEvent in class wx.JoystickEvent in class wx.JoystickEvent in class wx.ListEvent in class wx.ListEvent in class wx.ListItem in class wx.KeyEvent in class wx.MouseEvent in class wx.ListItem in class wx.ProcessEvent in class wx.ListItem in class wx.ListItem in class wx.ListEvent in class wx.ListItem in class wx.ListEvent in class wx.JoystickEvent in class wx.KeyEvent in class wx.MouseEvent in class wx.MouseEvent in class wx.ListItem in class wx.KeyEvent in class wx.MouseEvent in class wx.MouseEvent in class wx.ListEvent in class wx.ProcessEvent in class wx.TreeItemId in class wx.ListEvent in class wx.JoystickEvent in class wx.MoveEvent in class wx.KeyEvent in class wx.KeyEvent in class wx.MoveEvent in class wx.SizeEvent in class wx.MouseEvent in class wx.KeyEvent in class wx.KeyEvent

m_shiftDown

Method in class wx.py.shell.Shell in class wx.KeyEvent in class wx.MouseEvent in class wx.JoystickEvent in class wx.JoystickEvent in class wx.ListEvent in class wx.ListEvent in class wx.ListItem in class wx.KeyEvent in class wx.MouseEvent in class wx.ListItem in class wx.ProcessEvent in class wx.ListItem in class wx.ListItem in class wx.ListEvent in class wx.ListItem in class wx.ListEvent in class wx.JoystickEvent in class wx.KeyEvent in class wx.MouseEvent in class wx.MouseEvent in class wx.ListItem in class wx.KeyEvent in class wx.MouseEvent in class wx.MouseEvent in class wx.ListEvent in class wx.ProcessEvent in class wx.TreeItemId in class wx.ListEvent in class wx.JoystickEvent in class wx.MoveEvent in class wx.KeyEvent in class wx.KeyEvent in class wx.MoveEvent in class wx.SizeEvent in class wx.MouseEvent in class wx.KeyEvent in class wx.KeyEvent in class wx.MouseEvent

m_size

Method in class wx.py.shell.Shell in class wx.KeyEvent in class wx.MouseEvent in class wx.JoystickEvent in class wx.JoystickEvent in class wx.ListEvent in class wx.ListEvent in class wx.ListItem in class wx.KeyEvent in class wx.MouseEvent in class wx.ListItem in class wx.ProcessEvent in class wx.ListItem in class wx.ListItem in class wx.ListEvent in class wx.ListItem in class wx.ListEvent in class wx.JoystickEvent in class wx.KeyEvent in class wx.MouseEvent in class wx.MouseEvent in class wx.ListItem in class wx.KeyEvent in class wx.MouseEvent in class wx.MouseEvent in class wx.ListEvent in class wx.ProcessEvent in class wx.TreeItemId in class wx.ListEvent in class wx.JoystickEvent in class wx.MoveEvent in class wx.KeyEvent in class wx.KeyEvent in class wx.MoveEvent in class wx.SizeEvent in class wx.MouseEvent in class wx.KeyEvent in class wx.KeyEvent in class wx.MouseEvent in class wx.SizeEvent

m_state

Method in class wx.py.shell.Shell in class wx.KeyEvent in class wx.MouseEvent in class wx.JoystickEvent in class wx.JoystickEvent in class wx.ListEvent in class wx.ListEvent in class wx.ListItem in class wx.KeyEvent in class wx.MouseEvent in class wx.ListItem in class wx.ProcessEvent in class wx.ListItem in class wx.ListItem in class wx.ListEvent in class wx.ListItem in class wx.ListEvent in class wx.JoystickEvent in class wx.KeyEvent in class wx.MouseEvent in class wx.MouseEvent in class wx.ListItem in class wx.KeyEvent in class wx.MouseEvent in class wx.MouseEvent in class wx.ListEvent in class wx.ProcessEvent in class wx.TreeItemId in class wx.ListEvent in class wx.JoystickEvent in class wx.MoveEvent in class wx.KeyEvent in class wx.KeyEvent in class wx.MoveEvent in class wx.SizeEvent in class wx.MouseEvent in class wx.KeyEvent in class wx.KeyEvent in class wx.MouseEvent in class wx.SizeEvent in class wx.ListItem

m_stateMask

Method in class wx.py.shell.Shell in class wx.KeyEvent in class wx.MouseEvent in class wx.JoystickEvent in class wx.JoystickEvent in class wx.ListEvent in class wx.ListEvent in class wx.ListItem in class wx.KeyEvent in class wx.MouseEvent in class wx.ListItem in class wx.ProcessEvent in class wx.ListItem in class wx.ListItem in class wx.ListEvent in class wx.ListItem in class wx.ListEvent in class wx.JoystickEvent in class wx.KeyEvent in class wx.MouseEvent in class wx.MouseEvent in class wx.ListItem in class wx.KeyEvent in class wx.MouseEvent in class wx.MouseEvent in class wx.ListEvent in class wx.ProcessEvent in class wx.TreeItemId in class wx.ListEvent in class wx.JoystickEvent in class wx.MoveEvent in class wx.KeyEvent in class wx.KeyEvent in class wx.MoveEvent in class wx.SizeEvent in class wx.MouseEvent in class wx.KeyEvent in class wx.KeyEvent in class wx.MouseEvent in class wx.SizeEvent in class wx.ListItem in class wx.ListItem

m_text

Method in class wx.py.shell.Shell in class wx.KeyEvent in class wx.MouseEvent in class wx.JoystickEvent in class wx.JoystickEvent in class wx.ListEvent in class wx.ListEvent in class wx.ListItem in class wx.KeyEvent in class wx.MouseEvent in class wx.ListItem in class wx.ProcessEvent in class wx.ListItem in class wx.ListItem in class wx.ListEvent in class wx.ListItem in class wx.ListEvent in class wx.JoystickEvent in class wx.KeyEvent in class wx.MouseEvent in class wx.MouseEvent in class wx.ListItem in class wx.KeyEvent in class wx.MouseEvent in class wx.MouseEvent in class wx.ListEvent in class wx.ProcessEvent in class wx.TreeItemId in class wx.ListEvent in class wx.JoystickEvent in class wx.MoveEvent in class wx.KeyEvent in class wx.KeyEvent in class wx.MoveEvent in class wx.SizeEvent in class wx.MouseEvent in class wx.KeyEvent in class wx.KeyEvent in class wx.MouseEvent in class wx.SizeEvent in class wx.ListItem in class wx.ListItem in class wx.ListItem

m_wheelDelta

Method in class wx.py.shell.Shell in class wx.KeyEvent in class wx.MouseEvent in class wx.JoystickEvent in class wx.JoystickEvent in class wx.ListEvent in class wx.ListEvent in class wx.ListItem in class wx.KeyEvent in class wx.MouseEvent in class wx.ListItem in class wx.ProcessEvent in class wx.ListItem in class wx.ListItem in class wx.ListEvent in class wx.ListItem in class wx.ListEvent in class wx.JoystickEvent in class wx.KeyEvent in class wx.MouseEvent in class wx.MouseEvent in class wx.ListItem in class wx.KeyEvent in class wx.MouseEvent in class wx.MouseEvent in class wx.ListEvent in class wx.ProcessEvent in class wx.TreeItemId in class wx.ListEvent in class wx.JoystickEvent in class wx.MoveEvent in class wx.KeyEvent in class wx.KeyEvent in class wx.MoveEvent in class wx.SizeEvent in class wx.MouseEvent in class wx.KeyEvent in class wx.KeyEvent in class wx.MouseEvent in class wx.SizeEvent in class wx.ListItem in class wx.ListItem in class wx.ListItem in class wx.MouseEvent

m_wheelRotation

Method in class wx.py.shell.Shell in class wx.KeyEvent in class wx.MouseEvent in class wx.JoystickEvent in class wx.JoystickEvent in class wx.ListEvent in class wx.ListEvent in class wx.ListItem in class wx.KeyEvent in class wx.MouseEvent in class wx.ListItem in class wx.ProcessEvent in class wx.ListItem in class wx.ListItem in class wx.ListEvent in class wx.ListItem in class wx.ListEvent in class wx.JoystickEvent in class wx.KeyEvent in class wx.MouseEvent in class wx.MouseEvent in class wx.ListItem in class wx.KeyEvent in class wx.MouseEvent in class wx.MouseEvent in class wx.ListEvent in class wx.ProcessEvent in class wx.TreeItemId in class wx.ListEvent in class wx.JoystickEvent in class wx.MoveEvent in class wx.KeyEvent in class wx.KeyEvent in class wx.MoveEvent in class wx.SizeEvent in class wx.MouseEvent in class wx.KeyEvent in class wx.KeyEvent in class wx.MouseEvent in class wx.SizeEvent in class wx.ListItem in class wx.ListItem in class wx.ListItem in class wx.MouseEvent in class wx.MouseEvent

m_width

Method in class wx.py.shell.Shell in class wx.KeyEvent in class wx.MouseEvent in class wx.JoystickEvent in class wx.JoystickEvent in class wx.ListEvent in class wx.ListEvent in class wx.ListItem in class wx.KeyEvent in class wx.MouseEvent in class wx.ListItem in class wx.ProcessEvent in class wx.ListItem in class wx.ListItem in class wx.ListEvent in class wx.ListItem in class wx.ListEvent in class wx.JoystickEvent in class wx.KeyEvent in class wx.MouseEvent in class wx.MouseEvent in class wx.ListItem in class wx.KeyEvent in class wx.MouseEvent in class wx.MouseEvent in class wx.ListEvent in class wx.ProcessEvent in class wx.TreeItemId in class wx.ListEvent in class wx.JoystickEvent in class wx.MoveEvent in class wx.KeyEvent in class wx.KeyEvent in class wx.MoveEvent in class wx.SizeEvent in class wx.MouseEvent in class wx.KeyEvent in class wx.KeyEvent in class wx.MouseEvent in class wx.SizeEvent in class wx.ListItem in class wx.ListItem in class wx.ListItem in class wx.MouseEvent in class wx.MouseEvent in class wx.ListItem

m_x

Method in class wx.py.shell.Shell in class wx.KeyEvent in class wx.MouseEvent in class wx.JoystickEvent in class wx.JoystickEvent in class wx.ListEvent in class wx.ListEvent in class wx.ListItem in class wx.KeyEvent in class wx.MouseEvent in class wx.ListItem in class wx.ProcessEvent in class wx.ListItem in class wx.ListItem in class wx.ListEvent in class wx.ListItem in class wx.ListEvent in class wx.JoystickEvent in class wx.KeyEvent in class wx.MouseEvent in class wx.MouseEvent in class wx.ListItem in class wx.KeyEvent in class wx.MouseEvent in class wx.MouseEvent in class wx.ListEvent in class wx.ProcessEvent in class wx.TreeItemId in class wx.ListEvent in class wx.JoystickEvent in class wx.MoveEvent in class wx.KeyEvent in class wx.KeyEvent in class wx.MoveEvent in class wx.SizeEvent in class wx.MouseEvent in class wx.KeyEvent in class wx.KeyEvent in class wx.MouseEvent in class wx.SizeEvent in class wx.ListItem in class wx.ListItem in class wx.ListItem in class wx.MouseEvent in class wx.MouseEvent in class wx.ListItem in class wx.KeyEvent

m_x

Method in class wx.py.shell.Shell in class wx.KeyEvent in class wx.MouseEvent in class wx.JoystickEvent in class wx.JoystickEvent in class wx.ListEvent in class wx.ListEvent in class wx.ListItem in class wx.KeyEvent in class wx.MouseEvent in class wx.ListItem in class wx.ProcessEvent in class wx.ListItem in class wx.ListItem in class wx.ListEvent in class wx.ListItem in class wx.ListEvent in class wx.JoystickEvent in class wx.KeyEvent in class wx.MouseEvent in class wx.MouseEvent in class wx.ListItem in class wx.KeyEvent in class wx.MouseEvent in class wx.MouseEvent in class wx.ListEvent in class wx.ProcessEvent in class wx.TreeItemId in class wx.ListEvent in class wx.JoystickEvent in class wx.MoveEvent in class wx.KeyEvent in class wx.KeyEvent in class wx.MoveEvent in class wx.SizeEvent in class wx.MouseEvent in class wx.KeyEvent in class wx.KeyEvent in class wx.MouseEvent in class wx.SizeEvent in class wx.ListItem in class wx.ListItem in class wx.ListItem in class wx.MouseEvent in class wx.MouseEvent in class wx.ListItem in class wx.KeyEvent in class wx.MouseEvent

m_y

Method in class wx.py.shell.Shell in class wx.KeyEvent in class wx.MouseEvent in class wx.JoystickEvent in class wx.JoystickEvent in class wx.ListEvent in class wx.ListEvent in class wx.ListItem in class wx.KeyEvent in class wx.MouseEvent in class wx.ListItem in class wx.ProcessEvent in class wx.ListItem in class wx.ListItem in class wx.ListEvent in class wx.ListItem in class wx.ListEvent in class wx.JoystickEvent in class wx.KeyEvent in class wx.MouseEvent in class wx.MouseEvent in class wx.ListItem in class wx.KeyEvent in class wx.MouseEvent in class wx.MouseEvent in class wx.ListEvent in class wx.ProcessEvent in class wx.TreeItemId in class wx.ListEvent in class wx.JoystickEvent in class wx.MoveEvent in class wx.KeyEvent in class wx.KeyEvent in class wx.MoveEvent in class wx.SizeEvent in class wx.MouseEvent in class wx.KeyEvent in class wx.KeyEvent in class wx.MouseEvent in class wx.SizeEvent in class wx.ListItem in class wx.ListItem in class wx.ListItem in class wx.MouseEvent in class wx.MouseEvent in class wx.ListItem in class wx.KeyEvent in class wx.MouseEvent in class wx.KeyEvent

m_y

Method in class wx.py.shell.Shell in class wx.KeyEvent in class wx.MouseEvent in class wx.JoystickEvent in class wx.JoystickEvent in class wx.ListEvent in class wx.ListEvent in class wx.ListItem in class wx.KeyEvent in class wx.MouseEvent in class wx.ListItem in class wx.ProcessEvent in class wx.ListItem in class wx.ListItem in class wx.ListEvent in class wx.ListItem in class wx.ListEvent in class wx.JoystickEvent in class wx.KeyEvent in class wx.MouseEvent in class wx.MouseEvent in class wx.ListItem in class wx.KeyEvent in class wx.MouseEvent in class wx.MouseEvent in class wx.ListEvent in class wx.ProcessEvent in class wx.TreeItemId in class wx.ListEvent in class wx.JoystickEvent in class wx.MoveEvent in class wx.KeyEvent in class wx.KeyEvent in class wx.MoveEvent in class wx.SizeEvent in class wx.MouseEvent in class wx.KeyEvent in class wx.KeyEvent in class wx.MouseEvent in class wx.SizeEvent in class wx.ListItem in class wx.ListItem in class wx.ListItem in class wx.MouseEvent in class wx.MouseEvent in class wx.ListItem in class wx.KeyEvent in class wx.MouseEvent in class wx.KeyEvent in class wx.MouseEvent

m_zPosition

Method in class wx.py.shell.Shell in class wx.KeyEvent in class wx.MouseEvent in class wx.JoystickEvent in class wx.JoystickEvent in class wx.ListEvent in class wx.ListEvent in class wx.ListItem in class wx.KeyEvent in class wx.MouseEvent in class wx.ListItem in class wx.ProcessEvent in class wx.ListItem in class wx.ListItem in class wx.ListEvent in class wx.ListItem in class wx.ListEvent in class wx.JoystickEvent in class wx.KeyEvent in class wx.MouseEvent in class wx.MouseEvent in class wx.ListItem in class wx.KeyEvent in class wx.MouseEvent in class wx.MouseEvent in class wx.ListEvent in class wx.ProcessEvent in class wx.TreeItemId in class wx.ListEvent in class wx.JoystickEvent in class wx.MoveEvent in class wx.KeyEvent in class wx.KeyEvent in class wx.MoveEvent in class wx.SizeEvent in class wx.MouseEvent in class wx.KeyEvent in class wx.KeyEvent in class wx.MouseEvent in class wx.SizeEvent in class wx.ListItem in class wx.ListItem in class wx.ListItem in class wx.MouseEvent in class wx.MouseEvent in class wx.ListItem in class wx.KeyEvent in class wx.MouseEvent in class wx.KeyEvent in class wx.MouseEvent in class wx.JoystickEvent

MacGetMetalAppearance

Method in class wx.TopLevelWindow

macroIsA

Method in class wx.lib.evtmgr.EventMacroInfo

MacSetMetalAppearance

Method in class wx.TopLevelWindow

MagicImageList

Class in module wx.lib.mixins.imagelist

main

Function in module wx.lib.colourchooser.pycolourchooser

main

Function in module wx.py.PyAlaCarte

main

Function in module wx.py.PyAlaMode

main

Function in module wx.py.PyAlaModeTest

main

Function in module wx.py.PyCrust

main

Function in module wx.py.PyFilling

main

Function in module wx.py.PyShell

main

Function in module wx.py.PyWrap

main

Function in module wx.tools.helpviewer

main

Function in module wx.tools.img2img

main

Function in module wx.tools.img2png

main

Function in module wx.tools.img2py

main

Function in module wx.tools.img2xpm

MainLoop

Method in class wx.App

MainLoop

Method in class wx.PyApp

make_archive

Method in class distutils.cmd.Command

make_editor

Method in class wx.lib.mixins.listctrl.TextEditMixin

make_file

Method in class distutils.cmd.Command

MakeBitmap

Method in class wx.lib.colourselect.ColourSelect

MakeCellVisible

Method in class wx.grid.Grid

MakeColor

Function in module wx.lib.calendar

MakeContainer

Method in class wx.lib.ogl.CompositeShape

MakeControlPoints

Method in class wx.lib.ogl.DividedShape

MakeControlPoints

Method in class wx.lib.ogl.DivisionShape

MakeControlPoints

Method in class wx.lib.ogl.LineShape

MakeControlPoints

Method in class wx.lib.ogl.PolygonShape

MakeControlPoints

Method in class wx.lib.ogl.Shape

MakeDefaultName

Method in class wx.lib.docview.DocManager

MakeFrameTitle

Method in class wx.lib.docview.DocManager

MakeGMT

Method in class wx.DateTime

makeGray

Function in module wx.lib.imageutils

MakeHitDict

Method in class wx.lib.floatcanvas.FloatCanvas.FloatCanvas

MakeKey

Method in class wx.ImageHistogram

MakeLineControlPoints

Method in class wx.lib.ogl.LineShape

MakeMandatoryControlPoints

Method in class wx.lib.ogl.DividedShape

MakeMandatoryControlPoints

Method in class wx.lib.ogl.DivisionShape

MakeMandatoryControlPoints

Method in class wx.lib.ogl.Shape

MakeModal

Method in class wx.Window

MakeNewBuffer

Method in class wx.lib.colourchooser.canvas.Canvas

MakeNewBuffers

Method in class wx.lib.floatcanvas.FloatCanvas.FloatCanvas

MakeNewHTdc

Method in class wx.lib.floatcanvas.FloatCanvas.FloatCanvas

MakeRegex

Method in class wx.lib.imagebrowser.FindFiles

MakeTimezone

Method in class wx.DateTime

MapEvents

Method in class wx.lib.editor.editor.Editor

Mar

Variable in class wx.DateTime

Mar

Variable in class wx.DateTime

MarkDirty

Method in class wx.TextCtrl

MarkerAdd

Method in class wx.stc.StyledTextCtrl

MarkerDefine

Method in class wx.stc.StyledTextCtrl

MarkerDefineBitmap

Method in class wx.stc.StyledTextCtrl

MarkerDelete

Method in class wx.stc.StyledTextCtrl

MarkerDeleteAll

Method in class wx.stc.StyledTextCtrl

MarkerDeleteHandle

Method in class wx.stc.StyledTextCtrl

MarkerGet

Method in class wx.stc.StyledTextCtrl

MarkerLineFromHandle

Method in class wx.stc.StyledTextCtrl

MarkerNext

Method in class wx.stc.StyledTextCtrl

MarkerPrevious

Method in class wx.stc.StyledTextCtrl

MarkerSetBackground

Method in class wx.stc.StyledTextCtrl

MarkerSetForeground

Method in class wx.stc.StyledTextCtrl

Mask

Class in package wx

maskchars

Variable in module wx.lib.masked.maskededit

masked

Package in package wx.lib

MaskedComboBoxSelectEvent

Class in module wx.lib.masked.combobox

maskededit

Module in package wx.lib.masked

MaskedEditAccessorsMixin

Class in module wx.lib.masked.maskededit

MaskedEditMixin

Class in module wx.lib.masked.maskededit

masktags

Variable in module wx.lib.masked.maskededit

Matches

Method in class wx.VideoMode

MatchTemplate

Method in class wx.lib.docview.DocManager

MAX_FILE_HISTORY

Variable in module wx.lib.docview

Maximize

Method in class wx.MDIChildFrame

Maximize

Method in class wx.TopLevelWindow

MaximizeEvent

Class in package wx

MaxX

Method in class wx.DC

MaxY

Method in class wx.DC

May

Variable in class wx.DateTime

May

Variable in class wx.DateTime

mdays

Variable in module wx.lib.CDate

MDIChildFrame

Class in package wx

MDIClientWindow

Class in package wx

MDIParentFrame

Class in package wx

MDT

Variable in class wx.DateTime

MDT

Variable in class wx.DateTime

media

Module in package wx

MediaCtrl

Class in module wx.media

MediaEvent

Class in module wx.media

MemoryDC

Class in package wx

MemoryDCFromDC

Function in package wx

MemoryFSHandler

Class in package wx

MemoryFSHandler_AddFile

Function in package wx

MemoryFSHandler_RemoveFile

Function in package wx

Menu

Class in package wx

MenuBar

Class in package wx

MenuEvent

Class in package wx

MenuItem

Class in package wx

MenuItem_GetDefaultMarginWidth

Function in package wx

MenuItem_GetLabelFromText

Function in package wx

Merged

Variable in class wx.grid.GridCellAttr

MergeWith

Method in class wx.grid.GridCellAttr

Message

Class in module wx.lib.pubsub

MessageAdapter

Class in module wx.lib.evtmgr

MessageBox

Function in package wx

MessageDialog

Class in package wx

messageDialog

Function in module wx.lib.dialogs

messageDialog

Function in module wx.py.editor

MetaDown

Method in class wx.KeyEvent

MetaDown

Method in class wx.MouseEvent

MetaDown

Method in class wx.grid.GridEvent

MetaDown

Method in class wx.grid.GridRangeSelectEvent

MetaDown

Method in class wx.grid.GridSizeEvent

MetaFile

Class in package wx

MetafileDataObject

Class in package wx

MetaFileDC

Class in package wx

MicroSleep

Function in package wx

MiddleDClick

Method in class wx.MouseEvent

MiddleDoubleClickEvent

Method in class wx.lib.floatcanvas.FloatCanvas.FloatCanvas

MiddleDown

Method in class wx.MouseEvent

MiddleDownEvent

Method in class wx.lib.floatcanvas.FloatCanvas.FloatCanvas

MiddleIsDown

Method in class wx.MouseEvent

MiddleUp

Method in class wx.MouseEvent

MiddleUpEvent

Method in class wx.lib.floatcanvas.FloatCanvas.FloatCanvas

milhours

Variable in module wx.lib.masked.maskededit

MilliSleep

Function in package wx

MimeTypesManager

Class in package wx

MimeTypesManager_IsOfType

Function in package wx

MiniFrame

Class in package wx

MININT

Variable in module wx.lib.intctrl

MININT

Variable in module wx.lib.masked.numctrl

Minute

Method in class wx.TimeSpan

Minutes

Method in class wx.TimeSpan

minutes

Variable in module wx.lib.masked.maskededit

MinX

Method in class wx.DC

MinY

Method in class wx.DC

Mirror

Method in class wx.Image

MirrorDC

Class in package wx

mixins

Package in package wx.lib

mkpath

Method in class distutils.cmd.Command

ModifierKey

Method in class wx.lib.editor.editor.Editor

Modify

Method in class wx.lib.docview.Document

Mon

Variable in class wx.DateTime

Mon

Variable in class wx.DateTime

Monday_First

Variable in class wx.DateTime

Monday_First

Variable in class wx.DateTime

Month

Method in class wx.DateSpan

Month

Variable in module wx.lib.CDate

Months

Method in class wx.DateSpan

months

Variable in module wx.lib.masked.maskededit

MoreRequested

Method in class wx.IdleEvent

MotionEvent

Method in class wx.lib.floatcanvas.FloatCanvas.FloatCanvas

MouseCaptureChangedEvent

Class in package wx

MouseClick

Method in class wx.lib.calendar.CalenDlg

MouseEvent

Class in package wx

MouseGestures

Class in module wx.lib.gestures

MouseOverTest

Method in class wx.lib.floatcanvas.FloatCanvas.FloatCanvas

MouseToCol

Method in class wx.lib.editor.editor.Editor

MouseToCursor

Method in class wx.lib.editor.editor.Editor

MouseToRow

Method in class wx.lib.editor.editor.Editor

Move

Method in class wx.Caret

Move

Method in class wx.DragImage

Move

Method in class wx.Window

Move

Method in class wx.lib.editor.editor.Editor

Move

Method in class wx.lib.floatcanvas.FloatCanvas.XYObjectMixin

Move

Method in class wx.lib.ogl.Shape

move_file

Method in class distutils.cmd.Command

MoveAfterInTabOrder

Method in class wx.Window

MoveBeforeInTabOrder

Method in class wx.Window

MoveCaretInsideView

Method in class wx.stc.StyledTextCtrl

MoveCursorDown

Method in class wx.grid.Grid

MoveCursorDownBlock

Method in class wx.grid.Grid

MoveCursorLeft

Method in class wx.grid.Grid

MoveCursorLeftBlock

Method in class wx.grid.Grid

MoveCursorRight

Method in class wx.grid.Grid

MoveCursorRightBlock

Method in class wx.grid.Grid

MoveCursorUp

Method in class wx.grid.Grid

MoveCursorUpBlock

Method in class wx.grid.Grid

MoveDown

Method in class wx.lib.editor.editor.Editor

MoveEnd

Method in class wx.lib.editor.editor.Editor

MoveEndOfFile

Method in class wx.lib.editor.editor.Editor

MoveEvent

Class in package wx

MoveHome

Method in class wx.lib.editor.editor.Editor

MoveImage

Method in class wx.lib.floatcanvas.FloatCanvas.FloatCanvas

MoveLeft

Method in class wx.lib.editor.editor.Editor

MoveLineToNewAttachment

Method in class wx.lib.ogl.Shape

MoveLinks

Method in class wx.lib.ogl.Shape

MovePageDown

Method in class wx.grid.Grid

MovePageDown

Method in class wx.lib.editor.editor.Editor

MovePageUp

Method in class wx.grid.Grid

MovePageUp

Method in class wx.lib.editor.editor.Editor

MoveRight

Method in class wx.lib.editor.editor.Editor

MoveSpecialControlKey

Method in class wx.lib.editor.editor.Editor

MoveSpecialKey

Method in class wx.lib.editor.editor.Editor

MoveStartOfFile

Method in class wx.lib.editor.editor.Editor

MoveUp

Method in class wx.lib.editor.editor.Editor

MoveXY

Method in class wx.Caret

MoveXY

Method in class wx.Window

Moving

Method in class wx.MouseEvent

mro

Method in class __builtin__.type

MSD

Variable in class wx.DateTime

MSD

Variable in class wx.DateTime

MSK

Variable in class wx.DateTime

MSK

Variable in class wx.DateTime

MST

Variable in class wx.DateTime

MST

Variable in class wx.DateTime

MultiChoiceDialog

Class in package wx

MultiClient

Class in module wx.lib.multisash

MultiCloser

Class in module wx.lib.multisash

MultiCreator

Class in module wx.lib.multisash

MultipleChoiceDialog

Class in module wx.lib.dialogs

multipleChoiceDialog

Function in module wx.lib.dialogs

MultipleLineCopy

Method in class wx.lib.editor.editor.Editor

MultipleLineDelete

Method in class wx.lib.editor.editor.Editor

MultipleLinePaste

Method in class wx.lib.editor.editor.Editor

Multiply

Method in class wx.DateSpan

Multiply

Method in class wx.TimeSpan

multisash

Module in package wx.lib

MultiSash

Class in module wx.lib.multisash

MultiSizer

Class in module wx.lib.multisash

MultiSplit

Class in module wx.lib.multisash

MultiViewLeaf

Class in module wx.lib.multisash

MutexGuiEnter

Function in package wx

MutexGuiLeave

Function in package wx

MutexGuiLocker

Class in package wx

MV_HOR

Variable in module wx.lib.multisash

MV_VER

Variable in module wx.lib.multisash

mvctree

Module in package wx.lib

MVCTree

Class in module wx.lib.mvctree

MVCTreeEvent

Class in module wx.lib.mvctree

MVCTreeNode

Class in module wx.lib.mvctree

MVCTreeNotifyEvent

Class in module wx.lib.mvctree

Name

Method in class wx.ConfigPathChanger

name

Variable in class wx.py.crust.Crust

name

Variable in class wx.py.crust.CrustFrame

name

Variable in class wx.py.filling.Filling

name

Variable in class wx.py.filling.FillingFrame

name

Variable in class wx.py.filling.FillingText

name

Variable in class wx.py.filling.FillingTree

name

Variable in class wx.py.shell.Shell

name

Variable in class wx.py.shell.ShellFacade

name

Variable in class wx.py.shell.ShellFrame

Name_Abbr

Variable in class wx.DateTime

Name_Abbr

Variable in class wx.DateTime

Name_Full

Variable in class wx.DateTime

Name_Full

Variable in class wx.DateTime

NamedColour

Function in package wx

NameRegions

Method in class wx.lib.ogl.Shape

NativeEncodingInfo

Class in package wx

NativeFontInfo

Class in package wx

nav

Variable in module wx.lib.masked.maskededit

NavCanvas

Module in package wx.lib.floatcanvas

NavCanvas

Class in module wx.lib.floatcanvas.NavCanvas

Navigate

Method in class wx.Window

NavigationKeyEvent

Class in package wx

NAVKEYS

Variable in module wx.py.shell

NcPaintEvent

Class in package wx

Neg

Method in class wx.DateSpan

Neg

Method in class wx.TimeSpan

negative_opt

Variable in class distutils.command.install.install

negative_opt

Variable in class distutils.command.install.install

new

Method in class wx.py.buffer.Buffer

NewCommandEvent

Function in module wx.lib.newevent

NewControlId

Method in class wx.Window

newevent

Module in package wx.lib

NewEvent

Function in module wx.lib.newevent

NewEventType

Function in package wx

NewId

Function in package wx

NewLine

Method in class wx.stc.StyledTextCtrl

Next

Method in class wx.RegionIterator

NextControlId

Method in class wx.Window

NiceFontForPlatform

Method in class wx.lib.editor.editor.Editor

NO_CUSTOM_COLOURS

Variable in class wx.lib.colourchooser.pycolourchooser.PyColourChooser

NodeAdded

Method in class wx.lib.mvctree.MVCTree

NodeInserted

Method in class wx.lib.mvctree.MVCTree

NodePainter

Class in module wx.lib.mvctree

NodeRemoved

Method in class wx.lib.mvctree.MVCTree

NormalChar

Method in class wx.lib.editor.editor.Editor

Normalize

Method in class wx.Point2D

normalizeBox

Function in module wx.lib.mixins.rubberband

NormalizedSelect

Method in class wx.lib.editor.editor.Editor

Notebook

Class in package wx

Notebook_GetClassDefaultAttributes

Function in package wx

NotebookEvent

Class in package wx

NotebookPage

Class in package wx

NotebookSizer

Class in package wx

Notify

Method in class wx.FutureCall

Notify

Method in class wx.PyTimer

Notify

Method in class wx.lib.buttons.GenButton

Notify

Method in class wx.lib.popupctl.PopButton

NotifyClosing

Method in class wx.lib.docview.Document

NotifyEvent

Class in package wx

Nov

Variable in class wx.DateTime

Nov

Variable in class wx.DateTime

Now

Method in class wx.DateTime

Now

Function in package wx

now

Class in module wx.lib.CDate

NullFileTypeInfo

Function in package wx

NullTransform

Class in module wx.lib.mvctree

NUMBER

Variable in module wx.lib.masked.ctrl

NUMBER

Variable in class wx.lib.masked.ctrl.controlTypes

NumberUpdatedEvent

Class in module wx.lib.masked.numctrl

numctrl

Module in package wx.lib.masked

NumCtrl

Class in module wx.lib.masked.numctrl

NumCtrlAccessorsMixin

Class in module wx.lib.masked.numctrl

object

Class in module __builtin__

Object

Class in package wx

objGetChildren

Method in class wx.py.filling.FillingTree

objHasChildren

Method in class wx.py.filling.FillingTree

Oct

Variable in class wx.DateTime

Oct

Variable in class wx.DateTime

Offset

Method in class wx.Rect

Offset

Method in class wx.Region

OffsetXY

Method in class wx.Rect

ogl

Package in package wx.lib

OGLCleanUp

Function in package wx.lib.ogl

OGLInitialize

Function in package wx.lib.ogl

Ok

Method in class wx.AcceleratorTable

Ok

Method in class wx.Bitmap

Ok

Method in class wx.Brush

Ok

Method in class wx.Colour

Ok

Method in class wx.Cursor

Ok

Method in class wx.DC

Ok

Method in class wx.Font

Ok

Method in class wx.Icon

Ok

Method in class wx.Image

Ok

Method in class wx.PageSetupDialogData

Ok

Method in class wx.Palette

Ok

Method in class wx.Pen

Ok

Method in class wx.PrintData

Ok

Method in class wx.PrintDialogData

Ok

Method in class wx.PrintPreview

OnAbout

Method in class wx.lib.pydocview.DocFrameMixIn

OnAbout

Method in class wx.py.crust.CrustFrame

OnAbout

Method in class wx.py.editor.EditorFrame

OnAbout

Method in class wx.py.editor.EditorNotebookFrame

OnAbout

Method in class wx.py.editor.EditorShellNotebookFrame

OnAbout

Method in class wx.py.frame.Frame

OnAbout

Method in class wx.py.shell.ShellFrame

OnActivate

Method in class wx.lib.docview.DocChildFrame

OnActivate

Method in class wx.lib.docview.DocMDIChildFrame

OnActivate

Method in class wx.lib.pydocview.DocMDIChildFrame

OnActivateView

Method in class wx.lib.docview.View

onAddCustom

Method in class wx.lib.colourchooser.pycolourchooser.PyColourChooser

OnArrangeWindows

Method in class wx.lib.pydocview.WindowMenuService

OnAutoCompleteDouble

Method in class wx.py.frame.Frame

OnAutoCompleteMagic

Method in class wx.py.frame.Frame

OnAutoCompleteShow

Method in class wx.py.frame.Frame

OnAutoCompleteSingle

Method in class wx.py.frame.Frame

onBasicClick

Method in class wx.lib.colourchooser.pycolourchooser.PyColourChooser

OnBeginDocument

Method in class wx.lib.docview.DocPrintout

OnBeginDocument

Method in class wx.lib.printout.SetPrintout

OnBeginDragLeft

Method in class wx.lib.ogl.CompositeShape

OnBeginDragLeft

Method in class wx.lib.ogl.ControlPoint

OnBeginDragLeft

Method in class wx.lib.ogl.DividedShapeControlPoint

OnBeginDragLeft

Method in class wx.lib.ogl.DivisionControlPoint

OnBeginDragLeft

Method in class wx.lib.ogl.DivisionShape

OnBeginDragLeft

Method in class wx.lib.ogl.LabelShape

OnBeginDragLeft

Method in class wx.lib.ogl.LineControlPoint

OnBeginDragLeft

Method in class wx.lib.ogl.LineShape

OnBeginDragLeft

Method in class wx.lib.ogl.PolygonControlPoint

OnBeginDragLeft

Method in class wx.lib.ogl.Shape

OnBeginDragLeft

Method in class wx.lib.ogl.ShapeCanvas

OnBeginDragLeft

Method in class wx.lib.ogl.ShapeEvtHandler

OnBeginDragRight

Method in class wx.lib.ogl.Shape

OnBeginDragRight

Method in class wx.lib.ogl.ShapeCanvas

OnBeginDragRight

Method in class wx.lib.ogl.ShapeEvtHandler

OnBeginPrinting

Method in class wx.lib.printout.SetPrintout

OnBeginSize

Method in class wx.lib.ogl.ShapeEvtHandler

OnBrowse

Method in class wx.lib.filebrowsebutton.DirBrowseButton

OnBrowse

Method in class wx.lib.filebrowsebutton.FileBrowseButton

OnBtnClick

Method in class wx.lib.foldmenu.FoldOutWindow

OnButton

Method in class wx.lib.popupctl.PopupControl

OnCallTipsShow

Method in class wx.py.frame.Frame

OnCancel

Method in class wx.lib.calendar.CalenDlg

OnCancel

Method in class wx.lib.imagebrowser.ImageDialog

OnCellChange

Method in class wx.lib.sheet.CSheet

OnChange

Method in class wx.lib.colourselect.ColourSelect

OnChangeAttachment

Method in class wx.lib.ogl.Shape

OnChangeAttachment

Method in class wx.lib.ogl.ShapeEvtHandler

OnChanged

Method in class wx.lib.filebrowsebutton.FileBrowseButton

OnChangedViewList

Method in class wx.lib.docview.Document

OnChangeFilename

Method in class wx.lib.docview.View

OnChangeStyle

Method in class wx.lib.analogclockopts.ACCustomizationFrame

OnChar

Method in class wx.lib.editor.editor.Editor

OnChar

Method in class wx.lib.foldpanelbar.CaptionBar

OnChar

Method in class wx.lib.intctrl.IntValidator

OnChar

Method in class wx.lib.mixins.listctrl.TextEditMixin

OnChar

Method in class wx.lib.sheet.CTextCellEditor

OnChar

Method in class wx.lib.shell.PyShellInput

OnChar

Method in class wx.py.editor.Editor

OnChar

Method in class wx.py.shell.Shell

OnChildFocus

Method in class wx.lib.multisash.MultiClient

OnChildFocus

Method in class wx.lib.scrolledpanel.ScrolledPanel

OnClear

Method in class wx.py.frame.Frame

OnClick

Method in class wx.lib.colourselect.ColourSelect

OnClick

Method in class wx.lib.editor.editor.Editor

OnClose

Method in class wx.lib.docview.View

OnClose

Method in class wx.py.crust.CrustFrame

OnClose

Method in class wx.py.editor.EditorFrame

OnClose

Method in class wx.py.frame.Frame

OnClose

Method in class wx.py.shell.ShellFrame

OnCloseChildWindow

Method in class wx.lib.pydocview.DocApp

OnCloseDocument

Method in class wx.lib.docview.Document

OnCloseFrame

Method in class wx.lib.pydocview.DocService

OnCloseMainWindow

Method in class wx.lib.pydocview.DocApp

OnCloseWindow

Method in class wx.PyOnDemandOutputWindow

OnCloseWindow

Method in class wx.lib.docview.DocChildFrame

OnCloseWindow

Method in class wx.lib.docview.DocMDIChildFrame

OnCloseWindow

Method in class wx.lib.docview.DocMDIParentFrame

OnCloseWindow

Method in class wx.lib.docview.DocParentFrame

OnCloseWindow

Method in class wx.lib.infoframe.PyInformationalMessagesFrame

OnCloseWindow

Method in class wx.lib.pydocview.DocMDIChildFrame

OnCloseWindow

Method in class wx.lib.pydocview.DocMDIParentFrame

OnCloseWindow

Method in class wx.lib.pydocview.DocSDIFrame

OnCloseWindow

Method in class wx.lib.pydocview.DocTabbedParentFrame

OnCloseWindow

Method in class wx.lib.splashscreen.SplashScreen

OnClosingDocument

Method in class wx.lib.docview.View

OnColSize

Method in class wx.lib.sheet.CSheet

OnCopy

Method in class wx.py.frame.Frame

OnCopyPlus

Method in class wx.py.frame.Frame

OnCopySelection

Method in class wx.lib.editor.editor.Editor

OnCreate

Method in class wx.lib.docview.Document

OnCreate

Method in class wx.lib.docview.View

OnCreate

Method in class wx.lib.masked.combobox.PreMaskedComboBox

OnCreate

Method in class wx.lib.masked.textctrl.PreMaskedTextCtrl

OnCreateCommandProcessor

Method in class wx.lib.docview.Document

OnCreateDivision

Method in class wx.lib.ogl.CompositeShape

OnCreateFileHistory

Method in class wx.lib.docview.DocManager

OnCreateLabelShape

Method in class wx.lib.ogl.LineShape

OnCreatePrintout

Method in class wx.lib.docview.View

onCustomClick

Method in class wx.lib.colourchooser.pycolourchooser.PyColourChooser

OnCut

Method in class wx.py.frame.Frame

OnCutSelection

Method in class wx.lib.editor.editor.Editor

OnDefaults

Method in class wx.lib.analogclockopts.ACCustomizationFrame

OnDelete

Method in class wx.lib.ogl.ShapeEvtHandler

OnDeleteSelection

Method in class wx.lib.editor.editor.Editor

OnDestroy

Method in class wx.lib.editor.editor.Editor

OnDestroyWindow

Method in class wx.lib.throbber.Throbber

OnDot

Method in class wx.lib.masked.ipaddrctrl.IpAddrCtrl

OnDragLeft

Method in class wx.lib.ogl.CompositeShape

OnDragLeft

Method in class wx.lib.ogl.ControlPoint

OnDragLeft

Method in class wx.lib.ogl.DividedShapeControlPoint

OnDragLeft

Method in class wx.lib.ogl.DivisionControlPoint

OnDragLeft

Method in class wx.lib.ogl.DivisionShape

OnDragLeft

Method in class wx.lib.ogl.LabelShape

OnDragLeft

Method in class wx.lib.ogl.LineControlPoint

OnDragLeft

Method in class wx.lib.ogl.LineShape

OnDragLeft

Method in class wx.lib.ogl.PolygonControlPoint

OnDragLeft

Method in class wx.lib.ogl.Shape

OnDragLeft

Method in class wx.lib.ogl.ShapeCanvas

OnDragLeft

Method in class wx.lib.ogl.ShapeEvtHandler

OnDragRight

Method in class wx.lib.ogl.Shape

OnDragRight

Method in class wx.lib.ogl.ShapeCanvas

OnDragRight

Method in class wx.lib.ogl.ShapeEvtHandler

OnDraw

Method in class wx.lib.docview.View

OnDraw

Method in class wx.lib.ogl.BitmapShape

OnDraw

Method in class wx.lib.ogl.CompositeShape

OnDraw

Method in class wx.lib.ogl.ControlPoint

OnDraw

Method in class wx.lib.ogl.DividedShape

OnDraw

Method in class wx.lib.ogl.DivisionShape

OnDraw

Method in class wx.lib.ogl.DrawnShape

OnDraw

Method in class wx.lib.ogl.EllipseShape

OnDraw

Method in class wx.lib.ogl.LabelShape

OnDraw

Method in class wx.lib.ogl.LineControlPoint

OnDraw

Method in class wx.lib.ogl.LineShape

OnDraw

Method in class wx.lib.ogl.PolygonShape

OnDraw

Method in class wx.lib.ogl.RectangleShape

OnDraw

Method in class wx.lib.ogl.Shape

OnDraw

Method in class wx.lib.ogl.ShapeEvtHandler

OnDraw

Method in class wx.lib.ogl.TextShape

OnDrawBranches

Method in class wx.lib.ogl.Shape

OnDrawBranches

Method in class wx.lib.ogl.ShapeEvtHandler

OnDrawBranchesAttachment

Method in class wx.lib.ogl.Shape

OnDrawContents

Method in class wx.lib.ogl.CompositeShape

OnDrawContents

Method in class wx.lib.ogl.ControlPoint

OnDrawContents

Method in class wx.lib.ogl.DividedShape

OnDrawContents

Method in class wx.lib.ogl.DivisionShape

OnDrawContents

Method in class wx.lib.ogl.LabelShape

OnDrawContents

Method in class wx.lib.ogl.LineShape

OnDrawContents

Method in class wx.lib.ogl.Shape

OnDrawContents

Method in class wx.lib.ogl.ShapeEvtHandler

OnDrawControlPoints

Method in class wx.lib.ogl.LineShape

OnDrawControlPoints

Method in class wx.lib.ogl.Shape

OnDrawControlPoints

Method in class wx.lib.ogl.ShapeEvtHandler

OnDrawOutline

Method in class wx.lib.ogl.DrawnShape

OnDrawOutline

Method in class wx.lib.ogl.LineShape

OnDrawOutline

Method in class wx.lib.ogl.OpPolyDraw

OnDrawOutline

Method in class wx.lib.ogl.PolygonShape

OnDrawOutline

Method in class wx.lib.ogl.Shape

OnDrawOutline

Method in class wx.lib.ogl.ShapeEvtHandler

OnEnableGrid

Method in class wx.lib.plot.TestFrame

OnEnableLegend

Method in class wx.lib.plot.TestFrame

OnEnablePointLabel

Method in class wx.lib.plot.TestFrame

OnEnableZoom

Method in class wx.lib.plot.TestFrame

OnEndDocument

Method in class wx.lib.printout.SetPrintout

OnEndDragLeft

Method in class wx.lib.ogl.CompositeShape

OnEndDragLeft

Method in class wx.lib.ogl.ControlPoint

OnEndDragLeft

Method in class wx.lib.ogl.DividedShapeControlPoint

OnEndDragLeft

Method in class wx.lib.ogl.DivisionControlPoint

OnEndDragLeft

Method in class wx.lib.ogl.DivisionShape

OnEndDragLeft

Method in class wx.lib.ogl.LabelShape

OnEndDragLeft

Method in class wx.lib.ogl.LineControlPoint

OnEndDragLeft

Method in class wx.lib.ogl.LineShape

OnEndDragLeft

Method in class wx.lib.ogl.PolygonControlPoint

OnEndDragLeft

Method in class wx.lib.ogl.Shape

OnEndDragLeft

Method in class wx.lib.ogl.ShapeCanvas

OnEndDragLeft

Method in class wx.lib.ogl.ShapeEvtHandler

OnEndDragRight

Method in class wx.lib.ogl.Shape

OnEndDragRight

Method in class wx.lib.ogl.ShapeCanvas

OnEndDragRight

Method in class wx.lib.ogl.ShapeEvtHandler

OnEndSize

Method in class wx.lib.ogl.ShapeEvtHandler

OnEnter

Method in class wx.lib.multisash.MultiCloser

OnEnter

Method in class wx.lib.multisash.MultiCreator

OnEnter

Method in class wx.lib.multisash.MultiSizer

OnErase

Method in class wx.lib.ogl.CompositeShape

OnErase

Method in class wx.lib.ogl.ControlPoint

OnErase

Method in class wx.lib.ogl.LineShape

OnErase

Method in class wx.lib.ogl.Shape

OnErase

Method in class wx.lib.ogl.ShapeEvtHandler

OnErase

Method in class wx.lib.ticker.Ticker

OnEraseBackground

Method in class wx.lib.editor.editor.Editor

OnEraseBackground

Method in class wx.lib.mvctree.MVCTree

OnEraseBackground

Method in class wx.lib.popupctl.PopButton

OnEraseBackground

Method in class wx.lib.statbmp.GenStaticBitmap

OnEraseBackground

Method in class wx.lib.stattext.GenStaticText

OnEraseBG

Method in class wx.lib.splashscreen.SplashScreen

OnEraseContents

Method in class wx.lib.ogl.Shape

OnEraseContents

Method in class wx.lib.ogl.ShapeEvtHandler

OnEraseControlPoints

Method in class wx.lib.ogl.LineShape

OnEraseControlPoints

Method in class wx.lib.ogl.Shape

OnEraseControlPoints

Method in class wx.lib.ogl.ShapeEvtHandler

OnEventsHook

Method in class wx.lib.analogclockopts.ACCustomizationFrame

OnExit

Method in class wx.lib.docview.DocMDIParentFrame

OnExit

Method in class wx.lib.docview.DocParentFrame

OnExit

Method in class wx.lib.pydocview.DocApp

OnExit

Method in class wx.lib.pydocview.DocSDIFrame

OnExit

Method in class wx.lib.pydocview.DocService

OnExit

Method in class wx.lib.pydocview.DocTabbedParentFrame

OnExit

Method in class wx.py.frame.Frame

OnFileClose

Method in class wx.lib.docview.DocManager

OnFileClose

Method in class wx.py.frame.Frame

OnFileCloseAll

Method in class wx.lib.docview.DocManager

OnFileDlg

Function in module wx.lib.imagebrowser

OnFileExit

Method in class wx.lib.plot.TestFrame

OnFileNew

Method in class wx.lib.docview.DocManager

OnFileNew

Method in class wx.py.frame.Frame

OnFileOpen

Method in class wx.lib.docview.DocManager

OnFileOpen

Method in class wx.py.frame.Frame

OnFilePageSetup

Method in class wx.lib.plot.TestFrame

OnFilePrint

Method in class wx.lib.plot.TestFrame

OnFilePrint

Method in class wx.py.frame.Frame

OnFilePrintPreview

Method in class wx.lib.plot.TestFrame

OnFileRevert

Method in class wx.lib.docview.DocManager

OnFileRevert

Method in class wx.py.frame.Frame

OnFileSave

Method in class wx.lib.docview.DocManager

OnFileSave

Method in class wx.py.frame.Frame

OnFileSaveAll

Method in class wx.lib.pydocview.DocFrameMixIn

OnFileSaveAs

Method in class wx.lib.docview.DocManager

OnFileSaveAs

Method in class wx.py.frame.Frame

OnFileUpdateNamespace

Method in class wx.py.frame.Frame

OnFirst

Method in class wx.PreviewControlBar

OnFocus

Method in class wx.lib.popupctl.PopupControl

OnGainFocus

Method in class wx.lib.buttons.GenButton

OnGoto

Method in class wx.PreviewControlBar

OnGridSelectCell

Method in class wx.lib.sheet.CSheet

OnHelpAbout

Method in class wx.lib.plot.TestFrame

OnHighlight

Method in class wx.lib.ogl.Shape

OnHighlight

Method in class wx.lib.ogl.ShapeEvtHandler

OnHistoryInsert

Method in class wx.py.shell.Shell

OnHistoryReplace

Method in class wx.py.shell.Shell

OnHistorySearch

Method in class wx.py.shell.Shell

OnIdle

Method in class wx.lib.shell.PyShellOutput

OnIdle

Method in class wx.py.editor.EditorFrame

OnIdle

Method in class wx.py.editor.EditorNotebook

OnIdle

Method in class wx.py.shell.Shell

OnInit

Method in class wx.PySimpleApp

OnInit

Method in class wx.PyWidgetTester

OnInit

Method in class wx.lib.pydocview.DocApp

OnInit

Method in class wx.py.PyAlaCarte.App

OnInit

Method in class wx.py.PyAlaMode.App

OnInit

Method in class wx.py.PyAlaModeTest.App

OnInit

Method in class wx.py.PyCrust.App

OnInit

Method in class wx.py.PyFilling.App

OnInit

Method in class wx.py.PyShell.App

OnInit

Method in class wx.py.filling.App

OnItemActivated

Method in class wx.py.filling.FillingTree

OnItemCollapsed

Method in class wx.py.filling.FillingTree

OnItemExpanding

Method in class wx.py.filling.FillingTree

OnItemSelected

Method in class wx.lib.mixins.listctrl.TextEditMixin

OnKey

Method in class wx.lib.pyshell.PyShellWindow

OnKeyDown

Method in class wx.lib.buttons.GenButton

OnKeyDown

Method in class wx.lib.calendar.Calendar

OnKeyDown

Method in class wx.lib.mvctree.MVCTree

OnKeyDown

Method in class wx.py.editor.Editor

OnKeyDown

Method in class wx.py.shell.Shell

OnKeyUp

Method in class wx.lib.buttons.GenButton

OnKillFocus

Method in class wx.lib.calendar.Calendar

OnKillFocus

Method in class wx.lib.rightalign.RightTextCtrl

OnKnobClick

Method in class wx.lib.mvctree.MVCTree

OnLabelMovePre

Method in class wx.lib.ogl.LineShape

OnLast

Method in class wx.PreviewControlBar

OnLCSMDoPopup

Method in class wx.lib.mixins.listctrl.ListCtrlSelectionManagerMix

OnLCSMRightDown

Method in class wx.lib.mixins.listctrl.ListCtrlSelectionManagerMix

OnLeave

Method in class wx.lib.multisash.MultiCloser

OnLeave

Method in class wx.lib.multisash.MultiCreator

OnLeave

Method in class wx.lib.multisash.MultiSizer

OnLeave

Method in class wx.lib.plot.PlotCanvas

OnLeftClick

Method in class wx.lib.ogl.LabelShape

OnLeftClick

Method in class wx.lib.ogl.Shape

OnLeftClick

Method in class wx.lib.ogl.ShapeCanvas

OnLeftClick

Method in class wx.lib.ogl.ShapeEvtHandler

OnLeftClick

Method in class wx.lib.sheet.CSheet

OnLeftDEvent

Method in class wx.lib.calendar.Calendar

OnLeftDoubleClick

Method in class wx.lib.ogl.ShapeEvtHandler

OnLeftDoubleClick

Method in class wx.lib.sheet.CSheet

OnLeftDown

Method in class wx.lib.buttons.GenButton

OnLeftDown

Method in class wx.lib.editor.editor.Editor

OnLeftDown

Method in class wx.lib.mixins.listctrl.TextEditMixin

OnLeftDown

Method in class wx.lib.popupctl.PopButton

OnLeftEvent

Method in class wx.lib.calendar.Calendar

OnLeftUp

Method in class wx.lib.buttons.GenButton

OnLeftUp

Method in class wx.lib.editor.editor.Editor

OnLeftUp

Method in class wx.lib.popupctl.PopButton

OnLinkClicked

Method in class wx.lib.ClickableHtmlWindow.PyClickableHtmlWindow

OnListClick

Method in class wx.lib.imagebrowser.ImageDialog

OnListDClick

Method in class wx.lib.imagebrowser.ImageDialog

OnLog

Method in class wx.Log

OnLoseFocus

Method in class wx.lib.buttons.GenButton

OnMenu

Method in class wx.lib.ogl.PopupDivisionMenu

OnMonthSpin

Method in class wx.lib.calendar.CalenDlg

OnMotion

Method in class wx.lib.buttons.GenButton

OnMotion

Method in class wx.lib.editor.editor.Editor

OnMotion

Method in class wx.lib.gestures.MouseGestures

OnMotion

Method in class wx.lib.plot.PlotCanvas

OnMotion

Method in class wx.lib.plot.TestFrame

OnMotion

Method in class wx.lib.popupctl.PopButton

OnMouse

Method in class wx.lib.mvctree.MVCTree

OnMouse

Method in class wx.lib.mvctree.Painter

OnMouse

Method in class wx.lib.mvctree.TreePainter

OnMouseClick

Method in class wx.lib.splashscreen.SplashScreen

OnMouseDoubleClick

Method in class wx.lib.plot.PlotCanvas

OnMouseEvent

Method in class wx.lib.foldpanelbar.CaptionBar

OnMouseEvent

Method in class wx.lib.gestures.MouseGestures

OnMouseEvent

Method in class wx.lib.hyperlink.HyperLinkCtrl

OnMouseEvent

Method in class wx.lib.ogl.ShapeCanvas

OnMouseLeftDown

Method in class wx.lib.plot.PlotCanvas

OnMouseLeftDown

Method in class wx.lib.plot.TestFrame

OnMouseLeftUp

Method in class wx.lib.plot.PlotCanvas

OnMouseMove

Method in class wx.lib.gridmovers.GridColMover

OnMouseMove

Method in class wx.lib.gridmovers.GridRowMover

OnMouseMove

Method in class wx.lib.multisash.MultiCreator

OnMouseMove

Method in class wx.lib.multisash.MultiSizer

OnMouseRightDown

Method in class wx.lib.plot.PlotCanvas

OnMoveLink

Method in class wx.lib.ogl.LineShape

OnMoveLink

Method in class wx.lib.ogl.ShapeEvtHandler

OnMoveLinks

Method in class wx.lib.ogl.Shape

OnMoveLinks

Method in class wx.lib.ogl.ShapeEvtHandler

OnMoveMiddleControlPoint

Method in class wx.lib.ogl.LineShape

OnMovePost

Method in class wx.lib.ogl.ShapeEvtHandler

OnMovePre

Method in class wx.lib.ogl.CompositeShape

OnMovePre

Method in class wx.lib.ogl.DivisionShape

OnMovePre

Method in class wx.lib.ogl.LabelShape

OnMovePre

Method in class wx.lib.ogl.LineShape

OnMovePre

Method in class wx.lib.ogl.Shape

OnMovePre

Method in class wx.lib.ogl.ShapeEvtHandler

OnMRUFile

Method in class wx.lib.docview.DocMDIParentFrame

OnMRUFile

Method in class wx.lib.docview.DocParentFrame

OnMRUFile

Method in class wx.lib.pydocview.DocSDIFrame

OnMRUFile

Method in class wx.lib.pydocview.DocTabbedParentFrame

OnMultiSize

Method in class wx.lib.multisash.MultiSash

OnNewDocument

Method in class wx.lib.docview.Document

OnNext

Method in class wx.PreviewControlBar

OnNodeClick

Method in class wx.lib.mvctree.MVCTree

OnNotebookMouseOver

Method in class wx.lib.pydocview.DocTabbedParentFrame

OnNotebookPageChanged

Method in class wx.lib.pydocview.DocTabbedParentFrame

OnNotebookRightClick

Method in class wx.lib.pydocview.DocTabbedParentFrame

OnOk

Method in class wx.lib.calendar.CalenDlg

OnOk

Method in class wx.lib.imagebrowser.ImageDialog

OnOK

Method in class wx.lib.pydocview.GeneralOptionsPanel

OnOK

Method in class wx.lib.pydocview.OptionsDialog

OnOpenDocument

Method in class wx.lib.docview.Document

OnOpenDocument

Method in class wx.lib.pydocview.ChildDocument

OnOpenFileFailure

Method in class wx.lib.docview.DocManager

OnOptions

Method in class wx.lib.pydocview.DocOptionsService

OnPageChanged

Method in class wx.py.editor.EditorNotebook

OnPageChanged

Method in class wx.py.editor.EditorShellNotebook

OnPageChanging

Method in class wx.py.editor.EditorNotebook

OnPaint

Method in class wx.lib.analogclock.AnalogClockWindow

OnPaint

Method in class wx.lib.buttons.GenButton

OnPaint

Method in class wx.lib.calendar.Calendar

onPaint

Method in class wx.lib.colourchooser.canvas.Canvas

OnPaint

Method in class wx.lib.editor.editor.Editor

OnPaint

Method in class wx.lib.floatcanvas.FloatCanvas.FloatCanvas

OnPaint

Method in class wx.lib.foldpanelbar.CaptionBar

OnPaint

Method in class wx.lib.foldpanelbar.FoldPanelItem

OnPaint

Method in class wx.lib.gridmovers.ColDragWindow

OnPaint

Method in class wx.lib.gridmovers.RowDragWindow

OnPaint

Method in class wx.lib.imagebrowser.ImageView

OnPaint

Method in class wx.lib.multisash.MultiCloser

OnPaint

Method in class wx.lib.multisash.MultiCreator

OnPaint

Method in class wx.lib.mvctree.MVCTree

OnPaint

Method in class wx.lib.ogl.ShapeCanvas

OnPaint

Method in class wx.lib.plot.PlotCanvas

OnPaint

Method in class wx.lib.popupctl.PopButton

OnPaint

Method in class wx.lib.rightalign.RightTextCtrl

OnPaint

Method in class wx.lib.splashscreen.SplashScreen

OnPaint

Method in class wx.lib.statbmp.GenStaticBitmap

OnPaint

Method in class wx.lib.stattext.GenStaticText

OnPaint

Method in class wx.lib.throbber.Throbber

OnPaint

Method in class wx.lib.ticker.Ticker

OnPaint

Method in class wx.lib.wxPlotCanvas.PlotCanvas

onPaletteDown

Method in class wx.lib.colourchooser.pycolourchooser.PyColourChooser

onPaletteMotion

Method in class wx.lib.colourchooser.pycolourchooser.PyColourChooser

onPaletteUp

Method in class wx.lib.colourchooser.pycolourchooser.PyColourChooser

OnPaste

Method in class wx.lib.editor.editor.Editor

OnPaste

Method in class wx.py.frame.Frame

OnPastePlus

Method in class wx.py.frame.Frame

OnPlotClear

Method in class wx.lib.plot.TestFrame

OnPlotDraw1

Method in class wx.lib.plot.TestFrame

OnPlotDraw2

Method in class wx.lib.plot.TestFrame

OnPlotDraw3

Method in class wx.lib.plot.TestFrame

OnPlotDraw4

Method in class wx.lib.plot.TestFrame

OnPlotDraw5

Method in class wx.lib.plot.TestFrame

OnPlotDraw6

Method in class wx.lib.plot.TestFrame

OnPlotRedraw

Method in class wx.lib.plot.TestFrame

OnPlotScale

Method in class wx.lib.plot.TestFrame

OnPopUpCopy

Method in class wx.lib.hyperlink.HyperLinkCtrl

OnPopupOne

Method in class wx.lib.analogclock.AnalogClockWindow

OnPopupTwo

Method in class wx.lib.analogclock.AnalogClockWindow

OnPreparePrinting

Method in class wx.lib.printout.SetPrintout

OnPress

Method in class wx.lib.gridmovers.GridColMover

OnPress

Method in class wx.lib.gridmovers.GridRowMover

OnPress

Method in class wx.lib.multisash.MultiCloser

OnPress

Method in class wx.lib.multisash.MultiCreator

OnPress

Method in class wx.lib.multisash.MultiSizer

OnPressCaption

Method in class wx.lib.foldpanelbar.FoldPanelBar

OnPressCaption

Method in class wx.lib.foldpanelbar.FoldPanelItem

OnPreview

Method in class wx.lib.docview.DocManager

OnPrevious

Method in class wx.PreviewControlBar

OnPrint

Method in class wx.lib.docview.DocManager

OnPrint

Method in class wx.lib.docview.View

OnPrintPage

Method in class wx.lib.docview.DocPrintout

OnPrintPage

Method in class wx.lib.plot.PlotPrintout

OnPrintPage

Method in class wx.lib.printout.SetPrintout

OnPrintSetup

Method in class wx.lib.docview.DocManager

OnQuit

Method in class wx.lib.analogclock.AnalogClockWindow

OnQuit

Method in class wx.lib.analogclockopts.ACCustomizationFrame

OnRangeSelect

Method in class wx.lib.sheet.CSheet

OnRedo

Method in class wx.lib.docview.DocManager

OnRedo

Method in class wx.py.frame.Frame

OnRelease

Method in class wx.lib.gridmovers.GridColMover

OnRelease

Method in class wx.lib.gridmovers.GridRowMover

OnRelease

Method in class wx.lib.multisash.MultiCloser

OnRelease

Method in class wx.lib.multisash.MultiCreator

OnRelease

Method in class wx.lib.multisash.MultiSizer

OnReset

Method in class wx.lib.plot.TestFrame

OnRightClick

Method in class wx.lib.analogclock.AnalogClockWindow

OnRightClick

Method in class wx.lib.ogl.CompositeShape

OnRightClick

Method in class wx.lib.ogl.DividedShape

OnRightClick

Method in class wx.lib.ogl.DivisionShape

OnRightClick

Method in class wx.lib.ogl.LabelShape

OnRightClick

Method in class wx.lib.ogl.Shape

OnRightClick

Method in class wx.lib.ogl.ShapeCanvas

OnRightClick

Method in class wx.lib.ogl.ShapeEvtHandler

OnRightClick

Method in class wx.lib.sheet.CSheet

OnRightDEvent

Method in class wx.lib.calendar.Calendar

OnRightDown

Method in class wx.lib.analogclock.AnalogClockWindow

OnRightEvent

Method in class wx.lib.calendar.Calendar

OnRowSize

Method in class wx.lib.sheet.CSheet

OnSaveDocument

Method in class wx.lib.docview.Document

OnSaveDocument

Method in class wx.lib.pydocview.ChildDocument

OnSaveFile

Method in class wx.lib.plot.TestFrame

OnSaveModified

Method in class wx.lib.docview.Document

onScroll

Method in class wx.lib.colourchooser.pycolourchooser.PyColourChooser

OnScroll

Method in class wx.lib.editor.editor.Editor

OnScrRt

Method in class wx.lib.plot.TestFrame

OnScrUp

Method in class wx.lib.plot.TestFrame

OnSelChanged

Method in class wx.py.filling.FillingTree

OnSelectAll

Method in class wx.py.frame.Frame

OnSelectColour

Method in class wx.lib.analogclockopts.ACCustomizationFrame

OnSelectFont

Method in class wx.lib.analogclockopts.ACCustomizationFrame

OnSelectMoreWindows

Method in class wx.lib.pydocview.WindowMenuService

OnSelectWindowMenu

Method in class wx.lib.pydocview.WindowMenuService

OnSetFocus

Method in class wx.lib.calendar.Calendar

OnSetFocus

Method in class wx.lib.filebrowsebutton.FileBrowseButtonWithHistory

OnSetFocus

Method in class wx.lib.multisash.MultiClient

OnSetFocus

Method in class wx.lib.shell.PyShell

OnSetFocus

Method in class wx.lib.shell.PyShellInput

OnSetType

Method in class wx.lib.imagebrowser.ImageDialog

OnSize

Method in class wx.NotebookPage

OnSize

Method in class wx.lib.analogclock.AnalogClockWindow

OnSize

Method in class wx.lib.calendar.Calendar

onSize

Method in class wx.lib.colourchooser.canvas.Canvas

OnSize

Method in class wx.lib.editor.editor.Editor

OnSize

Method in class wx.lib.floatcanvas.FloatCanvas.FloatCanvas

OnSize

Method in class wx.lib.foldpanelbar.CaptionBar

OnSize

Method in class wx.lib.multisash.MultiClient

OnSize

Method in class wx.lib.multisash.MultiCloser

OnSize

Method in class wx.lib.multisash.MultiCreator

OnSize

Method in class wx.lib.multisash.MultiSizer

OnSize

Method in class wx.lib.multisash.MultiSplit

OnSize

Method in class wx.lib.multisash.MultiViewLeaf

OnSize

Method in class wx.lib.mvctree.MVCTree

OnSize

Method in class wx.lib.ogl.Shape

OnSize

Method in class wx.lib.ogl.ShapeEvtHandler

OnSize

Method in class wx.lib.plot.PlotCanvas

OnSize

Method in class wx.lib.popupctl.PopupControl

OnSize

Method in class wx.lib.pydocview.DocMDIParentFrame

OnSize

Method in class wx.lib.pydocview.DocTabbedParentFrame

OnSize

Method in class wx.lib.shell.PyShell

OnSize

Method in class wx.lib.shell.PyShellOutput

OnSizePanel

Method in class wx.lib.foldpanelbar.FoldPanelBar

OnSizingBeginDragLeft

Method in class wx.lib.ogl.LineShape

OnSizingBeginDragLeft

Method in class wx.lib.ogl.PolygonShape

OnSizingBeginDragLeft

Method in class wx.lib.ogl.Shape

OnSizingBeginDragLeft

Method in class wx.lib.ogl.ShapeEvtHandler

OnSizingDragLeft

Method in class wx.lib.ogl.LineShape

OnSizingDragLeft

Method in class wx.lib.ogl.PolygonShape

OnSizingDragLeft

Method in class wx.lib.ogl.Shape

OnSizingDragLeft

Method in class wx.lib.ogl.ShapeEvtHandler

OnSizingEndDragLeft

Method in class wx.lib.ogl.LineShape

OnSizingEndDragLeft

Method in class wx.lib.ogl.PolygonShape

OnSizingEndDragLeft

Method in class wx.lib.ogl.Shape

OnSizingEndDragLeft

Method in class wx.lib.ogl.ShapeEvtHandler

OnSpinChange

Method in class wx.lib.analogclockopts.ACCustomizationFrame

OnSplashExitDefault

Method in class wx.lib.splashscreen.SplashScreen

OnStyle

Method in class wx.lib.pyshell.PyShellWindow

OnText

Method in class wx.lib.intctrl.IntCtrl

OnTextChange

Method in class wx.lib.masked.numctrl.NumCtrl

OnTick

Method in class wx.lib.ticker.Ticker

OnTimer

Method in class wx.lib.editor.editor.Editor

OnTimer

Method in class wx.lib.throbber.Throbber

OnTimerExpire

Method in class wx.lib.analogclock.AnalogClockWindow

OnUndo

Method in class wx.lib.docview.DocManager

OnUndo

Method in class wx.py.frame.Frame

OnUpdate

Method in class wx.lib.docview.View

OnUpdateFileClose

Method in class wx.lib.docview.DocManager

OnUpdateFileCloseAll

Method in class wx.lib.docview.DocManager

OnUpdateFileNew

Method in class wx.lib.docview.DocManager

OnUpdateFileOpen

Method in class wx.lib.docview.DocManager

OnUpdateFileRevert

Method in class wx.lib.docview.DocManager

OnUpdateFileSave

Method in class wx.lib.docview.DocManager

OnUpdateFileSaveAs

Method in class wx.lib.docview.DocManager

OnUpdateMenu

Method in class wx.py.frame.Frame

OnUpdatePreview

Method in class wx.lib.docview.DocManager

OnUpdatePrint

Method in class wx.lib.docview.DocManager

OnUpdatePrintSetup

Method in class wx.lib.docview.DocManager

OnUpdateRedo

Method in class wx.lib.docview.DocManager

OnUpdateUI

Method in class wx.lib.pyshell.PyShellWindow

OnUpdateUI

Method in class wx.py.editwindow.EditWindow

OnUpdateUndo

Method in class wx.lib.docview.DocManager

OnUpdateViewStatusBar

Method in class wx.lib.pydocview.DocFrameMixIn

OnUpdateViewToolBar

Method in class wx.lib.pydocview.DocFrameMixIn

OnUseAA

Method in class wx.py.frame.Frame

OnViewStatusBar

Method in class wx.lib.pydocview.DocFrameMixIn

OnViewToolBar

Method in class wx.lib.pydocview.DocFrameMixIn

OnWrap

Method in class wx.py.frame.Frame

OnYrSpin

Method in class wx.lib.calendar.CalenDlg

op_d

Variable in class wx.lib.layoutf.Layoutf

OpDraw

Class in package wx.lib.ogl

Open

Method in class wx.Clipboard

Open

Method in class wx.Process

open

Method in class wx.py.buffer.Buffer

OpenCommandLineArgs

Method in class wx.lib.pydocview.DocApp

OpenContainer

Method in class wx.html.HtmlWinParser

OpenEditor

Method in class wx.lib.mixins.listctrl.TextEditMixin

OpenFile

Method in class wx.FileSystem

OpenFile

Method in class wx.FileSystemHandler

OpenFile

Method in class wx.InternetFSHandler

OpenFile

Method in class wx.MemoryFSHandler

OpenFile

Method in class wx.ZipFSHandler

openFileDialog

Function in module wx.lib.dialogs

OpenInSameWindow

Method in class wx.lib.hyperlink.HyperLinkCtrl

OpenMainFrame

Method in class wx.lib.pydocview.DocApp

openMultiple

Function in module wx.py.editor

OpenNewFile

Method in class wx.lib.infoframe.PyInformationalMessagesFrame

openSingle

Function in module wx.py.editor

OpPolyDraw

Class in package wx.lib.ogl

OpSetClipping

Class in package wx.lib.ogl

OpSetGDI

Class in package wx.lib.ogl

OptionsDialog

Class in module wx.lib.pydocview

original

Variable in module wx.py.PyCrust

original

Variable in module wx.py.PyShell

out_style

Variable in class wx.lib.shell.PyShellOutput

OutCanvas

Method in class wx.lib.printout.PrintTableDraw

OutPage

Method in class wx.lib.printout.PrintTableDraw

OutputStream

Class in package wx

PyOnDemandOutputWindow

Class in package wx

OutTextPageWidth

Method in class wx.lib.printout.PrintBase

OutTextRegion

Method in class wx.lib.printout.PrintBase

overwriteConfirm

Method in class wx.py.buffer.Buffer

pack

Method in class wx.lib.layoutf.Layoutf

PageDown

Method in class wx.Window

PageDown

Method in class wx.stc.StyledTextCtrl

PageDownExtend

Method in class wx.stc.StyledTextCtrl

PageDownRectExtend

Method in class wx.stc.StyledTextCtrl

PageSetup

Method in class wx.html.HtmlEasyPrinting

PageSetup

Method in class wx.lib.plot.PlotCanvas

PageSetupDialog

Class in package wx

PageSetupDialogData

Class in package wx

PageUp

Method in class wx.Window

PageUp

Method in class wx.stc.StyledTextCtrl

PageUpExtend

Method in class wx.stc.StyledTextCtrl

PageUpRectExtend

Method in class wx.stc.StyledTextCtrl

Paint

Method in class wx.lib.mvctree.LinePainter

Paint

Method in class wx.lib.mvctree.NodePainter

Paint

Method in class wx.lib.mvctree.Painter

Paint

Method in class wx.lib.mvctree.TreeLinePainter

Paint

Method in class wx.lib.mvctree.TreeNodePainter

Paint

Method in class wx.lib.mvctree.TreePainter

PaintBackground

Method in class wx.grid.GridCellEditor

PaintBackground

Method in class wx.lib.sheet.CCellEditor

PaintDC

Class in package wx

Painter

Class in module wx.lib.mvctree

PaintEvent

Class in package wx

PaintPage

Method in class wx.PrintPreview

paintWalk

Method in class wx.lib.mvctree.TreePainter

Palette

Class in package wx

PaletteChangedEvent

Class in package wx

Panel

Class in package wx

Panel_GetClassDefaultAttributes

Function in package wx

ParaDown

Method in class wx.stc.StyledTextCtrl

ParaDownExtend

Method in class wx.stc.StyledTextCtrl

param

Variable in class wx.lib.masked.ipaddrctrl.IpAddrCtrlAccessorsMixin

param

Variable in class wx.lib.masked.ipaddrctrl.IpAddrCtrlAccessorsMixin

param

Variable in class wx.lib.masked.maskededit.MaskedEditAccessorsMixin

param

Variable in class wx.lib.masked.maskededit.MaskedEditAccessorsMixin

param

Variable in class wx.lib.masked.maskededit.MaskedEditAccessorsMixin

param

Variable in class wx.lib.masked.maskededit.MaskedEditAccessorsMixin

param

Variable in class wx.lib.masked.maskededit.MaskedEditAccessorsMixin

param

Variable in class wx.lib.masked.numctrl.NumCtrlAccessorsMixin

param

Variable in class wx.lib.masked.numctrl.NumCtrlAccessorsMixin

param

Variable in class wx.lib.masked.timectrl.TimeCtrlAccessorsMixin

Parameter

Class in module wx.py.dispatcher

PARAMTAG

Variable in module wx.lib.wxpTag

ParaUp

Method in class wx.stc.StyledTextCtrl

ParaUpExtend

Method in class wx.stc.StyledTextCtrl

Parse

Method in class wx.html.HtmlParser

ParseDate

Method in class wx.DateTime

ParseDateTime

Method in class wx.DateTime

ParseFormat

Method in class wx.DateTime

ParseInner

Method in class wx.html.HtmlTagHandler

ParseInner

Method in class wx.html.HtmlWinTagHandler

ParseRfc822Date

Method in class wx.DateTime

ParseTime

Method in class wx.DateTime

PassMessages

Method in class wx.LogChain

PassMessages

Method in class wx.LogWindow

PasswordEntryDialog

Class in package wx

Paste

Method in class wx.ComboBox

Paste

Method in class wx.Image

Paste

Method in class wx.TextCtrl

Paste

Method in class wx.lib.intctrl.IntCtrl

Paste

Method in class wx.lib.masked.combobox.BaseMaskedComboBox

Paste

Method in class wx.lib.masked.textctrl.BaseMaskedTextCtrl

Paste

Method in class wx.lib.sheet.CSheet

Paste

Method in class wx.py.shell.Shell

Paste

Method in class wx.stc.StyledTextCtrl

PasteAndRun

Method in class wx.py.shell.Shell

PathOnly

Function in module wx.lib.docview

Pause

Method in class wx.StopWatch

Pause

Method in class wx.media.MediaCtrl

pause

Method in class wx.py.shell.Shell

PCXHandler

Class in package wx

PDT

Variable in class wx.DateTime

PDT

Variable in class wx.DateTime

Peek

Method in class wx.InputStream

Pen

Class in package wx

Pending

Method in class wx.EventLoop

Pending

Method in class wx.PyApp

PenList

Class in package wx

PenList

Variable in class wx.lib.floatcanvas.FloatCanvas.DrawObject

PenList

Variable in class wx.lib.floatcanvas.FloatCanvas.DrawObject

PenList

Variable in class wx.lib.floatcanvas.FloatCanvas.DrawObject

PenList

Variable in class wx.lib.floatcanvas.FloatCanvas.DrawObject

PenList

Variable in class wx.lib.floatcanvas.FloatCanvas.DrawObject

PenList

Variable in class wx.lib.floatcanvas.FloatCanvas.DrawObject

PenList

Variable in class wx.lib.floatcanvas.FloatCanvas.DrawObject

PenList

Variable in class wx.lib.floatcanvas.FloatCanvas.DrawObject

PenList

Variable in class wx.lib.floatcanvas.FloatCanvas.DrawObject

PenList

Variable in class wx.lib.floatcanvas.FloatCanvas.DrawObject

PenList

Variable in class wx.lib.floatcanvas.FloatCanvas.DrawObject

PenList

Variable in class wx.lib.floatcanvas.FloatCanvas.DrawObject

PercentOf

Method in class wx.IndividualLayoutConstraint

PhysicalToLogicalAttachment

Method in class wx.lib.ogl.Shape

PixelToWorld

Method in class wx.lib.floatcanvas.FloatCanvas.FloatCanvas

Play

Method in class wx.Sound

Play

Method in class wx.animate.AnimationPlayer

Play

Method in class wx.animate.GIFAnimationCtrl

Play

Method in class wx.media.MediaCtrl

PlayFrame

Method in class wx.animate.AnimationPlayer

PlayNextFrame

Method in class wx.animate.AnimationPlayer

PlaySound

Method in class wx.Sound

plot

Module in package wx.lib

PlotCanvas

Class in module wx.lib.plot

PlotCanvas

Class in module wx.lib.wxPlotCanvas

PlotGraphics

Class in module wx.lib.plot

PlotGraphics

Class in module wx.lib.wxPlotCanvas

PlotPrintout

Class in module wx.lib.plot

PNGHandler

Class in package wx

PNMHandler

Class in package wx

Point

Class in package wx

Point

Class in module wx.lib.floatcanvas.FloatCanvas

Point2D

Class in package wx

Point2DCopy

Function in package wx

Point2DFromPoint

Function in package wx

PointFromPosition

Method in class wx.stc.StyledTextCtrl

pointInBox

Function in module wx.lib.mixins.rubberband

pointOnBox

Function in module wx.lib.mixins.rubberband

PointSet

Class in module wx.lib.floatcanvas.FloatCanvas

PointsObjectMixin

Class in module wx.lib.floatcanvas.FloatCanvas

Polygon

Class in module wx.lib.floatcanvas.FloatCanvas

PolygonControlPoint

Class in package wx.lib.ogl

PolygonShape

Class in package wx.lib.ogl

PolyLine

Class in module wx.lib.plot

PolyLine

Class in module wx.lib.wxPlotCanvas

PolylineHitTest

Function in package wx.lib.ogl

PolyMarker

Class in module wx.lib.plot

PolyMarker

Class in module wx.lib.wxPlotCanvas

PolyPoints

Class in module wx.lib.plot

PolyPoints

Class in module wx.lib.wxPlotCanvas

PopButton

Class in module wx.lib.popupctl

PopDown

Method in class wx.lib.popupctl.PopupControl

PopEventHandler

Method in class wx.Window

PopProvider

Method in class wx.ArtProvider

PopStatusText

Method in class wx.Frame

PopStatusText

Method in class wx.StatusBar

PopTagHandler

Method in class wx.html.HtmlParser

Popup

Method in class wx.PopupTransientWindow

Popup

Method in class wx.lib.foldmenu.FoldOutWindow

PopupControl

Class in module wx.lib.popupctl

popupctl

Module in package wx.lib

PopupDialog

Class in module wx.lib.popupctl

PopupDivisionMenu

Class in package wx.lib.ogl

PopupMenu

Method in class wx.TaskBarIcon

PopupMenu

Method in class wx.Window

PopupMenu

Method in class wx.lib.ogl.DivisionShape

PopupMenuXY

Method in class wx.Window

PopupTransientWindow

Class in package wx

PopupWindow

Class in package wx

Position

Method in class wx.PopupWindow

position

Method in class wx.PopupWindow in class wx.Rect

PositionAfter

Method in class wx.stc.StyledTextCtrl

PositionBefore

Method in class wx.stc.StyledTextCtrl

PositionFromLine

Method in class wx.stc.StyledTextCtrl

PositionFromPoint

Method in class wx.stc.StyledTextCtrl

PositionFromPointClose

Method in class wx.stc.StyledTextCtrl

PositionScreenToUser

Method in class wx.lib.plot.PlotCanvas

PositionToXY

Method in class wx.TextCtrl

PositionUserToScreen

Method in class wx.lib.plot.PlotCanvas

PostCreate

Method in class wx.Window

PostEvent

Function in package wx

PostScriptDC

Class in package wx

PostScriptDC_GetResolution

Function in package wx

PostScriptDC_SetResolution

Function in package wx

PreBitmapButton

Function in package wx

PreButton

Function in package wx

PreCalendarCtrl

Function in module wx.calendar

PreCheckBox

Function in package wx

PreCheckListBox

Function in package wx

PreChoice

Function in package wx

PreChoicebook

Function in package wx

PreComboBox

Function in package wx

PreControl

Function in package wx

PreDatePickerCtrl

Function in package wx

PreDialog

Function in package wx

PreDirFilterListCtrl

Function in package wx

PreDynamicSashWindow

Function in module wx.gizmos

PreFindReplaceDialog

Function in package wx

PreFrame

Function in package wx

PreGauge

Function in package wx

PreGenericDirCtrl

Function in package wx

PreGIFAnimationCtrl

Function in module wx.animate

PreGrid

Function in module wx.grid

PreHtmlListBox

Function in package wx

PreHtmlWindow

Function in module wx.html

PreLEDNumberCtrl

Function in module wx.gizmos

PreListbook

Function in package wx

PreListBox

Function in package wx

PreListCtrl

Function in package wx

PreListView

Function in package wx

PreMaskedComboBox

Class in module wx.lib.masked.combobox

PreMaskedTextCtrl

Class in module wx.lib.masked.textctrl

PreMDIChildFrame

Function in package wx

PreMDIClientWindow

Function in package wx

PreMDIParentFrame

Function in package wx

PreMediaCtrl

Function in module wx.media

PreMiniFrame

Function in package wx

PreNotebook

Function in package wx

PrePanel

Function in package wx

PrepareDC

Method in class wx.Window

Prepend

Method in class wx.Menu

Prepend

Method in class wx.Sizer

PrependCheckItem

Method in class wx.Menu

PrependItem

Method in class wx.Menu

PrependItem

Method in class wx.Sizer

PrependItem

Method in class wx.TreeCtrl

PrependItem

Method in class wx.gizmos.TreeListCtrl

PrependMenu

Method in class wx.Menu

PrependRadioItem

Method in class wx.Menu

PrependSeparator

Method in class wx.Menu

PrependSizer

Method in class wx.Sizer

PrependSpacer

Method in class wx.Sizer

PrependWindow

Method in class wx.Sizer

PrePopupTransientWindow

Function in package wx

PrePopupWindow

Function in package wx

PreprocessTip

Method in class wx.TipProvider

PrePyControl

Function in package wx

PrePyPanel

Function in package wx

PrePyScrolledWindow

Function in package wx

PrePyWindow

Function in package wx

PrePyWizardPage

Function in module wx.wizard

PreRadioBox

Function in package wx

PreRadioButton

Function in package wx

PreSashLayoutWindow

Function in package wx

PreSashWindow

Function in package wx

PreScrollBar

Function in package wx

PreScrolledWindow

Function in package wx

PreSingleInstanceChecker

Function in package wx

PreSlider

Function in package wx

PreSpinButton

Function in package wx

PreSpinCtrl

Function in package wx

PreSplitterWindow

Function in package wx

PreStaticBitmap

Function in package wx

PreStaticBox

Function in package wx

PreStaticLine

Function in package wx

PreStaticPicture

Function in module wx.gizmos

PreStaticText

Function in package wx

PreStatusBar

Function in package wx

PreStyledTextCtrl

Function in module wx.stc

PreTextCtrl

Function in package wx

PreToggleButton

Function in package wx

PreToolBar

Function in package wx

PreTreeCtrl

Function in package wx

PreTreeListCtrl

Function in module wx.gizmos

PrevControlId

Method in class wx.Window

Preview

Method in class wx.lib.printout.PrintGrid

Preview

Method in class wx.lib.printout.PrintTable

PreviewCanvas

Class in package wx

PreviewControlBar

Class in package wx

PreviewFile

Method in class wx.html.HtmlEasyPrinting

PreviewFrame

Class in package wx

PreviewText

Method in class wx.html.HtmlEasyPrinting

PreVListBox

Function in package wx

PreVScrolledWindow

Function in package wx

PreWebKitCtrl

Function in module wx.webkit

PreWindow

Function in package wx

PreWizard

Function in module wx.wizard

PreWizardPageSimple

Function in module wx.wizard

Print

Method in class wx.PrintPreview

Print

Method in class wx.Printer

Print

Method in class wx.lib.printout.PrintGrid

Print

Method in class wx.lib.printout.PrintTable

PrintBase

Class in module wx.lib.printout

PrintData

Class in package wx

PrintDialog

Class in package wx

PrintDialog

Method in class wx.Printer

PrintDialogData

Class in package wx

Printer

Class in package wx

Printer_GetLastError

Function in package wx

PrinterDC

Class in package wx

PrintFile

Method in class wx.html.HtmlEasyPrinting

PrintFooter

Method in class wx.lib.printout.PrintTableDraw

PrintGrid

Class in module wx.lib.printout

PrintHeader

Method in class wx.lib.printout.PrintTableDraw

PrintLabel

Method in class wx.lib.printout.PrintTableDraw

Printout

Class in package wx

Printout

Method in class wx.lib.plot.PlotCanvas

printout

Module in package wx.lib

PrintPreview

Class in package wx

PrintPreview

Method in class wx.lib.plot.PlotCanvas

PrintRow

Method in class wx.lib.printout.PrintTableDraw

PrintTable

Class in module wx.lib.printout

PrintTableDraw

Class in module wx.lib.printout

PrintText

Method in class wx.html.HtmlEasyPrinting

Process

Class in package wx

Process_Exists

Function in package wx

Process_Kill

Function in package wx

Process_Open

Function in package wx

ProcessClick

Method in class wx.lib.calendar.Calendar

ProcessCommand

Method in class wx.Frame

ProcessEvent

Method in class wx.EvtHandler

ProcessEvent

Class in package wx

ProcessEvent

Method in class wx.lib.docview.DocChildFrame

ProcessEvent

Method in class wx.lib.docview.DocMDIChildFrame

ProcessEvent

Method in class wx.lib.docview.DocMDIParentFrame

ProcessEvent

Method in class wx.lib.docview.DocManager

ProcessEvent

Method in class wx.lib.docview.DocParentFrame

ProcessEvent

Method in class wx.lib.docview.Document

ProcessEvent

Method in class wx.lib.docview.View

ProcessEvent

Method in class wx.lib.pydocview.DocApp

ProcessEvent

Method in class wx.lib.pydocview.DocMDIChildFrame

ProcessEvent

Method in class wx.lib.pydocview.DocMDIParentFrame

ProcessEvent

Method in class wx.lib.pydocview.DocMDIParentFrameMixIn

ProcessEvent

Method in class wx.lib.pydocview.DocOptionsService

ProcessEvent

Method in class wx.lib.pydocview.DocSDIFrame

ProcessEvent

Method in class wx.lib.pydocview.DocService

ProcessEvent

Method in class wx.lib.pydocview.DocTabbedChildFrame

ProcessEvent

Method in class wx.lib.pydocview.DocTabbedParentFrame

ProcessEvent

Method in class wx.lib.pydocview.FilePropertiesService

ProcessEvent

Method in class wx.lib.pydocview.WindowMenuService

ProcessEventBeforeWindows

Method in class wx.lib.pydocview.DocApp

ProcessEventBeforeWindows

Method in class wx.lib.pydocview.DocService

ProcessIdle

Method in class wx.PyApp

processLine

Method in class wx.py.shell.Shell

ProcessPendingEvents

Method in class wx.EvtHandler

ProcessPendingEvents

Method in class wx.PyApp

ProcessTableMessage

Method in class wx.grid.Grid

ProcessUpdateUIEvent

Method in class wx.lib.docview.DocChildFrame

ProcessUpdateUIEvent

Method in class wx.lib.docview.DocMDIParentFrame

ProcessUpdateUIEvent

Method in class wx.lib.docview.DocManager

ProcessUpdateUIEvent

Method in class wx.lib.docview.DocParentFrame

ProcessUpdateUIEvent

Method in class wx.lib.docview.View

ProcessUpdateUIEvent

Method in class wx.lib.pydocview.DocApp

ProcessUpdateUIEvent

Method in class wx.lib.pydocview.DocMDIParentFrame

ProcessUpdateUIEvent

Method in class wx.lib.pydocview.DocMDIParentFrameMixIn

ProcessUpdateUIEvent

Method in class wx.lib.pydocview.DocSDIFrame

ProcessUpdateUIEvent

Method in class wx.lib.pydocview.DocService

ProcessUpdateUIEvent

Method in class wx.lib.pydocview.DocTabbedParentFrame

ProcessUpdateUIEvent

Method in class wx.lib.pydocview.FilePropertiesService

ProcessUpdateUIEvent

Method in class wx.lib.pydocview.WindowMenuService

ProcessUpdateUIEventBeforeWindows

Method in class wx.lib.pydocview.DocApp

ProcessUpdateUIEventBeforeWindows

Method in class wx.lib.pydocview.DocService

ProgressDialog

Class in package wx

Prompt

Method in class wx.lib.pyshell.PyShellWindow

prompt

Method in class wx.py.shell.Shell

PropagateOnce

Class in package wx

propagating_params

Variable in class wx.lib.masked.maskededit.Field

PropagationDisabler

Class in package wx

PROPERTIES_ID

Variable in class wx.lib.pydocview.FilePropertiesService

propname

Variable in class wx.lib.masked.ipaddrctrl.IpAddrCtrlAccessorsMixin

propname

Variable in class wx.lib.masked.ipaddrctrl.IpAddrCtrlAccessorsMixin

propname

Variable in class wx.lib.masked.maskededit.MaskedEditAccessorsMixin

propname

Variable in class wx.lib.masked.maskededit.MaskedEditAccessorsMixin

propname

Variable in class wx.lib.masked.maskededit.MaskedEditAccessorsMixin

propname

Variable in class wx.lib.masked.maskededit.MaskedEditAccessorsMixin

propname

Variable in class wx.lib.masked.maskededit.MaskedEditAccessorsMixin

propname

Variable in class wx.lib.masked.numctrl.NumCtrlAccessorsMixin

propname

Variable in class wx.lib.masked.numctrl.NumCtrlAccessorsMixin

propname

Variable in class wx.lib.masked.timectrl.TimeCtrlAccessorsMixin

PrtCalDraw

Class in module wx.lib.calendar

PS1

Variable in class wx.lib.shell.PyShellInput

PS2

Variable in class wx.lib.shell.PyShellInput

pseudo

Module in package wx.py

PseudoFile

Class in module wx.py.pseudo

PseudoFileErr

Class in module wx.py.pseudo

PseudoFileIn

Class in module wx.py.pseudo

PseudoFileOut

Class in module wx.py.pseudo

PseudoKeyword

Class in module wx.py.pseudo

PseudoMetaFile

Class in package wx.lib.ogl

PST

Variable in class wx.DateTime

PST

Variable in class wx.DateTime

Publisher

Variable in module wx.lib.pubsub

pubsub

Module in package wx.lib

push

Method in class wx.py.crust.Display

push

Method in class wx.py.crust.SessionListing

push

Method in class wx.py.filling.FillingText

push

Method in class wx.py.filling.FillingTree

push

Method in class wx.py.interpreter.Interpreter

push

Method in class wx.py.shell.Shell

PushEventHandler

Method in class wx.Window

PushLine

Method in class wx.lib.pyshell.PyShellWindow

PushProvider

Method in class wx.ArtProvider

PushStatusText

Method in class wx.Frame

PushStatusText

Method in class wx.StatusBar

PushTagHandler

Method in class wx.html.HtmlParser

PutInBackground

Method in class wx.lib.floatcanvas.FloatCanvas.DrawObject

PutInForeground

Method in class wx.lib.floatcanvas.FloatCanvas.DrawObject

py

Package in package wx

PyAlaCarte

Module in package wx.py

PyAlaMode

Module in package wx.py

PyAlaModeTest

Module in package wx.py

PyApp

Class in package wx

PyApp_GetComCtl32Version

Function in package wx

PyApp_GetComCtl32Version

Function in package wx

PyApp_GetMacAboutMenuItemId

Function in package wx

PyApp_GetMacAboutMenuItemId

Function in package wx

PyApp_GetMacExitMenuItemId

Function in package wx

PyApp_GetMacExitMenuItemId

Function in package wx

PyApp_GetMacHelpMenuTitleName

Function in package wx

PyApp_GetMacHelpMenuTitleName

Function in package wx

PyApp_GetMacPreferencesMenuItemId

Function in package wx

PyApp_GetMacPreferencesMenuItemId

Function in package wx

PyApp_GetMacSupportPCMenuShortcuts

Function in package wx

PyApp_GetMacSupportPCMenuShortcuts

Function in package wx

PyApp_IsMainLoopRunning

Function in package wx

PyApp_SetMacAboutMenuItemId

Function in package wx

PyApp_SetMacAboutMenuItemId

Function in package wx

PyApp_SetMacExitMenuItemId

Function in package wx

PyApp_SetMacExitMenuItemId

Function in package wx

PyApp_SetMacHelpMenuTitleName

Function in package wx

PyApp_SetMacHelpMenuTitleName

Function in package wx

PyApp_SetMacPreferencesMenuItemId

Function in package wx

PyApp_SetMacPreferencesMenuItemId

Function in package wx

PyApp_SetMacSupportPCMenuShortcuts

Function in package wx

PyApp_SetMacSupportPCMenuShortcuts

Function in package wx

PyAssertionError

Class in package wx

PyBitmapDataObject

Class in package wx

PyClickableHtmlWindow

Class in module wx.lib.ClickableHtmlWindow

pycolourbox

Module in package wx.lib.colourchooser

PyColourBox

Class in module wx.lib.colourchooser.pycolourbox

pycolourchooser

Module in package wx.lib.colourchooser

PyColourChooser

Class in module wx.lib.colourchooser.pycolourchooser

pycolourslider

Module in package wx.lib.colourchooser

PyColourSlider

Class in module wx.lib.colourchooser.pycolourslider

PyCommandEvent

Class in package wx

PyControl

Class in package wx

PyCrust

Module in package wx.py

PyDataObjectSimple

Class in package wx

PyDeadObjectError

Class in package wx

pydocview

Module in package wx.lib

PyEvent

Class in package wx

PyEventBinder

Class in package wx

PyFilling

Module in package wx.py

PyFlexGridSizer

Class in module wx.lib.grids

PyGetDate

Method in class wx.calendar.CalendarCtrl

PyGetDate

Method in class wx.calendar.CalendarEvent

PyGetLowerDateLimit

Method in class wx.calendar.CalendarCtrl

PyGetUpperDateLimit

Method in class wx.calendar.CalendarCtrl

PyGridCellAttrProvider

Class in module wx.grid

PyGridCellEditor

Class in module wx.grid

PyGridCellRenderer

Class in module wx.grid

PyGridSizer

Class in module wx.lib.grids

PyGridTableBase

Class in module wx.grid

PyInformationalMessagesFrame

Class in module wx.lib.infoframe

PyLog

Class in package wx

PyNoAppError

Class in package wx

PyOnDemandOutputWindow

Class in package wx

pypalette

Module in package wx.lib.colourchooser

PyPalette

Class in module wx.lib.colourchooser.pypalette

PyPanel

Class in package wx

PyPreviewControlBar

Class in package wx

PyPreviewFrame

Class in package wx

PyPrintPreview

Class in package wx

PyScrolledWindow

Class in package wx

PySetDate

Method in class wx.calendar.CalendarCtrl

PySetDate

Method in class wx.calendar.CalendarEvent

PySetDateRange

Method in class wx.calendar.CalendarCtrl

PySetLowerDateLimit

Method in class wx.calendar.CalendarCtrl

PySetUpperDateLimit

Method in class wx.calendar.CalendarCtrl

pyshell

Module in package wx.lib

PyShell

Class in module wx.lib.shell

PyShell

Module in package wx.py

PyShellInput

Class in module wx.lib.shell

PyShellOutput

Class in module wx.lib.shell

PyShellWindow

Class in module wx.lib.pyshell

PySimpleApp

Class in package wx

PySizer

Class in package wx

PyTextDataObject

Class in package wx

PyTimer

Class in package wx

PyTipProvider

Class in package wx

PyUnbornObjectError

Class in package wx

PyValidator

Class in package wx

PyWidgetTester

Class in package wx

PyWindow

Class in package wx

PyWizardPage

Class in module wx.wizard

PyWrap

Module in package wx.py

Quantize

Class in package wx

Quantize

Method in class wx.Quantize

Quantize_Quantize

Function in package wx

QueryLayoutInfoEvent

Class in package wx

QueryNewPaletteEvent

Class in package wx

quit

Method in class wx.py.shell.Shell

RadioBox

Class in package wx

RadioBox_GetClassDefaultAttributes

Function in package wx

RadioButton

Class in package wx

RadioButton_GetClassDefaultAttributes

Function in package wx

Raise

Method in class wx.Window

raw_input

Method in class wx.py.shell.Shell

rcsizer

Module in package wx.lib

Read

Method in class wx.ConfigBase

read

Method in class wx.InputStream

read

Method in class wx.py.document.Document

ReadBool

Method in class wx.ConfigBase

ReadCustomization

Method in class wx.html.HtmlHelpController

ReadCustomization

Method in class wx.html.HtmlHelpFrame

ReadCustomization

Method in class wx.html.HtmlWindow

ReadFloat

Method in class wx.ConfigBase

ReadInt

Method in class wx.ConfigBase

readline

Method in class wx.InputStream

readline

Method in class wx.py.pseudo.PseudoFile

readline

Method in class wx.py.shell.Shell

readlines

Method in class wx.InputStream

readlines

Method in class wx.py.shell.Shell

ReadMailcap

Method in class wx.MimeTypesManager

ReadMimeTypes

Method in class wx.MimeTypesManager

Realize

Method in class wx.StdDialogButtonSizer

Realize

Method in class wx.ToolBarBase

RealPoint

Class in package wx

RecalcSizes

Method in class wx.BookCtrlSizer

RecalcSizes

Method in class wx.NotebookSizer

RecalcSizes

Method in class wx.Sizer

RecalcSizes

Method in class wx.lib.grids.PyFlexGridSizer

RecalcSizes

Method in class wx.lib.grids.PyGridSizer

RecalcSizes

Method in class wx.lib.rcsizer.RowColSizer

Recentre

Method in class wx.lib.ogl.Shape

RecentreAll

Method in class wx.lib.ogl.Diagram

Recompute

Method in class wx.lib.ogl.CompositeShape

Recompute

Method in class wx.lib.ogl.Shape

reconfigure

Method in class wx.lib.wxPlotCanvas.PlotCanvas

ReCreateTree

Method in class wx.GenericDirCtrl

Rect

Class in package wx

Rect

Class in module wx.lib.mvctree

Rectangle

Class in module wx.lib.floatcanvas.FloatCanvas

RectangleShape

Class in package wx.lib.ogl

RectEllipse

Class in module wx.lib.floatcanvas.FloatCanvas

RectPP

Function in package wx

RectPS

Function in package wx

RectS

Function in package wx

Red

Method in class wx.Colour

Redirect

Method in class wx.Process

redirectStderr

Method in class wx.py.shell.Shell

redirectStdin

Method in class wx.py.shell.Shell

RedirectStdio

Method in class wx.App

redirectStdout

Method in class wx.py.shell.Shell

RedisplayFoldPanelItems

Method in class wx.lib.foldpanelbar.FoldPanelBar

Redo

Method in class wx.ComboBox

Redo

Method in class wx.TextCtrl

Redo

Method in class wx.lib.docview.CommandProcessor

Redo

Method in class wx.stc.StyledTextCtrl

ReDraw

Method in class wx.lib.colourchooser.canvas.Canvas

Redraw

Method in class wx.lib.ogl.Diagram

Redraw

Method in class wx.lib.ogl.ShapeCanvas

Redraw

Method in class wx.lib.plot.PlotCanvas

redraw

Method in class wx.lib.wxPlotCanvas.PlotCanvas

RedrawIconBitmap

Method in class wx.lib.foldpanelbar.CaptionBar

RedrawImage

Method in class wx.DragImage

refresh

Method in class wx.DragImage in class wx.VideoMode

Refresh

Method in class wx.Window

Refresh

Method in class wx.lib.colourchooser.canvas.Canvas

Refresh

Method in class wx.lib.masked.combobox.BaseMaskedComboBox

Refresh

Method in class wx.lib.masked.textctrl.BaseMaskedTextCtrl

Refresh

Method in class wx.lib.mvctree.MVCTree

Refresh

Method in class wx.py.crust.Display

RefreshAll

Method in class wx.HtmlListBox

RefreshAll

Method in class wx.VScrolledWindow

RefreshItem

Method in class wx.ListCtrl

RefreshItems

Method in class wx.ListCtrl

RefreshLine

Method in class wx.VScrolledWindow

RefreshLines

Method in class wx.VScrolledWindow

RefreshPanelsFrom

Method in class wx.lib.foldpanelbar.FoldPanelBar

RefreshRect

Method in class wx.Window

Region

Class in package wx

RegionFromBitmap

Function in package wx

RegionFromBitmapColour

Function in package wx

RegionFromPoints

Function in package wx

RegionIterator

Class in package wx

Register

Method in class wx.lib.evtmgr.EventManager

RegisterDataType

Method in class wx.grid.Grid

RegisterHotKey

Method in class wx.Window

RegisterId

Function in package wx

RegisterImage

Method in class wx.stc.StyledTextCtrl

reinitialize_command

Method in class distutils.cmd.Command

ReleaseCapture

Method in class wx.Joystick

ReleaseDocument

Method in class wx.stc.StyledTextCtrl

ReleaseMouse

Method in class wx.Window

Reload

Method in class wx.webkit.WebKitCtrl

RemotelyScrolledTreeCtrl

Class in module wx.gizmos

Remove

Method in class wx.ComboBox

Remove

Method in class wx.ImageList

Remove

Method in class wx.Menu

Remove

Method in class wx.MenuBar

Remove

Method in class wx.Sizer

Remove

Method in class wx.TextCtrl

Remove

Method in class wx.lib.mvctree.MVCTreeNode

RemoveAll

Method in class wx.ImageList

RemoveAllShapes

Method in class wx.lib.ogl.Diagram

RemoveBrush

Method in class wx.BrushList

RemoveChild

Method in class wx.Window

RemoveChild

Method in class wx.lib.ogl.CompositeShape

RemoveChild

Method in class wx.xrc.XmlNode

RemoveChildFromConstraints

Method in class wx.lib.ogl.CompositeShape

RemoveColumn

Method in class wx.gizmos.TreeListCtrl

RemoveCustomEventHandler

Method in class wx.lib.pydocview.FilePropertiesService

RemoveDocument

Method in class wx.lib.docview.DocManager

RemoveEditor

Method in class wx.lib.mvctree.MVCTree

RemoveEventHandler

Method in class wx.Window

RemoveFile

Method in class wx.MemoryFSHandler

RemoveFileFromHistory

Method in class wx.FileHistory

RemoveFileFromHistory

Method in class wx.lib.docview.DocManager

RemoveFont

Method in class wx.FontList

RemoveFromCanvas

Method in class wx.lib.ogl.Shape

RemoveFromSelection

Method in class wx.lib.mvctree.MVCTree

RemoveGesture

Method in class wx.lib.gestures.MouseGestures

RemoveGrowableCol

Method in class wx.FlexGridSizer

RemoveGrowableRow

Method in class wx.FlexGridSizer

RemoveHandler

Method in class wx.Image

RemoveHelp

Method in class wx.HelpProvider

RemoveIcon

Method in class wx.TaskBarIcon

RemoveItem

Method in class wx.Menu

RemoveLine

Method in class wx.lib.ogl.Shape

RemoveMenu

Method in class wx.FileHistory

RemoveNode

Method in class wx.lib.mvctree.BasicTreeModel

RemoveNode

Method in class wx.lib.mvctree.TreeModel

RemoveNotebookPage

Method in class wx.lib.pydocview.DocTabbedParentFrame

RemoveObject

Method in class wx.lib.floatcanvas.FloatCanvas.FloatCanvas

RemoveObjects

Method in class wx.lib.floatcanvas.FloatCanvas.FloatCanvas

RemovePage

Method in class wx.BookCtrlBase

RemovePen

Method in class wx.PenList

RemovePos

Method in class wx.Sizer

RemoveProvider

Method in class wx.ArtProvider

RemoveShape

Method in class wx.lib.ogl.Diagram

RemoveShape

Method in class wx.lib.ogl.ShapeCanvas

RemoveSizer

Method in class wx.Sizer

RemoveTool

Method in class wx.ToolBarBase

RemoveTraceMask

Method in class wx.Log

RemoveView

Method in class wx.lib.docview.Document

RemoveWindow

Method in class wx.Sizer

RenameEntry

Method in class wx.ConfigBase

RenameGroup

Method in class wx.ConfigBase

Render

Method in class wx.html.HtmlDCRenderer

RenderPage

Method in class wx.PrintPreview

RenderToBitmap

Function in module wx.lib.fancytext

RenderToDC

Function in module wx.lib.fancytext

Reparent

Method in class wx.Window

Replace

Method in class wx.ComboBox

Replace

Method in class wx.Image

Replace

Method in class wx.ImageList

Replace

Method in class wx.MenuBar

Replace

Method in class wx.TextCtrl

replaceFromHistory

Method in class wx.py.shell.Shell

ReplaceSelection

Method in class wx.stc.StyledTextCtrl

ReplaceTarget

Method in class wx.stc.StyledTextCtrl

ReplaceTargetRE

Method in class wx.stc.StyledTextCtrl

ReplaceWindow

Method in class wx.SplitterWindow

ReportError

Method in class wx.Printer

ReportErrors

Method in class wx.lib.hyperlink.HyperLinkCtrl

Reposition

Method in class wx.lib.foldpanelbar.FoldPanelItem

RepositionCollapsedToBottom

Method in class wx.lib.foldpanelbar.FoldPanelBar

RequestMore

Method in class wx.IdleEvent

RequestUserAttention

Method in class wx.TopLevelWindow

Rescale

Method in class wx.Image

Reset

Method in class wx.RegionIterator

Reset

Method in class wx.grid.GridCellEditor

reset

Method in class wx.lib.mixins.rubberband.RubberBand

Reset

Method in class wx.lib.plot.PlotCanvas

Reset

Method in class wx.lib.sheet.CCellEditor

ResetAttr

Method in class wx.calendar.CalendarCtrl

ResetBoundingBox

Method in class wx.DC

ResetControlPoints

Method in class wx.lib.ogl.DividedShape

ResetControlPoints

Method in class wx.lib.ogl.DivisionShape

ResetControlPoints

Method in class wx.lib.ogl.LineShape

ResetControlPoints

Method in class wx.lib.ogl.PolygonShape

ResetControlPoints

Method in class wx.lib.ogl.Shape

ResetDefaults

Method in class wx.lib.foldpanelbar.CaptionBarStyle

resetDefaults

Method in class wx.lib.plot.TestFrame

ResetDisplay

Method in class wx.lib.calendar.CalenDlg

ResetFiles

Method in class wx.lib.imagebrowser.ImageDialog

ResetIfWin

Method in class wx.IndividualLayoutConstraint

ResetMandatoryControlPoints

Method in class wx.lib.ogl.DividedShape

ResetMandatoryControlPoints

Method in class wx.lib.ogl.DivisionShape

ResetMandatoryControlPoints

Method in class wx.lib.ogl.Shape

ResetMode

Method in class wx.Display

ResetOwnerDrawn

Method in class wx.MenuItem

ResetTime

Method in class wx.DateTime

ResetUpdateTime

Method in class wx.UpdateUIEvent

Resize

Method in class wx.Image

ResizeAdjoining

Method in class wx.lib.ogl.DivisionShape

resizeColumn

Method in class wx.lib.mixins.listctrl.ListCtrlAutoWidthMixin

ResizeItem

Method in class wx.lib.foldpanelbar.FoldWindowItem

resizeLastColumn

Method in class wx.lib.mixins.listctrl.ListCtrlAutoWidthMixin

ResizePanel

Method in class wx.lib.foldpanelbar.FoldPanelItem

Resources

Module in package wx.lib.floatcanvas

Rest

Method in class wx.lib.throbber.Throbber

RestOfLine

Function in module wx.lib.editor.selection

Restore

Method in class wx.MDIChildFrame

Restore

Method in class wx.TopLevelWindow

RestoreStdio

Method in class wx.App

Resume

Method in class wx.Log

Resume

Method in class wx.ProgressDialog

Resume

Method in class wx.StopWatch

ResumePropagation

Method in class wx.Event

returnedString

Function in module wx.lib.dialogs

Reverse

Method in class wx.lib.throbber.Throbber

Revert

Method in class wx.lib.docview.Document

revision

Variable in class wx.py.crust.Crust

revision

Variable in class wx.py.crust.CrustFrame

revision

Variable in class wx.py.editwindow.EditWindow

revision

Variable in class wx.py.editwindow.EditWindow

revision

Variable in class wx.py.editwindow.EditWindow

revision

Variable in class wx.py.filling.Filling

revision

Variable in class wx.py.filling.FillingFrame

revision

Variable in class wx.py.filling.FillingText

revision

Variable in class wx.py.filling.FillingTree

revision

Variable in class wx.py.frame.Frame

revision

Variable in class wx.py.frame.Frame

revision

Variable in class wx.py.frame.Frame

revision

Variable in class wx.py.frame.Frame

revision

Variable in class wx.py.interpreter.Interpreter

revision

Variable in class wx.py.interpreter.Interpreter

revision

Variable in class wx.py.shell.Shell

revision

Variable in class wx.py.shell.ShellFacade

revision

Variable in class wx.py.shell.ShellFrame

rexp1

Variable in class wx.lib.layoutf.Layoutf

rexp2

Variable in class wx.lib.layoutf.Layoutf

right

Variable in class wx.lib.layoutf.Layoutf in class wx.LayoutConstraints

right

Variable in class wx.lib.layoutf.Layoutf in class wx.LayoutConstraints in class wx.Rect

rightalign

Module in package wx.lib

RightDClick

Method in class wx.MouseEvent

RightDoubleCLickEvent

Method in class wx.lib.floatcanvas.FloatCanvas.FloatCanvas

RightDown

Method in class wx.MouseEvent

RightDownEvent

Method in class wx.lib.floatcanvas.FloatCanvas.FloatCanvas

RightIsDown

Method in class wx.MouseEvent

RightOf

Method in class wx.IndividualLayoutConstraint

RightOfScreen

Method in class wx.lib.editor.editor.Editor

RightTextCtrl

Class in module wx.lib.rightalign

RightUp

Method in class wx.MouseEvent

RightUpEvent

Method in class wx.lib.floatcanvas.FloatCanvas.FloatCanvas

Rotate

Method in class wx.Image

Rotate

Method in class wx.lib.ogl.DrawOp

Rotate

Method in class wx.lib.ogl.DrawnShape

Rotate

Method in class wx.lib.ogl.OpDraw

Rotate

Method in class wx.lib.ogl.OpPolyDraw

Rotate

Method in class wx.lib.ogl.PolygonShape

Rotate

Method in class wx.lib.ogl.PseudoMetaFile

Rotate

Method in class wx.lib.ogl.Shape

Rotate

Method in class wx.lib.throbber.Throbber

Rotate90

Method in class wx.Image

RoughlyEqual

Function in package wx.lib.ogl

row

Function in package wx.lib.ogl in class wx.GBPosition

Row

Variable in class wx.grid.GridCellAttr

row_h

Variable in class wx.lib.rcsizer.RowColSizer

RowColSizer

Class in module wx.lib.rcsizer

RowDragWindow

Class in module wx.lib.gridmovers

rowspan

Class in module wx.lib.gridmovers in class wx.GBSpan

rtrimTerminus

Function in module wx.py.introspect

rubberband

Module in package wx.lib.mixins

RubberBand

Class in module wx.lib.mixins.rubberband

run

Method in class distutils.cmd.Command

run

Method in class distutils.command.clean.clean

run

Method in class distutils.command.install.install

run

Method in class distutils.command.install_data.install_data

run

Method in class distutils.command.install_headers.install_headers

Run

Method in class wx.EventLoop

run

Method in class wx.py.shell.Shell

run_command

Method in class distutils.cmd.Command

runcode

Method in class code.InteractiveInterpreter

runfile

Method in class wx.py.shell.Shell

Running

Method in class wx.lib.throbber.Throbber

runsource

Method in class code.InteractiveInterpreter

runsource

Method in class wx.lib.pyshell.PyShellWindow

runsource

Method in class wx.py.interpreter.Interpreter

RuntimeError

Class in module exceptions

RunWizard

Method in class wx.wizard.Wizard

Russia

Variable in class wx.DateTime

Russia

Variable in class wx.DateTime

safeRef

Function in module wx.py.dispatcher

SafeShowMessage

Function in package wx

SafeYield

Function in package wx

SameAs

Method in class wx.IndividualLayoutConstraint

SashEvent

Class in package wx

SashHitTest

Method in class wx.SashWindow

SashHitTest

Method in class wx.SplitterWindow

SashLayoutWindow

Class in package wx

SashWindow

Class in package wx

Sat

Variable in class wx.DateTime

Sat

Variable in class wx.DateTime

SatisfyConstraint

Method in class wx.IndividualLayoutConstraint

SatisfyConstraints

Method in class wx.LayoutConstraints

Save

Method in class wx.FileHistory

Save

Method in class wx.lib.docview.Document

Save

Method in class wx.lib.pydocview.ChildDocument

save

Method in class wx.py.buffer.Buffer

Save

Method in class wx.xrc.XmlDocument

SAVEALL_ID

Variable in module wx.lib.pydocview

SaveAs

Method in class wx.lib.docview.Document

SaveAs

Method in class wx.lib.pydocview.ChildDocument

saveAs

Method in class wx.py.buffer.Buffer

SaveBackground

Method in class wx.animate.AnimationPlayer

SaveEditControlValue

Method in class wx.grid.Grid

SaveEmbeddedWindowSizes

Method in class wx.lib.pydocview.DocMDIParentFrameMixIn

SaveFile

Method in class wx.Bitmap

SaveFile

Method in class wx.Image

SaveFile

Method in class wx.TextCtrl

SaveFile

Method in class wx.lib.plot.PlotCanvas

SaveFile

Method in class wx.stc.StyledTextCtrl

saveFileDialog

Function in module wx.lib.dialogs

SaveFileSelector

Function in package wx

SaveMDIDocumentFrameMaximizedState

Method in class wx.lib.pydocview.DocApp

SaveMimeFile

Method in class wx.Image

SaveObject

Method in class wx.lib.docview.Document

saveSingle

Function in module wx.py.editor

SaveToStream

Method in class wx.xrc.XmlDocument

Scale

Method in class wx.Image

Scale

Method in class wx.lib.ogl.DrawOp

Scale

Method in class wx.lib.ogl.DrawnShape

Scale

Method in class wx.lib.ogl.OpDraw

Scale

Method in class wx.lib.ogl.OpPolyDraw

Scale

Method in class wx.lib.ogl.OpSetClipping

Scale

Method in class wx.lib.ogl.PseudoMetaFile

scaleAndShift

Method in class wx.lib.plot.PlotGraphics

scaleAndShift

Method in class wx.lib.plot.PolyPoints

scaleAndShift

Method in class wx.lib.wxPlotCanvas.PlotGraphics

scaleAndShift

Method in class wx.lib.wxPlotCanvas.PolyPoints

ScaledText

Class in module wx.lib.floatcanvas.FloatCanvas

ScalePixelToWorld

Method in class wx.lib.floatcanvas.FloatCanvas.FloatCanvas

ScaleTo

Method in class wx.lib.ogl.PseudoMetaFile

ScaleWorldToPixel

Method in class wx.lib.floatcanvas.FloatCanvas.FloatCanvas

ScreenDC

Class in package wx

ScreenToClient

Method in class wx.Window

ScreenToClientXY

Method in class wx.Window

Scroll

Method in class wx.ScrolledWindow

ScrollBar

Class in package wx

ScrollBar_GetClassDefaultAttributes

Function in package wx

ScrolledMessageDialog

Class in module wx.lib.dialogs

scrolledMessageDialog

Function in module wx.lib.dialogs

scrolledpanel

Module in package wx.lib

ScrolledPanel

Class in module wx.lib.scrolledpanel

ScrolledWindow

Class in package wx

ScrolledWindow_GetClassDefaultAttributes

Function in package wx

Scroller

Class in module wx.lib.editor.editor

ScrollEvent

Class in package wx

ScrollLines

Method in class wx.VScrolledWindow

ScrollLines

Method in class wx.Window

ScrollList

Method in class wx.ListCtrl

ScrollPages

Method in class wx.VScrolledWindow

ScrollPages

Method in class wx.Window

ScrollRight

Method in class wx.lib.plot.PlotCanvas

ScrollTo

Method in class wx.TreeCtrl

ScrollTo

Method in class wx.gizmos.TreeListCtrl

ScrollToAnchor

Method in class wx.html.HtmlWindow

ScrollToColumn

Method in class wx.stc.StyledTextCtrl

ScrollToLine

Method in class wx.VScrolledWindow

ScrollToLine

Method in class wx.gizmos.RemotelyScrolledTreeCtrl

ScrollToLine

Method in class wx.stc.StyledTextCtrl

ScrollUp

Method in class wx.lib.plot.PlotCanvas

ScrollWindow

Method in class wx.Window

ScrollWinEvent

Class in package wx

Search

Method in class wx.html.HtmlSearchStatus

SearchAnchor

Method in class wx.stc.StyledTextCtrl

SearchInTarget

Method in class wx.stc.StyledTextCtrl

SearchNext

Method in class wx.stc.StyledTextCtrl

SearchPrev

Method in class wx.stc.StyledTextCtrl

Second

Method in class wx.TimeSpan

SecondColourUsed

Method in class wx.lib.foldpanelbar.CaptionBarStyle

Seconds

Method in class wx.TimeSpan

seconds

Variable in module wx.lib.masked.maskededit

seek

Method in class wx.InputStream

Seek

Method in class wx.media.MediaCtrl

SeekI

Method in class wx.InputStream

SEL_FOC

Variable in module wx.lib.mixins.listctrl

Select

Method in class wx.ItemContainer

Select

Method in class wx.ListBox

Select

Method in class wx.ListCtrl

Select

Method in class wx.ListView

Select

Method in class wx.VListBox

Select

Method in class wx.lib.multisash.MultiClient

Select

Method in class wx.lib.ogl.LineShape

Select

Method in class wx.lib.ogl.Shape

select

Function in module wxversion

select_scheme

Method in class distutils.command.install.install

SelectAll

Method in class wx.ComboBox

SelectAll

Method in class wx.TextCtrl

SelectAll

Method in class wx.VListBox

SelectAll

Method in class wx.gizmos.TreeListCtrl

SelectAll

Method in class wx.grid.Grid

SelectAll

Method in class wx.html.HtmlWindow

SelectAll

Method in class wx.stc.StyledTextCtrl

selectBeforePopup

Function in module wx.lib.mixins.listctrl

SelectBlock

Method in class wx.grid.Grid

SelectCells

Variable in class wx.grid.Grid

SelectCells

Variable in class wx.grid.Grid

SelectCol

Method in class wx.grid.Grid

SelectColumns

Variable in class wx.grid.Grid

SelectColumns

Variable in class wx.grid.Grid

SelectDay

Method in class wx.lib.calendar.Calendar

SelectDocumentPath

Method in class wx.lib.docview.DocManager

SelectDocumentType

Method in class wx.lib.docview.DocManager

Selected

Method in class wx.lib.ogl.Shape

Selecting

Method in class wx.grid.GridEvent

Selecting

Method in class wx.grid.GridRangeSelectEvent

selection

Module in package wx.lib.editor

Selection

Function in module wx.lib.editor.selection

SelectionIsRectangle

Method in class wx.stc.StyledTextCtrl

SelectionToText

Method in class wx.html.HtmlWindow

SelectItem

Method in class wx.TreeCtrl

SelectItem

Method in class wx.gizmos.TreeListCtrl

SelectLine

Method in class wx.html.HtmlWindow

SelectNotify

Method in class wx.lib.editor.editor.Editor

SelectObject

Method in class wx.MemoryDC

SelectOff

Method in class wx.lib.editor.editor.Editor

SelectRange

Method in class wx.VListBox

SelectRow

Method in class wx.grid.Grid

SelectRows

Variable in class wx.grid.Grid

SelectRows

Variable in class wx.grid.Grid

SelectUpdate

Method in class wx.lib.editor.editor.Editor

SelectViewType

Method in class wx.lib.docview.DocManager

SelectWord

Method in class wx.html.HtmlWindow

send

Function in module wx.py.dispatcher

senders

Variable in module wx.py.dispatcher

SendIdleEvents

Method in class wx.PyApp

SendMsg

Method in class wx.stc.StyledTextCtrl

SendSizeEvent

Method in class wx.Dialog

SendSizeEvent

Method in class wx.Frame

Sep

Variable in class wx.DateTime

Sep

Variable in class wx.DateTime

SessionListing

Class in module wx.py.crust

Set

Method in class wx.AcceleratorEntry

Set

Method in class wx.Colour

Set

Method in class wx.ConfigBase

Set

Variable in class wx.DataObject

Set

Variable in class wx.DataObject

Set

Variable in class wx.DataObject

Set

Variable in class wx.DataObject

Set

Variable in class wx.DataObject

Set

Variable in class wx.DataObject

Set

Variable in class wx.DataObject

Set

Variable in class wx.DataObject

Set

Variable in class wx.DataObject

Set

Variable in class wx.DataObject

Set

Variable in class wx.DataObject

Set

Variable in class wx.DataObject

Set

Variable in class wx.DataObject

Set

Variable in class wx.DataObject

Set

Variable in class wx.DataObject

Set

Variable in class wx.DataObject

Set

Variable in class wx.DataObject

Set

Variable in class wx.DataObject

Set

Variable in class wx.DataObject

Set

Variable in class wx.DataObject

Set

Variable in class wx.DataObject

Set

Variable in class wx.DataObject

Set

Variable in class wx.DataObject

Set

Variable in class wx.DataObject

Set

Method in class wx.DateTime

Set

Method in class wx.Effects

Set

Method in class wx.FontMapper

Set

Method in class wx.GBPosition

Set

Method in class wx.GBSpan

Set

Method in class wx.HelpProvider

Set

Method in class wx.IndividualLayoutConstraint

Set

Method in class wx.ListBox

Set

Method in class wx.Point

Set

Method in class wx.Point2D

Set

Method in class wx.RealPoint

Set

Method in class wx.Rect

Set

Method in class wx.Size

Set

Method in class wx.grid.GridCellCoords

Set

Method in class wx.html.HtmlSelection

Set

Method in class wx.xrc.XmlResource

Set3StateValue

Method in class wx.CheckBox

set_undefined_options

Method in class distutils.cmd.Command

SetAboutDialog

Method in class wx.lib.pydocview.AboutService

SetAccel

Method in class wx.MenuItem

SetAcceleratorTable

Method in class wx.Window

SetActive

Method in class wx.EventLoop

SetActiveTarget

Method in class wx.Log

SetActualColor

Method in class wx.html.HtmlWinParser

SetAffirmativeButton

Method in class wx.StdDialogButtonSizer

SetAlign

Method in class wx.ListItem

SetAlign

Method in class wx.html.HtmlContainerCell

SetAlign

Method in class wx.html.HtmlWinParser

SetAlignHor

Method in class wx.html.HtmlContainerCell

SetAlignment

Method in class wx.QueryLayoutInfoEvent

SetAlignment

Method in class wx.SashLayoutWindow

SetAlignment

Method in class wx.TextAttr

SetAlignment

Method in class wx.gizmos.LEDNumberCtrl

SetAlignment

Method in class wx.gizmos.StaticPicture

SetAlignment

Method in class wx.gizmos.TreeListColumnInfo

SetAlignment

Method in class wx.grid.GridCellAttr

SetAlignmentOrientation

Method in class wx.lib.ogl.LineShape

SetAlignmentType

Method in class wx.lib.ogl.LineShape

SetAlignVer

Method in class wx.html.HtmlContainerCell

SetAllowNegative

Method in class wx.lib.masked.numctrl.NumCtrl

SetAllowNone

Method in class wx.lib.masked.numctrl.NumCtrl

SetAllowSymbols

Method in class wx.FontData

SetAllPages

Method in class wx.PrintDialogData

SetAlpha

Method in class wx.Image

SetAlphaBuffer

Method in class wx.Image

SetAlphaData

Method in class wx.Image

SetAltFuncs

Method in class wx.lib.editor.editor.Editor

SetAnchor

Method in class wx.stc.StyledTextCtrl

SetAnimation

Method in class wx.animate.AnimationPlayer

SetAppName

Method in class wx.ConfigBase

SetAppName

Method in class wx.PyApp

SetArgs

Method in class wx.FutureCall

SetAssertMode

Method in class wx.PyApp

SetAssumeChildren

Method in class wx.lib.mvctree.MVCTree

SetAttachmentFrom

Method in class wx.lib.ogl.LineShape

SetAttachmentMode

Method in class wx.lib.ogl.Shape

SetAttachments

Method in class wx.lib.ogl.LineShape

SetAttachmentSize

Method in class wx.lib.ogl.Shape

SetAttachmentTo

Method in class wx.lib.ogl.LineShape

SetAttr

Method in class wx.calendar.CalendarCtrl

SetAttr

Method in class wx.grid.Grid

SetAttr

Method in class wx.grid.GridCellAttrProvider

SetAttr

Method in class wx.grid.GridTableBase

SetAttributes

Method in class wx.lib.printout.PrintGrid

SetAttrProvider

Method in class wx.grid.GridTableBase

SetAuto

Method in class wx.lib.gestures.MouseGestures

SetAutoCompleteKeycodes

Method in class wx.lib.masked.maskededit.MaskedEditAccessorsMixin

SetAutoformat

Method in class wx.lib.masked.maskededit.MaskedEditAccessorsMixin

SetAutoLayout

Method in class wx.Window

SetAutoSelect

Method in class wx.lib.masked.maskededit.MaskedEditAccessorsMixin

SetAutoSize

Method in class wx.lib.masked.numctrl.NumCtrl

SetAutoSize

Method in class wx.lib.masked.numctrl.NumCtrlAccessorsMixin

SetAxisOrientation

Method in class wx.DC

SetBackground

Method in class wx.DC

SetBackgroundColor

Method in class wx.lib.floatcanvas.FloatCanvas.TextObjectMixin

SetBackgroundColour

Method in class wx.ListCtrl

SetBackgroundColour

Method in class wx.ListItem

SetBackgroundColour

Method in class wx.ListItemAttr

SetBackgroundColour

Method in class wx.MenuItem

SetBackgroundColour

Method in class wx.TextAttr

SetBackgroundColour

Method in class wx.Window

SetBackgroundColour

Method in class wx.calendar.CalendarDateAttr

SetBackgroundColour

Method in class wx.grid.GridCellAttr

SetBackgroundColour

Method in class wx.html.HtmlContainerCell

SetBackgroundColour

Method in class wx.lib.buttons.GenButton

SetBackgroundColour

Method in class wx.lib.filebrowsebutton.FileBrowseButton

SetBackgroundColour

Method in class wx.lib.mvctree.MVCTree

SetBackgroundColour

Method in class wx.lib.mvctree.Painter

SetBackgroundColour

Method in class wx.lib.ogl.PseudoMetaFile

SetBackgroundImage

Method in class wx.html.HtmlWindow

SetBackgroundMode

Method in class wx.DC

SetBackgroundMode

Method in class wx.lib.ogl.PseudoMetaFile

SetBackgroundStyle

Method in class wx.Window

SetBackingBitmap

Method in class wx.DragImage

SetBackSpaceUnIndents

Method in class wx.stc.StyledTextCtrl

SetBar

Method in class wx.lib.foldpanelbar.CaptionBarEvent

SetBaseColour

Method in class wx.lib.colourchooser.pycolourslider.PyColourSlider

SetBasePath

Method in class wx.html.HtmlBookRecord

SetBellOnError

Method in class wx.Validator

SetBestFittingSize

Method in class wx.Window

SetBestSize

Method in class wx.PyControl

SetBestSize

Method in class wx.PyPanel

SetBestSize

Method in class wx.PyScrolledWindow

SetBestSize

Method in class wx.PyWindow

SetBestSize

Method in class wx.lib.buttons.GenButton

SetBezelFace

Method in class wx.Gauge

SetBezelWidth

Method in class wx.lib.buttons.GenButton

SetBgColour

Method in class wx.html.HtmlRenderingState

SetBin

Method in class wx.PrintData

SetBitmap

Method in class wx.BitmapDataObject

SetBitmap

Method in class wx.MenuItem

SetBitmap

Method in class wx.SplashScreenWindow

SetBitmap

Method in class wx.StaticBitmap

SetBitmap

Method in class wx.gizmos.StaticPicture

SetBitmap

Method in class wx.lib.colourselect.ColourSelect

SetBitmap

Method in class wx.lib.ogl.BitmapShape

SetBitmap

Method in class wx.lib.statbmp.GenStaticBitmap

SetBitmapDisabled

Method in class wx.BitmapButton

SetBitmapDisabled

Method in class wx.lib.buttons.GenBitmapButton

SetBitmapFocus

Method in class wx.BitmapButton

SetBitmapFocus

Method in class wx.lib.buttons.GenBitmapButton

SetBitmapLabel

Method in class wx.BitmapButton

SetBitmapLabel

Method in class wx.lib.buttons.GenBitmapButton

SetBitmaps

Method in class wx.MenuItem

SetBitmapSelected

Method in class wx.BitmapButton

SetBitmapSelected

Method in class wx.lib.buttons.GenBitmapButton

SetBlinkTime

Method in class wx.Caret

SetBold

Method in class wx.lib.hyperlink.HyperLinkCtrl

SetBoldFont

Method in class wx.lib.foldpanelbar.CaptionBar

SetBorder

Method in class wx.SizerItem

SetBorder

Method in class wx.calendar.CalendarDateAttr

SetBorder

Method in class wx.html.HtmlContainerCell

SetBorder

Method in class wx.wizard.Wizard

SetBorderColour

Method in class wx.calendar.CalendarDateAttr

SetBorders

Method in class wx.html.HtmlWindow

SetBorderSize

Method in class wx.SplitterWindow

SetBottom

Method in class wx.Rect

SetBottomRight

Method in class wx.Rect

SetBottomSide

Method in class wx.lib.ogl.DivisionShape

SetBoundingRect

Method in class wx.TipWindow

SetBounds

Method in class wx.lib.intctrl.IntCtrl

SetBounds

Method in class wx.lib.masked.numctrl.NumCtrl

SetBounds

Method in class wx.lib.masked.timectrl.TimeCtrl

SetBrush

Method in class wx.DC

SetBrush

Method in class wx.lib.floatcanvas.FloatCanvas.DrawObject

SetBrush

Method in class wx.lib.ogl.PseudoMetaFile

SetBrush

Method in class wx.lib.ogl.Shape

SetBufferedDraw

Method in class wx.stc.StyledTextCtrl

setBuiltinKeywords

Method in class wx.py.shell.Shell

SetBusType

Method in class wx.lib.calendar.Calendar

SetButtonChange

Method in class wx.JoystickEvent

SetButtonObj

Method in class wx.lib.buttons.GenButtonEvent

SetButtonsImageList

Method in class wx.gizmos.TreeListCtrl

SetButtonState

Method in class wx.JoystickEvent

SetCal

Method in class wx.lib.calendar.CalDraw

SetCancelButton

Method in class wx.StdDialogButtonSizer

SetCanLiveOnPagebreak

Method in class wx.html.HtmlCell

SetCanvas

Method in class wx.PrintPreview

SetCanvas

Method in class wx.lib.ogl.Diagram

SetCanvas

Method in class wx.lib.ogl.Shape

SetCanVeto

Method in class wx.CloseEvent

SetCap

Method in class wx.Pen

SetCaptionColour

Method in class wx.lib.foldpanelbar.CaptionBarStyle

SetCaptionFont

Method in class wx.lib.foldpanelbar.CaptionBarStyle

SetCaptionStyle

Method in class wx.lib.foldpanelbar.CaptionBar

SetCaptionStyle

Method in class wx.lib.foldpanelbar.CaptionBarStyle

SetCapture

Method in class wx.Joystick

SetCaret

Method in class wx.Window

SetCaretForeground

Method in class wx.stc.StyledTextCtrl

SetCaretLineBack

Method in class wx.stc.StyledTextCtrl

SetCaretLineVisible

Method in class wx.stc.StyledTextCtrl

SetCaretPeriod

Method in class wx.stc.StyledTextCtrl

SetCaretWidth

Method in class wx.stc.StyledTextCtrl

SetCellAlignment

Method in class wx.grid.Grid

SetCellAttr

Method in class wx.grid.GridCellEditor

SetCellBackgroundColour

Method in class wx.grid.Grid

SetCellColour

Method in class wx.lib.printout.PrintTable

SetCellEditor

Method in class wx.grid.Grid

SetCellFont

Method in class wx.grid.Grid

SetCellHighlightColour

Method in class wx.grid.Grid

SetCellHighlightPenWidth

Method in class wx.grid.Grid

SetCellHighlightROPenWidth

Method in class wx.grid.Grid

SetCellOverflow

Method in class wx.grid.Grid

SetCellRenderer

Method in class wx.grid.Grid

SetCells

Method in class wx.html.HtmlSelection

SetCellSize

Method in class wx.grid.Grid

SetCellText

Method in class wx.lib.printout.PrintTable

SetCellTextColour

Method in class wx.grid.Grid

SetCellValue

Method in class wx.grid.Grid

SetCentreResize

Method in class wx.lib.ogl.Shape

SetChangedWindow

Method in class wx.PaletteChangedEvent

SetChar

Method in class wx.lib.printout.PrintBase

SetCharDimensions

Method in class wx.lib.editor.editor.Editor

SetCharsDefault

Method in class wx.stc.StyledTextCtrl

SetCheckable

Method in class wx.MenuItem

SetChildren

Method in class wx.xrc.XmlNode

SetChoiceRequired

Method in class wx.lib.masked.maskededit.MaskedEditAccessorsMixin

SetChoices

Method in class wx.lib.masked.maskededit.MaskedEditAccessorsMixin

SetChooseFull

Method in class wx.ColourData

SetChosenFont

Method in class wx.FontData

SetClassName

Method in class wx.PyApp

SetClientData

Method in class wx.ItemContainer

SetClientData

Method in class wx.ToolBarToolBase

SetClientData

Method in class wx.lib.ogl.PopupDivisionMenu

SetClientRect

Method in class wx.Window

SetClientSize

Method in class wx.Window

SetClientSizeWH

Method in class wx.Window

SetClippingRect

Method in class wx.DC

SetClippingRect

Method in class wx.lib.ogl.DrawnShape

SetClippingRect

Method in class wx.lib.ogl.PseudoMetaFile

SetClippingRegion

Method in class wx.DC

SetClippingRegionAsRegion

Method in class wx.DC

SetClippingRegionPointSize

Method in class wx.DC

SetClockStyle

Method in class wx.lib.analogclock.AnalogClockWindow

SetCodePage

Method in class wx.stc.StyledTextCtrl

SetCol

Method in class wx.GBPosition

SetCol

Method in class wx.grid.GridCellCoords

SetCol

Method in class wx.grid.GridEditorCreatedEvent

SetColAlignment

Method in class wx.lib.printout.PrintTable

SetColAttr

Method in class wx.grid.Grid

SetColAttr

Method in class wx.grid.GridCellAttrProvider

SetColAttr

Method in class wx.grid.GridTableBase

SetColBackgroundColour

Method in class wx.lib.printout.PrintTable

SetColFormatBool

Method in class wx.grid.Grid

SetColFormatCustom

Method in class wx.grid.Grid

SetColFormatFloat

Method in class wx.grid.Grid

SetColFormatNumber

Method in class wx.grid.Grid

SetColLabelAlignment

Method in class wx.grid.Grid

SetColLabelSize

Method in class wx.grid.Grid

SetColLabelTextOrientation

Method in class wx.grid.Grid

SetColLabelValue

Method in class wx.grid.Grid

SetColLabelValue

Method in class wx.grid.GridTableBase

SetCollate

Method in class wx.PrintData

SetCollate

Method in class wx.PrintDialogData

SetColMinimalAcceptableWidth

Method in class wx.grid.Grid

SetColMinimalWidth

Method in class wx.grid.Grid

SetColor

Method in class wx.lib.calendar.CalDraw

SetColor

Method in class wx.lib.calendar.Calendar

SetColor

Method in class wx.lib.floatcanvas.FloatCanvas.ColorOnlyMixin

SetColor

Method in class wx.lib.floatcanvas.FloatCanvas.TextObjectMixin

SetColors

Method in class wx.lib.editor.editor.Editor

SetColors

Method in class wx.lib.intctrl.IntCtrl

SetColors

Method in class wx.lib.printout.PrintTable

SetColour

Method in class wx.Brush

SetColour

Method in class wx.ColourData

SetColour

Method in class wx.FontData

SetColour

Method in class wx.Pen

SetColour

Method in class wx.PrintData

SetColour

Method in class wx.glcanvas.GLCanvas

SetColour

Method in class wx.glcanvas.GLContext

SetColour

Method in class wx.lib.colourchooser.pycolourbox.PyColourBox

SetColour

Method in class wx.lib.colourselect.ColourSelect

SetColour

Method in class wx.lib.ogl.ShapeRegion

SetColours

Method in class wx.lib.hyperlink.HyperLinkCtrl

SetColourTuple

Method in class wx.lib.colourchooser.pycolourbox.PyColourBox

SetCols

Method in class wx.GridSizer

SetColSize

Method in class wx.grid.Grid

SetColspan

Method in class wx.GBSpan

SetColTextColour

Method in class wx.lib.printout.PrintTable

SetColumn

Method in class wx.ListCtrl

SetColumn

Method in class wx.ListItem

SetColumn

Method in class wx.gizmos.TreeListCtrl

SetColumnAlignment

Method in class wx.gizmos.TreeListCtrl

SetColumnCount

Method in class wx.lib.mixins.listctrl.ColumnSorterMixin

SetColumnImage

Method in class wx.ListCtrl

SetColumnImage

Method in class wx.ListView

SetColumnImage

Method in class wx.gizmos.TreeListCtrl

SetColumnLineColour

Method in class wx.lib.printout.PrintTable

SetColumnLineSize

Method in class wx.lib.printout.PrintTable

SetColumns

Method in class wx.lib.grids.PyGridSizer

SetColumns

Method in class wx.lib.printout.PrintTableDraw

SetColumnText

Method in class wx.gizmos.TreeListCtrl

SetColumnWidth

Method in class wx.ListCtrl

SetColumnWidth

Method in class wx.gizmos.TreeListCtrl

SetCommand

Method in class wx.FileType

SetCommandInt

Method in class wx.grid.GridTableMessage

SetCommandInt2

Method in class wx.grid.GridTableMessage

SetCommandProcessor

Method in class wx.lib.docview.Document

SetCompanionWindow

Method in class wx.gizmos.RemotelyScrolledTreeCtrl

SetCompareNoCase

Method in class wx.lib.masked.maskededit.MaskedEditAccessorsMixin

SetConfig

Method in class wx.FontMapper

SetConfigPath

Method in class wx.FontMapper

SetConstraints

Method in class wx.Window

setConstraintSides

Method in class wx.lib.anchors.LayoutAnchors

SetContainer

Method in class wx.html.HtmlWinParser

SetContainingSizer

Method in class wx.Window

SetContent

Method in class wx.lib.popupctl.PopupDialog

SetContent

Method in class wx.xrc.XmlNode

SetContentsRange

Method in class wx.html.HtmlBookRecord

SetControl

Method in class wx.grid.GridCellEditor

SetControl

Method in class wx.grid.GridEditorCreatedEvent

SetControlBar

Method in class wx.PyPreviewFrame

SetControlCharSymbol

Method in class wx.stc.StyledTextCtrl

SetControlFuncs

Method in class wx.lib.editor.editor.Editor

SetCornerRadius

Method in class wx.lib.ogl.RectangleShape

SetCountry

Method in class wx.DateTime

SetCtrlParameters

Method in class wx.lib.masked.maskededit.MaskedEditMixin

SetCurrent

Method in class wx.glcanvas.GLCanvas

SetCurrent

Method in class wx.glcanvas.GLContext

SetCurrentDay

Method in class wx.lib.calendar.Calendar

SetCurrentFocus

Method in class wx.NavigationKeyEvent

SetCurrentFrame

Method in class wx.animate.AnimationPlayer

SetCurrentPage

Method in class wx.PrintPreview

SetCurrentPos

Method in class wx.stc.StyledTextCtrl

SetCursor

Method in class wx.DropSource

SetCursor

Function in package wx

SetCursor

Method in class wx.SetCursorEvent

SetCursor

Method in class wx.Window

SetCursorEvent

Class in package wx

SetCustomBackgroundColour

Method in class wx.animate.AnimationPlayer

SetCustomColour

Method in class wx.ColourData

setCustomColour

Method in class wx.lib.colourchooser.pycolourchooser.PyColourChooser

SetCustomScale

Method in class wx.gizmos.StaticPicture

SetDarkShadow

Method in class wx.Effects

SetDashes

Method in class wx.Pen

SetData

Method in class wx.Clipboard

SetData

Method in class wx.CustomDataObject

SetData

Method in class wx.DataObject

SetData

Method in class wx.DataObjectSimple

SetData

Method in class wx.DropSource

SetData

Method in class wx.FindReplaceDialog

SetData

Method in class wx.Image

SetData

Method in class wx.ListItem

SetData

Method in class wx.TreeItemData

SetData

Method in class wx.lib.pydocview.ChildDocument

SetDataBuffer

Method in class wx.Image

SetDataObject

Method in class wx.DropTarget

SetDate

Method in class wx.DateEvent

SetDate

Method in class wx.calendar.CalendarCtrl

SetDateRange

Method in class wx.calendar.CalendarCtrl

SetDatestyle

Method in class wx.lib.masked.maskededit.MaskedEditAccessorsMixin

SetDay

Method in class wx.DateTime

SetDay

Method in class wx.lib.calendar.Calendar

SetDays

Method in class wx.DateSpan

SetDayValue

Method in class wx.lib.calendar.Calendar

SetDC

Method in class wx.Printout

SetDC

Method in class wx.html.HtmlDCRenderer

SetDC

Method in class wx.html.HtmlWinParser

SetDebug

Method in class wx.lib.pydocview.DocApp

SetDecimalChar

Method in class wx.lib.masked.maskededit.MaskedEditAccessorsMixin

SetDecimalChar

Method in class wx.lib.masked.numctrl.NumCtrl

SetDecimalChar

Method in class wx.lib.masked.numctrl.NumCtrlAccessorsMixin

SetDefAttr

Method in class wx.grid.GridCellAttr

SetDefault

Method in class wx.Button

SetDefault

Method in class wx.lib.buttons.GenButton

SetDefaultAction

Method in class wx.DropTarget

SetDefaultBorderSize

Method in class wx.SashWindow

SetDefaultCellAlignment

Method in class wx.grid.Grid

SetDefaultCellBackgroundColour

Method in class wx.grid.Grid

SetDefaultCellFont

Method in class wx.grid.Grid

SetDefaultCellOverflow

Method in class wx.grid.Grid

SetDefaultCellTextColour

Method in class wx.grid.Grid

SetDefaultChildClass

Method in class wx.lib.multisash.MultiSash

SetDefaultColSize

Method in class wx.grid.Grid

SetDefaultEditor

Method in class wx.grid.Grid

SetDefaultEncoding

Method in class wx.Font

SetDefaultEncoding

Method in class wx.lib.masked.maskededit.MaskedEditAccessorsMixin

SetDefaultExtension

Method in class wx.lib.docview.DocTemplate

SetDefaultIcon

Method in class wx.FileType

SetDefaultIcon

Method in class wx.lib.pydocview.DocApp

SetDefaultInfo

Method in class wx.PageSetupDialogData

SetDefaultItem

Method in class wx.Window

SetDefaultMinMargins

Method in class wx.PageSetupDialogData

SetDefaultPath

Method in class wx.GenericDirCtrl

SetDefaultPyEncoding

Function in package wx

SetDefaultRegionSize

Method in class wx.lib.ogl.Shape

SetDefaultRenderer

Method in class wx.grid.Grid

SetDefaultRowSize

Method in class wx.grid.Grid

SetDefaults

Method in class wx.Size

SetDefaults

Method in class wx.lib.printout.PrintTableDraw

SetDefaultSize

Method in class wx.SashLayoutWindow

SetDefaultStyle

Method in class wx.TextCtrl

SetDefaultValue

Method in class wx.lib.masked.ipaddrctrl.IpAddrCtrlAccessorsMixin

SetDefaultValue

Method in class wx.lib.masked.maskededit.MaskedEditAccessorsMixin

SetDefaultValue

Method in class wx.lib.masked.numctrl.NumCtrlAccessorsMixin

SetDefaultValue

Method in class wx.lib.masked.timectrl.TimeCtrlAccessorsMixin

SetDelay

Method in class wx.ToolTip

SetDemo

Method in class wx.lib.masked.maskededit.MaskedEditAccessorsMixin

SetDepth

Method in class wx.Bitmap

SetDepth

Method in class wx.Icon

SetDescription

Method in class wx.lib.docview.DocTemplate

SetDescription

Method in class wx.lib.masked.ipaddrctrl.IpAddrCtrlAccessorsMixin

SetDescription

Method in class wx.lib.masked.maskededit.MaskedEditAccessorsMixin

SetDescription

Method in class wx.lib.masked.numctrl.NumCtrlAccessorsMixin

SetDescription

Method in class wx.lib.masked.timectrl.TimeCtrlAccessorsMixin

SetDestroyAnimation

Method in class wx.animate.AnimationPlayer

SetDeviceOrigin

Method in class wx.DC

SetDeviceOriginPoint

Method in class wx.DC

SetDiagram

Method in class wx.lib.ogl.ShapeCanvas

SetDialogParent

Method in class wx.FontMapper

SetDialogTitle

Method in class wx.FontMapper

SetDiameter

Method in class wx.lib.floatcanvas.FloatCanvas.Circle

SetDiameter

Method in class wx.lib.floatcanvas.FloatCanvas.Point

SetDiameter

Method in class wx.lib.floatcanvas.FloatCanvas.PointSet

SetDimension

Method in class wx.Sizer

SetDimension

Method in class wx.SizerItem

SetDimensions

Method in class wx.Window

SetDirect

Method in class wx.lib.imagebrowser.ImageDialog

SetDirection

Method in class wx.NavigationKeyEvent

SetDirection

Method in class wx.lib.floatcanvas.FloatCanvas.Arrow

SetDirection

Method in class wx.lib.ticker.Ticker

SetDirectory

Method in class wx.FileDialog

SetDirectory

Method in class wx.lib.docview.DocTemplate

SetDisabledBitmap

Method in class wx.MenuItem

SetDisabledBitmap

Method in class wx.ToolBarToolBase

SetDisableLabel

Method in class wx.lib.ogl.Shape

SetDocPointer

Method in class wx.stc.StyledTextCtrl

SetDocument

Method in class wx.lib.docview.DocChildFrame

SetDocument

Method in class wx.lib.docview.DocMDIChildFrame

SetDocument

Method in class wx.lib.docview.View

SetDocument

Method in class wx.lib.pydocview.DocMDIChildFrame

SetDocument

Method in class wx.lib.pydocview.DocTabbedChildFrame

SetDocumentManager

Method in class wx.lib.docview.DocTemplate

SetDocumentManager

Method in class wx.lib.pydocview.DocApp

SetDocumentManager

Method in class wx.lib.pydocview.DocService

SetDocumentModificationDate

Method in class wx.lib.docview.Document

SetDocumentName

Method in class wx.lib.docview.Document

SetDocumentSaved

Method in class wx.lib.docview.Document

SetDocumentTemplate

Method in class wx.lib.docview.Document

SetDone

Method in class wx.IndividualLayoutConstraint

SetDoubleBuffered

Method in class wx.lib.mvctree.MVCTree

SetDragAllowMove

Method in class wx.stc.StyledTextEvent

SetDraggable

Method in class wx.lib.ogl.Shape

SetDragRect

Method in class wx.SashEvent

SetDragResult

Method in class wx.stc.StyledTextEvent

SetDragStatus

Method in class wx.SashEvent

SetDragText

Method in class wx.stc.StyledTextEvent

SetDrawFaded

Method in class wx.gizmos.LEDNumberCtrl

SetDrawHandles

Method in class wx.lib.ogl.Shape

SetDrawnBackgroundColour

Method in class wx.lib.ogl.DrawnShape

SetDrawnBackgroundMode

Method in class wx.lib.ogl.DrawnShape

SetDrawnBrush

Method in class wx.lib.ogl.DrawnShape

SetDrawnFont

Method in class wx.lib.ogl.DrawnShape

SetDrawnPen

Method in class wx.lib.ogl.DrawnShape

SetDrawnTextColour

Method in class wx.lib.ogl.DrawnShape

SetDropTarget

Method in class wx.Window

SetDuplex

Method in class wx.PrintData

SetEdge

Method in class wx.IndividualLayoutConstraint

SetEdge

Method in class wx.SashEvent

SetEdgeColour

Method in class wx.stc.StyledTextCtrl

SetEdgeColumn

Method in class wx.stc.StyledTextCtrl

SetEdgeMode

Method in class wx.stc.StyledTextCtrl

SetEditable

Method in class wx.ComboBox

SetEditable

Method in class wx.TextCtrl

SetEditable

Method in class wx.lib.mvctree.BasicTreeModel

SetEditable

Method in class wx.lib.mvctree.FSTreeModel

SetEditable

Method in class wx.lib.mvctree.TreeModel

SetEditCanceled

Method in class wx.ListEvent

SetEditCanceled

Method in class wx.TreeEvent

SetEditMenu

Method in class wx.lib.docview.CommandProcessor

SetEditor

Method in class wx.grid.GridCellAttr

setEditor

Method in class wx.py.editor.EditorFrame

SetEmptyBackgroundColour

Method in class wx.lib.masked.ipaddrctrl.IpAddrCtrlAccessorsMixin

SetEmptyBackgroundColour

Method in class wx.lib.masked.maskededit.MaskedEditAccessorsMixin

SetEmptyBackgroundColour

Method in class wx.lib.masked.numctrl.NumCtrlAccessorsMixin

SetEmptyBackgroundColour

Method in class wx.lib.masked.timectrl.TimeCtrlAccessorsMixin

SetEmptyCellSize

Method in class wx.GridBagSizer

SetEmptyInvalid

Method in class wx.lib.masked.ipaddrctrl.IpAddrCtrlAccessorsMixin

SetEmptyInvalid

Method in class wx.lib.masked.maskededit.MaskedEditAccessorsMixin

SetEmptyInvalid

Method in class wx.lib.masked.numctrl.NumCtrlAccessorsMixin

SetEnabled

Method in class wx.tools.dbg.Logger

SetEnableGrid

Method in class wx.lib.plot.PlotCanvas

SetEnableLegend

Method in class wx.lib.plot.PlotCanvas

SetEnablePointLabel

Method in class wx.lib.plot.PlotCanvas

SetEnableZoom

Method in class wx.lib.plot.PlotCanvas

SetEncoding

Method in class wx.Font

SetEncoding

Method in class wx.NativeFontInfo

SetEndAtLastLine

Method in class wx.stc.StyledTextCtrl

SetEnds

Method in class wx.lib.ogl.LineShape

SetEOLMode

Method in class wx.stc.StyledTextCtrl

SetEraseObject

Method in class wx.lib.ogl.ControlPoint

SetEvent

Method in class wx.html.HtmlLinkInfo

SetEventHandler

Method in class wx.Menu

SetEventHandler

Method in class wx.Window

SetEventHandler

Method in class wx.lib.ogl.Shape

SetEventObject

Method in class wx.Event

SetEventType

Method in class wx.Event

SetEvtHandlerEnabled

Method in class wx.EvtHandler

SetExcludeChars

Method in class wx.lib.masked.maskededit.MaskedEditAccessorsMixin

SetExitOnFrameDelete

Method in class wx.PyApp

SetExpanded

Method in class wx.lib.mvctree.MVCTree

SetExpandEnvVars

Method in class wx.ConfigBase

SetExtension

Method in class wx.ImageHandler

SetExtraBorderSize

Method in class wx.SashWindow

SetExtraLong

Method in class wx.CommandEvent

SetExtraStyle

Method in class wx.Window

SetFaceColour

Method in class wx.Effects

SetFaceName

Method in class wx.Font

SetFaceName

Method in class wx.NativeFontInfo

SetFamily

Method in class wx.Font

SetFamily

Method in class wx.NativeFontInfo

SetFgColour

Method in class wx.html.HtmlRenderingState

SetFieldParameters

Method in class wx.lib.masked.maskededit.MaskedEditMixin

SetFields

Method in class wx.lib.masked.ipaddrctrl.IpAddrCtrlAccessorsMixin

SetFields

Method in class wx.lib.masked.maskededit.MaskedEditAccessorsMixin

SetFieldsCount

Method in class wx.StatusBar

SetFileEncoding

Method in class wx.xrc.XmlDocument

SetFileFilter

Method in class wx.lib.docview.DocTemplate

SetFilename

Method in class wx.FileDialog

SetFileName

Method in class wx.IconLocation

SetFilename

Method in class wx.PrintData

SetFilename

Method in class wx.animate.GIFAnimationCtrl

SetFilename

Method in class wx.lib.docview.Document

SetFilename

Method in class wx.lib.ogl.BitmapShape

SetFillBrush

Method in class wx.lib.ogl.PseudoMetaFile

SetFillChar

Method in class wx.lib.masked.ipaddrctrl.IpAddrCtrlAccessorsMixin

SetFillChar

Method in class wx.lib.masked.maskededit.MaskedEditAccessorsMixin

SetFillColor

Method in class wx.lib.floatcanvas.FloatCanvas.LineAndFillMixin

SetFillStyle

Method in class wx.lib.floatcanvas.FloatCanvas.LineAndFillMixin

SetFilter

Method in class wx.GenericDirCtrl

SetFilterIndex

Method in class wx.FileDialog

SetFilterIndex

Method in class wx.GenericDirCtrl

SetFindString

Method in class wx.FindDialogEvent

SetFindString

Method in class wx.FindReplaceData

SetFirstColour

Method in class wx.lib.foldpanelbar.CaptionBarStyle

SetFirstItem

Method in class wx.ListBox

SetFirstItemStr

Method in class wx.ListBox

SetFixedSize

Method in class wx.lib.ogl.Shape

SetFlag

Method in class wx.SizerItem

SetFlags

Method in class wx.CalculateLayoutEvent

SetFlags

Method in class wx.FindDialogEvent

SetFlags

Method in class wx.FindReplaceData

SetFlags

Method in class wx.NavigationKeyEvent

SetFlags

Method in class wx.QueryLayoutInfoEvent

SetFlags

Method in class wx.TextAttr

SetFlags

Method in class wx.lib.docview.DocTemplate

SetFlags

Method in class wx.xrc.XmlResource

SetFlexibleDirection

Method in class wx.FlexGridSizer

SetFloatable

Method in class wx.lib.floatbar.FloatBar

SetFlow

Method in class wx.lib.printout.PrintBase

SetFocus

Method in class wx.Panel

SetFocus

Method in class wx.Window

SetFocus

Method in class wx.lib.pydocview.DocTabbedChildFrame

setFocus

Method in class wx.py.editor.Editor

SetFocus

Method in class wx.py.editor.EditorShellNotebook

setFocus

Method in class wx.py.shell.Shell

SetFocusFromKbd

Method in class wx.Window

SetFocusIgnoringChildren

Method in class wx.Panel

SetFoldExpanded

Method in class wx.stc.StyledTextCtrl

SetFoldFlags

Method in class wx.stc.StyledTextCtrl

SetFoldLevel

Method in class wx.stc.StyledTextCtrl

SetFoldLevelNow

Method in class wx.stc.StyledTextEvent

SetFoldLevelPrev

Method in class wx.stc.StyledTextEvent

SetFoldMarginColour

Method in class wx.stc.StyledTextCtrl

SetFoldMarginHiColour

Method in class wx.stc.StyledTextCtrl

SetFont

Method in class wx.DC

SetFont

Method in class wx.ListItem

SetFont

Method in class wx.ListItemAttr

SetFont

Method in class wx.MenuItem

SetFont

Method in class wx.TextAttr

SetFont

Method in class wx.Window

SetFont

Method in class wx.calendar.CalendarDateAttr

SetFont

Method in class wx.grid.GridCellAttr

SetFont

Method in class wx.lib.floatcanvas.FloatCanvas.TextObjectMixin

SetFont

Method in class wx.lib.masked.combobox.BaseMaskedComboBox

SetFont

Method in class wx.lib.masked.textctrl.BaseMaskedTextCtrl

SetFont

Method in class wx.lib.mvctree.MVCTree

SetFont

Method in class wx.lib.mvctree.Painter

SetFont

Method in class wx.lib.ogl.PseudoMetaFile

SetFont

Method in class wx.lib.ogl.Shape

SetFont

Method in class wx.lib.ogl.ShapeRegion

SetFont

Method in class wx.lib.stattext.GenStaticText

SetFont

Method in class wx.lib.throbber.Throbber

SetFont

Method in class wx.lib.ticker.Ticker

SetFontBold

Method in class wx.html.HtmlWinParser

SetFontFixed

Method in class wx.html.HtmlWinParser

SetFontItalic

Method in class wx.html.HtmlWinParser

SetFontMetricPath

Method in class wx.PrintData

SetFonts

Method in class wx.html.HtmlDCRenderer

SetFonts

Method in class wx.html.HtmlEasyPrinting

SetFonts

Method in class wx.html.HtmlPrintout

SetFonts

Method in class wx.html.HtmlWinParser

SetFonts

Method in class wx.html.HtmlWindow

SetFonts

Method in class wx.lib.printout.PrintTable

SetFontSize

Method in class wx.html.HtmlWinParser

SetFontSizeAxis

Method in class wx.lib.plot.PlotCanvas

SetFontSizeLegend

Method in class wx.lib.plot.PlotCanvas

SetFontSizeTitle

Method in class wx.lib.plot.PlotCanvas

SetFontUnderlined

Method in class wx.html.HtmlWinParser

SetFooter

Method in class wx.html.HtmlEasyPrinting

SetFooter

Method in class wx.html.HtmlPrintout

SetFooter

Method in class wx.lib.printout.PrintTable

SetFooterValue

Method in class wx.lib.printout.PrintTable

SetForegroundColour

Method in class wx.ListCtrl

SetForegroundColour

Method in class wx.Window

SetForegroundColour

Method in class wx.lib.buttons.GenButton

SetForegroundColour

Method in class wx.lib.mvctree.MVCTree

SetForegroundColour

Method in class wx.lib.mvctree.Painter

SetFormat

Method in class wx.DataObjectSimple

SetFormat

Method in class wx.lib.masked.timectrl.TimeCtrl

SetFormatcodes

Method in class wx.lib.masked.ipaddrctrl.IpAddrCtrlAccessorsMixin

SetFormatcodes

Method in class wx.lib.masked.maskededit.MaskedEditAccessorsMixin

SetFormatMode

Method in class wx.lib.ogl.Shape

SetFormatMode

Method in class wx.lib.ogl.ShapeRegion

SetFPS

Method in class wx.lib.ticker.Ticker

SetFractionWidth

Method in class wx.lib.masked.numctrl.NumCtrl

SetFrame

Method in class wx.PrintPreview

SetFrame

Method in class wx.lib.docview.View

SetFrameDelay

Method in class wx.lib.throbber.Throbber

SetFrom

Method in class wx.lib.ogl.LineShape

SetFromName

Method in class wx.Colour

SetFromPage

Method in class wx.PrintDialogData

SetFromPrivPos

Method in class wx.html.HtmlSelection

SetFromTab

Method in class wx.NavigationKeyEvent

SetFS

Method in class wx.html.HtmlParser

SetGBSizer

Method in class wx.GBSizerItem

SetGesturePen

Method in class wx.lib.gestures.MouseGestures

SetGesturesVisible

Method in class wx.lib.gestures.MouseGestures

SetGridCursor

Method in class wx.grid.Grid

SetGridLineColour

Method in class wx.grid.Grid

SetGridSpacing

Method in class wx.lib.ogl.Diagram

SetGroupChar

Method in class wx.lib.masked.maskededit.MaskedEditAccessorsMixin

SetGroupChar

Method in class wx.lib.masked.numctrl.NumCtrl

SetGroupChar

Method in class wx.lib.masked.numctrl.NumCtrlAccessorsMixin

SetGroupDigits

Method in class wx.lib.masked.numctrl.NumCtrl

SetHandColours

Method in class wx.lib.analogclock.AnalogClockWindow

SetHandleSide

Method in class wx.lib.ogl.DivisionShape

SetHandWeights

Method in class wx.lib.analogclock.AnalogClockWindow

SetHeader

Method in class wx.html.HtmlEasyPrinting

SetHeader

Method in class wx.html.HtmlPrintout

SetHeader

Method in class wx.lib.printout.PrintTable

SetHeaderColours

Method in class wx.calendar.CalendarCtrl

SetHeaderValue

Method in class wx.lib.printout.PrintTable

SetHeight

Method in class wx.Bitmap

SetHeight

Method in class wx.Icon

SetHeight

Method in class wx.Rect

SetHeight

Method in class wx.Size

SetHeight

Method in class wx.lib.mvctree.TreeLayout

SetHeight

Method in class wx.lib.ogl.EllipseShape

SetHeight

Method in class wx.lib.ogl.RectangleShape

SetHelp

Method in class wx.MenuItem

SetHelpString

Method in class wx.Menu

SetHelpString

Method in class wx.MenuBar

SetHelpText

Method in class wx.Window

SetHelpTextForId

Method in class wx.Window

SetHGap

Method in class wx.GridSizer

SetHgap

Method in class wx.lib.grids.PyGridSizer

SetHighlight

Method in class wx.lib.colourchooser.pycolourbox.PyColourBox

SetHighlight

Method in class wx.lib.ogl.Shape

SetHighlightColour

Method in class wx.Effects

SetHighlightColours

Method in class wx.calendar.CalendarCtrl

SetHighlightGuide

Method in class wx.stc.StyledTextCtrl

SetHistory

Method in class wx.lib.filebrowsebutton.FileBrowseButtonWithHistory

SetHitBrush

Method in class wx.lib.floatcanvas.FloatCanvas.DrawObject

SetHitPen

Method in class wx.lib.floatcanvas.FloatCanvas.DrawObject

SetHMS

Method in class wx.DateTime

SetHoliday

Method in class wx.calendar.CalendarCtrl

SetHoliday

Method in class wx.calendar.CalendarDateAttr

SetHolidayColours

Method in class wx.calendar.CalendarCtrl

SetHotspotActiveBackground

Method in class wx.stc.StyledTextCtrl

SetHotspotActiveForeground

Method in class wx.stc.StyledTextCtrl

SetHotspotActiveUnderline

Method in class wx.stc.StyledTextCtrl

SetHotspotSingleLine

Method in class wx.stc.StyledTextCtrl

SetHour

Method in class wx.DateTime

SetHScrollBar

Method in class wx.stc.StyledTextCtrl

SetHtmlCell

Method in class wx.html.HtmlLinkInfo

SetHtmlFile

Method in class wx.html.HtmlPrintout

SetHtmlText

Method in class wx.html.HtmlDCRenderer

SetHtmlText

Method in class wx.html.HtmlPrintout

SetIcon

Method in class wx.FileTypeInfo

SetIcon

Method in class wx.StaticBitmap

SetIcon

Method in class wx.TaskBarIcon

SetIcon

Method in class wx.TopLevelWindow

SetIcon

Method in class wx.gizmos.StaticPicture

SetIcon

Method in class wx.lib.docview.DocTemplate

SetIcon

Method in class wx.lib.pydocview.DocTabbedChildFrame

SetIcons

Method in class wx.TopLevelWindow

SetId

Method in class wx.DataFormat

SetId

Method in class wx.Event

SetId

Method in class wx.ListItem

SetId

Method in class wx.MenuItem

SetId

Method in class wx.TreeItemData

SetId

Method in class wx.Window

SetId

Method in class wx.grid.GridTableMessage

SetId

Method in class wx.html.HtmlCell

SetId

Method in class wx.lib.ogl.Shape

SetIgnoreOffsets

Method in class wx.lib.ogl.LineShape

SetImage

Method in class wx.ListItem

SetImage

Method in class wx.gizmos.TreeListColumnInfo

SetImageList

Method in class wx.BookCtrlBase

SetImageList

Method in class wx.ListCtrl

SetImageList

Method in class wx.TreeCtrl

SetImageList

Method in class wx.gizmos.TreeListCtrl

SetIncludeChars

Method in class wx.lib.masked.maskededit.MaskedEditAccessorsMixin

SetIndent

Method in class wx.TreeCtrl

SetIndent

Method in class wx.gizmos.TreeListCtrl

SetIndent

Method in class wx.html.HtmlContainerCell

SetIndent

Method in class wx.stc.StyledTextCtrl

SetIndent

Method in class wx.tools.dbg.Logger

SetIndentationGuides

Method in class wx.stc.StyledTextCtrl

SetIndex

Method in class wx.IconLocation

SetInitialFont

Method in class wx.FontData

SetInitSize

Method in class wx.SizerItem

SetInsertionPoint

Method in class wx.ComboBox

SetInsertionPoint

Method in class wx.TextCtrl

SetInsertionPoint

Method in class wx.lib.masked.timectrl.TimeCtrl

SetInsertionPointEnd

Method in class wx.ComboBox

SetInsertionPointEnd

Method in class wx.TextCtrl

SetInstallPrefix

Method in class wx.StandardPaths

SetInt

Method in class wx.CommandEvent

SetIntegerWidth

Method in class wx.lib.masked.numctrl.NumCtrl

SetInvalidBackgroundColour

Method in class wx.lib.masked.ipaddrctrl.IpAddrCtrlAccessorsMixin

SetInvalidBackgroundColour

Method in class wx.lib.masked.maskededit.MaskedEditAccessorsMixin

SetInvalidBackgroundColour

Method in class wx.lib.masked.numctrl.NumCtrlAccessorsMixin

SetInvalidBackgroundColour

Method in class wx.lib.masked.timectrl.TimeCtrlAccessorsMixin

SetInvokingWindow

Method in class wx.Menu

SetIsDown

Method in class wx.lib.buttons.GenButtonEvent

SetIsPreview

Method in class wx.Printout

SetItem

Method in class wx.ListCtrl

SetItem

Method in class wx.TreeEvent

setItem

Method in class wx.py.crust.Display

SetItemBackgroundColour

Method in class wx.ListBox

SetItemBackgroundColour

Method in class wx.ListCtrl

SetItemBackgroundColour

Method in class wx.TreeCtrl

SetItemBackgroundColour

Method in class wx.gizmos.TreeListCtrl

SetItemBold

Method in class wx.TreeCtrl

SetItemBold

Method in class wx.gizmos.TreeListCtrl

SetItemBounds

Method in class wx.lib.grids.PyGridSizer

SetItemBounds

Method in class wx.lib.rcsizer.RowColSizer

SetItemCount

Method in class wx.HtmlListBox

SetItemCount

Method in class wx.ListCtrl

SetItemCount

Method in class wx.VListBox

SetItemData

Method in class wx.ListCtrl

SetItemData

Method in class wx.TreeCtrl

SetItemData

Method in class wx.gizmos.TreeListCtrl

SetItemDropHighlight

Method in class wx.TreeCtrl

SetItemFont

Method in class wx.ListBox

SetItemFont

Method in class wx.TreeCtrl

SetItemFont

Method in class wx.gizmos.TreeListCtrl

SetItemForegroundColour

Method in class wx.ListBox

SetItemHasChildren

Method in class wx.TreeCtrl

SetItemHasChildren

Method in class wx.gizmos.TreeListCtrl

SetItemImage

Method in class wx.ListCtrl

SetItemImage

Method in class wx.TreeCtrl

SetItemImage

Method in class wx.gizmos.TreeListCtrl

SetItemMinSize

Method in class wx.Sizer

SetItemPosition

Method in class wx.GridBagSizer

SetItemPosition

Method in class wx.ListCtrl

SetItemPyData

Method in class wx.TreeCtrl

SetItemPyData

Method in class wx.gizmos.TreeListCtrl

SetItemSpacing

Method in class wx.ListCtrl

SetItemSpan

Method in class wx.GridBagSizer

SetItemState

Method in class wx.ListCtrl

SetItemText

Method in class wx.ListCtrl

SetItemText

Method in class wx.TreeCtrl

SetItemText

Method in class wx.gizmos.TreeListCtrl

SetItemTextColour

Method in class wx.ListCtrl

SetItemTextColour

Method in class wx.TreeCtrl

SetItemTextColour

Method in class wx.gizmos.TreeListCtrl

SetJDN

Method in class wx.DateTime

SetJoin

Method in class wx.Pen

SetJoystick

Method in class wx.JoystickEvent

SetKey

Method in class wx.stc.StyledTextEvent

SetKeyEvent

Method in class wx.TreeEvent

SetKeyWords

Method in class wx.stc.StyledTextCtrl

SetKind

Method in class wx.MenuItem

SetKind

Method in class wx.grid.GridCellAttr

SetLabel

Method in class wx.Control

SetLabel

Method in class wx.Menu

SetLabel

Method in class wx.MenuBar

SetLabel

Method in class wx.ToggleButton

SetLabel

Method in class wx.ToolBarToolBase

SetLabel

Method in class wx.TreeEvent

SetLabel

Method in class wx.Window

SetLabel

Method in class wx.lib.colourselect.ColourSelect

SetLabel

Method in class wx.lib.filebrowsebutton.FileBrowseButton

SetLabel

Method in class wx.lib.stattext.GenStaticText

SetLabel

Method in class wx.lib.throbber.Throbber

SetLabelBackgroundColour

Method in class wx.grid.Grid

SetLabelFont

Method in class wx.grid.Grid

SetLabelSpacing

Method in class wx.lib.printout.PrintTable

SetLabelTextColour

Method in class wx.grid.Grid

SetLabelTop

Method in class wx.MenuBar

SetLandscape

Method in class wx.lib.printout.PrintTable

SetLastKeydownProcessed

Method in class wx.stc.StyledTextCtrl

SetLayoutCache

Method in class wx.stc.StyledTextCtrl

SetLeft

Method in class wx.Rect

SetLeftIndent

Method in class wx.TextAttr

SetLeftSide

Method in class wx.lib.ogl.DivisionShape

SetLeftSideColour

Method in class wx.lib.ogl.DivisionShape

SetLeftSidePen

Method in class wx.lib.ogl.DivisionShape

SetLeftSideStyle

Method in class wx.lib.ogl.DivisionShape

SetLength

Method in class wx.lib.floatcanvas.FloatCanvas.Arrow

SetLength

Method in class wx.stc.StyledTextEvent

SetLengthDirection

Method in class wx.lib.floatcanvas.FloatCanvas.Arrow

SetLexer

Method in class wx.stc.StyledTextCtrl

SetLexerLanguage

Method in class wx.stc.StyledTextCtrl

SetLightShadow

Method in class wx.Effects

SetLimited

Method in class wx.lib.intctrl.IntCtrl

SetLimited

Method in class wx.lib.masked.numctrl.NumCtrl

SetLimited

Method in class wx.lib.masked.timectrl.TimeCtrl

SetLine

Method in class wx.stc.StyledTextEvent

SetLineColor

Method in class wx.lib.floatcanvas.FloatCanvas.LineOnlyMixin

SetLineColour

Method in class wx.lib.mvctree.Painter

SetLineCount

Method in class wx.VScrolledWindow

SetLineIndentation

Method in class wx.stc.StyledTextCtrl

SetLinePen

Method in class wx.lib.mvctree.TreePainter

SetLinesAdded

Method in class wx.stc.StyledTextEvent

SetLineSize

Method in class wx.Slider

SetLineSpacing

Method in class wx.gizmos.TreeListCtrl

SetLineState

Method in class wx.stc.StyledTextCtrl

SetLineStyle

Method in class wx.lib.floatcanvas.FloatCanvas.LineOnlyMixin

SetLineWidth

Method in class wx.lib.floatcanvas.FloatCanvas.LineOnlyMixin

SetLink

Method in class wx.HelpEvent

SetLink

Method in class wx.html.HtmlCell

SetLink

Method in class wx.html.HtmlWinParser

SetLinkColor

Method in class wx.html.HtmlWinParser

SetLinkCursor

Method in class wx.lib.hyperlink.HyperLinkCtrl

SetListType

Method in class wx.stc.StyledTextEvent

SetListValue

Method in class wx.lib.imagebrowser.ImageDialog

SetLocals

Method in class wx.lib.pyshell.PyShellWindow

setLocalShell

Method in class wx.py.shell.Shell

SetLog

Method in class wx.LogChain

SetLoggingOff

Method in class wx.CloseEvent

SetLogicalFunction

Method in class wx.DC

SetLogicalOrigin

Method in class wx.DC

SetLogicalOriginPoint

Method in class wx.DC

SetLogicalScale

Method in class wx.DC

SetLogLevel

Method in class wx.Log

SetLongAllowed

Method in class wx.lib.intctrl.IntCtrl

SetLongHelp

Method in class wx.ToolBarToolBase

SetLooped

Method in class wx.animate.AnimationPlayer

SetLowerDateLimit

Method in class wx.calendar.CalendarCtrl

SetLParam

Method in class wx.stc.StyledTextEvent

SetMacAboutMenuItemId

Method in class wx.PyApp

SetMacExitMenuItemId

Method in class wx.PyApp

SetMacHelpMenuTitleName

Method in class wx.PyApp

SetMacPreferencesMenuItemId

Method in class wx.PyApp

SetMacSupportPCMenuShortcuts

Method in class wx.PyApp

SetMainColumn

Method in class wx.gizmos.TreeListCtrl

SetMaintainAspectRatio

Method in class wx.lib.ogl.Shape

SetMapMode

Method in class wx.DC

SetMarg

Method in class wx.lib.calendar.CalDraw

SetMargin

Method in class wx.IndividualLayoutConstraint

SetMargin

Method in class wx.lib.calendar.Calendar

SetMargin

Method in class wx.stc.StyledTextEvent

SetMarginBottomRight

Method in class wx.PageSetupDialogData

SetMarginLeft

Method in class wx.stc.StyledTextCtrl

SetMarginMask

Method in class wx.stc.StyledTextCtrl

SetMarginRight

Method in class wx.stc.StyledTextCtrl

SetMargins

Method in class wx.BitmapButton

SetMargins

Method in class wx.ToolBarBase

SetMargins

Method in class wx.VListBox

SetMargins

Method in class wx.grid.Grid

SetMargins

Method in class wx.html.HtmlPrintout

SetMargins

Method in class wx.lib.printout.PrintTable

SetMargins

Method in class wx.stc.StyledTextCtrl

SetMarginSensitive

Method in class wx.stc.StyledTextCtrl

SetMarginsXY

Method in class wx.ToolBarBase

SetMarginsXY

Method in class wx.VListBox

SetMarginTopLeft

Method in class wx.PageSetupDialogData

SetMarginType

Method in class wx.stc.StyledTextCtrl

SetMarginWidth

Method in class wx.MenuItem

SetMarginWidth

Method in class wx.stc.StyledTextCtrl

SetMark

Method in class wx.ComboBox

SetMask

Method in class wx.Bitmap

SetMask

Method in class wx.Image

SetMask

Method in class wx.ListItem

SetMask

Method in class wx.lib.masked.maskededit.MaskedEditAccessorsMixin

SetMaskColour

Method in class wx.Bitmap

SetMaskColour

Method in class wx.Image

SetMaskFromImage

Method in class wx.Image

SetMaskParameters

Method in class wx.lib.masked.maskededit.MaskedEditMixin

SetMax

Method in class wx.Slider

SetMax

Method in class wx.SpinButton

SetMax

Method in class wx.lib.intctrl.IntCtrl

SetMax

Method in class wx.lib.masked.numctrl.NumCtrl

SetMax

Method in class wx.lib.masked.timectrl.TimeCtrl

SetMaxDocsOpen

Method in class wx.lib.docview.DocManager

SetMaximumSizeX

Method in class wx.SashWindow

SetMaximumSizeY

Method in class wx.SashWindow

SetMaxLength

Method in class wx.TextCtrl

SetMaxPage

Method in class wx.PrintDialogData

SetMaxRowsCols

Method in class wx.ToolBarBase

SetMaxSize

Method in class wx.Window

SetMediumShadow

Method in class wx.Effects

SetMenu

Method in class wx.MenuItem

SetMenuBar

Method in class wx.Frame

SetMenuStrings

Method in class wx.lib.docview.CommandProcessor

SetMessage

Method in class wx.DirDialog

SetMessage

Method in class wx.FileDialog

SetMessage

Method in class wx.stc.StyledTextEvent

SetMillisecond

Method in class wx.DateTime

SetMimeType

Method in class wx.ImageHandler

SetMin

Method in class wx.Slider

SetMin

Method in class wx.SpinButton

SetMin

Method in class wx.lib.intctrl.IntCtrl

SetMin

Method in class wx.lib.masked.numctrl.NumCtrl

SetMin

Method in class wx.lib.masked.timectrl.TimeCtrl

SetMinHeight

Method in class wx.StatusBar

SetMinHeight

Method in class wx.html.HtmlContainerCell

SetMinimumPaneSize

Method in class wx.SplitterWindow

SetMinimumSizeX

Method in class wx.SashWindow

SetMinimumSizeY

Method in class wx.SashWindow

SetMinMarginBottomRight

Method in class wx.PageSetupDialogData

SetMinMarginTopLeft

Method in class wx.PageSetupDialogData

SetMinPage

Method in class wx.PrintDialogData

SetMinSize

Method in class wx.Sizer

SetMinSize

Method in class wx.Window

SetMinSize

Method in class wx.lib.ogl.ShapeRegion

SetMinute

Method in class wx.DateTime

SetMinutesOffset

Method in class wx.lib.analogclock.AnalogClockWindow

SetMode

Method in class wx.IdleEvent

SetMode

Method in class wx.UpdateUIEvent

SetMode

Method in class wx.lib.floatcanvas.FloatCanvas.FloatCanvas

SetModel

Method in class wx.lib.mvctree.MVCTree

SetModEventMask

Method in class wx.stc.StyledTextCtrl

SetModificationType

Method in class wx.stc.StyledTextEvent

SetModifiers

Method in class wx.lib.gestures.MouseGestures

SetModifiers

Method in class wx.stc.StyledTextEvent

SetMonth

Method in class wx.DateTime

SetMonth

Method in class wx.lib.calendar.Calendar

SetMonths

Method in class wx.DateSpan

SetMouseButton

Method in class wx.lib.gestures.MouseGestures

SetMouseDownCaptures

Method in class wx.stc.StyledTextCtrl

SetMouseDwellTime

Method in class wx.stc.StyledTextCtrl

SetMouseTolerance

Method in class wx.lib.ogl.Diagram

SetMovementThreshold

Method in class wx.Joystick

SetMoveSpecialControlFuncs

Method in class wx.lib.editor.editor.Editor

SetMoveSpecialFuncs

Method in class wx.lib.editor.editor.Editor

SetMultiSelect

Method in class wx.lib.mvctree.MVCTree

SetMxDateTime

Method in class wx.lib.masked.timectrl.TimeCtrl

SetName

Method in class wx.ImageHandler

SetName

Method in class wx.Window

SetName

Method in class wx.lib.ogl.ShapeRegion

SetName

Method in class wx.xrc.XmlNode

SetName

Method in class wx.xrc.XmlProperty

SetNativeFontInfo

Method in class wx.Font

SetNativeFontInfoFromString

Method in class wx.Font

SetNativeFontInfoUserDesc

Method in class wx.Font

SetNeedUpdating

Method in class wx.SplitterWindow

SetNegativeButton

Method in class wx.StdDialogButtonSizer

SetNewChildCls

Method in class wx.lib.multisash.MultiClient

SetNext

Method in class wx.html.HtmlCell

SetNext

Method in class wx.wizard.WizardPageSimple

SetNext

Method in class wx.xrc.XmlNode

SetNext

Method in class wx.xrc.XmlProperty

SetNextHandler

Method in class wx.EvtHandler

SetNoAntiAliasing

Method in class wx.Font

SetNoCopies

Method in class wx.PrintData

SetNoCopies

Method in class wx.PrintDialogData

SetNoneAllowed

Method in class wx.lib.intctrl.IntCtrl

SetNonFlexibleGrowMode

Method in class wx.FlexGridSizer

SetNormalBitmap

Method in class wx.ToolBarToolBase

SetNormalFont

Method in class wx.lib.foldpanelbar.CaptionBar

SetNotebookPageTitle

Method in class wx.lib.pydocview.DocTabbedParentFrame

SetNow

Method in class wx.lib.calendar.Calendar

SetNumberCols

Method in class wx.lib.sheet.CSheet

SetNumberRows

Method in class wx.lib.sheet.CSheet

SetOk

Method in class wx.PrintPreview

SetOldItem

Method in class wx.TreeEvent

SetOldSelection

Method in class wx.BookCtrlBaseEvent

SetOption

Method in class wx.Image

SetOption

Method in class wx.SystemOptions

SetOptionInt

Method in class wx.Image

SetOptionInt

Method in class wx.SystemOptions

SetOrientation

Method in class wx.BoxSizer

SetOrientation

Method in class wx.PrintData

SetOrientation

Method in class wx.QueryLayoutInfoEvent

SetOrientation

Method in class wx.SashLayoutWindow

SetOrientation

Method in class wx.ScrollEvent

SetOrientation

Method in class wx.ScrollWinEvent

SetOrientation

Method in class wx.lib.printout.PrintTable

SetOriginalHeight

Method in class wx.lib.ogl.PolygonShape

SetOriginalWidth

Method in class wx.lib.ogl.PolygonShape

SetOtherMenuBar

Method in class wx.lib.infoframe.PyInformationalMessagesFrame

SetOutlineOp

Method in class wx.lib.ogl.PseudoMetaFile

SetOutlinePen

Method in class wx.lib.ogl.PseudoMetaFile

SetOutputDirectory

Method in class wx.lib.infoframe.PyInformationalMessagesFrame

SetOutputWindowAttributes

Method in class wx.App

SetOverflow

Method in class wx.grid.GridCellAttr

SetOvertype

Method in class wx.stc.StyledTextCtrl

SetOwnBackgroundColour

Method in class wx.Window

SetOwner

Method in class wx.Timer

SetOwnerDrawn

Method in class wx.MenuItem

SetOwnFont

Method in class wx.Window

SetOwnForegroundColour

Method in class wx.Window

SetPadding

Method in class wx.Notebook

SetPage

Method in class wx.html.HtmlWindow

SetPage

Method in class wx.lib.printout.PrintTable

SetPage

Method in class wx.lib.printout.PrintTableDraw

SetPageImage

Method in class wx.BookCtrlBase

SetPageSize

Method in class wx.BookCtrlBase

SetPageSize

Method in class wx.Slider

SetPageSize

Method in class wx.lib.printout.PrintTable

SetPageSize

Method in class wx.wizard.Wizard

SetPageSizeMM

Method in class wx.Printout

SetPageSizePixels

Method in class wx.Printout

SetPageSource

Method in class wx.webkit.WebKitCtrl

SetPageText

Method in class wx.BookCtrlBase

SetPalette

Method in class wx.DC

SetPaletteRealized

Method in class wx.QueryNewPaletteEvent

SetPaperId

Method in class wx.PageSetupDialogData

SetPaperId

Method in class wx.PrintData

SetPaperId

Method in class wx.lib.printout.PrintTable

SetPaperSize

Method in class wx.PageSetupDialogData

SetPaperSize

Method in class wx.PrintData

SetParameters

Method in class wx.grid.GridCellEditor

SetParameters

Method in class wx.grid.GridCellRenderer

SetParameters

Method in class wx.lib.masked.numctrl.NumCtrl

SetParameters

Method in class wx.lib.masked.timectrl.TimeCtrl

SetParent

Method in class wx.Menu

SetParent

Method in class wx.PyOnDemandOutputWindow

SetParent

Method in class wx.html.HtmlCell

SetParent

Method in class wx.lib.infoframe.Dummy_PyInformationalMessagesFrame

SetParent

Method in class wx.lib.infoframe.PyInformationalMessagesFrame

SetParent

Method in class wx.lib.mvctree.MVCTreeNode

SetParent

Method in class wx.lib.ogl.Shape

SetParent

Method in class wx.xrc.XmlNode

SetParentDocument

Method in class wx.lib.pydocview.ChildDocument

SetParentResource

Method in class wx.xrc.XmlResourceHandler

SetParms

Method in class wx.lib.printout.PrintTable

SetParser

Method in class wx.html.HtmlTagHandler

SetParser

Method in class wx.html.HtmlWinTagHandler

SetPath

Method in class wx.ConfigBase

SetPath

Method in class wx.DirDialog

SetPath

Method in class wx.FileDialog

SetPath

Method in class wx.GenericDirCtrl

SetPen

Method in class wx.DC

SetPen

Method in class wx.lib.floatcanvas.FloatCanvas.DrawObject

SetPen

Method in class wx.lib.ogl.PseudoMetaFile

SetPen

Method in class wx.lib.ogl.Shape

SetPenColour

Method in class wx.lib.ogl.ShapeRegion

SetPenStyle

Method in class wx.lib.ogl.ShapeRegion

SetPixelSize

Method in class wx.Font

SetPlaybackRate

Method in class wx.media.MediaCtrl

SetPoint

Method in class wx.TreeEvent

SetPoint

Method in class wx.lib.floatcanvas.FloatCanvas.XYObjectMixin

SetPointAdjust

Method in class wx.lib.printout.PrintTableDraw

SetPointLabelFunc

Method in class wx.lib.plot.PlotCanvas

SetPoints

Method in class wx.lib.floatcanvas.FloatCanvas.PointsObjectMixin

SetPointSize

Method in class wx.Font

SetPointSize

Method in class wx.NativeFontInfo

SetPolarCoordinates

Method in class wx.Point2D

SetPopupContent

Method in class wx.lib.popupctl.PopupControl

setPopupMenu

Method in class wx.lib.mixins.listctrl.ListCtrlSelectionManagerMix

SetPortrait

Method in class wx.lib.printout.PrintTable

SetPos

Method in class wx.GBSizerItem

SetPos

Method in class wx.html.HtmlCell

SetPos

Method in class wx.lib.calendar.CalDraw

SetPosition

Method in class wx.ContextMenuEvent

SetPosition

Method in class wx.HelpEvent

SetPosition

Method in class wx.JoystickEvent

SetPosition

Method in class wx.MoveEvent

SetPosition

Method in class wx.Rect

SetPosition

Method in class wx.ScrollEvent

SetPosition

Method in class wx.ScrollWinEvent

SetPosition

Method in class wx.SpinEvent

SetPosition

Method in class wx.animate.AnimationPlayer

SetPosition

Method in class wx.lib.hyperlink.HyperLinkEvent

SetPosition

Method in class wx.lib.ogl.ArrowHead

SetPosition

Method in class wx.lib.ogl.ShapeRegion

SetPosition

Method in class wx.stc.StyledTextEvent

SetPPF

Method in class wx.lib.ticker.Ticker

SetPPIPrinter

Method in class wx.Printout

SetPPIScreen

Method in class wx.Printout

SetPrecision

Method in class wx.grid.GridCellFloatRenderer

SetPrev

Method in class wx.wizard.WizardPageSimple

SetPreview

Method in class wx.lib.calendar.PrtCalDraw

SetPreview

Method in class wx.lib.printout.PrintBase

SetPreview

Method in class wx.lib.printout.PrintTable

SetPreviewCanvas

Method in class wx.PyPreviewFrame

SetPreviewCommand

Method in class wx.PrintData

SetPreviewSize

Method in class wx.lib.printout.PrintTable

SetPreviousHandler

Method in class wx.EvtHandler

SetPreviousHandler

Method in class wx.lib.ogl.ShapeEvtHandler

SetPrintColourMode

Method in class wx.stc.StyledTextCtrl

SetPrintData

Method in class wx.PageSetupDialogData

SetPrintData

Method in class wx.PostScriptDC

SetPrintData

Method in class wx.PrintDialogData

SetPrinterCommand

Method in class wx.PrintData

SetPrinterName

Method in class wx.PrintData

SetPrinterOffset

Method in class wx.lib.printout.PrintTable

SetPrinterOptions

Method in class wx.PrintData

setPrinterScale

Method in class wx.lib.plot.PlotGraphics

SetPrinterScaleX

Method in class wx.PrintData

SetPrinterScaleY

Method in class wx.PrintData

SetPrinterScaling

Method in class wx.PrintData

SetPrinterTranslateX

Method in class wx.PrintData

SetPrinterTranslateY

Method in class wx.PrintData

SetPrinterTranslation

Method in class wx.PrintData

SetPrintFont

Method in class wx.lib.printout.PrintBase

SetPrintMagnification

Method in class wx.stc.StyledTextCtrl

SetPrintMode

Method in class wx.PrintData

SetPrintMode

Method in class wx.PyApp

SetPrintout

Method in class wx.PrintPreview

SetPrintout

Class in module wx.lib.printout

SetPrintPreview

Method in class wx.PyPreviewControlBar

SetPrintToFile

Method in class wx.PrintDialogData

SetPrintWrapMode

Method in class wx.stc.StyledTextCtrl

SetPrivData

Method in class wx.PrintData

SetProjectionFun

Method in class wx.lib.floatcanvas.FloatCanvas.FloatCanvas

SetProperties

Method in class wx.lib.pyshell.PyShellWindow

SetProperties

Method in class wx.xrc.XmlNode

SetProperty

Method in class wx.stc.StyledTextCtrl

SetProportion

Method in class wx.SizerItem

SetProportions

Method in class wx.lib.ogl.ShapeRegion

SetPSize

Method in class wx.lib.calendar.PrtCalDraw

SetPSize

Method in class wx.lib.printout.PrintBase

SetPTSize

Method in class wx.lib.printout.PrintBase

SetQuality

Method in class wx.PrintData

SetQuickEditMode

Method in class wx.lib.ogl.Diagram

SetRange

Method in class wx.DatePickerCtrl

SetRange

Method in class wx.FontData

SetRange

Method in class wx.Gauge

SetRange

Method in class wx.Slider

SetRange

Method in class wx.SpinButton

SetRange

Method in class wx.SpinCtrl

SetRatio

Method in class wx.SizerItem

SetRatioSize

Method in class wx.SizerItem

SetRatioWH

Method in class wx.SizerItem

SetReadOnly

Method in class wx.grid.Grid

SetReadOnly

Method in class wx.grid.GridCellAttr

SetReadOnly

Method in class wx.stc.StyledTextCtrl

SetRecordDefaults

Method in class wx.ConfigBase

SetRect

Method in class wx.CalculateLayoutEvent

SetRect

Method in class wx.MoveEvent

SetRect

Method in class wx.SizeEvent

SetRect

Method in class wx.Window

SetRedoAccelerator

Method in class wx.lib.docview.CommandProcessor

SetRegionName

Method in class wx.lib.ogl.Shape

SetRegionSizes

Method in class wx.lib.ogl.DividedShape

SetRelatedFrame

Method in class wx.html.HtmlWindow

SetRelatedStatusBar

Method in class wx.html.HtmlWindow

SetRelationship

Method in class wx.IndividualLayoutConstraint

SetRenderer

Method in class wx.grid.GridCellAttr

SetReplaceString

Method in class wx.FindDialogEvent

SetReplaceString

Method in class wx.FindReplaceData

SetRequestedLength

Method in class wx.QueryLayoutInfoEvent

setResizeColumn

Method in class wx.lib.mixins.listctrl.ListCtrlAutoWidthMixin

SetResolution

Method in class wx.PostScriptDC

SetRetainFieldValidation

Method in class wx.lib.masked.ipaddrctrl.IpAddrCtrlAccessorsMixin

SetRetainFieldValidation

Method in class wx.lib.masked.maskededit.MaskedEditAccessorsMixin

SetReturnCode

Method in class wx.Dialog

SetRGB

Method in class wx.Colour

SetRGB

Method in class wx.Image

SetRGBRect

Method in class wx.Image

SetRight

Method in class wx.Rect

SetRightIndent

Method in class wx.TextAttr

SetRightIndent

Method in class wx.lib.foldpanelbar.CaptionBar

SetRightSide

Method in class wx.lib.ogl.DivisionShape

SetRoot

Method in class wx.lib.mvctree.BasicTreeModel

SetRoot

Method in class wx.lib.mvctree.TreeModel

SetRoot

Method in class wx.xrc.XmlDocument

SetRotateable

Method in class wx.lib.ogl.PseudoMetaFile

SetRotation

Method in class wx.lib.ogl.Shape

SetRow

Method in class wx.GBPosition

SetRow

Method in class wx.grid.GridCellCoords

SetRow

Method in class wx.grid.GridEditorCreatedEvent

SetRowAttr

Method in class wx.grid.Grid

SetRowAttr

Method in class wx.grid.GridCellAttrProvider

SetRowAttr

Method in class wx.grid.GridTableBase

SetRowLabelAlignment

Method in class wx.grid.Grid

SetRowLabelSize

Method in class wx.grid.Grid

SetRowLabelValue

Method in class wx.grid.Grid

SetRowLabelValue

Method in class wx.grid.GridTableBase

SetRowLineColour

Method in class wx.lib.printout.PrintTable

SetRowLineSize

Method in class wx.lib.printout.PrintTable

SetRowMinimalAcceptableHeight

Method in class wx.grid.Grid

SetRowMinimalHeight

Method in class wx.grid.Grid

SetRows

Method in class wx.GridSizer

SetRows

Method in class wx.ToolBarBase

SetRows

Method in class wx.lib.grids.PyGridSizer

SetRowSize

Method in class wx.grid.Grid

SetRowSpacing

Method in class wx.lib.printout.PrintTable

SetRowspan

Method in class wx.GBSpan

SetSashBorder

Method in class wx.SashWindow

SetSashGravity

Method in class wx.SplitterWindow

SetSashPosition

Method in class wx.SplitterEvent

SetSashPosition

Method in class wx.SplitterWindow

SetSashSize

Method in class wx.SplitterWindow

SetSashVisible

Method in class wx.SashWindow

SetSaveData

Method in class wx.lib.multisash.MultiSash

SetSaveData

Method in class wx.lib.multisash.MultiSplit

SetSaveData

Method in class wx.lib.multisash.MultiViewLeaf

setSavePoint

Method in class wx.py.editor.Editor

SetSavePoint

Method in class wx.stc.StyledTextCtrl

SetSaveToFile

Method in class wx.lib.ogl.DrawnShape

SetScale

Method in class wx.ScrolledWindow

SetScale

Method in class wx.gizmos.StaticPicture

SetScale

Method in class wx.lib.printout.PrintBase

SetScreenType

Method in class wx.SystemSettings

SetScrollbar

Method in class wx.ScrollBar

SetScrollbar

Method in class wx.Window

SetScrollbars

Method in class wx.ScrolledWindow

SetScrollbars

Method in class wx.lib.editor.editor.Scroller

SetScrollLineX

Method in class wx.grid.Grid

SetScrollLineY

Method in class wx.grid.Grid

SetScrollPageSize

Method in class wx.ScrolledWindow

SetScrollPos

Method in class wx.Window

SetScrollRate

Method in class wx.ScrolledWindow

SetScrollTimer

Method in class wx.lib.editor.editor.Editor

SetScrollWidth

Method in class wx.stc.StyledTextCtrl

SetSearchFlags

Method in class wx.stc.StyledTextCtrl

SetSecond

Method in class wx.DateTime

SetSecondColour

Method in class wx.lib.foldpanelbar.CaptionBarStyle

SetSelBackground

Method in class wx.stc.StyledTextCtrl

SetSelDay

Method in class wx.lib.calendar.Calendar

SetSelectedImage

Method in class wx.gizmos.TreeListColumnInfo

SetSelection

Method in class wx.BookCtrlBase

SetSelection

Method in class wx.BookCtrlBaseEvent

SetSelection

Method in class wx.ComboBox

SetSelection

Method in class wx.ItemContainer

SetSelection

Method in class wx.ListBox

SetSelection

Method in class wx.PrintDialogData

SetSelection

Method in class wx.RadioBox

SetSelection

Method in class wx.SingleChoiceDialog

SetSelection

Method in class wx.Slider

SetSelection

Method in class wx.SpinCtrl

SetSelection

Method in class wx.TextCtrl

SetSelection

Method in class wx.VListBox

SetSelection

Method in class wx.html.HtmlRenderingInfo

SetSelection

Method in class wx.lib.masked.combobox.BaseMaskedComboBox

SetSelection

Method in class wx.lib.masked.timectrl.TimeCtrl

SetSelection

Method in class wx.lib.mvctree.MVCTree

SetSelection

Method in class wx.stc.StyledTextCtrl

SetSelectionBackground

Method in class wx.VListBox

SetSelectionBackground

Method in class wx.grid.Grid

SetSelectionEnd

Method in class wx.stc.StyledTextCtrl

SetSelectionForeground

Method in class wx.grid.Grid

SetSelectionMode

Method in class wx.grid.Grid

SetSelectionMode

Method in class wx.stc.StyledTextCtrl

SetSelections

Method in class wx.MultiChoiceDialog

SetSelectionStart

Method in class wx.stc.StyledTextCtrl

SetSelectionState

Method in class wx.html.HtmlRenderingState

SetSelectOnEntry

Method in class wx.lib.masked.numctrl.NumCtrl

SetSelForeground

Method in class wx.stc.StyledTextCtrl

SetSensitivityFilter

Method in class wx.lib.ogl.Shape

SetSetupDialog

Method in class wx.PrintDialogData

SetShadowColour

Method in class wx.lib.analogclock.AnalogClockWindow

SetShadowMode

Method in class wx.lib.ogl.Shape

SetShadowWidth

Method in class wx.Gauge

SetShape

Method in class wx.TopLevelWindow

SetShape

Method in class wx.lib.floatcanvas.FloatCanvas.RectEllipse

SetShape

Method in class wx.lib.ogl.Shape

SetShape

Method in class wx.lib.ogl.ShapeEvtHandler

SetShiftDecimalChar

Method in class wx.lib.masked.maskededit.MaskedEditAccessorsMixin

SetShiftDecimalChar

Method in class wx.lib.masked.numctrl.NumCtrlAccessorsMixin

SetShiftFuncs

Method in class wx.lib.editor.editor.Editor

SetShortDesc

Method in class wx.FileTypeInfo

SetShortHelp

Method in class wx.ToolBarToolBase

SetShow

Method in class wx.ShowEvent

SetShowHelp

Method in class wx.FontData

SetShown

Method in class wx.gizmos.TreeListColumnInfo

SetSignedForegroundColour

Method in class wx.lib.masked.ipaddrctrl.IpAddrCtrlAccessorsMixin

SetSignedForegroundColour

Method in class wx.lib.masked.maskededit.MaskedEditAccessorsMixin

SetSignedForegroundColour

Method in class wx.lib.masked.numctrl.NumCtrlAccessorsMixin

SetSingleInstance

Method in class wx.lib.pydocview.DocApp

SetSingleStyle

Method in class wx.ListCtrl

SetSize

Method in class wx.Bitmap

SetSize

Method in class wx.Caret

SetSize

Method in class wx.QueryLayoutInfoEvent

SetSize

Method in class wx.Rect

SetSize

Method in class wx.SizeEvent

SetSize

Method in class wx.Window

SetSize

Method in class wx.grid.GridCellAttr

SetSize

Method in class wx.grid.GridCellEditor

SetSize

Method in class wx.html.HtmlDCRenderer

SetSize

Method in class wx.lib.calendar.CalDraw

SetSize

Method in class wx.lib.calendar.Calendar

SetSize

Method in class wx.lib.ogl.ArrowHead

SetSize

Method in class wx.lib.ogl.BitmapShape

SetSize

Method in class wx.lib.ogl.CompositeShape

SetSize

Method in class wx.lib.ogl.DividedShape

SetSize

Method in class wx.lib.ogl.DivisionShape

SetSize

Method in class wx.lib.ogl.DrawnShape

SetSize

Method in class wx.lib.ogl.EllipseShape

SetSize

Method in class wx.lib.ogl.PolygonShape

SetSize

Method in class wx.lib.ogl.PseudoMetaFile

SetSize

Method in class wx.lib.ogl.RectangleShape

SetSize

Method in class wx.lib.ogl.Shape

SetSize

Method in class wx.lib.ogl.ShapeRegion

SetSize

Method in class wx.lib.sheet.CCellEditor

SetSizeHints

Method in class wx.Sizer

SetSizeHints

Method in class wx.Window

SetSizeHintsSz

Method in class wx.Window

SetSizer

Method in class wx.SizerItem

SetSizer

Method in class wx.Window

SetSizerAndFit

Method in class wx.Window

SetSizeWH

Method in class wx.Caret

SetSizeWH

Method in class wx.Window

SetSnapToGrid

Method in class wx.lib.ogl.Diagram

SetSpaceAttachments

Method in class wx.lib.ogl.Shape

SetSpacer

Method in class wx.SizerItem

SetSpacing

Method in class wx.TreeCtrl

SetSpacing

Method in class wx.lib.ogl.ArrowHead

SetSpacing

Method in class wx.lib.ogl.Constraint

SetSpan

Method in class wx.GBSizerItem

SetSpecialControlFuncs

Method in class wx.lib.editor.editor.Editor

SetSpecialFuncs

Method in class wx.lib.editor.editor.Editor

SetSpline

Method in class wx.lib.ogl.LineShape

SetSplitMode

Method in class wx.SplitterWindow

SetStandardFonts

Method in class wx.html.HtmlDCRenderer

SetStandardFonts

Method in class wx.html.HtmlEasyPrinting

SetStandardFonts

Method in class wx.html.HtmlPrintout

SetStandardFonts

Method in class wx.html.HtmlWinParser

SetStandardFonts

Method in class wx.html.HtmlWindow

SetStart

Method in class wx.html.HtmlBookRecord

SetState

Method in class wx.ListItem

SetState

Method in class wx.webkit.WebKitStateChangedEvent

SetStateImageList

Method in class wx.TreeCtrl

SetStateImageList

Method in class wx.gizmos.TreeListCtrl

SetStateMask

Method in class wx.ListItem

SetStatus

Method in class wx.stc.StyledTextCtrl

SetStatusBar

Method in class wx.Frame

SetStatusBarPane

Method in class wx.Frame

SetStatusStyles

Method in class wx.StatusBar

SetStatusText

Method in class wx.Frame

SetStatusText

Method in class wx.StatusBar

setStatusText

Method in class wx.py.filling.FillingTree

setStatusText

Method in class wx.py.shell.Shell

SetStatusWidths

Method in class wx.Frame

SetStatusWidths

Method in class wx.StatusBar

SetSTCCursor

Method in class wx.stc.StyledTextCtrl

SetSTCFocus

Method in class wx.stc.StyledTextCtrl

SetStipple

Method in class wx.Brush

SetStream

Method in class wx.tools.dbg.Logger

SetString

Method in class wx.ComboBox

SetString

Method in class wx.CommandEvent

SetString

Method in class wx.ItemContainer

SetString

Method in class wx.RadioBox

SetStringItem

Method in class wx.ListCtrl

SetStrings

Method in class wx.gizmos.EditableListBox

SetStringSelection

Method in class wx.ComboBox

SetStringSelection

Method in class wx.ItemContainer

SetStringSelection

Method in class wx.ListBox

SetStringSelection

Method in class wx.RadioBox

SetStyle

Method in class wx.Brush

SetStyle

Method in class wx.ConfigBase

SetStyle

Method in class wx.FileDialog

SetStyle

Method in class wx.Font

SetStyle

Method in class wx.NativeFontInfo

SetStyle

Method in class wx.Pen

SetStyle

Method in class wx.TextCtrl

SetStyle

Method in class wx.html.HtmlRenderingInfo

SetStyleBits

Method in class wx.stc.StyledTextCtrl

SetStyleBytes

Method in class wx.stc.StyledTextCtrl

setStyles

Method in class wx.py.editwindow.EditWindow

SetStyling

Method in class wx.stc.StyledTextCtrl

SetSubMenu

Method in class wx.MenuItem

SetSupportedModes

Method in class wx.lib.pydocview.DocOptionsService

SetSuspend

Method in class wx.tools.dbg.Logger

SetTabIndents

Method in class wx.stc.StyledTextCtrl

SetTable

Method in class wx.grid.Grid

SetTableObject

Method in class wx.grid.GridTableMessage

SetTabs

Method in class wx.TextAttr

SetTabSize

Method in class wx.Notebook

SetTabWidth

Method in class wx.stc.StyledTextCtrl

SetTag

Method in class wx.lib.foldpanelbar.CaptionBarEvent

SetTarget

Method in class wx.HelpEvent

SetTargetEnd

Method in class wx.stc.StyledTextCtrl

SetTargetStart

Method in class wx.stc.StyledTextCtrl

SetTargetWindow

Method in class wx.ScrolledWindow

SetTempDir

Method in class wx.html.HtmlHelpController

SetTempDir

Method in class wx.html.HtmlHelpData

SetText

Method in class wx.ListItem

SetText

Method in class wx.MenuItem

SetText

Method in class wx.TextDataObject

SetText

Method in class wx.UpdateUIEvent

SetText

Method in class wx.gizmos.TreeListColumnInfo

SetText

Method in class wx.lib.editor.editor.Editor

SetText

Method in class wx.lib.ogl.ShapeRegion

SetText

Method in class wx.lib.ogl.ShapeTextLine

SetText

Method in class wx.lib.ticker.Ticker

setText

Method in class wx.py.editor.Editor

SetText

Method in class wx.py.filling.FillingText

setText

Method in class wx.py.filling.FillingTree

SetText

Method in class wx.stc.StyledTextCtrl

SetText

Method in class wx.stc.StyledTextEvent

SetTextAlign

Method in class wx.lib.calendar.Calendar

SetTextBackground

Method in class wx.DC

SetTextColour

Method in class wx.ListCtrl

SetTextColour

Method in class wx.ListItem

SetTextColour

Method in class wx.ListItemAttr

SetTextColour

Method in class wx.MenuItem

SetTextColour

Method in class wx.TextAttr

SetTextColour

Method in class wx.calendar.CalendarDateAttr

SetTextColour

Method in class wx.grid.GridCellAttr

SetTextColour

Method in class wx.lib.mvctree.Painter

SetTextColour

Method in class wx.lib.ogl.PseudoMetaFile

SetTextColour

Method in class wx.lib.ogl.Shape

SetTextForeground

Method in class wx.DC

SetTextLine

Method in class wx.lib.editor.editor.Editor

SetTextRaw

Method in class wx.stc.StyledTextCtrl

SetTextUTF8

Method in class wx.stc.StyledTextCtrl

SetThemeEnabled

Method in class wx.Window

SetThumbLength

Method in class wx.Slider

SetThumbPosition

Method in class wx.ScrollBar

SetTick

Method in class wx.Slider

SetTickColours

Method in class wx.lib.analogclock.AnalogClockWindow

SetTickFonts

Method in class wx.lib.analogclock.AnalogClockWindow

SetTickFreq

Method in class wx.Slider

SetTickShapes

Method in class wx.lib.analogclock.AnalogClockWindow

SetTickSizes

Method in class wx.lib.analogclock.AnalogClockWindow

SetTickStyles

Method in class wx.lib.analogclock.AnalogClockWindow

SetTimestamp

Method in class wx.Event

SetTimestamp

Method in class wx.Log

SetTimeT

Method in class wx.DateTime

SetTip

Method in class wx.ToolTip

SetTitle

Method in class wx.Menu

SetTitle

Method in class wx.TopLevelWindow

SetTitle

Method in class wx.Window

SetTitle

Method in class wx.html.HtmlBookRecord

SetTitle

Method in class wx.html.HtmlWindow

SetTitle

Method in class wx.lib.docview.Document

SetTitle

Method in class wx.lib.floatbar.FloatBar

setTitle

Method in class wx.lib.plot.PlotGraphics

SetTitle

Method in class wx.lib.pydocview.DocTabbedChildFrame

SetTitleFormat

Method in class wx.html.HtmlHelpController

SetTitleFormat

Method in class wx.html.HtmlHelpFrame

SetTmpDefaultItem

Method in class wx.Window

SetTo

Method in class wx.lib.ogl.LineShape

SetToCurrent

Method in class wx.DateTime

SetToggle

Method in class wx.ToolBarBase

SetToggle

Method in class wx.ToolBarToolBase

SetToLastMonthDay

Method in class wx.DateTime

SetToLastWeekDay

Method in class wx.DateTime

SetToNextWeekDay

Method in class wx.DateTime

SetToolBar

Method in class wx.Frame

SetToolBitmapSize

Method in class wx.ToolBarBase

SetToolClientData

Method in class wx.ToolBarBase

SetToolLongHelp

Method in class wx.ToolBarBase

SetToolMode

Method in class wx.lib.floatcanvas.NavCanvas.NavCanvas

SetToolPacking

Method in class wx.ToolBarBase

SetToolSeparation

Method in class wx.ToolBarBase

SetToolShortHelp

Method in class wx.ToolBarBase

SetToolTip

Method in class wx.TreeEvent

SetToolTip

Method in class wx.Window

SetToolTipString

Method in class wx.Window

SetTop

Method in class wx.Rect

SetToPage

Method in class wx.PrintDialogData

SetTopLeft

Method in class wx.Rect

SetToPrevWeekDay

Method in class wx.DateTime

SetToPrivPos

Method in class wx.html.HtmlSelection

SetTopSide

Method in class wx.lib.ogl.DivisionShape

SetTopSideColour

Method in class wx.lib.ogl.DivisionShape

SetTopSidePen

Method in class wx.lib.ogl.DivisionShape

SetTopSideStyle

Method in class wx.lib.ogl.DivisionShape

SetTopWindow

Method in class wx.App

SetTopWindow

Method in class wx.PyApp

SetTotalSize

Method in class wx.lib.printout.PrintTable

SetToWeekDay

Method in class wx.DateTime

SetToWeekDayInSameWeek

Method in class wx.DateTime

SetToWeekOfYear

Method in class wx.DateTime

SetToYearDay

Method in class wx.DateTime

SetTraceMask

Method in class wx.Log

SetTreeCtrl

Method in class wx.gizmos.TreeCompanionWindow

SetTwoPhaseDraw

Method in class wx.stc.StyledTextCtrl

SetType

Method in class wx.DataFormat

SetType

Method in class wx.ImageHandler

SetType

Method in class wx.xrc.XmlNode

SetUnderlined

Method in class wx.Font

SetUnderlined

Method in class wx.NativeFontInfo

SetUnderlines

Method in class wx.lib.hyperlink.HyperLinkCtrl

SetUndoAccelerator

Method in class wx.lib.docview.CommandProcessor

SetUndoCollection

Method in class wx.stc.StyledTextCtrl

Setup

Method in class wx.Printer

SetUpdateInterval

Method in class wx.UpdateUIEvent

SetUpDraw

Method in class wx.lib.floatcanvas.FloatCanvas.RectEllipse

SetupIcons

Method in class wx.lib.mixins.imagelist.MagicImageList

SetupPalette

Method in class wx.glcanvas.GLContext

SetUpperDateLimit

Method in class wx.calendar.CalendarCtrl

SetupPixelFormat

Method in class wx.glcanvas.GLContext

SetupScrolling

Method in class wx.lib.scrolledpanel.ScrolledPanel

SetupWindow

Method in class wx.xrc.XmlResourceHandler

SetURL

Method in class wx.URLDataObject

SetURL

Method in class wx.lib.hyperlink.HyperLinkCtrl

SetURL

Method in class wx.webkit.WebKitStateChangedEvent

SetUseAntiAliasing

Method in class wx.stc.StyledTextCtrl

SetUseBestVisual

Method in class wx.PyApp

SetUseFixedWidthFont

Method in class wx.lib.masked.ipaddrctrl.IpAddrCtrlAccessorsMixin

SetUseFixedWidthFont

Method in class wx.lib.masked.maskededit.MaskedEditAccessorsMixin

SetUseFixedWidthFont

Method in class wx.lib.masked.numctrl.NumCtrlAccessorsMixin

SetUseFixedWidthFont

Method in class wx.lib.masked.timectrl.TimeCtrlAccessorsMixin

SetUseFocusIndicator

Method in class wx.lib.buttons.GenButton

SetUseHorizontalScrollBar

Method in class wx.stc.StyledTextCtrl

SetUseParensForNegatives

Method in class wx.lib.masked.maskededit.MaskedEditAccessorsMixin

SetUseParensForNegatives

Method in class wx.lib.masked.numctrl.NumCtrlAccessorsMixin

SetUserScale

Method in class wx.DC

SetUseTabbedMDI

Method in class wx.lib.pydocview.DocApp

SetUseTabs

Method in class wx.stc.StyledTextCtrl

SetUseVerticalScrollBar

Method in class wx.stc.StyledTextCtrl

SetValidator

Method in class wx.Window

SetValidBackgroundColour

Method in class wx.lib.masked.ipaddrctrl.IpAddrCtrlAccessorsMixin

SetValidBackgroundColour

Method in class wx.lib.masked.maskededit.MaskedEditAccessorsMixin

SetValidBackgroundColour

Method in class wx.lib.masked.numctrl.NumCtrlAccessorsMixin

SetValidBackgroundColour

Method in class wx.lib.masked.timectrl.TimeCtrlAccessorsMixin

SetValidFunc

Method in class wx.lib.masked.ipaddrctrl.IpAddrCtrlAccessorsMixin

SetValidFunc

Method in class wx.lib.masked.maskededit.MaskedEditAccessorsMixin

SetValidFunc

Method in class wx.lib.masked.numctrl.NumCtrlAccessorsMixin

SetValidFunc

Method in class wx.lib.masked.timectrl.TimeCtrlAccessorsMixin

SetValidRange

Method in class wx.lib.masked.maskededit.MaskedEditAccessorsMixin

SetValidRegex

Method in class wx.lib.masked.maskededit.MaskedEditAccessorsMixin

SetValidRequired

Method in class wx.lib.masked.ipaddrctrl.IpAddrCtrlAccessorsMixin

SetValidRequired

Method in class wx.lib.masked.maskededit.MaskedEditAccessorsMixin

SetValidRequired

Method in class wx.lib.masked.numctrl.NumCtrlAccessorsMixin

SetValidRequired

Method in class wx.lib.masked.timectrl.TimeCtrlAccessorsMixin

SetValue

Method in class wx.CheckBox

SetValue

Method in class wx.ComboBox

SetValue

Method in class wx.DatePickerCtrl

SetValue

Method in class wx.Gauge

SetValue

Method in class wx.IndividualLayoutConstraint

SetValue

Method in class wx.RadioButton

SetValue

Method in class wx.Slider

SetValue

Method in class wx.SpinButton

SetValue

Method in class wx.SpinCtrl

SetValue

Method in class wx.TextCtrl

SetValue

Method in class wx.TextEntryDialog

SetValue

Method in class wx.ToggleButton

SetValue

Method in class wx.gizmos.LEDNumberCtrl

SetValue

Method in class wx.grid.GridTableBase

SetValue

Method in class wx.lib.colourchooser.pycolourchooser.PyColourChooser

SetValue

Method in class wx.lib.colourselect.ColourSelect

SetValue

Method in class wx.lib.filebrowsebutton.FileBrowseButton

SetValue

Method in class wx.lib.imagebrowser.ImageView

SetValue

Method in class wx.lib.intctrl.IntCtrl

SetValue

Method in class wx.lib.masked.combobox.BaseMaskedComboBox

SetValue

Method in class wx.lib.masked.ipaddrctrl.IpAddrCtrl

SetValue

Method in class wx.lib.masked.numctrl.NumCtrl

SetValue

Method in class wx.lib.masked.textctrl.BaseMaskedTextCtrl

SetValue

Method in class wx.lib.masked.timectrl.TimeCtrl

SetValue

Method in class wx.lib.popupctl.PopupControl

SetValue

Method in class wx.xrc.XmlProperty

SetValueAsBool

Method in class wx.grid.GridTableBase

SetValueAsDouble

Method in class wx.grid.GridTableBase

SetValueAsLong

Method in class wx.grid.GridTableBase

SetValueString

Method in class wx.SpinCtrl

SetVectorAngle

Method in class wx.Point2D

SetVectorLength

Method in class wx.Point2D

SetVendorName

Method in class wx.ConfigBase

SetVendorName

Method in class wx.PyApp

SetVerbose

Method in class wx.Log

SetVersion

Method in class wx.xrc.XmlDocument

SetVGap

Method in class wx.GridSizer

SetVgap

Method in class wx.lib.grids.PyGridSizer

SetView

Method in class wx.grid.GridTableBase

SetView

Method in class wx.lib.docview.DocChildFrame

SetView

Method in class wx.lib.docview.DocMDIChildFrame

SetView

Method in class wx.lib.pydocview.DocMDIChildFrame

SetView

Method in class wx.lib.pydocview.DocTabbedChildFrame

SetViewEOL

Method in class wx.stc.StyledTextCtrl

SetViewName

Method in class wx.lib.docview.View

SetViewWhiteSpace

Method in class wx.stc.StyledTextCtrl

SetVirtualSize

Method in class wx.Window

SetVirtualSizeHints

Method in class wx.Sizer

SetVirtualSizeHints

Method in class wx.Window

SetVirtualSizeHintsSz

Method in class wx.Window

SetVirtualSizeWH

Method in class wx.Window

SetVisible

Method in class wx.GDIObject

SetVisiblePolicy

Method in class wx.stc.StyledTextCtrl

SetVisited

Method in class wx.lib.hyperlink.HyperLinkCtrl

SetVolume

Method in class wx.media.MediaCtrl

SetVScrollBar

Method in class wx.stc.StyledTextCtrl

SetWatchPenBrush

Method in class wx.lib.analogclock.AnalogClockWindow

SetWeekColor

Method in class wx.lib.calendar.CalDraw

SetWeekColor

Method in class wx.lib.calendar.Calendar

SetWeekDay

Method in class wx.calendar.CalendarEvent

SetWeekEnd

Method in class wx.lib.calendar.CalDraw

SetWeeks

Method in class wx.DateSpan

SetWeight

Method in class wx.Font

SetWeight

Method in class wx.NativeFontInfo

SetWhitespaceBackground

Method in class wx.stc.StyledTextCtrl

SetWhitespaceChars

Method in class wx.stc.StyledTextCtrl

SetWhitespaceForeground

Method in class wx.stc.StyledTextCtrl

SetWidget

Method in class wx.PyWidgetTester

SetWidth

Method in class wx.Bitmap

SetWidth

Method in class wx.Icon

SetWidth

Method in class wx.ListItem

SetWidth

Method in class wx.Pen

SetWidth

Method in class wx.Rect

SetWidth

Method in class wx.Size

SetWidth

Method in class wx.gizmos.TreeListColumnInfo

SetWidth

Method in class wx.grid.GridCellFloatRenderer

SetWidth

Method in class wx.lib.ogl.EllipseShape

SetWidth

Method in class wx.lib.ogl.RectangleShape

SetWidthFloat

Method in class wx.html.HtmlContainerCell

SetWidthFloatFromTag

Method in class wx.html.HtmlContainerCell

SetWildcard

Method in class wx.FileDialog

SetWindow

Method in class wx.FocusEvent

SetWindow

Method in class wx.SizerItem

SetWindow

Method in class wx.Validator

SetWindow

Method in class wx.animate.AnimationPlayer

SetWindowChange

Method in class wx.NavigationKeyEvent

SetWindowStyleFlag

Method in class wx.ListCtrl

SetWindowStyleFlag

Method in class wx.Window

SetWindowVariant

Method in class wx.Window

SetWobbleTolerance

Method in class wx.lib.gestures.MouseGestures

SetWordChars

Method in class wx.stc.StyledTextCtrl

SetWParam

Method in class wx.stc.StyledTextEvent

SetWrapMode

Method in class wx.stc.StyledTextCtrl

SetWrapStartIndent

Method in class wx.stc.StyledTextCtrl

SetWrapVisualFlags

Method in class wx.stc.StyledTextCtrl

SetWrapVisualFlagsLocation

Method in class wx.stc.StyledTextCtrl

SetWriteable

Method in class wx.lib.docview.Document

SetWxDateTime

Method in class wx.lib.masked.timectrl.TimeCtrl

SetWxLog

Method in class wx.tools.dbg.Logger

SetX

Method in class wx.Rect

SetX

Method in class wx.lib.ogl.Shape

SetX

Method in class wx.lib.ogl.ShapeTextLine

SetX

Method in class wx.stc.StyledTextEvent

SetXCaretPolicy

Method in class wx.stc.StyledTextCtrl

setXLabel

Method in class wx.lib.plot.PlotGraphics

SetXOffset

Method in class wx.lib.ogl.ArrowHead

SetXOffset

Method in class wx.stc.StyledTextCtrl

SetXSpec

Method in class wx.lib.plot.PlotCanvas

SetXY

Method in class wx.lib.floatcanvas.FloatCanvas.XYObjectMixin

SetY

Method in class wx.Rect

SetY

Method in class wx.lib.ogl.Shape

SetY

Method in class wx.lib.ogl.ShapeTextLine

SetY

Method in class wx.stc.StyledTextEvent

SetYCaretPolicy

Method in class wx.stc.StyledTextCtrl

SetYear

Method in class wx.DateTime

SetYear

Method in class wx.lib.calendar.Calendar

SetYears

Method in class wx.DateSpan

setYLabel

Method in class wx.lib.plot.PlotGraphics

SetYOffset

Method in class wx.lib.ogl.ArrowHead

SetYSpec

Method in class wx.lib.plot.PlotCanvas

SetZoom

Method in class wx.PrintPreview

SetZoom

Method in class wx.stc.StyledTextCtrl

SetZoomControl

Method in class wx.PreviewControlBar

SetZPosition

Method in class wx.JoystickEvent

SH_SIZE

Variable in module wx.lib.multisash

Shape

Class in package wx.lib.ogl

ShapeCanvas

Class in package wx.lib.ogl

ShapeEvtHandler

Class in package wx.lib.ogl

ShapeRegion

Class in package wx.lib.ogl

ShapeTextLine

Class in package wx.lib.ogl

sheet

Module in package wx.lib

Shell

Function in package wx

shell

Module in package wx.lib

shell

Module in package wx.py

Shell

Class in module wx.py.shell

ShellFacade

Class in module wx.py.shell

ShellFrame

Class in module wx.py.shell

ShiftDown

Method in class wx.KeyEvent

ShiftDown

Method in class wx.MouseEvent

ShiftDown

Method in class wx.grid.GridEvent

ShiftDown

Method in class wx.grid.GridRangeSelectEvent

ShiftDown

Method in class wx.grid.GridSizeEvent

ShiftFunDict

Variable in class wx.lib.floatcanvas.FloatCanvas.TextObjectMixin

ShiftFunDict

Variable in class wx.lib.floatcanvas.FloatCanvas.TextObjectMixin

ShiftFunDict

Variable in class wx.lib.floatcanvas.FloatCanvas.TextObjectMixin

ShiftKey

Method in class wx.lib.editor.editor.Editor

ShouldInheritColours

Method in class wx.Window

ShouldInheritColours

Method in class wx.lib.buttons.GenButton

ShouldInheritColours

Method in class wx.lib.statbmp.GenStaticBitmap

ShouldInheritColours

Method in class wx.lib.stattext.GenStaticText

ShouldInheritColours

Method in class wx.lib.ticker.Ticker

ShouldPropagate

Method in class wx.Event

Show

Method in class wx.Caret

Show

Method in class wx.DragImage

Show

Method in class wx.LogWindow

Show

Method in class wx.Sizer

Show

Method in class wx.SizerItem

Show

Method in class wx.Window

Show

Method in class wx.grid.GridCellEditor

Show

Method in class wx.lib.ogl.Shape

Show

Method in class wx.lib.sheet.CCellEditor

ShowAbout

Method in class wx.lib.pydocview.AboutService

ShowAll

Method in class wx.lib.ogl.Diagram

ShowCellEditControl

Method in class wx.grid.Grid

ShowColumn

Method in class wx.gizmos.TreeListCtrl

ShowEmbeddedWindow

Method in class wx.lib.pydocview.DocMDIParentFrameMixIn

ShowEvent

Class in package wx

ShowException

Method in class wx.lib.shell.PyShell

ShowFullScreen

Method in class wx.TopLevelWindow

ShowHelp

Method in class wx.HelpProvider

ShowHidden

Method in class wx.GenericDirCtrl

showIntro

Method in class wx.py.shell.Shell

ShowItem

Method in class wx.RadioBox

ShowItems

Method in class wx.Sizer

ShowLines

Method in class wx.stc.StyledTextCtrl

ShowModal

Method in class wx.Dialog

ShowModal

Method in class wx.PageSetupDialog

ShowModal

Method in class wx.PrintDialog

ShowPage

Method in class wx.wizard.Wizard

ShowPosition

Method in class wx.TextCtrl

ShowPropertiesDialog

Method in class wx.lib.pydocview.FilePropertiesService

ShowSplash

Method in class wx.lib.pydocview.DocApp

showsyntaxerror

Method in class code.InteractiveInterpreter

showsyntaxerror

Method in class wx.lib.pyshell.PyShellWindow

ShowSyntaxError

Method in class wx.lib.shell.PyShell

ShowTip

Function in package wx

ShowTip

Method in class wx.lib.pydocview.DocApp

showtraceback

Method in class code.InteractiveInterpreter

showtraceback

Method in class wx.lib.pyshell.PyShellWindow

ShowWeekEnd

Method in class wx.lib.calendar.Calendar

ShrinkBy

Method in class wx.Image

Shutdown

Function in package wx

SimpleHelpProvider

Class in package wx

SIMPLETYPES

Variable in module wx.py.filling

SingleChoiceDialog

Class in package wx

singleChoiceDialog

Function in module wx.lib.dialogs

SingleInstanceChecker

Class in package wx

SingleLineCopy

Method in class wx.lib.editor.editor.Editor

SingleLineDelete

Method in class wx.lib.editor.editor.Editor

SingleLineInsert

Method in class wx.lib.editor.editor.Editor

Size

Method in class wx.Image

size

Method in class wx.Image in class wx.Rect

Size

Class in package wx

SizeEvent

Class in package wx

SizeLeaf

Method in class wx.lib.multisash.MultiSplit

Sizer

Class in package wx

SizerItem

Class in package wx

SizerItemSizer

Function in package wx

SizerItemSpacer

Function in package wx

SizerItemWindow

Function in package wx

SizeTarget

Method in class wx.lib.multisash.MultiSplit

SizeTarget

Method in class wx.lib.multisash.MultiViewLeaf

SizeWindows

Method in class wx.SashWindow

SizeWindows

Method in class wx.SplitterWindow

Skip

Method in class wx.Event

Sleep

Function in package wx

Slider

Class in package wx

Slider_GetClassDefaultAttributes

Function in package wx

Snap

Method in class wx.lib.ogl.Diagram

Snap

Method in class wx.lib.ogl.ShapeCanvas

SortChildren

Method in class wx.TreeCtrl

SortChildren

Method in class wx.gizmos.TreeListCtrl

SortItems

Method in class wx.ListCtrl

SortLines

Method in class wx.lib.ogl.Shape

SortListItems

Method in class wx.lib.mixins.listctrl.ColumnSorterMixin

Sound

Class in package wx

Sound_PlaySound

Function in package wx

Sound_Stop

Function in package wx

SoundFromData

Function in package wx

spawn

Method in class distutils.cmd.Command

SpecialControlKey

Method in class wx.lib.editor.editor.Editor

SpinButton

Class in package wx

SpinButton_GetClassDefaultAttributes

Function in package wx

SpinCtrl

Class in package wx

SpinCtrl_GetClassDefaultAttributes

Function in package wx

SpinEvent

Class in package wx

SplashScreen

Class in package wx

splashscreen

Module in package wx.lib

SplashScreen

Class in module wx.lib.splashscreen

SplashScreenWindow

Class in package wx

SplitHorizontally

Method in class wx.SplitterWindow

SplitterEvent

Class in package wx

SplitterScrolledWindow

Class in module wx.gizmos

SplitterWindow

Class in package wx

SplitterWindow_GetClassDefaultAttributes

Function in package wx

SplitVertically

Method in class wx.SplitterWindow

spy

Method in class wx.py.crust.DispatcherListing

StandardError

Class in module exceptions

StandardPaths

Class in package wx

StandardPaths_Get

Function in package wx

Start

Method in class wx.FutureCall

Start

Method in class wx.StopWatch

Start

Method in class wx.Timer

Start

Method in class wx.TimerRunner

Start

Method in class wx.lib.gestures.MouseGestures

Start

Method in class wx.lib.throbber.Throbber

Start

Method in class wx.lib.ticker.Ticker

StartDoc

Method in class wx.DC

StartDrawingOnTop

Method in class wx.ScreenDC

StartDrawingOnTopWin

Method in class wx.ScreenDC

StartingClick

Method in class wx.grid.GridCellEditor

StartingClick

Method in class wx.lib.sheet.CCellEditor

StartingKey

Method in class wx.grid.GridCellEditor

StartingKey

Method in class wx.lib.sheet.CCellEditor

StartPage

Method in class wx.DC

StartRecord

Method in class wx.stc.StyledTextCtrl

StartStyling

Method in class wx.stc.StyledTextCtrl

StartTimer

Function in package wx

statbmp

Module in package wx.lib

state_names

Variable in module wx.lib.masked.maskededit

states

Variable in module wx.lib.masked.maskededit

StaticBitmap

Class in package wx

StaticBitmap_GetClassDefaultAttributes

Function in package wx

StaticBox

Class in package wx

StaticBox_GetClassDefaultAttributes

Function in package wx

StaticBoxSizer

Class in package wx

StaticFancyText

Class in module wx.lib.fancytext

StaticLine

Class in package wx

StaticLine_GetClassDefaultAttributes

Function in package wx

StaticLine_GetDefaultSize

Function in package wx

StaticPicture

Class in module wx.gizmos

StaticText

Class in package wx

StaticText_GetClassDefaultAttributes

Function in package wx

stattext

Module in package wx.lib

StatusBar

Class in package wx

StatusBar_GetClassDefaultAttributes

Function in package wx

stc

Module in package wx

StdDialogButtonSizer

Class in package wx

StockCursor

Function in package wx

Stop

Method in class wx.FutureCall

Stop

Method in class wx.Sound

Stop

Method in class wx.Timer

Stop

Method in class wx.animate.AnimationPlayer

Stop

Method in class wx.animate.GIFAnimationCtrl

Stop

Method in class wx.lib.throbber.Throbber

Stop

Method in class wx.lib.ticker.Ticker

Stop

Method in class wx.media.MediaCtrl

Stop

Method in class wx.webkit.WebKitCtrl

StopParsing

Method in class wx.html.HtmlParser

StopPropagation

Method in class wx.Event

StopRecord

Method in class wx.stc.StyledTextCtrl

StopWatch

Class in package wx

Straighten

Method in class wx.lib.ogl.LineShape

StripExt

Method in class wx.lib.imagebrowser.FindFiles

StripMenuCodes

Function in package wx

StrTextConverter

Class in module wx.lib.mvctree

StutteredPageDown

Method in class wx.stc.StyledTextCtrl

StutteredPageDownExtend

Method in class wx.stc.StyledTextCtrl

StutteredPageUp

Method in class wx.stc.StyledTextCtrl

StutteredPageUpExtend

Method in class wx.stc.StyledTextCtrl

StyleClearAll

Method in class wx.stc.StyledTextCtrl

StyledTextCtrl

Class in module wx.stc

StyledTextEvent

Class in module wx.stc

StyleResetDefault

Method in class wx.stc.StyledTextCtrl

StyleSetBackground

Method in class wx.stc.StyledTextCtrl

StyleSetBold

Method in class wx.stc.StyledTextCtrl

StyleSetCase

Method in class wx.stc.StyledTextCtrl

StyleSetChangeable

Method in class wx.stc.StyledTextCtrl

StyleSetCharacterSet

Method in class wx.stc.StyledTextCtrl

StyleSetEOLFilled

Method in class wx.stc.StyledTextCtrl

StyleSetFaceName

Method in class wx.stc.StyledTextCtrl

StyleSetFont

Method in class wx.stc.StyledTextCtrl

StyleSetFontAttr

Method in class wx.stc.StyledTextCtrl

StyleSetFontEncoding

Method in class wx.stc.StyledTextCtrl

StyleSetForeground

Method in class wx.stc.StyledTextCtrl

StyleSetHotSpot

Method in class wx.stc.StyledTextCtrl

StyleSetItalic

Method in class wx.stc.StyledTextCtrl

StyleSetSize

Method in class wx.stc.StyledTextCtrl

StyleSetSpec

Method in class wx.stc.StyledTextCtrl

StyleSetUnderline

Method in class wx.stc.StyledTextCtrl

StyleSetVisible

Method in class wx.stc.StyledTextCtrl

sub_commands

Variable in class distutils.cmd.Command

sub_commands

Variable in class distutils.cmd.Command

sub_commands

Variable in class distutils.cmd.Command

sub_commands

Variable in class distutils.cmd.Command

sub_commands

Variable in class distutils.cmd.Command

sub_commands

Variable in class distutils.cmd.Command

sub_commands

Variable in class distutils.cmd.Command

sub_commands

Variable in class distutils.command.install.install

sub_commands

Variable in class distutils.command.install.install

Submit

Method in class wx.lib.docview.CommandProcessor

Subtract

Method in class wx.DateSpan

Subtract

Method in class wx.DateTime

Subtract

Method in class wx.Region

Subtract

Method in class wx.TimeSpan

SubtractDS

Method in class wx.DateTime

SubtractRect

Method in class wx.Region

SubtractRegion

Method in class wx.Region

SubtractTS

Method in class wx.DateTime

Sun

Variable in class wx.DateTime

Sun

Variable in class wx.DateTime

Sunday_First

Variable in class wx.DateTime

Sunday_First

Variable in class wx.DateTime

Suspend

Method in class wx.Log

SwapBuffers

Method in class wx.glcanvas.GLCanvas

SwapBuffers

Method in class wx.glcanvas.GLContext

SysColourChangedEvent

Class in package wx

SysErrorCode

Function in package wx

SysErrorMsg

Function in package wx

SystemOptions

Class in package wx

SystemOptions_GetOption

Function in package wx

SystemOptions_GetOptionInt

Function in package wx

SystemOptions_HasOption

Function in package wx

SystemOptions_IsFalse

Function in package wx

SystemOptions_SetOption

Function in package wx

SystemOptions_SetOptionInt

Function in package wx

SystemSettings

Class in package wx

SystemSettings_GetColour

Function in package wx

SystemSettings_GetFont

Function in package wx

SystemSettings_GetMetric

Function in package wx

SystemSettings_GetScreenType

Function in package wx

SystemSettings_HasFeature

Function in package wx

SystemSettings_SetScreenType

Function in package wx

Tab

Method in class wx.stc.StyledTextCtrl

TabKey

Method in class wx.lib.editor.editor.Editor

TargetFromSelection

Method in class wx.stc.StyledTextCtrl

TaskBarIcon

Class in package wx

TaskBarIconEvent

Class in package wx

tell

Method in class wx.InputStream

Tell

Method in class wx.media.MediaCtrl

TellI

Method in class wx.InputStream

TEMPLATE_INVISIBLE

Variable in module wx.lib.docview

TEMPLATE_VISIBLE

Variable in module wx.lib.docview

test

Function in module wx.lib.pubsub

TestDay

Method in class wx.lib.calendar.Calendar

TestFontEncoding

Function in package wx

TestFrame

Class in module wx.lib.plot

TestFull

Method in class wx.lib.printout.PrintBase

Text

Class in module wx.lib.floatcanvas.FloatCanvas

TEXT

Variable in module wx.lib.masked.ctrl

TEXT

Variable in class wx.lib.masked.ctrl.controlTypes

TextAttr

Class in package wx

TextAttr_Combine

Function in package wx

TextConverter

Class in module wx.lib.mvctree

TextCtrl

Class in package wx

textctrl

Module in package wx.lib.masked

TextCtrl

Class in module wx.lib.masked.textctrl

TextCtrl_GetClassDefaultAttributes

Function in package wx

TextDataObject

Class in package wx

TextDropTarget

Class in package wx

TextEditMixin

Class in module wx.lib.mixins.listctrl

TextEntryDialog

Class in package wx

textEntryDialog

Function in module wx.lib.dialogs

TextHeight

Method in class wx.stc.StyledTextCtrl

TextObjectMixin

Class in module wx.lib.floatcanvas.FloatCanvas

TextShape

Class in package wx.lib.ogl

TextSpacing

Method in class wx.lib.printout.PrintTable

TextUrlEvent

Class in package wx

TextWidth

Method in class wx.stc.StyledTextCtrl

Thaw

Method in class wx.Window

ThinSplitterWindow

Class in module wx.gizmos

Thread_IsMain

Function in package wx

throbber

Module in package wx.lib

Throbber

Class in module wx.lib.throbber

THROBBER_EVENT

Variable in module wx.lib.throbber

Thu

Variable in class wx.DateTime

Thu

Variable in class wx.DateTime

ticker

Module in package wx.lib

Ticker

Class in module wx.lib.ticker

ticker_xrc

Module in package wx.lib

TIFFHandler

Class in package wx

Tile

Method in class wx.MDIParentFrame

TileBitmap

Method in class wx.Effects

Time

Method in class wx.StopWatch

TIME

Variable in module wx.lib.masked.ctrl

TIME

Variable in class wx.lib.masked.ctrl.controlTypes

timectrl

Module in package wx.lib.masked

TimeCtrl

Class in module wx.lib.masked.timectrl

TimeCtrlAccessorsMixin

Class in module wx.lib.masked.timectrl

Timer

Class in package wx

TimerEvent

Class in package wx

TimerRunner

Class in package wx

TimeSpan

Class in package wx

TimeSpan_Day

Function in package wx

TimeSpan_Days

Function in package wx

TimeSpan_Hour

Function in package wx

TimeSpan_Hours

Function in package wx

TimeSpan_Minute

Function in package wx

TimeSpan_Minutes

Function in package wx

TimeSpan_Second

Function in package wx

TimeSpan_Seconds

Function in package wx

TimeSpan_Week

Function in package wx

TimeSpan_Weeks

Function in package wx

TimeStamp

Method in class wx.Log

TimeUpdatedEvent

Class in module wx.lib.masked.timectrl

TipProvider

Class in package wx

TipWindow

Class in package wx

Today

Method in class wx.DateTime

TodayDay

Function in module wx.lib.CDate

Toggle

Method in class wx.MenuItem

Toggle

Method in class wx.ToolBarToolBase

Toggle

Method in class wx.TreeCtrl

Toggle

Method in class wx.VListBox

Toggle

Method in class wx.gizmos.TreeListCtrl

ToggleButton

Class in package wx

ToggleButton_GetClassDefaultAttributes

Function in package wx

ToggleFold

Method in class wx.stc.StyledTextCtrl

ToggleItemSelection

Method in class wx.TreeCtrl

ToggleLabel

Method in class wx.lib.throbber.Throbber

ToggleOverlay

Method in class wx.lib.throbber.Throbber

ToggleTool

Method in class wx.ToolBarBase

ToGMT

Method in class wx.DateTime

ToolBar

Class in package wx

ToolBar_GetClassDefaultAttributes

Function in package wx

ToolBarBase

Class in package wx

ToolBarToolBase

Class in package wx

tools

Package in package wx

ToolTip

Class in package wx

ToolTip_Enable

Function in package wx

ToolTip_SetDelay

Function in package wx

top

Class in module wx._misc in class wx.LayoutConstraints

top

Class in module wx._misc in class wx.LayoutConstraints in class wx.Rect

TopLevelWindow

Class in package wx

ToString

Method in class wx.NativeEncodingInfo

ToString

Method in class wx.NativeFontInfo

ToText

Method in class wx.html.HtmlWindow

ToTimezone

Method in class wx.DateTime

TouchBuffer

Method in class wx.lib.editor.editor.Editor

ToUserString

Method in class wx.NativeFontInfo

TransferDataFromWindow

Method in class wx.Window

TransferDataToWindow

Method in class wx.Window

TransferFromWindow

Method in class wx.Validator

TransferFromWindow

Method in class wx.lib.intctrl.IntValidator

TransferToWindow

Method in class wx.Validator

TransferToWindow

Method in class wx.lib.intctrl.IntValidator

Transform

Method in class wx.lib.mvctree.NullTransform

Transform

Class in module wx.lib.mvctree

Transform

Method in class wx.lib.mvctree.Transform

Translate

Method in class wx.lib.ogl.DrawOp

Translate

Method in class wx.lib.ogl.DrawnShape

Translate

Method in class wx.lib.ogl.OpDraw

Translate

Method in class wx.lib.ogl.OpPolyDraw

Translate

Method in class wx.lib.ogl.OpSetClipping

Translate

Method in class wx.lib.ogl.PseudoMetaFile

Trap

Function in package wx

TreeCompanionWindow

Class in module wx.gizmos

TreeCtrl

Class in package wx

TreeCtrl_GetClassDefaultAttributes

Function in package wx

TreeEvent

Class in package wx

TreeItemData

Class in package wx

TreeItemId

Class in package wx

TreeLayout

Class in module wx.lib.mvctree

TreeLinePainter

Class in module wx.lib.mvctree

TreeListColumnInfo

Class in module wx.gizmos

TreeListCtrl

Class in module wx.gizmos

TreeModel

Class in module wx.lib.mvctree

TreeNodePainter

Class in module wx.lib.mvctree

TreePainter

Class in module wx.lib.mvctree

TryExec

Method in class wx.lib.shell.PyShell

Tue

Variable in class wx.DateTime

Tue

Variable in class wx.DateTime

type

Class in module __builtin__

Type_Boolean

Variable in class wx.ConfigBase

Type_Boolean

Variable in class wx.ConfigBase

Type_Boolean

Variable in class wx.ConfigBase

Type_Boolean

Variable in class wx.ConfigBase

Type_Boolean

Variable in class wx.ConfigBase

Type_Boolean

Variable in class wx.ConfigBase

Type_Float

Variable in class wx.ConfigBase

Type_Float

Variable in class wx.ConfigBase

Type_Float

Variable in class wx.ConfigBase

Type_Float

Variable in class wx.ConfigBase

Type_Float

Variable in class wx.ConfigBase

Type_Float

Variable in class wx.ConfigBase

Type_Integer

Variable in class wx.ConfigBase

Type_Integer

Variable in class wx.ConfigBase

Type_Integer

Variable in class wx.ConfigBase

Type_Integer

Variable in class wx.ConfigBase

Type_Integer

Variable in class wx.ConfigBase

Type_Integer

Variable in class wx.ConfigBase

Type_String

Variable in class wx.ConfigBase

Type_String

Variable in class wx.ConfigBase

Type_String

Variable in class wx.ConfigBase

Type_String

Variable in class wx.ConfigBase

Type_String

Variable in class wx.ConfigBase

Type_String

Variable in class wx.ConfigBase

Type_Unknown

Variable in class wx.ConfigBase

Type_Unknown

Variable in class wx.ConfigBase

Type_Unknown

Variable in class wx.ConfigBase

Type_Unknown

Variable in class wx.ConfigBase

Type_Unknown

Variable in class wx.ConfigBase

Type_Unknown

Variable in class wx.ConfigBase

UK

Variable in class wx.DateTime

UK

Variable in class wx.DateTime

Unassociate

Method in class wx.FileType

Unassociate

Method in class wx.MimeTypesManager

Unbind

Method in class wx.EvtHandler

Unbind

Method in class wx.PyEventBinder

UnBindAll

Method in class wx.lib.floatcanvas.FloatCanvas.DrawObject

Unconstrained

Method in class wx.IndividualLayoutConstraint

Undo

Method in class wx.ComboBox

Undo

Method in class wx.TextCtrl

Undo

Method in class wx.lib.docview.Command

Undo

Method in class wx.lib.docview.CommandProcessor

Undo

Method in class wx.lib.masked.combobox.BaseMaskedComboBox

Undo

Method in class wx.lib.masked.textctrl.BaseMaskedTextCtrl

Undo

Method in class wx.stc.StyledTextCtrl

Ungetch

Method in class wx.InputStream

Union

Method in class wx.Rect

Union

Method in class wx.Region

UnionBitmap

Method in class wx.Region

UnionBitmapColour

Method in class wx.Region

UnionRect

Method in class wx.Region

UnionRegion

Method in class wx.Region

UnixKeyHack

Method in class wx.lib.editor.editor.Editor

Unlink

Method in class wx.lib.ogl.LineShape

UnMask

Method in class wx.BufferedDC

UNow

Method in class wx.DateTime

UnregisterHotKey

Method in class wx.Window

Unselect

Method in class wx.TreeCtrl

Unselect

Method in class wx.gizmos.TreeListCtrl

UnSelect

Method in class wx.lib.multisash.MultiClient

UnSelect

Method in class wx.lib.multisash.MultiSash

UnSelect

Method in class wx.lib.multisash.MultiSplit

UnSelect

Method in class wx.lib.multisash.MultiViewLeaf

UnselectAll

Method in class wx.TreeCtrl

UnselectAll

Method in class wx.gizmos.TreeListCtrl

UnselectItem

Method in class wx.TreeCtrl

Unsplit

Method in class wx.SplitterWindow

UnTouchBuffer

Method in class wx.lib.editor.editor.Editor

Update

Method in class wx.ProgressDialog

Update

Method in class wx.Window

Update

Method in class wx.lib.colourchooser.pycolourbox.PyColourBox

UPDATE_URL

Variable in module wxversion

UpdateAll

Method in class wx.lib.analogclockopts.ACCustomizationFrame

UpdateAllViews

Method in class wx.lib.docview.Document

UpdateAttrCols

Method in class wx.grid.GridCellAttrProvider

UpdateAttrRows

Method in class wx.grid.GridCellAttrProvider

UpdateBackingFromWindow

Method in class wx.DragImage

UpdateColour

Method in class wx.lib.colourchooser.pycolourchooser.PyColourChooser

updateColourDB

Function in module wx.lib.colourdb

UpdateEntries

Method in class wx.lib.colourchooser.pycolourchooser.PyColourChooser

UpdateExtent

Method in class wx.lib.ticker.Ticker

UpdateLink

Method in class wx.lib.hyperlink.HyperLinkCtrl

updateNamespace

Method in class wx.py.buffer.Buffer

updateNamespace

Method in class wx.py.editor.EditorFrame

UpdateOriginalPoints

Method in class wx.lib.ogl.PolygonShape

UpdatePointLabel

Method in class wx.lib.plot.PlotCanvas

UpdateProperties

Method in class wx.lib.pyshell.PyShellWindow

UpdateSize

Method in class wx.SplitterWindow

UpdateStatus

Method in class wx.lib.pydocview.DocFrameMixIn

UpdateThrobberEvent

Class in module wx.lib.throbber

UpdateUI

Method in class wx.Menu

UpdateUIEvent

Class in package wx

UpdateUIEvent_CanUpdate

Function in package wx

UpdateUIEvent_GetMode

Function in package wx

UpdateUIEvent_GetUpdateInterval

Function in package wx

UpdateUIEvent_ResetUpdateTime

Function in package wx

UpdateUIEvent_SetMode

Function in package wx

UpdateUIEvent_SetUpdateInterval

Function in package wx

UpdateView

Method in class wx.lib.editor.editor.Editor

UpdateWidgets

Method in class wx.lib.analogclockopts.ACCustomizationFrame

UpdateWindowMenu

Method in class wx.lib.pydocview.DocMDIParentFrame

UpdateWindowUI

Method in class wx.Window

UpdWindow

Method in class wx.lib.shell.PyShellOutput

UpperCase

Method in class wx.stc.StyledTextCtrl

URLDataObject

Class in package wx

URLToFileName

Method in class wx.FileSystem

USA

Variable in class wx.DateTime

USA

Variable in class wx.DateTime

UseBackgroundColour

Method in class wx.animate.AnimationPlayer

UseBgCol

Method in class wx.Window

UseConfig

Method in class wx.html.HtmlHelpController

UseConfig

Method in class wx.html.HtmlHelpFrame

UseMenu

Method in class wx.FileHistory

UseParentBackground

Method in class wx.animate.AnimationPlayer

UsePopUp

Method in class wx.stc.StyledTextCtrl

UsePrimarySelection

Method in class wx.Clipboard

user_options

Variable in class distutils.command.clean.clean

user_options

Variable in class distutils.command.clean.clean

user_options

Variable in class distutils.command.install.install

user_options

Variable in class distutils.command.install.install

user_options

Variable in class distutils.command.install_data.install_data

user_options

Variable in class distutils.command.install_data.install_data

user_options

Variable in class distutils.command.install_headers.install_headers

user_options

Variable in class distutils.command.install_headers.install_headers

UserListShow

Method in class wx.stc.StyledTextCtrl

UsingBackgroundColour

Method in class wx.animate.AnimationPlayer

UsingCustomBackgroundColour

Method in class wx.animate.AnimationPlayer

UsingParentBackground

Method in class wx.animate.AnimationPlayer

UTC

Variable in class wx.DateTime

UTC

Variable in class wx.DateTime

valid_ctrl_params

Variable in class wx.lib.masked.maskededit.MaskedEditMixin

valid_ctrl_params

Variable in class wx.lib.masked.maskededit.MaskedEditMixin

valid_ctrl_params

Variable in class wx.lib.masked.maskededit.MaskedEditMixin

valid_ctrl_params

Variable in class wx.lib.masked.maskededit.MaskedEditMixin

valid_ctrl_params

Variable in class wx.lib.masked.maskededit.MaskedEditMixin

valid_ctrl_params

Variable in class wx.lib.masked.maskededit.MaskedEditMixin

valid_ctrl_params

Variable in class wx.lib.masked.maskededit.MaskedEditMixin

valid_ctrl_params

Variable in class wx.lib.masked.maskededit.MaskedEditMixin

valid_ctrl_params

Variable in class wx.lib.masked.numctrl.NumCtrl

valid_ctrl_params

Variable in class wx.lib.masked.timectrl.TimeCtrl

valid_params

Variable in class wx.lib.masked.maskededit.Field

Validate

Method in class wx.Validator

Validate

Method in class wx.Window

Validate

Method in class wx.lib.intctrl.IntValidator

Validator

Class in package wx

Validator_IsSilent

Function in package wx

Validator_SetBellOnError

Function in package wx

VCHome

Method in class wx.stc.StyledTextCtrl

VCHomeExtend

Method in class wx.stc.StyledTextCtrl

VCHomeRectExtend

Method in class wx.stc.StyledTextCtrl

VCHomeWrap

Method in class wx.stc.StyledTextCtrl

VCHomeWrapExtend

Method in class wx.stc.StyledTextCtrl

version

Module in package wx.py

VERSION

Variable in module wx.py.version

VersionError

Class in module wxversion

VertBoundaries

Method in class wx.lib.editor.editor.Editor

VERTICAL_STEP

Variable in class wx.lib.colourchooser.pypalette.PyPalette

VertScroll

Method in class wx.lib.editor.editor.Editor

Veto

Method in class wx.CloseEvent

Veto

Method in class wx.NotifyEvent

VideoMode

Class in package wx

View

Class in module wx.lib.docview

VIEW_STATUSBAR_ID

Variable in module wx.lib.pydocview

VIEW_TOOLBAR_ID

Variable in module wx.lib.pydocview

VisibleFromDocLine

Method in class wx.stc.StyledTextCtrl

VisualAttributes

Class in package wx

VListBox

Class in package wx

VScrolledWindow

Class in package wx

vtk

Module in package wx.lib

w

Module in package wx.lib in class wx.VideoMode

WakeUpIdle

Method in class wx.PyApp

WakeUpIdle

Function in package wx

WakeUpMainThread

Function in package wx

warn

Method in class distutils.cmd.Command

warningmsg

Variable in module wx.lib.floatbar

warningmsg

Variable in module wx.lib.grids

warningmsg

Variable in module wx.lib.mvctree

warningmsg

Variable in module wx.lib.pyshell

warningmsg

Variable in module wx.lib.shell

warningmsg

Variable in module wx.lib.splashscreen

warningmsg

Variable in module wx.lib.wxPlotCanvas

WarpPointer

Method in class wx.Window

webkit

Module in package wx

WebKitCtrl

Class in module wx.webkit

WebKitStateChangedEvent

Class in module wx.webkit

Wed

Variable in class wx.DateTime

Wed

Variable in class wx.DateTime

Week

Method in class wx.DateSpan

Week

Method in class wx.TimeSpan

Weeks

Method in class wx.DateSpan

Weeks

Method in class wx.TimeSpan

WEST

Variable in class wx.DateTime

WEST

Variable in class wx.DateTime

WET

Variable in class wx.DateTime

WET

Variable in class wx.DateTime

WheelEvent

Method in class wx.lib.floatcanvas.FloatCanvas.FloatCanvas

WhollyContains

Function in package wx.lib.ogl

width

Function in package wx.lib.ogl in class wx.LayoutConstraints

width

Function in package wx.lib.ogl in class wx.LayoutConstraints in class wx.Rect

width

Function in package wx.lib.ogl in class wx.LayoutConstraints in class wx.Rect in class wx.Size

WIDTH

Variable in class wx.lib.colourchooser.pycolourslider.PyColourSlider

WinChange

Variable in class wx.NavigationKeyEvent

WinChange

Variable in class wx.NavigationKeyEvent

Window

Class in package wx

Window_FindFocus

Function in package wx

Window_FromHWND

Function in package wx

Window_GetCapture

Function in package wx

Window_GetClassDefaultAttributes

Function in package wx

WINDOW_MENU_NUM_ITEMS

Variable in module wx.lib.pydocview

Window_NewControlId

Function in package wx

Window_NextControlId

Function in package wx

Window_PrevControlId

Function in package wx

WindowCreateEvent

Class in package wx

WindowDC

Class in package wx

WindowDestroyEvent

Class in package wx

WindowDisabler

Class in package wx

WindowMenuService

Class in module wx.lib.pydocview

wizard

Module in package wx

Wizard

Class in module wx.wizard

WizardEvent

Class in module wx.wizard

WizardPage

Class in module wx.wizard

WizardPageSimple

Class in module wx.wizard

WizardPageSimple_Chain

Function in module wx.wizard

WordEndPosition

Method in class wx.stc.StyledTextCtrl

WordLeft

Method in class wx.stc.StyledTextCtrl

WordLeftEnd

Method in class wx.stc.StyledTextCtrl

WordLeftEndExtend

Method in class wx.stc.StyledTextCtrl

WordLeftExtend

Method in class wx.stc.StyledTextCtrl

WordPartLeft

Method in class wx.stc.StyledTextCtrl

WordPartLeftExtend

Method in class wx.stc.StyledTextCtrl

WordPartRight

Method in class wx.stc.StyledTextCtrl

WordPartRightExtend

Method in class wx.stc.StyledTextCtrl

WordRight

Method in class wx.stc.StyledTextCtrl

WordRightEnd

Method in class wx.stc.StyledTextCtrl

WordRightEndExtend

Method in class wx.stc.StyledTextCtrl

WordRightExtend

Method in class wx.stc.StyledTextCtrl

WordStartPosition

Method in class wx.stc.StyledTextCtrl

WorldToPixel

Method in class wx.lib.floatcanvas.FloatCanvas.FloatCanvas

wrap

Function in module wx.py.PyWrap

wrap

Method in class wx.py.shell.Shell

write

Method in class code.InteractiveInterpreter

Write

Method in class wx.ConfigBase

write

Method in class wx.OutputStream

write

Method in class wx.PyOnDemandOutputWindow

write

Method in class wx.TextCtrl

write

Method in class wx.lib.infoframe.Dummy_PyInformationalMessagesFrame

write

Method in class wx.lib.infoframe.PyInformationalMessagesFrame

write

Method in class wx.lib.pyshell.FauxFile

write

Method in class wx.lib.shell.PyShellOutput

write

Method in class wx.py.document.Document

write

Method in class wx.py.pseudo.PseudoFile

write

Method in class wx.py.shell.Shell

write_exc

Method in class wx.lib.shell.PyShellOutput

write_in

Method in class wx.lib.shell.PyShellOutput

WriteBool

Method in class wx.ConfigBase

WriteCustomization

Method in class wx.html.HtmlHelpController

WriteCustomization

Method in class wx.html.HtmlHelpFrame

WriteCustomization

Method in class wx.html.HtmlWindow

writeErr

Method in class wx.py.shell.Shell

WriteFloat

Method in class wx.ConfigBase

WriteInt

Method in class wx.ConfigBase

writelines

Method in class wx.lib.pyshell.FauxFile

writelines

Method in class wx.py.pseudo.PseudoFile

writeOut

Method in class wx.py.shell.Shell

WriteText

Method in class wx.TextCtrl

writeTrace

Method in class wx.lib.pyshell.PyShellWindow

wx

Package

wxEVT_CAPTIONBAR

Variable in module wx.lib.foldpanelbar

wxEVT_COMMAND_COLOURSELECT

Variable in module wx.lib.colourselect

wxEVT_COMMAND_GRID_COL_MOVE

Variable in module wx.lib.gridmovers

wxEVT_COMMAND_GRID_ROW_MOVE

Variable in module wx.lib.gridmovers

wxEVT_COMMAND_INT_UPDATED

Variable in module wx.lib.intctrl

wxEVT_COMMAND_MASKED_NUMBER_UPDATED

Variable in module wx.lib.masked.numctrl

wxEVT_COMMAND_PYCALENDAR_DAY_CLICKED

Variable in module wx.lib.calendar

wxEVT_DOPOPUPMENU

Variable in module wx.lib.mixins.listctrl

wxEVT_HYPERLINK_LEFT

Variable in module wx.lib.hyperlink

wxEVT_HYPERLINK_MIDDLE

Variable in module wx.lib.hyperlink

wxEVT_HYPERLINK_RIGHT

Variable in module wx.lib.hyperlink

wxEVT_MVCTREE_ITEM_COLLAPSED

Variable in module wx.lib.mvctree

wxEVT_MVCTREE_ITEM_COLLAPSING

Variable in module wx.lib.mvctree

wxEVT_MVCTREE_ITEM_EXPANDED

Variable in module wx.lib.mvctree

wxEVT_MVCTREE_ITEM_EXPANDING

Variable in module wx.lib.mvctree

wxEVT_MVCTREE_KEY_DOWN

Variable in module wx.lib.mvctree

wxEVT_MVCTREE_SEL_CHANGED

Variable in module wx.lib.mvctree

wxEVT_TIMEVAL_UPDATED

Variable in module wx.lib.masked.timectrl

wxGridSelectCells

Variable in class wx.grid.Grid

wxGridSelectCells

Variable in class wx.grid.Grid

wxGridSelectColumns

Variable in class wx.grid.Grid

wxGridSelectColumns

Variable in class wx.grid.Grid

wxGridSelectRows

Variable in class wx.grid.Grid

wxGridSelectRows

Variable in class wx.grid.Grid

wxHYPERLINKS_POPUP_COPY

Variable in module wx.lib.hyperlink

WXK_CTRL_C

Variable in module wx.lib.masked.maskededit

WXK_CTRL_S

Variable in module wx.lib.masked.maskededit

WXK_CTRL_V

Variable in module wx.lib.intctrl

WXK_CTRL_V

Variable in module wx.lib.masked.maskededit

WXK_CTRL_X

Variable in module wx.lib.intctrl

WXK_CTRL_X

Variable in module wx.lib.masked.maskededit

WXK_CTRL_Z

Variable in module wx.lib.masked.maskededit

wxPlotCanvas

Module in package wx.lib

wxpTag

Module in package wx.lib

WXPTAG

Variable in module wx.lib.wxpTag

wxpTagHandler

Class in module wx.lib.wxpTag

wxTickerXmlHandler

Class in module wx.lib.ticker_xrc

wxversion

Module

x

Module in class wx.Point

x

Module in class wx.Point in class wx.Point2D

x

Module in class wx.Point in class wx.Point2D in class wx.RealPoint

x

Module in class wx.Point in class wx.Point2D in class wx.RealPoint in class wx.Rect

x

Module in class wx.Point in class wx.Point2D in class wx.RealPoint in class wx.Rect in class wx.Size

XmlDocument

Class in module wx.xrc

XmlDocumentFromStream

Function in module wx.xrc

XmlNode

Class in module wx.xrc

XmlNodeEasy

Function in module wx.xrc

XmlProperty

Class in module wx.xrc

XmlResource

Class in module wx.xrc

XmlResource_AddSubclassFactory

Function in module wx.xrc

XmlResource_Get

Function in module wx.xrc

XmlResource_GetXRCID

Function in module wx.xrc

XmlResource_Set

Function in module wx.xrc

XmlResourceHandler

Class in module wx.xrc

XmlSubclassFactory

Class in module wx.xrc

XmlSubclassFactory_Python

Class in module wx.xrc

Xor

Method in class wx.Region

XorRect

Method in class wx.Region

XorRegion

Method in class wx.Region

XPMHandler

Class in package wx

xrc

Module in package wx

XRCCTRL

Function in module wx.xrc

XRCID

Function in module wx.xrc

XToCol

Method in class wx.grid.Grid

XToEdgeOfCol

Method in class wx.grid.Grid

XYObjectMixin

Class in module wx.lib.floatcanvas.FloatCanvas

XYToCell

Method in class wx.grid.Grid

XYToPosition

Method in class wx.TextCtrl

y

Method in class wx.TextCtrl in class wx.Point

y

Method in class wx.TextCtrl in class wx.Point in class wx.Point2D

y

Method in class wx.TextCtrl in class wx.Point in class wx.Point2D in class wx.RealPoint

y

Method in class wx.TextCtrl in class wx.Point in class wx.Point2D in class wx.RealPoint in class wx.Rect

y

Method in class wx.TextCtrl in class wx.Point in class wx.Point2D in class wx.RealPoint in class wx.Rect in class wx.Size

Year

Method in class wx.DateSpan

Years

Method in class wx.DateSpan

Yield

Method in class wx.PyApp

Yield

Function in package wx

YieldIfNeeded

Function in package wx

YToEdgeOfRow

Method in class wx.grid.Grid

YToRow

Method in class wx.grid.Grid

ZipFSHandler

Class in package wx

Zoom

Method in class wx.lib.floatcanvas.FloatCanvas.FloatCanvas

Zoom

Method in class wx.lib.plot.PlotCanvas

zoom

Method in class wx.py.shell.Shell

ZoomIn

Method in class wx.stc.StyledTextCtrl

ZoomOut

Method in class wx.stc.StyledTextCtrl

ZoomToBB

Method in class wx.lib.floatcanvas.FloatCanvas.FloatCanvas

ZoomToFit

Method in class wx.lib.floatcanvas.NavCanvas.NavCanvas

Home

Trees

Index

Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:26 2005

http://epydoc.sf.net


Table of Contents
Everything

Packages
wx
wx.build
wx.lib
wx.lib.colourchooser
wx.lib.editor
wx.lib.floatcanvas
wx.lib.masked
wx.lib.mixins
wx.lib.ogl
wx.py
wx.tools

Modules
wx.animate
wx.calendar
wx.gizmos
wx.glcanvas
wx.grid
wx.html
wx.lib.analogclock
wx.lib.analogclockopts
wx.lib.anchors
wx.lib.buttons
wx.lib.calendar
wx.lib.CDate
wx.lib.ClickableHtmlWindow
wx.lib.colourchooser.canvas
wx.lib.colourchooser.pycolourbox
wx.lib.colourchooser.pycolourchooser
wx.lib.colourchooser.pycolourslider
wx.lib.colourchooser.pypalette
wx.lib.colourdb
wx.lib.colourselect
wx.lib.dialogs
wx.lib.docview
wx.lib.editor.editor
wx.lib.editor.images
wx.lib.editor.selection
wx.lib.evtmgr
wx.lib.fancytext
wx.lib.filebrowsebutton
wx.lib.floatbar
wx.lib.floatcanvas.FloatCanvas
wx.lib.floatcanvas.NavCanvas
wx.lib.floatcanvas.Resources
wx.lib.foldmenu
wx.lib.foldpanelbar
wx.lib.gestures
wx.lib.gridmovers
wx.lib.grids
wx.lib.hyperlink
wx.lib.imagebrowser
wx.lib.imageutils
wx.lib.infoframe
wx.lib.intctrl
wx.lib.layoutf
wx.lib.masked.combobox
wx.lib.masked.ctrl
wx.lib.masked.ipaddrctrl
wx.lib.masked.maskededit
wx.lib.masked.numctrl
wx.lib.masked.textctrl
wx.lib.masked.timectrl
wx.lib.mixins.grid
wx.lib.mixins.imagelist
wx.lib.mixins.listctrl
wx.lib.mixins.rubberband
wx.lib.multisash
wx.lib.mvctree
wx.lib.newevent
wx.lib.plot
wx.lib.popupctl
wx.lib.printout
wx.lib.pubsub
wx.lib.pydocview
wx.lib.pyshell
wx.lib.rcsizer
wx.lib.rightalign
wx.lib.scrolledpanel
wx.lib.sheet
wx.lib.shell
wx.lib.splashscreen
wx.lib.statbmp
wx.lib.stattext
wx.lib.throbber
wx.lib.ticker
wx.lib.ticker_xrc
wx.lib.vtk
wx.lib.wxPlotCanvas
wx.lib.wxpTag
wx.media
wx.py.buffer
wx.py.crust
wx.py.dispatcher
wx.py.document
wx.py.editor
wx.py.editwindow
wx.py.filling
wx.py.frame
wx.py.images
wx.py.interpreter
wx.py.introspect
wx.py.pseudo
wx.py.PyAlaCarte
wx.py.PyAlaMode
wx.py.PyAlaModeTest
wx.py.PyCrust
wx.py.PyFilling
wx.py.PyShell
wx.py.PyWrap
wx.py.shell
wx.py.version
wx.stc
wx.tools.dbg
wx.tools.helpviewer
wx.tools.img2img
wx.tools.img2png
wx.tools.img2py
wx.tools.img2xpm
wx.webkit
wx.wizard
wx.xrc
wxversion


Everything
All Classes
wx.AcceleratorEntry
wx.AcceleratorTable
wx.ActivateEvent
wx.ANIHandler
wx.animate.AnimationBase
wx.animate.AnimationPlayer
wx.animate.GIFAnimation
wx.animate.GIFAnimationCtrl
wx.App
wx.ArtProvider
wx.Bitmap
wx.BitmapButton
wx.BitmapDataObject
wx.BMPHandler
wx.BookCtrlBase
wx.BookCtrlBaseEvent
wx.BookCtrlSizer
wx.BoxSizer
wx.Brush
wx.BrushList
wx.BufferedDC
wx.BufferedPaintDC
wx.BusyCursor
wx.BusyInfo
wx.Button
wx.CalculateLayoutEvent
wx.calendar.CalendarCtrl
wx.calendar.CalendarDateAttr
wx.calendar.CalendarEvent
wx.Caret
wx.CheckBox
wx.CheckListBox
wx.ChildFocusEvent
wx.Choice
wx.Choicebook
wx.ChoicebookEvent
wx.ClientDC
wx.Clipboard
wx.ClipboardLocker
wx.CloseEvent
wx.Colour
wx.ColourData
wx.ColourDatabase
wx.ColourDialog
wx.ComboBox
wx.CommandEvent
wx.Config
wx.ConfigBase
wx.ConfigPathChanger
wx.ContextHelp
wx.ContextHelpButton
wx.ContextMenuEvent
wx.Control
wx.ControlWithItems
wx.CPPFileSystemHandler
wx.CURHandler
wx.Cursor
wx.CustomDataObject
wx.DataFormat
wx.DataObject
wx.DataObjectComposite
wx.DataObjectSimple
wx.DateEvent
wx.DatePickerCtrl
wx.DateSpan
wx.DateTime
wx.DC
wx.Dialog
wx.DirDialog
wx.DirFilterListCtrl
wx.Display
wx.DisplayChangedEvent
wx.DragImage
wx.DropFilesEvent
wx.DropSource
wx.DropTarget
wx.Effects
wx.EncodingConverter
wx.EraseEvent
wx.Event
wx.EventLoop
wx.EvtHandler
wx.FileConfig
wx.FileDataObject
wx.FileDialog
wx.FileDropTarget
wx.FileHistory
wx.FileSystem
wx.FileSystemHandler
wx.FileType
wx.FileTypeInfo
wx.FindDialogEvent
wx.FindReplaceData
wx.FindReplaceDialog
wx.FlexGridSizer
wx.FocusEvent
wx.Font
wx.FontData
wx.FontDialog
wx.FontEnumerator
wx.FontList
wx.FontMapper
wx.Frame
wx.FSFile
wx.FutureCall
wx.Gauge
wx.GBPosition
wx.GBSizerItem
wx.GBSpan
wx.GDIObject
wx.GenericDirCtrl
wx.GIFHandler
wx.gizmos.DynamicSashSplitEvent
wx.gizmos.DynamicSashUnifyEvent
wx.gizmos.DynamicSashWindow
wx.gizmos.EditableListBox
wx.gizmos.LEDNumberCtrl
wx.gizmos.RemotelyScrolledTreeCtrl
wx.gizmos.SplitterScrolledWindow
wx.gizmos.StaticPicture
wx.gizmos.ThinSplitterWindow
wx.gizmos.TreeCompanionWindow
wx.gizmos.TreeListColumnInfo
wx.gizmos.TreeListCtrl
wx.glcanvas.GLCanvas
wx.glcanvas.GLContext
wx.grid.Grid
wx.grid.GridCellAttr
wx.grid.GridCellAttrProvider
wx.grid.GridCellAutoWrapStringEditor
wx.grid.GridCellAutoWrapStringRenderer
wx.grid.GridCellBoolEditor
wx.grid.GridCellBoolRenderer
wx.grid.GridCellChoiceEditor
wx.grid.GridCellCoords
wx.grid.GridCellDateTimeRenderer
wx.grid.GridCellEditor
wx.grid.GridCellEnumEditor
wx.grid.GridCellEnumRenderer
wx.grid.GridCellFloatEditor
wx.grid.GridCellFloatRenderer
wx.grid.GridCellNumberEditor
wx.grid.GridCellNumberRenderer
wx.grid.GridCellRenderer
wx.grid.GridCellStringRenderer
wx.grid.GridCellTextEditor
wx.grid.GridEditorCreatedEvent
wx.grid.GridEvent
wx.grid.GridRangeSelectEvent
wx.grid.GridSizeEvent
wx.grid.GridStringTable
wx.grid.GridTableBase
wx.grid.GridTableMessage
wx.grid.PyGridCellAttrProvider
wx.grid.PyGridCellEditor
wx.grid.PyGridCellRenderer
wx.grid.PyGridTableBase
wx.GridBagSizer
wx.GridSizer
wx.HelpEvent
wx.HelpProvider
wx.html.DefaultHtmlRenderingStyle
wx.html.HtmlBookRecord
wx.html.HtmlCell
wx.html.HtmlColourCell
wx.html.HtmlContainerCell
wx.html.HtmlContentsItem
wx.html.HtmlDCRenderer
wx.html.HtmlEasyPrinting
wx.html.HtmlFilter
wx.html.HtmlFontCell
wx.html.HtmlHelpController
wx.html.HtmlHelpData
wx.html.HtmlHelpFrame
wx.html.HtmlLinkInfo
wx.html.HtmlParser
wx.html.HtmlPrintout
wx.html.HtmlRenderingInfo
wx.html.HtmlRenderingState
wx.html.HtmlRenderingStyle
wx.html.HtmlSearchStatus
wx.html.HtmlSelection
wx.html.HtmlTag
wx.html.HtmlTagHandler
wx.html.HtmlWidgetCell
wx.html.HtmlWindow
wx.html.HtmlWinParser
wx.html.HtmlWinTagHandler
wx.html.HtmlWordCell
wx.HtmlListBox
wx.ICOHandler
wx.Icon
wx.IconBundle
wx.IconizeEvent
wx.IconLocation
wx.IdleEvent
wx.Image
wx.ImageHandler
wx.ImageHistogram
wx.ImageList
wx.IndividualLayoutConstraint
wx.InitDialogEvent
wx.InputStream
wx.InternetFSHandler
wx.ItemContainer
wx.Joystick
wx.JoystickEvent
wx.JPEGHandler
wx.KeyEvent
wx.LanguageInfo
wx.LayoutAlgorithm
wx.LayoutConstraints
wx.lib.analogclock.AnalogClockWindow
wx.lib.analogclockopts.ACCustomizationFrame
wx.lib.anchors.LayoutAnchors
wx.lib.buttons.GenBitmapButton
wx.lib.buttons.GenBitmapTextButton
wx.lib.buttons.GenBitmapTextToggleButton
wx.lib.buttons.GenBitmapToggleButton
wx.lib.buttons.GenButton
wx.lib.buttons.GenButtonEvent
wx.lib.buttons.GenToggleButton
wx.lib.calendar.CalDraw
wx.lib.calendar.Calendar
wx.lib.calendar.CalenDlg
wx.lib.calendar.PrtCalDraw
wx.lib.CDate.Date
wx.lib.CDate.now
wx.lib.ClickableHtmlWindow.PyClickableHtmlWindow
wx.lib.colourchooser.canvas.BitmapBuffer
wx.lib.colourchooser.canvas.Canvas
wx.lib.colourchooser.pycolourbox.PyColourBox
wx.lib.colourchooser.pycolourchooser.PyColourChooser
wx.lib.colourchooser.pycolourslider.PyColourSlider
wx.lib.colourchooser.pypalette.PyPalette
wx.lib.colourselect.ColourSelect
wx.lib.colourselect.ColourSelectEvent
wx.lib.dialogs.DialogResults
wx.lib.dialogs.MultipleChoiceDialog
wx.lib.dialogs.ScrolledMessageDialog
wx.lib.docview.Command
wx.lib.docview.CommandProcessor
wx.lib.docview.DocChildFrame
wx.lib.docview.DocManager
wx.lib.docview.DocMDIChildFrame
wx.lib.docview.DocMDIParentFrame
wx.lib.docview.DocParentFrame
wx.lib.docview.DocPrintout
wx.lib.docview.DocTemplate
wx.lib.docview.Document
wx.lib.docview.View
wx.lib.editor.editor.Editor
wx.lib.editor.editor.Scroller
wx.lib.evtmgr.EventAdapter
wx.lib.evtmgr.EventMacroInfo
wx.lib.evtmgr.EventManager
wx.lib.evtmgr.FakeWindow
wx.lib.evtmgr.MessageAdapter
wx.lib.fancytext.StaticFancyText
wx.lib.filebrowsebutton.DirBrowseButton
wx.lib.filebrowsebutton.FileBrowseButton
wx.lib.filebrowsebutton.FileBrowseButtonWithHistory
wx.lib.floatbar.FloatBar
wx.lib.floatcanvas.FloatCanvas.Arrow
wx.lib.floatcanvas.FloatCanvas.Circle
wx.lib.floatcanvas.FloatCanvas.ColorOnlyMixin
wx.lib.floatcanvas.FloatCanvas.DrawObject
wx.lib.floatcanvas.FloatCanvas.Ellipse
wx.lib.floatcanvas.FloatCanvas.FloatCanvas
wx.lib.floatcanvas.FloatCanvas.Line
wx.lib.floatcanvas.FloatCanvas.LineAndFillMixin
wx.lib.floatcanvas.FloatCanvas.LineOnlyMixin
wx.lib.floatcanvas.FloatCanvas.Point
wx.lib.floatcanvas.FloatCanvas.PointSet
wx.lib.floatcanvas.FloatCanvas.PointsObjectMixin
wx.lib.floatcanvas.FloatCanvas.Polygon
wx.lib.floatcanvas.FloatCanvas.Rectangle
wx.lib.floatcanvas.FloatCanvas.RectEllipse
wx.lib.floatcanvas.FloatCanvas.ScaledText
wx.lib.floatcanvas.FloatCanvas.Text
wx.lib.floatcanvas.FloatCanvas.TextObjectMixin
wx.lib.floatcanvas.FloatCanvas.XYObjectMixin
wx.lib.floatcanvas.NavCanvas.NavCanvas
wx.lib.foldmenu.FoldOutMenu
wx.lib.foldmenu.FoldOutWindow
wx.lib.foldpanelbar.CaptionBar
wx.lib.foldpanelbar.CaptionBarEvent
wx.lib.foldpanelbar.CaptionBarStyle
wx.lib.foldpanelbar.FoldPanelBar
wx.lib.foldpanelbar.FoldPanelItem
wx.lib.foldpanelbar.FoldWindowItem
wx.lib.gestures.MouseGestures
wx.lib.gridmovers.ColDragWindow
wx.lib.gridmovers.GridColMoveEvent
wx.lib.gridmovers.GridColMover
wx.lib.gridmovers.GridRowMoveEvent
wx.lib.gridmovers.GridRowMover
wx.lib.gridmovers.RowDragWindow
wx.lib.grids.PyFlexGridSizer
wx.lib.grids.PyGridSizer
wx.lib.hyperlink.HyperLinkCtrl
wx.lib.hyperlink.HyperLinkEvent
wx.lib.imagebrowser.FindFiles
wx.lib.imagebrowser.ImageDialog
wx.lib.imagebrowser.ImageView
wx.lib.infoframe.Dummy_PyInformationalMessagesFrame
wx.lib.infoframe.PyInformationalMessagesFrame
wx.lib.intctrl.IntCtrl
wx.lib.intctrl.IntUpdatedEvent
wx.lib.intctrl.IntValidator
wx.lib.layoutf.Layoutf
wx.lib.masked.combobox.BaseMaskedComboBox
wx.lib.masked.combobox.ComboBox
wx.lib.masked.combobox.MaskedComboBoxSelectEvent
wx.lib.masked.combobox.PreMaskedComboBox
wx.lib.masked.ctrl.controlTypes
wx.lib.masked.ipaddrctrl.IpAddrCtrl
wx.lib.masked.ipaddrctrl.IpAddrCtrlAccessorsMixin
wx.lib.masked.maskededit.Field
wx.lib.masked.maskededit.MaskedEditAccessorsMixin
wx.lib.masked.maskededit.MaskedEditMixin
wx.lib.masked.numctrl.NumberUpdatedEvent
wx.lib.masked.numctrl.NumCtrl
wx.lib.masked.numctrl.NumCtrlAccessorsMixin
wx.lib.masked.textctrl.BaseMaskedTextCtrl
wx.lib.masked.textctrl.PreMaskedTextCtrl
wx.lib.masked.textctrl.TextCtrl
wx.lib.masked.timectrl.TimeCtrl
wx.lib.masked.timectrl.TimeCtrlAccessorsMixin
wx.lib.masked.timectrl.TimeUpdatedEvent
wx.lib.mixins.grid.GridAutoEditMixin
wx.lib.mixins.imagelist.MagicImageList
wx.lib.mixins.listctrl.ColumnSorterMixin
wx.lib.mixins.listctrl.ListCtrlAutoWidthMixin
wx.lib.mixins.listctrl.ListCtrlSelectionManagerMix
wx.lib.mixins.listctrl.TextEditMixin
wx.lib.mixins.rubberband.RubberBand
wx.lib.multisash.EmptyChild
wx.lib.multisash.MultiClient
wx.lib.multisash.MultiCloser
wx.lib.multisash.MultiCreator
wx.lib.multisash.MultiSash
wx.lib.multisash.MultiSizer
wx.lib.multisash.MultiSplit
wx.lib.multisash.MultiViewLeaf
wx.lib.mvctree.BasicTreeModel
wx.lib.mvctree.Editor
wx.lib.mvctree.FileEditor
wx.lib.mvctree.FileWrapper
wx.lib.mvctree.FSTreeModel
wx.lib.mvctree.LateFSTreeModel
wx.lib.mvctree.LayoutEngine
wx.lib.mvctree.LinePainter
wx.lib.mvctree.MVCTree
wx.lib.mvctree.MVCTreeEvent
wx.lib.mvctree.MVCTreeNode
wx.lib.mvctree.MVCTreeNotifyEvent
wx.lib.mvctree.NodePainter
wx.lib.mvctree.NullTransform
wx.lib.mvctree.Painter
wx.lib.mvctree.Rect
wx.lib.mvctree.StrTextConverter
wx.lib.mvctree.TextConverter
wx.lib.mvctree.Transform
wx.lib.mvctree.TreeLayout
wx.lib.mvctree.TreeLinePainter
wx.lib.mvctree.TreeModel
wx.lib.mvctree.TreeNodePainter
wx.lib.mvctree.TreePainter
wx.lib.ogl.ArrowHead
wx.lib.ogl.BitmapShape
wx.lib.ogl.CircleShape
wx.lib.ogl.CompositeShape
wx.lib.ogl.Constraint
wx.lib.ogl.ConstraintType
wx.lib.ogl.ControlPoint
wx.lib.ogl.Diagram
wx.lib.ogl.DividedShape
wx.lib.ogl.DividedShapeControlPoint
wx.lib.ogl.DivisionControlPoint
wx.lib.ogl.DivisionShape
wx.lib.ogl.DrawnShape
wx.lib.ogl.DrawOp
wx.lib.ogl.EllipseShape
wx.lib.ogl.LabelShape
wx.lib.ogl.LineControlPoint
wx.lib.ogl.LineShape
wx.lib.ogl.OpDraw
wx.lib.ogl.OpPolyDraw
wx.lib.ogl.OpSetClipping
wx.lib.ogl.OpSetGDI
wx.lib.ogl.PolygonControlPoint
wx.lib.ogl.PolygonShape
wx.lib.ogl.PopupDivisionMenu
wx.lib.ogl.PseudoMetaFile
wx.lib.ogl.RectangleShape
wx.lib.ogl.Shape
wx.lib.ogl.ShapeCanvas
wx.lib.ogl.ShapeEvtHandler
wx.lib.ogl.ShapeRegion
wx.lib.ogl.ShapeTextLine
wx.lib.ogl.TextShape
wx.lib.plot.PlotCanvas
wx.lib.plot.PlotGraphics
wx.lib.plot.PlotPrintout
wx.lib.plot.PolyLine
wx.lib.plot.PolyMarker
wx.lib.plot.PolyPoints
wx.lib.plot.TestFrame
wx.lib.popupctl.PopButton
wx.lib.popupctl.PopupControl
wx.lib.popupctl.PopupDialog
wx.lib.printout.PrintBase
wx.lib.printout.PrintGrid
wx.lib.printout.PrintTable
wx.lib.printout.PrintTableDraw
wx.lib.printout.SetPrintout
wx.lib.pubsub.Message
wx.lib.pydocview.AboutDialog
wx.lib.pydocview.AboutService
wx.lib.pydocview.ChildDocTemplate
wx.lib.pydocview.ChildDocument
wx.lib.pydocview.DocApp
wx.lib.pydocview.DocFrameMixIn
wx.lib.pydocview.DocMDIChildFrame
wx.lib.pydocview.DocMDIParentFrame
wx.lib.pydocview.DocMDIParentFrameMixIn
wx.lib.pydocview.DocOptionsService
wx.lib.pydocview.DocSDIFrame
wx.lib.pydocview.DocService
wx.lib.pydocview.DocTabbedChildFrame
wx.lib.pydocview.DocTabbedParentFrame
wx.lib.pydocview.FilePropertiesDialog
wx.lib.pydocview.FilePropertiesService
wx.lib.pydocview.GeneralOptionsPanel
wx.lib.pydocview.OptionsDialog
wx.lib.pydocview.WindowMenuService
wx.lib.pyshell.FauxFile
wx.lib.pyshell.PyShellWindow
wx.lib.rcsizer.RowColSizer
wx.lib.rightalign.RightTextCtrl
wx.lib.scrolledpanel.ScrolledPanel
wx.lib.sheet.CCellEditor
wx.lib.sheet.CSheet
wx.lib.sheet.CTextCellEditor
wx.lib.shell.PyShell
wx.lib.shell.PyShellInput
wx.lib.shell.PyShellOutput
wx.lib.splashscreen.SplashScreen
wx.lib.statbmp.GenStaticBitmap
wx.lib.stattext.GenStaticText
wx.lib.throbber.Throbber
wx.lib.throbber.UpdateThrobberEvent
wx.lib.ticker.Ticker
wx.lib.ticker_xrc.wxTickerXmlHandler
wx.lib.wxPlotCanvas.PlotCanvas
wx.lib.wxPlotCanvas.PlotGraphics
wx.lib.wxPlotCanvas.PolyLine
wx.lib.wxPlotCanvas.PolyMarker
wx.lib.wxPlotCanvas.PolyPoints
wx.lib.wxpTag.wxpTagHandler
wx.Listbook
wx.ListbookEvent
wx.ListBox
wx.ListCtrl
wx.ListEvent
wx.ListItem
wx.ListItemAttr
wx.ListView
wx.Locale
wx.Log
wx.LogChain
wx.LogGui
wx.LogNull
wx.LogStderr
wx.LogTextCtrl
wx.LogWindow
wx.Mask
wx.MaximizeEvent
wx.MDIChildFrame
wx.MDIClientWindow
wx.MDIParentFrame
wx.media.MediaCtrl
wx.media.MediaEvent
wx.MemoryDC
wx.MemoryFSHandler
wx.Menu
wx.MenuBar
wx.MenuEvent
wx.MenuItem
wx.MessageDialog
wx.MetaFile
wx.MetafileDataObject
wx.MetaFileDC
wx.MimeTypesManager
wx.MiniFrame
wx.MirrorDC
wx.MouseCaptureChangedEvent
wx.MouseEvent
wx.MoveEvent
wx.MultiChoiceDialog
wx.MutexGuiLocker
wx.NativeEncodingInfo
wx.NativeFontInfo
wx.NavigationKeyEvent
wx.NcPaintEvent
wx.Notebook
wx.NotebookEvent
wx.NotebookPage
wx.NotebookSizer
wx.NotifyEvent
wx.Object
wx.OutputStream
wx.PageSetupDialog
wx.PageSetupDialogData
wx.PaintDC
wx.PaintEvent
wx.Palette
wx.PaletteChangedEvent
wx.Panel
wx.PasswordEntryDialog
wx.PCXHandler
wx.Pen
wx.PenList
wx.PNGHandler
wx.PNMHandler
wx.Point
wx.Point2D
wx.PopupTransientWindow
wx.PopupWindow
wx.PostScriptDC
wx.PreviewCanvas
wx.PreviewControlBar
wx.PreviewFrame
wx.PrintData
wx.PrintDialog
wx.PrintDialogData
wx.Printer
wx.PrinterDC
wx.Printout
wx.PrintPreview
wx.Process
wx.ProcessEvent
wx.ProgressDialog
wx.PropagateOnce
wx.PropagationDisabler
wx.py.buffer.Buffer
wx.py.crust.Calltip
wx.py.crust.Crust
wx.py.crust.CrustFrame
wx.py.crust.DispatcherListing
wx.py.crust.Display
wx.py.crust.SessionListing
wx.py.dispatcher.BoundMethodWeakref
wx.py.dispatcher.Parameter
wx.py.document.Document
wx.py.editor.DialogResults
wx.py.editor.Editor
wx.py.editor.EditorFrame
wx.py.editor.EditorNotebook
wx.py.editor.EditorNotebookFrame
wx.py.editor.EditorShellNotebook
wx.py.editor.EditorShellNotebookFrame
wx.py.editor.EditWindow
wx.py.editwindow.EditWindow
wx.py.filling.App
wx.py.filling.Filling
wx.py.filling.FillingFrame
wx.py.filling.FillingText
wx.py.filling.FillingTree
wx.py.frame.Frame
wx.py.interpreter.Interpreter
wx.py.interpreter.InterpreterAlaCarte
wx.py.pseudo.PseudoFile
wx.py.pseudo.PseudoFileErr
wx.py.pseudo.PseudoFileIn
wx.py.pseudo.PseudoFileOut
wx.py.pseudo.PseudoKeyword
wx.py.PyAlaCarte.App
wx.py.PyAlaMode.App
wx.py.PyAlaModeTest.App
wx.py.PyCrust.App
wx.py.PyFilling.App
wx.py.PyShell.App
wx.py.shell.Shell
wx.py.shell.ShellFacade
wx.py.shell.ShellFrame
wx.PyApp
wx.PyBitmapDataObject
wx.PyCommandEvent
wx.PyControl
wx.PyDataObjectSimple
wx.PyEvent
wx.PyEventBinder
wx.PyLog
wx.PyOnDemandOutputWindow
wx.PyPanel
wx.PyPreviewControlBar
wx.PyPreviewFrame
wx.PyPrintPreview
wx.PyScrolledWindow
wx.PySimpleApp
wx.PySizer
wx.PyTextDataObject
wx.PyTimer
wx.PyTipProvider
wx.PyValidator
wx.PyWidgetTester
wx.PyWindow
wx.Quantize
wx.QueryLayoutInfoEvent
wx.QueryNewPaletteEvent
wx.RadioBox
wx.RadioButton
wx.RealPoint
wx.Rect
wx.Region
wx.RegionIterator
wx.SashEvent
wx.SashLayoutWindow
wx.SashWindow
wx.ScreenDC
wx.ScrollBar
wx.ScrolledWindow
wx.ScrollEvent
wx.ScrollWinEvent
wx.SetCursorEvent
wx.ShowEvent
wx.SimpleHelpProvider
wx.SingleChoiceDialog
wx.SingleInstanceChecker
wx.Size
wx.SizeEvent
wx.Sizer
wx.SizerItem
wx.Slider
wx.Sound
wx.SpinButton
wx.SpinCtrl
wx.SpinEvent
wx.SplashScreen
wx.SplashScreenWindow
wx.SplitterEvent
wx.SplitterWindow
wx.StandardPaths
wx.StaticBitmap
wx.StaticBox
wx.StaticBoxSizer
wx.StaticLine
wx.StaticText
wx.StatusBar
wx.stc.StyledTextCtrl
wx.stc.StyledTextEvent
wx.StdDialogButtonSizer
wx.StopWatch
wx.SysColourChangedEvent
wx.SystemOptions
wx.SystemSettings
wx.TaskBarIcon
wx.TaskBarIconEvent
wx.TextAttr
wx.TextCtrl
wx.TextDataObject
wx.TextDropTarget
wx.TextEntryDialog
wx.TextUrlEvent
wx.TIFFHandler
wx.Timer
wx.TimerEvent
wx.TimerRunner
wx.TimeSpan
wx.TipProvider
wx.TipWindow
wx.ToggleButton
wx.ToolBar
wx.ToolBarBase
wx.ToolBarToolBase
wx.tools.dbg.Logger
wx.ToolTip
wx.TopLevelWindow
wx.TreeCtrl
wx.TreeEvent
wx.TreeItemData
wx.TreeItemId
wx.UpdateUIEvent
wx.URLDataObject
wx.Validator
wx.VideoMode
wx.VisualAttributes
wx.VListBox
wx.VScrolledWindow
wx.webkit.WebKitCtrl
wx.webkit.WebKitStateChangedEvent
wx.Window
wx.WindowCreateEvent
wx.WindowDC
wx.WindowDestroyEvent
wx.WindowDisabler
wx.wizard.PyWizardPage
wx.wizard.Wizard
wx.wizard.WizardEvent
wx.wizard.WizardPage
wx.wizard.WizardPageSimple
wx.XPMHandler
wx.xrc.XmlDocument
wx.xrc.XmlNode
wx.xrc.XmlProperty
wx.xrc.XmlResource
wx.xrc.XmlResourceHandler
wx.xrc.XmlSubclassFactory
wx.xrc.XmlSubclassFactory_Python
wx.ZipFSHandler

All Exceptions
wx.lib.floatcanvas.FloatCanvas.FloatCanvasError
wx.py.dispatcher.DispatcherError
wx.PyAssertionError
wx.PyDeadObjectError
wx.PyNoAppError
wx.PyUnbornObjectError
wxversion.VersionError

All Functions
alertDialog
App_CleanUp
App_GetComCtl32Version
App_GetMacAboutMenuItemId
App_GetMacExitMenuItemId
App_GetMacHelpMenuTitleName
App_GetMacPreferencesMenuItemId
App_GetMacSupportPCMenuShortcuts
App_SetMacAboutMenuItemId
App_SetMacExitMenuItemId
App_SetMacHelpMenuTitleName
App_SetMacPreferencesMenuItemId
App_SetMacSupportPCMenuShortcuts
ArtProvider_GetBitmap
ArtProvider_GetIcon
ArtProvider_GetSizeHint
ArtProvider_PopProvider
ArtProvider_PushProvider
ArtProvider_RemoveProvider
BeginBusyCursor
Bell
BitmapFromBits
BitmapFromIcon
BitmapFromImage
BitmapFromXPMData
BookCtrlBase_GetClassDefaultAttributes
boxToExtent
BrushFromBitmap
Button_GetClassDefaultAttributes
Button_GetDefaultSize
CalendarCtrl_GetClassDefaultAttributes
CallAfter
Caret_GetBlinkTime
Caret_SetBlinkTime
CentreText
CheckBox_GetClassDefaultAttributes
checkInstalled
CheckLineIntersection
Choice_GetClassDefaultAttributes
ClientDisplayRect
Clipboard_Get
colorDialog
ColorRGB
colourDialog
ColourDisplay
ColourRGB
ComboBox_GetClassDefaultAttributes
ConfigBase_Create
ConfigBase_DontCreateOnDemand
ConfigBase_Get
ConfigBase_Set
connect
Control_GetClassDefaultAttributes
convert
ConvertBMP
CreateFileTipProvider
crunch_data
Ctrl
CursorFromImage
CustomDataFormat
DateSpan_Day
DateSpan_Days
DateSpan_Month
DateSpan_Months
DateSpan_Week
DateSpan_Weeks
DateSpan_Year
DateSpan_Years
DateTime_ConvertYearToBC
DateTime_GetAmPmStrings
DateTime_GetBeginDST
DateTime_GetCentury
DateTime_GetCountry
DateTime_GetCurrentMonth
DateTime_GetCurrentYear
DateTime_GetEndDST
DateTime_GetMonthName
DateTime_GetNumberOfDaysInMonth
DateTime_GetNumberOfDaysinYear
DateTime_GetWeekDayName
DateTime_IsDSTApplicable
DateTime_IsLeapYear
DateTime_IsWestEuropeanCountry
DateTime_Now
DateTime_SetCountry
DateTime_SetToWeekOfYear
DateTime_Today
DateTime_UNow
DateTimeFromDMY
DateTimeFromHMS
DateTimeFromJDN
DateTimeFromTimeT
dayOfWeek
daysPerMonth
DefaultColors
Dialog_GetClassDefaultAttributes
dirDialog
directory
directoryDialog
DirSelector
disconnect
Display_GetCount
Display_GetFromPoint
Display_GetFromWindow
DisplayDepth
DisplaySize
DisplaySizeMM
DLG_PNT
DLG_SZE
DragIcon
DragListItem
DragString
DragTreeItem
DrawArcToEllipse
DrawFormattedText
DrawSash
DrawWindowOnDC
DROP_ICON
EmptyBitmap
EmptyIcon
EmptyImage
EmptyXmlDocument
EmptyXmlResource
EnableTopLevelWindows
EncodingConverter_CanConvert
EncodingConverter_GetAllEquivalents
EncodingConverter_GetPlatformEquivalents
EndBusyCursor
ensureMinimal
EventLoop_GetActive
EventLoop_SetActive
EVT_LEFT_DCLICK
EVT_LEFT_DOWN
EVT_LEFT_UP
EVT_MIDDLE_DCLICK
EVT_MIDDLE_DOWN
EVT_MIDDLE_UP
EVT_MOTION
EVT_MOUSEWHEEL
EVT_RIGHT_DCLICK
EVT_RIGHT_DOWN
EVT_RIGHT_UP
Execute
Exit
ExpandEnvVars
FFont
FFontFromPixelSize
fileDialog
fileDialog
FileExists
FileNameFromPath
FileSelector
FileSystem_AddHandler
FileSystem_CleanUpHandlers
FileSystem_FileNameToURL
FileSystem_URLToFileName
FileType_ExpandCommand
FileTypeInfoSequence
FillDate
findDialog
FindEndForBox
FindEndForCircle
FindEndForPolyline
FindExtension
FindWindowAtPoint
FindWindowById
FindWindowByLabel
FindWindowByName
Font2
Font_GetDefaultEncoding
Font_SetDefaultEncoding
fontDialog
FontFromNativeInfo
FontFromNativeInfoString
FontFromPixelSize
FontMapper_Get
FontMapper_GetDefaultConfigPath
FontMapper_GetEncoding
FontMapper_GetEncodingDescription
FontMapper_GetEncodingFromName
FontMapper_GetEncodingName
FontMapper_GetSupportedEncodingsCount
FontMapper_Set
ForceBetween
FormatDay
FormatText
Frame_GetClassDefaultAttributes
FromJulian
Gauge_GetClassDefaultAttributes
GBSizerItemSizer
GBSizerItemSpacer
GBSizerItemWindow
GenericFindWindowAtPoint
GetAccelFromString
GetActiveWindow
getAllAttributeNames
GetApp
GetArrowPoints
getAttributeNames
getAutoCompleteList
getBaseObject
getBitmap
GetBitmap
getBlankBitmap
getBlankData
getBlankIcon
getBlankImage
getCallTip
GetCentredTextExtent
GetClientDisplayRect
GetCollapsedIconBitmap
GetCollapsedIconData
GetCollapsedIconImage
getColourInfoList
getColourList
getConstructor
getCopyBitmap
getCopyData
getCopyImage
GetCurrentId
GetCurrentTime
getCursorPosition
getCutBitmap
getCutData
getCutImage
getData
GetDefaultPyEncoding
GetDisplayDepth
GetDisplaySize
GetDisplaySizeMM
GetElapsedTime
GetEmailAddress
GetExpandedIconBitmap
GetExpandedIconData
GetExpandedIconImage
getExtent
GetExtent
GetFreeMemory
GetFullExtent
GetFullHostName
GetHandBitmap
GetHandData
GetHomeDir
GetHostName
getImage
GetImage
getInstalled
GetKeyState
getListCtrlSelection
GetLocale
GetLocalTime
GetLocalTimeMillis
GetMinusBitmap
GetMinusData
GetMonthList
GetMousePosition
GetNativeFontEncoding
getNewBitmap
getNewData
getNewImage
GetNumberFromUser
getOpenBitmap
getOpenData
getOpenImage
GetOsDescription
GetOsVersion
GetPasswordFromUser
getPasteBitmap
getPasteData
getPasteImage
GetPlusBitmap
GetPlusData
GetPointerBitmap
GetPointerData
GetPointerImage
GetPointOnLine
getPrintBitmap
getPrintData
getPrintImage
getPrintPreviewBitmap
getPrintPreviewData
getPrintPreviewImage
GetProcessId
getPyBitmap
getPyData
getPyIcon
getPyImage
getRedoBitmap
getRedoData
getRedoImage
getRoot
getSaveAllBitmap
getSaveAllData
getSaveAllImage
getSaveBitmap
getSaveData
getSaveImage
GetSingleChoice
GetSingleChoiceIndex
GetSize
GetStockLabel
getStrAllTopics
GetTextFromUser
getTokens
GetTopLevelParent
GetTopLevelWindows
GetTranslation
getUndoBitmap
getUndoData
getUndoImage
GetUserHome
GetUserId
GetUserName
GetUTCTime
GetXDisplay
GLCanvasWithContext
GraphicsStraightenLine
grayOut
Grid_GetClassDefaultAttributes
hasattrAlwaysReturnsTrue
HelpProvider_Get
HelpProvider_Set
HtmlPrintout_AddFilter
HtmlPrintout_CleanUpStatics
HtmlWindow_AddFilter
HtmlWindow_GetClassDefaultAttributes
HtmlWinParser_AddTagHandler
IconBundleFromFile
IconBundleFromIcon
IconFromBitmap
IconFromLocation
IconFromXPMData
IdleEvent_CanSend
IdleEvent_GetMode
IdleEvent_SetMode
Image_AddHandler
Image_CanRead
Image_CanReadStream
Image_GetImageCount
Image_GetImageExtWildcard
Image_InsertHandler
Image_RemoveHandler
ImageFromBitmap
ImageFromData
ImageFromDataWithAlpha
ImageFromMime
ImageFromStream
ImageFromStreamMime
ImageHistogram_MakeKey
InitAllImageHandlers
IntersectRect
IsBusy
IsDragResultOk
isleap
isNegative
IsStockID
IsStockLabel
julianDay
Kill
LaunchDefaultBrowser
leapdays
LineSplitter
LineTrimmer
ListBox_GetClassDefaultAttributes
ListCtrl_GetClassDefaultAttributes
LoadFileSelector
Locale_AddCatalogLookupPathPrefix
Locale_AddLanguage
Locale_FindLanguageInfo
Locale_GetLanguageInfo
Locale_GetLanguageName
Locale_GetSystemEncoding
Locale_GetSystemEncodingName
Locale_GetSystemLanguage
Log_AddTraceMask
Log_ClearTraceMasks
Log_DontCreateOnDemand
Log_EnableLogging
Log_FlushActive
Log_GetActiveTarget
Log_GetLogLevel
Log_GetTimestamp
Log_GetTraceMask
Log_GetTraceMasks
Log_GetVerbose
Log_IsAllowedTraceMask
Log_IsEnabled
Log_OnLog
Log_RemoveTraceMask
Log_Resume
Log_SetActiveTarget
Log_SetLogLevel
Log_SetTimestamp
Log_SetTraceMask
Log_SetVerbose
Log_Suspend
Log_TimeStamp
LogDebug
LogError
LogFatalError
LogGeneric
LogInfo
LogMessage
LogStatus
LogStatusFrame
LogSysError
LogTrace
LogVerbose
LogWarning
main
main
main
main
main
main
main
main
main
main
main
main
main
MakeColor
makeGray
MaskColour
MemoryDCFromDC
MemoryFSHandler_AddFile
MemoryFSHandler_RemoveFile
MenuItem_GetDefaultMarginWidth
MenuItem_GetLabelFromText
MessageBox
messageDialog
messageDialog
MicroSleep
MilliSleep
MimeTypesManager_IsOfType
multipleChoiceDialog
MutexGuiEnter
MutexGuiLeave
NamedColor
NamedColour
NewCommandEvent
NewEvent
NewEventType
NewId
normalizeBox
Notebook_GetClassDefaultAttributes
Now
NullFileTypeInfo
OGLCleanUp
OGLConstraint
OGLInitialize
OnFileDlg
openFileDialog
openMultiple
openSingle
Panel_GetClassDefaultAttributes
PathOnly
Point2DCopy
Point2DFromPoint
pointInBox
pointOnBox
PolylineHitTest
PostEvent
PostScriptDC_GetResolution
PostScriptDC_SetResolution
PreBitmapButton
PreButton
PreCalendarCtrl
PreCheckBox
PreCheckListBox
PreChoice
PreChoicebook
PreComboBox
PreControl
PreDatePickerCtrl
PreDialog
PreDirFilterListCtrl
PreDynamicSashWindow
PreFindReplaceDialog
PreFrame
PreGauge
PreGenericDirCtrl
PreGIFAnimationCtrl
PreGrid
PreHtmlListBox
PreHtmlWindow
PreLEDNumberCtrl
PreListbook
PreListBox
PreListCtrl
PreListView
PreMDIChildFrame
PreMDIClientWindow
PreMDIParentFrame
PreMediaCtrl
PreMiniFrame
PreNotebook
PrePanel
PrePopupTransientWindow
PrePopupWindow
PrePyControl
PrePyPanel
PrePyScrolledWindow
PrePyWindow
PrePyWizardPage
PreRadioBox
PreRadioButton
PreSashLayoutWindow
PreSashWindow
PreScrollBar
PreScrolledWindow
PreSingleInstanceChecker
PreSlider
PreSpinButton
PreSpinCtrl
PreSplitterWindow
PreStaticBitmap
PreStaticBox
PreStaticLine
PreStaticPicture
PreStaticText
PreStatusBar
PreStyledTextCtrl
PreTextCtrl
PreToggleButton
PreToolBar
PreTreeCtrl
PreTreeListCtrl
PreVListBox
PreVScrolledWindow
PreWebKitCtrl
PreWindow
PreWizard
PreWizardPageSimple
Printer_GetLastError
Process_Exists
Process_Kill
Process_Open
PyApp_GetComCtl32Version
PyApp_GetMacAboutMenuItemId
PyApp_GetMacExitMenuItemId
PyApp_GetMacHelpMenuTitleName
PyApp_GetMacPreferencesMenuItemId
PyApp_GetMacSupportPCMenuShortcuts
PyApp_IsMainLoopRunning
PyApp_SetMacAboutMenuItemId
PyApp_SetMacExitMenuItemId
PyApp_SetMacHelpMenuTitleName
PyApp_SetMacPreferencesMenuItemId
PyApp_SetMacSupportPCMenuShortcuts
Quantize_Quantize
RadioBox_GetClassDefaultAttributes
RadioButton_GetClassDefaultAttributes
RectPP
RectPS
RectS
RegionFromBitmap
RegionFromBitmapColour
RegionFromPoints
RegisterId
renderToBitmap
RenderToBitmap
RenderToDC
renderToDC
RestOfLine
returnedString
RoughlyEqual
rtrimTerminus
safeRef
SafeShowMessage
SafeYield
saveFileDialog
SaveFileSelector
saveSingle
ScrollBar_GetClassDefaultAttributes
scrolledMessageDialog
ScrolledWindow_GetClassDefaultAttributes
select
selectBeforePopup
Selection
send
SetCursor
SetDefaultPyEncoding
Shell
ShowTip
Shutdown
singleChoiceDialog
SizerItemSizer
SizerItemSpacer
SizerItemWindow
Sleep
Slider_GetClassDefaultAttributes
Sound_PlaySound
Sound_Stop
SoundFromData
SpinButton_GetClassDefaultAttributes
SpinCtrl_GetClassDefaultAttributes
SplitterWindow_GetClassDefaultAttributes
StandardPaths_Get
StartTimer
StaticBitmap_GetClassDefaultAttributes
StaticBox_GetClassDefaultAttributes
StaticLine_GetClassDefaultAttributes
StaticLine_GetDefaultSize
StaticText_GetClassDefaultAttributes
StatusBar_GetClassDefaultAttributes
StockCursor
StripMenuCodes
SysErrorCode
SysErrorMsg
SystemOptions_GetOption
SystemOptions_GetOptionInt
SystemOptions_HasOption
SystemOptions_IsFalse
SystemOptions_SetOption
SystemOptions_SetOptionInt
SystemSettings_GetColour
SystemSettings_GetFont
SystemSettings_GetMetric
SystemSettings_GetScreenType
SystemSettings_HasFeature
SystemSettings_SetScreenType
test
TestFontEncoding
TextAttr_Combine
TextCtrl_GetClassDefaultAttributes
textEntryDialog
Thread_IsMain
TimeSpan_Day
TimeSpan_Days
TimeSpan_Hour
TimeSpan_Hours
TimeSpan_Minute
TimeSpan_Minutes
TimeSpan_Second
TimeSpan_Seconds
TimeSpan_Week
TimeSpan_Weeks
TodayDay
ToggleButton_GetClassDefaultAttributes
ToolBar_GetClassDefaultAttributes
ToolTip_Enable
ToolTip_SetDelay
Trap
TreeCtrl_GetClassDefaultAttributes
updateColourDB
UpdateUIEvent_CanUpdate
UpdateUIEvent_GetMode
UpdateUIEvent_GetUpdateInterval
UpdateUIEvent_ResetUpdateTime
UpdateUIEvent_SetMode
UpdateUIEvent_SetUpdateInterval
Usleep
Validator_IsSilent
Validator_SetBellOnError
WakeUpIdle
WakeUpMainThread
WhollyContains
Window_FindFocus
Window_FromHWND
Window_GetCapture
Window_GetClassDefaultAttributes
Window_NewControlId
Window_NextControlId
Window_PrevControlId
WizardPageSimple_Chain
wrap
XmlDocumentFromStream
XmlNodeEasy
XmlResource_AddSubclassFactory
XmlResource_Get
XmlResource_GetXRCID
XmlResource_Set
XRCCTRL
XRCID
Yield
YieldIfNeeded

All Variables
__author__
__author__
__author__
__author__
__author__
__author__
__author__
__author__
__author__
__author__
__author__
__author__
__author__
__author__
__author__
__author__
__author__
__author__
__author__
__author__
__author__
__author__
__author__
__cvsid__
__cvsid__
__cvsid__
__cvsid__
__cvsid__
__cvsid__
__cvsid__
__cvsid__
__cvsid__
__cvsid__
__cvsid__
__cvsid__
__cvsid__
__cvsid__
__cvsid__
__cvsid__
__cvsid__
__cvsid__
__cvsid__
__cvsid__
__cvsid__
__cvsid__
__revision__
__revision__
__revision__
__revision__
__revision__
__revision__
__revision__
__revision__
__revision__
__revision__
__revision__
__revision__
__revision__
__revision__
__revision__
__revision__
__revision__
__revision__
__revision__
__revision__
__revision__
__revision__
__version__
__version__
AbrWeekday
ALL_TOPICS
am_pm_exclude
Anonymous
ansichars
Any
app
autoformats
BusCalDays
CalDays
CAPTIONBAR_FILLED_RECTANGLE
CAPTIONBAR_GRADIENT_H
CAPTIONBAR_GRADIENT_V
CAPTIONBAR_NOSTYLE
CAPTIONBAR_RECTANGLE
CAPTIONBAR_SINGLE
charmonths
charmonths_dict
COLOR_3D_DARK
COLOR_3D_LIGHT
COLOR_BACKGROUND
COLOR_BORDER
COLOR_FONT
COLOR_GRID_LINES
COLOR_HEADER_BACKGROUND
COLOR_HEADER_FONT
COLOR_HIGHLIGHT_BACKGROUND
COLOR_HIGHLIGHT_FONT
COLOR_SELECTION_BACKGROUND
COLOR_SELECTION_FONT
COLOR_WEEKEND_BACKGROUND
COLOR_WEEKEND_FONT
COMBO
COMMONTYPES
connections
control
CR_SIZE
day_abbr
day_name
days
dbg
dbg
DEFAULT_DOCMAN_FLAGS
DEFAULT_TEMPLATE_FLAGS
dir_path
DOC_MDI
DOC_NEW
DOC_OPEN_ONCE
DOC_SDI
DOC_SILENT
DOCTYPES
EMBEDDED_WINDOW_ALL
EMBEDDED_WINDOW_BOTTOM
EMBEDDED_WINDOW_BOTTOMLEFT
EMBEDDED_WINDOW_BOTTOMRIGHT
EMBEDDED_WINDOW_LEFT
EMBEDDED_WINDOW_RIGHT
EMBEDDED_WINDOW_TOP
EMBEDDED_WINDOW_TOPLEFT
EMBEDDED_WINDOW_TOPRIGHT
EofImageData
eventManager
EVT_CALENDAR
EVT_CAPTIONBAR
EVT_COLOURSELECT
EVT_DOPOPUPMENU
EVT_FC_ENTER_OBJECT
EVT_FC_LEAVE_OBJECT
EVT_FC_LEFT_DCLICK
EVT_FC_LEFT_DOWN
EVT_FC_LEFT_UP
EVT_FC_MIDDLE_DCLICK
EVT_FC_MIDDLE_DOWN
EVT_FC_MIDDLE_UP
EVT_FC_MOTION
EVT_FC_MOUSEWHEEL
EVT_FC_RIGHT_DCLICK
EVT_FC_RIGHT_DOWN
EVT_FC_RIGHT_UP
EVT_GRID_COL_MOVE
EVT_GRID_ROW_MOVE
EVT_HYPERLINK_LEFT
EVT_HYPERLINK_MIDDLE
EVT_HYPERLINK_RIGHT
EVT_INT
EVT_MVCTREE_ADD_ITEM
EVT_MVCTREE_DELETE_ITEM
EVT_MVCTREE_ITEM_COLLAPSED
EVT_MVCTREE_ITEM_COLLAPSING
EVT_MVCTREE_ITEM_EXPANDED
EVT_MVCTREE_ITEM_EXPANDING
EVT_MVCTREE_KEY_DOWN
EVT_MVCTREE_SEL_CHANGED
EVT_MVCTREE_SEL_CHANGING
EVT_NUM
EVT_TIMEUPDATE
EVT_UPDATE_THROBBER
FPB_ALIGN_LEFT
FPB_ALIGN_WIDTH
FPB_BMP_RIGHTSPACE
FPB_COLLAPSE_TO_BOTTOM
FPB_DEFAULT_EXTRASTYLE
FPB_DEFAULT_LEFTLINESPACING
FPB_DEFAULT_LEFTSPACING
FPB_DEFAULT_RIGHTLINESPACING
FPB_DEFAULT_RIGHTSPACING
FPB_DEFAULT_SPACING
FPB_DEFAULT_STYLE
FPB_EXCLUSIVE_FOLD
FPB_EXTRA_X
FPB_EXTRA_Y
FPB_HORIZONTAL
FPB_SINGLE_FOLD
FPB_VERTICAL
hours
ID_ABOUT
ID_AUTOCOMP
ID_AUTOCOMP_DOUBLE
ID_AUTOCOMP_MAGIC
ID_AUTOCOMP_SHOW
ID_AUTOCOMP_SINGLE
ID_CALLTIPS
ID_CALLTIPS_SHOW
ID_CLEAR
ID_CLOSE
ID_COPY
ID_COPY_PLUS
ID_CUT
ID_EXIT
ID_MOVE_MODE_BUTTON
ID_NAMESPACE
ID_NEW
ID_OPEN
ID_PASTE
ID_PASTE_PLUS
ID_POINTER_BUTTON
ID_PRINT
ID_REDO
ID_REVERT
ID_SAVE
ID_SAVEAS
ID_SELECTALL
ID_UNDO
ID_USEAA
ID_WRAP
ID_ZOOM_IN_BUTTON
ID_ZOOM_OUT_BUTTON
ID_ZOOM_TO_FIT_BUTTON
IPADDR
maskchars
masktags
MAX_FILE_HISTORY
mdays
milhours
MININT
MININT
minutes
Month
months
MV_HOR
MV_VER
nav
NAVKEYS
NUMBER
original
original
PARAMTAG
Publisher
SAVEALL_ID
seconds
SEL_FOC
senders
SH_SIZE
SIMPLETYPES
state_names
states
TEMPLATE_INVISIBLE
TEMPLATE_VISIBLE
TEXT
THROBBER_EVENT
TIME
UPDATE_URL
VERSION
VIEW_STATUSBAR_ID
VIEW_TOOLBAR_ID
warningmsg
warningmsg
warningmsg
warningmsg
warningmsg
warningmsg
warningmsg
WINDOW_MENU_NUM_ITEMS
wxEVT_CAPTIONBAR
wxEVT_COMMAND_COLOURSELECT
wxEVT_COMMAND_GRID_COL_MOVE
wxEVT_COMMAND_GRID_ROW_MOVE
wxEVT_COMMAND_INT_UPDATED
wxEVT_COMMAND_MASKED_NUMBER_UPDATED
wxEVT_COMMAND_PYCALENDAR_DAY_CLICKED
wxEVT_DOPOPUPMENU
wxEVT_HYPERLINK_LEFT
wxEVT_HYPERLINK_MIDDLE
wxEVT_HYPERLINK_RIGHT
wxEVT_MVCTREE_ITEM_COLLAPSED
wxEVT_MVCTREE_ITEM_COLLAPSING
wxEVT_MVCTREE_ITEM_EXPANDED
wxEVT_MVCTREE_ITEM_EXPANDING
wxEVT_MVCTREE_KEY_DOWN
wxEVT_MVCTREE_SEL_CHANGED
wxEVT_TIMEVAL_UPDATED
wxHYPERLINKS_POPUP_COPY
WXK_CTRL_C
WXK_CTRL_S
WXK_CTRL_V
WXK_CTRL_V
WXK_CTRL_X
WXK_CTRL_X
WXK_CTRL_Z
WXPTAG


wx.animate

animate
Classes
AnimationBase
AnimationPlayer
GIFAnimation
GIFAnimationCtrl

Functions
PreGIFAnimationCtrl


wx.build

build
Modules


wx.calendar

calendar
Classes
CalendarCtrl
CalendarDateAttr
CalendarEvent

Functions
CalendarCtrl_GetClassDefaultAttributes
PreCalendarCtrl


wx.gizmos

gizmos
Classes
DynamicSashSplitEvent
DynamicSashUnifyEvent
DynamicSashWindow
EditableListBox
LEDNumberCtrl
RemotelyScrolledTreeCtrl
SplitterScrolledWindow
StaticPicture
ThinSplitterWindow
TreeCompanionWindow
TreeListColumnInfo
TreeListCtrl

Functions
PreDynamicSashWindow
PreLEDNumberCtrl
PreStaticPicture
PreTreeListCtrl


wx.glcanvas

glcanvas
Classes
GLCanvas
GLContext

Functions
GLCanvasWithContext


wx.grid

grid
Classes
Grid
GridCellAttr
GridCellAttrProvider
GridCellAutoWrapStringEditor
GridCellAutoWrapStringRenderer
GridCellBoolEditor
GridCellBoolRenderer
GridCellChoiceEditor
GridCellCoords
GridCellDateTimeRenderer
GridCellEditor
GridCellEnumEditor
GridCellEnumRenderer
GridCellFloatEditor
GridCellFloatRenderer
GridCellNumberEditor
GridCellNumberRenderer
GridCellRenderer
GridCellStringRenderer
GridCellTextEditor
GridEditorCreatedEvent
GridEvent
GridRangeSelectEvent
GridSizeEvent
GridStringTable
GridTableBase
GridTableMessage
PyGridCellAttrProvider
PyGridCellEditor
PyGridCellRenderer
PyGridTableBase

Functions
Grid_GetClassDefaultAttributes
PreGrid


wx.html

html
Classes
DefaultHtmlRenderingStyle
HtmlBookRecord
HtmlCell
HtmlColourCell
HtmlContainerCell
HtmlContentsItem
HtmlDCRenderer
HtmlEasyPrinting
HtmlFilter
HtmlFontCell
HtmlHelpController
HtmlHelpData
HtmlHelpFrame
HtmlLinkInfo
HtmlParser
HtmlPrintout
HtmlRenderingInfo
HtmlRenderingState
HtmlRenderingStyle
HtmlSearchStatus
HtmlSelection
HtmlTag
HtmlTagHandler
HtmlWidgetCell
HtmlWindow
HtmlWinParser
HtmlWinTagHandler
HtmlWordCell

Functions
HtmlPrintout_AddFilter
HtmlPrintout_CleanUpStatics
HtmlWindow_AddFilter
HtmlWindow_GetClassDefaultAttributes
HtmlWinParser_AddTagHandler
PreHtmlWindow


wx.lib.analogclock

analogclock
Classes
AnalogClockWindow


wx.lib.analogclockopts

analogclockopts
Classes
ACCustomizationFrame


wx.lib.anchors

anchors
Classes
LayoutAnchors


wx.lib.buttons

buttons
Classes
GenBitmapButton
GenBitmapTextButton
GenBitmapTextToggleButton
GenBitmapToggleButton
GenButton
GenButtonEvent
GenToggleButton


wx.lib.calendar

calendar
Classes
CalDraw
Calendar
CalenDlg
PrtCalDraw

Functions
DefaultColors
GetMonthList
MakeColor

Variables
AbrWeekday
BusCalDays
CalDays
COLOR_3D_DARK
COLOR_3D_LIGHT
COLOR_BACKGROUND
COLOR_BORDER
COLOR_FONT
COLOR_GRID_LINES
COLOR_HEADER_BACKGROUND
COLOR_HEADER_FONT
COLOR_HIGHLIGHT_BACKGROUND
COLOR_HIGHLIGHT_FONT
COLOR_SELECTION_BACKGROUND
COLOR_SELECTION_FONT
COLOR_WEEKEND_BACKGROUND
COLOR_WEEKEND_FONT
EVT_CALENDAR
wxEVT_COMMAND_PYCALENDAR_DAY_CLICKED


wx.lib.CDate

CDate
Classes
Date
now

Functions
dayOfWeek
daysPerMonth
FillDate
FormatDay
FromJulian
isleap
julianDay
leapdays
TodayDay

Variables
day_abbr
day_name
mdays
Month


wx.lib.ClickableHtmlWindow

ClickableHtmlWindow
Classes
PyClickableHtmlWindow


wx.lib.colourchooser.canvas

canvas
Classes
BitmapBuffer
Canvas


wx.lib.colourchooser.pycolourbox

pycolourbox
Classes
PyColourBox


wx.lib.colourchooser.pycolourchooser

pycolourchooser
Classes
PyColourChooser

Functions
main


wx.lib.colourchooser.pycolourslider

pycolourslider
Classes
PyColourSlider


wx.lib.colourchooser.pypalette

pypalette
Classes
PyPalette

Functions
getBitmap
getData
getImage


wx.lib.colourchooser

colourchooser
Modules
canvas
pycolourbox
pycolourchooser
pycolourslider
pypalette


wx.lib.colourdb

colourdb
Functions
getColourInfoList
getColourList
updateColourDB

Variables


wx.lib.colourselect

colourselect
Classes
ColourSelect
ColourSelectEvent

Variables
EVT_COLOURSELECT
wxEVT_COMMAND_COLOURSELECT


wx.lib.dialogs

dialogs
Classes
DialogResults
MultipleChoiceDialog
ScrolledMessageDialog

Functions
alertDialog
colorDialog
colourDialog
dirDialog
directoryDialog
fileDialog
findDialog
fontDialog
messageDialog
multipleChoiceDialog
openFileDialog
returnedString
saveFileDialog
scrolledMessageDialog
singleChoiceDialog
textEntryDialog


wx.lib.docview

docview
Classes
Command
CommandProcessor
DocChildFrame
DocManager
DocMDIChildFrame
DocMDIParentFrame
DocParentFrame
DocPrintout
DocTemplate
Document
View

Functions
FileExists
FileNameFromPath
FindExtension
PathOnly

Variables
DEFAULT_DOCMAN_FLAGS
DEFAULT_TEMPLATE_FLAGS
DOC_MDI
DOC_NEW
DOC_OPEN_ONCE
DOC_SDI
DOC_SILENT
MAX_FILE_HISTORY
TEMPLATE_INVISIBLE
TEMPLATE_VISIBLE


wx.lib.editor.editor

editor
Classes
Editor
Scroller

Functions
ForceBetween
LineSplitter
LineTrimmer


wx.lib.editor.images

images
Functions
GetBitmap
GetImage

Variables
EofImageData


wx.lib.editor.selection

selection
Functions
RestOfLine
Selection


wx.lib.editor

editor
Modules
editor
images
selection


wx.lib.evtmgr

evtmgr
Classes
EventAdapter
EventMacroInfo
EventManager
FakeWindow
MessageAdapter

Variables
eventManager


wx.lib.fancytext

fancytext
Classes
StaticFancyText

Functions
getExtent
GetExtent
GetFullExtent
renderToBitmap
RenderToBitmap
RenderToDC
renderToDC

Variables


wx.lib.filebrowsebutton

filebrowsebutton
Classes
DirBrowseButton
FileBrowseButton
FileBrowseButtonWithHistory


wx.lib.floatbar

floatbar
Classes
FloatBar

Variables
warningmsg


wx.lib.floatcanvas.FloatCanvas

FloatCanvas
Classes
Arrow
Circle
ColorOnlyMixin
DrawObject
Ellipse
FloatCanvas
Line
LineAndFillMixin
LineOnlyMixin
Point
PointSet
PointsObjectMixin
Polygon
Rectangle
RectEllipse
ScaledText
Text
TextObjectMixin
XYObjectMixin

Exceptions
FloatCanvasError

Functions
EVT_LEFT_DCLICK
EVT_LEFT_DOWN
EVT_LEFT_UP
EVT_MIDDLE_DCLICK
EVT_MIDDLE_DOWN
EVT_MIDDLE_UP
EVT_MOTION
EVT_MOUSEWHEEL
EVT_RIGHT_DCLICK
EVT_RIGHT_DOWN
EVT_RIGHT_UP

Variables
EVT_FC_ENTER_OBJECT
EVT_FC_LEAVE_OBJECT
EVT_FC_LEFT_DCLICK
EVT_FC_LEFT_DOWN
EVT_FC_LEFT_UP
EVT_FC_MIDDLE_DCLICK
EVT_FC_MIDDLE_DOWN
EVT_FC_MIDDLE_UP
EVT_FC_MOTION
EVT_FC_MOUSEWHEEL
EVT_FC_RIGHT_DCLICK
EVT_FC_RIGHT_DOWN
EVT_FC_RIGHT_UP


wx.lib.floatcanvas.NavCanvas

NavCanvas
Classes
NavCanvas

Variables
ID_MOVE_MODE_BUTTON
ID_POINTER_BUTTON
ID_ZOOM_IN_BUTTON
ID_ZOOM_OUT_BUTTON
ID_ZOOM_TO_FIT_BUTTON


wx.lib.floatcanvas.Resources

Resources
Functions
GetHandBitmap
GetHandData
GetMinusBitmap
GetMinusData
GetPlusBitmap
GetPlusData
GetPointerBitmap
GetPointerData
GetPointerImage


wx.lib.floatcanvas

floatcanvas
Modules
FloatCanvas
NavCanvas
Resources

Variables
__version__


wx.lib.foldmenu

foldmenu
Classes
FoldOutMenu
FoldOutWindow


wx.lib.foldpanelbar

foldpanelbar
Classes
CaptionBar
CaptionBarEvent
CaptionBarStyle
FoldPanelBar
FoldPanelItem
FoldWindowItem

Functions
GetCollapsedIconBitmap
GetCollapsedIconData
GetCollapsedIconImage
GetExpandedIconBitmap
GetExpandedIconData
GetExpandedIconImage

Variables
CAPTIONBAR_FILLED_RECTANGLE
CAPTIONBAR_GRADIENT_H
CAPTIONBAR_GRADIENT_V
CAPTIONBAR_NOSTYLE
CAPTIONBAR_RECTANGLE
CAPTIONBAR_SINGLE
EVT_CAPTIONBAR
FPB_ALIGN_LEFT
FPB_ALIGN_WIDTH
FPB_BMP_RIGHTSPACE
FPB_COLLAPSE_TO_BOTTOM
FPB_DEFAULT_EXTRASTYLE
FPB_DEFAULT_LEFTLINESPACING
FPB_DEFAULT_LEFTSPACING
FPB_DEFAULT_RIGHTLINESPACING
FPB_DEFAULT_RIGHTSPACING
FPB_DEFAULT_SPACING
FPB_DEFAULT_STYLE
FPB_EXCLUSIVE_FOLD
FPB_EXTRA_X
FPB_EXTRA_Y
FPB_HORIZONTAL
FPB_SINGLE_FOLD
FPB_VERTICAL
wxEVT_CAPTIONBAR


wx.lib.gestures

gestures
Classes
MouseGestures


wx.lib.gridmovers

gridmovers
Classes
ColDragWindow
GridColMoveEvent
GridColMover
GridRowMoveEvent
GridRowMover
RowDragWindow

Functions

Variables
EVT_GRID_COL_MOVE
EVT_GRID_ROW_MOVE
wxEVT_COMMAND_GRID_COL_MOVE
wxEVT_COMMAND_GRID_ROW_MOVE


wx.lib.grids

grids
Classes
PyFlexGridSizer
PyGridSizer

Variables
warningmsg


wx.lib.hyperlink

hyperlink
Classes
HyperLinkCtrl
HyperLinkEvent

Variables
EVT_HYPERLINK_LEFT
EVT_HYPERLINK_MIDDLE
EVT_HYPERLINK_RIGHT
wxEVT_HYPERLINK_LEFT
wxEVT_HYPERLINK_MIDDLE
wxEVT_HYPERLINK_RIGHT
wxHYPERLINKS_POPUP_COPY


wx.lib.imagebrowser

imagebrowser
Classes
FindFiles
ImageDialog
ImageView

Functions
ConvertBMP
GetSize
OnFileDlg

Variables
dir_path


wx.lib.imageutils

imageutils
Functions
grayOut
makeGray


wx.lib.infoframe

infoframe
Classes
Dummy_PyInformationalMessagesFrame
PyInformationalMessagesFrame


wx.lib.intctrl

intctrl
Classes
IntCtrl
IntUpdatedEvent
IntValidator

Variables
EVT_INT
MININT
wxEVT_COMMAND_INT_UPDATED
WXK_CTRL_V
WXK_CTRL_X


wx.lib.layoutf

layoutf
Classes
Layoutf


wx.lib.masked.combobox

combobox
Classes
BaseMaskedComboBox
ComboBox
MaskedComboBoxSelectEvent
PreMaskedComboBox

Variables


wx.lib.masked.ctrl

ctrl
Classes
controlTypes

Functions
Ctrl

Variables
COMBO
IPADDR
NUMBER
TEXT
TIME


wx.lib.masked.ipaddrctrl

ipaddrctrl
Classes
IpAddrCtrl
IpAddrCtrlAccessorsMixin

Variables


wx.lib.masked.maskededit

maskededit
Classes
Field
MaskedEditAccessorsMixin
MaskedEditMixin

Functions

Variables
am_pm_exclude
ansichars
autoformats
charmonths
charmonths_dict
control
days
hours
maskchars
masktags
milhours
minutes
months
nav
seconds
state_names
states
WXK_CTRL_C
WXK_CTRL_S
WXK_CTRL_V
WXK_CTRL_X
WXK_CTRL_Z


wx.lib.masked.numctrl

numctrl
Classes
NumberUpdatedEvent
NumCtrl
NumCtrlAccessorsMixin

Variables
dbg
EVT_NUM
MININT
wxEVT_COMMAND_MASKED_NUMBER_UPDATED


wx.lib.masked.textctrl

textctrl
Classes
BaseMaskedTextCtrl
PreMaskedTextCtrl
TextCtrl

Variables


wx.lib.masked.timectrl

timectrl
Classes
TimeCtrl
TimeCtrlAccessorsMixin
TimeUpdatedEvent

Variables
dbg
EVT_TIMEUPDATE
wxEVT_TIMEVAL_UPDATED


wx.lib.masked

masked
Modules
combobox
ctrl
ipaddrctrl
maskededit
numctrl
textctrl
timectrl


wx.lib.mixins.grid

grid
Classes
GridAutoEditMixin


wx.lib.mixins.imagelist

imagelist
Classes
MagicImageList


wx.lib.mixins.listctrl

listctrl
Classes
ColumnSorterMixin
ListCtrlAutoWidthMixin
ListCtrlSelectionManagerMix
TextEditMixin

Functions
getListCtrlSelection
selectBeforePopup

Variables
EVT_DOPOPUPMENU
SEL_FOC
wxEVT_DOPOPUPMENU


wx.lib.mixins.rubberband

rubberband
Classes
RubberBand

Functions
boxToExtent
getCursorPosition
isNegative
normalizeBox
pointInBox
pointOnBox


wx.lib.mixins

mixins
Modules
grid
imagelist
listctrl
rubberband


wx.lib.multisash

multisash
Classes
EmptyChild
MultiClient
MultiCloser
MultiCreator
MultiSash
MultiSizer
MultiSplit
MultiViewLeaf

Functions
DrawSash

Variables
CR_SIZE
MV_HOR
MV_VER
SH_SIZE


wx.lib.mvctree

mvctree
Classes
BasicTreeModel
Editor
FileEditor
FileWrapper
FSTreeModel
LateFSTreeModel
LayoutEngine
LinePainter
MVCTree
MVCTreeEvent
MVCTreeNode
MVCTreeNotifyEvent
NodePainter
NullTransform
Painter
Rect
StrTextConverter
TextConverter
Transform
TreeLayout
TreeLinePainter
TreeModel
TreeNodePainter
TreePainter

Variables
EVT_MVCTREE_ADD_ITEM
EVT_MVCTREE_DELETE_ITEM
EVT_MVCTREE_ITEM_COLLAPSED
EVT_MVCTREE_ITEM_COLLAPSING
EVT_MVCTREE_ITEM_EXPANDED
EVT_MVCTREE_ITEM_EXPANDING
EVT_MVCTREE_KEY_DOWN
EVT_MVCTREE_SEL_CHANGED
EVT_MVCTREE_SEL_CHANGING
warningmsg
wxEVT_MVCTREE_ITEM_COLLAPSED
wxEVT_MVCTREE_ITEM_COLLAPSING
wxEVT_MVCTREE_ITEM_EXPANDED
wxEVT_MVCTREE_ITEM_EXPANDING
wxEVT_MVCTREE_KEY_DOWN
wxEVT_MVCTREE_SEL_CHANGED


wx.lib.newevent

newevent
Functions
NewCommandEvent
NewEvent

Variables
__author__


wx.lib.ogl

ogl
Modules

Classes
ArrowHead
BitmapShape
CircleShape
CompositeShape
Constraint
ConstraintType
ControlPoint
Diagram
DividedShape
DividedShapeControlPoint
DivisionControlPoint
DivisionShape
DrawnShape
DrawOp
EllipseShape
LabelShape
LineControlPoint
LineShape
OpDraw
OpPolyDraw
OpSetClipping
OpSetGDI
PolygonControlPoint
PolygonShape
PopupDivisionMenu
PseudoMetaFile
RectangleShape
Shape
ShapeCanvas
ShapeEvtHandler
ShapeRegion
ShapeTextLine
TextShape

Functions
CentreText
CheckLineIntersection
DrawArcToEllipse
DrawFormattedText
FindEndForBox
FindEndForCircle
FindEndForPolyline
FormatText
GetArrowPoints
GetCentredTextExtent
GetPointOnLine
GraphicsStraightenLine
OGLCleanUp
OGLConstraint
OGLInitialize
PolylineHitTest
RoughlyEqual
WhollyContains


wx.lib.plot

plot
Classes
PlotCanvas
PlotGraphics
PlotPrintout
PolyLine
PolyMarker
PolyPoints
TestFrame

Functions


wx.lib.popupctl

popupctl
Classes
PopButton
PopupControl
PopupCtrl
PopupDialog


wx.lib.printout

printout
Classes
PrintBase
PrintGrid
PrintTable
PrintTableDraw
SetPrintout


wx.lib.pubsub

pubsub
Classes
Message

Functions
getStrAllTopics
test

Variables
ALL_TOPICS
Publisher


wx.lib.pydocview

pydocview
Classes
AboutDialog
AboutService
ChildDocTemplate
ChildDocument
DocApp
DocFrameMixIn
DocMDIChildFrame
DocMDIParentFrame
DocMDIParentFrameMixIn
DocOptionsService
DocSDIFrame
DocService
DocTabbedChildFrame
DocTabbedParentFrame
FilePropertiesDialog
FilePropertiesService
GeneralOptionsPanel
OptionsDialog
WindowMenuService

Functions
getBlankBitmap
getBlankData
getBlankIcon
getBlankImage
getCopyBitmap
getCopyData
getCopyImage
getCutBitmap
getCutData
getCutImage
getNewBitmap
getNewData
getNewImage
getOpenBitmap
getOpenData
getOpenImage
getPasteBitmap
getPasteData
getPasteImage
getPrintBitmap
getPrintData
getPrintImage
getPrintPreviewBitmap
getPrintPreviewData
getPrintPreviewImage
getRedoBitmap
getRedoData
getRedoImage
getSaveAllBitmap
getSaveAllData
getSaveAllImage
getSaveBitmap
getSaveData
getSaveImage
getUndoBitmap
getUndoData
getUndoImage

Variables
EMBEDDED_WINDOW_ALL
EMBEDDED_WINDOW_BOTTOM
EMBEDDED_WINDOW_BOTTOMLEFT
EMBEDDED_WINDOW_BOTTOMRIGHT
EMBEDDED_WINDOW_LEFT
EMBEDDED_WINDOW_RIGHT
EMBEDDED_WINDOW_TOP
EMBEDDED_WINDOW_TOPLEFT
EMBEDDED_WINDOW_TOPRIGHT
SAVEALL_ID
VIEW_STATUSBAR_ID
VIEW_TOOLBAR_ID
WINDOW_MENU_NUM_ITEMS


wx.lib.pyshell

pyshell
Classes
FauxFile
PyShellWindow

Variables
warningmsg


wx.lib.rcsizer

rcsizer
Classes
RowColSizer


wx.lib.rightalign

rightalign
Classes
RightTextCtrl


wx.lib.scrolledpanel

scrolledpanel
Classes
ScrolledPanel


wx.lib.sheet

sheet
Classes
CCellEditor
CSheet
CTextCellEditor


wx.lib.shell

shell
Classes
PyShell
PyShellInput
PyShellOutput

Variables
__version__
warningmsg


wx.lib.splashscreen

splashscreen
Classes
SplashScreen

Variables
warningmsg


wx.lib.statbmp

statbmp
Classes
GenStaticBitmap


wx.lib.stattext

stattext
Classes
GenStaticText


wx.lib.throbber

throbber
Classes
Throbber
UpdateThrobberEvent

Variables
EVT_UPDATE_THROBBER
THROBBER_EVENT


wx.lib.ticker_xrc

ticker_xrc
Classes
wxTickerXmlHandler


wx.lib.ticker

ticker
Classes
Ticker


wx.lib.vtk

vtk


wx.lib.wxPlotCanvas

wxPlotCanvas
Classes
PlotCanvas
PlotGraphics
PolyLine
PolyMarker
PolyPoints

Variables
warningmsg


wx.lib.wxpTag

wxpTag
Classes
wxpTagHandler

Functions

Variables
PARAMTAG
WXPTAG


wx.lib

lib
Modules
analogclock
analogclockopts
anchors
buttons
calendar
CDate
ClickableHtmlWindow
colourchooser
colourdb
colourselect
dialogs
docview
editor
evtmgr
fancytext
filebrowsebutton
floatbar
floatcanvas
foldmenu
foldpanelbar
gestures
gridmovers
grids
hyperlink
imagebrowser
imageutils
infoframe
intctrl
layoutf
masked
mixins
multisash
mvctree
newevent
ogl
plot
popupctl
printout
pubsub
pydocview
pyshell
rcsizer
rightalign
scrolledpanel
sheet
shell
splashscreen
statbmp
stattext
throbber
ticker
ticker_xrc
vtk
wxPlotCanvas
wxpTag


wx.media

media
Classes
MediaCtrl
MediaEvent

Functions
PreMediaCtrl


wx.py.buffer

buffer
Classes
Buffer

Variables
__author__
__cvsid__
__revision__


wx.py.crust

crust
Classes
Calltip
Crust
CrustFrame
DispatcherListing
Display
SessionListing

Variables
__author__
__cvsid__
__revision__


wx.py.dispatcher

dispatcher
Classes
BoundMethodWeakref
Parameter

Exceptions
DispatcherError

Functions
connect
disconnect
safeRef
send

Variables
__author__
__cvsid__
__revision__
Anonymous
Any
connections
senders


wx.py.document

document
Classes
Document

Variables
__author__
__cvsid__
__revision__


wx.py.editor

editor
Classes
DialogResults
Editor
EditorFrame
EditorNotebook
EditorNotebookFrame
EditorShellNotebook
EditorShellNotebookFrame
EditWindow

Functions
directory
fileDialog
messageDialog
openMultiple
openSingle
saveSingle

Variables
__author__
__cvsid__
__revision__


wx.py.editwindow

editwindow
Classes
EditWindow

Variables
__author__
__cvsid__
__revision__


wx.py.filling

filling
Classes
App
Filling
FillingFrame
FillingText
FillingTree

Variables
__author__
__cvsid__
__revision__
COMMONTYPES
DOCTYPES
SIMPLETYPES


wx.py.frame

frame
Classes
Frame

Variables
__author__
__cvsid__
__revision__
ID_ABOUT
ID_AUTOCOMP
ID_AUTOCOMP_DOUBLE
ID_AUTOCOMP_MAGIC
ID_AUTOCOMP_SHOW
ID_AUTOCOMP_SINGLE
ID_CALLTIPS
ID_CALLTIPS_SHOW
ID_CLEAR
ID_CLOSE
ID_COPY
ID_COPY_PLUS
ID_CUT
ID_EXIT
ID_NAMESPACE
ID_NEW
ID_OPEN
ID_PASTE
ID_PASTE_PLUS
ID_PRINT
ID_REDO
ID_REVERT
ID_SAVE
ID_SAVEAS
ID_SELECTALL
ID_UNDO
ID_USEAA
ID_WRAP


wx.py.images

images
Functions
getPyBitmap
getPyData
getPyIcon
getPyImage

Variables
__author__
__cvsid__
__revision__


wx.py.interpreter

interpreter
Classes
Interpreter
InterpreterAlaCarte

Variables
__author__
__cvsid__
__revision__


wx.py.introspect

introspect
Functions
getAllAttributeNames
getAttributeNames
getAutoCompleteList
getBaseObject
getCallTip
getConstructor
getRoot
getTokens
hasattrAlwaysReturnsTrue
rtrimTerminus

Variables
__author__
__cvsid__
__revision__


wx.py.pseudo

pseudo
Classes
PseudoFile
PseudoFileErr
PseudoFileIn
PseudoFileOut
PseudoKeyword

Variables
__author__
__cvsid__
__revision__


wx.py.PyAlaCarte

PyAlaCarte
Classes
App

Functions
main

Variables
__author__
__cvsid__
__revision__


wx.py.PyAlaMode

PyAlaMode
Classes
App

Functions
main

Variables
__author__
__cvsid__
__revision__


wx.py.PyAlaModeTest

PyAlaModeTest
Classes
App

Functions
main

Variables
__author__
__cvsid__
__revision__


wx.py.PyCrust

PyCrust
Classes
App

Functions
main

Variables
__author__
__cvsid__
__revision__
original


wx.py.PyFilling

PyFilling
Classes
App

Functions
main

Variables
__author__
__cvsid__
__revision__
app


wx.py.PyShell

PyShell
Classes
App

Functions
main

Variables
__author__
__cvsid__
__revision__
original


wx.py.PyWrap

PyWrap
Functions
main
wrap

Variables
__author__
__cvsid__
__revision__


wx.py.shell

shell
Classes
Shell
ShellFacade
ShellFrame

Variables
__author__
__cvsid__
__revision__
NAVKEYS


wx.py.version

version
Variables
__author__
__cvsid__
__revision__
VERSION


wx.py

py
Modules
buffer
crust
dispatcher
document
editor
editwindow
filling
frame
images
interpreter
introspect
pseudo
PyAlaCarte
PyAlaMode
PyAlaModeTest
PyCrust
PyFilling
PyShell
PyWrap
shell
version

Variables
__author__
__cvsid__
__revision__


wx.stc

stc
Classes
StyledTextCtrl
StyledTextEvent

Functions
PreStyledTextCtrl


wx.tools.dbg

dbg
Classes
Logger


wx.tools.helpviewer

helpviewer
Functions
main


wx.tools.img2img

img2img
Functions
convert
main


wx.tools.img2png

img2png
Functions
main


wx.tools.img2py

img2py
Functions
crunch_data
main


wx.tools.img2xpm

img2xpm
Functions
main


wx.tools

tools
Modules
dbg
helpviewer
img2img
img2png
img2py
img2xpm


wx.webkit

webkit
Classes
WebKitCtrl
WebKitStateChangedEvent

Functions
PreWebKitCtrl


wx.wizard

wizard
Classes
PyWizardPage
Wizard
WizardEvent
WizardPage
WizardPageSimple

Functions
PrePyWizardPage
PreWizard
PreWizardPageSimple
WizardPageSimple_Chain


wx.xrc

xrc
Classes
XmlDocument
XmlNode
XmlProperty
XmlResource
XmlResourceHandler
XmlSubclassFactory
XmlSubclassFactory_Python

Functions
EmptyXmlDocument
EmptyXmlResource
XmlDocumentFromStream
XmlNodeEasy
XmlResource_AddSubclassFactory
XmlResource_Get
XmlResource_GetXRCID
XmlResource_Set
XRCCTRL
XRCID


wx
Modules
animate
build
calendar
gizmos
glcanvas
grid
html
lib
media
py
stc
tools
webkit
wizard
xrc

Classes
AcceleratorEntry
AcceleratorTable
ActivateEvent
ANIHandler
App
ArtProvider
Bitmap
BitmapButton
BitmapDataObject
BMPHandler
BookCtrlBase
BookCtrlBaseEvent
BookCtrlSizer
BoxSizer
Brush
BrushList
BufferedDC
BufferedPaintDC
BusyCursor
BusyInfo
Button
CalculateLayoutEvent
Caret
CheckBox
CheckListBox
ChildFocusEvent
Choice
Choicebook
ChoicebookEvent
ClientDC
Clipboard
ClipboardLocker
CloseEvent
Color
Colour
ColourData
ColourDatabase
ColourDialog
ComboBox
CommandEvent
Config
ConfigBase
ConfigPathChanger
ContextHelp
ContextHelpButton
ContextMenuEvent
Control
ControlWithItems
CPPFileSystemHandler
CURHandler
Cursor
CustomDataObject
DataFormat
DataObject
DataObjectComposite
DataObjectSimple
DateEvent
DatePickerCtrl
DateSpan
DateTime
DC
Dialog
DirDialog
DirFilterListCtrl
Display
DisplayChangedEvent
DragImage
DropFilesEvent
DropSource
DropTarget
Effects
EncodingConverter
EraseEvent
Event
EventLoop
EvtHandler
FileConfig
FileDataObject
FileDialog
FileDropTarget
FileHistory
FileSystem
FileSystemHandler
FileType
FileTypeInfo
FindDialogEvent
FindReplaceData
FindReplaceDialog
FlexGridSizer
FocusEvent
Font
FontData
FontDialog
FontEnumerator
FontList
FontMapper
Frame
FSFile
FutureCall
Gauge
GBPosition
GBSizerItem
GBSpan
GDIObject
GenericDirCtrl
GIFHandler
GridBagSizer
GridSizer
HelpEvent
HelpProvider
HtmlListBox
ICOHandler
Icon
IconBundle
IconizeEvent
IconLocation
IdleEvent
Image
ImageHandler
ImageHistogram
ImageList
IndividualLayoutConstraint
InitDialogEvent
InputStream
InternetFSHandler
ItemContainer
Joystick
JoystickEvent
JPEGHandler
KeyEvent
LanguageInfo
LayoutAlgorithm
LayoutConstraints
Listbook
ListbookEvent
ListBox
ListCtrl
ListEvent
ListItem
ListItemAttr
ListView
Locale
Log
LogChain
LogGui
LogNull
LogStderr
LogTextCtrl
LogWindow
Mask
MaximizeEvent
MDIChildFrame
MDIClientWindow
MDIParentFrame
MemoryDC
MemoryFSHandler
Menu
MenuBar
MenuEvent
MenuItem
MessageDialog
MetaFile
MetafileDataObject
MetaFileDC
MimeTypesManager
MiniFrame
MirrorDC
MouseCaptureChangedEvent
MouseEvent
MoveEvent
MultiChoiceDialog
MutexGuiLocker
NativeEncodingInfo
NativeFontInfo
NavigationKeyEvent
NcPaintEvent
Notebook
NotebookEvent
NotebookPage
NotebookSizer
NotifyEvent
Object
OutputStream
PageSetupDialog
PageSetupDialogData
PaintDC
PaintEvent
Palette
PaletteChangedEvent
Panel
PasswordEntryDialog
PCXHandler
Pen
PenList
PNGHandler
PNMHandler
Point
Point2D
PopupTransientWindow
PopupWindow
PostScriptDC
PreviewCanvas
PreviewControlBar
PreviewFrame
PrintData
PrintDialog
PrintDialogData
Printer
PrinterDC
Printout
PrintPreview
Process
ProcessEvent
ProgressDialog
PropagateOnce
PropagationDisabler
PyApp
PyBitmapDataObject
PyCommandEvent
PyControl
PyDataObjectSimple
PyDropTarget
PyEvent
PyEventBinder
PyLog
PyOnDemandOutputWindow
PyPanel
PyPreviewControlBar
PyPreviewFrame
PyPrintPreview
PyScrolledWindow
PySimpleApp
PySizer
PyTextDataObject
PyTimer
PyTipProvider
PyValidator
PyWidgetTester
PyWindow
Quantize
QueryLayoutInfoEvent
QueryNewPaletteEvent
RadioBox
RadioButton
RealPoint
Rect
Region
RegionIterator
SashEvent
SashLayoutWindow
SashWindow
ScreenDC
ScrollBar
ScrolledWindow
ScrollEvent
ScrollWinEvent
SetCursorEvent
ShowEvent
SimpleHelpProvider
SingleChoiceDialog
SingleInstanceChecker
Size
SizeEvent
Sizer
SizerItem
Slider
Sound
SpinButton
SpinCtrl
SpinEvent
SplashScreen
SplashScreenWindow
SplitterEvent
SplitterWindow
StandardPaths
StaticBitmap
StaticBox
StaticBoxSizer
StaticLine
StaticText
StatusBar
StdDialogButtonSizer
StopWatch
SysColourChangedEvent
SystemOptions
SystemSettings
TaskBarIcon
TaskBarIconEvent
TextAttr
TextCtrl
TextDataObject
TextDropTarget
TextEntryDialog
TextUrlEvent
TIFFHandler
Timer
TimerEvent
TimerRunner
TimeSpan
TipProvider
TipWindow
ToggleButton
ToolBar
ToolBarBase
ToolBarToolBase
ToolTip
TopLevelWindow
TreeCtrl
TreeEvent
TreeItemData
TreeItemId
UpdateUIEvent
URLDataObject
Validator
VideoMode
VisualAttributes
VListBox
VScrolledWindow
Window
WindowCreateEvent
WindowDC
WindowDestroyEvent
WindowDisabler
XPMHandler
ZipFSHandler

Exceptions
PyAssertionError
PyDeadObjectError
PyNoAppError
PyUnbornObjectError

Functions
App_CleanUp
App_GetComCtl32Version
App_GetMacAboutMenuItemId
App_GetMacExitMenuItemId
App_GetMacHelpMenuTitleName
App_GetMacPreferencesMenuItemId
App_GetMacSupportPCMenuShortcuts
App_SetMacAboutMenuItemId
App_SetMacExitMenuItemId
App_SetMacHelpMenuTitleName
App_SetMacPreferencesMenuItemId
App_SetMacSupportPCMenuShortcuts
ArtProvider_GetBitmap
ArtProvider_GetIcon
ArtProvider_GetSizeHint
ArtProvider_PopProvider
ArtProvider_PushProvider
ArtProvider_RemoveProvider
BeginBusyCursor
Bell
BitmapFromBits
BitmapFromIcon
BitmapFromImage
BitmapFromXPMData
BookCtrlBase_GetClassDefaultAttributes
BrushFromBitmap
Button_GetClassDefaultAttributes
Button_GetDefaultSize
CallAfter
Caret_GetBlinkTime
Caret_SetBlinkTime
CheckBox_GetClassDefaultAttributes
Choice_GetClassDefaultAttributes
ClientDisplayRect
Clipboard_Get
ColorRGB
ColourDisplay
ColourRGB
ComboBox_GetClassDefaultAttributes
ConfigBase_Create
ConfigBase_DontCreateOnDemand
ConfigBase_Get
ConfigBase_Set
Control_GetClassDefaultAttributes
CreateFileTipProvider
CursorFromImage
CustomDataFormat
DateSpan_Day
DateSpan_Days
DateSpan_Month
DateSpan_Months
DateSpan_Week
DateSpan_Weeks
DateSpan_Year
DateSpan_Years
DateTime_ConvertYearToBC
DateTime_GetAmPmStrings
DateTime_GetBeginDST
DateTime_GetCentury
DateTime_GetCountry
DateTime_GetCurrentMonth
DateTime_GetCurrentYear
DateTime_GetEndDST
DateTime_GetMonthName
DateTime_GetNumberOfDaysInMonth
DateTime_GetNumberOfDaysinYear
DateTime_GetWeekDayName
DateTime_IsDSTApplicable
DateTime_IsLeapYear
DateTime_IsWestEuropeanCountry
DateTime_Now
DateTime_SetCountry
DateTime_SetToWeekOfYear
DateTime_Today
DateTime_UNow
DateTimeFromDMY
DateTimeFromHMS
DateTimeFromJDN
DateTimeFromTimeT
Dialog_GetClassDefaultAttributes
DirSelector
Display_GetCount
Display_GetFromPoint
Display_GetFromWindow
DisplayDepth
DisplaySize
DisplaySizeMM
DLG_PNT
DLG_SZE
DragIcon
DragListItem
DragString
DragTreeItem
DrawWindowOnDC
DROP_ICON
EmptyBitmap
EmptyIcon
EmptyImage
EnableTopLevelWindows
EncodingConverter_CanConvert
EncodingConverter_GetAllEquivalents
EncodingConverter_GetPlatformEquivalents
EndBusyCursor
EventLoop_GetActive
EventLoop_SetActive
Execute
Exit
ExpandEnvVars
FFont
FFontFromPixelSize
FileSelector
FileSystem_AddHandler
FileSystem_CleanUpHandlers
FileSystem_FileNameToURL
FileSystem_URLToFileName
FileType_ExpandCommand
FileTypeInfoSequence
FindWindowAtPoint
FindWindowById
FindWindowByLabel
FindWindowByName
Font2
Font_GetDefaultEncoding
Font_SetDefaultEncoding
FontFromNativeInfo
FontFromNativeInfoString
FontFromPixelSize
FontMapper_Get
FontMapper_GetDefaultConfigPath
FontMapper_GetEncoding
FontMapper_GetEncodingDescription
FontMapper_GetEncodingFromName
FontMapper_GetEncodingName
FontMapper_GetSupportedEncodingsCount
FontMapper_Set
Frame_GetClassDefaultAttributes
Gauge_GetClassDefaultAttributes
GBSizerItemSizer
GBSizerItemSpacer
GBSizerItemWindow
GenericFindWindowAtPoint
GetAccelFromString
GetActiveWindow
GetApp
GetClientDisplayRect
GetCurrentId
GetCurrentTime
GetDefaultPyEncoding
GetDisplayDepth
GetDisplaySize
GetDisplaySizeMM
GetElapsedTime
GetEmailAddress
GetFreeMemory
GetFullHostName
GetHomeDir
GetHostName
GetKeyState
GetLocale
GetLocalTime
GetLocalTimeMillis
GetMousePosition
GetNativeFontEncoding
GetNumberFromUser
GetOsDescription
GetOsVersion
GetPasswordFromUser
GetProcessId
GetSingleChoice
GetSingleChoiceIndex
GetStockLabel
GetTextFromUser
GetTopLevelParent
GetTopLevelWindows
GetTranslation
GetUserHome
GetUserId
GetUserName
GetUTCTime
GetXDisplay
HelpProvider_Get
HelpProvider_Set
IconBundleFromFile
IconBundleFromIcon
IconFromBitmap
IconFromLocation
IconFromXPMData
IdleEvent_CanSend
IdleEvent_GetMode
IdleEvent_SetMode
Image_AddHandler
Image_CanRead
Image_CanReadStream
Image_GetImageCount
Image_GetImageExtWildcard
Image_InsertHandler
Image_RemoveHandler
ImageFromBitmap
ImageFromData
ImageFromDataWithAlpha
ImageFromMime
ImageFromStream
ImageFromStreamMime
ImageHistogram_MakeKey
InitAllImageHandlers
IntersectRect
IsBusy
IsDragResultOk
IsStockID
IsStockLabel
Kill
LaunchDefaultBrowser
ListBox_GetClassDefaultAttributes
ListCtrl_GetClassDefaultAttributes
LoadFileSelector
Locale_AddCatalogLookupPathPrefix
Locale_AddLanguage
Locale_FindLanguageInfo
Locale_GetLanguageInfo
Locale_GetLanguageName
Locale_GetSystemEncoding
Locale_GetSystemEncodingName
Locale_GetSystemLanguage
Log_AddTraceMask
Log_ClearTraceMasks
Log_DontCreateOnDemand
Log_EnableLogging
Log_FlushActive
Log_GetActiveTarget
Log_GetLogLevel
Log_GetTimestamp
Log_GetTraceMask
Log_GetTraceMasks
Log_GetVerbose
Log_IsAllowedTraceMask
Log_IsEnabled
Log_OnLog
Log_RemoveTraceMask
Log_Resume
Log_SetActiveTarget
Log_SetLogLevel
Log_SetTimestamp
Log_SetTraceMask
Log_SetVerbose
Log_Suspend
Log_TimeStamp
LogDebug
LogError
LogFatalError
LogGeneric
LogInfo
LogMessage
LogStatus
LogStatusFrame
LogSysError
LogTrace
LogVerbose
LogWarning
MaskColour
MemoryDCFromDC
MemoryFSHandler_AddFile
MemoryFSHandler_RemoveFile
MenuItem_GetDefaultMarginWidth
MenuItem_GetLabelFromText
MessageBox
MicroSleep
MilliSleep
MimeTypesManager_IsOfType
MutexGuiEnter
MutexGuiLeave
NamedColor
NamedColour
NewEventType
NewId
Notebook_GetClassDefaultAttributes
Now
NullFileTypeInfo
Panel_GetClassDefaultAttributes
Point2DCopy
Point2DFromPoint
PostEvent
PostScriptDC_GetResolution
PostScriptDC_SetResolution
PreBitmapButton
PreButton
PreCheckBox
PreCheckListBox
PreChoice
PreChoicebook
PreComboBox
PreControl
PreDatePickerCtrl
PreDialog
PreDirFilterListCtrl
PreFindReplaceDialog
PreFrame
PreGauge
PreGenericDirCtrl
PreHtmlListBox
PreListbook
PreListBox
PreListCtrl
PreListView
PreMDIChildFrame
PreMDIClientWindow
PreMDIParentFrame
PreMiniFrame
PreNotebook
PrePanel
PrePopupTransientWindow
PrePopupWindow
PrePyControl
PrePyPanel
PrePyScrolledWindow
PrePyWindow
PreRadioBox
PreRadioButton
PreSashLayoutWindow
PreSashWindow
PreScrollBar
PreScrolledWindow
PreSingleInstanceChecker
PreSlider
PreSpinButton
PreSpinCtrl
PreSplitterWindow
PreStaticBitmap
PreStaticBox
PreStaticLine
PreStaticText
PreStatusBar
PreTextCtrl
PreToggleButton
PreToolBar
PreTreeCtrl
PreVListBox
PreVScrolledWindow
PreWindow
Printer_GetLastError
Process_Exists
Process_Kill
Process_Open
PyApp_GetComCtl32Version
PyApp_GetMacAboutMenuItemId
PyApp_GetMacExitMenuItemId
PyApp_GetMacHelpMenuTitleName
PyApp_GetMacPreferencesMenuItemId
PyApp_GetMacSupportPCMenuShortcuts
PyApp_IsMainLoopRunning
PyApp_SetMacAboutMenuItemId
PyApp_SetMacExitMenuItemId
PyApp_SetMacHelpMenuTitleName
PyApp_SetMacPreferencesMenuItemId
PyApp_SetMacSupportPCMenuShortcuts
Quantize_Quantize
RadioBox_GetClassDefaultAttributes
RadioButton_GetClassDefaultAttributes
RectPP
RectPS
RectS
RegionFromBitmap
RegionFromBitmapColour
RegionFromPoints
RegisterId
SafeShowMessage
SafeYield
SaveFileSelector
ScrollBar_GetClassDefaultAttributes
ScrolledWindow_GetClassDefaultAttributes
SetCursor
SetDefaultPyEncoding
Shell
ShowTip
Shutdown
SizerItemSizer
SizerItemSpacer
SizerItemWindow
Sleep
Slider_GetClassDefaultAttributes
Sound_PlaySound
Sound_Stop
SoundFromData
SpinButton_GetClassDefaultAttributes
SpinCtrl_GetClassDefaultAttributes
SplitterWindow_GetClassDefaultAttributes
StandardPaths_Get
StartTimer
StaticBitmap_GetClassDefaultAttributes
StaticBox_GetClassDefaultAttributes
StaticLine_GetClassDefaultAttributes
StaticLine_GetDefaultSize
StaticText_GetClassDefaultAttributes
StatusBar_GetClassDefaultAttributes
StockCursor
StripMenuCodes
SysErrorCode
SysErrorMsg
SystemOptions_GetOption
SystemOptions_GetOptionInt
SystemOptions_HasOption
SystemOptions_IsFalse
SystemOptions_SetOption
SystemOptions_SetOptionInt
SystemSettings_GetColour
SystemSettings_GetFont
SystemSettings_GetMetric
SystemSettings_GetScreenType
SystemSettings_HasFeature
SystemSettings_SetScreenType
TestFontEncoding
TextAttr_Combine
TextCtrl_GetClassDefaultAttributes
Thread_IsMain
TimeSpan_Day
TimeSpan_Days
TimeSpan_Hour
TimeSpan_Hours
TimeSpan_Minute
TimeSpan_Minutes
TimeSpan_Second
TimeSpan_Seconds
TimeSpan_Week
TimeSpan_Weeks
ToggleButton_GetClassDefaultAttributes
ToolBar_GetClassDefaultAttributes
ToolTip_Enable
ToolTip_SetDelay
Trap
TreeCtrl_GetClassDefaultAttributes
UpdateUIEvent_CanUpdate
UpdateUIEvent_GetMode
UpdateUIEvent_GetUpdateInterval
UpdateUIEvent_ResetUpdateTime
UpdateUIEvent_SetMode
UpdateUIEvent_SetUpdateInterval
Usleep
Validator_IsSilent
Validator_SetBellOnError
WakeUpIdle
WakeUpMainThread
Window_FindFocus
Window_FromHWND
Window_GetCapture
Window_GetClassDefaultAttributes
Window_NewControlId
Window_NextControlId
Window_PrevControlId
Yield
YieldIfNeeded


wxversion
Classes

Exceptions
VersionError

Functions
checkInstalled
ensureMinimal
getInstalled
select

Variables
UPDATE_URL


Module and Class Hierarchies

Module Hierarchy

  • wx
  • wxversion: If you have more than one version of wxPython installed this module allows your application to choose which version of wxPython will be imported when it does 'import wx'.

Class Hierarchy

  • __builtin__.object: The most base type
    • wx.AcceleratorEntry: A class used to define items in an wx.AcceleratorTable.
    • wx.lib.ogl.ArrowHead
    • wx.ArtProvider: The wx.ArtProvider class is used to customize the look of wxWidgets application.
    • wx.BusyCursor: Proxy of C++ BusyCursor class
    • wx.calendar.CalendarDateAttr: A set of customization attributes for a calendar date, which can be used to control the look of the Calendar object.
    • wx.Caret: Proxy of C++ Caret class
    • wx.ClipboardLocker: A helpful class for opening the clipboard and automatically closing it when the locker is destroyed.
    • wx.ConfigBase: wx.ConfigBase class defines the basic interface of all config classes.
      • wx.Config: This ConfigBase-derived class will use the registry on Windows, and will be a wx.FileConfig on other platforms.
      • wx.FileConfig: This config class will use a file for storage on all platforms.
    • wx.ConfigPathChanger: A handy little class which changes current path to the path of given entry and restores it in the destructoir: so if you declare a local variable of this type, you work in the entry directory and the path is automatically restored when the function returns.
    • wx.lib.ogl.Constraint: A Constraint object helps specify how child shapes are laid out with respect to siblings and parents.
    • wx.lib.ogl.ConstraintType
    • wx.CPPFileSystemHandler: Proxy of C++ CPPFileSystemHandler class
      • wx.FileSystemHandler: Proxy of C++ FileSystemHandler class
      • wx.InternetFSHandler: Proxy of C++ InternetFSHandler class
      • wx.MemoryFSHandler: Proxy of C++ MemoryFSHandler class
      • wx.ZipFSHandler: Proxy of C++ ZipFSHandler class
    • wx.DataFormat: A wx.DataFormat is an encapsulation of a platform-specific format handle which is used by the system for the clipboard and drag and drop operations.
    • wx.DataObject: A wx.DataObject represents data that can be copied to or from the clipboard, or dragged and dropped.
      • wx.DataObjectComposite: wx.DataObjectComposite is the simplest wx.DataObject derivation which may be sued to support multiple formats.
        • wx.URLDataObject: This data object holds a URL in a format that is compatible with some browsers such that it is able to be dragged to or from them.
      • wx.DataObjectSimple: wx.DataObjectSimple is a wx.DataObject which only supports one format.
        • wx.BitmapDataObject: wx.BitmapDataObject is a specialization of wxDataObject for bitmap data.
          • wx.PyBitmapDataObject: wx.PyBitmapDataObject is a version of wx.BitmapDataObject that is Python-aware and knows how to reflect calls to its C++ virtual methods to methods in the Python derived class.
        • wx.CustomDataObject: wx.CustomDataObject is a specialization of wx.DataObjectSimple for some application-specific data in arbitrary format.
        • wx.FileDataObject: wx.FileDataObject is a specialization of wx.DataObjectSimple for file names.
        • wx.MetafileDataObject: Proxy of C++ MetafileDataObject class
        • wx.PyDataObjectSimple: wx.PyDataObjectSimple is a version of wx.DataObjectSimple that is Python-aware and knows how to reflect calls to its C++ virtual methods to methods in the Python derived class.
        • wx.TextDataObject: wx.TextDataObject is a specialization of wx.DataObject for text data.
          • wx.PyTextDataObject: wx.PyTextDataObject is a version of wx.TextDataObject that is Python-aware and knows how to reflect calls to its C++ virtual methods to methods in the Python derived class.
    • wx.DateSpan: Proxy of C++ DateSpan class
    • wx.DateTime: Proxy of C++ DateTime class
    • wx.lib.ogl.Diagram: Encapsulates an entire diagram, with methods for drawing.
    • wx.Display: Represents a display/monitor attached to the system
    • wx.lib.ogl.DrawOp
      • wx.lib.ogl.OpDraw: Draw line, rectangle, rounded rectangle, ellipse, point, arc, text.
      • wx.lib.ogl.OpPolyDraw: Draw polygon, polyline, spline.
      • wx.lib.ogl.OpSetClipping: Set/destroy clipping.
      • wx.lib.ogl.OpSetGDI: Set font, brush, text colour.
    • wx.DropSource: Proxy of C++ DropSource class
    • wx.DropTarget: Proxy of C++ DropTarget class
      • wx.FileDropTarget: Proxy of C++ FileDropTarget class
      • wx.TextDropTarget: Proxy of C++ TextDropTarget class
    • wx.EventLoop: Proxy of C++ EventLoop class
    • wx.FileType: Proxy of C++ FileType class
    • wx.FileTypeInfo: Proxy of C++ FileTypeInfo class
    • wx.FontEnumerator: Proxy of C++ FontEnumerator class
    • wx.FontMapper: Proxy of C++ FontMapper class
    • wx.GBPosition: This class represents the position of an item in a virtual grid of rows and columns managed by a wx.GridBagSizer.
    • wx.GBSpan: This class is used to hold the row and column spanning attributes of items in a wx.GridBagSizer.
    • wx.grid.GridCellAttr: Proxy of C++ GridCellAttr class
    • wx.grid.GridCellAttrProvider: Proxy of C++ GridCellAttrProvider class
      • wx.grid.PyGridCellAttrProvider: Proxy of C++ PyGridCellAttrProvider class
    • wx.grid.GridCellCoords: Proxy of C++ GridCellCoords class
    • wx.grid.GridCellEditor: Proxy of C++ GridCellEditor class
      • wx.grid.GridCellBoolEditor: Proxy of C++ GridCellBoolEditor class
      • wx.grid.GridCellChoiceEditor: Proxy of C++ GridCellChoiceEditor class
        • wx.grid.GridCellEnumEditor: Proxy of C++ GridCellEnumEditor class
      • wx.grid.GridCellTextEditor: Proxy of C++ GridCellTextEditor class
        • wx.grid.GridCellAutoWrapStringEditor: Proxy of C++ GridCellAutoWrapStringEditor class
        • wx.grid.GridCellFloatEditor: Proxy of C++ GridCellFloatEditor class
        • wx.grid.GridCellNumberEditor: Proxy of C++ GridCellNumberEditor class
      • wx.grid.PyGridCellEditor: Proxy of C++ PyGridCellEditor class
        • wx.lib.sheet.CCellEditor: Custom cell editor
    • wx.grid.GridCellRenderer: Proxy of C++ GridCellRenderer class
      • wx.grid.GridCellBoolRenderer: Proxy of C++ GridCellBoolRenderer class
      • wx.grid.GridCellStringRenderer: Proxy of C++ GridCellStringRenderer class
        • wx.grid.GridCellAutoWrapStringRenderer: Proxy of C++ GridCellAutoWrapStringRenderer class
        • wx.grid.GridCellDateTimeRenderer: Proxy of C++ GridCellDateTimeRenderer class
        • wx.grid.GridCellEnumRenderer: Proxy of C++ GridCellEnumRenderer class
        • wx.grid.GridCellFloatRenderer: Proxy of C++ GridCellFloatRenderer class
        • wx.grid.GridCellNumberRenderer: Proxy of C++ GridCellNumberRenderer class
      • wx.grid.PyGridCellRenderer: Proxy of C++ PyGridCellRenderer class
    • wx.grid.GridTableMessage: Proxy of C++ GridTableMessage class
    • wx.HelpProvider: wx.HelpProvider is an abstract class used by a program implementing context-sensitive help to show the help text for the given window.
      • wx.SimpleHelpProvider: wx.SimpleHelpProvider is an implementation of wx.HelpProvider which supports only plain text help strings, and shows the string associated with the control (if any) in a tooltip.
    • wx.html.HtmlBookRecord: Proxy of C++ HtmlBookRecord class
    • wx.html.HtmlContentsItem: Proxy of C++ HtmlContentsItem class
    • wx.html.HtmlHelpData: Proxy of C++ HtmlHelpData class
    • wx.html.HtmlRenderingInfo: Proxy of C++ HtmlRenderingInfo class
    • wx.html.HtmlRenderingState: Proxy of C++ HtmlRenderingState class
    • wx.html.HtmlRenderingStyle: Proxy of C++ HtmlRenderingStyle class
      • wx.html.DefaultHtmlRenderingStyle: Proxy of C++ DefaultHtmlRenderingStyle class
    • wx.html.HtmlSearchStatus: Proxy of C++ HtmlSearchStatus class
    • wx.html.HtmlSelection: Proxy of C++ HtmlSelection class
    • wx.IconBundle: Proxy of C++ IconBundle class
    • wx.IconLocation: Proxy of C++ IconLocation class
    • wx.ImageHistogram: Proxy of C++ ImageHistogram class
    • wx.InputStream: Proxy of C++ InputStream class
    • wx.ItemContainer: The wx.ItemContainer class defines an interface which is implemented by all controls which have string subitems, each of which may be selected, such as wx.ListBox, wx.CheckListBox, wx.Choice as well as wx.ComboBox which implements an extended interface deriving from this one.
      • wx.ComboBox: A combobox is like a combination of an edit control and a listbox.
        • wx.lib.masked.combobox.BaseMaskedComboBox: Base class for generic masked edit comboboxes; allows auto-complete of values.
          • wx.lib.masked.combobox.ComboBox: The "user-visible" masked combobox control, this class is identical to the BaseMaskedComboBox class it's derived from.
          • wx.lib.masked.combobox.PreMaskedComboBox: This class exists to support the use of XRC subclassing.
      • wx.ControlWithItems: wx.ControlWithItems combines the wx.ItemContainer class with the wx.Control class, and is used for the base class of various controls that have items.
        • wx.Choice: A Choice control is used to select one of a list of strings.
          • wx.DirFilterListCtrl: Proxy of C++ DirFilterListCtrl class
        • wx.ListBox: Proxy of C++ ListBox class
          • wx.CheckListBox: Proxy of C++ CheckListBox class
    • wx.Joystick: Proxy of C++ Joystick class
    • wx.LanguageInfo: Proxy of C++ LanguageInfo class
    • wx.ListItemAttr: Proxy of C++ ListItemAttr class
    • wx.Locale: Proxy of C++ Locale class
    • wx.Log: Proxy of C++ Log class
      • wx.LogChain: Proxy of C++ LogChain class
      • wx.LogGui: Proxy of C++ LogGui class
      • wx.LogStderr: Proxy of C++ LogStderr class
      • wx.LogTextCtrl: Proxy of C++ LogTextCtrl class
      • wx.LogWindow: Proxy of C++ LogWindow class
      • wx.PyLog: Proxy of C++ PyLog class
    • wx.LogNull: Proxy of C++ LogNull class
    • wx.MimeTypesManager: Proxy of C++ MimeTypesManager class
    • wx.MutexGuiLocker: Proxy of C++ MutexGuiLocker class
    • wx.NativeEncodingInfo: Proxy of C++ NativeEncodingInfo class
    • wx.NativeFontInfo: Proxy of C++ NativeFontInfo class
    • wx.Object: The base class for most wx objects, although in wxPython not much functionality is needed nor exposed.
      • wx.AcceleratorTable: An accelerator table allows the application to specify a table of keyboard shortcuts for menus or other commands.
      • wx.animate.AnimationBase: Proxy of C++ AnimationBase class
        • wx.animate.GIFAnimation: Proxy of C++ GIFAnimation class
      • wx.animate.AnimationPlayer: Proxy of C++ AnimationPlayer class
      • wx.BrushList: Proxy of C++ BrushList class
      • wx.BusyInfo: Proxy of C++ BusyInfo class
      • wx.Clipboard: wx.Clipboard represents the system clipboard and provides methods to copy data to it or paste data from it.
      • wx.Colour: A colour is an object representing a combination of Red, Green, and Blue (RGB) intensity values, and is used to determine drawing colours, window colours, etc.
      • wx.ColourData: This class holds a variety of information related to the colour chooser dialog, used to transfer settings and results to and from the wx.ColourDialog.
      • wx.ColourDatabase: Proxy of C++ ColourDatabase class
      • wx.lib.docview.Command: wxCommand is a base class for modelling an application command, which is an action usually performed by selecting a menu item, pressing a toolbar button or any other means provided by the application to change the data or view.
      • wx.lib.docview.CommandProcessor: wxCommandProcessor is a class that maintains a history of wxCommands, with undo/redo functionality built-in.
      • wx.ContextHelp: This class changes the cursor to a query and puts the application into a 'context-sensitive help mode'.
      • wx.DC: A wx.DC is a device context onto which graphics and text can be drawn.
        • wx.ClientDC: A wx.ClientDC must be constructed if an application wishes to paint on the client area of a window from outside an EVT_PAINT event.
        • wx.MemoryDC: A memory device context provides a means to draw graphics onto a bitmap.
          • wx.lib.colourchooser.canvas.BitmapBuffer: A screen buffer class.
          • wx.BufferedDC: This simple class provides a simple way to avoid flicker: when drawing on it, everything is in fact first drawn on an in-memory buffer (a wx.Bitmap) and then copied to the screen only once, when this object is destroyed.
            • wx.BufferedPaintDC: This is a subclass of wx.BufferedDC which can be used inside of an EVT_PAINT event handler.
        • wx.MetaFileDC: Proxy of C++ MetaFileDC class
        • wx.MirrorDC: wx.MirrorDC is a simple wrapper class which is always associated with a real wx.DC object and either forwards all of its operations to it without changes (no mirroring takes place) or exchanges x and y coordinates which makes it possible to reuse the same code to draw a figure and its mirror -- i.e.
        • wx.PaintDC: A wx.PaintDC must be constructed if an application wishes to paint on the client area of a window from within an EVT_PAINT event handler.
        • wx.PostScriptDC: This is a wx.DC that can write to PostScript files on any platform.
        • wx.PrinterDC: Proxy of C++ PrinterDC class
        • wx.ScreenDC: A wxScreenDC can be used to paint anywhere on the screen.
        • wx.WindowDC: A wx.WindowDC must be constructed if an application wishes to paint on the whole area of a window (client and decorations).
      • wx.lib.docview.DocTemplate: The wxDocTemplate class is used to model the relationship between a document class and a view class.
        • wx.lib.pydocview.ChildDocTemplate: A ChildDocTemplate is a DocTemplate subclass that enables the creation of ChildDocuments that represents a portion of a Document.
      • wx.DragImage: Proxy of C++ DragImage class
      • wx.Effects: Proxy of C++ Effects class
      • wx.EncodingConverter: Proxy of C++ EncodingConverter class
      • wx.Event: An event is a structure holding information about an event passed to a callback or member function.
        • wx.ActivateEvent: An activate event is sent when a top-level window or the entire application is being activated or deactivated.
        • wx.CalculateLayoutEvent: Proxy of C++ CalculateLayoutEvent class
        • wx.CloseEvent: This event class contains information about window and session close events.
        • wx.CommandEvent: This event class contains information about command events, which originate from a variety of simple controls, as well as menus and toolbars.
          • wx.ChildFocusEvent: wx.ChildFocusEvent notifies the parent that a child has received the focus.
          • wx.ContextMenuEvent: This class is used for context menu events (EVT_CONTECT_MENU,) sent to give the application a chance to show a context (popup) menu.
          • wx.DateEvent: This event class holds information about a date change event and is used together with wx.DatePickerCtrl.
            • wx.calendar.CalendarEvent: Proxy of C++ CalendarEvent class
          • wx.gizmos.DynamicSashSplitEvent: Proxy of C++ DynamicSashSplitEvent class
          • wx.gizmos.DynamicSashUnifyEvent: Proxy of C++ DynamicSashUnifyEvent class
          • wx.FindDialogEvent: Events for the FindReplaceDialog
          • wx.grid.GridEditorCreatedEvent: Proxy of C++ GridEditorCreatedEvent class
          • wx.HelpEvent: A help event is sent when the user has requested context-sensitive help.
          • wx.NotifyEvent: An instance of this class (or one of its derived classes) is sent from a control when the control's state is being changed and the control allows that change to be prevented from happening.
            • wx.BookCtrlBaseEvent: Proxy of C++ BookCtrlBaseEvent class
              • wx.ChoicebookEvent: Proxy of C++ ChoicebookEvent class
              • wx.ListbookEvent: Proxy of C++ ListbookEvent class
              • wx.NotebookEvent: Proxy of C++ NotebookEvent class
            • wx.grid.GridEvent: Proxy of C++ GridEvent class
            • wx.grid.GridRangeSelectEvent: Proxy of C++ GridRangeSelectEvent class
            • wx.grid.GridSizeEvent: Proxy of C++ GridSizeEvent class
            • wx.ListEvent: Proxy of C++ ListEvent class
            • wx.media.MediaEvent: Proxy of C++ MediaEvent class
            • wx.SpinEvent: Proxy of C++ SpinEvent class
            • wx.SplitterEvent: This class represents the events generated by a splitter control.
            • wx.TreeEvent: Proxy of C++ TreeEvent class
            • wx.wizard.WizardEvent: Proxy of C++ WizardEvent class
          • wx.PyCommandEvent: wx.PyCommandEvent can be used as a base class for implementing custom event types in Python, where the event shoudl travel up to parent windows looking for a handler.
            • wx.lib.foldpanelbar.CaptionBarEvent: This event will be sent when a EVT_CAPTIONBAR is mapped in the parent.
            • wx.lib.colourselect.ColourSelectEvent
            • wx.lib.buttons.GenButtonEvent: Event sent from the generic buttons when the button is activated.
            • wx.lib.gridmovers.GridColMoveEvent
            • wx.lib.gridmovers.GridRowMoveEvent
            • wx.lib.hyperlink.HyperLinkEvent: Event object sent in response to clicking on a HyperLinkCtrl.
            • wx.lib.intctrl.IntUpdatedEvent
            • wx.lib.masked.combobox.MaskedComboBoxSelectEvent: Because calling SetSelection programmatically does not fire EVT_COMBOBOX events, the derived control has to do it itself when it auto-completes.
            • wx.lib.mvctree.MVCTreeEvent
              • wx.lib.mvctree.MVCTreeNotifyEvent
            • wx.lib.masked.numctrl.NumberUpdatedEvent: Used to fire an EVT_NUM event whenever the value in a NumCtrl changes.
            • wx.lib.masked.timectrl.TimeUpdatedEvent: Used to fire an EVT_TIMEUPDATE event whenever the value in a TimeCtrl changes.
          • wx.SashEvent: Proxy of C++ SashEvent class
          • wx.ScrollEvent: A scroll event holds information about events sent from stand-alone scrollbars and sliders.
          • wx.stc.StyledTextEvent: Proxy of C++ StyledTextEvent class
          • wx.TextUrlEvent: Proxy of C++ TextUrlEvent class
          • wx.UpdateUIEvent: This class is used for EVT_UPDATE_UI pseudo-events which are sent by wxWidgets to give an application the chance to update various user interface elements.
          • wx.webkit.WebKitStateChangedEvent: Proxy of C++ WebKitStateChangedEvent class
          • wx.WindowCreateEvent: The EVT_WINDOW_CREATE event is sent as soon as the window object (the underlying GUI object) exists.
          • wx.WindowDestroyEvent: The EVT_WINDOW_DESTROY event is sent right before the window is destroyed.
        • wx.DisplayChangedEvent: An EVT_DISPLAY_CHANGED event is sent to all windows when the display resolution has changed.
        • wx.DropFilesEvent: This class is used for drop files events, that is, when files have been dropped onto the window.
        • wx.EraseEvent: An erase event is sent whenever the background of a window needs to be repainted.
        • wx.FocusEvent: A focus event is sent when a window's focus changes.
        • wx.IconizeEvent: An EVT_ICONIZE event is sent when a frame is iconized (minimized) or restored.
        • wx.IdleEvent: This class is used for EVT_IDLE events, which are generated and sent when the application becomes idle.
        • wx.InitDialogEvent: A wx.InitDialogEvent is sent as a dialog is being initialised, or for any window when wx.Window.InitDialog is called.
        • wx.JoystickEvent: Proxy of C++ JoystickEvent class
        • wx.KeyEvent: This event class contains information about keypress and character events.
        • wx.MaximizeEvent: An EVT_MAXIMIZE event is sent when a frame is maximized or restored.
        • wx.MenuEvent: This class is used for a variety of menu-related events.
        • wx.MouseCaptureChangedEvent: An mouse capture changed event (EVT_MOUSE_CAPTURE_CHANGED) is sent to a window that loses its mouse capture.
        • wx.MouseEvent: This event class contains information about the events generated by the mouse: they include mouse buttons press and release events and mouse move events.
        • wx.MoveEvent: This event object is sent for EVT_MOVE event bindings when a window is moved to a new position.
        • wx.NavigationKeyEvent: EVT_NAVIGATION_KEY events are used to control moving the focus between widgets, otherwise known as tab-traversal.
        • wx.NcPaintEvent: Proxy of C++ NcPaintEvent class
        • wx.PaintEvent: A paint event is sent when a window's contents needs to be repainted.
        • wx.PaletteChangedEvent: An EVT_PALETTE_CHANGED event is sent when the system palette has changed, thereby giving each window a chance to redo their own to match.
        • wx.ProcessEvent: Proxy of C++ ProcessEvent class
        • wx.PyEvent: wx.PyEvent can be used as a base class for implementing custom event types in Python.
          • wx.lib.throbber.UpdateThrobberEvent
        • wx.QueryLayoutInfoEvent: Proxy of C++ QueryLayoutInfoEvent class
        • wx.QueryNewPaletteEvent: An EVT_QUERY_NEW_PALETE event indicates the window is getting keyboard focus and should re-do its palette.
        • wx.ScrollWinEvent: A wx.ScrollWinEvent holds information about scrolling and is sent from scrolling windows.
        • wx.SetCursorEvent: A SetCursorEvent is generated when the mouse cursor is about to be set as a result of mouse motion.
        • wx.ShowEvent: An EVT_SHOW event is sent when a window is shown or hidden.
        • wx.SizeEvent: A size event holds information about size change events.
        • wx.SysColourChangedEvent: This class is used for EVT_SYS_COLOUR_CHANGED, which are generated when the user changes the colour settings using the control panel.
        • wx.TaskBarIconEvent: Proxy of C++ TaskBarIconEvent class
        • wx.TimerEvent: Proxy of C++ TimerEvent class
      • wx.EvtHandler: Proxy of C++ EvtHandler class
        • wx.lib.docview.DocManager: The wxDocManager class is part of the document/view framework supported by wxWindows, and cooperates with the wxView, wxDocument and wxDocTemplate classes.
        • wx.lib.pydocview.DocService: An abstract class used to add reusable services to a docview application.
          • wx.lib.pydocview.AboutService: About Dialog Service that installs under the Help menu to show the properties of the current application.
          • wx.lib.pydocview.DocOptionsService: A service that implements an options menu item and an options dialog with notebook tabs.
          • wx.lib.pydocview.FilePropertiesService: Service that installs under the File menu to show the properties of the file associated with the current document.
          • wx.lib.pydocview.WindowMenuService: The WindowMenuService is a service that implements a standard Window menu that is used by the DocSDIFrame.
        • wx.lib.docview.Document: The document class can be used to model an application's file-based data.
          • wx.lib.pydocview.ChildDocument: A ChildDocument is a document that represents a portion of a Document.
        • wx.lib.gridmovers.GridColMover
        • wx.lib.gridmovers.GridRowMover
        • wx.Menu: Proxy of C++ Menu class
          • wx.lib.ogl.PopupDivisionMenu
        • wx.Process: Proxy of C++ Process class
        • wx.PyApp: The wx.PyApp class is an implementation detail, please use the wx.App class (or some other derived class) instead.
          • wx.App: The wx.App class represents the application and is used to:
            • wx.py.PyAlaCarte.App: PyAlaCarte standalone application.
            • wx.py.PyAlaMode.App: PyAlaMode standalone application.
            • wx.py.PyAlaModeTest.App: PyAlaModeTest standalone application.
            • wx.py.PyCrust.App: PyCrust standalone application.
            • wx.py.PyShell.App: PyShell standalone application.
            • wx.py.filling.App: PyFilling standalone application.
              • wx.py.PyFilling.App
            • wx.PySimpleApp: A simple application class.
              • wx.lib.pydocview.DocApp: The DocApp class serves as the base class for pydocview applications and offers functionality such as services, creation of SDI and MDI frames, show tips, and a splash screen.
            • wx.PyWidgetTester
        • wx.TaskBarIcon: Proxy of C++ TaskBarIcon class
        • wx.Timer: Proxy of C++ Timer class
          • wx.PyTimer
        • wx.Validator: Proxy of C++ Validator class
          • wx.PyValidator: Proxy of C++ PyValidator class
            • wx.lib.intctrl.IntValidator: Validator class used with IntCtrl; handles all validation of input prior to changing the value of the underlying wx.TextCtrl.
        • wx.lib.docview.View: The view class can be used to model the viewing and editing component of an application's file-based data.
        • wx.Window: wx.Window is the base class for all windows and represents any visible object on the screen.
          • wx.lib.colourchooser.canvas.Canvas: A canvas class for arbitrary drawing.
            • wx.lib.colourchooser.pycolourslider.PyColourSlider: A Pure-Python Colour Slider
            • wx.lib.colourchooser.pypalette.PyPalette: The Pure-Python Palette
          • wx.lib.foldpanelbar.CaptionBar: This class is a graphical caption component that consists of a caption and a clickable arrow.
          • wx.lib.gridmovers.ColDragWindow
          • wx.Control: This is the base class for a control or 'widget'.
            • wx.BookCtrlBase: Proxy of C++ BookCtrlBase class
              • wx.Choicebook: Proxy of C++ Choicebook class
              • wx.Listbook: Proxy of C++ Listbook class
              • wx.Notebook: Proxy of C++ Notebook class
                • wx.py.editor.EditorNotebook: A notebook containing a page for each editor.
                • wx.py.editor.EditorShellNotebook: A notebook containing an editor page and a shell page.
            • wx.Button: A button is a control that contains a text string, and is one of the most common elements of a GUI.
              • wx.BitmapButton: A Button that contains a bitmap.
                • wx.lib.colourselect.ColourSelect
                • wx.ContextHelpButton: Instances of this class may be used to add a question mark button that when pressed, puts the application into context-help mode.
                • wx.lib.foldmenu.FoldOutMenu
            • wx.calendar.CalendarCtrl: The calendar control allows the user to pick a date interactively.
            • wx.CheckBox: A checkbox is a labelled box which by default is either on (the checkmark is visible) or off (no checkmark).
            • wx.ComboBox: A combobox is like a combination of an edit control and a listbox.
              • wx.lib.masked.combobox.BaseMaskedComboBox: Base class for generic masked edit comboboxes; allows auto-complete of values.
                • wx.lib.masked.combobox.ComboBox: The "user-visible" masked combobox control, this class is identical to the BaseMaskedComboBox class it's derived from.
                • wx.lib.masked.combobox.PreMaskedComboBox: This class exists to support the use of XRC subclassing.
            • wx.ControlWithItems: wx.ControlWithItems combines the wx.ItemContainer class with the wx.Control class, and is used for the base class of various controls that have items.
              • wx.Choice: A Choice control is used to select one of a list of strings.
                • wx.DirFilterListCtrl: Proxy of C++ DirFilterListCtrl class
              • wx.ListBox: Proxy of C++ ListBox class
                • wx.CheckListBox: Proxy of C++ CheckListBox class
            • wx.DatePickerCtrl: This control allows the user to select a date.
            • wx.Gauge: Proxy of C++ Gauge class
            • wx.GenericDirCtrl: Proxy of C++ GenericDirCtrl class
            • wx.animate.GIFAnimationCtrl: Proxy of C++ GIFAnimationCtrl class
            • wx.gizmos.LEDNumberCtrl: Proxy of C++ LEDNumberCtrl class
            • wx.ListCtrl: Proxy of C++ ListCtrl class
              • wx.ListView: Proxy of C++ ListView class
            • wx.media.MediaCtrl: Proxy of C++ MediaCtrl class
            • wx.PyControl: Proxy of C++ PyControl class
              • wx.lib.calendar.Calendar
              • wx.lib.buttons.GenButton: A generic button, and base class for the other generic buttons.
                • wx.lib.buttons.GenBitmapButton: A generic bitmap button.
                  • wx.lib.buttons.GenBitmapTextButton: A generic bitmapped button with text label
                    • wx.lib.buttons.GenBitmapTextToggleButton: A generic toggle bitmap button with text label
                  • wx.lib.buttons.GenBitmapToggleButton: A generic toggle bitmap button
                • wx.lib.buttons.GenToggleButton: A generic toggle button
              • wx.lib.statbmp.GenStaticBitmap
              • wx.lib.stattext.GenStaticText
                • wx.lib.hyperlink.HyperLinkCtrl: HyperLinkCtrl is a control for wxPython that acts like a hyper link in a typical browser.
              • wx.lib.popupctl.PopButton
              • wx.lib.popupctl.PopupControl
              • wx.lib.ticker.Ticker
            • wx.RadioBox: Proxy of C++ RadioBox class
            • wx.RadioButton: Proxy of C++ RadioButton class
            • wx.ScrollBar: Proxy of C++ ScrollBar class
            • wx.Slider: Proxy of C++ Slider class
            • wx.SpinButton: Proxy of C++ SpinButton class
            • wx.SpinCtrl: Proxy of C++ SpinCtrl class
            • wx.StaticBitmap: Proxy of C++ StaticBitmap class
              • wx.lib.fancytext.StaticFancyText
            • wx.StaticBox: Proxy of C++ StaticBox class
            • wx.StaticLine: Proxy of C++ StaticLine class
            • wx.gizmos.StaticPicture: Proxy of C++ StaticPicture class
            • wx.StaticText: Proxy of C++ StaticText class
            • wx.stc.StyledTextCtrl: Proxy of C++ StyledTextCtrl class
              • wx.py.editwindow.EditWindow: EditWindow based on StyledTextCtrl.
                • wx.py.crust.Display: STC used to display an object using Pretty Print.
                • wx.py.editor.EditWindow: EditWindow based on StyledTextCtrl.
                • wx.py.filling.FillingText: FillingText based on StyledTextCtrl.
                • wx.py.shell.Shell: Shell based on StyledTextCtrl.
              • wx.lib.pyshell.PyShellWindow
            • wx.TextCtrl: Proxy of C++ TextCtrl class
              • wx.lib.masked.textctrl.BaseMaskedTextCtrl: This is the primary derivation from MaskedEditMixin.
                • wx.lib.masked.ipaddrctrl.IpAddrCtrl: This class is a particular type of MaskedTextCtrl that accepts and understands the semantics of IP addresses, reformats input as you move from field to field, and accepts '.' as a navigation character, so that typing an IP address can be done naturally.
                • wx.lib.masked.numctrl.NumCtrl: Masked edit control supporting "native" numeric values, ie.
                • wx.lib.masked.textctrl.PreMaskedTextCtrl: This class exists to support the use of XRC subclassing.
                • wx.lib.masked.textctrl.TextCtrl: The "user-visible" masked text control; it is identical to the BaseMaskedTextCtrl class it's derived from.
                • wx.lib.masked.timectrl.TimeCtrl: Masked control providing several time formats and manipulation of time values.
              • wx.py.crust.Calltip: Text control containing the most recent shell calltip.
              • wx.lib.sheet.CTextCellEditor: Custom text control for cell editing
              • wx.py.crust.DispatcherListing: Text control containing all dispatches for session.
              • wx.lib.intctrl.IntCtrl: This class provides a control that takes and returns integers as value, and provides bounds support and optional value limiting.
              • wx.lib.rightalign.RightTextCtrl
              • wx.py.crust.SessionListing: Text control containing all commands for session.
            • wx.ToggleButton: Proxy of C++ ToggleButton class
            • wx.ToolBarBase: Proxy of C++ ToolBarBase class
              • wx.ToolBar: Proxy of C++ ToolBar class
                • wx.lib.floatbar.FloatBar
            • wx.TreeCtrl: Proxy of C++ TreeCtrl class
              • wx.py.filling.FillingTree: FillingTree based on TreeCtrl.
              • wx.gizmos.RemotelyScrolledTreeCtrl: Proxy of C++ RemotelyScrolledTreeCtrl class
            • wx.gizmos.TreeListCtrl: Proxy of C++ TreeListCtrl class
            • wx.webkit.WebKitCtrl: Proxy of C++ WebKitCtrl class
          • wx.gizmos.DynamicSashWindow: Proxy of C++ DynamicSashWindow class
          • wx.lib.multisash.EmptyChild
          • wx.glcanvas.GLCanvas: Proxy of C++ GLCanvas class
          • wx.lib.imagebrowser.ImageView
          • wx.MDIClientWindow: Proxy of C++ MDIClientWindow class
          • wx.MenuBar: Proxy of C++ MenuBar class
          • wx.lib.multisash.MultiClient
          • wx.lib.multisash.MultiCloser
          • wx.lib.multisash.MultiCreator
          • wx.lib.multisash.MultiSash
          • wx.lib.multisash.MultiSizer
          • wx.lib.multisash.MultiSplit
          • wx.lib.multisash.MultiViewLeaf
          • wx.Panel: Proxy of C++ Panel class
            • wx.lib.pydocview.DocTabbedChildFrame: The wxDocMDIChildFrame class provides a default frame for displaying documents on separate windows.
            • wx.gizmos.EditableListBox: Proxy of C++ EditableListBox class
            • wx.lib.filebrowsebutton.FileBrowseButton: A control to allow the user to type in a filename or browse with the standard file dialog to select file
              • wx.lib.filebrowsebutton.DirBrowseButton
              • wx.lib.filebrowsebutton.FileBrowseButtonWithHistory: __init__(..., history=None)
            • wx.lib.floatcanvas.FloatCanvas.FloatCanvas: FloatCanvas.py
            • wx.lib.foldpanelbar.FoldPanelBar: The FoldPanelBar is a class which can maintain a list of collapsable panels.
            • wx.lib.foldpanelbar.FoldPanelItem: This class is a child sibling of the FoldPanelBar class.
            • wx.lib.pydocview.GeneralOptionsPanel: A general options panel that is used in the OptionDialog to configure the generic properties of a pydocview application, such as "show tips at startup" and whether to use SDI or MDI for the application.
            • wx.lib.floatcanvas.NavCanvas.NavCanvas: NavCanvas.py
            • wx.NotebookPage: There is an old (and apparently unsolvable) bug when placing a window with a nonstandard background colour in a wx.Notebook on wxGTK1, as the notbooks's background colour would always be used when the window is refreshed.
            • wx.PreviewControlBar: Proxy of C++ PreviewControlBar class
              • wx.PyPreviewControlBar: Proxy of C++ PyPreviewControlBar class
            • wx.lib.colourchooser.pycolourbox.PyColourBox: A Colour Selection Box
            • wx.lib.colourchooser.pycolourchooser.PyColourChooser: A Pure-Python implementation of the colour chooser dialog.
            • wx.PyPanel: Proxy of C++ PyPanel class
              • wx.lib.throbber.Throbber: The first argument is either the name of a file that will be split into frames (a composite image) or a list of strings of image names that will be treated as individual frames.
            • wx.lib.shell.PyShell: interactive Python shell with wxPython interface
            • wx.lib.shell.PyShellInput: PyShell input window
            • wx.lib.shell.PyShellOutput: PyShell output window
            • wx.ScrolledWindow: Proxy of C++ ScrolledWindow class
              • wx.lib.editor.editor.Editor
              • wx.grid.Grid: Proxy of C++ Grid class
                • wx.lib.sheet.CSheet
              • wx.html.HtmlWindow: Proxy of C++ HtmlWindow class
                • wx.lib.ClickableHtmlWindow.PyClickableHtmlWindow: Class for a wxHtmlWindow which responds to clicks on links by opening a browser pointed at that link, and to shift-clicks by copying the link to the clipboard.
              • wx.lib.mvctree.MVCTree: The main mvc tree class.
              • wx.PreviewCanvas: Proxy of C++ PreviewCanvas class
              • wx.lib.printout.PrintTableDraw
              • wx.PyScrolledWindow: Proxy of C++ PyScrolledWindow class
                • wx.lib.scrolledpanel.ScrolledPanel: ScrolledPanel fills a "hole" in the implementation of wx.ScrolledWindow, providing automatic scrollbar and scrolling behavior and the tab traversal management that wxScrolledWindow lacks.
              • wx.lib.ogl.ShapeCanvas
              • wx.gizmos.SplitterScrolledWindow: Proxy of C++ SplitterScrolledWindow class
            • wx.VScrolledWindow: Proxy of C++ VScrolledWindow class
              • wx.VListBox: Proxy of C++ VListBox class
                • wx.HtmlListBox: Proxy of C++ HtmlListBox class
            • wx.wizard.WizardPage: Proxy of C++ WizardPage class
              • wx.wizard.PyWizardPage: Proxy of C++ PyWizardPage class
              • wx.wizard.WizardPageSimple: Proxy of C++ WizardPageSimple class
          • wx.lib.plot.PlotCanvas: Subclass of a wx.Window to allow simple general plotting of data with zoom, labels, and automatic axis scaling.
          • wx.lib.wxPlotCanvas.PlotCanvas
          • wx.PopupWindow: Proxy of C++ PopupWindow class
            • wx.lib.foldmenu.FoldOutWindow
            • wx.PopupTransientWindow: Proxy of C++ PopupTransientWindow class
              • wx.TipWindow: Proxy of C++ TipWindow class
          • wx.PyWindow: Proxy of C++ PyWindow class
            • wx.lib.analogclock.AnalogClockWindow: An analog clock window
          • wx.lib.gridmovers.RowDragWindow
          • wx.SashWindow: Proxy of C++ SashWindow class
            • wx.SashLayoutWindow: Proxy of C++ SashLayoutWindow class
          • wx.SplashScreenWindow: Proxy of C++ SplashScreenWindow class
          • wx.SplitterWindow: wx.SplitterWindow manages up to two subwindows or panes, with an optional vertical or horizontal split which can be used with the mouse or programmatically.
            • wx.py.crust.Crust: Crust based on SplitterWindow.
            • wx.py.filling.Filling: Filling based on wxSplitterWindow.
            • wx.gizmos.ThinSplitterWindow: Proxy of C++ ThinSplitterWindow class
          • wx.StatusBar: Proxy of C++ StatusBar class
          • wx.TopLevelWindow: Proxy of C++ TopLevelWindow class
            • wx.Dialog: Proxy of C++ Dialog class
              • wx.lib.pydocview.AboutDialog: Opens an AboutDialog.
              • wx.lib.calendar.CalenDlg
              • wx.ColourDialog: This class represents the colour chooser dialog.
              • wx.DirDialog: wx.DirDialog allows the user to select a directory by browising the file system.
              • wx.FileDialog: wx.FileDialog allows the user to select one or more files from the filesystem.
              • wx.lib.pydocview.FilePropertiesDialog: Dialog that shows the properties of a file.
              • wx.FindReplaceDialog: wx.FindReplaceDialog is a standard modeless dialog which is used to allow the user to search for some text (and possibly replace it with something else).
              • wx.FontDialog: wx.FontDialog allows the user to select a system font and its attributes.
              • wx.lib.imagebrowser.ImageDialog
              • wx.MessageDialog: This class provides a simple dialog that shows a single or multi-line message, with a choice of OK, Yes, No and/or Cancel buttons.
              • wx.MultiChoiceDialog: A simple dialog with a multi selection listbox.
              • wx.lib.dialogs.MultipleChoiceDialog
              • wx.lib.pydocview.OptionsDialog: A default options dialog used by the OptionsService that hosts a notebook tab of options panels.
              • wx.lib.popupctl.PopupDialog
              • wx.lib.dialogs.ScrolledMessageDialog
              • wx.SingleChoiceDialog: A simple dialog with a single selection listbox.
              • wx.TextEntryDialog: A dialog with text control, [ok] and [cancel] buttons
                • wx.PasswordEntryDialog: Proxy of C++ PasswordEntryDialog class
              • wx.wizard.Wizard: Proxy of C++ Wizard class
            • wx.Frame: Proxy of C++ Frame class
              • wx.lib.analogclockopts.ACCustomizationFrame
              • wx.lib.docview.DocChildFrame: The wxDocChildFrame class provides a default frame for displaying documents on separate windows.
                • wx.lib.pydocview.DocSDIFrame: The DocSDIFrame host DocManager Document windows.
              • wx.lib.docview.DocParentFrame: The wxDocParentFrame class provides a default top-level frame for applications using the document/view framework.
              • wx.lib.pydocview.DocTabbedParentFrame: The DocTabbedParentFrame class provides a default top-level frame for applications using the document/view framework.
              • wx.py.filling.FillingFrame: Frame containing the namespace tree component.
              • wx.py.frame.Frame: Frame with standard menu items.
                • wx.py.crust.CrustFrame: Frame containing all the PyCrust components.
                • wx.py.editor.EditorFrame: Frame containing one editor.
                  • wx.py.editor.EditorNotebookFrame: Frame containing one or more editors in a notebook.
                    • wx.py.editor.EditorShellNotebookFrame: Frame containing a notebook containing EditorShellNotebooks.
                • wx.py.shell.ShellFrame: Frame containing the shell component.
              • wx.html.HtmlHelpFrame: Proxy of C++ HtmlHelpFrame class
              • wx.MDIChildFrame: Proxy of C++ MDIChildFrame class
                • wx.lib.docview.DocMDIChildFrame: The wxDocMDIChildFrame class provides a default frame for displaying documents on separate windows.
                • wx.lib.pydocview.DocMDIChildFrame: The wxDocMDIChildFrame class provides a default frame for displaying documents on separate windows.
              • wx.MDIParentFrame: Proxy of C++ MDIParentFrame class
                • wx.lib.docview.DocMDIParentFrame: The wxDocMDIParentFrame class provides a default top-level frame for applications using the document/view framework.
                  • wx.lib.pydocview.DocMDIParentFrame: The DocMDIParentFrame is the primary frame which the DocApp uses to host MDI child windows.
              • wx.MiniFrame: Proxy of C++ MiniFrame class
              • wx.PreviewFrame: Proxy of C++ PreviewFrame class
                • wx.PyPreviewFrame: Proxy of C++ PyPreviewFrame class
              • wx.ProgressDialog: A dialog that shows a short message and a progress bar.
              • wx.SplashScreen: Proxy of C++ SplashScreen class
              • wx.lib.splashscreen.SplashScreen
              • wx.lib.plot.TestFrame
          • wx.gizmos.TreeCompanionWindow: Proxy of C++ TreeCompanionWindow class
      • wx.FileHistory: Proxy of C++ FileHistory class
      • wx.FileSystem: Proxy of C++ FileSystem class
      • wx.FindReplaceData: wx.FindReplaceData holds the data for wx.FindReplaceDialog.
      • wx.FontData: This class holds a variety of information related to font dialogs and is used to transfer settings to and results from a wx.FontDialog.
      • wx.FontList: Proxy of C++ FontList class
      • wx.FSFile: Proxy of C++ FSFile class
      • wx.GDIObject: Proxy of C++ GDIObject class
        • wx.Bitmap: The wx.Bitmap class encapsulates the concept of a platform-dependent bitmap.
        • wx.Brush: A brush is a drawing tool for filling in areas.
        • wx.Cursor: A cursor is a small bitmap usually used for denoting where the mouse pointer is, with a picture that might indicate the interpretation of a mouse click.
        • wx.Font: A font is an object which determines the appearance of text.
        • wx.Icon: Proxy of C++ Icon class
        • wx.Palette: Proxy of C++ Palette class
        • wx.Pen: Proxy of C++ Pen class
        • wx.Region: Proxy of C++ Region class
      • wx.glcanvas.GLContext: Proxy of C++ GLContext class
      • wx.grid.GridTableBase: Proxy of C++ GridTableBase class
        • wx.grid.GridStringTable: Proxy of C++ GridStringTable class
        • wx.grid.PyGridTableBase: Proxy of C++ PyGridTableBase class
      • wx.html.HtmlCell: Proxy of C++ HtmlCell class
        • wx.html.HtmlColourCell: Proxy of C++ HtmlColourCell class
        • wx.html.HtmlContainerCell: Proxy of C++ HtmlContainerCell class
        • wx.html.HtmlFontCell: Proxy of C++ HtmlFontCell class
        • wx.html.HtmlWidgetCell: Proxy of C++ HtmlWidgetCell class
        • wx.html.HtmlWordCell: Proxy of C++ HtmlWordCell class
      • wx.html.HtmlDCRenderer: Proxy of C++ HtmlDCRenderer class
      • wx.html.HtmlEasyPrinting: Proxy of C++ HtmlEasyPrinting class
      • wx.html.HtmlFilter: Proxy of C++ HtmlFilter class
      • wx.html.HtmlHelpController: Proxy of C++ HtmlHelpController class
      • wx.html.HtmlLinkInfo: Proxy of C++ HtmlLinkInfo class
      • wx.html.HtmlParser: Proxy of C++ HtmlParser class
        • wx.html.HtmlWinParser: Proxy of C++ HtmlWinParser class
      • wx.html.HtmlTag: Proxy of C++ HtmlTag class
      • wx.html.HtmlTagHandler: Proxy of C++ HtmlTagHandler class
        • wx.html.HtmlWinTagHandler: Proxy of C++ HtmlWinTagHandler class
          • wx.lib.wxpTag.wxpTagHandler
      • wx.Image: A platform-independent image class.
      • wx.ImageHandler: This is the base class for implementing image file loading/saving, and image creation from data.
        • wx.BMPHandler: A wx.ImageHandler for *.bmp bitmap files.
          • wx.ICOHandler: A wx.ImageHandler for *.ico icon files.
            • wx.CURHandler: A wx.ImageHandler for *.cur cursor files.
              • wx.ANIHandler: A wx.ImageHandler for *.ani animated cursor files.
        • wx.GIFHandler: A wx.ImageHandler for GIF image files.
        • wx.JPEGHandler: A wx.ImageHandler for JPEG/JPG image files.
        • wx.PCXHandler: A wx.ImageHandler for PCX imager files.
        • wx.PNGHandler: A wx.ImageHandler for PNG image files.
        • wx.PNMHandler: A wx.ImageHandler for PNM image files.
        • wx.TIFFHandler: A wx.ImageHandler for TIFF image files.
        • wx.XPMHandler: A wx.ImageHandler for XPM image.
      • wx.ImageList: Proxy of C++ ImageList class
      • wx.IndividualLayoutConstraint: Objects of this class are stored in the wx.LayoutConstraints class as one of eight possible constraints that a window can be involved in.
      • wx.LayoutAlgorithm: Proxy of C++ LayoutAlgorithm class
      • wx.LayoutConstraints: Note: constraints are now deprecated and you should use sizers instead.
        • wx.lib.anchors.LayoutAnchors: A class that implements Delphi's Anchors with wx.LayoutConstraints.
        • wx.lib.layoutf.Layoutf: The class Layoutf(wxLayoutConstraints) presents a simplification of the wxLayoutConstraints syntax.
      • wx.ListItem: Proxy of C++ ListItem class
      • wx.Mask: This class encapsulates a monochrome mask bitmap, where the masked area is black and the unmasked area is white.
      • wx.MenuItem: Proxy of C++ MenuItem class
      • wx.MetaFile: Proxy of C++ MetaFile class
      • wx.PageSetupDialog: Proxy of C++ PageSetupDialog class
      • wx.PageSetupDialogData: Proxy of C++ PageSetupDialogData class
      • wx.PenList: Proxy of C++ PenList class
      • wx.PrintData: Proxy of C++ PrintData class
      • wx.PrintDialog: Proxy of C++ PrintDialog class
      • wx.PrintDialogData: Proxy of C++ PrintDialogData class
      • wx.Printer: Proxy of C++ Printer class
      • wx.Printout: Proxy of C++ Printout class
        • wx.lib.docview.DocPrintout: DocPrintout is a default Printout that prints the first page of a document view.
        • wx.html.HtmlPrintout: Proxy of C++ HtmlPrintout class
        • wx.lib.plot.PlotPrintout: Controls how the plot is made in printing and previewing
        • wx.lib.printout.SetPrintout
      • wx.PrintPreview: Proxy of C++ PrintPreview class
        • wx.PyPrintPreview: Proxy of C++ PyPrintPreview class
      • wx.RegionIterator: Proxy of C++ RegionIterator class
      • wx.Sizer: wx.Sizer is the abstract base class used for laying out subwindows in a window.
        • wx.BookCtrlSizer: Proxy of C++ BookCtrlSizer class
        • wx.BoxSizer: The basic idea behind a box sizer is that windows will most often be laid out in rather simple basic geometry, typically in a row or a column or nested hierarchies of either.
          • wx.StaticBoxSizer: wx.StaticBoxSizer derives from and functions identically to the wx.BoxSizer and adds a wx.StaticBox around the items that the sizer manages.
          • wx.StdDialogButtonSizer: A special sizer that knows how to order and position standard buttons in order to conform to the current platform's standards.
        • wx.GridSizer: A grid sizer is a sizer which lays out its children in a two-dimensional table with all cells having the same size.
          • wx.FlexGridSizer: A flex grid sizer is a sizer which lays out its children in a two-dimensional table with all table cells in one row having the same height and all cells in one column having the same width, but all rows or all columns are not necessarily the same height or width as in the wx.GridSizer.
            • wx.GridBagSizer: A wx.Sizer that can lay out items in a virtual grid like a wx.FlexGridSizer but in this case explicit positioning of the items is allowed using wx.GBPosition, and items can optionally span more than one row and/or column using wx.GBSpan.
        • wx.NotebookSizer: Proxy of C++ NotebookSizer class
        • wx.PySizer: wx.PySizer is a special version of wx.Sizer that has been instrumented to allow the C++ virtual methods to be overloaded in Python derived classes.
          • wx.lib.grids.PyGridSizer
            • wx.lib.grids.PyFlexGridSizer
          • wx.lib.rcsizer.RowColSizer
      • wx.SizerItem: The wx.SizerItem class is used to track the position, size and other attributes of each item managed by a wx.Sizer.
        • wx.GBSizerItem: The wx.GBSizerItem class is used to track the additional data about items in a wx.GridBagSizer such as the item's position in the grid and how many rows or columns it spans.
      • wx.SystemOptions: Proxy of C++ SystemOptions class
      • wx.ToolBarToolBase: Proxy of C++ ToolBarToolBase class
      • wx.ToolTip: Proxy of C++ ToolTip class
      • wx.gizmos.TreeListColumnInfo: Proxy of C++ TreeListColumnInfo class
      • wx.xrc.XmlDocument: Proxy of C++ XmlDocument class
      • wx.xrc.XmlResource: Proxy of C++ XmlResource class
      • wx.xrc.XmlResourceHandler: Proxy of C++ XmlResourceHandler class
        • wx.lib.ticker_xrc.wxTickerXmlHandler
    • wx.OutputStream: Proxy of C++ OutputStream class
    • wx.Point: A data structure for representing a point or position with integer x and y properties.
    • wx.Point2D: wx.Point2Ds represent a point or a vector in a 2d coordinate system with floating point values.
    • wx.PropagateOnce: A helper class that will temporarily lower propagation level of an event.
    • wx.PropagationDisabler: Helper class to temporarily change an event not to propagate.
    • wx.lib.ogl.PseudoMetaFile: A simple metafile-like class which can load data from a Windows metafile on all platforms.
    • wx.PyEventBinder: Instances of this class are used to bind specific events to event handlers.
    • wx.Quantize: Performs quantization, or colour reduction, on a wxImage.
    • wx.RealPoint: A data structure for representing a point or position with floating point x and y properties.
    • wx.Rect: A class for representing and manipulating rectangles.
    • wx.lib.ogl.ShapeEvtHandler
      • wx.lib.ogl.Shape: OGL base class
        • wx.lib.ogl.EllipseShape: The EllipseShape behaves similarly to the RectangleShape but is elliptical.
          • wx.lib.ogl.CircleShape: An EllipseShape whose width and height are the same.
        • wx.lib.ogl.LineShape: LineShape may be attached to two nodes; it may be segmented, in which case a control point is drawn for each joint.
        • wx.lib.ogl.PolygonShape: A PolygonShape's shape is defined by a number of points passed to the object's constructor.
        • wx.lib.ogl.RectangleShape: The wxRectangleShape has rounded or square corners.
          • wx.lib.ogl.BitmapShape: Draws a bitmap (non-resizable).
          • wx.lib.ogl.CompositeShape: This is an object with a list of child objects, and a list of size and positioning constraints between the children.
            • wx.lib.ogl.DivisionShape: A division shape is like a composite in that it can contain further objects, but is used exclusively to divide another shape into regions, or divisions.
          • wx.lib.ogl.ControlPoint
            • wx.lib.ogl.DividedShapeControlPoint
            • wx.lib.ogl.DivisionControlPoint
            • wx.lib.ogl.LineControlPoint
            • wx.lib.ogl.PolygonControlPoint
          • wx.lib.ogl.DividedShape: A DividedShape is a rectangle with a number of vertical divisions.
          • wx.lib.ogl.DrawnShape: Draws a pseudo-metafile shape, which can be loaded from a simple Windows metafile.
          • wx.lib.ogl.LabelShape
          • wx.lib.ogl.TextShape: As wxRectangleShape, but only the text is displayed.
    • wx.lib.ogl.ShapeRegion: Object region.
    • wx.lib.ogl.ShapeTextLine
    • wx.SingleInstanceChecker: Proxy of C++ SingleInstanceChecker class
    • wx.Size: wx.Size is a useful data structure used to represent the size of something.
    • wx.Sound: Proxy of C++ Sound class
    • wx.StandardPaths: wx.StandardPaths returns the standard locations in the file system and should be used by the programs to find their data files in a portable way.
    • wx.StopWatch: Proxy of C++ StopWatch class
    • wx.SystemSettings: Proxy of C++ SystemSettings class
    • wx.TextAttr: Proxy of C++ TextAttr class
    • wx.TimerRunner: Proxy of C++ TimerRunner class
    • wx.TimeSpan: Proxy of C++ TimeSpan class
    • wx.TipProvider: Proxy of C++ TipProvider class
      • wx.PyTipProvider: Proxy of C++ PyTipProvider class
    • wx.TreeItemData: Proxy of C++ TreeItemData class
    • wx.TreeItemId: Proxy of C++ TreeItemId class
    • __builtin__.type: type(object) -> the object's type type(name, bases, dict) -> a new type
    • wx.VideoMode: A simple struct containing video mode parameters for a display
    • wx.VisualAttributes: struct containing all the visual attributes of a control
    • wx.WindowDisabler: Proxy of C++ WindowDisabler class
    • wx.xrc.XmlNode: Proxy of C++ XmlNode class
    • wx.xrc.XmlProperty: Proxy of C++ XmlProperty class
    • wx.xrc.XmlSubclassFactory: Proxy of C++ XmlSubclassFactory class
      • wx.xrc.XmlSubclassFactory_Python
  • code.InteractiveInterpreter: Base class for InteractiveConsole.
    • wx.py.interpreter.Interpreter: Interpreter based on code.InteractiveInterpreter.
      • wx.py.interpreter.InterpreterAlaCarte: Demo Interpreter.
    • wx.lib.pyshell.PyShellWindow
  • distutils.cmd.Command: Abstract base class for defining command classes, the "worker bees" of the Distutils.
    • distutils.command.clean.clean
    • distutils.command.install.install
    • distutils.command.install_data.install_data
    • distutils.command.install_headers.install_headers
  • exceptions.Exception: Common base class for all exceptions.
    • wx.py.dispatcher.DispatcherError
    • wx.lib.floatcanvas.FloatCanvas.FloatCanvasError
    • exceptions.StandardError: Base class for all standard Python exceptions.
      • exceptions.AssertionError: Assertion failed.
        • wx.PyAssertionError
      • exceptions.AttributeError: Attribute not found.
        • wx.PyDeadObjectError
        • wx.PyUnbornObjectError
      • exceptions.RuntimeError: Unspecified run-time error.
        • wx.PyNoAppError
    • wxversion.VersionError
  • wx.FutureCall: A convenience class for wx.Timer, that calls the given callable object once after the given amount of milliseconds, passing any positional or keyword args.
  • wx.PyOnDemandOutputWindow: A class that can be used for redirecting Python's stdout and stderr streams.
  • wx.lib.CDate.Date
  • wx.lib.CDate.now
  • wx.lib.calendar.CalDraw
    • wx.lib.calendar.PrtCalDraw
  • wx.lib.dialogs.DialogResults
  • wx.lib.editor.editor.Scroller
  • wx.lib.evtmgr.EventAdapter: A class that adapts incoming wxWindows events to Publish/Subscribe messages.
  • wx.lib.evtmgr.EventMacroInfo: A class that provides information about event macros.
  • wx.lib.evtmgr.EventManager: This is the main class in the module, and is the only class that the application programmer needs to use.
  • wx.lib.evtmgr.FakeWindow: Used internally by the EventMacroInfo class.
  • wx.lib.evtmgr.MessageAdapter: A class that adapts incoming Publish/Subscribe messages to wxWindows event calls.
  • wx.lib.floatcanvas.FloatCanvas.ColorOnlyMixin: Mixin class for objects that have just one color, rather than a fill color and line color
    • wx.lib.floatcanvas.FloatCanvas.Point: The Point class takes a 2-tuple, or a (2,) NumPy array of point coordinates.
    • wx.lib.floatcanvas.FloatCanvas.PointSet: The PointSet class takes a list of 2-tuples, or a NX2 NumPy array of point coordinates.
  • wx.lib.floatcanvas.FloatCanvas.DrawObject: This is the base class for all the objects that can be drawn.
    • wx.lib.floatcanvas.FloatCanvas.Arrow: Arrow(XY, # coords of origin of arrow (x,y) Length, # length of arrow in pixels theta, # angle of arrow in degrees: zero is straight up # angle is to the right LineColor = "Black", LineStyle = "Solid", LineWidth = 1, ArrowHeadSize = 4, ArrowHeadAngle = 45, InForeground = False): It will draw an arrow , starting at the point, (X,Y) pointing in direction, theta.
    • wx.lib.floatcanvas.FloatCanvas.Line: The Line class takes a list of 2-tuples, or a NX2 NumPy Float array of point coordinates.
    • wx.lib.floatcanvas.FloatCanvas.Point: The Point class takes a 2-tuple, or a (2,) NumPy array of point coordinates.
    • wx.lib.floatcanvas.FloatCanvas.PointSet: The PointSet class takes a list of 2-tuples, or a NX2 NumPy array of point coordinates.
    • wx.lib.floatcanvas.FloatCanvas.Polygon: The Polygon class takes a list of 2-tuples, or a NX2 NumPy array of point coordinates.
    • wx.lib.floatcanvas.FloatCanvas.RectEllipse
      • wx.lib.floatcanvas.FloatCanvas.Ellipse
        • wx.lib.floatcanvas.FloatCanvas.Circle
      • wx.lib.floatcanvas.FloatCanvas.Rectangle
    • wx.lib.floatcanvas.FloatCanvas.ScaledText: This class creates a text object that is scaled when zoomed.
    • wx.lib.floatcanvas.FloatCanvas.Text: This class creates a text object, placed at the coordinates, x,y.
  • wx.lib.floatcanvas.FloatCanvas.LineOnlyMixin: Mixin class for objects that have just one color, rather than a fill color and line color
    • wx.lib.floatcanvas.FloatCanvas.Arrow: Arrow(XY, # coords of origin of arrow (x,y) Length, # length of arrow in pixels theta, # angle of arrow in degrees: zero is straight up # angle is to the right LineColor = "Black", LineStyle = "Solid", LineWidth = 1, ArrowHeadSize = 4, ArrowHeadAngle = 45, InForeground = False): It will draw an arrow , starting at the point, (X,Y) pointing in direction, theta.
    • wx.lib.floatcanvas.FloatCanvas.Line: The Line class takes a list of 2-tuples, or a NX2 NumPy Float array of point coordinates.
    • wx.lib.floatcanvas.FloatCanvas.LineAndFillMixin: Mixin class for objects that have both a line and a fill color and style.
      • wx.lib.floatcanvas.FloatCanvas.Polygon: The Polygon class takes a list of 2-tuples, or a NX2 NumPy array of point coordinates.
      • wx.lib.floatcanvas.FloatCanvas.RectEllipse
        • wx.lib.floatcanvas.FloatCanvas.Ellipse
          • wx.lib.floatcanvas.FloatCanvas.Circle
        • wx.lib.floatcanvas.FloatCanvas.Rectangle
  • wx.lib.floatcanvas.FloatCanvas.PointsObjectMixin: This is a mixin class that provides some methods suitable for use with objects that have a set of (x,y) coordinate pairs.
    • wx.lib.floatcanvas.FloatCanvas.Line: The Line class takes a list of 2-tuples, or a NX2 NumPy Float array of point coordinates.
    • wx.lib.floatcanvas.FloatCanvas.PointSet: The PointSet class takes a list of 2-tuples, or a NX2 NumPy array of point coordinates.
    • wx.lib.floatcanvas.FloatCanvas.Polygon: The Polygon class takes a list of 2-tuples, or a NX2 NumPy array of point coordinates.
  • wx.lib.floatcanvas.FloatCanvas.XYObjectMixin: This is a mixin class that provides some methods suitable for use with objects that have a single (x,y) coordinate pair.
    • wx.lib.floatcanvas.FloatCanvas.Arrow: Arrow(XY, # coords of origin of arrow (x,y) Length, # length of arrow in pixels theta, # angle of arrow in degrees: zero is straight up # angle is to the right LineColor = "Black", LineStyle = "Solid", LineWidth = 1, ArrowHeadSize = 4, ArrowHeadAngle = 45, InForeground = False): It will draw an arrow , starting at the point, (X,Y) pointing in direction, theta.
    • wx.lib.floatcanvas.FloatCanvas.Point: The Point class takes a 2-tuple, or a (2,) NumPy array of point coordinates.
    • wx.lib.floatcanvas.FloatCanvas.RectEllipse
      • wx.lib.floatcanvas.FloatCanvas.Ellipse
        • wx.lib.floatcanvas.FloatCanvas.Circle
      • wx.lib.floatcanvas.FloatCanvas.Rectangle
    • wx.lib.floatcanvas.FloatCanvas.TextObjectMixin: A mix in class that holds attributes and methods that are needed by the Text objects
      • wx.lib.floatcanvas.FloatCanvas.ScaledText: This class creates a text object that is scaled when zoomed.
      • wx.lib.floatcanvas.FloatCanvas.Text: This class creates a text object, placed at the coordinates, x,y.
  • wx.lib.foldpanelbar.CaptionBarStyle: This class encapsulates the styles you wish to set for the CaptionBar (this is the part of the FoldPanel where the caption is displayed).
  • wx.lib.foldpanelbar.FoldWindowItem: This class is a child sibling of the FoldPanelItem class.
  • wx.lib.gestures.MouseGestures
  • wx.lib.imagebrowser.FindFiles
  • wx.lib.infoframe.Dummy_PyInformationalMessagesFrame
  • wx.lib.infoframe.PyInformationalMessagesFrame
  • wx.lib.masked.ctrl.controlTypes
  • wx.lib.masked.ipaddrctrl.IpAddrCtrlAccessorsMixin: Defines IpAddrCtrl's list of attributes having their own Get/Set functions, exposing only those that make sense for an IP address control.
    • wx.lib.masked.ipaddrctrl.IpAddrCtrl: This class is a particular type of MaskedTextCtrl that accepts and understands the semantics of IP addresses, reformats input as you move from field to field, and accepts '.' as a navigation character, so that typing an IP address can be done naturally.
  • wx.lib.masked.maskededit.Field: This class manages the individual fields in a masked edit control.
  • wx.lib.masked.maskededit.MaskedEditAccessorsMixin: To avoid a ton of boiler-plate, and to automate the getter/setter generation for each valid control parameter so we never forget to add the functions when adding parameters, this class programmatically adds the masked edit mixin parameters to itself.
    • wx.lib.masked.combobox.ComboBox: The "user-visible" masked combobox control, this class is identical to the BaseMaskedComboBox class it's derived from.
    • wx.lib.masked.combobox.PreMaskedComboBox: This class exists to support the use of XRC subclassing.
    • wx.lib.masked.textctrl.PreMaskedTextCtrl: This class exists to support the use of XRC subclassing.
    • wx.lib.masked.textctrl.TextCtrl: The "user-visible" masked text control; it is identical to the BaseMaskedTextCtrl class it's derived from.
  • wx.lib.masked.maskededit.MaskedEditMixin: This class allows us to abstract the masked edit functionality that could be associated with any text entry control.
    • wx.lib.masked.combobox.BaseMaskedComboBox: Base class for generic masked edit comboboxes; allows auto-complete of values.
      • wx.lib.masked.combobox.ComboBox: The "user-visible" masked combobox control, this class is identical to the BaseMaskedComboBox class it's derived from.
      • wx.lib.masked.combobox.PreMaskedComboBox: This class exists to support the use of XRC subclassing.
    • wx.lib.masked.textctrl.BaseMaskedTextCtrl: This is the primary derivation from MaskedEditMixin.
      • wx.lib.masked.ipaddrctrl.IpAddrCtrl: This class is a particular type of MaskedTextCtrl that accepts and understands the semantics of IP addresses, reformats input as you move from field to field, and accepts '.' as a navigation character, so that typing an IP address can be done naturally.
      • wx.lib.masked.numctrl.NumCtrl: Masked edit control supporting "native" numeric values, ie.
      • wx.lib.masked.textctrl.PreMaskedTextCtrl: This class exists to support the use of XRC subclassing.
      • wx.lib.masked.textctrl.TextCtrl: The "user-visible" masked text control; it is identical to the BaseMaskedTextCtrl class it's derived from.
      • wx.lib.masked.timectrl.TimeCtrl: Masked control providing several time formats and manipulation of time values.
  • wx.lib.masked.numctrl.NumCtrlAccessorsMixin: Defines masked.NumCtrl's list of attributes having their own Get/Set functions, ignoring those that make no sense for a numeric control.
    • wx.lib.masked.numctrl.NumCtrl: Masked edit control supporting "native" numeric values, ie.
  • wx.lib.masked.timectrl.TimeCtrlAccessorsMixin: Defines TimeCtrl's list of attributes having their own Get/Set functions, ignoring those in the base class that make no sense for a time control.
  • wx.lib.mixins.grid.GridAutoEditMixin: A mix-in class that automatically enables the grid edit control when a cell is selected.
  • wx.lib.mixins.imagelist.MagicImageList: Mix-in to provide "magic" growing image lists By Mike Fletcher
  • wx.lib.mixins.listctrl.ColumnSorterMixin: A mixin class that handles sorting of a wx.ListCtrl in REPORT mode when the column header is clicked on.
  • wx.lib.mixins.listctrl.ListCtrlAutoWidthMixin: A mix-in class that automatically resizes the last column to take up the remaining width of the wx.ListCtrl.
  • wx.lib.mixins.listctrl.ListCtrlSelectionManagerMix: Mixin that defines a platform independent selection policy
  • wx.lib.mixins.listctrl.TextEditMixin: A mixin class that enables any text in any column of a multi-column listctrl to be edited by clicking on the given row and column.
  • wx.lib.mixins.rubberband.RubberBand: A stretchable border which is drawn on top of an image to define an area.
  • wx.lib.mvctree.Editor
    • wx.lib.mvctree.FileEditor
  • wx.lib.mvctree.FileWrapper: Node class for FSTreeModel.
  • wx.lib.mvctree.LayoutEngine: Interface for layout engines.
    • wx.lib.mvctree.TreeLayout
  • wx.lib.mvctree.LinePainter: The linepainter interface.
    • wx.lib.mvctree.TreeLinePainter
  • wx.lib.mvctree.MVCTreeNode: Used internally by MVCTree to manage its data.
  • wx.lib.mvctree.NodePainter: This is the interface expected of a nodepainter.
    • wx.lib.mvctree.TreeNodePainter
  • wx.lib.mvctree.Painter: This is the interface that MVCTree expects from painters.
    • wx.lib.mvctree.TreePainter: The default painter class.
  • wx.lib.mvctree.Rect
  • wx.lib.mvctree.TextConverter: TextConverter interface.
    • wx.lib.mvctree.StrTextConverter
  • wx.lib.mvctree.Transform: Transform interface.
    • wx.lib.mvctree.NullTransform
  • wx.lib.mvctree.TreeModel: Interface for tree models
    • wx.lib.mvctree.BasicTreeModel: A very simple treemodel implementation, but flexible enough for many needs.
      • wx.lib.mvctree.FSTreeModel: This treemodel models the filesystem starting from a given path.
        • wx.lib.mvctree.LateFSTreeModel: This treemodel models the filesystem starting from a given path.
  • wx.lib.plot.PlotGraphics: Container to hold PolyXXX objects and graph labels - All methods except __init__ are private.
  • wx.lib.plot.PolyPoints: Base Class for lines and markers - All methods are private.
    • wx.lib.plot.PolyLine: Class to define line type and style - All methods except __init__ are private.
    • wx.lib.plot.PolyMarker: Class to define marker type and style - All methods except __init__ are private.
  • wx.lib.printout.PrintBase
    • wx.lib.printout.PrintTableDraw
  • wx.lib.printout.PrintGrid
  • wx.lib.printout.PrintTable
  • wx.lib.pubsub.Message: A simple container object for the two components of a message; the topic and the user data.
  • wx.lib.pydocview.DocFrameMixIn: Class with common code used by DocMDIParentFrame, DocTabbedParentFrame, and DocSDIFrame.
    • wx.lib.pydocview.DocMDIParentFrame: The DocMDIParentFrame is the primary frame which the DocApp uses to host MDI child windows.
    • wx.lib.pydocview.DocSDIFrame: The DocSDIFrame host DocManager Document windows.
    • wx.lib.pydocview.DocTabbedParentFrame: The DocTabbedParentFrame class provides a default top-level frame for applications using the document/view framework.
  • wx.lib.pydocview.DocMDIParentFrameMixIn: Class with common code used by DocMDIParentFrame and DocTabbedParentFrame.
    • wx.lib.pydocview.DocMDIParentFrame: The DocMDIParentFrame is the primary frame which the DocApp uses to host MDI child windows.
    • wx.lib.pydocview.DocTabbedParentFrame: The DocTabbedParentFrame class provides a default top-level frame for applications using the document/view framework.
  • wx.lib.pyshell.FauxFile
  • wx.lib.wxPlotCanvas.PlotGraphics
  • wx.lib.wxPlotCanvas.PolyPoints
    • wx.lib.wxPlotCanvas.PolyLine
    • wx.lib.wxPlotCanvas.PolyMarker
  • wx.py.buffer.Buffer: Buffer class.
  • wx.py.dispatcher.BoundMethodWeakref: BoundMethodWeakref class.
  • wx.py.dispatcher.Parameter: Used to represent default parameter values.
  • wx.py.document.Document: Document class.
  • wx.py.editor.DialogResults: DialogResults class.
  • wx.py.editor.Editor: Editor having an EditWindow.
  • wx.py.pseudo.PseudoFile
    • wx.py.pseudo.PseudoFileErr
    • wx.py.pseudo.PseudoFileIn
    • wx.py.pseudo.PseudoFileOut
  • wx.py.pseudo.PseudoKeyword: A callable class that calls a method passed as a parameter.
  • wx.py.shell.ShellFacade: Simplified interface to all shell-related functionality.
  • wx.tools.dbg.Logger
Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:42 2005 http://epydoc.sf.net


wx.AcceleratorEntry

Package wx :: Class AcceleratorEntry

Type AcceleratorEntry

object --+
         |
        AcceleratorEntry

A class used to define items in an wx.AcceleratorTable. wxPython programs can choose to use wx.AcceleratorEntry objects, but using a list of 3-tuple of integers (flags, keyCode, cmdID) usually works just as well. See __init__ for of the tuple values.

See Also:

wx.AcceleratorTable

Method Summary
AcceleratorEntry | __init__(self, flags, keyCode, cmdID)
 | __del__(self)
 | __repr__(self)
int | GetCommand(self) Get the AcceleratorEntry's command ID.
int | GetFlags(self) Get the AcceleratorEntry's flags.
int | GetKeyCode(self) Get the AcceleratorEntry's keycode.
 | Set(self, flags, keyCode, cmd) (Re)set the attributes of a wx.AcceleratorEntry.

Method Details

__init__(self,
          flags=0,
          keyCode=0,
          cmdID=0)
(Constructor)

Construct a wx.AcceleratorEntry.
Parameters:
flags - A bitmask of wx.ACCEL_ALT, wx.ACCEL_SHIFT, wx.ACCEL_CTRL or wx.ACCEL_NORMAL used to specify which modifier keys are held down.
(type=int)

keyCode - The keycode to be detected
(type=int)

cmdID - The menu or control command ID to use for the accellerator event.
(type=int)

Returns:
AcceleratorEntry
Overrides:
__builtin__.object.__init__

GetCommand(self)

Get the AcceleratorEntry's command ID.

Returns:
int

GetFlags(self)

Get the AcceleratorEntry's flags.

Returns:
int

GetKeyCode(self)

Get the AcceleratorEntry's keycode.

Returns:
int

Set(self, flags, keyCode, cmd)

(Re)set the attributes of a wx.AcceleratorEntry. :see __init__

Parameters:
flags
(type=int)

keyCode
(type=int)

cmd
(type=int)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:15 2005 http://epydoc.sf.net


wx.AcceleratorTable

Package wx :: Class AcceleratorTable

Type AcceleratorTable

object --+
         |
    Object --+
             |
            AcceleratorTable

An accelerator table allows the application to specify a table of keyboard shortcuts for menus or other commands. On Windows, menu or button commands are supported; on GTK, only menu commands are supported.

The object wx.NullAcceleratorTable is defined to be a table with no data, and is the initial accelerator table for a window.

An accelerator takes precedence over normal processing and can be a convenient way to program some event handling. For example, you can use an accelerator table to make a hotkey generate an event no matter which window within a frame has the focus.

Foe example:

aTable = wx.AcceleratorTable([(wx.ACCEL_ALT,  ord('X'), exitID),
                              (wx.ACCEL_CTRL, ord('H'), helpID),
                              (wx.ACCEL_CTRL, ord('F'), findID),
                              (wx.ACCEL_NORMAL, wx.WXK_F3, findnextID)
                              ])
self.SetAcceleratorTable(aTable)

See Also:

wx.AcceleratorEntry, wx.Window.SetAcceleratorTable

Method Summary
AcceleratorTable | __init__(entries) Construct an AcceleratorTable from a list of wx.AcceleratorEntry items or or of 3-tuples (flags, keyCode, cmdID)
 | __del__(self)
 | __repr__(self)
bool | Ok(self)

Method Details

__init__(entries)
(Constructor)

Construct an AcceleratorTable from a list of wx.AcceleratorEntry items or or of 3-tuples (flags, keyCode, cmdID)

Returns:
AcceleratorTable
Overrides:
wx.Object.__init__

See Also:

wx.AcceleratorEntry

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:12 2005 http://epydoc.sf.net


wx.ActivateEvent

Package wx :: Class ActivateEvent

Type ActivateEvent

object --+
         |
    Object --+
             |
         Event --+
                 |
                ActivateEvent

An activate event is sent when a top-level window or the entire application is being activated or deactivated.

A top-level window (a dialog or frame) receives an activate event when is being activated or deactivated. This is indicated visually by the title bar changing colour, and a subwindow gaining the keyboard focus. An application is activated or deactivated when one of its frames becomes activated, or a frame becomes inactivate resulting in all application frames being inactive.

Please note that usually you should call event.Skip() in your handlers for these events so the default handlers will still be called, as not doing so can result in strange effects.

Events

wx.EVT_ACTIVATE | Sent to a frame when it has been activated or deactivated.
wx.EVT_ACTIVATE_APP | Sent to the app object when its activation state changes.
Method Summary
ActivateEvent | __init__(self, type, active, Id) Constructor
 | __repr__(self)
bool | GetActive(self) Returns true if the application or window is being activated, false otherwise.

Method Details

__init__(self,
          type=wxEVT_NULL,
          active=True,
          Id=0)
(Constructor)

Constructor

Parameters:
type
(type=wxEventType)

active
(type=bool)

Id
(type=int)

Returns:
ActivateEvent
Overrides:
wx.Event.__init__

GetActive(self)

Returns true if the application or window is being activated, false otherwise.

Returns:
bool

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:12 2005 http://epydoc.sf.net


wx.ANIHandler

Package wx :: Class ANIHandler

Type ANIHandler

object --+
         |
    Object --+
             |
  ImageHandler --+
                 |
        BMPHandler --+
                     |
            ICOHandler --+
                         |
                CURHandler --+
                             |
                            ANIHandler

A wx.ImageHandler for *.ani animated cursor files.

Method Summary
ANIHandler | __init__(self) A wx.ImageHandler for *.ani animated cursor files.
 | __repr__(self)

Method Details

__init__(self)
(Constructor)

A wx.ImageHandler for *.ani animated cursor files.

Returns:
ANIHandler
Overrides:
wx.CURHandler.__init__

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:38 2005 http://epydoc.sf.net


wx.animate.AnimationBase

Package wx :: Module animate :: Class AnimationBase

Type AnimationBase

object --+
         |
    Object --+
             |
            AnimationBase

Known Subclasses:
GIFAnimation

Proxy of C++ AnimationBase class

Method Summary
 | __init__(self)
 | __del__(self)
 | __repr__(self)
bool | GetBackgroundColour(self, col)
int | GetDelay(self, i)
int | GetDisposalMethod(self, i)
Image | GetFrame(self, i)
int | GetFrameCount(self)
Rect | GetFrameRect(self, i)
Size | GetLogicalScreenSize(self)
bool | GetTransparentColour(self, col)
bool | IsValid(self)
bool | LoadFile(self, filename)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:10:50 2005 http://epydoc.sf.net


wx.animate.AnimationPlayer

Package wx :: Module animate :: Class AnimationPlayer

Type AnimationPlayer

object --+
         |
    Object --+
             |
            AnimationPlayer

Proxy of C++ AnimationPlayer class

Method Summary
AnimationPlayer | __init__(self, animation, destroyAnimation)
 | __del__(self)
 | __repr__(self)
bool | Build(self)
 | ClearCache(self)
 | Draw(self, dc)
 | DrawBackground(self, dc, pos, colour)
 | DrawFrame(self, frame, dc, pos)
AnimationBase | GetAnimation(self)
bool | GetBackgroundColour(self, col)
Bitmap | GetBackingStore(self)
int | GetCurrentFrame(self)
Colour | GetCustomBackgroundColour(self)
int | GetDelay(self, i)
bool | GetDestroyAnimation(self)
int | GetDisposalMethod(self, i)
Image | GetFrame(self, i)
int | GetFrameCount(self)
Rect | GetFrameRect(self, i)
Size | GetLogicalScreenSize(self)
bool | GetLooped(self)
Point | GetPosition(self)
bool | GetTransparentColour(self, col)
Window | GetWindow(self)
bool | HasAnimation(self)
bool | IsPlaying(self)
bool | Play(self, window, pos, 0), looped)
bool | PlayFrame(self, frame, window, pos)
bool | PlayNextFrame(self)
 | SaveBackground(self, rect)
 | SetAnimation(self, animation, destroyAnimation)
 | SetCurrentFrame(self, currentFrame)
 | SetCustomBackgroundColour(self, col, useCustomBackgroundColour)
 | SetDestroyAnimation(self, destroyAnimation)
 | SetLooped(self, looped)
 | SetPosition(self, pos)
 | SetWindow(self, window)
 | Stop(self)
 | UseBackgroundColour(self, useBackground)
 | UseParentBackground(self, useParent)
bool | UsingBackgroundColour(self)
bool | UsingCustomBackgroundColour(self)
bool | UsingParentBackground(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:41 2005 http://epydoc.sf.net


wx.animate.GIFAnimation

Package wx :: Module animate :: Class GIFAnimation

Type GIFAnimation

object --+
         |
    Object --+
             |
 AnimationBase --+
                 |
                GIFAnimation

Proxy of C++ GIFAnimation class

Method Summary
GIFAnimation | __init__(self)
 | __del__(self)
 | __repr__(self)
bool | GetBackgroundColour(self, col)
int | GetDelay(self, i)
int | GetDisposalMethod(self, i)
Image | GetFrame(self, i)
int | GetFrameCount(self)
Rect | GetFrameRect(self, i)
Size | GetLogicalScreenSize(self)
bool | GetTransparentColour(self, col)
bool | IsValid(self)
bool | LoadFile(self, filename)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:10 2005 http://epydoc.sf.net


wx.animate.GIFAnimationCtrl

Package wx :: Module animate :: Class GIFAnimationCtrl

Type GIFAnimationCtrl

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
               Control --+
                         |
                        GIFAnimationCtrl

Proxy of C++ GIFAnimationCtrl class

Method Summary
Control | __init__(self, parent, id, pos, size, style, validator, name) Create a Control.
 | __repr__(self)
bool | Create(self, parent, id, pos, size, style, validator, name) Do the 2nd phase and create the GUI control.
 | FitToAnimation(self)
AnimationBase | GetAnimation(self)
String | GetFilename(self)
AnimationPlayer | GetPlayer(self)
bool | IsPlaying(self)
bool | LoadFile(self, filename)
bool | Play(self, looped)
 | SetFilename(self, filename)
 | Stop(self)

Instance Method Details

__init__(self,
          parent,
          id=-1,
          filename=EmptyString,
          pos=DefaultPosition,
          size=DefaultSize,
          style=wxAN_FIT_ANIMATION|wxNO_BORDER,
          name=AnimationControlNameStr)
(Constructor)

Create a Control. Normally you should only call this from a subclass' __init__ as a plain old wx.Control is not very useful.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

validator
(type=Validator)

name
(type=String)

Returns:
Control
Overrides:
wx.Control.__init__ (inherited documentation)

Create(self,
          parent,
          id=-1,
          filename=EmptyString,
          pos=DefaultPosition,
          size=DefaultSize,
          style=wxAN_FIT_ANIMATION|wxNO_BORDER,
          name=AnimationControlNameStr)

Do the 2nd phase and create the GUI control.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

validator
(type=Validator)

name
(type=String)

Returns:
bool
Overrides:
wx.Control.Create (inherited documentation)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:22 2005 http://epydoc.sf.net


wx.animate

Package wx :: Module animate

Module wx.animate

Simple animation player classes, including GIFAnimationCtrl for displaying animated GIF files

Classes
AnimationBase | Proxy of C++ AnimationBase class
AnimationPlayer | Proxy of C++ AnimationPlayer class
GIFAnimation | Proxy of C++ GIFAnimation class
GIFAnimationCtrl | Proxy of C++ GIFAnimationCtrl class

Function Summary
GIFAnimationCtrl PreGIFAnimationCtrl()

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:56 2005 http://epydoc.sf.net


wx.App

Package wx :: Class App

Type App

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
             PyApp --+
                     |
                    App

Known Subclasses:
App, App, App, App, App, App, PySimpleApp, PyWidgetTester

The wx.App class represents the application and is used to:

  • bootstrap the wxPython system and initialize the underlying gui toolkit
  • set and get application-wide properties
  • implement the windowing system main message or event loop, and to dispatch events to window instances
  • etc.

Every application must have a wx.App instance, and all creation of UI objects should be delayed until after the wx.App object has been created in order to ensure that the gui platform and wxWidgets have been fully initialized.

Normally you would derive from this class and implement an OnInit method that creates a frame and then calls self.SetTopWindow(frame).

See Also:

wx.PySimpleApp for a simpler app class that can be used directly.

Method Summary
 | __init__(self, redirect, filename, useBestVisual, clearSigInt) Construct a wx.App object.
 | __del__(self, destroy)
 | Destroy(self)
 | MainLoop(self) Execute the main GUI event loop
 | RedirectStdio(self, filename) Redirect sys.stdout and sys.stderr to a file or a popup window.
 | RestoreStdio(self)
 | SetOutputWindowAttributes(self, title, pos, size) Set the title, position and/or size of the output window if the stdio has been redirected.
 | SetTopWindow(self, frame) Set the "main" top level window

Class Variable Summary
classobj outputWindowClass = wx.PyOnDemandOutputWindow

Instance Method Details

__init__(self,
          redirect=False,
          filename=None,
          useBestVisual=False,
          clearSigInt=True)
(Constructor)

Construct a wx.App object.

Parameters:
redirect - Should sys.stdout and sys.stderr be redirected? Defaults to True on Windows and Mac, False otherwise. If filename is None then output will be redirected to a window that pops up as needed. (You can control what kind of window is created for the output by resetting the class variable outputWindowClass to a class of your choosing.)

filename - The name of a file to redirect output to, if redirect is True.

useBestVisual - Should the app try to use the best available visual provided by the system (only relevant on systems that have more than one visual.) This parameter must be used instead of calling SetUseBestVisual later on because it must be set before the underlying GUI toolkit is initialized.

clearSigInt - Should SIGINT be cleared? This allows the app to terminate upon a Ctrl-C in the console like other GUI apps will.

Overrides:
wx.PyApp.__init__

Note:

You should override OnInit to do applicaition initialization to ensure that the system, toolkit and wxWidgets are fully initialized.

MainLoop(self)

Execute the main GUI event loop

Overrides:
wx.PyApp.MainLoop

RedirectStdio(self, filename=None)

Redirect sys.stdout and sys.stderr to a file or a popup window.

SetOutputWindowAttributes(self,
          title=None,
          pos=None,
          size=None)

Set the title, position and/or size of the output window if the stdio has been redirected. This should be called before any output would cause the output window to be created.

SetTopWindow(self, frame)

Set the "main" top level window

Overrides:
wx.PyApp.SetTopWindow

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:46 2005 http://epydoc.sf.net


wx.ArtProvider

Package wx :: Class ArtProvider

Type ArtProvider

object --+
         |
        ArtProvider

The wx.ArtProvider class is used to customize the look of wxWidgets application. When wxWidgets needs to display an icon or a bitmap (e.g. in the standard file dialog), it does not use hard-coded resource but asks wx.ArtProvider for it instead. This way the users can plug in their own wx.ArtProvider class and easily replace standard art with his/her own version. It is easy thing to do: all that is needed is to derive a class from wx.ArtProvider, override it's CreateBitmap method and register the provider with wx.ArtProvider.PushProvider:

class MyArtProvider(wx.ArtProvider):
    def __init__(self):
        wx.ArtProvider.__init__(self)

    def CreateBitmap(self, artid, client, size):
        ...
        return bmp

Identifying art resources

Every bitmap is known to wx.ArtProvider under an unique ID that is used when requesting a resource from it. The IDs can have one of the following predefined values. Additionally, any string recognized by custom art providers registered using PushProvider may be used.

GTK+ Note

When running under GTK+ 2, GTK+ stock item IDs (e.g. 'gtk-cdrom') may be used as well. Additionally, if wxGTK was compiled against GTK+ >= 2.4, then it is also possible to load icons from current icon theme by specifying their name without the extension and directory components. Icon themes recognized by GTK+ follow the freedesktop.org Icon Themes specification. Note that themes are not guaranteed to contain all icons, so wx.ArtProvider may return wx.NullBitmap or wx.NullIcon. The default theme is typically installed in /usr/share/icons/hicolor.

  • wx.ART_ADD_BOOKMARK
  • wx.ART_DEL_BOOKMARK
  • wx.ART_HELP_SIDE_PANEL
  • wx.ART_HELP_SETTINGS
  • wx.ART_HELP_BOOK
  • wx.ART_HELP_FOLDER
  • wx.ART_HELP_PAGE
  • wx.ART_GO_BACK
  • wx.ART_GO_FORWARD
  • wx.ART_GO_UP
  • wx.ART_GO_DOWN
  • wx.ART_GO_TO_PARENT
  • wx.ART_GO_HOME
  • wx.ART_FILE_OPEN
  • wx.ART_FILE_SAVE
  • wx.ART_FILE_SAVE_AS
  • wx.ART_PRINT
  • wx.ART_HELP
  • wx.ART_TIP
  • wx.ART_REPORT_VIEW
  • wx.ART_LIST_VIEW
  • wx.ART_NEW_DIR
  • wx.ART_HARDDISK
  • wx.ART_FLOPPY
  • wx.ART_CDROM
  • wx.ART_REMOVABLE
  • wx.ART_FOLDER
  • wx.ART_FOLDER_OPEN
  • wx.ART_GO_DIR_UP
  • wx.ART_EXECUTABLE_FILE
  • wx.ART_NORMAL_FILE
  • wx.ART_TICK_MARK
  • wx.ART_CROSS_MARK
  • wx.ART_ERROR
  • wx.ART_QUESTION
  • wx.ART_WARNING
  • wx.ART_INFORMATION
  • wx.ART_MISSING_IMAGE
  • wx.ART_COPY
  • wx.ART_CUT
  • wx.ART_PASTE
  • wx.ART_DELETE
  • wx.ART_NEW
  • wx.ART_UNDO
  • wx.ART_REDO
  • wx.ART_QUIT
  • wx.ART_FIND
  • wx.ART_FIND_AND_REPLACE

Clients

The Client is the entity that calls wx.ArtProvider's GetBitmap or GetIcon function. Client IDs serve as a hint to wx.ArtProvider that is supposed to help it to choose the best looking bitmap. For example it is often desirable to use slightly different icons in menus and toolbars even though they represent the same action (e.g. wx.ART_FILE_OPEN). Remember that this is really only a hint for wx.ArtProvider -- it is common that wx.ArtProvider.GetBitmap returns identical bitmap for different client values!

  • wx.ART_TOOLBAR
  • wx.ART_MENU
  • wx.ART_FRAME_ICON
  • wx.ART_CMN_DIALOG
  • wx.ART_HELP_BROWSER
  • wx.ART_MESSAGE_BOX
  • wx.ART_BUTTON
  • wx.ART_OTHER (used for all requests that don't fit into any of the categories above)
Method Summary
ArtProvider | __init__(self) The wx.ArtProvider class is used to customize the look of wxWidgets application.
 | __repr__(self)
 | Destroy(self)
Bitmap | GetBitmap(id, client, size) Query the providers for bitmap with given ID and return it. (Static method)
Icon | GetIcon(id, client, size) Query the providers for icon with given ID and return it. (Static method)
Size | GetSizeHint(client, platform_dependent) Get the size hint of an icon from a specific Art Client, queries the topmost provider if platform_dependent = false (Static method)
bool | PopProvider() Remove latest added provider and delete it. (Static method)
 | PushProvider(provider) Add new provider to the top of providers stack. (Static method)
bool | RemoveProvider(provider) Remove provider. (Static method)

Instance Method Details

__init__(self)
(Constructor)

The wx.ArtProvider class is used to customize the look of wxWidgets application. When wxWidgets needs to display an icon or a bitmap (e.g. in the standard file dialog), it does not use hard-coded resource but asks wx.ArtProvider for it instead. This way the users can plug in their own wx.ArtProvider class and easily replace standard art with his/her own version. It is easy thing to do: all that is needed is to derive a class from wx.ArtProvider, override it's CreateBitmap method and register the provider with wx.ArtProvider.PushProvider:

class MyArtProvider(wx.ArtProvider):
    def __init__(self):
        wx.ArtProvider.__init__(self)

    def CreateBitmap(self, artid, client, size):
        ...
        return bmp

Identifying art resources

Every bitmap is known to wx.ArtProvider under an unique ID that is used when requesting a resource from it. The IDs can have one of the following predefined values. Additionally, any string recognized by custom art providers registered using PushProvider may be used.

GTK+ Note

When running under GTK+ 2, GTK+ stock item IDs (e.g. 'gtk-cdrom') may be used as well. Additionally, if wxGTK was compiled against GTK+ >= 2.4, then it is also possible to load icons from current icon theme by specifying their name without the extension and directory components. Icon themes recognized by GTK+ follow the freedesktop.org Icon Themes specification. Note that themes are not guaranteed to contain all icons, so wx.ArtProvider may return wx.NullBitmap or wx.NullIcon. The default theme is typically installed in /usr/share/icons/hicolor.

  • wx.ART_ADD_BOOKMARK
  • wx.ART_DEL_BOOKMARK
  • wx.ART_HELP_SIDE_PANEL
  • wx.ART_HELP_SETTINGS
  • wx.ART_HELP_BOOK
  • wx.ART_HELP_FOLDER
  • wx.ART_HELP_PAGE
  • wx.ART_GO_BACK
  • wx.ART_GO_FORWARD
  • wx.ART_GO_UP
  • wx.ART_GO_DOWN
  • wx.ART_GO_TO_PARENT
  • wx.ART_GO_HOME
  • wx.ART_FILE_OPEN
  • wx.ART_FILE_SAVE
  • wx.ART_FILE_SAVE_AS
  • wx.ART_PRINT
  • wx.ART_HELP
  • wx.ART_TIP
  • wx.ART_REPORT_VIEW
  • wx.ART_LIST_VIEW
  • wx.ART_NEW_DIR
  • wx.ART_HARDDISK
  • wx.ART_FLOPPY
  • wx.ART_CDROM
  • wx.ART_REMOVABLE
  • wx.ART_FOLDER
  • wx.ART_FOLDER_OPEN
  • wx.ART_GO_DIR_UP
  • wx.ART_EXECUTABLE_FILE
  • wx.ART_NORMAL_FILE
  • wx.ART_TICK_MARK
  • wx.ART_CROSS_MARK
  • wx.ART_ERROR
  • wx.ART_QUESTION
  • wx.ART_WARNING
  • wx.ART_INFORMATION
  • wx.ART_MISSING_IMAGE
  • wx.ART_COPY
  • wx.ART_CUT
  • wx.ART_PASTE
  • wx.ART_DELETE
  • wx.ART_NEW
  • wx.ART_UNDO
  • wx.ART_REDO
  • wx.ART_QUIT
  • wx.ART_FIND
  • wx.ART_FIND_AND_REPLACE

Clients

The Client is the entity that calls wx.ArtProvider's GetBitmap or GetIcon function. Client IDs serve as a hint to wx.ArtProvider that is supposed to help it to choose the best looking bitmap. For example it is often desirable to use slightly different icons in menus and toolbars even though they represent the same action (e.g. wx.ART_FILE_OPEN). Remember that this is really only a hint for wx.ArtProvider -- it is common that wx.ArtProvider.GetBitmap returns identical bitmap for different client values!

  • wx.ART_TOOLBAR
  • wx.ART_MENU
  • wx.ART_FRAME_ICON
  • wx.ART_CMN_DIALOG
  • wx.ART_HELP_BROWSER
  • wx.ART_MESSAGE_BOX
  • wx.ART_BUTTON
  • wx.ART_OTHER (used for all requests that don't fit into any of the categories above)
Returns:
ArtProvider
Overrides:
__builtin__.object.__init__

Static Method Details

GetBitmap(id, client=ART_OTHER, size=DefaultSize)

Query the providers for bitmap with given ID and return it. Return wx.NullBitmap if no provider provides it.

Parameters:
id
(type=String)

client
(type=String)

size
(type=Size)

Returns:
Bitmap

GetIcon(id, client=ART_OTHER, size=DefaultSize)

Query the providers for icon with given ID and return it. Return wx.NullIcon if no provider provides it.

Parameters:
id
(type=String)

client
(type=String)

size
(type=Size)

Returns:
Icon

GetSizeHint(client, platform_dependent=False)

Get the size hint of an icon from a specific Art Client, queries the topmost provider if platform_dependent = false

Parameters:
client
(type=String)

platform_dependent
(type=bool)

Returns:
Size

PopProvider()

Remove latest added provider and delete it.

Returns:
bool

PushProvider(provider)

Add new provider to the top of providers stack.

Parameters:
provider
(type=ArtProvider)

RemoveProvider(provider)

Remove provider. The provider must have been added previously! The provider is _not_ deleted.

Parameters:
provider
(type=ArtProvider)

Returns:
bool

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:04 2005 http://epydoc.sf.net


wx.BitmapButton

Package wx :: Class BitmapButton

Type BitmapButton

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
               Control --+
                         |
                    Button --+
                             |
                            BitmapButton

Known Subclasses:
ColourSelect, ContextHelpButton, FoldOutMenu

A Button that contains a bitmap. A bitmap button can be supplied with a single bitmap, and wxWidgets will draw all button states using this bitmap. If the application needs more control, additional bitmaps for the selected state, unpressed focused state, and greyed-out state may be supplied.

Window Styles

wx.BU_AUTODRAW | If this is specified, the button will be drawn automatically using the label bitmap only, providing a 3D-look border. If this style is not specified, the button will be drawn without borders and using all provided bitmaps. WIN32 only.
wx.BU_LEFT | Left-justifies the label. WIN32 only.
wx.BU_TOP | Aligns the label to the top of the button. WIN32 only.
wx.BU_RIGHT | Right-justifies the bitmap label. WIN32 only.
wx.BU_BOTTOM | Aligns the label to the bottom of the button. WIN32 only.
wx.BU_EXACTFIT | Creates the button as small as possible instead of making it of the standard size (which is the default behaviour.)

Events

EVT_BUTTON Sent when the button is clicked.

See Also:

wx.Button, wx.Bitmap

Method Summary
BitmapButton | __init__(self, parent, id, bitmap, pos, size, style, validator, name) Create and show a button with a bitmap for the label.
 | __repr__(self)
bool | Create(self, parent, id, bitmap, pos, size, style, validator, name) Acutally create the GUI BitmapButton for 2-phase creation.
Bitmap | GetBitmapDisabled(self) Returns the bitmap for the disabled state.
Bitmap | GetBitmapFocus(self) Returns the bitmap for the focused state.
Bitmap | GetBitmapLabel(self) Returns the label bitmap (the one passed to the constructor).
Bitmap | GetBitmapSelected(self) Returns the bitmap for the selected state.
int | GetMarginX(self)
int | GetMarginY(self)
 | SetBitmapDisabled(self, bitmap) Sets the bitmap for the disabled button appearance.
 | SetBitmapFocus(self, bitmap) Sets the bitmap for the button appearance when it has the keyboard focus.
 | SetBitmapLabel(self, bitmap) Sets the bitmap label for the button.
 | SetBitmapSelected(self, bitmap) Sets the bitmap for the selected (depressed) button appearance.
 | SetMargins(self, x, y)

Instance Method Details

__init__(self,
          parent,
          id=-1,
          bitmap=wxNullBitmap,
          pos=DefaultPosition,
          size=DefaultSize,
          style=BU_AUTODRAW,
          validator=DefaultValidator,
          name=ButtonNameStr)
(Constructor)

Create and show a button with a bitmap for the label.

Parameters:
parent
(type=Window)

id
(type=int)

bitmap
(type=Bitmap)

pos
(type=Point)

size
(type=Size)

style
(type=long)

validator
(type=Validator)

name
(type=String)

Returns:
BitmapButton
Overrides:
wx.Button.__init__

Create(self,
          parent,
          id=-1,
          bitmap=wxNullBitmap,
          pos=DefaultPosition,
          size=DefaultSize,
          style=BU_AUTODRAW,
          validator=DefaultValidator,
          name=ButtonNameStr)

Acutally create the GUI BitmapButton for 2-phase creation.

Parameters:
parent
(type=Window)

id
(type=int)

bitmap
(type=Bitmap)

pos
(type=Point)

size
(type=Size)

style
(type=long)

validator
(type=Validator)

name
(type=String)

Returns:
bool
Overrides:
wx.Button.Create

GetBitmapDisabled(self)

Returns the bitmap for the disabled state.

Returns:
Bitmap

GetBitmapFocus(self)

Returns the bitmap for the focused state.

Returns:
Bitmap

GetBitmapLabel(self)

Returns the label bitmap (the one passed to the constructor).

Returns:
Bitmap

GetBitmapSelected(self)

Returns the bitmap for the selected state.

Returns:
Bitmap

SetBitmapDisabled(self, bitmap)

Sets the bitmap for the disabled button appearance.

Parameters:
bitmap
(type=Bitmap)

SetBitmapFocus(self, bitmap)

Sets the bitmap for the button appearance when it has the keyboard focus.

Parameters:
bitmap
(type=Bitmap)

SetBitmapLabel(self, bitmap)

Sets the bitmap label for the button. This is the bitmap used for the unselected state, and for all other states if no other bitmaps are provided.

Parameters:
bitmap
(type=Bitmap)

SetBitmapSelected(self, bitmap)

Sets the bitmap for the selected (depressed) button appearance.

Parameters:
bitmap
(type=Bitmap)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:22 2005 http://epydoc.sf.net


wx.Bitmap

Package wx :: Class Bitmap

Type Bitmap

object --+
         |
    Object --+
             |
     GDIObject --+
                 |
                Bitmap

The wx.Bitmap class encapsulates the concept of a platform-dependent bitmap. It can be either monochrome or colour, and either loaded from a file or created dynamically. A bitmap can be selected into a memory device context (instance of wx.MemoryDC). This enables the bitmap to be copied to a window or memory device context using wx.DC.Blit, or to be used as a drawing surface.

The BMP and XMP image file formats are supported on all platforms by wx.Bitmap. Other formats are automatically loaded by wx.Image and converted to a wx.Bitmap, so any image file format supported by wx.Image can be used.

To Do:

  • Add wrappers and support for raw bitmap data access. Can this be be put into Python without losing the speed benefits of the teplates and iterators in rawbmp.h?

  • Find a way to do very efficient PIL Image <--> wx.Bitmap converstions.

Method Summary
Bitmap | __init__(self, name, type)
 | __del__(self)
bool | __eq__(self, other)
bool | __ne__(self, other)
 | __nonzero__(self)
 | __repr__(self)
Image | ConvertToImage(self) Creates a platform-independent image from a platform-dependent bitmap.
bool | CopyFromIcon(self, icon)
int | GetDepth(self) Gets the colour depth of the bitmap.
int | GetHeight(self) Gets the height of the bitmap in pixels.
Mask | GetMask(self) Gets the associated mask (if any) which may have been loaded from a file or explpicitly set for the bitmap.
Palette | GetPalette(self)
Size | GetSize(self) Get the size of the bitmap.
Bitmap | GetSubBitmap(self, rect) Returns a sub-bitmap of the current one as long as the rect belongs entirely to the bitmap.
int | GetWidth(self) Gets the width of the bitmap in pixels.
bool | LoadFile(self, name, type) Loads a bitmap from a file.
bool | Ok(self)
bool | SaveFile(self, name, type, palette) Saves a bitmap in the named file.
 | SetDepth(self, depth) Set the depth property (does not affect the existing bitmap data).
 | SetHeight(self, height) Set the height property (does not affect the existing bitmap data).
 | SetMask(self, mask) Sets the mask for this bitmap.
 | SetMaskColour(self, colour) Create a Mask based on a specified colour in the Bitmap.
 | SetSize(self, size) Set the bitmap size (does not affect the existing bitmap data).
 | SetWidth(self, width) Set the width property (does not affect the existing bitmap data).

Method Details

__init__(self, name, type=BITMAP_TYPE_ANY)
(Constructor)

Loads a bitmap from a file.
Parameters:
name - Name of the file to load the bitmap from.
(type=String)

type - The type of image to expect. Can be one of the following constants (assuming that the neccessary wx.Image handlers are loaded):

  • wx.BITMAP_TYPE_ANY
  • wx.BITMAP_TYPE_BMP
  • wx.BITMAP_TYPE_ICO
  • wx.BITMAP_TYPE_CUR
  • wx.BITMAP_TYPE_XBM
  • wx.BITMAP_TYPE_XPM
  • wx.BITMAP_TYPE_TIF
  • wx.BITMAP_TYPE_GIF
  • wx.BITMAP_TYPE_PNG
  • wx.BITMAP_TYPE_JPEG
  • wx.BITMAP_TYPE_PNM
  • wx.BITMAP_TYPE_PCX
  • wx.BITMAP_TYPE_PICT
  • wx.BITMAP_TYPE_ICON
  • wx.BITMAP_TYPE_ANI
  • wx.BITMAP_TYPE_IFF

(type=int)

Returns:
Bitmap
Overrides:
wx.GDIObject.__init__

See Also:

Alternate constructors wx.EmptyBitmap, wx.BitmapFromIcon, wx.BitmapFromImage, wx.BitmapFromXPMData, wx.BitmapFromBits

ConvertToImage(self)

Creates a platform-independent image from a platform-dependent bitmap. This preserves mask information so that bitmaps and images can be converted back and forth without loss in that respect.

Returns:
Image

GetDepth(self)

Gets the colour depth of the bitmap. A value of 1 indicates a monochrome bitmap.

Returns:
int

GetHeight(self)

Gets the height of the bitmap in pixels.

Returns:
int

GetMask(self)

Gets the associated mask (if any) which may have been loaded from a file or explpicitly set for the bitmap.

Returns:
Mask

See Also:

SetMask, wx.Mask

GetSize(self)

Get the size of the bitmap.

Returns:
Size

GetSubBitmap(self, rect)

Returns a sub-bitmap of the current one as long as the rect belongs entirely to the bitmap. This function preserves bit depth and mask information.

Parameters:
rect
(type=Rect)

Returns:
Bitmap

GetWidth(self)

Gets the width of the bitmap in pixels.

Returns:
int

LoadFile(self, name, type)

Loads a bitmap from a file. See __init__ for a description of the type parameter.

Parameters:
name
(type=String)

type
(type=int)

Returns:
bool

SaveFile(self, name, type, palette=None)

Saves a bitmap in the named file. See __init__ for a description of the type parameter.

Parameters:
name
(type=String)

type
(type=int)

palette
(type=Palette)

Returns:
bool

SetDepth(self, depth)

Set the depth property (does not affect the existing bitmap data).

Parameters:
depth
(type=int)

SetHeight(self, height)

Set the height property (does not affect the existing bitmap data).

Parameters:
height
(type=int)

SetMask(self, mask)

Sets the mask for this bitmap.

Parameters:
mask
(type=Mask)

See Also:

GetMask, wx.Mask

SetMaskColour(self, colour)

Create a Mask based on a specified colour in the Bitmap.

Parameters:
colour
(type=Colour)

SetSize(self, size)

Set the bitmap size (does not affect the existing bitmap data).

Parameters:
size
(type=Size)

SetWidth(self, width)

Set the width property (does not affect the existing bitmap data).

Parameters:
width
(type=int)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:10:48 2005 http://epydoc.sf.net


wx.BitmapDataObject

Package wx :: Class BitmapDataObject

Type BitmapDataObject

  object --+
           |
  DataObject --+
               |
DataObjectSimple --+
                   |
                  BitmapDataObject

Known Subclasses:
PyBitmapDataObject

wx.BitmapDataObject is a specialization of wxDataObject for bitmap data. It can be used without change to paste data into the wx.Clipboard or a wx.DropSource.

See Also:

wx.PyBitmapDataObject if you wish to override GetBitmap to increase efficiency.

Method Summary
BitmapDataObject | __init__(self, bitmap) Constructor, optionally passing a bitmap (otherwise use SetBitmap later).
 | __repr__(self)
Bitmap | GetBitmap(self) Returns the bitmap associated with the data object.
 | SetBitmap(self, bitmap) Sets the bitmap associated with the data object.

Class Variable Summary

Method Details

__init__(self, bitmap=wxNullBitmap)
(Constructor)

Constructor, optionally passing a bitmap (otherwise use SetBitmap later).

Parameters:
bitmap
(type=Bitmap)

Returns:
BitmapDataObject
Overrides:
wx.DataObjectSimple.__init__

GetBitmap(self)

Returns the bitmap associated with the data object. You may wish to override this method (by deriving from wx.PyBitmapDataObject) when offering data on-demand, but this is not required by wxWidgets' internals. Use this method to get data in bitmap form from the wx.Clipboard.

Returns:
Bitmap

SetBitmap(self, bitmap)

Sets the bitmap associated with the data object. This method is called when the data object receives data. Usually there will be no reason to override this function.

Parameters:
bitmap
(type=Bitmap)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:40 2005 http://epydoc.sf.net


wx.BMPHandler

Package wx :: Class BMPHandler

Type BMPHandler

object --+
         |
    Object --+
             |
  ImageHandler --+
                 |
                BMPHandler

Known Subclasses:
ICOHandler

A wx.ImageHandler for *.bmp bitmap files.

Method Summary
BMPHandler | __init__(self) A wx.ImageHandler for *.bmp bitmap files.
 | __repr__(self)

Method Details

__init__(self)
(Constructor)

A wx.ImageHandler for *.bmp bitmap files.

Returns:
BMPHandler
Overrides:
wx.ImageHandler.__init__

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:56 2005 http://epydoc.sf.net


wx.BookCtrlBase

Package wx :: Class BookCtrlBase

Type BookCtrlBase

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
               Control --+
                         |
                        BookCtrlBase

Known Subclasses:
Choicebook, Listbook, Notebook

Proxy of C++ BookCtrlBase class

Method Summary
 | __init__(self)
 | __repr__(self)
bool | AddPage(self, page, text, select, imageId)
 | AdvanceSelection(self, forward)
 | AssignImageList(self, imageList)
Size | CalcSizeFromPage(self, sizePage)
bool | DeleteAllPages(self)
bool | DeletePage(self, n)
VisualAttributes | GetClassDefaultAttributes(variant) Get the default attributes for this class. (Static method)
Window | GetCurrentPage(self)
ImageList | GetImageList(self)
Window | GetPage(self, n)
size_t | GetPageCount(self)
int | GetPageImage(self, n)
String | GetPageText(self, n)
int | GetSelection(self)
bool | InsertPage(self, n, page, text, select, imageId)
bool | RemovePage(self, n)
 | SetImageList(self, imageList)
bool | SetPageImage(self, n, imageId)
 | SetPageSize(self, size)
bool | SetPageText(self, n, strText)
int | SetSelection(self, n)

Static Method Details

GetClassDefaultAttributes(variant=WINDOW_VARIANT_NORMAL)

Get the default attributes for this class. This is useful if you want to use the same font or colour in your own control as in a standard control -- which is a much better idea than hard coding specific colours or fonts which might look completely out of place on the user's system, especially if it uses themes.

The variant parameter is only relevant under Mac currently and is ignore under other platforms. Under Mac, it will change the size of the returned font. See wx.Window.SetWindowVariant for more about this.

Parameters:
variant
(type=int)

Returns:
VisualAttributes

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:34 2005 http://epydoc.sf.net


wx.BookCtrlBaseEvent

Package wx :: Class BookCtrlBaseEvent

Type BookCtrlBaseEvent

object --+
         |
    Object --+
             |
         Event --+
                 |
      CommandEvent --+
                     |
           NotifyEvent --+
                         |
                        BookCtrlBaseEvent

Known Subclasses:
ChoicebookEvent, ListbookEvent, NotebookEvent

Proxy of C++ BookCtrlBaseEvent class

Method Summary
NotifyEvent | __init__(self, commandType, winid) An instance of this class (or one of its derived classes) is sent from a control when the control's state is being changed and the control allows that change to be prevented from happening.
 | __repr__(self)
int | GetOldSelection(self)
int | GetSelection(self) Returns item index for a listbox or choice selection event (not valid for a deselection).
 | SetOldSelection(self, nOldSel)
 | SetSelection(self, nSel)

Method Details

__init__(self,
          commandType=wxEVT_NULL,
          id=0,
          nSel=-1,
          nOldSel=-1)
(Constructor)

An instance of this class (or one of its derived classes) is sent from a control when the control's state is being changed and the control allows that change to be prevented from happening. The event handler can call Veto or Allow to tell the control what to do.

Parameters:
commandType
(type=wxEventType)

winid
(type=int)

Returns:
NotifyEvent
Overrides:
wx.NotifyEvent.__init__ (inherited documentation)

GetSelection(self)

Returns item index for a listbox or choice selection event (not valid for a deselection).

Returns:
int
Overrides:
wx.CommandEvent.GetSelection

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:17 2005 http://epydoc.sf.net


wx.BookCtrlSizer

Package wx :: Class BookCtrlSizer

Type BookCtrlSizer

object --+
         |
    Object --+
             |
         Sizer --+
                 |
                BookCtrlSizer

Proxy of C++ BookCtrlSizer class

Method Summary
 | __init__(*args, **kwargs) BookCtrlSizer is no longer needed.
 | __repr__(self)
Size | CalcMin(self) This method is where the sizer will do the actual calculation of its children's minimal sizes.
BookCtrlBase | GetControl(self)
 | RecalcSizes(self) Using the sizes calculated by CalcMin reposition and resize all the items managed by this sizer.

Method Details

__init__(*args, **kwargs)
(Constructor)

BookCtrlSizer is no longer needed.

CalcMin(self)

This method is where the sizer will do the actual calculation of its children's minimal sizes. You should not need to call this directly as it is called by Layout.

Returns:
Size
Overrides:
wx.Sizer.CalcMin

RecalcSizes(self)

Using the sizes calculated by CalcMin reposition and resize all the items managed by this sizer. You should not need to call this directly as it is called by Layout.

Overrides:
wx.Sizer.RecalcSizes

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:04 2005 http://epydoc.sf.net


wx.BoxSizer

Package wx :: Class BoxSizer

Type BoxSizer

object --+
         |
    Object --+
             |
         Sizer --+
                 |
                BoxSizer

Known Subclasses:
StaticBoxSizer, StdDialogButtonSizer

The basic idea behind a box sizer is that windows will most often be laid out in rather simple basic geometry, typically in a row or a column or nested hierarchies of either. A wx.BoxSizer will lay out its items in a simple row or column, depending on the orientation parameter passed to the constructor.

It is the unique feature of a box sizer, that it can grow in both directions (height and width) but can distribute its growth in the main direction (horizontal for a row) unevenly among its children. This is determined by the proportion parameter give to items when they are added to the sizer. It is interpreted as a weight factor, i.e. it can be zero, indicating that the window may not be resized at all, or above zero. If several windows have a value above zero, the value is interpreted relative to the sum of all weight factors of the sizer, so when adding two windows with a value of 1, they will both get resized equally and each will receive half of the available space after the fixed size items have been sized. If the items have unequal proportion settings then they will receive a coresondingly unequal allotment of the free space.

See Also:

wx.StaticBoxSizer

Method Summary
BoxSizer | __init__(self, orient) Constructor for a wx.BoxSizer.
 | __repr__(self)
int | GetOrientation(self) Returns the current orientation of the sizer.
 | SetOrientation(self, orient) Resets the orientation of the sizer.

Method Details

__init__(self, orient=HORIZONTAL)
(Constructor)

Constructor for a wx.BoxSizer. orient may be one of wx.VERTICAL or wx.HORIZONTAL for creating either a column sizer or a row sizer.

Parameters:
orient
(type=int)

Returns:
BoxSizer
Overrides:
wx.Sizer.__init__

GetOrientation(self)

Returns the current orientation of the sizer.

Returns:
int

SetOrientation(self, orient)

Resets the orientation of the sizer.

Parameters:
orient
(type=int)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:25 2005 http://epydoc.sf.net


wx.Brush

Package wx :: Class Brush

Type Brush

object --+
         |
    Object --+
             |
     GDIObject --+
                 |
                Brush

A brush is a drawing tool for filling in areas. It is used for painting the background of rectangles, ellipses, etc. when drawing on a wx.DC. It has a colour and a style.

Warning:

Do not create instances of wx.Brush before the wx.App object has been created because, depending on the platform, required internal data structures may not have been initialized yet. Instead create your brushes in the app's OnInit or as they are needed for drawing.

Note:

On monochrome displays all brushes are white, unless the colour really is black.

See Also:

wx.BrushList, wx.DC, wx.DC.SetBrush

Method Summary
Brush | __init__(self, colour, style) Constructs a brush from a wx.Colour object and a style.The style parameter may be one of the following:
 | __del__(self)
 | __nonzero__(self)
 | __repr__(self)
Colour | GetColour(self) Returns the wx.Colour of the brush.
Bitmap | GetStipple(self) Returns the stiple wx.Bitmap of the brush.
int | GetStyle(self) Returns the style of the brush.
bool | IsHatch(self) Is the current style a hatch type?
bool | Ok(self) Returns True if the brush is initialised and valid.
 | SetColour(self, col) Set the brush's wx.Colour.
 | SetStipple(self, stipple) Sets the stipple wx.Bitmap.
 | SetStyle(self, style) Sets the style of the brush.

Method Details

__init__(self, colour, style=SOLID)
(Constructor)

Constructs a brush from a wx.Colour object and a style.The style parameter may be one of the following:

Style | Meaning
wx.TRANSPARENT | Transparent (no fill).
wx.SOLID | Solid.
wx.STIPPLE | Uses a bitmap as a stipple.
wx.BDIAGONAL_HATCH | Backward diagonal hatch.
wx.CROSSDIAG_HATCH | Cross-diagonal hatch.
wx.FDIAGONAL_HATCH | Forward diagonal hatch.
wx.CROSS_HATCH | Cross hatch.
wx.HORIZONTAL_HATCH | Horizontal hatch.
wx.VERTICAL_HATCH | Vertical hatch.
Parameters:
colour
(type=Colour)

style
(type=int)

Returns:
Brush
Overrides:
wx.GDIObject.__init__

See Also:

wx.BrushFromBitmap

GetColour(self)

Returns the wx.Colour of the brush.

Returns:
Colour

GetStipple(self)

Returns the stiple wx.Bitmap of the brush. If the brush does not have a wx.STIPPLE style, then the return value may be non-None but an uninitialised bitmap (wx.Bitmap.Ok returns False).

Returns:
Bitmap

GetStyle(self)

Returns the style of the brush. See __init__ for a listing of styles.

Returns:
int

IsHatch(self)

Is the current style a hatch type?

Returns:
bool

Ok(self)

Returns True if the brush is initialised and valid.

Returns:
bool

SetColour(self, col)

Set the brush's wx.Colour.

Parameters:
col
(type=Colour)

SetStipple(self, stipple)

Sets the stipple wx.Bitmap.

Parameters:
stipple
(type=Bitmap)

SetStyle(self, style)

Sets the style of the brush. See __init__ for a listing of styles.

Parameters:
style
(type=int)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:34 2005 http://epydoc.sf.net


wx.BrushList

Package wx :: Class BrushList

Type BrushList

object --+
         |
    Object --+
             |
            BrushList

Proxy of C++ BrushList class

Method Summary
 | __init__(self)
 | __repr__(self)
 | AddBrush(self, brush)
Brush | FindOrCreateBrush(self, colour, style)
int | GetCount(self)
 | RemoveBrush(self, brush)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:36 2005 http://epydoc.sf.net


wx.BufferedDC

Package wx :: Class BufferedDC

Type BufferedDC

object --+
         |
    Object --+
             |
            DC --+
                 |
          MemoryDC --+
                     |
                    BufferedDC

Known Subclasses:
BufferedPaintDC

This simple class provides a simple way to avoid flicker: when drawing on it, everything is in fact first drawn on an in-memory buffer (a wx.Bitmap) and then copied to the screen only once, when this object is destroyed.

It can be used in the same way as any other device context. wx.BufferedDC itself typically replaces wx.ClientDC, if you want to use it in your EVT_PAINT handler, you should look at wx.BufferedPaintDC.

Method Summary
BufferedDC __init__(self, dc, buffer, style)
__init__(self, DC dc, Size area, int style=BUFFER_CLIENT_AREA) -> BufferedDC
__del__(self)
Copies everything drawn on the DC so far to the underlying DC associated with this object, if any.
__repr__(self)
UnMask(self)
Blits the buffer to the dc, and detaches the dc from the buffer (so it can be effectively used once only).

Method Details

__init__(self, dc, buffer=NullBitmap, style=BUFFER_CLIENT_AREA)
(Constructor)

__init__(self, DC dc, Size area, int style=BUFFER_CLIENT_AREA) -> BufferedDC

Constructs a buffered DC.

Parameters:
dc - The underlying DC: everything drawn to this object will be flushed to this DC when this object is destroyed. You may pass None in order to just initialize the buffer, and not flush it.
(type=DC)

buffer - If a wx.Size object is passed as the 2nd arg then it is the size of the bitmap that will be created internally and used for an implicit buffer. If the 2nd arg is a wx.Bitmap then it is the explicit buffer that will be used. Using an explicit buffer is the most efficient solution as the bitmap doesn't have to be recreated each time but it also requires more memory as the bitmap is never freed. The bitmap should have appropriate size, anything drawn outside of its bounds is clipped. If wx.NullBitmap is used then a new buffer will be allocated that is the same size as the dc.
(type=Bitmap)

style - The style parameter indicates whether the supplied buffer is intended to cover the entire virtual size of a wx.ScrolledWindow or if it only covers the client area. Acceptable values are wx.BUFFER_VIRTUAL_AREA and wx.BUFFER_CLIENT_AREA.
(type=int)

Returns:
BufferedDC
Overrides:
wx.MemoryDC.__init__

__del__(self)
(Destructor)

Copies everything drawn on the DC so far to the underlying DC associated with this object, if any.

Overrides:
wx.DC.__del__

UnMask(self)

Blits the buffer to the dc, and detaches the dc from the buffer (so it can be effectively used once only). This is usually only called in the destructor.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:10 2005 http://epydoc.sf.net


wx.BufferedPaintDC

Package wx :: Class BufferedPaintDC

Type BufferedPaintDC

object --+
         |
    Object --+
             |
            DC --+
                 |
          MemoryDC --+
                     |
            BufferedDC --+
                         |
                        BufferedPaintDC

This is a subclass of wx.BufferedDC which can be used inside of an EVT_PAINT event handler. Just create an object of this class instead of wx.PaintDC and that's all you have to do to (mostly) avoid flicker. The only thing to watch out for is that if you are using this class together with wx.ScrolledWindow, you probably do not want to call wx.Window.PrepareDC on it as it already does this internally for the real underlying wx.PaintDC.

If your window is already fully buffered in a wx.Bitmap then your EVT_PAINT handler can be as simple as just creating a wx.BufferedPaintDC as it will Blit the buffer to the window automatically when it is destroyed. For example:

def OnPaint(self, event):
    dc = wx.BufferedPaintDC(self, self.buffer)

Method Summary
BufferedPaintDC | __init__(self, window, buffer, style) Create a buffered paint DC.
 | __repr__(self)

Method Details

__init__(self, window, buffer=NullBitmap, style=BUFFER_CLIENT_AREA)
(Constructor)

Create a buffered paint DC. As with wx.BufferedDC, you may either provide the bitmap to be used for buffering or let this object create one internally (in the latter case, the size of the client part of the window is automatically used).

Parameters:
window
(type=Window)

buffer
(type=Bitmap)

style
(type=int)

Returns:
BufferedPaintDC
Overrides:
wx.BufferedDC.__init__

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:23 2005 http://epydoc.sf.net


wx.build

Package wx :: Package build

Package wx.build

This package provides the config module, which is used by wxPython's setup.py distutils script. It was moved here so it would be installed with the rest of wxPython and could therefore be used by the setup.py for other projects that needed this same info and functionality (most likely in order to be compatible with wxPython.)

See config.py and wxPython's setup.py for more details.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:03 2005 http://epydoc.sf.net


wx.BusyCursor

Package wx :: Class BusyCursor

Type BusyCursor

object --+
         |
        BusyCursor

Proxy of C++ BusyCursor class

Method Summary
BusyCursor | __init__(self, cursor)
 | __del__(self)
 | __repr__(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:11 2005 http://epydoc.sf.net


wx.BusyInfo

Package wx :: Class BusyInfo

Type BusyInfo

object --+
         |
    Object --+
             |
            BusyInfo

Proxy of C++ BusyInfo class

Method Summary
BusyInfo | __init__(self, message)
 | __del__(self)
 | __repr__(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:16 2005 http://epydoc.sf.net


wx.Button

Package wx :: Class Button

Type Button

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
               Control --+
                         |
                        Button

Known Subclasses:
BitmapButton

A button is a control that contains a text string, and is one of the most common elements of a GUI. It may be placed on a dialog box or panel, or indeed almost any other window.

Window Styles

wx.BU_LEFT | Left-justifies the label. Windows and GTK+ only.
wx.BU_TOP | Aligns the label to the top of the button. Windows and GTK+ only.
wx.BU_RIGHT | Right-justifies the bitmap label. Windows and GTK+ only.
wx.BU_BOTTOM | Aligns the label to the bottom of the button. Windows and GTK+ only.
wx.BU_EXACTFIT | Creates the button as small as possible instead of making it of the standard size (which is the default behaviour.)

Events

EVT_BUTTON Sent when the button is clicked.

See Also:

wx.BitmapButton

Method Summary
Button | __init__(self, parent, id, label, pos, size, style, validator, name) Create and show a button.
 | __repr__(self)
bool | Create(self, parent, id, label, pos, size, style, validator, name) Acutally create the GUI Button for 2-phase creation.
VisualAttributes | GetClassDefaultAttributes(variant) Get the default attributes for this class. (Static method)
Size | GetDefaultSize() Returns the default button size for this platform. (Static method)
 | SetDefault(self) This sets the button to be the default item for the panel or dialog box.

Instance Method Details

__init__(self,
          parent,
          id=-1,
          label=EmptyString,
          pos=DefaultPosition,
          size=DefaultSize,
          style=0,
          validator=DefaultValidator,
          name=ButtonNameStr)
(Constructor)

Create and show a button. The preferred way to create standard buttons is to use a standard ID and an empty label. In this case wxWigets will automatically use a stock label that coresponds to the ID given. In additon, the button will be decorated with stock icons under GTK+ 2.

The stock IDs and coresponding labels are

wx.ID_ADD | 'Add'
wx.ID_APPLY | '&Apply'
wx.ID_BOLD | '&Bold'
wx.ID_CANCEL | '&Cancel'
wx.ID_CLEAR | '&Clear'
wx.ID_CLOSE | '&Close'
wx.ID_COPY | '&Copy'
wx.ID_CUT | 'Cu&t'
wx.ID_DELETE | '&Delete'
wx.ID_FIND | '&Find'
wx.ID_REPLACE | 'Find and rep&lace'
wx.ID_BACKWARD | '&Back'
wx.ID_DOWN | '&Down'
wx.ID_FORWARD | '&Forward'
wx.ID_UP | '&Up'
wx.ID_HELP | '&Help'
wx.ID_HOME | '&Home'
wx.ID_INDENT | 'Indent'
wx.ID_INDEX | '&Index'
wx.ID_ITALIC | '&Italic'
wx.ID_JUSTIFY_CENTER | 'Centered'
wx.ID_JUSTIFY_FILL | 'Justified'
wx.ID_JUSTIFY_LEFT | 'Align Left'
wx.ID_JUSTIFY_RIGHT | 'Align Right'
wx.ID_NEW | '&New'
wx.ID_NO | '&No'
wx.ID_OK | '&OK'
wx.ID_OPEN | '&Open'
wx.ID_PASTE | '&Paste'
wx.ID_PREFERENCES | '&Preferences'
wx.ID_PRINT | '&Print'
wx.ID_PREVIEW | 'Print previe&w'
wx.ID_PROPERTIES | '&Properties'
wx.ID_EXIT | '&Quit'
wx.ID_REDO | '&Redo'
wx.ID_REFRESH | 'Refresh'
wx.ID_REMOVE | 'Remove'
wx.ID_REVERT_TO_SAVED | 'Revert to Saved'
wx.ID_SAVE | '&Save'
wx.ID_SAVEAS | 'Save &As...'
wx.ID_STOP | '&Stop'
wx.ID_UNDELETE | 'Undelete'
wx.ID_UNDERLINE | '&Underline'
wx.ID_UNDO | '&Undo'
wx.ID_UNINDENT | '&Unindent'
wx.ID_YES | '&Yes'
wx.ID_ZOOM_100 | '&Actual Size'
wx.ID_ZOOM_FIT | 'Zoom to &Fit'
wx.ID_ZOOM_IN | 'Zoom &In'
wx.ID_ZOOM_OUT | 'Zoom &Out'
Parameters:
parent
(type=Window)

id
(type=int)

label
(type=String)

pos
(type=Point)

size
(type=Size)

style
(type=long)

validator
(type=Validator)

name
(type=String)

Returns:
Button
Overrides:
wx.Control.__init__

Create(self,
          parent,
          id=-1,
          label=EmptyString,
          pos=DefaultPosition,
          size=DefaultSize,
          style=0,
          validator=DefaultValidator,
          name=ButtonNameStr)

Acutally create the GUI Button for 2-phase creation.

Parameters:
parent
(type=Window)

id
(type=int)

label
(type=String)

pos
(type=Point)

size
(type=Size)

style
(type=long)

validator
(type=Validator)

name
(type=String)

Returns:
bool
Overrides:
wx.Control.Create

SetDefault(self)

This sets the button to be the default item for the panel or dialog box.

Static Method Details

GetClassDefaultAttributes(variant=WINDOW_VARIANT_NORMAL)

Get the default attributes for this class. This is useful if you want to use the same font or colour in your own control as in a standard control -- which is a much better idea than hard coding specific colours or fonts which might look completely out of place on the user's system, especially if it uses themes.

The variant parameter is only relevant under Mac currently and is ignore under other platforms. Under Mac, it will change the size of the returned font. See wx.Window.SetWindowVariant for more about this.

Parameters:
variant
(type=int)

Returns:
VisualAttributes

GetDefaultSize()

Returns the default button size for this platform.

Returns:
Size

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:33 2005 http://epydoc.sf.net


wx.CalculateLayoutEvent

Package wx :: Class CalculateLayoutEvent

Type CalculateLayoutEvent

object --+
         |
    Object --+
             |
         Event --+
                 |
                CalculateLayoutEvent

Proxy of C++ CalculateLayoutEvent class

Method Summary
CalculateLayoutEvent | __init__(self, id)
 | __repr__(self)
int | GetFlags(self)
Rect | GetRect(self)
 | SetFlags(self, flags)
 | SetRect(self, rect)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:40 2005 http://epydoc.sf.net


wx.calendar.CalendarCtrl

Package wx :: Module calendar :: Class CalendarCtrl

Type CalendarCtrl

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
               Control --+
                         |
                        CalendarCtrl

The calendar control allows the user to pick a date interactively.

The CalendarCtrl displays a window containing several parts: the control to pick the month and the year at the top (either or both of them may be disabled) and a month area below them which shows all the days in the month. The user can move the current selection using the keyboard and select the date (generating EVT_CALENDAR event) by pressing <Return> or double clicking it.

It has advanced possibilities for the customization of its display. All global settings (such as colours and fonts used) can, of course, be changed. But also, the display style for each day in the month can be set independently using CalendarDateAttr class.

An item without custom attributes is drawn with the default colours and font and without border, but setting custom attributes with SetAttr allows to modify its appearance. Just create a custom attribute object and set it for the day you want to be displayed specially A day may be marked as being a holiday, (even if it is not recognized as one by wx.DateTime) by using the SetHoliday method.

As the attributes are specified for each day, they may change when the month is changed, so you will often want to update them in an EVT_CALENDAR_MONTH event handler.

Window Styles

CAL_SUNDAY_FIRST | Show Sunday as the first day in the week
CAL_MONDAY_FIRST | Show Monday as the first day in the week
CAL_SHOW_HOLIDAYS | Highlight holidays in the calendar
CAL_NO_YEAR_CHANGE | Disable the year changing
CAL_NO_MONTH_CHANGE | Disable the month (and, implicitly, the year) changing
CAL_SHOW_SURROUNDING_WEEKS | Show the neighbouring weeks in the previous and next months
CAL_SEQUENTIAL_MONTH_SELECTION | Use alternative, more compact, style for the month and year selection controls.

The default calendar style is CAL_SHOW_HOLIDAYS.

Events

EVT_CALENDAR | A day was double clicked in the calendar.
EVT_CALENDAR_SEL_CHANGED | The selected date changed.
EVT_CALENDAR_DAY | The selected day changed.
EVT_CALENDAR_MONTH | The selected month changed.
EVT_CALENDAR_YEAR | The selected year changed.
EVT_CALENDAR_WEEKDAY_CLICKED | User clicked on the week day header

Note that changing the selected date will result in one of EVT_CALENDAR_DAY, MONTH or YEAR events and an EVT_CALENDAR_SEL_CHANGED event.

Method Summary
CalendarCtrl | __init__(self, parent, id, date, pos, size, style, name) Create and show a calendar control.
 | __repr__(self)
bool | Create(self, parent, id, date, pos, size, style, name) Acutally create the GUI portion of the CalendarCtrl for 2-phase creation.
 | EnableHolidayDisplay(self, display) This function should be used instead of changing CAL_SHOW_HOLIDAYS style bit directly.
 | EnableMonthChange(self, enable) This function should be used instead of changing CAL_NO_MONTH_CHANGE style bit.
 | EnableYearChange(self, enable) This function should be used instead of changing CAL_NO_YEAR_CHANGE style bit directly.
CalendarDateAttr | GetAttr(self, day) Returns the attribute for the given date (should be in the range 1...31).
VisualAttributes | GetClassDefaultAttributes(variant) Get the default attributes for this class. (Static method)
DateTime | GetDate(self) Gets the currently selected date.
Colour | GetHeaderColourBg(self) Header colours are used for painting the weekdays at the top.
Colour | GetHeaderColourFg(self) Header colours are used for painting the weekdays at the top.
Colour | GetHighlightColourBg(self) Highlight colour is used for the currently selected date.
Colour | GetHighlightColourFg(self) Highlight colour is used for the currently selected date.
Colour | GetHolidayColourBg(self) Holiday colour is used for the holidays (if CAL_SHOW_HOLIDAYS style is used).
Colour | GetHolidayColourFg(self) Holiday colour is used for the holidays (if CAL_SHOW_HOLIDAYS style is used).
DateTime | GetLowerDateLimit(self) get the range in which selection can occur
Control | GetMonthControl(self) Get the currently shown control for month.
DateTime | GetUpperDateLimit(self) get the range in which selection can occur
Control | GetYearControl(self) Get the currently shown control for year.
(result, date, weekday) | HitTest(pos) Returns 3-tuple with information about the given position on the calendar control.
 | PyGetDate(self) returns datetime.date object
 | PyGetLowerDateLimit(self) returns datetime.date object
 | PyGetUpperDateLimit(self) returns datetime.date object
 | PySetDate(self, date) takes datetime.datetime or datetime.date object
 | PySetDateRange(self, lowerdate, upperdate) takes datetime.datetime or datetime.date objects
 | PySetLowerDateLimit(self, date) takes datetime.datetime or datetime.date object
 | PySetUpperDateLimit(self, date) takes datetime.datetime or datetime.date object
 | ResetAttr(self, day) Clears any attributes associated with the given day (in the range 1...31).
 | SetAttr(self, day, attr) Associates the attribute with the specified date (in the range 1...31).
 | SetDate(self, date) Sets the current date.
bool | SetDateRange(self, lowerdate, upperdate) set the range in which selection can occur
 | SetHeaderColours(self, colFg, colBg) Header colours are used for painting the weekdays at the top.
 | SetHighlightColours(self, colFg, colBg) Highlight colour is used for the currently selected date.
 | SetHoliday(self, day) Marks the specified day as being a holiday in the current month.
 | SetHolidayColours(self, colFg, colBg) Holiday colour is used for the holidays (if CAL_SHOW_HOLIDAYS style is used).
bool | SetLowerDateLimit(self, date) set the range in which selection can occur
bool | SetUpperDateLimit(self, date) set the range in which selection can occur

Instance Method Details

__init__(self,
          parent,
          id=-1,
          date=DefaultDateTime,
          pos=DefaultPosition,
          size=DefaultSize,
          style=wxCAL_SHOW_HOLIDAYS|wxWANTS_CHARS,
          name=CalendarNameStr)
(Constructor)

Create and show a calendar control.

Parameters:
parent
(type=Window)

id
(type=int)

date
(type=DateTime)

pos
(type=Point)

size
(type=Size)

style
(type=long)

name
(type=String)

Returns:
CalendarCtrl
Overrides:
wx.Control.__init__

Create(self,
          parent,
          id,
          date=DefaultDateTime,
          pos=DefaultPosition,
          size=DefaultSize,
          style=wxCAL_SHOW_HOLIDAYS|wxWANTS_CHARS,
          name=CalendarNameStr)

Acutally create the GUI portion of the CalendarCtrl for 2-phase creation.

Parameters:
parent
(type=Window)

id
(type=int)

date
(type=DateTime)

pos
(type=Point)

size
(type=Size)

style
(type=long)

name
(type=String)

Returns:
bool
Overrides:
wx.Control.Create

EnableHolidayDisplay(self, display=True)

This function should be used instead of changing CAL_SHOW_HOLIDAYS style bit directly. It enables or disables the special highlighting of the holidays.

Parameters:
display
(type=bool)

EnableMonthChange(self, enable=True)

This function should be used instead of changing CAL_NO_MONTH_CHANGE style bit. It allows or disallows the user to change the month interactively. Note that if the month can not be changed, the year can not be changed either.

Parameters:
enable
(type=bool)

EnableYearChange(self, enable=True)

This function should be used instead of changing CAL_NO_YEAR_CHANGE style bit directly. It allows or disallows the user to change the year interactively.

Parameters:
enable
(type=bool)

GetAttr(self, day)

Returns the attribute for the given date (should be in the range 1...31). The returned value may be None

Parameters:
day
(type=size_t)

Returns:
CalendarDateAttr

GetDate(self)

Gets the currently selected date.

Returns:
DateTime

GetHeaderColourBg(self)

Header colours are used for painting the weekdays at the top.

Returns:
Colour

GetHeaderColourFg(self)

Header colours are used for painting the weekdays at the top.

Returns:
Colour

GetHighlightColourBg(self)

Highlight colour is used for the currently selected date.

Returns:
Colour

GetHighlightColourFg(self)

Highlight colour is used for the currently selected date.

Returns:
Colour

GetHolidayColourBg(self)

Holiday colour is used for the holidays (if CAL_SHOW_HOLIDAYS style is used).

Returns:
Colour

GetHolidayColourFg(self)

Holiday colour is used for the holidays (if CAL_SHOW_HOLIDAYS style is used).

Returns:
Colour

GetLowerDateLimit(self)

get the range in which selection can occur

Returns:
DateTime

GetMonthControl(self)

Get the currently shown control for month.

Returns:
Control

GetUpperDateLimit(self)

get the range in which selection can occur

Returns:
DateTime

GetYearControl(self)

Get the currently shown control for year.

Returns:
Control

HitTest(pos)

Returns 3-tuple with information about the given position on the calendar control. The first value of the tuple is a result code and determines the validity of the remaining two values. The result codes are:

CAL_HITTEST_NOWHERE | hit outside of anything
CAL_HITTEST_HEADER | hit on the header, weekday is valid
CAL_HITTEST_DAY | hit on a day in the calendar, date is set.
Parameters:
pos
(type=Point)

Returns:
(result, date, weekday)
Overrides:
wx.Window.HitTest

PyGetDate(self)

returns datetime.date object

PyGetLowerDateLimit(self)

returns datetime.date object

PyGetUpperDateLimit(self)

returns datetime.date object

PySetDate(self, date)

takes datetime.datetime or datetime.date object

PySetDateRange(self, lowerdate, upperdate)

takes datetime.datetime or datetime.date objects

PySetLowerDateLimit(self, date)

takes datetime.datetime or datetime.date object

PySetUpperDateLimit(self, date)

takes datetime.datetime or datetime.date object

ResetAttr(self, day)

Clears any attributes associated with the given day (in the range 1...31).

Parameters:
day
(type=size_t)

SetAttr(self, day, attr)

Associates the attribute with the specified date (in the range 1...31). If the attribute passed is None, the items attribute is cleared.

Parameters:
day
(type=size_t)

attr
(type=CalendarDateAttr)

SetDate(self, date)

Sets the current date.

Parameters:
date
(type=DateTime)

SetDateRange(self, lowerdate=DefaultDateTime, upperdate=DefaultDateTime)

set the range in which selection can occur

Parameters:
lowerdate
(type=DateTime)

upperdate
(type=DateTime)

Returns:
bool

SetHeaderColours(self, colFg, colBg)

Header colours are used for painting the weekdays at the top.

Parameters:
colFg
(type=Colour)

colBg
(type=Colour)

SetHighlightColours(self, colFg, colBg)

Highlight colour is used for the currently selected date.

Parameters:
colFg
(type=Colour)

colBg
(type=Colour)

SetHoliday(self, day)

Marks the specified day as being a holiday in the current month.

Parameters:
day
(type=size_t)

SetHolidayColours(self, colFg, colBg)

Holiday colour is used for the holidays (if CAL_SHOW_HOLIDAYS style is used).

Parameters:
colFg
(type=Colour)

colBg
(type=Colour)

SetLowerDateLimit(self, date=DefaultDateTime)

set the range in which selection can occur

Parameters:
date
(type=DateTime)

Returns:
bool

SetUpperDateLimit(self, date=DefaultDateTime)

set the range in which selection can occur

Parameters:
date
(type=DateTime)

Returns:
bool

Static Method Details

GetClassDefaultAttributes(variant=WINDOW_VARIANT_NORMAL)

Get the default attributes for this class. This is useful if you want to use the same font or colour in your own control as in a standard control -- which is a much better idea than hard coding specific colours or fonts which might look completely out of place on the user's system, especially if it uses themes.

The variant parameter is only relevant under Mac currently and is ignore under other platforms. Under Mac, it will change the size of the returned font. See wx.Window.SetWindowVariant for more about this.

Parameters:
variant
(type=int)

Returns:
VisualAttributes

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:50 2005 http://epydoc.sf.net


wx.calendar.CalendarDateAttr

Package wx :: Module calendar :: Class CalendarDateAttr

Type CalendarDateAttr

object --+
         |
        CalendarDateAttr

A set of customization attributes for a calendar date, which can be used to control the look of the Calendar object.

Method Summary
CalendarDateAttr | __init__(self, colText, colBack, colBorder, font, border) Create a CalendarDateAttr.
 | __repr__(self)
Colour | GetBackgroundColour(self)
int | GetBorder(self)
Colour | GetBorderColour(self)
Font | GetFont(self)
Colour | GetTextColour(self)
bool | HasBackgroundColour(self)
bool | HasBorder(self)
bool | HasBorderColour(self)
bool | HasFont(self)
bool | HasTextColour(self)
bool | IsHoliday(self)
 | SetBackgroundColour(self, colBack)
 | SetBorder(self, border)
 | SetBorderColour(self, col)
 | SetFont(self, font)
 | SetHoliday(self, holiday)
 | SetTextColour(self, colText)

Method Details

__init__(self,
          colText=wxNullColour,
          colBack=wxNullColour,
          colBorder=wxNullColour,
          font=wxNullFont,
          border=CAL_BORDER_NONE)
(Constructor)

Create a CalendarDateAttr.

Parameters:
colText
(type=Colour)

colBack
(type=Colour)

colBorder
(type=Colour)

font
(type=Font)

border
(type=int)

Returns:
CalendarDateAttr
Overrides:
__builtin__.object.__init__

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:15 2005 http://epydoc.sf.net


wx.calendar.CalendarEvent

Package wx :: Module calendar :: Class CalendarEvent

Type CalendarEvent

object --+
         |
    Object --+
             |
         Event --+
                 |
      CommandEvent --+
                     |
             DateEvent --+
                         |
                        CalendarEvent

Proxy of C++ CalendarEvent class

Method Summary
CommandEvent | __init__(self, commandType, winid) This event class contains information about command events, which originate from a variety of simple controls, as well as menus and toolbars.
 | __repr__(self)
int | GetWeekDay(self)
 | PyGetDate(self) returns datetime.date object
 | PySetDate(self, date) takes datetime.datetime or datetime.date object
 | SetWeekDay(self, wd)

Method Details

__init__(self, cal, type)
(Constructor)

This event class contains information about command events, which originate from a variety of simple controls, as well as menus and toolbars.

Parameters:
commandType
(type=wxEventType)

winid
(type=int)

Returns:
CommandEvent
Overrides:
wx.DateEvent.__init__ (inherited documentation)

PyGetDate(self)

returns datetime.date object

PySetDate(self, date)

takes datetime.datetime or datetime.date object

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:11 2005 http://epydoc.sf.net


wx.calendar

Package wx :: Module calendar

Module wx.calendar

Classes for an interactive Calendar control.

Classes
CalendarCtrl | The calendar control allows the user to pick a date interactively.
CalendarDateAttr | A set of customization attributes for a calendar date, which can be used to control the look of the Calendar object.
CalendarEvent | Proxy of C++ CalendarEvent class

Function Summary
VisualAttributes | CalendarCtrl_GetClassDefaultAttributes(variant) Get the default attributes for this class.
CalendarCtrl | PreCalendarCtrl() Precreate a CalendarCtrl for 2-phase creation.

Function Details

CalendarCtrl_GetClassDefaultAttributes(variant=WINDOW_VARIANT_NORMAL)

Get the default attributes for this class. This is useful if you want to use the same font or colour in your own control as in a standard control -- which is a much better idea than hard coding specific colours or fonts which might look completely out of place on the user's system, especially if it uses themes.

The variant parameter is only relevant under Mac currently and is ignore under other platforms. Under Mac, it will change the size of the returned font. See wx.Window.SetWindowVariant for more about this.

Parameters:
variant
(type=int)

Returns:
VisualAttributes

PreCalendarCtrl()

Precreate a CalendarCtrl for 2-phase creation.

Returns:
CalendarCtrl

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:02 2005 http://epydoc.sf.net


wx.Caret

Package wx :: Class Caret

Type Caret

object --+
         |
        Caret

Proxy of C++ Caret class

Method Summary
Caret | __init__(self, window, size)
 | __nonzero__(self)
 | __repr__(self)
 | Destroy(self) Deletes the C++ object this Python object is a proxy for.
int | GetBlinkTime() (Static method)
Point | GetPosition(self)
(x,y) | GetPositionTuple()
Size | GetSize(self)
(width, height) | GetSizeTuple()
Window | GetWindow(self)
 | Hide(self)
bool | IsOk(self)
bool | IsVisible(self)
 | Move(self, pt)
 | MoveXY(self, x, y)
 | SetBlinkTime(milliseconds) (Static method)
 | SetSize(self, size)
 | SetSizeWH(self, width, height)
 | Show(self, show)

Instance Method Details

Destroy(self)

Deletes the C++ object this Python object is a proxy for.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:16 2005 http://epydoc.sf.net


wx.CheckBox

Package wx :: Class CheckBox

Type CheckBox

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
               Control --+
                         |
                        CheckBox

A checkbox is a labelled box which by default is either on (the checkmark is visible) or off (no checkmark). Optionally (When the wx.CHK_3STATE style flag is set) it can have a third state, called the mixed or undetermined state. Often this is used as a "Does Not Apply" state.

Window Styles

wx.CHK_2STATE | Create a 2-state checkbox. This is the default.
wx.CHK_3STATE | Create a 3-state checkbox.
wx.CHK_ALLOW_3RD_STATE_FOR_USER | By default a user can't set a 3-state checkbox to the third state. It can only be done from code. Using this flags allows the user to set the checkbox to the third state by clicking. wx.ALIGN_RIGHT Makes the text appear on the left of the checkbox.

Events

EVT_CHECKBOX Sent when checkbox is clicked.
Method Summary
CheckBox | __init__(self, parent, id, label, pos, size, style, validator, name) Creates and shows a CheckBox control
 | __repr__(self)
bool | Create(self, parent, id, label, pos, size, style, validator, name) Actually create the GUI CheckBox for 2-phase creation.
int | Get3StateValue(self) Returns wx.CHK_UNCHECKED when the CheckBox is unchecked, wx.CHK_CHECKED when it is checked and wx.CHK_UNDETERMINED when it's in the undetermined state.
VisualAttributes | GetClassDefaultAttributes(variant) Get the default attributes for this class. (Static method)
bool | GetValue(self) Gets the state of a 2-state CheckBox.
bool | Is3rdStateAllowedForUser(self) Returns whether or not the user can set the CheckBox to the third state.
bool | Is3State(self) Returns whether or not the CheckBox is a 3-state CheckBox.
bool | IsChecked(self) Similar to GetValue, but raises an exception if it is not a 2-state CheckBox.
 | Set3StateValue(self, state) Sets the CheckBox to the given state.
 | SetValue(self, state) Set the state of a 2-state CheckBox.

Instance Method Details

__init__(self,
          parent,
          id=-1,
          label=EmptyString,
          pos=DefaultPosition,
          size=DefaultSize,
          style=0,
          validator=DefaultValidator,
          name=CheckBoxNameStr)
(Constructor)

Creates and shows a CheckBox control

Parameters:
parent
(type=Window)

id
(type=int)

label
(type=String)

pos
(type=Point)

size
(type=Size)

style
(type=long)

validator
(type=Validator)

name
(type=String)

Returns:
CheckBox
Overrides:
wx.Control.__init__

Create(self,
          parent,
          id=-1,
          label=EmptyString,
          pos=DefaultPosition,
          size=DefaultSize,
          style=0,
          validator=DefaultValidator,
          name=CheckBoxNameStr)

Actually create the GUI CheckBox for 2-phase creation.

Parameters:
parent
(type=Window)

id
(type=int)

label
(type=String)

pos
(type=Point)

size
(type=Size)

style
(type=long)

validator
(type=Validator)

name
(type=String)

Returns:
bool
Overrides:
wx.Control.Create

Get3StateValue(self)

Returns wx.CHK_UNCHECKED when the CheckBox is unchecked, wx.CHK_CHECKED when it is checked and wx.CHK_UNDETERMINED when it's in the undetermined state. Raises an exceptiion when the function is used with a 2-state CheckBox.

Returns:
int

GetValue(self)

Gets the state of a 2-state CheckBox. Returns True if it is checked, False otherwise.

Returns:
bool

Is3rdStateAllowedForUser(self)

Returns whether or not the user can set the CheckBox to the third state.

Returns:
bool

Is3State(self)

Returns whether or not the CheckBox is a 3-state CheckBox.

Returns:
bool

IsChecked(self)

Similar to GetValue, but raises an exception if it is not a 2-state CheckBox.

Returns:
bool

Set3StateValue(self, state)

Sets the CheckBox to the given state. The state parameter can be one of the following: wx.CHK_UNCHECKED (Check is off), wx.CHK_CHECKED (the Check is on) or wx.CHK_UNDETERMINED (Check is mixed). Raises an exception when the CheckBox is a 2-state checkbox and setting the state to wx.CHK_UNDETERMINED.

Parameters:
state
(type=int)

SetValue(self, state)

Set the state of a 2-state CheckBox. Pass True for checked, False for unchecked.

Parameters:
state
(type=bool)

Static Method Details

GetClassDefaultAttributes(variant=WINDOW_VARIANT_NORMAL)

Get the default attributes for this class. This is useful if you want to use the same font or colour in your own control as in a standard control -- which is a much better idea than hard coding specific colours or fonts which might look completely out of place on the user's system, especially if it uses themes.

The variant parameter is only relevant under Mac currently and is ignore under other platforms. Under Mac, it will change the size of the returned font. See wx.Window.SetWindowVariant for more about this.

Parameters:
variant
(type=int)

Returns:
VisualAttributes

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:46 2005 http://epydoc.sf.net


wx.CheckListBox

Package wx :: Class CheckListBox

Type CheckListBox

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
               Control --+
                         |
            object --+   |
                     |   |
         ItemContainer --+
                         |
          ControlWithItems --+
                             |
                       ListBox --+
                                 |
                                CheckListBox

Proxy of C++ CheckListBox class

Method Summary
CheckListBox | __init__(self, parent, id, pos, size, choices, style, validator, name)
 | __repr__(self)
 | Check(self, index, check)
bool | Create(self, parent, id, pos, size, style, validator, name) Do the 2nd phase and create the GUI control.
int | GetItemHeight(self)
int | HitTest(self, pt) Test where the given (in client coords) point lies
int | HitTestXY(self, x, y) Test where the given (in client coords) point lies
bool | IsChecked(self, index)

Instance Method Details

Create(self,
          parent,
          id=-1,
          pos=DefaultPosition,
          size=DefaultSize,
          choices=wxPyEmptyStringArray,
          style=0,
          validator=DefaultValidator,
          name=ListBoxNameStr)

Do the 2nd phase and create the GUI control.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

validator
(type=Validator)

name
(type=String)

Returns:
bool
Overrides:
wx.ListBox.Create (inherited documentation)

HitTest(self, pt)

Test where the given (in client coords) point lies

Parameters:
pt
(type=Point)

Returns:
int
Overrides:
wx.Window.HitTest

HitTestXY(self, x, y)

Test where the given (in client coords) point lies

Parameters:
x
(type=int)

y
(type=int)

Returns:
int
Overrides:
wx.Window.HitTestXY

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:51 2005 http://epydoc.sf.net


wx.ChildFocusEvent

Package wx :: Class ChildFocusEvent

Type ChildFocusEvent

object --+
         |
    Object --+
             |
         Event --+
                 |
      CommandEvent --+
                     |
                    ChildFocusEvent

wx.ChildFocusEvent notifies the parent that a child has received the focus. Unlike wx.FocusEvent it is propagated up the window heirarchy.

Method Summary
ChildFocusEvent | __init__(self, win) Constructor
 | __repr__(self)
Window | GetWindow(self) The window which has just received the focus.

Method Details

__init__(self, win=None)
(Constructor)

Constructor

Parameters:
win
(type=Window)

Returns:
ChildFocusEvent
Overrides:
wx.CommandEvent.__init__

GetWindow(self)

The window which has just received the focus.

Returns:
Window

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:25 2005 http://epydoc.sf.net


wx.Choicebook

Package wx :: Class Choicebook

Type Choicebook

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
               Control --+
                         |
              BookCtrlBase --+
                             |
                            Choicebook

Proxy of C++ Choicebook class

Method Summary
Choicebook | __init__(self, parent, id, pos, size, style, name)
 | __repr__(self)
bool | Create(self, parent, id, pos, size, style, validator, name) Do the 2nd phase and create the GUI control.
bool | DeleteAllPages(self)
Choice | GetChoiceCtrl(self)
bool | IsVertical(self)

Instance Method Details

Create(self, parent, id, pos=DefaultPosition, size=DefaultSize, style=0, name=EmptyString)

Do the 2nd phase and create the GUI control.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

validator
(type=Validator)

name
(type=String)

Returns:
bool
Overrides:
wx.Control.Create (inherited documentation)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:27 2005 http://epydoc.sf.net


wx.ChoicebookEvent

Package wx :: Class ChoicebookEvent

Type ChoicebookEvent

object --+
         |
    Object --+
             |
         Event --+
                 |
      CommandEvent --+
                     |
           NotifyEvent --+
                         |
         BookCtrlBaseEvent --+
                             |
                            ChoicebookEvent

Proxy of C++ ChoicebookEvent class

Method Summary
NotifyEvent | __init__(self, commandType, winid) An instance of this class (or one of its derived classes) is sent from a control when the control's state is being changed and the control allows that change to be prevented from happening.
 | __repr__(self)

Method Details

__init__(self,
          commandType=wxEVT_NULL,
          id=0,
          nSel=-1,
          nOldSel=-1)
(Constructor)

An instance of this class (or one of its derived classes) is sent from a control when the control's state is being changed and the control allows that change to be prevented from happening. The event handler can call Veto or Allow to tell the control what to do.

Parameters:
commandType
(type=wxEventType)

winid
(type=int)

Returns:
NotifyEvent
Overrides:
wx.BookCtrlBaseEvent.__init__ (inherited documentation)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:57 2005 http://epydoc.sf.net


wx.Choice

Package wx :: Class Choice

Type Choice

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
               Control --+
                         |
            object --+   |
                     |   |
         ItemContainer --+
                         |
          ControlWithItems --+
                             |
                            Choice

Known Subclasses:
DirFilterListCtrl

A Choice control is used to select one of a list of strings. Unlike a wx.ListBox, only the selection is visible until the user pulls down the menu of choices.

Events

EVT_CHOICE Sent when an item in the list is selected.
Method Summary
Choice | __init__(parent, id, pos, size, choices, style, validator, name) Create and show a Choice control
 | __repr__(self)
bool | Create(parent, id, pos, size, choices, style, validator, name) Actually create the GUI Choice control for 2-phase creation
VisualAttributes | GetClassDefaultAttributes(variant) Get the default attributes for this class. (Static method)

Instance Method Details

__init__(parent,
          id,
          pos=DefaultPosition,
          size=DefaultSize,
          choices=EmptyList,
          style=0,
          validator=DefaultValidator,
          name=ChoiceNameStr)
(Constructor)

Create and show a Choice control

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

choices
(type=List)

style
(type=long)

validator
(type=Validator)

name
(type=String)

Returns:
Choice
Overrides:
wx.ControlWithItems.__init__

Create(parent,
          id,
          pos=DefaultPosition,
          size=DefaultSize,
          choices=EmptyList,
          style=0,
          validator=DefaultValidator,
          name=ChoiceNameStr)

Actually create the GUI Choice control for 2-phase creation

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

choices
(type=List)

style
(type=long)

validator
(type=Validator)

name
(type=String)

Returns:
bool
Overrides:
wx.Control.Create

Static Method Details

GetClassDefaultAttributes(variant=WINDOW_VARIANT_NORMAL)

Get the default attributes for this class. This is useful if you want to use the same font or colour in your own control as in a standard control -- which is a much better idea than hard coding specific colours or fonts which might look completely out of place on the user's system, especially if it uses themes.

The variant parameter is only relevant under Mac currently and is ignore under other platforms. Under Mac, it will change the size of the returned font. See wx.Window.SetWindowVariant for more about this.

Parameters:
variant
(type=int)

Returns:
VisualAttributes

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:12 2005 http://epydoc.sf.net


wx.ClientDC

Package wx :: Class ClientDC

Type ClientDC

object --+
         |
    Object --+
             |
            DC --+
                 |
                ClientDC

A wx.ClientDC must be constructed if an application wishes to paint on the client area of a window from outside an EVT_PAINT event. This should normally be constructed as a temporary stack object; don't store a wx.ClientDC object long term.

To draw on a window from within an EVT_PAINT handler, construct a wx.PaintDC object.

To draw on the whole window including decorations, construct a wx.WindowDC object (Windows only).

Method Summary
ClientDC | __init__(self, win) Constructor.
 | __repr__(self)

Method Details

__init__(self, win)
(Constructor)

Constructor. Pass the window on which you wish to paint.

Parameters:
win
(type=Window)

Returns:
ClientDC
Overrides:
wx.DC.__init__

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:05 2005 http://epydoc.sf.net


wx.Clipboard

Package wx :: Class Clipboard

Type Clipboard

object --+
         |
    Object --+
             |
            Clipboard

wx.Clipboard represents the system clipboard and provides methods to copy data to it or paste data from it. Normally, you should only use wx.TheClipboard which is a reference to a global wx.Clipboard instance.

Call wx.TheClipboard's Open method to get ownership of the clipboard. If this operation returns True, you now own the clipboard. Call SetData to put data on the clipboard, or GetData to retrieve data from the clipboard. Call Close to close the clipboard and relinquish ownership. You should keep the clipboard open only momentarily.

See Also:

wx.DataObject

Method Summary
Clipboard | __init__(self)
 | __del__(self)
 | __repr__(self)
bool | AddData(self, data) Call this function to add the data object to the clipboard.
 | Clear(self) Clears data from the clipboard object and also the system's clipboard if possible.
 | Close(self) Closes the clipboard.
bool | Flush(self) Flushes the clipboard: this means that the data which is currently on clipboard will stay available even after the application exits, possibly eating memory, otherwise the clipboard will be emptied on exit.
Clipboard | Get() Returns global instance (wxTheClipboard) of the object. (Static method)
bool | GetData(self, data) Call this function to fill data with data on the clipboard, if available in the required format.
bool | IsOpened(self) Query whether the clipboard is opened
bool | IsSupported(self, format) Returns True if the given format is available in the data object(s) on the clipboard.
bool | Open(self) Call this function to open the clipboard before calling SetData and GetData.
bool | SetData(self, data) Set the clipboard data, this is the same as Clear followed by AddData.
 | UsePrimarySelection(self, primary) On platforms supporting it (the X11 based platforms), selects the so called PRIMARY SELECTION as the clipboard as opposed to the normal clipboard, if primary is True.

Instance Method Details

AddData(self, data)

Call this function to add the data object to the clipboard. You may call this function repeatedly after having cleared the clipboard. After this function has been called, the clipboard owns the data, so do not delete the data explicitly.

Parameters:
data
(type=DataObject)

Returns:
bool

See Also:

wx.DataObject

Clear(self)

Clears data from the clipboard object and also the system's clipboard if possible.

Close(self)

Closes the clipboard.

Flush(self)

Flushes the clipboard: this means that the data which is currently on clipboard will stay available even after the application exits, possibly eating memory, otherwise the clipboard will be emptied on exit. Returns False if the operation is unsuccesful for any reason.

Returns:
bool

GetData(self, data)

Call this function to fill data with data on the clipboard, if available in the required format. Returns true on success.

Parameters:
data
(type=DataObject)

Returns:
bool

IsOpened(self)

Query whether the clipboard is opened

Returns:
bool

IsSupported(self, format)

Returns True if the given format is available in the data object(s) on the clipboard.

Parameters:
format
(type=DataFormat)

Returns:
bool

Open(self)

Call this function to open the clipboard before calling SetData and GetData. Call Close when you have finished with the clipboard. You should keep the clipboard open for only a very short time. Returns True on success.

Returns:
bool

SetData(self, data)

Set the clipboard data, this is the same as Clear followed by AddData.

Parameters:
data
(type=DataObject)

Returns:
bool

See Also:

wx.DataObject

UsePrimarySelection(self, primary=True)

On platforms supporting it (the X11 based platforms), selects the so called PRIMARY SELECTION as the clipboard as opposed to the normal clipboard, if primary is True.

Parameters:
primary
(type=bool)

Static Method Details

Get()

Returns global instance (wxTheClipboard) of the object.

Returns:
Clipboard

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:51 2005 http://epydoc.sf.net


wx.ClipboardLocker

Package wx :: Class ClipboardLocker

Type ClipboardLocker

object --+
         |
        ClipboardLocker

A helpful class for opening the clipboard and automatically closing it when the locker is destroyed.

Method Summary
ClipboardLocker | __init__(self, clipboard) A helpful class for opening the clipboard and automatically closing it when the locker is destroyed.
 | __del__(self)
bool | __nonzero__(self) A ClipboardLocker instance evaluates to True if the clipboard was successfully opened.
 | __repr__(self)

Method Details

__init__(self, clipboard=None)
(Constructor)

A helpful class for opening the clipboard and automatically closing it when the locker is destroyed.

Parameters:
clipboard
(type=Clipboard)

Returns:
ClipboardLocker
Overrides:
__builtin__.object.__init__

__nonzero__(self)
(Boolean test operator)

A ClipboardLocker instance evaluates to True if the clipboard was successfully opened.

Returns:
bool

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:28 2005 http://epydoc.sf.net


wx.CloseEvent

Package wx :: Class CloseEvent

Type CloseEvent

object --+
         |
    Object --+
             |
         Event --+
                 |
                CloseEvent

This event class contains information about window and session close events.

The handler function for EVT_CLOSE is called when the user has tried to close a a frame or dialog box using the window manager controls or the system menu. It can also be invoked by the application itself programmatically, for example by calling the wx.Window.Close function.

You should check whether the application is forcing the deletion of the window using CanVeto. If it returns False, you must destroy the window using wx.Window.Destroy. If the return value is True, it is up to you whether you respond by destroying the window or not. For example you may wish to display a message dialog prompting to save files or to cancel the close.

If you don't destroy the window, you should call Veto to let the calling code know that you did not destroy the window. This allows the wx.Window.Close function to return True or False depending on whether the close instruction was honored or not.

Events

wx.EVT_CLOSE | This event is sent to a top-level window when it has been requested to close either from the user or programatically.
wx.EVT_QUERY_END_SESSION | This event is sent to the wx.App when the system is about to be logged off, giving the app a chance to veto the shutdown.
wx.EVT_END_SESSION | This event is sent to the wx.App when the system is being logged off.
Method Summary
CloseEvent | __init__(self, type, winid) Constructor.
 | __repr__(self)
bool | CanVeto(self) Returns true if you can veto a system shutdown or a window close event.
bool | GetLoggingOff(self) Returns True if the user is logging off or False if the system is shutting down.
bool | GetVeto(self)
 | SetCanVeto(self, canVeto) Sets the 'can veto' flag.
 | SetLoggingOff(self, logOff) Sets the 'logging off' flag.
 | Veto(self, veto) Call this from your event handler to veto a system shutdown or to signal to the calling application that a window close did not happen.

Method Details

__init__(self, type=wxEVT_NULL, winid=0)
(Constructor)

Constructor.

Parameters:
type
(type=wxEventType)

winid
(type=int)

Returns:
CloseEvent
Overrides:
wx.Event.__init__

CanVeto(self)

Returns true if you can veto a system shutdown or a window close event. Vetoing a window close event is not possible if the calling code wishes to force the application to exit, and so this function must be called to check this.

Returns:
bool

GetLoggingOff(self)

Returns True if the user is logging off or False if the system is shutting down. This method can only be called for end session and query end session events, it doesn't make sense for close window event.

Returns:
bool

SetCanVeto(self, canVeto)

Sets the 'can veto' flag.

Parameters:
canVeto
(type=bool)

SetLoggingOff(self, logOff)

Sets the 'logging off' flag.

Parameters:
logOff
(type=bool)

Veto(self, veto=True)

Call this from your event handler to veto a system shutdown or to signal to the calling application that a window close did not happen.

You can only veto a shutdown or close if CanVeto returns true.

Parameters:
veto
(type=bool)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:59 2005 http://epydoc.sf.net


wx.Colour

Package wx :: Class Colour

Type Colour

object --+
         |
    Object --+
             |
            Colour

A colour is an object representing a combination of Red, Green, and Blue (RGB) intensity values, and is used to determine drawing colours, window colours, etc. Valid RGB values are in the range 0 to 255.

In wxPython there are typemaps that will automatically convert from a colour name, or from a '#RRGGBB' colour hex value string to a wx.Colour object when calling C++ methods that expect a wxColour. This means that the following are all equivallent:

win.SetBackgroundColour(wxColour(0,0,255))
win.SetBackgroundColour('BLUE')
win.SetBackgroundColour('#0000FF')

Additional colour names and their coresponding values can be added using wx.ColourDatabase. Various system colours (as set in the user's system preferences) can be retrieved with wx.SystemSettings.GetColour.

Method Summary
Colour __init__(self, red, green, blue)
Constructs a colour from red, green and blue values.
__del__(self)
bool __eq__(self, colour)
Compare colours for equality
bool __ne__(self, colour)
Compare colours for inequality
__nonzero__(self)
__reduce__(self)
__repr__(self)
__str__(self)
asTuple(*args, **kwargs)
asTuple is deprecated, use Get instead
byte Blue(self)
Returns the blue intensity.
(r, g, b) Get()
Returns the RGB intensity values as a tuple.
long GetPixel(self)
Returns a pixel value which is platform-dependent.
unsigned long GetRGB(self)
Return the colour as a packed RGB value
byte Green(self)
Returns the green intensity.
bool Ok(self)
Returns True if the colour object is valid (the colour has been initialised with RGB values).
byte Red(self)
Returns the red intensity.
Set(self, red, green, blue)
Sets the RGB intensity values.
SetFromName(self, colourName)
Sets the RGB intensity values using a colour name listed in wx.TheColourDatabase.
SetRGB(*args, **kwargs)
SetRGB(self, unsigned long colRGB)

Class Variable Summary
bool __safe_for_unpickling__ = True

Method Details

__init__(self,
          red=0,
          green=0,
          blue=0)
(Constructor)

Constructs a colour from red, green and blue values.

Parameters:
red
(type=byte)

green
(type=byte)

blue
(type=byte)

Returns:
Colour
Overrides:
wx.Object.__init__

See Also:

Alternate constructors wx.NamedColour and wx.ColourRGB.

__eq__(self, colour)
(Equality operator)

Compare colours for equality

Parameters:
colour
(type=Colour)

Returns:
bool

__ne__(self, colour)

Compare colours for inequality

Parameters:
colour
(type=Colour)

Returns:
bool

asTuple(*args, **kwargs)

asTuple is deprecated, use Get instead

Blue(self)

Returns the blue intensity.

Returns:
byte

Get()

Returns the RGB intensity values as a tuple.

Returns:
(r, g, b)

GetPixel(self)

Returns a pixel value which is platform-dependent. On Windows, a COLORREF is returned. On X, an allocated pixel value is returned. -1 is returned if the pixel is invalid (on X, unallocated).

Returns:
long

GetRGB(self)

Return the colour as a packed RGB value

Returns:
unsigned long

Green(self)

Returns the green intensity.

Returns:
byte

Ok(self)

Returns True if the colour object is valid (the colour has been initialised with RGB values).

Returns:
bool

Red(self)

Returns the red intensity.

Returns:
byte

Set(self, red, green, blue)

Sets the RGB intensity values.

Parameters:
red
(type=byte)

green
(type=byte)

blue
(type=byte)

SetFromName(self, colourName)

Sets the RGB intensity values using a colour name listed in wx.TheColourDatabase.

Parameters:
colourName
(type=String)

SetRGB(*args, **kwargs)

SetRGB(self, unsigned long colRGB)

Sets the RGB intensity values from a packed RGB value.

Class Variable Details

__safe_for_unpickling__

Type:
bool
Value:
True

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:23 2005 http://epydoc.sf.net


wx.ColourDatabase

Package wx :: Class ColourDatabase

Type ColourDatabase

object --+
         |
    Object --+
             |
            ColourDatabase

Proxy of C++ ColourDatabase class

Method Summary
ColourDatabase | __init__(self)
 | __del__(self)
 | __repr__(self)
 | AddColour(self, name, colour)
 | Append(self, name, red, green, blue)
Colour | Find(self, name)
Colour | FindColour(self, name)
String | FindName(self, colour)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:04 2005 http://epydoc.sf.net


wx.ColourData

Package wx :: Class ColourData

Type ColourData

object --+
         |
    Object --+
             |
            ColourData

This class holds a variety of information related to the colour chooser dialog, used to transfer settings and results to and from the wx.ColourDialog.

Method Summary
ColourData | __init__(self) Constructor, sets default values.
 | __del__(self)
 | __repr__(self)
bool | GetChooseFull(self) Under Windows, determines whether the Windows colour dialog will display the full dialog with custom colour selection controls.
Colour | GetColour(self) Gets the colour (pre)selected by the dialog.
Colour | GetCustomColour(self, i) Gets the i'th custom colour associated with the colour dialog.
 | SetChooseFull(self, flag) Under Windows, tells the Windows colour dialog to display the full dialog with custom colour selection controls.
 | SetColour(self, colour) Sets the default colour for the colour dialog.
 | SetCustomColour(self, i, colour) Sets the i'th custom colour for the colour dialog.

Method Details

__init__(self)
(Constructor)

Constructor, sets default values.

Returns:
ColourData
Overrides:
wx.Object.__init__

GetChooseFull(self)

Under Windows, determines whether the Windows colour dialog will display the full dialog with custom colour selection controls. Has no meaning under other platforms. The default value is true.

Returns:
bool

GetColour(self)

Gets the colour (pre)selected by the dialog.

Returns:
Colour

GetCustomColour(self, i)

Gets the i'th custom colour associated with the colour dialog. i should be an integer between 0 and 15. The default custom colours are all invalid colours.

Parameters:
i
(type=int)

Returns:
Colour

SetChooseFull(self, flag)

Under Windows, tells the Windows colour dialog to display the full dialog with custom colour selection controls. Under other platforms, has no effect. The default value is true.

Parameters:
flag
(type=int)

SetColour(self, colour)

Sets the default colour for the colour dialog. The default colour is black.

Parameters:
colour
(type=Colour)

SetCustomColour(self, i, colour)

Sets the i'th custom colour for the colour dialog. i should be an integer between 0 and 15. The default custom colours are all invalid colours.

Parameters:
i
(type=int)

colour
(type=Colour)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:06 2005 http://epydoc.sf.net


wx.ColourDialog

Package wx :: Class ColourDialog

Type ColourDialog

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
        TopLevelWindow --+
                         |
                    Dialog --+
                             |
                            ColourDialog

This class represents the colour chooser dialog.

Method Summary
ColourDialog | __init__(self, parent, data) Constructor.
 | __repr__(self)
ColourData | GetColourData(self) Returns a reference to the wx.ColourData used by the dialog.

Instance Method Details

__init__(self, parent, data=None)
(Constructor)

Constructor. Pass a parent window, and optionally a wx.ColourData, which will be copied to the colour dialog's internal ColourData instance.

Parameters:
parent
(type=Window)

data
(type=ColourData)

Returns:
ColourDialog
Overrides:
wx.Dialog.__init__

GetColourData(self)

Returns a reference to the wx.ColourData used by the dialog.

Returns:
ColourData

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:12 2005 http://epydoc.sf.net


wx.ComboBox

Package wx :: Class ComboBox

Type ComboBox

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
               Control --+
                         |
            object --+   |
                     |   |
         ItemContainer --+
                         |
                        ComboBox

Known Subclasses:
BaseMaskedComboBox

A combobox is like a combination of an edit control and a listbox. It can be displayed as static list with editable or read-only text field; or a drop-down list with text field.

A combobox permits a single selection only. Combobox items are numbered from zero.

Styles

wx.CB_SIMPLE | Creates a combobox with a permanently displayed list. Windows only.
wx.CB_DROPDOWN | Creates a combobox with a drop-down list.
wx.CB_READONLY | Same as wxCB_DROPDOWN but only the strings specified as the combobox choices can be selected, it is impossible to select (even from a program) a string which is not in the choices list.
wx.CB_SORT | Sorts the entries in the list alphabetically.

Events

EVT_COMBOBOX | Sent when an item on the list is selected. Note that calling GetValue in this handler will return the newly selected value.
EVT_TEXT | Sent when the combobox text changes.
EVT_TEXT_ENTER | Sent when the RETURN/ENTER key is pressed in the combobox.
Method Summary
ComboBox | __init__(parent, id, value, pos, size, choices, style, validator, name) Constructor, creates and shows a ComboBox control.
 | __repr__(self)
bool | CanCopy(self) Returns True if the combobox is editable and there is a text selection to copy to the clipboard.
bool | CanCut(self) Returns True if the combobox is editable and there is a text selection to copy to the clipboard.
bool | CanPaste(self) Returns True if the combobox is editable and there is text on the clipboard that can be pasted into the text field.
bool | CanRedo(self) Returns True if the combobox is editable and the last undo can be redone.
bool | CanUndo(self) Returns True if the combobox is editable and the last edit can be undone.
 | Copy(self) Copies the selected text to the clipboard.
bool | Create(parent, id, value, pos, size, choices, style, validator, name) Actually create the GUI wxComboBox control for 2-phase creation
 | Cut(self) Copies the selected text to the clipboard and removes the selection.
VisualAttributes | GetClassDefaultAttributes(variant) Get the default attributes for this class. (Static method)
long | GetInsertionPoint(self) Returns the insertion point for the combobox's text field.
long | GetLastPosition(self) Returns the last position in the combobox text field.
(from, to) | GetMark(self) Gets the positions of the begining and ending of the selection mark in the combobox text field.
String | GetValue(self) Returns the current value in the combobox text field.
bool | IsEditable(self) Returns True if the combo is ediatable (not read-only.)
 | Paste(self) Pastes text from the clipboard to the text field.
 | Redo(self) Undoes the last edit in the text field.
 | Remove(self, from, to) Removes the text between the two positions in the combobox text field.
 | Replace(self, from, to, value) Replaces the text between two positions with the given text, in the combobox text field.
 | SelectAll(self) Select all the text in the combo's text field.
 | SetEditable(self, editable)
 | SetInsertionPoint(self, pos) Sets the insertion point in the combobox text field.
 | SetInsertionPointEnd(self) Sets the insertion point at the end of the combobox text field.
 | SetMark(self, from, to) Selects the text between the two positions in the combobox text field.
 | SetSelection(self, n) Sets the item at index 'n' to be the selected item.
 | SetString(self, n, string) Set the label for the n'th item (zero based) in the list.
bool | SetStringSelection(self, string) Select the item with the specifed string
 | SetValue(self, value)
 | Undo(self) Redoes the last undo in the text field.

Instance Method Details

__init__(parent,
          id,
          value=EmptyString,
          pos=DefaultPosition,
          size=DefaultSize,
          choices=EmptyList,
          style=0,
          validator=DefaultValidator,
          name=ComboBoxNameStr)
(Constructor)

Constructor, creates and shows a ComboBox control.

Parameters:
parent
(type=Window)

id
(type=int)

value
(type=String)

pos
(type=Point)

size
(type=Size)

choices
(type=List)

style
(type=long)

validator
(type=Validator)

name
(type=String)

Returns:
ComboBox
Overrides:
wx.Control.__init__

CanCopy(self)

Returns True if the combobox is editable and there is a text selection to copy to the clipboard. Only available on Windows.

Returns:
bool

CanCut(self)

Returns True if the combobox is editable and there is a text selection to copy to the clipboard. Only available on Windows.

Returns:
bool

CanPaste(self)

Returns True if the combobox is editable and there is text on the clipboard that can be pasted into the text field. Only available on Windows.

Returns:
bool

CanRedo(self)

Returns True if the combobox is editable and the last undo can be redone. Only available on Windows.

Returns:
bool

CanUndo(self)

Returns True if the combobox is editable and the last edit can be undone. Only available on Windows.

Returns:
bool

Copy(self)

Copies the selected text to the clipboard.

Create(parent,
          id,
          value=EmptyString,
          pos=DefaultPosition,
          size=DefaultSize,
          choices=EmptyList,
          style=0,
          validator=DefaultValidator,
          name=ChoiceNameStr)

Actually create the GUI wxComboBox control for 2-phase creation

Parameters:
parent
(type=Window)

id
(type=int)

value
(type=String)

pos
(type=Point)

size
(type=Size)

choices
(type=List)

style
(type=long)

validator
(type=Validator)

name
(type=String)

Returns:
bool
Overrides:
wx.Control.Create

Cut(self)

Copies the selected text to the clipboard and removes the selection.

GetInsertionPoint(self)

Returns the insertion point for the combobox's text field.

Returns:
long

GetLastPosition(self)

Returns the last position in the combobox text field.

Returns:
long

GetMark(self)

Gets the positions of the begining and ending of the selection mark in the combobox text field.

Returns:
(from, to)

GetValue(self)

Returns the current value in the combobox text field.

Returns:
String

IsEditable(self)

Returns True if the combo is ediatable (not read-only.)

Returns:
bool

Paste(self)

Pastes text from the clipboard to the text field.

Redo(self)

Undoes the last edit in the text field. Windows only.

Remove(self, from, to)

Removes the text between the two positions in the combobox text field.

Parameters:
from
(type=long)

to
(type=long)

Replace(self, from, to, value)

Replaces the text between two positions with the given text, in the combobox text field.

Parameters:
from
(type=long)

to
(type=long)

value
(type=String)

SelectAll(self)

Select all the text in the combo's text field.

SetInsertionPoint(self, pos)

Sets the insertion point in the combobox text field.

Parameters:
pos
(type=long)

SetInsertionPointEnd(self)

Sets the insertion point at the end of the combobox text field.

SetMark(self, from, to)

Selects the text between the two positions in the combobox text field.

Parameters:
from
(type=long)

to
(type=long)

SetSelection(self, n)

Sets the item at index 'n' to be the selected item.

Parameters:
n
(type=int)

Overrides:
wx.ItemContainer.SetSelection

SetString(self, n, string)

Set the label for the n'th item (zero based) in the list.

Parameters:
n
(type=int)

string
(type=String)

Overrides:
wx.ItemContainer.SetString

SetStringSelection(self, string)

Select the item with the specifed string

Parameters:
string
(type=String)

Returns:
bool
Overrides:
wx.ItemContainer.SetStringSelection

Undo(self)

Redoes the last undo in the text field. Windows only.

Static Method Details

GetClassDefaultAttributes(variant=WINDOW_VARIANT_NORMAL)

Get the default attributes for this class. This is useful if you want to use the same font or colour in your own control as in a standard control -- which is a much better idea than hard coding specific colours or fonts which might look completely out of place on the user's system, especially if it uses themes.

The variant parameter is only relevant under Mac currently and is ignore under other platforms. Under Mac, it will change the size of the returned font. See wx.Window.SetWindowVariant for more about this.

Parameters:
variant
(type=int)

Returns:
VisualAttributes

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:53 2005 http://epydoc.sf.net


wx.CommandEvent

Package wx :: Class CommandEvent

Type CommandEvent

object --+
         |
    Object --+
             |
         Event --+
                 |
                CommandEvent

Known Subclasses:
ChildFocusEvent, ContextMenuEvent, DateEvent, DynamicSashSplitEvent, DynamicSashUnifyEvent, FindDialogEvent, GridEditorCreatedEvent, HelpEvent, NotifyEvent, PyCommandEvent, SashEvent, ScrollEvent, StyledTextEvent, TextUrlEvent, UpdateUIEvent, WebKitStateChangedEvent, WindowCreateEvent, WindowDestroyEvent

This event class contains information about command events, which originate from a variety of simple controls, as well as menus and toolbars.

Method Summary
CommandEvent | __init__(self, commandType, winid) This event class contains information about command events, which originate from a variety of simple controls, as well as menus and toolbars.
 | __repr__(self)
bool | Checked(self) This method can be used with checkbox and menu events: for the checkboxes, the method returns true for a selection event and false for a deselection one.
Event | Clone(self)
long | GetExtraLong(self) Returns extra information dependant on the event objects type.
long | GetInt(self) Returns the integer identifier corresponding to a listbox, choice or radiobox selection (only if the event was a selection, not a deselection), or a boolean value representing the value of a checkbox.
int | GetSelection(self) Returns item index for a listbox or choice selection event (not valid for a deselection).
String | GetString(self) Returns item string for a listbox or choice selection event (not valid for a deselection).
bool | IsChecked(self) This method can be used with checkbox and menu events: for the checkboxes, the method returns true for a selection event and false for a deselection one.
bool | IsSelection(self) For a listbox or similar event, returns true if it is a selection, false if it is a deselection.
 | SetExtraLong(self, extraLong)
 | SetInt(self, i)
 | SetString(self, s)

Method Details

__init__(self, commandType=wxEVT_NULL, winid=0)
(Constructor)

This event class contains information about command events, which originate from a variety of simple controls, as well as menus and toolbars.

Parameters:
commandType
(type=wxEventType)

winid
(type=int)

Returns:
CommandEvent
Overrides:
wx.Event.__init__

Checked(self)

This method can be used with checkbox and menu events: for the checkboxes, the method returns true for a selection event and false for a deselection one. For the menu events, this method indicates if the menu item just has become checked or unchecked (and thus only makes sense for checkable menu items).

Returns:
bool

GetExtraLong(self)

Returns extra information dependant on the event objects type. If the event comes from a listbox selection, it is a boolean determining whether the event was a selection (true) or a deselection (false). A listbox deselection only occurs for multiple-selection boxes, and in this case the index and string values are indeterminate and the listbox must be examined by the application.

Returns:
long

GetInt(self)

Returns the integer identifier corresponding to a listbox, choice or radiobox selection (only if the event was a selection, not a deselection), or a boolean value representing the value of a checkbox.

Returns:
long

GetSelection(self)

Returns item index for a listbox or choice selection event (not valid for a deselection).

Returns:
int

GetString(self)

Returns item string for a listbox or choice selection event (not valid for a deselection).

Returns:
String

IsChecked(self)

This method can be used with checkbox and menu events: for the checkboxes, the method returns true for a selection event and false for a deselection one. For the menu events, this method indicates if the menu item just has become checked or unchecked (and thus only makes sense for checkable menu items).

Returns:
bool

IsSelection(self)

For a listbox or similar event, returns true if it is a selection, false if it is a deselection.

Returns:
bool

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:15 2005 http://epydoc.sf.net


wx.ConfigBase

Package wx :: Class ConfigBase

Type ConfigBase

object --+
         |
        ConfigBase

Known Subclasses:
Config, FileConfig

wx.ConfigBase class defines the basic interface of all config classes. It can not be used by itself (it is an abstract base class) and you will always use one of its derivations: wx.Config or wx.FileConfig.

wx.ConfigBase organizes the items in a tree-like structure, modeled after the Unix/Dos filesystem. There are groups that act like directories and entries, key/value pairs that act like files. There is always one current group given by the current path. As in the file system case, to specify a key in the config class you must use a path to it. Config classes also support the notion of the current group, which makes it possible to use relative paths.

Keys are pairs "key_name = value" where value may be of string, integer floating point or boolean, you can not store binary data without first encoding it as a string. For performance reasons items should be kept small, no more than a couple kilobytes.

Method Summary
__init__(self)
__del__(self)
__repr__(self)
ConfigBase Create()
Create and return a new global config object. (Static method)
bool DeleteAll(self)
Delete the whole underlying object (disk file, registry key, ...) primarly intended for use by deinstallation routine.
bool DeleteEntry(self, key, deleteGroupIfEmpty)
Deletes the specified entry and the group it belongs to if it was the last key in it and the second parameter is True
bool DeleteGroup(self, key)
Delete the group (with all subgroups)
DontCreateOnDemand()
Should Get() try to create a new log object if there isn't a current one? (Static method)
bool Exists(self, name)
Returns True if either a group or an entry with a given name exists
String ExpandEnvVars(self, str)
Expand any environment variables in str and return the result
bool Flush(self, currentOnly)
permanently writes all changes
ConfigBase Get(createOnDemand)
Returns the current global config object, creating one if neccessary. (Static method)
String | GetAppName(self)
int GetEntryType(self, name)
Get the type of the entry.
(more, value, index) GetFirstEntry()
Allows enumerating the entries in the current group in a config object.
(more, value, index) GetFirstGroup()
Allows enumerating the subgroups in a config object.
(more, value, index) GetNextEntry(index)
Allows enumerating the entries in the current group in a config object.
(more, value, index) GetNextGroup(index)
Allows enumerating the subgroups in a config object.
size_t GetNumberOfEntries(self, recursive)
Get the number of entries in the current group, with or without its subgroups.
size_t GetNumberOfGroups(self, recursive)
Get the number of subgroups in the current group, with or without its subgroups.
String GetPath(self)
Retrieve the current path (always as absolute path)
long | GetStyle(self)
String | GetVendorName(self)
bool HasEntry(self, name)
Returns True if the entry by this name exists
bool HasGroup(self, name)
Returns True if the group by this name exists
bool IsExpandingEnvVars(self)
Are we currently expanding environment variables?
bool IsRecordingDefaults(self)
Are we currently recording default values?
String Read(self, key, defaultVal)
Returns the value of key if it exists, defaultVal otherwise.
bool ReadBool(self, key, defaultVal)
Returns the value of key if it exists, defaultVal otherwise.
double ReadFloat(self, key, defaultVal)
Returns the value of key if it exists, defaultVal otherwise.
long ReadInt(self, key, defaultVal)
Returns the value of key if it exists, defaultVal otherwise.
bool RenameEntry(self, oldName, newName)
Rename an entry.
bool RenameGroup(self, oldName, newName)
Rename a group.
ConfigBase Set(config)
Sets the global config object (the one returned by Get) and returns a reference to the previous global config object. (Static method)
SetAppName(self, appName)
SetExpandEnvVars(self, doIt)
We can automatically expand environment variables in the config entries this option is on by default, you can turn it on/off at any time)
SetPath(self, path)
Set current path: if the first character is '/', it's the absolute path, otherwise it's a relative path.
SetRecordDefaults(self, doIt)
Set whether the config objec should record default values.
SetStyle(self, style)
SetVendorName(self, vendorName)
bool Write(self, key, value)
write the value (return True on success)
bool WriteBool(self, key, value)
write the value (return True on success)
bool WriteFloat(self, key, value)
write the value (return True on success)
bool WriteInt(self, key, value)
write the value (return True on success)

Class Variable Summary
int | Type_Boolean = 2
int | Type_Float = 4
int | Type_Integer = 3
int | Type_String = 1
int | Type_Unknown = 0

Instance Method Details

DeleteAll(self)

Delete the whole underlying object (disk file, registry key, ...) primarly intended for use by deinstallation routine.

Returns:
bool

DeleteEntry(self, key, deleteGroupIfEmpty=True)

Deletes the specified entry and the group it belongs to if it was the last key in it and the second parameter is True

Parameters:
key
(type=String)

deleteGroupIfEmpty
(type=bool)

Returns:
bool

DeleteGroup(self, key)

Delete the group (with all subgroups)

Parameters:
key
(type=String)

Returns:
bool

Exists(self, name)

Returns True if either a group or an entry with a given name exists

Parameters:
name
(type=String)

Returns:
bool

ExpandEnvVars(self, str)

Expand any environment variables in str and return the result

Parameters:
str
(type=String)

Returns:
String

Flush(self, currentOnly=False)

permanently writes all changes

Parameters:
currentOnly
(type=bool)

Returns:
bool

GetEntryType(self, name)

Get the type of the entry. Returns one of the wx.Config.Type_XXX values.

Parameters:
name
(type=String)

Returns:
int

GetFirstEntry()

Allows enumerating the entries in the current group in a config object. Returns a tuple containing a flag indicating there are more items, the name of the current item, and an index to pass to GetNextGroup to fetch the next item.

Returns:
(more, value, index)

GetFirstGroup()

Allows enumerating the subgroups in a config object. Returns a tuple containing a flag indicating there are more items, the name of the current item, and an index to pass to GetNextGroup to fetch the next item.

Returns:
(more, value, index)

GetNextEntry(index)

Allows enumerating the entries in the current group in a config object. Returns a tuple containing a flag indicating there are more items, the name of the current item, and an index to pass to GetNextGroup to fetch the next item.

Parameters:
index
(type=long)

Returns:
(more, value, index)

GetNextGroup(index)

Allows enumerating the subgroups in a config object. Returns a tuple containing a flag indicating there are more items, the name of the current item, and an index to pass to GetNextGroup to fetch the next item.

Parameters:
index
(type=long)

Returns:
(more, value, index)

GetNumberOfEntries(self, recursive=False)

Get the number of entries in the current group, with or without its subgroups.

Parameters:
recursive
(type=bool)

Returns:
size_t

GetNumberOfGroups(self, recursive=False)

Get the number of subgroups in the current group, with or without its subgroups.

Parameters:
recursive
(type=bool)

Returns:
size_t

GetPath(self)

Retrieve the current path (always as absolute path)

Returns:
String

HasEntry(self, name)

Returns True if the entry by this name exists

Parameters:
name
(type=String)

Returns:
bool

HasGroup(self, name)

Returns True if the group by this name exists

Parameters:
name
(type=String)

Returns:
bool

IsExpandingEnvVars(self)

Are we currently expanding environment variables?

Returns:
bool

IsRecordingDefaults(self)

Are we currently recording default values?

Returns:
bool

Read(self, key, defaultVal=EmptyString)

Returns the value of key if it exists, defaultVal otherwise.

Parameters:
key
(type=String)

defaultVal
(type=String)

Returns:
String

ReadBool(self, key, defaultVal=False)

Returns the value of key if it exists, defaultVal otherwise.

Parameters:
key
(type=String)

defaultVal
(type=bool)

Returns:
bool

ReadFloat(self, key, defaultVal=0.0)

Returns the value of key if it exists, defaultVal otherwise.

Parameters:
key
(type=String)

defaultVal
(type=double)

Returns:
double

ReadInt(self, key, defaultVal=0)

Returns the value of key if it exists, defaultVal otherwise.

Parameters:
key
(type=String)

defaultVal
(type=long)

Returns:
long

RenameEntry(self, oldName, newName)

Rename an entry. Returns False on failure (probably because the new name is already taken by an existing entry)

Parameters:
oldName
(type=String)

newName
(type=String)

Returns:
bool

RenameGroup(self, oldName, newName)

Rename a group. Returns False on failure (probably because the new name is already taken by an existing entry)

Parameters:
oldName
(type=String)

newName
(type=String)

Returns:
bool

SetExpandEnvVars(self, doIt=True)

We can automatically expand environment variables in the config entries this option is on by default, you can turn it on/off at any time)

Parameters:
doIt
(type=bool)

SetPath(self, path)

Set current path: if the first character is '/', it's the absolute path, otherwise it's a relative path. '..' is supported. If the strPath doesn't exist it is created.

Parameters:
path
(type=String)

SetRecordDefaults(self, doIt=True)

Set whether the config objec should record default values.

Parameters:
doIt
(type=bool)

Write(self, key, value)

write the value (return True on success)

Parameters:
key
(type=String)

value
(type=String)

Returns:
bool

WriteBool(self, key, value)

write the value (return True on success)

Parameters:
key
(type=String)

value
(type=bool)

Returns:
bool

WriteFloat(self, key, value)

write the value (return True on success)

Parameters:
key
(type=String)

value
(type=double)

Returns:
bool

WriteInt(self, key, value)

write the value (return True on success)

Parameters:
key
(type=String)

value
(type=long)

Returns:
bool

Static Method Details

Create()

Create and return a new global config object. This function will create the "best" implementation of wx.Config available for the current platform.

Returns:
ConfigBase

DontCreateOnDemand()

Should Get() try to create a new log object if there isn't a current one?

Get(createOnDemand=True)

Returns the current global config object, creating one if neccessary.

Parameters:
createOnDemand
(type=bool)

Returns:
ConfigBase

Set(config)

Sets the global config object (the one returned by Get) and returns a reference to the previous global config object.

Parameters:
config
(type=ConfigBase)

Returns:
ConfigBase

Class Variable Details

Type_Boolean

Type:
int
Value:
2

Type_Float

Type:
int
Value:
4

Type_Integer

Type:
int
Value:
3

Type_String

Type:
int
Value:
1

Type_Unknown

Type:
int
Value:
0

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:03 2005 http://epydoc.sf.net


wx.Config

Package wx :: Class Config

Type Config

object --+
         |
ConfigBase --+
             |
            Config

This ConfigBase-derived class will use the registry on Windows, and will be a wx.FileConfig on other platforms.

Method Summary
Config | __init__(self, appName, vendorName, localFilename, globalFilename, style)
 | __del__(self)
 | __repr__(self)

Class Variable Summary

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:46 2005 http://epydoc.sf.net


wx.ConfigPathChanger

Package wx :: Class ConfigPathChanger

Type ConfigPathChanger

object --+
         |
        ConfigPathChanger

A handy little class which changes current path to the path of given entry and restores it in the destructoir: so if you declare a local variable of this type, you work in the entry directory and the path is automatically restored when the function returns.

Method Summary
ConfigPathChanger | __init__(self, config, entry)
 | __del__(self)
 | __repr__(self)
String | Name(self) Get the key name

Method Details

Name(self)

Get the key name

Returns:
String

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:39 2005 http://epydoc.sf.net


wx.ContextHelpButton

Package wx :: Class ContextHelpButton

Type ContextHelpButton

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
               Control --+
                         |
                    Button --+
                             |
                  BitmapButton --+
                                 |
                                ContextHelpButton

Instances of this class may be used to add a question mark button that when pressed, puts the application into context-help mode. It does this by creating a wx.ContextHelp object which itself generates a EVT_HELP event when the user clicks on a window.

On Windows, you may add a question-mark icon to a dialog by use of the wx.DIALOG_EX_CONTEXTHELP extra style, but on other platforms you will have to add a button explicitly, usually next to OK, Cancel or similar buttons.

See Also:

wx.ContextHelp, wx.ContextHelpButton

Method Summary
ContextHelpButton | __init__(self, parent, id, pos, size, style) Constructor, creating and showing a context help button.
 | __repr__(self)

Instance Method Details

__init__(self, parent, id=ID_CONTEXT_HELP, pos=DefaultPosition, size=DefaultSize, style=BU_AUTODRAW)
(Constructor)

Constructor, creating and showing a context help button.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

Returns:
ContextHelpButton
Overrides:
wx.BitmapButton.__init__

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:11 2005 http://epydoc.sf.net


wx.ContextHelp

Package wx :: Class ContextHelp

Type ContextHelp

object --+
         |
    Object --+
             |
            ContextHelp

This class changes the cursor to a query and puts the application into a 'context-sensitive help mode'. When the user left-clicks on a window within the specified window, a EVT_HELP event is sent to that control, and the application may respond to it by popping up some help.

There are a couple of ways to invoke this behaviour implicitly:

  • Use the wx.DIALOG_EX_CONTEXTHELP extended style for a dialog (Windows only). This will put a question mark in the titlebar, and Windows will put the application into context-sensitive help mode automatically, with further programming.
  • Create a wx.ContextHelpButton, whose predefined behaviour is to create a context help object. Normally you will write your application so that this button is only added to a dialog for non-Windows platforms (use wx.DIALOG_EX_CONTEXTHELP on Windows).

See Also:

wx.ContextHelpButton

Method Summary
ContextHelp | __init__(self, window, doNow) Constructs a context help object, calling BeginContextHelp if doNow is true (the default).
 | __del__(self)
 | __repr__(self)
bool | BeginContextHelp(self, window) Puts the application into context-sensitive help mode.
bool | EndContextHelp(self) Ends context-sensitive help mode.

Method Details

__init__(self, window=None, doNow=True)
(Constructor)

Constructs a context help object, calling BeginContextHelp if doNow is true (the default).

If window is None, the top window is used.

Parameters:
window
(type=Window)

doNow
(type=bool)

Returns:
ContextHelp
Overrides:
wx.Object.__init__

BeginContextHelp(self, window=None)

Puts the application into context-sensitive help mode. window is the window which will be used to catch events; if NULL, the top window will be used.

Returns true if the application was successfully put into context-sensitive help mode. This function only returns when the event loop has finished.

Parameters:
window
(type=Window)

Returns:
bool

EndContextHelp(self)

Ends context-sensitive help mode. Not normally called by the application.

Returns:
bool

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:03 2005 http://epydoc.sf.net


wx.ContextMenuEvent

Package wx :: Class ContextMenuEvent

Type ContextMenuEvent

object --+
         |
    Object --+
             |
         Event --+
                 |
      CommandEvent --+
                     |
                    ContextMenuEvent

This class is used for context menu events (EVT_CONTECT_MENU,) sent to give the application a chance to show a context (popup) menu.

Method Summary
ContextMenuEvent | __init__(self, type, winid, pt) Constructor.
 | __repr__(self)
Point | GetPosition(self) Returns the position (in screen coordinants) at which the menu should be shown.
 | SetPosition(self, pos) Sets the position at which the menu should be shown.

Method Details

__init__(self,
          type=wxEVT_NULL,
          winid=0,
          pt=DefaultPosition)
(Constructor)

Constructor.

Parameters:
type
(type=wxEventType)

winid
(type=int)

pt
(type=Point)

Returns:
ContextMenuEvent
Overrides:
wx.CommandEvent.__init__

GetPosition(self)

Returns the position (in screen coordinants) at which the menu should be shown.

Returns:
Point

SetPosition(self, pos)

Sets the position at which the menu should be shown.

Parameters:
pos
(type=Point)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:10:49 2005 http://epydoc.sf.net


wx.Control

Package wx :: Class Control

Type Control

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
                    Control

Known Subclasses:
BookCtrlBase, Button, CalendarCtrl, CheckBox, ComboBox, ControlWithItems, DatePickerCtrl, Gauge, GenericDirCtrl, GIFAnimationCtrl, LEDNumberCtrl, ListCtrl, MediaCtrl, PyControl, RadioBox, RadioButton, ScrollBar, Slider, SpinButton, SpinCtrl, StaticBitmap, StaticBox, StaticLine, StaticPicture, StaticText, StyledTextCtrl, TextCtrl, ToggleButton, ToolBarBase, TreeCtrl, TreeListCtrl, WebKitCtrl

This is the base class for a control or 'widget'.

A control is generally a small window which processes user input and/or displays one or more item of data.

Method Summary
Control | __init__(self, parent, id, pos, size, style, validator, name) Create a Control.
 | __repr__(self)
 | Command(self, event) Simulates the effect of the user issuing a command to the item.
bool | Create(self, parent, id, pos, size, style, validator, name) Do the 2nd phase and create the GUI control.
VisualAttributes | GetClassDefaultAttributes(variant) Get the default attributes for this class. (Static method)
String | GetLabel(self) Return a control's text.
 | SetLabel(self, label) Sets the item's text.

Instance Method Details

__init__(self,
          parent,
          id=-1,
          pos=DefaultPosition,
          size=DefaultSize,
          style=0,
          validator=DefaultValidator,
          name=ControlNameStr)
(Constructor)

Create a Control. Normally you should only call this from a subclass' __init__ as a plain old wx.Control is not very useful.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

validator
(type=Validator)

name
(type=String)

Returns:
Control
Overrides:
wx.Window.__init__

Command(self, event)

Simulates the effect of the user issuing a command to the item.

Parameters:
event
(type=CommandEvent)

See Also:

wx.CommandEvent

Create(self,
          parent,
          id=-1,
          pos=DefaultPosition,
          size=DefaultSize,
          style=0,
          validator=DefaultValidator,
          name=ControlNameStr)

Do the 2nd phase and create the GUI control.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

validator
(type=Validator)

name
(type=String)

Returns:
bool
Overrides:
wx.Window.Create

GetLabel(self)

Return a control's text.

Returns:
String
Overrides:
wx.Window.GetLabel

SetLabel(self, label)

Sets the item's text.

Parameters:
label
(type=String)

Overrides:
wx.Window.SetLabel

Static Method Details

GetClassDefaultAttributes(variant=WINDOW_VARIANT_NORMAL)

Get the default attributes for this class. This is useful if you want to use the same font or colour in your own control as in a standard control -- which is a much better idea than hard coding specific colours or fonts which might look completely out of place on the user's system, especially if it uses themes.

The variant parameter is only relevant under Mac currently and is ignore under other platforms. Under Mac, it will change the size of the returned font. See wx.Window.SetWindowVariant for more about this.

Parameters:
variant
(type=int)

Returns:
VisualAttributes

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:48 2005 http://epydoc.sf.net


wx.ControlWithItems

Package wx :: Class ControlWithItems

Type ControlWithItems

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
               Control --+
                         |
            object --+   |
                     |   |
         ItemContainer --+
                         |
                        ControlWithItems

Known Subclasses:
Choice, ListBox

wx.ControlWithItems combines the wx.ItemContainer class with the wx.Control class, and is used for the base class of various controls that have items.

Method Summary
 | __init__(self)
 | __repr__(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:09 2005 http://epydoc.sf.net


wx.CPPFileSystemHandler

Package wx :: Class CPPFileSystemHandler

Type CPPFileSystemHandler

object --+
         |
        CPPFileSystemHandler

Known Subclasses:
FileSystemHandler, InternetFSHandler, MemoryFSHandler, ZipFSHandler

Proxy of C++ CPPFileSystemHandler class

Method Summary
 | __init__(self)
 | __repr__(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:12 2005 http://epydoc.sf.net


wx.CURHandler

Package wx :: Class CURHandler

Type CURHandler

object --+
         |
    Object --+
             |
  ImageHandler --+
                 |
        BMPHandler --+
                     |
            ICOHandler --+
                         |
                        CURHandler

Known Subclasses:
ANIHandler

A wx.ImageHandler for *.cur cursor files.

Method Summary
CURHandler | __init__(self) A wx.ImageHandler for *.cur cursor files.
 | __repr__(self)

Method Details

__init__(self)
(Constructor)

A wx.ImageHandler for *.cur cursor files.

Returns:
CURHandler
Overrides:
wx.ICOHandler.__init__

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:09 2005 http://epydoc.sf.net


wx.Cursor

Package wx :: Class Cursor

Type Cursor

object --+
         |
    Object --+
             |
     GDIObject --+
                 |
                Cursor

A cursor is a small bitmap usually used for denoting where the mouse pointer is, with a picture that might indicate the interpretation of a mouse click.

A single cursor object may be used in many windows (any subwindow type). The wxWindows convention is to set the cursor for a window, as in X, rather than to set it globally as in MS Windows, although a global wx.SetCursor function is also available for use on MS Windows.

Stock Cursor IDs

wx.CURSOR_ARROW | A standard arrow cursor.
wx.CURSOR_RIGHT_ARROW | A standard arrow cursor pointing to the right.
wx.CURSOR_BLANK | Transparent cursor.
wx.CURSOR_BULLSEYE | Bullseye cursor.
wx.CURSOR_CHAR | Rectangular character cursor.
wx.CURSOR_CROSS | A cross cursor.
wx.CURSOR_HAND | A hand cursor.
wx.CURSOR_IBEAM | An I-beam cursor (vertical line).
wx.CURSOR_LEFT_BUTTON | Represents a mouse with the left button depressed.
wx.CURSOR_MAGNIFIER | A magnifier icon.
wx.CURSOR_MIDDLE_BUTTON | Represents a mouse with the middle button depressed.
wx.CURSOR_NO_ENTRY | A no-entry sign cursor.
wx.CURSOR_PAINT_BRUSH | A paintbrush cursor.
wx.CURSOR_PENCIL | A pencil cursor.
wx.CURSOR_POINT_LEFT | A cursor that points left.
wx.CURSOR_POINT_RIGHT | A cursor that points right.
wx.CURSOR_QUESTION_ARROW | An arrow and question mark.
wx.CURSOR_RIGHT_BUTTON | Represents a mouse with the right button depressed.
wx.CURSOR_SIZENESW | A sizing cursor pointing NE-SW.
wx.CURSOR_SIZENS | A sizing cursor pointing N-S.
wx.CURSOR_SIZENWSE | A sizing cursor pointing NW-SE.
wx.CURSOR_SIZEWE | A sizing cursor pointing W-E.
wx.CURSOR_SIZING | A general sizing cursor.
wx.CURSOR_SPRAYCAN | A spraycan cursor.
wx.CURSOR_WAIT | A wait cursor.
wx.CURSOR_WATCH | A watch cursor.
wx.CURSOR_ARROWWAIT | A cursor with both an arrow and an hourglass, (windows.)
Method Summary
Cursor | __init__(self, cursorName, type, hotSpotX, hotSpotY) Construct a Cursor from a file.
 | __del__(self)
 | __nonzero__(self)
 | __repr__(self)
bool | Ok(self)

Method Details

__init__(self, cursorName, type, hotSpotX=0, hotSpotY=0)
(Constructor)

Construct a Cursor from a file. Specify the type of file using wx.BITAMP_TYPE* constants, and specify the hotspot if not using a .cur file. :see: Alternate constructors wx.StockCursor,`wx.CursorFromImage`

Parameters:
cursorName
(type=String)

type
(type=long)

hotSpotX
(type=int)

hotSpotY
(type=int)

Returns:
Cursor
Overrides:
wx.GDIObject.__init__

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:00 2005 http://epydoc.sf.net


wx.CustomDataObject

Package wx :: Class CustomDataObject

Type CustomDataObject

  object --+
           |
  DataObject --+
               |
DataObjectSimple --+
                   |
                  CustomDataObject

wx.CustomDataObject is a specialization of wx.DataObjectSimple for some application-specific data in arbitrary format. Python strings are used for getting and setting data, but any picklable object can easily be transfered via strings. A copy of the data is stored in the data object.

Method Summary
CustomDataObject __init__(self, format)
__init__(self, String formatName) -> CustomDataObject __init__(self) -> CustomDataObject
__repr__(self)
String GetData(self)
Returns the data bytes from the data object as a string.
size_t GetSize(self)
Get the size of the data.
bool SetData(self, data)
Copy the data value to the data object.
bool TakeData(self, data)
Copy the data value to the data object.

Class Variable Summary

Method Details

__init__(self, format)
(Constructor)

__init__(self, String formatName) -> CustomDataObject __init__(self) -> CustomDataObject

wx.CustomDataObject is a specialization of wx.DataObjectSimple for some application-specific data in arbitrary format. Python strings are used for getting and setting data, but any picklable object can easily be transfered via strings. A copy of the data is stored in the data object.

Parameters:
format
(type=DataFormat)

Returns:
CustomDataObject
Overrides:
wx.DataObjectSimple.__init__

GetData(self)

Returns the data bytes from the data object as a string.

Returns:
String

GetSize(self)

Get the size of the data.

Returns:
size_t

SetData(self, data)

Copy the data value to the data object.

Parameters:
data
(type=String)

Returns:
bool
Overrides:
wx.DataObjectSimple.SetData

TakeData(self, data)

Copy the data value to the data object.

Parameters:
data
(type=String)

Returns:
bool
Overrides:
wx.DataObjectSimple.SetData

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:59 2005 http://epydoc.sf.net


wx.DataFormat

Package wx :: Class DataFormat

Type DataFormat

object --+
         |
        DataFormat

A wx.DataFormat is an encapsulation of a platform-specific format handle which is used by the system for the clipboard and drag and drop operations. The applications are usually only interested in, for example, pasting data from the clipboard only if the data is in a format the program understands. A data format is is used to uniquely identify this format. On the system level, a data format is usually just a number, (which may be the CLIPFORMAT under Windows or Atom under X11, for example.)

The standard format IDs are:

wx.DF_INVALID | An invalid format
wx.DF_TEXT | Text format
wx.DF_BITMAP | A bitmap (wx.Bitmap)
wx.DF_METAFILE | A metafile (wx.Metafile, Windows only)
wx.DF_FILENAME | A list of filenames
wx.DF_HTML | An HTML string. This is only valid on Windows and non-unicode builds

Besies the standard formats, the application may also use custom formats which are identified by their names (strings) and not numeric identifiers. Although internally custom format must be created (or registered) first, you shouldn't care about it because it is done automatically the first time the wxDataFormat object corresponding to a given format name is created.

Method Summary
DataFormat __init__(self, type)
Constructs a data format object for one of the standard data formats or an empty data object (use SetType or SetId later in this case)
__del__(self)
bool __eq__(self, format)
__eq__(self, DataFormat format) -> bool
bool __ne__(self, format)
__ne__(self, DataFormat format) -> bool
__repr__(self)
String GetId(self)
Returns the name of a custom format (this function will fail for a standard format).
int GetType(self)
Returns the platform-specific number identifying the format.
SetId(self, format)
Sets the format to be the custom format identified by the given name.
SetType(self, format)
Sets the format to the given value, which should be one of wx.DF_XXX constants.

Method Details

__init__(self, type)
(Constructor)

Constructs a data format object for one of the standard data formats or an empty data object (use SetType or SetId later in this case)

Parameters:
type
(type=int)

Returns:
DataFormat
Overrides:
__builtin__.object.__init__

__eq__(self, format)
(Equality operator)

__eq__(self, DataFormat format) -> bool

Parameters:
format
(type=int)

Returns:
bool

__ne__(self, format)

__ne__(self, DataFormat format) -> bool

Parameters:
format
(type=int)

Returns:
bool

GetId(self)

Returns the name of a custom format (this function will fail for a standard format).

Returns:
String

GetType(self)

Returns the platform-specific number identifying the format.

Returns:
int

SetId(self, format)

Sets the format to be the custom format identified by the given name.

Parameters:
format
(type=String)

SetType(self, format)

Sets the format to the given value, which should be one of wx.DF_XXX constants.

Parameters:
format
(type=int)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:40 2005 http://epydoc.sf.net


wx.DataObject

Package wx :: Class DataObject

Type DataObject

object --+
         |
        DataObject

Known Subclasses:
DataObjectComposite, DataObjectSimple

A wx.DataObject represents data that can be copied to or from the clipboard, or dragged and dropped. The important thing about wx.DataObject is that this is a 'smart' piece of data unlike usual 'dumb' data containers such as memory buffers or files. Being 'smart' here means that the data object itself should know what data formats it supports and how to render itself in each of supported formats.

NOTE: This class is an abstract base class and can not be used directly from Python. If you need a custom type of data object then you should instead derive from wx.PyDataObjectSimple or use wx.CustomDataObject.

Not surprisingly, being 'smart' comes at a price of added complexity. This is reasonable for the situations when you really need to support multiple formats, but may be annoying if you only want to do something simple like cut and paste text.

To provide a solution for both cases, wxWidgets has two predefined classes which derive from wx.DataObject: wx.DataObjectSimple and wx.DataObjectComposite. wx.DataObjectSimple is the simplest wx.DataObject possible and only holds data in a single format (such as text or bitmap) and wx.DataObjectComposite is the simplest way to implement a wx.DataObject which supports multiple simultaneous formats because it achievs this by simply holding several wx.DataObjectSimple objects.

Please note that the easiest way to use drag and drop and the clipboard with multiple formats is by using wx.DataObjectComposite, but it is not the most efficient one as each wx.DataObjectSimple would contain the whole data in its respective formats. Now imagine that you want to paste 200 pages of text in your proprietary format, as well as Word, RTF, HTML, Unicode and plain text to the clipboard and even today's computers are in trouble. For this case, you will have to derive from wx.DataObject directly and make it enumerate its formats and provide the data in the requested format on demand. (TODO: This is currently not possible from Python. Make it so.)

Note that the platform transfer mechanisms for the clipboard and drag and drop, do not copy any data out of the source application until another application actually requests the data. This is in contrast to the 'feel' offered to the user of a program who would normally think that the data resides in the clipboard after having pressed 'Copy' - in reality it is only declared to be available.

Method Summary
 | __init__(self)
 | __del__(self)
 | __repr__(self)
[formats] | GetAllFormats(self, dir) Returns a list of all the wx.DataFormats that this dataobject supports in the given direction.
String | GetDataHere(self, format) Get the data bytes in the specified format, returns None on failure.
size_t | GetDataSize(self, format) Get the (total) size of data for the given format
size_t | GetFormatCount(self, dir) Returns the number of available formats for rendering or setting the data.
DataFormat | GetPreferredFormat(self, dir) Returns the preferred format for either rendering the data (if dir is Get, its default value) or for setting it.
bool | IsSupported(self, format, dir) Returns True if this format is supported.
bool | SetData(self, format, data) Set the data in the specified format from the bytes in the the data string.

Class Variable Summary
int | Both = 3
int | Get = 1
int | Set = 2

Method Details

GetAllFormats(self, dir=Get)

Returns a list of all the wx.DataFormats that this dataobject supports in the given direction.

Parameters:
dir
(type=int)

Returns:
[formats]

GetDataHere(self, format)

Get the data bytes in the specified format, returns None on failure.

Parameters:
format
(type=DataFormat)

Returns:
String

To Do:

This should use the python buffer interface isntead...

GetDataSize(self, format)

Get the (total) size of data for the given format

Parameters:
format
(type=DataFormat)

Returns:
size_t

GetFormatCount(self, dir=Get)

Returns the number of available formats for rendering or setting the data.

Parameters:
dir
(type=int)

Returns:
size_t

GetPreferredFormat(self, dir=Get)

Returns the preferred format for either rendering the data (if dir is Get, its default value) or for setting it. Usually this will be the native format of the wx.DataObject.

Parameters:
dir
(type=int)

Returns:
DataFormat

IsSupported(self, format, dir=Get)

Returns True if this format is supported.

Parameters:
format
(type=DataFormat)

dir
(type=int)

Returns:
bool

SetData(self, format, data)

Set the data in the specified format from the bytes in the the data string.

Parameters:
format
(type=DataFormat)

data
(type=String)

Returns:
bool

To Do:

This should use the python buffer interface isntead...

Class Variable Details

Both

Type:
int
Value:
3

Get

Type:
int
Value:
1

Set

Type:
int
Value:
2

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:03 2005 http://epydoc.sf.net


wx.DataObjectComposite

Package wx :: Class DataObjectComposite

Type DataObjectComposite

object --+
         |
DataObject --+
             |
            DataObjectComposite

Known Subclasses:
URLDataObject

wx.DataObjectComposite is the simplest wx.DataObject derivation which may be sued to support multiple formats. It contains several 'wx.DataObjectSimple` objects and supports any format supported by at least one of them. Only one of these data objects is preferred (the first one if not explicitly changed by using the second parameter of Add) and its format determines the preferred format of the composite data object as well.

See wx.DataObject documentation for the reasons why you might prefer to use wx.DataObject directly instead of wx.DataObjectComposite for efficiency reasons.

Method Summary
DataObjectComposite | __init__(self) wx.DataObjectComposite is the simplest wx.DataObject derivation which may be sued to support multiple formats.
 | __repr__(self)
 | Add(self, dataObject, preferred) Adds the dataObject to the list of supported objects and it becomes the preferred object if preferred is True.

Class Variable Summary

Method Details

__init__(self)
(Constructor)

wx.DataObjectComposite is the simplest wx.DataObject derivation which may be sued to support multiple formats. It contains several 'wx.DataObjectSimple` objects and supports any format supported by at least one of them. Only one of these data objects is preferred (the first one if not explicitly changed by using the second parameter of Add) and its format determines the preferred format of the composite data object as well.

See wx.DataObject documentation for the reasons why you might prefer to use wx.DataObject directly instead of wx.DataObjectComposite for efficiency reasons.

Returns:
DataObjectComposite
Overrides:
wx.DataObject.__init__

Add(self, dataObject, preferred=False)

Adds the dataObject to the list of supported objects and it becomes the preferred object if preferred is True.

Parameters:
dataObject
(type=DataObjectSimple)

preferred
(type=bool)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:09 2005 http://epydoc.sf.net


wx.DataObjectSimple

Package wx :: Class DataObjectSimple

Type DataObjectSimple

object --+
         |
DataObject --+
             |
            DataObjectSimple

Known Subclasses:
BitmapDataObject, CustomDataObject, FileDataObject, MetafileDataObject, PyDataObjectSimple, TextDataObject

wx.DataObjectSimple is a wx.DataObject which only supports one format. This is the simplest possible wx.DataObject implementation.

This is still an "abstract base class" meaning that you can't use it directly. You either need to use one of the predefined base classes, or derive your own class from wx.PyDataObjectSimple.

Method Summary
DataObjectSimple | __init__(self, format) Constructor accepts the supported format (none by default) which may also be set later with SetFormat.
 | __repr__(self)
String | GetDataHere(self) Returns the data bytes from the data object as a string, returns None on failure.
size_t | GetDataSize(self) Get the size of our data.
DataFormat | GetFormat(self) Returns the (one and only one) format supported by this object.
bool | SetData(self, data) Copy the data value to the data object.
 | SetFormat(self, format) Sets the supported format.

Class Variable Summary

Method Details

__init__(self, format=FormatInvalid)
(Constructor)

Constructor accepts the supported format (none by default) which may also be set later with SetFormat.

Parameters:
format
(type=DataFormat)

Returns:
DataObjectSimple
Overrides:
wx.DataObject.__init__

GetDataHere(self)

Returns the data bytes from the data object as a string, returns None on failure. Must be implemented in the derived class if the object supports rendering its data.

Returns:
String
Overrides:
wx.DataObject.GetDataHere

GetDataSize(self)

Get the size of our data.

Returns:
size_t
Overrides:
wx.DataObject.GetDataSize

GetFormat(self)

Returns the (one and only one) format supported by this object. It is assumed that the format is supported in both directions.

Returns:
DataFormat

SetData(self, data)

Copy the data value to the data object. Must be implemented in the derived class if the object supports setting its data.

Parameters:
data
(type=String)

Returns:
bool
Overrides:
wx.DataObject.SetData

SetFormat(self, format)

Sets the supported format.

Parameters:
format
(type=DataFormat)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:44 2005 http://epydoc.sf.net


wx.DateEvent

Package wx :: Class DateEvent

Type DateEvent

object --+
         |
    Object --+
             |
         Event --+
                 |
      CommandEvent --+
                     |
                    DateEvent

Known Subclasses:
CalendarEvent

This event class holds information about a date change event and is used together with wx.DatePickerCtrl. It also serves as a base class for wx.calendar.CalendarEvent. Bind these event types with EVT_DATE_CHANGED.

Method Summary
CommandEvent | __init__(self, commandType, winid) This event class contains information about command events, which originate from a variety of simple controls, as well as menus and toolbars.
 | __repr__(self)
DateTime | GetDate(self) Returns the date.
 | SetDate(self, date) Sets the date carried by the event, normally only used by the library internally.

Method Details

__init__(self, win, dt, type)
(Constructor)

This event class contains information about command events, which originate from a variety of simple controls, as well as menus and toolbars.

Parameters:
commandType
(type=wxEventType)

winid
(type=int)

Returns:
CommandEvent
Overrides:
wx.CommandEvent.__init__ (inherited documentation)

GetDate(self)

Returns the date.

Returns:
DateTime

SetDate(self, date)

Sets the date carried by the event, normally only used by the library internally.

Parameters:
date
(type=DateTime)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:19 2005 http://epydoc.sf.net


wx.DatePickerCtrl

Package wx :: Class DatePickerCtrl

Type DatePickerCtrl

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
               Control --+
                         |
                        DatePickerCtrl

This control allows the user to select a date. Unlike wx.calendar.CalendarCtrl, which is a relatively big control, wx.DatePickerCtrl is implemented as a small window showing the currently selected date. The control can be edited using the keyboard, and can also display a popup window for more user-friendly date selection, depending on the styles used and the platform.

Styles

wx.DP_SPIN | Creates a control without month calendar drop down but with spin control-like arrows to change individual date components. This style is not supported by the generic version.
wx.DP_DROPDOWN | Creates a control with a month calendar drop down part from which the user can select a date.
wx.DP_DEFAULT | Creates a control with default style which is the best supported for the current platform (currently wx.DP_SPIN under Windows and wx.DP_DROPDOWN elsewhere).
wx.DP_ALLOWNONE | With this style, the control allows the user to not enter any valid date at all. Without it -- which is by default -- the control always has some valid date.
wx.DP_SHOWCENTURY | Forces display of the century in the default date format. Without this flas the century could be displayed or not depending on the default date representation in the system.

Events

EVT_DATE_CHANGED This event fires when the user changes the current selection in the control.

See Also:

wx.calendar.CalendarCtrl, wx.DateEvent

Method Summary
DatePickerCtrl | __init__(self, parent, id, dt, pos, size, style, validator, name) Create a new DatePickerCtrl.
 | __repr__(self)
bool | Create(self, parent, id, dt, pos, size, style, validator, name) Create the GUI parts of the DatePickerCtrl, for use in 2-phase creation.
DateTime | GetLowerLimit(self) Get the lower limit of the valid range for the date selection, if any.
DateTime | GetUpperLimit(self) Get the upper limit of the valid range for the date selection, if any.
DateTime | GetValue(self) Returns the currently selected date.
 | SetRange(self, dt1, dt2) Sets the valid range for the date selection.
 | SetValue(self, dt) Changes the current value of the control.

Instance Method Details

__init__(self,
          parent,
          id=-1,
          dt=wxDefaultDateTime,
          pos=DefaultPosition,
          size=DefaultSize,
          style=wxDP_DEFAULT|wxDP_SHOWCENTURY,
          validator=DefaultValidator,
          name=DatePickerCtrlNameStr)
(Constructor)

Create a new DatePickerCtrl.

Parameters:
parent
(type=Window)

id
(type=int)

dt
(type=DateTime)

pos
(type=Point)

size
(type=Size)

style
(type=long)

validator
(type=Validator)

name
(type=String)

Returns:
DatePickerCtrl
Overrides:
wx.Control.__init__

Create(self,
          parent,
          id=-1,
          dt=wxDefaultDateTime,
          pos=DefaultPosition,
          size=DefaultSize,
          style=wxDP_DEFAULT|wxDP_SHOWCENTURY,
          validator=DefaultValidator,
          name=DatePickerCtrlNameStr)

Create the GUI parts of the DatePickerCtrl, for use in 2-phase creation.

Parameters:
parent
(type=Window)

id
(type=int)

dt
(type=DateTime)

pos
(type=Point)

size
(type=Size)

style
(type=long)

validator
(type=Validator)

name
(type=String)

Returns:
bool
Overrides:
wx.Control.Create

GetLowerLimit(self)

Get the lower limit of the valid range for the date selection, if any. If there is no range or there is no lower limit, then the wx.DateTime value returned will be invalid.

Returns:
DateTime

GetUpperLimit(self)

Get the upper limit of the valid range for the date selection, if any. If there is no range or there is no upper limit, then the wx.DateTime value returned will be invalid.

Returns:
DateTime

GetValue(self)

Returns the currently selected date. If there is no selection or the selection is outside of the current range, an invalid wx.DateTime object is returned.

Returns:
DateTime

SetRange(self, dt1, dt2)

Sets the valid range for the date selection. If dt1 is valid, it becomes the earliest date (inclusive) accepted by the control. If dt2 is valid, it becomes the latest possible date.

If the current value of the control is outside of the newly set range bounds, the behaviour is undefined.

Parameters:
dt1
(type=DateTime)

dt2
(type=DateTime)

SetValue(self, dt)

Changes the current value of the control. The date should be valid and included in the currently selected range, if any.

Calling this method does not result in a date change event.

Parameters:
dt
(type=DateTime)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:10:55 2005 http://epydoc.sf.net


wx.DateSpan

Package wx :: Class DateSpan

Type DateSpan

object --+
         |
        DateSpan

Proxy of C++ DateSpan class

Method Summary
DateSpan | __init__(self, years, months, weeks, days)
DateSpan | __add__(self, other)
 | __del__(self)
bool | __eq__(self, other)
DateSpan | __iadd__(self, other)
DateSpan | __imul__(self, factor)
DateSpan | __isub__(self, other)
DateSpan | __mul__(self, n)
bool | __ne__(self, other)
DateSpan | __neg__(self)
 | __repr__(self)
DateSpan | __rmul__(self, n)
DateSpan | __sub__(self, other)
DateSpan | Add(self, other)
DateSpan | Day() (Static method)
DateSpan | Days(days) (Static method)
int | GetDays(self)
int | GetMonths(self)
int | GetTotalDays(self)
int | GetWeeks(self)
int | GetYears(self)
DateSpan | Month() (Static method)
DateSpan | Months(mon) (Static method)
DateSpan | Multiply(self, factor)
DateSpan | Neg(self)
DateSpan | SetDays(self, n)
DateSpan | SetMonths(self, n)
DateSpan | SetWeeks(self, n)
DateSpan | SetYears(self, n)
DateSpan | Subtract(self, other)
DateSpan | Week() (Static method)
DateSpan | Weeks(weeks) (Static method)
DateSpan | Year() (Static method)
DateSpan | Years(years) (Static method)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:10 2005 http://epydoc.sf.net


wx.DateTime

Package wx :: Class DateTime

Type DateTime

object --+
         |
        DateTime

Proxy of C++ DateTime class

Method Summary
DateTime | __init__(self)
DateTime __add__(self, other)
__add__(self, DateSpan other) -> DateTime
__del__(self)
bool | __eq__(self, other)
bool | __ge__(self, other)
bool | __gt__(self, other)
DateTime __iadd__(self, diff)
__iadd__(self, DateSpan diff) -> DateTime
DateTime __isub__(self, diff)
__isub__(self, DateSpan diff) -> DateTime
bool | __le__(self, other)
bool | __lt__(self, other)
bool | __ne__(self, other)
__nonzero__(self)
__repr__(self)
__str__(self)
TimeSpan __sub__(self, other)
__sub__(self, TimeSpan other) -> DateTime __sub__(self, DateSpan other) -> DateTime
DateTime | AddDS(self, diff)
DateTime | AddTS(self, diff)
int ConvertYearToBC(year)
(Static method)
String | Format(self, format, tz)
String | FormatDate(self)
String | FormatISODate(self)
String | FormatISOTime(self)
String | FormatTime(self)
(am, pm) GetAmPmStrings()
Get the AM and PM strings in the current locale (may be empty) (Static method)
DateTime GetBeginDST(year, country)
(Static method)
int GetCentury(year)
(Static method)
int GetCountry()
(Static method)
int GetCurrentMonth(cal)
(Static method)
int GetCurrentYear(cal)
(Static method)
GetDay(*args, **kwargs)
GetDay(self, wxDateTime::TimeZone tz=LOCAL_TZ) -> int
GetDayOfYear(*args, **kwargs)
GetDayOfYear(self, wxDateTime::TimeZone tz=LOCAL_TZ) -> int
DateTime GetEndDST(year, country)
(Static method)
GetHour(*args, **kwargs)
GetHour(self, wxDateTime::TimeZone tz=LOCAL_TZ) -> int
double | GetJDN(self)
double | GetJulianDayNumber(self)
DateTime | GetLastMonthDay(self, month, year)
DateTime | GetLastWeekDay(self, weekday, month, year)
GetMillisecond(*args, **kwargs)
GetMillisecond(self, wxDateTime::TimeZone tz=LOCAL_TZ) -> int
GetMinute(*args, **kwargs)
GetMinute(self, wxDateTime::TimeZone tz=LOCAL_TZ) -> int
double | GetMJD(self)
double | GetModifiedJulianDayNumber(self)
GetMonth(*args, **kwargs)
GetMonth(self, wxDateTime::TimeZone tz=LOCAL_TZ) -> int
String GetMonthName(month, flags)
(Static method)
DateTime | GetNextWeekDay(self, weekday)
int GetNumberOfDaysInMonth(month, year, cal)
(Static method)
int GetNumberOfDaysinYear(year, cal)
(Static method)
DateTime | GetPrevWeekDay(self, weekday)
double | GetRataDie(self)
GetSecond(*args, **kwargs)
GetSecond(self, wxDateTime::TimeZone tz=LOCAL_TZ) -> int
time_t | GetTicks(self)
GetWeek(*args, **kwargs)
GetWeek is deprecated, use GetWeekOfYear instead
GetWeekDay(*args, **kwargs)
GetWeekDay(self, wxDateTime::TimeZone tz=LOCAL_TZ) -> int
DateTime | GetWeekDayInSameWeek(self, weekday, flags)
String GetWeekDayName(weekday, flags)
(Static method)
int | GetWeekOfMonth(self, flags, tz)
int | GetWeekOfYear(self, flags, tz)
GetYear(*args, **kwargs)
GetYear(self, wxDateTime::TimeZone tz=LOCAL_TZ) -> int
DateTime | GetYearDay(self, yday)
bool | IsBetween(self, t1, t2)
int | IsDST(self, country)
bool IsDSTApplicable(year, country)
(Static method)
bool | IsEarlierThan(self, datetime)
bool | IsEqualTo(self, datetime)
bool | IsEqualUpTo(self, dt, ts)
bool | IsLaterThan(self, datetime)
bool IsLeapYear(year, cal)
(Static method)
bool | IsSameDate(self, dt)
bool | IsSameTime(self, dt)
bool | IsStrictlyBetween(self, t1, t2)
bool | IsValid(self)
bool IsWestEuropeanCountry(country)
(Static method)
bool | IsWorkDay(self, country)
DateTime | MakeGMT(self, noDST)
MakeTimezone(*args, **kwargs)
MakeTimezone(self, wxDateTime::TimeZone tz, bool noDST=False) -> DateTime
DateTime Now()
(Static method)
bool | Ok(self)
int | ParseDate(self, date)
int | ParseDateTime(self, datetime)
int | ParseFormat(self, date, format, dateDef)
int | ParseRfc822Date(self, date)
int | ParseTime(self, time)
DateTime | ResetTime(self)
DateTime | Set(self, day, month, year, hour, minute, second, millisec)
SetCountry(country)
(Static method)
DateTime | SetDay(self, day)
DateTime | SetHMS(self, hour, minute, second, millisec)
DateTime | SetHour(self, hour)
DateTime | SetJDN(self, jdn)
DateTime | SetMillisecond(self, millisecond)
DateTime | SetMinute(self, minute)
DateTime | SetMonth(self, month)
DateTime | SetSecond(self, second)
DateTime | SetTimeT(self, timet)
DateTime | SetToCurrent(self)
DateTime | SetToLastMonthDay(self, month, year)
bool | SetToLastWeekDay(self, weekday, month, year)
DateTime | SetToNextWeekDay(self, weekday)
DateTime | SetToPrevWeekDay(self, weekday)
SetToTheWeek(*args, **kwargs)
SetToTheWeek is deprecated, use (static) SetToWeekOfYear instead
bool | SetToWeekDay(self, weekday, n, month, year)
DateTime | SetToWeekDayInSameWeek(self, weekday, flags)
DateTime SetToWeekOfYear(year, numWeek, weekday)
(Static method)
DateTime | SetToYearDay(self, yday)
DateTime | SetYear(self, year)
TimeSpan | Subtract(self, dt)
DateTime | SubtractDS(self, diff)
DateTime | SubtractTS(self, diff)
DateTime Today()
(Static method)
DateTime | ToGMT(self, noDST)
ToTimezone(*args, **kwargs)
ToTimezone(self, wxDateTime::TimeZone tz, bool noDST=False) -> DateTime
DateTime UNow()
(Static method)

Class Variable Summary
int | A_CST = 26
int | A_ESST = 24
int | A_EST = 23
int | A_WST = 21
int | ADT = 10
int | AKDT = 5
int | AKST = 4
int | Apr = 3
int | AST = 9
int | Aug = 7
int | CDT = 8
int | CEST = 15
int | CET = 14
int | Country_Default = 1
int | Country_EEC = 2
int | Country_Unknown = 0
int | Country_WesternEurope_End = 5
int | Country_WesternEurope_Start = 2
int | CST = 7
int | Dec = 11
int | Default_First = 0
int | EDT = 9
int | EEST = 16
int | EET = 15
int | EST = 8
int | Feb = 1
int | France = 3
int | Fri = 5
int | Germany = 4
int | GMT0 = 13
int | GMT1 = 14
int | GMT10 = 23
int | GMT11 = 24
int | GMT12 = 25
int | GMT2 = 15
int | GMT3 = 16
int | GMT4 = 17
int | GMT5 = 18
int | GMT6 = 19
int | GMT7 = 20
int | GMT8 = 21
int | GMT9 = 22
int | GMT_1 = 12
int | GMT_10 = 3
int | GMT_11 = 2
int | GMT_12 = 1
int | GMT_2 = 11
int | GMT_3 = 10
int | GMT_4 = 9
int | GMT_5 = 8
int | GMT_6 = 7
int | GMT_7 = 6
int | GMT_8 = 5
int | GMT_9 = 4
int | Gr_Alaska = 2
int | Gr_Albania = 3
int | Gr_Austria = 0
int | Gr_Austria_Brixen = 1
int | Gr_Austria_Carinthia = 2
int | Gr_Austria_Salzburg = 1
int | Gr_Austria_Styria = 2
int | Gr_Austria_Tyrol = 1
int | Gr_Belgium = 3
int | Gr_Bulgaria = 0
int | Gr_Bulgaria_1 = 1
int | Gr_Bulgaria_2 = 2
int | Gr_Bulgaria_3 = 3
int | Gr_Canada = 0
int | Gr_China = 0
int | Gr_China_1 = 1
int | Gr_China_2 = 2
int | Gr_Czechoslovakia = 3
int | Gr_Denmark = 4
int | Gr_Egypt = 5
int | Gr_Estonia = 6
int | Gr_Finland = 7
int | Gr_France = 8
int | Gr_France_Alsace = 9
int | Gr_France_Lorraine = 10
int | Gr_France_Strasbourg = 11
int | Gr_Germany = 0
int | Gr_Germany_Catholic = 1
int | Gr_Germany_Protestant = 3
int | Gr_Germany_Prussia = 2
int | Gr_GreatBritain = 4
int | Gr_Greece = 5
int | Gr_Hungary = 6
int | Gr_Ireland = 4
int | Gr_Italy = 1
int | Gr_Japan = 0
int | Gr_Japan_1 = 1
int | Gr_Japan_2 = 2
int | Gr_Japan_3 = 3
int | Gr_Latvia = 4
int | Gr_Lithuania = 5
int | Gr_Luxemburg = 6
int | Gr_Netherlands = 3
int | Gr_Netherlands_Friesland = 7
int | Gr_Netherlands_Gelderland = 5
int | Gr_Netherlands_Groningen = 4
int | Gr_Netherlands_Utrecht = 6
int | Gr_Norway = 4
int | Gr_Poland = 1
int | Gr_Portugal = 1
int | Gr_Romania = 2
int | Gr_Russia = 3
int | Gr_Scotland = 4
int | Gr_Spain = 1
int | Gr_Standard = 1
int | Gr_Sweden = 7
int | Gr_Switzerland = 0
int | Gr_Switzerland_Catholic = 1
int | Gr_Switzerland_Protestant = 2
int | Gr_Turkey = 3
int | Gr_Unknown = 0
int | Gr_USA = 4
int | Gr_Wales = 4
int | Gr_Yugoslavia = 5
int | Gregorian = 0
int | HST = 3
int | Inv_Month = 12
int | Inv_WeekDay = 7
int | Inv_Year = -32768
int | Jan = 0
int | Jul = 6
int | Julian = 1
int | Jun = 5
int | Local = 0
int | Mar = 2
int | May = 4
int | MDT = 7
int | Mon = 1
int | Monday_First = 1
int | MSD = 17
int | MSK = 16
int | MST = 6
int | Name_Abbr = 2
int | Name_Full = 1
int | Nov = 10
int | Oct = 9
int | PDT = 6
int | PST = 5
int | Russia = 6
int | Sat = 6
int | Sep = 8
int | Sun = 0
int | Sunday_First = 2
int | Thu = 4
int | Tue = 2
int | UK = 5
int | USA = 7
int | UTC = 13
int | Wed = 3
int | WEST = 14
int | WET = 13

Instance Method Details

__add__(self, other)
(Addition operator)

__add__(self, DateSpan other) -> DateTime

Parameters:
other
(type=TimeSpan)

Returns:
DateTime

__iadd__(self, diff)

__iadd__(self, DateSpan diff) -> DateTime

Parameters:
diff
(type=TimeSpan)

Returns:
DateTime

__isub__(self, diff)

__isub__(self, DateSpan diff) -> DateTime

Parameters:
diff
(type=TimeSpan)

Returns:
DateTime

__sub__(self, other)
(Subtraction operator)

__sub__(self, TimeSpan other) -> DateTime __sub__(self, DateSpan other) -> DateTime

Parameters:
other
(type=DateTime)

Returns:
TimeSpan

GetDay(*args, **kwargs)

GetDay(self, wxDateTime::TimeZone tz=LOCAL_TZ) -> int

GetDayOfYear(*args, **kwargs)

GetDayOfYear(self, wxDateTime::TimeZone tz=LOCAL_TZ) -> int

GetHour(*args, **kwargs)

GetHour(self, wxDateTime::TimeZone tz=LOCAL_TZ) -> int

GetMillisecond(*args, **kwargs)

GetMillisecond(self, wxDateTime::TimeZone tz=LOCAL_TZ) -> int

GetMinute(*args, **kwargs)

GetMinute(self, wxDateTime::TimeZone tz=LOCAL_TZ) -> int

GetMonth(*args, **kwargs)

GetMonth(self, wxDateTime::TimeZone tz=LOCAL_TZ) -> int

GetSecond(*args, **kwargs)

GetSecond(self, wxDateTime::TimeZone tz=LOCAL_TZ) -> int

GetWeek(*args, **kwargs)

GetWeek is deprecated, use GetWeekOfYear instead

GetWeekDay(*args, **kwargs)

GetWeekDay(self, wxDateTime::TimeZone tz=LOCAL_TZ) -> int

GetYear(*args, **kwargs)

GetYear(self, wxDateTime::TimeZone tz=LOCAL_TZ) -> int

MakeTimezone(*args, **kwargs)

MakeTimezone(self, wxDateTime::TimeZone tz, bool noDST=False) -> DateTime

SetToTheWeek(*args, **kwargs)

SetToTheWeek is deprecated, use (static) SetToWeekOfYear instead

ToTimezone(*args, **kwargs)

ToTimezone(self, wxDateTime::TimeZone tz, bool noDST=False) -> DateTime

Static Method Details

GetAmPmStrings()

Get the AM and PM strings in the current locale (may be empty)

Returns:
(am, pm)

Class Variable Details

A_CST

Type:
int
Value:
26

A_ESST

Type:
int
Value:
24

A_EST

Type:
int
Value:
23

A_WST

Type:
int
Value:
21

ADT

Type:
int
Value:
10

AKDT

Type:
int
Value:
5

AKST

Type:
int
Value:
4

Apr

Type:
int
Value:
3

AST

Type:
int
Value:
9

Aug

Type:
int
Value:
7

CDT

Type:
int
Value:
8

CEST

Type:
int
Value:
15

CET

Type:
int
Value:
14

Country_Default

Type:
int
Value:
1

Country_EEC

Type:
int
Value:
2

Country_Unknown

Type:
int
Value:
0

Country_WesternEurope_End

Type:
int
Value:
5

Country_WesternEurope_Start

Type:
int
Value:
2

CST

Type:
int
Value:
7

Dec

Type:
int
Value:
11

Default_First

Type:
int
Value:
0

EDT

Type:
int
Value:
9

EEST

Type:
int
Value:
16

EET

Type:
int
Value:
15

EST

Type:
int
Value:
8

Feb

Type:
int
Value:
1

France

Type:
int
Value:
3

Fri

Type:
int
Value:
5

Germany

Type:
int
Value:
4

GMT0

Type:
int
Value:
13

GMT1

Type:
int
Value:
14

GMT10

Type:
int
Value:
23

GMT11

Type:
int
Value:
24

GMT12

Type:
int
Value:
25

GMT2

Type:
int
Value:
15

GMT3

Type:
int
Value:
16

GMT4

Type:
int
Value:
17

GMT5

Type:
int
Value:
18

GMT6

Type:
int
Value:
19

GMT7

Type:
int
Value:
20

GMT8

Type:
int
Value:
21

GMT9

Type:
int
Value:
22

GMT_1

Type:
int
Value:
12

GMT_10

Type:
int
Value:
3

GMT_11

Type:
int
Value:
2

GMT_12

Type:
int
Value:
1

GMT_2

Type:
int
Value:
11

GMT_3

Type:
int
Value:
10

GMT_4

Type:
int
Value:
9

GMT_5

Type:
int
Value:
8

GMT_6

Type:
int
Value:
7

GMT_7

Type:
int
Value:
6

GMT_8

Type:
int
Value:
5

GMT_9

Type:
int
Value:
4

Gr_Alaska

Type:
int
Value:
2

Gr_Albania

Type:
int
Value:
3

Gr_Austria

Type:
int
Value:
0

Gr_Austria_Brixen

Type:
int
Value:
1

Gr_Austria_Carinthia

Type:
int
Value:
2

Gr_Austria_Salzburg

Type:
int
Value:
1

Gr_Austria_Styria

Type:
int
Value:
2

Gr_Austria_Tyrol

Type:
int
Value:
1

Gr_Belgium

Type:
int
Value:
3

Gr_Bulgaria

Type:
int
Value:
0

Gr_Bulgaria_1

Type:
int
Value:
1

Gr_Bulgaria_2

Type:
int
Value:
2

Gr_Bulgaria_3

Type:
int
Value:
3

Gr_Canada

Type:
int
Value:
0

Gr_China

Type:
int
Value:
0

Gr_China_1

Type:
int
Value:
1

Gr_China_2

Type:
int
Value:
2

Gr_Czechoslovakia

Type:
int
Value:
3

Gr_Denmark

Type:
int
Value:
4

Gr_Egypt

Type:
int
Value:
5

Gr_Estonia

Type:
int
Value:
6

Gr_Finland

Type:
int
Value:
7

Gr_France

Type:
int
Value:
8

Gr_France_Alsace

Type:
int
Value:
9

Gr_France_Lorraine

Type:
int
Value:
10

Gr_France_Strasbourg

Type:
int
Value:
11

Gr_Germany

Type:
int
Value:
0

Gr_Germany_Catholic

Type:
int
Value:
1

Gr_Germany_Protestant

Type:
int
Value:
3

Gr_Germany_Prussia

Type:
int
Value:
2

Gr_GreatBritain

Type:
int
Value:
4

Gr_Greece

Type:
int
Value:
5

Gr_Hungary

Type:
int
Value:
6

Gr_Ireland

Type:
int
Value:
4

Gr_Italy

Type:
int
Value:
1

Gr_Japan

Type:
int
Value:
0

Gr_Japan_1

Type:
int
Value:
1

Gr_Japan_2

Type:
int
Value:
2

Gr_Japan_3

Type:
int
Value:
3

Gr_Latvia

Type:
int
Value:
4

Gr_Lithuania

Type:
int
Value:
5

Gr_Luxemburg

Type:
int
Value:
6

Gr_Netherlands

Type:
int
Value:
3

Gr_Netherlands_Friesland

Type:
int
Value:
7

Gr_Netherlands_Gelderland

Type:
int
Value:
5

Gr_Netherlands_Groningen

Type:
int
Value:
4

Gr_Netherlands_Utrecht

Type:
int
Value:
6

Gr_Norway

Type:
int
Value:
4

Gr_Poland

Type:
int
Value:
1

Gr_Portugal

Type:
int
Value:
1

Gr_Romania

Type:
int
Value:
2

Gr_Russia

Type:
int
Value:
3

Gr_Scotland

Type:
int
Value:
4

Gr_Spain

Type:
int
Value:
1

Gr_Standard

Type:
int
Value:
1

Gr_Sweden

Type:
int
Value:
7

Gr_Switzerland

Type:
int
Value:
0

Gr_Switzerland_Catholic

Type:
int
Value:
1

Gr_Switzerland_Protestant

Type:
int
Value:
2

Gr_Turkey

Type:
int
Value:
3

Gr_Unknown

Type:
int
Value:
0

Gr_USA

Type:
int
Value:
4

Gr_Wales

Type:
int
Value:
4

Gr_Yugoslavia

Type:
int
Value:
5

Gregorian

Type:
int
Value:
0

HST

Type:
int
Value:
3

Inv_Month

Type:
int
Value:
12

Inv_WeekDay

Type:
int
Value:
7

Inv_Year

Type:
int
Value:
-32768

Jan

Type:
int
Value:
0

Jul

Type:
int
Value:
6

Julian

Type:
int
Value:
1

Jun

Type:
int
Value:
5

Local

Type:
int
Value:
0

Mar

Type:
int
Value:
2

May

Type:
int
Value:
4

MDT

Type:
int
Value:
7

Mon

Type:
int
Value:
1

Monday_First

Type:
int
Value:
1

MSD

Type:
int
Value:
17

MSK

Type:
int
Value:
16

MST

Type:
int
Value:
6

Name_Abbr

Type:
int
Value:
2

Name_Full

Type:
int
Value:
1

Nov

Type:
int
Value:
10

Oct

Type:
int
Value:
9

PDT

Type:
int
Value:
6

PST

Type:
int
Value:
5

Russia

Type:
int
Value:
6

Sat

Type:
int
Value:
6

Sep

Type:
int
Value:
8

Sun

Type:
int
Value:
0

Sunday_First

Type:
int
Value:
2

Thu

Type:
int
Value:
4

Tue

Type:
int
Value:
2

UK

Type:
int
Value:
5

USA

Type:
int
Value:
7

UTC

Type:
int
Value:
13

Wed

Type:
int
Value:
3

WEST

Type:
int
Value:
14

WET

Type:
int
Value:
13

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:56 2005 http://epydoc.sf.net


wx.DC

Package wx :: Class DC

Type DC

object --+
         |
    Object --+
             |
            DC

Known Subclasses:
ClientDC, MemoryDC, MetaFileDC, MirrorDC, PaintDC, PostScriptDC, PrinterDC, ScreenDC, WindowDC

A wx.DC is a device context onto which graphics and text can be drawn. It is intended to represent a number of output devices in a generic way, so a window can have a device context associated with it, and a printer also has a device context. In this way, the same piece of code may write to a number of different devices, if the device context is used as a parameter.

Derived types of wxDC have documentation for specific features only, so refer to this section for most device context information.

The wx.DC class is abstract and can not be instantiated, you must use one of the derived classes instead. Which one will depend on the situation in which it is used.

Method Summary
 | __init__(self)
 | __del__(self)
 | __nonzero__(self)
 | __repr__(self)
 | BeginDrawing(self) Allows for optimization of drawing code on platforms that need it.
bool | Blit(self, xdest, ydest, width, height, source, xsrc, ysrc, rop, useMask, xsrcMask, ysrcMask) Copy from a source DC to this DC.
bool | BlitPointSize(self, destPt, sz, source, srcPt, rop, useMask, srcPtMask) Copy from a source DC to this DC.
 | CalcBoundingBox(self, x, y) Adds the specified point to the bounding box which can be retrieved with MinX, MaxX and MinY, MaxY or GetBoundingBox functions.
 | CalcBoundingBoxPoint(self, point) Adds the specified point to the bounding box which can be retrieved with MinX, MaxX and MinY, MaxY or GetBoundingBox functions.
bool | CanDrawBitmap(self)
bool | CanGetTextExtent(self)
 | Clear(self) Clears the device context using the current background brush.
 | ComputeScaleAndOrigin(self) Performs all necessary computations for given platform and context type after each change of scale and origin parameters.
 | CrossHair(self, x, y) Displays a cross hair using the current pen.
 | CrossHairPoint(self, pt) Displays a cross hair using the current pen.
 | DestroyClippingRegion(self) Destroys the current clipping region so that none of the DC is clipped.
int | DeviceToLogicalX(self, x) Convert device X coordinate to logical coordinate, using the current mapping mode.
int | DeviceToLogicalXRel(self, x) Convert device X coordinate to relative logical coordinate, using the current mapping mode but ignoring the x axis orientation.
int | DeviceToLogicalY(self, y) Converts device Y coordinate to logical coordinate, using the current mapping mode.
int | DeviceToLogicalYRel(self, y) Convert device Y coordinate to relative logical coordinate, using the current mapping mode but ignoring the y axis orientation.
 | DrawArc(self, x1, y1, x2, y2, xc, yc) Draws an arc of a circle, centred on the center point (xc, yc), from the first point to the second.
 | DrawArcPoint(self, pt1, pt2, center) Draws an arc of a circle, centred on the center point (xc, yc), from the first point to the second.
 | DrawBitmap(self, bmp, x, y, useMask) Draw a bitmap on the device context at the specified point.
 | DrawBitmapPoint(self, bmp, pt, useMask) Draw a bitmap on the device context at the specified point.
 | DrawCheckMark(self, x, y, width, height) Draws a check mark inside the given rectangle.
 | DrawCheckMarkRect(self, rect) Draws a check mark inside the given rectangle.
 | DrawCircle(self, x, y, radius) Draws a circle with the given center point and radius.
 | DrawCirclePoint(self, pt, radius) Draws a circle with the given center point and radius.
 | DrawEllipse(self, x, y, width, height) Draws an ellipse contained in the specified rectangle.
 | DrawEllipseList(self, ellipses, pens, brushes) Draw a list of ellipses as quickly as possible.
 | DrawEllipsePointSize(self, pt, sz) Draws an ellipse contained in the specified rectangle.
 | DrawEllipseRect(self, rect) Draws an ellipse contained in the specified rectangle.
 | DrawEllipticArc(self, x, y, w, h, start, end) Draws an arc of an ellipse, with the given rectangle defining the bounds of the ellipse.
 | DrawEllipticArcPointSize(self, pt, sz, start, end) Draws an arc of an ellipse, with the given rectangle defining the bounds of the ellipse.
 | DrawIcon(self, icon, x, y) Draw an icon on the display (does nothing if the device context is PostScript).
 | DrawIconPoint(self, icon, pt) Draw an icon on the display (does nothing if the device context is PostScript).
Rect | DrawImageLabel(self, text, image, rect, alignment, indexAccel) Draw text and an image (which may be wx.NullBitmap to skip drawing it) within the specified rectangle, abiding by the alignment flags.
 | DrawLabel(self, text, rect, alignment, indexAccel) Draw text within the specified rectangle, abiding by the alignment flags.
 | DrawLine(self, x1, y1, x2, y2) Draws a line from the first point to the second.
 | DrawLineList(self, lines, pens) Draw a list of lines as quickly as possible.
 | DrawLinePoint(self, pt1, pt2) Draws a line from the first point to the second.
 | DrawLines(self, points, xoffset, yoffset) Draws lines using a sequence of wx.Point objects, adding the optional offset coordinate.
 | DrawPoint(self, x, y) Draws a point using the current pen.
 | DrawPointList(self, points, pens) Draw a list of points as quickly as possible.
 | DrawPointPoint(self, pt) Draws a point using the current pen.
 | DrawPolygon(self, points, xoffset, yoffset, fillStyle) Draws a filled polygon using a sequence of wx.Point objects, adding the optional offset coordinate.
 | DrawPolygonList(self, polygons, pens, brushes) Draw a list of polygons, each of which is a list of points.
 | DrawRectangle(self, x, y, width, height) Draws a rectangle with the given top left corner, and with the given size.
 | DrawRectangleList(self, rectangles, pens, brushes) Draw a list of rectangles as quickly as possible.
 | DrawRectanglePointSize(self, pt, sz) Draws a rectangle with the given top left corner, and with the given size.
 | DrawRectangleRect(self, rect) Draws a rectangle with the given top left corner, and with the given size.
 | DrawRotatedText(self, text, x, y, angle) Draws the text rotated by angle degrees, if supported by the platform.
 | DrawRotatedTextPoint(self, text, pt, angle) Draws the text rotated by angle degrees, if supported by the platform.
 | DrawRoundedRectangle(self, x, y, width, height, radius) Draws a rectangle with the given top left corner, and with the given size.
 | DrawRoundedRectanglePointSize(self, pt, sz, radius) Draws a rectangle with the given top left corner, and with the given size.
 | DrawRoundedRectangleRect(self, r, radius) Draws a rectangle with the given top left corner, and with the given size.
 | DrawSpline(self, points) Draws a spline between all given control points, (a list of wx.Point objects) using the current pen.
 | DrawText(self, text, x, y) Draws a text string at the specified point, using the current text font, and the current text foreground and background colours.
 | DrawTextList(self, textList, coords, foregrounds, backgrounds) Draw a list of strings using a list of coordinants for positioning each string.
 | DrawTextPoint(self, text, pt) Draws a text string at the specified point, using the current text font, and the current text foreground and background colours.
 | EndDoc(self) Ends a document (only relevant when outputting to a printer).
 | EndDrawing(self) Ends the group of drawing primitives started with BeginDrawing, and invokes whatever optimization is available for this DC type on the current platform.
 | EndPage(self) Ends a document page (only relevant when outputting to a printer).
bool | FloodFill(self, x, y, col, style) Flood fills the device context starting from the given point, using the current brush colour, and using a style:
bool | FloodFillPoint(self, pt, col, style) Flood fills the device context starting from the given point, using the current brush colour, and using a style:
Brush | GetBackground(self) Gets the brush used for painting the background.
int | GetBackgroundMode(self) Returns the current background mode, either wx.SOLID or wx.TRANSPARENT.
(x1,y1, x2,y2) | GetBoundingBox() Returns the min and max points used in drawing commands so far.
Brush | GetBrush(self) Gets the current brush
int | GetCharHeight(self) Gets the character height of the currently set font.
int | GetCharWidth(self) Gets the average character width of the currently set font.
(x, y, width, height) | GetClippingBox() Gets the rectangle surrounding the current clipping region.
Rect | GetClippingRect(self) Gets the rectangle surrounding the current clipping region.
int | GetDepth(self) Returns the colour depth of the DC.
Point | GetDeviceOrigin(self)
(x,y) | GetDeviceOriginTuple()
Font | GetFont(self) Gets the current font
(width, height, descent, externalLeading) | GetFullTextExtent(string, font) Get the width, height, decent and leading of the text using the current or specified font.
int | GetLogicalFunction(self) Gets the current logical function (set by SetLogicalFunction).
Point | GetLogicalOrigin(self)
(x,y) | GetLogicalOriginTuple()
(xScale, yScale) | GetLogicalScale()
int | GetMapMode(self) Gets the current mapping mode for the device context
(width, height, descent, externalLeading) | GetMultiLineTextExtent(string, font) Get the width, height, decent and leading of the text using the current or specified font.
 | GetOptimization(*args, **kwargs) <function GetOptimization at 0xb7b68a04> is deprecated
[widths] | GetPartialTextExtents(self, text) Returns a list of integers such that each value is the distance in pixels from the begining of text to the coresponding character of text.
Pen | GetPen(self) Gets the current pen
Colour | GetPixel(self, x, y) Gets the colour at the specified location on the DC.
Colour | GetPixelPoint(self, pt)
Size | GetPPI(self) Resolution in Pixels per inch
Size | GetSize(self) This gets the horizontal and vertical resolution in device units.
Size | GetSizeMM(self) Get the DC size in milimeters.
(width, height) | GetSizeMMTuple() Get the DC size in milimeters.
(width, height) | GetSizeTuple() This gets the horizontal and vertical resolution in device units.
Colour | GetTextBackground(self) Gets the current text background colour
(width, height) | GetTextExtent(string) Get the width and height of the text using the current font.
Colour | GetTextForeground(self) Gets the current text foreground colour
(xScale, yScale) | GetUserScale(self) Gets the current user scale factor (set by SetUserScale).
int | LogicalToDeviceX(self, x) Converts logical X coordinate to device coordinate, using the current mapping mode.
int | LogicalToDeviceXRel(self, x) Converts logical X coordinate to relative device coordinate, using the current mapping mode but ignoring the x axis orientation.
int | LogicalToDeviceY(self, y) Converts logical Y coordinate to device coordinate, using the current mapping mode.
int | LogicalToDeviceYRel(self, y) Converts logical Y coordinate to relative device coordinate, using the current mapping mode but ignoring the y axis orientation.
int | MaxX(self) Gets the maximum horizontal extent used in drawing commands so far.
int | MaxY(self) Gets the maximum vertical extent used in drawing commands so far.
int | MinX(self) Gets the minimum horizontal extent used in drawing commands so far.
int | MinY(self) Gets the minimum vertical extent used in drawing commands so far.
bool | Ok(self) Returns true if the DC is ok to use.
 | ResetBoundingBox(self) Resets the bounding box: after a call to this function, the bounding box doesn't contain anything.
 | SetAxisOrientation(self, xLeftRight, yBottomUp) Sets the x and y axis orientation (i.e., the direction from lowest to highest values on the axis).
 | SetBackground(self, brush) Sets the current background brush for the DC.
 | SetBackgroundMode(self, mode) mode may be one of wx.SOLID and wx.TRANSPARENT.
 | SetBrush(self, brush) Sets the current brush for the DC.
 | SetClippingRect(self, rect) Sets the clipping region for this device context to the intersection of the given region described by the parameters of this method and the previously set clipping region.
 | SetClippingRegion(self, x, y, width, height) Sets the clipping region for this device context to the intersection of the given region described by the parameters of this method and the previously set clipping region.
 | SetClippingRegionAsRegion(self, region) Sets the clipping region for this device context to the intersection of the given region described by the parameters of this method and the previously set clipping region.
 | SetClippingRegionPointSize(self, pt, sz) Sets the clipping region for this device context to the intersection of the given region described by the parameters of this method and the previously set clipping region.
 | SetDeviceOrigin(self, x, y)
 | SetDeviceOriginPoint(self, point)
 | SetFont(self, font) Sets the current font for the DC.
 | SetLogicalFunction(self, function) Sets the current logical function for the device context.
 | SetLogicalOrigin(self, x, y)
 | SetLogicalOriginPoint(self, point)
 | SetLogicalScale(self, x, y)
 | SetMapMode(self, mode) The mapping mode of the device context defines the unit of measurement used to convert logical units to device units.
 | SetOptimization(*args, **kwargs) <function SetOptimization at 0xb7b689cc> is deprecated
 | SetPalette(self, palette) If this is a window DC or memory DC, assigns the given palette to the window or bitmap associated with the DC.
 | SetPen(self, pen) Sets the current pen for the DC.
 | SetTextBackground(self, colour) Sets the current text background colour for the DC.
 | SetTextForeground(self, colour) Sets the current text foreground colour for the DC.
 | SetUserScale(self, x, y) Sets the user scaling factor, useful for applications which require 'zooming'.
bool | StartDoc(self, message) Starts a document (only relevant when outputting to a printer).
 | StartPage(self) Starts a document page (only relevant when outputting to a printer).

Method Details

BeginDrawing(self)

Allows for optimization of drawing code on platforms that need it. On other platforms this is just an empty function and is harmless. To take advantage of this postential optimization simply enclose each group of calls to the drawing primitives within calls to BeginDrawing and EndDrawing.

Blit(self, xdest, ydest, width, height, source, xsrc, ysrc, rop=COPY, useMask=False, xsrcMask=-1, ysrcMask=-1)

Copy from a source DC to this DC. Parameters specify the destination coordinates, size of area to copy, source DC, source coordinates, logical function, whether to use a bitmap mask, and mask source position.

Parameters:
xdest - Destination device context x position.
(type=int)

ydest - Destination device context y position.
(type=int)

width - Width of source area to be copied.
(type=int)

height - Height of source area to be copied.
(type=int)

source - Source device context.
(type=DC)

xsrc - Source device context x position.
(type=int)

ysrc - Source device context y position.
(type=int)

rop - Logical function to use: see SetLogicalFunction.
(type=int)

useMask - If true, Blit does a transparent blit using the mask that is associated with the bitmap selected into the source device context.
(type=bool)

xsrcMask - Source x position on the mask. If both xsrcMask and ysrcMask are -1, xsrc and ysrc will be assumed for the mask source position.
(type=int)

ysrcMask - Source y position on the mask.
(type=int)

Returns:
bool

BlitPointSize(self, destPt, sz, source, srcPt, rop=COPY, useMask=False, srcPtMask=DefaultPosition)

Copy from a source DC to this DC. Parameters specify the destination coordinates, size of area to copy, source DC, source coordinates, logical function, whether to use a bitmap mask, and mask source position.

Parameters:
destPt - Destination device context position.
(type=Point)

sz - Size of source area to be copied.
(type=Size)

source - Source device context.
(type=DC)

srcPt - Source device context position.
(type=Point)

rop - Logical function to use: see SetLogicalFunction.
(type=int)

useMask - If true, Blit does a transparent blit using the mask that is associated with the bitmap selected into the source device context.
(type=bool)

srcPtMask - Source position on the mask.
(type=Point)

Returns:
bool

CalcBoundingBox(self, x, y)

Adds the specified point to the bounding box which can be retrieved with MinX, MaxX and MinY, MaxY or GetBoundingBox functions.

Parameters:
x
(type=int)

y
(type=int)

CalcBoundingBoxPoint(self, point)

Adds the specified point to the bounding box which can be retrieved with MinX, MaxX and MinY, MaxY or GetBoundingBox functions.

Parameters:
point
(type=Point)

Clear(self)

Clears the device context using the current background brush.

ComputeScaleAndOrigin(self)

Performs all necessary computations for given platform and context type after each change of scale and origin parameters. Usually called automatically internally after such changes.

CrossHair(self, x, y)

Displays a cross hair using the current pen. This is a vertical and horizontal line the height and width of the window, centred on the given point.

Parameters:
x
(type=int)

y
(type=int)

CrossHairPoint(self, pt)

Displays a cross hair using the current pen. This is a vertical and horizontal line the height and width of the window, centred on the given point.

Parameters:
pt
(type=Point)

DestroyClippingRegion(self)

Destroys the current clipping region so that none of the DC is clipped.

See Also:

SetClippingRegion

DeviceToLogicalX(self, x)

Convert device X coordinate to logical coordinate, using the current mapping mode.

Parameters:
x
(type=int)

Returns:
int

DeviceToLogicalXRel(self, x)

Convert device X coordinate to relative logical coordinate, using the current mapping mode but ignoring the x axis orientation. Use this function for converting a width, for example.

Parameters:
x
(type=int)

Returns:
int

DeviceToLogicalY(self, y)

Converts device Y coordinate to logical coordinate, using the current mapping mode.

Parameters:
y
(type=int)

Returns:
int

DeviceToLogicalYRel(self, y)

Convert device Y coordinate to relative logical coordinate, using the current mapping mode but ignoring the y axis orientation. Use this function for converting a height, for example.

Parameters:
y
(type=int)

Returns:
int

DrawArc(self, x1, y1, x2, y2, xc, yc)

Draws an arc of a circle, centred on the center point (xc, yc), from the first point to the second. The current pen is used for the outline and the current brush for filling the shape.

The arc is drawn in an anticlockwise direction from the start point to the end point.

Parameters:
x1
(type=int)

y1
(type=int)

x2
(type=int)

y2
(type=int)

xc
(type=int)

yc
(type=int)

DrawArcPoint(self, pt1, pt2, center)

Draws an arc of a circle, centred on the center point (xc, yc), from the first point to the second. The current pen is used for the outline and the current brush for filling the shape.

The arc is drawn in an anticlockwise direction from the start point to the end point.

Parameters:
pt1
(type=Point)

pt2
(type=Point)

center
(type=Point)

DrawBitmap(self, bmp, x, y, useMask=False)

Draw a bitmap on the device context at the specified point. If transparent is true and the bitmap has a transparency mask, (or alpha channel on the platforms that support it) then the bitmap will be drawn transparently.

When drawing a mono-bitmap, the current text foreground colour will be used to draw the foreground of the bitmap (all bits set to 1), and the current text background colour to draw the background (all bits set to 0).

Parameters:
bmp
(type=Bitmap)

x
(type=int)

y
(type=int)

useMask
(type=bool)

See Also:

SetTextForeground, SetTextBackground and wx.MemoryDC

DrawBitmapPoint(self, bmp, pt, useMask=False)

Draw a bitmap on the device context at the specified point. If transparent is true and the bitmap has a transparency mask, (or alpha channel on the platforms that support it) then the bitmap will be drawn transparently.

When drawing a mono-bitmap, the current text foreground colour will be used to draw the foreground of the bitmap (all bits set to 1), and the current text background colour to draw the background (all bits set to 0).

Parameters:
bmp
(type=Bitmap)

pt
(type=Point)

useMask
(type=bool)

See Also:

SetTextForeground, SetTextBackground and wx.MemoryDC

DrawCheckMark(self, x, y, width, height)

Draws a check mark inside the given rectangle.

Parameters:
x
(type=int)

y
(type=int)

width
(type=int)

height
(type=int)

DrawCheckMarkRect(self, rect)

Draws a check mark inside the given rectangle.

Parameters:
rect
(type=Rect)

DrawCircle(self, x, y, radius)

Draws a circle with the given center point and radius. The current pen is used for the outline and the current brush for filling the shape.

Parameters:
x
(type=int)

y
(type=int)

radius
(type=int)

See Also:

DrawEllipse

DrawCirclePoint(self, pt, radius)

Draws a circle with the given center point and radius. The current pen is used for the outline and the current brush for filling the shape.

Parameters:
pt
(type=Point)

radius
(type=int)

See Also:

DrawEllipse

DrawEllipse(self, x, y, width, height)

Draws an ellipse contained in the specified rectangle. The current pen is used for the outline and the current brush for filling the shape.

Parameters:
x
(type=int)

y
(type=int)

width
(type=int)

height
(type=int)

See Also:

DrawCircle

DrawEllipseList(self, ellipses, pens=None, brushes=None)

Draw a list of ellipses as quickly as possible.

Parameters:
ellipses - A sequence of 4-element sequences representing each ellipse to draw, (x,y, w,h).

pens - If None, then the current pen is used. If a single pen then it will be used for all ellipses. If a list of pens then there should be one for each ellipse in ellipses.

brushes - A brush or brushes to be used to fill the ellipses, with similar semantics as the pens parameter.

DrawEllipsePointSize(self, pt, sz)

Draws an ellipse contained in the specified rectangle. The current pen is used for the outline and the current brush for filling the shape.

Parameters:
pt
(type=Point)

sz
(type=Size)

See Also:

DrawCircle

DrawEllipseRect(self, rect)

Draws an ellipse contained in the specified rectangle. The current pen is used for the outline and the current brush for filling the shape.

Parameters:
rect
(type=Rect)

See Also:

DrawCircle

DrawEllipticArc(self, x, y, w, h, start, end)

Draws an arc of an ellipse, with the given rectangle defining the bounds of the ellipse. The current pen is used for drawing the arc and the current brush is used for drawing the pie.

The start and end parameters specify the start and end of the arc relative to the three-o'clock position from the center of the rectangle. Angles are specified in degrees (360 is a complete circle). Positive values mean counter-clockwise motion. If start is equal to end, a complete ellipse will be drawn.

Parameters:
x
(type=int)

y
(type=int)

w
(type=int)

h
(type=int)

start
(type=double)

end
(type=double)

DrawEllipticArcPointSize(self, pt, sz, start, end)

Draws an arc of an ellipse, with the given rectangle defining the bounds of the ellipse. The current pen is used for drawing the arc and the current brush is used for drawing the pie.

The start and end parameters specify the start and end of the arc relative to the three-o'clock position from the center of the rectangle. Angles are specified in degrees (360 is a complete circle). Positive values mean counter-clockwise motion. If start is equal to end, a complete ellipse will be drawn.

Parameters:
pt
(type=Point)

sz
(type=Size)

start
(type=double)

end
(type=double)

DrawIcon(self, icon, x, y)

Draw an icon on the display (does nothing if the device context is PostScript). This can be the simplest way of drawing bitmaps on a window.

Parameters:
icon
(type=Icon)

x
(type=int)

y
(type=int)

DrawIconPoint(self, icon, pt)

Draw an icon on the display (does nothing if the device context is PostScript). This can be the simplest way of drawing bitmaps on a window.

Parameters:
icon
(type=Icon)

pt
(type=Point)

DrawImageLabel(self, text, image, rect, alignment=wxALIGN_LEFT|wxALIGN_TOP, indexAccel=-1)

Draw text and an image (which may be wx.NullBitmap to skip drawing it) within the specified rectangle, abiding by the alignment flags. Will additionally emphasize the character at indexAccel if it is not -1. Returns the bounding rectangle.

Parameters:
text
(type=String)

image
(type=Bitmap)

rect
(type=Rect)

alignment
(type=int)

indexAccel
(type=int)

Returns:
Rect

DrawLabel(self, text, rect, alignment=wxALIGN_LEFT|wxALIGN_TOP, indexAccel=-1)

Draw text within the specified rectangle, abiding by the alignment flags. Will additionally emphasize the character at indexAccel if it is not -1.

Parameters:
text
(type=String)

rect
(type=Rect)

alignment
(type=int)

indexAccel
(type=int)

See Also:

DrawImageLabel

DrawLine(self, x1, y1, x2, y2)

Draws a line from the first point to the second. The current pen is used for drawing the line. Note that the second point is not part of the line and is not drawn by this function (this is consistent with the behaviour of many other toolkits).

Parameters:
x1
(type=int)

y1
(type=int)

x2
(type=int)

y2
(type=int)

DrawLineList(self, lines, pens=None)

Draw a list of lines as quickly as possible.

Parameters:
lines - A sequence of 4-element sequences representing each line to draw, (x1,y1, x2,y2).

pens - If None, then the current pen is used. If a single pen then it will be used for all lines. If a list of pens then there should be one for each line in lines.

DrawLinePoint(self, pt1, pt2)

Draws a line from the first point to the second. The current pen is used for drawing the line. Note that the second point is not part of the line and is not drawn by this function (this is consistent with the behaviour of many other toolkits).

Parameters:
pt1
(type=Point)

pt2
(type=Point)

DrawLines(self, points, xoffset=0, yoffset=0)

Draws lines using a sequence of wx.Point objects, adding the optional offset coordinate. The current pen is used for drawing the lines.

Parameters:
points
(type=List)

xoffset
(type=int)

yoffset
(type=int)

DrawPoint(self, x, y)

Draws a point using the current pen.

Parameters:
x
(type=int)

y
(type=int)

DrawPointList(self, points, pens=None)

Draw a list of points as quickly as possible.

Parameters:
points - A sequence of 2-element sequences representing each point to draw, (x,y).

pens - If None, then the current pen is used. If a single pen then it will be used for all points. If a list of pens then there should be one for each point in points.

DrawPointPoint(self, pt)

Draws a point using the current pen.

Parameters:
pt
(type=Point)

DrawPolygon(self,
          points,
          xoffset=0,
          yoffset=0,
          fillStyle=ODDEVEN_RULE)

Draws a filled polygon using a sequence of wx.Point objects, adding the optional offset coordinate. The last argument specifies the fill rule: wx.ODDEVEN_RULE (the default) or wx.WINDING_RULE.

The current pen is used for drawing the outline, and the current brush for filling the shape. Using a transparent brush suppresses filling. Note that wxWidgets automatically closes the first and last points.

Parameters:
points
(type=List)

xoffset
(type=int)

yoffset
(type=int)

fillStyle
(type=int)

DrawPolygonList(self, polygons, pens=None, brushes=None)

Draw a list of polygons, each of which is a list of points.

Parameters:
polygons - A sequence of sequences of sequences. [[(x1,y1),(x2,y2),(x3,y3)...], [(x1,y1),(x2,y2),(x3,y3)...]]

pens - If None, then the current pen is used. If a single pen then it will be used for all polygons. If a list of pens then there should be one for each polygon.

brushes - A brush or brushes to be used to fill the polygons, with similar semantics as the pens parameter.

DrawRectangle(self, x, y, width, height)

Draws a rectangle with the given top left corner, and with the given size. The current pen is used for the outline and the current brush for filling the shape.

Parameters:
x
(type=int)

y
(type=int)

width
(type=int)

height
(type=int)

DrawRectangleList(self, rectangles, pens=None, brushes=None)

Draw a list of rectangles as quickly as possible.

Parameters:
rectangles - A sequence of 4-element sequences representing each rectangle to draw, (x,y, w,h).

pens - If None, then the current pen is used. If a single pen then it will be used for all rectangles. If a list of pens then there should be one for each rectangle in rectangles.

brushes - A brush or brushes to be used to fill the rectagles, with similar semantics as the pens parameter.

DrawRectanglePointSize(self, pt, sz)

Draws a rectangle with the given top left corner, and with the given size. The current pen is used for the outline and the current brush for filling the shape.

Parameters:
pt
(type=Point)

sz
(type=Size)

DrawRectangleRect(self, rect)

Draws a rectangle with the given top left corner, and with the given size. The current pen is used for the outline and the current brush for filling the shape.

Parameters:
rect
(type=Rect)

DrawRotatedText(self, text, x, y, angle)

Draws the text rotated by angle degrees, if supported by the platform.

NOTE: Under Win9x only TrueType fonts can be drawn by this function. In particular, a font different from wx.NORMAL_FONT should be used as the it is not normally a TrueType font. wx.SWISS_FONT is an example of a font which is.

Parameters:
text
(type=String)

x
(type=int)

y
(type=int)

angle
(type=double)

See Also:

DrawText

DrawRotatedTextPoint(self, text, pt, angle)

Draws the text rotated by angle degrees, if supported by the platform.

NOTE: Under Win9x only TrueType fonts can be drawn by this function. In particular, a font different from wx.NORMAL_FONT should be used as the it is not normally a TrueType font. wx.SWISS_FONT is an example of a font which is.

Parameters:
text
(type=String)

pt
(type=Point)

angle
(type=double)

See Also:

DrawText

DrawRoundedRectangle(self, x, y, width, height, radius)

Draws a rectangle with the given top left corner, and with the given size. The corners are quarter-circles using the given radius. The current pen is used for the outline and the current brush for filling the shape.

If radius is positive, the value is assumed to be the radius of the rounded corner. If radius is negative, the absolute value is assumed to be the proportion of the smallest dimension of the rectangle. This means that the corner can be a sensible size relative to the size of the rectangle, and also avoids the strange effects X produces when the corners are too big for the rectangle.

Parameters:
x
(type=int)

y
(type=int)

width
(type=int)

height
(type=int)

radius
(type=double)

DrawRoundedRectanglePointSize(self, pt, sz, radius)

Draws a rectangle with the given top left corner, and with the given size. The corners are quarter-circles using the given radius. The current pen is used for the outline and the current brush for filling the shape.

If radius is positive, the value is assumed to be the radius of the rounded corner. If radius is negative, the absolute value is assumed to be the proportion of the smallest dimension of the rectangle. This means that the corner can be a sensible size relative to the size of the rectangle, and also avoids the strange effects X produces when the corners are too big for the rectangle.

Parameters:
pt
(type=Point)

sz
(type=Size)

radius
(type=double)

DrawRoundedRectangleRect(self, r, radius)

Draws a rectangle with the given top left corner, and with the given size. The corners are quarter-circles using the given radius. The current pen is used for the outline and the current brush for filling the shape.

If radius is positive, the value is assumed to be the radius of the rounded corner. If radius is negative, the absolute value is assumed to be the proportion of the smallest dimension of the rectangle. This means that the corner can be a sensible size relative to the size of the rectangle, and also avoids the strange effects X produces when the corners are too big for the rectangle.

Parameters:
r
(type=Rect)

radius
(type=double)

DrawSpline(self, points)

Draws a spline between all given control points, (a list of wx.Point objects) using the current pen. The spline is drawn using a series of lines, using an algorithm taken from the X drawing program 'XFIG'.

Parameters:
points
(type=List)

DrawText(self, text, x, y)

Draws a text string at the specified point, using the current text font, and the current text foreground and background colours.

The coordinates refer to the top-left corner of the rectangle bounding the string. See GetTextExtent for how to get the dimensions of a text string, which can be used to position the text more precisely.

NOTE: under wxGTK the current logical function is used by this function but it is ignored by wxMSW. Thus, you should avoid using logical functions with this function in portable programs.

Parameters:
text
(type=String)

x
(type=int)

y
(type=int)

See Also:

DrawRotatedText

DrawTextList(self, textList, coords, foregrounds=None, backgrounds=None)

Draw a list of strings using a list of coordinants for positioning each string.

NOTE: Make sure you set Background mode to wx.Solid (DC.SetBackgroundMode)
If you want backgrounds to do anything.
Parameters:
textList - A list of strings

coords - A list of (x,y) positions

foregrounds - A list of wx.Colour objects to use for the foregrounds of the strings.

backgrounds - A list of wx.Colour objects to use for the backgrounds of the strings.

DrawTextPoint(self, text, pt)

Draws a text string at the specified point, using the current text font, and the current text foreground and background colours.

The coordinates refer to the top-left corner of the rectangle bounding the string. See GetTextExtent for how to get the dimensions of a text string, which can be used to position the text more precisely.

NOTE: under wxGTK the current logical function is used by this function but it is ignored by wxMSW. Thus, you should avoid using logical functions with this function in portable programs.

Parameters:
text
(type=String)

pt
(type=Point)

See Also:

DrawRotatedText

EndDoc(self)

Ends a document (only relevant when outputting to a printer).

EndDrawing(self)

Ends the group of drawing primitives started with BeginDrawing, and invokes whatever optimization is available for this DC type on the current platform.

EndPage(self)

Ends a document page (only relevant when outputting to a printer).

FloodFill(self, x, y, col, style=FLOOD_SURFACE)

Flood fills the device context starting from the given point, using the current brush colour, and using a style:

  • wxFLOOD_SURFACE: the flooding occurs until a colour other than the given colour is encountered.
  • wxFLOOD_BORDER: the area to be flooded is bounded by the given colour.

Returns False if the operation failed.

Note: The present implementation for non-Windows platforms may fail to find colour borders if the pixels do not match the colour exactly. However the function will still return true.

Parameters:
x
(type=int)

y
(type=int)

col
(type=Colour)

style
(type=int)

Returns:
bool

FloodFillPoint(self, pt, col, style=FLOOD_SURFACE)

Flood fills the device context starting from the given point, using the current brush colour, and using a style:

  • wxFLOOD_SURFACE: the flooding occurs until a colour other than the given colour is encountered.
  • wxFLOOD_BORDER: the area to be flooded is bounded by the given colour.

Returns False if the operation failed.

Note: The present implementation for non-Windows platforms may fail to find colour borders if the pixels do not match the colour exactly. However the function will still return true.

Parameters:
pt
(type=Point)

col
(type=Colour)

style
(type=int)

Returns:
bool

GetBackground(self)

Gets the brush used for painting the background.

Returns:
Brush

See Also:

SetBackground

GetBackgroundMode(self)

Returns the current background mode, either wx.SOLID or wx.TRANSPARENT.

Returns:
int

See Also:

SetBackgroundMode

GetBoundingBox()

Returns the min and max points used in drawing commands so far.

Returns:
(x1,y1, x2,y2)

GetBrush(self)

Gets the current brush

Returns:
Brush

GetCharHeight(self)

Gets the character height of the currently set font.

Returns:
int

GetCharWidth(self)

Gets the average character width of the currently set font.

Returns:
int

GetClippingBox()

Gets the rectangle surrounding the current clipping region.

Returns:
(x, y, width, height)

GetClippingRect(self)

Gets the rectangle surrounding the current clipping region.

Returns:
Rect

GetDepth(self)

Returns the colour depth of the DC.

Returns:
int

GetFont(self)

Gets the current font

Returns:
Font

GetFullTextExtent(string, font=None)

Get the width, height, decent and leading of the text using the current or specified font. Only works for single line strings.

Parameters:
string
(type=wxString)

font
(type=Font)

Returns:
(width, height, descent, externalLeading)

GetLogicalFunction(self)

Gets the current logical function (set by SetLogicalFunction).

Returns:
int

GetMapMode(self)

Gets the current mapping mode for the device context

Returns:
int

GetMultiLineTextExtent(string, font=None)

Get the width, height, decent and leading of the text using the current or specified font. Works for single as well as multi-line strings.

Parameters:
string
(type=wxString)

font
(type=Font)

Returns:
(width, height, descent, externalLeading)

GetOptimization(*args, **kwargs)

<function GetOptimization at 0xb7b68a04> is deprecated

GetPartialTextExtents(self, text)

Returns a list of integers such that each value is the distance in pixels from the begining of text to the coresponding character of text. The generic version simply builds a running total of the widths of each character using GetTextExtent, however if the various platforms have a native API function that is faster or more accurate than the generic implementation then it will be used instead.

Returns:
[widths]

GetPen(self)

Gets the current pen

Returns:
Pen

GetPixel(self, x, y)

Gets the colour at the specified location on the DC.

Parameters:
x
(type=int)

y
(type=int)

Returns:
Colour

GetPPI(self)

Resolution in Pixels per inch

Returns:
Size

GetSize(self)

This gets the horizontal and vertical resolution in device units. It can be used to scale graphics to fit the page. For example, if maxX and maxY represent the maximum horizontal and vertical 'pixel' values used in your application, the following code will scale the graphic to fit on the printer page:

w, h = dc.GetSize()
scaleX = maxX*1.0 / w
scaleY = maxY*1.0 / h
dc.SetUserScale(min(scaleX,scaleY),min(scaleX,scaleY))
Returns:
Size

GetSizeMM(self)

Get the DC size in milimeters.

Returns:
Size

GetSizeMMTuple()

Get the DC size in milimeters.

Returns:
(width, height)

GetSizeTuple()

This gets the horizontal and vertical resolution in device units. It can be used to scale graphics to fit the page. For example, if maxX and maxY represent the maximum horizontal and vertical 'pixel' values used in your application, the following code will scale the graphic to fit on the printer page:

w, h = dc.GetSize()
scaleX = maxX*1.0 / w
scaleY = maxY*1.0 / h
dc.SetUserScale(min(scaleX,scaleY),min(scaleX,scaleY))
Returns:
(width, height)

GetTextBackground(self)

Gets the current text background colour

Returns:
Colour

GetTextExtent(string)

Get the width and height of the text using the current font. Only works for single line strings.

Parameters:
string
(type=wxString)

Returns:
(width, height)

GetTextForeground(self)

Gets the current text foreground colour

Returns:
Colour

GetUserScale(self)

Gets the current user scale factor (set by SetUserScale).

Returns:
(xScale, yScale)

LogicalToDeviceX(self, x)

Converts logical X coordinate to device coordinate, using the current mapping mode.

Parameters:
x
(type=int)

Returns:
int

LogicalToDeviceXRel(self, x)

Converts logical X coordinate to relative device coordinate, using the current mapping mode but ignoring the x axis orientation. Use this for converting a width, for example.

Parameters:
x
(type=int)

Returns:
int

LogicalToDeviceY(self, y)

Converts logical Y coordinate to device coordinate, using the current mapping mode.

Parameters:
y
(type=int)

Returns:
int

LogicalToDeviceYRel(self, y)

Converts logical Y coordinate to relative device coordinate, using the current mapping mode but ignoring the y axis orientation. Use this for converting a height, for example.

Parameters:
y
(type=int)

Returns:
int

MaxX(self)

Gets the maximum horizontal extent used in drawing commands so far.

Returns:
int

MaxY(self)

Gets the maximum vertical extent used in drawing commands so far.

Returns:
int

MinX(self)

Gets the minimum horizontal extent used in drawing commands so far.

Returns:
int

MinY(self)

Gets the minimum vertical extent used in drawing commands so far.

Returns:
int

Ok(self)

Returns true if the DC is ok to use.

Returns:
bool

ResetBoundingBox(self)

Resets the bounding box: after a call to this function, the bounding box doesn't contain anything.

SetAxisOrientation(self, xLeftRight, yBottomUp)

Sets the x and y axis orientation (i.e., the direction from lowest to highest values on the axis). The default orientation is the natural orientation, e.g. x axis from left to right and y axis from bottom up.

Parameters:
xLeftRight
(type=bool)

yBottomUp
(type=bool)

SetBackground(self, brush)

Sets the current background brush for the DC.

Parameters:
brush
(type=Brush)

SetBackgroundMode(self, mode)

mode may be one of wx.SOLID and wx.TRANSPARENT. This setting determines whether text will be drawn with a background colour or not.

Parameters:
mode
(type=int)

SetBrush(self, brush)

Sets the current brush for the DC.

If the argument is wx.NullBrush, the current brush is selected out of the device context, and the original brush restored, allowing the current brush to be destroyed safely.

Parameters:
brush
(type=Brush)

See Also:

wx.Brush

SetClippingRect(self, rect)

Sets the clipping region for this device context to the intersection of the given region described by the parameters of this method and the previously set clipping region. You should call DestroyClippingRegion if you want to set the clipping region exactly to the region specified.

The clipping region is an area to which drawing is restricted. Possible uses for the clipping region are for clipping text or for speeding up window redraws when only a known area of the screen is damaged.

Parameters:
rect
(type=Rect)

See Also:

DestroyClippingRegion, wx.Region

SetClippingRegion(self, x, y, width, height)

Sets the clipping region for this device context to the intersection of the given region described by the parameters of this method and the previously set clipping region. You should call DestroyClippingRegion if you want to set the clipping region exactly to the region specified.

The clipping region is an area to which drawing is restricted. Possible uses for the clipping region are for clipping text or for speeding up window redraws when only a known area of the screen is damaged.

Parameters:
x
(type=int)

y
(type=int)

width
(type=int)

height
(type=int)

See Also:

DestroyClippingRegion, wx.Region

SetClippingRegionAsRegion(self, region)

Sets the clipping region for this device context to the intersection of the given region described by the parameters of this method and the previously set clipping region. You should call DestroyClippingRegion if you want to set the clipping region exactly to the region specified.

The clipping region is an area to which drawing is restricted. Possible uses for the clipping region are for clipping text or for speeding up window redraws when only a known area of the screen is damaged.

Parameters:
region
(type=Region)

See Also:

DestroyClippingRegion, wx.Region

SetClippingRegionPointSize(self, pt, sz)

Sets the clipping region for this device context to the intersection of the given region described by the parameters of this method and the previously set clipping region. You should call DestroyClippingRegion if you want to set the clipping region exactly to the region specified.

The clipping region is an area to which drawing is restricted. Possible uses for the clipping region are for clipping text or for speeding up window redraws when only a known area of the screen is damaged.

Parameters:
pt
(type=Point)

sz
(type=Size)

See Also:

DestroyClippingRegion, wx.Region

SetFont(self, font)

Sets the current font for the DC. It must be a valid font, in particular you should not pass wx.NullFont to this method.

Parameters:
font
(type=Font)

See Also:

wx.Font

SetLogicalFunction(self, function)

Sets the current logical function for the device context. This determines how a source pixel (from a pen or brush colour, or source device context if using Blit) combines with a destination pixel in the current device context.

The possible values and their meaning in terms of source and destination pixel values are as follows:

wx.AND | src AND dst
wx.AND_INVERT | (NOT src) AND dst
wx.AND_REVERSE | src AND (NOT dst)
wx.CLEAR | 0
wx.COPY | src
wx.EQUIV | (NOT src) XOR dst
wx.INVERT | NOT dst
wx.NAND | (NOT src) OR (NOT dst)
wx.NOR | (NOT src) AND (NOT dst)
wx.NO_OP | dst
wx.OR | src OR dst
wx.OR_INVERT | (NOT src) OR dst
wx.OR_REVERSE | src OR (NOT dst)
wx.SET | 1
wx.SRC_INVERT | NOT src
wx.XOR | src XOR dst

The default is wx.COPY, which simply draws with the current colour. The others combine the current colour and the background using a logical operation. wx.INVERT is commonly used for drawing rubber bands or moving outlines, since drawing twice reverts to the original colour.

Parameters:
function
(type=int)

SetMapMode(self, mode)

The mapping mode of the device context defines the unit of measurement used to convert logical units to device units. The mapping mode can be one of the following:

wx.MM_TWIPS | Each logical unit is 1/20 of a point, or 1/1440 of an inch.
wx.MM_POINTS | Each logical unit is a point, or 1/72 of an inch.
wx.MM_METRIC | Each logical unit is 1 mm.
wx.MM_LOMETRIC | Each logical unit is 1/10 of a mm.
wx.MM_TEXT | Each logical unit is 1 pixel.

Note that in X, text drawing isn't handled consistently with the mapping mode; a font is always specified in point size. However, setting the user scale (see SetUserScale) scales the text appropriately. In Windows, scalable TrueType fonts are always used; in X, results depend on availability of fonts, but usually a reasonable match is found.

The coordinate origin is always at the top left of the screen/printer.

Drawing to a Windows printer device context uses the current mapping mode, but mapping mode is currently ignored for PostScript output.

Parameters:
mode
(type=int)

SetOptimization(*args, **kwargs)

<function SetOptimization at 0xb7b689cc> is deprecated

SetPalette(self, palette)

If this is a window DC or memory DC, assigns the given palette to the window or bitmap associated with the DC. If the argument is wx.NullPalette, the current palette is selected out of the device context, and the original palette restored.

Parameters:
palette
(type=Palette)

See Also:

wx.Palette

SetPen(self, pen)

Sets the current pen for the DC.

If the argument is wx.NullPen, the current pen is selected out of the device context, and the original pen restored.

Parameters:
pen
(type=Pen)

See Also:

wx.Pen

SetTextBackground(self, colour)

Sets the current text background colour for the DC.

Parameters:
colour
(type=Colour)

SetTextForeground(self, colour)

Sets the current text foreground colour for the DC.

Parameters:
colour
(type=Colour)

SetUserScale(self, x, y)

Sets the user scaling factor, useful for applications which require 'zooming'.

Parameters:
x
(type=double)

y
(type=double)

StartDoc(self, message)

Starts a document (only relevant when outputting to a printer). Message is a message to show whilst printing.

Parameters:
message
(type=String)

Returns:
bool

StartPage(self)

Starts a document page (only relevant when outputting to a printer).

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:33 2005 http://epydoc.sf.net


wx.Dialog

Package wx :: Class Dialog

Type Dialog

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
        TopLevelWindow --+
                         |
                        Dialog

Known Subclasses:
AboutDialog, CalenDlg, ColourDialog, DirDialog, FileDialog, FilePropertiesDialog, FindReplaceDialog, FontDialog, ImageDialog, MessageDialog, MultiChoiceDialog, MultipleChoiceDialog, OptionsDialog, PopupDialog, ScrolledMessageDialog, SingleChoiceDialog, TextEntryDialog, Wizard

Proxy of C++ Dialog class

Method Summary
Dialog | __init__(self, parent, id, title, pos, size, style, name)
 | __repr__(self)
bool | Create(self, parent, id, pos, size, style, name) Create the GUI part of the Window for 2-phase creation mode.
Sizer | CreateButtonSizer(self, flags)
StdDialogButtonSizer | CreateStdDialogButtonSizer(self, flags)
Sizer | CreateTextSizer(self, message)
 | EndModal(self, retCode)
VisualAttributes | GetClassDefaultAttributes(variant) Get the default attributes for this class. (Static method)
int | GetReturnCode(self)
bool | IsModal(self)
 | SendSizeEvent(self)
 | SetReturnCode(self, returnCode)
int | ShowModal(self)

Instance Method Details

Create(self,
          parent,
          id=-1,
          title=EmptyString,
          pos=DefaultPosition,
          size=DefaultSize,
          style=DEFAULT_DIALOG_STYLE,
          name=DialogNameStr)

Create the GUI part of the Window for 2-phase creation mode.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

name
(type=String)

Returns:
bool
Overrides:
wx.Window.Create (inherited documentation)

Static Method Details

GetClassDefaultAttributes(variant=WINDOW_VARIANT_NORMAL)

Get the default attributes for this class. This is useful if you want to use the same font or colour in your own control as in a standard control -- which is a much better idea than hard coding specific colours or fonts which might look completely out of place on the user's system, especially if it uses themes.

The variant parameter is only relevant under Mac currently and is ignore under other platforms. Under Mac, it will change the size of the returned font. See wx.Window.SetWindowVariant for more about this.

Parameters:
variant
(type=int)

Returns:
VisualAttributes

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:40 2005 http://epydoc.sf.net


wx.DirDialog

Package wx :: Class DirDialog

Type DirDialog

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
        TopLevelWindow --+
                         |
                    Dialog --+
                             |
                            DirDialog

wx.DirDialog allows the user to select a directory by browising the file system.

Window Styles

wx.DD_NEW_DIR_BUTTON Add 'Create new directory' button and allow directory names to be editable. On Windows the new directory button is only available with recent versions of the common dialogs.
Method Summary
DirDialog | __init__(self, parent, message, defaultPath, style, pos, size, name) Constructor.
 | __repr__(self)
String | GetMessage(self) Returns the message that will be displayed on the dialog.
String | GetPath(self) Returns the default or user-selected path.
long | GetStyle(self) Returns the dialog style.
 | SetMessage(self, message) Sets the message that will be displayed on the dialog.
 | SetPath(self, path) Sets the default path.

Instance Method Details

__init__(self,
          parent,
          message=DirSelectorPromptStr,
          defaultPath=EmptyString,
          style=0,
          pos=DefaultPosition,
          size=DefaultSize,
          name=DirDialogNameStr)
(Constructor)

Constructor. Use ShowModal method to show the dialog.

Parameters:
parent
(type=Window)

message
(type=String)

defaultPath
(type=String)

style
(type=long)

pos
(type=Point)

size
(type=Size)

name
(type=String)

Returns:
DirDialog
Overrides:
wx.Dialog.__init__

GetMessage(self)

Returns the message that will be displayed on the dialog.

Returns:
String

GetPath(self)

Returns the default or user-selected path.

Returns:
String

GetStyle(self)

Returns the dialog style.

Returns:
long

SetMessage(self, message)

Sets the message that will be displayed on the dialog.

Parameters:
message
(type=String)

SetPath(self, path)

Sets the default path.

Parameters:
path
(type=String)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:17 2005 http://epydoc.sf.net


wx.DirFilterListCtrl

Package wx :: Class DirFilterListCtrl

Type DirFilterListCtrl

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
               Control --+
                         |
            object --+   |
                     |   |
         ItemContainer --+
                         |
          ControlWithItems --+
                             |
                        Choice --+
                                 |
                                DirFilterListCtrl

Proxy of C++ DirFilterListCtrl class

Method Summary
Choice | __init__(parent, id, pos, size, choices, style, validator, name) Create and show a Choice control
 | __repr__(self)
bool | Create(parent, id, pos, size, choices, style, validator, name) Actually create the GUI Choice control for 2-phase creation
 | FillFilterList(self, filter, defaultFilter)

Instance Method Details

__init__(self, parent, id=-1, pos=DefaultPosition, size=DefaultSize, style=0)
(Constructor)

Create and show a Choice control

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

choices
(type=List)

style
(type=long)

validator
(type=Validator)

name
(type=String)

Returns:
Choice
Overrides:
wx.Choice.__init__ (inherited documentation)

Create(self,
          parent,
          id=-1,
          pos=DefaultPosition,
          size=DefaultSize,
          style=0)

Actually create the GUI Choice control for 2-phase creation

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

choices
(type=List)

style
(type=long)

validator
(type=Validator)

name
(type=String)

Returns:
bool
Overrides:
wx.Choice.Create (inherited documentation)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:11 2005 http://epydoc.sf.net


wx.DisplayChangedEvent

Package wx :: Class DisplayChangedEvent

Type DisplayChangedEvent

object --+
         |
    Object --+
             |
         Event --+
                 |
                DisplayChangedEvent

An EVT_DISPLAY_CHANGED event is sent to all windows when the display resolution has changed.

This event is implemented under Windows only.

Method Summary
DisplayChangedEvent | __init__(self)
 | __repr__(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:55 2005 http://epydoc.sf.net


wx.Display

Package wx :: Class Display

Type Display

object --+
         |
        Display

Represents a display/monitor attached to the system

Method Summary
Display | __init__(self, index) Set up a Display instance with the specified display.
 | __del__(self)
 | __nonzero__(self)
 | __repr__(self)
bool | ChangeMode(self, mode) Changes the video mode of this display to the mode specified in the mode parameter.
size_t | GetCount() Return the number of available displays. (Static method)
VideoMode | GetCurrentMode(self) Get the current video mode.
int | GetFromPoint(pt) Find the display where the given point lies, return wx.NOT_FOUND if it doesn't belong to any display (Static method)
int | GetFromWindow(window) Find the display where the given window lies, return wx.NOT_FOUND if it is not shown at all. (Static method)
Rect | GetGeometry(self) Returns the bounding rectangle of the display whose index was passed to the constructor.
[videoMode...] | GetModes(mode) Enumerate all video modes supported by this display matching the given one (in the sense of VideoMode.Match()).
String | GetName(self) Returns the display's name.
bool | IsOk(self) Return true if the object was initialized successfully
bool | IsPrimary(self) Returns true if the display is the primary display.
 | ResetMode(self) Restore the default video mode (just a more readable synonym)

Instance Method Details

__init__(self, index=0)
(Constructor)

Set up a Display instance with the specified display. The displays are numbered from 0 to GetCount() - 1, 0 is always the primary display and the only one which is always supported

Parameters:
index
(type=size_t)

Returns:
Display
Overrides:
__builtin__.object.__init__

ChangeMode(self, mode=DefaultVideoMode)

Changes the video mode of this display to the mode specified in the mode parameter.

If wx.DefaultVideoMode is passed in as the mode parameter, the defined behaviour is that wx.Display will reset the video mode to the default mode used by the display. On Windows, the behavior is normal. However, there are differences on other platforms. On Unix variations using X11 extensions it should behave as defined, but some irregularities may occur.

On wxMac passing in wx.DefaultVideoMode as the mode parameter does nothing. This happens because Carbon no longer has access to DMUseScreenPrefs, an undocumented function that changed the video mode to the system default by using the system's 'scrn' resource.

Returns True if succeeded, False otherwise

Parameters:
mode
(type=VideoMode)

Returns:
bool

GetCurrentMode(self)

Get the current video mode.

Returns:
VideoMode

GetGeometry(self)

Returns the bounding rectangle of the display whose index was passed to the constructor.

Returns:
Rect

GetModes(mode=DefaultVideoMode)

Enumerate all video modes supported by this display matching the given one (in the sense of VideoMode.Match()).

As any mode matches the default value of the argument and there is always at least one video mode supported by display, the returned array is only empty for the default value of the argument if this function is not supported at all on this platform.

Parameters:
mode
(type=VideoMode)

Returns:
[videoMode...]

GetName(self)

Returns the display's name. A name is not available on all platforms.

Returns:
String

IsOk(self)

Return true if the object was initialized successfully

Returns:
bool

IsPrimary(self)

Returns true if the display is the primary display. The primary display is the one whose index is 0.

Returns:
bool

ResetMode(self)

Restore the default video mode (just a more readable synonym)

Static Method Details

GetCount()

Return the number of available displays.

Returns:
size_t

GetFromPoint(pt)

Find the display where the given point lies, return wx.NOT_FOUND if it doesn't belong to any display

Parameters:
pt
(type=Point)

Returns:
int

GetFromWindow(window)

Find the display where the given window lies, return wx.NOT_FOUND if it is not shown at all.

Parameters:
window
(type=Window)

Returns:
int

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:56 2005 http://epydoc.sf.net


wx.DragImage

Package wx :: Class DragImage

Type DragImage

object --+
         |
    Object --+
             |
            DragImage

Proxy of C++ DragImage class

Method Summary
DragImage | __init__(self, image, cursor)
 | __del__(self)
 | __repr__(self)
bool | BeginDrag(self, hotspot, window, fullScreen, rect)
bool | BeginDragBounded(self, hotspot, window, boundingWindow)
bool | DoDrawImage(self, dc, pos)
bool | EndDrag(self)
Rect | GetImageRect(self, pos)
bool | Hide(self)
bool | Move(self, pt)
bool | RedrawImage(self, oldPos, newPos, eraseOld, drawNew)
 | SetBackingBitmap(self, bitmap)
bool | Show(self)
bool | UpdateBackingFromWindow(self, windowDC, destDC, sourceRect, destRect)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:10:49 2005 http://epydoc.sf.net


wx.DropFilesEvent

Package wx :: Class DropFilesEvent

Type DropFilesEvent

object --+
         |
    Object --+
             |
         Event --+
                 |
                DropFilesEvent

This class is used for drop files events, that is, when files have been dropped onto the window. This functionality is only available under Windows. The window must have previously been enabled for dropping by calling wx.Window.DragAcceptFiles.

Important note: this is a separate implementation to the more general drag and drop implementation using wx.FileDropTarget, and etc. This implementation uses the older, Windows message-based approach of dropping files.

Use wx.EVT_DROP_FILES to bind an event handler to receive file drop events.

Method Summary
 | __init__(self)
 | __repr__(self)
PyObject | GetFiles(self) Returns a list of the filenames that were dropped.
int | GetNumberOfFiles(self) Returns the number of files dropped.
Point | GetPosition(self) Returns the position at which the files were dropped.

Method Details

GetFiles(self)

Returns a list of the filenames that were dropped.

Returns:
PyObject

GetNumberOfFiles(self)

Returns the number of files dropped.

Returns:
int

GetPosition(self)

Returns the position at which the files were dropped.

Returns:
Point

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:33 2005 http://epydoc.sf.net


wx.DropSource

Package wx :: Class DropSource

Type DropSource

object --+
         |
        DropSource

Proxy of C++ DropSource class

Method Summary
DropSource | __init__(self, win, copy, move, none)
 | __del__(self)
 | __repr__(self)
bool | base_GiveFeedback(self, effect)
int | DoDragDrop(self, flags)
DataObject | GetDataObject(self)
 | SetCursor(self, res, cursor)
 | SetData(self, data)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:10 2005 http://epydoc.sf.net


wx.DropTarget

Package wx :: Class DropTarget

Type DropTarget

object --+
         |
        DropTarget

Known Subclasses:
FileDropTarget, TextDropTarget

Proxy of C++ DropTarget class

Method Summary
DropTarget | __init__(self, dataObject)
 | __del__(self)
 | __repr__(self)
int | base_OnDragOver(self, x, y, def)
bool | base_OnDrop(self, x, y)
int | base_OnEnter(self, x, y, def)
 | base_OnLeave(self)
bool | GetData(self)
DataObject | GetDataObject(self)
int | GetDefaultAction(self)
 | SetDataObject(self, dataObject)
 | SetDefaultAction(self, action)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:16 2005 http://epydoc.sf.net


wx.Effects

Package wx :: Class Effects

Type Effects

object --+
         |
    Object --+
             |
            Effects

Proxy of C++ Effects class

Method Summary
Effects | __init__(self)
 | __repr__(self)
 | DrawSunkenEdge(self, dc, rect, borderSize)
Colour | GetDarkShadow(self)
Colour | GetFaceColour(self)
Colour | GetHighlightColour(self)
Colour | GetLightShadow(self)
Colour | GetMediumShadow(self)
 | Set(self, highlightColour, lightShadow, faceColour, mediumShadow, darkShadow)
 | SetDarkShadow(self, c)
 | SetFaceColour(self, c)
 | SetHighlightColour(self, c)
 | SetLightShadow(self, c)
 | SetMediumShadow(self, c)
bool | TileBitmap(self, rect, dc, bitmap)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:09 2005 http://epydoc.sf.net


wx.EncodingConverter

Package wx :: Class EncodingConverter

Type EncodingConverter

object --+
         |
    Object --+
             |
            EncodingConverter

Proxy of C++ EncodingConverter class

Method Summary
EncodingConverter | __init__(self)
 | __del__(self)
 | __nonzero__(self)
 | __repr__(self)
bool | CanConvert(encIn, encOut) (Static method)
String | Convert(self, input)
wxFontEncodingArray | GetAllEquivalents(enc) (Static method)
wxFontEncodingArray | GetPlatformEquivalents(enc, platform) (Static method)
bool | Init(self, input_enc, output_enc, method)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:33 2005 http://epydoc.sf.net


wx.EraseEvent

Package wx :: Class EraseEvent

Type EraseEvent

object --+
         |
    Object --+
             |
         Event --+
                 |
                EraseEvent

An erase event is sent whenever the background of a window needs to be repainted. To intercept this event use the EVT_ERASE_BACKGROUND event binder. On some platforms, such as GTK+, this event is simulated (simply generated just before the paint event) and may cause flicker.

To paint a custom background use the GetDC method and use the returned device context if it is not None, otherwise create a temporary wx.ClientDC and draw on that.

Method Summary
EraseEvent | __init__(self, Id, dc) Constructor
 | __repr__(self)
DC | GetDC(self) Returns the device context the event handler should draw upon.

Method Details

__init__(self, Id=0, dc=None)
(Constructor)

Constructor

Parameters:
Id
(type=int)

dc
(type=DC)

Returns:
EraseEvent
Overrides:
wx.Event.__init__

GetDC(self)

Returns the device context the event handler should draw upon. If None is returned then create a temporary wx.ClientDC and use that instead.

Returns:
DC

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:52 2005 http://epydoc.sf.net


wx.Event

Package wx :: Class Event

Type Event

object --+
         |
    Object --+
             |
            Event

Known Subclasses:
ActivateEvent, CalculateLayoutEvent, CloseEvent, CommandEvent, DisplayChangedEvent, DropFilesEvent, EraseEvent, FocusEvent, IconizeEvent, IdleEvent, InitDialogEvent, JoystickEvent, KeyEvent, MaximizeEvent, MenuEvent, MouseCaptureChangedEvent, MouseEvent, MoveEvent, NavigationKeyEvent, NcPaintEvent, PaintEvent, PaletteChangedEvent, ProcessEvent, PyEvent, QueryLayoutInfoEvent, QueryNewPaletteEvent, ScrollWinEvent, SetCursorEvent, ShowEvent, SizeEvent, SysColourChangedEvent, TaskBarIconEvent, TimerEvent

An event is a structure holding information about an event passed to a callback or member function. wx.Event is an abstract base class for other event classes

Method Summary
 | __init__(self)
 | __del__(self)
 | __repr__(self)
Event | Clone(self)
Object | GetEventObject(self) Returns the object (usually a window) associated with the event, if any.
wxEventType | GetEventType(self) Returns the identifier of the given event type, such as wxEVT_COMMAND_BUTTON_CLICKED.
int | GetId(self) Returns the identifier associated with this event, such as a button command id.
bool | GetSkipped(self) Returns true if the event handler should be skipped, false otherwise.
long | GetTimestamp(self)
bool | IsCommandEvent(self) Returns true if the event is or is derived from wx.CommandEvent else it returns false.
 | ResumePropagation(self, propagationLevel) Resume the event propagation by restoring the propagation level.
 | SetEventObject(self, obj) Sets the originating object, or in other words, obj is normally the object that is sending the event.
 | SetEventType(self, typ) Sets the specific type of the event.
 | SetId(self, Id) Set's the ID for the event.
 | SetTimestamp(self, ts)
bool | ShouldPropagate(self) Test if this event should be propagated to the parent window or not, i.e.
 | Skip(self, skip) Called by an event handler, it controls whether additional event handlers bound to this event will be called after the current event handler returns.
int | StopPropagation(self) Stop the event from propagating to its parent window.

Method Details

GetEventObject(self)

Returns the object (usually a window) associated with the event, if any.

Returns:
Object

GetEventType(self)

Returns the identifier of the given event type, such as wxEVT_COMMAND_BUTTON_CLICKED.

Returns:
wxEventType

GetId(self)

Returns the identifier associated with this event, such as a button command id.

Returns:
int

GetSkipped(self)

Returns true if the event handler should be skipped, false otherwise. :see: Skip

Returns:
bool

IsCommandEvent(self)

Returns true if the event is or is derived from wx.CommandEvent else it returns false. Note: Exists only for optimization purposes.

Returns:
bool

ResumePropagation(self, propagationLevel)

Resume the event propagation by restoring the propagation level. (For example, you can use the value returned by an earlier call to StopPropagation.)

Parameters:
propagationLevel
(type=int)

SetEventObject(self, obj)

Sets the originating object, or in other words, obj is normally the object that is sending the event.

Parameters:
obj
(type=Object)

SetEventType(self, typ)

Sets the specific type of the event.

Parameters:
typ
(type=wxEventType)

SetId(self, Id)

Set's the ID for the event. This is usually the ID of the window that is sending the event, but it can also be a command id from a menu item, etc.

Parameters:
Id
(type=int)

ShouldPropagate(self)

Test if this event should be propagated to the parent window or not, i.e. if the propagation level is currently greater than 0.

Returns:
bool

Skip(self, skip=True)

Called by an event handler, it controls whether additional event handlers bound to this event will be called after the current event handler returns. Skip(false) (the default setting) will prevent additional event handlers from being called and control will be returned to the sender of the event immediately after the current handler has finished. Skip(True) will cause the event processing system to continue searching for a handler function for this event.

Parameters:
skip
(type=bool)

StopPropagation(self)

Stop the event from propagating to its parent window. Returns the old propagation level value which may be later passed to ResumePropagation to allow propagating the event again.

Returns:
int

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:51 2005 http://epydoc.sf.net


wx.EventLoop

Package wx :: Class EventLoop

Type EventLoop

object --+
         |
        EventLoop

Proxy of C++ EventLoop class

Method Summary
EventLoop | __init__(self)
 | __del__(self)
 | __repr__(self)
bool | Dispatch(self)
 | Exit(self, rc)
EventLoop | GetActive() (Static method)
bool | IsRunning(self)
bool | Pending(self)
int | Run(self)
 | SetActive(loop) (Static method)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:10 2005 http://epydoc.sf.net


wx.EvtHandler

Package wx :: Class EvtHandler

Type EvtHandler

object --+
         |
    Object --+
             |
            EvtHandler

Known Subclasses:
DocManager, DocService, Document, GridColMover, GridRowMover, Menu, Process, PyApp, TaskBarIcon, Timer, Validator, View, Window

Proxy of C++ EvtHandler class

Method Summary
EvtHandler | __init__(self)
 | __repr__(self)
 | AddPendingEvent(self, event)
 | Bind(self, event, handler, source, id, id2) Bind an event to an event handler.
 | Connect(self, id, lastId, eventType, func)
bool | Disconnect(self, id, lastId, eventType)
bool | GetEvtHandlerEnabled(self)
EvtHandler | GetNextHandler(self)
EvtHandler | GetPreviousHandler(self)
bool | ProcessEvent(self, event)
 | ProcessPendingEvents(self)
 | SetEvtHandlerEnabled(self, enabled)
 | SetNextHandler(self, handler)
 | SetPreviousHandler(self, handler)
 | Unbind(self, event, source, id, id2) Disconencts the event handler binding for event from self.

Method Details

Bind(self, event, handler, source=None, id=-1, id2=-1)

Bind an event to an event handler.

Parameters:
event - One of the EVT_* objects that specifies the type of event to bind,

handler - A callable object to be invoked when the event is delivered to self. Pass None to disconnect an event handler.

source - Sometimes the event originates from a different window than self, but you still want to catch it in self. (For example, a button event delivered to a frame.) By passing the source of the event, the event handling system is able to differentiate between the same event type from different controls.

id - Used to spcify the event source by ID instead of instance.

id2 - Used when it is desirable to bind a handler to a range of IDs, such as with EVT_MENU_RANGE.

Unbind(self,
          event,
          source=None,
          id=-1,
          id2=-1)

Disconencts the event handler binding for event from self. Returns True if successful.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:27 2005 http://epydoc.sf.net


wx.FileConfig

Package wx :: Class FileConfig

Type FileConfig

object --+
         |
ConfigBase --+
             |
            FileConfig

This config class will use a file for storage on all platforms.

Method Summary
FileConfig | __init__(self, appName, vendorName, localFilename, globalFilename, style)
 | __del__(self)
 | __repr__(self)

Class Variable Summary

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:32 2005 http://epydoc.sf.net


wx.FileDataObject

Package wx :: Class FileDataObject

Type FileDataObject

  object --+
           |
  DataObject --+
               |
DataObjectSimple --+
                   |
                  FileDataObject

wx.FileDataObject is a specialization of wx.DataObjectSimple for file names. The program works with it just as if it were a list of absolute file names, but internally it uses the same format as Explorer and other compatible programs under Windows or GNOME/KDE filemanager under Unix which makes it possible to receive files from them using this class.

Method Summary
DataObjectSimple | __init__(self, format) Constructor accepts the supported format (none by default) which may also be set later with SetFormat.
 | __repr__(self)
 | AddFile(self, filename) Adds a file to the list of files represented by this data object.
[names] | GetFilenames(self) Returns a list of file names.

Class Variable Summary

Method Details

__init__(self)
(Constructor)

Constructor accepts the supported format (none by default) which may also be set later with SetFormat.

Parameters:
format
(type=DataFormat)

Returns:
DataObjectSimple
Overrides:
wx.DataObjectSimple.__init__ (inherited documentation)

AddFile(self, filename)

Adds a file to the list of files represented by this data object.

Parameters:
filename
(type=String)

GetFilenames(self)

Returns a list of file names.

Returns:
[names]

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:48 2005 http://epydoc.sf.net


wx.FileDialog

Package wx :: Class FileDialog

Type FileDialog

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
        TopLevelWindow --+
                         |
                    Dialog --+
                             |
                            FileDialog

wx.FileDialog allows the user to select one or more files from the filesystem.

In Windows, this is the common file selector dialog. On X based platforms a generic alternative is used. The path and filename are distinct elements of a full file pathname. If path is "", the current directory will be used. If filename is "", no default filename will be supplied. The wildcard determines what files are displayed in the file selector, and file extension supplies a type extension for the required filename.

Both the X and Windows versions implement a wildcard filter. Typing a filename containing wildcards (*, ?) in the filename text item, and clicking on Ok, will result in only those files matching the pattern being displayed. The wildcard may be a specification for multiple types of file with a description for each, such as:

"BMP files (*.bmp)|*.bmp|GIF files (*.gif)|*.gif"

Window Styles

wx.OPEN | This is an open dialog.
wx.SAVE | This is a save dialog.
wx.HIDE_READONLY | For open dialog only: hide the checkbox allowing to open the file in read-only mode.
wx.OVERWRITE_PROMPT | For save dialog only: prompt for a confirmation if a file will be overwritten.
wx.MULTIPLE | For open dialog only: allows selecting multiple files.
wx.CHANGE_DIR | Change the current working directory to the directory where the file(s) chosen by the user are.
Method Summary
FileDialog | __init__(self, parent, message, defaultDir, defaultFile, wildcard, style, pos) Constructor.
 | __repr__(self)
String | GetDirectory(self) Returns the default directory.
String | GetFilename(self) Returns the default filename.
PyObject | GetFilenames(self) Returns a list of filenames chosen in the dialog.
int | GetFilterIndex(self) Returns the index into the list of filters supplied, optionally, in the wildcard parameter.
String | GetMessage(self) Returns the message that will be displayed on the dialog.
String | GetPath(self) Returns the full path (directory and filename) of the selected file.
PyObject | GetPaths(self) Fills the array paths with the full paths of the files chosen.
long | GetStyle(self) Returns the dialog style.
String | GetWildcard(self) Returns the file dialog wildcard.
 | SetDirectory(self, dir) Sets the default directory.
 | SetFilename(self, name) Sets the default filename.
 | SetFilterIndex(self, filterIndex) Sets the default filter index, starting from zero.
 | SetMessage(self, message) Sets the message that will be displayed on the dialog.
 | SetPath(self, path) Sets the path (the combined directory and filename that will be returned when the dialog is dismissed).
 | SetStyle(self, style) Sets the dialog style.
 | SetWildcard(self, wildCard) Sets the wildcard, which can contain multiple file types, for example:

Instance Method Details

__init__(self,
          parent,
          message=FileSelectorPromptStr,
          defaultDir=EmptyString,
          defaultFile=EmptyString,
          wildcard=FileSelectorDefaultWildcardStr,
          style=0,
          pos=DefaultPosition)
(Constructor)

Constructor. Use ShowModal method to show the dialog.

Parameters:
parent
(type=Window)

message
(type=String)

defaultDir
(type=String)

defaultFile
(type=String)

wildcard
(type=String)

style
(type=long)

pos
(type=Point)

Returns:
FileDialog
Overrides:
wx.Dialog.__init__

GetDirectory(self)

Returns the default directory.

Returns:
String

GetFilename(self)

Returns the default filename.

Returns:
String

GetFilenames(self)

Returns a list of filenames chosen in the dialog. This function should only be used with the dialogs which have wx.MULTIPLE style, use GetFilename for the others.

Returns:
PyObject

GetFilterIndex(self)

Returns the index into the list of filters supplied, optionally, in the wildcard parameter. Before the dialog is shown, this is the index which will be used when the dialog is first displayed. After the dialog is shown, this is the index selected by the user.

Returns:
int

GetMessage(self)

Returns the message that will be displayed on the dialog.

Returns:
String

GetPath(self)

Returns the full path (directory and filename) of the selected file.

Returns:
String

GetPaths(self)

Fills the array paths with the full paths of the files chosen. This function should only be used with the dialogs which have wx.MULTIPLE style, use GetPath for the others.

Returns:
PyObject

GetStyle(self)

Returns the dialog style.

Returns:
long

GetWildcard(self)

Returns the file dialog wildcard.

Returns:
String

SetDirectory(self, dir)

Sets the default directory.

Parameters:
dir
(type=String)

SetFilename(self, name)

Sets the default filename.

Parameters:
name
(type=String)

SetFilterIndex(self, filterIndex)

Sets the default filter index, starting from zero.

Parameters:
filterIndex
(type=int)

SetMessage(self, message)

Sets the message that will be displayed on the dialog.

Parameters:
message
(type=String)

SetPath(self, path)

Sets the path (the combined directory and filename that will be returned when the dialog is dismissed).

Parameters:
path
(type=String)

SetStyle(self, style)

Sets the dialog style.

Parameters:
style
(type=long)

SetWildcard(self, wildCard)

Sets the wildcard, which can contain multiple file types, for example:

"BMP files (*.bmp)|*.bmp|GIF files (*.gif)|*.gif"
Parameters:
wildCard
(type=String)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:41 2005 http://epydoc.sf.net


wx.FileDropTarget

Package wx :: Class FileDropTarget

Type FileDropTarget

object --+
         |
DropTarget --+
             |
            FileDropTarget

Proxy of C++ FileDropTarget class

Method Summary
FileDropTarget | __init__(self)
 | __repr__(self)
int | base_OnData(self, x, y, def)
int | base_OnDragOver(self, x, y, def)
bool | base_OnDrop(self, x, y)
int | base_OnEnter(self, x, y, def)
 | base_OnLeave(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:40 2005 http://epydoc.sf.net


wx.FileHistory

Package wx :: Class FileHistory

Type FileHistory

object --+
         |
    Object --+
             |
            FileHistory

Proxy of C++ FileHistory class

Method Summary
FileHistory | __init__(self, maxFiles, idBase)
 | __del__(self)
 | __repr__(self)
 | AddFilesToMenu(self)
 | AddFilesToThisMenu(self, menu)
 | AddFileToHistory(self, file)
int | GetCount(self)
String | GetHistoryFile(self, i)
int | GetMaxFiles(self)
int | GetNoHistoryFiles(self)
 | Load(self, config)
 | RemoveFileFromHistory(self, i)
 | RemoveMenu(self, menu)
 | Save(self, config)
 | UseMenu(self, menu)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:18 2005 http://epydoc.sf.net


wx.FileSystem

Package wx :: Class FileSystem

Type FileSystem

object --+
         |
    Object --+
             |
            FileSystem

Proxy of C++ FileSystem class

Method Summary
FileSystem | __init__(self)
 | __del__(self)
 | __repr__(self)
 | AddHandler(handler) (Static method)
 | ChangePathTo(self, location, is_dir)
 | CleanUpHandlers() (Static method)
String | FileNameToURL(filename) (Static method)
String | FindFirst(self, spec, flags)
String | FindNext(self)
String | GetPath(self)
FSFile | OpenFile(self, location)
String | URLToFileName(url) (Static method)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:39 2005 http://epydoc.sf.net


wx.FileSystemHandler

Package wx :: Class FileSystemHandler

Type FileSystemHandler

          object --+
                   |
CPPFileSystemHandler --+
                       |
                      FileSystemHandler

Proxy of C++ FileSystemHandler class

Method Summary
FileSystemHandler | __init__(self)
 | __repr__(self)
bool | CanOpen(self, location)
String | FindFirst(self, spec, flags)
String | FindNext(self)
String | GetAnchor(self, location)
String | GetLeftLocation(self, location)
String | GetMimeTypeFromExt(self, location)
String | GetProtocol(self, location)
String | GetRightLocation(self, location)
FSFile | OpenFile(self, fs, location)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:09 2005 http://epydoc.sf.net


wx.FileType

Package wx :: Class FileType

Type FileType

object --+
         |
        FileType

Proxy of C++ FileType class

Method Summary
FileType | __init__(self, ftInfo)
 | __del__(self)
 | __repr__(self)
String | ExpandCommand(command, filename, mimetype) (Static method)
PyObject | GetAllCommands(self, filename, mimetype)
PyObject | GetDescription(self)
PyObject | GetExtensions(self)
Icon | GetIcon(self)
PyObject | GetIconInfo(self)
PyObject | GetMimeType(self)
PyObject | GetMimeTypes(self)
PyObject | GetOpenCommand(self, filename, mimetype)
PyObject | GetPrintCommand(self, filename, mimetype)
bool | SetCommand(self, cmd, verb, overwriteprompt)
bool | SetDefaultIcon(self, cmd, index)
bool | Unassociate(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:41 2005 http://epydoc.sf.net


wx.FileTypeInfo

Package wx :: Class FileTypeInfo

Type FileTypeInfo

object --+
         |
        FileTypeInfo

Proxy of C++ FileTypeInfo class

Method Summary
FileTypeInfo | __init__(self, mimeType, openCmd, printCmd, desc)
 | __repr__(self)
String | GetDescription(self)
wxArrayString | GetExtensions(self)
int | GetExtensionsCount(self)
String | GetIconFile(self)
int | GetIconIndex(self)
String | GetMimeType(self)
String | GetOpenCommand(self)
String | GetPrintCommand(self)
String | GetShortDesc(self)
bool | IsValid(self)
 | SetIcon(self, iconFile, iconIndex)
 | SetShortDesc(self, shortDesc)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:18 2005 http://epydoc.sf.net


wx.FindDialogEvent

Package wx :: Class FindDialogEvent

Type FindDialogEvent

object --+
         |
    Object --+
             |
         Event --+
                 |
      CommandEvent --+
                     |
                    FindDialogEvent

Events for the FindReplaceDialog

Method Summary
FindDialogEvent | __init__(self, commandType, id) Events for the FindReplaceDialog
 | __repr__(self)
FindReplaceDialog | GetDialog(self) Return the pointer to the dialog which generated this event.
String | GetFindString(self) Return the string to find (never empty).
int | GetFlags(self) Get the currently selected flags: this is the combination of wx.FR_DOWN, wx.FR_WHOLEWORD and wx.FR_MATCHCASE flags.
String | GetReplaceString(self) Return the string to replace the search string with (only for replace and replace all events).
 | SetFindString(self, str)
 | SetFlags(self, flags)
 | SetReplaceString(self, str)

Method Details

__init__(self, commandType=wxEVT_NULL, id=0)
(Constructor)

Events for the FindReplaceDialog

Parameters:
commandType
(type=wxEventType)

id
(type=int)

Returns:
FindDialogEvent
Overrides:
wx.CommandEvent.__init__

GetDialog(self)

Return the pointer to the dialog which generated this event.

Returns:
FindReplaceDialog

GetFindString(self)

Return the string to find (never empty).

Returns:
String

GetFlags(self)

Get the currently selected flags: this is the combination of wx.FR_DOWN, wx.FR_WHOLEWORD and wx.FR_MATCHCASE flags.

Returns:
int

GetReplaceString(self)

Return the string to replace the search string with (only for replace and replace all events).

Returns:
String

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:38 2005 http://epydoc.sf.net


wx.FindReplaceData

Package wx :: Class FindReplaceData

Type FindReplaceData

object --+
         |
    Object --+
             |
            FindReplaceData

wx.FindReplaceData holds the data for wx.FindReplaceDialog. It is used to initialize the dialog with the default values and will keep the last values from the dialog when it is closed. It is also updated each time a wx.FindDialogEvent is generated so instead of using the wx.FindDialogEvent methods you can also directly query this object.

Note that all SetXXX() methods may only be called before showing the dialog and calling them has no effect later.

Flags

wx.FR_DOWN | Downward search/replace selected (otherwise, upwards)
wx.FR_WHOLEWORD | Whole word search/replace selected
wx.FR_MATCHCASE | Case sensitive search/replace selected (otherwise, case insensitive)
Method Summary
FindReplaceData | __init__(self, flags) Constuctor initializes the flags to default value (0).
 | __del__(self)
 | __repr__(self)
String | GetFindString(self) Get the string to find.
int | GetFlags(self) Get the combination of flag values.
String | GetReplaceString(self) Get the replacement string.
 | SetFindString(self, str) Set the string to find (used as initial value by the dialog).
 | SetFlags(self, flags) Set the flags to use to initialize the controls of the dialog.
 | SetReplaceString(self, str) Set the replacement string (used as initial value by the dialog).

Method Details

__init__(self, flags=0)
(Constructor)

Constuctor initializes the flags to default value (0).

Parameters:
flags
(type=int)

Returns:
FindReplaceData
Overrides:
wx.Object.__init__

GetFindString(self)

Get the string to find.

Returns:
String

GetFlags(self)

Get the combination of flag values.

Returns:
int

GetReplaceString(self)

Get the replacement string.

Returns:
String

SetFindString(self, str)

Set the string to find (used as initial value by the dialog).

Parameters:
str
(type=String)

SetFlags(self, flags)

Set the flags to use to initialize the controls of the dialog.

Parameters:
flags
(type=int)

SetReplaceString(self, str)

Set the replacement string (used as initial value by the dialog).

Parameters:
str
(type=String)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:52 2005 http://epydoc.sf.net


wx.FindReplaceDialog

Package wx :: Class FindReplaceDialog

Type FindReplaceDialog

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
        TopLevelWindow --+
                         |
                    Dialog --+
                             |
                            FindReplaceDialog

wx.FindReplaceDialog is a standard modeless dialog which is used to allow the user to search for some text (and possibly replace it with something else). The actual searching is supposed to be done in the owner window which is the parent of this dialog. Note that it means that unlike for the other standard dialogs this one must have a parent window. Also note that there is no way to use this dialog in a modal way; it is always, by design and implementation, modeless.

Window Styles

wx.FR_REPLACEDIALOG | replace dialog (otherwise find dialog)
wx.FR_NOUPDOWN | don't allow changing the search direction
wx.FR_NOMATCHCASE | don't allow case sensitive searching
wx.FR_NOWHOLEWORD | don't allow whole word searching
Method Summary
FindReplaceDialog | __init__(self, parent, data, title, style) Create a FindReplaceDialog.
 | __repr__(self)
bool | Create(self, parent, data, title, style) Create the dialog, for 2-phase create.
FindReplaceData | GetData(self) Get the FindReplaceData object used by this dialog.
 | SetData(self, data) Set the FindReplaceData object used by this dialog.

Instance Method Details

__init__(self, parent, data, title, style=0)
(Constructor)

Create a FindReplaceDialog. The parent and data parameters must be non-None. Use Show to display the dialog.

Parameters:
parent
(type=Window)

data
(type=FindReplaceData)

title
(type=String)

style
(type=int)

Returns:
FindReplaceDialog
Overrides:
wx.Dialog.__init__

Create(self, parent, data, title, style=0)

Create the dialog, for 2-phase create.

Parameters:
parent
(type=Window)

data
(type=FindReplaceData)

title
(type=String)

style
(type=int)

Returns:
bool
Overrides:
wx.Dialog.Create

GetData(self)

Get the FindReplaceData object used by this dialog.

Returns:
FindReplaceData

SetData(self, data)

Set the FindReplaceData object used by this dialog.

Parameters:
data
(type=FindReplaceData)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:09 2005 http://epydoc.sf.net


wx.FlexGridSizer

Package wx :: Class FlexGridSizer

Type FlexGridSizer

object --+
         |
    Object --+
             |
         Sizer --+
                 |
         GridSizer --+
                     |
                    FlexGridSizer

Known Subclasses:
GridBagSizer

A flex grid sizer is a sizer which lays out its children in a two-dimensional table with all table cells in one row having the same height and all cells in one column having the same width, but all rows or all columns are not necessarily the same height or width as in the wx.GridSizer.

wx.FlexGridSizer can also size items equally in one direction but unequally ("flexibly") in the other. If the sizer is only flexible in one direction (this can be changed using SetFlexibleDirection), it needs to be decided how the sizer should grow in the other ("non flexible") direction in order to fill the available space. The SetNonFlexibleGrowMode method serves this purpose.

Method Summary
FlexGridSizer | __init__(self, rows, cols, vgap, hgap) Constructor for a wx.FlexGridSizer.
 | __repr__(self)
 | AddGrowableCol(self, idx, proportion) Specifies that column idx (starting from zero) should be grown if there is extra space available to the sizer.
 | AddGrowableRow(self, idx, proportion) Specifies that row idx (starting from zero) should be grown if there is extra space available to the sizer.
list | GetColWidths(self) Returns a list of integers representing the widths of each of the columns in the sizer.
int | GetFlexibleDirection(self) Returns a value that specifies whether the sizer flexibly resizes its columns, rows, or both (default).
int | GetNonFlexibleGrowMode(self) Returns the value that specifies how the sizer grows in the non-flexible direction if there is one.
list | GetRowHeights(self) Returns a list of integers representing the heights of each of the rows in the sizer.
 | RemoveGrowableCol(self, idx) Specifies that column idx is no longer growable.
 | RemoveGrowableRow(self, idx) Specifies that row idx is no longer growable.
 | SetFlexibleDirection(self, direction) Specifies whether the sizer should flexibly resize its columns, rows, or both.
 | SetNonFlexibleGrowMode(self, mode) Specifies how the sizer should grow in the non-flexible direction if there is one (so SetFlexibleDirection must have been called previously).

Method Details

__init__(self,
          rows=1,
          cols=0,
          vgap=0,
          hgap=0)
(Constructor)

Constructor for a wx.FlexGridSizer. rows and cols determine the number of columns and rows in the sizer - if either of the parameters is zero, it will be calculated to from the total number of children in the sizer, thus making the sizer grow dynamically. vgap and hgap define extra space between all children.

Parameters:
rows
(type=int)

cols
(type=int)

vgap
(type=int)

hgap
(type=int)

Returns:
FlexGridSizer
Overrides:
wx.GridSizer.__init__

AddGrowableCol(self, idx, proportion=0)

Specifies that column idx (starting from zero) should be grown if there is extra space available to the sizer.

The proportion parameter has the same meaning as the stretch factor for the box sizers except that if all proportions are 0, then all columns are resized equally (instead of not being resized at all).

Parameters:
idx
(type=size_t)

proportion
(type=int)

AddGrowableRow(self, idx, proportion=0)

Specifies that row idx (starting from zero) should be grown if there is extra space available to the sizer.

The proportion parameter has the same meaning as the stretch factor for the box sizers except that if all proportions are 0, then all columns are resized equally (instead of not being resized at all).

Parameters:
idx
(type=size_t)

proportion
(type=int)

GetColWidths(self)

Returns a list of integers representing the widths of each of the columns in the sizer.

Returns:
list

GetFlexibleDirection(self)

Returns a value that specifies whether the sizer flexibly resizes its columns, rows, or both (default).

Returns:
int

See Also:

SetFlexibleDirection

GetNonFlexibleGrowMode(self)

Returns the value that specifies how the sizer grows in the non-flexible direction if there is one.

Returns:
int

See Also:

SetNonFlexibleGrowMode

GetRowHeights(self)

Returns a list of integers representing the heights of each of the rows in the sizer.

Returns:
list

RemoveGrowableCol(self, idx)

Specifies that column idx is no longer growable.

Parameters:
idx
(type=size_t)

RemoveGrowableRow(self, idx)

Specifies that row idx is no longer growable.

Parameters:
idx
(type=size_t)

SetFlexibleDirection(self, direction)

Specifies whether the sizer should flexibly resize its columns, rows, or both. Argument direction can be one of the following values. Any other value is ignored.

wx.VERTICAL | Rows are flexibly sized.
wx.HORIZONTAL | Columns are flexibly sized.
wx.BOTH | Both rows and columns are flexibly sized (this is the default value).

Note that this method does not trigger relayout.

Parameters:
direction
(type=int)

SetNonFlexibleGrowMode(self, mode)

Specifies how the sizer should grow in the non-flexible direction if there is one (so SetFlexibleDirection must have been called previously). Argument mode can be one of the following values:

wx.FLEX_GROWMODE_NONE | Sizer doesn't grow in the non flexible direction.
wx.FLEX_GROWMODE_SPECIFIED | Sizer honors growable columns/rows set with AddGrowableCol and AddGrowableRow. In this case equal sizing applies to minimum sizes of columns or rows (this is the default value).
wx.FLEX_GROWMODE_ALL | Sizer equally stretches all columns or rows in the non flexible direction, whether they are growable or not in the flexbile direction.

Note that this method does not trigger relayout.

Parameters:
mode
(type=int)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:10:48 2005 http://epydoc.sf.net


wx.FocusEvent

Package wx :: Class FocusEvent

Type FocusEvent

object --+
         |
    Object --+
             |
         Event --+
                 |
                FocusEvent

A focus event is sent when a window's focus changes. The window losing focus receives an EVT_KILL_FOCUS event while the window gaining it gets an EVT_SET_FOCUS event.

Notice that the set focus event happens both when the user gives focus to the window (whether using the mouse or keyboard) and when it is done from the program itself using wx.Window.SetFocus.

Method Summary
FocusEvent | __init__(self, type, winid) Constructor
 | __repr__(self)
Window | GetWindow(self) Returns the other window associated with this event, that is the window which had the focus before for the EVT_SET_FOCUS event and the window which is going to receive focus for the wxEVT_KILL_FOCUS event.
 | SetWindow(self, win)

Method Details

__init__(self, type=wxEVT_NULL, winid=0)
(Constructor)

Constructor

Parameters:
type
(type=wxEventType)

winid
(type=int)

Returns:
FocusEvent
Overrides:
wx.Event.__init__

GetWindow(self)

Returns the other window associated with this event, that is the window which had the focus before for the EVT_SET_FOCUS event and the window which is going to receive focus for the wxEVT_KILL_FOCUS event.

Warning: the window returned may be None!

Returns:
Window

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:39 2005 http://epydoc.sf.net


wx.Font

Package wx :: Class Font

Type Font

object --+
         |
    Object --+
             |
     GDIObject --+
                 |
                Font

A font is an object which determines the appearance of text. Fonts are used for drawing text to a device context, and setting the appearance of a window's text.

You can retrieve the current system font settings with wx.SystemSettings.

The possible values for the family parameter of wx.Font constructor are:

wx.FONTFAMILY_DEFAULT | Chooses a default font.
wx.FONTFAMILY_DECORATIVE | A decorative font.
wx.FONTFAMILY_ROMAN | A formal, serif font.
wx.FONTFAMILY_SCRIPT | A handwriting font.
wx.FONTFAMILY_SWISS | A sans-serif font.
wx.FONTFAMILY_MODERN | Usually a fixed pitch font.
wx.FONTFAMILY_TELETYPE | A teletype font.

The possible values for the weight parameter are:

wx.FONTWEIGHT_NORMAL
wx.FONTWEIGHT_LIGHT
wx.FONTWEIGHT_BOLD

The known font encodings are:

wx.FONTENCODING_SYSTEM | system default
wx.FONTENCODING_DEFAULT | current default encoding
wx.FONTENCODING_ISO8859_1 | West European (Latin1)
wx.FONTENCODING_ISO8859_2 | Central and East European (Latin2)
wx.FONTENCODING_ISO8859_3 | Esperanto (Latin3)
wx.FONTENCODING_ISO8859_4 | Baltic (old) (Latin4)
wx.FONTENCODING_ISO8859_5 | Cyrillic
wx.FONTENCODING_ISO8859_6 | Arabic
wx.FONTENCODING_ISO8859_7 | Greek
wx.FONTENCODING_ISO8859_8 | Hebrew
wx.FONTENCODING_ISO8859_9 | Turkish (Latin5)
wx.FONTENCODING_ISO8859_10 | Variation of Latin4 (Latin6)
wx.FONTENCODING_ISO8859_11 | Thai
wx.FONTENCODING_ISO8859_12 | doesn't exist currently, but put it here anyhow to make all ISO8859 consecutive numbers
wx.FONTENCODING_ISO8859_13 | Baltic (Latin7)
wx.FONTENCODING_ISO8859_14 | Latin8
wx.FONTENCODING_ISO8859_15 | Latin9 (a.k.a. Latin0, includes euro)
wx.FONTENCODING_KOI8 | Cyrillic charset
wx.FONTENCODING_ALTERNATIVE | same as MS-DOS CP866
wx.FONTENCODING_BULGARIAN | used under Linux in Bulgaria
wx.FONTENCODING_CP437 | original MS-DOS codepage
wx.FONTENCODING_CP850 | CP437 merged with Latin1
wx.FONTENCODING_CP852 | CP437 merged with Latin2
wx.FONTENCODING_CP855 | another cyrillic encoding
wx.FONTENCODING_CP866 | and another one
wx.FONTENCODING_CP874 | WinThai
wx.FONTENCODING_CP1250 | WinLatin2
wx.FONTENCODING_CP1251 | WinCyrillic
wx.FONTENCODING_CP1252 | WinLatin1
wx.FONTENCODING_CP1253 | WinGreek (8859-7)
wx.FONTENCODING_CP1254 | WinTurkish
wx.FONTENCODING_CP1255 | WinHebrew
wx.FONTENCODING_CP1256 | WinArabic
wx.FONTENCODING_CP1257 | WinBaltic (same as Latin 7)
wx.FONTENCODING_UTF7 | UTF-7 Unicode encoding
wx.FONTENCODING_UTF8 | UTF-8 Unicode encoding
Method Summary
Font | __init__(self, pointSize, family, style, weight, underline, face, encoding) Creates a font object with the specified attributes.
 | __del__(self)
bool | __eq__(self, other)
bool | __ne__(self, other)
 | __nonzero__(self)
 | __repr__(self)
int | GetDefaultEncoding() Returns the encoding used for all fonts created with an encoding of wx.FONTENCODING_DEFAULT. (Static method)
int | GetEncoding(self) Get the font's encoding.
String | GetFaceName(self) Returns the typeface name associated with the font, or the empty string if there is no typeface information.
int | GetFamily(self) Gets the font family.
String | GetFamilyString(self) Returns a string representation of the font family.
NativeFontInfo | GetNativeFontInfo(self) Constructs a wx.NativeFontInfo object from this font.
String | GetNativeFontInfoDesc(self) Returns the platform-dependent string completely describing this font or an empty string if the font isn't valid.
String | GetNativeFontInfoUserDesc(self) Returns a human readable version of GetNativeFontInfoDesc.
bool | GetNoAntiAliasing(self)
Size | GetPixelSize(self) Returns the size in pixels if the font was constructed with a pixel size.
int | GetPointSize(self) Gets the point size.
int | GetStyle(self) Gets the font style.
String | GetStyleString(self) Returns a string representation of the font style.
bool | GetUnderlined(self) Returns True if the font is underlined, False otherwise.
int | GetWeight(self) Gets the font weight.
String | GetWeightString(self) Return a string representation of the font weight.
bool | IsFixedWidth(self) Returns true if the font is a fixed width (or monospaced) font, false if it is a proportional one or font is invalid.
bool | IsUsingSizeInPixels(self) Returns True if the font is using a pixelSize.
bool | Ok(self) Returns True if this font was successfully created.
 | SetDefaultEncoding(encoding) Sets the default font encoding. (Static method)
 | SetEncoding(self, encoding) Set the font encoding.
 | SetFaceName(self, faceName) Sets the facename for the font.
 | SetFamily(self, family) Sets the font family.
 | SetNativeFontInfo(self, info) Set the font's attributes from a wx.NativeFontInfo object.
 | SetNativeFontInfoFromString(self, info) Set the font's attributes from string representation of a wx.NativeFontInfo object.
 | SetNativeFontInfoUserDesc(self, info) Set the font's attributes from a string formerly returned from GetNativeFontInfoDesc.
 | SetNoAntiAliasing(self, no)
 | SetPixelSize(self, pixelSize) Sets the size in pixels rather than points.
 | SetPointSize(self, pointSize) Sets the point size.
 | SetStyle(self, style) Sets the font style.
 | SetUnderlined(self, underlined) Sets underlining.
 | SetWeight(self, weight) Sets the font weight.

Instance Method Details

__init__(self, pointSize, family, style, weight, underline=False, face=EmptyString, encoding=FONTENCODING_DEFAULT)
(Constructor)

Creates a font object with the specified attributes.

Parameters:
pointSize - The size of the font in points.
(type=int)

family - Font family. A generic way of referring to fonts without specifying actual facename. It can be One of the wx.FONTFAMILY_xxx constants.
(type=int)

style - One of the wx.FONTSTYLE_xxx constants.
(type=int)

weight - Font weight, sometimes also referred to as font boldness. One of the wx.FONTWEIGHT_xxx constants.
(type=int)

underline - The value can be True or False and indicates whether the font will include an underline. This may not be supported on all platforms.
(type=bool)

face - An optional string specifying the actual typeface to be used. If it is an empty string, a default typeface will be chosen based on the family.
(type=String)

encoding - An encoding which may be one of the wx.FONTENCODING_xxx constants. If the specified encoding isn't available, no font is created.
(type=int)

Returns:
Font
Overrides:
wx.GDIObject.__init__

See Also:

wx.FFont, wx.FontFromPixelSize, wx.FFontFromPixelSize, wx.FontFromNativeInfoString, wx.FontFromNativeInfo

GetEncoding(self)

Get the font's encoding.

Returns:
int

GetFaceName(self)

Returns the typeface name associated with the font, or the empty string if there is no typeface information.

Returns:
String

GetFamily(self)

Gets the font family.

Returns:
int

GetFamilyString(self)

Returns a string representation of the font family.

Returns:
String

GetNativeFontInfo(self)

Constructs a wx.NativeFontInfo object from this font.

Returns:
NativeFontInfo

GetNativeFontInfoDesc(self)

Returns the platform-dependent string completely describing this font or an empty string if the font isn't valid.

Returns:
String

GetNativeFontInfoUserDesc(self)

Returns a human readable version of GetNativeFontInfoDesc.

Returns:
String

GetPixelSize(self)

Returns the size in pixels if the font was constructed with a pixel size.

Returns:
Size

GetPointSize(self)

Gets the point size.

Returns:
int

GetStyle(self)

Gets the font style.

Returns:
int

GetStyleString(self)

Returns a string representation of the font style.

Returns:
String

GetUnderlined(self)

Returns True if the font is underlined, False otherwise.

Returns:
bool

GetWeight(self)

Gets the font weight.

Returns:
int

GetWeightString(self)

Return a string representation of the font weight.

Returns:
String

IsFixedWidth(self)

Returns true if the font is a fixed width (or monospaced) font, false if it is a proportional one or font is invalid.

Returns:
bool

IsUsingSizeInPixels(self)

Returns True if the font is using a pixelSize.

Returns:
bool

Ok(self)

Returns True if this font was successfully created.

Returns:
bool

SetEncoding(self, encoding)

Set the font encoding.

Parameters:
encoding
(type=int)

SetFaceName(self, faceName)

Sets the facename for the font. The facename, which should be a valid font installed on the end-user's system.

To avoid portability problems, don't rely on a specific face, but specify the font family instead or as well. A suitable font will be found on the end-user's system. If both the family and the facename are specified, wxWidgets will first search for the specific face, and then for a font belonging to the same family.

Parameters:
faceName
(type=String)

SetFamily(self, family)

Sets the font family.

Parameters:
family
(type=int)

SetNativeFontInfo(self, info)

Set the font's attributes from a wx.NativeFontInfo object.

Parameters:
info
(type=NativeFontInfo)

SetNativeFontInfoFromString(self, info)

Set the font's attributes from string representation of a wx.NativeFontInfo object.

Parameters:
info
(type=String)

SetNativeFontInfoUserDesc(self, info)

Set the font's attributes from a string formerly returned from GetNativeFontInfoDesc.

Parameters:
info
(type=String)

SetPixelSize(self, pixelSize)

Sets the size in pixels rather than points. If there is platform API support for this then it is used, otherwise a font with the closest size is found using a binary search.

Parameters:
pixelSize
(type=Size)

SetPointSize(self, pointSize)

Sets the point size.

Parameters:
pointSize
(type=int)

SetStyle(self, style)

Sets the font style.

Parameters:
style
(type=int)

SetUnderlined(self, underlined)

Sets underlining.

Parameters:
underlined
(type=bool)

SetWeight(self, weight)

Sets the font weight.

Parameters:
weight
(type=int)

Static Method Details

GetDefaultEncoding()

Returns the encoding used for all fonts created with an encoding of wx.FONTENCODING_DEFAULT.

Returns:
int

SetDefaultEncoding(encoding)

Sets the default font encoding.

Parameters:
encoding
(type=int)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:18 2005 http://epydoc.sf.net


wx.FontData

Package wx :: Class FontData

Type FontData

object --+
         |
    Object --+
             |
            FontData

This class holds a variety of information related to font dialogs and is used to transfer settings to and results from a wx.FontDialog.

Method Summary
FontData | __init__(self) This class holds a variety of information related to font dialogs and is used to transfer settings to and results from a wx.FontDialog.
 | __del__(self)
 | __repr__(self)
 | EnableEffects(self, enable) Enables or disables 'effects' under MS Windows only.
bool | GetAllowSymbols(self) Under MS Windows, returns a flag determining whether symbol fonts can be selected.
Font | GetChosenFont(self) Gets the font chosen by the user.
Colour | GetColour(self) Gets the colour associated with the font dialog.
bool | GetEnableEffects(self) Determines whether 'effects' are enabled under Windows.
Font | GetInitialFont(self) Gets the font that will be initially used by the font dialog.
bool | GetShowHelp(self) Returns true if the Help button will be shown (Windows only).
 | SetAllowSymbols(self, allowSymbols) Under MS Windows, determines whether symbol fonts can be selected.
 | SetChosenFont(self, font) Sets the font that will be returned to the user (normally for internal use only).
 | SetColour(self, colour) Sets the colour that will be used for the font foreground colour.
 | SetInitialFont(self, font) Sets the font that will be initially used by the font dialog.
 | SetRange(self, min, max) Sets the valid range for the font point size (Windows only).
 | SetShowHelp(self, showHelp) Determines whether the Help button will be displayed in the font dialog (Windows only).

Method Details

__init__(self)
(Constructor)

This class holds a variety of information related to font dialogs and is used to transfer settings to and results from a wx.FontDialog.

Returns:
FontData
Overrides:
wx.Object.__init__

EnableEffects(self, enable)

Enables or disables 'effects' under MS Windows only. This refers to the controls for manipulating colour, strikeout and underline properties. The default value is true.

Parameters:
enable
(type=bool)

GetAllowSymbols(self)

Under MS Windows, returns a flag determining whether symbol fonts can be selected. Has no effect on other platforms. The default value is true.

Returns:
bool

GetChosenFont(self)

Gets the font chosen by the user.

Returns:
Font

GetColour(self)

Gets the colour associated with the font dialog. The default value is black.

Returns:
Colour

GetEnableEffects(self)

Determines whether 'effects' are enabled under Windows.

Returns:
bool

GetInitialFont(self)

Gets the font that will be initially used by the font dialog. This should have previously been set by the application.

Returns:
Font

GetShowHelp(self)

Returns true if the Help button will be shown (Windows only). The default value is false.

Returns:
bool

SetAllowSymbols(self, allowSymbols)

Under MS Windows, determines whether symbol fonts can be selected. Has no effect on other platforms. The default value is true.

Parameters:
allowSymbols
(type=bool)

SetChosenFont(self, font)

Sets the font that will be returned to the user (normally for internal use only).

Parameters:
font
(type=Font)

SetColour(self, colour)

Sets the colour that will be used for the font foreground colour. The default colour is black.

Parameters:
colour
(type=Colour)

SetInitialFont(self, font)

Sets the font that will be initially used by the font dialog.

Parameters:
font
(type=Font)

SetRange(self, min, max)

Sets the valid range for the font point size (Windows only). The default is 0, 0 (unrestricted range).

Parameters:
min
(type=int)

max
(type=int)

SetShowHelp(self, showHelp)

Determines whether the Help button will be displayed in the font dialog (Windows only). The default value is false.

Parameters:
showHelp
(type=bool)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:34 2005 http://epydoc.sf.net


wx.FontDialog

Package wx :: Class FontDialog

Type FontDialog

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
        TopLevelWindow --+
                         |
                    Dialog --+
                             |
                            FontDialog

wx.FontDialog allows the user to select a system font and its attributes.

See Also:

wx.FontData

Method Summary
FontDialog | __init__(self, parent, data) Constructor.
 | __repr__(self)
FontData | GetFontData(self) Returns a reference to the internal wx.FontData used by the wx.FontDialog.

Instance Method Details

__init__(self, parent, data)
(Constructor)

Constructor. Pass a parent window and the wx.FontData object to be used to initialize the dialog controls. Call ShowModal to display the dialog. If ShowModal returns wx.ID_OK then you can fetch the results with via the wx.FontData returned by GetFontData.

Parameters:
parent
(type=Window)

data
(type=FontData)

Returns:
FontDialog
Overrides:
wx.Dialog.__init__

GetFontData(self)

Returns a reference to the internal wx.FontData used by the wx.FontDialog.

Returns:
FontData

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:39 2005 http://epydoc.sf.net


wx.FontEnumerator

Package wx :: Class FontEnumerator

Type FontEnumerator

object --+
         |
        FontEnumerator

Proxy of C++ FontEnumerator class

Method Summary
FontEnumerator | __init__(self)
 | __del__(self)
 | __repr__(self)
bool | EnumerateEncodings(self, facename)
bool | EnumerateFacenames(self, encoding, fixedWidthOnly)
PyObject | GetEncodings(self)
PyObject | GetFacenames(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:05 2005 http://epydoc.sf.net


wx.FontList

Package wx :: Class FontList

Type FontList

object --+
         |
    Object --+
             |
            FontList

Proxy of C++ FontList class

Method Summary
 | __init__(self)
 | __repr__(self)
 | AddFont(self, font)
Font | FindOrCreateFont(self, point_size, family, style, weight, underline, facename, encoding)
int | GetCount(self)
 | RemoveFont(self, font)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:09 2005 http://epydoc.sf.net


wx.FontMapper

Package wx :: Class FontMapper

Type FontMapper

object --+
         |
        FontMapper

Proxy of C++ FontMapper class

Method Summary
FontMapper | __init__(self)
 | __del__(self)
 | __repr__(self)
int | CharsetToEncoding(self, charset, interactive)
FontMapper | Get() (Static method)
PyObject | GetAltForEncoding(self, encoding, facename, interactive)
String | GetDefaultConfigPath() (Static method)
int | GetEncoding(n) (Static method)
String | GetEncodingDescription(encoding) (Static method)
int | GetEncodingFromName(name) (Static method)
String | GetEncodingName(encoding) (Static method)
size_t | GetSupportedEncodingsCount() (Static method)
bool | IsEncodingAvailable(self, encoding, facename)
FontMapper | Set(mapper) (Static method)
 | SetConfig(self, config)
 | SetConfigPath(self, prefix)
 | SetDialogParent(self, parent)
 | SetDialogTitle(self, title)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:00 2005 http://epydoc.sf.net


wx.Frame

Package wx :: Class Frame

Type Frame

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
        TopLevelWindow --+
                         |
                        Frame

Known Subclasses:
ACCustomizationFrame, DocChildFrame, DocParentFrame, DocTabbedParentFrame, FillingFrame, Frame, HtmlHelpFrame, MDIChildFrame, MDIParentFrame, MiniFrame, PreviewFrame, ProgressDialog, SplashScreen, SplashScreen, TestFrame

Proxy of C++ Frame class

Method Summary
Frame | __init__(self, parent, id, title, pos, size, style, name)
 | __repr__(self)
bool | Command(self, winid)
bool | Create(self, parent, id, pos, size, style, name) Create the GUI part of the Window for 2-phase creation mode.
StatusBar | CreateStatusBar(self, number, style, winid, name)
wxToolBar | CreateToolBar(self, style, winid, name)
 | DoGiveHelp(self, text, show)
 | DoMenuUpdates(self, menu)
VisualAttributes | GetClassDefaultAttributes(variant) Get the default attributes for this class. (Static method)
Point | GetClientAreaOrigin(self) Get the origin of the client area of the window relative to the window's top left corner (the client area may be shifted because of the borders, scrollbars, other decorations...)
MenuBar | GetMenuBar(self)
StatusBar | GetStatusBar(self)
int | GetStatusBarPane(self)
wxToolBar | GetToolBar(self)
 | PopStatusText(self, number)
bool | ProcessCommand(self, winid)
 | PushStatusText(self, text, number)
 | SendSizeEvent(self)
 | SetMenuBar(self, menubar)
 | SetStatusBar(self, statBar)
 | SetStatusBarPane(self, n)
 | SetStatusText(self, text, number)
 | SetStatusWidths(self, widths)
 | SetToolBar(self, toolbar)

Instance Method Details

Create(self,
          parent,
          id=-1,
          title=EmptyString,
          pos=DefaultPosition,
          size=DefaultSize,
          style=DEFAULT_FRAME_STYLE,
          name=FrameNameStr)

Create the GUI part of the Window for 2-phase creation mode.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

name
(type=String)

Returns:
bool
Overrides:
wx.Window.Create (inherited documentation)

GetClientAreaOrigin(self)

Get the origin of the client area of the window relative to the window's top left corner (the client area may be shifted because of the borders, scrollbars, other decorations...)

Returns:
Point
Overrides:
wx.Window.GetClientAreaOrigin

Static Method Details

GetClassDefaultAttributes(variant=WINDOW_VARIANT_NORMAL)

Get the default attributes for this class. This is useful if you want to use the same font or colour in your own control as in a standard control -- which is a much better idea than hard coding specific colours or fonts which might look completely out of place on the user's system, especially if it uses themes.

The variant parameter is only relevant under Mac currently and is ignore under other platforms. Under Mac, it will change the size of the returned font. See wx.Window.SetWindowVariant for more about this.

Parameters:
variant
(type=int)

Returns:
VisualAttributes

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:38 2005 http://epydoc.sf.net


wx.FSFile

Package wx :: Class FSFile

Type FSFile

object --+
         |
    Object --+
             |
            FSFile

Proxy of C++ FSFile class

Method Summary
FSFile | __init__(self, stream, loc, mimetype, anchor, modif)
 | __del__(self)
 | __repr__(self)
String | GetAnchor(self)
String | GetLocation(self)
String | GetMimeType(self)
DateTime | GetModificationTime(self)
InputStream | GetStream(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:10 2005 http://epydoc.sf.net


wx.FutureCall

Package wx :: Class FutureCall

Class FutureCall

A convenience class for wx.Timer, that calls the given callable object once after the given amount of milliseconds, passing any positional or keyword args. The return value of the callable is availbale after it has been run with the GetResult method.

If you don't need to get the return value or restart the timer then there is no need to hold a reference to this object. It will hold a reference to itself while the timer is running (the timer has a reference to self.Notify) but the cycle will be broken when the timer completes, automatically cleaning up the wx.FutureCall object.

See Also:

wx.CallAfter

Method Summary
 | __init__(self, millis, callable, *args, **kwargs)
 | __del__(self)
 | GetInterval(self)
 | GetResult(self)
 | HasRun(self)
 | IsRunning(self)
 | Notify(self) The timer has expired so call the callable.
 | Restart(self, millis, *args, **kwargs) (Re)start the timer
 | SetArgs(self, *args, **kwargs) (Re)set the args passed to the callable object.
 | Start(self, millis, *args, **kwargs) (Re)start the timer
 | Stop(self) Stop and destroy the timer.

Method Details

Notify(self)

The timer has expired so call the callable.

Restart(self, millis=None, *args, **kwargs)

(Re)start the timer

SetArgs(self, *args, **kwargs)

(Re)set the args passed to the callable object. This is useful in conjunction with Restart if you want to schedule a new call to the same callable object but with different parameters.

Start(self, millis=None, *args, **kwargs)

(Re)start the timer

Stop(self)

Stop and destroy the timer.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:17 2005 http://epydoc.sf.net


wx.Gauge

Package wx :: Class Gauge

Type Gauge

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
               Control --+
                         |
                        Gauge

Proxy of C++ Gauge class

Method Summary
Control | __init__(self, parent, id, pos, size, style, validator, name) Create a Control.
 | __repr__(self)
bool | Create(self, parent, id, pos, size, style, validator, name) Do the 2nd phase and create the GUI control.
int | GetBezelFace(self)
VisualAttributes | GetClassDefaultAttributes(variant) Get the default attributes for this class. (Static method)
int | GetRange(self)
int | GetShadowWidth(self)
int | GetValue(self)
bool | IsVertical(self)
 | SetBezelFace(self, w)
 | SetRange(self, range)
 | SetShadowWidth(self, w)
 | SetValue(self, pos)

Instance Method Details

__init__(self,
          parent,
          id=-1,
          range=100,
          pos=DefaultPosition,
          size=DefaultSize,
          style=GA_HORIZONTAL,
          validator=DefaultValidator,
          name=GaugeNameStr)
(Constructor)

Create a Control. Normally you should only call this from a subclass' __init__ as a plain old wx.Control is not very useful.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

validator
(type=Validator)

name
(type=String)

Returns:
Control
Overrides:
wx.Control.__init__ (inherited documentation)

Create(self,
          parent,
          id=-1,
          range=100,
          pos=DefaultPosition,
          size=DefaultSize,
          style=GA_HORIZONTAL,
          validator=DefaultValidator,
          name=GaugeNameStr)

Do the 2nd phase and create the GUI control.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

validator
(type=Validator)

name
(type=String)

Returns:
bool
Overrides:
wx.Control.Create (inherited documentation)

Static Method Details

GetClassDefaultAttributes(variant=WINDOW_VARIANT_NORMAL)

Get the default attributes for this class. This is useful if you want to use the same font or colour in your own control as in a standard control -- which is a much better idea than hard coding specific colours or fonts which might look completely out of place on the user's system, especially if it uses themes.

The variant parameter is only relevant under Mac currently and is ignore under other platforms. Under Mac, it will change the size of the returned font. See wx.Window.SetWindowVariant for more about this.

Parameters:
variant
(type=int)

Returns:
VisualAttributes

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:27 2005 http://epydoc.sf.net


wx.GBPosition

Package wx :: Class GBPosition

Type GBPosition

object --+
         |
        GBPosition

This class represents the position of an item in a virtual grid of rows and columns managed by a wx.GridBagSizer. wxPython has typemaps that will automatically convert from a 2-element sequence of integers to a wx.GBPosition, so you can use the more pythonic representation of the position nearly transparently in Python code.

Method Summary
GBPosition | __init__(self, row, col) This class represents the position of an item in a virtual grid of rows and columns managed by a wx.GridBagSizer.
bool | __eq__(self, other)
 | __getitem__(self, index)
 | __len__(self)
bool | __ne__(self, other)
 | __nonzero__(self)
 | __reduce__(self)
 | __repr__(self)
 | __setitem__(self, index, val)
 | __str__(self)
 | asTuple(*args, **kwargs) asTuple is deprecated, use Get instead
PyObject | Get(self)
int | GetCol(self)
int | GetRow(self)
 | Set(self, row, col)
 | SetCol(self, col)
 | SetRow(self, row)

Property Summary
 | col
 | row

Class Variable Summary
bool __safe_for_unpickling__ = True

Method Details

__init__(self, row=0, col=0)
(Constructor)

This class represents the position of an item in a virtual grid of rows and columns managed by a wx.GridBagSizer. wxPython has typemaps that will automatically convert from a 2-element sequence of integers to a wx.GBPosition, so you can use the more pythonic representation of the position nearly transparently in Python code.

Parameters:
row
(type=int)

col
(type=int)

Returns:
GBPosition
Overrides:
__builtin__.object.__init__

asTuple(*args, **kwargs)

asTuple is deprecated, use Get instead

Property Details

col

Get Method:
GetCol(self)
Set Method:
SetCol(self, col)

row

Get Method:
GetRow(self)
Set Method:
SetRow(self, row)

Class Variable Details

__safe_for_unpickling__

Type:
bool
Value:
True

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:12 2005 http://epydoc.sf.net


wx.GBSizerItem

Package wx :: Class GBSizerItem

Type GBSizerItem

object --+
         |
    Object --+
             |
     SizerItem --+
                 |
                GBSizerItem

The wx.GBSizerItem class is used to track the additional data about items in a wx.GridBagSizer such as the item's position in the grid and how many rows or columns it spans.

Method Summary
GBSizerItem | __init__(self) Constructs an empty wx.GBSizerItem.
 | __repr__(self)
GBPosition | GetEndPos(self) Get the row and column of the endpoint of this item.
GridBagSizer | GetGBSizer(self) Get the sizer this item is a member of.
GBPosition | GetPos(self) Get the grid position of the item
 | GetPosTuple(self)
GBSpan | GetSpan(self) Get the row and column spanning of the item
 | GetSpanTuple(self)
bool | Intersects(self, other) Returns True if this item and the other item instersect.
bool | IntersectsPos(self, pos, span) Returns True if the given pos/span would intersect with this item.
 | SetGBSizer(self, sizer) Set the sizer this item is a member of.
bool | SetPos(self, pos) If the item is already a member of a sizer then first ensure that there is no other item that would intersect with this one at the new position, then set the new position.
bool | SetSpan(self, span) If the item is already a member of a sizer then first ensure that there is no other item that would intersect with this one with its new spanning size, then set the new spanning.

Method Details

__init__(self)
(Constructor)

Constructs an empty wx.GBSizerItem. Either a window, sizer or spacer size will need to be set, as well as a position and span before this item can be used in a Sizer.

You will probably never need to create a wx.GBSizerItem directly as they are created automatically when the sizer's Add method is called.

Returns:
GBSizerItem
Overrides:
wx.SizerItem.__init__

GetEndPos(self)

Get the row and column of the endpoint of this item.

Returns:
GBPosition

GetGBSizer(self)

Get the sizer this item is a member of.

Returns:
GridBagSizer

GetPos(self)

Get the grid position of the item

Returns:
GBPosition

GetSpan(self)

Get the row and column spanning of the item

Returns:
GBSpan

Intersects(self, other)

Returns True if this item and the other item instersect.

Parameters:
other
(type=GBSizerItem)

Returns:
bool

IntersectsPos(self, pos, span)

Returns True if the given pos/span would intersect with this item.

Parameters:
pos
(type=GBPosition)

span
(type=GBSpan)

Returns:
bool

SetGBSizer(self, sizer)

Set the sizer this item is a member of.

Parameters:
sizer
(type=GridBagSizer)

SetPos(self, pos)

If the item is already a member of a sizer then first ensure that there is no other item that would intersect with this one at the new position, then set the new position. Returns True if the change is successful and after the next Layout() the item will be moved.

Parameters:
pos
(type=GBPosition)

Returns:
bool

SetSpan(self, span)

If the item is already a member of a sizer then first ensure that there is no other item that would intersect with this one with its new spanning size, then set the new spanning. Returns True if the change is successful and after the next Layout() the item will be resized.

Parameters:
span
(type=GBSpan)

Returns:
bool

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:40 2005 http://epydoc.sf.net


wx.GBSpan

Package wx :: Class GBSpan

Type GBSpan

object --+
         |
        GBSpan

This class is used to hold the row and column spanning attributes of items in a wx.GridBagSizer. wxPython has typemaps that will automatically convert from a 2-element sequence of integers to a wx.GBSpan, so you can use the more pythonic representation of the span nearly transparently in Python code.

Method Summary
GBSpan | __init__(self, rowspan, colspan) Construct a new wxGBSpan, optionally setting the rowspan and colspan.
bool | __eq__(self, other)
 | __getitem__(self, index)
 | __len__(self)
bool | __ne__(self, other)
 | __nonzero__(self)
 | __reduce__(self)
 | __repr__(self)
 | __setitem__(self, index, val)
 | __str__(self)
 | asTuple(*args, **kwargs) asTuple is deprecated, use Get instead
PyObject | Get(self)
int | GetColspan(self)
int | GetRowspan(self)
 | Set(self, rowspan, colspan)
 | SetColspan(self, colspan)
 | SetRowspan(self, rowspan)

Property Summary
 | colspan
 | rowspan

Class Variable Summary
bool __safe_for_unpickling__ = True

Method Details

__init__(self, rowspan=1, colspan=1)
(Constructor)

Construct a new wxGBSpan, optionally setting the rowspan and colspan. The default is (1,1). (Meaning that the item occupies one cell in each direction.

Parameters:
rowspan
(type=int)

colspan
(type=int)

Returns:
GBSpan
Overrides:
__builtin__.object.__init__

asTuple(*args, **kwargs)

asTuple is deprecated, use Get instead

Property Details

colspan

Get Method:
GetColspan(self)
Set Method:
SetColspan(self, colspan)

rowspan

Get Method:
GetRowspan(self)
Set Method:
SetRowspan(self, rowspan)

Class Variable Details

__safe_for_unpickling__

Type:
bool
Value:
True

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:05 2005 http://epydoc.sf.net


wx.GDIObject

Package wx :: Class GDIObject

Type GDIObject

object --+
         |
    Object --+
             |
            GDIObject

Known Subclasses:
Bitmap, Brush, Cursor, Font, Icon, Palette, Pen, Region

Proxy of C++ GDIObject class

Method Summary
GDIObject | __init__(self)
 | __del__(self)
 | __repr__(self)
bool | GetVisible(self)
bool | IsNull(self)
 | SetVisible(self, visible)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:13 2005 http://epydoc.sf.net


wx.GenericDirCtrl

Package wx :: Class GenericDirCtrl

Type GenericDirCtrl

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
               Control --+
                         |
                        GenericDirCtrl

Proxy of C++ GenericDirCtrl class

Method Summary
Control | __init__(self, parent, id, pos, size, style, validator, name) Create a Control.
 | __repr__(self)
bool | Create(self, parent, id, pos, size, style, validator, name) Do the 2nd phase and create the GUI control.
 | DoResize(self)
bool | ExpandPath(self, path)
(item, done) | FindChild(parentId, path) Find the child that matches the first part of 'path'.
String | GetDefaultPath(self)
String | GetFilePath(self)
String | GetFilter(self)
int | GetFilterIndex(self)
DirFilterListCtrl | GetFilterListCtrl(self)
String | GetPath(self)
TreeItemId | GetRootId(self)
bool | GetShowHidden(self)
TreeCtrl | GetTreeCtrl(self)
 | ReCreateTree(self)
 | SetDefaultPath(self, path)
 | SetFilter(self, filter)
 | SetFilterIndex(self, n)
 | SetPath(self, path)
 | ShowHidden(self, show)

Instance Method Details

__init__(self,
          parent,
          id=-1,
          dir=DirDialogDefaultFolderStr,
          pos=DefaultPosition,
          size=DefaultSize,
          style=wxDIRCTRL_3D_INTERNAL|wxSUNKEN_BORDER,
          filter=EmptyString,
          defaultFilter=0,
          name=TreeCtrlNameStr)
(Constructor)

Create a Control. Normally you should only call this from a subclass' __init__ as a plain old wx.Control is not very useful.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

validator
(type=Validator)

name
(type=String)

Returns:
Control
Overrides:
wx.Control.__init__ (inherited documentation)

Create(self,
          parent,
          id=-1,
          dir=DirDialogDefaultFolderStr,
          pos=DefaultPosition,
          size=DefaultSize,
          style=wxDIRCTRL_3D_INTERNAL|wxSUNKEN_BORDER,
          filter=EmptyString,
          defaultFilter=0,
          name=TreeCtrlNameStr)

Do the 2nd phase and create the GUI control.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

validator
(type=Validator)

name
(type=String)

Returns:
bool
Overrides:
wx.Control.Create (inherited documentation)

FindChild(parentId, path)

Find the child that matches the first part of 'path'. E.g. if a child path is "/usr" and 'path' is "/usr/include" then the child for /usr is returned. If the path string has been used (we're at the leaf), done is set to True.

Parameters:
parentId
(type=wxTreeItemId)

path
(type=wxString)

Returns:
(item, done)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:16 2005 http://epydoc.sf.net


wx.GIFHandler

Package wx :: Class GIFHandler

Type GIFHandler

object --+
         |
    Object --+
             |
  ImageHandler --+
                 |
                GIFHandler

A wx.ImageHandler for GIF image files.

Method Summary
GIFHandler | __init__(self) A wx.ImageHandler for GIF image files.
 | __repr__(self)

Method Details

__init__(self)
(Constructor)

A wx.ImageHandler for GIF image files.

Returns:
GIFHandler
Overrides:
wx.ImageHandler.__init__

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:16 2005 http://epydoc.sf.net


wx.gizmos.DynamicSashSplitEvent

Package wx :: Module gizmos :: Class DynamicSashSplitEvent

Type DynamicSashSplitEvent

object --+
         |
    Object --+
             |
         Event --+
                 |
      CommandEvent --+
                     |
                    DynamicSashSplitEvent

Proxy of C++ DynamicSashSplitEvent class

Method Summary
CommandEvent | __init__(self, commandType, winid) This event class contains information about command events, which originate from a variety of simple controls, as well as menus and toolbars.
 | __repr__(self)

Method Details

__init__(self, target)
(Constructor)

This event class contains information about command events, which originate from a variety of simple controls, as well as menus and toolbars.

Parameters:
commandType
(type=wxEventType)

winid
(type=int)

Returns:
CommandEvent
Overrides:
wx.CommandEvent.__init__ (inherited documentation)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:10 2005 http://epydoc.sf.net


wx.gizmos.DynamicSashUnifyEvent

Package wx :: Module gizmos :: Class DynamicSashUnifyEvent

Type DynamicSashUnifyEvent

object --+
         |
    Object --+
             |
         Event --+
                 |
      CommandEvent --+
                     |
                    DynamicSashUnifyEvent

Proxy of C++ DynamicSashUnifyEvent class

Method Summary
CommandEvent | __init__(self, commandType, winid) This event class contains information about command events, which originate from a variety of simple controls, as well as menus and toolbars.
 | __repr__(self)

Method Details

__init__(self, target)
(Constructor)

This event class contains information about command events, which originate from a variety of simple controls, as well as menus and toolbars.

Parameters:
commandType
(type=wxEventType)

winid
(type=int)

Returns:
CommandEvent
Overrides:
wx.CommandEvent.__init__ (inherited documentation)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:10:55 2005 http://epydoc.sf.net


wx.gizmos.DynamicSashWindow

Package wx :: Module gizmos :: Class DynamicSashWindow

Type DynamicSashWindow

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
                    DynamicSashWindow

Proxy of C++ DynamicSashWindow class

Method Summary
Window | __init__(self, parent, id, pos, size, style, name) Construct and show a generic Window.
 | __repr__(self)
bool | Create(self, parent, id, pos, size, style, name) Create the GUI part of the Window for 2-phase creation mode.
ScrollBar | GetHScrollBar(self, child)
ScrollBar | GetVScrollBar(self, child)

Instance Method Details

__init__(self,
          parent,
          id=-1,
          pos=DefaultPosition,
          size=DefaultSize,
          style=wxCLIP_CHILDREN|wxDS_MANAGE_SCROLLBARS|wxDS_DRAG_CORNER,
          name=DynamicSashNameStr)
(Constructor)

Construct and show a generic Window.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

name
(type=String)

Returns:
Window
Overrides:
wx.Window.__init__ (inherited documentation)

Create(self,
          parent,
          id=-1,
          pos=DefaultPosition,
          size=DefaultSize,
          style=wxCLIP_CHILDREN|wxDS_MANAGE_SCROLLBARS|wxDS_DRAG_CORNER,
          name=DynamicSashNameStr)

Create the GUI part of the Window for 2-phase creation mode.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

name
(type=String)

Returns:
bool
Overrides:
wx.Window.Create (inherited documentation)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:13 2005 http://epydoc.sf.net


wx.gizmos.EditableListBox

Package wx :: Module gizmos :: Class EditableListBox

Type EditableListBox

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
                 Panel --+
                         |
                        EditableListBox

Proxy of C++ EditableListBox class

Method Summary
Window | __init__(self, parent, id, pos, size, style, name) Construct and show a generic Window.
 | __repr__(self)
BitmapButton | GetDelButton(self)
BitmapButton | GetDownButton(self)
BitmapButton | GetEditButton(self)
ListCtrl | GetListCtrl(self)
BitmapButton | GetNewButton(self)
PyObject | GetStrings(self)
BitmapButton | GetUpButton(self)
 | SetStrings(self, strings)

Instance Method Details

__init__(self,
          parent,
          id=-1,
          label=EmptyString,
          pos=DefaultPosition,
          size=DefaultSize,
          style=wxEL_ALLOW_NEW|wxEL_ALLOW_EDIT|wxEL_ALLOW_DELETE,
          name=EditableListBoxNameStr)
(Constructor)

Construct and show a generic Window.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

name
(type=String)

Returns:
Window
Overrides:
wx.Panel.__init__ (inherited documentation)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:04 2005 http://epydoc.sf.net


wx.gizmos.LEDNumberCtrl

Package wx :: Module gizmos :: Class LEDNumberCtrl

Type LEDNumberCtrl

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
               Control --+
                         |
                        LEDNumberCtrl

Proxy of C++ LEDNumberCtrl class

Method Summary
Control | __init__(self, parent, id, pos, size, style, validator, name) Create a Control.
 | __repr__(self)
bool | Create(self, parent, id, pos, size, style) Do the 2nd phase and create the GUI control.
int | GetAlignment(self)
bool | GetDrawFaded(self)
String | GetValue(self)
 | SetAlignment(self, Alignment, Redraw)
 | SetDrawFaded(self, DrawFaded, Redraw)
 | SetValue(self, Value, Redraw)

Instance Method Details

__init__(self, parent, id=-1, pos=DefaultPosition, size=DefaultSize, style=wxLED_ALIGN_LEFT|wxLED_DRAW_FADED)
(Constructor)

Create a Control. Normally you should only call this from a subclass' __init__ as a plain old wx.Control is not very useful.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

validator
(type=Validator)

name
(type=String)

Returns:
Control
Overrides:
wx.Control.__init__ (inherited documentation)

Create(self,
          parent,
          id=-1,
          pos=DefaultPosition,
          size=DefaultSize,
          style=wxLED_ALIGN_LEFT|wxLED_DRAW_FADED)

Do the 2nd phase and create the GUI control.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

Returns:
bool
Overrides:
wx.Control.Create

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:18 2005 http://epydoc.sf.net


wx.gizmos.RemotelyScrolledTreeCtrl

Package wx :: Module gizmos :: Class RemotelyScrolledTreeCtrl
[frames | no frames]

Type RemotelyScrolledTreeCtrl

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
               Control --+
                         |
                  TreeCtrl --+
                             |
                            RemotelyScrolledTreeCtrl

Proxy of C++ RemotelyScrolledTreeCtrl class

Method Summary
Control | __init__(self, parent, id, pos, size, style, validator, name) Create a Control.
 | __repr__(self)
 | AdjustRemoteScrollbars(self)
Window | GetCompanionWindow(self)
ScrolledWindow | GetScrolledWindow(self)
 | HideVScrollbar(self)
 | ScrollToLine(self, posHoriz, posVert)
 | SetCompanionWindow(self, companion)

Instance Method Details

__init__(self, parent, id, pos=DefaultPosition, size=DefaultSize, style=TR_HAS_BUTTONS)
(Constructor)

Create a Control. Normally you should only call this from a subclass' __init__ as a plain old wx.Control is not very useful.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

validator
(type=Validator)

name
(type=String)

Returns:
Control
Overrides:
wx.TreeCtrl.__init__ (inherited documentation)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:41 2005 http://epydoc.sf.net


wx.gizmos.SplitterScrolledWindow

Package wx :: Module gizmos :: Class SplitterScrolledWindow

Type SplitterScrolledWindow

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
                 Panel --+
                         |
            ScrolledWindow --+
                             |
                            SplitterScrolledWindow

Proxy of C++ SplitterScrolledWindow class

Method Summary
Window | __init__(self, parent, id, pos, size, style, name) Construct and show a generic Window.
 | __repr__(self)

Instance Method Details

__init__(self, parent, id=-1, pos=DefaultPosition, size=DefaultSize, style=0)
(Constructor)

Construct and show a generic Window.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

name
(type=String)

Returns:
Window
Overrides:
wx.ScrolledWindow.__init__ (inherited documentation)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:11 2005 http://epydoc.sf.net


wx.gizmos.StaticPicture

Package wx :: Module gizmos :: Class StaticPicture

Type StaticPicture

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
               Control --+
                         |
                        StaticPicture

Proxy of C++ StaticPicture class

Method Summary
Control | __init__(self, parent, id, pos, size, style, validator, name) Create a Control.
 | __repr__(self)
bool | Create(self, parent, id, pos, size, style, validator, name) Do the 2nd phase and create the GUI control.
int | GetAlignment(self)
Bitmap | GetBitmap(self)
 | GetCustomScale(self, OUTPUT, OUTPUT)
Icon | GetIcon(self)
int | GetScale(self)
 | SetAlignment(self, align)
 | SetBitmap(self, bmp)
 | SetCustomScale(self, sx, sy)
 | SetIcon(self, icon)
 | SetScale(self, scale)

Instance Method Details

__init__(self,
          parent,
          id=-1,
          label=wxNullBitmap,
          pos=DefaultPosition,
          size=DefaultSize,
          style=0,
          name=StaticPictureNameStr)
(Constructor)

Create a Control. Normally you should only call this from a subclass' __init__ as a plain old wx.Control is not very useful.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

validator
(type=Validator)

name
(type=String)

Returns:
Control
Overrides:
wx.Control.__init__ (inherited documentation)

Create(self,
          parent,
          id=-1,
          label=wxNullBitmap,
          pos=DefaultPosition,
          size=DefaultSize,
          style=0,
          name=StaticPictureNameStr)

Do the 2nd phase and create the GUI control.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

validator
(type=Validator)

name
(type=String)

Returns:
bool
Overrides:
wx.Control.Create (inherited documentation)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:17 2005 http://epydoc.sf.net


wx.gizmos.ThinSplitterWindow

Package wx :: Module gizmos :: Class ThinSplitterWindow

Type ThinSplitterWindow

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
        SplitterWindow --+
                         |
                        ThinSplitterWindow

Proxy of C++ ThinSplitterWindow class

Method Summary
SplitterWindow | __init__(self, parent, id, pos, size, style, name) Constructor.
 | __repr__(self)

Instance Method Details

__init__(self, parent, id=-1, pos=DefaultPosition, size=DefaultSize, style=wxSP_3D|wxCLIP_CHILDREN)
(Constructor)

Constructor. Creates and shows a SplitterWindow.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

name
(type=String)

Returns:
SplitterWindow
Overrides:
wx.SplitterWindow.__init__ (inherited documentation)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:38 2005 http://epydoc.sf.net


wx.gizmos.TreeCompanionWindow

Package wx :: Module gizmos :: Class TreeCompanionWindow

Type TreeCompanionWindow

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
                    TreeCompanionWindow

Proxy of C++ TreeCompanionWindow class

Method Summary
Window | __init__(self, parent, id, pos, size, style, name) Construct and show a generic Window.
 | __repr__(self)
RemotelyScrolledTreeCtrl | GetTreeCtrl(self)
 | SetTreeCtrl(self, treeCtrl)

Instance Method Details

__init__(self, parent, id=-1, pos=DefaultPosition, size=DefaultSize, style=0)
(Constructor)

Construct and show a generic Window.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

name
(type=String)

Returns:
Window
Overrides:
wx.Window.__init__ (inherited documentation)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:10:44 2005 http://epydoc.sf.net


wx.gizmos.TreeListColumnInfo

Package wx :: Module gizmos :: Class TreeListColumnInfo

Type TreeListColumnInfo

object --+
         |
    Object --+
             |
            TreeListColumnInfo

Proxy of C++ TreeListColumnInfo class

Method Summary
TreeListColumnInfo | __init__(self, text, image, width, shown, alignment)
 | __repr__(self)
int | GetAlignment(self)
int | GetImage(self)
int | GetSelectedImage(self)
bool | GetShown(self)
String | GetText(self)
size_t | GetWidth(self)
 | SetAlignment(self, alignment)
 | SetImage(self, image)
 | SetSelectedImage(self, image)
 | SetShown(self, shown)
 | SetText(self, text)
 | SetWidth(self, with)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:40 2005 http://epydoc.sf.net


wx.gizmos.TreeListCtrl

Package wx :: Module gizmos :: Class TreeListCtrl

Type TreeListCtrl

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
               Control --+
                         |
                        TreeListCtrl

Proxy of C++ TreeListCtrl class

Method Summary
Control __init__(self, parent, id, pos, size, style, validator, name)
Create a Control.
__repr__(self)
AddColumn(self, text)
AddColumnInfo(self, col)
TreeItemId | AddRoot(self, text, image, selectedImage, data)
TreeItemId | AppendItem(self, parent, text, image, selectedImage, data)
AssignButtonsImageList(self, imageList)
AssignImageList(self, imageList)
AssignStateImageList(self, imageList)
Collapse(self, item)
CollapseAndReset(self, item)
bool Create(self, parent, id, pos, size, style, validator, name)
Do the 2nd phase and create the GUI control.
Delete(self, item)
DeleteAllItems(self)
DeleteChildren(self, item)
Edit(self, item)
EditLabel(self, item)
EnsureVisible(self, item)
Expand(self, item)
ExpandAll(self, item)
TreeItemId | FindItem(self, item, str, flags)
PyObject | GetBoundingRect(self, item, textOnly)
ImageList | GetButtonsImageList(self)
size_t | GetChildrenCount(self, item, recursively)
TreeListColumnInfo | GetColumn(self, column)
int | GetColumnAlignment(self, column)
size_t | GetColumnCount(self)
int | GetColumnImage(self, column)
String | GetColumnText(self, column)
int | GetColumnWidth(self, column)
size_t | GetCount(self)
PyObject | GetFirstChild(self, item)
TreeItemId | GetFirstVisibleItem(self)
Window | GetHeaderWindow(self)
ImageList | GetImageList(self)
unsigned int | GetIndent(self)
Colour | GetItemBackgroundColour(self, item)
bool | GetItemBold(self, item)
TreeItemData | GetItemData(self, item)
Font | GetItemFont(self, item)
int | GetItemImage(self, item, column, which)
TreeItemId | GetItemParent(self, item)
PyObject | GetItemPyData(self, item)
String | GetItemText(self, item, column)
Colour | GetItemTextColour(self, item)
TreeItemId | GetLastChild(self, item)
unsigned int | GetLineSpacing(self)
size_t | GetMainColumn(self)
ScrolledWindow | GetMainWindow(self)
TreeItemId | GetNext(self, item)
PyObject | GetNextChild(self, item, cookie)
TreeItemId | GetNextSibling(self, item)
TreeItemId | GetNextVisible(self, item)
TreeItemId | GetPrevSibling(self, item)
TreeItemId | GetPrevVisible(self, item)
PyObject | GetPyData(self, item)
TreeItemId | GetRootItem(self)
TreeItemId | GetSelection(self)
PyObject | GetSelections(self)
ImageList | GetStateImageList(self)
int HitTest(self, pt)
Test where the given (in client coords) point lies
InsertColumn(self, before, text)
InsertColumnInfo(self, before, col)
TreeItemId | InsertItem(self, parent, idPrevious, text, image, selectedImage, data)
TreeItemId | InsertItemBefore(self, parent, index, text, image, selectedImage, data)
bool | IsBold(self, item)
bool | IsColumnShown(self, column)
bool | IsExpanded(self, item)
bool | IsSelected(self, item)
bool | IsVisible(self, item)
bool | ItemHasChildren(self, item)
TreeItemId | PrependItem(self, parent, text, image, selectedImage, data)
RemoveColumn(self, column)
ScrollTo(self, item)
SelectAll(self, extended_select)
SelectItem(self, item, unselect_others, extended_select)
SetButtonsImageList(self, imageList)
SetColumn(self, column, info)
SetColumnAlignment(self, column, align)
SetColumnImage(self, column, image)
SetColumnText(self, column, text)
SetColumnWidth(self, column, width)
SetImageList(self, imageList)
SetIndent(*args, **kwargs)
SetIndent(self, unsigned int indent)
SetItemBackgroundColour(self, item, colour)
SetItemBold(self, item, bold)
SetItemData(self, item, data)
SetItemFont(self, item, font)
SetItemHasChildren(self, item, has)
SetItemImage(self, item, image, column, which)
SetItemPyData(self, item, obj)
SetItemText(self, item, text, column)
SetItemTextColour(self, item, colour)
SetLineSpacing(*args, **kwargs)
SetLineSpacing(self, unsigned int spacing)
SetMainColumn(self, column)
SetPyData(self, item, obj)
SetStateImageList(self, imageList)
ShowColumn(self, column, shown)
SortChildren(self, item)
Toggle(self, item)
Unselect(self)
UnselectAll(self)

Instance Method Details

__init__(self,
          parent,
          id=-1,
          pos=DefaultPosition,
          size=DefaultSize,
          style=TR_DEFAULT_STYLE,
          validator=DefaultValidator,
          name=TreeListCtrlNameStr)
(Constructor)

Create a Control. Normally you should only call this from a subclass' __init__ as a plain old wx.Control is not very useful.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

validator
(type=Validator)

name
(type=String)

Returns:
Control
Overrides:
wx.Control.__init__ (inherited documentation)

Create(self,
          parent,
          id=-1,
          pos=DefaultPosition,
          size=DefaultSize,
          style=TR_DEFAULT_STYLE,
          validator=DefaultValidator,
          name=TreeListCtrlNameStr)

Do the 2nd phase and create the GUI control.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

validator
(type=Validator)

name
(type=String)

Returns:
bool
Overrides:
wx.Control.Create

HitTest(self, point, OUTPUT, OUTPUT)

Test where the given (in client coords) point lies

Parameters:
pt
(type=Point)

Returns:
int
Overrides:
wx.Window.HitTest (inherited documentation)

SetIndent(*args, **kwargs)

SetIndent(self, unsigned int indent)

SetLineSpacing(*args, **kwargs)

SetLineSpacing(self, unsigned int spacing)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:39 2005 http://epydoc.sf.net


wx.gizmos

Package wx :: Module gizmos

Module wx.gizmos

Various gizmo classes: DynamicSashWindow, EditableListBox, LEDNumberCtrl, TreeListCtrl, etc.

Classes
DynamicSashSplitEvent | Proxy of C++ DynamicSashSplitEvent class
DynamicSashUnifyEvent | Proxy of C++ DynamicSashUnifyEvent class
DynamicSashWindow | Proxy of C++ DynamicSashWindow class
EditableListBox | Proxy of C++ EditableListBox class
LEDNumberCtrl | Proxy of C++ LEDNumberCtrl class
RemotelyScrolledTreeCtrl | Proxy of C++ RemotelyScrolledTreeCtrl class
SplitterScrolledWindow | Proxy of C++ SplitterScrolledWindow class
StaticPicture | Proxy of C++ StaticPicture class
ThinSplitterWindow | Proxy of C++ ThinSplitterWindow class
TreeCompanionWindow | Proxy of C++ TreeCompanionWindow class
TreeListColumnInfo | Proxy of C++ TreeListColumnInfo class
TreeListCtrl | Proxy of C++ TreeListCtrl class

Function Summary
DynamicSashWindow | PreDynamicSashWindow()
LEDNumberCtrl | PreLEDNumberCtrl()
StaticPicture | PreStaticPicture()
TreeListCtrl | PreTreeListCtrl()

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:03 2005 http://epydoc.sf.net


wx.glcanvas.GLCanvas

Package wx :: Module glcanvas :: Class GLCanvas

Type GLCanvas

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
                    GLCanvas

Proxy of C++ GLCanvas class

Method Summary
Window | __init__(self, parent, id, pos, size, style, name) Construct and show a generic Window.
 | __repr__(self)
GLContext | GetContext(self)
 | SetColour(self, colour)
 | SetCurrent(self)
 | SwapBuffers(self)

Instance Method Details

__init__(self,
          parent,
          id=-1,
          pos=DefaultPosition,
          size=DefaultSize,
          style=0,
          name=GLCanvasNameStr,
          attribList=None,
          palette=wxNullPalette)
(Constructor)

Construct and show a generic Window.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

name
(type=String)

Returns:
Window
Overrides:
wx.Window.__init__ (inherited documentation)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:17 2005 http://epydoc.sf.net


wx.glcanvas.GLContext

Package wx :: Module glcanvas :: Class GLContext

Type GLContext

object --+
         |
    Object --+
             |
            GLContext

Proxy of C++ GLContext class

Method Summary
GLContext | __init__(self, isRGB, win, palette, other)
 | __del__(self)
 | __repr__(self)
wxPalette | CreateDefaultPalette(self)
wxPalette | GetPalette(self)
Window | GetWindow(self)
 | SetColour(self, colour)
 | SetCurrent(self)
 | SetupPalette(self, palette)
 | SetupPixelFormat(self)
 | SwapBuffers(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:01 2005 http://epydoc.sf.net


wx.glcanvas

Package wx :: Module glcanvas

Module wx.glcanvas

GLCanvas provides an OpenGL Context on a wx.Window.

Classes
GLCanvas | Proxy of C++ GLCanvas class
GLContext | Proxy of C++ GLContext class

Function Summary
GLCanvas GLCanvasWithContext(parent, shared, id, pos, size, style, name, attribList, palette)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:03 2005 http://epydoc.sf.net


wx.grid.GridCellAttr

Package wx :: Module grid :: Class GridCellAttr

Type GridCellAttr

object --+
         |
        GridCellAttr

Proxy of C++ GridCellAttr class

Method Summary
GridCellAttr | __init__(self, attrDefault)
 | __repr__(self)
GridCellAttr | Clone(self)
 | DecRef(self)
(hAlign, vAlign) | GetAlignment()
Colour | GetBackgroundColour(self)
GridCellEditor | GetEditor(self, grid, row, col)
Font | GetFont(self)
int | GetKind(self)
bool | GetOverflow(self)
GridCellRenderer | GetRenderer(self, grid, row, col)
(num_rows, num_cols) | GetSize()
Colour | GetTextColour(self)
bool | HasAlignment(self)
bool | HasBackgroundColour(self)
bool | HasEditor(self)
bool | HasFont(self)
bool | HasOverflowMode(self)
bool | HasReadWriteMode(self)
bool | HasRenderer(self)
bool | HasTextColour(self)
 | IncRef(self)
bool | IsReadOnly(self)
 | MergeWith(self, mergefrom)
 | SetAlignment(self, hAlign, vAlign)
 | SetBackgroundColour(self, colBack)
 | SetDefAttr(self, defAttr)
 | SetEditor(self, editor)
 | SetFont(self, font)
 | SetKind(self, kind)
 | SetOverflow(self, allow)
 | SetReadOnly(self, isReadOnly)
 | SetRenderer(self, renderer)
 | SetSize(self, num_rows, num_cols)
 | SetTextColour(self, colText)

Class Variable Summary
int | Any = 0
int | Cell = 2
int | Col = 4
int | Default = 1
int | Merged = 5
int | Row = 3

Class Variable Details

Any

Type:
int
Value:
0

Cell

Type:
int
Value:
2

Col

Type:
int
Value:
4

Default

Type:
int
Value:
1

Merged

Type:
int
Value:
5

Row

Type:
int
Value:
3

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:10 2005 http://epydoc.sf.net


wx.grid.GridCellAttrProvider

Package wx :: Module grid :: Class GridCellAttrProvider

Type GridCellAttrProvider

object --+
         |
        GridCellAttrProvider

Known Subclasses:
PyGridCellAttrProvider

Proxy of C++ GridCellAttrProvider class

Method Summary
GridCellAttrProvider | __init__(self)
 | __repr__(self)
GridCellAttr | GetAttr(self, row, col, kind)
 | SetAttr(self, attr, row, col)
 | SetColAttr(self, attr, col)
 | SetRowAttr(self, attr, row)
 | UpdateAttrCols(self, pos, numCols)
 | UpdateAttrRows(self, pos, numRows)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:41 2005 http://epydoc.sf.net


wx.grid.GridCellAutoWrapStringEditor

Package wx :: Module grid :: Class GridCellAutoWrapStringEditor
[frames | no frames]

Type GridCellAutoWrapStringEditor

    object --+
             |
GridCellEditor --+
                 |
GridCellTextEditor --+
                     |
                    GridCellAutoWrapStringEditor

Proxy of C++ GridCellAutoWrapStringEditor class

Method Summary
GridCellAutoWrapStringEditor | __init__(self)
 | __repr__(self)
String | GetValue(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:58 2005 http://epydoc.sf.net


wx.grid.GridCellAutoWrapStringRenderer

Package wx :: Module grid :: Class GridCellAutoWrapStringRenderer
[frames | no frames]

Type GridCellAutoWrapStringRenderer

        object --+
                 |
  GridCellRenderer --+
                     |
GridCellStringRenderer --+
                         |
                        GridCellAutoWrapStringRenderer

Proxy of C++ GridCellAutoWrapStringRenderer class

Method Summary
GridCellAutoWrapStringRenderer | __init__(self)
 | __repr__(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:59 2005 http://epydoc.sf.net


wx.grid.GridCellBoolEditor

Package wx :: Module grid :: Class GridCellBoolEditor

Type GridCellBoolEditor

    object --+
             |
GridCellEditor --+
                 |
                GridCellBoolEditor

Proxy of C++ GridCellBoolEditor class

Method Summary
GridCellBoolEditor | __init__(self)
 | __repr__(self)
String | GetValue(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:27 2005 http://epydoc.sf.net


wx.grid.GridCellBoolRenderer

Package wx :: Module grid :: Class GridCellBoolRenderer

Type GridCellBoolRenderer

      object --+
               |
GridCellRenderer --+
                   |
                  GridCellBoolRenderer

Proxy of C++ GridCellBoolRenderer class

Method Summary
GridCellBoolRenderer | __init__(self)
 | __repr__(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:11 2005 http://epydoc.sf.net


wx.grid.GridCellChoiceEditor

Package wx :: Module grid :: Class GridCellChoiceEditor

Type GridCellChoiceEditor

    object --+
             |
GridCellEditor --+
                 |
                GridCellChoiceEditor

Known Subclasses:
GridCellEnumEditor

Proxy of C++ GridCellChoiceEditor class

Method Summary
GridCellChoiceEditor | __init__(self, choices, allowOthers)
 | __repr__(self)
String | GetValue(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:21 2005 http://epydoc.sf.net


wx.grid.GridCellCoords

Package wx :: Module grid :: Class GridCellCoords

Type GridCellCoords

object --+
         |
        GridCellCoords

Proxy of C++ GridCellCoords class

Method Summary
GridCellCoords | __init__(self, r, c)
 | __del__(self)
bool | __eq__(self, other)
 | __getitem__(self, index)
 | __len__(self)
bool | __ne__(self, other)
 | __repr__(self)
 | __setitem__(self, index, val)
 | __str__(self)
 | asTuple(*args, **kwargs) asTuple is deprecated, use Get instead
PyObject | Get(self)
int | GetCol(self)
int | GetRow(self)
 | Set(self, row, col)
 | SetCol(self, n)
 | SetRow(self, n)

Method Details

asTuple(*args, **kwargs)

asTuple is deprecated, use Get instead

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:41 2005 http://epydoc.sf.net


wx.grid.GridCellDateTimeRenderer

Package wx :: Module grid :: Class GridCellDateTimeRenderer

Type GridCellDateTimeRenderer

        object --+
                 |
  GridCellRenderer --+
                     |
GridCellStringRenderer --+
                         |
                        GridCellDateTimeRenderer

Proxy of C++ GridCellDateTimeRenderer class

Method Summary
GridCellDateTimeRenderer | __init__(self, outformat, informat)
 | __repr__(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:17 2005 http://epydoc.sf.net


wx.grid.GridCellEditor

Package wx :: Module grid :: Class GridCellEditor

Type GridCellEditor

object --+
         |
        GridCellEditor

Known Subclasses:
GridCellBoolEditor, GridCellChoiceEditor, GridCellTextEditor, PyGridCellEditor

Proxy of C++ GridCellEditor class

Method Summary
 | __init__(self)
 | __repr__(self)
 | BeginEdit(self, row, col, grid)
GridCellEditor | Clone(self)
 | Create(self, parent, id, evtHandler)
 | DecRef(self)
 | Destroy(self)
bool | EndEdit(self, row, col, grid)
GridCellAttr | GetCellAttr(self)
Control | GetControl(self)
 | HandleReturn(self, event)
 | IncRef(self)
bool | IsAcceptedKey(self, event)
bool | IsCreated(self)
 | PaintBackground(self, rectCell, attr)
 | Reset(self)
 | SetCellAttr(self, attr)
 | SetControl(self, control)
 | SetParameters(self, params)
 | SetSize(self, rect)
 | Show(self, show, attr)
 | StartingClick(self)
 | StartingKey(self, event)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:00 2005 http://epydoc.sf.net


wx.grid.GridCellEnumEditor

Package wx :: Module grid :: Class GridCellEnumEditor

Type GridCellEnumEditor

      object --+
               |
  GridCellEditor --+
                   |
GridCellChoiceEditor --+
                       |
                      GridCellEnumEditor

Proxy of C++ GridCellEnumEditor class

Method Summary
GridCellEnumEditor | __init__(self, choices)
 | __repr__(self)
String | GetValue(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:56 2005 http://epydoc.sf.net


wx.grid.GridCellEnumRenderer

Package wx :: Module grid :: Class GridCellEnumRenderer

Type GridCellEnumRenderer

        object --+
                 |
  GridCellRenderer --+
                     |
GridCellStringRenderer --+
                         |
                        GridCellEnumRenderer

Proxy of C++ GridCellEnumRenderer class

Method Summary
GridCellEnumRenderer | __init__(self, choices)
 | __repr__(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:16 2005 http://epydoc.sf.net


wx.grid.GridCellFloatEditor

Package wx :: Module grid :: Class GridCellFloatEditor

Type GridCellFloatEditor

    object --+
             |
GridCellEditor --+
                 |
GridCellTextEditor --+
                     |
                    GridCellFloatEditor

Proxy of C++ GridCellFloatEditor class

Method Summary
GridCellFloatEditor | __init__(self, width, precision)
 | __repr__(self)
String | GetValue(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:17 2005 http://epydoc.sf.net


wx.grid.GridCellFloatRenderer

Package wx :: Module grid :: Class GridCellFloatRenderer

Type GridCellFloatRenderer

        object --+
                 |
  GridCellRenderer --+
                     |
GridCellStringRenderer --+
                         |
                        GridCellFloatRenderer

Proxy of C++ GridCellFloatRenderer class

Method Summary
GridCellFloatRenderer | __init__(self, width, precision)
 | __repr__(self)
int | GetPrecision(self)
int | GetWidth(self)
 | SetPrecision(self, precision)
 | SetWidth(self, width)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:10 2005 http://epydoc.sf.net


wx.grid.GridCellNumberEditor

Package wx :: Module grid :: Class GridCellNumberEditor

Type GridCellNumberEditor

    object --+
             |
GridCellEditor --+
                 |
GridCellTextEditor --+
                     |
                    GridCellNumberEditor

Proxy of C++ GridCellNumberEditor class

Method Summary
GridCellNumberEditor | __init__(self, min, max)
 | __repr__(self)
String | GetValue(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:10:48 2005 http://epydoc.sf.net


wx.grid.GridCellNumberRenderer

Package wx :: Module grid :: Class GridCellNumberRenderer

Type GridCellNumberRenderer

        object --+
                 |
  GridCellRenderer --+
                     |
GridCellStringRenderer --+
                         |
                        GridCellNumberRenderer

Proxy of C++ GridCellNumberRenderer class

Method Summary
GridCellNumberRenderer | __init__(self)
 | __repr__(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:59 2005 http://epydoc.sf.net


wx.grid.GridCellRenderer

Package wx :: Module grid :: Class GridCellRenderer

Type GridCellRenderer

object --+
         |
        GridCellRenderer

Known Subclasses:
GridCellBoolRenderer, GridCellStringRenderer, PyGridCellRenderer

Proxy of C++ GridCellRenderer class

Method Summary
 | __init__(self)
 | __repr__(self)
GridCellRenderer | Clone(self)
 | DecRef(self)
 | Draw(self, grid, attr, dc, rect, row, col, isSelected)
Size | GetBestSize(self, grid, attr, dc, row, col)
 | IncRef(self)
 | SetParameters(self, params)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:12 2005 http://epydoc.sf.net


wx.grid.GridCellStringRenderer

Package wx :: Module grid :: Class GridCellStringRenderer

Type GridCellStringRenderer

      object --+
               |
GridCellRenderer --+
                   |
                  GridCellStringRenderer

Known Subclasses:
GridCellAutoWrapStringRenderer, GridCellDateTimeRenderer, GridCellEnumRenderer, GridCellFloatRenderer, GridCellNumberRenderer

Proxy of C++ GridCellStringRenderer class

Method Summary
GridCellStringRenderer | __init__(self)
 | __repr__(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:27 2005 http://epydoc.sf.net


wx.grid.GridCellTextEditor

Package wx :: Module grid :: Class GridCellTextEditor

Type GridCellTextEditor

    object --+
             |
GridCellEditor --+
                 |
                GridCellTextEditor

Known Subclasses:
GridCellAutoWrapStringEditor, GridCellFloatEditor, GridCellNumberEditor

Proxy of C++ GridCellTextEditor class

Method Summary
GridCellTextEditor | __init__(self)
 | __repr__(self)
String | GetValue(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:07 2005 http://epydoc.sf.net


wx.grid.Grid

Package wx :: Module grid :: Class Grid

Type Grid

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
                 Panel --+
                         |
            ScrolledWindow --+
                             |
                            Grid

Known Subclasses:
CSheet

Proxy of C++ Grid class

Method Summary
Window __init__(self, parent, id, pos, size, style, name)
Construct and show a generic Window.
__repr__(self)
bool | AppendCols(self, numCols, updateLabels)
bool | AppendRows(self, numRows, updateLabels)
AutoSize(self)
AutoSizeColLabelSize(self, col)
AutoSizeColumn(self, col, setAsMin)
AutoSizeColumns(self, setAsMin)
AutoSizeRow(self, row, setAsMin)
AutoSizeRowLabelSize(self, row)
AutoSizeRows(self, setAsMin)
BeginBatch(self)
Rect | BlockToDeviceRect(self, topLeft, bottomRight)
bool | CanDragCell(self)
bool | CanDragColSize(self)
bool | CanDragGridSize(self)
bool | CanDragRowSize(self)
bool | CanEnableCellControl(self)
Rect | CellToRect(self, row, col)
ClearGrid(self)
ClearSelection(self)
bool Create(self, parent, id, pos, size, style, name)
Create the GUI part of the Window for 2-phase creation mode.
bool | CreateGrid(self, numRows, numCols, selmode)
bool | DeleteCols(self, pos, numCols, updateLabels)
bool | DeleteRows(self, pos, numRows, updateLabels)
DeselectCell(self, row, col)
DeselectCol(self, col)
DeselectRow(self, row)
DisableCellEditControl(self)
DisableDragCell(self)
DisableDragColSize(self)
DisableDragGridSize(self)
DisableDragRowSize(self)
DrawCellHighlight(self, dc, attr)
DrawTextRectangle(*args, **kwargs)
int verticalAlignment=TOP, int textOrientation=HORIZONTAL)
EnableCellEditControl(self, enable)
EnableDragCell(self, enable)
EnableDragColSize(self, enable)
EnableDragGridSize(self, enable)
EnableDragRowSize(self, enable)
EnableEditing(self, edit)
EnableGridLines(self, enable)
EndBatch(self)
ForceRefresh(self)
int | GetBatchCount(self)
(horiz, vert) | GetCellAlignment()
Colour | GetCellBackgroundColour(self, row, col)
GridCellEditor | GetCellEditor(self, row, col)
Font | GetCellFont(self, row, col)
Colour | GetCellHighlightColour(self)
int | GetCellHighlightPenWidth(self)
int | GetCellHighlightROPenWidth(self)
bool | GetCellOverflow(self, row, col)
GridCellRenderer | GetCellRenderer(self, row, col)
(num_rows, num_cols) | GetCellSize(row, col)
Colour | GetCellTextColour(self, row, col)
String | GetCellValue(self, row, col)
VisualAttributes GetClassDefaultAttributes(variant)
Get the default attributes for this class. (Static method)
(horiz, vert) | GetColLabelAlignment()
int | GetColLabelSize(self)
int | GetColLabelTextOrientation(self)
String | GetColLabelValue(self, col)
int | GetColMinimalAcceptableWidth(self)
int | GetColSize(self, col)
(horiz, vert) | GetDefaultCellAlignment()
Colour | GetDefaultCellBackgroundColour(self)
Font | GetDefaultCellFont(self)
bool | GetDefaultCellOverflow(self)
Colour | GetDefaultCellTextColour(self)
int | GetDefaultColLabelSize(self)
int | GetDefaultColSize(self)
GridCellEditor | GetDefaultEditor(self)
GridCellEditor | GetDefaultEditorForCell(self, row, col)
GridCellEditor | GetDefaultEditorForType(self, typeName)
GridCellRenderer | GetDefaultRenderer(self)
GridCellRenderer | GetDefaultRendererForCell(self, row, col)
GridCellRenderer | GetDefaultRendererForType(self, typeName)
int | GetDefaultRowLabelSize(self)
int | GetDefaultRowSize(self)
Window | GetGridColLabelWindow(self)
Window | GetGridCornerLabelWindow(self)
int | GetGridCursorCol(self)
int | GetGridCursorRow(self)
Colour | GetGridLineColour(self)
Window | GetGridRowLabelWindow(self)
Window | GetGridWindow(self)
Colour | GetLabelBackgroundColour(self)
Font | GetLabelFont(self)
Colour | GetLabelTextColour(self)
int | GetNumberCols(self)
int | GetNumberRows(self)
GridCellAttr | GetOrCreateCellAttr(self, row, col)
(horiz, vert) | GetRowLabelAlignment()
int | GetRowLabelSize(self)
String | GetRowLabelValue(self, row)
int | GetRowMinimalAcceptableHeight(self)
int | GetRowSize(self, row)
int | GetScrollLineX(self)
int | GetScrollLineY(self)
int | GetScrollX(self, x)
int | GetScrollY(self, y)
wxGridCellCoordsArray | GetSelectedCells(self)
wxArrayInt | GetSelectedCols(self)
wxArrayInt | GetSelectedRows(self)
Colour | GetSelectionBackground(self)
wxGridCellCoordsArray | GetSelectionBlockBottomRight(self)
wxGridCellCoordsArray | GetSelectionBlockTopLeft(self)
Colour | GetSelectionForeground(self)
WXGRIDSELECTIONMODES | GetSelectionMode(self)
GridTableBase | GetTable(self)
(width, height) | GetTextBoxSize(dc, lines)
bool | GridLinesEnabled(self)
HideCellEditControl(self)
bool | InsertCols(self, pos, numCols, updateLabels)
bool | InsertRows(self, pos, numRows, updateLabels)
bool | IsCellEditControlEnabled(self)
bool | IsCellEditControlShown(self)
bool | IsCurrentCellReadOnly(self)
bool | IsEditable(self)
bool | IsInSelection(self, row, col)
bool | IsReadOnly(self, row, col)
bool | IsSelection(self)
bool | IsVisible(self, row, col, wholeCellVisible)
MakeCellVisible(self, row, col)
bool | MoveCursorDown(self, expandSelection)
bool | MoveCursorDownBlock(self, expandSelection)
bool | MoveCursorLeft(self, expandSelection)
bool | MoveCursorLeftBlock(self, expandSelection)
bool | MoveCursorRight(self, expandSelection)
bool | MoveCursorRightBlock(self, expandSelection)
bool | MoveCursorUp(self, expandSelection)
bool | MoveCursorUpBlock(self, expandSelection)
bool | MovePageDown(self)
bool | MovePageUp(self)
ProcessTableMessage(*args, **kwargs)
ProcessTableMessage(self, GridTableMessage ??) -> bool
RegisterDataType(self, typeName, renderer, editor)
SaveEditControlValue(self)
SelectAll(self)
SelectBlock(self, topRow, leftCol, bottomRow, rightCol, addToSelected)
SelectCol(self, col, addToSelected)
SelectRow(self, row, addToSelected)
SetAttr(self, row, col, attr)
SetCellAlignment(self, row, col, horiz, vert)
SetCellBackgroundColour(*args, **kwargs)
SetCellBackgroundColour(self, int row, int col, Colour ??)
SetCellEditor(self, row, col, editor)
SetCellFont(*args, **kwargs)
SetCellFont(self, int row, int col, Font ??)
SetCellHighlightColour(*args, **kwargs)
SetCellHighlightColour(self, Colour ??)
SetCellHighlightPenWidth(self, width)
SetCellHighlightROPenWidth(self, width)
SetCellOverflow(self, row, col, allow)
SetCellRenderer(self, row, col, renderer)
SetCellSize(self, row, col, num_rows, num_cols)
SetCellTextColour(*args, **kwargs)
SetCellTextColour(self, int row, int col, Colour ??)
SetCellValue(self, row, col, s)
SetColAttr(self, col, attr)
SetColFormatBool(self, col)
SetColFormatCustom(self, col, typeName)
SetColFormatFloat(self, col, width, precision)
SetColFormatNumber(self, col)
SetColLabelAlignment(self, horiz, vert)
SetColLabelSize(self, height)
SetColLabelTextOrientation(self, textOrientation)
SetColLabelValue(*args, **kwargs)
SetColLabelValue(self, int col, String ??)
SetColMinimalAcceptableWidth(self, width)
SetColMinimalWidth(self, col, width)
SetColSize(self, col, width)
SetDefaultCellAlignment(self, horiz, vert)
SetDefaultCellBackgroundColour(*args, **kwargs)
SetDefaultCellBackgroundColour(self, Colour ??)
SetDefaultCellFont(*args, **kwargs)
SetDefaultCellFont(self, Font ??)
SetDefaultCellOverflow(self, allow)
SetDefaultCellTextColour(*args, **kwargs)
SetDefaultCellTextColour(self, Colour ??)
SetDefaultColSize(self, width, resizeExistingCols)
SetDefaultEditor(self, editor)
SetDefaultRenderer(self, renderer)
SetDefaultRowSize(self, height, resizeExistingRows)
SetGridCursor(self, row, col)
SetGridLineColour(*args, **kwargs)
SetGridLineColour(self, Colour ??)
SetLabelBackgroundColour(*args, **kwargs)
SetLabelBackgroundColour(self, Colour ??)
SetLabelFont(*args, **kwargs)
SetLabelFont(self, Font ??)
SetLabelTextColour(*args, **kwargs)
SetLabelTextColour(self, Colour ??)
SetMargins(self, extraWidth, extraHeight)
SetReadOnly(self, row, col, isReadOnly)
SetRowAttr(self, row, attr)
SetRowLabelAlignment(self, horiz, vert)
SetRowLabelSize(self, width)
SetRowLabelValue(*args, **kwargs)
SetRowLabelValue(self, int row, String ??)
SetRowMinimalAcceptableHeight(self, width)
SetRowMinimalHeight(self, row, width)
SetRowSize(self, row, height)
SetScrollLineX(self, x)
SetScrollLineY(self, y)
SetSelectionBackground(self, c)
SetSelectionForeground(self, c)
SetSelectionMode(self, selmode)
bool | SetTable(self, table, takeOwnership, selmode)
ShowCellEditControl(self)
int | XToCol(self, x)
int | XToEdgeOfCol(self, x)
GridCellCoords | XYToCell(self, x, y)
int | YToEdgeOfRow(self, y)
int | YToRow(self, y)

Class Variable Summary
int | SelectCells = 0
int | SelectColumns = 2
int | SelectRows = 1
int | wxGridSelectCells = 0
int | wxGridSelectColumns = 2
int | wxGridSelectRows = 1

Instance Method Details

__init__(self,
          parent,
          id=-1,
          pos=DefaultPosition,
          size=DefaultSize,
          style=WANTS_CHARS,
          name=PanelNameStr)
(Constructor)

Construct and show a generic Window.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

name
(type=String)

Returns:
Window
Overrides:
wx.ScrolledWindow.__init__ (inherited documentation)

Create(self,
          parent,
          id=-1,
          pos=DefaultPosition,
          size=DefaultSize,
          style=WANTS_CHARS,
          name=PanelNameStr)

Create the GUI part of the Window for 2-phase creation mode.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

name
(type=String)

Returns:
bool
Overrides:
wx.ScrolledWindow.Create (inherited documentation)

DrawTextRectangle(*args, **kwargs)

DrawTextRectangle(self, DC dc, String ??, Rect ??, int horizontalAlignment=LEFT,
int verticalAlignment=TOP, int textOrientation=HORIZONTAL)

ProcessTableMessage(*args, **kwargs)

ProcessTableMessage(self, GridTableMessage ??) -> bool

SetCellBackgroundColour(*args, **kwargs)

SetCellBackgroundColour(self, int row, int col, Colour ??)

SetCellFont(*args, **kwargs)

SetCellFont(self, int row, int col, Font ??)

SetCellHighlightColour(*args, **kwargs)

SetCellHighlightColour(self, Colour ??)

SetCellTextColour(*args, **kwargs)

SetCellTextColour(self, int row, int col, Colour ??)

SetColLabelValue(*args, **kwargs)

SetColLabelValue(self, int col, String ??)

SetDefaultCellBackgroundColour(*args, **kwargs)

SetDefaultCellBackgroundColour(self, Colour ??)

SetDefaultCellFont(*args, **kwargs)

SetDefaultCellFont(self, Font ??)

SetDefaultCellTextColour(*args, **kwargs)

SetDefaultCellTextColour(self, Colour ??)

SetGridLineColour(*args, **kwargs)

SetGridLineColour(self, Colour ??)

SetLabelBackgroundColour(*args, **kwargs)

SetLabelBackgroundColour(self, Colour ??)

SetLabelFont(*args, **kwargs)

SetLabelFont(self, Font ??)

SetLabelTextColour(*args, **kwargs)

SetLabelTextColour(self, Colour ??)

SetRowLabelValue(*args, **kwargs)

SetRowLabelValue(self, int row, String ??)

Static Method Details

GetClassDefaultAttributes(variant=WINDOW_VARIANT_NORMAL)

Get the default attributes for this class. This is useful if you want to use the same font or colour in your own control as in a standard control -- which is a much better idea than hard coding specific colours or fonts which might look completely out of place on the user's system, especially if it uses themes.

The variant parameter is only relevant under Mac currently and is ignore under other platforms. Under Mac, it will change the size of the returned font. See wx.Window.SetWindowVariant for more about this.

Parameters:
variant
(type=int)

Returns:
VisualAttributes

Class Variable Details

SelectCells

Type:
int
Value:
0

SelectColumns

Type:
int
Value:
2

SelectRows

Type:
int
Value:
1

wxGridSelectCells

Type:
int
Value:
0

wxGridSelectColumns

Type:
int
Value:
2

wxGridSelectRows

Type:
int
Value:
1

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:40 2005 http://epydoc.sf.net


wx.grid.GridEditorCreatedEvent

Package wx :: Module grid :: Class GridEditorCreatedEvent

Type GridEditorCreatedEvent

object --+
         |
    Object --+
             |
         Event --+
                 |
      CommandEvent --+
                     |
                    GridEditorCreatedEvent

Proxy of C++ GridEditorCreatedEvent class

Method Summary
CommandEvent | __init__(self, commandType, winid) This event class contains information about command events, which originate from a variety of simple controls, as well as menus and toolbars.
 | __repr__(self)
int | GetCol(self)
Control | GetControl(self)
int | GetRow(self)
 | SetCol(self, col)
 | SetControl(self, ctrl)
 | SetRow(self, row)

Method Details

__init__(self, id, type, obj, row, col, ctrl)
(Constructor)

This event class contains information about command events, which originate from a variety of simple controls, as well as menus and toolbars.

Parameters:
commandType
(type=wxEventType)

winid
(type=int)

Returns:
CommandEvent
Overrides:
wx.CommandEvent.__init__ (inherited documentation)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:23 2005 http://epydoc.sf.net


wx.grid.GridEvent

Package wx :: Module grid :: Class GridEvent

Type GridEvent

object --+
         |
    Object --+
             |
         Event --+
                 |
      CommandEvent --+
                     |
           NotifyEvent --+
                         |
                        GridEvent

Proxy of C++ GridEvent class

Method Summary
NotifyEvent | __init__(self, commandType, winid) An instance of this class (or one of its derived classes) is sent from a control when the control's state is being changed and the control allows that change to be prevented from happening.
 | __repr__(self)
bool | AltDown(self)
bool | ControlDown(self)
int | GetCol(self)
Point | GetPosition(self)
int | GetRow(self)
bool | MetaDown(self)
bool | Selecting(self)
bool | ShiftDown(self)

Method Details

__init__(self,
          id,
          type,
          obj,
          row=-1,
          col=-1,
          x=-1,
          y=-1,
          sel=True,
          control=False,
          shift=False,
          alt=False,
          meta=False)
(Constructor)

An instance of this class (or one of its derived classes) is sent from a control when the control's state is being changed and the control allows that change to be prevented from happening. The event handler can call Veto or Allow to tell the control what to do.

Parameters:
commandType
(type=wxEventType)

winid
(type=int)

Returns:
NotifyEvent
Overrides:
wx.NotifyEvent.__init__ (inherited documentation)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:56 2005 http://epydoc.sf.net


wx.grid.GridRangeSelectEvent

Package wx :: Module grid :: Class GridRangeSelectEvent

Type GridRangeSelectEvent

object --+
         |
    Object --+
             |
         Event --+
                 |
      CommandEvent --+
                     |
           NotifyEvent --+
                         |
                        GridRangeSelectEvent

Proxy of C++ GridRangeSelectEvent class

Method Summary
NotifyEvent | __init__(self, commandType, winid) An instance of this class (or one of its derived classes) is sent from a control when the control's state is being changed and the control allows that change to be prevented from happening.
 | __repr__(self)
bool | AltDown(self)
bool | ControlDown(self)
GridCellCoords | GetBottomRightCoords(self)
int | GetBottomRow(self)
int | GetLeftCol(self)
int | GetRightCol(self)
GridCellCoords | GetTopLeftCoords(self)
int | GetTopRow(self)
bool | MetaDown(self)
bool | Selecting(self)
bool | ShiftDown(self)

Method Details

__init__(self, id, type, obj, topLeft, bottomRight, sel=True, control=False, shift=False, alt=False, meta=False)
(Constructor)

An instance of this class (or one of its derived classes) is sent from a control when the control's state is being changed and the control allows that change to be prevented from happening. The event handler can call Veto or Allow to tell the control what to do.

Parameters:
commandType
(type=wxEventType)

winid
(type=int)

Returns:
NotifyEvent
Overrides:
wx.NotifyEvent.__init__ (inherited documentation)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:17 2005 http://epydoc.sf.net


wx.grid.GridSizeEvent

Package wx :: Module grid :: Class GridSizeEvent

Type GridSizeEvent

object --+
         |
    Object --+
             |
         Event --+
                 |
      CommandEvent --+
                     |
           NotifyEvent --+
                         |
                        GridSizeEvent

Proxy of C++ GridSizeEvent class

Method Summary
NotifyEvent | __init__(self, commandType, winid) An instance of this class (or one of its derived classes) is sent from a control when the control's state is being changed and the control allows that change to be prevented from happening.
 | __repr__(self)
bool | AltDown(self)
bool | ControlDown(self)
Point | GetPosition(self)
int | GetRowOrCol(self)
bool | MetaDown(self)
bool | ShiftDown(self)

Method Details

__init__(self, id, type, obj, rowOrCol=-1, x=-1, y=-1, control=False, shift=False, alt=False, meta=False)
(Constructor)

An instance of this class (or one of its derived classes) is sent from a control when the control's state is being changed and the control allows that change to be prevented from happening. The event handler can call Veto or Allow to tell the control what to do.

Parameters:
commandType
(type=wxEventType)

winid
(type=int)

Returns:
NotifyEvent
Overrides:
wx.NotifyEvent.__init__ (inherited documentation)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:16 2005 http://epydoc.sf.net


wx.grid.GridStringTable

Package wx :: Module grid :: Class GridStringTable

Type GridStringTable

object --+
         |
    Object --+
             |
 GridTableBase --+
                 |
                GridStringTable

Proxy of C++ GridStringTable class

Method Summary
GridStringTable | __init__(self, numRows, numCols)
 | __repr__(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:46 2005 http://epydoc.sf.net


wx.grid.GridTableBase

Package wx :: Module grid :: Class GridTableBase

Type GridTableBase

object --+
         |
    Object --+
             |
            GridTableBase

Known Subclasses:
GridStringTable, PyGridTableBase

Proxy of C++ GridTableBase class

Method Summary
 | __init__(self)
 | __repr__(self)
bool | AppendCols(self, numCols)
bool | AppendRows(self, numRows)
bool | CanGetValueAs(self, row, col, typeName)
bool | CanHaveAttributes(self)
bool | CanSetValueAs(self, row, col, typeName)
 | Clear(self)
bool | DeleteCols(self, pos, numCols)
bool | DeleteRows(self, pos, numRows)
GridCellAttr | GetAttr(self, row, col, kind)
GridCellAttrProvider | GetAttrProvider(self)
String | GetColLabelValue(self, col)
int | GetNumberCols(self)
int | GetNumberRows(self)
String | GetRowLabelValue(self, row)
String | GetTypeName(self, row, col)
String | GetValue(self, row, col)
bool | GetValueAsBool(self, row, col)
double | GetValueAsDouble(self, row, col)
long | GetValueAsLong(self, row, col)
Grid | GetView(self)
bool | InsertCols(self, pos, numCols)
bool | InsertRows(self, pos, numRows)
bool | IsEmptyCell(self, row, col)
 | SetAttr(self, attr, row, col)
 | SetAttrProvider(self, attrProvider)
 | SetColAttr(self, attr, col)
 | SetColLabelValue(self, col, value)
 | SetRowAttr(self, attr, row)
 | SetRowLabelValue(self, row, value)
 | SetValue(self, row, col, value)
 | SetValueAsBool(self, row, col, value)
 | SetValueAsDouble(self, row, col, value)
 | SetValueAsLong(self, row, col, value)
 | SetView(self, grid)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:10:55 2005 http://epydoc.sf.net


wx.grid.GridTableMessage

Package wx :: Module grid :: Class GridTableMessage

Type GridTableMessage

object --+
         |
        GridTableMessage

Proxy of C++ GridTableMessage class

Method Summary
GridTableMessage | __init__(self, table, id, comInt1, comInt2)
 | __del__(self)
 | __repr__(self)
int | GetCommandInt(self)
int | GetCommandInt2(self)
int | GetId(self)
GridTableBase | GetTableObject(self)
 | SetCommandInt(self, comInt1)
 | SetCommandInt2(self, comInt2)
 | SetId(self, id)
 | SetTableObject(self, table)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:03 2005 http://epydoc.sf.net


wx.grid.PyGridCellAttrProvider

Package wx :: Module grid :: Class PyGridCellAttrProvider

Type PyGridCellAttrProvider

          object --+
                   |
GridCellAttrProvider --+
                       |
                      PyGridCellAttrProvider

Proxy of C++ PyGridCellAttrProvider class

Method Summary
PyGridCellAttrProvider | __init__(self)
 | __repr__(self)
GridCellAttr | base_GetAttr(self, row, col, kind)
 | base_SetAttr(self, attr, row, col)
 | base_SetColAttr(self, attr, col)
 | base_SetRowAttr(self, attr, row)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:10 2005 http://epydoc.sf.net


wx.grid.PyGridCellEditor

Package wx :: Module grid :: Class PyGridCellEditor

Type PyGridCellEditor

    object --+
             |
GridCellEditor --+
                 |
                PyGridCellEditor

Known Subclasses:
CCellEditor

Proxy of C++ PyGridCellEditor class

Method Summary
PyGridCellEditor | __init__(self)
 | __repr__(self)
 | base_Destroy(self)
 | base_HandleReturn(self, event)
bool | base_IsAcceptedKey(self, event)
 | base_PaintBackground(self, rectCell, attr)
 | base_SetParameters(self, params)
 | base_SetSize(self, rect)
 | base_Show(self, show, attr)
 | base_StartingClick(self)
 | base_StartingKey(self, event)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:10:53 2005 http://epydoc.sf.net


wx.grid.PyGridCellRenderer

Package wx :: Module grid :: Class PyGridCellRenderer

Type PyGridCellRenderer

      object --+
               |
GridCellRenderer --+
                   |
                  PyGridCellRenderer

Proxy of C++ PyGridCellRenderer class

Method Summary
PyGridCellRenderer | __init__(self)
 | __repr__(self)
 | base_SetParameters(self, params)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:46 2005 http://epydoc.sf.net


wx.grid.PyGridTableBase

Package wx :: Module grid :: Class PyGridTableBase

Type PyGridTableBase

object --+
         |
    Object --+
             |
 GridTableBase --+
                 |
                PyGridTableBase

Proxy of C++ PyGridTableBase class

Method Summary
PyGridTableBase | __init__(self)
 | __repr__(self)
bool | base_AppendCols(self, numCols)
bool | base_AppendRows(self, numRows)
bool | base_CanGetValueAs(self, row, col, typeName)
bool | base_CanHaveAttributes(self)
bool | base_CanSetValueAs(self, row, col, typeName)
 | base_Clear(self)
bool | base_DeleteCols(self, pos, numCols)
bool | base_DeleteRows(self, pos, numRows)
GridCellAttr | base_GetAttr(self, row, col, kind)
String | base_GetColLabelValue(self, col)
String | base_GetRowLabelValue(self, row)
String | base_GetTypeName(self, row, col)
bool | base_InsertCols(self, pos, numCols)
bool | base_InsertRows(self, pos, numRows)
 | base_SetAttr(self, attr, row, col)
 | base_SetColAttr(self, attr, col)
 | base_SetColLabelValue(self, col, value)
 | base_SetRowAttr(self, attr, row)
 | base_SetRowLabelValue(self, row, value)
 | Destroy(self) Deletes the C++ object this Python object is a proxy for.

Method Details

Destroy(self)

Deletes the C++ object this Python object is a proxy for.

Overrides:
wx.Object.Destroy

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:10:53 2005 http://epydoc.sf.net


wx.GridBagSizer

Package wx :: Class GridBagSizer

Type GridBagSizer

object --+
         |
    Object --+
             |
         Sizer --+
                 |
         GridSizer --+
                     |
         FlexGridSizer --+
                         |
                        GridBagSizer

A wx.Sizer that can lay out items in a virtual grid like a wx.FlexGridSizer but in this case explicit positioning of the items is allowed using wx.GBPosition, and items can optionally span more than one row and/or column using wx.GBSpan. The total size of the virtual grid is determined by the largest row and column that items are positioned at, adjusted for spanning.

Method Summary
GridBagSizer __init__(self, vgap, hgap)
Constructor, with optional parameters to specify the gap between the rows and columns.
__repr__(self)
wx.GBSizerItem Add(self, item, pos, span, flag, border, userData)
Adds an item to the sizer at the grid cell pos, optionally spanning more than one row or column as specified with span.
AddItem(*args, **kwargs)
Add(self, GBSizerItem item) -> wx.GBSizerItem
bool CheckForIntersection(self, item, excludeItem)
Look at all items and see if any intersect (or would overlap) the given item.
bool CheckForIntersectionPos(self, pos, span, excludeItem)
Look at all items and see if any intersect (or would overlap) the given position and span.
GBSizerItem FindItem(self, item)
Find the sizer item for the given window or subsizer, returns None if not found.
GBSizerItem FindItemAtPoint(self, pt)
Return the sizer item located at the point given in pt, or None if there is no item at that point.
GBSizerItem FindItemAtPosition(self, pos)
Return the sizer item for the given grid cell, or None if there is no item at that position.
Size GetCellSize(self, row, col)
Get the size of the specified cell, including hgap and vgap.
Size GetEmptyCellSize(self)
Get the size used for cells in the grid with no item.
GBPosition GetItemPosition(self, item)
Get the grid position of the specified item where item is either a window or subsizer that is a member of this sizer, or a zero-based index of an item.
GBSpan GetItemSpan(self, item)
Get the row/col spanning of the specified item where item is either a window or subsizer that is a member of this sizer, or a zero-based index of an item.
SetEmptyCellSize(self, sz)
Set the size used for cells in the grid with no item.
bool SetItemPosition(self, item, pos)
Set the grid position of the specified item where item is either a window or subsizer that is a member of this sizer, or a zero-based index of an item.
bool SetItemSpan(self, item, span)
Set the row/col spanning of the specified item where item is either a window or subsizer that is a member of this sizer, or a zero-based index of an item.

Method Details

__init__(self, vgap=0, hgap=0)
(Constructor)

Constructor, with optional parameters to specify the gap between the rows and columns.

Parameters:
vgap
(type=int)

hgap
(type=int)

Returns:
GridBagSizer
Overrides:
wx.FlexGridSizer.__init__

Add(self, item, pos, span=DefaultSpan, flag=0, border=0, userData=None)

Adds an item to the sizer at the grid cell pos, optionally spanning more than one row or column as specified with span. The remaining args behave similarly to wx.Sizer.Add.

Returns True if the item was successfully placed at the given cell position, False if something was already there.

Parameters:
pos
(type=GBPosition)

span
(type=GBSpan)

flag
(type=int)

border
(type=int)

Returns:
wx.GBSizerItem
Overrides:
wx.Sizer.Add

AddItem(*args, **kwargs)

Add(self, GBSizerItem item) -> wx.GBSizerItem

Add an item to the sizer using a wx.GBSizerItem. Returns True if the item was successfully placed at its given cell position, False if something was already there.

Overrides:
wx.Sizer.AddItem

CheckForIntersection(self, item, excludeItem=None)

Look at all items and see if any intersect (or would overlap) the given item. Returns True if so, False if there would be no overlap. If an excludeItem is given then it will not be checked for intersection, for example it may be the item we are checking the position of.

Parameters:
item
(type=GBSizerItem)

excludeItem
(type=GBSizerItem)

Returns:
bool

CheckForIntersectionPos(self, pos, span, excludeItem=None)

Look at all items and see if any intersect (or would overlap) the given position and span. Returns True if so, False if there would be no overlap. If an excludeItem is given then it will not be checked for intersection, for example it may be the item we are checking the position of.

Parameters:
pos
(type=GBPosition)

span
(type=GBSpan)

excludeItem
(type=GBSizerItem)

Returns:
bool

FindItem(self, item)

Find the sizer item for the given window or subsizer, returns None if not found. (non-recursive)

Returns:
GBSizerItem

FindItemAtPoint(self, pt)

Return the sizer item located at the point given in pt, or None if there is no item at that point. The (x,y) coordinates in pt correspond to the client coordinates of the window using the sizer for layout. (non-recursive)

Parameters:
pt
(type=Point)

Returns:
GBSizerItem

FindItemAtPosition(self, pos)

Return the sizer item for the given grid cell, or None if there is no item at that position. (non-recursive)

Parameters:
pos
(type=GBPosition)

Returns:
GBSizerItem

GetCellSize(self, row, col)

Get the size of the specified cell, including hgap and vgap. Only valid after a Layout.

Parameters:
row
(type=int)

col
(type=int)

Returns:
Size

GetEmptyCellSize(self)

Get the size used for cells in the grid with no item.

Returns:
Size

GetItemPosition(self, item)

Get the grid position of the specified item where item is either a window or subsizer that is a member of this sizer, or a zero-based index of an item.

Returns:
GBPosition

GetItemSpan(self, item)

Get the row/col spanning of the specified item where item is either a window or subsizer that is a member of this sizer, or a zero-based index of an item.

Returns:
GBSpan

SetEmptyCellSize(self, sz)

Set the size used for cells in the grid with no item.

Parameters:
sz
(type=Size)

SetItemPosition(self, item, pos)

Set the grid position of the specified item where item is either a window or subsizer that is a member of this sizer, or a zero-based index of an item. Returns True on success. If the move is not allowed (because an item is already there) then False is returned.

Parameters:
pos
(type=GBPosition)

Returns:
bool

SetItemSpan(self, item, span)

Set the row/col spanning of the specified item where item is either a window or subsizer that is a member of this sizer, or a zero-based index of an item. Returns True on success. If the move is not allowed (because an item is already there) then False is returned.

Parameters:
span
(type=GBSpan)

Returns:
bool

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:10:55 2005 http://epydoc.sf.net


wx.grid

Package wx :: Module grid

Module wx.grid

Classes for implementing a spreadsheet-like control.

Classes
Grid | Proxy of C++ Grid class
GridCellAttr | Proxy of C++ GridCellAttr class
GridCellAttrProvider | Proxy of C++ GridCellAttrProvider class
GridCellAutoWrapStringEditor | Proxy of C++ GridCellAutoWrapStringEditor class
GridCellAutoWrapStringRenderer | Proxy of C++ GridCellAutoWrapStringRenderer class
GridCellBoolEditor | Proxy of C++ GridCellBoolEditor class
GridCellBoolRenderer | Proxy of C++ GridCellBoolRenderer class
GridCellChoiceEditor | Proxy of C++ GridCellChoiceEditor class
GridCellCoords | Proxy of C++ GridCellCoords class
GridCellDateTimeRenderer | Proxy of C++ GridCellDateTimeRenderer class
GridCellEditor | Proxy of C++ GridCellEditor class
GridCellEnumEditor | Proxy of C++ GridCellEnumEditor class
GridCellEnumRenderer | Proxy of C++ GridCellEnumRenderer class
GridCellFloatEditor | Proxy of C++ GridCellFloatEditor class
GridCellFloatRenderer | Proxy of C++ GridCellFloatRenderer class
GridCellNumberEditor | Proxy of C++ GridCellNumberEditor class
GridCellNumberRenderer | Proxy of C++ GridCellNumberRenderer class
GridCellRenderer | Proxy of C++ GridCellRenderer class
GridCellStringRenderer | Proxy of C++ GridCellStringRenderer class
GridCellTextEditor | Proxy of C++ GridCellTextEditor class
GridEditorCreatedEvent | Proxy of C++ GridEditorCreatedEvent class
GridEvent | Proxy of C++ GridEvent class
GridRangeSelectEvent | Proxy of C++ GridRangeSelectEvent class
GridSizeEvent | Proxy of C++ GridSizeEvent class
GridStringTable | Proxy of C++ GridStringTable class
GridTableBase | Proxy of C++ GridTableBase class
GridTableMessage | Proxy of C++ GridTableMessage class
PyGridCellAttrProvider | Proxy of C++ PyGridCellAttrProvider class
PyGridCellEditor | Proxy of C++ PyGridCellEditor class
PyGridCellRenderer | Proxy of C++ PyGridCellRenderer class
PyGridTableBase | Proxy of C++ PyGridTableBase class

Function Summary
VisualAttributes | Grid_GetClassDefaultAttributes(variant) Get the default attributes for this class.
Grid | PreGrid()

Function Details

Grid_GetClassDefaultAttributes(variant=WINDOW_VARIANT_NORMAL)

Get the default attributes for this class. This is useful if you want to use the same font or colour in your own control as in a standard control -- which is a much better idea than hard coding specific colours or fonts which might look completely out of place on the user's system, especially if it uses themes.

The variant parameter is only relevant under Mac currently and is ignore under other platforms. Under Mac, it will change the size of the returned font. See wx.Window.SetWindowVariant for more about this.

Parameters:
variant
(type=int)

Returns:
VisualAttributes

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:04 2005 http://epydoc.sf.net


wx.GridSizer

Package wx :: Class GridSizer

Type GridSizer

object --+
         |
    Object --+
             |
         Sizer --+
                 |
                GridSizer

Known Subclasses:
FlexGridSizer

A grid sizer is a sizer which lays out its children in a two-dimensional table with all cells having the same size. In other words, the width of each cell within the grid is the width of the widest item added to the sizer and the height of each grid cell is the height of the tallest item. An optional vertical and/or horizontal gap between items can also be specified (in pixels.)

Items are placed in the cells of the grid in the order they are added, in row-major order. In other words, the first row is filled first, then the second, and so on until all items have been added. (If neccessary, additional rows will be added as items are added.) If you need to have greater control over the cells that items are placed in then use the wx.GridBagSizer.

Method Summary
GridSizer | __init__(self, rows, cols, vgap, hgap) Constructor for a wx.GridSizer.
 | __repr__(self)
int | GetCols(self) Returns the number of columns in the sizer.
int | GetHGap(self) Returns the horizontal gap (in pixels) between cells in the sizer.
int | GetRows(self) Returns the number of rows in the sizer.
int | GetVGap(self) Returns the vertical gap (in pixels) between the cells in the sizer.
 | SetCols(self, cols) Sets the number of columns in the sizer.
 | SetHGap(self, gap) Sets the horizontal gap (in pixels) between cells in the sizer
 | SetRows(self, rows) Sets the number of rows in the sizer.
 | SetVGap(self, gap) Sets the vertical gap (in pixels) between the cells in the sizer.

Method Details

__init__(self,
          rows=1,
          cols=0,
          vgap=0,
          hgap=0)
(Constructor)

Constructor for a wx.GridSizer. rows and cols determine the number of columns and rows in the sizer - if either of the parameters is zero, it will be calculated to from the total number of children in the sizer, thus making the sizer grow dynamically. vgap and hgap define extra space between all children.

Parameters:
rows
(type=int)

cols
(type=int)

vgap
(type=int)

hgap
(type=int)

Returns:
GridSizer
Overrides:
wx.Sizer.__init__

GetCols(self)

Returns the number of columns in the sizer.

Returns:
int

GetHGap(self)

Returns the horizontal gap (in pixels) between cells in the sizer.

Returns:
int

GetRows(self)

Returns the number of rows in the sizer.

Returns:
int

GetVGap(self)

Returns the vertical gap (in pixels) between the cells in the sizer.

Returns:
int

SetCols(self, cols)

Sets the number of columns in the sizer.

Parameters:
cols
(type=int)

SetHGap(self, gap)

Sets the horizontal gap (in pixels) between cells in the sizer

Parameters:
gap
(type=int)

SetRows(self, rows)

Sets the number of rows in the sizer.

Parameters:
rows
(type=int)

SetVGap(self, gap)

Sets the vertical gap (in pixels) between the cells in the sizer.

Parameters:
gap
(type=int)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:17 2005 http://epydoc.sf.net


wx.HelpEvent

Package wx :: Class HelpEvent

Type HelpEvent

object --+
         |
    Object --+
             |
         Event --+
                 |
      CommandEvent --+
                     |
                    HelpEvent

A help event is sent when the user has requested context-sensitive help. This can either be caused by the application requesting context-sensitive help mode via wx.ContextHelp, or (on MS Windows) by the system generating a WM_HELP message when the user pressed F1 or clicked on the query button in a dialog caption.

A help event is sent to the window that the user clicked on, and is propagated up the window hierarchy until the event is processed or there are no more event handlers. The application should call event.GetId to check the identity of the clicked-on window, and then either show some suitable help or call event.Skip if the identifier is unrecognised. Calling Skip is important because it allows wxWindows to generate further events for ancestors of the clicked-on window. Otherwise it would be impossible to show help for container windows, since processing would stop after the first window found.

Events

EVT_HELP | Sent when the user has requested context- sensitive help.
EVT_HELP_RANGE | Allows to catch EVT_HELP for a range of IDs

See Also:

wx.ContextHelp, wx.ContextHelpButton

Method Summary
CommandEvent | __init__(self, commandType, winid) This event class contains information about command events, which originate from a variety of simple controls, as well as menus and toolbars.
 | __repr__(self)
String | GetLink(self) Get an optional link to further help
Point | GetPosition(self) Returns the left-click position of the mouse, in screen coordinates.
String | GetTarget(self) Get an optional target to display help in.
 | SetLink(self, link) Set an optional link to further help
 | SetPosition(self, pos) Sets the left-click position of the mouse, in screen coordinates.
 | SetTarget(self, target) Set an optional target to display help in.

Method Details

__init__(self,
          type=wxEVT_NULL,
          winid=0,
          pt=DefaultPosition)
(Constructor)

This event class contains information about command events, which originate from a variety of simple controls, as well as menus and toolbars.

Parameters:
commandType
(type=wxEventType)

winid
(type=int)

Returns:
CommandEvent
Overrides:
wx.CommandEvent.__init__ (inherited documentation)

GetLink(self)

Get an optional link to further help

Returns:
String

GetPosition(self)

Returns the left-click position of the mouse, in screen coordinates. This allows the application to position the help appropriately.

Returns:
Point

GetTarget(self)

Get an optional target to display help in. E.g. a window specification

Returns:
String

SetLink(self, link)

Set an optional link to further help

Parameters:
link
(type=String)

SetPosition(self, pos)

Sets the left-click position of the mouse, in screen coordinates.

Parameters:
pos
(type=Point)

SetTarget(self, target)

Set an optional target to display help in. E.g. a window specification

Parameters:
target
(type=String)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:33 2005 http://epydoc.sf.net


wx.HelpProvider

Package wx :: Class HelpProvider

Type HelpProvider

object --+
         |
        HelpProvider

Known Subclasses:
SimpleHelpProvider

wx.HelpProvider is an abstract class used by a program implementing context-sensitive help to show the help text for the given window.

The current help provider must be explicitly set by the application using wx.HelpProvider.Set().

Method Summary
 | __init__(self)
 | __repr__(self)
 | AddHelp(self, window, text) Associates the text with the given window.
 | AddHelpById(self, id, text) This version associates the given text with all windows with this id.
 | Destroy(self)
HelpProvider | Get() Return the current application-wide help provider. (Static method)
String | GetHelp(self, window) Gets the help string for this window.
 | RemoveHelp(self, window) Removes the association between the window pointer and the help text.
HelpProvider | Set(helpProvider) Sset the current, application-wide help provider. (Static method)
bool | ShowHelp(self, window) Shows help for the given window.

Instance Method Details

AddHelp(self, window, text)

Associates the text with the given window.

Parameters:
window
(type=Window)

text
(type=String)

AddHelpById(self, id, text)

This version associates the given text with all windows with this id. May be used to set the same help string for all Cancel buttons in the application, for example.

Parameters:
id
(type=int)

text
(type=String)

GetHelp(self, window)

Gets the help string for this window. Its interpretation is dependent on the help provider except that empty string always means that no help is associated with the window.

Parameters:
window
(type=Window)

Returns:
String

RemoveHelp(self, window)

Removes the association between the window pointer and the help text. This is called by the wx.Window destructor. Without this, the table of help strings will fill up and when window pointers are reused, the wrong help string will be found.

Parameters:
window
(type=Window)

ShowHelp(self, window)

Shows help for the given window. Uses GetHelp internally if applicable. Returns True if it was done, or False if no help was available for this window.

Parameters:
window
(type=Window)

Returns:
bool

Static Method Details

Get()

Return the current application-wide help provider.

Returns:
HelpProvider

Set(helpProvider)

Sset the current, application-wide help provider. Returns the previous one. Unlike some other classes, the help provider is not created on demand. This must be explicitly done by the application.

Parameters:
helpProvider
(type=HelpProvider)

Returns:
HelpProvider

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:33 2005 http://epydoc.sf.net


wx.html.DefaultHtmlRenderingStyle

Package wx :: Module html :: Class DefaultHtmlRenderingStyle

Type DefaultHtmlRenderingStyle

        object --+
                 |
HtmlRenderingStyle --+
                     |
                    DefaultHtmlRenderingStyle

Proxy of C++ DefaultHtmlRenderingStyle class

Method Summary
 | __init__(self)
 | __repr__(self)
Colour | GetSelectedTextBgColour(self, clr)
Colour | GetSelectedTextColour(self, clr)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:46 2005 http://epydoc.sf.net


wx.html.HtmlBookRecord

Package wx :: Module html :: Class HtmlBookRecord

Type HtmlBookRecord

object --+
         |
        HtmlBookRecord

Proxy of C++ HtmlBookRecord class

Method Summary
HtmlBookRecord | __init__(self, bookfile, basepath, title, start)
 | __repr__(self)
String | GetBasePath(self)
String | GetBookFile(self)
int | GetContentsEnd(self)
int | GetContentsStart(self)
String | GetFullPath(self, page)
String | GetStart(self)
String | GetTitle(self)
 | SetBasePath(self, path)
 | SetContentsRange(self, start, end)
 | SetStart(self, start)
 | SetTitle(self, title)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:11 2005 http://epydoc.sf.net


wx.html.HtmlCell

Package wx :: Module html :: Class HtmlCell

Type HtmlCell

object --+
         |
    Object --+
             |
            HtmlCell

Known Subclasses:
HtmlColourCell, HtmlContainerCell, HtmlFontCell, HtmlWidgetCell, HtmlWordCell

Proxy of C++ HtmlCell class

Method Summary
HtmlCell | __init__(self)
__repr__(self)
bool | AdjustPagebreak(self, INOUT)
String | ConvertToText(self, sel)
Draw(self, dc, x, y, view_y1, view_y2, info)
DrawInvisible(self, dc, x, y, info)
HtmlCell | Find(self, condition, param)
FindCellByPos(*args, **kwargs)
FindCellByPos(self, int x, int y, unsigned int flags=HTML_FIND_EXACT) -> HtmlCell
Point | GetAbsPos(self)
Cursor | GetCursor(self)
unsigned int | GetDepth(self)
int | GetDescent(self)
HtmlCell | GetFirstChild(self)
HtmlCell | GetFirstTerminal(self)
int | GetHeight(self)
String | GetId(self)
HtmlCell | GetLastTerminal(self)
HtmlLinkInfo | GetLink(self, x, y)
int | GetMaxTotalWidth(self)
HtmlCell | GetNext(self)
HtmlContainerCell | GetParent(self)
int | GetPosX(self)
int | GetPosY(self)
int | GetWidth(self)
bool | IsBefore(self, cell)
bool | IsFormattingCell(self)
bool | IsLinebreakAllowed(self)
bool | IsTerminalCell(self)
Layout(self, w)
SetCanLiveOnPagebreak(self, can)
SetId(self, id)
SetLink(self, link)
SetNext(self, cell)
SetParent(self, p)
SetPos(self, x, y)

Method Details

FindCellByPos(*args, **kwargs)

FindCellByPos(self, int x, int y, unsigned int flags=HTML_FIND_EXACT) -> HtmlCell

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:27 2005 http://epydoc.sf.net


wx.html.HtmlColourCell

Package wx :: Module html :: Class HtmlColourCell

Type HtmlColourCell

object --+
         |
    Object --+
             |
      HtmlCell --+
                 |
                HtmlColourCell

Proxy of C++ HtmlColourCell class

Method Summary
HtmlColourCell | __init__(self, clr, flags)
 | __repr__(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:51 2005 http://epydoc.sf.net


wx.html.HtmlContainerCell

Package wx :: Module html :: Class HtmlContainerCell

Type HtmlContainerCell

object --+
         |
    Object --+
             |
      HtmlCell --+
                 |
                HtmlContainerCell

Proxy of C++ HtmlContainerCell class

Method Summary
HtmlContainerCell | __init__(self, parent)
 | __repr__(self)
int | GetAlignHor(self)
int | GetAlignVer(self)
Colour | GetBackgroundColour(self)
HtmlCell | GetFirstChild(self)
int | GetIndent(self, ind)
int | GetIndentUnits(self, ind)
 | InsertCell(self, cell)
 | SetAlign(self, tag)
 | SetAlignHor(self, al)
 | SetAlignVer(self, al)
 | SetBackgroundColour(self, clr)
 | SetBorder(self, clr1, clr2)
 | SetIndent(self, i, what, units)
 | SetMinHeight(self, h, align)
 | SetWidthFloat(self, w, units)
 | SetWidthFloatFromTag(self, tag)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:39 2005 http://epydoc.sf.net


wx.html.HtmlContentsItem

Package wx :: Module html :: Class HtmlContentsItem

Type HtmlContentsItem

object --+
         |
        HtmlContentsItem

Proxy of C++ HtmlContentsItem class

Method Summary
 | __init__(self)
 | __repr__(self)
HtmlBookRecord | GetBook(self)
int | GetID(self)
int | GetLevel(self)
String | GetName(self)
String | GetPage(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:16 2005 http://epydoc.sf.net


wx.html.HtmlDCRenderer

Package wx :: Module html :: Class HtmlDCRenderer

Type HtmlDCRenderer

object --+
         |
    Object --+
             |
            HtmlDCRenderer

Proxy of C++ HtmlDCRenderer class

Method Summary
HtmlDCRenderer | __init__(self)
 | __del__(self)
 | __repr__(self)
int | GetTotalHeight(self)
int | Render(self, x, y, from, dont_render, maxHeight, choices, LCOUNT)
 | SetDC(self, dc, maxwidth)
 | SetFonts(self, normal_face, fixed_face, sizes)
 | SetHtmlText(self, html, basepath, isdir)
 | SetSize(self, width, height)
 | SetStandardFonts(self, size, normal_face, fixed_face)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:10:53 2005 http://epydoc.sf.net


wx.html.HtmlEasyPrinting

Package wx :: Module html :: Class HtmlEasyPrinting

Type HtmlEasyPrinting

object --+
         |
    Object --+
             |
            HtmlEasyPrinting

Proxy of C++ HtmlEasyPrinting class

Method Summary
HtmlEasyPrinting | __init__(self, name, parentWindow)
 | __del__(self)
 | __repr__(self)
PageSetupDialogData | GetPageSetupData(self)
PrintData | GetPrintData(self)
 | PageSetup(self)
 | PreviewFile(self, htmlfile)
 | PreviewText(self, htmltext, basepath)
 | PrintFile(self, htmlfile)
 | PrintText(self, htmltext, basepath)
 | SetFonts(self, normal_face, fixed_face, sizes)
 | SetFooter(self, footer, pg)
 | SetHeader(self, header, pg)
 | SetStandardFonts(self, size, normal_face, fixed_face)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:03 2005 http://epydoc.sf.net


wx.html.HtmlFilter

Package wx :: Module html :: Class HtmlFilter

Type HtmlFilter

object --+
         |
    Object --+
             |
            HtmlFilter

Proxy of C++ HtmlFilter class

Method Summary
HtmlFilter | __init__(self)
 | __repr__(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:41 2005 http://epydoc.sf.net


wx.html.HtmlFontCell

Package wx :: Module html :: Class HtmlFontCell

Type HtmlFontCell

object --+
         |
    Object --+
             |
      HtmlCell --+
                 |
                HtmlFontCell

Proxy of C++ HtmlFontCell class

Method Summary
HtmlFontCell | __init__(self, font)
 | __repr__(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:56 2005 http://epydoc.sf.net


wx.html.HtmlHelpController

Package wx :: Module html :: Class HtmlHelpController

Type HtmlHelpController

object --+
         |
    Object --+
             |
            HtmlHelpController

Proxy of C++ HtmlHelpController class

Method Summary
HtmlHelpController | __init__(self, style)
 | __del__(self)
 | __repr__(self)
bool | AddBook(self, book, show_wait_msg)
 | Display(self, x)
 | DisplayContents(self)
 | DisplayID(self, id)
 | DisplayIndex(self)
HtmlHelpFrame | GetFrame(self)
bool | KeywordSearch(self, keyword)
 | ReadCustomization(self, cfg, path)
 | SetTempDir(self, path)
 | SetTitleFormat(self, format)
 | UseConfig(self, config, rootpath)
 | WriteCustomization(self, cfg, path)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:59 2005 http://epydoc.sf.net


wx.html.HtmlHelpData

Package wx :: Module html :: Class HtmlHelpData

Type HtmlHelpData

object --+
         |
        HtmlHelpData

Proxy of C++ HtmlHelpData class

Method Summary
HtmlHelpData | __init__(self)
 | __del__(self)
 | __repr__(self)
bool | AddBook(self, book)
String | FindPageById(self, id)
String | FindPageByName(self, page)
wxHtmlBookRecArray | GetBookRecArray(self)
HtmlContentsItem | GetContents(self)
int | GetContentsCnt(self)
HtmlContentsItem | GetIndex(self)
int | GetIndexCnt(self)
 | SetTempDir(self, path)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:41 2005 http://epydoc.sf.net


wx.html.HtmlHelpFrame

Package wx :: Module html :: Class HtmlHelpFrame

Type HtmlHelpFrame

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
        TopLevelWindow --+
                         |
                     Frame --+
                             |
                            HtmlHelpFrame

Proxy of C++ HtmlHelpFrame class

Method Summary
 | __init__(self, *args, **kwargs) HtmlHelpData data=None) -> HtmlHelpFrame
 | __repr__(self)
 | Display(self, x)
 | DisplayContents(self)
 | DisplayID(self, id)
 | DisplayIndex(self)
HtmlHelpData | GetData(self)
bool | KeywordSearch(self, keyword)
 | ReadCustomization(self, cfg, path)
 | SetTitleFormat(self, format)
 | UseConfig(self, config, rootpath)
 | WriteCustomization(self, cfg, path)

Instance Method Details

__init__(self, *args, **kwargs)
(Constructor)

__init__(self, Window parent, int ??, String title=EmptyString, int style=HF_DEFAULTSTYLE,
HtmlHelpData data=None) -> HtmlHelpFrame
Overrides:
wx.Frame.__init__

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:48 2005 http://epydoc.sf.net


wx.html.HtmlLinkInfo

Package wx :: Module html :: Class HtmlLinkInfo

Type HtmlLinkInfo

object --+
         |
    Object --+
             |
            HtmlLinkInfo

Proxy of C++ HtmlLinkInfo class

Method Summary
HtmlLinkInfo | __init__(self, href, target)
 | __repr__(self)
MouseEvent | GetEvent(self)
String | GetHref(self)
HtmlCell | GetHtmlCell(self)
String | GetTarget(self)
 | SetEvent(self, e)
 | SetHtmlCell(self, e)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:41 2005 http://epydoc.sf.net


wx.html.HtmlParser

Package wx :: Module html :: Class HtmlParser

Type HtmlParser

object --+
         |
    Object --+
             |
            HtmlParser

Known Subclasses:
HtmlWinParser

Proxy of C++ HtmlParser class

Method Summary
 | __init__(self)
 | __repr__(self)
 | AddTagHandler(self, handler)
 | DoneParser(self)
 | DoParsing(self, begin_pos, end_pos)
FileSystem | GetFS(self)
String | GetSource(self)
 | InitParser(self, source)
Object | Parse(self, source)
 | PopTagHandler(self)
 | PushTagHandler(self, handler, tags)
 | SetFS(self, fs)
 | StopParsing(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:27 2005 http://epydoc.sf.net


wx.html.HtmlPrintout

Package wx :: Module html :: Class HtmlPrintout

Type HtmlPrintout

object --+
         |
    Object --+
             |
      Printout --+
                 |
                HtmlPrintout

Proxy of C++ HtmlPrintout class

Method Summary
HtmlPrintout | __init__(self, title)
 | __repr__(self)
 | AddFilter(filter) (Static method)
 | CleanUpStatics() (Static method)
 | SetFonts(self, normal_face, fixed_face, sizes)
 | SetFooter(self, footer, pg)
 | SetHeader(self, header, pg)
 | SetHtmlFile(self, htmlfile)
 | SetHtmlText(self, html, basepath, isdir)
 | SetMargins(self, top, bottom, left, right, spaces)
 | SetStandardFonts(self, size, normal_face, fixed_face)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:05 2005 http://epydoc.sf.net


wx.html.HtmlRenderingInfo

Package wx :: Module html :: Class HtmlRenderingInfo

Type HtmlRenderingInfo

object --+
         |
        HtmlRenderingInfo

Proxy of C++ HtmlRenderingInfo class

Method Summary
HtmlRenderingInfo | __init__(self)
 | __del__(self)
 | __repr__(self)
HtmlSelection | GetSelection(self)
HtmlRenderingState | GetState(self)
HtmlRenderingStyle | GetStyle(self)
 | SetSelection(self, s)
 | SetStyle(self, style)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:51 2005 http://epydoc.sf.net


wx.html.HtmlRenderingState

Package wx :: Module html :: Class HtmlRenderingState

Type HtmlRenderingState

object --+
         |
        HtmlRenderingState

Proxy of C++ HtmlRenderingState class

Method Summary
HtmlRenderingState | __init__(self)
 | __del__(self)
 | __repr__(self)
Colour | GetBgColour(self)
Colour | GetFgColour(self)
int | GetSelectionState(self)
 | SetBgColour(self, c)
 | SetFgColour(self, c)
 | SetSelectionState(self, s)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:40 2005 http://epydoc.sf.net


wx.html.HtmlRenderingStyle

Package wx :: Module html :: Class HtmlRenderingStyle

Type HtmlRenderingStyle

object --+
         |
        HtmlRenderingStyle

Known Subclasses:
DefaultHtmlRenderingStyle

Proxy of C++ HtmlRenderingStyle class

Method Summary
 | __init__(self)
 | __repr__(self)
Colour | GetSelectedTextBgColour(self, clr)
Colour | GetSelectedTextColour(self, clr)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:34 2005 http://epydoc.sf.net


wx.html.HtmlSearchStatus

Package wx :: Module html :: Class HtmlSearchStatus

Type HtmlSearchStatus

object --+
         |
        HtmlSearchStatus

Proxy of C++ HtmlSearchStatus class

Method Summary
 | __init__(self)
 | __repr__(self)
HtmlContentsItem | GetContentsItem(self)
int | GetCurIndex(self)
int | GetMaxIndex(self)
String | GetName(self)
bool | IsActive(self)
bool | Search(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:04 2005 http://epydoc.sf.net


wx.html.HtmlSelection

Package wx :: Module html :: Class HtmlSelection

Type HtmlSelection

object --+
         |
        HtmlSelection

Proxy of C++ HtmlSelection class

Method Summary
HtmlSelection | __init__(self)
 | __del__(self)
 | __repr__(self)
 | ClearPrivPos(self)
HtmlCell | GetFromCell(self)
Point | GetFromPos(self)
Point | GetFromPrivPos(self)
HtmlCell | GetToCell(self)
Point | GetToPos(self)
Point | GetToPrivPos(self)
bool | IsEmpty(self)
 | Set(self, fromPos, fromCell, toPos, toCell)
 | SetCells(self, fromCell, toCell)
 | SetFromPrivPos(self, pos)
 | SetToPrivPos(self, pos)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:32 2005 http://epydoc.sf.net


wx.html.HtmlTag

Package wx :: Module html :: Class HtmlTag

Type HtmlTag

object --+
         |
    Object --+
             |
            HtmlTag

Proxy of C++ HtmlTag class

Method Summary
 | __init__(self)
 | __repr__(self)
String | GetAllParams(self)
int | GetBeginPos(self)
int | GetEndPos1(self)
int | GetEndPos2(self)
String | GetName(self)
String | GetParam(self, par, with_commas)
bool | HasEnding(self)
bool | HasParam(self, par)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:11 2005 http://epydoc.sf.net


wx.html.HtmlTagHandler

Package wx :: Module html :: Class HtmlTagHandler

Type HtmlTagHandler

object --+
         |
    Object --+
             |
            HtmlTagHandler

Known Subclasses:
HtmlWinTagHandler

Proxy of C++ HtmlTagHandler class

Method Summary
HtmlTagHandler | __init__(self)
 | __repr__(self)
HtmlParser | GetParser(self)
 | ParseInner(self, tag)
 | SetParser(self, parser)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:04 2005 http://epydoc.sf.net


wx.html.HtmlWidgetCell

Package wx :: Module html :: Class HtmlWidgetCell

Type HtmlWidgetCell

object --+
         |
    Object --+
             |
      HtmlCell --+
                 |
                HtmlWidgetCell

Proxy of C++ HtmlWidgetCell class

Method Summary
HtmlWidgetCell | __init__(self, wnd, w)
 | __repr__(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:02 2005 http://epydoc.sf.net


wx.html.HtmlWindow

Package wx :: Module html :: Class HtmlWindow

Type HtmlWindow

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
                 Panel --+
                         |
            ScrolledWindow --+
                             |
                            HtmlWindow

Known Subclasses:
PyClickableHtmlWindow

Proxy of C++ HtmlWindow class

Method Summary
Window | __init__(self, parent, id, pos, size, style, name) Construct and show a generic Window.
 | __repr__(self)
 | AddFilter(filter) (Static method)
bool | AppendToPage(self, source)
 | base_OnCellClicked(self, cell, x, y, event)
 | base_OnCellMouseHover(self, cell, x, y)
 | base_OnLinkClicked(self, link)
 | base_OnSetTitle(self, title)
bool | Create(self, parent, id, pos, size, style, name) Create the GUI part of the Window for 2-phase creation mode.
VisualAttributes | GetClassDefaultAttributes(variant) Get the default attributes for this class. (Static method)
HtmlContainerCell | GetInternalRepresentation(self)
String | GetOpenedAnchor(self)
String | GetOpenedPage(self)
String | GetOpenedPageTitle(self)
HtmlWinParser | GetParser(self)
Frame | GetRelatedFrame(self)
bool | HasAnchor(self, anchor)
bool | HistoryBack(self)
bool | HistoryCanBack(self)
bool | HistoryCanForward(self)
 | HistoryClear(self)
bool | HistoryForward(self)
bool | LoadFile(self, filename)
bool | LoadPage(self, location)
 | ReadCustomization(self, cfg, path)
bool | ScrollToAnchor(self, anchor)
 | SelectAll(self)
String | SelectionToText(self)
 | SelectLine(self, pos)
 | SelectWord(self, pos)
 | SetBackgroundImage(self, bmpBg)
 | SetBorders(self, b)
 | SetFonts(self, normal_face, fixed_face, sizes)
bool | SetPage(self, source)
 | SetRelatedFrame(self, frame, format)
 | SetRelatedStatusBar(self, bar)
 | SetStandardFonts(self, size, normal_face, fixed_face)
 | SetTitle(self, title) Sets the window's title.
String | ToText(self)
 | WriteCustomization(self, cfg, path)

Instance Method Details

__init__(self,
          parent,
          id=-1,
          pos=DefaultPosition,
          size=DefaultSize,
          style=HW_DEFAULT_STYLE,
          name=HtmlWindowNameStr)
(Constructor)

Construct and show a generic Window.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

name
(type=String)

Returns:
Window
Overrides:
wx.ScrolledWindow.__init__ (inherited documentation)

Create(self,
          parent,
          id=-1,
          pos=DefaultPosition,
          size=DefaultSize,
          style=HW_SCROLLBAR_AUTO,
          name=HtmlWindowNameStr)

Create the GUI part of the Window for 2-phase creation mode.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

name
(type=String)

Returns:
bool
Overrides:
wx.ScrolledWindow.Create (inherited documentation)

SetTitle(self, title)

Sets the window's title. Applicable only to frames and dialogs.

Parameters:
title
(type=String)

Overrides:
wx.Window.SetTitle (inherited documentation)

Static Method Details

GetClassDefaultAttributes(variant=WINDOW_VARIANT_NORMAL)

Get the default attributes for this class. This is useful if you want to use the same font or colour in your own control as in a standard control -- which is a much better idea than hard coding specific colours or fonts which might look completely out of place on the user's system, especially if it uses themes.

The variant parameter is only relevant under Mac currently and is ignore under other platforms. Under Mac, it will change the size of the returned font. See wx.Window.SetWindowVariant for more about this.

Parameters:
variant
(type=int)

Returns:
VisualAttributes

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:53 2005 http://epydoc.sf.net


wx.html.HtmlWinParser

Package wx :: Module html :: Class HtmlWinParser

Type HtmlWinParser

object --+
         |
    Object --+
             |
    HtmlParser --+
                 |
                HtmlWinParser

Proxy of C++ HtmlWinParser class

Method Summary
HtmlWinParser | __init__(self, wnd)
 | __repr__(self)
HtmlContainerCell | CloseContainer(self)
Font | CreateCurrentFont(self)
Colour | GetActualColor(self)
Colour | GetActualColour(self)
int | GetAlign(self)
int | GetCharHeight(self)
int | GetCharWidth(self)
HtmlContainerCell | GetContainer(self)
DC | GetDC(self)
int | GetFontBold(self)
int | GetFontFixed(self)
int | GetFontItalic(self)
int | GetFontSize(self)
int | GetFontUnderlined(self)
HtmlLinkInfo | GetLink(self)
Colour | GetLinkColor(self)
HtmlWindow | GetWindow(self)
HtmlContainerCell | OpenContainer(self)
 | SetActualColor(self, clr)
 | SetActualColour(self, clr)
 | SetAlign(self, a)
HtmlContainerCell | SetContainer(self, c)
 | SetDC(self, dc)
 | SetFontBold(self, x)
 | SetFontFixed(self, x)
 | SetFontItalic(self, x)
 | SetFonts(self, normal_face, fixed_face, sizes)
 | SetFontSize(self, s)
 | SetFontUnderlined(self, x)
 | SetLink(self, link)
 | SetLinkColor(self, clr)
 | SetStandardFonts(self, size, normal_face, fixed_face)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:40 2005 http://epydoc.sf.net


wx.html.HtmlWinTagHandler

Package wx :: Module html :: Class HtmlWinTagHandler

Type HtmlWinTagHandler

object --+
         |
    Object --+
             |
HtmlTagHandler --+
                 |
                HtmlWinTagHandler

Known Subclasses:
wxpTagHandler

Proxy of C++ HtmlWinTagHandler class

Method Summary
HtmlWinTagHandler | __init__(self)
 | __repr__(self)
HtmlWinParser | GetParser(self)
 | ParseInner(self, tag)
 | SetParser(self, parser)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:58 2005 http://epydoc.sf.net


wx.html.HtmlWordCell

Package wx :: Module html :: Class HtmlWordCell

Type HtmlWordCell

object --+
         |
    Object --+
             |
      HtmlCell --+
                 |
                HtmlWordCell

Proxy of C++ HtmlWordCell class

Method Summary
HtmlWordCell | __init__(self, word, dc)
 | __repr__(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:11 2005 http://epydoc.sf.net


wx.HtmlListBox

Package wx :: Class HtmlListBox

Type HtmlListBox

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
                 Panel --+
                         |
           VScrolledWindow --+
                             |
                      VListBox --+
                                 |
                                HtmlListBox

Proxy of C++ HtmlListBox class

Method Summary
Window | __init__(self, parent, id, pos, size, style, name) Construct and show a generic Window.
 | __repr__(self)
bool | Create(self, parent, id, pos, size, style, name) Create the GUI part of the Window for 2-phase creation mode.
FileSystem | GetFileSystem(self)
 | RefreshAll(self)
 | SetItemCount(self, count)

Instance Method Details

__init__(self,
          parent,
          id=ID_ANY,
          pos=DefaultPosition,
          size=DefaultSize,
          style=0,
          name=VListBoxNameStr)
(Constructor)

Construct and show a generic Window.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

name
(type=String)

Returns:
Window
Overrides:
wx.VListBox.__init__ (inherited documentation)

Create(self,
          parent,
          id=ID_ANY,
          pos=DefaultPosition,
          size=DefaultSize,
          style=0,
          name=VListBoxNameStr)

Create the GUI part of the Window for 2-phase creation mode.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

name
(type=String)

Returns:
bool
Overrides:
wx.VListBox.Create (inherited documentation)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:10:54 2005 http://epydoc.sf.net


wx.html

Package wx :: Module html

Module wx.html

Classes for a simple HTML rendering window, HTML Help Window, etc.

Classes
DefaultHtmlRenderingStyle | Proxy of C++ DefaultHtmlRenderingStyle class
HtmlBookRecord | Proxy of C++ HtmlBookRecord class
HtmlCell | Proxy of C++ HtmlCell class
HtmlColourCell | Proxy of C++ HtmlColourCell class
HtmlContainerCell | Proxy of C++ HtmlContainerCell class
HtmlContentsItem | Proxy of C++ HtmlContentsItem class
HtmlDCRenderer | Proxy of C++ HtmlDCRenderer class
HtmlEasyPrinting | Proxy of C++ HtmlEasyPrinting class
HtmlFilter | Proxy of C++ HtmlFilter class
HtmlFontCell | Proxy of C++ HtmlFontCell class
HtmlHelpController | Proxy of C++ HtmlHelpController class
HtmlHelpData | Proxy of C++ HtmlHelpData class
HtmlHelpFrame | Proxy of C++ HtmlHelpFrame class
HtmlLinkInfo | Proxy of C++ HtmlLinkInfo class
HtmlParser | Proxy of C++ HtmlParser class
HtmlPrintout | Proxy of C++ HtmlPrintout class
HtmlRenderingInfo | Proxy of C++ HtmlRenderingInfo class
HtmlRenderingState | Proxy of C++ HtmlRenderingState class
HtmlRenderingStyle | Proxy of C++ HtmlRenderingStyle class
HtmlSearchStatus | Proxy of C++ HtmlSearchStatus class
HtmlSelection | Proxy of C++ HtmlSelection class
HtmlTag | Proxy of C++ HtmlTag class
HtmlTagHandler | Proxy of C++ HtmlTagHandler class
HtmlWidgetCell | Proxy of C++ HtmlWidgetCell class
HtmlWindow | Proxy of C++ HtmlWindow class
HtmlWinParser | Proxy of C++ HtmlWinParser class
HtmlWinTagHandler | Proxy of C++ HtmlWinTagHandler class
HtmlWordCell | Proxy of C++ HtmlWordCell class

Function Summary
 | HtmlPrintout_AddFilter(filter)
 | HtmlPrintout_CleanUpStatics()
 | HtmlWindow_AddFilter(filter)
VisualAttributes | HtmlWindow_GetClassDefaultAttributes(variant) Get the default attributes for this class.
 | HtmlWinParser_AddTagHandler(tagHandlerClass)
HtmlWindow | PreHtmlWindow()

Function Details

HtmlWindow_GetClassDefaultAttributes(variant=WINDOW_VARIANT_NORMAL)

Get the default attributes for this class. This is useful if you want to use the same font or colour in your own control as in a standard control -- which is a much better idea than hard coding specific colours or fonts which might look completely out of place on the user's system, especially if it uses themes.

The variant parameter is only relevant under Mac currently and is ignore under other platforms. Under Mac, it will change the size of the returned font. See wx.Window.SetWindowVariant for more about this.

Parameters:
variant
(type=int)

Returns:
VisualAttributes

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:47 2005 http://epydoc.sf.net


wx.ICOHandler

Package wx :: Class ICOHandler

Type ICOHandler

object --+
         |
    Object --+
             |
  ImageHandler --+
                 |
        BMPHandler --+
                     |
                    ICOHandler

Known Subclasses:
CURHandler

A wx.ImageHandler for *.ico icon files.

Method Summary
ICOHandler | __init__(self) A wx.ImageHandler for *.ico icon files.
 | __repr__(self)

Method Details

__init__(self)
(Constructor)

A wx.ImageHandler for *.ico icon files.

Returns:
ICOHandler
Overrides:
wx.BMPHandler.__init__

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:04 2005 http://epydoc.sf.net


wx.IconBundle

Package wx :: Class IconBundle

Type IconBundle

object --+
         |
        IconBundle

Proxy of C++ IconBundle class

Method Summary
IconBundle | __init__(self)
 | __del__(self)
 | __repr__(self)
 | AddIcon(self, icon)
 | AddIconFromFile(self, file, type)
Icon | GetIcon(self, size)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:10:54 2005 http://epydoc.sf.net


wx.Icon

Package wx :: Class Icon

Type Icon

object --+
         |
    Object --+
             |
     GDIObject --+
                 |
                Icon

Proxy of C++ Icon class

Method Summary
Icon | __init__(self, name, type, desiredWidth, desiredHeight)
 | __del__(self)
 | __nonzero__(self)
 | __repr__(self)
 | CopyFromBitmap(self, bmp)
int | GetDepth(self)
int | GetHeight(self)
int | GetWidth(self)
bool | LoadFile(self, name, type)
bool | Ok(self)
 | SetDepth(self, d)
 | SetHeight(self, h)
 | SetWidth(self, w)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:06 2005 http://epydoc.sf.net


wx.IconizeEvent

Package wx :: Class IconizeEvent

Type IconizeEvent

object --+
         |
    Object --+
             |
         Event --+
                 |
                IconizeEvent

An EVT_ICONIZE event is sent when a frame is iconized (minimized) or restored.

Method Summary
IconizeEvent | __init__(self, id, iconized) An EVT_ICONIZE event is sent when a frame is iconized (minimized) or restored.
 | __repr__(self)
bool | Iconized(self) Returns True if the frame has been iconized, False if it has been restored.

Method Details

__init__(self, id=0, iconized=True)
(Constructor)

An EVT_ICONIZE event is sent when a frame is iconized (minimized) or restored.

Parameters:
id
(type=int)

iconized
(type=bool)

Returns:
IconizeEvent
Overrides:
wx.Event.__init__

Iconized(self)

Returns True if the frame has been iconized, False if it has been restored.

Returns:
bool

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:16 2005 http://epydoc.sf.net


wx.IconLocation

Package wx :: Class IconLocation

Type IconLocation

object --+
         |
        IconLocation

Proxy of C++ IconLocation class

Method Summary
IconLocation | __init__(self, filename, num)
 | __del__(self)
 | __nonzero__(self)
 | __repr__(self)
String | GetFileName(self)
int | GetIndex(self)
bool | IsOk(self)
 | SetFileName(self, filename)
 | SetIndex(self, num)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:22 2005 http://epydoc.sf.net


wx.IdleEvent

Package wx :: Class IdleEvent

Type IdleEvent

object --+
         |
    Object --+
             |
         Event --+
                 |
                IdleEvent

This class is used for EVT_IDLE events, which are generated and sent when the application becomes idle. In other words, the when the event queue becomes empty then idle events are sent to all windows (by default) and as long as none of them call RequestMore then there are no more idle events until after the system event queue has some normal events and then becomes empty again.

By default, idle events are sent to all windows. If this is causing a significant overhead in your application, you can call wx.IdleEvent.SetMode with the value wx.IDLE_PROCESS_SPECIFIED, and set the wx.WS_EX_PROCESS_IDLE extra window style for every window which should receive idle events. Then idle events will only be sent to those windows and not to any others.

Method Summary
IdleEvent | __init__(self) Constructor
 | __repr__(self)
bool | CanSend(win) Returns True if it is appropriate to send idle events to this window. (Static method)
int | GetMode() Static method returning a value specifying how wxWidgets will send idle events: to all windows, or only to those which specify that they will process the events. (Static method)
bool | MoreRequested(self) Returns True if the OnIdle function processing this event requested more processing time.
 | RequestMore(self, needMore) Tells wxWidgets that more processing is required.
 | SetMode(mode) Static method for specifying how wxWidgets will send idle events: to all windows, or only to those which specify that they will process the events. (Static method)

Instance Method Details

__init__(self)
(Constructor)

Constructor

Returns:
IdleEvent
Overrides:
wx.Event.__init__

MoreRequested(self)

Returns True if the OnIdle function processing this event requested more processing time.

Returns:
bool

RequestMore(self, needMore=True)

Tells wxWidgets that more processing is required. This function can be called by an EVT_IDLE handler for a window to indicate that the application should forward the EVT_IDLE event once more to the application windows. If no window calls this function during its EVT_IDLE handler, then the application will remain in a passive event loop until a new event is posted to the application by the windowing system.

Parameters:
needMore
(type=bool)

Static Method Details

CanSend(win)

Returns True if it is appropriate to send idle events to this window.

This function looks at the mode used (see wx.IdleEvent.SetMode), and the wx.WS_EX_PROCESS_IDLE style in window to determine whether idle events should be sent to this window now. By default this will always return True because the update mode is initially wx.IDLE_PROCESS_ALL. You can change the mode to only send idle events to windows with the wx.WS_EX_PROCESS_IDLE extra window style set.

Parameters:
win
(type=Window)

Returns:
bool

GetMode()

Static method returning a value specifying how wxWidgets will send idle events: to all windows, or only to those which specify that they will process the events.

Returns:
int

SetMode(mode)

Static method for specifying how wxWidgets will send idle events: to all windows, or only to those which specify that they will process the events.

The mode can be one of the following values:

wx.IDLE_PROCESS_ALL | Send idle events to all windows
wx.IDLE_PROCESS_SPECIFIED | Send idle events only to windows that have the wx.WS_EX_PROCESS_IDLE extra style flag set.
Parameters:
mode
(type=int)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:00 2005 http://epydoc.sf.net


wx.Image

Package wx :: Class Image

Type Image

object --+
         |
    Object --+
             |
            Image

A platform-independent image class. An image can be created from data, or using wx.Bitmap.ConvertToImage, or loaded from a file in a variety of formats. Functions are available to set and get image bits, so it can be used for basic image manipulation.

A wx.Image cannot be drawn directly to a wx.DC. Instead, a platform-specific wx.Bitmap object must be created from it using the wx.BitmapFromImage constructor. This bitmap can then be drawn in a device context, using wx.DC.DrawBitmap.

One colour value of the image may be used as a mask colour which will lead to the automatic creation of a wx.Mask object associated to the bitmap object.

wx.Image supports alpha channel data, that is in addition to a byte for the red, green and blue colour components for each pixel it also stores a byte representing the pixel opacity. An alpha value of 0 corresponds to a transparent pixel (null opacity) while a value of 255 means that the pixel is 100% opaque.

Unlike RGB data, not all images have an alpha channel and before using GetAlpha you should check if this image contains an alpha channel with HasAlpha. Note that currently only images loaded from PNG files with transparency information will have an alpha channel.

Method Summary
Image | __init__(self, name, type, index)
 | __del__(self)
 | __nonzero__(self)
 | __repr__(self)
 | AddHandler(handler) (Static method)
bool | CanRead(filename) Returns True if the image handlers can read this file. (Static method)
bool | CanReadStream(stream) Returns True if the image handlers can read an image file from the data currently on the input stream, or a readable Python file-like object. (Static method)
unsigned long | ComputeHistogram(self, h)
bool | ConvertAlphaToMask(self, threshold) If the image has alpha channel, this method converts it to mask.
bool | ConvertColourToAlpha(self, r, g, b) This method converts an image where the original alpha information is only available as a shades of a colour (actually shades of grey) typically when you draw anti-aliased text into a bitmap.
Bitmap | ConvertToBitmap(self, depth)
Image | ConvertToMono(self, r, g, b) Returns monochromatic version of the image.
Bitmap | ConvertToMonoBitmap(self, red, green, blue)
Image | Copy(self) Returns an identical copy of the image.
 | CountColours(*args, **kwargs) CountColours(self, unsigned long stopafter=(unsigned long) -1) -> unsigned long
 | Create(self, width, height, clear) Creates a fresh image.
 | Destroy(self) Destroys the image data.
(success, r, g, b) | FindFirstUnusedColour(startR, startG, startB) Find first colour that is not used in the image and has higher RGB values than startR, startG, startB.
byte | GetAlpha(self, x, y) Returns the alpha value for the given pixel.
PyObject | GetAlphaBuffer(self)
PyObject | GetAlphaData(self) Returns a string containing a copy of the alpha bytes of the image.
byte | GetBlue(self, x, y) Returns the blue intensity at the given coordinate.
PyObject | GetData(self) Returns a string containing a copy of the RGB bytes of the image.
PyObject | GetDataBuffer(self) Returns a writable Python buffer object that is pointing at the RGB image data buffer inside the wx.Image.
byte | GetGreen(self, x, y) Returns the green intensity at the given coordinate.
int | GetHeight(self) Gets the height of the image in pixels.
int | GetImageCount(filename, type) If the image file contains more than one image and the image handler is capable of retrieving these individually, this function will return the number of available images. (Static method)
String | GetImageExtWildcard() Iterates all registered wxImageHandler objects, and returns a string containing file extension masks suitable for passing to file open/save dialog boxes. (Static method)
byte | GetMaskBlue(self) Gets the blue component of the mask colour.
byte | GetMaskGreen(self) Gets the green component of the mask colour.
byte | GetMaskRed(self) Gets the red component of the mask colour.
String | GetOption(self, name) Gets the value of an image handler option.
int | GetOptionInt(self, name) Gets the value of an image handler option as an integer.
(r,g,b) | GetOrFindMaskColour() Get the current mask colour or find a suitable colour.
byte | GetRed(self, x, y) Returns the red intensity at the given coordinate.
Size | GetSize(self) Returns the size of the image in pixels.
Image | GetSubImage(self, rect) Returns a sub image of the current one as long as the rect belongs entirely to the image.
int | GetWidth(self) Gets the width of the image in pixels.
bool | HasAlpha(self) Returns true if this image has alpha channel, false otherwise.
bool | HasMask(self) Returns True if there is a mask active, False otherwise.
bool | HasOption(self, name) Returns true if the given option is present.
 | InitAlpha(self) Initializes the image alpha channel data.
 | InsertHandler(handler) (Static method)
bool | IsTransparent(self, x, y, threshold) Returns True if this pixel is masked or has an alpha value less than the spcified threshold.
bool | LoadFile(self, name, type, index) Loads an image from a file.
bool | LoadMimeFile(self, name, mimetype, index) Loads an image from a file, specifying the image type with a MIME type string.
bool | LoadMimeStream(self, stream, mimetype, index) Loads an image from an input stream or a readable Python file-like object, using a MIME type string to specify the image file format.
bool | LoadStream(self, stream, type, index) Loads an image from an input stream or a readable Python file-like object.
Image | Mirror(self, horizontally) Returns a mirrored copy of the image.
bool | Ok(self) Returns true if image data is present.
 | Paste(self, image, x, y) Pastes image into this instance and takes care of the mask colour and any out of bounds problems.
bool | RemoveHandler(name) (Static method)
 | Replace(self, r1, g1, b1, r2, g2, b2) Replaces the colour specified by (r1,g1,b1) by the colour (r2,g2,b2).
Image | Rescale(self, width, height) Changes the size of the image in-place by scaling it: after a call to this function, the image will have the given width and height.
Image | Resize(self, size, pos, r, g, b) Changes the size of the image in-place without scaling it, by adding either a border with the given colour or cropping as necessary.
Image | Rotate(self, angle, centre_of_rotation, interpolating, offset_after_rotation) Rotates the image about the given point, by angle radians.
Image | Rotate90(self, clockwise) Returns a copy of the image rotated 90 degrees in the direction indicated by clockwise.
bool | SaveFile(self, name, type) Saves an image in the named file.
bool | SaveMimeFile(self, name, mimetype) Saves an image in the named file.
Image | Scale(self, width, height) Returns a scaled version of the image.
 | SetAlpha(self, x, y, alpha) Sets the alpha value for the given pixel.
 | SetAlphaBuffer(self, alpha)
 | SetAlphaData(self, alpha) Resets the Image's alpha data from a buffer of bytes.
 | SetData(self, data) Resets the Image's RGB data from a buffer of RGB bytes.
 | SetDataBuffer(self, data) Sets the internal image data pointer to point at a Python buffer object.
 | SetMask(self, mask) Specifies whether there is a mask or not.
 | SetMaskColour(self, r, g, b) Sets the mask colour for this image (and tells the image to use the mask).
bool | SetMaskFromImage(self, mask, mr, mg, mb) Sets the image's mask so that the pixels that have RGB value of (mr,mg,mb) in mask will be masked in this image.
 | SetOption(self, name, value) Sets an image handler defined option.
 | SetOptionInt(self, name, value) Sets an image option as an integer.
 | SetRGB(self, x, y, r, g, b) Sets the pixel at the given coordinate.
 | SetRGBRect(self, rect, r, g, b) Sets the colour of the pixels within the given rectangle.
Image | ShrinkBy(self, xFactor, yFactor) Return a version of the image scaled smaller by the given factors.
Image | Size(self, size, pos, r, g, b) Returns a resized version of this image without scaling it by adding either a border with the given colour or cropping as necessary.

Instance Method Details

__init__(self, name, type=BITMAP_TYPE_ANY, index=-1)
(Constructor)

Loads an image from a file.
Parameters:
name - Name of the file from which to load the image.
(type=String)

type - May be one of the following:

wx.BITMAP_TYPE_BMP | Load a Windows bitmap file.
wx.BITMAP_TYPE_GIF | Load a GIF bitmap file.
wx.BITMAP_TYPE_JPEG | Load a JPEG bitmap file.
wx.BITMAP_TYPE_PNG | Load a PNG bitmap file.
wx.BITMAP_TYPE_PCX | Load a PCX bitmap file.
wx.BITMAP_TYPE_PNM | Load a PNM bitmap file.
wx.BITMAP_TYPE_TIF | Load a TIFF bitmap file.
wx.BITMAP_TYPE_XPM | Load a XPM bitmap file.
wx.BITMAP_TYPE_ICO | Load a Windows icon file (ICO).
wx.BITMAP_TYPE_CUR | Load a Windows cursor file (CUR).
wx.BITMAP_TYPE_ANI | Load a Windows animated cursor file (ANI).
wx.BITMAP_TYPE_ANY | Will try to autodetect the format.

(type=long)

index - Index of the image to load in the case that the image file contains multiple images. This is only used by GIF, ICO and TIFF handlers. The default value (-1) means to choose the default image and is interpreted as the first image (the one with index=0) by the GIF and TIFF handler and as the largest and most colourful one by the ICO handler.
(type=int)

Returns:
Image
Overrides:
wx.Object.__init__

See Also:

wx.ImageFromMime, wx.ImageFromStream, wx.ImageFromStreamMime, wx.EmptyImage, wx.ImageFromBitmap, wx.ImageFromData, wx.ImageFromDataWithAlpha

ConvertAlphaToMask(self, threshold=IMAGE_ALPHA_THRESHOLD)

If the image has alpha channel, this method converts it to mask. All pixels with alpha value less than threshold are replaced with the mask colour and the alpha channel is removed. The mask colour is chosen automatically using FindFirstUnusedColour.

If the image image doesn't have alpha channel, ConvertAlphaToMask does nothing.

Parameters:
threshold
(type=byte)

Returns:
bool

ConvertColourToAlpha(self, r, g, b)

This method converts an image where the original alpha information is only available as a shades of a colour (actually shades of grey) typically when you draw anti-aliased text into a bitmap. The DC drawing routines draw grey values on the black background although they actually mean to draw white with differnt alpha values. This method reverses it, assuming a black (!) background and white text. The method will then fill up the whole image with the colour given.

Parameters:
r
(type=byte)

g
(type=byte)

b
(type=byte)

Returns:
bool

ConvertToMono(self, r, g, b)

Returns monochromatic version of the image. The returned image has white colour where the original has (r,g,b) colour and black colour everywhere else.

Parameters:
r
(type=byte)

g
(type=byte)

b
(type=byte)

Returns:
Image

Copy(self)

Returns an identical copy of the image.

Returns:
Image

CountColours(*args, **kwargs)

CountColours(self, unsigned long stopafter=(unsigned long) -1) -> unsigned long

Create(self, width, height, clear=True)

Creates a fresh image. If clear is True, the new image will be initialized to black. Otherwise, the image data will be uninitialized.

Parameters:
width
(type=int)

height
(type=int)

clear
(type=bool)

Destroy(self)

Destroys the image data.

Overrides:
wx.Object.Destroy

FindFirstUnusedColour(startR=1, startG=0, startB=0)

Find first colour that is not used in the image and has higher RGB values than startR, startG, startB. Returns a tuple consisting of a success flag and rgb values.

Parameters:
startR
(type=int)

startG
(type=int)

startB
(type=int)

Returns:
(success, r, g, b)

GetAlpha(self, x, y)

Returns the alpha value for the given pixel. This function may only be called for the images with alpha channel, use HasAlpha to check for this.

The returned value is the opacity of the image, i.e. the value of 0 corresponds to the fully transparent pixels while the value of 255 to the fully opaque pixels.

Parameters:
x
(type=int)

y
(type=int)

Returns:
byte

GetAlphaData(self)

Returns a string containing a copy of the alpha bytes of the image.

Returns:
PyObject

GetBlue(self, x, y)

Returns the blue intensity at the given coordinate.

Parameters:
x
(type=int)

y
(type=int)

Returns:
byte

GetData(self)

Returns a string containing a copy of the RGB bytes of the image.

Returns:
PyObject

GetDataBuffer(self)

Returns a writable Python buffer object that is pointing at the RGB image data buffer inside the wx.Image. You need to ensure that you do not use this buffer object after the image has been destroyed.

Returns:
PyObject

GetGreen(self, x, y)

Returns the green intensity at the given coordinate.

Parameters:
x
(type=int)

y
(type=int)

Returns:
byte

GetHeight(self)

Gets the height of the image in pixels.

Returns:
int

GetMaskBlue(self)

Gets the blue component of the mask colour.

Returns:
byte

GetMaskGreen(self)

Gets the green component of the mask colour.

Returns:
byte

GetMaskRed(self)

Gets the red component of the mask colour.

Returns:
byte

GetOption(self, name)

Gets the value of an image handler option.

Parameters:
name
(type=String)

Returns:
String

See Also:

HasOption, GetOptionInt, SetOption, SetOptionInt

GetOptionInt(self, name)

Gets the value of an image handler option as an integer. If the given option is not present, the function returns 0.

Parameters:
name
(type=String)

Returns:
int

See Also:

HasOption, GetOption, SetOptionInt, SetOption

GetOrFindMaskColour()

Get the current mask colour or find a suitable colour.

Returns:
(r,g,b)

GetRed(self, x, y)

Returns the red intensity at the given coordinate.

Parameters:
x
(type=int)

y
(type=int)

Returns:
byte

GetSize(self)

Returns the size of the image in pixels.

Returns:
Size

GetSubImage(self, rect)

Returns a sub image of the current one as long as the rect belongs entirely to the image.

Parameters:
rect
(type=Rect)

Returns:
Image

GetWidth(self)

Gets the width of the image in pixels.

Returns:
int

HasAlpha(self)

Returns true if this image has alpha channel, false otherwise.

Returns:
bool

See Also:

GetAlpha, SetAlpha

HasMask(self)

Returns True if there is a mask active, False otherwise.

Returns:
bool

HasOption(self, name)

Returns true if the given option is present.

Parameters:
name
(type=String)

Returns:
bool

See Also:

GetOption, GetOptionInt, SetOption, SetOptionInt

InitAlpha(self)

Initializes the image alpha channel data. It is an error to call it if the image already has alpha data. If it doesn't, alpha data will be by default initialized to all pixels being fully opaque. But if the image has a a mask colour, all mask pixels will be completely transparent.

IsTransparent(self, x, y, threshold=IMAGE_ALPHA_THRESHOLD)

Returns True if this pixel is masked or has an alpha value less than the spcified threshold.

Parameters:
x
(type=int)

y
(type=int)

threshold
(type=byte)

Returns:
bool

LoadFile(self, name, type=BITMAP_TYPE_ANY, index=-1)

Loads an image from a file. If no handler type is provided, the library will try to autodetect the format.

Parameters:
name
(type=String)

type
(type=long)

index
(type=int)

Returns:
bool

LoadMimeFile(self, name, mimetype, index=-1)

Loads an image from a file, specifying the image type with a MIME type string.

Parameters:
name
(type=String)

mimetype
(type=String)

index
(type=int)

Returns:
bool

LoadMimeStream(self, stream, mimetype, index=-1)

Loads an image from an input stream or a readable Python file-like object, using a MIME type string to specify the image file format.

Parameters:
stream
(type=InputStream)

mimetype
(type=String)

index
(type=int)

Returns:
bool

LoadStream(self, stream, type=BITMAP_TYPE_ANY, index=-1)

Loads an image from an input stream or a readable Python file-like object. If no handler type is provided, the library will try to autodetect the format.

Parameters:
stream
(type=InputStream)

type
(type=long)

index
(type=int)

Returns:
bool

Mirror(self, horizontally=True)

Returns a mirrored copy of the image. The parameter horizontally indicates the orientation.

Parameters:
horizontally
(type=bool)

Returns:
Image

Ok(self)

Returns true if image data is present.

Returns:
bool

Paste(self, image, x, y)

Pastes image into this instance and takes care of the mask colour and any out of bounds problems.

Parameters:
image
(type=Image)

x
(type=int)

y
(type=int)

Replace(self, r1, g1, b1, r2, g2, b2)

Replaces the colour specified by (r1,g1,b1) by the colour (r2,g2,b2).

Parameters:
r1
(type=byte)

g1
(type=byte)

b1
(type=byte)

r2
(type=byte)

g2
(type=byte)

b2
(type=byte)

Rescale(self, width, height)

Changes the size of the image in-place by scaling it: after a call to this function, the image will have the given width and height.

Returns the (modified) image itself.

Parameters:
width
(type=int)

height
(type=int)

Returns:
Image

See Also:

Scale

Resize(self, size, pos, r=-1, g=-1, b=-1)

Changes the size of the image in-place without scaling it, by adding either a border with the given colour or cropping as necessary. The image is pasted into a new image with the given size and background colour at the position pos relative to the upper left of the new image. If red = green = blue = -1 then use either the current mask colour if set or find, use, and set a suitable mask colour for any newly exposed areas.

Returns the (modified) image itself.

Parameters:
size
(type=Size)

pos
(type=Point)

r
(type=int)

g
(type=int)

b
(type=int)

Returns:
Image

See Also:

Size

Rotate(self, angle, centre_of_rotation, interpolating=True, offset_after_rotation=None)

Rotates the image about the given point, by angle radians. Passing True to interpolating results in better image quality, but is slower. If the image has a mask, then the mask colour is used for the uncovered pixels in the rotated image background. Otherwise, black will be used as the fill colour.

Returns the rotated image, leaving this image intact.

Parameters:
angle
(type=double)

centre_of_rotation
(type=Point)

interpolating
(type=bool)

offset_after_rotation
(type=Point)

Returns:
Image

Rotate90(self, clockwise=True)

Returns a copy of the image rotated 90 degrees in the direction indicated by clockwise.

Parameters:
clockwise
(type=bool)

Returns:
Image

SaveFile(self, name, type)

Saves an image in the named file.

Parameters:
name
(type=String)

type
(type=int)

Returns:
bool

SaveMimeFile(self, name, mimetype)

Saves an image in the named file.

Parameters:
name
(type=String)

mimetype
(type=String)

Returns:
bool

Scale(self, width, height)

Returns a scaled version of the image. This is also useful for scaling bitmaps in general as the only other way to scale bitmaps is to blit a wx.MemoryDC into another wx.MemoryDC.

Parameters:
width
(type=int)

height
(type=int)

Returns:
Image

See Also:

Rescale

SetAlpha(self, x, y, alpha)

Sets the alpha value for the given pixel. This function should only be called if the image has alpha channel data, use HasAlpha to check for this.

Parameters:
x
(type=int)

y
(type=int)

alpha
(type=byte)

SetAlphaData(self, alpha)

Resets the Image's alpha data from a buffer of bytes. Accepts either a string or a buffer object holding the data and the length of the data must be width*height.

Parameters:
alpha
(type=buffer)

SetData(self, data)

Resets the Image's RGB data from a buffer of RGB bytes. Accepts either a string or a buffer object holding the data and the length of the data must be width*height*3.

Parameters:
data
(type=buffer)

SetDataBuffer(self, data)

Sets the internal image data pointer to point at a Python buffer object. This can save making an extra copy of the data but you must ensure that the buffer object lives longer than the wx.Image does.

Parameters:
data
(type=buffer)

SetMask(self, mask=True)

Specifies whether there is a mask or not. The area of the mask is determined by the current mask colour.

Parameters:
mask
(type=bool)

SetMaskColour(self, r, g, b)

Sets the mask colour for this image (and tells the image to use the mask).

Parameters:
r
(type=byte)

g
(type=byte)

b
(type=byte)

SetMaskFromImage(self, mask, mr, mg, mb)

Sets the image's mask so that the pixels that have RGB value of (mr,mg,mb) in mask will be masked in this image. This is done by first finding an unused colour in the image, setting this colour as the mask colour and then using this colour to draw all pixels in the image who corresponding pixel in mask has given RGB value.

Returns False if mask does not have same dimensions as the image or if there is no unused colour left. Returns True if the mask was successfully applied.

Note that this method involves computing the histogram, which is computationally intensive operation.

Parameters:
mask
(type=Image)

mr
(type=byte)

mg
(type=byte)

mb
(type=byte)

Returns:
bool

SetOption(self, name, value)

Sets an image handler defined option. For example, when saving as a JPEG file, the option wx.IMAGE_OPTION_QUALITY is used, which is a number between 0 and 100 (0 is terrible, 100 is very good).

wx.IMAGE_OPTION_BMP_FORMAT
wx.IMAGE_OPTION_CUR_HOTSPOT_X
wx.IMAGE_OPTION_CUR_HOTSPOT_Y
wx.IMAGE_OPTION_RESOLUTION
wx.IMAGE_OPTION_RESOLUTIONX
wx.IMAGE_OPTION_RESOLUTIONY
wx.IMAGE_OPTION_RESOLUTIONUNIT
wx.IMAGE_OPTION_QUALITY
wx.IMAGE_OPTION_BITSPERSAMPLE
wx.IMAGE_OPTION_SAMPLESPERPIXEL
wx.IMAGE_OPTION_COMPRESSION
wx.IMAGE_OPTION_IMAGEDESCRIPTOR
wx.IMAGE_OPTION_PNG_FORMAT
wx.IMAGE_OPTION_PNG_BITDEPTH
Parameters:
name
(type=String)

value
(type=String)

See Also:

HasOption, GetOption, GetOptionInt, SetOptionInt

SetOptionInt(self, name, value)

Sets an image option as an integer.

Parameters:
name
(type=String)

value
(type=int)

See Also:

HasOption, GetOption, GetOptionInt, SetOption

SetRGB(self, x, y, r, g, b)

Sets the pixel at the given coordinate. This routine performs bounds-checks for the coordinate so it can be considered a safe way to manipulate the data, but in some cases this might be too slow so that the data will have to be set directly. In that case you will have to get access to the image data using the GetData method.

Parameters:
x
(type=int)

y
(type=int)

r
(type=byte)

g
(type=byte)

b
(type=byte)

SetRGBRect(self, rect, r, g, b)

Sets the colour of the pixels within the given rectangle. This routine performs bounds-checks for the rectangle so it can be considered a safe way to manipulate the data.

Parameters:
rect
(type=Rect)

r
(type=byte)

g
(type=byte)

b
(type=byte)

ShrinkBy(self, xFactor, yFactor)

Return a version of the image scaled smaller by the given factors.

Parameters:
xFactor
(type=int)

yFactor
(type=int)

Returns:
Image

Size(self, size, pos, r=-1, g=-1, b=-1)

Returns a resized version of this image without scaling it by adding either a border with the given colour or cropping as necessary. The image is pasted into a new image with the given size and background colour at the position pos relative to the upper left of the new image. If red = green = blue = -1 then use either the current mask colour if set or find, use, and set a suitable mask colour for any newly exposed areas.

Parameters:
size
(type=Size)

pos
(type=Point)

r
(type=int)

g
(type=int)

b
(type=int)

Returns:
Image

See Also:

Resize

Static Method Details

CanRead(filename)

Returns True if the image handlers can read this file.

Parameters:
filename
(type=String)

Returns:
bool

CanReadStream(stream)

Returns True if the image handlers can read an image file from the data currently on the input stream, or a readable Python file-like object.

Parameters:
stream
(type=InputStream)

Returns:
bool

GetImageCount(filename, type=BITMAP_TYPE_ANY)

If the image file contains more than one image and the image handler is capable of retrieving these individually, this function will return the number of available images.

Parameters:
filename
(type=String)

type
(type=long)

Returns:
int

GetImageExtWildcard()

Iterates all registered wxImageHandler objects, and returns a string containing file extension masks suitable for passing to file open/save dialog boxes.

Returns:
String

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:00 2005 http://epydoc.sf.net


wx.ImageHandler

Package wx :: Class ImageHandler

Type ImageHandler

object --+
         |
    Object --+
             |
            ImageHandler

Known Subclasses:
BMPHandler, GIFHandler, JPEGHandler, PCXHandler, PNGHandler, PNMHandler, TIFFHandler, XPMHandler

This is the base class for implementing image file loading/saving, and image creation from data. It is used within wx.Image and is not normally seen by the application.

Method Summary
 | __init__(self)
 | __repr__(self)
bool | CanRead(self, name)
String | GetExtension(self)
String | GetMimeType(self)
String | GetName(self)
long | GetType(self)
 | SetExtension(self, extension)
 | SetMimeType(self, mimetype)
 | SetName(self, name)
 | SetType(self, type)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:31 2005 http://epydoc.sf.net


wx.ImageHistogram

Package wx :: Class ImageHistogram

Type ImageHistogram

object --+
         |
        ImageHistogram

Proxy of C++ ImageHistogram class

Method Summary
ImageHistogram __init__(self)
__repr__(self)
(success, r, g, b) FindFirstUnusedColour(startR, startG, startB)
Find first colour that is not used in the image and has higher RGB values than startR, startG, startB.
GetCount(*args, **kwargs)
GetCount(self, unsigned long key) -> unsigned long
unsigned long GetCountColour(self, colour)
Returns the pixel count for the given wx.Colour value.
unsigned long GetCountRGB(self, r, g, b)
Returns the pixel count for the given RGB values.
unsigned long MakeKey(r, g, b)
Get the key in the histogram for the given RGB values (Static method)

Instance Method Details

FindFirstUnusedColour(startR=1, startG=0, startB=0)

Find first colour that is not used in the image and has higher RGB values than startR, startG, startB. Returns a tuple consisting of a success flag and rgb values.

Parameters:
startR
(type=int)

startG
(type=int)

startB
(type=int)

Returns:
(success, r, g, b)

GetCount(*args, **kwargs)

GetCount(self, unsigned long key) -> unsigned long

Returns the pixel count for the given key. Use MakeKey to create a key value from a RGB tripple.

GetCountColour(self, colour)

Returns the pixel count for the given wx.Colour value.

Parameters:
colour
(type=Colour)

Returns:
unsigned long

GetCountRGB(self, r, g, b)

Returns the pixel count for the given RGB values.

Parameters:
r
(type=byte)

g
(type=byte)

b
(type=byte)

Returns:
unsigned long

Static Method Details

MakeKey(r, g, b)

Get the key in the histogram for the given RGB values

Parameters:
r
(type=byte)

g
(type=byte)

b
(type=byte)

Returns:
unsigned long

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:40 2005 http://epydoc.sf.net


wx.ImageList

Package wx :: Class ImageList

Type ImageList

object --+
         |
    Object --+
             |
            ImageList

Proxy of C++ ImageList class

Method Summary
ImageList | __init__(self, width, height, mask, initialCount)
 | __del__(self)
 | __repr__(self)
int | Add(self, bitmap, mask)
int | AddIcon(self, icon)
int | AddWithColourMask(self, bitmap, maskColour)
bool | Draw(self, index, dc, x, x, flags, solidBackground)
Bitmap | GetBitmap(self, index)
Icon | GetIcon(self, index)
int | GetImageCount(self)
(width,height) | GetSize()
bool | Remove(self, index)
bool | RemoveAll(self)
bool | Replace(self, index, bitmap)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:41 2005 http://epydoc.sf.net


wx.IndividualLayoutConstraint

Package wx :: Class IndividualLayoutConstraint

Type IndividualLayoutConstraint

object --+
         |
    Object --+
             |
            IndividualLayoutConstraint

Objects of this class are stored in the wx.LayoutConstraints class as one of eight possible constraints that a window can be involved in. You will never need to create an instance of wx.IndividualLayoutConstraint, rather you should create a wx.LayoutConstraints instance and use the individual contstraints that it contains.

Constraints are initially set to have the relationship wx.Unconstrained, which means that their values should be calculated by looking at known constraints.

The Edge specifies the type of edge or dimension of a window.

Edges

wx.Left | The left edge.
wx.Top | The top edge.
wx.Right | The right edge.
wx.Bottom | The bottom edge.
wx.CentreX | The x-coordinate of the centre of the window.
wx.CentreY | The y-coordinate of the centre of the window.

The Relationship specifies the relationship that this edge or dimension has with another specified edge or dimension. Normally, the user doesn't use these directly because functions such as Below and RightOf are a convenience for using the more general Set function.

Relationships

wx.Unconstrained | The edge or dimension is unconstrained (the default for edges.)
wx.AsIs | The edge or dimension is to be taken from the current window position or size (the default for dimensions.)
wx.Above | The edge should be above another edge.
wx.Below | The edge should be below another edge.
wx.LeftOf | The edge should be to the left of another edge.
wx.RightOf | The edge should be to the right of another edge.
wx.SameAs | The edge or dimension should be the same as another edge or dimension.
wx.PercentOf | The edge or dimension should be a percentage of another edge or dimension.
wx.Absolute | The edge or dimension should be a given absolute value.

See Also:

wx.LayoutConstraints, wx.Window.SetConstraints

Method Summary
 | __init__(self)
 | __repr__(self)
 | Above(self, sibling, marg) Constrains this edge to be above the given window, with an optional margin.
 | Absolute(self, val) Constrains this edge or dimension to be the given absolute value.
 | AsIs(self) Sets this edge or constraint to be whatever the window's value is at the moment.
 | Below(self, sibling, marg) Constrains this edge to be below the given window, with an optional margin.
bool | GetDone(self)
int | GetEdge(self, which, thisWin, other) Get the value of this edge or dimension, or if this is not determinable, -1.
int | GetMargin(self)
int | GetMyEdge(self)
int | GetOtherEdge(self)
Window | GetOtherWindow(self)
int | GetPercent(self)
int | GetRelationship(self)
int | GetValue(self)
 | LeftOf(self, sibling, marg) Constrains this edge to be to the left of the given window, with an optional margin.
 | PercentOf(self, otherW, wh, per) Constrains this edge or dimension to be to a percentage of the given window, with an optional margin.
bool | ResetIfWin(self, otherW) Reset constraint if it mentions otherWin
 | RightOf(self, sibling, marg) Constrains this edge to be to the right of the given window, with an optional margin.
 | SameAs(self, otherW, edge, marg) Constrains this edge or dimension to be to the same as the edge of the given window, with an optional margin.
bool | SatisfyConstraint(self, constraints, win) Try to satisfy constraint
 | Set(self, rel, otherW, otherE, val, marg) Sets the properties of the constraint.
 | SetDone(self, d)
 | SetEdge(self, which)
 | SetMargin(self, m)
 | SetRelationship(self, r)
 | SetValue(self, v)
 | Unconstrained(self) Sets this edge or dimension to be unconstrained, that is, dependent on other edges and dimensions from which this value can be deduced.

Method Details

Above(self, sibling, marg=0)

Constrains this edge to be above the given window, with an optional margin. Implicitly, this is relative to the top edge of the other window.

Parameters:
sibling
(type=Window)

marg
(type=int)

Absolute(self, val)

Constrains this edge or dimension to be the given absolute value.

Parameters:
val
(type=int)

AsIs(self)

Sets this edge or constraint to be whatever the window's value is at the moment. If either of the width and height constraints are as is, the window will not be resized, but moved instead. This is important when considering panel items which are intended to have a default size, such as a button, which may take its size from the size of the button label.

Below(self, sibling, marg=0)

Constrains this edge to be below the given window, with an optional margin. Implicitly, this is relative to the bottom edge of the other window.

Parameters:
sibling
(type=Window)

marg
(type=int)

GetEdge(self, which, thisWin, other)

Get the value of this edge or dimension, or if this is not determinable, -1.

Parameters:
which
(type=int)

thisWin
(type=Window)

other
(type=Window)

Returns:
int

LeftOf(self, sibling, marg=0)

Constrains this edge to be to the left of the given window, with an optional margin. Implicitly, this is relative to the left edge of the other window.

Parameters:
sibling
(type=Window)

marg
(type=int)

PercentOf(self, otherW, wh, per)

Constrains this edge or dimension to be to a percentage of the given window, with an optional margin.

Parameters:
otherW
(type=Window)

wh
(type=int)

per
(type=int)

ResetIfWin(self, otherW)

Reset constraint if it mentions otherWin

Parameters:
otherW
(type=Window)

Returns:
bool

RightOf(self, sibling, marg=0)

Constrains this edge to be to the right of the given window, with an optional margin. Implicitly, this is relative to the right edge of the other window.

Parameters:
sibling
(type=Window)

marg
(type=int)

SameAs(self, otherW, edge, marg=0)

Constrains this edge or dimension to be to the same as the edge of the given window, with an optional margin.

Parameters:
otherW
(type=Window)

edge
(type=int)

marg
(type=int)

SatisfyConstraint(self, constraints, win)

Try to satisfy constraint

Parameters:
constraints
(type=LayoutConstraints)

win
(type=Window)

Returns:
bool

Set(self, rel, otherW, otherE, val=0, marg=wxLAYOUT_DEFAULT_MARGIN)

Sets the properties of the constraint. Normally called by one of the convenience functions such as Above, RightOf, SameAs.

Parameters:
rel
(type=int)

otherW
(type=Window)

otherE
(type=int)

val
(type=int)

marg
(type=int)

Unconstrained(self)

Sets this edge or dimension to be unconstrained, that is, dependent on other edges and dimensions from which this value can be deduced.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:06 2005 http://epydoc.sf.net


wx.InitDialogEvent

Package wx :: Class InitDialogEvent

Type InitDialogEvent

object --+
         |
    Object --+
             |
         Event --+
                 |
                InitDialogEvent

A wx.InitDialogEvent is sent as a dialog is being initialised, or for any window when wx.Window.InitDialog is called. Handlers for this event can transfer data to the window, or anything else that should be done before the user begins editing the form. The default handler calls wx.Window.TransferDataToWindow.

Events

wx.EVT_INIT_DIALOG Binder for init dialog events.
Method Summary
InitDialogEvent | __init__(self, Id) Constructor
 | __repr__(self)

Method Details

__init__(self, Id=0)
(Constructor)

Constructor

Parameters:
Id
(type=int)

Returns:
InitDialogEvent
Overrides:
wx.Event.__init__

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:40 2005 http://epydoc.sf.net


wx.InputStream

Package wx :: Class InputStream

Type InputStream

object --+
         |
        InputStream

Proxy of C++ InputStream class

Method Summary
InputStream | __init__(self, p)
 | __del__(self)
 | __repr__(self)
bool | CanRead(self)
 | close(self)
bool | Eof(self)
bool | eof(self)
 | flush(self)
char | GetC(self)
size_t | LastRead(self)
char | Peek(self)
PyObject | read(self, size)
PyObject | readline(self, size)
PyObject | readlines(self, sizehint)
 | seek(self, offset, whence)
long | SeekI(self, pos, mode)
int | tell(self)
long | TellI(self)
bool | Ungetch(self, c)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:40 2005 http://epydoc.sf.net


wx.InternetFSHandler

Package wx :: Class InternetFSHandler

Type InternetFSHandler

          object --+
                   |
CPPFileSystemHandler --+
                       |
                      InternetFSHandler

Proxy of C++ InternetFSHandler class

Method Summary
InternetFSHandler | __init__(self)
 | __repr__(self)
bool | CanOpen(self, location)
FSFile | OpenFile(self, fs, location)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:57 2005 http://epydoc.sf.net


wx.ItemContainer

Package wx :: Class ItemContainer

Type ItemContainer

object --+
         |
        ItemContainer

Known Subclasses:
ComboBox, ControlWithItems

The wx.ItemContainer class defines an interface which is implemented by all controls which have string subitems, each of which may be selected, such as wx.ListBox, wx.CheckListBox, wx.Choice as well as wx.ComboBox which implements an extended interface deriving from this one.

It defines the methods for accessing the control's items and although each of the derived classes implements them differently, they still all conform to the same interface.

The items in a wx.ItemContainer have (non empty) string labels and, optionally, client data associated with them.

Method Summary
 | __init__(self)
 | __repr__(self)
int | Append(self, item, clientData) Adds the item to the control, associating the given data with the item if not None.
 | AppendItems(self, strings) Apend several items at once to the control.
 | Clear(self) Removes all items from the control.
 | Delete(self, n) Deletes the item at the zero-based index 'n' from the control.
int | FindString(self, s) Finds an item whose label matches the given string.
PyObject | GetClientData(self, n) Returns the client data associated with the given item, (if any.)
int | GetCount(self) Returns the number of items in the control.
int | GetSelection(self) Returns the index of the selected item or wx.NOT_FOUND if no item is selected.
String | GetString(self, n) Returns the label of the item with the given index.
wxArrayString | GetStrings(self)
String | GetStringSelection(self) Returns the label of the selected item or an empty string if no item is selected.
int | Insert(self, item, pos, clientData) Insert an item into the control before the item at the pos index, optionally associating some data object with the item.
bool | IsEmpty(self) Returns True if the control is empty or False if it has some items.
 | Select(self, n) This is the same as SetSelection and exists only because it is slightly more natural for controls which support multiple selection.
 | SetClientData(self, n, clientData) Associate the given client data with the item at position n.
 | SetSelection(self, n) Sets the item at index 'n' to be the selected item.
 | SetString(self, n, s) Sets the label for the given item.
bool | SetStringSelection(self, s)

Method Details

Append(self, item, clientData=None)

Adds the item to the control, associating the given data with the item if not None. The return value is the index of the newly added item which may be different from the last one if the control is sorted (e.g. has wx.LB_SORT or wx.CB_SORT style).

Parameters:
item
(type=String)

clientData
(type=PyObject)

Returns:
int

AppendItems(self, strings)

Apend several items at once to the control. Notice that calling this method may be much faster than appending the items one by one if you need to add a lot of items.

Parameters:
strings
(type=List)

Clear(self)

Removes all items from the control.

Delete(self, n)

Deletes the item at the zero-based index 'n' from the control. Note that it is an error (signalled by a wx.PyAssertionError exception if enabled) to remove an item with the index negative or greater or equal than the number of items in the control.

Parameters:
n
(type=int)

FindString(self, s)

Finds an item whose label matches the given string. Returns the zero-based position of the item, or wx.NOT_FOUND if the string was not found.

Parameters:
s
(type=String)

Returns:
int

GetClientData(self, n)

Returns the client data associated with the given item, (if any.)

Parameters:
n
(type=int)

Returns:
PyObject

GetCount(self)

Returns the number of items in the control.

Returns:
int

GetSelection(self)

Returns the index of the selected item or wx.NOT_FOUND if no item is selected.

Returns:
int

GetString(self, n)

Returns the label of the item with the given index.

Parameters:
n
(type=int)

Returns:
String

GetStringSelection(self)

Returns the label of the selected item or an empty string if no item is selected.

Returns:
String

Insert(self, item, pos, clientData=None)

Insert an item into the control before the item at the pos index, optionally associating some data object with the item.

Parameters:
item
(type=String)

pos
(type=int)

clientData
(type=PyObject)

Returns:
int

IsEmpty(self)

Returns True if the control is empty or False if it has some items.

Returns:
bool

Select(self, n)

This is the same as SetSelection and exists only because it is slightly more natural for controls which support multiple selection.

Parameters:
n
(type=int)

SetClientData(self, n, clientData)

Associate the given client data with the item at position n.

Parameters:
n
(type=int)

clientData
(type=PyObject)

SetSelection(self, n)

Sets the item at index 'n' to be the selected item.

Parameters:
n
(type=int)

SetString(self, n, s)

Sets the label for the given item.

Parameters:
n
(type=int)

s
(type=String)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:10 2005 http://epydoc.sf.net


wx.Joystick

Package wx :: Class Joystick

Type Joystick

object --+
         |
        Joystick

Proxy of C++ Joystick class

Method Summary
Joystick | __init__(self, joystick)
 | __del__(self)
 | __nonzero__(self)
 | __repr__(self)
int | GetButtonState(self)
int | GetManufacturerId(self)
int | GetMaxAxes(self)
int | GetMaxButtons(self)
int | GetMovementThreshold(self)
int | GetNumberAxes(self)
int | GetNumberButtons(self)
int | GetNumberJoysticks(self)
int | GetPollingMax(self)
int | GetPollingMin(self)
Point | GetPosition(self)
int | GetPOVCTSPosition(self)
int | GetPOVPosition(self)
int | GetProductId(self)
String | GetProductName(self)
int | GetRudderMax(self)
int | GetRudderMin(self)
int | GetRudderPosition(self)
int | GetUMax(self)
int | GetUMin(self)
int | GetUPosition(self)
int | GetVMax(self)
int | GetVMin(self)
int | GetVPosition(self)
int | GetXMax(self)
int | GetXMin(self)
int | GetYMax(self)
int | GetYMin(self)
int | GetZMax(self)
int | GetZMin(self)
int | GetZPosition(self)
bool | HasPOV(self)
bool | HasPOV4Dir(self)
bool | HasPOVCTS(self)
bool | HasRudder(self)
bool | HasU(self)
bool | HasV(self)
bool | HasZ(self)
bool | IsOk(self)
bool | ReleaseCapture(self)
bool | SetCapture(self, win, pollingFreq)
 | SetMovementThreshold(self, threshold)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:09 2005 http://epydoc.sf.net


wx.JoystickEvent

Package wx :: Class JoystickEvent

Type JoystickEvent

object --+
         |
    Object --+
             |
         Event --+
                 |
                JoystickEvent

Proxy of C++ JoystickEvent class

Method Summary
JoystickEvent | __init__(self, type, state, joystick, change)
 | __repr__(self)
bool | ButtonDown(self, but)
bool | ButtonIsDown(self, but)
bool | ButtonUp(self, but)
int | GetButtonChange(self)
int | GetButtonState(self)
int | GetJoystick(self)
Point | GetPosition(self)
int | GetZPosition(self)
bool | IsButton(self)
bool | IsMove(self)
bool | IsZMove(self)
 | SetButtonChange(self, change)
 | SetButtonState(self, state)
 | SetJoystick(self, stick)
 | SetPosition(self, pos)
 | SetZPosition(self, zPos)

Property Summary
 | m_buttonChange
 | m_buttonState
 | m_joyStick
 | m_pos
 | m_zPosition

Property Details

m_buttonChange

Get Method:
GetButtonChange(self)
Set Method:
SetButtonChange(self, change)

m_buttonState

Get Method:
GetButtonState(self)
Set Method:
SetButtonState(self, state)

m_joyStick

Get Method:
GetJoystick(self)
Set Method:
SetJoystick(self, stick)

m_pos

Get Method:
GetPosition(self)
Set Method:
SetPosition(self, pos)

m_zPosition

Get Method:
GetZPosition(self)
Set Method:
SetZPosition(self, zPos)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:33 2005 http://epydoc.sf.net


wx.JPEGHandler

Package wx :: Class JPEGHandler

Type JPEGHandler

object --+
         |
    Object --+
             |
  ImageHandler --+
                 |
                JPEGHandler

A wx.ImageHandler for JPEG/JPG image files.

Method Summary
JPEGHandler | __init__(self) A wx.ImageHandler for JPEG/JPG image files.
 | __repr__(self)

Method Details

__init__(self)
(Constructor)

A wx.ImageHandler for JPEG/JPG image files.

Returns:
JPEGHandler
Overrides:
wx.ImageHandler.__init__

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:01 2005 http://epydoc.sf.net


wx.KeyEvent

Package wx :: Class KeyEvent

Type KeyEvent

object --+
         |
    Object --+
             |
         Event --+
                 |
                KeyEvent

This event class contains information about keypress and character events. These events are only sent to the widget that currently has the keyboard focus.

Notice that there are three different kinds of keyboard events in wxWidgets: key down and up events and char events. The difference between the first two is clear - the first corresponds to a key press and the second to a key release - otherwise they are identical. Just note that if the key is maintained in a pressed state you will typically get a lot of (automatically generated) down events but only one up so it is wrong to assume that there is one up event corresponding to each down one.

Both key events provide untranslated key codes while the char event carries the translated one. The untranslated code for alphanumeric keys is always an upper case value. For the other keys it is one of WXK_XXX values from the keycodes table. The translated key is, in general, the character the user expects to appear as the result of the key combination when typing the text into a text entry zone, for example.

A few examples to clarify this (all assume that CAPS LOCK is unpressed and the standard US keyboard): when the 'A' key is pressed, the key down event key code is equal to ASCII A == 65. But the char event key code is ASCII a == 97. On the other hand, if you press both SHIFT and 'A' keys simultaneously , the key code in key down event will still be just 'A' while the char event key code parameter will now be 'A' as well.

Although in this simple case it is clear that the correct key code could be found in the key down event handler by checking the value returned by ShiftDown, in general you should use EVT_CHAR for this as for non alphanumeric keys or non-US keyboard layouts the translation is keyboard-layout dependent and can only be done properly by the system itself.

Another kind of translation is done when the control key is pressed: for example, for CTRL-A key press the key down event still carries the same key code 'A' as usual but the char event will have key code of 1, the ASCII value of this key combination.

You may discover how the other keys on your system behave interactively by running the KeyEvents sample in the wxPython demo and pressing some keys while the blue box at the top has the keyboard focus.

Note: If a key down event is caught and the event handler does not call event.Skip() then the coresponding char event will not happen. This is by design and enables the programs that handle both types of events to be a bit simpler.

Note for Windows programmers: The key and char events in wxWidgets are similar to but slightly different from Windows WM_KEYDOWN and WM_CHAR events. In particular, Alt-x combination will generate a char event in wxWidgets (unless it is used as an accelerator).

Tip: be sure to call event.Skip() for events that you don't process in key event function, otherwise menu shortcuts may cease to work under Windows.

Events

wx.EVT_KEY_DOWN | Sent when a keyboard key has been pressed
wx.EVT_KEY_UP | Sent when a keyboard key has been released
wx.EVT_CHAR | Sent for translated character events.

Keycode Table

WXK_BACK | WXK_EXECUTE | WXK_F1 | WXK_NUMPAD_SPACE | WXK_WINDOWS_LEFT
WXK_TAB | WXK_SNAPSHOT | WXK_F2 | WXK_NUMPAD_TAB | WXK_WINDOWS_RIGHT
WXK_RETURN | WXK_INSERT | WXK_F3 | WXK_NUMPAD_ENTER | WXK_WINDOWS_MENU
WXK_ESCAPE | WXK_HELP | WXK_F4 | WXK_NUMPAD_F1 | WXK_SPECIAL1
WXK_SPACE | WXK_NUMPAD0 | WXK_F5 | WXK_NUMPAD_F2 | WXK_SPECIAL2
WXK_DELETE | WXK_NUMPAD1 | WXK_F6 | WXK_NUMPAD_F3 | WXK_SPECIAL3
WXK_LBUTTON | WXK_NUMPAD2 | WXK_F7 | WXK_NUMPAD_F4 | WXK_SPECIAL4
WXK_RBUTTON | WXK_NUMPAD3 | WXK_F8 | WXK_NUMPAD_HOME | WXK_SPECIAL5
WXK_CANCEL | WXK_NUMPAD4 | WXK_F9 | WXK_NUMPAD_LEFT | WXK_SPECIAL6
WXK_MBUTTON | WXK_NUMPAD5 | WXK_F10 | WXK_NUMPAD_UP | WXK_SPECIAL7
WXK_CLEAR | WXK_NUMPAD6 | WXK_F11 | WXK_NUMPAD_RIGHT | WXK_SPECIAL8
WXK_SHIFT | WXK_NUMPAD7 | WXK_F12 | WXK_NUMPAD_DOWN | WXK_SPECIAL9
WXK_ALT | WXK_NUMPAD8 | WXK_F13 | WXK_NUMPAD_PRIOR | WXK_SPECIAL10
WXK_CONTROL | WXK_NUMPAD9 | WXK_F14 | WXK_NUMPAD_PAGEUP | WXK_SPECIAL11
WXK_MENU | WXK_MULTIPLY | WXK_F15 | WXK_NUMPAD_NEXT | WXK_SPECIAL12
WXK_PAUSE | WXK_ADD | WXK_F16 | WXK_NUMPAD_PAGEDOWN | WXK_SPECIAL13
WXK_CAPITAL | WXK_SEPARATOR | WXK_F17 | WXK_NUMPAD_END | WXK_SPECIAL14
WXK_PRIOR | WXK_SUBTRACT | WXK_F18 | WXK_NUMPAD_BEGIN | WXK_SPECIAL15
WXK_NEXT | WXK_DECIMAL | WXK_F19 | WXK_NUMPAD_INSERT | WXK_SPECIAL16
WXK_END | WXK_DIVIDE | WXK_F20 | WXK_NUMPAD_DELETE | WXK_SPECIAL17
WXK_HOME | WXK_NUMLOCK | WXK_F21 | WXK_NUMPAD_EQUAL | WXK_SPECIAL18
WXK_LEFT | WXK_SCROLL | WXK_F22 | WXK_NUMPAD_MULTIPLY | WXK_SPECIAL19
WXK_UP | WXK_PAGEUP | WXK_F23 | WXK_NUMPAD_ADD | WXK_SPECIAL20
WXK_RIGHT | WXK_PAGEDOWN | WXK_F24 | WXK_NUMPAD_SEPARATOR
WXK_DOWN | WXK_NUMPAD_SUBTRACT
WXK_SELECT | WXK_NUMPAD_DECIMAL
WXK_PRINT | WXK_NUMPAD_DIVIDE
Method Summary
KeyEvent | __init__(self, eventType)
 | __repr__(self)
bool | AltDown(self) Returns True if the Alt key was down at the time of the event.
bool | CmdDown(self) "Cmd" is a pseudo key which is the same as Control for PC and Unix platforms but the special "Apple" (a.k.a as "Command") key on Macs.
bool | ControlDown(self) Returns True if the Control key was down at the time of the event.
int | GetKeyCode(self) Returns the virtual key code.
Point | GetPosition(self) Find the position of the event, if applicable.
(x,y) | GetPositionTuple() Find the position of the event, if applicable.
unsigned int | GetRawKeyCode(self) Returns the raw key code for this event.
unsigned int | GetRawKeyFlags(self) Returns the low level key flags for this event.
int | GetUniChar(self) Returns the Unicode character corresponding to this key event.
int | GetUnicodeKey(self) Returns the Unicode character corresponding to this key event.
int | GetX(self) Returns the X position (in client coordinates) of the event, if applicable.
int | GetY(self) Returns the Y position (in client coordinates) of the event, if applicable.
bool | HasModifiers(self) Returns true if either CTRL or ALT keys was down at the time of the key event.
int | KeyCode(self) Returns the virtual key code.
bool | MetaDown(self) Returns True if the Meta key was down at the time of the event.
bool | ShiftDown(self) Returns True if the Shift key was down at the time of the event.

Property Summary
 | m_altDown
 | m_controlDown
 | m_keyCode
 | m_metaDown
 | m_rawCode
 | m_rawFlags
 | m_scanCode
 | m_shiftDown
 | m_x
 | m_y

Method Details

__init__(self, eventType=wxEVT_NULL)
(Constructor)

Construct a new wx.KeyEvent. Valid event types are:
Parameters:
eventType
(type=wxEventType)

Returns:
KeyEvent
Overrides:
wx.Event.__init__

AltDown(self)

Returns True if the Alt key was down at the time of the event.

Returns:
bool

CmdDown(self)

"Cmd" is a pseudo key which is the same as Control for PC and Unix platforms but the special "Apple" (a.k.a as "Command") key on Macs. It makes often sense to use it instead of, say, ControlDown because Cmd key is used for the same thing under Mac as Ctrl elsewhere. The Ctrl still exists, it's just not used for this purpose. So for non-Mac platforms this is the same as ControlDown and Macs this is the same as MetaDown.

Returns:
bool

ControlDown(self)

Returns True if the Control key was down at the time of the event.

Returns:
bool

GetKeyCode(self)

Returns the virtual key code. ASCII events return normal ASCII values, while non-ASCII events return values such as WXK_LEFT for the left cursor key. See wx.KeyEvent for a full list of the virtual key codes.

Note that in Unicode build, the returned value is meaningful only if the user entered a character that can be represented in current locale's default charset. You can obtain the corresponding Unicode character using GetUnicodeKey.

Returns:
int

GetPosition(self)

Find the position of the event, if applicable.

Returns:
Point

GetPositionTuple()

Find the position of the event, if applicable.

Returns:
(x,y)

GetRawKeyCode(self)

Returns the raw key code for this event. This is a platform-dependent scan code which should only be used in advanced applications. Currently the raw key codes are not supported by all ports.

Returns:
unsigned int

GetRawKeyFlags(self)

Returns the low level key flags for this event. The flags are platform-dependent and should only be used in advanced applications. Currently the raw key flags are not supported by all ports.

Returns:
unsigned int

GetUniChar(self)

Returns the Unicode character corresponding to this key event. This function is only meaningfule in a Unicode build of wxPython.

Returns:
int

GetUnicodeKey(self)

Returns the Unicode character corresponding to this key event. This function is only meaningfule in a Unicode build of wxPython.

Returns:
int

GetX(self)

Returns the X position (in client coordinates) of the event, if applicable.

Returns:
int

GetY(self)

Returns the Y position (in client coordinates) of the event, if applicable.

Returns:
int

HasModifiers(self)

Returns true if either CTRL or ALT keys was down at the time of the key event. Note that this function does not take into account neither SHIFT nor META key states (the reason for ignoring the latter is that it is common for NUMLOCK key to be configured as META under X but the key presses even while NUMLOCK is on should be still processed normally).

Returns:
bool

KeyCode(self)

Returns the virtual key code. ASCII events return normal ASCII values, while non-ASCII events return values such as WXK_LEFT for the left cursor key. See wx.KeyEvent for a full list of the virtual key codes.

Note that in Unicode build, the returned value is meaningful only if the user entered a character that can be represented in current locale's default charset. You can obtain the corresponding Unicode character using GetUnicodeKey.

Returns:
int

MetaDown(self)

Returns True if the Meta key was down at the time of the event.

Returns:
bool

ShiftDown(self)

Returns True if the Shift key was down at the time of the event.

Returns:
bool

Property Details

m_altDown

Get Method:
KeyEvent_m_altDown_get(...)
Set Method:
KeyEvent_m_altDown_set(...)

m_controlDown

Get Method:
KeyEvent_m_controlDown_get(...)
Set Method:
KeyEvent_m_controlDown_set(...)

m_keyCode

Get Method:
KeyEvent_m_keyCode_get(...)
Set Method:
KeyEvent_m_keyCode_set(...)

m_metaDown

Get Method:
KeyEvent_m_metaDown_get(...)
Set Method:
KeyEvent_m_metaDown_set(...)

m_rawCode

Get Method:
KeyEvent_m_rawCode_get(...)
Set Method:
KeyEvent_m_rawCode_set(...)

m_rawFlags

Get Method:
KeyEvent_m_rawFlags_get(...)
Set Method:
KeyEvent_m_rawFlags_set(...)

m_scanCode

Get Method:
KeyEvent_m_scanCode_get(...)
Set Method:
KeyEvent_m_scanCode_set(...)

m_shiftDown

Get Method:
KeyEvent_m_shiftDown_get(...)
Set Method:
KeyEvent_m_shiftDown_set(...)

m_x

Get Method:
KeyEvent_m_x_get(...)
Set Method:
KeyEvent_m_x_set(...)

m_y

Get Method:
KeyEvent_m_y_get(...)
Set Method:
KeyEvent_m_y_set(...)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:59 2005 http://epydoc.sf.net


wx.LanguageInfo

Package wx :: Class LanguageInfo

Type LanguageInfo

object --+
         |
        LanguageInfo

Proxy of C++ LanguageInfo class

Method Summary
 | __init__(self)
 | __repr__(self)

Property Summary
 | CanonicalName
 | Description
 | Language

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:05 2005 http://epydoc.sf.net


wx.LayoutAlgorithm

Package wx :: Class LayoutAlgorithm

Type LayoutAlgorithm

object --+
         |
    Object --+
             |
            LayoutAlgorithm

Proxy of C++ LayoutAlgorithm class

Method Summary
LayoutAlgorithm | __init__(self)
 | __del__(self)
 | __repr__(self)
bool | LayoutFrame(self, frame, mainWindow)
bool | LayoutMDIFrame(self, frame, rect)
bool | LayoutWindow(self, parent, mainWindow)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:16 2005 http://epydoc.sf.net


wx.LayoutConstraints

Package wx :: Class LayoutConstraints

Type LayoutConstraints

object --+
         |
    Object --+
             |
            LayoutConstraints

Known Subclasses:
LayoutAnchors, Layoutf

Note: constraints are now deprecated and you should use sizers instead.

Objects of this class can be associated with a window to define its layout constraints, with respect to siblings or its parent.

The class consists of the following eight constraints of class wx.IndividualLayoutConstraint, some or all of which should be accessed directly to set the appropriate constraints.

  • left: represents the left hand edge of the window
  • right: represents the right hand edge of the window
  • top: represents the top edge of the window
  • bottom: represents the bottom edge of the window
  • width: represents the width of the window
  • height: represents the height of the window
  • centreX: represents the horizontal centre point of the window
  • centreY: represents the vertical centre point of the window

Most constraints are initially set to have the relationship wxUnconstrained, which means that their values should be calculated by looking at known constraints. The exceptions are width and height, which are set to wxAsIs to ensure that if the user does not specify a constraint, the existing width and height will be used, to be compatible with panel items which often have take a default size. If the constraint is wx.AsIs, the dimension will not be changed.

See Also:

wx.IndividualLayoutConstraint, wx.Window.SetConstraints

Method Summary
LayoutConstraints | __init__(self)
 | __repr__(self)
bool | AreSatisfied(self)
(areSatisfied, noChanges) | SatisfyConstraints(win)

Property Summary
 | bottom
 | centreX
 | centreY
 | height
 | left
 | right
 | top
 | width

Property Details

bottom

Get Method:
LayoutConstraints_bottom_get(...)

centreX

Get Method:
LayoutConstraints_centreX_get(...)

centreY

Get Method:
LayoutConstraints_centreY_get(...)

height

Get Method:
LayoutConstraints_height_get(...)

left

Get Method:
LayoutConstraints_left_get(...)

right

Get Method:
LayoutConstraints_right_get(...)

top

Get Method:
LayoutConstraints_top_get(...)

width

Get Method:
LayoutConstraints_width_get(...)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:04 2005 http://epydoc.sf.net


wx.lib.analogclock.AnalogClockWindow

Package wx :: Package lib :: Module analogclock :: Class AnalogClockWindow
[frames | no frames]

Type AnalogClockWindow

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
              PyWindow --+
                         |
                        AnalogClockWindow

An analog clock window

Method Summary
 | __init__(self, parent, ID, pos, size, style, name)
 | DoGetBestSize(self)
 | OnPaint(self, event)
 | OnPopupOne(self, event)
 | OnPopupTwo(self, event)
 | OnQuit(self, event)
 | OnRightClick(self, event)
 | OnRightDown(self, event)
 | OnSize(self, event)
 | OnTimerExpire(self, event)
 | SetClockStyle(self, style) Set the clock style, acording to these options:
 | SetHandColours(self, h, m, s) h, m, s: wx.Colour
 | SetHandWeights(self, h, m, s) h, m, s: value
 | SetMinutesOffset(self, o) s = value
 | SetShadowColour(self, s) s = wx.Colour or (r,g,b) tuple.
 | SetTickColours(self, h, m) h, m: wx.Colour
 | SetTickFonts(self, h, m) h, m: wx.Font
 | SetTickShapes(self, tsh, tsm) tsh, tsm: [[x0,y0], [x1,y1], ...
 | SetTickSizes(self, h, m) h, m: value
 | SetTickStyles(self, h, m) Set the ticks styles, acording to the options below.
 | SetWatchPenBrush(self, p, b) p = wx.Pen; b = wx.Brush

Instance Method Details

SetClockStyle(self, style)

Set the clock style, acording to these options:

SHOW_QUARTERS_TICKS | Show marks for hours 3, 6, 9, 12
SHOW_HOURS_TICKS | Show marks for all hours
SHOW_MINUTES_TICKS | Show marks for minutes
SHOW_HOURS_HAND | Show hours hand
SHOW_MINUTES_HAND | Show minutes hand
SHOW_SECONDS_HAND | Show seconds hand
SHOW_SHADOWS | Show hands and marks shadows
ROTATE_TICKS | Align tick marks to watch
OVERLAP_TICKS | Draw tick marks for minutes even when they match the hours marks.

SetHandColours(self,
          h=None,
          m=None,
          s=None)

h, m, s: wx.Colour

Sets colours of hands. If m and s are ommitted, we'll use h for all.

SetHandWeights(self,
          h=None,
          m=None,
          s=None)

h, m, s: value

Sets thickness of hands.

SetMinutesOffset(self, o)

s = value

Sets the distance between tick marks for hours and minutes.

SetShadowColour(self, s)

s = wx.Colour or (r,g,b) tuple.

Sets the colour to be used to draw shadows.

SetTickColours(self, h=None, m=None)

h, m: wx.Colour

Sets colours of ticks. If m is ommitted, we'll use h for both.

SetTickFonts(self, h=None, m=None)

h, m: wx.Font

Fonts for tick marks when using TICKS_DECIMAL or TICKS_ROMAN style. If m is ommitted, we'll use h for both.

SetTickShapes(self, tsh, tsm=None)

tsh, tsm: [[x0,y0], [x1,y1], ... [xn,yn]]

Sets lists of lists of points to be used as polygon shapes when using the TICKS_POLY style. If tsm is ommitted, we'll use tsh for both shapes.

SetTickSizes(self, h=None, m=None)

h, m: value

Sizes for tick marks.

SetTickStyles(self, h=None, m=None)

Set the ticks styles, acording to the options below.

TICKS_NONE | Don't show tick marks.
TICKS_SQUARE | Use squares as tick marks.
TICKS_CIRCLE | Use circles as tick marks.
TICKS_POLY | Use a polygon as tick marks. The polygon must be passed using SetTickShapes, otherwise the default polygon will be used.
TICKS_DECIMAL | Use decimal numbers.
TICKS_ROMAN | Use Roman numbers.

SetWatchPenBrush(self, p=None, b=None)

p = wx.Pen; b = wx.Brush

Set the pen and brush for the watch.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:17 2005 http://epydoc.sf.net


wx.lib.analogclock

Package wx :: Package lib :: Module analogclock

Module wx.lib.analogclock

AnalogClockWindow is a simple analog clock class.

Classes
AnalogClockWindow An analog clock window

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:02 2005 http://epydoc.sf.net


wx.lib.analogclockopts.ACCustomizationFrame

Package wx :: Package lib :: Module analogclockopts :: Class ACCustomizationFrame
[frames | no frames]

Type ACCustomizationFrame

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
        TopLevelWindow --+
                         |
                     Frame --+
                             |
                            ACCustomizationFrame

Method Summary
 | __init__(self, parent, id, name, pos, size, style)
 | gfid(self, id, lista)
 | OnChangeStyle(self, evt)
 | OnDefaults(self, evt)
 | OnEventsHook(self, evt)
 | OnQuit(self, evt)
 | OnSelectColour(self, evt)
 | OnSelectFont(self, evt)
 | OnSpinChange(self, evt)
 | UpdateAll(self)
 | UpdateWidgets(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:22 2005 http://epydoc.sf.net


wx.lib.analogclockopts

Package wx :: Package lib :: Module analogclockopts

Module wx.lib.analogclockopts

A configuration dialog (frame actually) for the AnalogClockWindow

Classes
ACCustomizationFrame

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:39 2005 http://epydoc.sf.net


wx.lib.anchors.LayoutAnchors

Package wx :: Package lib :: Module anchors :: Class LayoutAnchors
[frames | no frames]

Type LayoutAnchors

   object --+
            |
       Object --+
                |
LayoutConstraints --+
                    |
                   LayoutAnchors

A class that implements Delphi's Anchors with wx.LayoutConstraints.

Anchored sides maintain the distance from the edge of the control to the same edge of the parent. When neither side is selected, the control keeps the same relative position to both sides.

The current position and size of the control and it's parent is used when setting up the constraints. To change the size or position of an already anchored control, set the constraints to None, reposition or resize and reapply the anchors.

Examples:

Let's anchor the right and bottom edge of a control and
resize it's parent.

ctrl.SetConstraints(LayoutAnchors(ctrl, left=0, top=0, right=1, bottom=1))

+=========+         +===================+
| +-----+ |         |                   |
| |     * |   ->    |                   |
| +--*--+ |         |           +-----+ |
+---------+         |           |     * |
                    |           +--*--+ |
                    +-------------------+
* = anchored edge

When anchored on both sides the control will stretch horizontally.

ctrl.SetConstraints(LayoutAnchors(ctrl, 1, 0, 1, 1))

+=========+         +===================+
| +-----+ |         |                   |
| *     * |   ->    |                   |
| +--*--+ |         | +---------------+ |
+---------+         | *     ctrl      * |
                    | +-------*-------+ |
                    +-------------------+
* = anchored edge

Method Summary
 | __init__(self, control, left, top, right, bottom)
 | setConstraintSides(self, side1, side1Edge, side1Anchor, side2, side2Edge, side2Anchor, size, sizeEdge, centre, cPos, cSize, pSize, parent)

Property Summary

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:17 2005 http://epydoc.sf.net


wx.lib.anchors

Package wx :: Package lib :: Module anchors

Module wx.lib.anchors

LayoutAnchors is a class that implements Delphi's Anchors using wx.LayoutConstraints.

Classes
LayoutAnchors A class that implements Delphi's Anchors with wx.LayoutConstraints.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:10:48 2005 http://epydoc.sf.net


wx.lib.buttons.GenBitmapButton

Package wx :: Package lib :: Module buttons :: Class GenBitmapButton
[frames | no frames]

Type GenBitmapButton

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
               Control --+
                         |
                 PyControl --+
                             |
                     GenButton --+
                                 |
                                GenBitmapButton

Known Subclasses:
GenBitmapTextButton, GenBitmapToggleButton

A generic bitmap button.

Method Summary
 | __init__(self, parent, ID, bitmap, pos, size, style, validator, name)
 | DrawLabel(self, dc, width, height, dw, dy)
 | GetBitmapDisabled(self)
 | GetBitmapFocus(self)
 | GetBitmapLabel(self)
 | GetBitmapSelected(self)
 | SetBitmapDisabled(self, bitmap) Set bitmap to display when the button is disabled
 | SetBitmapFocus(self, bitmap) Set bitmap to display when the button has the focus
 | SetBitmapLabel(self, bitmap, createOthers) Set the bitmap to display normally.
 | SetBitmapSelected(self, bitmap) Set bitmap to display when the button is selected (pressed down)

Class Variable Summary

Instance Method Details

SetBitmapDisabled(self, bitmap)

Set bitmap to display when the button is disabled

SetBitmapFocus(self, bitmap)

Set bitmap to display when the button has the focus

SetBitmapLabel(self, bitmap, createOthers=True)

Set the bitmap to display normally. This is the only one that is required. If createOthers is True, then the other bitmaps will be generated on the fly. Currently, only the disabled bitmap is generated.

SetBitmapSelected(self, bitmap)

Set bitmap to display when the button is selected (pressed down)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:17 2005 http://epydoc.sf.net


wx.lib.buttons.GenBitmapTextButton

Package wx :: Package lib :: Module buttons :: Class GenBitmapTextButton
[frames | no frames]

Type GenBitmapTextButton

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
               Control --+
                         |
                 PyControl --+
                             |
                     GenButton --+
                                 |
                   GenBitmapButton --+
                                     |
                                    GenBitmapTextButton

Known Subclasses:
GenBitmapTextToggleButton

A generic bitmapped button with text label

Method Summary
 | __init__(self, parent, ID, bitmap, label, pos, size, style, validator, name)
 | DrawLabel(self, dc, width, height, dw, dy)

Class Variable Summary

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:23 2005 http://epydoc.sf.net


wx.lib.buttons.GenBitmapTextToggleButton

Package wx :: Package lib :: Module buttons :: Class GenBitmapTextToggleButton
[frames | no frames]

Type GenBitmapTextToggleButton

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
               Control --+
                         |
                 PyControl --+
                             |
                     GenButton --+
                                 |
                   GenBitmapButton --+
                                     |
                   GenBitmapTextButton --+
                                         |
                         __ToggleMixin --+
                                         |
                                        GenBitmapTextToggleButton

A generic toggle bitmap button with text label

Method Summary

Class Variable Summary

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:03 2005 http://epydoc.sf.net


wx.lib.buttons.GenBitmapToggleButton

Package wx :: Package lib :: Module buttons :: Class GenBitmapToggleButton
[frames | no frames]

Type GenBitmapToggleButton

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
               Control --+
                         |
                 PyControl --+
                             |
                     GenButton --+
                                 |
                   GenBitmapButton --+
                                     |
                     __ToggleMixin --+
                                     |
                                    GenBitmapToggleButton

A generic toggle bitmap button

Method Summary

Class Variable Summary

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:46 2005 http://epydoc.sf.net


wx.lib.buttons.GenButton

Package wx :: Package lib :: Module buttons :: Class GenButton
[frames | no frames]

Type GenButton

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
               Control --+
                         |
                 PyControl --+
                             |
                            GenButton

Known Subclasses:
GenBitmapButton, GenToggleButton

A generic button, and base class for the other generic buttons.

Method Summary
 | __init__(self, parent, ID, label, pos, size, style, validator, name)
 | AcceptsFocus(self) Overridden base class virtual.
 | DoGetBestSize(self) Overridden base class virtual.
 | DrawBezel(self, dc, x1, y1, x2, y2)
 | DrawFocusIndicator(self, dc, w, h)
 | DrawLabel(self, dc, width, height, dw, dy)
 | Enable(self, enable)
 | GetBezelWidth(self) Return the width of the 3D effect
 | GetDefaultAttributes(self) Overridden base class virtual.
 | GetUseFocusIndicator(self) Return focus indicator flag
 | InitColours(self) Calculate a new set of highlight and shadow colours based on the background colour.
 | Notify(self)
 | OnGainFocus(self, event)
 | OnKeyDown(self, event)
 | OnKeyUp(self, event)
 | OnLeftDown(self, event)
 | OnLeftUp(self, event)
 | OnLoseFocus(self, event)
 | OnMotion(self, event)
 | OnPaint(self, event)
 | SetBackgroundColour(self, colour)
 | SetBestSize(self, size) Given the current font and bezel width settings, calculate and set a good size.
 | SetBezelWidth(self, width) Set the width of the 3D effect
 | SetDefault(self)
 | SetForegroundColour(self, colour)
 | SetUseFocusIndicator(self, flag) Specifiy if a focus indicator (dotted line) should be used
 | ShouldInheritColours(self) Overridden base class virtual.

Class Variable Summary
int labelDelta = 1

Instance Method Details

AcceptsFocus(self)

Overridden base class virtual.

Overrides:
wx.Window.AcceptsFocus

DoGetBestSize(self)

Overridden base class virtual. Determines the best size of the button based on the label and bezel size.

GetBezelWidth(self)

Return the width of the 3D effect

GetDefaultAttributes(self)

Overridden base class virtual. By default we should use the same font/colour attributes as the native Button.

Overrides:
wx.Window.GetDefaultAttributes

GetUseFocusIndicator(self)

Return focus indicator flag

InitColours(self)

Calculate a new set of highlight and shadow colours based on the background colour. Works okay if the colour is dark...

SetBestSize(self, size=None)

Given the current font and bezel width settings, calculate and set a good size.

Overrides:
wx.PyControl.SetBestSize

SetBezelWidth(self, width)

Set the width of the 3D effect

SetUseFocusIndicator(self, flag)

Specifiy if a focus indicator (dotted line) should be used

ShouldInheritColours(self)

Overridden base class virtual. Buttons usually don't inherit the parent's colours.

Overrides:
wx.Window.ShouldInheritColours

Class Variable Details

labelDelta

Type:
int
Value:
1

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:33 2005 http://epydoc.sf.net


wx.lib.buttons.GenButtonEvent

Package wx :: Package lib :: Module buttons :: Class GenButtonEvent
[frames | no frames]

Type GenButtonEvent

object --+
         |
    Object --+
             |
         Event --+
                 |
      CommandEvent --+
                     |
        PyCommandEvent --+
                         |
                        GenButtonEvent

Event sent from the generic buttons when the button is activated.

Method Summary
 | __init__(self, eventType, ID)
 | GetButtonObj(self)
 | GetIsDown(self)
 | SetButtonObj(self, btn)
 | SetIsDown(self, isDown)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:12 2005 http://epydoc.sf.net


wx.lib.buttons.GenToggleButton

Package wx :: Package lib :: Module buttons :: Class GenToggleButton
[frames | no frames]

Type GenToggleButton

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
               Control --+
                         |
                 PyControl --+
                             |
                     GenButton --+
                                 |
                 __ToggleMixin --+
                                 |
                                GenToggleButton

A generic toggle button

Method Summary

Class Variable Summary

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:09 2005 http://epydoc.sf.net


wx.lib.buttons

Package wx :: Package lib :: Module buttons

Module wx.lib.buttons

This module implements various forms of generic buttons, meaning that they are not built on native controls but are self-drawn. They act like normal buttons but you are able to better control how they look, bevel width, colours, etc.

Classes
GenBitmapButton | A generic bitmap button.
GenBitmapTextButton | A generic bitmapped button with text label
GenBitmapTextToggleButton | A generic toggle bitmap button with text label
GenBitmapToggleButton | A generic toggle bitmap button
GenButton | A generic button, and base class for the other generic buttons.
GenButtonEvent | Event sent from the generic buttons when the button is activated.
GenToggleButton | A generic toggle button

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:26 2005 http://epydoc.sf.net


wx.lib.calendar.CalDraw

Package wx :: Package lib :: Module calendar :: Class CalDraw
[frames | no frames]

Class CalDraw

Known Subclasses:
PrtCalDraw
Method Summary
 | __init__(self, parent)
 | AddSelect(self, list, cfont, cbackgrd)
 | Center(self)
 | DefParms(self)
 | DrawBorder(self, DC, transparent)
 | DrawCal(self, DC, sel_lst)
 | DrawDayText(self, DC, key)
 | DrawFocusIndicator(self, DC)
 | DrawGrid(self, DC)
 | DrawMonth(self, DC)
 | DrawNum(self, DC)
 | DrawNumVal(self)
 | DrawSel(self, DC)
 | DrawWeek(self, DC)
 | GetCal(self)
 | GetColor(self, name)
 | GetOffset(self)
 | GetRect(self)
 | InitScale(self)
 | InitValues(self)
 | SetCal(self, year, month)
 | SetColor(self, name, value)
 | SetMarg(self, xmarg, ymarg)
 | SetPos(self, xpos, ypos)
 | SetSize(self, size)
 | SetWeekColor(self, font_color, week_color)
 | SetWeekEnd(self, font_color, backgrd)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:05 2005 http://epydoc.sf.net


wx.lib.calendar.Calendar

Package wx :: Package lib :: Module calendar :: Class Calendar
[frames | no frames]

Type Calendar

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
               Control --+
                         |
                 PyControl --+
                             |
                            Calendar

Method Summary
 | __init__(self, parent, id, pos, size, style, validator, name)
 | AcceptsFocus(self)
 | AddSelect(self, list, font_color, back_color)
 | ClearDsp(self)
 | DecMonth(self)
 | DecYear(self)
 | DoDrawing(self, DC)
 | DrawFocusIndicator(self, draw)
 | DrawRect(self, key, bgcolor, fgcolor, width)
 | DrawRectOrg(self, key, fgcolor, width)
 | GetColor(self, name)
 | GetDate(self)
 | GetDay(self)
 | GetDayHit(self, mx, my)
 | GetMonth(self)
 | GetYear(self)
 | HideGrid(self)
 | HideTitle(self)
 | IncMonth(self)
 | IncYear(self)
 | IsDayInWeekend(self, key)
 | OnKeyDown(self, event)
 | OnKillFocus(self, event)
 | OnLeftDEvent(self, event)
 | OnLeftEvent(self, event)
 | OnPaint(self, event)
 | OnRightDEvent(self, event)
 | OnRightEvent(self, event)
 | OnSetFocus(self, event)
 | OnSize(self, evt)
 | ProcessClick(self, event)
 | SelectDay(self, key)
 | SetBusType(self)
 | SetColor(self, name, value)
 | SetCurrentDay(self)
 | SetDay(self, day)
 | SetDayValue(self, day)
 | SetMargin(self, xmarg, ymarg)
 | SetMonth(self, month)
 | SetNow(self)
 | SetSelDay(self, sel)
 | SetSize(self, set_size)
 | SetTextAlign(self, vert, horz)
 | SetWeekColor(self, font_color, week_color)
 | SetYear(self, year)
 | ShowWeekEnd(self)
 | TestDay(self, key)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:09 2005 http://epydoc.sf.net


wx.lib.calendar.CalenDlg

Package wx :: Package lib :: Module calendar :: Class CalenDlg
[frames | no frames]

Type CalenDlg

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
        TopLevelWindow --+
                         |
                    Dialog --+
                             |
                            CalenDlg

Method Summary
 | __init__(self, parent, month, day, year)
 | EvtComboBox(self, event)
 | MouseClick(self, evt)
 | OnCancel(self, event)
 | OnMonthSpin(self, event)
 | OnOk(self, evt)
 | OnYrSpin(self, event)
 | ResetDisplay(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:10:49 2005 http://epydoc.sf.net


wx.lib.calendar.PrtCalDraw

Package wx :: Package lib :: Module calendar :: Class PrtCalDraw
[frames | no frames]

Class PrtCalDraw

CalDraw --+
          |
         PrtCalDraw

Method Summary
 | InitValues(self)
 | SetPreview(self, preview)
 | SetPSize(self, pwidth, pheight)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:05 2005 http://epydoc.sf.net


wx.lib.calendar

Package wx :: Package lib :: Module calendar

Module wx.lib.calendar

Classes
CalDraw
Calendar
CalenDlg
PrtCalDraw

Function Summary
 | DefaultColors()
 | GetMonthList()
 | MakeColor(in_color)

Variable Summary
dict | AbrWeekday = {0: 'Mon', 1: 'Tue', 2: 'Wed', 3: 'Thu', 4:...
list | BusCalDays = [0, 1, 2, 3, 4, 5, 6]
list | CalDays = [6, 0, 1, 2, 3, 4, 5]
str | COLOR_3D_DARK = '3d_dark'
str | COLOR_3D_LIGHT = '3d_light'
str | COLOR_BACKGROUND = 'background'
str | COLOR_BORDER = 'border'
str | COLOR_FONT = 'font'
str | COLOR_GRID_LINES = 'grid_lines'
str | COLOR_HEADER_BACKGROUND = 'header_background'
str | COLOR_HEADER_FONT = 'header_font'
str | COLOR_HIGHLIGHT_BACKGROUND = 'highlight_background'
str | COLOR_HIGHLIGHT_FONT = 'highlight_font'
str | COLOR_SELECTION_BACKGROUND = 'selection_background'
str | COLOR_SELECTION_FONT = 'selection_font'
str | COLOR_WEEKEND_BACKGROUND = 'weekend_background'
str | COLOR_WEEKEND_FONT = 'weekend_font'
PyEventBinder | EVT_CALENDAR = <wx._core.PyEventBinder object at 0xb5bf4...
int | wxEVT_COMMAND_PYCALENDAR_DAY_CLICKED = 10257

Variable Details

AbrWeekday

Type:
dict
Value:
{0: 'Mon', 1: 'Tue', 2: 'Wed', 3: 'Thu', 4: 'Fri', 5: 'Sat', 6: 'Sun'}

BusCalDays

Type:
list
Value:
[0, 1, 2, 3, 4, 5, 6]

CalDays

Type:
list
Value:
[6, 0, 1, 2, 3, 4, 5]

COLOR_3D_DARK

Type:
str
Value:
'3d_dark'

COLOR_3D_LIGHT

Type:
str
Value:
'3d_light'

COLOR_BACKGROUND

Type:
str
Value:
'background'

COLOR_BORDER

Type:
str
Value:
'border'

COLOR_FONT

Type:
str
Value:
'font'

COLOR_GRID_LINES

Type:
str
Value:
'grid_lines'

COLOR_HEADER_BACKGROUND

Type:
str
Value:
'header_background'

COLOR_HEADER_FONT

Type:
str
Value:
'header_font'

COLOR_HIGHLIGHT_BACKGROUND

Type:
str
Value:
'highlight_background'

COLOR_HIGHLIGHT_FONT

Type:
str
Value:
'highlight_font'

COLOR_SELECTION_BACKGROUND

Type:
str
Value:
'selection_background'

COLOR_SELECTION_FONT

Type:
str
Value:
'selection_font'

COLOR_WEEKEND_BACKGROUND

Type:
str
Value:
'weekend_background'

COLOR_WEEKEND_FONT

Type:
str
Value:
'weekend_font'

EVT_CALENDAR

Type:
PyEventBinder
Value:
<wx._core.PyEventBinder object at 0xb5bf488c>

wxEVT_COMMAND_PYCALENDAR_DAY_CLICKED

Type:
int
Value:
10257

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:12 2005 http://epydoc.sf.net


wx.lib.CDate.Date

Package wx :: Package lib :: Module CDate :: Class Date

Class Date

Method Summary
__init__(self, year, month, day)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:41 2005 http://epydoc.sf.net


wx.lib.CDate.now

Package wx :: Package lib :: Module CDate :: Class now

Class now

Method Summary
__init__(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:58 2005 http://epydoc.sf.net


wx.lib.CDate

Package wx :: Package lib :: Module CDate

Module wx.lib.CDate

Classes
Date
now

Function Summary
 | dayOfWeek(julian)
 | daysPerMonth(month, year)
 | FillDate(val)
 | FormatDay(value)
 | FromJulian(julian)
 | isleap(year)
 | julianDay(year, month, day)
 | leapdays(y1, y2)
 | TodayDay()

Variable Summary
list | day_abbr = ['Sun', 'Mon', 'Tue', 'Wed', 'Thu', 'Fri', 'S...
list | day_name = ['Sunday', 'Monday', 'Tuesday', 'Wednesday', ...
list | mdays = [0, 31, 28, 31, 30, 31, 30, 31, 31, 30, 31, 30, ...
dict | Month = {0: None, 1: 'January', 2: 'February', 3: 'March...

Variable Details

day_abbr

Type:
list
Value:
['Sun', 'Mon', 'Tue', 'Wed', 'Thu', 'Fri', 'Sat']

day_name

Type:
list
Value:
['Sunday', 'Monday', 'Tuesday', 'Wednesday', 'Thursday', 'Friday', 'Sa\
turday']

mdays

Type:
list
Value:
[0, 31, 28, 31, 30, 31, 30, 31, 31, 30, 31, 30, 31]

Month

Type:
dict
Value:
{None: 0,
 0: None,
 1: 'January',
 2: 'February',
 3: 'March',
 4: 'April',
 5: 'May',
 6: 'June',
...

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:04 2005 http://epydoc.sf.net


wx.lib.ClickableHtmlWindow.PyClickableHtmlWindow

Package wx :: Package lib :: Module ClickableHtmlWindow :: Class PyClickableHtmlWindow
[frames | no frames]

Type PyClickableHtmlWindow

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
                 Panel --+
                         |
            ScrolledWindow --+
                             |
                    HtmlWindow --+
                                 |
                                PyClickableHtmlWindow

Class for a wxHtmlWindow which responds to clicks on links by opening a browser pointed at that link, and to shift-clicks by copying the link to the clipboard.

Method Summary
 | __init__(self, parent, ID, **kw)
 | OnLinkClicked(self, link)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:16 2005 http://epydoc.sf.net


wx.lib.ClickableHtmlWindow

Package wx :: Package lib :: Module ClickableHtmlWindow

Module wx.lib.ClickableHtmlWindow

sorry no documentation... Christopher J. Fama

Classes
PyClickableHtmlWindow Class for a wxHtmlWindow which responds to clicks on links by opening a browser pointed at that link, and to shift-clicks by copying the link to the clipboard.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:04 2005 http://epydoc.sf.net


wx.lib.colourchooser.canvas.BitmapBuffer

Package wx :: Package lib :: Package colourchooser :: Module canvas :: Class BitmapBuffer
[frames | no frames]

Type BitmapBuffer

object --+
         |
    Object --+
             |
            DC --+
                 |
          MemoryDC --+
                     |
                    BitmapBuffer

A screen buffer class.

This class implements a screen output buffer. Data is meant to be drawn in the buffer class and then blitted directly to the output device, or on-screen window.

Method Summary
 | __init__(self, width, height, colour) Initialize the empty buffer object.
 | GetBitmap(self) Returns the internal bitmap for direct drawing.

Method Details

__init__(self, width, height, colour)
(Constructor)

Initialize the empty buffer object.

Overrides:
wx.MemoryDC.__init__

GetBitmap(self)

Returns the internal bitmap for direct drawing.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:47 2005 http://epydoc.sf.net


wx.lib.colourchooser.canvas.Canvas

Package wx :: Package lib :: Package colourchooser :: Module canvas :: Class Canvas
[frames | no frames]

Type Canvas

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
                    Canvas

Known Subclasses:
PyColourSlider, PyPalette

A canvas class for arbitrary drawing.

The Canvas class implements a window that allows for drawing arbitrary graphics. It implements a double buffer scheme and blits the off-screen buffer to the window during paint calls by the windowing system for speed.

Some other methods for determining the canvas colour and size are also provided.

Method Summary
 | __init__(self, parent, id, pos, size, style) Creates a canvas instance and initializes the off-screen buffer.
 | Blit(self, dc) Performs the blit of the buffer contents on-screen.
 | DrawBuffer(self) Actual drawing function for drawing into the off-screen buffer.
 | GetBoundingRect(self) Returns a tuple that contains the co-ordinates of the top-left and bottom-right corners of the canvas.
 | MakeNewBuffer(self)
 | onPaint(self, event) Renders the off-screen buffer on-screen.
 | onSize(self, event) Perform actual redraw to off-screen buffer only when the size of the canvas has changed.
 | ReDraw(self) Explicitly tells the canvas to redraw it's contents.
 | Refresh(self) Re-draws the buffer contents on-screen.

Instance Method Details

__init__(self, parent, id, pos=wx.Point(-1, -1), size=wx.Size(-1, -1), style=33554432)
(Constructor)

Creates a canvas instance and initializes the off-screen buffer. Also sets the handler for rendering the canvas automatically via size and paint calls from the windowing system.

Overrides:
wx.Window.__init__

Blit(self, dc)

Performs the blit of the buffer contents on-screen.

DrawBuffer(self)

Actual drawing function for drawing into the off-screen buffer. To be overrideen in the implementing class. Do nothing by default.

GetBoundingRect(self)

Returns a tuple that contains the co-ordinates of the top-left and bottom-right corners of the canvas.

onPaint(self, event)

Renders the off-screen buffer on-screen.

onSize(self, event)

Perform actual redraw to off-screen buffer only when the size of the canvas has changed. This saves a lot of computation since the same image can be re-used, provided the canvas size hasn't changed.

ReDraw(self)

Explicitly tells the canvas to redraw it's contents.

Refresh(self)

Re-draws the buffer contents on-screen.

Overrides:
wx.Window.Refresh

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:26 2005 http://epydoc.sf.net


wx.lib.colourchooser.canvas

Package wx :: Package lib :: Package colourchooser :: Module canvas
[frames | no frames]

Module wx.lib.colourchooser.canvas

PyColourChooser Copyright (C) 2002 Michael Gilfix <mgilfix@eecs.tufts.edu>

This file is part of PyColourChooser.

This version of PyColourChooser is open source; you can redistribute it and/or modify it under the licensed terms.

This program is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

Classes
BitmapBuffer | A screen buffer class.
Canvas | A canvas class for arbitrary drawing.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:38 2005 http://epydoc.sf.net


wx.lib.colourchooser.pycolourbox.PyColourBox

Package wx :: Package lib :: Package colourchooser :: Module pycolourbox :: Class PyColourBox
[frames | no frames]

Type PyColourBox

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
                 Panel --+
                         |
                        PyColourBox

A Colour Selection Box

The Colour selection box implements button like behavior but contains a solid-filled, coloured sub-box. Placing the colour in a sub-box allows for filling in the main panel's background for a high-lighting effect.

Method Summary
 | __init__(self, parent, id, colour, size) Creates a new colour box instance and initializes the colour content.
 | GetColour(self) Returns a wxColour object indicating the box's current colour.
 | GetColourBox(self) Returns a reference to the internal box object containing the color.
 | SetColour(self, colour) Accepts a wxColour object and sets the box's current color.
 | SetColourTuple(self, colour) Sets the box's current couple to the given tuple.
 | SetHighlight(self, val) Accepts a boolean 'val' toggling the box's highlighting.
 | Update(self)

Instance Method Details

__init__(self, parent, id, colour=(0, 0, 0), size=(25, 20))
(Constructor)

Creates a new colour box instance and initializes the colour content.

Overrides:
wx.Panel.__init__

GetColour(self)

Returns a wxColour object indicating the box's current colour.

GetColourBox(self)

Returns a reference to the internal box object containing the color. This function is useful for setting up event handlers for the box.

SetColour(self, colour)

Accepts a wxColour object and sets the box's current color.

SetColourTuple(self, colour)

Sets the box's current couple to the given tuple.

SetHighlight(self, val)

Accepts a boolean 'val' toggling the box's highlighting.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:12 2005 http://epydoc.sf.net


wx.lib.colourchooser.pycolourbox

Package wx :: Package lib :: Package colourchooser :: Module pycolourbox
[frames | no frames]

Module wx.lib.colourchooser.pycolourbox

PyColourChooser Copyright (C) 2002 Michael Gilfix <mgilfix@eecs.tufts.edu>

This file is part of PyColourChooser.

This version of PyColourChooser is open source; you can redistribute it and/or modify it under the licensed terms.

This program is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

Classes
PyColourBox A Colour Selection Box

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:06 2005 http://epydoc.sf.net


wx.lib.colourchooser.pycolourchooser.PyColourChooser

Package wx :: Package lib :: Package colourchooser :: Module pycolourchooser :: Class PyColourChooser
[frames | no frames]

Type PyColourChooser

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
                 Panel --+
                         |
                        PyColourChooser

A Pure-Python implementation of the colour chooser dialog.

The PyColourChooser is a pure python implementation of the colour chooser dialog. It's useful for embedding the colour choosing functionality inside other widgets, when the pop-up dialog is undesirable. It can also be used as a drop-in replacement on the GTK platform, as the native dialog is kind of ugly.

Method Summary
 | __init__(self, parent, id) Creates an instance of the colour chooser.
 | doPaletteClick(self, m_x, m_y) Updates the colour values based on the mouse location over the palette.
 | GetValue(self) Returns a wxColour object indicating the current colour choice.
 | InitColours(self) Initializes the pre-set palette colours.
 | onAddCustom(self, event) Adds a custom colour to the custom colour box set.
 | onBasicClick(self, event, box) Highlights the selected colour box and updates the solid colour display and colour slider to reflect the choice.
 | onCustomClick(self, event, box) Highlights the selected custom colour box and updates the solid colour display and colour slider to reflect the choice.
 | onPaletteDown(self, event) Stores state that the mouse has been pressed and updates the selected colour values.
 | onPaletteMotion(self, event) Updates the colour values during mouse motion while the mouse button is depressed.
 | onPaletteUp(self, event) Stores state that the mouse is no longer depressed.
 | onScroll(self, event) Updates the solid colour display to reflect the changing slider.
 | setCustomColour(self, index, true_colour, base_colour, slidepos) Sets the custom colour at the given index.
 | SetValue(self, colour) Updates the colour chooser to reflect the given wxColour.
 | UpdateColour(self, colour) Performs necessary updates for when the colour selection has changed.
 | UpdateEntries(self, colour) Updates the color levels to display the new values.

Class Variable Summary
list | colour_names = ['ORANGE', 'GOLDENROD', 'WHEAT', 'SPRING ...
list | custom_colours = [(wx.Colour(255, 255, 255), 86), (wx.Co...
int | idADD_CUSTOM = 102
int | idSCROLL = 103
int | last_custom = 0
int | NO_CUSTOM_COLOURS = 16

Instance Method Details

__init__(self, parent, id)
(Constructor)

Creates an instance of the colour chooser. Note that it is best to accept the given size of the colour chooser as it is currently not resizeable.

Overrides:
wx.Panel.__init__

doPaletteClick(self, m_x, m_y)

Updates the colour values based on the mouse location over the palette.

GetValue(self)

Returns a wxColour object indicating the current colour choice.

InitColours(self)

Initializes the pre-set palette colours.

onAddCustom(self, event)

Adds a custom colour to the custom colour box set. Boxes are chosen in a round-robin fashion, eventually overwriting previously added colours.

onBasicClick(self, event, box)

Highlights the selected colour box and updates the solid colour display and colour slider to reflect the choice.

onCustomClick(self, event, box)

Highlights the selected custom colour box and updates the solid colour display and colour slider to reflect the choice.

onPaletteDown(self, event)

Stores state that the mouse has been pressed and updates the selected colour values.

onPaletteMotion(self, event)

Updates the colour values during mouse motion while the mouse button is depressed.

onPaletteUp(self, event)

Stores state that the mouse is no longer depressed.

onScroll(self, event)

Updates the solid colour display to reflect the changing slider.

setCustomColour(self, index, true_colour, base_colour, slidepos)

Sets the custom colour at the given index. true_colour is wxColour object containing the actual rgb value of the custom colour. base_colour (wxColour) and slidepos (int) are used to configure the colour slider and set everything to its original position.

SetValue(self, colour)

Updates the colour chooser to reflect the given wxColour.

UpdateColour(self, colour)

Performs necessary updates for when the colour selection has changed.

UpdateEntries(self, colour)

Updates the color levels to display the new values.

Class Variable Details

colour_names

Type:
list
Value:
['ORANGE',
 'GOLDENROD',
 'WHEAT',
 'SPRING GREEN',
 'SKY BLUE',
 'SLATE BLUE',
 'MEDIUM VIOLET RED',
 'PURPLE',
...

custom_colours

Type:
list
Value:
[(wx.Colour(255, 255, 255), 86),
 (wx.Colour(255, 255, 255), 86),
 (wx.Colour(255, 255, 255), 86),
 (wx.Colour(255, 255, 255), 86),
 (wx.Colour(255, 255, 255), 86),
 (wx.Colour(255, 255, 255), 86),
 (wx.Colour(255, 255, 255), 86),
 (wx.Colour(255, 255, 255), 86),
...

idADD_CUSTOM

Type:
int
Value:
102

idSCROLL

Type:
int
Value:
103

last_custom

Type:
int
Value:
0

NO_CUSTOM_COLOURS

Type:
int
Value:
16

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:44 2005 http://epydoc.sf.net


wx.lib.colourchooser.pycolourchooser

Package wx :: Package lib :: Package colourchooser :: Module pycolourchooser
[frames | no frames]

Module wx.lib.colourchooser.pycolourchooser

PyColourChooser Copyright (C) 2002 Michael Gilfix <mgilfix@eecs.tufts.edu>

This file is part of PyColourChooser.

This version of PyColourChooser is open source; you can redistribute it and/or modify it under the licensed terms.

This program is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

Classes
PyColourChooser A Pure-Python implementation of the colour chooser dialog.

Function Summary
main()
Simple test display.

Function Details

main()

Simple test display.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:11 2005 http://epydoc.sf.net


wx.lib.colourchooser.pycolourslider.PyColourSlider

Package wx :: Package lib :: Package colourchooser :: Module pycolourslider :: Class PyColourSlider
[frames | no frames]

Type PyColourSlider

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
                Canvas --+
                         |
                        PyColourSlider

A Pure-Python Colour Slider

The colour slider displays transitions from value 0 to value 1 in HSV, allowing the user to select a colour within the transition spectrum.

This class is best accompanying by a wxSlider that allows the user to select a particular colour shade.

Method Summary
 | __init__(self, parent, id, colour) Creates a blank slider instance.
 | DrawBuffer(self) Actual implementation of the widget's drawing.
 | GetBaseColour(self) Return the current colour used as a colour base for filling out the slider.
 | GetValue(self, pos) Returns the colour value for a position on the slider.
 | SetBaseColour(self, colour) Sets the base, or target colour, to use as the central colour when calculating colour transitions.

Class Variable Summary
int | HEIGHT = 172
int | WIDTH = 12

Instance Method Details

__init__(self, parent, id, colour=None)
(Constructor)

Creates a blank slider instance. A colour must be set before the slider will be filled in.

Overrides:
wx.lib.colourchooser.canvas.Canvas.__init__

DrawBuffer(self)

Actual implementation of the widget's drawing. We simply draw from value 0.0 to value 1.0 in HSV.

Overrides:
wx.lib.colourchooser.canvas.Canvas.DrawBuffer

GetBaseColour(self)

Return the current colour used as a colour base for filling out the slider.

GetValue(self, pos)

Returns the colour value for a position on the slider. The position must be within the valid height of the slider, or results can be unpredictable.

SetBaseColour(self, colour)

Sets the base, or target colour, to use as the central colour when calculating colour transitions.

Class Variable Details

HEIGHT

Type:
int
Value:
172

WIDTH

Type:
int
Value:
12

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:22 2005 http://epydoc.sf.net


wx.lib.colourchooser.pycolourslider

Package wx :: Package lib :: Package colourchooser :: Module pycolourslider
[frames | no frames]

Module wx.lib.colourchooser.pycolourslider

PyColourChooser Copyright (C) 2002 Michael Gilfix

This file is part of PyColourChooser.

You should have received a file COPYING containing license terms along with this program; if not, write to Michael Gilfix (mgilfix@eecs.tufts.edu) for a copy.

This version of PyColourChooser is open source; you can redistribute it and/or modify it under the terms listed in the file COPYING.

This program is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

Classes
PyColourSlider A Pure-Python Colour Slider

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:23 2005 http://epydoc.sf.net


wx.lib.colourchooser.pypalette.PyPalette

Package wx :: Package lib :: Package colourchooser :: Module pypalette :: Class PyPalette
[frames | no frames]

Type PyPalette

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
                Canvas --+
                         |
                        PyPalette

The Pure-Python Palette

The PyPalette is a pure python implementation of a colour palette. The palette implementation here imitates the palette layout used by MS Windows and Adobe Photoshop.

The actual palette image has been embedded as an XPM for speed. The actual reverse-engineered drawing algorithm is provided in the GeneratePaletteBMP() method. The algorithm is tweakable by supplying the granularity factor to improve speed at the cost of display beauty. Since the generator isn't used in real time, no one will likely care :) But if you need it for some sort of unforeseen realtime application, it's there.

Method Summary
 | __init__(self, parent, id) Creates a palette object.
 | DrawBuffer(self) Draws the palette XPM into the memory buffer.
 | GeneratePaletteBMP(self, file_name, granularity) The actual palette drawing algorithm.
 | GetValue(self, x, y) Returns a colour value at a specific x, y coordinate pair.
 | HighlightPoint(self, x, y) Highlights an area of the palette with a little circle around the coordinate point

Class Variable Summary
int | HORIZONTAL_STEP = 2
int | VERTICAL_STEP = 4

Instance Method Details

__init__(self, parent, id)
(Constructor)

Creates a palette object.

Overrides:
wx.lib.colourchooser.canvas.Canvas.__init__

DrawBuffer(self)

Draws the palette XPM into the memory buffer.

Overrides:
wx.lib.colourchooser.canvas.Canvas.DrawBuffer

GeneratePaletteBMP(self, file_name, granularity=1)

The actual palette drawing algorithm.

This used to be 100% reverse engineered by looking at the values on the MS map, but has since been redone Correctly(tm) according to the HSV (hue, saturation, value) colour model by Charl P. Botha <http://cpbotha.net/>.

Speed is tweakable by changing the granularity factor, but that affects how nice the output looks (makes the vertical blocks bigger. This method was used to generate the embedded XPM data.

GetValue(self, x, y)

Returns a colour value at a specific x, y coordinate pair. This is useful for determining the colour found a specific mouse click in an external event handler.

HighlightPoint(self, x, y)

Highlights an area of the palette with a little circle around the coordinate point

Class Variable Details

HORIZONTAL_STEP

Type:
int
Value:
2

VERTICAL_STEP

Type:
int
Value:
4

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:38 2005 http://epydoc.sf.net


wx.lib.colourchooser.pypalette

Package wx :: Package lib :: Package colourchooser :: Module pypalette
[frames | no frames]

Module wx.lib.colourchooser.pypalette

PyColourChooser Copyright (C) 2002 Michael Gilfix

This file is part of PyColourChooser.

You should have received a file COPYING containing license terms along with this program; if not, write to Michael Gilfix (mgilfix@eecs.tufts.edu) for a copy.

This version of PyColourChooser is open source; you can redistribute it and/or modify it under the terms listed in the file COPYING.

This program is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

Classes
PyPalette The Pure-Python Palette

Function Summary
 | getBitmap()
 | getData()
 | getImage()

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:10 2005 http://epydoc.sf.net


wx.lib.colourchooser

Package wx :: Package lib :: Package colourchooser

Package wx.lib.colourchooser

PyColourChooser Copyright (C) 2002 Michael Gilfix <mgilfix@eecs.tufts.edu>

This file is part of PyColourChooser.

This version of PyColourChooser is open source; you can redistribute it and/or modify it under the licensed terms.

This program is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

Submodules
  • canvas: PyColourChooser Copyright (C) 2002 Michael Gilfix <mgilfix@eecs.tufts.edu>
  • pycolourbox: PyColourChooser Copyright (C) 2002 Michael Gilfix <mgilfix@eecs.tufts.edu>
  • pycolourchooser: PyColourChooser Copyright (C) 2002 Michael Gilfix <mgilfix@eecs.tufts.edu>
  • pycolourslider: PyColourChooser Copyright (C) 2002 Michael Gilfix
  • pypalette: PyColourChooser Copyright (C) 2002 Michael Gilfix

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:27 2005 http://epydoc.sf.net


wx.lib.colourdb

Package wx :: Package lib :: Module colourdb

Module wx.lib.colourdb

Load addition color names/values into the wx colour database. These names and values originally came from the rgb.txt file on my system...

Function Summary
 | getColourInfoList() Returns the list of colour name/value tuples used by this module.
 | getColourList() Returns a list of just the colour names used by this module.
 | updateColourDB() Updates the wx colour database by adding new colour names and RGB values.

Function Details

getColourInfoList()

Returns the list of colour name/value tuples used by this module.

getColourList()

Returns a list of just the colour names used by this module.

updateColourDB()

Updates the wx colour database by adding new colour names and RGB values.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:06 2005 http://epydoc.sf.net


wx.lib.colourselect.ColourSelect

Package wx :: Package lib :: Module colourselect :: Class ColourSelect
[frames | no frames]

Type ColourSelect

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
               Control --+
                         |
                    Button --+
                             |
                  BitmapButton --+
                                 |
                                ColourSelect

Method Summary
 | __init__(self, parent, id, label, colour, pos, size, callback, style)
 | GetColour(self)
 | GetLabel(self)
 | GetValue(self)
 | MakeBitmap(self)
 | OnChange(self)
 | OnClick(self, event)
 | SetBitmap(self, bmp)
 | SetColour(self, colour)
 | SetLabel(self, label)
 | SetValue(self, colour)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:01 2005 http://epydoc.sf.net


wx.lib.colourselect.ColourSelectEvent

Package wx :: Package lib :: Module colourselect :: Class ColourSelectEvent
[frames | no frames]

Type ColourSelectEvent

object --+
         |
    Object --+
             |
         Event --+
                 |
      CommandEvent --+
                     |
        PyCommandEvent --+
                         |
                        ColourSelectEvent

Method Summary
 | __init__(self, id, value)
 | GetValue(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:12 2005 http://epydoc.sf.net


wx.lib.colourselect

Package wx :: Package lib :: Module colourselect

Module wx.lib.colourselect

Provides a ColourSelect button that, when clicked, will display a colour selection dialog. The selected colour is displayed on the button itself.

Classes
ColourSelect
ColourSelectEvent

Variable Summary
PyEventBinder | EVT_COLOURSELECT = <wx._core.PyEventBinder object at 0xb...
int | wxEVT_COMMAND_COLOURSELECT = 10256

Variable Details

EVT_COLOURSELECT

Type:
PyEventBinder
Value:
<wx._core.PyEventBinder object at 0xb5bfd4cc>

wxEVT_COMMAND_COLOURSELECT

Type:
int
Value:
10256

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:02 2005 http://epydoc.sf.net


wx.lib.dialogs.DialogResults

Package wx :: Package lib :: Module dialogs :: Class DialogResults
[frames | no frames]

Class DialogResults

Method Summary
 | __init__(self, returned)
 | __repr__(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:08 2005 http://epydoc.sf.net


wx.lib.dialogs.MultipleChoiceDialog

Package wx :: Package lib :: Module dialogs :: Class MultipleChoiceDialog
[frames | no frames]

Type MultipleChoiceDialog

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
        TopLevelWindow --+
                         |
                    Dialog --+
                             |
                            MultipleChoiceDialog

Method Summary
 | __init__(self, parent, msg, title, lst, pos, size, style)
 | GetValue(self)
 | GetValueString(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:28 2005 http://epydoc.sf.net


wx.lib.dialogs.ScrolledMessageDialog

Package wx :: Package lib :: Module dialogs :: Class ScrolledMessageDialog
[frames | no frames]

Type ScrolledMessageDialog

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
        TopLevelWindow --+
                         |
                    Dialog --+
                             |
                            ScrolledMessageDialog

Method Summary
__init__(self, parent, msg, caption, pos, size, style)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:22 2005 http://epydoc.sf.net


wx.lib.dialogs

Package wx :: Package lib :: Module dialogs

Module wx.lib.dialogs

Classes
DialogResults
MultipleChoiceDialog
ScrolledMessageDialog

Function Summary
 | alertDialog(parent, message, title, pos)
 | colorDialog(parent, colorData, color)
 | colourDialog(parent, colourData, colour)
 | dirDialog(parent, message, path, style, pos, size)
 | directoryDialog(parent, message, path, style, pos, size)
 | fileDialog(parent, title, directory, filename, wildcard, style)
 | findDialog(parent, searchText, wholeWordsOnly, caseSensitive)
 | fontDialog(parent, fontData, font)
 | messageDialog(parent, message, title, aStyle, pos)
 | multipleChoiceDialog(parent, message, title, lst, pos, size)
 | openFileDialog(parent, title, directory, filename, wildcard, style)
 | returnedString(ret)
 | saveFileDialog(parent, title, directory, filename, wildcard, style)
 | scrolledMessageDialog(parent, message, title, pos, size)
 | singleChoiceDialog(parent, message, title, lst, style)
 | textEntryDialog(parent, message, title, defaultText, style)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:09 2005 http://epydoc.sf.net


wx.lib.docview.Command

Package wx :: Package lib :: Module docview :: Class Command

Type Command

object --+
         |
    Object --+
             |
            Command

wxCommand is a base class for modelling an application command, which is an action usually performed by selecting a menu item, pressing a toolbar button or any other means provided by the application to change the data or view.

Method Summary
 | __init__(self, canUndo, name) Constructor.
 | CanUndo(self) Returns true if the command can be undone, false otherwise.
 | Do(self) Override this member function to execute the appropriate action when called.
 | GetName(self) Returns the command name.
 | Undo(self) Override this member function to un-execute a previous Do.

Method Details

__init__(self, canUndo=False, name=None)
(Constructor)

Constructor. wxCommand is an abstract class, so you will need to derive a new class and call this constructor from your own constructor.

canUndo tells the command processor whether this command is undo-able. You can achieve the same functionality by overriding the CanUndo member function (if for example the criteria for undoability is context- dependent).

name must be supplied for the command processor to display the command name in the application's edit menu.

Overrides:
wx.Object.__init__

CanUndo(self)

Returns true if the command can be undone, false otherwise.

Do(self)

Override this member function to execute the appropriate action when called. Return true to indicate that the action has taken place, false otherwise. Returning false will indicate to the command processor that the action is not undoable and should not be added to the command history.

GetName(self)

Returns the command name.

Undo(self)

Override this member function to un-execute a previous Do. Return true to indicate that the action has taken place, false otherwise. Returning false will indicate to the command processor that the action is not redoable and no change should be made to the command history.

How you implement this command is totally application dependent, but typical strategies include:

Perform an inverse operation on the last modified piece of data in the document. When redone, a copy of data stored in command is pasted back or some operation reapplied. This relies on the fact that you know the ordering of Undos; the user can never Undo at an arbitrary position in he command history.

Restore the entire document state (perhaps using document transactioning). Potentially very inefficient, but possibly easier to code if the user interface and data are complex, and an 'inverse execute' operation is hard to write.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:03 2005 http://epydoc.sf.net


wx.lib.docview.CommandProcessor

Package wx :: Package lib :: Module docview :: Class CommandProcessor
[frames | no frames]

Type CommandProcessor

object --+
         |
    Object --+
             |
            CommandProcessor

wxCommandProcessor is a class that maintains a history of wxCommands, with undo/redo functionality built-in. Derive a new class from this if you want different behaviour.

Method Summary
 | __init__(self, maxCommands) Constructor.
 | CanRedo(self) Returns true if the currently-active command can be redone, false otherwise.
 | CanUndo(self) Returns true if the currently-active command can be undone, false otherwise.
 | ClearCommands(self) Deletes all the commands in the list and sets the current command pointer to None.
 | GetCommands(self) Returns the list of commands.
 | GetEditMenu(self) Returns the edit menu associated with the command processor.
 | GetMaxCommands(self) Returns the maximum number of commands that the command processor stores.
 | GetRedoAccelerator(self) Returns the string that will be appended to the Redo menu item.
 | GetUndoAccelerator(self) Returns the string that will be appended to the Undo menu item.
 | Redo(self) Redoes the command just undone.
 | SetEditMenu(self, menu) Tells the command processor to update the Undo and Redo items on this menu as appropriate.
 | SetMenuStrings(self) Sets the menu labels according to the currently set menu and the current command state.
 | SetRedoAccelerator(self, accel) Sets the string that will be appended to the Redo menu item.
 | SetUndoAccelerator(self, accel) Sets the string that will be appended to the Redo menu item.
 | Submit(self, command, storeIt) Submits a new command to the command processor.
 | Undo(self) Undoes the command just executed.

Method Details

__init__(self, maxCommands=-1)
(Constructor)

Constructor. maxCommands may be set to a positive integer to limit the number of commands stored to it, otherwise (and by default) the list of commands can grow arbitrarily.

Overrides:
wx.Object.__init__

CanRedo(self)

Returns true if the currently-active command can be redone, false otherwise.

CanUndo(self)

Returns true if the currently-active command can be undone, false otherwise.

ClearCommands(self)

Deletes all the commands in the list and sets the current command pointer to None.

GetCommands(self)

Returns the list of commands.

GetEditMenu(self)

Returns the edit menu associated with the command processor.

GetMaxCommands(self)

Returns the maximum number of commands that the command processor stores.

GetRedoAccelerator(self)

Returns the string that will be appended to the Redo menu item.

GetUndoAccelerator(self)

Returns the string that will be appended to the Undo menu item.

Redo(self)

Redoes the command just undone.

SetEditMenu(self, menu)

Tells the command processor to update the Undo and Redo items on this menu as appropriate. Set this to NULL if the menu is about to be destroyed and command operations may still be performed, or the command processor may try to access an invalid pointer.

SetMenuStrings(self)

Sets the menu labels according to the currently set menu and the current command state.

SetRedoAccelerator(self, accel)

Sets the string that will be appended to the Redo menu item.

SetUndoAccelerator(self, accel)

Sets the string that will be appended to the Redo menu item.

Submit(self, command, storeIt=True)

Submits a new command to the command processor. The command processor calls wxCommand::Do to execute the command; if it succeeds, the command is stored in the history list, and the associated edit menu (if any) updated appropriately. If it fails, the command is deleted immediately. Once Submit has been called, the passed command should not be deleted directly by the application.

storeIt indicates whether the successful command should be stored in the history list.

Undo(self)

Undoes the command just executed.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:42 2005 http://epydoc.sf.net


wx.lib.docview.DocChildFrame

Package wx :: Package lib :: Module docview :: Class DocChildFrame
[frames | no frames]

Type DocChildFrame

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
        TopLevelWindow --+
                         |
                     Frame --+
                             |
                            DocChildFrame

Known Subclasses:
DocSDIFrame

The wxDocChildFrame class provides a default frame for displaying documents on separate windows. This class can only be used for SDI (not MDI) child frames.

The class is part of the document/view framework supported by wxWindows, and cooperates with the wxView, wxDocument, wxDocManager and wxDocTemplate classes.

Method Summary
 | __init__(self, doc, view, frame, id, title, pos, size, style, name) Constructor.
 | GetDocument(self) Returns the document associated with this frame.
 | GetView(self) Returns the view associated with this frame.
 | OnActivate(self, event) Activates the current view.
 | OnCloseWindow(self, event) Closes and deletes the current view and document.
 | ProcessEvent(self, event) Processes an event, searching event tables and calling zero or more suitable event handler function(s).
 | ProcessUpdateUIEvent(self, event) Processes a UI event, searching event tables and calling zero or more suitable event handler function(s).
 | SetDocument(self, document) Sets the document for this frame.
 | SetView(self, view) Sets the view for this frame.

Instance Method Details

__init__(self, doc, view, frame, id, title, pos=wx.Point(-1, -1), size=wx.Size(-1, -1), style=541072960, name='frame')
(Constructor)

Constructor. Note that the event table must be rebuilt for the frame since the EvtHandler is not virtual.

Overrides:
wx.Frame.__init__

GetDocument(self)

Returns the document associated with this frame.

GetView(self)

Returns the view associated with this frame.

OnActivate(self, event)

Activates the current view.

OnCloseWindow(self, event)

Closes and deletes the current view and document.

ProcessEvent(self, event)

Processes an event, searching event tables and calling zero or more suitable event handler function(s). Note that the ProcessEvent method is called from the wxPython docview framework directly since wxPython does not have a virtual ProcessEvent function.

Overrides:
wx.EvtHandler.ProcessEvent

ProcessUpdateUIEvent(self, event)

Processes a UI event, searching event tables and calling zero or more suitable event handler function(s). Note that the ProcessEvent method is called from the wxPython docview framework directly since wxPython does not have a virtual ProcessEvent function.

SetDocument(self, document)

Sets the document for this frame.

SetView(self, view)

Sets the view for this frame.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:03 2005 http://epydoc.sf.net


wx.lib.docview.DocManager

Package wx :: Package lib :: Module docview :: Class DocManager
[frames | no frames]

Type DocManager

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
                DocManager

The wxDocManager class is part of the document/view framework supported by wxWindows, and cooperates with the wxView, wxDocument and wxDocTemplate classes.

Method Summary
 | __init__(self, flags, initialize) Constructor.
 | ActivateView(self, view, activate, deleting) Sets the current view.
 | AddDocument(self, document) Adds the document to the list of documents.
 | AddFileToHistory(self, fileName) Adds a file to the file history list, if we have a pointer to an appropriate file menu.
 | AssociateTemplate(self, docTemplate) Adds the template to the document manager's template list.
 | Clear(self, force) Closes all currently opened document by callling CloseDocuments and clears the document manager's templates.
 | CloseDocument(self, doc, force) Closes the specified document.
 | CloseDocuments(self, force) Closes all currently opened documents.
 | CreateDocument(self, path, flags) Creates a new document in a manner determined by the flags parameter, which can be:
 | CreateView(self, document, flags) Creates a new view for the given document.
 | DeleteTemplate(self, template, flags) Placeholder, not yet implemented in wxWindows.
 | Destroy(self) Destructor.
 | DisassociateTemplate(self, docTemplate) Removes the template from the list of templates.
 | FileHistoryAddFilesToMenu(self, menu) Appends the files in the history list, to all menus managed by the file history object.
 | FileHistoryLoad(self, config) Loads the file history from a config object.
 | FileHistoryRemoveMenu(self, menu) Removes the given menu from the list of menus managed by the file history object.
 | FileHistorySave(self, config) Saves the file history into a config object.
 | FileHistoryUseMenu(self, menu) Use this menu for appending recently-visited document filenames, for convenient access.
 | FindSuitableParent(self) Returns a parent frame or dialog, either the frame with the current focus or if there is no current focus the application's top frame.
 | FindTemplateForPath(self, path) Given a path, try to find template that matches the extension.
 | FlushDoc(self, doc) Placeholder, not yet implemented in wxWindows.
 | GetCurrentDocument(self) Returns the document associated with the currently active view (if any).
 | GetCurrentView(self) Returns the currently active view.
 | GetDocuments(self) Returns the list of documents.
 | GetFileHistory(self) Returns the file history.
 | GetFlags(self) Returns the document manager's flags.
 | GetHistoryFile(self, i) Returns the file at index i from the file history.
 | GetHistoryFilesCount(self) Returns the number of files currently stored in the file history.
 | GetLastActiveView(self) Returns the last active view.
 | GetMaxDocsOpen(self) Returns the number of documents that can be open simultaneously.
 | GetTemplates(self) Returns the document manager's template list.
 | Initialize(self) Initializes data; currently just calls OnCreateFileHistory.
 | MakeDefaultName(self) Returns a suitable default name.
 | MakeFrameTitle(self) Returns a suitable title for a document frame.
 | MatchTemplate(self, path) Placeholder, not yet implemented in wxWindows.
 | OnCreateFileHistory(self) A hook to allow a derived class to create a different type of file history.
 | OnFileClose(self, event) Closes and deletes the currently active document.
 | OnFileCloseAll(self, event) Closes and deletes all the currently opened documents.
 | OnFileNew(self, event) Creates a new document and reads in the selected file.
 | OnFileOpen(self, event) Creates a new document and reads in the selected file.
 | OnFileRevert(self, event) Reverts the current document by calling wxDocument.Save for the current document.
 | OnFileSave(self, event) Saves the current document by calling wxDocument.Save for the current document.
 | OnFileSaveAs(self, event) Calls wxDocument.SaveAs for the current document.
 | OnOpenFileFailure(self) Called when there is an error opening a file.
 | OnPreview(self, event) Previews the current document by calling its View's OnCreatePrintout method.
 | OnPrint(self, event) Prints the current document by calling its View's OnCreatePrintout method.
 | OnPrintSetup(self, event) Presents the print setup dialog.
 | OnRedo(self, event) Issues a Redo command to the current document's command processor.
 | OnUndo(self, event) Issues an Undo command to the current document's command processor.
 | OnUpdateFileClose(self, event) Updates the user interface for the File Close command.
 | OnUpdateFileCloseAll(self, event) Updates the user interface for the File Close All command.
 | OnUpdateFileNew(self, event) Updates the user interface for the File New command.
 | OnUpdateFileOpen(self, event) Updates the user interface for the File Open command.
 | OnUpdateFileRevert(self, event) Updates the user interface for the File Revert command.
 | OnUpdateFileSave(self, event) Updates the user interface for the File Save command.
 | OnUpdateFileSaveAs(self, event) Updates the user interface for the File Save As command.
 | OnUpdatePreview(self, event) Updates the user interface for the Print Preview command.
 | OnUpdatePrint(self, event) Updates the user interface for the Print command.
 | OnUpdatePrintSetup(self, event) Updates the user interface for the Print Setup command.
 | OnUpdateRedo(self, event) Updates the user interface for the Redo command.
 | OnUpdateUndo(self, event) Updates the user interface for the Undo command.
 | ProcessEvent(self, event) Processes an event, searching event tables and calling zero or more suitable event handler function(s).
 | ProcessUpdateUIEvent(self, event) Processes a UI event, searching event tables and calling zero or more suitable event handler function(s).
 | RemoveDocument(self, doc) Removes the document from the list of documents.
 | RemoveFileFromHistory(self, i) Removes a file from the file history list, if we have a pointer to an appropriate file menu.
 | SelectDocumentPath(self, templates, flags, save) Under Windows, pops up a file selector with a list of filters corresponding to document templates.
 | SelectDocumentType(self, temps, sort) Returns a document template by asking the user (if there is more than one template).
 | SelectViewType(self, temps, sort) Returns a document template by asking the user (if there is more than one template), displaying a list of valid views.
 | SetMaxDocsOpen(self, maxDocsOpen) Sets the maximum number of documents that can be open at a time.

Method Details

__init__(self, flags=0, initialize=True)
(Constructor)

Constructor. Create a document manager instance dynamically near the start of your application before doing any document or view operations.

flags is used in the Python version to indicate whether the document manager is in DOC_SDI or DOC_MDI mode.

If initialize is true, the Initialize function will be called to create a default history list object. If you derive from wxDocManager, you may wish to call the base constructor with false, and then call Initialize in your own constructor, to allow your own Initialize or OnCreateFileHistory functions to be called.

Overrides:
wx.EvtHandler.__init__

ActivateView(self, view, activate=True, deleting=False)

Sets the current view.

AddDocument(self, document)

Adds the document to the list of documents.

AddFileToHistory(self, fileName)

Adds a file to the file history list, if we have a pointer to an appropriate file menu.

AssociateTemplate(self, docTemplate)

Adds the template to the document manager's template list.

Clear(self, force=True)

Closes all currently opened document by callling CloseDocuments and clears the document manager's templates.

CloseDocument(self, doc, force=True)

Closes the specified document.

CloseDocuments(self, force=True)

Closes all currently opened documents.

CreateDocument(self, path, flags=0)

Creates a new document in a manner determined by the flags parameter, which can be:

wx.lib.docview.DOC_NEW Creates a fresh document. wx.lib.docview.DOC_SILENT Silently loads the given document file.

If wx.lib.docview.DOC_NEW is present, a new document will be created and returned, possibly after asking the user for a template to use if there is more than one document template. If wx.lib.docview.DOC_SILENT is present, a new document will be created and the given file loaded into it. If neither of these flags is present, the user will be presented with a file selector for the file to load, and the template to use will be determined by the extension (Windows) or by popping up a template choice list (other platforms).

If the maximum number of documents has been reached, this function will delete the oldest currently loaded document before creating a new one.

wxPython version supports the document manager's wx.lib.docview.DOC_OPEN_ONCE flag.

CreateView(self, document, flags=0)

Creates a new view for the given document. If more than one view is allowed for the document (by virtue of multiple templates mentioning the same document type), a choice of view is presented to the user.

DeleteTemplate(self, template, flags)

Placeholder, not yet implemented in wxWindows.

Destroy(self)

Destructor.

Overrides:
wx.Object.Destroy

DisassociateTemplate(self, docTemplate)

Removes the template from the list of templates.

FileHistoryAddFilesToMenu(self, menu=None)

Appends the files in the history list, to all menus managed by the file history object.

If menu is specified, appends the files in the history list to the given menu only.

FileHistoryLoad(self, config)

Loads the file history from a config object.

FileHistoryRemoveMenu(self, menu)

Removes the given menu from the list of menus managed by the file history object.

FileHistorySave(self, config)

Saves the file history into a config object. This must be called explicitly by the application.

FileHistoryUseMenu(self, menu)

Use this menu for appending recently-visited document filenames, for convenient access. Calling this function with a valid menu enables the history list functionality.

Note that you can add multiple menus using this function, to be managed by the file history object.

FindSuitableParent(self)

Returns a parent frame or dialog, either the frame with the current focus or if there is no current focus the application's top frame.

FindTemplateForPath(self, path)

Given a path, try to find template that matches the extension. This is only an approximate method of finding a template for creating a document.

FlushDoc(self, doc)

Placeholder, not yet implemented in wxWindows.

GetCurrentDocument(self)

Returns the document associated with the currently active view (if any).

GetCurrentView(self)

Returns the currently active view.

GetDocuments(self)

Returns the list of documents.

GetFileHistory(self)

Returns the file history.

GetFlags(self)

Returns the document manager's flags. This method has been added to wxPython and is not in wxWindows.

GetHistoryFile(self, i)

Returns the file at index i from the file history.

GetHistoryFilesCount(self)

Returns the number of files currently stored in the file history.

GetLastActiveView(self)

Returns the last active view. This is used in the SDI framework where dialogs can be mistaken for a view and causes the framework to deactivete the current view. This happens when something like a custom dialog box used to operate on the current view is shown.

GetMaxDocsOpen(self)

Returns the number of documents that can be open simultaneously.

GetTemplates(self)

Returns the document manager's template list. This method has been added to wxPython and is not in wxWindows.

Initialize(self)

Initializes data; currently just calls OnCreateFileHistory. Some data cannot always be initialized in the constructor because the programmer must be given the opportunity to override functionality. In fact Initialize is called from the wxDocManager constructor, but this can be vetoed by passing false to the second argument, allowing the derived class's constructor to call Initialize, possibly calling a different OnCreateFileHistory from the default.

The bottom line: if you're not deriving from Initialize, forget it and construct wxDocManager with no arguments.

MakeDefaultName(self)

Returns a suitable default name. This is implemented by appending an integer counter to the string "Untitled" and incrementing the counter.

MakeFrameTitle(self)

Returns a suitable title for a document frame. This is implemented by appending the document name to the application name.

MatchTemplate(self, path)

Placeholder, not yet implemented in wxWindows.

OnCreateFileHistory(self)

A hook to allow a derived class to create a different type of file history. Called from Initialize.

OnFileClose(self, event)

Closes and deletes the currently active document.

OnFileCloseAll(self, event)

Closes and deletes all the currently opened documents.

OnFileNew(self, event)

Creates a new document and reads in the selected file.

OnFileOpen(self, event)

Creates a new document and reads in the selected file.

OnFileRevert(self, event)

Reverts the current document by calling wxDocument.Save for the current document.

OnFileSave(self, event)

Saves the current document by calling wxDocument.Save for the current document.

OnFileSaveAs(self, event)

Calls wxDocument.SaveAs for the current document.

OnOpenFileFailure(self)

Called when there is an error opening a file.

OnPreview(self, event)

Previews the current document by calling its View's OnCreatePrintout method.

OnPrint(self, event)

Prints the current document by calling its View's OnCreatePrintout method.

OnPrintSetup(self, event)

Presents the print setup dialog.

OnRedo(self, event)

Issues a Redo command to the current document's command processor.

OnUndo(self, event)

Issues an Undo command to the current document's command processor.

OnUpdateFileClose(self, event)

Updates the user interface for the File Close command.

OnUpdateFileCloseAll(self, event)

Updates the user interface for the File Close All command.

OnUpdateFileNew(self, event)

Updates the user interface for the File New command.

OnUpdateFileOpen(self, event)

Updates the user interface for the File Open command.

OnUpdateFileRevert(self, event)

Updates the user interface for the File Revert command.

OnUpdateFileSave(self, event)

Updates the user interface for the File Save command.

OnUpdateFileSaveAs(self, event)

Updates the user interface for the File Save As command.

OnUpdatePreview(self, event)

Updates the user interface for the Print Preview command.

OnUpdatePrint(self, event)

Updates the user interface for the Print command.

OnUpdatePrintSetup(self, event)

Updates the user interface for the Print Setup command.

OnUpdateRedo(self, event)

Updates the user interface for the Redo command.

OnUpdateUndo(self, event)

Updates the user interface for the Undo command.

ProcessEvent(self, event)

Processes an event, searching event tables and calling zero or more suitable event handler function(s). Note that the ProcessEvent method is called from the wxPython docview framework directly since wxPython does not have a virtual ProcessEvent function.

Overrides:
wx.EvtHandler.ProcessEvent

ProcessUpdateUIEvent(self, event)

Processes a UI event, searching event tables and calling zero or more suitable event handler function(s). Note that the ProcessEvent method is called from the wxPython docview framework directly since wxPython does not have a virtual ProcessEvent function.

RemoveDocument(self, doc)

Removes the document from the list of documents.

RemoveFileFromHistory(self, i)

Removes a file from the file history list, if we have a pointer to an appropriate file menu.

SelectDocumentPath(self, templates, flags, save)

Under Windows, pops up a file selector with a list of filters corresponding to document templates. The wxDocTemplate corresponding to the selected file's extension is returned.

On other platforms, if there is more than one document template a choice list is popped up, followed by a file selector.

This function is used in wxDocManager.CreateDocument.

SelectDocumentType(self, temps, sort=False)

Returns a document template by asking the user (if there is more than one template). This function is used in wxDocManager.CreateDocument.

Parameters

templates - list of templates from which to choose a desired template.

sort - If more than one template is passed in in templates, then this parameter indicates whether the list of templates that the user will have to choose from is sorted or not when shown the choice box dialog. Default is false.

SelectViewType(self, temps, sort=False)

Returns a document template by asking the user (if there is more than one template), displaying a list of valid views. This function is used in wxDocManager::CreateView. The dialog normally will not appear because the array of templates only contains those relevant to the document in question, and often there will only be one such.

SetMaxDocsOpen(self, maxDocsOpen)

Sets the maximum number of documents that can be open at a time. By default, this is 10,000. If you set it to 1, existing documents will be saved and deleted when the user tries to open or create a new one (similar to the behaviour of Windows Write, for example). Allowing multiple documents gives behaviour more akin to MS Word and other Multiple Document Interface applications.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:38 2005 http://epydoc.sf.net


wx.lib.docview.DocMDIChildFrame

Package wx :: Package lib :: Module docview :: Class DocMDIChildFrame
[frames | no frames]

Type DocMDIChildFrame

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
        TopLevelWindow --+
                         |
                     Frame --+
                             |
                 MDIChildFrame --+
                                 |
                                DocMDIChildFrame

The wxDocMDIChildFrame class provides a default frame for displaying documents on separate windows. This class can only be used for MDI child frames.

The class is part of the document/view framework supported by wxWindows, and cooperates with the wxView, wxDocument, wxDocManager and wxDocTemplate classes.

Method Summary
 | __init__(self, doc, view, frame, id, title, pos, size, style, name) Constructor.
 | Activate(self) Activates the current view.
 | GetDocument(self) Returns the document associated with this frame.
 | GetView(self) Returns the view associated with this frame.
 | OnActivate(self, event) Sets the currently active view to be the frame's view.
 | OnCloseWindow(self, event) Closes and deletes the current view and document.
 | ProcessEvent(event) Processes an event, searching event tables and calling zero or more suitable event handler function(s).
 | SetDocument(self, document) Sets the document for this frame.
 | SetView(self, view) Sets the view for this frame.

Instance Method Details

__init__(self, doc, view, frame, id, title, pos=wx.Point(-1, -1), size=wx.Size(-1, -1), style=541072960, name='frame')
(Constructor)

Constructor. Note that the event table must be rebuilt for the frame since the EvtHandler is not virtual.

Overrides:
wx.MDIChildFrame.__init__

Activate(self)

Activates the current view.

Overrides:
wx.MDIChildFrame.Activate

GetDocument(self)

Returns the document associated with this frame.

GetView(self)

Returns the view associated with this frame.

OnActivate(self, event)

Sets the currently active view to be the frame's view. You may need to override (but still call) this function in order to set the keyboard focus for your subwindow.

OnCloseWindow(self, event)

Closes and deletes the current view and document.

ProcessEvent(event)

Processes an event, searching event tables and calling zero or more suitable event handler function(s). Note that the ProcessEvent method is called from the wxPython docview framework directly since wxPython does not have a virtual ProcessEvent function.

Overrides:
wx.EvtHandler.ProcessEvent

SetDocument(self, document)

Sets the document for this frame.

SetView(self, view)

Sets the view for this frame.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:31 2005 http://epydoc.sf.net


wx.lib.docview.DocMDIParentFrame

Package wx :: Package lib :: Module docview :: Class DocMDIParentFrame
[frames | no frames]

Type DocMDIParentFrame

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
        TopLevelWindow --+
                         |
                     Frame --+
                             |
                MDIParentFrame --+
                                 |
                                DocMDIParentFrame

Known Subclasses:
DocMDIParentFrame

The wxDocMDIParentFrame class provides a default top-level frame for applications using the document/view framework. This class can only be used for MDI parent frames.

It cooperates with the wxView, wxDocument, wxDocManager and wxDocTemplate classes.

Method Summary
 | __init__(self, manager, frame, id, title, pos, size, style, name) Constructor.
 | OnCloseWindow(self, event) Deletes all views and documents.
 | OnExit(self, event) Called when File/Exit is chosen and closes the window.
 | OnMRUFile(self, event) Opens the appropriate file when it is selected from the file history menu.
 | ProcessEvent(self, event) Processes an event, searching event tables and calling zero or more suitable event handler function(s).
 | ProcessUpdateUIEvent(self, event) Processes a UI event, searching event tables and calling zero or more suitable event handler function(s).

Instance Method Details

__init__(self, manager, frame, id, title, pos=wx.Point(-1, -1), size=wx.Size(-1, -1), style=541072960, name='frame')
(Constructor)

Constructor. Note that the event table must be rebuilt for the frame since the EvtHandler is not virtual.

Overrides:
wx.MDIParentFrame.__init__

OnCloseWindow(self, event)

Deletes all views and documents. If no user input cancelled the operation, the frame will be destroyed and the application will exit.

OnExit(self, event)

Called when File/Exit is chosen and closes the window.

OnMRUFile(self, event)

Opens the appropriate file when it is selected from the file history menu.

ProcessEvent(self, event)

Processes an event, searching event tables and calling zero or more suitable event handler function(s). Note that the ProcessEvent method is called from the wxPython docview framework directly since wxPython does not have a virtual ProcessEvent function.

Overrides:
wx.EvtHandler.ProcessEvent

ProcessUpdateUIEvent(self, event)

Processes a UI event, searching event tables and calling zero or more suitable event handler function(s). Note that the ProcessEvent method is called from the wxPython docview framework directly since wxPython does not have a virtual ProcessEvent function.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:52 2005 http://epydoc.sf.net


wx.lib.docview.DocParentFrame

Package wx :: Package lib :: Module docview :: Class DocParentFrame
[frames | no frames]

Type DocParentFrame

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
        TopLevelWindow --+
                         |
                     Frame --+
                             |
                            DocParentFrame

The wxDocParentFrame class provides a default top-level frame for applications using the document/view framework. This class can only be used for SDI (not MDI) parent frames.

It cooperates with the wxView, wxDocument, wxDocManager and wxDocTemplates classes.

Method Summary
 | __init__(self, manager, frame, id, title, pos, size, style, name) Constructor.
 | OnCloseWindow(self, event) Deletes all views and documents.
 | OnExit(self, event) Called when File/Exit is chosen and closes the window.
 | OnMRUFile(self, event) Opens the appropriate file when it is selected from the file history menu.
 | ProcessEvent(self, event) Processes an event, searching event tables and calling zero or more suitable event handler function(s).
 | ProcessUpdateUIEvent(self, event) Processes a UI event, searching event tables and calling zero or more suitable event handler function(s).

Instance Method Details

__init__(self, manager, frame, id, title, pos=wx.Point(-1, -1), size=wx.Size(-1, -1), style=541072960, name='frame')
(Constructor)

Constructor. Note that the event table must be rebuilt for the frame since the EvtHandler is not virtual.

Overrides:
wx.Frame.__init__

OnCloseWindow(self, event)

Deletes all views and documents. If no user input cancelled the operation, the frame will be destroyed and the application will exit.

OnExit(self, event)

Called when File/Exit is chosen and closes the window.

OnMRUFile(self, event)

Opens the appropriate file when it is selected from the file history menu.

ProcessEvent(self, event)

Processes an event, searching event tables and calling zero or more suitable event handler function(s). Note that the ProcessEvent method is called from the wxPython docview framework directly since wxPython does not have a virtual ProcessEvent function.

Overrides:
wx.EvtHandler.ProcessEvent

ProcessUpdateUIEvent(self, event)

Processes a UI event, searching event tables and calling zero or more suitable event handler function(s). Note that the ProcessEvent method is called from the wxPython docview framework directly since wxPython does not have a virtual ProcessEvent function.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:33 2005 http://epydoc.sf.net


wx.lib.docview.DocPrintout

Package wx :: Package lib :: Module docview :: Class DocPrintout
[frames | no frames]

Type DocPrintout

object --+
         |
    Object --+
             |
      Printout --+
                 |
                DocPrintout

DocPrintout is a default Printout that prints the first page of a document view.

Method Summary
 | __init__(self, view, title) Constructor.
 | GetPageInfo(self) Indicates that the DocPrintout only has a single page.
 | GetView(self) Returns the DocPrintout's view.
 | HasPage(self, pageNum) Indicates that the DocPrintout only has a single page.
 | OnBeginDocument(self, startPage, endPage) Not quite sure why this was overridden, but it was in wxWindows! :)
 | OnPrintPage(self, page) Prints the first page of the view.

Method Details

__init__(self, view, title='Printout')
(Constructor)

Constructor.

Overrides:
wx.Printout.__init__

GetPageInfo(self)

Indicates that the DocPrintout only has a single page.

GetView(self)

Returns the DocPrintout's view.

HasPage(self, pageNum)

Indicates that the DocPrintout only has a single page.

OnBeginDocument(self, startPage, endPage)

Not quite sure why this was overridden, but it was in wxWindows! :)

OnPrintPage(self, page)

Prints the first page of the view.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:17 2005 http://epydoc.sf.net


wx.lib.docview.DocTemplate

Package wx :: Package lib :: Module docview :: Class DocTemplate
[frames | no frames]

Type DocTemplate

object --+
         |
    Object --+
             |
            DocTemplate

Known Subclasses:
ChildDocTemplate

The wxDocTemplate class is used to model the relationship between a document class and a view class.

Method Summary
 | __init__(self, manager, description, filter, dir, ext, docTypeName, viewTypeName, docType, viewType, flags, icon) Constructor.
 | CreateDocument(self, path, flags) Creates a new instance of the associated document class.
 | CreateView(self, doc, flags) Creates a new instance of the associated document view.
 | FileMatchesTemplate(self, path) Returns True if the path's extension matches one of this template's file filter extensions.
 | GetDefaultExtension(self) Returns the default file extension for the document data, as passed to the document template constructor.
 | GetDescription(self) Returns the text description of this template, as passed to the document template constructor.
 | GetDirectory(self) Returns the default directory, as passed to the document template constructor.
 | GetDocumentManager(self) Returns the document manager instance for which this template was created.
 | GetDocumentName(self) Returns the document type name, as passed to the document template constructor.
 | GetDocumentType(self) Returns the Python document class, as passed to the document template constructor.
 | GetFileFilter(self) Returns the file filter, as passed to the document template constructor.
 | GetFlags(self) Returns the flags, as passed to the document template constructor.
 | GetIcon(self) Returns the icon, as passed to the document template constructor.
 | GetViewName(self) Returns the view type name, as passed to the document template constructor.
 | GetViewType(self) Returns the Python view class, as passed to the document template constructor.
 | IsVisible(self) Returns true if the document template can be shown in user dialogs, false otherwise.
 | SetDefaultExtension(self, defaultExt) Sets the default file extension.
 | SetDescription(self, description) Sets the template description.
 | SetDirectory(self, dir) Sets the default directory.
 | SetDocumentManager(self, manager) Sets the document manager instance for which this template was created.
 | SetFileFilter(self, filter) Sets the file filter.
 | SetFlags(self, flags) Sets the internal document template flags (see the constructor description for more details).
 | SetIcon(self, flags) Sets the icon.

Method Details

__init__(self, manager, description, filter, dir, ext, docTypeName, viewTypeName, docType, viewType, flags=1, icon=None)
(Constructor)

Constructor. Create instances dynamically near the start of your application after creating a wxDocManager instance, and before doing any document or view operations.

manager is the document manager object which manages this template.

description is a short description of what the template is for. This string will be displayed in the file filter list of Windows file selectors.

filter is an appropriate file filter such as *.txt.

dir is the default directory to use for file selectors.

ext is the default file extension (such as txt).

docTypeName is a name that should be unique for a given type of document, used for gathering a list of views relevant to a particular document.

viewTypeName is a name that should be unique for a given view.

docClass is a Python class. If this is not supplied, you will need to derive a new wxDocTemplate class and override the CreateDocument member to return a new document instance on demand.

viewClass is a Python class. If this is not supplied, you will need to derive a new wxDocTemplate class and override the CreateView member to return a new view instance on demand.

flags is a bit list of the following: wx.TEMPLATE_VISIBLE The template may be displayed to the user in dialogs.

wx.TEMPLATE_INVISIBLE The template may not be displayed to the user in dialogs.

wx.DEFAULT_TEMPLATE_FLAGS Defined as wxTEMPLATE_VISIBLE.

Overrides:
wx.Object.__init__

CreateDocument(self, path, flags)

Creates a new instance of the associated document class. If you have not supplied a class to the template constructor, you will need to override this function to return an appropriate document instance.

CreateView(self, doc, flags)

Creates a new instance of the associated document view. If you have not supplied a class to the template constructor, you will need to override this function to return an appropriate view instance.

FileMatchesTemplate(self, path)

Returns True if the path's extension matches one of this template's file filter extensions.

GetDefaultExtension(self)

Returns the default file extension for the document data, as passed to the document template constructor.

GetDescription(self)

Returns the text description of this template, as passed to the document template constructor.

GetDirectory(self)

Returns the default directory, as passed to the document template constructor.

GetDocumentManager(self)

Returns the document manager instance for which this template was created.

GetDocumentName(self)

Returns the document type name, as passed to the document template constructor.

GetDocumentType(self)

Returns the Python document class, as passed to the document template constructor.

GetFileFilter(self)

Returns the file filter, as passed to the document template constructor.

GetFlags(self)

Returns the flags, as passed to the document template constructor. (see the constructor description for more details).

GetIcon(self)

Returns the icon, as passed to the document template constructor. This method has been added to wxPython and is not in wxWindows.

GetViewName(self)

Returns the view type name, as passed to the document template constructor.

GetViewType(self)

Returns the Python view class, as passed to the document template constructor.

IsVisible(self)

Returns true if the document template can be shown in user dialogs, false otherwise.

SetDefaultExtension(self, defaultExt)

Sets the default file extension.

SetDescription(self, description)

Sets the template description.

SetDirectory(self, dir)

Sets the default directory.

SetDocumentManager(self, manager)

Sets the document manager instance for which this template was created. Should not be called by the application.

SetFileFilter(self, filter)

Sets the file filter.

SetFlags(self, flags)

Sets the internal document template flags (see the constructor description for more details).

SetIcon(self, flags)

Sets the icon. This method has been added to wxPython and is not in wxWindows.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:19 2005 http://epydoc.sf.net


wx.lib.docview.Document

Package wx :: Package lib :: Module docview :: Class Document
[frames | no frames]

Type Document

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
                Document

Known Subclasses:
ChildDocument

The document class can be used to model an application's file-based data. It is part of the document/view framework supported by wxWindows, and cooperates with the wxView, wxDocTemplate and wxDocManager classes.

Note this wxPython version also keeps track of the modification date of the document and if it changes on disk outside of the application, we will warn the user before saving to avoid clobbering the file.

Method Summary
 | __init__(self, parent) Constructor.
 | AddView(self, view) If the view is not already in the list of views, adds the view and calls OnChangedViewList.
 | Close(self) Closes the document, by calling OnSaveModified and then (if this true) OnCloseDocument.
 | DeleteAllViews(self) Calls wxView.Close and deletes each view.
 | DeleteContents(self) Deletes the contents of the document.
 | Destroy(self) Destructor.
 | Draw(context) Called by printing framework to draw the view.
 | GetCommandProcessor(self) Returns the command processor associated with this document.
 | GetDocumentManager(self) Returns the associated document manager.
 | GetDocumentModificationDate(self) Returns the file's modification date when it was loaded from disk.
 | GetDocumentName(self) The document type name given to the wxDocTemplate constructor, copied to this document when the document is created.
 | GetDocumentSaved(self) Returns True if the document has been saved.
 | GetDocumentTemplate(self) Returns the template that created the document.
 | GetDocumentWindow(self) Intended to return a suitable window for using as a parent for document-related dialog boxes.
 | GetFilename(self) Gets the filename associated with this document, or "" if none is associated.
 | GetFirstView(self) A convenience function to get the first view for a document, because in many cases a document will only have a single view.
 | GetPrintableName(self) Copies a suitable document name into the supplied name buffer.
 | GetTitle(self) Gets the title for this document.
 | GetViews(self) Returns the list whose elements are the views on the document.
 | GetWriteable(self) Returns true if the document can be written to its accociated file path.
 | IsModified(self) Returns true if the document has been modified since the last save, false otherwise.
 | LoadObject(self, file) Override this function and call it from your own LoadObject before loading your own data.
 | Modify(self, modify) Call with true to mark the document as modified since the last save, false otherwise.
 | NotifyClosing(self) Notifies the views that the document is going to close.
 | OnChangedViewList(self) Called when a view is added to or deleted from this document.
 | OnCloseDocument(self) The default implementation calls DeleteContents (an empty implementation) sets the modified flag to false.
 | OnCreate(self, path, flags) The default implementation calls DeleteContents (an empty implementation) sets the modified flag to false.
 | OnCreateCommandProcessor(self) Override this function if you want a different (or no) command processor to be created when the document is created.
 | OnNewDocument(self) The default implementation calls OnSaveModified and DeleteContents, makes a default title for the document, and notifies the views that the filename (in fact, the title) has changed.
 | OnOpenDocument(self, filename) Constructs an input file for the given filename (which must not be empty), and calls LoadObject.
 | OnSaveDocument(self, filename) Constructs an output file for the given filename (which must not be empty), and calls SaveObject.
 | OnSaveModified(self) If the document has been modified, prompts the user to ask if the changes should be changed.
 | ProcessEvent(self, event) Processes an event, searching event tables and calling zero or more suitable event handler function(s).
 | RemoveView(self, view) Removes the view from the document's list of views, and calls OnChangedViewList.
 | Revert(self) Override this function to revert the document to its last saved state.
 | Save(self) Saves the document by calling OnSaveDocument if there is an associated filename, or SaveAs if there is no filename.
 | SaveAs(self) Prompts the user for a file to save to, and then calls OnSaveDocument.
 | SaveObject(self, file) Override this function and call it from your own SaveObject before saving your own data.
 | SetCommandProcessor(self, processor) Sets the command processor to be used for this document.
 | SetDocumentModificationDate(self) Saves the file's last modification date.
 | SetDocumentName(self, name) Sets he document type name given to the wxDocTemplate constructor, copied to this document when the document is created.
 | SetDocumentSaved(self, saved) Sets whether the document has been saved.
 | SetDocumentTemplate(self, template) Sets the template that created the document.
 | SetFilename(self, filename, notifyViews) Sets the filename for this document.
 | SetTitle(self, title) Sets the title for this document.
 | SetWriteable(self, writeable) Set to False if the document can not be saved.
 | UpdateAllViews(self, sender, hint) Updates all views.

Method Details

__init__(self, parent=None)
(Constructor)

Constructor. Define your own default constructor to initialize application-specific data.

Overrides:
wx.EvtHandler.__init__

AddView(self, view)

If the view is not already in the list of views, adds the view and calls OnChangedViewList.

Close(self)

Closes the document, by calling OnSaveModified and then (if this true) OnCloseDocument. This does not normally delete the document object: use DeleteAllViews to do this implicitly.

DeleteAllViews(self)

Calls wxView.Close and deletes each view. Deleting the final view will implicitly delete the document itself, because the wxView destructor calls RemoveView. This in turns calls wxDocument::OnChangedViewList, whose default implemention is to save and delete the document if no views exist.

DeleteContents(self)

Deletes the contents of the document. Override this method as necessary.

Destroy(self)

Destructor. Removes itself from the document manager.

Overrides:
wx.Object.Destroy

Draw(context)

Called by printing framework to draw the view.

GetCommandProcessor(self)

Returns the command processor associated with this document.

GetDocumentManager(self)

Returns the associated document manager.

GetDocumentModificationDate(self)

Returns the file's modification date when it was loaded from disk. This is used to check if the file has been modified outside of the application. This method has been added to wxPython and is not in wxWindows.

GetDocumentName(self)

The document type name given to the wxDocTemplate constructor, copied to this document when the document is created. If several document templates are created that use the same document type, this variable is used in wxDocManager::CreateView to collate a list of alternative view types that can be used on this kind of document.

GetDocumentSaved(self)

Returns True if the document has been saved. This method has been added to wxPython and is not in wxWindows.

GetDocumentTemplate(self)

Returns the template that created the document.

GetDocumentWindow(self)

Intended to return a suitable window for using as a parent for document-related dialog boxes. By default, uses the frame associated with the first view.

GetFilename(self)

Gets the filename associated with this document, or "" if none is associated.

GetFirstView(self)

A convenience function to get the first view for a document, because in many cases a document will only have a single view.

GetPrintableName(self)

Copies a suitable document name into the supplied name buffer. The default function uses the title, or if there is no title, uses the filename; or if no filename, the string 'Untitled'.

GetTitle(self)

Gets the title for this document. The document title is used for an associated frame (if any), and is usually constructed by the framework from the filename.

GetViews(self)

Returns the list whose elements are the views on the document.

GetWriteable(self)

Returns true if the document can be written to its accociated file path. This method has been added to wxPython and is not in wxWindows.

IsModified(self)

Returns true if the document has been modified since the last save, false otherwise. You may need to override this if your document view maintains its own record of being modified (for example if using wxTextWindow to view and edit the document).

LoadObject(self, file)

Override this function and call it from your own LoadObject before loading your own data. LoadObject is called by the framework automatically when the document contents need to be loaded.

Note that the wxPython version simply sends you a Python file object, so you can use pickle.

Modify(self, modify)

Call with true to mark the document as modified since the last save, false otherwise. You may need to override this if your document view maintains its own record of being modified (for example if using xTextWindow to view and edit the document).

NotifyClosing(self)

Notifies the views that the document is going to close.

OnChangedViewList(self)

Called when a view is added to or deleted from this document. The default implementation saves and deletes the document if no views exist (the last one has just been removed).

OnCloseDocument(self)

The default implementation calls DeleteContents (an empty implementation) sets the modified flag to false. Override this to supply additional behaviour when the document is closed with Close.

OnCreate(self, path, flags)

The default implementation calls DeleteContents (an empty implementation) sets the modified flag to false. Override this to supply additional behaviour when the document is closed with Close.

OnCreateCommandProcessor(self)

Override this function if you want a different (or no) command processor to be created when the document is created. By default, it returns an instance of wxCommandProcessor.

OnNewDocument(self)

The default implementation calls OnSaveModified and DeleteContents, makes a default title for the document, and notifies the views that the filename (in fact, the title) has changed.

OnOpenDocument(self, filename)

Constructs an input file for the given filename (which must not be empty), and calls LoadObject. If LoadObject returns true, the document is set to unmodified; otherwise, an error message box is displayed. The document's views are notified that the filename has changed, to give windows an opportunity to update their titles. All of the document's views are then updated.

OnSaveDocument(self, filename)

Constructs an output file for the given filename (which must not be empty), and calls SaveObject. If SaveObject returns true, the document is set to unmodified; otherwise, an error message box is displayed.

OnSaveModified(self)

If the document has been modified, prompts the user to ask if the changes should be changed. If the user replies Yes, the Save function is called. If No, the document is marked as unmodified and the function succeeds. If Cancel, the function fails.

ProcessEvent(self, event)

Processes an event, searching event tables and calling zero or more suitable event handler function(s). Note that the ProcessEvent method is called from the wxPython docview framework directly since wxPython does not have a virtual ProcessEvent function.

Overrides:
wx.EvtHandler.ProcessEvent

RemoveView(self, view)

Removes the view from the document's list of views, and calls OnChangedViewList.

Revert(self)

Override this function to revert the document to its last saved state.

Save(self)

Saves the document by calling OnSaveDocument if there is an associated filename, or SaveAs if there is no filename.

SaveAs(self)

Prompts the user for a file to save to, and then calls OnSaveDocument.

SaveObject(self, file)

Override this function and call it from your own SaveObject before saving your own data. SaveObject is called by the framework automatically when the document contents need to be saved.

Note that the wxPython version simply sends you a Python file object, so you can use pickle.

SetCommandProcessor(self, processor)

Sets the command processor to be used for this document. The document will then be responsible for its deletion. Normally you should not call this; override OnCreateCommandProcessor instead.

SetDocumentModificationDate(self)

Saves the file's last modification date. This is used to check if the file has been modified outside of the application. This method has been added to wxPython and is not in wxWindows.

SetDocumentName(self, name)

Sets he document type name given to the wxDocTemplate constructor, copied to this document when the document is created. If several document templates are created that use the same document type, this variable is used in wxDocManager::CreateView to collate a list of alternative view types that can be used on this kind of document. Do not change the value of this variable.

SetDocumentSaved(self, saved=True)

Sets whether the document has been saved. This method has been added to wxPython and is not in wxWindows.

SetDocumentTemplate(self, template)

Sets the template that created the document. Should only be called by the framework.

SetFilename(self, filename, notifyViews=False)

Sets the filename for this document. Usually called by the framework. If notifyViews is true, wxView.OnChangeFilename is called for all views.

SetTitle(self, title)

Sets the title for this document. The document title is used for an associated frame (if any), and is usually constructed by the framework from the filename.

SetWriteable(self, writeable)

Set to False if the document can not be saved. This will disable the ID_SAVE_AS event and is useful for custom documents that should not be saveable. The ID_SAVE event can be disabled by never Modifying the document. This method has been added to wxPython and is not in wxWindows.

UpdateAllViews(self, sender=None, hint=None)

Updates all views. If sender is non-NULL, does not update this view. hint represents optional information to allow a view to optimize its update.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:41 2005 http://epydoc.sf.net


wx.lib.docview.View

Package wx :: Package lib :: Module docview :: Class View

Type View

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
                View

The view class can be used to model the viewing and editing component of an application's file-based data. It is part of the document/view framework supported by wxWindows, and cooperates with the wxDocument, wxDocTemplate and wxDocManager classes.

Method Summary
__init__(self)
Constructor.
Activate(self, activate)
Call this from your view frame's OnActivate member to tell the framework which view is currently active.
Close(self, deleteWindow)
Closes the view by calling OnClose.
Destroy(self)
Destructor.
GetDocument(self)
Returns the document associated with the view.
GetDocumentManager(self)
Returns the document manager instance associated with this view.
GetFrame(self)
Gets the frame associated with the view (if any).
GetViewName(self)
Gets the name associated with the view (passed to the wxDocTemplate constructor).
OnActivateView(self, activate, activeView, deactiveView)
Called when a view is activated by means of wxView::Activate.
OnChangeFilename(self)
Called when the filename has changed.
OnClose(self, deleteWindow)
Implements closing behaviour.
OnClosingDocument(self)
Override this to clean up the view when the document is being closed.
OnCreate(self, doc, flags)
wxDocManager or wxDocument creates a wxView via a wxDocTemplate.
OnCreatePrintout(self)
Returns a wxPrintout object for the purposes of printing.
OnDraw(self, dc)
Override this to draw the view for the printing framework.
OnPrint(self, dc, info)
Override this to print the view for the printing framework.
OnUpdate(self, sender, hint)
Called when the view should be updated.
ProcessEvent(self, event)
Processes an event, searching event tables and calling zero or more suitable event handler function(s).
ProcessUpdateUIEvent(self, event)
Processes a UI event, searching event tables and calling zero or more suitable event handler function(s).
SetDocument(self, doc)
Associates the given document with the view.
SetFrame(self, frame)
Sets the frame associated with this view.
SetViewName(self, name)
Sets the view type name.

Method Details

__init__(self)
(Constructor)

Constructor. Define your own default constructor to initialize application-specific data.

Overrides:
wx.EvtHandler.__init__

Activate(self, activate=True)

Call this from your view frame's OnActivate member to tell the framework which view is currently active. If your windowing system doesn't call OnActivate, you may need to call this function from OnMenuCommand or any place where you know the view must be active, and the framework will need to get the current view.

The prepackaged view frame wxDocChildFrame calls wxView.Activate from its OnActivate member and from its OnMenuCommand member.

Close(self, deleteWindow=True)

Closes the view by calling OnClose. If deleteWindow is true, this function should delete the window associated with the view.

Destroy(self)

Destructor. Removes itself from the document's list of views.

Overrides:
wx.Object.Destroy

GetDocument(self)

Returns the document associated with the view.

GetDocumentManager(self)

Returns the document manager instance associated with this view.

GetFrame(self)

Gets the frame associated with the view (if any). Note that this "frame" is not a wxFrame at all in the generic MDI implementation which uses the notebook pages instead of the frames and this is why this method returns a wxWindow and not a wxFrame.

GetViewName(self)

Gets the name associated with the view (passed to the wxDocTemplate constructor). Not currently used by the framework.

OnActivateView(self, activate, activeView, deactiveView)

Called when a view is activated by means of wxView::Activate. The default implementation does nothing.

OnChangeFilename(self)

Called when the filename has changed. The default implementation constructs a suitable title and sets the title of the view frame (if any).

OnClose(self, deleteWindow=True)

Implements closing behaviour. The default implementation calls wxDocument.Close to close the associated document. Does not delete the view. The application may wish to do some cleaning up operations in this function, if a call to wxDocument::Close succeeded. For example, if your application's all share the same window, you need to disassociate the window from the view and perhaps clear the window. If deleteWindow is true, delete the frame associated with the view.

OnClosingDocument(self)

Override this to clean up the view when the document is being closed. The default implementation does nothing.

OnCreate(self, doc, flags)

wxDocManager or wxDocument creates a wxView via a wxDocTemplate. Just after the wxDocTemplate creates the wxView, it calls wxView::OnCreate. In its OnCreate member function, the wxView can create a wxDocChildFrame or a derived class. This wxDocChildFrame provides user interface elements to view and/or edit the contents of the wxDocument.

By default, simply returns true. If the function returns false, the view will be deleted.

OnCreatePrintout(self)

Returns a wxPrintout object for the purposes of printing. It should create a new object every time it is called; the framework will delete objects it creates.

By default, this function returns an instance of wxDocPrintout, which prints and previews one page by calling wxView.OnDraw.

Override to return an instance of a class other than wxDocPrintout.

OnDraw(self, dc)

Override this to draw the view for the printing framework. The default implementation does nothing.

OnPrint(self, dc, info)

Override this to print the view for the printing framework. The default implementation calls View.OnDraw.

OnUpdate(self, sender, hint)

Called when the view should be updated. sender is a pointer to the view that sent the update request, or NULL if no single view requested the update (for instance, when the document is opened). hint is as yet unused but may in future contain application-specific information for making updating more efficient.

ProcessEvent(self, event)

Processes an event, searching event tables and calling zero or more suitable event handler function(s). Note that the ProcessEvent method is called from the wxPython docview framework directly since wxPython does not have a virtual ProcessEvent function.

Overrides:
wx.EvtHandler.ProcessEvent

ProcessUpdateUIEvent(self, event)

Processes a UI event, searching event tables and calling zero or more suitable event handler function(s). Note that the ProcessEvent method is called from the wxPython docview framework directly since wxPython does not have a virtual ProcessEvent function.

SetDocument(self, doc)

Associates the given document with the view. Normally called by the framework.

SetFrame(self, frame)

Sets the frame associated with this view. The application should call this if possible, to tell the view about the frame. See GetFrame for the explanation about the mismatch between the "Frame" in the method name and the type of its parameter.

SetViewName(self, name)

Sets the view type name. Should only be called by the framework.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:04 2005 http://epydoc.sf.net


wx.lib.docview

Package wx :: Package lib :: Module docview

Module wx.lib.docview

Classes
Command | wxCommand is a base class for modelling an application command, which is an action usually performed by selecting a menu item, pressing a toolbar button or any other means provided by the application to change the data or view.
CommandProcessor | wxCommandProcessor is a class that maintains a history of wxCommands, with undo/redo functionality built-in.
DocChildFrame | The wxDocChildFrame class provides a default frame for displaying documents on separate windows.
DocManager | The wxDocManager class is part of the document/view framework supported by wxWindows, and cooperates with the wxView, wxDocument and wxDocTemplate classes.
DocMDIChildFrame | The wxDocMDIChildFrame class provides a default frame for displaying documents on separate windows.
DocMDIParentFrame | The wxDocMDIParentFrame class provides a default top-level frame for applications using the document/view framework.
DocParentFrame | The wxDocParentFrame class provides a default top-level frame for applications using the document/view framework.
DocPrintout | DocPrintout is a default Printout that prints the first page of a document view.
DocTemplate | The wxDocTemplate class is used to model the relationship between a document class and a view class.
Document | The document class can be used to model an application's file-based data.
View | The view class can be used to model the viewing and editing component of an application's file-based data.

Function Summary
 | FileExists(path) Returns True if the path exists.
 | FileNameFromPath(path) Returns the filename for a full path.
 | FindExtension(path) Returns the extension of a filename for a full path.
 | PathOnly(path) Returns the path of a full path without the filename.

Variable Summary
int | DEFAULT_DOCMAN_FLAGS = 0
int | DEFAULT_TEMPLATE_FLAGS = 1
int | DOC_MDI = 2
int | DOC_NEW = 4
int | DOC_OPEN_ONCE = 16
int | DOC_SDI = 1
int | DOC_SILENT = 8
int | MAX_FILE_HISTORY = 9
int | TEMPLATE_INVISIBLE = 2
int | TEMPLATE_VISIBLE = 1

Function Details

FileExists(path)

Returns True if the path exists.

FileNameFromPath(path)

Returns the filename for a full path.

FindExtension(path)

Returns the extension of a filename for a full path.

PathOnly(path)

Returns the path of a full path without the filename.

Variable Details

DEFAULT_DOCMAN_FLAGS

Type:
int
Value:
0

DEFAULT_TEMPLATE_FLAGS

Type:
int
Value:
1

DOC_MDI

Type:
int
Value:
2

DOC_NEW

Type:
int
Value:
4

DOC_OPEN_ONCE

Type:
int
Value:
16

DOC_SDI

Type:
int
Value:
1

DOC_SILENT

Type:
int
Value:
8

MAX_FILE_HISTORY

Type:
int
Value:
9

TEMPLATE_INVISIBLE

Type:
int
Value:
2

TEMPLATE_VISIBLE

Type:
int
Value:
1

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:40 2005 http://epydoc.sf.net


wx.lib.editor.editor.Editor

Package wx :: Package lib :: Package editor :: Module editor :: Class Editor
[frames | no frames]

Type Editor

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
                 Panel --+
                         |
            ScrolledWindow --+
                             |
                            Editor

Method Summary
 | __init__(self, parent, id, pos, size, style)
 | AboveScreen(self, row)
 | AdjustScrollbars(self)
 | AltKey(self, event, key)
 | BackSpace(self, event)
 | BelowScreen(self, row)
 | BreakLine(self, event)
 | BufferWasTouched(self)
 | CalcMaxLineLen(self) get length of longest line on screen
 | CanScroll(self)
 | cHoriz(self, num)
 | ControlKey(self, event, key)
 | CopySelection(self, event)
 | CopyToClipboard(self, linesOfText)
 | CurrentLineLength(self)
 | cVert(self, num)
 | Delete(self, event)
 | DeleteChar(self, x, y, oldtext)
 | Dispatch(self, keySettingFunction, key, event)
 | Draw(self, odc)
 | DrawCursor(self, dc)
 | DrawEditText(self, t, x, y, dc)
 | DrawEofMarker(self, dc)
 | DrawLine(self, line, dc)
 | DrawSimpleCursor(self, xp, yp, dc, old)
 | Escape(self, event)
 | FindSelection(self)
 | GetText(self)
 | GetTextLine(self, lineNum)
 | HandleAboveScreen(self, row)
 | HandleBelowScreen(self, row)
 | HandleLeftOfScreen(self, col)
 | HandleRightOfScreen(self, col)
 | HorizBoundaries(self)
 | HorizScroll(self, event, eventType)
 | InitCoords(self)
 | InitDoubleBuffering(self)
 | InitFonts(self)
 | InitScrolling(self)
 | InsertChar(self, char)
 | IsLine(self, lineNum)
 | JoinLines(self)
 | KeepCursorOnScreen(self)
 | LeftOfScreen(self, col)
 | LinesInFile(self)
 | LoadImages(self)
 | MapEvents(self)
 | ModifierKey(self, key, event, modifierKeyDown, MappingFunc)
 | MouseToCol(self, mouseX)
 | MouseToCursor(self, event)
 | MouseToRow(self, mouseY)
 | Move(self, keySettingFunction, key, event)
 | MoveDown(self, event)
 | MoveEnd(self, event)
 | MoveEndOfFile(self, event)
 | MoveHome(self, event)
 | MoveLeft(self, event)
 | MovePageDown(self, event)
 | MovePageUp(self, event)
 | MoveRight(self, event)
 | MoveSpecialControlKey(self, event, key)
 | MoveSpecialKey(self, event, key)
 | MoveStartOfFile(self, event)
 | MoveUp(self, event)
 | MultipleLineCopy(self, bRow, bCol, eRow, eCol)
 | MultipleLineDelete(self, bRow, bCol, eRow, eCol)
 | MultipleLinePaste(self, pastedLines)
 | NiceFontForPlatform(self)
 | NormalChar(self, event, key)
 | NormalizedSelect(self)
 | OnChar(self, event)
 | OnClick(self)
 | OnCopySelection(self, event)
 | OnCutSelection(self, event)
 | OnDeleteSelection(self, event)
 | OnDestroy(self, event)
 | OnEraseBackground(self, evt)
 | OnLeftDown(self, event)
 | OnLeftUp(self, event)
 | OnMotion(self, event)
 | OnPaint(self, event)
 | OnPaste(self, event)
 | OnScroll(self, event)
 | OnSize(self, event)
 | OnTimer(self, event)
 | RightOfScreen(self, col)
 | SelectNotify(self, Selecting, SelectionBegin, SelectionEnd)
 | SelectOff(self)
 | SelectUpdate(self)
 | SetAltFuncs(self, action)
 | SetCharDimensions(self)
 | SetColors(self)
 | SetControlFuncs(self, action)
 | SetMoveSpecialControlFuncs(self, action)
 | SetMoveSpecialFuncs(self, action)
 | SetScrollTimer(self)
 | SetShiftFuncs(self, action)
 | SetSpecialControlFuncs(self, action)
 | SetSpecialFuncs(self, action)
 | SetText(self, lines)
 | SetTextLine(self, lineNum, text)
 | ShiftKey(self, event, key)
 | SingleLineCopy(self, Row, bCol, eCol)
 | SingleLineDelete(self, Row, bCol, eCol)
 | SingleLineInsert(self, newText)
 | SpecialControlKey(self, event, key)
 | TabKey(self, event)
 | TouchBuffer(self)
 | UnixKeyHack(self, key)
 | UnTouchBuffer(self)
 | UpdateView(self, dc)
 | VertBoundaries(self)
 | VertScroll(self, event, eventType)

Instance Method Details

CalcMaxLineLen(self)

get length of longest line on screen

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:46 2005 http://epydoc.sf.net


wx.lib.editor.editor.Scroller

Package wx :: Package lib :: Package editor :: Module editor :: Class Scroller
[frames | no frames]

Class Scroller

Method Summary
 | __init__(self, parent)
 | SetScrollbars(self, fw, fh, w, h, x, y)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:12 2005 http://epydoc.sf.net


wx.lib.editor.editor

Package wx :: Package lib :: Package editor :: Module editor

Module wx.lib.editor.editor

Classes
Editor
Scroller

Function Summary
 | ForceBetween(min, val, max)
 | LineSplitter(text)
 | LineTrimmer(lineOfText)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:39 2005 http://epydoc.sf.net


wx.lib.editor.images

Package wx :: Package lib :: Package editor :: Module images

Module wx.lib.editor.images

Function Summary
 | GetBitmap(ImageData)
 | GetImage(ImageData)

Variable Summary
str EofImageData = '\x89PNG\r\n\x1a\n\x00\x00\x00\rIHDR\x00\...

Variable Details

EofImageData

Type:
str
Value:
'''\x89PNG\r
\x1a
\x00\x00\x00\rIHDR\x00\x00\x00\x07\x00\x00\x00\x07\x08\x06\x00\x00\x00\
\xc4RW\xd3\x00\x00\x00\x04sBIT\x08\x08\x08\x08|\x08d\x88\x00\x00\x00:I\
DATx\x9c]\x8e\xc1\r\x000\x08\x02\xc5\tn\xff)\xdd\xa0}\xd1`\xf9(\x9c\t
(kf\x0e \xfbN\x90\xf3\xc1\x0c\xd2\xab\xaa\x16Huv\xa4\x00\xb5\x97\x1f\x\
ac\x87\x1c\xe4\xe1\x05`2\x15\x9e\xc54\xca\xb4\x00\x00\x00\x00IEND\xaeB\
`\x82'''

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:11 2005 http://epydoc.sf.net


wx.lib.editor.selection

Package wx :: Package lib :: Package editor :: Module selection
[frames | no frames]

Module wx.lib.editor.selection

Function Summary
 | RestOfLine(sx, width, data, bool)
 | Selection(SelectBegin, SelectEnd, sx, width, line, data)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:39 2005 http://epydoc.sf.net


wx.lib.editor

Package wx :: Package lib :: Package editor

Package wx.lib.editor

Submodules
  • editor
  • images
  • selection

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:40 2005 http://epydoc.sf.net


wx.lib.evtmgr.EventAdapter

Package wx :: Package lib :: Module evtmgr :: Class EventAdapter
[frames | no frames]

Class EventAdapter

A class that adapts incoming wxWindows events to Publish/Subscribe messages.

In other words, this is the object that's seen by the wxWindows system. Only one of these registers for any particular wxWindows event. It then relays it into the PS system, which lets many listeners respond.

Method Summary
 | __init__(self, func, win, id) Instantiate a new adapter.
 | Destroy(self)
 | disconnect(self)
 | handleEvent(self, event) In response to a wxWindows event, send a PS message

Method Details

__init__(self, func, win, id)
(Constructor)

Instantiate a new adapter. Pre-compute my Publish/Subscribe topic, which is constant, and register with wxWindows.

handleEvent(self, event)

In response to a wxWindows event, send a PS message

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:10:48 2005 http://epydoc.sf.net


wx.lib.evtmgr.EventMacroInfo

Package wx :: Package lib :: Module evtmgr :: Class EventMacroInfo
[frames | no frames]

Class EventMacroInfo

A class that provides information about event macros.

Method Summary
 | __init__(self)
 | eventIsA(self, event, macroList) Return True if the event is one of the given macros.
 | getEventTypes(self, eventMacro) Return the list of event types that the given macro corresponds to.
 | isMultiEvent(self, macro) Return True if the given macro actually causes multiple events to be registered.
 | macroIsA(self, macro, macroList) Return True if the macro is in the macroList.

Method Details

eventIsA(self, event, macroList)

Return True if the event is one of the given macros.

getEventTypes(self, eventMacro)

Return the list of event types that the given macro corresponds to.

isMultiEvent(self, macro)

Return True if the given macro actually causes multiple events to be registered.

macroIsA(self, macro, macroList)

Return True if the macro is in the macroList. The added value of this method is that it takes multi-events into account. The macroList parameter will be coerced into a sequence if needed.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:10:48 2005 http://epydoc.sf.net


wx.lib.evtmgr.EventManager

Package wx :: Package lib :: Module evtmgr :: Class EventManager
[frames | no frames]

Class EventManager

This is the main class in the module, and is the only class that the application programmer needs to use. There is a pre-created instance of this class called 'eventManager'. It should not be necessary to create other instances.

Method Summary
 | __init__(self)
 | Bind(self, listener, event, source, win, id) Registers a listener function (or any callable object) to receive events of type event coming from the source window.
 | DeregisterDeadTopics(self) Deregister any entries relating to dead wxPython objects.
 | DeregisterListener(self, listener) Deregister all event notifications for the given listener.
 | DeregisterWindow(self, win) Deregister all events coming from the given window.
 | GetDeadTopics(self) Return a list of topics relating to dead wxPython objects.
 | GetStats(self) Return a dictionary with data about my state.
 | Register(self, listener, event, source, win, id) Registers a listener function (or any callable object) to receive events of type event coming from the source window.
 | Subscribe(self, listener, event, source, win, id) Registers a listener function (or any callable object) to receive events of type event coming from the source window.

Method Details

Bind(self, listener, event, source=None, win=None, id=None)

Registers a listener function (or any callable object) to receive events of type event coming from the source window. For example:

eventManager.Register(self.OnButton, EVT_BUTTON, theButton)

Alternatively, the specific window where the event is delivered, and/or the ID of the event source can be specified. For example:

eventManager.Register(self.OnButton, EVT_BUTTON, win=self, id=ID_BUTTON)

or:

eventManager.Register(self.OnButton, EVT_BUTTON, theButton, self)

DeregisterDeadTopics(self)

Deregister any entries relating to dead wxPython objects. Not sure if this is an important issue; 1) My app code always de-registers listeners it doesn't need. 2) I don't think that lingering references to these dead objects is a problem.

DeregisterListener(self, listener)

Deregister all event notifications for the given listener.

DeregisterWindow(self, win)

Deregister all events coming from the given window.

GetDeadTopics(self)

Return a list of topics relating to dead wxPython objects.

GetStats(self)

Return a dictionary with data about my state.

Register(self, listener, event, source=None, win=None, id=None)

Registers a listener function (or any callable object) to receive events of type event coming from the source window. For example:

eventManager.Register(self.OnButton, EVT_BUTTON, theButton)

Alternatively, the specific window where the event is delivered, and/or the ID of the event source can be specified. For example:

eventManager.Register(self.OnButton, EVT_BUTTON, win=self, id=ID_BUTTON)

or:

eventManager.Register(self.OnButton, EVT_BUTTON, theButton, self)

Subscribe(self, listener, event, source=None, win=None, id=None)

Registers a listener function (or any callable object) to receive events of type event coming from the source window. For example:

eventManager.Register(self.OnButton, EVT_BUTTON, theButton)

Alternatively, the specific window where the event is delivered, and/or the ID of the event source can be specified. For example:

eventManager.Register(self.OnButton, EVT_BUTTON, win=self, id=ID_BUTTON)

or:

eventManager.Register(self.OnButton, EVT_BUTTON, theButton, self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:03 2005 http://epydoc.sf.net


wx.lib.evtmgr.FakeWindow

Package wx :: Package lib :: Module evtmgr :: Class FakeWindow
[frames | no frames]

Class FakeWindow

Used internally by the EventMacroInfo class. The FakeWindow is the most important component of the macro-info utility: it implements the Connect() protocol of wxWindow, but instead of registering for events, it keeps track of what parameters were passed to it.

Method Summary
 | __init__(self)
 | Connect(self, id1, id2, eventType, handlerFunction)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:10:48 2005 http://epydoc.sf.net


wx.lib.evtmgr.MessageAdapter

Package wx :: Package lib :: Module evtmgr :: Class MessageAdapter
[frames | no frames]

Class MessageAdapter

A class that adapts incoming Publish/Subscribe messages to wxWindows event calls.

This class works opposite the EventAdapter, and retrieves the information an EventAdapter has sent in a message. Strictly speaking, this class is not required: Event listeners could pull the original wxEvent object out of the PS Message themselves.

However, by pairing an instance of this class with each wxEvent handler, the handlers can use the standard API: they receive an event as a parameter.

Method Summary
 | __init__(self, eventHandler, topicPattern) Instantiate a new MessageAdapter that send wxEvents to the given eventHandler.
 | deliverEvent(self, message)
 | Destroy(self)

Method Details

__init__(self, eventHandler, topicPattern)
(Constructor)

Instantiate a new MessageAdapter that send wxEvents to the given eventHandler.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:01 2005 http://epydoc.sf.net


wx.lib.evtmgr

Package wx :: Package lib :: Module evtmgr

Module wx.lib.evtmgr

A module that allows multiple handlers to respond to single wxWidgets events. This allows true NxN Observer/Observable connections: One event can be received by multiple handlers, and one handler can receive multiple events.

There are two ways to register event handlers. The first way is similar to standard wxPython handler registration:

from wx.lib.evtmgr import eventManager
eventManager.Register(handleEvents, EVT_BUTTON, win=frame, id=101)

There's also a new object-oriented way to register for events. This invocation is equivalent to the one above, but does not require the programmer to declare or track control ids or parent containers:

eventManager.Register(handleEvents, EVT_BUTTON, myButton)

This module is Python 2.1+ compatible.

Classes
EventAdapter | A class that adapts incoming wxWindows events to Publish/Subscribe messages.
EventMacroInfo | A class that provides information about event macros.
EventManager | This is the main class in the module, and is the only class that the application programmer needs to use.
FakeWindow | Used internally by the EventMacroInfo class.
MessageAdapter | A class that adapts incoming Publish/Subscribe messages to wxWindows event calls.

Variable Summary
EventManager eventManager = <wx.lib.evtmgr.EventManager instance at 0...

Variable Details

eventManager

Type:
EventManager
Value:
<wx.lib.evtmgr.EventManager instance at 0xb7a406ec>

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:06 2005 http://epydoc.sf.net


wx.lib.fancytext.StaticFancyText

Package wx :: Package lib :: Module fancytext :: Class StaticFancyText
[frames | no frames]

Type StaticFancyText

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
               Control --+
                         |
              StaticBitmap --+
                             |
                            StaticFancyText

Method Summary
__init__(self, window, id, text, *args, **kargs)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:11 2005 http://epydoc.sf.net


wx.lib.fancytext

Package wx :: Package lib :: Module fancytext

Module wx.lib.fancytext

FancyText -- methods for rendering XML specified text

This module exports four main methods:

def GetExtent(str, dc=None, enclose=True)
def GetFullExtent(str, dc=None, enclose=True)
def RenderToBitmap(str, background=None, enclose=True)
def RenderToDC(str, dc, x, y, enclose=True)

In all cases, 'str' is an XML string. Note that start and end tags are only required if enclose is set to False. In this case the text should be wrapped in FancyText tags.

In addition, the module exports one class:

class StaticFancyText(self, window, id, text, background, ...)

This class works similar to StaticText except it interprets its text as FancyText.

The text can support superscripts and subscripts, text in different sizes, colors, styles, weights and families. It also supports a limited set of symbols, currently times, infinity, angle as well as greek letters in both upper case (Alpha Beta... Omega) and lower case (alpha beta... omega).

>>> frame = wx.Frame(wx.NULL, -1, "FancyText demo", wx.DefaultPosition)
>>> sft = StaticFancyText(frame, -1, testText, wx.Brush("light grey", wx.SOLID))
>>> frame.SetClientSize(sft.GetSize())
>>> didit = frame.Show()
>>> from guitest import PauseTests; PauseTests()
Classes
StaticFancyText

Function Summary
 | getExtent(str, dc, enclose) Return the extent of str
 | GetExtent(str, dc, enclose) Return the extent of str
 | GetFullExtent(str, dc, enclose)
 | renderToBitmap(str, background, enclose) Return str rendered on a minumum size bitmap
 | RenderToBitmap(str, background, enclose) Return str rendered on a minumum size bitmap
 | RenderToDC(str, dc, x, y, enclose) Render str onto a wxDC at (x,y)
 | renderToDC(str, dc, x, y, enclose) Render str onto a wxDC at (x,y)

Function Details

getExtent(str, dc=None, enclose=True)

Return the extent of str

GetExtent(str, dc=None, enclose=True)

Return the extent of str

renderToBitmap(str, background=None, enclose=1)

Return str rendered on a minumum size bitmap

RenderToBitmap(str, background=None, enclose=1)

Return str rendered on a minumum size bitmap

RenderToDC(str, dc, x, y, enclose=1)

Render str onto a wxDC at (x,y)

renderToDC(str, dc, x, y, enclose=1)

Render str onto a wxDC at (x,y)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:07 2005 http://epydoc.sf.net


wx.lib.filebrowsebutton.DirBrowseButton

Package wx :: Package lib :: Module filebrowsebutton :: Class DirBrowseButton
[frames | no frames]

Type DirBrowseButton

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
                 Panel --+
                         |
          FileBrowseButton --+
                             |
                            DirBrowseButton

Method Summary
 | __init__(self, parent, id, pos, size, style, labelText, buttonText, toolTip, dialogTitle, startDirectory, changeCallback, dialogClass, newDirectory)
 | OnBrowse(self, ev)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:17 2005 http://epydoc.sf.net


wx.lib.filebrowsebutton.FileBrowseButton

Package wx :: Package lib :: Module filebrowsebutton :: Class FileBrowseButton
[frames | no frames]

Type FileBrowseButton

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
                 Panel --+
                         |
                        FileBrowseButton

Known Subclasses:
DirBrowseButton, FileBrowseButtonWithHistory

A control to allow the user to type in a filename or browse with the standard file dialog to select file

Method Summary
 | __init__(self, parent, id, pos, size, style, labelText, buttonText, toolTip, dialogTitle, startDirectory, initialValue, fileMask, fileMode, changeCallback)
 | createBrowseButton(self) Create the browse-button control
 | createDialog(self, parent, id, pos, size, style) Setup the graphic representation of the dialog
 | createLabel(self) Create the label/caption
 | createTextControl(self) Create the text control
 | Enable(self, value) Convenient enabling/disabling of entire control
 | GetLabel(self) Retrieve the label's current text
 | GetValue(self) retrieve current value of text control
 | OnBrowse(self, event) Going to browse for file...
 | OnChanged(self, evt)
 | SetBackgroundColour(self, color)
 | SetLabel(self, value) Set the label's current text
 | SetValue(self, value, callBack) set current value of text control

Instance Method Details

__init__(self,
          parent,
          id=-1,
          pos=wx.Point(-1, -1),
          size=wx.Size(-1, -1),
          style=524288,
          labelText='File Entry:',
          buttonText='Browse',
          toolTip='Type filename or click browse to choose file',
          dialogTitle='Choose a file',
          startDirectory='.',
          initialValue='',
          fileMask='*.*',
          fileMode=1,
          changeCallback=<function <lambda> at 0xb7a56aac>)
(Constructor)

Parameters:
labelText - Text for label to left of text field

buttonText - Text for button which launches the file dialog

toolTip - Help text

dialogTitle - Title used in file dialog

startDirectory - Default directory for file dialog startup

fileMask - File mask (glob pattern, such as .) to use in file dialog

fileMode - wx.OPEN or wx.SAVE, indicates type of file dialog to use

changeCallback - Optional callback called for all changes in value of the control

Overrides:
wx.Panel.__init__

createBrowseButton(self)

Create the browse-button control

createDialog(self, parent, id, pos, size, style)

Setup the graphic representation of the dialog

createLabel(self)

Create the label/caption

createTextControl(self)

Create the text control

Enable(self, value)

Convenient enabling/disabling of entire control

Overrides:
wx.Window.Enable

GetLabel(self)

Retrieve the label's current text

Overrides:
wx.Window.GetLabel

GetValue(self)

retrieve current value of text control

OnBrowse(self, event=None)

Going to browse for file...

SetLabel(self, value)

Set the label's current text

Overrides:
wx.Window.SetLabel

SetValue(self, value, callBack=1)

set current value of text control

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:46 2005 http://epydoc.sf.net


wx.lib.filebrowsebutton.FileBrowseButtonWithHistory

Package wx :: Package lib :: Module filebrowsebutton :: Class FileBrowseButtonWithHistory
[frames | no frames]

Type FileBrowseButtonWithHistory

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
                 Panel --+
                         |
          FileBrowseButton --+
                             |
                            FileBrowseButtonWithHistory

with following additions:

__init__(..., history=None)

history -- optional list of paths for initial history drop-down
(must be passed by name, not a positional argument) If history is callable it will must return a list used for the history drop-down
changeCallback -- as for FileBrowseButton, but with a work-around
for win32 systems which don't appear to create wx.EVT_COMBOBOX events properly. There is a (slight) chance that this work-around will cause some systems to create two events for each Combobox selection. If you discover this condition, please report it!

As for a FileBrowseButton.__init__ otherwise.

GetHistoryControl()
Return reference to the control which implements interfaces required for manipulating the history list. See GetHistoryControl documentation for description of what that interface is.
GetHistory()
Return current history list
SetHistory( value=(), selectionIndex = None )
Set current history list, if selectionIndex is not None, select that index
Method Summary
 | __init__(self, *arguments, **namedarguments)
 | createTextControl(self) Create the text control
 | GetHistory(self) Return the current history list
 | GetHistoryControl(self) Return a pointer to the control which provides (at least) the following methods for manipulating the history list:
 | OnSetFocus(self, event) When the history scroll is selected, update the history
 | SetHistory(self, value, selectionIndex, control) Set the current history list

Instance Method Details

createTextControl(self)

Create the text control

Overrides:
wx.lib.filebrowsebutton.FileBrowseButton.createTextControl

GetHistory(self)

Return the current history list

GetHistoryControl(self)

Return a pointer to the control which provides (at least) the following methods for manipulating the history list:

Append( item ) -- add item Clear() -- clear all items Delete( index ) -- 0-based index to delete from list SetSelection( index ) -- 0-based index to select in list

Semantics of the methods follow those for the wxComboBox control

OnSetFocus(self, event)

When the history scroll is selected, update the history

SetHistory(self,
          value=(),
          selectionIndex=None,
          control=None)

Set the current history list

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:01 2005 http://epydoc.sf.net


wx.lib.filebrowsebutton

Package wx :: Package lib :: Module filebrowsebutton

Module wx.lib.filebrowsebutton

Classes
DirBrowseButton |
FileBrowseButton | A control to allow the user to type in a filename or browse with the standard file dialog to select file
FileBrowseButtonWithHistory | __init__(..., history=None)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:11 2005 http://epydoc.sf.net


wx.lib.floatbar.FloatBar

Package wx :: Package lib :: Module floatbar :: Class FloatBar
[frames | no frames]

Type FloatBar

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
               Control --+
                         |
               ToolBarBase --+
                             |
                       ToolBar --+
                                 |
                                FloatBar

Method Summary
 | __init__(self, parent, ID, pos, size, style, name)
 | GetTitle(self)
 | IsFloating(self)
 | SetFloatable(self, float)
 | SetTitle(self, title)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:27 2005 http://epydoc.sf.net


wx.lib.floatbar

Package wx :: Package lib :: Module floatbar

Module wx.lib.floatbar

NOTE: This module is not supported in any way. Use it however you
wish, but be warned that dealing with any consequences is entirly up to you. --Robin
Classes
FloatBar

Variable Summary
str warningmsg = '\\\n\n####################################...

Variable Details

warningmsg

Type:
str
Value:
'''\\

################################################\\
# This module is not supported in any way!      |
#                                               |
# See cource code for wx.lib.floatbar for more  |
# information.                                  |
################################################/
...

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:11 2005 http://epydoc.sf.net


wx.lib.floatcanvas.FloatCanvas.Arrow

Package wx :: Package lib :: Package floatcanvas :: Module FloatCanvas :: Class Arrow
[frames | no frames]

Class Arrow

   DrawObject --+
                |
LineOnlyMixin --+
                |
XYObjectMixin --+
                |
               Arrow

Arrow(XY, # coords of origin of arrow (x,y)
      Length, # length of arrow in pixels
      theta, # angle of arrow in degrees: zero is straight up
             # angle is to the right
      LineColor = "Black",
      LineStyle = "Solid",
      LineWidth    = 1,
      ArrowHeadSize = 4,
      ArrowHeadAngle = 45,
      InForeground = False):

It will draw an arrow , starting at the point, (X,Y) pointing in
direction, theta.

Method Summary
 | __init__(self, XY, Length, Direction, LineColor, LineStyle, LineWidth, ArrowHeadSize, ArrowHeadAngle, InForeground)
 | CalcArrowPoints(self)
 | SetDirection(self, Direction)
 | SetLength(self, Length)
 | SetLengthDirection(self, Length, Direction)

Class Variable Summary

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:26 2005 http://epydoc.sf.net


wx.lib.floatcanvas.FloatCanvas.Circle

Package wx :: Package lib :: Package floatcanvas :: Module FloatCanvas :: Class Circle
[frames | no frames]

Class Circle

       DrawObject --+
                    |
LineOnlyMixin --+   |
                |   |
 LineAndFillMixin --+
                    |
    XYObjectMixin --+
                    |
          RectEllipse --+
                        |
                  Ellipse --+
                            |
                           Circle

Method Summary
 | __init__(self, x, y, Diameter, **kwargs)
 | SetDiameter(self, Diameter)

Class Variable Summary

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:11 2005 http://epydoc.sf.net


wx.lib.floatcanvas.FloatCanvas.ColorOnlyMixin

Package wx :: Package lib :: Package floatcanvas :: Module FloatCanvas :: Class ColorOnlyMixin
[frames | no frames]

Class ColorOnlyMixin

Known Subclasses:
Point, PointSet

Mixin class for objects that have just one color, rather than a fill color and line color

Method Summary
 | SetColor(self, Color)
 | SetFillColor(self, Color)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:25 2005 http://epydoc.sf.net


wx.lib.floatcanvas.FloatCanvas.DrawObject

Package wx :: Package lib :: Package floatcanvas :: Module FloatCanvas :: Class DrawObject
[frames | no frames]

Class DrawObject

Known Subclasses:
Arrow, Line, Point, PointSet, Polygon, RectEllipse, ScaledText, Text

This is the base class for all the objects that can be drawn.

One must subclass from this (and an assortment of Mixins) to create a new DrawObject.

Method Summary
 | __init__(self, InForeground)
 | Bind(self, Event, CallBackFun)
 | PutInBackground(self)
 | PutInForeground(self)
 | SetBrush(self, FillColor, FillStyle)
 | SetHitBrush(self, HitColor)
 | SetHitPen(self, HitColor, LineWidth)
 | SetPen(self, LineColor, LineStyle, LineWidth)
 | UnBindAll(self)

Class Variable Summary
dict | BrushList = {('MediumGrey', 'Solid'): wxPython wrapper f...
dict | FillStyleList = {'CrossHatch': 114, 'FDiagonal_Hatch': 1...
dict | LineStyleList = {'Solid': 100, 'ShortDash': 103, 'Dot': ...
dict | PenList = {('LightGrey', 'Solid', 1): wxPython wrapper f...

Class Variable Details

BrushList

Type:
dict
Value:
{(None, 'Transparent'): wxPython wrapper for UNBORN object! (The C++ o\
bject is not initialized yet.),
 ('Black', 'Solid'): wxPython wrapper for UNBORN object! (The C++ obje\
ct is not initialized yet.),
 ('Blue', 'Solid'): wxPython wrapper for UNBORN object! (The C++ objec\
t is not initialized yet.),
 ('Cyan', 'Solid'): wxPython wrapper for UNBORN object! (The C++ objec\
t is not initialized yet.),
...

FillStyleList

Type:
dict
Value:
{'BiDiagonalHatch': 111,
 'CrossDiagHatch': 112,
 'CrossHatch': 114,
 'FDiagonal_Hatch': 113,
 'HorizontalHatch': 115,
 'Solid': 100,
 'Transparent': 106,
 'VerticalHatch': 116}

LineStyleList

Type:
dict
Value:
{'Dot': 101,
 'DotDash': 104,
 'LongDash': 102,
 'ShortDash': 103,
 'Solid': 100,
 'Transparent': 106}

PenList

Type:
dict
Value:
{(None, 'Transparent', 1): wxPython wrapper for UNBORN object! (The C+\
+ object is not initialized yet.),
 ('Black', 'Solid', 1): wxPython wrapper for UNBORN object! (The C++ o\
bject is not initialized yet.),
 ('Cyan', 'Solid', 1): wxPython wrapper for UNBORN object! (The C++ ob\
ject is not initialized yet.),
 ('Green', 'Solid', 1): wxPython wrapper for UNBORN object! (The C++ o\
bject is not initialized yet.),
...

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:05 2005 http://epydoc.sf.net


wx.lib.floatcanvas.FloatCanvas.Ellipse

Package wx :: Package lib :: Package floatcanvas :: Module FloatCanvas :: Class Ellipse
[frames | no frames]

Class Ellipse

       DrawObject --+
                    |
LineOnlyMixin --+   |
                |   |
 LineAndFillMixin --+
                    |
    XYObjectMixin --+
                    |
          RectEllipse --+
                        |
                       Ellipse

Known Subclasses:
Circle
Method Summary

Class Variable Summary

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:26 2005 http://epydoc.sf.net


wx.lib.floatcanvas.FloatCanvas.FloatCanvas

Package wx :: Package lib :: Package floatcanvas :: Module FloatCanvas :: Class FloatCanvas
[frames | no frames]

Type FloatCanvas

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
                 Panel --+
                         |
                        FloatCanvas

FloatCanvas.py

This is a high level window for drawing maps and anything else in an arbitrary coordinate system.

The goal is to provide a convenient way to draw stuff on the screen without having to deal with handling OnPaint events, converting to pixel coordinates, knowing about wxWindows brushes, pens, and colors, etc. It also provides virtually unlimited zooming and scrolling

I am using it for two things: 1) general purpose drawing in floating point coordinates 2) displaying map data in Lat-long coordinates

If the projection is set to None, it will draw in general purpose floating point coordinates. If the projection is set to 'FlatEarth', it will draw a FlatEarth projection, centered on the part of the map that you are viewing. You can also pass in your own projection function.

It is double buffered, so re-draws after the window is uncovered by something else are very quick.

It relies on NumPy, which is needed for speed (maybe, I havn't profiled it)

Bugs and Limitations:
Lots: patches, fixes welcome

For Map drawing: It ignores the fact that the world is, in fact, a sphere, so it will do strange things if you are looking at stuff near the poles or the date line. so far I don't have a need to do that, so I havn't bothered to add any checks for that yet.

Zooming: I have set no zoom limits. What this means is that if you zoom in really far, you can get integer overflows, and get wierd results. It doesn't seem to actually cause any problems other than wierd output, at least when I have run it.

Speed: I have done a couple of things to improve speed in this app. The one thing I have done is used NumPy Arrays to store the coordinates of the points of the objects. This allowed me to use array oriented functions when doing transformations, and should provide some speed improvement for objects with a lot of points (big polygons, polylines, pointsets).

The real slowdown comes when you have to draw a lot of objects, because you have to call the wx.DC.DrawSomething call each time. This is plenty fast for tens of objects, OK for hundreds of objects, but pretty darn slow for thousands of objects.

The solution is to be able to pass some sort of object set to the DC directly. I've used DC.DrawPointList(Points), and it helped a lot with drawing lots of points. I havn't got a LineSet type object, so I havn't used DC.DrawLineList yet. I'd like to get a full set of DrawStuffList() methods implimented, and then I'd also have a full set of Object sets that could take advantage of them. I hope to get to it some day.

Mouse Events:

At this point, there are a full set of custom mouse events. They are just like the rebulsr mouse events, but include an extra attribute: Event.GetCoords(), that returns the (x,y) position in world coordinates, as a length-2 NumPy vector of Floats.

Copyright: Christopher Barker

License: Same as the version of wxPython you are using it with

Please let me know if you're using this!!!

Contact me at:

Chris.Barker@noaa.gov

Method Summary
__init__(self, parent, id, size, ProjectionFun, BackgroundColor, Debug)
AddArrow(self, *args, **kwargs)
Creates Arrow and adds its reference to the canvas.
AddCircle(self, *args, **kwargs)
Creates Circle and adds its reference to the canvas.
AddEllipse(self, *args, **kwargs)
Creates Ellipse and adds its reference to the canvas.
AddLine(self, *args, **kwargs)
Creates Line and adds its reference to the canvas.
AddObject(self, obj)
AddPoint(self, *args, **kwargs)
Creates Point and adds its reference to the canvas.
AddPointSet(self, *args, **kwargs)
Creates PointSet and adds its reference to the canvas.
AddPolygon(self, *args, **kwargs)
Creates Polygon and adds its reference to the canvas.
AddRectangle(self, *args, **kwargs)
Creates Rectangle and adds its reference to the canvas.
AddScaledText(self, *args, **kwargs)
Creates ScaledText and adds its reference to the canvas.
AddText(self, *args, **kwargs)
Creates Text and adds its reference to the canvas.
ClearAll(self, ResetBB)
Draw(self, Force)
There is a main buffer set up to double buffer the screen, so you can get quick re-draws when the window gets uncovered.
FlatEarthProjection(self, CenterPoint)
HitTest(self, event, HitEvent)
LeftDoubleClickEvent(self, event)
LeftDownEvent(self, event)
LeftUpEvent(self, event)
MakeHitDict(self)
MakeNewBuffers(self)
MakeNewHTdc(self)
MiddleDoubleClickEvent(self, event)
MiddleDownEvent(self, event)
MiddleUpEvent(self, event)
MotionEvent(self, event)
MouseOverTest(self, event)
MoveImage(self, shift, CoordType)
move the image in the window.
OnPaint(self, event)
OnSize(self, event)
PixelToWorld(self, Points)
Converts coordinates from Pixel coordinates to world coordinates.
RemoveObject(self, Object, ResetBB)
RemoveObjects(self, Objects)
RightDoubleCLickEvent(self, event)
RightDownEvent(self, event)
RightUpEvent(self, event)
ScalePixelToWorld(self, Lengths)
This function computes a pair of x.y lengths, to change then from pixel to world coordinates.
ScaleWorldToPixel(self, Lengths)
This function will get passed to the drawing functions of the objects, to Change a length from world to pixel coordinates.
SetMode(self, Mode)
SetProjectionFun(self, ProjectionFun)
WheelEvent(self, event)
WorldToPixel(self, Coordinates)
This function will get passed to the drawing functions of the objects, to transform from world to pixel coordinates.
Zoom(self, factor, center)
Zoom(factor, center) changes the amount of zoom of the image by factor.
ZoomToBB(self, NewBB, DrawFlag)
Zooms the image to the bounding box given, or to the bounding box of all the objects on the canvas, if none is given.

Instance Method Details

AddArrow(self, *args, **kwargs)

Creates Arrow and adds its reference to the canvas.
Argument protocol same as Arrow class, whose docstring is:

    Arrow(XY, # coords of origin of arrow (x,y)
          Length, # length of arrow in pixels
          theta, # angle of arrow in degrees: zero is straight up
                 # angle is to the right
          LineColor = "Black",
          LineStyle = "Solid",
          LineWidth    = 1,
          ArrowHeadSize = 4,
          ArrowHeadAngle = 45,
          InForeground = False):

    It will draw an arrow , starting at the point, (X,Y) pointing in
    direction, theta.

AddCircle(self, *args, **kwargs)

Creates Circle and adds its reference to the canvas. Argument protocol same as Circle class

AddEllipse(self, *args, **kwargs)

Creates Ellipse and adds its reference to the canvas. Argument protocol same as Ellipse class

AddLine(self, *args, **kwargs)

Creates Line and adds its reference to the canvas. Argument protocol same as Line class, whose docstring is:

The Line class takes a list of 2-tuples, or a NX2 NumPy Float array of point coordinates.

It will draw a straight line if there are two points, and a polyline if there are more than two.

AddPoint(self, *args, **kwargs)

Creates Point and adds its reference to the canvas. Argument protocol same as Point class, whose docstring is:

The Point class takes a 2-tuple, or a (2,) NumPy array of point coordinates.

The Diameter is in screen points, not world coordinates, So the Bounding box is just the point, and doesn't include the Diameter.

The HitLineWidth is used as diameter for the Hit Test.

AddPointSet(self, *args, **kwargs)

Creates PointSet and adds its reference to the canvas. Argument protocol same as PointSet class, whose docstring is:

The PointSet class takes a list of 2-tuples, or a NX2 NumPy array of point coordinates.

If Points is a sequence of tuples: Points[N][0] is the x-coordinate of point N and Points[N][1] is the y-coordinate.

If Points is a NumPy array: Points[N,0] is the x-coordinate of point N and Points[N,1] is the y-coordinate for arrays.

Each point will be drawn the same color and Diameter. The Diameter is in screen pixels, not world coordinates.

The hit-test code does not distingish between the points, you will only know that one of the points got hit, not which one. You can use PointSet.FindClosestPoint(WorldPoint) to find out which one

In the case of points, the HitLineWidth is used as diameter.

AddPolygon(self, *args, **kwargs)

Creates Polygon and adds its reference to the canvas. Argument protocol same as Polygon class, whose docstring is:

The Polygon class takes a list of 2-tuples, or a NX2 NumPy array of point coordinates. so that Points[N][0] is the x-coordinate of point N and Points[N][1] is the y-coordinate or Points[N,0] is the x-coordinate of point N and Points[N,1] is the y-coordinate for arrays.

The other parameters specify various properties of the Polygon, and should be self explanatory.

AddRectangle(self, *args, **kwargs)

Creates Rectangle and adds its reference to the canvas. Argument protocol same as Rectangle class

AddScaledText(self, *args, **kwargs)

Creates ScaledText and adds its reference to the canvas.
Argument protocol same as ScaledText class, whose docstring is:

    This class creates a text object that is scaled when zoomed.  It is
    placed at the coordinates, x,y. the "Position" argument is a two
    charactor string, indicating where in relation to the coordinates
    the string should be oriented.

    The first letter is: t, c, or b, for top, center and bottom The
    second letter is: l, c, or r, for left, center and right The
    position refers to the position relative to the text itself. It
    defaults to "tl" (top left).

    Size is the size of the font in world coordinates.

    Family:
        Font family, a generic way of referring to fonts without
        specifying actual facename. One of:
            wx.DEFAULT:  Chooses a default font.
            wx.DECORATI: A decorative font.
            wx.ROMAN: A formal, serif font.
            wx.SCRIPT: A handwriting font.
            wx.SWISS: A sans-serif font.
            wx.MODERN: A fixed pitch font.
        NOTE: these are only as good as the wxWindows defaults, which aren't so good.
    Style:
        One of wx.NORMAL, wx.SLANT and wx.ITALIC.
    Weight:
        One of wx.NORMAL, wx.LIGHT and wx.BOLD.
    Underline:
        The value can be True or False. At present this may have an an
        effect on Windows only.

    Alternatively, you can set the kw arg: Font, to a wx.Font, and the
    above will be ignored. The size of the font you specify will be
    ignored, but the rest of it's attributes will be preserved.

    The size will scale as the drawing is zoomed.

    Bugs/Limitations:

    As fonts are scaled, the do end up a little different, so you don't
    get exactly the same picture as you scale up and doen, but it's
    pretty darn close.

    On wxGTK1 on my Linux system, at least, using a font of over about
    3000 pts. brings the system to a halt. It's the Font Server using
    huge amounts of memory. My work around is to max the font size to
    3000 points, so it won't scale past there. GTK2 uses smarter font
    drawing, so that may not be an issue in future versions, so feel
    free to test. Another smarter way to do it would be to set a global
    zoom limit at that point.

    The hit-test is done on the entire text extent. This could be made
    optional, but I havn't gotten around to it.

AddText(self, *args, **kwargs)

Creates Text and adds its reference to the canvas.
Argument protocol same as Text class, whose docstring is:

    This class creates a text object, placed at the coordinates,
    x,y. the "Position" argument is a two charactor string, indicating
    where in relation to the coordinates the string should be oriented.

    The first letter is: t, c, or b, for top, center and bottom The
    second letter is: l, c, or r, for left, center and right The
    position refers to the position relative to the text itself. It
    defaults to "tl" (top left).

    Size is the size of the font in pixels, or in points for printing
    (if it ever gets implimented). Those will be the same, If you assume
    72 PPI.

    Family:
        Font family, a generic way of referring to fonts without
        specifying actual facename. One of:
            wx.DEFAULT:  Chooses a default font.
            wx.DECORATIVE: A decorative font.
            wx.ROMAN: A formal, serif font.
            wx.SCRIPT: A handwriting font.
            wx.SWISS: A sans-serif font.
            wx.MODERN: A fixed pitch font.
        NOTE: these are only as good as the wxWindows defaults, which aren't so good.
    Style:
        One of wx.NORMAL, wx.SLANT and wx.ITALIC.
    Weight:
        One of wx.NORMAL, wx.LIGHT and wx.BOLD.
    Underline:
        The value can be True or False. At present this may have an an
        effect on Windows only.

    Alternatively, you can set the kw arg: Font, to a wx.Font, and the above will be ignored.

    The size is fixed, and does not scale with the drawing.

    The hit-test is done on the entire text extent

Draw(self, Force=False)

There is a main buffer set up to double buffer the screen, so you can get quick re-draws when the window gets uncovered.

If there are any objects in self._ForeDrawList, then the background gets drawn to a new buffer, and the foreground objects get drawn on top of it. The final result if blitted to the screen, and stored for future Paint events. This is done so that you can have a complicated background, but have something changing on the foreground, without having to wait for the background to get re-drawn. This can be used to support simple animation, for instance.

MoveImage(self, shift, CoordType)

move the image in the window.

shift is an (x,y) tuple, specifying the amount to shift in each direction

It can be in any of three coordinates: Panel, Pixel, World, specified by the CoordType parameter

Panel coordinates means you want to shift the image by some fraction of the size of the displaed image

Pixel coordinates means you want to shift the image by some number of pixels

World coordinates mean you want to shift the image by an amount in Floating point world coordinates

PixelToWorld(self, Points)

Converts coordinates from Pixel coordinates to world coordinates.

Points is a tuple of (x,y) coordinates, or a list of such tuples, or a NX2 Numpy array of x,y coordinates.

ScalePixelToWorld(self, Lengths)

This function computes a pair of x.y lengths, to change then from pixel to world coordinates.

Lengths should be a NX2 array of (x,y) coordinates, or a 2-tuple, or sequence of 2-tuples.

ScaleWorldToPixel(self, Lengths)

This function will get passed to the drawing functions of the objects, to Change a length from world to pixel coordinates.

Lengths should be a NX2 array of (x,y) coordinates, or a 2-tuple, or sequence of 2-tuples.

WorldToPixel(self, Coordinates)

This function will get passed to the drawing functions of the objects, to transform from world to pixel coordinates. Coordinates should be a NX2 array of (x,y) coordinates, or a 2-tuple, or sequence of 2-tuples.

Zoom(self, factor, center=None)

Zoom(factor, center) changes the amount of zoom of the image by factor. If factor is greater than one, the image gets larger. If factor is less than one, the image gets smaller.

Center is a tuple of (x,y) coordinates of the center of the viewport, after zooming. If center is not given, the center will stay the same.

ZoomToBB(self, NewBB=None, DrawFlag=True)

Zooms the image to the bounding box given, or to the bounding box of all the objects on the canvas, if none is given.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:11 2005 http://epydoc.sf.net


wx.lib.floatcanvas.FloatCanvas.FloatCanvasError

Package wx :: Package lib :: Package floatcanvas :: Module FloatCanvas :: Class FloatCanvasError
[frames | no frames]

Class FloatCanvasError

Exception --+
            |
           FloatCanvasError

Method Summary

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:10:55 2005 http://epydoc.sf.net


wx.lib.floatcanvas.FloatCanvas.LineAndFillMixin

Package wx :: Package lib :: Package floatcanvas :: Module FloatCanvas :: Class LineAndFillMixin
[frames | no frames]

Class LineAndFillMixin

LineOnlyMixin --+
                |
               LineAndFillMixin

Known Subclasses:
Polygon, RectEllipse

Mixin class for objects that have both a line and a fill color and style.

Method Summary
 | SetFillColor(self, FillColor)
 | SetFillStyle(self, FillStyle)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:10:53 2005 http://epydoc.sf.net


wx.lib.floatcanvas.FloatCanvas.Line

Package wx :: Package lib :: Package floatcanvas :: Module FloatCanvas :: Class Line
[frames | no frames]

Class Line

       DrawObject --+
                    |
    LineOnlyMixin --+
                    |
PointsObjectMixin --+
                    |
                   Line

The Line class takes a list of 2-tuples, or a NX2 NumPy Float array of point coordinates.

It will draw a straight line if there are two points, and a polyline if there are more than two.

Method Summary
__init__(self, Points, LineColor, LineStyle, LineWidth, InForeground)

Class Variable Summary

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:25 2005 http://epydoc.sf.net


wx.lib.floatcanvas.FloatCanvas.LineOnlyMixin

Package wx :: Package lib :: Package floatcanvas :: Module FloatCanvas :: Class LineOnlyMixin
[frames | no frames]

Class LineOnlyMixin

Known Subclasses:
Arrow, Line, LineAndFillMixin

Mixin class for objects that have just one color, rather than a fill color and line color

Method Summary
 | SetLineColor(self, LineColor)
 | SetLineStyle(self, LineStyle)
 | SetLineWidth(self, LineWidth)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:10:49 2005 http://epydoc.sf.net


wx.lib.floatcanvas.FloatCanvas.Point

Package wx :: Package lib :: Package floatcanvas :: Module FloatCanvas :: Class Point
[frames | no frames]

Class Point

ColorOnlyMixin --+
                 |
    DrawObject --+
                 |
 XYObjectMixin --+
                 |
                Point

The Point class takes a 2-tuple, or a (2,) NumPy array of point coordinates.

The Diameter is in screen points, not world coordinates, So the Bounding box is just the point, and doesn't include the Diameter.

The HitLineWidth is used as diameter for the Hit Test.

Method Summary
 | __init__(self, XY, Color, Diameter, InForeground)
 | SetDiameter(self, Diameter)

Class Variable Summary

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:26 2005 http://epydoc.sf.net


wx.lib.floatcanvas.FloatCanvas.PointSet

Package wx :: Package lib :: Package floatcanvas :: Module FloatCanvas :: Class PointSet
[frames | no frames]

Class PointSet

   ColorOnlyMixin --+
                    |
       DrawObject --+
                    |
PointsObjectMixin --+
                    |
                   PointSet

The PointSet class takes a list of 2-tuples, or a NX2 NumPy array of point coordinates.

If Points is a sequence of tuples: Points[N][0] is the x-coordinate of point N and Points[N][1] is the y-coordinate.

If Points is a NumPy array: Points[N,0] is the x-coordinate of point N and Points[N,1] is the y-coordinate for arrays.

Each point will be drawn the same color and Diameter. The Diameter is in screen pixels, not world coordinates.

The hit-test code does not distingish between the points, you will only know that one of the points got hit, not which one. You can use PointSet.FindClosestPoint(WorldPoint) to find out which one

In the case of points, the HitLineWidth is used as diameter.

Method Summary
 | __init__(self, Points, Color, Diameter, InForeground)
 | DrawD2(self, dc, Points)
 | FindClosestPoint(self, XY) Returns the index of the closest point to the point, XY, given in World coordinates.
 | SetDiameter(self, Diameter)

Class Variable Summary

Method Details

FindClosestPoint(self, XY)

Returns the index of the closest point to the point, XY, given in World coordinates. It's essentially random which you get if there are more than one that are the same.

This can be used to figure out which point got hit in a mouse binding callback, for instance. It's a lot faster that using a lot of separate points.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:05 2005 http://epydoc.sf.net


wx.lib.floatcanvas.FloatCanvas.PointsObjectMixin

Package wx :: Package lib :: Package floatcanvas :: Module FloatCanvas :: Class PointsObjectMixin
[frames | no frames]

Class PointsObjectMixin

Known Subclasses:
Line, PointSet, Polygon

This is a mixin class that provides some methods suitable for use with objects that have a set of (x,y) coordinate pairs.

Method Summary
 | CalcBoundingBox(self)
 | SetPoints(self, Points, copy) Sets the coordinates of the points of the object to Points (NX2 array).

Method Details

SetPoints(self, Points, copy=True)

Sets the coordinates of the points of the object to Points (NX2 array).

By default, a copy is made, if copy is set to False, a reference is used, iff Points is a NumPy array of Floats. This allows you to change some or all of the points without making any copies.

For example:

Points = Object.Points Points += (5,10) # shifts the points 5 in the x dir, and 10 in the y dir. Object.SetPoints(Points, False) # Sets the points to the same array as it was

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:25 2005 http://epydoc.sf.net


wx.lib.floatcanvas.FloatCanvas.Polygon

Package wx :: Package lib :: Package floatcanvas :: Module FloatCanvas :: Class Polygon
[frames | no frames]

Class Polygon

       DrawObject --+
                    |
LineOnlyMixin --+   |
                |   |
 LineAndFillMixin --+
                    |
PointsObjectMixin --+
                    |
                   Polygon

The Polygon class takes a list of 2-tuples, or a NX2 NumPy array of point coordinates. so that Points[N][0] is the x-coordinate of point N and Points[N][1] is the y-coordinate or Points[N,0] is the x-coordinate of point N and Points[N,1] is the y-coordinate for arrays.

The other parameters specify various properties of the Polygon, and should be self explanatory.

Method Summary
__init__(self, Points, LineColor, LineStyle, LineWidth, FillColor, FillStyle, InForeground)

Class Variable Summary

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:25 2005 http://epydoc.sf.net


wx.lib.floatcanvas.FloatCanvas.Rectangle

Package wx :: Package lib :: Package floatcanvas :: Module FloatCanvas :: Class Rectangle
[frames | no frames]

Class Rectangle

       DrawObject --+
                    |
LineOnlyMixin --+   |
                |   |
 LineAndFillMixin --+
                    |
    XYObjectMixin --+
                    |
          RectEllipse --+
                        |
                       Rectangle

Method Summary

Class Variable Summary

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:44 2005 http://epydoc.sf.net


wx.lib.floatcanvas.FloatCanvas.RectEllipse

Package wx :: Package lib :: Package floatcanvas :: Module FloatCanvas :: Class RectEllipse
[frames | no frames]

Class RectEllipse

       DrawObject --+
                    |
LineOnlyMixin --+   |
                |   |
 LineAndFillMixin --+
                    |
    XYObjectMixin --+
                    |
                   RectEllipse

Known Subclasses:
Ellipse, Rectangle
Method Summary
 | __init__(self, x, y, width, height, LineColor, LineStyle, LineWidth, FillColor, FillStyle, InForeground)
 | CalcBoundingBox(self)
 | SetShape(self, x, y, width, height)
 | SetUpDraw(self, dc, WorldToPixel, ScaleWorldToPixel, HTdc)

Class Variable Summary

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:07 2005 http://epydoc.sf.net


wx.lib.floatcanvas.FloatCanvas.ScaledText

Package wx :: Package lib :: Package floatcanvas :: Module FloatCanvas :: Class ScaledText
[frames | no frames]

Class ScaledText

       DrawObject --+
                    |
XYObjectMixin --+   |
                |   |
  TextObjectMixin --+
                    |
                   ScaledText

This class creates a text object that is scaled when zoomed.  It is
placed at the coordinates, x,y. the "Position" argument is a two
charactor string, indicating where in relation to the coordinates
the string should be oriented.

The first letter is: t, c, or b, for top, center and bottom The
second letter is: l, c, or r, for left, center and right The
position refers to the position relative to the text itself. It
defaults to "tl" (top left).

Size is the size of the font in world coordinates.

Family:
    Font family, a generic way of referring to fonts without
    specifying actual facename. One of:
        wx.DEFAULT:  Chooses a default font.
        wx.DECORATI: A decorative font.
        wx.ROMAN: A formal, serif font.
        wx.SCRIPT: A handwriting font.
        wx.SWISS: A sans-serif font.
        wx.MODERN: A fixed pitch font.
    NOTE: these are only as good as the wxWindows defaults, which aren't so good.
Style:
    One of wx.NORMAL, wx.SLANT and wx.ITALIC.
Weight:
    One of wx.NORMAL, wx.LIGHT and wx.BOLD.
Underline:
    The value can be True or False. At present this may have an an
    effect on Windows only.

Alternatively, you can set the kw arg: Font, to a wx.Font, and the
above will be ignored. The size of the font you specify will be
ignored, but the rest of it's attributes will be preserved.

The size will scale as the drawing is zoomed.

Bugs/Limitations:

As fonts are scaled, the do end up a little different, so you don't
get exactly the same picture as you scale up and doen, but it's
pretty darn close.

On wxGTK1 on my Linux system, at least, using a font of over about
3000 pts. brings the system to a halt. It's the Font Server using
huge amounts of memory. My work around is to max the font size to
3000 points, so it won't scale past there. GTK2 uses smarter font
drawing, so that may not be an issue in future versions, so feel
free to test. Another smarter way to do it would be to set a global
zoom limit at that point.

The hit-test is done on the entire text extent. This could be made
optional, but I havn't gotten around to it.

Method Summary
 | __init__(self, String, x, y, Size, Color, BackgroundColor, Family, Style, Weight, Underline, Position, Font, InForeground)
 | CalcBoundingBox(self)

Class Variable Summary

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:23 2005 http://epydoc.sf.net


wx.lib.floatcanvas.FloatCanvas.Text

Package wx :: Package lib :: Package floatcanvas :: Module FloatCanvas :: Class Text
[frames | no frames]

Class Text

       DrawObject --+
                    |
XYObjectMixin --+   |
                |   |
  TextObjectMixin --+
                    |
                   Text

This class creates a text object, placed at the coordinates,
x,y. the "Position" argument is a two charactor string, indicating
where in relation to the coordinates the string should be oriented.

The first letter is: t, c, or b, for top, center and bottom The
second letter is: l, c, or r, for left, center and right The
position refers to the position relative to the text itself. It
defaults to "tl" (top left).

Size is the size of the font in pixels, or in points for printing
(if it ever gets implimented). Those will be the same, If you assume
72 PPI.

Family:
    Font family, a generic way of referring to fonts without
    specifying actual facename. One of:
        wx.DEFAULT:  Chooses a default font.
        wx.DECORATIVE: A decorative font.
        wx.ROMAN: A formal, serif font.
        wx.SCRIPT: A handwriting font.
        wx.SWISS: A sans-serif font.
        wx.MODERN: A fixed pitch font.
    NOTE: these are only as good as the wxWindows defaults, which aren't so good.
Style:
    One of wx.NORMAL, wx.SLANT and wx.ITALIC.
Weight:
    One of wx.NORMAL, wx.LIGHT and wx.BOLD.
Underline:
    The value can be True or False. At present this may have an an
    effect on Windows only.

Alternatively, you can set the kw arg: Font, to a wx.Font, and the above will be ignored.

The size is fixed, and does not scale with the drawing.

The hit-test is done on the entire text extent
Method Summary
__init__(self, String, x, y, Size, Color, BackgroundColor, Family, Style, Weight, Underline, Position, InForeground, Font)

Class Variable Summary

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:26 2005 http://epydoc.sf.net


wx.lib.floatcanvas.FloatCanvas.TextObjectMixin

Package wx :: Package lib :: Package floatcanvas :: Module FloatCanvas :: Class TextObjectMixin
[frames | no frames]

Class TextObjectMixin

XYObjectMixin --+
                |
               TextObjectMixin

Known Subclasses:
ScaledText, Text

A mix in class that holds attributes and methods that are needed by the Text objects

Method Summary
 | SetBackgroundColor(self, BackgroundColor)
 | SetColor(self, Color)
 | SetFont(self, Size, Family, Style, Weight, Underline, FaceName)

Class Variable Summary
dict | FontList = {}
dict | ShiftFunDict = {'cl': <function <lambda> at 0xb7a1187c>,...

Class Variable Details

FontList

Type:
dict
Value:
{}

ShiftFunDict

Type:
dict
Value:
{'bc': <function <lambda> at 0xb7a1195c>,
 'bl': <function <lambda> at 0xb7a11924>,
 'br': <function <lambda> at 0xb7a11994>,
 'cc': <function <lambda> at 0xb7a118b4>,
 'cl': <function <lambda> at 0xb7a1187c>,
 'cr': <function <lambda> at 0xb7a118ec>,
 'tc': <function <lambda> at 0xb7a1180c>,
 'tl': <function <lambda> at 0xb7a117d4>,
...

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:26 2005 http://epydoc.sf.net


wx.lib.floatcanvas.FloatCanvas.XYObjectMixin

Package wx :: Package lib :: Package floatcanvas :: Module FloatCanvas :: Class XYObjectMixin
[frames | no frames]

Class XYObjectMixin

Known Subclasses:
Arrow, Point, RectEllipse, TextObjectMixin

This is a mixin class that provides some methods suitable for use with objects that have a single (x,y) coordinate pair.

Method Summary
 | CalcBoundingBox(self)
 | Move(self, Delta) Move(Delta): moves the object by delta, where delta is a (dx,dy) pair.
 | SetPoint(self, xy)
 | SetXY(self, x, y)

Method Details

Move(self, Delta)

Move(Delta): moves the object by delta, where delta is a (dx,dy) pair. Ideally a Numpy array of shape (2,)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:10:53 2005 http://epydoc.sf.net


wx.lib.floatcanvas.FloatCanvas

Package wx :: Package lib :: Package floatcanvas :: Module FloatCanvas
[frames | no frames]

Module wx.lib.floatcanvas.FloatCanvas

Classes
Arrow | Arrow(XY, # coords of origin of arrow (x,y) Length, # length of arrow in pixels theta, # angle of arrow in degrees: zero is straight up # angle is to the right LineColor = "Black", LineStyle = "Solid", LineWidth = 1, ArrowHeadSize = 4, ArrowHeadAngle = 45, InForeground = False): It will draw an arrow , starting at the point, (X,Y) pointing in direction, theta.
Circle |
ColorOnlyMixin | Mixin class for objects that have just one color, rather than a fill color and line color
DrawObject | This is the base class for all the objects that can be drawn.
Ellipse |
FloatCanvas | FloatCanvas.py
Line | The Line class takes a list of 2-tuples, or a NX2 NumPy Float array of point coordinates.
LineAndFillMixin | Mixin class for objects that have both a line and a fill color and style.
LineOnlyMixin | Mixin class for objects that have just one color, rather than a fill color and line color
Point | The Point class takes a 2-tuple, or a (2,) NumPy array of point coordinates.
PointSet | The PointSet class takes a list of 2-tuples, or a NX2 NumPy array of point coordinates.
PointsObjectMixin | This is a mixin class that provides some methods suitable for use with objects that have a set of (x,y) coordinate pairs.
Polygon | The Polygon class takes a list of 2-tuples, or a NX2 NumPy array of point coordinates.
Rectangle |
RectEllipse |
ScaledText | This class creates a text object that is scaled when zoomed.
Text | This class creates a text object, placed at the coordinates, x,y.
TextObjectMixin | A mix in class that holds attributes and methods that are needed by the Text objects
XYObjectMixin | This is a mixin class that provides some methods suitable for use with objects that have a single (x,y) coordinate pair.

Exceptions
FloatCanvasError

Function Summary
 | EVT_LEFT_DCLICK(window, function)
 | EVT_LEFT_DOWN(window, function)
 | EVT_LEFT_UP(window, function)
 | EVT_MIDDLE_DCLICK(window, function)
 | EVT_MIDDLE_DOWN(window, function)
 | EVT_MIDDLE_UP(window, function)
 | EVT_MOTION(window, function)
 | EVT_MOUSEWHEEL(window, function)
 | EVT_RIGHT_DCLICK(window, function)
 | EVT_RIGHT_DOWN(window, function)
 | EVT_RIGHT_UP(window, function)

Variable Summary
int | EVT_FC_ENTER_OBJECT = 10269
int | EVT_FC_LEAVE_OBJECT = 10270
int | EVT_FC_LEFT_DCLICK = 10260
int | EVT_FC_LEFT_DOWN = 10258
int | EVT_FC_LEFT_UP = 10259
int | EVT_FC_MIDDLE_DCLICK = 10263
int | EVT_FC_MIDDLE_DOWN = 10261
int | EVT_FC_MIDDLE_UP = 10262
int | EVT_FC_MOTION = 10267
int | EVT_FC_MOUSEWHEEL = 10268
int | EVT_FC_RIGHT_DCLICK = 10266
int | EVT_FC_RIGHT_DOWN = 10264
int | EVT_FC_RIGHT_UP = 10265

Variable Details

EVT_FC_ENTER_OBJECT

Type:
int
Value:
10269

EVT_FC_LEAVE_OBJECT

Type:
int
Value:
10270

EVT_FC_LEFT_DCLICK

Type:
int
Value:
10260

EVT_FC_LEFT_DOWN

Type:
int
Value:
10258

EVT_FC_LEFT_UP

Type:
int
Value:
10259

EVT_FC_MIDDLE_DCLICK

Type:
int
Value:
10263

EVT_FC_MIDDLE_DOWN

Type:
int
Value:
10261

EVT_FC_MIDDLE_UP

Type:
int
Value:
10262

EVT_FC_MOTION

Type:
int
Value:
10267

EVT_FC_MOUSEWHEEL

Type:
int
Value:
10268

EVT_FC_RIGHT_DCLICK

Type:
int
Value:
10266

EVT_FC_RIGHT_DOWN

Type:
int
Value:
10264

EVT_FC_RIGHT_UP

Type:
int
Value:
10265

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:06 2005 http://epydoc.sf.net


wx.lib.floatcanvas.NavCanvas.NavCanvas

Package wx :: Package lib :: Package floatcanvas :: Module NavCanvas :: Class NavCanvas
[frames | no frames]

Type NavCanvas

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
                 Panel --+
                         |
                        NavCanvas

NavCanvas.py

This is a high level window that encloses the FloatCanvas in a panel and adds a Navigation toolbar.

Copyright: wxWindows Software Foundation (Assigned by: Christopher Barker)

License: Same as the version of wxPython you are using it with

Please let me know if you're using this!!!

Contact me at:

Chris.Barker@noaa.gov

Method Summary
 | __init__(self, parent, id, size, **kwargs)
 | __getattr__(self, name) Delegate all extra methods to the Canvas
 | BuildToolbar(self)
 | SetToolMode(self, event)
 | ZoomToFit(self, Event)

Instance Method Details

__getattr__(self, name)
(Qualification operator)

Delegate all extra methods to the Canvas

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:12 2005 http://epydoc.sf.net


wx.lib.floatcanvas.NavCanvas

Package wx :: Package lib :: Package floatcanvas :: Module NavCanvas
[frames | no frames]

Module wx.lib.floatcanvas.NavCanvas

A Panel that includes the FloatCanvas and Navigation controls

Classes
NavCanvas NavCanvas.py

Variable Summary
int | ID_MOVE_MODE_BUTTON = 125
int | ID_POINTER_BUTTON = 126
int | ID_ZOOM_IN_BUTTON = 122
int | ID_ZOOM_OUT_BUTTON = 123
int | ID_ZOOM_TO_FIT_BUTTON = 124

Variable Details

ID_MOVE_MODE_BUTTON

Type:
int
Value:
125

ID_POINTER_BUTTON

Type:
int
Value:
126

ID_ZOOM_IN_BUTTON

Type:
int
Value:
122

ID_ZOOM_OUT_BUTTON

Type:
int
Value:
123

ID_ZOOM_TO_FIT_BUTTON

Type:
int
Value:
124

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:12 2005 http://epydoc.sf.net


wx.lib.floatcanvas.Resources

Package wx :: Package lib :: Package floatcanvas :: Module Resources
[frames | no frames]

Module wx.lib.floatcanvas.Resources

Resources.py Various resources needed by the FloatCanvas package

Includes, icons, etc.

Function Summary
 | GetHandBitmap()
 | GetHandData()
 | GetMinusBitmap()
 | GetMinusData()
 | GetPlusBitmap()
 | GetPlusData()
 | GetPointerBitmap()
 | GetPointerData()
 | GetPointerImage()

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:41 2005 http://epydoc.sf.net


wx.lib.floatcanvas

Package wx :: Package lib :: Package floatcanvas

Package wx.lib.floatcanvas

This is the floatcanvas package. It provides two primary modules, and a support module.

FloatCanvas.py contains the main FloatCanvas class, and its supporting classes. NavCanvas.py contains a wrapper for the FloatCanvas that provides the canvas and a toolbar with tools that allow you to navigate the canvas (zooming, panning, etc.) Resources.py is a module that contains a few resources required by the FloatCanvas (icons, etc)

The FloatCanvas is a high level window for drawing maps and anything else in an arbitrary coordinate system.

The goal is to provide a convenient way to draw stuff on the screen without having to deal with handling OnPaint events, converting to pixel coordinates, knowing about wxWindows brushes, pens, and colors, etc. It also provides virtually unlimited zooming and scrolling

I am using it for two things: 1) general purpose drawing in floating point coordinates 2) displaying map data in Lat-long coordinates

If the projection is set to None, it will draw in general purpose floating point coordinates. If the projection is set to 'FlatEarth', it will draw a FlatEarth projection, centered on the part of the map that you are viewing. You can also pass in your own projection function.

It is double buffered, so re-draws after the window is uncovered by something else are very quick.

It relies on NumPy, which is needed for speed (maybe, I haven't profiled it). It will also use numarray, if you don't have Numeric, but it is slower.

Bugs and Limitations: Lots: patches, fixes welcome

For Map drawing: It ignores the fact that the world is, in fact, a sphere, so it will do strange things if you are looking at stuff near the poles or the date line. so far I don't have a need to do that, so I havn't bothered to add any checks for that yet.

Zooming: I have set no zoom limits. What this means is that if you zoom in really far, you can get integer overflows, and get weird results. It doesn't seem to actually cause any problems other than weird output, at least when I have run it.

Speed: I have done a couple of things to improve speed in this app. The one thing I have done is used NumPy Arrays to store the coordinates of the points of the objects. This allowed me to use array oriented functions when doing transformations, and should provide some speed improvement for objects with a lot of points (big polygons, polylines, pointsets).

The real slowdown comes when you have to draw a lot of objects, because you have to call the wx.DC.DrawSomething call each time. This is plenty fast for tens of objects, OK for hundreds of objects, but pretty darn slow for thousands of objects.

If you are zoomed in, it checks the Bounding box of an object before drawing it. This makes it a great deal faster when there are a lot of objects and you are zoomed in so that only a few are shown.

One solution is to be able to pass some sort of object set to the DC directly. I've used DC.DrawPointList(Points), and it helped a lot with drawing lots of points. However, when zoomed in, the Bounding boxes need to be checked, so I may some day write C++ code that does the loop and checks the BBs.

Mouse Events:

At this point, there are a full set of custom mouse events. They are just like the regular mouse events, but include an extra attribute: Event.GetCoords(), that returns the (x,y) position in world coordinates, as a length-2 NumPy vector of Floats.

There are also a full set of bindings to mouse events on objects, so that you can specify a given function be called when an objects is clicked, mouse-over'd, etc.

See the Demo for what it can do, and how to use it.

Copyright: Christopher Barker

License: Same as the version of wxPython you are using it with.

Check for updates at: http://home.comcast.net/~chrishbarker/FloatCanvas/

Please let me know if you're using this!!!

Contact me at:

Chris.Barker@noaa.gov

Submodules
  • FloatCanvas
  • NavCanvas: A Panel that includes the FloatCanvas and Navigation controls
  • Resources: Resources.py Various resources needed by the FloatCanvas package

Variable Summary
str __version__ = '0.8.7'

Variable Details

__version__

Type:
str
Value:
'0.8.7'

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:03 2005 http://epydoc.sf.net


wx.lib.foldmenu.FoldOutMenu

Package wx :: Package lib :: Module foldmenu :: Class FoldOutMenu
[frames | no frames]

Type FoldOutMenu

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
               Control --+
                         |
                    Button --+
                             |
                  BitmapButton --+
                                 |
                                FoldOutMenu

Method Summary
 | __init__(self, parent, id, bitmap, pos, size, style, validator, name)
 | AddButton(self, bitmap, handler)
 | click(self, event)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:34 2005 http://epydoc.sf.net


wx.lib.foldmenu.FoldOutWindow

Package wx :: Package lib :: Module foldmenu :: Class FoldOutWindow
[frames | no frames]

Type FoldOutWindow

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
           PopupWindow --+
                         |
                        FoldOutWindow

Method Summary
 | __init__(self, parent, style)
 | AddButton(self, bitmap, handler)
 | evEnter(self, event)
 | evLeave(self, event)
 | InitColors(self)
 | OnBtnClick(self, event)
 | Popup(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:17 2005 http://epydoc.sf.net


wx.lib.foldmenu

Package wx :: Package lib :: Module foldmenu

Module wx.lib.foldmenu

Classes
FoldOutMenu
FoldOutWindow

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:42 2005 http://epydoc.sf.net


wx.lib.foldpanelbar.CaptionBar

Package wx :: Package lib :: Module foldpanelbar :: Class CaptionBar
[frames | no frames]

Type CaptionBar

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
                    CaptionBar

This class is a graphical caption component that consists of a caption and a clickable arrow.

The CaptionBar fires an event EVT_CAPTIONBAR which is a CaptionBarEvent. This event can be caught and the parent window can act upon the collapsed or expanded state of the bar (which is actually just the icon which changed). The parent panel can reduce size or expand again.

Method Summary
 | __init__(self, parent, id, pos, size, caption, foldIcons, cbstyle, rightIndent, iconWidth, iconHeight, collapsed) Default Class Constructor.
 | ApplyCaptionStyle(self, cbstyle, applyDefault) Applies the style defined in cbstyle to the CaptionBar.
 | Collapse(self) This sets the internal state / representation to collapsed.
 | DoGetBestSize(self) Returns the best size for this panel, based upon the font assigned to this window, and the caption string
 | DrawHorizontalGradient(self, dc, rect) Gradient fill from colour 1 to colour 2 with left to right.
 | DrawSingleColour(self, dc, rect) Single colour fill.
 | DrawSingleRectangle(self, dc, rect) Single rectangle.
 | DrawVerticalGradient(self, dc, rect) Gradient fill from colour 1 to colour 2 with top to bottom.
 | Expand(self) This sets the internal state / representation to expanded.
 | FillCaptionBackground(self, dc) Fills the background of the caption with either a gradient or a solid color.
 | GetCaptionStyle(self) Returns the current style of the captionbar in a CaptionBarStyle class.
 | IsCollapsed(self) Returns wether the status of the bar is expanded or collapsed.
 | IsVertical(self) Returns wether the CaptionBar Has Default Orientation Or Not.
 | OnChar(self, event) Unused Methods.
 | OnMouseEvent(self, event) Catches the mouse click-double click.
 | OnPaint(self, event) The paint event for flat or gradient fill.
 | OnSize(self, event) Handles the size events for the CaptionBar.
 | RedrawIconBitmap(self) Redraws the icons (if they exists).
 | SetBoldFont(self) Sets the CaptionBarFont weight to BOLD.
 | SetCaptionStyle(self, cbstyle, applyDefault) Sets CaptionBar styles with CapionBarStyle class.
 | SetNormalFont(self) Sets the CaptionBarFont weight to NORMAL.
 | SetRightIndent(self, pixels) Sets the amount of pixels on the right from which the bitmap is trailing.

Class Variable Summary
CaptionBarStyle EmptyCaptionBarStyle = <wx.lib.foldpanelbar.CaptionBarSt...

Instance Method Details

__init__(self, parent, id, pos, size, caption='', foldIcons=None, cbstyle=<wx.lib.foldpanelbar.CaptionBarStyle instance at 0xb79a09cc>, rightIndent=2, iconWidth=16, iconHeight=16, collapsed=False)
(Constructor)

Default Class Constructor.

Overrides:
wx.Window.__init__

ApplyCaptionStyle(self, cbstyle=<wx.lib.foldpanelbar.CaptionBarStyle instance at 0xb79a09cc>, applyDefault=True)

Applies the style defined in cbstyle to the CaptionBar.

Collapse(self)

This sets the internal state / representation to collapsed.

This does not trigger a CaptionBarEvent to be sent to the parent.

DoGetBestSize(self)

Returns the best size for this panel, based upon the font assigned to this window, and the caption string

DrawHorizontalGradient(self, dc, rect)

Gradient fill from colour 1 to colour 2 with left to right.

DrawSingleColour(self, dc, rect)

Single colour fill. This is the most easy one to find.

DrawSingleRectangle(self, dc, rect)

Single rectangle. This is the most easy one to find.

DrawVerticalGradient(self, dc, rect)

Gradient fill from colour 1 to colour 2 with top to bottom.

Expand(self)

This sets the internal state / representation to expanded.

This does not trigger a CaptionBarEvent to be sent to the parent.

FillCaptionBackground(self, dc)

Fills the background of the caption with either a gradient or a solid color.

GetCaptionStyle(self)

Returns the current style of the captionbar in a CaptionBarStyle class.

This can be used to change and set back the changes.

IsCollapsed(self)

Returns wether the status of the bar is expanded or collapsed.

IsVertical(self)

Returns wether the CaptionBar Has Default Orientation Or Not.

Default is vertical.

OnChar(self, event)

Unused Methods. Any Ideas?!?

OnMouseEvent(self, event)

Catches the mouse click-double click.

If clicked on the arrow (single) or double on the caption we change state and an event must be fired to let this panel collapse or expand.

OnPaint(self, event)

The paint event for flat or gradient fill.

OnSize(self, event)

Handles the size events for the CaptionBar.

RedrawIconBitmap(self)

Redraws the icons (if they exists).

SetBoldFont(self)

Sets the CaptionBarFont weight to BOLD.

SetCaptionStyle(self, cbstyle=<wx.lib.foldpanelbar.CaptionBarStyle instance at 0xb79a09cc>, applyDefault=True)

Sets CaptionBar styles with CapionBarStyle class.

All styles that are actually set, are applied. If you set applyDefault to True, all other (not defined) styles will be set to default. If it is False, the styles which are not set in the CaptionBarStyle will be ignored.

SetNormalFont(self)

Sets the CaptionBarFont weight to NORMAL.

SetRightIndent(self, pixels)

Sets the amount of pixels on the right from which the bitmap is trailing.

If this is 0, it will be drawn all the way to the right, default is equal to FPB_BMP_RIGHTSPACE. Assign this before assigning an image list to prevent a redraw.

Class Variable Details

EmptyCaptionBarStyle

Type:
CaptionBarStyle
Value:
<wx.lib.foldpanelbar.CaptionBarStyle instance at 0xb79a09cc>

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:26 2005 http://epydoc.sf.net


wx.lib.foldpanelbar.CaptionBarEvent

Package wx :: Package lib :: Module foldpanelbar :: Class CaptionBarEvent
[frames | no frames]

Type CaptionBarEvent

object --+
         |
    Object --+
             |
         Event --+
                 |
      CommandEvent --+
                     |
        PyCommandEvent --+
                         |
                        CaptionBarEvent

This event will be sent when a EVT_CAPTIONBAR is mapped in the parent. It is to notify the parent that the bar is now in collapsed or expanded state. The parent should re-arrange the associated windows accordingly

Method Summary
 | __init__(self, evtType) Default Constructor For This Class.
 | GetBar(self) Returns The CaptionBar Selected.
 | GetFoldStatus(self) Returns whether the bar is expanded or collapsed.
 | GetTag(self) Returns The Tag Assigned To The Selected CaptionBar.
 | SetBar(self, bar) Sets the bar associated with this event.
 | SetTag(self, tag) Assign A Tag To The Selected CaptionBar.

Method Details

__init__(self, evtType)
(Constructor)

Default Constructor For This Class.

Overrides:
wx.PyCommandEvent.__init__

GetBar(self)

Returns The CaptionBar Selected.

GetFoldStatus(self)

Returns whether the bar is expanded or collapsed. True means expanded.

GetTag(self)

Returns The Tag Assigned To The Selected CaptionBar.

SetBar(self, bar)

Sets the bar associated with this event.

Should not used by any other then the originator of the event.

SetTag(self, tag)

Assign A Tag To The Selected CaptionBar.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:47 2005 http://epydoc.sf.net


wx.lib.foldpanelbar.CaptionBarStyle

Package wx :: Package lib :: Module foldpanelbar :: Class CaptionBarStyle
[frames | no frames]

Class CaptionBarStyle

This class encapsulates the styles you wish to set for the CaptionBar (this is the part of the FoldPanel where the caption is displayed). It can either be applied at creation time be reapplied when styles need to be changed.

At construction time, all styles are set to their default transparency. This means none of the styles will be applied to the CaptionBar in question, meaning it will be created using the default internals. When setting i.e the color, font or panel style, these styles become active to be used.

Method Summary
 | __init__(self) Default constructor for this class.
 | CaptionColourUsed(self) Checks if the caption colour of the caption bar is set.
 | CaptionFontUsed(self) Checks if the caption bar font is set.
 | CaptionStyleUsed(self) Checks if the caption style of the caption bar is set.
 | FirstColourUsed(self) Checks if the first colour of the caption bar is set.
 | GetCaptionColour(self) Returns the caption colour for the caption bar.
 | GetCaptionFont(self) Returns the font for the caption bar.
 | GetCaptionStyle(self) Returns the caption style for the caption bar.
 | GetFirstColour(self) Returns the first colour for the caption bar.
 | GetSecondColour(self) Returns the second colour for the caption bar.
 | ResetDefaults(self) Resets default CaptionBarStyle.
 | SecondColourUsed(self) Checks if the second colour of the caption bar is set.
 | SetCaptionColour(self, colour) Sets caption colour for the caption bar.
 | SetCaptionFont(self, font) Sets font for the caption bar.
 | SetCaptionStyle(self, style) Sets caption style for the caption bar.
 | SetFirstColour(self, colour) Sets first colour for the caption bar.
 | SetSecondColour(self, colour) Sets second colour for the caption bar.

Method Details

__init__(self)
(Constructor)

Default constructor for this class.

CaptionColourUsed(self)

Checks if the caption colour of the caption bar is set.

CaptionFontUsed(self)

Checks if the caption bar font is set.

CaptionStyleUsed(self)

Checks if the caption style of the caption bar is set.

FirstColourUsed(self)

Checks if the first colour of the caption bar is set.

GetCaptionColour(self)

Returns the caption colour for the caption bar.

Please be warned this will result in an assertion failure when this property is not previously set. See also SetCaptionColour(), CaptionColourUsed()

GetCaptionFont(self)

Returns the font for the caption bar.

Please be warned this will result in an assertion failure when this property is not previously set.

See Also:

SetCaptionFont, CaptionFontUsed

GetCaptionStyle(self)

Returns the caption style for the caption bar.

Please be warned this will result in an assertion failure when this property is not previously set.

See Also:

SetCaptionStyle, CaptionStyleUsed

GetFirstColour(self)

Returns the first colour for the caption bar.

Please be warned this will result in an assertion failure when this property is not previously set.

See Also:

SetFirstColour, FirstColourUsed

GetSecondColour(self)

Returns the second colour for the caption bar.

Please be warned this will result in an assertion failure when this property is not previously set.

See Also:

SetSecondColour, SecondColourUsed

ResetDefaults(self)

Resets default CaptionBarStyle.

SecondColourUsed(self)

Checks if the second colour of the caption bar is set.

SetCaptionColour(self, colour)

Sets caption colour for the caption bar.

If this is not set, the colour property is undefined and will not be used. Use CaptionColourUsed to check if this style is used.

SetCaptionFont(self, font)

Sets font for the caption bar.

If this is not set, the font property is undefined and will not be used. Use CaptionFontUsed to check if this style is used.

SetCaptionStyle(self, style)

Sets caption style for the caption bar.

If this is not set, the property is undefined and will not be used. Use CaptionStyleUsed() to check if this style is used. The following styles can be applied:

  • CAPTIONBAR_GRADIENT_V: Draws a vertical gradient from top to bottom
  • CAPTIONBAR_GRADIENT_H: Draws a horizontal gradient from left to right
  • CAPTIONBAR_SINGLE: Draws a single filled rectangle to draw the caption
  • CAPTIONBAR_RECTANGLE: Draws a single colour with a rectangle around the caption
  • CAPTIONBAR_FILLED_RECTANGLE: Draws a filled rectangle and a border around it

SetFirstColour(self, colour)

Sets first colour for the caption bar.

If this is not set, the colour property is undefined and will not be used. Use FirstColourUsed to check if this style is used.

SetSecondColour(self, colour)

Sets second colour for the caption bar.

If this is not set, the colour property is undefined and will not be used. Use SecondColourUsed to check if this style is used.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:11 2005 http://epydoc.sf.net


wx.lib.foldpanelbar.FoldPanelBar

Package wx :: Package lib :: Module foldpanelbar :: Class FoldPanelBar
[frames | no frames]

Type FoldPanelBar

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
                 Panel --+
                         |
                        FoldPanelBar

The FoldPanelBar is a class which can maintain a list of collapsable panels. Once a panel is collapsed, only it's caption bar is visible to the user. This will provide more space for the other panels, or allow the user to close panels which are not used often to get the most out of the work area.

This control is easy to use. Simply create it as a child for a panel or sash window, and populate panels with AddFoldPanel. Then use the AdddFoldPanelWindow` to add wx.Window derived controls to the current fold panel. Use AddFoldPanelSeparator to put separators between the groups of controls that need a visual separator to group them together. After all is constructed, the user can fold the panels by doubleclicking on the bar or single click on the arrow, which will indicate the collapsed or expanded state.

Method Summary
 | __init__(self, parent, id, pos, size, style, extraStyle) Default Class Constructor.
 | AddFoldPanel(self, caption, collapsed, foldIcons, cbstyle) Adds a fold panel to the list of panels.
 | AddFoldPanelSeparator(self, panel, colour, Spacing, leftSpacing, rightSpacing) Adds a separator line to the current FoldPanel.
 | AddFoldPanelWindow(self, panel, window, flags, Spacing, leftSpacing, rightSpacing) Adds a wx.Window derived instance to the referenced FoldPanel.
 | ApplyCaptionStyle(self, foldpanel, cbstyle) Sets the style of the caption bar (CaptionBar) of the FoldPanel.
 | ApplyCaptionStyleAll(self, cbstyle) Sets the style of all the caption bars of the FoldPanel.
 | Collapse(self, foldpanel) Collapses the given FoldPanel reference, and updates the foldpanel bar.
 | Expand(self, foldpanel) Expands the given FoldPanel reference, and updates the foldpanel bar.
 | GetCaptionStyle(self, foldpanel) Returns the currently used caption style for the FoldPanel.
 | GetCount(self) Returns the number of panels in the FoldPanelBar.
 | GetFoldPanel(self, item) Returns the panel associated with the index "item".
 | GetPanelsLength(self, collapsed, expanded) Returns the length of the panels that are expanded and collapsed.
 | IsVertical(self) Returns whether the CaptionBar has default orientation or not.
 | OnPressCaption(self, event) Handles the EVT_CAPTIONBAR event in the FoldPanelBar.
 | OnSizePanel(self, event) Handles the EVT_SIZE event for the FoldPanelBar.
 | RedisplayFoldPanelItems(self) Resizes the fold panels so they match the width.
 | RefreshPanelsFrom(self, item) Refreshes all the panels from given index down to last one.
 | RepositionCollapsedToBottom(self) Repositions all the collapsed panels to the bottom.

Class Variable Summary
CaptionBarStyle EmptyCaptionBarStyle = <wx.lib.foldpanelbar.CaptionBarSt...

Instance Method Details

__init__(self,
          parent,
          id=-1,
          pos=wx.Point(-1, -1),
          size=wx.Size(-1, -1),
          style=2621440,
          extraStyle=0)
(Constructor)

Default Class Constructor.

Overrides:
wx.Panel.__init__

AddFoldPanel(self,
          caption='',
          collapsed=False,
          foldIcons=None,
          cbstyle=<wx.lib.foldpanelbar.CaptionBarStyle instance at 0xb79a0a2c>)

Adds a fold panel to the list of panels.

If the flag collapsed is set to True, the panel is collapsed initially. The FoldPanel item which is returned, can be used as a reference to perform actions upon the fold panel like collapsing it, expanding it, or deleting it from the list.

Use this foldpanel to add windows to it. Please consult AddFoldPanelWindow and AddFoldPanelSeparator to know how to add items derived from wx.Window to the panels.

AddFoldPanelSeparator(self,
          panel,
          colour=wxPython wrapper for UNBORN object! (The C++ object is no...,
          Spacing=8,
          leftSpacing=2,
          rightSpacing=2)

Adds a separator line to the current FoldPanel.

The seperator is a simple line which is drawn and is no real component. It can be used to separate groups of controls which belong to each other. The colour is adjustable, and it takes the same Spacing, leftSpacing and rightSpacing as AddFoldPanelWindow.

AddFoldPanelWindow(self, panel, window, flags=1, Spacing=8, leftSpacing=2, rightSpacing=2)

Adds a wx.Window derived instance to the referenced FoldPanel.

IMPORTANT: Make the window be a child of the FoldPanel. See example that follows. The flags to be used are:

  • FPB_ALIGN_WIDTH: Which means the wxWindow to be added will be aligned to fit the width of the FoldPanel when it is resized. Very handy for sizer items, buttons and text boxes.
  • FPB_ALIGN_LEFT: Alligns left instead of fitting the width of the child window to be added. Use either this one or FPB_ALIGN_WIDTH.

The wx.Window to be added can be slightly indented from left and right so it is more visibly placed in the FoldPanel. Use Spacing > 0 to give the control an y offset from the previous wx.Window added, use leftSpacing to give it a slight indent from the left, and rightSpacing also reserves a little space on the right so the wxWindow can be properly placed in the FoldPanel.

The following example adds a FoldPanel to the FoldPanelBar and adds two wx.Window derived controls to the FoldPanel:

# create the FoldPanelBar
>>> m_pnl = FoldPanelBar(self, wx.ID_ANY, wx.DefaultPosition,
                         wx.DefaultSize, FPB_DEFAULT_STYLE,
                         FPB_COLLAPSE_TO_BOTTOM)

# add a foldpanel to the control. "Test me" is the caption and it is
# initially not collapsed.
>>> item = m_pnl.AddFoldPanel("Test me", False)

# now add a button to the fold panel. Mind that the button should be
# made child of the FoldPanel and not of the main form.
>>> m_pnl.AddFoldPanelWindow(item, wx.Button(item, ID_COLLAPSEME,
                            "Collapse Me"))

# add a separator between the two controls. This is purely a visual
# line that can have a certain color and also the indents and width
# aligning like a control.
>>> m_pnl.AddFoldPanelSeparator(item)

# now add a text ctrl. Also very easy. Align this on width so that
# when the control gets wider the text control also sizes along.
>>> m_pnl.AddFoldPanelWindow(item, wx.TextCtrl(item, wx.ID_ANY, "Comment"),
                             FPB_ALIGN_WIDTH, FPB_DEFAULT_SPACING, 20)

ApplyCaptionStyle(self, foldpanel, cbstyle)

Sets the style of the caption bar (CaptionBar) of the FoldPanel.

The changes are applied immediately. All styles not set in the CaptionBarStyle class are not applied. Use the CaptionBar reference to indicate what captionbar you want to apply the style to. To apply one style to all CaptionBar items, use ApplyCaptionStyleAll

ApplyCaptionStyleAll(self, cbstyle)

Sets the style of all the caption bars of the FoldPanel.

The changes are applied immediately.

Collapse(self, foldpanel)

Collapses the given FoldPanel reference, and updates the foldpanel bar.

In the FPB_COLLAPSE_TO_BOTTOM style, all collapsed captions are put at the bottom of the control. In the normal mode, they stay where they are.

Expand(self, foldpanel)

Expands the given FoldPanel reference, and updates the foldpanel bar.

In the FPB_COLLAPSE_TO_BOTTOM style, they will be removed from the bottom and the order where the panel originally was placed is restored.

GetCaptionStyle(self, foldpanel)

Returns the currently used caption style for the FoldPanel.

It is returned as a CaptionBarStyle class. After modifying it, it can be set again.

GetCount(self)

Returns the number of panels in the FoldPanelBar.

GetFoldPanel(self, item)

Returns the panel associated with the index "item".

See the example at the bottom of the module, especially the events for the "Collapse Me" and "Expand Me" buttons.

GetPanelsLength(self, collapsed, expanded)

Returns the length of the panels that are expanded and collapsed.

This is useful to determine quickly what size is used to display, and what is left at the bottom (right) to align the collapsed panels.

IsVertical(self)

Returns whether the CaptionBar has default orientation or not.

Default is vertical.

OnPressCaption(self, event)

Handles the EVT_CAPTIONBAR event in the FoldPanelBar.

OnSizePanel(self, event)

Handles the EVT_SIZE event for the FoldPanelBar.

RedisplayFoldPanelItems(self)

Resizes the fold panels so they match the width.

RefreshPanelsFrom(self, item)

Refreshes all the panels from given index down to last one.

RepositionCollapsedToBottom(self)

Repositions all the collapsed panels to the bottom.

When it is not possible to align them to the bottom, stick them behind the visible panels. The Rect holds the slack area left between last repositioned panel and the bottom panels. This needs to get a refresh.

Class Variable Details

EmptyCaptionBarStyle

Type:
CaptionBarStyle
Value:
<wx.lib.foldpanelbar.CaptionBarStyle instance at 0xb79a0a2c>

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:17 2005 http://epydoc.sf.net


wx.lib.foldpanelbar.FoldPanelItem

Package wx :: Package lib :: Module foldpanelbar :: Class FoldPanelItem
[frames | no frames]

Type FoldPanelItem

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
                 Panel --+
                         |
                        FoldPanelItem

This class is a child sibling of the FoldPanelBar class. It will contain a CaptionBar class for receiving of events, and a the rest of the area can be populated by a wx.Panel derived class.

Method Summary
 | __init__(self, parent, id, caption, foldIcons, collapsed, cbstyle) Default Class Constructor.
 | AddSeparator(self, colour, Spacing, leftSpacing, rightSpacing) Adds a separator item to the list of items on this panel.
 | AddWindow(self, window, flags, Spacing, leftSpacing, rightSpacing) Adds a window item to the list of items on this panel.
 | ApplyCaptionStyle(self, cbstyle) Applies the style defined in cbstyle to the CaptionBar.
 | Collapse(self)
 | Expand(self)
 | GetCaptionLength(self) Returns height of caption only.
 | GetCaptionStyle(self) Returns the current style of the captionbar in a CaptionBarStyle class.
 | GetItemPos(self) Returns item's position.
 | GetPanelLength(self) Returns size of panel.
 | IsExpanded(self) Returns expanded or collapsed status.
 | IsVertical(self) Returns wether the CaptionBar Has Default Orientation Or Not.
 | OnPaint(self, event) Handles the EVT_PAINT event in the FoldPanelItem.
 | OnPressCaption(self, event) Handles the EVT_CAPTIONBAR event in the FoldPanelItem.
 | Reposition(self, pos) Repositions this FoldPanelBar and reports the length occupied for the next FoldPanelBar in the list.
 | ResizePanel(self) Resizes the panel.

Class Variable Summary
CaptionBarStyle EmptyCaptionBarStyle = <wx.lib.foldpanelbar.CaptionBarSt...

Instance Method Details

__init__(self,
          parent,
          id=-1,
          caption='',
          foldIcons=None,
          collapsed=False,
          cbstyle=<wx.lib.foldpanelbar.CaptionBarStyle instance at 0xb79a0a6c>)
(Constructor)

Default Class Constructor.

Overrides:
wx.Panel.__init__

AddSeparator(self,
          colour=wxPython wrapper for UNBORN object! (The C++ object is no...,
          Spacing=8,
          leftSpacing=5,
          rightSpacing=10)

Adds a separator item to the list of items on this panel.

AddWindow(self,
          window,
          flags=1,
          Spacing=8,
          leftSpacing=2,
          rightSpacing=2)

Adds a window item to the list of items on this panel.

The flags are FPB_ALIGN_LEFT for a non sizing window element, and FPB_ALIGN_WIDTH for a width aligned item. The Spacing parameter reserves a number of pixels before the window element, and leftSpacing is an indent. rightSpacing is only relevant when the style FPB_ALIGN_WIDTH is chosen.

ApplyCaptionStyle(self, cbstyle)

Applies the style defined in cbstyle to the CaptionBar.

GetCaptionLength(self)

Returns height of caption only. This is for folding calculation purposes.

GetCaptionStyle(self)

Returns the current style of the captionbar in a CaptionBarStyle class.

This can be used to change and set back the changes.

GetItemPos(self)

Returns item's position.

GetPanelLength(self)

Returns size of panel.

IsExpanded(self)

Returns expanded or collapsed status. If the panel is expanded, True is returned.

IsVertical(self)

Returns wether the CaptionBar Has Default Orientation Or Not.

Default is vertical.

OnPaint(self, event)

Handles the EVT_PAINT event in the FoldPanelItem.

OnPressCaption(self, event)

Handles the EVT_CAPTIONBAR event in the FoldPanelItem.

Reposition(self, pos)

Repositions this FoldPanelBar and reports the length occupied for the next FoldPanelBar in the list.

ResizePanel(self)

Resizes the panel.

Class Variable Details

EmptyCaptionBarStyle

Type:
CaptionBarStyle
Value:
<wx.lib.foldpanelbar.CaptionBarStyle instance at 0xb79a0a6c>

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:39 2005 http://epydoc.sf.net


wx.lib.foldpanelbar.FoldWindowItem

Package wx :: Package lib :: Module foldpanelbar :: Class FoldWindowItem
[frames | no frames]

Class FoldWindowItem

This class is a child sibling of the FoldPanelItem class. It will contain wx.Window that can be either a separator (a colored line simulated by a wx.Window) or a wxPython controls (such as a wx.Button, a wx.ListCtrl etc...).

Method Summary
 | __init__(self, parent, window, **kw) Default Class Constructor
 | GetLeftSpacing(self)
 | GetLineColour(self)
 | GetLineLength(self)
 | GetLineY(self)
 | GetRightSpacing(self)
 | GetSpacing(self)
 | GetType(self)
 | GetWindowLength(self, vertical) Returns space needed by the window if type is FoldWindowItem "WINDOW" and returns the total size plus the extra spacing.
 | ResizeItem(self, size, vertical) Resizes the element, whatever it is.

Method Details

__init__(self, parent, window=None, **kw)
(Constructor)

Default Class Constructor

Initialize with:

Type = "WINDOW", flags = FPB_ALIGN_WIDTH,
Spacing = FPB_DEFAULT_SPACING,
leftSpacing = FPB_DEFAULT_LEFTSPACING,
rightSpacing = FPB_DEFAULT_RIGHTSPACING

or:

Type = "SEPARATOR"
y, lineColor = wx.BLACK,
flags = FPB_ALIGN_WIDTH,
Spacing = FPB_DEFAULT_SPACING,
leftSpacing = FPB_DEFAULT_LEFTLINESPACING,
rightSpacing = FPB_DEFAULT_RIGHTLINESPACING

GetWindowLength(self, vertical=True)

Returns space needed by the window if type is FoldWindowItem "WINDOW" and returns the total size plus the extra spacing.

ResizeItem(self, size, vertical=True)

Resizes the element, whatever it is.

A separator or line will be always aligned by width or height depending on orientation of the whole panel.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:09 2005 http://epydoc.sf.net


wx.lib.foldpanelbar

Package wx :: Package lib :: Module foldpanelbar

Module wx.lib.foldpanelbar

The FoldPanelBar is a control that contains multiple panels (of type FoldPanelItem) that can be expanded or collapsed. The captionbar of the FoldPanel can be customized by setting it to a horizontal gradient style, vertical gradient style, a single color, a rectangle or filled rectangle. The FoldPanel items can be collapsed in place or to the bottom of the control. wx.Window derived controls can be added dynamically, and separated by separator lines. FoldPanelBar is freeware and distributed under the wxPython license.

How does it work

The internals of the FoldPanelBar is a list of FoldPanelItem objects. Through the reference of FoldPanel these panels can be controlled by adding new controls to a FoldPanel or adding new FoldPanels to the FoldPanelBar. The CaptionBar fires events to the parent (container of all panel items) when a sub-panel needs resizing (either folding or expanding). The fold or expand process is simply a resize of the panel so it looks like all controls on it are gone. All controls are still child of the FoldPanel they are located on. If they don't handle the event (and they won't) then the owner of the FoldPanelBar gets the events. This is what you need to handle the controls. There isn't much to it just a lot of calculations to see what panel belongs where. There are no sizers involved in the panels, everything is purely x-y positioning.

What can it do and what not?

  1. What it can do:
    • Run-time addition of panels (no deletion just yet)
    • Run time addition of controls to the panel (it will be resized accordingly)
    • Creating panels in collapsed mode or expanded mode
    • Various modes of caption behaviour and filling to make it more appealing
    • Panels can be folded and collapsed (or all of them) to allow more space

  2. What it cannot do:

    • Selection of a panel like in a list ctrl
    • Dragging and dropping the panels
    • Re-ordering the panels (not yet)

Supported platforms

FoldPanelBar is supported on the following platforms:
  • Windows (Verified on Windows XP, 2000)
  • Linux/Unix (GTK2) (Thanks To Toni Brkic And Robin Dunn)
  • Mac OSX (Thanks To Robin Dunn For The CaptionBar Size Patch)

Latest Revision: Andrea Gavana @ 30 Mar 2005, 22.30 CET

Classes
CaptionBar | This class is a graphical caption component that consists of a caption and a clickable arrow.
CaptionBarEvent | This event will be sent when a EVT_CAPTIONBAR is mapped in the parent.
CaptionBarStyle | This class encapsulates the styles you wish to set for the CaptionBar (this is the part of the FoldPanel where the caption is displayed).
FoldPanelBar | The FoldPanelBar is a class which can maintain a list of collapsable panels.
FoldPanelItem | This class is a child sibling of the FoldPanelBar class.
FoldWindowItem | This class is a child sibling of the FoldPanelItem class.

Function Summary
 | GetCollapsedIconBitmap()
 | GetCollapsedIconData()
 | GetCollapsedIconImage()
 | GetExpandedIconBitmap()
 | GetExpandedIconData()
 | GetExpandedIconImage()

Variable Summary
int | CAPTIONBAR_FILLED_RECTANGLE = 5
int | CAPTIONBAR_GRADIENT_H = 2
int | CAPTIONBAR_GRADIENT_V = 1
int | CAPTIONBAR_NOSTYLE = 0
int | CAPTIONBAR_RECTANGLE = 4
int | CAPTIONBAR_SINGLE = 3
PyEventBinder | EVT_CAPTIONBAR = <wx._core.PyEventBinder object at 0xb79...
int | FPB_ALIGN_LEFT = 0
int | FPB_ALIGN_WIDTH = 1
int | FPB_BMP_RIGHTSPACE = 2
int | FPB_COLLAPSE_TO_BOTTOM = 2
int | FPB_DEFAULT_EXTRASTYLE = 0
int | FPB_DEFAULT_LEFTLINESPACING = 2
int | FPB_DEFAULT_LEFTSPACING = 5
int | FPB_DEFAULT_RIGHTLINESPACING = 2
int | FPB_DEFAULT_RIGHTSPACING = 10
int | FPB_DEFAULT_SPACING = 8
int | FPB_DEFAULT_STYLE = 2621440
int | FPB_EXCLUSIVE_FOLD = 3
int | FPB_EXTRA_X = 10
int | FPB_EXTRA_Y = 4
int | FPB_HORIZONTAL = 4
int | FPB_SINGLE_FOLD = 1
int | FPB_VERTICAL = 8
int | wxEVT_CAPTIONBAR = 10271

Variable Details

CAPTIONBAR_FILLED_RECTANGLE

Type:
int
Value:
5

CAPTIONBAR_GRADIENT_H

Type:
int
Value:
2

CAPTIONBAR_GRADIENT_V

Type:
int
Value:
1

CAPTIONBAR_NOSTYLE

Type:
int
Value:
0

CAPTIONBAR_RECTANGLE

Type:
int
Value:
4

CAPTIONBAR_SINGLE

Type:
int
Value:
3

EVT_CAPTIONBAR

Type:
PyEventBinder
Value:
<wx._core.PyEventBinder object at 0xb79a096c>

FPB_ALIGN_LEFT

Type:
int
Value:
0

FPB_ALIGN_WIDTH

Type:
int
Value:
1

FPB_BMP_RIGHTSPACE

Type:
int
Value:
2

FPB_COLLAPSE_TO_BOTTOM

Type:
int
Value:
2

FPB_DEFAULT_EXTRASTYLE

Type:
int
Value:
0

FPB_DEFAULT_LEFTLINESPACING

Type:
int
Value:
2

FPB_DEFAULT_LEFTSPACING

Type:
int
Value:
5

FPB_DEFAULT_RIGHTLINESPACING

Type:
int
Value:
2

FPB_DEFAULT_RIGHTSPACING

Type:
int
Value:
10

FPB_DEFAULT_SPACING

Type:
int
Value:
8

FPB_DEFAULT_STYLE

Type:
int
Value:
2621440

FPB_EXCLUSIVE_FOLD

Type:
int
Value:
3

FPB_EXTRA_X

Type:
int
Value:
10

FPB_EXTRA_Y

Type:
int
Value:
4

FPB_HORIZONTAL

Type:
int
Value:
4

FPB_SINGLE_FOLD

Type:
int
Value:
1

FPB_VERTICAL

Type:
int
Value:
8

wxEVT_CAPTIONBAR

Type:
int
Value:
10271

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:10:44 2005 http://epydoc.sf.net


wx.lib.gestures.MouseGestures

Package wx :: Package lib :: Module gestures :: Class MouseGestures
[frames | no frames]

Class MouseGestures

Method Summary
 | __init__(self, parent, Auto, MouseButton)
 | AddGesture(self, gesture, action, *args) Registers a gesture, and an associated function, with any arguments needed.
 | DoAction(self, gesture) If the gesture is in the array of registered gestures, run the associated function.
 | End(self) Stops recording the points to create the mouse gesture from, and creates the mouse gesture, returns the result as a string.
 | GetDirection(self, point1, point2) Gets the direction between two points.
 | GetRecording(self) Returns whether or not Gesture Recording has started.
 | OnMotion(self, event) Internal.
 | OnMouseEvent(self, event) Internal.
 | RemoveGesture(self, gesture) Removes a gesture, and its associated action
 | SetAuto(self, auto) Warning: Once auto is set, it stays set, unless you manually use UnBind
 | SetGesturePen(self, colour, width) Sets the colour and width of the line drawn to visually represent each gesture
 | SetGesturesVisible(self, vis) Sets whether a line is drawn to visually represent each gesture
 | SetModifiers(self, modifiers) Takes an array of wx Key constants (Control, Shift, and/or Alt).
 | SetMouseButton(self, mousebutton) Takes the wx constant for the target mousebutton
 | SetWobbleTolerance(self, wobbletolerance) Sets just how much wobble this class can take!
 | Start(self) Starts recording the points to create the mouse gesture from

Method Details

AddGesture(self, gesture, action, *args)

Registers a gesture, and an associated function, with any arguments needed.

DoAction(self, gesture)

If the gesture is in the array of registered gestures, run the associated function.

End(self)

Stops recording the points to create the mouse gesture from, and creates the mouse gesture, returns the result as a string.

GetDirection(self, point1, point2)

Gets the direction between two points.

GetRecording(self)

Returns whether or not Gesture Recording has started.

OnMotion(self, event)

Internal. Used if Start() has been run

OnMouseEvent(self, event)

Internal. Used in Auto Mode.

RemoveGesture(self, gesture)

Removes a gesture, and its associated action

SetAuto(self, auto)

Warning: Once auto is set, it stays set, unless you manually use UnBind

SetGesturePen(self, colour, width)

Sets the colour and width of the line drawn to visually represent each gesture

SetGesturesVisible(self, vis)

Sets whether a line is drawn to visually represent each gesture

SetModifiers(self, modifiers=[])

Takes an array of wx Key constants (Control, Shift, and/or Alt). Leave empty to unset all modifiers.

SetMouseButton(self, mousebutton)

Takes the wx constant for the target mousebutton

SetWobbleTolerance(self, wobbletolerance)

Sets just how much wobble this class can take!

Start(self)

Starts recording the points to create the mouse gesture from

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:10:47 2005 http://epydoc.sf.net


wx.lib.gestures

Package wx :: Package lib :: Module gestures

Module wx.lib.gestures

This is a class to add Mouse Gestures to a program.
It can be used in two ways:

1.  Automatic:
    Automatically runs mouse gestures.
    You need to set the gestures, and their associated actions,
    as well as the Mouse Button/Modifiers to use.

2.  Manual:
    Same as above, but you do not need to set the mouse button/modifiers.
    You can launch this from events as you wish.

An example is provided in the demo.
The parent window is where the mouse events will be recorded.
(So if you want to record them in a pop up window, use manual mode,
and set the pop up as the parent).

Start() starts recording mouse movement.
End() stops the recording, compiles all the gestures into a list,
and looks through the registered gestures to find a match.
The first matchs associated    action is then run.

The marginoferror is how much to forgive when calculating movement:
If the margin is 25, then movement less than 25 pixels will not be detected.

Recognized:  L, R, U, D, 1, 3, 7, 9

Styles:  Manual (Automatic By Default), DisplayNumbersForDiagonals (Off By Default).
Not Yet Implemented

The criteria for a direction is as follows:
x in a row.  (Where x is the WobbleTolerance).
So if the WobbleTolerance is 9
 'URUUUUUUUUUUUUUUURUURUUUU1' is Up.

The higher this number, the less sensitive this class is.
So the more likely something like 1L will translate to 1.

This is good, since the mouse does tend to wobble somewhat,
and a higher number allows for this.

To change this, use SetWobbleTolerance

Also, to help with recognition of a diagonal versus
a vey messy straight line, if the greater absolute value
is not greater than twice the lesser, only the grater value
is counted.

In automatic mode, EVT_MOUSE_EVENTS is used.
This allows the user to change the mouse button/modifiers at runtime.
Classes
MouseGestures

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:10:49 2005 http://epydoc.sf.net


wx.lib.gridmovers.ColDragWindow

Package wx :: Package lib :: Module gridmovers :: Class ColDragWindow
[frames | no frames]

Type ColDragWindow

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
                    ColDragWindow

Method Summary
 | __init__(self, parent, image, dragCol)
 | DisplayAt(self, pos, y)
 | GetInsertionColumn(self)
 | GetInsertionPos(self)
 | GetMoveColumn(self)
 | OnPaint(self, evt)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:01 2005 http://epydoc.sf.net


wx.lib.gridmovers.GridColMoveEvent

Package wx :: Package lib :: Module gridmovers :: Class GridColMoveEvent
[frames | no frames]

Type GridColMoveEvent

object --+
         |
    Object --+
             |
         Event --+
                 |
      CommandEvent --+
                     |
        PyCommandEvent --+
                         |
                        GridColMoveEvent

Method Summary
 | __init__(self, id, dCol, bCol)
 | GetBeforeColumn(self)
 | GetMoveColumn(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:10:54 2005 http://epydoc.sf.net


wx.lib.gridmovers.GridColMover

Package wx :: Package lib :: Module gridmovers :: Class GridColMover
[frames | no frames]

Type GridColMover

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
                GridColMover

Method Summary
 | __init__(self, grid)
 | OnMouseMove(self, evt)
 | OnPress(self, evt)
 | OnRelease(self, evt)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:16 2005 http://epydoc.sf.net


wx.lib.gridmovers.GridRowMoveEvent

Package wx :: Package lib :: Module gridmovers :: Class GridRowMoveEvent
[frames | no frames]

Type GridRowMoveEvent

object --+
         |
    Object --+
             |
         Event --+
                 |
      CommandEvent --+
                     |
        PyCommandEvent --+
                         |
                        GridRowMoveEvent

Method Summary
 | __init__(self, id, dRow, bRow)
 | GetBeforeRow(self)
 | GetMoveRow(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:02 2005 http://epydoc.sf.net


wx.lib.gridmovers.GridRowMover

Package wx :: Package lib :: Module gridmovers :: Class GridRowMover
[frames | no frames]

Type GridRowMover

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
                GridRowMover

Method Summary
 | __init__(self, grid)
 | OnMouseMove(self, evt)
 | OnPress(self, evt)
 | OnRelease(self, evt)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:12 2005 http://epydoc.sf.net


wx.lib.gridmovers.RowDragWindow

Package wx :: Package lib :: Module gridmovers :: Class RowDragWindow
[frames | no frames]

Type RowDragWindow

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
                    RowDragWindow

Method Summary
 | __init__(self, parent, image, dragRow)
 | DisplayAt(self, x, pos)
 | GetInsertionPos(self)
 | GetInsertionRow(self)
 | GetMoveRow(self)
 | OnPaint(self, evt)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:51 2005 http://epydoc.sf.net


wx.lib.gridmovers

Package wx :: Package lib :: Module gridmovers

Module wx.lib.gridmovers

Classes
ColDragWindow
GridColMoveEvent
GridColMover
GridRowMoveEvent
GridRowMover
RowDragWindow

Variable Summary
PyEventBinder | EVT_GRID_COL_MOVE = <wx._core.PyEventBinder object at 0x...
PyEventBinder | EVT_GRID_ROW_MOVE = <wx._core.PyEventBinder object at 0x...
int | wxEVT_COMMAND_GRID_COL_MOVE = 10272
int | wxEVT_COMMAND_GRID_ROW_MOVE = 10273

Variable Details

EVT_GRID_COL_MOVE

Type:
PyEventBinder
Value:
<wx._core.PyEventBinder object at 0xb79a6cac>

EVT_GRID_ROW_MOVE

Type:
PyEventBinder
Value:
<wx._core.PyEventBinder object at 0xb79a6cec>

wxEVT_COMMAND_GRID_COL_MOVE

Type:
int
Value:
10272

wxEVT_COMMAND_GRID_ROW_MOVE

Type:
int
Value:
10273

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:16 2005 http://epydoc.sf.net


wx.lib.grids.PyFlexGridSizer

Package wx :: Package lib :: Module grids :: Class PyFlexGridSizer
[frames | no frames]

Type PyFlexGridSizer

object --+
         |
    Object --+
             |
         Sizer --+
                 |
           PySizer --+
                     |
           PyGridSizer --+
                         |
                        PyFlexGridSizer

Method Summary
 | __init__(self, rows, cols, hgap, vgap)
 | AddGrowableCol(self, idx)
 | AddGrowableRow(self, idx)
 | CalcMin(self)
 | RecalcSizes(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:16 2005 http://epydoc.sf.net


wx.lib.grids.PyGridSizer

Package wx :: Package lib :: Module grids :: Class PyGridSizer
[frames | no frames]

Type PyGridSizer

object --+
         |
    Object --+
             |
         Sizer --+
                 |
           PySizer --+
                     |
                    PyGridSizer

Known Subclasses:
PyFlexGridSizer
Method Summary
 | __init__(self, rows, cols, hgap, vgap)
 | CalcMin(self)
 | GetColumns(self)
 | GetHgap(self, hgap)
 | GetRows(self)
 | GetVgap(self, vgap)
 | RecalcSizes(self)
 | SetColumns(self, cols)
 | SetHgap(self, hgap)
 | SetItemBounds(self, item, x, y, w, h)
 | SetRows(self, rows)
 | SetVgap(self, vgap)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:09 2005 http://epydoc.sf.net


wx.lib.grids

Package wx :: Package lib :: Module grids

Module wx.lib.grids

In this module you will find PyGridSizer and PyFlexGridSizer. Please note that these sizers have since been ported to C++ (as wx.GridSizer and wx.FlexGridSizer) and those versions are now exposed in the regular wxPython wrappers. However I am also leaving them here in the library so they can serve as an example of how to implement sizers in Python.

PyGridSizer: Sizes and positions items such that all rows are the same height and all columns are the same width. You can specify a gap in pixels to be used between the rows and/or the columns. When you create the sizer you specify the number of rows or the number of columns and then as you add items it figures out the other dimension automatically. Like other sizers, items can be set to fill their available space, or to be aligned on a side, in a corner, or in the center of the space. When the sizer is resized, all the items are resized the same amount so all rows and all columns remain the same size.

PyFlexGridSizer: Derives from PyGridSizer and adds the ability for particular rows and/or columns to be marked as growable. This means that when the sizer changes size, the growable rows and colums are the ones that stretch. The others remain at their initial size.

Classes
PyFlexGridSizer
PyGridSizer

Variable Summary
str warningmsg = '\\\n\n####################################...

Variable Details

warningmsg

Type:
str
Value:
'''\\

################################################\\
# THIS MODULE IS DEPRECATED                     |
#                                               |
# You should use the native wx.GridSizer and    |
# wx.FlexGridSizer unless there is a compelling |
# need to use this module.                      |
...

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:12 2005 http://epydoc.sf.net


wx.lib.hyperlink.HyperLinkCtrl

Package wx :: Package lib :: Module hyperlink :: Class HyperLinkCtrl
[frames | no frames]

Type HyperLinkCtrl

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
               Control --+
                         |
                 PyControl --+
                             |
                 GenStaticText --+
                                 |
                                HyperLinkCtrl

HyperLinkCtrl is a control for wxPython that acts like a hyper link in a typical browser. Latest features include the ability to capture your own Left, Middle, and Right click events to perform your own custom event handling and ability to open link in a new or current browser window.

Events

EVT_HYPERLINK_LEFT | Sent when the left mouse button is clicked, but only if AutoBrowse is set to False.
EVT_HYPERLINK_MIDDLE | Sent when the middle mouse button is clicked.
EVT_HYPERLINK_RIGHT | Sent when the right mouse button is clicked, but only if DoPopup is set to False.
Method Summary
 | __init__(self, parent, id, label, pos, size, style, name, URL) Default class constructor.
 | AutoBrowse(self, AutoBrowse) Automatically browse to URL when clicked.
 | DisplayError(self, ErrorMessage, ReportErrors) Displays an error message (according to ReportErrors variable) in a MessageBox.
 | DoPopup(self, DoPopup) Sets whether to show popup menu on right click or not.
 | EnableRollover(self, EnableRollover) Enable/disable rollover.
 | GetBold(self) Returns whether the HyperLink has text in bold or not.
 | GetColours(self) Gets the colours for the link, the visited link and the mouse rollover.
 | GetLinkCursor(self) Gets the link cursor.
 | GetUnderlines(self) Returns if link is underlined, if the mouse rollover is underlined and if the visited link is underlined.
 | GetURL(self) Retrieve the URL associated to the HyperLink.
 | GetVisited(self) Returns whether a link has been visited or not.
 | GotoURL(self, URL, ReportErrors, NotSameWinIfPossible) Goto The Specified URL.
 | OnMouseEvent(self, event) Captures mouse events for cursor, link colors and underlines.
 | OnPopUpCopy(self, event) Copy data from the HyperLink to the clipboard.
 | OpenInSameWindow(self, NotSameWinIfPossible) Open multiple URL in the same window (if possible).
 | ReportErrors(self, ReportErrors) Set whether to report browser errors or not.
 | SetBold(self, Bold) Sets the HyperLink in bold text.
 | SetColours(self, link, visited, rollover) Sets the colours for the link, the visited link and the mouse rollover.
 | SetLinkCursor(self, cur) Sets link cursor properties.
 | SetUnderlines(self, link, visited, rollover) Underlines Properties.
 | SetURL(self, URL) Sets the HyperLink text to the specified URL.
 | SetVisited(self, Visited) Sets a link as visited.
 | UpdateLink(self, OnRefresh) Updates the link.

Class Variable Summary

Instance Method Details

__init__(self,
          parent,
          id=-1,
          label='',
          pos=wx.Point(-1, -1),
          size=wx.Size(-1, -1),
          style=0,
          name='staticText',
          URL='')
(Constructor)

Default class constructor.

Pass URL == "" to use the label as the url link to navigate to

Overrides:
wx.lib.stattext.GenStaticText.__init__

AutoBrowse(self, AutoBrowse=True)

Automatically browse to URL when clicked. set to False to receive EVT_HYPERLINK_LEFT event.

DisplayError(self, ErrorMessage, ReportErrors=True)

Displays an error message (according to ReportErrors variable) in a MessageBox.

DoPopup(self, DoPopup=True)

Sets whether to show popup menu on right click or not.

EnableRollover(self, EnableRollover=False)

Enable/disable rollover.

GetBold(self)

Returns whether the HyperLink has text in bold or not.

GetColours(self)

Gets the colours for the link, the visited link and the mouse rollover.

GetLinkCursor(self)

Gets the link cursor.

GetUnderlines(self)

Returns if link is underlined, if the mouse rollover is underlined and if the visited link is underlined.

GetURL(self)

Retrieve the URL associated to the HyperLink.

GetVisited(self)

Returns whether a link has been visited or not.

GotoURL(self, URL, ReportErrors=True, NotSameWinIfPossible=False)

Goto The Specified URL.

Parameters:
ReportErrors - Use True to display error dialog if an error occurrs navigating to the URL.

NotSameWinIfPossible - Use True to attempt to open the URL in new browser window.

OnMouseEvent(self, event)

Captures mouse events for cursor, link colors and underlines.

OnPopUpCopy(self, event)

Copy data from the HyperLink to the clipboard.

OpenInSameWindow(self, NotSameWinIfPossible=False)

Open multiple URL in the same window (if possible).

ReportErrors(self, ReportErrors=True)

Set whether to report browser errors or not.

SetBold(self, Bold=False)

Sets the HyperLink in bold text.

SetColours(self,
          link=wx.Colour(0, 0, 255),
          visited=wx.Colour(79, 47, 79),
          rollover=wx.Colour(0, 0, 255))

Sets the colours for the link, the visited link and the mouse rollover.

Defaults Are:
  • New Link: RED
  • Visited Link: VIOLET
  • Rollover: BLUE

SetLinkCursor(self, cur=6)

Sets link cursor properties.

SetUnderlines(self,
          link=True,
          visited=True,
          rollover=True)

Underlines Properties.

SetURL(self, URL)

Sets the HyperLink text to the specified URL.

SetVisited(self, Visited=False)

Sets a link as visited.

UpdateLink(self, OnRefresh=True)

Updates the link.

Changing text properties if:
  • User Specific Setting
  • Link Visited
  • New Link

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:01 2005 http://epydoc.sf.net


wx.lib.hyperlink.HyperLinkEvent

Package wx :: Package lib :: Module hyperlink :: Class HyperLinkEvent
[frames | no frames]

Type HyperLinkEvent

object --+
         |
    Object --+
             |
         Event --+
                 |
      CommandEvent --+
                     |
        PyCommandEvent --+
                         |
                        HyperLinkEvent

Event object sent in response to clicking on a HyperLinkCtrl.

Method Summary
 | __init__(self, eventType, id) Default Class Constructor.
 | GetPosition(self) Returns Event Position
 | SetPosition(self, pos) Sets Event Position

Method Details

__init__(self, eventType, id)
(Constructor)

Default Class Constructor.

Overrides:
wx.PyCommandEvent.__init__

GetPosition(self)

Returns Event Position

SetPosition(self, pos)

Sets Event Position

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:25 2005 http://epydoc.sf.net


wx.lib.hyperlink

Package wx :: Package lib :: Module hyperlink

Module wx.lib.hyperlink

HyperLinkCtrl is a control for wxPython that acts like a hyper link in a typical browser. Latest features include the ability to capture your own Left, Middle, and Right click events to perform your own custom event handling and ability to open link in a new or current browser window.

Special thanks to Robin Dunn for the event binder for the 3 mouse buttons.

Latest Revision: Andrea Gavana @ 11 May 2005, 21.00 CET

Classes
HyperLinkCtrl | HyperLinkCtrl is a control for wxPython that acts like a hyper link in a typical browser.
HyperLinkEvent | Event object sent in response to clicking on a HyperLinkCtrl.

Variable Summary
PyEventBinder | EVT_HYPERLINK_LEFT = <wx._core.PyEventBinder object at 0...
PyEventBinder | EVT_HYPERLINK_MIDDLE = <wx._core.PyEventBinder object at...
PyEventBinder | EVT_HYPERLINK_RIGHT = <wx._core.PyEventBinder object at ...
int | wxEVT_HYPERLINK_LEFT = 10274
int | wxEVT_HYPERLINK_MIDDLE = 10275
int | wxEVT_HYPERLINK_RIGHT = 10276
int | wxHYPERLINKS_POPUP_COPY = 1000

Variable Details

EVT_HYPERLINK_LEFT

Type:
PyEventBinder
Value:
<wx._core.PyEventBinder object at 0xb79ae1ec>

EVT_HYPERLINK_MIDDLE

Type:
PyEventBinder
Value:
<wx._core.PyEventBinder object at 0xb79ae18c>

EVT_HYPERLINK_RIGHT

Type:
PyEventBinder
Value:
<wx._core.PyEventBinder object at 0xb79ae48c>

wxEVT_HYPERLINK_LEFT

Type:
int
Value:
10274

wxEVT_HYPERLINK_MIDDLE

Type:
int
Value:
10275

wxEVT_HYPERLINK_RIGHT

Type:
int
Value:
10276

wxHYPERLINKS_POPUP_COPY

Type:
int
Value:
1000

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:10:54 2005 http://epydoc.sf.net


wx.lib.imagebrowser.FindFiles

Package wx :: Package lib :: Module imagebrowser :: Class FindFiles
[frames | no frames]

Class FindFiles

Method Summary
 | __init__(self, parent, dir, mask)
 | MakeRegex(self, pattern)
 | StripExt(self, file_nm)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:27 2005 http://epydoc.sf.net


wx.lib.imagebrowser.ImageDialog

Package wx :: Package lib :: Module imagebrowser :: Class ImageDialog
[frames | no frames]

Type ImageDialog

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
        TopLevelWindow --+
                         |
                    Dialog --+
                             |
                            ImageDialog

Method Summary
 | __init__(self, parent, set_dir)
 | DisplayDir(self)
 | GetDirectory(self)
 | GetFile(self)
 | GetFiles(self)
 | OnCancel(self, event)
 | OnListClick(self, event)
 | OnListDClick(self, event)
 | OnOk(self, event)
 | OnSetType(self, event)
 | ResetFiles(self)
 | SetDirect(self, event)
 | SetListValue(self, val)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:10:47 2005 http://epydoc.sf.net


wx.lib.imagebrowser.ImageView

Package wx :: Package lib :: Module imagebrowser :: Class ImageView
[frames | no frames]

Type ImageView

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
                    ImageView

Method Summary
 | __init__(self, parent, id, pos, size)
 | DrawBorder(self, dc)
 | DrawImage(self, dc)
 | OnPaint(self, event)
 | SetValue(self, file_nm)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:09 2005 http://epydoc.sf.net


wx.lib.imagebrowser

Package wx :: Package lib :: Module imagebrowser

Module wx.lib.imagebrowser

Classes
FindFiles
ImageDialog
ImageView

Function Summary
 | ConvertBMP(file_nm)
 | GetSize(file_nm)
 | OnFileDlg(self)

Variable Summary
str dir_path = '/home/work/projects/wx2.6/wxPython'

Variable Details

dir_path

Type:
str
Value:
'/home/work/projects/wx2.6/wxPython'

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:12 2005 http://epydoc.sf.net


wx.lib.imageutils

Package wx :: Package lib :: Module imageutils

Module wx.lib.imageutils

Function Summary
 | grayOut(anImage) Convert the given image (in place) to a grayed-out version, appropriate for a 'disabled' appearance.
 | makeGray((r, g, b), factor, maskColor) Make a pixel grayed-out.

Function Details

grayOut(anImage)

Convert the given image (in place) to a grayed-out version, appropriate for a 'disabled' appearance.

makeGray((r, g, b), factor, maskColor)

Make a pixel grayed-out. If the pixel matches the maskColor, it won't be changed.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:08 2005 http://epydoc.sf.net


wx.lib.infoframe.Dummy_PyInformationalMessagesFrame

Package wx :: Package lib :: Module infoframe :: Class Dummy_PyInformationalMessagesFrame
[frames | no frames]

Class Dummy_PyInformationalMessagesFrame

Method Summary
 | __init__(self, progname)
 | __call__(self, *args)
 | close(self)
 | DisableOutput(self, exiting)
 | EnableOutput(self)
 | flush(self)
 | SetParent(self, wX)
 | write(self, s)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:48 2005 http://epydoc.sf.net


wx.lib.infoframe.PyInformationalMessagesFrame

Package wx :: Package lib :: Module infoframe :: Class PyInformationalMessagesFrame
[frames | no frames]

Class PyInformationalMessagesFrame

Method Summary
 | __init__(self, progname, text, dir, menuname, enableitem, disableitem, othermenubar)
 | __call__(self, *args)
 | close(self)
 | CloseFile(self)
 | DisableOutput(self, event, exiting)
 | EnableOutput(self, event, othermenubar, menuname, enableitem, disableitem)
 | flush(self)
 | OnCloseWindow(self, event, exiting)
 | OpenNewFile(self)
 | SetOtherMenuBar(self, othermenu, menuname, enableitem, disableitem)
 | SetOutputDirectory(self, dir)
 | SetParent(self, parent)
 | write(self, string)

Class Variable Summary
int | Enabled = 1
NoneType | f = None

Class Variable Details

Enabled

Type:
int
Value:
1

f

Type:
NoneType
Value:
None

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:23 2005 http://epydoc.sf.net


wx.lib.infoframe

Package wx :: Package lib :: Module infoframe

Module wx.lib.infoframe

infoframe.py
Released under wxWindows license etc.

This is a fairly rudimentary, but slightly fancier tha
wxPyOnDemandOutputWindow (on which it's based; thanks Robin), version
of the same sort of thing: a file-like class called
wxInformationalMessagesFrame. This window also has a status bar with a
couple of buttons for controlling the echoing of all output to a file
with a randomly-chosen filename...

The class behaves similarly to wxPyOnDemandOutputWindow in that (at
least by default) the frame does not appear until written to, but is
somewhat different in that, either under programmatic (the
DisableOutput method) or user (the frame's close button, it's status
bar's "Dismiss" button, or a "Disable output" item of some menu,
perhaps of some other frame), the frame will be destroyed, an
associated file closed, and writing to it will then do nothing.  This
can be reversed: either under programmatic (the EnableOutput method)
or user (an "Enable output" item of some menu), a new frame will be
opened,And an associated file (with a "randomly"selected filename)
opened for writing [to which all subsequent displayed messages will be
echoed].

Please note that, like wxPyOnDemandOutputWindow, the instance is not
itself a subclass of wxWindow: when the window is open (and ONLY
then), it's "frame" attribute is the actual instance of wFrame...

Typical usage:
    from wxPython.lib.infoframe import *
    ... # ... modify your wxApp as follows:
    class myApp(wxApp):
        outputWindowClass = PyInformationalMessagesFrame
        ...
If you're running on Linux, you'll also have to supply an argument 1 to your
constructor of myApp to redirect stdout/stderr to this window (it's done
automatically for you on Windows).

If you don't want to redirect stdout/stderr, but use the class directly: do
it this way:

 InformationalMessagesFrame = PyInformationalMessagesFrame                                         ([options from progname (default ""),
                                           txt (default "informational
                                                         messages"])
#^^^^ early in the program
...
InformationalMessagesFrame([comma-separated list of items to
                             display.  Note that these will never
                             be separated by spaces as they may
                             be when used in the Python 'print'
                             command])

The latter statement, of course, may be repeated arbitrarily often.
The window will not appear until it is written to, and it may be
manually closed by the user, after which it will reappear again until
written to... Also note that all output is echoed to a file with a
randomly-generated name [see the mktemp module in the standard
library], in the directory given as the 'dir' keyword argument to the
InformationalMessagesFrame constructor [which has a default value of
'.'), or set via the method SetOutputDirectory... This file will be
closed with the window--a new one will be created [by default] upon
each subsequent reopening.

Please also note the methods EnableOutput and DisableOutput, and the
possible arguments for the constructor in the code below... (* TO DO:
explain this here...*) Neither of these methods need be used at all,
and in this case the frame will only be displayed once it has been
written to, like wxPyOnDemandOutputWindow.

The former, EnableOutput, displays the frame with an introductory
message, opens a random file to which future displayed output also
goes (unless the nofile attribute is present), and sets the __debug__
variable of each module to 1 (unless the no __debug__ attribute is
present].  This is so that you can say, in any module whatsoever,

    if __debug__:
        InformationalMessagesFrame("... with lots of %<Character> constructs"
                                    % TUPLE)

without worrying about the overhead of evaluating the arguments, and
calling the wxInformationalMessagesFrame instance, in the case where
debugging is not turned on.  (This won't happen if the instance has an
attribute no__debug__; you can arrange this by sub-classing...)

"Debug mode" can also be turned on by selecting the item-"Enable
output" from the "Debug" menu [the default--see the optional arguments
to the SetOtherMenuBar method] of a frame which has been either passed
appropriately to the constructor of the wxInformationalMessagesFrame
(see the code), or set via the SetOtherMenuBar method thereof.  This
also writes an empty string to the instance, meaning that the frame
will open (unless DisablOutput has been called) with an appropriate
introductory message (which will vary according to whether the
instance/class has the "no __debug__" attribute)^  I have found this to
be an extremely useful tool, in lieu of a full wxPython debugger...

Following this, the menu item is also disabled, and an item "Disable
output" (again, by default) is enabled.  Note that these need not be
done: e.g., you don't NEED to have a menu with appropriate items; in
this case simply do not call the SetOtherMenuBar method or use the
othermenubar keyword argument of the class instance constructor.

The DisableOutput method does the reverse of this; it closes the
window (and associated file), and sets the __debug__ variable of each
module whose name begins with a capital letter {this happens to be the
author's personal practice; all my python module start with capital
letters} to 0.  It also enables/disabled the appropriate menu items,
if this was done previously (or SetOtherMenuBar has been called...).
Note too that after a call to DisableOutput, nothing further will be
done upon subsequent write()'s, until the EnableOutput method is
called, either explicitly or by the menu selection above...

Finally, note that the file-like method close() destroys the window
(and closes any associated file) and there is a file-like method
write() which displays it's argument.

All (well, most) of this is made clear by the example code at the end
of this file, which is run if the file is run by itself; otherwise,
see the appropriate "stub" file in the wxPython demo.
Classes
Dummy_PyInformationalMessagesFrame
PyInformationalMessagesFrame

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:10:55 2005 http://epydoc.sf.net


wx.lib.intctrl.IntCtrl

Package wx :: Package lib :: Module intctrl :: Class IntCtrl

Type IntCtrl

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
               Control --+
                         |
                  TextCtrl --+
                             |
                            IntCtrl

This class provides a control that takes and returns integers as value, and provides bounds support and optional value limiting.

IntCtrl(
parent, id = -1,
value = 0,
pos = wxDefaultPosition,
size = wxDefaultSize,
style = 0,
validator = wxDefaultValidator,
name = "integer",
min = None,
max = None,
limited = False,
allow_none = False,
allow_long = False,
default_color = wxBLACK,
oob_color = wxRED )
value
If no initial value is set, the default will be zero, or the minimum value, if specified. If an illegal string is specified, a ValueError will result. (You can always later set the initial value with SetValue() after instantiation of the control.)
min
The minimum value that the control should allow. This can be adjusted with SetMin(). If the control is not limited, any value below this bound will be colored with the current out-of-bounds color. If min < -sys.maxint-1 and the control is configured to not allow long values, the minimum bound will still be set to the long value, but the implicit bound will be -sys.maxint-1.
max
The maximum value that the control should allow. This can be adjusted with SetMax(). If the control is not limited, any value above this bound will be colored with the current out-of-bounds color. if max > sys.maxint and the control is configured to not allow long values, the maximum bound will still be set to the long value, but the implicit bound will be sys.maxint.
limited
Boolean indicating whether the control prevents values from exceeding the currently set minimum and maximum values (bounds). If False and bounds are set, out-of-bounds values will be colored with the current out-of-bounds color.
allow_none
Boolean indicating whether or not the control is allowed to be empty, representing a value of None for the control.
allow_long
Boolean indicating whether or not the control is allowed to hold and return a long as well as an int.
default_color
Color value used for in-bounds values of the control.
oob_color
Color value used for out-of-bounds values of the control when the bounds are set but the control is not limited.
validator
Normally None, IntCtrl uses its own validator to do value validation and input control. However, a validator derived from IntValidator can be supplied to override the data transfer methods for the IntValidator class.
Method Summary
 | __init__(self, parent, id, value, pos, size, style, validator, name, min, max, limited, allow_none, allow_long, default_color, oob_color)
 | Cut(self) Override the wxTextCtrl's .Cut function, with our own that does validation.
 | GetBounds(self) This function returns a two-tuple (min,max), indicating the current bounds of the control.
 | GetColors(self) Returns a tuple of (default_color, oob_color), indicating the current color settings for the control.
 | GetMax(self) Gets the maximum value of the control.
 | GetMin(self) Gets the minimum value of the control.
 | GetValue(self) Returns the current integer (long) value of the control.
 | IsInBounds(self, value) Returns True if no value is specified and the current value of the control falls within the current bounds.
 | IsLimited(self) Returns True if the control is currently limiting the value to fall within the current bounds.
 | IsLongAllowed(self)
 | IsNoneAllowed(self)
 | OnText(self, event) Handles an event indicating that the text control's value has changed, and issue EVT_INT event.
 | Paste(self) Override the wxTextCtrl's .Paste function, with our own that does validation.
 | SetBounds(self, min, max) This function is a convenience function for setting the min and max values at the same time.
 | SetColors(self, default_color, oob_color) Tells the control what colors to use for normal and out-of-bounds values.
 | SetLimited(self, limited) If called with a value of True, this function will cause the control to limit the value to fall within the bounds currently specified.
 | SetLongAllowed(self, allow_long) Change the behavior of the validation code, allowing control to have a long value or not, as appropriate.
 | SetMax(self, max) Sets the maximum value of the control.
 | SetMin(self, min) Sets the minimum value of the control.
 | SetNoneAllowed(self, allow_none) Change the behavior of the validation code, allowing control to have a value of None or not, as appropriate.
 | SetValue(self, value) Sets the value of the control to the integer value specified.

Instance Method Details

Cut(self)

Override the wxTextCtrl's .Cut function, with our own that does validation. Will result in a value of 0 if entire contents of control are removed.

Overrides:
wx.TextCtrl.Cut

GetBounds(self)

This function returns a two-tuple (min,max), indicating the current bounds of the control. Each value can be None if that bound is not set.

GetColors(self)

Returns a tuple of (default_color, oob_color), indicating the current color settings for the control.

GetMax(self)

Gets the maximum value of the control. It will return the current maximum integer, or None if not specified.

GetMin(self)

Gets the minimum value of the control. It will return the current minimum integer, or None if not specified.

GetValue(self)

Returns the current integer (long) value of the control.

Overrides:
wx.TextCtrl.GetValue

IsInBounds(self, value=None)

Returns True if no value is specified and the current value of the control falls within the current bounds. This function can also be called with a value to see if that value would fall within the current bounds of the given control.

IsLimited(self)

Returns True if the control is currently limiting the value to fall within the current bounds.

OnText(self, event)

Handles an event indicating that the text control's value has changed, and issue EVT_INT event. NOTE: using wx.TextCtrl.SetValue() to change the control's contents from within a wx.EVT_CHAR handler can cause double text events. So we check for actual changes to the text before passing the events on.

Paste(self)

Override the wxTextCtrl's .Paste function, with our own that does validation. Will raise ValueError if not a valid integerizable value.

Overrides:
wx.TextCtrl.Paste

SetBounds(self, min=None, max=None)

This function is a convenience function for setting the min and max values at the same time. The function only applies the maximum bound if setting the minimum bound is successful, and returns True only if both operations succeed. NOTE: leaving out an argument will remove the corresponding bound.

SetColors(self, default_color=wxPython wrapper for UNBORN object! (The C++ object is no..., oob_color=wxPython wrapper for UNBORN object! (The C++ object is no...)

Tells the control what colors to use for normal and out-of-bounds values. If the value currently exceeds the bounds, it will be recolored accordingly.

SetLimited(self, limited)

If called with a value of True, this function will cause the control to limit the value to fall within the bounds currently specified. If the control's value currently exceeds the bounds, it will then be limited accordingly.

If called with a value of 0, this function will disable value limiting, but coloring of out-of-bounds values will still take place if bounds have been set for the control.

SetLongAllowed(self, allow_long)

Change the behavior of the validation code, allowing control to have a long value or not, as appropriate. If the value of the control is currently long, and allow_long is 0, the value of the control will be adjusted to fall within the size of an integer type, at either the sys.maxint or -sys.maxint-1, for positive and negative values, respectively.

SetMax(self, max=None)

Sets the maximum value of the control. If a value of None is provided, then the control will have no explicit maximum value. If the value specified is less than the current minimum value, then the function returns 0 and the maximum will not change from its current setting. On success, the function returns 1.

If successful and the current value is greater than the new upper bound, if the control is limited the value will be automatically adjusted to this maximum value; if not limited, the value in the control will be colored with the current out-of-bounds color.

If max > sys.maxint and the control is configured to not allow longs, the function will return 0, and the max will not be set.

SetMin(self, min=None)

Sets the minimum value of the control. If a value of None is provided, then the control will have no explicit minimum value. If the value specified is greater than the current maximum value, then the function returns 0 and the minimum will not change from its current setting. On success, the function returns 1.

If successful and the current value is lower than the new lower bound, if the control is limited, the value will be automatically adjusted to the new minimum value; if not limited, the value in the control will be colored with the current out-of-bounds color.

If min > -sys.maxint-1 and the control is configured to not allow longs, the function will return 0, and the min will not be set.

SetNoneAllowed(self, allow_none)

Change the behavior of the validation code, allowing control to have a value of None or not, as appropriate. If the value of the control is currently None, and allow_none is 0, the value of the control will be set to the minimum value of the control, or 0 if no lower bound is set.

SetValue(self, value)

Sets the value of the control to the integer value specified. The resulting actual value of the control may be altered to conform with the bounds set on the control if limited, or colored if not limited but the value is out-of-bounds. A ValueError exception will be raised if an invalid value is specified.

Overrides:
wx.TextCtrl.SetValue

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:48 2005 http://epydoc.sf.net


wx.lib.intctrl.IntUpdatedEvent

Package wx :: Package lib :: Module intctrl :: Class IntUpdatedEvent
[frames | no frames]

Type IntUpdatedEvent

object --+
         |
    Object --+
             |
         Event --+
                 |
      CommandEvent --+
                     |
        PyCommandEvent --+
                         |
                        IntUpdatedEvent

Method Summary
 | __init__(self, id, value, object)
 | GetValue(self) Retrieve the value of the control at the time this event was generated.

Method Details

GetValue(self)

Retrieve the value of the control at the time this event was generated.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:59 2005 http://epydoc.sf.net


wx.lib.intctrl.IntValidator

Package wx :: Package lib :: Module intctrl :: Class IntValidator
[frames | no frames]

Type IntValidator

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
         Validator --+
                     |
           PyValidator --+
                         |
                        IntValidator

Validator class used with IntCtrl; handles all validation of input prior to changing the value of the underlying wx.TextCtrl.

Method Summary
 | __init__(self)
 | Clone(self)
 | OnChar(self, event) Validates keystrokes to make sure the resulting value will a legal value.
 | TransferFromWindow(self) Transfer data from window to validator.
 | TransferToWindow(self) Transfer data from validator to window.
 | Validate(self, window) Because each operation on the control is vetted as it's made, the value of the control is always valid.

Instance Method Details

OnChar(self, event)

Validates keystrokes to make sure the resulting value will a legal value. Erasing the value causes it to be set to 0, with the value selected, so it can be replaced. Similarly, replacing the value with a '-' sign causes the value to become -1, with the value selected. Leading zeros are removed if introduced by selection, and are prevented from being inserted.

TransferFromWindow(self)

Transfer data from window to validator.

The default implementation returns False, indicating that an error occurred. We simply return True, as we don't do any data transfer.

Overrides:
wx.Validator.TransferFromWindow

TransferToWindow(self)

Transfer data from validator to window.

The default implementation returns False, indicating that an error occurred. We simply return True, as we don't do any data transfer.

Overrides:
wx.Validator.TransferToWindow

Validate(self, window)

Because each operation on the control is vetted as it's made, the value of the control is always valid.

Overrides:
wx.Validator.Validate

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:16 2005 http://epydoc.sf.net


wx.lib.intctrl

Package wx :: Package lib :: Module intctrl

Module wx.lib.intctrl

Classes
IntCtrl | This class provides a control that takes and returns integers as value, and provides bounds support and optional value limiting.
IntUpdatedEvent |
IntValidator | Validator class used with IntCtrl; handles all validation of input prior to changing the value of the underlying wx.TextCtrl.

Variable Summary
PyEventBinder | EVT_INT = <wx._core.PyEventBinder object at 0xb79becac>
int | MININT = -2147483648
int | wxEVT_COMMAND_INT_UPDATED = 10277
int | WXK_CTRL_V = 22
int | WXK_CTRL_X = 24

Variable Details

EVT_INT

Type:
PyEventBinder
Value:
<wx._core.PyEventBinder object at 0xb79becac>

MININT

Type:
int
Value:
-2147483648

wxEVT_COMMAND_INT_UPDATED

Type:
int
Value:
10277

WXK_CTRL_V

Type:
int
Value:
22

WXK_CTRL_X

Type:
int
Value:
24

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:13 2005 http://epydoc.sf.net


wx.lib.layoutf.Layoutf

Package wx :: Package lib :: Module layoutf :: Class Layoutf

Type Layoutf

   object --+
            |
       Object --+
                |
LayoutConstraints --+
                    |
                   Layoutf

The class Layoutf(wxLayoutConstraints) presents a simplification of the wxLayoutConstraints syntax. The name Layoutf is choosen because of the similarity with C's printf function.

Quick Example:

lc = Layoutf('t=t#1;l=r10#2;r!100;h%h50#1', (self, self.panel))

is equivalent to

lc = wxLayoutContraints()
lc.top.SameAs(self, wxTop)
lc.left.SameAs(self.panel, wxRight, 10)
lc.right.Absolute(100)
lc.height.PercentOf(self, wxHeight, 50)

Usage:

You can give a constraint string to the Layoutf constructor,

or use the 'pack' method. The following are equivalent:

lc = Layoutf('t=t#1;l=r#2;r!100;h%h50#1', (self, self.panel))

and

lc = Layoutf() lc.pack('t=t#1;l=r#2;r!100;h%h50#1', (self, self.panel))

Besides 'pack' there's also 'debug_pack' which does not set

constraints, but prints traditional wxLayoutConstraint calls to stdout.

The calls to the Layoutf constructor and pack methods have

the following argument list:

(constraint_string, objects_tuple)

Constraint String syntax:

Constraint directives are separated by semi-colons. You

generally (always?) need four directives to completely describe a subwindow's location.

A single directive has either of the following forms:

1. <own attribute><compare operation>[numerical argument] for example r!100 -> lc.right.Absolute(100) ) and w* -> lc.width.AsIs()

  2. <own attribute><compare operation>[numerical argument] #<compare object nr.>

for example t_10#2 (lc.top.Below(<second obj>, 10)

  3. <own attribute><compare operation><compare attribute> [numerical argument]#<compare object nr.>

for example w%h50#2 ( lc.width.PercentOf(<second obj>, wxHeight, 50) and t=b#1 ( lc.top.SameAs(<first obj>, wxBottom) )

Which one you need is defined by the <compare operation>

type. The following take type 1 (no object to compare with):

'!': 'Absolute', '?': 'Unconstrained', '*': 'AsIs'

These take type 2 (need to be compared with another object)

'<': 'LeftOf', '>': 'RightOf', '^': 'Above', '_': 'Below'

These take type 3 (need to be compared to another object attribute)

'=': 'SameAs', '%': 'PercentOf'

For all types, the <own attribute> letter can be any of

't': 'top', 'l': 'left', 'b': 'bottom', 'r': 'right', 'h': 'height', 'w': 'width', 'x': 'centreX', 'y': 'centreY'

If the operation takes an (optional) numerical argument, place it in [numerical argument]. For type 3 directives, the <compare attribute> letter can be any of

't': 'wxTop', 'l': 'wxLeft', 'b': 'wxBottom' 'r': 'wxRight', 'h': 'wxHeight', 'w': 'wxWidth', 'x': 'wxCentreX', 'y': 'wxCentreY'

Note that these are the same letters as used for <own attribute>, so you'll only need to remember one set. Finally, the object whose attribute is refered to, is specified by #<compare object nr>, where <compare object nr> is the 1-based (stupid, I know, but I've gotten used to it) index of the object in the objects_tuple argument.

Bugs:

Not entirely happy about the logic in the order of arguments after the <compare operation> character.

Not all wxLayoutConstraint methods are included in the syntax. However, the type 3 directives are generally the most used. Further excuse: wxWindows layout constraints are at the time of this writing not documented.

Method Summary
 | __init__(self, pstr, winlist)
 | debug_pack(self, pstr, winlist)
 | pack(self, pstr, winlist)

Property Summary

Class Variable Summary
dict | attr_d = {'b': 'bottom', 'h': 'height', 'l': 'left', 'r'...
dict | cmp_d = {'b': 'wx.Bottom', 'h': 'wx.Height', 'l': 'wx.Le...
dict | op_d = {'!': 'Absolute', '%': 'PercentOf', '*': 'AsIs', ...
SRE_Pattern | rexp1 = ^\s*([tlrbhwxy])\s*([!\?\*])\s*(\d*)\s*$
SRE_Pattern | rexp2 = ^\s*([tlrbhwxy])\s*([=%<>\^_])\s*([tlrbhwxy]?)\s...

Class Variable Details

attr_d

Type:
dict
Value:
{'b': 'bottom',
 'h': 'height',
 'l': 'left',
 'r': 'right',
 't': 'top',
 'w': 'width',
 'x': 'centreX',
 'y': 'centreY'}

cmp_d

Type:
dict
Value:
{'b': 'wx.Bottom',
 'h': 'wx.Height',
 'l': 'wx.Left',
 'r': 'wx.Right',
 't': 'wx.Top',
 'w': 'wx.Width',
 'x': 'wx.CentreX',
 'y': 'wx.CentreY'}

op_d

Type:
dict
Value:
{'!': 'Absolute',
 '%': 'PercentOf',
 '*': 'AsIs',
 '<': 'LeftOf',
 '=': 'SameAs',
 '>': 'RightOf',
 '?': 'Unconstrained',
 '^': 'Above',
...

rexp1

Type:
SRE_Pattern
Value:
^\s*([tlrbhwxy])\s*([!\?\*])\s*(\d*)\s*$

rexp2

Type:
SRE_Pattern
Value:
^\s*([tlrbhwxy])\s*([=%<>\^_])\s*([tlrbhwxy]?)\s*(\d*)\s*#(\d+)\s*$

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:04 2005 http://epydoc.sf.net


wx.lib.layoutf

Package wx :: Package lib :: Module layoutf

Module wx.lib.layoutf

Classes
Layoutf The class Layoutf(wxLayoutConstraints) presents a simplification of the wxLayoutConstraints syntax.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:09 2005 http://epydoc.sf.net


wx.lib.masked.combobox.BaseMaskedComboBox

Package wx :: Package lib :: Package masked :: Module combobox :: Class BaseMaskedComboBox
[frames | no frames]

Type BaseMaskedComboBox

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
               Control --+
                         |
            object --+   |
                     |   |
         ItemContainer --+
                         |
                  ComboBox --+
                             |
           MaskedEditMixin --+
                             |
                            BaseMaskedComboBox

Known Subclasses:
ComboBox, PreMaskedComboBox

Base class for generic masked edit comboboxes; allows auto-complete of values. It is not meant to be instantiated directly, but rather serves as a base class for any subsequent refinements.

Method Summary
__init__(self, parent, id, value, pos, size, choices, style, validator, name, setupEventHandling, **kwargs)
__repr__(self)
Append(self, choice, clientData)
This base control function override is necessary so the control can keep track of any additions to the list of choices, because wx.ComboBox doesn't have an accessor for the choice list.
AppendItems(self, choices)
AppendItems() is handled in terms of Append, to avoid code replication.
Clear(self)
This base control function override is necessary so the derived control can keep track of any additions to the list of choices, because wx.ComboBox doesn't have an accessor for the choice list.
Cut(self)
This function redefines the externally accessible .Cut to be a smart "erase" of the text in question, so as not to corrupt the masked control.
GetMark(self)
Paste(self)
This function redefines the externally accessible .Paste to be a smart "paste" of the text in question, so as not to corrupt the masked control.
Refresh(self)
This function redefines the externally accessible .Refresh() to validate the contents of the masked control as it refreshes.
SetFont(self, *args, **kwargs)
Set the font, then recalculate control size, if appropriate.
SetSelection(self, index)
Necessary override for bookkeeping on choice selection, to keep current value current.
SetValue(self, value)
This function redefines the externally accessible .SetValue to be a smart "paste" of the text in question, so as not to corrupt the masked control.
Undo(self)
This function defines the undo operation for the control.

Class Variable Summary

Instance Method Details

Append(self, choice, clientData=None)

This base control function override is necessary so the control can keep track of any additions to the list of choices, because wx.ComboBox doesn't have an accessor for the choice list. The code here is the same as in the SetParameters() mixin function, but is done for the individual value as appended, so the list can be built incrementally without speed penalty.

Overrides:
wx.ItemContainer.Append

AppendItems(self, choices)

AppendItems() is handled in terms of Append, to avoid code replication.

Overrides:
wx.ItemContainer.AppendItems

Clear(self)

This base control function override is necessary so the derived control can keep track of any additions to the list of choices, because wx.ComboBox doesn't have an accessor for the choice list.

Overrides:
wx.ItemContainer.Clear

Cut(self)

This function redefines the externally accessible .Cut to be a smart "erase" of the text in question, so as not to corrupt the masked control. NOTE: this must be done in the class derived from the base wx control.

Overrides:
wx.ComboBox.Cut

Paste(self)

This function redefines the externally accessible .Paste to be a smart "paste" of the text in question, so as not to corrupt the masked control. NOTE: this must be done in the class derived from the base wx control.

Overrides:
wx.ComboBox.Paste

Refresh(self)

This function redefines the externally accessible .Refresh() to validate the contents of the masked control as it refreshes. NOTE: this must be done in the class derived from the base wx control.

Overrides:
wx.Window.Refresh

SetFont(self, *args, **kwargs)

Set the font, then recalculate control size, if appropriate.

Overrides:
wx.Window.SetFont

SetSelection(self, index)

Necessary override for bookkeeping on choice selection, to keep current value current.

Overrides:
wx.ComboBox.SetSelection

SetValue(self, value)

This function redefines the externally accessible .SetValue to be a smart "paste" of the text in question, so as not to corrupt the masked control. NOTE: this must be done in the class derived from the base wx control.

Overrides:
wx.ComboBox.SetValue

Undo(self)

This function defines the undo operation for the control. (The default undo is 1-deep.)

Overrides:
wx.ComboBox.Undo

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:41 2005 http://epydoc.sf.net


wx.lib.masked.combobox.ComboBox

Package wx :: Package lib :: Package masked :: Module combobox :: Class ComboBox
[frames | no frames]

Type ComboBox

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
               Control --+
                         |
            object --+   |
                     |   |
         ItemContainer --+
                         |
                  ComboBox --+
                             |
           MaskedEditMixin --+
                             |
            BaseMaskedComboBox --+
                                 |
      MaskedEditAccessorsMixin --+
                                 |
                                ComboBox

The "user-visible" masked combobox control, this class is identical to the BaseMaskedComboBox class it's derived from. (This extra level of inheritance allows us to add the generic set of masked edit parameters only to this class while allowing other classes to derive from the "base" masked combobox control, and provide a smaller set of valid accessor functions.) See BaseMaskedComboBox for available methods.

Method Summary

Class Variable Summary

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:17 2005 http://epydoc.sf.net


wx.lib.masked.combobox.MaskedComboBoxSelectEvent

Package wx :: Package lib :: Package masked :: Module combobox :: Class MaskedComboBoxSelectEvent
[frames | no frames]

Type MaskedComboBoxSelectEvent

object --+
         |
    Object --+
             |
         Event --+
                 |
      CommandEvent --+
                     |
        PyCommandEvent --+
                         |
                        MaskedComboBoxSelectEvent

Because calling SetSelection programmatically does not fire EVT_COMBOBOX events, the derived control has to do it itself when it auto-completes.

Method Summary
 | __init__(self, id, selection, object)
 | GetSelection(self) Retrieve the value of the control at the time this event was generated.

Method Details

GetSelection(self)

Retrieve the value of the control at the time this event was generated.

Overrides:
wx.CommandEvent.GetSelection

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:09 2005 http://epydoc.sf.net


wx.lib.masked.combobox.PreMaskedComboBox

Package wx :: Package lib :: Package masked :: Module combobox :: Class PreMaskedComboBox
[frames | no frames]

Type PreMaskedComboBox

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
               Control --+
                         |
            object --+   |
                     |   |
         ItemContainer --+
                         |
                  ComboBox --+
                             |
           MaskedEditMixin --+
                             |
            BaseMaskedComboBox --+
                                 |
      MaskedEditAccessorsMixin --+
                                 |
                                PreMaskedComboBox

This class exists to support the use of XRC subclassing.

Method Summary
 | __init__(self)
 | OnCreate(self, evt)

Class Variable Summary

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:58 2005 http://epydoc.sf.net


wx.lib.masked.combobox

Package wx :: Package lib :: Package masked :: Module combobox
[frames | no frames]

Module wx.lib.masked.combobox

Provides masked edit capabilities within a ComboBox format, as well as a base class from which you can derive masked comboboxes tailored to a specific function. See maskededit module overview for how to configure the control.

Classes
BaseMaskedComboBox | Base class for generic masked edit comboboxes; allows auto-complete of values.
ComboBox | The "user-visible" masked combobox control, this class is identical to the BaseMaskedComboBox class it's derived from.
MaskedComboBoxSelectEvent | Because calling SetSelection programmatically does not fire EVT_COMBOBOX events, the derived control has to do it itself when it auto-completes.
PreMaskedComboBox | This class exists to support the use of XRC subclassing.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:17 2005 http://epydoc.sf.net


wx.lib.masked.ctrl.controlTypes

Package wx :: Package lib :: Package masked :: Module ctrl :: Class controlTypes
[frames | no frames]

Class controlTypes

Class Variable Summary
int | COMBO = 1
int | IPADDR = 2
int | NUMBER = 4
int | TEXT = 0
int | TIME = 3

Class Variable Details

COMBO

Type:
int
Value:
1

IPADDR

Type:
int
Value:
2

NUMBER

Type:
int
Value:
4

TEXT

Type:
int
Value:
0

TIME

Type:
int
Value:
3

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:27 2005 http://epydoc.sf.net


wx.lib.masked.ctrl

Package wx :: Package lib :: Package masked :: Module ctrl

Module wx.lib.masked.ctrl

masked.Ctrl is actually a factory function for several types of masked edit controls:

masked.TextCtrl | standard masked edit text box
masked.ComboBox | adds combobox capabilities
masked.IpAddrCtrl | adds logical input semantics for IP address entry
masked.TimeCtrl | special subclass handling lots of time formats as values
masked.NumCtrl | special subclass handling numeric values

masked.Ctrl works by looking for a special controlType parameter in the variable arguments of the control, to determine what kind of instance to return. controlType can be one of:

controlTypes.TEXT
controlTypes.COMBO
controlTypes.IPADDR
controlTypes.TIME
controlTypes.NUMBER

These constants are also available individually, ie, you can use either of the following:

from wxPython.wx.lib.masked import Ctrl, COMBO, TEXT, NUMBER, TIME
from wxPython.wx.lib.masked import Ctrl, controlTypes

If not specified as a keyword argument, the default controlType is controlTypes.TEXT.

Each of the above classes has its own unique arguments, but Masked.Ctrl provides a single "unified" interface for masked controls.

Classes
controlTypes

Function Summary
Ctrl(*args, **kwargs)
Actually a factory function providing a unifying interface for generating masked controls.

Variable Summary
int | COMBO = 1
int | IPADDR = 2
int | NUMBER = 4
int | TEXT = 0
int | TIME = 3

Function Details

Ctrl(*args, **kwargs)

Actually a factory function providing a unifying interface for generating masked controls.

Variable Details

COMBO

Type:
int
Value:
1

IPADDR

Type:
int
Value:
2

NUMBER

Type:
int
Value:
4

TEXT

Type:
int
Value:
0

TIME

Type:
int
Value:
3

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:44 2005 http://epydoc.sf.net


wx.lib.masked.ipaddrctrl.IpAddrCtrlAccessorsMixin

Package wx :: Package lib :: Package masked :: Module ipaddrctrl :: Class IpAddrCtrlAccessorsMixin
[frames | no frames]

Class IpAddrCtrlAccessorsMixin

Known Subclasses:
IpAddrCtrl

Defines IpAddrCtrl's list of attributes having their own Get/Set functions, exposing only those that make sense for an IP address control.

Method Summary
 | GetDefaultValue(self)
 | GetDescription(self)
 | GetEmptyBackgroundColour(self)
 | GetEmptyInvalid(self)
 | GetFields(self)
 | GetFillChar(self)
 | GetFormatcodes(self)
 | GetInvalidBackgroundColour(self)
 | GetRetainFieldValidation(self)
 | GetSignedForegroundColour(self)
 | GetUseFixedWidthFont(self)
 | GetValidBackgroundColour(self)
 | GetValidFunc(self)
 | GetValidRequired(self)
 | SetDefaultValue(self, value)
 | SetDescription(self, value)
 | SetEmptyBackgroundColour(self, value)
 | SetEmptyInvalid(self, value)
 | SetFields(self, value)
 | SetFillChar(self, value)
 | SetFormatcodes(self, value)
 | SetInvalidBackgroundColour(self, value)
 | SetRetainFieldValidation(self, value)
 | SetSignedForegroundColour(self, value)
 | SetUseFixedWidthFont(self, value)
 | SetValidBackgroundColour(self, value)
 | SetValidFunc(self, value)
 | SetValidRequired(self, value)

Class Variable Summary
tuple | exposed_basectrl_params = ('fields', 'retainFieldValidat...
str | param = 'validRequired'
str | propname = 'ValidRequired'

Class Variable Details

exposed_basectrl_params

Type:
tuple
Value:
('fields',
 'retainFieldValidation',
 'formatcodes',
 'fillChar',
 'defaultValue',
 'description',
 'useFixedWidthFont',
 'signedForegroundColour',
...

param

Type:
str
Value:
'validRequired'

propname

Type:
str
Value:
'ValidRequired'

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:41 2005 http://epydoc.sf.net


wx.lib.masked.ipaddrctrl.IpAddrCtrl

Package wx :: Package lib :: Package masked :: Module ipaddrctrl :: Class IpAddrCtrl
[frames | no frames]

Type IpAddrCtrl

           MaskedEditMixin --+
                             |
object --+                   |
         |                   |
    Object --+               |
             |               |
    EvtHandler --+           |
                 |           |
            Window --+       |
                     |       |
               Control --+   |
                         |   |
                  TextCtrl --+
                             |
            BaseMaskedTextCtrl --+
                                 |
      IpAddrCtrlAccessorsMixin --+
                                 |
                                IpAddrCtrl

This class is a particular type of MaskedTextCtrl that accepts and understands the semantics of IP addresses, reformats input as you move from field to field, and accepts '.' as a navigation character, so that typing an IP address can be done naturally.

Method Summary
 | __init__(self, parent, id, value, pos, size, style, validator, name, setupEventHandling, **kwargs)
 | GetAddress(self) Returns the control value, with any spaces removed.
 | OnDot(self, event) Defines what action to take when the '.' character is typed in the control.
 | SetValue(self, value) Takes a string value, validates it for a valid IP address, splits it into an array of 4 fields, justifies it appropriately, and inserts it into the control.

Class Variable Summary

Instance Method Details

GetAddress(self)

Returns the control value, with any spaces removed.

OnDot(self, event)

Defines what action to take when the '.' character is typed in the control. By default, the current field is right-justified, and the cursor is placed in the next field.

SetValue(self, value)

Takes a string value, validates it for a valid IP address, splits it into an array of 4 fields, justifies it appropriately, and inserts it into the control. Invalid values will raise a ValueError exception.

Overrides:
wx.lib.masked.textctrl.BaseMaskedTextCtrl.SetValue

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:11 2005 http://epydoc.sf.net


wx.lib.masked.ipaddrctrl

Package wx :: Package lib :: Package masked :: Module ipaddrctrl
[frames | no frames]

Module wx.lib.masked.ipaddrctrl

Provides a smart text input control that understands the structure and limits of IP Addresses, and allows automatic field navigation as the user hits '.' when typing.

Classes
IpAddrCtrl | This class is a particular type of MaskedTextCtrl that accepts and understands the semantics of IP addresses, reformats input as you move from field to field, and accepts '.' as a navigation character, so that typing an IP address can be done naturally.
IpAddrCtrlAccessorsMixin | Defines IpAddrCtrl's list of attributes having their own Get/Set functions, exposing only those that make sense for an IP address control.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:22 2005 http://epydoc.sf.net


wx.lib.masked.maskededit.Field

Package wx :: Package lib :: Package masked :: Module maskededit :: Class Field
[frames | no frames]

Class Field

This class manages the individual fields in a masked edit control. Each field has a zero-based index, indicating its position in the control, an extent, an associated mask, and a plethora of optional parameters. Fields can be instantiated and then associated with parent masked controls, in order to provide field-specific configuration. Alternatively, fields will be implicitly created by the parent control if not provided at construction, at which point, the fields can then manipulated by the controls .SetFieldParameters() method.

Method Summary
 | __init__(self, **kwargs) This is the "constructor" for setting up parameters for fields.
 | IsEmpty(self, slice) Indicates whether the specified slice is considered empty for the field.
 | IsValid(self, slice) Indicates whether the specified slice is considered a valid value for the field.

Class Variable Summary
tuple | propagating_params = ('fillChar', 'groupChar', 'decimalC...
dict | valid_params = {'formatcodes': '', 'fillChar': ' ', 'gro...

Method Details

__init__(self, **kwargs)
(Constructor)

This is the "constructor" for setting up parameters for fields. a field_index of -1 is used to indicate "the entire control."

IsEmpty(self, slice)

Indicates whether the specified slice is considered empty for the field.

IsValid(self, slice)

Indicates whether the specified slice is considered a valid value for the field.

Class Variable Details

propagating_params

Type:
tuple
Value:
('fillChar',
 'groupChar',
 'decimalChar',
 'useParensForNegatives',
 'compareNoCase',
 'emptyInvalid',
 'validRequired')

valid_params

Type:
dict
Value:
{'autoSelect': False,
 'choiceRequired': False,
 'choices': [],
 'compareNoCase': False,
 'decimalChar': '.',
 'defaultValue': '',
 'description': '',
 'emptyInvalid': False,
...

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:52 2005 http://epydoc.sf.net


wx.lib.masked.maskededit.MaskedEditAccessorsMixin

Package wx :: Package lib :: Package masked :: Module maskededit :: Class MaskedEditAccessorsMixin
[frames | no frames]

Class MaskedEditAccessorsMixin

Known Subclasses:
ComboBox, PreMaskedComboBox, PreMaskedTextCtrl, TextCtrl

To avoid a ton of boiler-plate, and to automate the getter/setter generation for each valid control parameter so we never forget to add the functions when adding parameters, this class programmatically adds the masked edit mixin parameters to itself. (This makes it easier for Designers like Boa to deal with masked controls.)

To further complicate matters, this is done with an extra level of inheritance, so that "general" classes like masked.TextCtrl can have all possible attributes, while derived classes, like masked.TimeCtrl and masked.NumCtrl can prevent exposure of those optional attributes of their base class that do not make sense for their derivation.

Therefore, we define:
BaseMaskedTextCtrl(TextCtrl, MaskedEditMixin)
and
masked.TextCtrl(BaseMaskedTextCtrl, MaskedEditAccessorsMixin).
This allows us to then derive:
masked.NumCtrl( BaseMaskedTextCtrl )

and not have to expose all the same accessor functions for the derived control when they don't all make sense for it.

Method Summary
 | GetAutoCompleteKeycodes(self)
 | GetAutoformat(self)
 | GetAutoSelect(self)
 | GetChoiceRequired(self)
 | GetChoices(self)
 | GetCompareNoCase(self)
 | GetDatestyle(self)
 | GetDecimalChar(self)
 | GetDefaultEncoding(self)
 | GetDefaultValue(self)
 | GetDemo(self)
 | GetDescription(self)
 | GetEmptyBackgroundColour(self)
 | GetEmptyInvalid(self)
 | GetExcludeChars(self)
 | GetFields(self)
 | GetFillChar(self)
 | GetFormatcodes(self)
 | GetGroupChar(self)
 | GetIncludeChars(self)
 | GetInvalidBackgroundColour(self)
 | GetMask(self)
 | GetRetainFieldValidation(self)
 | GetShiftDecimalChar(self)
 | GetSignedForegroundColour(self)
 | GetUseFixedWidthFont(self)
 | GetUseParensForNegatives(self)
 | GetValidBackgroundColour(self)
 | GetValidFunc(self)
 | GetValidRange(self)
 | GetValidRegex(self)
 | GetValidRequired(self)
 | SetAutoCompleteKeycodes(self, value)
 | SetAutoformat(self, value)
 | SetAutoSelect(self, value)
 | SetChoiceRequired(self, value)
 | SetChoices(self, value)
 | SetCompareNoCase(self, value)
 | SetDatestyle(self, value)
 | SetDecimalChar(self, value)
 | SetDefaultEncoding(self, value)
 | SetDefaultValue(self, value)
 | SetDemo(self, value)
 | SetDescription(self, value)
 | SetEmptyBackgroundColour(self, value)
 | SetEmptyInvalid(self, value)
 | SetExcludeChars(self, value)
 | SetFields(self, value)
 | SetFillChar(self, value)
 | SetFormatcodes(self, value)
 | SetGroupChar(self, value)
 | SetIncludeChars(self, value)
 | SetInvalidBackgroundColour(self, value)
 | SetMask(self, value)
 | SetRetainFieldValidation(self, value)
 | SetShiftDecimalChar(self, value)
 | SetSignedForegroundColour(self, value)
 | SetUseFixedWidthFont(self, value)
 | SetUseParensForNegatives(self, value)
 | SetValidBackgroundColour(self, value)
 | SetValidFunc(self, value)
 | SetValidRange(self, value)
 | SetValidRegex(self, value)
 | SetValidRequired(self, value)

Class Variable Summary
list | exposed_basectrl_params = ['demo', 'retainFieldValidatio...
str | param = 'emptyInvalid'
str | propname = 'EmptyInvalid'

Class Variable Details

exposed_basectrl_params

Type:
list
Value:
['demo',
 'retainFieldValidation',
 'emptyBackgroundColour',
 'fields',
 'datestyle',
 'validBackgroundColour',
 'mask',
 'autoCompleteKeycodes',
...

param

Type:
str
Value:
'emptyInvalid'

propname

Type:
str
Value:
'EmptyInvalid'

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:22 2005 http://epydoc.sf.net


wx.lib.masked.maskededit.MaskedEditMixin

Package wx :: Package lib :: Package masked :: Module maskededit :: Class MaskedEditMixin
[frames | no frames]

Class MaskedEditMixin

Known Subclasses:
BaseMaskedComboBox, BaseMaskedTextCtrl

This class allows us to abstract the masked edit functionality that could be associated with any text entry control. (eg. wx.TextCtrl, wx.ComboBox, etc.) It forms the basis for all of the lib.masked controls.

Method Summary
 | __init__(self, name, **kwargs) This is the "constructor" for setting up the mixin variable parameters for the composite class.
 | ClearValue(self) Blanks the current control value by replacing it with the default value.
 | GetCtrlParameter(self, paramname) Routine for retrieving the value of any given parameter
 | GetFieldParameter(self, field_index, paramname) Routine provided for getting a parameter of an individual field.
 | GetMaskParameter(self, paramname) old name for the GetCtrlParameters function (DEPRECATED)
 | GetPlainValue(self, candidate) Returns control's value stripped of the template text.
 | IsDefault(self, value) Returns True if the value specified (or the value of the control if not specified) is equal to the default value.
 | IsEmpty(self, value) Returns True if control is equal to an empty value.
 | IsValid(self, value) Indicates whether the value specified (or the current value of the control if not specified) is considered valid.
 | SetCtrlParameters(self, **kwargs) This public function can be used to set individual or multiple masked edit parameters after construction.
 | SetFieldParameters(self, field_index, **kwargs) Routine provided to modify the parameters of a given field.
 | SetMaskParameters(self, **kwargs) old name for the SetCtrlParameters function (DEPRECATED)

Class Variable Summary
dict valid_ctrl_params = {'demo': False, 'foregroundColour': ...

Method Details

__init__(self, name='MaskedEdit', **kwargs)
(Constructor)

This is the "constructor" for setting up the mixin variable parameters for the composite class.

ClearValue(self)

Blanks the current control value by replacing it with the default value.

GetCtrlParameter(self, paramname)

Routine for retrieving the value of any given parameter

GetFieldParameter(self, field_index, paramname)

Routine provided for getting a parameter of an individual field.

GetMaskParameter(self, paramname)

old name for the GetCtrlParameters function (DEPRECATED)

GetPlainValue(self, candidate=None)

Returns control's value stripped of the template text. plainvalue = MaskedEditMixin.GetPlainValue()

IsDefault(self, value=None)

Returns True if the value specified (or the value of the control if not specified) is equal to the default value.

IsEmpty(self, value=None)

Returns True if control is equal to an empty value. (Empty means all editable positions in the template == fillChar.)

IsValid(self, value=None)

Indicates whether the value specified (or the current value of the control if not specified) is considered valid.

SetCtrlParameters(self, **kwargs)

This public function can be used to set individual or multiple masked edit parameters after construction. (See maskededit module overview for the list of valid parameters.)

SetFieldParameters(self, field_index, **kwargs)

Routine provided to modify the parameters of a given field. Because changes to fields can affect the overall control, direct access to the fields is prevented, and the control is always "reconfigured" after setting a field parameter. (See maskededit module overview for the list of valid field-level parameters.)

SetMaskParameters(self, **kwargs)

old name for the SetCtrlParameters function (DEPRECATED)

Class Variable Details

valid_ctrl_params

Type:
dict
Value:
{'autoCompleteKeycodes': [],
 'autoformat': '',
 'datestyle': 'MDY',
 'defaultEncoding': 'latin1',
 'demo': False,
 'emptyBackgroundColour': 'White',
 'fields': {},
 'foregroundColour': 'Black',
...

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:58 2005 http://epydoc.sf.net


wx.lib.masked.maskededit

Package wx :: Package lib :: Package masked :: Module maskededit
[frames | no frames]

Module wx.lib.masked.maskededit

masked.TextCtrl:

is a sublassed text control that can carefully control the user's input based on a mask string you provide.

General usage example:

control = masked.TextCtrl( win, -1, '', mask = '(###) ###-####')

The example above will create a text control that allows only numbers to be entered and then only in the positions indicated in the mask by the # sign.

masked.ComboBox:
is a similar subclass of wxComboBox that allows the same sort of masking, but also can do auto-complete of values, and can require the value typed to be in the list of choices to be colored appropriately.
masked.Ctrl:

is actually a factory function for several types of masked edit controls:

masked.TextCtrl | standard masked edit text box
masked.ComboBox | adds combobox capabilities
masked.IpAddrCtrl | adds special semantics for IP address entry
masked.TimeCtrl | special subclass handling lots of types as values
masked.NumCtrl | special subclass handling numeric values

It works by looking for a controlType parameter in the keyword arguments of the control, to determine what kind of instance to return. If not specified as a keyword argument, the default control type returned will be masked.TextCtrl.

Each of the above classes has its own set of arguments, but masked.Ctrl provides a single "unified" interface for masked controls. Those for masked.TextCtrl, masked.ComboBox and masked.IpAddrCtrl are all documented below; the others have their own demo pages and interface descriptions. (See end of following discussion for how to configure the wx.MaskedCtrl() to select the above control types.)

Initialization Parameters

mask

Allowed mask characters and function:

Character | Function
# Allow numeric only (0-9)
N | Allow letters and numbers (0-9)
A | Allow uppercase letters only
a | Allow lowercase letters only
C | Allow any letter, upper or lower
X | Allow string.letters, string.punctuation, string.digits
& Allow string.punctuation only
* Allow any ansi character

These controls define these sets of characters using string.letters, string.uppercase, etc. These sets are affected by the system locale setting, so in order to have the masked controls accept characters that are specific to your users' language, your application should set the locale. For example, to allow international characters to be used in the above masks, you can place the following in your code as part of your application's initialization code:

import locale
locale.setlocale(locale.LC_ALL, '')

The controls now also support (by popular demand) all "ansi" chars, that is, all ascii codes between 32 and 255, by use of the * mask character.

Using these mask characters, a variety of template masks can be built. See the demo for some other common examples include date+time, social security number, etc. If any of these characters are needed as template rather than mask characters, they can be escaped with , ie. N means "literal N". (use for literal backslash, as in: r'CCCNNN'.)

Note:
Masks containing only # characters and one optional decimal point character are handled specially, as "numeric" controls. Such controls have special handling for typing the '-' key, handling the "decimal point" character as truncating the integer portion, optionally allowing grouping characters and so forth. There are several parameters and format codes that only make sense when combined with such masks, eg. groupChar, decimalChar, and so forth (see below). These allow you to construct reasonable numeric entry controls.
Note:
Changing the mask for a control deletes any previous field classes (and any associated validation or formatting constraints) for them.
useFixedWidthFont
By default, masked edit controls use a fixed width font, so that the mask characters are fixed within the control, regardless of subsequent modifications to the value. Set to False if having the control font be the same as other controls is required. (This is a control-level parameter.)
defaultEncoding
(Applies to unicode systems only) By default, the default unicode encoding used is latin1, or iso-8859-1. If necessary, you can set this control-level parameter to govern the codec used to decode your keyboard inputs. (This is a control-level parameter.)
formatcodes
These other properties can be passed to the class when instantiating it:

Formatcodes are specified as a string of single character formatting codes that modify behavior of the control:

_  Allow spaces
!  Force upper
^  Force lower
R  Right-align field(s)
r  Right-insert in field(s) (implies R)
<  Stay in field until explicit navigation out of it

>  Allow insert/delete within partially filled fields (as
   opposed to the default "overwrite" mode for fixed-width
   masked edit controls.)  This allows single-field controls
   or each field within a multi-field control to optionally
   behave more like standard text controls.
   (See EMAIL or phone number autoformat examples.)

   *Note: This also governs whether backspace/delete operations
   shift contents of field to right of cursor, or just blank the
   erased section.

   Also, when combined with 'r', this indicates that the field
   or control allows right insert anywhere within the current
   non-empty value in the field.  (Otherwise right-insert behavior
   is only performed to when the entire right-insertable field is
   selected or the cursor is at the right edge of the field.*

,  Allow grouping character in integer fields of numeric controls
   and auto-group/regroup digits (if the result fits) when leaving
   such a field.  (If specified, .SetValue() will attempt to
   auto-group as well.)
   ',' is also the default grouping character.  To change the
   grouping character and/or decimal character, use the groupChar
   and decimalChar parameters, respectively.
   Note: typing the "decimal point" character in such fields will
   clip the value to that left of the cursor for integer
   fields of controls with "integer" or "floating point" masks.
   If the ',' format code is specified, this will also cause the
   resulting digits to be regrouped properly, using the current
   grouping character.
-  Prepend and reserve leading space for sign to mask and allow
   signed values (negative #s shown in red by default.) Can be
   used with argument useParensForNegatives (see below.)
0  integer fields get leading zeros
D  Date[/time] field
T  Time field
F  Auto-Fit: the control calulates its size from
   the length of the template mask
V  validate entered chars against validRegex before allowing them
   to be entered vs. being allowed by basic mask and then having
   the resulting value just colored as invalid.
   (See USSTATE autoformat demo for how this can be used.)
S  select entire field when navigating to new field

fillChar

defaultValue

These controls have two options for the initial state of the control. If a blank control with just the non-editable characters showing is desired, simply leave the constructor variable fillChar as its default (' '). If you want some other character there, simply change the fillChar to that value. Note: changing the control's fillChar will implicitly reset all of the fields' fillChars to this value.

If you need different default characters in each mask position, you can specify a defaultValue parameter in the constructor, or set them for each field individually. This value must satisfy the non-editable characters of the mask, but need not conform to the replaceable characters.

groupChar

decimalChar

These parameters govern what character is used to group numbers and is used to indicate the decimal point for numeric format controls. The default groupChar is ',', the default decimalChar is '.' By changing these, you can customize the presentation of numbers for your location.

Eg:

formatcodes = ',', groupChar='''                  allows  12'345.34
formatcodes = ',', groupChar='.', decimalChar=','  allows  12.345,34

(These are control-level parameters.)

shiftDecimalChar
The default "shiftDecimalChar" (used for "backwards-tabbing" until shift-tab is fixed in wxPython) is '>' (for QUERTY keyboards.) for other keyboards, you may want to customize this, eg '?' for shift ',' on AZERTY keyboards, ':' or ';' for other European keyboards, etc. (This is a control-level parameter.)
useParensForNegatives=False
This option can be used with signed numeric format controls to indicate signs via () rather than '-'. (This is a control-level parameter.)
autoSelect=False
This option can be used to have a field or the control try to auto-complete on each keystroke if choices have been specified.
autoCompleteKeycodes=[]

By default, DownArrow, PageUp and PageDown will auto-complete a partially entered field. Shift-DownArrow, Shift-UpArrow, PageUp and PageDown will also auto-complete, but if the field already contains a matched value, these keys will cycle through the list of choices forward or backward as appropriate. Shift-Up and Shift-Down also take you to the next/previous field after any auto-complete action.

Additional auto-complete keys can be specified via this parameter. Any keys so specified will act like PageDown. (This is a control-level parameter.)

Validating User Input

There are a variety of initialization parameters that are used to validate user input. These parameters can apply to the control as a whole, and/or to individual fields:

excludeChars | A string of characters to exclude even if otherwise allowed
includeChars | A string of characters to allow even if otherwise disallowed
validRegex | Use a regular expression to validate the contents of the text box
validRange | Pass a rangeas list (low,high) to limit numeric fields/values
choices | A list of strings that are allowed choices for the control.
choiceRequired | value must be member of choices list
compareNoCase | Perform case-insensitive matching when validating against list Note: for masked.ComboBox, this defaults to True.
emptyInvalid | Boolean indicating whether an empty value should be considered invalid
validFunc | A function to call of the form: bool = func(candidate_value) which will return True if the candidate_value satisfies some external criteria for the control in addition to the the other validation, or False if not. (This validation is applied last in the chain of validations.)
validRequired | Boolean indicating whether or not keys that are allowed by the mask, but result in an invalid value are allowed to be entered into the control. Setting this to True implies that a valid default value is set for the control.
retainFieldValidation | False by default; if True, this allows individual fields to retain their own validation constraints independently of any subsequent changes to the control's overall parameters. (This is a control-level parameter.)
validator | Validators are not normally needed for masked controls, because of the nature of the validation and control of input. However, you can supply one to provide data transfer routines for the controls.

Coloring Behavior

The following parameters have been provided to allow you to change the default coloring behavior of the control. These can be set at construction, or via the .SetCtrlParameters() function. Pass a color as string e.g. 'Yellow':

emptyBackgroundColour | Control Background color when identified as empty. Default=White
invalidBackgroundColour | Control Background color when identified as Not valid. Default=Yellow
validBackgroundColour | Control Background color when identified as Valid. Default=white

The following parameters control the default foreground color coloring behavior of the control. Pass a color as string e.g. 'Yellow':

foregroundColour | Control foreground color when value is not negative. Default=Black
signedForegroundColour | Control foreground color when value is negative. Default=Red

Fields

Each part of the mask that allows user input is considered a field. The fields are represented by their own class instances. You can specify field-specific constraints by constructing or accessing the field instances for the control and then specifying those constraints via parameters.
fields

This parameter allows you to specify Field instances containing constraints for the individual fields of a control, eg: local choice lists, validation rules, functions, regexps, etc. It can be either an ordered list or a dictionary. If a list, the fields will be applied as fields 0, 1, 2, etc. If a dictionary, it should be keyed by field index. the values should be a instances of maskededit.Field.

Any field not represented by the list or dictionary will be implicitly created by the control.

Eg:

fields = [ Field(formatcodes='_r'), Field('choices=['a', 'b', 'c']) ]

Or:

fields = {
           1: ( Field(formatcodes='_R', choices=['a', 'b', 'c']),
           3: ( Field(choices=['01', '02', '03'], choiceRequired=True)
         }

The following parameters are available for individual fields, with the same semantics as for the whole control but applied to the field in question:

fillChar | if set for a field, it will override the control's fillChar for that field
groupChar | if set for a field, it will override the control's default
defaultValue | sets field-specific default value; overrides any default from control
compareNoCase | overrides control's settings
emptyInvalid | determines whether field is required to be filled at all times
validRequired | if set, requires field to contain valid value

If any of the above parameters are subsequently specified for the control as a whole, that new value will be propagated to each field, unless the retainFieldValidation control-level parameter is set.

formatcodes Augments control's settings
excludeChars ' ' '
includeChars ' ' '
validRegex ' ' '
validRange ' ' '
choices ' ' '
choiceRequired ' ' '
validFunc ' ' '

Control Class Functions

.GetPlainValue(value=None)
Returns the value specified (or the control's text value not specified) without the formatting text. In the example above, might return phone no='3522640075', whereas control.GetValue() would return '(352) 264-0075'
.ClearValue()
Returns the control's value to its default, and places the cursor at the beginning of the control.
.SetValue()

Does "smart replacement" of passed value into the control, as does the .Paste() method. As with other text entry controls, the .SetValue() text replacement begins at left-edge of the control, with missing mask characters inserted as appropriate. .SetValue will also adjust integer, float or date mask entry values, adding commas, auto-completing years, etc. as appropriate. For "right-aligned" numeric controls, it will also now automatically right-adjust any value whose length is less than the width of the control before attempting to set the value. If a value does not follow the format of the control's mask, or will not fit into the control, a ValueError exception will be raised.

Eg:

mask = '(###) ###-####'
    .SetValue('1234567890')           => '(123) 456-7890'
    .SetValue('(123)4567890')         => '(123) 456-7890'
    .SetValue('(123)456-7890')        => '(123) 456-7890'
    .SetValue('123/4567-890')         => illegal paste; ValueError

mask = '#{6}.#{2}', formatcodes = '_,-',
    .SetValue('111')                  => ' 111   .  '
    .SetValue(' %9.2f' % -111.12345 ) => '   -111.12'
    .SetValue(' %9.2f' % 1234.00 )    => '  1,234.00'
    .SetValue(' %9.2f' % -1234567.12345 ) => insufficient room; ValueError

mask = '#{6}.#{2}', formatcodes = '_,-R'  # will right-adjust value for right-aligned control
    .SetValue('111')                  => padded value misalignment ValueError: "       111" will not fit
    .SetValue('%.2f' % 111 )          => '    111.00'
    .SetValue('%.2f' % -111.12345 )   => '   -111.12'
.IsValid(value=None)
Returns True if the value specified (or the value of the control if not specified) passes validation tests
.IsEmpty(value=None)
Returns True if the value specified (or the value of the control if not specified) is equal to an "empty value," ie. all editable characters == the fillChar for their respective fields.
.IsDefault(value=None)
Returns True if the value specified (or the value of the control if not specified) is equal to the initial value of the control.
.Refresh()
Recolors the control as appropriate to its current settings.
.SetCtrlParameters(**kwargs)

This function allows you to set up and/or change the control parameters after construction; it takes a list of key/value pairs as arguments, where the keys can be any of the mask-specific parameters in the constructor.

Eg:

ctl = masked.TextCtrl( self, -1 )
ctl.SetCtrlParameters( mask='###-####',
                       defaultValue='555-1212',
                       formatcodes='F')
.GetCtrlParameter(parametername)
This function allows you to retrieve the current value of a parameter from the control.
Note: Each of the control parameters can also be set using its
own Set and Get function. These functions follow a regular form: All of the parameter names start with lower case; for their corresponding Set/Get function, the parameter name is capitalized.

Eg:

ctl.SetMask('###-####')
ctl.SetDefaultValue('555-1212')
ctl.GetChoiceRequired()
ctl.GetFormatcodes()
Note: After any change in parameters, the choices for the
control are reevaluated to ensure that they are still legal. If you have large choice lists, it is therefore more efficient to set parameters before setting the choices available.
.SetFieldParameters(field_index, **kwargs)
This function allows you to specify change individual field parameters after construction. (Indices are 0-based.)
.GetFieldParameter(field_index, parametername)
Allows the retrieval of field parameters after construction

The control detects certain common constructions. In order to use the signed feature (negative numbers and coloring), the mask has to be all numbers with optionally one decimal point. Without a decimal (e.g. '######', the control will treat it as an integer value. With a decimal (e.g. '###.##'), the control will act as a floating point control (i.e. press decimal to 'tab' to the decimal position). Pressing decimal in the integer control truncates the value. However, for a true numeric control, masked.NumCtrl provides all this, and true numeric input/output support as well.

Check your controls by calling each control's .IsValid() function and the .IsEmpty() function to determine which controls have been a) filled in and b) filled in properly.

Regular expression validations can be used flexibly and creatively. Take a look at the demo; the zip-code validation succeeds as long as the first five numerals are entered. the last four are optional, but if any are entered, there must be 4 to be valid.

masked.Ctrl Configuration

masked.Ctrl works by looking for a special controlType parameter in the variable arguments of the control, to determine what kind of instance to return. controlType can be one of:

controlTypes.TEXT
controlTypes.COMBO
controlTypes.IPADDR
controlTypes.TIME
controlTypes.NUMBER

These constants are also available individually, ie, you can use either of the following:

from wxPython.wx.lib.masked import MaskedCtrl, controlTypes
from wxPython.wx.lib.masked import MaskedCtrl, COMBO, TEXT, NUMBER, IPADDR

If not specified as a keyword argument, the default controlType is controlTypes.TEXT.

Classes
Field | This class manages the individual fields in a masked edit control.
MaskedEditAccessorsMixin | To avoid a ton of boiler-plate, and to automate the getter/setter generation for each valid control parameter so we never forget to add the functions when adding parameters, this class programmatically adds the masked edit mixin parameters to itself.
MaskedEditMixin | This class allows us to abstract the masked edit functionality that could be associated with any text entry control.

Variable Summary
str | am_pm_exclude = 'BCDEFGHIJKLMNOQRSTUVWXYZ\x8a\x8c\x8e\x9...
str | ansichars = ' !"#$%&\'()*+,-./0123456789:;<=>?@ABCDEFGHI...
list | autoformats = [('24HRTIMEHHMM', '24Hr HH:MM\n(see TimeCt...
str | charmonths = '(Jan|Feb|Mar|Apr|May|Jun|Jul|Aug|Sep|Oct|N...
dict | charmonths_dict = {'mar': 3, 'feb': 2, 'aug': 8, 'sep': ...
tuple | control = (8, 127, 1, 3, 19, 22, 24, 26)
str | days = '(01|02|03|04|05|06|07|08|09|10|11|12|13|14|15|16...
str | hours = '(0\\d| \\d|1[012])'
tuple | maskchars = ('#', 'A', 'a', 'X', 'C', 'N', '*', '&')
dict | masktags = {'USPHONEFULLEXT': {'formatcodes': 'F^->', 'm...
str | milhours = '(00|01|02|03|04|05|06|07|08|09|10|11|12|13|1...
str | minutes = '(00|01|02|03|04|05|06|07|08|09|10|11|12|13|14...
str | months = '(01|02|03|04|05|06|07|08|09|10|11|12)'
tuple | nav = (8, 316, 318, 317, 319, 9, 315, 314, 13, 312, 313)
str | seconds = '(00|01|02|03|04|05|06|07|08|09|10|11|12|13|14...
list | state_names = ['Alabama', 'Alaska', 'Arizona', 'Arkansas...
list | states = ['AL', 'AK', 'AZ', 'AR', 'CA', 'CO', 'CT', 'DE'...
int | WXK_CTRL_C = 3
int | WXK_CTRL_S = 19
int | WXK_CTRL_V = 22
int | WXK_CTRL_X = 24
int | WXK_CTRL_Z = 26

Variable Details

am_pm_exclude

Type:
str
Value:
'BCDEFGHIJKLMNOQRSTUVWXYZ\x8a\x8c\x8e\x9f\xc0\xc1\xc2\xc3\xc4\xc5\xc6\\
xc7\xc8\xc9\xca\xcb\xcc\xcd\xce\xcf\xd0\xd1\xd2\xd3\xd4\xd5\xd6\xd8\xd\
9\xda\xdb\xdc\xdd\xde'

ansichars

Type:
str
Value:
' !"#$%&\'()*+,-./0123456789:;<=>?@ABCDEFGHIJKLMNOPQRSTUVWXYZ[\\]^_`ab\
cdefghijklmnopqrstuvwxyz{|}~\x7f\x80\x81\x82\x83\x84\x85\x86\x87\x88\x\
89\x8a\x8b\x8c\x8d\x8e\x8f\x90\x91\x92\x93\x94\x95\x96\x97\x98\x99\x9a\
\x9b\x9c\x9d\x9e\x9f\xa0\xa1\xa2\xa3\xa4\xa5\xa6\xa7\xa8\xa9\xaa\xab\x\
ac\xad\xae\xaf\xb0\xb1\xb2\xb3\xb4\xb5\xb6\xb7\xb8\xb9\xba\xbb\xbc\xbd\
\xbe\xbf\xc0\xc1\xc2\xc3\xc4\xc5\xc6\xc7\xc8\xc9\xca\xcb\xcc\xcd\xce\x\
cf\xd0\xd1\xd2\xd3\xd4\xd5\xd6\xd7\xd8\xd9\xda\xdb\xdc\xdd\xde\xdf\xe0\
\xe1\xe2\xe3\xe4\xe5\xe6\xe7\xe8\xe9\xea\xeb\xec\xed\xee\xef\xf0\xf1\x\
...

autoformats

Type:
list
Value:
[('24HRTIMEHHMM', '24Hr HH:MM\n(see TimeCtrl)'),
 ('24HRTIMEHHMMSS', '24Hr HH:MM:SS\n(see TimeCtrl)'),
 ('AGE', 'Age'),
 ('CREDITCARD', 'Credit Card'),
 ('EMAIL', 'Email address'),
 ('EUDATE24HRTIMEDDMMYYYY.HHMM', 'DD.MM.YYYY 24Hr Time\n(w/o seconds)'\
),
 ('EUDATE24HRTIMEDDMMYYYY.HHMMSS', 'DD.MM.YYYY 24Hr Time'),
...

charmonths

Type:
str
Value:
'(Jan|Feb|Mar|Apr|May|Jun|Jul|Aug|Sep|Oct|Nov|Dec|JAN|FEB|MAR|APR|MAY|\
JUN|JUL|AUG|SEP|OCT|NOV|DEC|jan|feb|mar|apr|may|jun|jul|aug|sep|oct|no\
v|dec)'

charmonths_dict

Type:
dict
Value:
{'apr': 4,
 'aug': 8,
 'dec': 12,
 'feb': 2,
 'jan': 1,
 'jul': 7,
 'jun': 6,
 'mar': 3,
...

control

Type:
tuple
Value:
(8, 127, 1, 3, 19, 22, 24, 26)

days

Type:
str
Value:
'(01|02|03|04|05|06|07|08|09|10|11|12|13|14|15|16|17|18|19|20|21|22|23\
|24|25|26|27|28|29|30|31)'

hours

Type:
str
Value:
'(0\\d| \\d|1[012])'

maskchars

Type:
tuple
Value:
('#', 'A', 'a', 'X', 'C', 'N', '*', '&')

masktags

Type:
dict
Value:
{'24HRTIMEHHMM': {'description': '24Hr HH:MM\n(see TimeCtrl)',
                  'formatcodes': 'TF',
                  'mask': '##:##',
                  'validRegex': '^(00|01|02|03|04|05|06|07|08|09|10|11\
|12|13|14|15|16|17|18|19|20|21|22|23):(00|01|02|03|04|05|06|07|08|09|1\
0|11|12|13|14|15|16|17|18|19|20|21|22|23|24|25|26|27|28|29|30|31|32|33\
|34|35|36|37|38|39|40|41|42|43|44|45|46|47|48|49|50|51|52|53|54|55|56|\
57|58|59)'},
...

milhours

Type:
str
Value:
'(00|01|02|03|04|05|06|07|08|09|10|11|12|13|14|15|16|17|18|19|20|21|22\
|23)'

minutes

Type:
str
Value:
'(00|01|02|03|04|05|06|07|08|09|10|11|12|13|14|15|16|17|18|19|20|21|22\
|23|24|25|26|27|28|29|30|31|32|33|34|35|36|37|38|39|40|41|42|43|44|45|\
46|47|48|49|50|51|52|53|54|55|56|57|58|59)'

months

Type:
str
Value:
'(01|02|03|04|05|06|07|08|09|10|11|12)'

nav

Type:
tuple
Value:
(8, 316, 318, 317, 319, 9, 315, 314, 13, 312, 313)

seconds

Type:
str
Value:
'(00|01|02|03|04|05|06|07|08|09|10|11|12|13|14|15|16|17|18|19|20|21|22\
|23|24|25|26|27|28|29|30|31|32|33|34|35|36|37|38|39|40|41|42|43|44|45|\
46|47|48|49|50|51|52|53|54|55|56|57|58|59)'

state_names

Type:
list
Value:
['Alabama',
 'Alaska',
 'Arizona',
 'Arkansas',
 'California',
 'Colorado',
 'Connecticut',
 'Delaware',
...

states

Type:
list
Value:
['AL', 'AK', 'AZ', 'AR', 'CA', 'CO', 'CT', 'DE', 'DC']

WXK_CTRL_C

Type:
int
Value:
3

WXK_CTRL_S

Type:
int
Value:
19

WXK_CTRL_V

Type:
int
Value:
22

WXK_CTRL_X

Type:
int
Value:
24

WXK_CTRL_Z

Type:
int
Value:
26

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:47 2005 http://epydoc.sf.net


wx.lib.masked.numctrl.NumberUpdatedEvent

Package wx :: Package lib :: Package masked :: Module numctrl :: Class NumberUpdatedEvent
[frames | no frames]

Type NumberUpdatedEvent

object --+
         |
    Object --+
             |
         Event --+
                 |
      CommandEvent --+
                     |
        PyCommandEvent --+
                         |
                        NumberUpdatedEvent

Used to fire an EVT_NUM event whenever the value in a NumCtrl changes.

Method Summary
 | __init__(self, id, value, object)
 | GetValue(self) Retrieve the value of the control at the time this event was generated.

Method Details

GetValue(self)

Retrieve the value of the control at the time this event was generated.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:03 2005 http://epydoc.sf.net


wx.lib.masked.numctrl.NumCtrlAccessorsMixin

Package wx :: Package lib :: Package masked :: Module numctrl :: Class NumCtrlAccessorsMixin
[frames | no frames]

Class NumCtrlAccessorsMixin

Known Subclasses:
NumCtrl

Defines masked.NumCtrl's list of attributes having their own Get/Set functions, ignoring those that make no sense for a numeric control.

Method Summary
 | GetAutoSize(self)
 | GetDecimalChar(self)
 | GetDefaultValue(self)
 | GetDescription(self)
 | GetEmptyBackgroundColour(self)
 | GetEmptyInvalid(self)
 | GetGroupChar(self)
 | GetInvalidBackgroundColour(self)
 | GetShiftDecimalChar(self)
 | GetSignedForegroundColour(self)
 | GetUseFixedWidthFont(self)
 | GetUseParensForNegatives(self)
 | GetValidBackgroundColour(self)
 | GetValidFunc(self)
 | GetValidRequired(self)
 | SetAutoSize(self, value)
 | SetDecimalChar(self, value)
 | SetDefaultValue(self, value)
 | SetDescription(self, value)
 | SetEmptyBackgroundColour(self, value)
 | SetEmptyInvalid(self, value)
 | SetGroupChar(self, value)
 | SetInvalidBackgroundColour(self, value)
 | SetShiftDecimalChar(self, value)
 | SetSignedForegroundColour(self, value)
 | SetUseFixedWidthFont(self, value)
 | SetUseParensForNegatives(self, value)
 | SetValidBackgroundColour(self, value)
 | SetValidFunc(self, value)
 | SetValidRequired(self, value)

Class Variable Summary
tuple | exposed_basectrl_params = ('decimalChar', 'shiftDecimalC...
str | param = 'validRequired'
str | propname = 'ValidRequired'

Class Variable Details

exposed_basectrl_params

Type:
tuple
Value:
('decimalChar',
 'shiftDecimalChar',
 'groupChar',
 'useParensForNegatives',
 'defaultValue',
 'description',
 'useFixedWidthFont',
 'autoSize',
...

param

Type:
str
Value:
'validRequired'

propname

Type:
str
Value:
'ValidRequired'

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:03 2005 http://epydoc.sf.net


wx.lib.masked.numctrl.NumCtrl

Package wx :: Package lib :: Package masked :: Module numctrl :: Class NumCtrl
[frames | no frames]

Type NumCtrl

           MaskedEditMixin --+
                             |
object --+                   |
         |                   |
    Object --+               |
             |               |
    EvtHandler --+           |
                 |           |
            Window --+       |
                     |       |
               Control --+   |
                         |   |
                  TextCtrl --+
                             |
            BaseMaskedTextCtrl --+
                                 |
         NumCtrlAccessorsMixin --+
                                 |
                                NumCtrl

Masked edit control supporting "native" numeric values, ie. .SetValue(3), for example, and supporting a variety of formatting options, including automatic rounding specifiable precision, grouping and decimal place characters, etc.

Method Summary
 | __init__(self, parent, id, value, pos, size, style, validator, name, **kwargs)
 | GetAllowNegative(self) (For regularization of property accessors)
 | GetAllowNone(self) (For regularization of property accessors)
 | GetAutoSize(self)
 | GetBounds(self) This function returns a two-tuple (min,max), indicating the current bounds of the control.
 | GetDecimalChar(self)
 | GetFraction(self, candidate) Returns the fractional portion of the value as a float.
 | GetFractionWidth(self)
 | GetGroupChar(self)
 | GetGroupDigits(self) (For regularization of property accessors)
 | GetIntegerWidth(self)
 | GetLimited(self) (For regularization of property accessors)
 | GetMax(self) Gets the maximum value of the control.
 | GetMin(self) Gets the lower bound value of the control.
 | GetSelectOnEntry(self)
 | GetValue(self) Returns the current numeric value of the control.
 | IsGroupingAllowed(self)
 | IsInBounds(self, value) Returns True if no value is specified and the current value of the control falls within the current bounds.
 | IsLimited(self) Returns True if the control is currently limiting the value to fall within the current bounds.
 | IsNegativeAllowed(self)
 | IsNoneAllowed(self)
 | OnTextChange(self, event) Handles an event indicating that the text control's value has changed, and issue EVT_NUM event.
 | SetAllowNegative(self, value)
 | SetAllowNone(self, allow_none) Change the behavior of the validation code, allowing control to have a value of None or not, as appropriate.
 | SetAutoSize(self, value)
 | SetBounds(self, min, max) This function is a convenience function for setting the min and max values at the same time.
 | SetDecimalChar(self, value)
 | SetFractionWidth(self, value)
 | SetGroupChar(self, value)
 | SetGroupDigits(self, value)
 | SetIntegerWidth(self, value)
 | SetLimited(self, limited) If called with a value of True, this function will cause the control to limit the value to fall within the bounds currently specified.
 | SetMax(self, max) Sets the maximum value of the control.
 | SetMin(self, min) Sets the minimum value of the control.
 | SetParameters(self, **kwargs) This function is used to initialize and reconfigure the control.
 | SetSelectOnEntry(self, value)
 | SetValue(self, value) Sets the value of the control to the value specified.

Class Variable Summary
dict valid_ctrl_params = {'limited': False, 'autoSize': True,...

Instance Method Details

GetAllowNegative(self)

(For regularization of property accessors)

GetAllowNone(self)

(For regularization of property accessors)

GetBounds(self)

This function returns a two-tuple (min,max), indicating the current bounds of the control. Each value can be None if that bound is not set.

GetFraction(self, candidate=None)

Returns the fractional portion of the value as a float. If there is no fractional portion, the value returned will be 0.0.

GetGroupDigits(self)

(For regularization of property accessors)

GetLimited(self)

(For regularization of property accessors)

GetMax(self)

Gets the maximum value of the control. It will return the current maximum integer, or None if not specified.

GetMin(self)

Gets the lower bound value of the control. It will return None if not specified.

GetValue(self)

Returns the current numeric value of the control.

Overrides:
wx.TextCtrl.GetValue

IsInBounds(self, value=None)

Returns True if no value is specified and the current value of the control falls within the current bounds. This function can also be called with a value to see if that value would fall within the current bounds of the given control.

IsLimited(self)

Returns True if the control is currently limiting the value to fall within the current bounds.

OnTextChange(self, event)

Handles an event indicating that the text control's value has changed, and issue EVT_NUM event. NOTE: using wxTextCtrl.SetValue() to change the control's contents from within a EVT_CHAR handler can cause double text events. So we check for actual changes to the text before passing the events on.

SetAllowNone(self, allow_none)

Change the behavior of the validation code, allowing control to have a value of None or not, as appropriate. If the value of the control is currently None, and allow_none is False, the value of the control will be set to the minimum value of the control, or 0 if no lower bound is set.

SetBounds(self, min=None, max=None)

This function is a convenience function for setting the min and max values at the same time. The function only applies the maximum bound if setting the minimum bound is successful, and returns True only if both operations succeed. NOTE: leaving out an argument will remove the corresponding bound.

SetLimited(self, limited)

If called with a value of True, this function will cause the control to limit the value to fall within the bounds currently specified. If the control's value currently exceeds the bounds, it will then be limited accordingly.

If called with a value of False, this function will disable value limiting, but coloring of out-of-bounds values will still take place if bounds have been set for the control.

SetMax(self, max=None)

Sets the maximum value of the control. If a value of None is provided, then the control will have no explicit maximum value. If the value specified is less than the current minimum value, then the function returns False and the maximum will not change from its current setting. On success, the function returns True.

If successful and the current value is greater than the new upper bound, if the control is limited the value will be automatically adjusted to this maximum value; if not limited, the value in the control will be colored as invalid.

If max > the max value allowed by the width of the control, the function will return False, and the max will not be set.

SetMin(self, min=None)

Sets the minimum value of the control. If a value of None is provided, then the control will have no explicit minimum value. If the value specified is greater than the current maximum value, then the function returns False and the minimum will not change from its current setting. On success, the function returns True.

If successful and the current value is lower than the new lower bound, if the control is limited, the value will be automatically adjusted to the new minimum value; if not limited, the value in the control will be colored as invalid.

If min > the max value allowed by the width of the control, the function will return False, and the min will not be set.

SetParameters(self, **kwargs)

This function is used to initialize and reconfigure the control. See TimeCtrl module overview for available parameters.

SetValue(self, value)

Sets the value of the control to the value specified. The resulting actual value of the control may be altered to conform with the bounds set on the control if limited, or colored if not limited but the value is out-of-bounds. A ValueError exception will be raised if an invalid value is specified.

Overrides:
wx.lib.masked.textctrl.BaseMaskedTextCtrl.SetValue

Class Variable Details

valid_ctrl_params

Type:
dict
Value:
{'allowNegative': True,
 'allowNone': False,
 'autoSize': True,
 'decimalChar': '.',
 'emptyBackgroundColour': 'White',
 'foregroundColour': 'Black',
 'fractionWidth': 0,
 'groupChar': ',',
...

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:10:49 2005 http://epydoc.sf.net


wx.lib.masked.numctrl

Package wx :: Package lib :: Package masked :: Module numctrl
[frames | no frames]

Module wx.lib.masked.numctrl

masked.NumCtrl:
  • allows you to get and set integer or floating point numbers as value,</LI>
  • provides bounds support and optional value limiting,</LI>
  • has the right-insert input style that MaskedTextCtrl supports,</LI>
  • provides optional automatic grouping, sign control and format, grouping and decimal character selection, etc. etc.</LI>

Being derived from masked.TextCtrl, the control only allows fixed-point notation. That is, it has a fixed (though reconfigurable) maximum width for the integer portion and optional fixed width fractional portion.

Here's the API:

from wx.lib.masked import NumCtrl

NumCtrl(
     parent, id = -1,
     value = 0,
     pos = wx.DefaultPosition,
     size = wx.DefaultSize,
     style = 0,
     validator = wx.DefaultValidator,
     name = "masked.number",
     integerWidth = 10,
     fractionWidth = 0,
     allowNone = False,
     allowNegative = True,
     useParensForNegatives = False,
     groupDigits = False,
     groupChar = ',',
     decimalChar = '.',
     min = None,
     max = None,
     limited = False,
     selectOnEntry = True,
     foregroundColour = "Black",
     signedForegroundColour = "Red",
     emptyBackgroundColour = "White",
     validBackgroundColour = "White",
     invalidBackgroundColour = "Yellow",
     autoSize = True
     )
value
If no initial value is set, the default will be zero, or the minimum value, if specified. If an illegal string is specified, a ValueError will result. (You can always later set the initial value with SetValue() after instantiation of the control.)
integerWidth
Indicates how many places to the right of any decimal point should be allowed in the control. This will, perforce, limit the size of the values that can be entered. This number need not include space for grouping characters or the sign, if either of these options are enabled, as the resulting underlying mask is automatically by the control. The default of 10 will allow any 32 bit integer value. The minimum value for integerWidth is 1.
fractionWidth
Indicates how many decimal places to show for numeric value. If default (0), then the control will display and return only integer or long values.
allowNone
Boolean indicating whether or not the control is allowed to be empty, representing a value of None for the control.
allowNegative
Boolean indicating whether or not control is allowed to hold negative numbers.
useParensForNegatives
If true, this will cause negative numbers to be displayed with ()s rather than -, (although '-' will still trigger a negative number.)
groupDigits
Indicates whether or not grouping characters should be allowed and/or inserted when leaving the control or the decimal character is entered.
groupChar
What grouping character will be used if allowed. (By default ',')
decimalChar
If fractionWidth is > 0, what character will be used to represent the decimal point. (By default '.')
min
The minimum value that the control should allow. This can be also be adjusted with SetMin(). If the control is not limited, any value below this bound will result in a background colored with the current invalidBackgroundColour. If the min specified will not fit into the control, the min setting will be ignored.
max
The maximum value that the control should allow. This can be adjusted with SetMax(). If the control is not limited, any value above this bound will result in a background colored with the current invalidBackgroundColour. If the max specified will not fit into the control, the max setting will be ignored.
limited
Boolean indicating whether the control prevents values from exceeding the currently set minimum and maximum values (bounds). If False and bounds are set, out-of-bounds values will result in a background colored with the current invalidBackgroundColour.
selectOnEntry
Boolean indicating whether or not the value in each field of the control should be automatically selected (for replacement) when that field is entered, either by cursor movement or tabbing. This can be desirable when using these controls for rapid data entry.
foregroundColour
Color value used for positive values of the control.
signedForegroundColour
Color value used for negative values of the control.
emptyBackgroundColour
What background color to use when the control is considered "empty." (allow_none must be set to trigger this behavior.)
validBackgroundColour
What background color to use when the control value is considered valid.
invalidBackgroundColour
Color value used for illegal values or values out-of-bounds of the control when the bounds are set but the control is not limited.
autoSize
Boolean indicating whether or not the control should set its own width based on the integer and fraction widths. True by default. <I>Note:</I> Setting this to False will produce seemingly odd behavior unless the control is large enough to hold the maximum specified value given the widths and the sign positions; if not, the control will appear to "jump around" as the contents scroll. (ie. autoSize is highly recommended.)
masked.EVT_NUM(win, id, func)
Respond to a EVT_COMMAND_MASKED_NUMBER_UPDATED event, generated when the value changes. Notice that this event will always be sent when the control's contents changes - whether this is due to user input or comes from the program itself (for example, if SetValue() is called.)
SetValue(int|long|float|string)
Sets the value of the control to the value specified, if possible. The resulting actual value of the control may be altered to conform to the format of the control, changed to conform with the bounds set on the control if limited, or colored if not limited but the value is out-of-bounds. A ValueError exception will be raised if an invalid value is specified.
GetValue()
Retrieves the numeric value from the control. The value retrieved will be either be returned as a long if the fractionWidth is 0, or a float otherwise.
SetParameters(**kwargs)
Allows simultaneous setting of various attributes of the control after construction. Keyword arguments allowed are the same parameters as supported in the constructor.
SetIntegerWidth(value)
Resets the width of the integer portion of the control. The value must be >= 1, or an AttributeError exception will result. This value should account for any grouping characters that might be inserted (if grouping is enabled), but does not need to account for the sign, as that is handled separately by the control.
GetIntegerWidth()
Returns the current width of the integer portion of the control, not including any reserved sign position.
SetFractionWidth(value)
Resets the width of the fractional portion of the control. The value must be >= 0, or an AttributeError exception will result. If 0, the current value of the control will be truncated to an integer value.
GetFractionWidth()
Returns the current width of the fractional portion of the control.
SetMin(min=None)

Resets the minimum value of the control. If a value of <I>None</I> is provided, then the control will have no explicit minimum value. If the value specified is greater than the current maximum value, then the function returns False and the minimum will not change from its current setting. On success, the function returns True.

If successful and the current value is lower than the new lower bound, if the control is limited, the value will be automatically adjusted to the new minimum value; if not limited, the value in the control will be colored as invalid.

If min > the max value allowed by the width of the control, the function will return False, and the min will not be set.

GetMin()
Gets the current lower bound value for the control. It will return None if no lower bound is currently specified.
SetMax(max=None)

Resets the maximum value of the control. If a value of <I>None</I> is provided, then the control will have no explicit maximum value. If the value specified is less than the current minimum value, then the function returns False and the maximum will not change from its current setting. On success, the function returns True.

If successful and the current value is greater than the new upper bound, if the control is limited the value will be automatically adjusted to this maximum value; if not limited, the value in the control will be colored as invalid.

If max > the max value allowed by the width of the control, the function will return False, and the max will not be set.

GetMax()
Gets the current upper bound value for the control. It will return None if no upper bound is currently specified.
SetBounds(min=None,max=None)
This function is a convenience function for setting the min and max values at the same time. The function only applies the maximum bound if setting the minimum bound is successful, and returns True only if both operations succeed. <B><I>Note:</I> leaving out an argument will remove the corresponding bound.
GetBounds()
This function returns a two-tuple (min,max), indicating the current bounds of the control. Each value can be None if that bound is not set.
IsInBounds(value=None)
Returns <I>True</I> if no value is specified and the current value of the control falls within the current bounds. This function can also be called with a value to see if that value would fall within the current bounds of the given control.
SetLimited(bool)
If called with a value of True, this function will cause the control to limit the value to fall within the bounds currently specified. If the control's value currently exceeds the bounds, it will then be limited accordingly. If called with a value of False, this function will disable value limiting, but coloring of out-of-bounds values will still take place if bounds have been set for the control.

GetLimited()

IsLimited()
Returns <I>True</I> if the control is currently limiting the value to fall within the current bounds.
SetAllowNone(bool)
If called with a value of True, this function will cause the control to allow the value to be empty, representing a value of None. If called with a value of False, this function will prevent the value from being None. If the value of the control is currently None, ie. the control is empty, then the value will be changed to that of the lower bound of the control, or 0 if no lower bound is set.

GetAllowNone()

IsNoneAllowed()
Returns <I>True</I> if the control currently allows its value to be None.
SetAllowNegative(bool)
If called with a value of True, this function will cause the control to allow the value to be negative (and reserve space for displaying the sign. If called with a value of False, and the value of the control is currently negative, the value of the control will be converted to the absolute value, and then limited appropriately based on the existing bounds of the control (if any).

GetAllowNegative()

IsNegativeAllowed()
Returns <I>True</I> if the control currently permits values to be negative.
SetGroupDigits(bool)
If called with a value of True, this will make the control automatically add and manage grouping characters to the presented value in integer portion of the control.

GetGroupDigits()

IsGroupingAllowed()
Returns <I>True</I> if the control is currently set to group digits.
SetGroupChar()
Sets the grouping character for the integer portion of the control. (The default grouping character this is ','.
GetGroupChar()
Returns the current grouping character for the control.
SetSelectOnEntry()
If called with a value of <I>True</I>, this will make the control automatically select the contents of each field as it is entered within the control. (The default is True.) GetSelectOnEntry() Returns <I>True</I> if the control currently auto selects the field values on entry.
SetAutoSize(bool)
Resets the autoSize attribute of the control.
GetAutoSize()
Returns the current state of the autoSize attribute for the control.
Classes
NumberUpdatedEvent | Used to fire an EVT_NUM event whenever the value in a NumCtrl changes.
NumCtrl | Masked edit control supporting "native" numeric values, ie.
NumCtrlAccessorsMixin | Defines masked.NumCtrl's list of attributes having their own Get/Set functions, ignoring those that make no sense for a numeric control.

Variable Summary
Logger | dbg = <wx.tools.dbg.Logger instance at 0xb75e916c>
PyEventBinder | EVT_NUM = <wx._core.PyEventBinder object at 0xb75e91cc>
int | MININT = -2147483648
int | wxEVT_COMMAND_MASKED_NUMBER_UPDATED = 10226

Variable Details

dbg

Type:
Logger
Value:
<wx.tools.dbg.Logger instance at 0xb75e916c>

EVT_NUM

Type:
PyEventBinder
Value:
<wx._core.PyEventBinder object at 0xb75e91cc>

MININT

Type:
int
Value:
-2147483648

wxEVT_COMMAND_MASKED_NUMBER_UPDATED

Type:
int
Value:
10226

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:02 2005 http://epydoc.sf.net


wx.lib.masked.textctrl.BaseMaskedTextCtrl

Package wx :: Package lib :: Package masked :: Module textctrl :: Class BaseMaskedTextCtrl
[frames | no frames]

Type BaseMaskedTextCtrl

           MaskedEditMixin --+
                             |
object --+                   |
         |                   |
    Object --+               |
             |               |
    EvtHandler --+           |
                 |           |
            Window --+       |
                     |       |
               Control --+   |
                         |   |
                  TextCtrl --+
                             |
                            BaseMaskedTextCtrl

Known Subclasses:
IpAddrCtrl, NumCtrl, PreMaskedTextCtrl, TextCtrl, TimeCtrl

This is the primary derivation from MaskedEditMixin. It provides a general masked text control that can be configured with different masks.

However, this is done with an extra level of inheritance, so that "general" classes like masked.TextCtrl can have all possible attributes, while derived classes, like masked.TimeCtrl and masked.NumCtrl can prevent exposure of those optional attributes of their base class that do not make sense for their derivation. Therefore, we define:

BaseMaskedTextCtrl(TextCtrl, MaskedEditMixin)

and:

masked.TextCtrl(BaseMaskedTextCtrl, MaskedEditAccessorsMixin).

This allows us to then derive:

masked.NumCtrl( BaseMaskedTextCtrl )

and not have to expose all the same accessor functions for the derived control when they don't all make sense for it.

In practice, BaseMaskedTextCtrl should never be instantiated directly, but should only be used in derived classes.

Method Summary
__init__(self, parent, id, value, pos, size, style, validator, name, setupEventHandling, **kwargs)
__repr__(self)
Clear(self)
Blanks the current control value by replacing it with the default value.
Cut(self)
This function redefines the externally accessible .Cut to be a smart "erase" of the text in question, so as not to corrupt the masked control.
IsModified(self)
This function overrides the raw wx.TextCtrl method, because the masked edit mixin uses SetValue to change the value, which doesn't modify the state of this attribute.
Paste(self)
This function redefines the externally accessible .Paste to be a smart "paste" of the text in question, so as not to corrupt the masked control.
Refresh(self)
This function redefines the externally accessible .Refresh() to validate the contents of the masked control as it refreshes.
SetFont(self, *args, **kwargs)
Set the font, then recalculate control size, if appropriate.
SetValue(self, value)
This function redefines the externally accessible .SetValue() to be a smart "paste" of the text in question, so as not to corrupt the masked control.
Undo(self)
This function defines the undo operation for the control.

Class Variable Summary

Instance Method Details

Clear(self)

Blanks the current control value by replacing it with the default value.

Overrides:
wx.TextCtrl.Clear

Cut(self)

This function redefines the externally accessible .Cut to be a smart "erase" of the text in question, so as not to corrupt the masked control. NOTE: this must be done in the class derived from the base wx control.

Overrides:
wx.TextCtrl.Cut

IsModified(self)

This function overrides the raw wx.TextCtrl method, because the masked edit mixin uses SetValue to change the value, which doesn't modify the state of this attribute. So, the derived control keeps track on each keystroke to see if the value changes, and if so, it's been modified.

Overrides:
wx.TextCtrl.IsModified

Paste(self)

This function redefines the externally accessible .Paste to be a smart "paste" of the text in question, so as not to corrupt the masked control. NOTE: this must be done in the class derived from the base wx control.

Overrides:
wx.TextCtrl.Paste

Refresh(self)

This function redefines the externally accessible .Refresh() to validate the contents of the masked control as it refreshes. NOTE: this must be done in the class derived from the base wx control.

Overrides:
wx.Window.Refresh

SetFont(self, *args, **kwargs)

Set the font, then recalculate control size, if appropriate.

Overrides:
wx.Window.SetFont

SetValue(self, value)

This function redefines the externally accessible .SetValue() to be a smart "paste" of the text in question, so as not to corrupt the masked control. NOTE: this must be done in the class derived from the base wx control.

Overrides:
wx.TextCtrl.SetValue

Undo(self)

This function defines the undo operation for the control. (The default undo is 1-deep.)

Overrides:
wx.TextCtrl.Undo

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:16 2005 http://epydoc.sf.net


wx.lib.masked.textctrl.PreMaskedTextCtrl

Package wx :: Package lib :: Package masked :: Module textctrl :: Class PreMaskedTextCtrl
[frames | no frames]

Type PreMaskedTextCtrl

           MaskedEditMixin --+
                             |
object --+                   |
         |                   |
    Object --+               |
             |               |
    EvtHandler --+           |
                 |           |
            Window --+       |
                     |       |
               Control --+   |
                         |   |
                  TextCtrl --+
                             |
            BaseMaskedTextCtrl --+
                                 |
      MaskedEditAccessorsMixin --+
                                 |
                                PreMaskedTextCtrl

This class exists to support the use of XRC subclassing.

Method Summary
 | __init__(self)
 | OnCreate(self, evt)

Class Variable Summary

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:09 2005 http://epydoc.sf.net


wx.lib.masked.textctrl.TextCtrl

Package wx :: Package lib :: Package masked :: Module textctrl :: Class TextCtrl
[frames | no frames]

Type TextCtrl

           MaskedEditMixin --+
                             |
object --+                   |
         |                   |
    Object --+               |
             |               |
    EvtHandler --+           |
                 |           |
            Window --+       |
                     |       |
               Control --+   |
                         |   |
                  TextCtrl --+
                             |
            BaseMaskedTextCtrl --+
                                 |
      MaskedEditAccessorsMixin --+
                                 |
                                TextCtrl

The "user-visible" masked text control; it is identical to the BaseMaskedTextCtrl class it's derived from. (This extra level of inheritance allows us to add the generic set of masked edit parameters only to this class while allowing other classes to derive from the "base" masked text control, and provide a smaller set of valid accessor functions.) See BaseMaskedTextCtrl for available methods.

Method Summary

Class Variable Summary

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:03 2005 http://epydoc.sf.net


wx.lib.masked.textctrl

Package wx :: Package lib :: Package masked :: Module textctrl
[frames | no frames]

Module wx.lib.masked.textctrl

Provides a generic, fully configurable masked edit text control, as well as a base class from which you can derive masked controls tailored to a specific function. See maskededit module overview for how to configure the control.

Classes
BaseMaskedTextCtrl | This is the primary derivation from MaskedEditMixin.
PreMaskedTextCtrl | This class exists to support the use of XRC subclassing.
TextCtrl | The "user-visible" masked text control; it is identical to the BaseMaskedTextCtrl class it's derived from.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:02 2005 http://epydoc.sf.net


wx.lib.masked.timectrl.TimeCtrlAccessorsMixin

Package wx :: Package lib :: Package masked :: Module timectrl :: Class TimeCtrlAccessorsMixin
[frames | no frames]

Class TimeCtrlAccessorsMixin

Defines TimeCtrl's list of attributes having their own Get/Set functions, ignoring those in the base class that make no sense for a time control.

Method Summary
 | GetDefaultValue(self)
 | GetDescription(self)
 | GetEmptyBackgroundColour(self)
 | GetInvalidBackgroundColour(self)
 | GetUseFixedWidthFont(self)
 | GetValidBackgroundColour(self)
 | GetValidFunc(self)
 | GetValidRequired(self)
 | SetDefaultValue(self, value)
 | SetDescription(self, value)
 | SetEmptyBackgroundColour(self, value)
 | SetInvalidBackgroundColour(self, value)
 | SetUseFixedWidthFont(self, value)
 | SetValidBackgroundColour(self, value)
 | SetValidFunc(self, value)
 | SetValidRequired(self, value)

Class Variable Summary
tuple | exposed_basectrl_params = ('defaultValue', 'description'...
str | param = 'validRequired'
str | propname = 'ValidRequired'

Class Variable Details

exposed_basectrl_params

Type:
tuple
Value:
('defaultValue',
 'description',
 'useFixedWidthFont',
 'emptyBackgroundColour',
 'validBackgroundColour',
 'invalidBackgroundColour',
 'validFunc',
 'validRequired')

param

Type:
str
Value:
'validRequired'

propname

Type:
str
Value:
'ValidRequired'

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:40 2005 http://epydoc.sf.net


wx.lib.masked.timectrl.TimeCtrl

Package wx :: Package lib :: Package masked :: Module timectrl :: Class TimeCtrl
[frames | no frames]

Type TimeCtrl

           MaskedEditMixin --+
                             |
object --+                   |
         |                   |
    Object --+               |
             |               |
    EvtHandler --+           |
                 |           |
            Window --+       |
                     |       |
               Control --+   |
                         |   |
                  TextCtrl --+
                             |
            BaseMaskedTextCtrl --+
                                 |
                                TimeCtrl

Masked control providing several time formats and manipulation of time values.

Method Summary
 | __init__(self, parent, id, value, pos, size, fmt24hr, spinButton, style, validator, name, **kwargs)
 | __repr__(self)
 | BindSpinButton(self, sb) This function binds an externally created spin button to the control, so that up/down events from the button automatically change the control.
 | GetBounds(self, as_string) This function returns a two-tuple (min,max), indicating the current bounds of the control.
 | GetFormat(self)
 | GetMax(self, as_string) Gets the minimum value of the control.
 | GetMin(self, as_string) Gets the minimum value of the control.
 | GetMxDateTime(self, value) Returns the value of the control as an mx.DateTime, with the date portion set to January 1, 1970.
 | GetValue(self, as_wxDateTime, as_mxDateTime, as_wxTimeSpan, as_mxDateTimeDelta) This function returns the value of the display as a string by default, but supports return as a wx.DateTime, mx.DateTime, wx.TimeSpan, or mx.DateTimeDelta, if requested.
 | GetWxDateTime(self, value) This function is the conversion engine for TimeCtrl; it takes one of the following types: time string wxDateTime wxTimeSpan mxDateTime mxDateTimeDelta and converts it to a wx.DateTime that always has Jan 1, 1970 as its date portion, so that range comparisons around values can work using wx.DateTime's built-in comparison function.
 | IsInBounds(self, value) Returns True if no value is specified and the current value of the control falls within the current bounds.
 | IsLimited(self) Returns True if the control is currently limiting the value to fall within any current bounds.
 | IsValid(self, value) Can be used to determine if a given value would be a legal and in-bounds value for the control.
 | SetBounds(self, min, max) This function is a convenience function for setting the min and max values at the same time.
 | SetFormat(self, format)
 | SetInsertionPoint(self, pos) This override records the specified position and associated cell before calling base class' function.
 | SetLimited(self, limited) If called with a value of True, this function will cause the control to limit the value to fall within the bounds currently specified.
 | SetMax(self, max) Sets the maximum value of the control.
 | SetMin(self, min) Sets the minimum value of the control.
 | SetMxDateTime(self, mxdt) Because SetValue can take an mx.DateTime, (if DateTime is importable), this is now just an alias.
 | SetParameters(self, **kwargs) Function providing access to the parameters governing TimeCtrl display and bounds.
 | SetSelection(self, sel_start, sel_to)
 | SetValue(self, value) Validating SetValue function for time values: This function will do dynamic type checking on the value argument, and convert wxDateTime, mxDateTime, or 12/24 format time string into the appropriate format string for the control.
 | SetWxDateTime(self, wxdt) Because SetValue can take a wx.DateTime, this is now just an alias.

Class Variable Summary
dict valid_ctrl_params = {'limited': False, 'displaySeconds':...

Instance Method Details

BindSpinButton(self, sb)

This function binds an externally created spin button to the control, so that up/down events from the button automatically change the control.

GetBounds(self, as_string=False)

This function returns a two-tuple (min,max), indicating the current bounds of the control. Each value can be None if that bound is not set.

GetMax(self, as_string=False)

Gets the minimum value of the control. If None, it will return None. Otherwise it will return the current minimum bound on the control, as a wxDateTime by default, or as a string if as_string argument is True.

GetMin(self, as_string=False)

Gets the minimum value of the control. If None, it will return None. Otherwise it will return the current minimum bound on the control, as a wxDateTime by default, or as a string if as_string argument is True.

GetMxDateTime(self, value=None)

Returns the value of the control as an mx.DateTime, with the date portion set to January 1, 1970.

GetValue(self,
          as_wxDateTime=False,
          as_mxDateTime=False,
          as_wxTimeSpan=False,
          as_mxDateTimeDelta=False)

This function returns the value of the display as a string by default, but supports return as a wx.DateTime, mx.DateTime, wx.TimeSpan, or mx.DateTimeDelta, if requested. (Evaluated in the order above-- first one wins!)

Overrides:
wx.TextCtrl.GetValue

GetWxDateTime(self, value=None)

This function is the conversion engine for TimeCtrl; it takes
one of the following types:
    time string
    wxDateTime
    wxTimeSpan
    mxDateTime
    mxDateTimeDelta
and converts it to a wx.DateTime that always has Jan 1, 1970 as its date
portion, so that range comparisons around values can work using
wx.DateTime's built-in comparison function.  If a value is not
provided to convert, the string value of the control will be used.
If the value is not one of the accepted types, a ValueError will be
raised.

IsInBounds(self, value=None)

Returns True if no value is specified and the current value of the control falls within the current bounds. As the clock is a "circle", both minimum and maximum bounds must be set for a value to ever be considered "out of bounds". This function can also be called with a value to see if that value would fall within the current bounds of the given control.

IsLimited(self)

Returns True if the control is currently limiting the value to fall within any current bounds. Note: can be set even if there are no current bounds.

IsValid(self, value)

Can be used to determine if a given value would be a legal and in-bounds value for the control.

Overrides:
wx.lib.masked.maskededit.MaskedEditMixin.IsValid

SetBounds(self, min=None, max=None)

This function is a convenience function for setting the min and max values at the same time. The function only applies the maximum bound if setting the minimum bound is successful, and returns True only if both operations succeed. NOTE: leaving out an argument will remove the corresponding bound.

SetInsertionPoint(self, pos)

This override records the specified position and associated cell before calling base class' function. This is necessary to handle the optional spin button, because the insertion point is lost when the focus shifts to the spin button.

Overrides:
wx.TextCtrl.SetInsertionPoint

SetLimited(self, limited)

If called with a value of True, this function will cause the control to limit the value to fall within the bounds currently specified. If the control's value currently exceeds the bounds, it will then be limited accordingly.

If called with a value of 0, this function will disable value limiting, but coloring of out-of-bounds values will still take place if bounds have been set for the control.

SetMax(self, max=None)

Sets the maximum value of the control. If a value of None is provided, then the control will have no explicit maximum value. If the value specified is less than the current minimum value, then the function returns False and the maximum will not change from its current setting. On success, the function returns True.

If successful and the current value is greater than the new upper bound, if the control is limited the value will be automatically adjusted to this maximum value; if not limited, the value in the control will be colored as invalid.

SetMin(self, min=None)

Sets the minimum value of the control. If a value of None is provided, then the control will have no explicit minimum value. If the value specified is greater than the current maximum value, then the function returns 0 and the minimum will not change from its current setting. On success, the function returns 1.

If successful and the current value is lower than the new lower bound, if the control is limited, the value will be automatically adjusted to the new minimum value; if not limited, the value in the control will be colored as invalid.

SetMxDateTime(self, mxdt)

Because SetValue can take an mx.DateTime, (if DateTime is importable), this is now just an alias.

SetParameters(self, **kwargs)

Function providing access to the parameters governing TimeCtrl display and bounds.

SetValue(self, value)

Validating SetValue function for time values: This function will do dynamic type checking on the value argument, and convert wxDateTime, mxDateTime, or 12/24 format time string into the appropriate format string for the control.

Overrides:
wx.lib.masked.textctrl.BaseMaskedTextCtrl.SetValue

SetWxDateTime(self, wxdt)

Because SetValue can take a wx.DateTime, this is now just an alias.

Class Variable Details

valid_ctrl_params

Type:
dict
Value:
{'displaySeconds': True,
 'format': 'HHMMSS',
 'limited': False,
 'max': None,
 'min': None,
 'oob_color': 'Yellow',
 'useFixedWidthFont': True}

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:03 2005 http://epydoc.sf.net


wx.lib.masked.timectrl.TimeUpdatedEvent

Package wx :: Package lib :: Package masked :: Module timectrl :: Class TimeUpdatedEvent
[frames | no frames]

Type TimeUpdatedEvent

object --+
         |
    Object --+
             |
         Event --+
                 |
      CommandEvent --+
                     |
        PyCommandEvent --+
                         |
                        TimeUpdatedEvent

Used to fire an EVT_TIMEUPDATE event whenever the value in a TimeCtrl changes.

Method Summary
 | __init__(self, id, value)
 | GetValue(self) Retrieve the value of the time control at the time this event was generated

Method Details

GetValue(self)

Retrieve the value of the time control at the time this event was generated

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:38 2005 http://epydoc.sf.net


wx.lib.masked.timectrl

Package wx :: Package lib :: Package masked :: Module timectrl
[frames | no frames]

Module wx.lib.masked.timectrl

TimeCtrl provides a multi-cell control that allows manipulation of a time value. It supports 12 or 24 hour format, and you can use wxDateTime or mxDateTime to get/set values from the control.

Left/right/tab keys to switch cells within a TimeCtrl, and the up/down arrows act like a spin control. TimeCtrl also allows for an actual spin button to be attached to the control, so that it acts like the up/down arrow keys.

The ! or c key sets the value of the control to the current time.

Here's the API for TimeCtrl:

from wx.lib.masked import TimeCtrl

TimeCtrl(
     parent, id = -1,
     value = '00:00:00',
     pos = wx.DefaultPosition,
     size = wx.DefaultSize,
     style = wxTE_PROCESS_TAB,
     validator = wx.DefaultValidator,
     name = "time",
     format = 'HHMMSS',
     fmt24hr = False,
     displaySeconds = True,
     spinButton = None,
     min = None,
     max = None,
     limited = None,
     oob_color = "Yellow"
    )
value
If no initial value is set, the default will be midnight; if an illegal string is specified, a ValueError will result. (You can always later set the initial time with SetValue() after instantiation of the control.)
size
The size of the control will be automatically adjusted for 12/24 hour format if wx.DefaultSize is specified. NOTE: due to a problem with wx.DateTime, if the locale does not use 'AM/PM' for its values, the default format will automatically change to 24 hour format, and an AttributeError will be thrown if a non-24 format is specified.
style
By default, TimeCtrl will process TAB events, by allowing tab to the different cells within the control.
validator
By default, TimeCtrl just uses the default (empty) validator, as all of its validation for entry control is handled internally. However, a validator can be supplied to provide data transfer capability to the control.
format
This parameter can be used instead of the fmt24hr and displaySeconds parameters, respectively; it provides a shorthand way to specify the time format you want. Accepted values are 'HHMMSS', 'HHMM', '24HHMMSS', and '24HHMM'. If the format is specified, the other two arguments will be ignored.
fmt24hr
If True, control will display time in 24 hour time format; if False, it will use 12 hour AM/PM format. SetValue() will adjust values accordingly for the control, based on the format specified. (This value is ignored if the format parameter is specified.)
displaySeconds
If True, control will include a seconds field; if False, it will just show hours and minutes. (This value is ignored if the format parameter is specified.)
spinButton
If specified, this button's events will be bound to the behavior of the TimeCtrl, working like up/down cursor key events. (See BindSpinButton.)
min
Defines the lower bound for "valid" selections in the control. By default, TimeCtrl doesn't have bounds. You must set both upper and lower bounds to make the control pay attention to them, (as only one bound makes no sense with times.) "Valid" times will fall between the min and max "pie wedge" of the clock.
max
Defines the upper bound for "valid" selections in the control. "Valid" times will fall between the min and max "pie wedge" of the clock. (This can be a "big piece", ie. min = 11pm, max= 10pm means all but the hour from 10:00pm to 11pm are valid times.)
limited
If True, the control will not permit entry of values that fall outside the set bounds.
oob_color
Sets the background color used to indicate out-of-bounds values for the control when the control is not limited. This is set to "Yellow" by default.
EVT_TIMEUPDATE(win, id, func)
func is fired whenever the value of the control changes.
SetValue(time_string | wxDateTime | wxTimeSpan | mx.DateTime | mx.DateTimeDelta)
Sets the value of the control to a particular time, given a valid value; raises ValueError on invalid value.
NOTE: This will only allow mx.DateTime or mx.DateTimeDelta if mx.DateTime
was successfully imported by the class module.
GetValue(as_wxDateTime = False, as_mxDateTime = False, as_wxTimeSpan=False, as mxDateTimeDelta=False)
Retrieves the value of the time from the control. By default this is returned as a string, unless one of the other arguments is set; args are searched in the order listed; only one value will be returned.
GetWxDateTime(value=None)
When called without arguments, retrieves the value of the control, and applies it to the wxDateTimeFromHMS() constructor, and returns the resulting value. The date portion will always be set to Jan 1, 1970. This form is the same as GetValue(as_wxDateTime=True). GetWxDateTime can also be called with any of the other valid time formats settable with SetValue, to regularize it to a single wxDateTime form. The function will raise ValueError on an unconvertable argument.
GetMxDateTime()
Retrieves the value of the control and applies it to the DateTime.Time() constructor,and returns the resulting value. (The date portion will always be set to Jan 1, 1970.) (Same as GetValue(as_wxDateTime=True); provided for backward compatibility with previous release.)
BindSpinButton(SpinBtton)
Binds an externally created spin button to the control, so that up/down spin events change the active cell or selection in the control (in addition to the up/down cursor keys.) (This is primarily to allow you to create a "standard" interface to time controls, as seen in Windows.)
SetMin(min=None)

Sets the expected minimum value, or lower bound, of the control. (The lower bound will only be enforced if the control is configured to limit its values to the set bounds.) If a value of None is provided, then the control will have explicit lower bound. If the value specified is greater than the current lower bound, then the function returns False and the lower bound will not change from its current setting. On success, the function returns True. Even if set, if there is no corresponding upper bound, the control will behave as if it is unbounded.

If successful and the current value is outside the new bounds, if the control is limited the value will be automatically adjusted to the nearest bound; if not limited, the background of the control will be colored with the current out-of-bounds color.

GetMin(as_string=False)
Gets the current lower bound value for the control, returning None, if not set, or a wxDateTime, unless the as_string parameter is set to True, at which point it will return the string representation of the lower bound.
SetMax(max=None)

Sets the expected maximum value, or upper bound, of the control. (The upper bound will only be enforced if the control is configured to limit its values to the set bounds.) If a value of None is provided, then the control will have no explicit upper bound. If the value specified is less than the current lower bound, then the function returns False and the maximum will not change from its current setting. On success, the function returns True. Even if set, if there is no corresponding lower bound, the control will behave as if it is unbounded.

If successful and the current value is outside the new bounds, if the control is limited the value will be automatically adjusted to the nearest bound; if not limited, the background of the control will be colored with the current out-of-bounds color.

GetMax(as_string = False)
Gets the current upper bound value for the control, returning None, if not set, or a wxDateTime, unless the as_string parameter is set to True, at which point it will return the string representation of the lower bound.
SetBounds(min=None,max=None)
This function is a convenience function for setting the min and max values at the same time. The function only applies the maximum bound if setting the minimum bound is successful, and returns True only if both operations succeed. Note: leaving out an argument will remove the corresponding bound, and result in the behavior of an unbounded control.
GetBounds(as_string = False)
This function returns a two-tuple (min,max), indicating the current bounds of the control. Each value can be None if that bound is not set. The values will otherwise be wxDateTimes unless the as_string argument is set to True, at which point they will be returned as string representations of the bounds.
IsInBounds(value=None)
Returns True if no value is specified and the current value of the control falls within the current bounds. This function can also be called with a value to see if that value would fall within the current bounds of the given control. It will raise ValueError if the value specified is not a wxDateTime, mxDateTime (if available) or parsable string.
IsValid(value)
Returns True if specified value is a legal time value and falls within the current bounds of the given control.
SetLimited(bool)
If called with a value of True, this function will cause the control to limit the value to fall within the bounds currently specified. (Provided both bounds have been set.) If the control's value currently exceeds the bounds, it will then be set to the nearest bound. If called with a value of False, this function will disable value limiting, but coloring of out-of-bounds values will still take place if bounds have been set for the control.
IsLimited()
Returns True if the control is currently limiting the value to fall within the current bounds.
Classes
TimeCtrl | Masked control providing several time formats and manipulation of time values.
TimeCtrlAccessorsMixin | Defines TimeCtrl's list of attributes having their own Get/Set functions, ignoring those in the base class that make no sense for a time control.
TimeUpdatedEvent | Used to fire an EVT_TIMEUPDATE event whenever the value in a TimeCtrl changes.

Variable Summary
Logger | dbg = <wx.tools.dbg.Logger instance at 0xb75e9b6c>
PyEventBinder | EVT_TIMEUPDATE = <wx._core.PyEventBinder object at 0xb75...
int | wxEVT_TIMEVAL_UPDATED = 10227

Variable Details

dbg

Type:
Logger
Value:
<wx.tools.dbg.Logger instance at 0xb75e9b6c>

EVT_TIMEUPDATE

Type:
PyEventBinder
Value:
<wx._core.PyEventBinder object at 0xb75e9dec>

wxEVT_TIMEVAL_UPDATED

Type:
int
Value:
10227

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:17 2005 http://epydoc.sf.net


wx.lib.masked

Package wx :: Package lib :: Package masked

Package wx.lib.masked

Submodules
  • combobox: Provides masked edit capabilities within a ComboBox format, as well as a base class from which you can derive masked comboboxes tailored to a specific function.
  • ctrl: masked.Ctrl is actually a factory function for several types of masked edit controls:
  • ipaddrctrl: Provides a smart text input control that understands the structure and limits of IP Addresses, and allows automatic field navigation as the user hits '.' when typing.
  • maskededit: is a sublassed text control that can carefully control the user's input based on a mask string you provide.
  • numctrl: allows you to get and set integer or floating point numbers as value,</LI>
  • textctrl: Provides a generic, fully configurable masked edit text control, as well as a base class from which you can derive masked controls tailored to a specific function.
  • timectrl: TimeCtrl provides a multi-cell control that allows manipulation of a time value.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:39 2005 http://epydoc.sf.net


wx.lib.mixins.grid.GridAutoEditMixin

Package wx :: Package lib :: Package mixins :: Module grid :: Class GridAutoEditMixin
[frames | no frames]

Class GridAutoEditMixin

A mix-in class that automatically enables the grid edit control when a cell is selected.

If your class hooks EVT_GRID_SELECT_CELL be sure to call event.Skip so this handler will be called too.

Method Summary
__init__(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:11 2005 http://epydoc.sf.net


wx.lib.mixins.grid

Package wx :: Package lib :: Package mixins :: Module grid

Module wx.lib.mixins.grid

Classes
GridAutoEditMixin A mix-in class that automatically enables the grid edit control when a cell is selected.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:11 2005 http://epydoc.sf.net


wx.lib.mixins.imagelist.MagicImageList

Package wx :: Package lib :: Package mixins :: Module imagelist :: Class MagicImageList
[frames | no frames]

Class MagicImageList

Mix-in to provide "magic" growing image lists By Mike Fletcher

Method Summary
 | AddIcon(self, icon, mask) Add an icon to the image list, or get the index if already there
 | GetIcon(self, node) Get the actual icon object for a node
 | GetIcons(self, node) Get icon indexes for a given node, or None if no associated icon
 | SetupIcons(self, images, size)

Class Variable Summary
int DEFAULTICONSIZE = 16

Method Details

AddIcon(self, icon, mask=wxPython wrapper for UNBORN object! (The C++ object is no...)

Add an icon to the image list, or get the index if already there

GetIcon(self, node)

Get the actual icon object for a node

GetIcons(self, node)

Get icon indexes for a given node, or None if no associated icon

Class Variable Details

DEFAULTICONSIZE

Type:
int
Value:
16

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:12 2005 http://epydoc.sf.net


wx.lib.mixins.imagelist

Package wx :: Package lib :: Package mixins :: Module imagelist
[frames | no frames]

Module wx.lib.mixins.imagelist

Classes
MagicImageList Mix-in to provide "magic" growing image lists By Mike Fletcher

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:13 2005 http://epydoc.sf.net


wx.lib.mixins.listctrl.ColumnSorterMixin

Package wx :: Package lib :: Package mixins :: Module listctrl :: Class ColumnSorterMixin
[frames | no frames]

Class ColumnSorterMixin

A mixin class that handles sorting of a wx.ListCtrl in REPORT mode when the column header is clicked on.

There are a few requirments needed in order for this to work genericly:

  1. The combined class must have a GetListCtrl method that returns the wx.ListCtrl to be sorted, and the list control must exist at the time the wx.ColumnSorterMixin.__init__ method is called because it uses GetListCtrl.
  2. Items in the list control must have a unique data value set with list.SetItemData.
  3. The combined class must have an attribute named itemDataMap that is a dictionary mapping the data values to a sequence of objects representing the values in each column. These values are compared in the column sorter to determine sort order.

Interesting methods to override are GetColumnSorter, GetSecondarySortValues, and GetSortImages. See below for details.

Method Summary
 | __init__(self, numColumns)
 | GetColumnSorter(self) Returns a callable object to be used for comparing column values when sorting.
 | GetColumnWidths(self) Returns a list of column widths.
 | GetSecondarySortValues(self, col, key1, key2) Returns a tuple of 2 values to use for secondary sort values when the items in the selected column match equal.
 | GetSortImages(self) Returns a tuple of image list indexesthe indexes in the image list for an image to be put on the column header when sorting in descending order.
 | SetColumnCount(self, newNumColumns)
 | SortListItems(self, col, ascending) Sort the list on demand.

Method Details

GetColumnSorter(self)

Returns a callable object to be used for comparing column values when sorting.

GetColumnWidths(self)

Returns a list of column widths. Can be used to help restore the current view later.

GetSecondarySortValues(self, col, key1, key2)

Returns a tuple of 2 values to use for secondary sort values when the items in the selected column match equal. The default just returns the item data values.

GetSortImages(self)

Returns a tuple of image list indexesthe indexes in the image list for an image to be put on the column header when sorting in descending order.

SortListItems(self, col=-1, ascending=1)

Sort the list on demand. Can also be used to set the sort column and order.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:00 2005 http://epydoc.sf.net


wx.lib.mixins.listctrl.ListCtrlAutoWidthMixin

Package wx :: Package lib :: Package mixins :: Module listctrl :: Class ListCtrlAutoWidthMixin
[frames | no frames]

Class ListCtrlAutoWidthMixin

A mix-in class that automatically resizes the last column to take up the remaining width of the wx.ListCtrl.

This causes the wx.ListCtrl to automatically take up the full width of the list, without either a horizontal scroll bar (unless absolutely necessary) or empty space to the right of the last column.

NOTE: This only works for report-style lists.

WARNING: If you override the EVT_SIZE event in your wx.ListCtrl, make
sure you call event.Skip() to ensure that the mixin's _OnResize method is called.

This mix-in class was written by Erik Westra <ewestra@wave.co.nz>

Method Summary
 | __init__(self) Standard initialiser.
 | resizeColumn(self, minWidth)
 | resizeLastColumn(self, minWidth) Resize the last column appropriately.
 | setResizeColumn(self, col) Specify which column that should be autosized.

Method Details

__init__(self)
(Constructor)

Standard initialiser.

resizeLastColumn(self, minWidth)

Resize the last column appropriately.

If the list's columns are too wide to fit within the window, we use a horizontal scrollbar. Otherwise, we expand the right-most column to take up the remaining free space in the list.

This method is called automatically when the wx.ListCtrl is resized; you can also call it yourself whenever you want the last column to be resized appropriately (eg, when adding, removing or resizing columns).

'minWidth' is the preferred minimum width for the last column.

setResizeColumn(self, col)

Specify which column that should be autosized. Pass either 'LAST' or the column number. Default is 'LAST'.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:13 2005 http://epydoc.sf.net


wx.lib.mixins.listctrl.ListCtrlSelectionManagerMix

Package wx :: Package lib :: Package mixins :: Module listctrl :: Class ListCtrlSelectionManagerMix
[frames | no frames]

Class ListCtrlSelectionManagerMix

Mixin that defines a platform independent selection policy

As selection single and multi-select list return the item index or a list of item indexes respectively.

Method Summary
 | __init__(self)
 | afterPopupMenu(self, menu) Override to implement dynamic menus (destroy)
 | getPopupMenu(self) Override to implement dynamic menus (create)
 | getSelection(self)
 | OnLCSMDoPopup(self, event)
 | OnLCSMRightDown(self, event)
 | setPopupMenu(self, menu) Must be set for default behaviour

Method Details

afterPopupMenu(self, menu)

Override to implement dynamic menus (destroy)

getPopupMenu(self)

Override to implement dynamic menus (create)

setPopupMenu(self, menu)

Must be set for default behaviour

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:03 2005 http://epydoc.sf.net


wx.lib.mixins.listctrl.TextEditMixin

Package wx :: Package lib :: Package mixins :: Module listctrl :: Class TextEditMixin
[frames | no frames]

Class TextEditMixin

A mixin class that enables any text in any column of a multi-column listctrl to be edited by clicking on the given row and column. You close the text editor by hitting the ENTER key or clicking somewhere else on the listctrl. You switch to the next column by hiting TAB.

To use the mixin you have to include it in the class definition and call the __init__ function:

class TestListCtrl(wx.ListCtrl, TextEditMixin):
    def __init__(self, parent, ID, pos=wx.DefaultPosition,
                 size=wx.DefaultSize, style=0):
        wx.ListCtrl.__init__(self, parent, ID, pos, size, style)
        TextEditMixin.__init__(self)

Authors: Steve Zatz, Pim Van Heuven (pim@think-wize.com)

Method Summary
 | __init__(self)
 | CloseEditor(self, evt) Close the editor and save the new value to the ListCtrl.
 | make_editor(self, col_style)
 | OnChar(self, event) Catch the TAB, Shift-TAB, cursor DOWN/UP key code so we can open the editor at the next column (if any).
 | OnItemSelected(self, evt)
 | OnLeftDown(self, evt) Examine the click and double click events to see if a row has been click on twice.
 | OpenEditor(self, col, row) Opens an editor at the current position.

Class Variable Summary
Colour | editorBgColour = wx.Colour(255, 255, 175)
Colour | editorFgColour = wx.Colour(0, 0, 0)

Method Details

CloseEditor(self, evt=None)

Close the editor and save the new value to the ListCtrl.

OnChar(self, event)

Catch the TAB, Shift-TAB, cursor DOWN/UP key code so we can open the editor at the next column (if any).

OnLeftDown(self, evt=None)

Examine the click and double click events to see if a row has been click on twice. If so, determine the current row and columnn and open the editor.

OpenEditor(self, col, row)

Opens an editor at the current position.

Class Variable Details

editorBgColour

Type:
Colour
Value:
wx.Colour(255, 255, 175)

editorFgColour

Type:
Colour
Value:
wx.Colour(0, 0, 0)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:05 2005 http://epydoc.sf.net


wx.lib.mixins.listctrl

Package wx :: Package lib :: Package mixins :: Module listctrl
[frames | no frames]

Module wx.lib.mixins.listctrl

Classes
ColumnSorterMixin | A mixin class that handles sorting of a wx.ListCtrl in REPORT mode when the column header is clicked on.
ListCtrlAutoWidthMixin | A mix-in class that automatically resizes the last column to take up the remaining width of the wx.ListCtrl.
ListCtrlSelectionManagerMix | Mixin that defines a platform independent selection policy
TextEditMixin | A mixin class that enables any text in any column of a multi-column listctrl to be edited by clicking on the given row and column.

Function Summary
 | getListCtrlSelection(listctrl, state) Returns list of item indexes of given state (selected by defaults)
 | selectBeforePopup(event) Ensures the item the mouse is pointing at is selected before a popup.

Variable Summary
PyEventBinder | EVT_DOPOPUPMENU = <wx._core.PyEventBinder object at 0xb7...
int | SEL_FOC = 6
int | wxEVT_DOPOPUPMENU = 10278

Function Details

getListCtrlSelection(listctrl, state=4)

Returns list of item indexes of given state (selected by defaults)

selectBeforePopup(event)

Ensures the item the mouse is pointing at is selected before a popup.

Works with both single-select and multi-select lists.

Variable Details

EVT_DOPOPUPMENU

Type:
PyEventBinder
Value:
<wx._core.PyEventBinder object at 0xb79d132c>

SEL_FOC

Type:
int
Value:
6

wxEVT_DOPOPUPMENU

Type:
int
Value:
10278

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:56 2005 http://epydoc.sf.net


wx.lib.mixins.rubberband.RubberBand

Package wx :: Package lib :: Package mixins :: Module rubberband :: Class RubberBand
[frames | no frames]

Class RubberBand

A stretchable border which is drawn on top of an image to define an area.

Method Summary
 | __init__(self, drawingSurface, aspectRatio)
 | getCurrentExtent(self) Return (x0, y0, x1, y1) or None if no drawing has yet been done.
 | reset(self, aspectRatio) Clear the existing rubberband

Property Summary
enabled: True if I am responding to mouse events

Method Details

getCurrentExtent(self)

Return (x0, y0, x1, y1) or None if no drawing has yet been done.

reset(self, aspectRatio=None)

Clear the existing rubberband

Property Details

enabled

True if I am responding to mouse events

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:40 2005 http://epydoc.sf.net


wx.lib.mixins.rubberband

Package wx :: Package lib :: Package mixins :: Module rubberband
[frames | no frames]

Module wx.lib.mixins.rubberband

A mixin class for doing "RubberBand"-ing on a window.

Classes
RubberBand A stretchable border which is drawn on top of an image to define an area.

Function Summary
 | boxToExtent(box) Convert a box specification to an extent specification.
 | getCursorPosition(x, y, box, thickness) Return a position number in the range 0 ..
 | isNegative(aNumber) x < 0: 1 else: 0
 | normalizeBox(box) Convert any negative measurements in the current box to positive, and adjust the origin.
 | pointInBox(x, y, box) Return True if the given point is contained in the box.
 | pointOnBox(x, y, box, thickness) Return True if the point is on the outside edge of the box.

Function Details

boxToExtent(box)

Convert a box specification to an extent specification. I put this into a seperate function after I realized that I had been implementing it wrong in several places.

getCursorPosition(x, y, box, thickness=1)

Return a position number in the range 0 .. 7 to indicate where on the box border the point is. The layout is:

0 1 2 7 3 6 5 4

isNegative(aNumber)

x < 0: 1 else: 0

normalizeBox(box)

Convert any negative measurements in the current box to positive, and adjust the origin.

pointInBox(x, y, box)

Return True if the given point is contained in the box.

pointOnBox(x, y, box, thickness=1)

Return True if the point is on the outside edge of the box. The thickness defines how thick the edge should be. This is necessary for HCI reasons: For example, it's normally very difficult for a user to manuever the mouse onto a one pixel border.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:12 2005 http://epydoc.sf.net


wx.lib.mixins

Package wx :: Package lib :: Package mixins

Package wx.lib.mixins

Submodules
  • grid
  • imagelist
  • listctrl
  • rubberband: A mixin class for doing "RubberBand"-ing on a window.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:40 2005 http://epydoc.sf.net


wx.lib.multisash.EmptyChild

Package wx :: Package lib :: Module multisash :: Class EmptyChild
[frames | no frames]

Type EmptyChild

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
                    EmptyChild

Method Summary
__init__(self, parent)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:27 2005 http://epydoc.sf.net


wx.lib.multisash.MultiClient

Package wx :: Package lib :: Module multisash :: Class MultiClient
[frames | no frames]

Type MultiClient

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
                    MultiClient

Method Summary
 | __init__(self, parent, childCls)
 | CalcSize(self, parent)
 | OnChildFocus(self, evt)
 | OnSetFocus(self, evt)
 | OnSize(self, evt)
 | Select(self)
 | SetNewChildCls(self, childCls)
 | UnSelect(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:10:54 2005 http://epydoc.sf.net


wx.lib.multisash.MultiCloser

Package wx :: Package lib :: Module multisash :: Class MultiCloser
[frames | no frames]

Type MultiCloser

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
                    MultiCloser

Method Summary
 | __init__(self, parent)
 | CalcSizePos(self, parent)
 | OnEnter(self, evt)
 | OnLeave(self, evt)
 | OnPaint(self, evt)
 | OnPress(self, evt)
 | OnRelease(self, evt)
 | OnSize(self, evt)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:41 2005 http://epydoc.sf.net


wx.lib.multisash.MultiCreator

Package wx :: Package lib :: Module multisash :: Class MultiCreator
[frames | no frames]

Type MultiCreator

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
                    MultiCreator

Method Summary
 | __init__(self, parent, side)
 | CalcSizePos(self, parent)
 | OnEnter(self, evt)
 | OnLeave(self, evt)
 | OnMouseMove(self, evt)
 | OnPaint(self, evt)
 | OnPress(self, evt)
 | OnRelease(self, evt)
 | OnSize(self, evt)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:04 2005 http://epydoc.sf.net


wx.lib.multisash.MultiSash

Package wx :: Package lib :: Module multisash :: Class MultiSash
[frames | no frames]

Type MultiSash

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
                    MultiSash

Method Summary
 | __init__(self, *_args, **_kwargs)
 | Clear(self)
 | GetSaveData(self)
 | OnMultiSize(self, evt)
 | SetDefaultChildClass(self, childCls)
 | SetSaveData(self, data)
 | UnSelect(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:01 2005 http://epydoc.sf.net


wx.lib.multisash.MultiSizer

Package wx :: Package lib :: Module multisash :: Class MultiSizer
[frames | no frames]

Type MultiSizer

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
                    MultiSizer

Method Summary
 | __init__(self, parent, side)
 | CalcSizePos(self, parent)
 | OnEnter(self, evt)
 | OnLeave(self, evt)
 | OnMouseMove(self, evt)
 | OnPress(self, evt)
 | OnRelease(self, evt)
 | OnSize(self, evt)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:04 2005 http://epydoc.sf.net


wx.lib.multisash.MultiSplit

Package wx :: Package lib :: Module multisash :: Class MultiSplit
[frames | no frames]

Type MultiSplit

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
                    MultiSplit

Method Summary
 | __init__(self, multiView, parent, pos, size, view1)
 | AddLeaf(self, direction, caller, pos)
 | CanSize(self, side, view)
 | DefaultChildChanged(self)
 | DestroyLeaf(self, caller)
 | GetSaveData(self)
 | OnSize(self, evt)
 | SetSaveData(self, data)
 | SizeLeaf(self, leaf, pos, side)
 | SizeTarget(self, side, view)
 | UnSelect(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:06 2005 http://epydoc.sf.net


wx.lib.multisash.MultiViewLeaf

Package wx :: Package lib :: Module multisash :: Class MultiViewLeaf
[frames | no frames]

Type MultiViewLeaf

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
                    MultiViewLeaf

Method Summary
 | __init__(self, multiView, parent, pos, size)
 | AddLeaf(self, direction, pos)
 | CanSize(self, side)
 | DefaultChildChanged(self)
 | DestroyLeaf(self)
 | GetSaveData(self)
 | OnSize(self, evt)
 | SetSaveData(self, data)
 | SizeTarget(self, side)
 | UnSelect(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:11 2005 http://epydoc.sf.net


wx.lib.multisash

Package wx :: Package lib :: Module multisash

Module wx.lib.multisash

Classes
EmptyChild
MultiClient
MultiCloser
MultiCreator
MultiSash
MultiSizer
MultiSplit
MultiViewLeaf

Function Summary
DrawSash(win, x, y, direction)

Variable Summary
int | CR_SIZE = 15
int | MV_HOR = 0
bool | MV_VER = True
int | SH_SIZE = 5

Variable Details

CR_SIZE

Type:
int
Value:
15

MV_HOR

Type:
int
Value:
0

MV_VER

Type:
bool
Value:
True

SH_SIZE

Type:
int
Value:
5

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:18 2005 http://epydoc.sf.net


wx.lib.mvctree.BasicTreeModel

Package wx :: Package lib :: Module mvctree :: Class BasicTreeModel
[frames | no frames]

Class BasicTreeModel

TreeModel --+
            |
           BasicTreeModel

Known Subclasses:
FSTreeModel

A very simple treemodel implementation, but flexible enough for many needs.

Method Summary
 | __init__(self)
 | AddChild(self, parent, child)
 | GetChildAt(self, node, index)
 | GetChildCount(self, node)
 | GetParent(self, node)
 | GetRoot(self)
 | InsertChild(self, parent, child, index)
 | IsEditable(self, node)
 | IsLeaf(self, node)
 | RemoveNode(self, node)
 | SetEditable(self, node, bool)
 | SetRoot(self, root)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:10:47 2005 http://epydoc.sf.net


wx.lib.mvctree.Editor

Package wx :: Package lib :: Module mvctree :: Class Editor

Class Editor

Known Subclasses:
FileEditor
Method Summary
 | __init__(self, tree)
 | CanEdit(self, node)
 | Edit(self, node)
 | EndEdit(self, node, commit)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:41 2005 http://epydoc.sf.net


wx.lib.mvctree.FileEditor

Package wx :: Package lib :: Module mvctree :: Class FileEditor
[frames | no frames]

Class FileEditor

Editor --+
         |
        FileEditor

Method Summary
 | CanEdit(self, node)
 | Edit(self, node)
 | EndEdit(self, commit)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:10:48 2005 http://epydoc.sf.net


wx.lib.mvctree.FileWrapper

Package wx :: Package lib :: Module mvctree :: Class FileWrapper
[frames | no frames]

Class FileWrapper

Node class for FSTreeModel.

Method Summary
 | __init__(self, path, fileName)
 | __str__(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:10:49 2005 http://epydoc.sf.net


wx.lib.mvctree.FSTreeModel

Package wx :: Package lib :: Module mvctree :: Class FSTreeModel
[frames | no frames]

Class FSTreeModel

 TreeModel --+
             |
BasicTreeModel --+
                 |
                FSTreeModel

Known Subclasses:
LateFSTreeModel

This treemodel models the filesystem starting from a given path.

Method Summary
 | __init__(self, path)
 | IsEditable(self, node)
 | SetEditable(self, node, bool)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:58 2005 http://epydoc.sf.net


wx.lib.mvctree.LateFSTreeModel

Package wx :: Package lib :: Module mvctree :: Class LateFSTreeModel
[frames | no frames]

Class LateFSTreeModel

 TreeModel --+
             |
BasicTreeModel --+
                 |
       FSTreeModel --+
                     |
                    LateFSTreeModel

This treemodel models the filesystem starting from a given path. It retrieves the directory list as requested.

Method Summary
 | __init__(self, path)
 | GetChildCount(self, node)
 | IsLeaf(self, node)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:10:53 2005 http://epydoc.sf.net


wx.lib.mvctree.LayoutEngine

Package wx :: Package lib :: Module mvctree :: Class LayoutEngine
[frames | no frames]

Class LayoutEngine

Known Subclasses:
TreeLayout

Interface for layout engines.

Method Summary
 | __init__(self, tree)
 | GetNodeList(self)
 | Layout(self, node)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:52 2005 http://epydoc.sf.net


wx.lib.mvctree.LinePainter

Package wx :: Package lib :: Module mvctree :: Class LinePainter
[frames | no frames]

Class LinePainter

Known Subclasses:
TreeLinePainter

The linepainter interface.

Method Summary
 | __init__(self, painter)
 | Paint(self, parent, child, dc)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:58 2005 http://epydoc.sf.net


wx.lib.mvctree.MVCTree

Package wx :: Package lib :: Module mvctree :: Class MVCTree

Type MVCTree

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
                 Panel --+
                         |
            ScrolledWindow --+
                             |
                            MVCTree

The main mvc tree class.

Method Summary
 | __init__(self, parent, id, model, layout, transform, painter, *args, **kwargs)
 | __repr__(self)
 | __str__(self)
 | AddEditor(self, editor)
 | AddToSelection(self, nodeOrTuple, enableMulti, shiftMulti)
 | Edit(self, node)
 | EndEdit(self)
 | GetAssumeChildren(self)
 | GetBackgroundColour(self)
 | GetCurrentRoot(self)
 | GetDisplayText(self, node)
 | GetFont(self)
 | GetForegroundColour(self)
 | GetLayoutEngine(self)
 | GetModel(self)
 | GetPainter(self)
 | GetSelection(self) Returns a tuple of selected nodes.
 | GetTransform(self)
 | IsDoubleBuffered(self)
 | IsExpanded(self, node)
 | IsMultiSelect(self)
 | IsSelected(self, node)
 | LoadChildren(self, layoutNode)
 | NodeAdded(self, parent, child)
 | NodeInserted(self, parent, child, index)
 | NodeRemoved(self, node)
 | OnEraseBackground(self, evt)
 | OnKeyDown(self, evt)
 | OnKnobClick(self, node)
 | OnMouse(self, evt)
 | OnNodeClick(self, node, mouseEvent)
 | OnPaint(self, evt) Ensures that the tree has been laid out and transformed, then calls the painter to paint the control.
 | OnSize(self, evt)
 | Refresh(self)
 | RemoveEditor(self, editor)
 | RemoveFromSelection(self, nodeTuple)
 | SetAssumeChildren(self, bool)
 | SetBackgroundColour(self, color)
 | SetDoubleBuffered(self, bool) By default MVCTree is double-buffered.
 | SetExpanded(self, node, bool)
 | SetFont(self, font)
 | SetForegroundColour(self, color)
 | SetModel(self, model) Completely change the data to be displayed.
 | SetMultiSelect(self, bool)
 | SetSelection(self, nodeTuple)

Instance Method Details

GetSelection(self)

Returns a tuple of selected nodes.

OnPaint(self, evt)

Ensures that the tree has been laid out and transformed, then calls the painter to paint the control.

SetDoubleBuffered(self, bool)

By default MVCTree is double-buffered.

SetModel(self, model)

Completely change the data to be displayed.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:10:55 2005 http://epydoc.sf.net


wx.lib.mvctree.MVCTreeEvent

Package wx :: Package lib :: Module mvctree :: Class MVCTreeEvent
[frames | no frames]

Type MVCTreeEvent

object --+
         |
    Object --+
             |
         Event --+
                 |
      CommandEvent --+
                     |
        PyCommandEvent --+
                         |
                        MVCTreeEvent

Known Subclasses:
MVCTreeNotifyEvent
Method Summary
 | __init__(self, type, id, node, nodes, keyEvent, **kwargs)
 | getKeyEvent(self)
 | GetNode(self)
 | GetNodes(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:10:54 2005 http://epydoc.sf.net


wx.lib.mvctree.MVCTreeNode

Package wx :: Package lib :: Module mvctree :: Class MVCTreeNode
[frames | no frames]

Class MVCTreeNode

Used internally by MVCTree to manage its data. Contains information about screen placement, the actual data associated with it, and more. These are the nodes passed to all the other helper parts to do their work with.

Method Summary
 | __init__(self, data, parent, kids, x, y)
 | __repr__(self)
 | __str__(self)
 | Add(self, node)
 | GetChildren(self)
 | GetParent(self)
 | GetTreeString(self, tabs)
 | Remove(self, node)
 | SetParent(self, parent)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:48 2005 http://epydoc.sf.net


wx.lib.mvctree.MVCTreeNotifyEvent

Package wx :: Package lib :: Module mvctree :: Class MVCTreeNotifyEvent
[frames | no frames]

Type MVCTreeNotifyEvent

object --+
         |
    Object --+
             |
         Event --+
                 |
      CommandEvent --+
                     |
        PyCommandEvent --+
                         |
              MVCTreeEvent --+
                             |
                            MVCTreeNotifyEvent

Method Summary
 | __init__(self, type, id, node, nodes, **kwargs)
 | getNotifyEvent(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:10 2005 http://epydoc.sf.net


wx.lib.mvctree.NodePainter

Package wx :: Package lib :: Module mvctree :: Class NodePainter
[frames | no frames]

Class NodePainter

Known Subclasses:
TreeNodePainter

This is the interface expected of a nodepainter.

Method Summary
 | __init__(self, painter)
 | Paint(self, node, dc, location) location should be provided only to draw in an unusual position (not the node's normal position), otherwise the node's projected x and y coordinates will be used.

Method Details

Paint(self, node, dc, location=None)

location should be provided only to draw in an unusual position (not the node's normal position), otherwise the node's projected x and y coordinates will be used.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:58 2005 http://epydoc.sf.net


wx.lib.mvctree.NullTransform

Package wx :: Package lib :: Module mvctree :: Class NullTransform
[frames | no frames]

Class NullTransform

Transform --+
            |
           NullTransform

Method Summary
 | GetSize(self) Returns the size of the entire tree as laid out and transformed as a tuple
 | Transform(self, node, offset, rotation) This method should only change the projx and projy attributes of the node.

Method Details

GetSize(self)

Returns the size of the entire tree as laid out and transformed as a tuple

Overrides:
wx.lib.mvctree.Transform.GetSize (inherited documentation)

Transform(self, node, offset, rotation)

This method should only change the projx and projy attributes of the node. These represent the position of the node as it should be drawn on screen. Adjusting the x and y attributes can and should cause havoc.

Overrides:
wx.lib.mvctree.Transform.Transform (inherited documentation)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:23 2005 http://epydoc.sf.net


wx.lib.mvctree.Painter

Package wx :: Package lib :: Module mvctree :: Class Painter

Class Painter

Known Subclasses:
TreePainter

This is the interface that MVCTree expects from painters. All painters should be Painter subclasses.

Method Summary
 | __init__(self, tree)
 | ClearBuffer(self)
 | GetBackgroundBrush(self)
 | GetBackgroundColour(self)
 | GetBackgroundPen(self)
 | GetBuffer(self)
 | GetFont(self)
 | GetForegroundBrush(self)
 | GetForegroundColour(self)
 | GetForegroundPen(self)
 | GetLineBrush(self)
 | GetLineColour(self)
 | GetLinePen(self)
 | GetTextBrush(self)
 | GetTextColour(self)
 | GetTextPen(self)
 | OnMouse(self, evt)
 | Paint(self, dc, node, doubleBuffered, paintBackground)
 | SetBackgroundColour(self, color)
 | SetFont(self, font)
 | SetForegroundColour(self, color)
 | SetLineColour(self, color)
 | SetTextColour(self, color)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:40 2005 http://epydoc.sf.net


wx.lib.mvctree.Rect

Package wx :: Package lib :: Module mvctree :: Class Rect

Class Rect

Method Summary
 | __init__(self, x, y, width, height)
 | __getitem__(self, index)
 | __setitem__(self, index, value)
 | __str__(self)
 | Contains(self, other)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:59 2005 http://epydoc.sf.net


wx.lib.mvctree.StrTextConverter

Package wx :: Package lib :: Module mvctree :: Class StrTextConverter
[frames | no frames]

Class StrTextConverter

TextConverter --+
                |
               StrTextConverter

Method Summary
Convert(self, node)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:59 2005 http://epydoc.sf.net


wx.lib.mvctree.TextConverter

Package wx :: Package lib :: Module mvctree :: Class TextConverter
[frames | no frames]

Class TextConverter

Known Subclasses:
StrTextConverter

TextConverter interface.

Method Summary
 | __init__(self, painter)
 | Convert(node) Should return a string.

Method Details

Convert(node)

Should return a string. The node argument will be an MVCTreeNode.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:09 2005 http://epydoc.sf.net


wx.lib.mvctree.Transform

Package wx :: Package lib :: Module mvctree :: Class Transform
[frames | no frames]

Class Transform

Known Subclasses:
NullTransform

Transform interface.

Method Summary
 | __init__(self, tree)
 | GetSize(self) Returns the size of the entire tree as laid out and transformed as a tuple
 | Transform(self, node, offset, rotation) This method should only change the projx and projy attributes of the node.

Method Details

GetSize(self)

Returns the size of the entire tree as laid out and transformed as a tuple

Transform(self, node, offset, rotation)

This method should only change the projx and projy attributes of the node. These represent the position of the node as it should be drawn on screen. Adjusting the x and y attributes can and should cause havoc.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:17 2005 http://epydoc.sf.net


wx.lib.mvctree.TreeLayout

Package wx :: Package lib :: Module mvctree :: Class TreeLayout
[frames | no frames]

Class TreeLayout

LayoutEngine --+
               |
              TreeLayout

Method Summary
 | __init__(self, tree)
 | GetNodeList(self)
 | Layout(self, node)
 | layoutwalk(self, node)
 | SetHeight(self, num)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:59 2005 http://epydoc.sf.net


wx.lib.mvctree.TreeLinePainter

Package wx :: Package lib :: Module mvctree :: Class TreeLinePainter
[frames | no frames]

Class TreeLinePainter

LinePainter --+
              |
             TreeLinePainter

Method Summary
Paint(self, parent, child, dc)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:59 2005 http://epydoc.sf.net


wx.lib.mvctree.TreeModel

Package wx :: Package lib :: Module mvctree :: Class TreeModel
[frames | no frames]

Class TreeModel

Known Subclasses:
BasicTreeModel

Interface for tree models

Method Summary
 | AddChild(self, parent, child)
 | GetChildAt(self, node, index)
 | GetChildCount(self, node)
 | GetParent(self, node)
 | GetRoot(self)
 | InsertChild(self, parent, child, index)
 | IsEditable(self, node)
 | IsLeaf(self, node)
 | RemoveNode(self, child)
 | SetEditable(self, node)
 | SetRoot(self, root)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:22 2005 http://epydoc.sf.net


wx.lib.mvctree.TreeNodePainter

Package wx :: Package lib :: Module mvctree :: Class TreeNodePainter
[frames | no frames]

Class TreeNodePainter

NodePainter --+
              |
             TreeNodePainter

Method Summary
Paint(self, node, dc, location)
location should be provided only to draw in an unusual position (not the node's normal position), otherwise the node's projected x and y coordinates will be used.

Method Details

Paint(self, node, dc, location=None, drawRects=0)

location should be provided only to draw in an unusual position (not the node's normal position), otherwise the node's projected x and y coordinates will be used.

Overrides:
wx.lib.mvctree.NodePainter.Paint (inherited documentation)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:01 2005 http://epydoc.sf.net


wx.lib.mvctree.TreePainter

Package wx :: Package lib :: Module mvctree :: Class TreePainter
[frames | no frames]

Class TreePainter

Painter --+
          |
         TreePainter

The default painter class. Uses double-buffering, delegates the painting of nodes and lines to helper classes deriving from NodePainter and LinePainter.

Method Summary
 | __init__(self, tree, nodePainter, linePainter, textConverter)
 | GetDashPen(self)
 | OnMouse(self, evt)
 | Paint(self, dc, node, doubleBuffered, paintBackground)
 | paintWalk(self, node, dc, paintRects)
 | SetLinePen(self, pen)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:00 2005 http://epydoc.sf.net


wx.lib.mvctree

Package wx :: Package lib :: Module mvctree

Module wx.lib.mvctree

MVCTree is a control which handles hierarchical data. It is constructed
in model-view-controller architecture, so the display of that data, and
the content of the data can be changed greatly without affecting the other parts.

MVCTree actually is even more configurable than MVC normally implies, because
almost every aspect of it is pluggable:
    MVCTree - Overall controller, and the window that actually gets placed
    in the GUI.
        Painter - Paints the control. The 'view' part of MVC.
           NodePainter - Paints just the nodes
           LinePainter - Paints just the lines between the nodes
           TextConverter - Figures out what text to print for each node
        Editor - Edits the contents of a node, if the model is editable.
        LayoutEngine - Determines initial placement of nodes
        Transform - Adjusts positions of nodes for movement or special effects.
        TreeModel - Contains the data which the rest of the control acts
        on. The 'model' part of MVC.

Author/Maintainer - Bryn Keller <xoltar@starship.python.net>

NOTE: This module is *not* supported in any way.  Use it however you
      wish, but be warned that dealing with any consequences is
      entirly up to you.
      --Robin

Classes
BasicTreeModel | A very simple treemodel implementation, but flexible enough for many needs.
Editor |
FileEditor |
FileWrapper | Node class for FSTreeModel.
FSTreeModel | This treemodel models the filesystem starting from a given path.
LateFSTreeModel | This treemodel models the filesystem starting from a given path.
LayoutEngine | Interface for layout engines.
LinePainter | The linepainter interface.
MVCTree | The main mvc tree class.
MVCTreeEvent |
MVCTreeNode | Used internally by MVCTree to manage its data.
MVCTreeNotifyEvent |
NodePainter | This is the interface expected of a nodepainter.
NullTransform |
Painter | This is the interface that MVCTree expects from painters.
Rect |
StrTextConverter |
TextConverter | TextConverter interface.
Transform | Transform interface.
TreeLayout |
TreeLinePainter |
TreeModel | Interface for tree models
TreeNodePainter |
TreePainter | The default painter class.

Variable Summary
PyEventBinder | EVT_MVCTREE_ADD_ITEM = <wx._core.PyEventBinder object at...
PyEventBinder | EVT_MVCTREE_DELETE_ITEM = <wx._core.PyEventBinder object...
PyEventBinder | EVT_MVCTREE_ITEM_COLLAPSED = <wx._core.PyEventBinder obj...
PyEventBinder | EVT_MVCTREE_ITEM_COLLAPSING = <wx._core.PyEventBinder ob...
PyEventBinder | EVT_MVCTREE_ITEM_EXPANDED = <wx._core.PyEventBinder obje...
PyEventBinder | EVT_MVCTREE_ITEM_EXPANDING = <wx._core.PyEventBinder obj...
PyEventBinder | EVT_MVCTREE_KEY_DOWN = <wx._core.PyEventBinder object at...
PyEventBinder | EVT_MVCTREE_SEL_CHANGED = <wx._core.PyEventBinder object...
PyEventBinder | EVT_MVCTREE_SEL_CHANGING = <wx._core.PyEventBinder objec...
str | warningmsg = '\\\n\n####################################...
int | wxEVT_MVCTREE_ITEM_COLLAPSED = 10284
int | wxEVT_MVCTREE_ITEM_COLLAPSING = 10285
int | wxEVT_MVCTREE_ITEM_EXPANDED = 10282
int | wxEVT_MVCTREE_ITEM_EXPANDING = 10283
int | wxEVT_MVCTREE_KEY_DOWN = 10288
int | wxEVT_MVCTREE_SEL_CHANGED = 10286

Variable Details

EVT_MVCTREE_ADD_ITEM

Type:
PyEventBinder
Value:
<wx._core.PyEventBinder object at 0xb797610c>

EVT_MVCTREE_DELETE_ITEM

Type:
PyEventBinder
Value:
<wx._core.PyEventBinder object at 0xb797614c>

EVT_MVCTREE_ITEM_COLLAPSED

Type:
PyEventBinder
Value:
<wx._core.PyEventBinder object at 0xb797608c>

EVT_MVCTREE_ITEM_COLLAPSING

Type:
PyEventBinder
Value:
<wx._core.PyEventBinder object at 0xb79760cc>

EVT_MVCTREE_ITEM_EXPANDED

Type:
PyEventBinder
Value:
<wx._core.PyEventBinder object at 0xb797604c>

EVT_MVCTREE_ITEM_EXPANDING

Type:
PyEventBinder
Value:
<wx._core.PyEventBinder object at 0xb797606c>

EVT_MVCTREE_KEY_DOWN

Type:
PyEventBinder
Value:
<wx._core.PyEventBinder object at 0xb797618c>

EVT_MVCTREE_SEL_CHANGED

Type:
PyEventBinder
Value:
<wx._core.PyEventBinder object at 0xb7969fcc>

EVT_MVCTREE_SEL_CHANGING

Type:
PyEventBinder
Value:
<wx._core.PyEventBinder object at 0xb797602c>

warningmsg

Type:
str
Value:
'''\\

################################################\\
# This module is not supported in any way!      |
#                                               |
# See cource code for wx.lib.mvctree for more   |
# information.                                  |
################################################/
...

wxEVT_MVCTREE_ITEM_COLLAPSED

Type:
int
Value:
10284

wxEVT_MVCTREE_ITEM_COLLAPSING

Type:
int
Value:
10285

wxEVT_MVCTREE_ITEM_EXPANDED

Type:
int
Value:
10282

wxEVT_MVCTREE_ITEM_EXPANDING

Type:
int
Value:
10283

wxEVT_MVCTREE_KEY_DOWN

Type:
int
Value:
10288

wxEVT_MVCTREE_SEL_CHANGED

Type:
int
Value:
10286

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:13 2005 http://epydoc.sf.net


wx.lib.newevent

Package wx :: Package lib :: Module newevent

Module wx.lib.newevent

Easy generation of new events classes and binder objects

Function Summary
 | NewCommandEvent() Generate new (CmdEvent, Binder) tuple e.g.
 | NewEvent() Generate new (Event, Binder) tuple e.g.

Variable Summary
str __author__ = 'Miki Tebeka <tebeka@cs.bgu.ac.il>'

Function Details

NewCommandEvent()

Generate new (CmdEvent, Binder) tuple e.g. MooCmdEvent, EVT_MOO = NewCommandEvent()

NewEvent()

Generate new (Event, Binder) tuple e.g. MooEvent, EVT_MOO = NewEvent()

Variable Details

__author__

Type:
str
Value:
'Miki Tebeka <tebeka@cs.bgu.ac.il>'

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:12 2005 http://epydoc.sf.net


wx.lib.ogl.ArrowHead

Package wx :: Package lib :: Package ogl :: Class ArrowHead

Type ArrowHead

object --+
         |
        ArrowHead

Method Summary
 | __init__(self, type, end, size, dist, name, mf, arrowId)
 | GetArrowEnd(self)
 | GetArrowSize(self)
 | GetId(self)
 | GetMetaFile(self)
 | GetName(self)
 | GetPosition(self)
 | GetSize(self)
 | GetSpacing(self)
 | GetXOffset(self)
 | GetYOffset(self)
 | SetPosition(self, pos)
 | SetSize(self, size)
 | SetSpacing(self, sp)
 | SetXOffset(self, x)
 | SetYOffset(self, y)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:57 2005 http://epydoc.sf.net


wx.lib.ogl.BitmapShape

Package wx :: Package lib :: Package ogl :: Class BitmapShape
[frames | no frames]

Type BitmapShape

     object --+
              |
ShapeEvtHandler --+
                  |
              Shape --+
                      |
         RectangleShape --+
                          |
                         BitmapShape

Draws a bitmap (non-resizable).

Method Summary
 | __init__(self)
 | GetBitmap(self) Return a the bitmap associated with this shape.
 | GetFilename(self) Return the bitmap filename.
 | OnDraw(self, dc)
 | SetBitmap(self, bitmap) Set the bitmap associated with this shape.
 | SetFilename(self, f) Set the bitmap filename.
 | SetSize(self, w, h, recursive)

Class Variable Summary

Method Details

GetBitmap(self)

Return a the bitmap associated with this shape.

GetFilename(self)

Return the bitmap filename.

SetBitmap(self, bitmap)

Set the bitmap associated with this shape.

You can delete the bitmap from the calling application, since reference counting will take care of holding on to the internal bitmap data.

SetFilename(self, f)

Set the bitmap filename.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:41 2005 http://epydoc.sf.net


wx.lib.ogl.CircleShape

Package wx :: Package lib :: Package ogl :: Class CircleShape
[frames | no frames]

Type CircleShape

     object --+
              |
ShapeEvtHandler --+
                  |
              Shape --+
                      |
           EllipseShape --+
                          |
                         CircleShape

An EllipseShape whose width and height are the same.

Method Summary
 | __init__(self, diameter)
 | GetPerimeterPoint(self, x1, y1, x2, y2) Get the point at which the line from (x1, y1) to (x2, y2) hits the shape.

Class Variable Summary

Method Details

GetPerimeterPoint(self, x1, y1, x2, y2)

Get the point at which the line from (x1, y1) to (x2, y2) hits the shape. Returns False if the line doesn't hit the perimeter.

Overrides:
wx.lib.ogl.EllipseShape.GetPerimeterPoint (inherited documentation)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:01 2005 http://epydoc.sf.net


wx.lib.ogl.CompositeShape

Package wx :: Package lib :: Package ogl :: Class CompositeShape
[frames | no frames]

Type CompositeShape

     object --+
              |
ShapeEvtHandler --+
                  |
              Shape --+
                      |
         RectangleShape --+
                          |
                         CompositeShape

Known Subclasses:
DivisionShape

This is an object with a list of child objects, and a list of size and positioning constraints between the children.

Derived from:
wxRectangleShape
Method Summary
 | __init__(self)
 | AddChild(self, child, addAfter) Adds a child shape to the composite.
 | AddConstraint(self, constraint) Adds a constraint to the composite.
 | AddSimpleConstraint(self, type, constraining, constrained) Add a constraint of the given type to the composite.
 | CalculateSize(self) Calculates the size and position of the composite based on child sizes and positions.
 | Constrain(self)
 | ContainsDivision(self, division) Returns TRUE if division is a descendant of this container.
 | DeleteConstraint(self, constraint) Deletes constraint from composite.
 | DeleteConstraintsInvolvingChild(self, child) This function deletes constraints which mention the given child.
 | FindConstraint(self, cId) Finds the constraint with the given id.
 | FindContainerImage(self) Finds the image used to visualize a container.
 | GetConstraints(self) Return the list of constraints.
 | GetDivisions(self) Return the list of divisions.
 | MakeContainer(self) Makes this composite into a container by creating one child DivisionShape.
 | OnBeginDragLeft(self, x, y, keys, attachment)
 | OnCreateDivision(self)
 | OnDragLeft(self, draw, x, y, keys, attachment)
 | OnDraw(self, dc)
 | OnDrawContents(self, dc)
 | OnEndDragLeft(self, x, y, keys, attachment)
 | OnErase(self, dc)
 | OnMovePre(self, dc, x, y, old_x, old_y, display)
 | OnRightClick(self, x, y, keys, attachment)
 | Recompute(self) Recomputes any constraints associated with the object.
 | RemoveChild(self, child) Removes the child from the composite and any constraint relationships, but does not delete the child.
 | RemoveChildFromConstraints(self, child)
 | SetSize(self, w, h, recursive)

Class Variable Summary

Method Details

AddChild(self, child, addAfter=None)

Adds a child shape to the composite.

If addAfter is not None, the shape will be added after this shape.

AddConstraint(self, constraint)

Adds a constraint to the composite.

AddSimpleConstraint(self, type, constraining, constrained)

Add a constraint of the given type to the composite.

constraining is the shape doing the constraining constrained is a list of shapes being constrained

CalculateSize(self)

Calculates the size and position of the composite based on child sizes and positions.

ContainsDivision(self, division)

Returns TRUE if division is a descendant of this container.

DeleteConstraint(self, constraint)

Deletes constraint from composite.

DeleteConstraintsInvolvingChild(self, child)

This function deletes constraints which mention the given child.

Used when deleting a child from the composite.

FindConstraint(self, cId)

Finds the constraint with the given id.

Returns a tuple of the constraint and the actual composite the constraint was in, in case that composite was a descendant of this composit.

Returns None if not found.

FindContainerImage(self)

Finds the image used to visualize a container. This is any child of the composite that is not in the divisions list.

GetConstraints(self)

Return the list of constraints.

GetDivisions(self)

Return the list of divisions.

MakeContainer(self)

Makes this composite into a container by creating one child DivisionShape.

Recompute(self)

Recomputes any constraints associated with the object. If FALSE is returned, the constraints could not be satisfied (there was an inconsistency).

Overrides:
wx.lib.ogl.Shape.Recompute

RemoveChild(self, child)

Removes the child from the composite and any constraint relationships, but does not delete the child.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:04 2005 http://epydoc.sf.net


wx.lib.ogl.Constraint

Package wx :: Package lib :: Package ogl :: Class Constraint

Type Constraint

object --+
         |
        Constraint

A Constraint object helps specify how child shapes are laid out with respect to siblings and parents.

Derived from:
wxObject
Method Summary
 | __init__(self, type, constraining, constrained)
 | __repr__(self)
 | Equals(self, a, b) Return TRUE if x and y are approximately equal (for the purposes of evaluating the constraint).
 | Evaluate(self) Evaluate this constraint and return TRUE if anything changed.
 | SetSpacing(self, x, y) Sets the horizontal and vertical spacing for the constraint.

Method Details

Equals(self, a, b)

Return TRUE if x and y are approximately equal (for the purposes of evaluating the constraint).

Evaluate(self)

Evaluate this constraint and return TRUE if anything changed.

SetSpacing(self, x, y)

Sets the horizontal and vertical spacing for the constraint.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:23 2005 http://epydoc.sf.net


wx.lib.ogl.ConstraintType

Package wx :: Package lib :: Package ogl :: Class ConstraintType
[frames | no frames]

Type ConstraintType

object --+
         |
        ConstraintType

Method Summary
__init__(self, theType, theName, thePhrase)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:40 2005 http://epydoc.sf.net


wx.lib.ogl.ControlPoint

Package wx :: Package lib :: Package ogl :: Class ControlPoint
[frames | no frames]

Type ControlPoint

     object --+
              |
ShapeEvtHandler --+
                  |
              Shape --+
                      |
         RectangleShape --+
                          |
                         ControlPoint

Known Subclasses:
DividedShapeControlPoint, DivisionControlPoint, LineControlPoint, PolygonControlPoint
Method Summary
 | __init__(self, theCanvas, object, size, the_xoffset, the_yoffset, the_type)
 | GetAttachmentPosition(self, attachment, nth, no_arcs, line) Get the position at which the given attachment point should be drawn.
 | GetNumberOfAttachments(self) Get the number of attachment points for this shape.
 | OnBeginDragLeft(self, x, y, keys, attachment)
 | OnDragLeft(self, draw, x, y, keys, attachment)
 | OnDraw(self, dc)
 | OnDrawContents(self, dc)
 | OnEndDragLeft(self, x, y, keys, attachment)
 | OnErase(self, dc)
 | SetEraseObject(self, er)

Class Variable Summary

Method Details

GetAttachmentPosition(self,
          attachment,
          nth=0,
          no_arcs=1,
          line=None)

Get the position at which the given attachment point should be drawn.

If attachment isn't found among the attachment points of the shape, returns None.

Overrides:
wx.lib.ogl.Shape.GetAttachmentPosition (inherited documentation)

GetNumberOfAttachments(self)

Get the number of attachment points for this shape.

Overrides:
wx.lib.ogl.Shape.GetNumberOfAttachments (inherited documentation)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:12 2005 http://epydoc.sf.net


wx.lib.ogl.Diagram

Package wx :: Package lib :: Package ogl :: Class Diagram

Type Diagram

object --+
         |
        Diagram

Encapsulates an entire diagram, with methods for drawing. A diagram has an associated ShapeCanvas.

Derived from:
Object
Method Summary
 | __init__(self)
 | AddShape(self, object, addAfter) Adds a shape to the diagram.
 | Clear(self, dc) Clear the specified device context.
 | DeleteAllShapes(self) Remove and delete all shapes in the diagram.
 | DrawOutline(self, dc, x1, y1, x2, y2) Draw an outline rectangle on the current device context.
 | FindShape(self, id) Return the shape for the given identifier.
 | GetCanvas(self) Return the shape canvas associated with this diagram.
 | GetCount(self) Return the number of shapes in the diagram.
 | GetGridSpacing(self) Return the grid spacing.
 | GetMouseTolerance(self) Return the tolerance within which a mouse move is ignored.
 | GetQuickEditMode(self) Return quick edit mode.
 | GetShapeList(self) Return the internal shape list.
 | GetSnapToGrid(self) Return snap-to-grid mode.
 | InsertShape(self, object) Insert a shape at the front of the shape list.
 | RecentreAll(self, dc) Make sure all text that should be centred, is centred.
 | Redraw(self, dc) Draw the shapes in the diagram on the specified device context.
 | RemoveAllShapes(self) Remove all shapes from the diagram but do not delete the shapes.
 | RemoveShape(self, object) Remove the shape from the diagram (non-recursively) but do not delete it.
 | SetCanvas(self, canvas) Set the canvas associated with this diagram.
 | SetGridSpacing(self, spacing) Sets grid spacing.
 | SetMouseTolerance(self, tolerance) Set the tolerance within which a mouse move is ignored.
 | SetQuickEditMode(self, mode) Set quick-edit-mode on of off.
 | SetSnapToGrid(self, snap) Sets snap-to-grid mode.
 | ShowAll(self, show) Call Show for each shape in the diagram.
 | Snap(self, x, y) 'Snaps' the coordinate to the nearest grid position, if snap-to-grid is on.

Method Details

AddShape(self, object, addAfter=None)

Adds a shape to the diagram. If addAfter is not None, the shape will be added after addAfter.

Clear(self, dc)

Clear the specified device context.

DeleteAllShapes(self)

Remove and delete all shapes in the diagram.

DrawOutline(self, dc, x1, y1, x2, y2)

Draw an outline rectangle on the current device context.

FindShape(self, id)

Return the shape for the given identifier.

GetCanvas(self)

Return the shape canvas associated with this diagram.

GetCount(self)

Return the number of shapes in the diagram.

GetGridSpacing(self)

Return the grid spacing.

GetMouseTolerance(self)

Return the tolerance within which a mouse move is ignored.

GetQuickEditMode(self)

Return quick edit mode.

GetShapeList(self)

Return the internal shape list.

GetSnapToGrid(self)

Return snap-to-grid mode.

InsertShape(self, object)

Insert a shape at the front of the shape list.

RecentreAll(self, dc)

Make sure all text that should be centred, is centred.

Redraw(self, dc)

Draw the shapes in the diagram on the specified device context.

RemoveAllShapes(self)

Remove all shapes from the diagram but do not delete the shapes.

RemoveShape(self, object)

Remove the shape from the diagram (non-recursively) but do not delete it.

SetCanvas(self, canvas)

Set the canvas associated with this diagram.

SetGridSpacing(self, spacing)

Sets grid spacing.

SetMouseTolerance(self, tolerance)

Set the tolerance within which a mouse move is ignored.

The default is 3 pixels.

SetQuickEditMode(self, mode)

Set quick-edit-mode on of off.

In this mode, refreshes are minimized, but the diagram may need manual refreshing occasionally.

SetSnapToGrid(self, snap)

Sets snap-to-grid mode.

ShowAll(self, show)

Call Show for each shape in the diagram.

Snap(self, x, y)

'Snaps' the coordinate to the nearest grid position, if snap-to-grid is on.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:00 2005 http://epydoc.sf.net


wx.lib.ogl.DividedShape

Package wx :: Package lib :: Package ogl :: Class DividedShape
[frames | no frames]

Type DividedShape

     object --+
              |
ShapeEvtHandler --+
                  |
              Shape --+
                      |
         RectangleShape --+
                          |
                         DividedShape

A DividedShape is a rectangle with a number of vertical divisions. Each division may have its text formatted with independent characteristics, and the size of each division relative to the whole image may be specified.

Derived from:
RectangleShape
Method Summary
 | __init__(self, w, h)
 | AttachmentIsValid(self, attachment) TRUE if attachment is a valid attachment point.
 | EditRegions(self) Edit the region colours and styles.
 | GetAttachmentPosition(self, attachment, nth, no_arcs, line) Get the position at which the given attachment point should be drawn.
 | GetNumberOfAttachments(self) Get the number of attachment points for this shape.
 | MakeControlPoints(self) Make a list of control points (draggable handles) appropriate to the shape.
 | MakeMandatoryControlPoints(self) Make the mandatory control points.
 | OnDraw(self, dc)
 | OnDrawContents(self, dc)
 | OnRightClick(self, x, y, keys, attachment)
 | ResetControlPoints(self) Reset the positions of the control points (for instance when the shape's shape has changed).
 | ResetMandatoryControlPoints(self) Reset the mandatory control points.
 | SetRegionSizes(self) Set all region sizes according to proportions and this object total size.
 | SetSize(self, w, h, recursive)

Class Variable Summary

Method Details

AttachmentIsValid(self, attachment)

TRUE if attachment is a valid attachment point.

Overrides:
wx.lib.ogl.Shape.AttachmentIsValid (inherited documentation)

EditRegions(self)

Edit the region colours and styles. Not implemented.

GetAttachmentPosition(self,
          attachment,
          nth=0,
          no_arcs=1,
          line=None)

Get the position at which the given attachment point should be drawn.

If attachment isn't found among the attachment points of the shape, returns None.

Overrides:
wx.lib.ogl.Shape.GetAttachmentPosition (inherited documentation)

GetNumberOfAttachments(self)

Get the number of attachment points for this shape.

Overrides:
wx.lib.ogl.Shape.GetNumberOfAttachments (inherited documentation)

MakeControlPoints(self)

Make a list of control points (draggable handles) appropriate to the shape.

Overrides:
wx.lib.ogl.Shape.MakeControlPoints (inherited documentation)

MakeMandatoryControlPoints(self)

Make the mandatory control points.

For example, the control point on a dividing line should appear even if the divided rectangle shape's handles should not appear (because it is the child of a composite, and children are not resizable).

Overrides:
wx.lib.ogl.Shape.MakeMandatoryControlPoints (inherited documentation)

ResetControlPoints(self)

Reset the positions of the control points (for instance when the shape's shape has changed).

Overrides:
wx.lib.ogl.Shape.ResetControlPoints (inherited documentation)

ResetMandatoryControlPoints(self)

Reset the mandatory control points.

Overrides:
wx.lib.ogl.Shape.ResetMandatoryControlPoints (inherited documentation)

SetRegionSizes(self)

Set all region sizes according to proportions and this object total size.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:09 2005 http://epydoc.sf.net


wx.lib.ogl.DividedShapeControlPoint

Package wx :: Package lib :: Package ogl :: Class DividedShapeControlPoint
[frames | no frames]

Type DividedShapeControlPoint

     object --+
              |
ShapeEvtHandler --+
                  |
              Shape --+
                      |
         RectangleShape --+
                          |
               ControlPoint --+
                              |
                             DividedShapeControlPoint

Method Summary
 | __init__(self, the_canvas, object, region, size, the_m_xoffset, the_m_yoffset, the_type)
 | OnBeginDragLeft(self, x, y, keys, attachment)
 | OnDragLeft(self, draw, x, y, keys, attachment)
 | OnEndDragLeft(self, x, y, keys, attachment)

Class Variable Summary

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:46 2005 http://epydoc.sf.net


wx.lib.ogl.DivisionControlPoint

Package wx :: Package lib :: Package ogl :: Class DivisionControlPoint
[frames | no frames]

Type DivisionControlPoint

     object --+
              |
ShapeEvtHandler --+
                  |
              Shape --+
                      |
         RectangleShape --+
                          |
               ControlPoint --+
                              |
                             DivisionControlPoint

Method Summary
 | __init__(self, the_canvas, object, size, the_xoffset, the_yoffset, the_type)
 | OnBeginDragLeft(self, x, y, keys, attachment)
 | OnDragLeft(self, draw, x, y, keys, attachment)
 | OnEndDragLeft(self, x, y, keys, attachment)

Class Variable Summary

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:22 2005 http://epydoc.sf.net


wx.lib.ogl.DivisionShape

Package wx :: Package lib :: Package ogl :: Class DivisionShape
[frames | no frames]

Type DivisionShape

     object --+
              |
ShapeEvtHandler --+
                  |
              Shape --+
                      |
         RectangleShape --+
                          |
             CompositeShape --+
                              |
                             DivisionShape

A division shape is like a composite in that it can contain further objects, but is used exclusively to divide another shape into regions, or divisions. A wxDivisionShape is never free-standing.

Derived from:
wxCompositeShape
Method Summary
 | __init__(self)
 | AdjustLeft(self, left, test) Adjust a side.
 | AdjustRight(self, right, test) Adjust a side.
 | AdjustTop(self, top, test) Adjust a side.
 | CalculateSize(self) Calculates the size and position of the composite based on child sizes and positions.
 | Divide(self, direction) Divide this division into two further divisions, horizontally (direction is wxHORIZONTAL) or vertically (direction is wxVERTICAL).
 | EditEdge(self, side)
 | GetBottomSide(self) Return the division on the bottom side of this division.
 | GetHandleSide(self) Return the side which the handle appears on.
 | GetLeftSide(self) Return the division on the left side of this division.
 | GetLeftSideColour(self) Return the colour used for drawing the left side of the division.
 | GetLeftSidePen(self) Return the pen used for drawing the left side of the division.
 | GetLeftSideStyle(self) Return the style used for the left side of the division.
 | GetRightSide(self) Return the division on the right side of this division.
 | GetTopSide(self) Return the division on the top side of this division.
 | GetTopSideColour(self) Return the colour used for drawing the top side of the division.
 | GetTopSidePen(self) Return the pen used for drawing the top side of the division.
 | GetTopSideStyle(self) Return the style used for the top side of the division.
 | MakeControlPoints(self) Make a list of control points (draggable handles) appropriate to the shape.
 | MakeMandatoryControlPoints(self) Make the mandatory control points.
 | OnBeginDragLeft(self, x, y, keys, attachment)
 | OnDragLeft(self, draw, x, y, keys, attachment)
 | OnDraw(self, dc)
 | OnDrawContents(self, dc)
 | OnEndDragLeft(self, x, y, keys, attachment)
 | OnMovePre(self, dc, x, y, oldx, oldy, display)
 | OnRightClick(self, x, y, keys, attachment)
 | PopupMenu(self, x, y)
 | ResetControlPoints(self) Reset the positions of the control points (for instance when the shape's shape has changed).
 | ResetMandatoryControlPoints(self) Reset the mandatory control points.
 | ResizeAdjoining(self, side, newPos, test) Resize adjoining divisions at the given side.
 | SetBottomSide(self, shape) Set the the division on the bottom side of this division.
 | SetHandleSide(self, side) Sets the side which the handle appears on.
 | SetLeftSide(self, shape) Set the the division on the left side of this division.
 | SetLeftSideColour(self, colour) Set the colour for drawing the left side of the division.
 | SetLeftSidePen(self, pen) Set the colour for drawing the left side of the division.
 | SetLeftSideStyle(self, style)
 | SetRightSide(self, shape) Set the the division on the right side of this division.
 | SetSize(self, w, h, recursive)
 | SetTopSide(self, shape) Set the the division on the top side of this division.
 | SetTopSideColour(self, colour) Set the colour for drawing the top side of the division.
 | SetTopSidePen(self, pen) Set the colour for drawing the top side of the division.
 | SetTopSideStyle(self, style)

Class Variable Summary

Method Details

AdjustLeft(self, left, test)

Adjust a side.

Returns FALSE if it's not physically possible to adjust it to this point.

AdjustRight(self, right, test)

Adjust a side.

Returns FALSE if it's not physically possible to adjust it to this point.

AdjustTop(self, top, test)

Adjust a side.

Returns FALSE if it's not physically possible to adjust it to this point.

CalculateSize(self)

Calculates the size and position of the composite based on child sizes and positions.

Overrides:
wx.lib.ogl.CompositeShape.CalculateSize (inherited documentation)

Divide(self, direction)

Divide this division into two further divisions, horizontally (direction is wxHORIZONTAL) or vertically (direction is wxVERTICAL).

GetBottomSide(self)

Return the division on the bottom side of this division.

GetHandleSide(self)

Return the side which the handle appears on.

GetLeftSide(self)

Return the division on the left side of this division.

GetLeftSideColour(self)

Return the colour used for drawing the left side of the division.

GetLeftSidePen(self)

Return the pen used for drawing the left side of the division.

GetLeftSideStyle(self)

Return the style used for the left side of the division.

GetRightSide(self)

Return the division on the right side of this division.

GetTopSide(self)

Return the division on the top side of this division.

GetTopSideColour(self)

Return the colour used for drawing the top side of the division.

GetTopSidePen(self)

Return the pen used for drawing the top side of the division.

GetTopSideStyle(self)

Return the style used for the top side of the division.

MakeControlPoints(self)

Make a list of control points (draggable handles) appropriate to the shape.

Overrides:
wx.lib.ogl.Shape.MakeControlPoints (inherited documentation)

MakeMandatoryControlPoints(self)

Make the mandatory control points.

For example, the control point on a dividing line should appear even if the divided rectangle shape's handles should not appear (because it is the child of a composite, and children are not resizable).

Overrides:
wx.lib.ogl.Shape.MakeMandatoryControlPoints (inherited documentation)

ResetControlPoints(self)

Reset the positions of the control points (for instance when the shape's shape has changed).

Overrides:
wx.lib.ogl.Shape.ResetControlPoints (inherited documentation)

ResetMandatoryControlPoints(self)

Reset the mandatory control points.

Overrides:
wx.lib.ogl.Shape.ResetMandatoryControlPoints (inherited documentation)

ResizeAdjoining(self, side, newPos, test)

Resize adjoining divisions at the given side.

If test is TRUE, just see whether it's possible for each adjoining region, returning FALSE if it's not.

side can be one of:

  • DIVISION_SIDE_NONE
  • DIVISION_SIDE_LEFT
  • DIVISION_SIDE_TOP
  • DIVISION_SIDE_RIGHT
  • DIVISION_SIDE_BOTTOM

SetBottomSide(self, shape)

Set the the division on the bottom side of this division.

SetHandleSide(self, side)

Sets the side which the handle appears on.

Either DIVISION_SIDE_LEFT or DIVISION_SIDE_TOP.

SetLeftSide(self, shape)

Set the the division on the left side of this division.

SetLeftSideColour(self, colour)

Set the colour for drawing the left side of the division.

SetLeftSidePen(self, pen)

Set the colour for drawing the left side of the division.

SetRightSide(self, shape)

Set the the division on the right side of this division.

SetTopSide(self, shape)

Set the the division on the top side of this division.

SetTopSideColour(self, colour)

Set the colour for drawing the top side of the division.

SetTopSidePen(self, pen)

Set the colour for drawing the top side of the division.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:22 2005 http://epydoc.sf.net


wx.lib.ogl.DrawnShape

Package wx :: Package lib :: Package ogl :: Class DrawnShape

Type DrawnShape

     object --+
              |
ShapeEvtHandler --+
                  |
              Shape --+
                      |
         RectangleShape --+
                          |
                         DrawnShape

Draws a pseudo-metafile shape, which can be loaded from a simple Windows metafile.

wxDrawnShape allows you to specify a different shape for each of four orientations (North, West, South and East). It also provides a set of drawing functions for programmatic drawing of a shape, so that during construction of the shape you can draw into it as if it were a device context.

Derived from:
RectangleShape
Method Summary
 | __init__(self)
 | CalculateSize(self) Calculate the wxDrawnShape size from the current metafile.
 | DestroyClippingRect(self) Destroy the clipping rectangle.
 | DetermineMetaFile(self, rotation)
 | DrawArc(self, centrePt, startPt, endPt) Draw an arc.
 | DrawAtAngle(self, angle) Set the metafile for the given orientation, which can be one of:
 | DrawEllipse(self, rect)
 | DrawEllipticArc(self, rect, startAngle, endAngle) Draw an elliptic arc.
 | DrawLine(self, pt1, pt2)
 | DrawLines(self, pts)
 | DrawPoint(self, pt)
 | DrawPolygon(self, pts, flags) Draw a polygon.
 | DrawRectangle(self, rect)
 | DrawRoundedRectangle(self, rect, radius) Draw a rounded rectangle.
 | DrawSpline(self, pts)
 | DrawText(self, text, pt)
 | GetAngle(self) Return the current orientation, which can be one of:
 | GetMetaFile(self, which) Return a reference to the internal 'pseudo-metafile'.
 | GetPerimeterPoint(self, x1, y1, x2, y2) Get the point at which the line from (x1, y1) to (x2, y2) hits the shape.
 | GetRotation(self) Return the current rotation of the shape in radians.
 | LoadFromMetaFile(self, filename) Load a (very simple) Windows metafile, created for example by Top Draw, the Windows shareware graphics package.
 | OnDraw(self, dc)
 | OnDrawOutline(self, dc, x, y, w, h)
 | Rotate(self, x, y, theta) Rotate about the given axis by the given amount in radians.
 | Scale(self, sx, sy) Scale the shape by the given amount.
 | SetClippingRect(self, rect) Set the clipping rectangle.
 | SetDrawnBackgroundColour(self, colour) Set the current background colour for the current metafile.
 | SetDrawnBackgroundMode(self, mode) Set the current background mode for the current metafile.
 | SetDrawnBrush(self, brush, isFill) Set the brush for this metafile.
 | SetDrawnFont(self, font)
 | SetDrawnPen(self, pen, isOutline) Set the pen for this metafile.
 | SetDrawnTextColour(self, colour) Set the current text colour for the current metafile.
 | SetSaveToFile(self, save) If save is True, the image will be saved along with the shape's other attributes.
 | SetSize(self, w, h, recursive)
 | Translate(self, x, y) Translate the shape by the given amount.

Class Variable Summary

Method Details

CalculateSize(self)

Calculate the wxDrawnShape size from the current metafile.

Call this after you have drawn into the shape.

DestroyClippingRect(self)

Destroy the clipping rectangle.

DrawArc(self, centrePt, startPt, endPt)

Draw an arc.

DrawAtAngle(self, angle)

Set the metafile for the given orientation, which can be one of:

  • DRAWN_ANGLE_0
  • DRAWN_ANGLE_90
  • DRAWN_ANGLE_180
  • DRAWN_ANGLE_270

DrawEllipticArc(self, rect, startAngle, endAngle)

Draw an elliptic arc.

DrawPolygon(self, pts, flags=0)

Draw a polygon.

flags can be one or more of: METAFLAGS_OUTLINE (use this polygon for the drag outline) and METAFLAGS_ATTACHMENTS (use the vertices of this polygon for attachments).

DrawRoundedRectangle(self, rect, radius)

Draw a rounded rectangle.

radius is the corner radius. If radius is negative, it expresses the radius as a proportion of the smallest dimension of the rectangle.

GetAngle(self)

Return the current orientation, which can be one of:

  • DRAWN_ANGLE_0
  • DRAWN_ANGLE_90
  • DRAWN_ANGLE_180
  • DRAWN_ANGLE_270

GetMetaFile(self, which=0)

Return a reference to the internal 'pseudo-metafile'.

GetPerimeterPoint(self, x1, y1, x2, y2)

Get the point at which the line from (x1, y1) to (x2, y2) hits the shape. Returns False if the line doesn't hit the perimeter.

Overrides:
wx.lib.ogl.RectangleShape.GetPerimeterPoint (inherited documentation)

GetRotation(self)

Return the current rotation of the shape in radians.

Overrides:
wx.lib.ogl.Shape.GetRotation

LoadFromMetaFile(self, filename)

Load a (very simple) Windows metafile, created for example by Top Draw, the Windows shareware graphics package.

Rotate(self, x, y, theta)

Rotate about the given axis by the given amount in radians.

Overrides:
wx.lib.ogl.Shape.Rotate

Scale(self, sx, sy)

Scale the shape by the given amount.

SetClippingRect(self, rect)

Set the clipping rectangle.

SetDrawnBackgroundColour(self, colour)

Set the current background colour for the current metafile.

SetDrawnBackgroundMode(self, mode)

Set the current background mode for the current metafile.

SetDrawnBrush(self, brush, isFill=False)

Set the brush for this metafile.

If isFill is True, the brush is used as the fill brush.

SetDrawnPen(self, pen, isOutline=False)

Set the pen for this metafile.

If isOutline is True, this pen is taken to indicate the outline (and if the outline pen is changed for the whole shape, the pen will be replaced with the outline pen).

SetDrawnTextColour(self, colour)

Set the current text colour for the current metafile.

SetSaveToFile(self, save)

If save is True, the image will be saved along with the shape's other attributes. The reason why this might not be desirable is that if there are many shapes with the same image, it would be more efficient for the application to save one copy, and not duplicate the information for every shape. The default is True.

Translate(self, x, y)

Translate the shape by the given amount.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:10:54 2005 http://epydoc.sf.net


wx.lib.ogl.DrawOp

Package wx :: Package lib :: Package ogl :: Class DrawOp

Type DrawOp

object --+
         |
        DrawOp

Known Subclasses:
OpDraw, OpPolyDraw, OpSetClipping, OpSetGDI
Method Summary
 | __init__(self, theOp)
 | GetOp(self)
 | GetPerimeterPoint(self, x1, y1, x2, y2, xOffset, yOffset, attachmentMode)
 | Rotate(self, x, y, theta, sinTheta, cosTheta)
 | Scale(self, scaleX, scaleY)
 | Translate(self, x, y)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:45 2005 http://epydoc.sf.net


wx.lib.ogl.EllipseShape

Package wx :: Package lib :: Package ogl :: Class EllipseShape
[frames | no frames]

Type EllipseShape

     object --+
              |
ShapeEvtHandler --+
                  |
              Shape --+
                      |
                     EllipseShape

Known Subclasses:
CircleShape

The EllipseShape behaves similarly to the RectangleShape but is elliptical.

Derived from:
wxShape
Method Summary
 | __init__(self, w, h)
 | GetAttachmentPosition(self, attachment, nth, no_arcs, line) Get the position at which the given attachment point should be drawn.
 | GetBoundingBoxMin(self) Get the minimum bounding box for the shape, that defines the area available for drawing the contents (such as text).
 | GetHeight(self)
 | GetNumberOfAttachments(self) Get the number of attachment points for this shape.
 | GetPerimeterPoint(self, x1, y1, x2, y2) Get the point at which the line from (x1, y1) to (x2, y2) hits the shape.
 | GetWidth(self)
 | OnDraw(self, dc)
 | SetHeight(self, h)
 | SetSize(self, x, y, recursive) Set the shape's size.
 | SetWidth(self, w)

Class Variable Summary

Method Details

GetAttachmentPosition(self,
          attachment,
          nth=0,
          no_arcs=1,
          line=None)

Get the position at which the given attachment point should be drawn.

If attachment isn't found among the attachment points of the shape, returns None.

Overrides:
wx.lib.ogl.Shape.GetAttachmentPosition (inherited documentation)

GetBoundingBoxMin(self)

Get the minimum bounding box for the shape, that defines the area available for drawing the contents (such as text).

Must be overridden.

Overrides:
wx.lib.ogl.Shape.GetBoundingBoxMin (inherited documentation)

GetNumberOfAttachments(self)

Get the number of attachment points for this shape.

Overrides:
wx.lib.ogl.Shape.GetNumberOfAttachments (inherited documentation)

GetPerimeterPoint(self, x1, y1, x2, y2)

Get the point at which the line from (x1, y1) to (x2, y2) hits the shape. Returns False if the line doesn't hit the perimeter.

Overrides:
wx.lib.ogl.Shape.GetPerimeterPoint (inherited documentation)

SetSize(self, x, y, recursive=True)

Set the shape's size.

Overrides:
wx.lib.ogl.Shape.SetSize (inherited documentation)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:18 2005 http://epydoc.sf.net


wx.lib.ogl.LabelShape

Package wx :: Package lib :: Package ogl :: Class LabelShape

Type LabelShape

     object --+
              |
ShapeEvtHandler --+
                  |
              Shape --+
                      |
         RectangleShape --+
                          |
                         LabelShape

Method Summary
 | __init__(self, parent, region, w, h)
 | OnBeginDragLeft(self, x, y, keys, attachment)
 | OnDragLeft(self, draw, x, y, keys, attachment)
 | OnDraw(self, dc)
 | OnDrawContents(self, dc)
 | OnEndDragLeft(self, x, y, keys, attachment)
 | OnLeftClick(self, x, y, keys, attachment)
 | OnMovePre(self, dc, x, y, old_x, old_y, display)
 | OnRightClick(self, x, y, keys, attachment)

Class Variable Summary

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:12 2005 http://epydoc.sf.net


wx.lib.ogl.LineControlPoint

Package wx :: Package lib :: Package ogl :: Class LineControlPoint
[frames | no frames]

Type LineControlPoint

     object --+
              |
ShapeEvtHandler --+
                  |
              Shape --+
                      |
         RectangleShape --+
                          |
               ControlPoint --+
                              |
                             LineControlPoint

Method Summary
 | __init__(self, theCanvas, object, size, x, y, the_type)
 | OnBeginDragLeft(self, x, y, keys, attachment)
 | OnDragLeft(self, draw, x, y, keys, attachment)
 | OnDraw(self, dc)
 | OnEndDragLeft(self, x, y, keys, attachment)

Class Variable Summary

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:04 2005 http://epydoc.sf.net


wx.lib.ogl.LineShape

Package wx :: Package lib :: Package ogl :: Class LineShape

Type LineShape

     object --+
              |
ShapeEvtHandler --+
                  |
              Shape --+
                      |
                     LineShape

LineShape may be attached to two nodes; it may be segmented, in which case a control point is drawn for each joint.

A wxLineShape may have arrows at the beginning, end and centre.

Derived from:
Shape
Method Summary
 | __init__(self)
 | __del__(self)
 | AddArrow(self, type, end, size, xOffset, name, mf, arrowId) Add an arrow (or annotation) to the line.
 | AddArrowOrdered(self, arrow, referenceList, end) Add an arrowhead in the position indicated by the reference list of arrowheads, which contains all legal arrowheads for this line, in the correct order.
 | ClearArrow(self, name) Delete the arrow with the given name.
 | ClearArrowsAtPosition(self, end) Delete the arrows at the specified position, or at any position if position is -1.
 | DeleteArrowHead(self, position, name) Delete arrowhead by position and name.
 | DeleteArrowHeadId(self, id) Delete arrowhead by id.
 | DeleteLineControlPoint(self) Delete an arbitary point on the line.
 | Draggable(self) TRUE if the shape may be dragged by the user.
 | DrawArrow(self, dc, arrow, XOffset, proportionalOffset) Draw the given arrowhead (or annotation).
 | DrawArrows(self, dc) Draw all arrows.
 | DrawRegion(self, dc, region, x, y) Format one region at this position.
 | EraseRegion(self, dc, region, x, y) Erase one region at this position.
 | FindArrowHead(self, position, name) Find arrowhead by position and name.
 | FindArrowHeadId(self, arrowId) Find arrowhead by id.
 | FindLineEndPoints(self) Finds the x, y points at the two ends of the line.
 | FindLinePosition(self, x, y) Find which position we're talking about at this x, y.
 | FindMinimumWidth(self) Find the horizontal width for drawing a line with arrows in minimum space.
 | FindNth(self, image, incoming) Find the position of the line on the given object.
 | FormatText(self, dc, s, i) Format a text string according to the region size, adding strings with positions to region text list.
 | GetAlignmentEnd(self)
 | GetAlignmentOrientation(self, isEnd)
 | GetAlignmentStart(self)
 | GetAlignmentType(self, isEnd)
 | GetArrows(self)
 | GetAttachmentFrom(self) Return the attachment point on the 'from' node.
 | GetAttachmentTo(self) Return the attachment point on the 'to' node.
 | GetBoundingBoxMin(self) Get the minimum bounding box for the shape, that defines the area available for drawing the contents (such as text).
 | GetEnds(self) Get the visible endpoints of the lines for drawing between two objects.
 | GetFrom(self) Return the 'from' object.
 | GetLabelPosition(self, position) Get the reference point for a label.
 | GetLineControlPoints(self)
 | GetNextControlPoint(self, shape) Find the next control point in the line after the start / end point, depending on whether the shape is at the start or end.
 | GetTo(self) Return the 'to' object.
 | HitTest(self, x, y) Given a point on a canvas, returns TRUE if the point was on the shape, and returns the nearest attachment point and distance from the given point and target.
 | Initialise(self) Initialise the line object.
 | InsertLineControlPoint(self, dc, point) Insert a control point at an optional given position.
 | IsEnd(self, nodeObject) TRUE if shape is at the end of the line.
 | IsSpline(self) TRUE if a spline is drawn through the control points.
 | MakeControlPoints(self) Make handle control points.
 | MakeLineControlPoints(self, n) Make a given number of control points (minimum of two).
 | OnBeginDragLeft(self, x, y, keys, attachment)
 | OnCreateLabelShape(self, parent, region, w, h)
 | OnDragLeft(self, draw, x, y, keys, attachment)
 | OnDraw(self, dc)
 | OnDrawContents(self, dc)
 | OnDrawControlPoints(self, dc)
 | OnDrawOutline(self, dc, x, y, w, h)
 | OnEndDragLeft(self, x, y, keys, attachment)
 | OnErase(self, dc)
 | OnEraseControlPoints(self, dc)
 | OnLabelMovePre(self, dc, labelShape, x, y, old_x, old_y, display)
 | OnMoveLink(self, dc, moveControlPoints) Called when a connected object has moved, to move the link to correct position
 | OnMoveMiddleControlPoint(self, dc, lpt, pt)
 | OnMovePre(self, dc, x, y, old_x, old_y, display)
 | OnSizingBeginDragLeft(self, pt, x, y, keys, attachment)
 | OnSizingDragLeft(self, pt, draw, x, y, keys, attachment)
 | OnSizingEndDragLeft(self, pt, x, y, keys, attachment)
 | ResetControlPoints(self) Reset the positions of the control points (for instance when the shape's shape has changed).
 | Select(self, select, dc) Select or deselect the given shape, drawing or erasing control points (handles) as necessary.
 | SetAlignmentOrientation(self, isEnd, isHoriz)
 | SetAlignmentType(self, isEnd, alignType)
 | SetAttachmentFrom(self, attach) Set the 'from' shape attachment.
 | SetAttachments(self, from_attach, to_attach) Specify which object attachment points should be used at each end of the line.
 | SetAttachmentTo(self, attach) Set the 'to' shape attachment.
 | SetEnds(self, x1, y1, x2, y2) Set the end positions of the line.
 | SetFrom(self, object) Set the 'from' object for the line.
 | SetIgnoreOffsets(self, ignore) Set whether to ignore offsets from the end of the line when drawing.
 | SetSpline(self, spline) Specifies whether a spline is to be drawn through the control points.
 | SetTo(self, object) Set the 'to' object for the line.
 | Straighten(self, dc) Straighten verticals and horizontals.
 | Unlink(self) Unlink the line from the nodes at either end.

Class Variable Summary

Method Details

AddArrow(self,
          type,
          end=1,
          size=10.0,
          xOffset=0.0,
          name='',
          mf=None,
          arrowId=-1)

Add an arrow (or annotation) to the line.

type may currently be one of:

ARROW_HOLLOW_CIRCLE
Hollow circle.
ARROW_FILLED_CIRCLE
Filled circle.
ARROW_ARROW
Conventional arrowhead.
ARROW_SINGLE_OBLIQUE
Single oblique stroke.
ARROW_DOUBLE_OBLIQUE
Double oblique stroke.
ARROW_DOUBLE_METAFILE
Custom arrowhead.

end may currently be one of:

ARROW_POSITION_END
Arrow appears at the end.
ARROW_POSITION_START
Arrow appears at the start.

arrowSize specifies the length of the arrow.

xOffset specifies the offset from the end of the line.

name specifies a name for the arrow.

mf can be a wxPseduoMetaFile, perhaps loaded from a simple Windows metafile.

arrowId is the id for the arrow.

AddArrowOrdered(self, arrow, referenceList, end)

Add an arrowhead in the position indicated by the reference list of arrowheads, which contains all legal arrowheads for this line, in the correct order. E.g.

Reference list: a b c d e Current line list: a d

Add c, then line list is: a c d.

If no legal arrowhead position, return FALSE. Assume reference list is for one end only, since it potentially defines the ordering for any one of the 3 positions. So we don't check the reference list for arrowhead position.

ClearArrow(self, name)

Delete the arrow with the given name.

ClearArrowsAtPosition(self, end)

Delete the arrows at the specified position, or at any position if position is -1.

DeleteArrowHead(self, position, name)

Delete arrowhead by position and name.

if position is -1, matches any position.

DeleteArrowHeadId(self, id)

Delete arrowhead by id.

DeleteLineControlPoint(self)

Delete an arbitary point on the line.

Draggable(self)

TRUE if the shape may be dragged by the user.

Overrides:
wx.lib.ogl.Shape.Draggable (inherited documentation)

DrawArrow(self, dc, arrow, XOffset, proportionalOffset)

Draw the given arrowhead (or annotation).

DrawArrows(self, dc)

Draw all arrows.

DrawRegion(self, dc, region, x, y)

Format one region at this position.

EraseRegion(self, dc, region, x, y)

Erase one region at this position.

FindArrowHead(self, position, name)

Find arrowhead by position and name.

if position is -1, matches any position.

FindArrowHeadId(self, arrowId)

Find arrowhead by id.

FindLineEndPoints(self)

Finds the x, y points at the two ends of the line.

This function can be used by e.g. line-routing routines to get the actual points on the two node images where the lines will be drawn to / from.

FindLinePosition(self, x, y)

Find which position we're talking about at this x, y.

Returns ARROW_POSITION_START, ARROW_POSITION_MIDDLE, ARROW_POSITION_END.

FindMinimumWidth(self)

Find the horizontal width for drawing a line with arrows in minimum space. Assume arrows at end only.

FindNth(self, image, incoming)

Find the position of the line on the given object.

Specify whether incoming or outgoing lines are being considered with incoming.

FormatText(self, dc, s, i)

Format a text string according to the region size, adding strings with positions to region text list.

Overrides:
wx.lib.ogl.Shape.FormatText

GetAttachmentFrom(self)

Return the attachment point on the 'from' node.

GetAttachmentTo(self)

Return the attachment point on the 'to' node.

GetBoundingBoxMin(self)

Get the minimum bounding box for the shape, that defines the area available for drawing the contents (such as text).

Must be overridden.

Overrides:
wx.lib.ogl.Shape.GetBoundingBoxMin (inherited documentation)

GetEnds(self)

Get the visible endpoints of the lines for drawing between two objects.

GetFrom(self)

Return the 'from' object.

GetLabelPosition(self, position)

Get the reference point for a label.

Region x and y are offsets from this. position is 0 (middle), 1 (start), 2 (end).

GetNextControlPoint(self, shape)

Find the next control point in the line after the start / end point, depending on whether the shape is at the start or end.

GetTo(self)

Return the 'to' object.

HitTest(self, x, y)

Given a point on a canvas, returns TRUE if the point was on the shape, and returns the nearest attachment point and distance from the given point and target.

Overrides:
wx.lib.ogl.Shape.HitTest (inherited documentation)

Initialise(self)

Initialise the line object.

InsertLineControlPoint(self, dc=None, point=None)

Insert a control point at an optional given position.

IsEnd(self, nodeObject)

TRUE if shape is at the end of the line.

IsSpline(self)

TRUE if a spline is drawn through the control points.

MakeControlPoints(self)

Make handle control points.

Overrides:
wx.lib.ogl.Shape.MakeControlPoints

MakeLineControlPoints(self, n)

Make a given number of control points (minimum of two).

OnMoveLink(self, dc, moveControlPoints=True)

Called when a connected object has moved, to move the link to correct position

Overrides:
wx.lib.ogl.ShapeEvtHandler.OnMoveLink

ResetControlPoints(self)

Reset the positions of the control points (for instance when the shape's shape has changed).

Overrides:
wx.lib.ogl.Shape.ResetControlPoints (inherited documentation)

Select(self, select, dc=None)

Select or deselect the given shape, drawing or erasing control points (handles) as necessary.

Overrides:
wx.lib.ogl.Shape.Select (inherited documentation)

SetAttachmentFrom(self, attach)

Set the 'from' shape attachment.

SetAttachments(self, from_attach, to_attach)

Specify which object attachment points should be used at each end of the line.

SetAttachmentTo(self, attach)

Set the 'to' shape attachment.

SetEnds(self, x1, y1, x2, y2)

Set the end positions of the line.

SetFrom(self, object)

Set the 'from' object for the line.

SetIgnoreOffsets(self, ignore)

Set whether to ignore offsets from the end of the line when drawing.

SetSpline(self, spline)

Specifies whether a spline is to be drawn through the control points.

SetTo(self, object)

Set the 'to' object for the line.

Straighten(self, dc=None)

Straighten verticals and horizontals.

Unlink(self)

Unlink the line from the nodes at either end.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:39 2005 http://epydoc.sf.net


wx.lib.ogl.OpDraw

Package wx :: Package lib :: Package ogl :: Class OpDraw

Type OpDraw

object --+
         |
    DrawOp --+
             |
            OpDraw

Draw line, rectangle, rounded rectangle, ellipse, point, arc, text.

Method Summary
 | __init__(self, theOp, theX1, theY1, theX2, theY2, theRadius, s)
 | Do(self, dc, xoffset, yoffset)
 | Rotate(self, x, y, theta, sinTheta, cosTheta)
 | Scale(self, scaleX, scaleY)
 | Translate(self, x, y)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:11 2005 http://epydoc.sf.net


wx.lib.ogl.OpPolyDraw

Package wx :: Package lib :: Package ogl :: Class OpPolyDraw

Type OpPolyDraw

object --+
         |
    DrawOp --+
             |
            OpPolyDraw

Draw polygon, polyline, spline.

Method Summary
 | __init__(self, theOp, thePoints)
 | Do(self, dc, xoffset, yoffset)
 | GetPerimeterPoint(self, x1, y1, x2, y2, xOffset, yOffset, attachmentMode)
 | OnDrawOutline(self, dc, x, y, w, h, oldW, oldH)
 | Rotate(self, x, y, theta, sinTheta, cosTheta)
 | Scale(self, scaleX, scaleY)
 | Translate(self, x, y)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:15 2005 http://epydoc.sf.net


wx.lib.ogl.OpSetClipping

Package wx :: Package lib :: Package ogl :: Class OpSetClipping
[frames | no frames]

Type OpSetClipping

object --+
         |
    DrawOp --+
             |
            OpSetClipping

Set/destroy clipping.

Method Summary
 | __init__(self, theOp, theX1, theY1, theX2, theY2)
 | Do(self, dc, xoffset, yoffset)
 | Scale(self, scaleX, scaleY)
 | Translate(self, x, y)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:27 2005 http://epydoc.sf.net


wx.lib.ogl.OpSetGDI

Package wx :: Package lib :: Package ogl :: Class OpSetGDI

Type OpSetGDI

object --+
         |
    DrawOp --+
             |
            OpSetGDI

Set font, brush, text colour.

Method Summary
 | __init__(self, theOp, theImage, theGdiIndex, theMode)
 | Do(self, dc, xoffset, yoffset)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:01 2005 http://epydoc.sf.net


wx.lib.ogl.PolygonControlPoint

Package wx :: Package lib :: Package ogl :: Class PolygonControlPoint
[frames | no frames]

Type PolygonControlPoint

     object --+
              |
ShapeEvtHandler --+
                  |
              Shape --+
                      |
         RectangleShape --+
                          |
               ControlPoint --+
                              |
                             PolygonControlPoint

Method Summary
 | __init__(self, theCanvas, object, size, vertex, the_xoffset, the_yoffset)
 | CalculateNewSize(self, x, y)
 | GetNewSize(self)
 | OnBeginDragLeft(self, x, y, keys, attachment)
 | OnDragLeft(self, draw, x, y, keys, attachment)
 | OnEndDragLeft(self, x, y, keys, attachment)

Class Variable Summary

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:17 2005 http://epydoc.sf.net


wx.lib.ogl.PolygonShape

Package wx :: Package lib :: Package ogl :: Class PolygonShape
[frames | no frames]

Type PolygonShape

     object --+
              |
ShapeEvtHandler --+
                  |
              Shape --+
                      |
                     PolygonShape

A PolygonShape's shape is defined by a number of points passed to the object's constructor. It can be used to create new shapes such as diamonds and triangles.

Method Summary
 | __init__(self)
 | AddPolygonPoint(self, pos) Add a control point after the given point.
 | AttachmentIsValid(self, attachment) TRUE if attachment is a valid attachment point.
 | CalculateBoundingBox(self)
 | CalculatePolygonCentre(self) Recalculates the centre of the polygon, and readjusts the point offsets accordingly.
 | ClearPoints(self)
 | Create(self, the_points) Takes a list of wx.RealPoints or tuples; each point is an offset from the centre.
 | DeletePolygonPoint(self, pos) Delete the given control point.
 | GetAttachmentPosition(self, attachment, nth, no_arcs, line) Get the position at which the given attachment point should be drawn.
 | GetBoundingBoxMin(self) Get the minimum bounding box for the shape, that defines the area available for drawing the contents (such as text).
 | GetNumberOfAttachments(self) Get the number of attachment points for this shape.
 | GetOriginalHeight(self)
 | GetOriginalPoints(self)
 | GetOriginalWidth(self)
 | GetPerimeterPoint(self, x1, y1, x2, y2) Get the point at which the line from (x1, y1) to (x2, y2) hits the shape.
 | GetPoints(self) Return the internal list of polygon vertices.
 | HitTest(self, x, y) Given a point on a canvas, returns TRUE if the point was on the shape, and returns the nearest attachment point and distance from the given point and target.
 | MakeControlPoints(self) Make a list of control points (draggable handles) appropriate to the shape.
 | OnDraw(self, dc)
 | OnDrawOutline(self, dc, x, y, w, h)
 | OnSizingBeginDragLeft(self, pt, x, y, keys, attachment)
 | OnSizingDragLeft(self, pt, draw, x, y, keys, attachment)
 | OnSizingEndDragLeft(self, pt, x, y, keys, attachment)
 | ResetControlPoints(self) Reset the positions of the control points (for instance when the shape's shape has changed).
 | Rotate(self, x, y, theta) Rotate about the given axis by the given amount in radians.
 | SetOriginalHeight(self, h)
 | SetOriginalWidth(self, w)
 | SetSize(self, new_width, new_height, recursive)
 | UpdateOriginalPoints(self) If we've changed the shape, must make the original points match the working points with this function.

Class Variable Summary

Method Details

AddPolygonPoint(self, pos)

Add a control point after the given point.

AttachmentIsValid(self, attachment)

TRUE if attachment is a valid attachment point.

Overrides:
wx.lib.ogl.Shape.AttachmentIsValid (inherited documentation)

CalculatePolygonCentre(self)

Recalculates the centre of the polygon, and readjusts the point offsets accordingly. Necessary since the centre of the polygon is expected to be the real centre of the bounding box.

Create(self, the_points=None)

Takes a list of wx.RealPoints or tuples; each point is an offset from the centre.

DeletePolygonPoint(self, pos)

Delete the given control point.

GetAttachmentPosition(self,
          attachment,
          nth=0,
          no_arcs=1,
          line=None)

Get the position at which the given attachment point should be drawn.

If attachment isn't found among the attachment points of the shape, returns None.

Overrides:
wx.lib.ogl.Shape.GetAttachmentPosition (inherited documentation)

GetBoundingBoxMin(self)

Get the minimum bounding box for the shape, that defines the area available for drawing the contents (such as text).

Must be overridden.

Overrides:
wx.lib.ogl.Shape.GetBoundingBoxMin (inherited documentation)

GetNumberOfAttachments(self)

Get the number of attachment points for this shape.

Overrides:
wx.lib.ogl.Shape.GetNumberOfAttachments (inherited documentation)

GetPerimeterPoint(self, x1, y1, x2, y2)

Get the point at which the line from (x1, y1) to (x2, y2) hits the shape. Returns False if the line doesn't hit the perimeter.

Overrides:
wx.lib.ogl.Shape.GetPerimeterPoint (inherited documentation)

GetPoints(self)

Return the internal list of polygon vertices.

HitTest(self, x, y)

Given a point on a canvas, returns TRUE if the point was on the shape, and returns the nearest attachment point and distance from the given point and target.

Overrides:
wx.lib.ogl.Shape.HitTest (inherited documentation)

MakeControlPoints(self)

Make a list of control points (draggable handles) appropriate to the shape.

Overrides:
wx.lib.ogl.Shape.MakeControlPoints (inherited documentation)

ResetControlPoints(self)

Reset the positions of the control points (for instance when the shape's shape has changed).

Overrides:
wx.lib.ogl.Shape.ResetControlPoints (inherited documentation)

Rotate(self, x, y, theta)

Rotate about the given axis by the given amount in radians.

Overrides:
wx.lib.ogl.Shape.Rotate (inherited documentation)

UpdateOriginalPoints(self)

If we've changed the shape, must make the original points match the working points with this function.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:06 2005 http://epydoc.sf.net


wx.lib.ogl.PopupDivisionMenu

Package wx :: Package lib :: Package ogl :: Class PopupDivisionMenu
[frames | no frames]

Type PopupDivisionMenu

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
              Menu --+
                     |
                    PopupDivisionMenu

Method Summary
 | __init__(self)
 | GetClientData(self)
 | OnMenu(self, event)
 | SetClientData(self, data)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:05 2005 http://epydoc.sf.net


wx.lib.ogl.PseudoMetaFile

Package wx :: Package lib :: Package ogl :: Class PseudoMetaFile
[frames | no frames]

Type PseudoMetaFile

object --+
         |
        PseudoMetaFile

A simple metafile-like class which can load data from a Windows metafile on all platforms.

Method Summary
 | __init__(self)
 | CalculateSize(self, shape)
 | Clear(self)
 | DestroyClippingRect(self)
 | Draw(self, dc, xoffset, yoffset)
 | DrawArc(self, centrePt, startPt, endPt)
 | DrawEllipse(self, rect)
 | DrawEllipticArc(self, rect, startAngle, endAngle)
 | DrawLine(self, pt1, pt2)
 | DrawLines(self, pts)
 | DrawPoint(self, pt)
 | DrawPolygon(self, pts, flags)
 | DrawRectangle(self, rect)
 | DrawRoundedRectangle(self, rect, radius)
 | DrawSpline(self, pts)
 | DrawText(self, text, pt)
 | GetBounds(self)
 | GetFillBrush(self)
 | GetFillColours(self)
 | GetOps(self)
 | GetOutlineColours(self)
 | GetOutlineOp(self)
 | GetOutlinePen(self, pen)
 | GetRotateable(self)
 | IsValid(self)
 | LoadFromMetaFile(self, filename, rwidth, rheight)
 | Rotate(self, x, y, theta)
 | Scale(self, sx, sy)
 | ScaleTo(self, w, h)
 | SetBackgroundColour(self, colour)
 | SetBackgroundMode(self, mode)
 | SetBrush(self, brush, isFill)
 | SetClippingRect(self, rect)
 | SetFillBrush(self, brush)
 | SetFont(self, font)
 | SetOutlineOp(self, op)
 | SetOutlinePen(self, pen)
 | SetPen(self, pen, isOutline)
 | SetRotateable(self, rot)
 | SetSize(self, w, h)
 | SetTextColour(self, colour)
 | Translate(self, x, y)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:23 2005 http://epydoc.sf.net


wx.lib.ogl.RectangleShape

Package wx :: Package lib :: Package ogl :: Class RectangleShape
[frames | no frames]

Type RectangleShape

     object --+
              |
ShapeEvtHandler --+
                  |
              Shape --+
                      |
                     RectangleShape

Known Subclasses:
BitmapShape, CompositeShape, ControlPoint, DividedShape, DrawnShape, LabelShape, TextShape

The wxRectangleShape has rounded or square corners.

Derived from:
Shape
Method Summary
 | __init__(self, w, h)
 | GetBoundingBoxMin(self) Get the minimum bounding box for the shape, that defines the area available for drawing the contents (such as text).
 | GetCornerRadius(self) Get the radius of the rectangle's rounded corners.
 | GetHeight(self)
 | GetPerimeterPoint(self, x1, y1, x2, y2) Get the point at which the line from (x1, y1) to (x2, y2) hits the shape.
 | GetWidth(self)
 | OnDraw(self, dc)
 | SetCornerRadius(self, rad) Set the radius of the rectangle's rounded corners.
 | SetHeight(self, h)
 | SetSize(self, x, y, recursive) Set the shape's size.
 | SetWidth(self, w)

Class Variable Summary

Method Details

GetBoundingBoxMin(self)

Get the minimum bounding box for the shape, that defines the area available for drawing the contents (such as text).

Must be overridden.

Overrides:
wx.lib.ogl.Shape.GetBoundingBoxMin (inherited documentation)

GetCornerRadius(self)

Get the radius of the rectangle's rounded corners.

GetPerimeterPoint(self, x1, y1, x2, y2)

Get the point at which the line from (x1, y1) to (x2, y2) hits the shape. Returns False if the line doesn't hit the perimeter.

Overrides:
wx.lib.ogl.Shape.GetPerimeterPoint (inherited documentation)

SetCornerRadius(self, rad)

Set the radius of the rectangle's rounded corners.

If the radius is zero, a non-rounded rectangle will be drawn. If the radius is negative, the value is the proportion of the smaller dimension of the rectangle.

SetSize(self, x, y, recursive=False)

Set the shape's size.

Overrides:
wx.lib.ogl.Shape.SetSize (inherited documentation)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:08 2005 http://epydoc.sf.net


wx.lib.ogl.ShapeCanvas

Package wx :: Package lib :: Package ogl :: Class ShapeCanvas
[frames | no frames]

Type ShapeCanvas

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
                 Panel --+
                         |
            ScrolledWindow --+
                             |
                            ShapeCanvas

Method Summary
 | __init__(self, parent, id, pos, size, style, name)
 | AddShape(self, object, addAfter)
 | FindShape(self, x, y, info, notObject)
 | GetDiagram(self)
 | GetQuickEditMode(self)
 | InsertShape(self, object)
 | OnBeginDragLeft(self, x, y, keys)
 | OnBeginDragRight(self, x, y, keys)
 | OnDragLeft(self, draw, x, y, keys)
 | OnDragRight(self, draw, x, y, keys)
 | OnEndDragLeft(self, x, y, keys)
 | OnEndDragRight(self, x, y, keys)
 | OnLeftClick(self, x, y, keys)
 | OnMouseEvent(self, evt)
 | OnPaint(self, evt)
 | OnRightClick(self, x, y, keys)
 | Redraw(self, dc)
 | RemoveShape(self, object)
 | SetDiagram(self, diag)
 | Snap(self, x, y)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:38 2005 http://epydoc.sf.net


wx.lib.ogl.Shape

Package wx :: Package lib :: Package ogl :: Class Shape

Type Shape

     object --+
              |
ShapeEvtHandler --+
                  |
                 Shape

Known Subclasses:
EllipseShape, LineShape, PolygonShape, RectangleShape

OGL base class

Shape(canvas = None)

The wxShape is the top-level, abstract object that all other objects are derived from. All common functionality is represented by wxShape's members, and overriden members that appear in derived classes and have behaviour as documented for wxShape, are not documented separately.

Method Summary
 | __init__(self, canvas)
 | __del__(self)
 | __str__(self)
 | AddLine(self, line, other, attachFrom, attachTo, positionFrom, positionTo) Add a line between this shape and the given other shape, at the specified attachment points.
 | AddRegion(self, region) Add a region to the shape.
 | AddText(self, string) Add a line of text to the shape's default text region.
 | AddToCanvas(self, theCanvas, addAfter) Add the shape to the canvas's shape list.
 | AncestorSelected(self) TRUE if the shape's ancestor is currently selected.
 | ApplyAttachmentOrdering(self, linesToSort) Apply the line ordering in linesToSort to the shape, to reorder the way lines are attached.
 | AssignNewIds(self) Assign new ids to this image and its children.
 | Attach(self, can) Set the shape's internal canvas pointer to point to the given canvas.
 | AttachmentIsValid(self, attachment) TRUE if attachment is a valid attachment point.
 | AttachmentSortTest(self, attachmentPoint, pt1, pt2) Return TRUE if pt1 is less than or equal to pt2, in the sense that one point comes before another on an edge of the shape.
 | CalcSimpleAttachment(self, pt1, pt2, nth, noArcs, line) Assuming the attachment lies along a vertical or horizontal line, calculate the position on that point.
 | ClearAttachments(self) Clear internal custom attachment point shapes (of class wxAttachmentPoint).
 | ClearRegions(self) Clear the ShapeRegions from the shape.
 | ClearText(self, regionId) Clear the text from the specified text region.
 | Delete(self)
 | DeleteControlPoints(self, dc) Delete the control points (or handles) for the shape.
 | Detach(self) Disassociates the shape from its canvas.
 | Draggable(self) TRUE if the shape may be dragged by the user.
 | Draw(self, dc) Draw the whole shape and any lines attached to it.
 | DrawContents(self, dc) Draw the internal graphic of the shape (such as text).
 | DrawLinks(self, dc, attachment, recurse) Draws any lines linked to this shape.
 | Erase(self, dc) Erase the shape.
 | EraseContents(self, dc) Erase the shape contents, that is, the area within the shape's minimum bounding box.
 | EraseLinks(self, dc, attachment, recurse) Erase links attached to this shape, but do not repair damage caused to other shapes.
 | FindRegion(self, name) Find the actual image ('this' if non-composite) and region id for the given region name.
 | FindRegionNames(self) Get a list of all region names for this image (composite or simple).
 | Flash(self) Flash the shape.
 | FormatText(self, dc, s, i) Reformat the given text region; defaults to formatting the default region.
 | GetAttachmentLineCount(self, attachment) Get the number of lines at this attachment position.
 | GetAttachmentMode(self) Return the attachment mode.
 | GetAttachmentPosition(self, attachment, nth, no_arcs, line) Get the position at which the given attachment point should be drawn.
 | GetAttachmentPositionEdge(self, attachment, nth, no_arcs, line) Only get the attachment position at the _edge_ of the shape, ignoring branching mode.
 | GetBackgroundBrush(self) Return brush of the right colour for the background.
 | GetBackgroundPen(self) Return pen of the right colour for the background.
 | GetBoundingBoxMax(self) Get the maximum bounding box for the shape, taking into account external features such as shadows.
 | GetBoundingBoxMin(self) Get the minimum bounding box for the shape, that defines the area available for drawing the contents (such as text).
 | GetBranchingAttachmentInfo(self, attachment) Get information about where branching connections go.
 | GetBranchingAttachmentPoint(self, attachment, n)
 | GetBranchingAttachmentRoot(self, attachment) Get the root point at the given attachment.
 | GetBranchStyle(self)
 | GetBrush(self) Return the brush used for filling the shape.
 | GetCanvas(self) Get the internal canvas.
 | GetCentreResize(self) TRUE if the shape is to be resized from the centre (the centre stands still), or FALSE if from the corner or side being dragged (the other corner or side stands still)
 | GetChildren(self) Return the list of children for this shape.
 | GetClassName(self)
 | GetDisableLabel(self) TRUE if the default region will not be shown, FALSE otherwise.
 | GetDrawHandles(self) Return the list of drawhandles.
 | GetEventHandler(self) Return the event handler for this shape.
 | GetFixedHeight(self) TRUE if the shape cannot be resized in the vertical plane.
 | GetFixedSize(self) Return flags indicating whether the shape is of fixed size in either direction.
 | GetFixedWidth(self) TRUE if the shape cannot be resized in the horizontal plane.
 | GetFont(self, regionId) Get the font for the specified text region.
 | GetFormatMode(self, regionId)
 | GetId(self) Return the integer identifier for this shape.
 | GetLinePosition(self, line) Get the zero-based position of line in the list of lines for this shape.
 | GetLines(self) Return the list of lines connected to this shape.
 | GetMaintainAspectRatio(self) TRUE if shape keeps aspect ratio during resize.
 | GetNumberOfAttachments(self) Get the number of attachment points for this shape.
 | GetNumberOfTextRegions(self) Return the number of text regions for this shape.
 | GetParent(self) Return the parent of this shape, if it is part of a composite.
 | GetPen(self) Return the pen used for drawing the shape's outline.
 | GetPerimeterPoint(self, x1, y1, x2, y2) Get the point at which the line from (x1, y1) to (x2, y2) hits the shape.
 | GetRegionId(self, name) Get the region's identifier by name.
 | GetRegionName(self, regionId) Get the region's name.
 | GetRegions(self) Return the list of ShapeRegions.
 | GetRotation(self) Return the angle of rotation in radians.
 | GetSensitivityFilter(self) Return the sensitivity filter, a bitlist of values.
 | GetShadowMode(self) Return the current shadow mode setting
 | GetSpaceAttachments(self) Return whether lines should be spaced out evenly at the point they touch the node (True), or whether they should join at a single point (False).
 | GetTextColour(self, regionId) Get the colour for the specified text region.
 | GetTopAncestor(self) Return the top-most ancestor of this shape (the root of the composite).
 | GetX(self) Get the x position of the centre of the shape.
 | GetY(self) Get the y position of the centre of the shape.
 | HasDescendant(self, image) TRUE if image is a descendant of this composite.
 | HitTest(self, x, y) Given a point on a canvas, returns TRUE if the point was on the shape, and returns the nearest attachment point and distance from the given point and target.
 | InsertInCanvas(self, theCanvas) Insert the shape at the front of the shape list of canvas.
 | IsHighlighted(self) TRUE if the shape is highlighted.
 | IsShown(self) TRUE if the shape is in a visible state, FALSE otherwise.
 | LogicalToPhysicalAttachment(self, logicalAttachment) Rotate the standard attachment point from logical to physical (0 is always North).
 | MakeControlPoints(self) Make a list of control points (draggable handles) appropriate to the shape.
 | MakeMandatoryControlPoints(self) Make the mandatory control points.
 | Move(self, dc, x, y, display) Move the shape to the given position.
 | MoveLineToNewAttachment(self, dc, to_move, x, y) Move the given line (which must already be attached to the shape) to a different attachment point on the shape, or a different order on the same attachment.
 | MoveLinks(self, dc) Redraw all the lines attached to the shape.
 | NameRegions(self, parentName) Make unique names for all the regions in a shape or composite shape.
 | OnBeginDragLeft(self, x, y, keys, attachment)
 | OnBeginDragRight(self, x, y, keys, attachment)
 | OnChangeAttachment(self, attachment, line, ordering)
 | OnDragLeft(self, draw, x, y, keys, attachment)
 | OnDragRight(self, draw, x, y, keys, attachment)
 | OnDraw(self, dc)
 | OnDrawBranches(self, dc, erase)
 | OnDrawBranchesAttachment(self, dc, attachment, erase)
 | OnDrawContents(self, dc)
 | OnDrawControlPoints(self, dc)
 | OnDrawOutline(self, dc, x, y, w, h)
 | OnEndDragLeft(self, x, y, keys, attachment)
 | OnEndDragRight(self, x, y, keys, attachment)
 | OnErase(self, dc)
 | OnEraseContents(self, dc)
 | OnEraseControlPoints(self, dc)
 | OnHighlight(self, dc)
 | OnLeftClick(self, x, y, keys, attachment)
 | OnMoveLinks(self, dc)
 | OnMovePre(self, dc, x, y, old_x, old_y, display)
 | OnRightClick(self, x, y, keys, attachment)
 | OnSize(self, x, y)
 | OnSizingBeginDragLeft(self, pt, x, y, keys, attachment)
 | OnSizingDragLeft(self, pt, draw, x, y, keys, attachment)
 | OnSizingEndDragLeft(self, pt, x, y, keys, attachment)
 | PhysicalToLogicalAttachment(self, physicalAttachment) Rotate the standard attachment point from physical (0 is always North) to logical (0 -> 1 if rotated by 90 degrees)
 | Recentre(self, dc) Do recentring (or other formatting) for all the text regions for this shape.
 | Recompute(self) Recomputes any constraints associated with the shape.
 | RemoveFromCanvas(self, theCanvas) Remove the shape from the canvas.
 | RemoveLine(self, line) Remove the given line from the shape's list of attached lines.
 | ResetControlPoints(self) Reset the positions of the control points (for instance when the shape's shape has changed).
 | ResetMandatoryControlPoints(self) Reset the mandatory control points.
 | Rotate(self, x, y, theta) Rotate about the given axis by the given amount in radians.
 | Select(self, select, dc) Select or deselect the given shape, drawing or erasing control points (handles) as necessary.
 | Selected(self) TRUE if the shape is currently selected.
 | SetAttachmentMode(self, mode) Set the attachment mode.
 | SetAttachmentSize(self, w, h)
 | SetBrush(self, the_brush) Set the brush for filling the shape's shape.
 | SetCanvas(self, theCanvas) Identical to Shape.Attach.
 | SetCentreResize(self, cr) Specify whether the shape is to be resized from the centre (the centre stands still) or from the corner or side being dragged (the other corner or side stands still).
 | SetDefaultRegionSize(self) Set the default region to be consistent with the shape size.
 | SetDisableLabel(self, flag) Set flag to TRUE to stop the default region being shown.
 | SetDraggable(self, drag, recursive) Set the shape to be draggable or not draggable.
 | SetDrawHandles(self, drawH) Set the drawHandles flag for this shape and all descendants.
 | SetEventHandler(self, handler) Set the event handler for this shape.
 | SetFixedSize(self, x, y) Set the shape to be fixed size.
 | SetFont(self, the_font, regionId) Set the font for the specified text region.
 | SetFormatMode(self, mode, regionId) Set the format mode of the default text region.
 | SetHighlight(self, hi, recurse) Set the highlight for a shape.
 | SetId(self, i) Set the integer identifier for this shape.
 | SetMaintainAspectRatio(self, ar) Set whether a shape that resizes should not change the aspect ratio (width and height should be in the original proportion).
 | SetParent(self, p)
 | SetPen(self, the_pen) Set the pen for drawing the shape's outline.
 | SetRegionName(self, name, regionId) Set the name for this region.
 | SetRotation(self, rotation)
 | SetSensitivityFilter(self, sens, recursive) Set the shape to be sensitive or insensitive to specific mouse operations.
 | SetShadowMode(self, mode, redraw) Set the shadow mode (whether a shadow is drawn or not).
 | SetShape(self, sh)
 | SetSize(self, x, y, recursive) Set the shape's size.
 | SetSpaceAttachments(self, sp) Indicate whether lines should be spaced out evenly at the point they touch the node (sp = True), or whether they should join at a single point (sp = False).
 | SetTextColour(self, the_colour, regionId) Set the colour for the specified text region.
 | SetX(self, x) Set the x position of the shape.
 | SetY(self, y) Set the y position of the shape.
 | Show(self, show) Set a flag indicating whether the shape should be drawn.
 | SortLines(self, attachment, linesToSort) Reorder the lines coming into the node image at this attachment position, in the order in which they appear in linesToSort.

Class Variable Summary
bool GraphicsInSizeToContents = False

Method Details

AddLine(self, line, other, attachFrom=0, attachTo=0, positionFrom=-1, positionTo=-1)

Add a line between this shape and the given other shape, at the specified attachment points.

The position in the list of lines at each end can also be specified, so that the line will be drawn at a particular point on its attachment point.

AddRegion(self, region)

Add a region to the shape.

AddText(self, string)

Add a line of text to the shape's default text region.

AddToCanvas(self, theCanvas, addAfter=None)

Add the shape to the canvas's shape list. If addAfter is non-NULL, will add the shape after this one.

AncestorSelected(self)

TRUE if the shape's ancestor is currently selected.

ApplyAttachmentOrdering(self, linesToSort)

Apply the line ordering in linesToSort to the shape, to reorder the way lines are attached.

AssignNewIds(self)

Assign new ids to this image and its children.

Attach(self, can)

Set the shape's internal canvas pointer to point to the given canvas.

AttachmentIsValid(self, attachment)

TRUE if attachment is a valid attachment point.

AttachmentSortTest(self, attachmentPoint, pt1, pt2)

Return TRUE if pt1 is less than or equal to pt2, in the sense that one point comes before another on an edge of the shape.

attachment is the attachment point (side) in question.

This function is used in Shape.MoveLineToNewAttachment to determine the new line ordering.

CalcSimpleAttachment(self, pt1, pt2, nth, noArcs, line)

Assuming the attachment lies along a vertical or horizontal line, calculate the position on that point.

Parameters:

pt1
The first point of the line repesenting the edge of the shape.
pt2
The second point of the line representing the edge of the shape.
nth
The position on the edge (for example there may be 6 lines at this attachment point, and this may be the 2nd line.
noArcs
The number of lines at this edge.
line
The line shape.

Remarks

This function expects the line to be either vertical or horizontal, and determines which.

ClearAttachments(self)

Clear internal custom attachment point shapes (of class wxAttachmentPoint).

ClearRegions(self)

Clear the ShapeRegions from the shape.

ClearText(self, regionId=0)

Clear the text from the specified text region.

DeleteControlPoints(self, dc=None)

Delete the control points (or handles) for the shape.

Does not redraw the shape.

Detach(self)

Disassociates the shape from its canvas.

Draggable(self)

TRUE if the shape may be dragged by the user.

Draw(self, dc)

Draw the whole shape and any lines attached to it.

Do not override this function: override OnDraw, which is called by this function.

DrawContents(self, dc)

Draw the internal graphic of the shape (such as text).

Do not override this function: override OnDrawContents, which is called by this function.

DrawLinks(self, dc, attachment=-1, recurse=False)

Draws any lines linked to this shape.

Erase(self, dc)

Erase the shape. Does not repair damage caused to other shapes.

EraseContents(self, dc)

Erase the shape contents, that is, the area within the shape's minimum bounding box.

EraseLinks(self, dc, attachment=-1, recurse=False)

Erase links attached to this shape, but do not repair damage caused to other shapes.

FindRegion(self, name)

Find the actual image ('this' if non-composite) and region id for the given region name.

FindRegionNames(self)

Get a list of all region names for this image (composite or simple).

Flash(self)

Flash the shape.

FormatText(self, dc, s, i=0)

Reformat the given text region; defaults to formatting the default region.

GetAttachmentLineCount(self, attachment)

Get the number of lines at this attachment position.

GetAttachmentMode(self)

Return the attachment mode.

See Shape.SetAttachmentMode.

GetAttachmentPosition(self,
          attachment,
          nth=0,
          no_arcs=1,
          line=None)

Get the position at which the given attachment point should be drawn.

If attachment isn't found among the attachment points of the shape, returns None.

GetAttachmentPositionEdge(self,
          attachment,
          nth=0,
          no_arcs=1,
          line=None)

Only get the attachment position at the _edge_ of the shape, ignoring branching mode. This is used e.g. to indicate the edge of interest, not the point on the attachment branch.

GetBackgroundBrush(self)

Return brush of the right colour for the background.

GetBackgroundPen(self)

Return pen of the right colour for the background.

GetBoundingBoxMax(self)

Get the maximum bounding box for the shape, taking into account external features such as shadows.

GetBoundingBoxMin(self)

Get the minimum bounding box for the shape, that defines the area available for drawing the contents (such as text).

Must be overridden.

GetBranchingAttachmentInfo(self, attachment)

Get information about where branching connections go.

Returns FALSE if there are no lines at this attachment.

GetBranchingAttachmentRoot(self, attachment)

Get the root point at the given attachment.

GetBrush(self)

Return the brush used for filling the shape.

GetCanvas(self)

Get the internal canvas.

GetCentreResize(self)

TRUE if the shape is to be resized from the centre (the centre stands still), or FALSE if from the corner or side being dragged (the other corner or side stands still)

GetChildren(self)

Return the list of children for this shape.

GetDisableLabel(self)

TRUE if the default region will not be shown, FALSE otherwise.

GetDrawHandles(self)

Return the list of drawhandles.

GetEventHandler(self)

Return the event handler for this shape.

GetFixedHeight(self)

TRUE if the shape cannot be resized in the vertical plane.

GetFixedSize(self)

Return flags indicating whether the shape is of fixed size in either direction.

GetFixedWidth(self)

TRUE if the shape cannot be resized in the horizontal plane.

GetFont(self, regionId=0)

Get the font for the specified text region.

GetId(self)

Return the integer identifier for this shape.

GetLinePosition(self, line)

Get the zero-based position of line in the list of lines for this shape.

GetLines(self)

Return the list of lines connected to this shape.

GetMaintainAspectRatio(self)

TRUE if shape keeps aspect ratio during resize.

GetNumberOfAttachments(self)

Get the number of attachment points for this shape.

GetNumberOfTextRegions(self)

Return the number of text regions for this shape.

GetParent(self)

Return the parent of this shape, if it is part of a composite.

GetPen(self)

Return the pen used for drawing the shape's outline.

GetPerimeterPoint(self, x1, y1, x2, y2)

Get the point at which the line from (x1, y1) to (x2, y2) hits the shape. Returns False if the line doesn't hit the perimeter.

GetRegionId(self, name)

Get the region's identifier by name. This is not unique for within an entire composite, but is unique for the image.

GetRegionName(self, regionId=0)

Get the region's name. A region's name can be used to uniquely determine a region within an entire composite image hierarchy. See also Shape.SetRegionName.

GetRegions(self)

Return the list of ShapeRegions.

GetRotation(self)

Return the angle of rotation in radians.

GetSensitivityFilter(self)

Return the sensitivity filter, a bitlist of values.

See Shape.SetSensitivityFilter.

GetShadowMode(self)

Return the current shadow mode setting

GetSpaceAttachments(self)

Return whether lines should be spaced out evenly at the point they touch the node (True), or whether they should join at a single point (False).

GetTextColour(self, regionId=0)

Get the colour for the specified text region.

GetTopAncestor(self)

Return the top-most ancestor of this shape (the root of the composite).

GetX(self)

Get the x position of the centre of the shape.

GetY(self)

Get the y position of the centre of the shape.

HasDescendant(self, image)

TRUE if image is a descendant of this composite.

HitTest(self, x, y)

Given a point on a canvas, returns TRUE if the point was on the shape, and returns the nearest attachment point and distance from the given point and target.

InsertInCanvas(self, theCanvas)

Insert the shape at the front of the shape list of canvas.

IsHighlighted(self)

TRUE if the shape is highlighted. Shape highlighting is unimplemented.

IsShown(self)

TRUE if the shape is in a visible state, FALSE otherwise.

Note that this has nothing to do with whether the window is hidden or the shape has scrolled off the canvas; it refers to the internal visibility flag.

LogicalToPhysicalAttachment(self, logicalAttachment)

Rotate the standard attachment point from logical to physical (0 is always North).

MakeControlPoints(self)

Make a list of control points (draggable handles) appropriate to the shape.

MakeMandatoryControlPoints(self)

Make the mandatory control points.

For example, the control point on a dividing line should appear even if the divided rectangle shape's handles should not appear (because it is the child of a composite, and children are not resizable).

Move(self, dc, x, y, display=True)

Move the shape to the given position. Redraw if display is TRUE.

MoveLineToNewAttachment(self, dc, to_move, x, y)

Move the given line (which must already be attached to the shape) to a different attachment point on the shape, or a different order on the same attachment.

Calls Shape.AttachmentSortTest and then ShapeEvtHandler.OnChangeAttachment.

MoveLinks(self, dc)

Redraw all the lines attached to the shape.

NameRegions(self, parentName='')

Make unique names for all the regions in a shape or composite shape.

PhysicalToLogicalAttachment(self, physicalAttachment)

Rotate the standard attachment point from physical (0 is always North) to logical (0 -> 1 if rotated by 90 degrees)

Recentre(self, dc)

Do recentring (or other formatting) for all the text regions for this shape.

Recompute(self)

Recomputes any constraints associated with the shape.

Normally applicable to CompositeShapes only, but harmless for other classes of Shape.

RemoveFromCanvas(self, theCanvas)

Remove the shape from the canvas.

RemoveLine(self, line)

Remove the given line from the shape's list of attached lines.

ResetControlPoints(self)

Reset the positions of the control points (for instance when the shape's shape has changed).

ResetMandatoryControlPoints(self)

Reset the mandatory control points.

Rotate(self, x, y, theta)

Rotate about the given axis by the given amount in radians.

Select(self, select, dc=None)

Select or deselect the given shape, drawing or erasing control points (handles) as necessary.

Selected(self)

TRUE if the shape is currently selected.

SetAttachmentMode(self, mode)

Set the attachment mode.

If TRUE, attachment points will be significant when drawing lines to and from this shape. If FALSE, lines will be drawn as if to the centre of the shape.

SetBrush(self, the_brush)

Set the brush for filling the shape's shape.

SetCanvas(self, theCanvas)

Identical to Shape.Attach.

SetCentreResize(self, cr)

Specify whether the shape is to be resized from the centre (the centre stands still) or from the corner or side being dragged (the other corner or side stands still).

SetDefaultRegionSize(self)

Set the default region to be consistent with the shape size.

SetDisableLabel(self, flag)

Set flag to TRUE to stop the default region being shown.

SetDraggable(self, drag, recursive=False)

Set the shape to be draggable or not draggable.

SetDrawHandles(self, drawH)

Set the drawHandles flag for this shape and all descendants. If drawH is TRUE (the default), any handles (control points) will be drawn. Otherwise, the handles will not be drawn.

SetEventHandler(self, handler)

Set the event handler for this shape.

SetFixedSize(self, x, y)

Set the shape to be fixed size.

SetFont(self, the_font, regionId=0)

Set the font for the specified text region.

SetFormatMode(self, mode, regionId=0)

Set the format mode of the default text region. The argument can be a bit list of the following:

FORMAT_NONE
No formatting.
FORMAT_CENTRE_HORIZ
Horizontal centring.
FORMAT_CENTRE_VERT
Vertical centring.

SetHighlight(self, hi, recurse=False)

Set the highlight for a shape. Shape highlighting is unimplemented.

SetId(self, i)

Set the integer identifier for this shape.

SetMaintainAspectRatio(self, ar)

Set whether a shape that resizes should not change the aspect ratio (width and height should be in the original proportion).

SetPen(self, the_pen)

Set the pen for drawing the shape's outline.

SetRegionName(self, name, regionId=0)

Set the name for this region. The name for a region is unique within the scope of the whole composite, whereas a region id is unique only for a single image.

SetSensitivityFilter(self, sens=15, recursive=False)

Set the shape to be sensitive or insensitive to specific mouse operations.

sens is a bitlist of the following:

  • OP_CLICK_LEFT
  • OP_CLICK_RIGHT
  • OP_DRAG_LEFT
  • OP_DRAG_RIGHT
  • OP_ALL (equivalent to a combination of all the above).

SetShadowMode(self, mode, redraw=False)

Set the shadow mode (whether a shadow is drawn or not). mode can be one of the following:

SHADOW_NONE
No shadow (the default).
SHADOW_LEFT
Shadow on the left side.
SHADOW_RIGHT
Shadow on the right side.

SetSize(self, x, y, recursive=True)

Set the shape's size.

SetSpaceAttachments(self, sp)

Indicate whether lines should be spaced out evenly at the point they touch the node (sp = True), or whether they should join at a single point (sp = False).

SetTextColour(self, the_colour, regionId=0)

Set the colour for the specified text region.

SetX(self, x)

Set the x position of the shape.

SetY(self, y)

Set the y position of the shape.

Show(self, show)

Set a flag indicating whether the shape should be drawn.

SortLines(self, attachment, linesToSort)

Reorder the lines coming into the node image at this attachment position, in the order in which they appear in linesToSort.

Any remaining lines not in the list will be added to the end.

Class Variable Details

GraphicsInSizeToContents

Type:
bool
Value:
False

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:50 2005 http://epydoc.sf.net


wx.lib.ogl.ShapeEvtHandler

Package wx :: Package lib :: Package ogl :: Class ShapeEvtHandler
[frames | no frames]

Type ShapeEvtHandler

object --+
         |
        ShapeEvtHandler

Known Subclasses:
Shape
Method Summary
 | __init__(self, prev, shape)
 | __del__(self)
 | GetPreviousHandler(self)
 | GetShape(self)
 | OnBeginDragLeft(self, x, y, keys, attachment)
 | OnBeginDragRight(self, x, y, keys, attachment)
 | OnBeginSize(self, w, h)
 | OnChangeAttachment(self, attachment, line, ordering)
 | OnDelete(self)
 | OnDragLeft(self, draw, x, y, keys, attachment)
 | OnDragRight(self, draw, x, y, keys, attachment)
 | OnDraw(self, dc)
 | OnDrawBranches(self, dc, erase)
 | OnDrawContents(self, dc)
 | OnDrawControlPoints(self, dc)
 | OnDrawOutline(self, dc, x, y, w, h)
 | OnEndDragLeft(self, x, y, keys, attachment)
 | OnEndDragRight(self, x, y, keys, attachment)
 | OnEndSize(self, w, h)
 | OnErase(self, dc)
 | OnEraseContents(self, dc)
 | OnEraseControlPoints(self, dc)
 | OnHighlight(self, dc)
 | OnLeftClick(self, x, y, keys, attachment)
 | OnLeftDoubleClick(self, x, y, keys, attachment)
 | OnMoveLink(self, dc, moveControlPoints)
 | OnMoveLinks(self, dc)
 | OnMovePost(self, dc, x, y, old_x, old_y, display)
 | OnMovePre(self, dc, x, y, old_x, old_y, display)
 | OnRightClick(self, x, y, keys, attachment)
 | OnSize(self, x, y)
 | OnSizingBeginDragLeft(self, pt, x, y, keys, attachment)
 | OnSizingDragLeft(self, pt, draw, x, y, keys, attachment)
 | OnSizingEndDragLeft(self, pt, x, y, keys, attachment)
 | SetPreviousHandler(self, handler)
 | SetShape(self, sh)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:10:53 2005 http://epydoc.sf.net


wx.lib.ogl.ShapeRegion

Package wx :: Package lib :: Package ogl :: Class ShapeRegion
[frames | no frames]

Type ShapeRegion

object --+
         |
        ShapeRegion

Object region.

Method Summary
 | __init__(self, region)
 | ClearText(self)
 | GetActualColourObject(self)
 | GetActualPen(self)
 | GetColour(self)
 | GetFont(self)
 | GetFormatMode(self)
 | GetFormattedText(self)
 | GetHeight(self)
 | GetMinSize(self)
 | GetName(self)
 | GetPenColour(self)
 | GetPenStyle(self)
 | GetPosition(self)
 | GetProportion(self)
 | GetSize(self)
 | GetText(self)
 | GetWidth(self)
 | SetColour(self, col)
 | SetFont(self, f)
 | SetFormatMode(self, mode)
 | SetMinSize(self, w, h)
 | SetName(self, s)
 | SetPenColour(self, col)
 | SetPenStyle(self, style)
 | SetPosition(self, xp, yp)
 | SetProportions(self, xp, yp)
 | SetSize(self, w, h)
 | SetText(self, s)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:18 2005 http://epydoc.sf.net


wx.lib.ogl.ShapeTextLine

Package wx :: Package lib :: Package ogl :: Class ShapeTextLine
[frames | no frames]

Type ShapeTextLine

object --+
         |
        ShapeTextLine

Method Summary
 | __init__(self, the_x, the_y, the_line)
 | GetText(self)
 | GetX(self)
 | GetY(self)
 | SetText(self, text)
 | SetX(self, x)
 | SetY(self, y)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:03 2005 http://epydoc.sf.net


wx.lib.ogl.TextShape

Package wx :: Package lib :: Package ogl :: Class TextShape

Type TextShape

     object --+
              |
ShapeEvtHandler --+
                  |
              Shape --+
                      |
         RectangleShape --+
                          |
                         TextShape

As wxRectangleShape, but only the text is displayed.

Method Summary
 | __init__(self, width, height)
 | OnDraw(self, dc)

Class Variable Summary

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:39 2005 http://epydoc.sf.net


wx.lib.ogl

Package wx :: Package lib :: Package ogl

Package wx.lib.ogl

The Object Graphics Library provides for simple drawing and manipulation of 2D objects.

Classes
ArrowHead |
BitmapShape | Draws a bitmap (non-resizable).
CircleShape | An EllipseShape whose width and height are the same.
CompositeShape | This is an object with a list of child objects, and a list of size and positioning constraints between the children.
Constraint | A Constraint object helps specify how child shapes are laid out with respect to siblings and parents.
ConstraintType |
ControlPoint |
Diagram | Encapsulates an entire diagram, with methods for drawing.
DividedShape | A DividedShape is a rectangle with a number of vertical divisions.
DividedShapeControlPoint |
DivisionControlPoint |
DivisionShape | A division shape is like a composite in that it can contain further objects, but is used exclusively to divide another shape into regions, or divisions.
DrawnShape | Draws a pseudo-metafile shape, which can be loaded from a simple Windows metafile.
DrawOp |
EllipseShape | The EllipseShape behaves similarly to the RectangleShape but is elliptical.
LabelShape |
LineControlPoint |
LineShape | LineShape may be attached to two nodes; it may be segmented, in which case a control point is drawn for each joint.
OpDraw | Draw line, rectangle, rounded rectangle, ellipse, point, arc, text.
OpPolyDraw | Draw polygon, polyline, spline.
OpSetClipping | Set/destroy clipping.
OpSetGDI | Set font, brush, text colour.
PolygonControlPoint |
PolygonShape | A PolygonShape's shape is defined by a number of points passed to the object's constructor.
PopupDivisionMenu |
PseudoMetaFile | A simple metafile-like class which can load data from a Windows metafile on all platforms.
RectangleShape | The wxRectangleShape has rounded or square corners.
Shape | OGL base class
ShapeCanvas |
ShapeEvtHandler |
ShapeRegion | Object region.
ShapeTextLine |
TextShape | As wxRectangleShape, but only the text is displayed.

Function Summary
 | CentreText(dc, text_list, xpos, ypos, width, height, formatMode)
 | CheckLineIntersection(x1, y1, x2, y2, x3, y3, x4, y4)
 | DrawArcToEllipse(x1, y1, width1, height1, x2, y2, x3, y3)
 | DrawFormattedText(dc, text_list, xpos, ypos, width, height, formatMode)
 | FindEndForBox(width, height, x1, y1, x2, y2)
 | FindEndForCircle(radius, x1, y1, x2, y2)
 | FindEndForPolyline(xvec, yvec, x1, y1, x2, y2)
 | FormatText(dc, text, width, height, formatMode)
 | GetArrowPoints(x1, y1, x2, y2, length, width)
 | GetCentredTextExtent(dc, text_list, xpos, ypos, width, height)
 | GetPointOnLine(x1, y1, x2, y2, length)
 | GraphicsStraightenLine(point1, point2)
 | OGLCleanUp()
 | OGLConstraint(*args, **kwargs) The OGLConstraint name is deprecated, use ogl.Constraint instead.
 | OGLInitialize()
 | PolylineHitTest(xvec, yvec, x1, y1, x2, y2)
 | RoughlyEqual(val1, val2, tol)
 | WhollyContains(contains, contained)

Function Details

OGLConstraint(*args, **kwargs)

The OGLConstraint name is deprecated, use ogl.Constraint instead.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:23 2005 http://epydoc.sf.net


wx.lib.plot.PlotCanvas

Package wx :: Package lib :: Module plot :: Class PlotCanvas

Type PlotCanvas

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
                    PlotCanvas

Subclass of a wx.Window to allow simple general plotting of data with zoom, labels, and automatic axis scaling.

Method Summary
 | __init__(self, parent, id, pos, size, style, name) Constucts a window, which can be a child of a frame, dialog or any other non-control window
 | Clear(self) Erase the window.
 | Draw(self, graphics, xAxis, yAxis, dc) Draw objects in graphics with specified x and y axis.
 | GetClosestPoints(self, pntXY, pointScaled) Returns list with [curveNumber, legend, index of closest point, pointXY, scaledXY, distance] list for each curve.
 | GetClosetPoint(self, pntXY, pointScaled) Returns list with [curveNumber, legend, index of closest point, pointXY, scaledXY, distance] list for only the closest curve.
 | GetEnableGrid(self) True if grid enabled.
 | GetEnableLegend(self) True if Legend enabled.
 | GetEnablePointLabel(self) True if pointLabel enabled.
 | GetEnableZoom(self) True if zooming enabled.
 | GetFontSizeAxis(self) Get current tick and axis label font size in points
 | GetFontSizeLegend(self) Get current Legend font size in points
 | GetFontSizeTitle(self) Get current Title font size in points
 | GetPointLabelFunc(self) Returns pointLabel Drawing Function
 | GetXCurrentRange(self) Returns (minX, maxX) x-axis for currently displayed portion of graph
 | GetXMaxRange(self) Returns (minX, maxX) x-axis range for displayed graph
 | GetXSpec(self) Returns current XSpec for axis
 | GetXY(self, event) Takes a mouse event and returns the XY user axis values.
 | GetYCurrentRange(self) Returns (minY, maxY) y-axis for currently displayed portion of graph
 | GetYMaxRange(self) Returns (minY, maxY) y-axis range for displayed graph
 | GetYSpec(self) Returns current YSpec for axis
 | OnLeave(self, event) Used to erase pointLabel when mouse outside window
 | OnMotion(self, event)
 | OnMouseDoubleClick(self, event)
 | OnMouseLeftDown(self, event)
 | OnMouseLeftUp(self, event)
 | OnMouseRightDown(self, event)
 | OnPaint(self, event)
 | OnSize(self, event)
 | PageSetup(self) Brings up the page setup dialog
 | PositionScreenToUser(self, pntXY) Converts Screen position to User Coordinates
 | PositionUserToScreen(self, pntXY) Converts User position to Screen Coordinates
 | Printout(self, paper) Print current plot.
 | PrintPreview(self) Print-preview current plot.
 | Redraw(self, dc) Redraw the existing plot.
 | Reset(self) Unzoom the plot.
 | SaveFile(self, fileName) Saves the file to the type specified in the extension.
 | ScrollRight(self, units) Move view right number of axis units.
 | ScrollUp(self, units) Move view up number of axis units.
 | SetEnableGrid(self, value) Set True to enable grid.
 | SetEnableLegend(self, value) Set True to enable legend.
 | SetEnablePointLabel(self, value) Set True to enable pointLabel.
 | SetEnableZoom(self, value) Set True to enable zooming.
 | SetFontSizeAxis(self, point) Set the tick and axis label font size (default is 10 point)
 | SetFontSizeLegend(self, point) Set Legend font size (default is 7 point)
 | SetFontSizeTitle(self, point) Set Title font size (default is 15 point)
 | SetPointLabelFunc(self, func) Sets the function with custom code for pointLabel drawing **** more info needed ***********
 | SetXSpec(self, type) xSpec- defines x axis type.
 | SetYSpec(self, type) ySpec- defines x axis type.
 | UpdatePointLabel(self, mDataDict) Updates the pointLabel point on screen with data contained in mDataDict.
 | Zoom(self, Center, Ratio) Zoom on the plot Centers on the X,Y coords given in Center Zooms by the Ratio = (Xratio, Yratio) given

Instance Method Details

__init__(self,
          parent,
          id=-1,
          pos=wx.Point(-1, -1),
          size=wx.Size(-1, -1),
          style=541072960,
          name='')
(Constructor)

Constucts a window, which can be a child of a frame, dialog or any other non-control window

Overrides:
wx.Window.__init__

Clear(self)

Erase the window.

Draw(self,
          graphics,
          xAxis=None,
          yAxis=None,
          dc=None)

Draw objects in graphics with specified x and y axis. graphics- instance of PlotGraphics with list of PolyXXX objects xAxis - tuple with (min, max) axis range to view yAxis - same as xAxis dc - drawing context - doesn't have to be specified. If it's not, the offscreen buffer is used

GetClosestPoints(self, pntXY, pointScaled=True)

Returns list with [curveNumber, legend, index of closest point, pointXY, scaledXY, distance] list for each curve. Returns [] if no curves are being plotted.

x, y in user coords if pointScaled == True based on screen coords if pointScaled == False based on user coords

GetClosetPoint(self, pntXY, pointScaled=True)

Returns list with [curveNumber, legend, index of closest point, pointXY, scaledXY, distance] list for only the closest curve. Returns [] if no curves are being plotted.

x, y in user coords if pointScaled == True based on screen coords if pointScaled == False based on user coords

GetEnableGrid(self)

True if grid enabled.

GetEnableLegend(self)

True if Legend enabled.

GetEnablePointLabel(self)

True if pointLabel enabled.

GetEnableZoom(self)

True if zooming enabled.

GetFontSizeAxis(self)

Get current tick and axis label font size in points

GetFontSizeLegend(self)

Get current Legend font size in points

GetFontSizeTitle(self)

Get current Title font size in points

GetPointLabelFunc(self)

Returns pointLabel Drawing Function

GetXCurrentRange(self)

Returns (minX, maxX) x-axis for currently displayed portion of graph

GetXMaxRange(self)

Returns (minX, maxX) x-axis range for displayed graph

GetXSpec(self)

Returns current XSpec for axis

GetXY(self, event)

Takes a mouse event and returns the XY user axis values.

GetYCurrentRange(self)

Returns (minY, maxY) y-axis for currently displayed portion of graph

GetYMaxRange(self)

Returns (minY, maxY) y-axis range for displayed graph

GetYSpec(self)

Returns current YSpec for axis

OnLeave(self, event)

Used to erase pointLabel when mouse outside window

PageSetup(self)

Brings up the page setup dialog

PositionScreenToUser(self, pntXY)

Converts Screen position to User Coordinates

PositionUserToScreen(self, pntXY)

Converts User position to Screen Coordinates

Printout(self, paper=None)

Print current plot.

PrintPreview(self)

Print-preview current plot.

Redraw(self, dc=None)

Redraw the existing plot.

Reset(self)

Unzoom the plot.

SaveFile(self, fileName='')

Saves the file to the type specified in the extension. If no file name is specified a dialog box is provided. Returns True if sucessful, otherwise False.

.bmp Save a Windows bitmap file. .xbm Save an X bitmap file. .xpm Save an XPM bitmap file. .png Save a Portable Network Graphics file. .jpg Save a Joint Photographic Experts Group file.

ScrollRight(self, units)

Move view right number of axis units.

ScrollUp(self, units)

Move view up number of axis units.

SetEnableGrid(self, value)

Set True to enable grid.

SetEnableLegend(self, value)

Set True to enable legend.

SetEnablePointLabel(self, value)

Set True to enable pointLabel.

SetEnableZoom(self, value)

Set True to enable zooming.

SetFontSizeAxis(self, point=10)

Set the tick and axis label font size (default is 10 point)

SetFontSizeLegend(self, point=7)

Set Legend font size (default is 7 point)

SetFontSizeTitle(self, point=15)

Set Title font size (default is 15 point)

SetPointLabelFunc(self, func)

Sets the function with custom code for pointLabel drawing **** more info needed ***********

SetXSpec(self, type='auto')

xSpec- defines x axis type. Can be 'none', 'min' or 'auto'
where:
    'none' - shows no axis or tick mark values
    'min' - shows min bounding box values
    'auto' - rounds axis range to sensible values

SetYSpec(self, type='auto')

ySpec- defines x axis type. Can be 'none', 'min' or 'auto'
where:
    'none' - shows no axis or tick mark values
    'min' - shows min bounding box values
    'auto' - rounds axis range to sensible values

UpdatePointLabel(self, mDataDict)

Updates the pointLabel point on screen with data contained in mDataDict.

mDataDict will be passed to your function set by SetPointLabelFunc. It can contain anything you want to display on the screen at the scaledXY point you specify.

This function can be called from parent window with onClick, onMotion events etc.

Zoom(self, Center, Ratio)

Zoom on the plot Centers on the X,Y coords given in Center Zooms by the Ratio = (Xratio, Yratio) given

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:58 2005 http://epydoc.sf.net


wx.lib.plot.PlotGraphics

Package wx :: Package lib :: Module plot :: Class PlotGraphics
[frames | no frames]

Class PlotGraphics

Container to hold PolyXXX objects and graph labels - All methods except __init__ are private.

Method Summary
 | __init__(self, objects, title, xLabel, yLabel) Creates PlotGraphics object objects - list of PolyXXX objects to make graph title - title shown at top of graph xLabel - label shown on x-axis yLabel - label shown on y-axis
 | __getitem__(self, item)
 | __len__(self)
 | boundingBox(self)
 | draw(self, dc)
 | getLegendNames(self) Returns list of legend names
 | getSymExtent(self, printerScale) Get max width and height of lines and markers symbols for legend
 | getTitle(self, title) Get the title at the top of graph
 | getXLabel(self) Get x axis label string
 | getYLabel(self) Get y axis label string
 | scaleAndShift(self, scale, shift)
 | setPrinterScale(self, scale) Thickens up lines and markers only for printing
 | setTitle(self, title) Set the title at the top of graph
 | setXLabel(self, xLabel) Set the X axis label on the graph
 | setYLabel(self, yLabel) Set the Y axis label on the graph

Method Details

__init__(self, objects, title='', xLabel='', yLabel='')
(Constructor)

Creates PlotGraphics object objects - list of PolyXXX objects to make graph title - title shown at top of graph xLabel - label shown on x-axis yLabel - label shown on y-axis

getLegendNames(self)

Returns list of legend names

getSymExtent(self, printerScale)

Get max width and height of lines and markers symbols for legend

getTitle(self, title='')

Get the title at the top of graph

getXLabel(self)

Get x axis label string

getYLabel(self)

Get y axis label string

setPrinterScale(self, scale)

Thickens up lines and markers only for printing

setTitle(self, title='')

Set the title at the top of graph

setXLabel(self, xLabel='')

Set the X axis label on the graph

setYLabel(self, yLabel='')

Set the Y axis label on the graph

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:12 2005 http://epydoc.sf.net


wx.lib.plot.PlotPrintout

Package wx :: Package lib :: Module plot :: Class PlotPrintout
[frames | no frames]

Type PlotPrintout

object --+
         |
    Object --+
             |
      Printout --+
                 |
                PlotPrintout

Controls how the plot is made in printing and previewing

Method Summary
 | __init__(self, graph) graph is instance of plotCanvas to be printed or previewed
 | GetPageInfo(self)
 | HasPage(self, page)
 | OnPrintPage(self, page)

Method Details

__init__(self, graph)
(Constructor)

graph is instance of plotCanvas to be printed or previewed

Overrides:
wx.Printout.__init__

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:33 2005 http://epydoc.sf.net


wx.lib.plot.PolyLine

Package wx :: Package lib :: Module plot :: Class PolyLine

Class PolyLine

PolyPoints --+
             |
            PolyLine

Class to define line type and style - All methods except __init__ are private.

Method Summary
 | __init__(self, points, **attr) Creates PolyLine object...
 | draw(self, dc, printerScale, coord)
 | getSymExtent(self, printerScale) Width and Height of Marker

Method Details

__init__(self, points, **attr)
(Constructor)

Creates PolyLine object
points - sequence (array, tuple or list) of (x,y) points making up line
**attr - key word attributes
    Defaults:
        'colour'= 'black',          - wx.Pen Colour any wx.NamedColour
        'width'= 1,                 - Pen width
        'style'= wx.SOLID,          - wx.Pen style
        'legend'= ''                - Line Legend to display
Overrides:
wx.lib.plot.PolyPoints.__init__

getSymExtent(self, printerScale)

Width and Height of Marker

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:21 2005 http://epydoc.sf.net


wx.lib.plot.PolyMarker

Package wx :: Package lib :: Module plot :: Class PolyMarker

Class PolyMarker

PolyPoints --+
             |
            PolyMarker

Class to define marker type and style - All methods except __init__ are private.

Method Summary
 | __init__(self, points, **attr) Creates PolyMarker object...
 | draw(self, dc, printerScale, coord)
 | getSymExtent(self, printerScale) Width and Height of Marker

Method Details

__init__(self, points, **attr)
(Constructor)

Creates PolyMarker object
points - sequence (array, tuple or list) of (x,y) points
**attr - key word attributes
    Defaults:
        'colour'= 'black',          - wx.Pen Colour any wx.NamedColour
        'width'= 1,                 - Pen width
        'size'= 2,                  - Marker size
        'fillcolour'= same as colour,      - wx.Brush Colour any wx.NamedColour
        'fillstyle'= wx.SOLID,      - wx.Brush fill style (use wx.TRANSPARENT for no fill)
        'marker'= 'circle'          - Marker shape
        'legend'= ''                - Marker Legend to display

    Marker Shapes:
        - 'circle'
        - 'dot'
        - 'square'
        - 'triangle'
        - 'triangle_down'
        - 'cross'
        - 'plus'
Overrides:
wx.lib.plot.PolyPoints.__init__

getSymExtent(self, printerScale)

Width and Height of Marker

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:21 2005 http://epydoc.sf.net


wx.lib.plot.PolyPoints

Package wx :: Package lib :: Module plot :: Class PolyPoints

Class PolyPoints

Known Subclasses:
PolyLine, PolyMarker

Base Class for lines and markers - All methods are private.

Method Summary
 | __init__(self, points, attr)
 | boundingBox(self)
 | getClosestPoint(self, pntXY, pointScaled) Returns the index of closest point on the curve, pointXY, scaledXY, distance x, y in user coords if pointScaled == True based on screen coords if pointScaled == False based on user coords
 | getLegend(self)
 | scaleAndShift(self, scale, shift)

Method Details

getClosestPoint(self, pntXY, pointScaled=True)

Returns the index of closest point on the curve, pointXY, scaledXY, distance x, y in user coords if pointScaled == True based on screen coords if pointScaled == False based on user coords

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:21 2005 http://epydoc.sf.net


wx.lib.plot.TestFrame

Package wx :: Package lib :: Module plot :: Class TestFrame

Type TestFrame

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
        TopLevelWindow --+
                         |
                     Frame --+
                             |
                            TestFrame

Method Summary
 | __init__(self, parent, id, title)
 | DrawPointLabel(self, dc, mDataDict) This is the fuction that defines how the pointLabels are plotted dc - DC that will be passed mDataDict - Dictionary of data that you want to use for the pointLabel
 | OnEnableGrid(self, event)
 | OnEnableLegend(self, event)
 | OnEnablePointLabel(self, event)
 | OnEnableZoom(self, event)
 | OnFileExit(self, event)
 | OnFilePageSetup(self, event)
 | OnFilePrint(self, event)
 | OnFilePrintPreview(self, event)
 | OnHelpAbout(self, event)
 | OnMotion(self, event)
 | OnMouseLeftDown(self, event)
 | OnPlotClear(self, event)
 | OnPlotDraw1(self, event)
 | OnPlotDraw2(self, event)
 | OnPlotDraw3(self, event)
 | OnPlotDraw4(self, event)
 | OnPlotDraw5(self, event)
 | OnPlotDraw6(self, event)
 | OnPlotRedraw(self, event)
 | OnPlotScale(self, event)
 | OnReset(self, event)
 | OnSaveFile(self, event)
 | OnScrRt(self, event)
 | OnScrUp(self, event)
 | resetDefaults(self) Just to reset the fonts back to the PlotCanvas defaults

Instance Method Details

DrawPointLabel(self, dc, mDataDict)

This is the fuction that defines how the pointLabels are plotted dc - DC that will be passed mDataDict - Dictionary of data that you want to use for the pointLabel

As an example I have decided I want a box at the curve point with some text information about the curve plotted below. Any wxDC method can be used.

resetDefaults(self)

Just to reset the fonts back to the PlotCanvas defaults

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:05 2005 http://epydoc.sf.net


wx.lib.plot

Package wx :: Package lib :: Module plot

Module wx.lib.plot

This is a simple light weight plotting module that can be used with Boa or easily integrated into your own wxPython application. The emphasis is on small size and fast plotting for large data sets. It has a reasonable number of features to do line and scatter graphs easily as well as simple bar graphs. It is not as sophisticated or as powerful as SciPy Plt or Chaco. Both of these are great packages but consume huge amounts of computer resources for simple plots. They can be found at http://scipy.com

This file contains two parts; first the re-usable library stuff, then, after a "if __name__=='__main__'" test, a simple frame and a few default plots for examples and testing.

Based on wxPlotCanvas Written by K.Hinsen, R. Srinivasan; Ported to wxPython Harm van der Heijden, feb 1999

Major Additions Gordon Williams Feb. 2003 (g_will@cyberus.ca)
-More style options -Zooming using mouse "rubber band" -Scroll left, right -Grid(graticule) -Printing, preview, and page set up (margins) -Axis and title labels -Cursor xy axis values -Doc strings and lots of comments -Optimizations for large number of points -Legends

Did a lot of work here to speed markers up. Only a factor of 4 improvement though. Lines are much faster than markers, especially filled markers. Stay away from circles and triangles unless you only have a few thousand points.

Times for 25,000 points Line - 0.078 sec Markers Square - 0.22 sec dot - 0.10 circle - 0.87 cross,plus - 0.28 triangle, triangle_down - 0.90

Thanks to Chris Barker for getting this version working on Linux.

Zooming controls with mouse (when enabled):
Left mouse drag - Zoom box. Left mouse double click - reset zoom. Right mouse click - zoom out centred on click location.
Classes
PlotCanvas | Subclass of a wx.Window to allow simple general plotting of data with zoom, labels, and automatic axis scaling.
PlotGraphics | Container to hold PolyXXX objects and graph labels - All methods except __init__ are private.
PlotPrintout | Controls how the plot is made in printing and previewing
PolyLine | Class to define line type and style - All methods except __init__ are private.
PolyMarker | Class to define marker type and style - All methods except __init__ are private.
PolyPoints | Base Class for lines and markers - All methods are private.
TestFrame |

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:52 2005 http://epydoc.sf.net


wx.lib.popupctl.PopButton

Package wx :: Package lib :: Module popupctl :: Class PopButton
[frames | no frames]

Type PopButton

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
               Control --+
                         |
                 PyControl --+
                             |
                            PopButton

Method Summary
 | __init__(self, *_args, **_kwargs)
 | DrawArrow(self, dc)
 | DrawBezel(self, dc, x1, y1, x2, y2)
 | InitColours(self)
 | Notify(self)
 | OnEraseBackground(self, event)
 | OnLeftDown(self, event)
 | OnLeftUp(self, event)
 | OnMotion(self, event)
 | OnPaint(self, event)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:11 2005 http://epydoc.sf.net


wx.lib.popupctl.PopupControl

Package wx :: Package lib :: Module popupctl :: Class PopupControl
[frames | no frames]

Type PopupControl

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
               Control --+
                         |
                 PyControl --+
                             |
                            PopupControl

Method Summary
 | __init__(self, *_args, **_kwargs)
 | Enable(self, flag)
 | FormatContent(self)
 | GetValue(self)
 | OnButton(self, evt)
 | OnFocus(self, evt)
 | OnSize(self, evt)
 | PopDown(self)
 | SetPopupContent(self, content)
 | SetValue(self, value)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:10:48 2005 http://epydoc.sf.net


wx.lib.popupctl.PopupDialog

Package wx :: Package lib :: Module popupctl :: Class PopupDialog
[frames | no frames]

Type PopupDialog

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
        TopLevelWindow --+
                         |
                    Dialog --+
                             |
                            PopupDialog

Method Summary
 | __init__(self, parent, content)
 | Display(self)
 | SetContent(self, content)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:46 2005 http://epydoc.sf.net


wx.lib.popupctl

Package wx :: Package lib :: Module popupctl

Module wx.lib.popupctl

Classes
PopButton
PopupControl
PopupCtrl
PopupDialog

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:12 2005 http://epydoc.sf.net


wx.lib.printout.PrintBase

Package wx :: Package lib :: Module printout :: Class PrintBase
[frames | no frames]

Class PrintBase

Known Subclasses:
PrintTableDraw
Method Summary
 | GetCellDiff(self, text, width)
 | GetDate(self)
 | GetDateTime(self)
 | GetFontColour(self, font)
 | getHeight(self)
 | GetNow(self)
 | getWidth(self)
 | OutTextPageWidth(self, textout, y_out, align, indent, txtdraw)
 | OutTextRegion(self, textout, txtdraw)
 | SetChar(self, ln_text, width)
 | SetFlow(self, ln_text, width)
 | SetPreview(self, preview)
 | SetPrintFont(self, font)
 | SetPSize(self, width, height)
 | SetPTSize(self, width, height)
 | SetScale(self, scale)
 | TestFull(self, text_test)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:10:54 2005 http://epydoc.sf.net


wx.lib.printout.PrintGrid

Package wx :: Package lib :: Module printout :: Class PrintGrid
[frames | no frames]

Class PrintGrid

Method Summary
 | __init__(self, parent, grid, format, total_col, total_row)
 | GetTable(self)
 | Preview(self)
 | Print(self)
 | SetAttributes(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:10:54 2005 http://epydoc.sf.net


wx.lib.printout.PrintTable

Package wx :: Package lib :: Module printout :: Class PrintTable
[frames | no frames]

Class PrintTable

Method Summary
 | __init__(self, parentFrame)
 | DoDrawing(self, DC)
 | GetColour(self, colour)
 | GetTotalPages(self)
 | HasPage(self, page)
 | Preview(self)
 | Print(self)
 | SetCellColour(self, row, col, colour)
 | SetCellText(self, row, col, colour)
 | SetColAlignment(self, col, align)
 | SetColBackgroundColour(self, col, colour)
 | SetColors(self)
 | SetColTextColour(self, col, colour)
 | SetColumnLineColour(self, col, colour)
 | SetColumnLineSize(self, col, size)
 | SetFonts(self)
 | SetFooter(self, text, type, font, align, indent, colour, size)
 | SetFooterValue(self)
 | SetHeader(self, text, type, font, align, indent, colour, size)
 | SetHeaderValue(self)
 | SetLabelSpacing(self, before, after)
 | SetLandscape(self)
 | SetMargins(self)
 | SetOrientation(self, orient)
 | SetPage(self, page)
 | SetPageSize(self, width, height)
 | SetPaperId(self, paper)
 | SetParms(self)
 | SetPortrait(self)
 | SetPreview(self, preview, scale)
 | SetPreviewSize(self, position, size)
 | SetPrinterOffset(self)
 | SetRowLineColour(self, row, colour)
 | SetRowLineSize(self, row, size)
 | SetRowSpacing(self, before, after)
 | SetTotalSize(self, width, height)
 | TextSpacing(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:48 2005 http://epydoc.sf.net


wx.lib.printout.PrintTableDraw

Package wx :: Package lib :: Module printout :: Class PrintTableDraw
[frames | no frames]

Type PrintTableDraw

                 PrintBase --+
                             |
object --+                   |
         |                   |
    Object --+               |
             |               |
    EvtHandler --+           |
                 |           |
            Window --+       |
                     |       |
                 Panel --+   |
                         |   |
            ScrolledWindow --+
                             |
                            PrintTableDraw

Method Summary
 | __init__(self, parent, DC, size)
 | AdjustValues(self)
 | ColourRowCells(self, height)
 | DoDrawing(self, DC)
 | DrawColumns(self)
 | DrawGridLine(self)
 | DrawText(self)
 | FinishDraw(self)
 | GetCellColour(self, row, col)
 | GetCellText(self, row, col)
 | GetTotalPages(self)
 | LabelColorRow(self, colour)
 | OutCanvas(self)
 | OutPage(self)
 | PrintFooter(self)
 | PrintHeader(self)
 | PrintLabel(self)
 | PrintRow(self, row_val, draw, align)
 | SetColumns(self, col)
 | SetDefaults(self)
 | SetPage(self, page)
 | SetPointAdjust(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:05 2005 http://epydoc.sf.net


wx.lib.printout.SetPrintout

Package wx :: Package lib :: Module printout :: Class SetPrintout
[frames | no frames]

Type SetPrintout

object --+
         |
    Object --+
             |
      Printout --+
                 |
                SetPrintout

Method Summary
 | __init__(self, canvas)
 | GetPageInfo(self)
 | GetSize(self)
 | GetTotalSize(self)
 | HasPage(self, page)
 | OnBeginDocument(self, start, end)
 | OnBeginPrinting(self)
 | OnEndDocument(self)
 | OnPreparePrinting(self)
 | OnPrintPage(self, page)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:10 2005 http://epydoc.sf.net


wx.lib.printout

Package wx :: Package lib :: Module printout

Module wx.lib.printout

Classes
PrintBase
PrintGrid
PrintTable
PrintTableDraw
SetPrintout

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:16 2005 http://epydoc.sf.net


wx.lib.pubsub.Message

Package wx :: Package lib :: Module pubsub :: Class Message

Class Message

A simple container object for the two components of a message; the topic and the user data.

Method Summary
 | __init__(self, topic, data)
 | __str__(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:10:47 2005 http://epydoc.sf.net


wx.lib.pubsub

Package wx :: Package lib :: Module pubsub

Module wx.lib.pubsub

This module provides a publish-subscribe component that allows listeners to subcribe to messages of a given topic. Contrary to the original wxPython.lib.pubsub module, which it is based on, it uses weak referencing to the subscribers so the subscribers are not kept alive by the Publisher. Also, callable objects can be used in addition to functions and bound methods. See Publisher class docs for more details.

Thanks to Robb Shecter and Robin Dunn for having provided the basis for this module (which now shares most of the concepts but very little design or implementation with the original wxPython.lib.pubsub).

Implementation notes

In class Publisher, I represent the topics-listener set as a tree where each node is a topic, and contains a list of listeners of that topic, and a dictionary of subtopics of that topic. When the Publisher is told to send a message for a given topic, it traverses the tree down to the topic for which a message is being generated, all listeners on the way get sent the message.

Publisher currently uses a weak listener topic tree to store the topics for each listener, and if a listener dies before being unsubscribed, the tree is notified, and the tree eliminates the listener from itself.

Ideally, _TopicTreeNode would be a generic _TreeNode with named subnodes, and _TopicTreeRoot would be a generic _Tree with named nodes, and Publisher would store listeners in each node and a topic tuple would be converted to a path in the tree. This would lead to a much cleaner separation of concerns. But time is over, tim to move on.

Version:

$Id: pubsub.py,v 1.5 2004/05/17 19:20:48 RD Exp $

Author:

Oliver Schoenborn

Copyright:

(c) 2004 Oliver Schoenborn

License:

wxWidgets

Since:

Apr 2004

Classes
Message A simple container object for the two components of a message; the topic and the user data.

Function Summary
 | getStrAllTopics() Function to call if, for whatever reason, you need to know explicitely what is the string to use to indicate 'all topics'.
 | test()

Variable Summary
str | ALL_TOPICS = ''
Publisher | Publisher = <wx.lib.pubsub.Publisher instance at 0xb7a4f...

Function Details

getStrAllTopics()

Function to call if, for whatever reason, you need to know explicitely what is the string to use to indicate 'all topics'.

Variable Details

ALL_TOPICS

Type:
str
Value:
''

Publisher

Type:
Publisher
Value:
<wx.lib.pubsub.Publisher instance at 0xb7a4f3cc>

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:43 2005 http://epydoc.sf.net


wx.lib.pydocview.AboutDialog

Package wx :: Package lib :: Module pydocview :: Class AboutDialog
[frames | no frames]

Type AboutDialog

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
        TopLevelWindow --+
                         |
                    Dialog --+
                             |
                            AboutDialog

Opens an AboutDialog. Shared by DocMDIParentFrame and DocSDIFrame.

Method Summary
__init__(self, parent, image)
Initializes the about dialog.

Instance Method Details

__init__(self, parent, image=None)
(Constructor)

Initializes the about dialog.

Overrides:
wx.Dialog.__init__

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:56 2005 http://epydoc.sf.net


wx.lib.pydocview.AboutService

Package wx :: Package lib :: Module pydocview :: Class AboutService
[frames | no frames]

Type AboutService

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
        DocService --+
                     |
                    AboutService

About Dialog Service that installs under the Help menu to show the properties of the current application.

Method Summary
 | __init__(self, aboutDialog, image) Initializes the AboutService.
 | SetAboutDialog(self, dlg) Customize the AboutDialog
 | ShowAbout(self) Show the AboutDialog

Method Details

__init__(self, aboutDialog=None, image=None)
(Constructor)

Initializes the AboutService.

Overrides:
wx.lib.pydocview.DocService.__init__

SetAboutDialog(self, dlg)

Customize the AboutDialog

ShowAbout(self)

Show the AboutDialog

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:59 2005 http://epydoc.sf.net


wx.lib.pydocview.ChildDocTemplate

Package wx :: Package lib :: Module pydocview :: Class ChildDocTemplate
[frames | no frames]

Type ChildDocTemplate

object --+
         |
    Object --+
             |
   DocTemplate --+
                 |
                ChildDocTemplate

A ChildDocTemplate is a DocTemplate subclass that enables the creation of ChildDocuments that represents a portion of a Document. The child document is managed by the parent document, so it will be prompted to close if its parent is closed, etc. Child Documents are useful when there are complicated Views of a Document and users will need to tunnel into the View.

Method Summary
 | __init__(self, manager, description, filter, dir, ext, docTypeName, viewTypeName, docType, viewType, flags, icon) Initializes the ChildDocTemplate.
 | CreateDocument(self, path, flags, data, parentDocument) Called when a ChildDocument is to be created and does the minimum such that the ChildDocument looks like a real Document to the framework.

Method Details

__init__(self, manager, description, filter, dir, ext, docTypeName, viewTypeName, docType, viewType, flags=2, icon=None)
(Constructor)

Initializes the ChildDocTemplate.

Overrides:
wx.lib.docview.DocTemplate.__init__

CreateDocument(self, path, flags, data=None, parentDocument=None)

Called when a ChildDocument is to be created and does the minimum such that the ChildDocument looks like a real Document to the framework.

Overrides:
wx.lib.docview.DocTemplate.CreateDocument

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:59 2005 http://epydoc.sf.net


wx.lib.pydocview.ChildDocument

Package wx :: Package lib :: Module pydocview :: Class ChildDocument
[frames | no frames]

Type ChildDocument

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
          Document --+
                     |
                    ChildDocument

A ChildDocument is a document that represents a portion of a Document. The child document is managed by the parent document, so it will be prompted to close if its parent is closed, etc. Child Documents are useful when there are complicated Views of a Document and users will need to tunnel into the View.

Method Summary
 | GetData(self) Returns the data that the ChildDocument contains.
 | GetParentDocument(self) Returns the parent Document of the ChildDocument.
 | OnOpenDocument(self, filename) Called when the ChildDocument is opened and does the minimum such that the ChildDocument looks like a real Document to the framework.
 | OnSaveDocument(self, filename) Called when the ChildDocument is saved and does the minimum such that the ChildDocument looks like a real Document to the framework.
 | Save(self) Called when the ChildDocument is saved and does the minimum such that the ChildDocument looks like a real Document to the framework.
 | SaveAs(self) Called when the ChildDocument is saved and does the minimum such that the ChildDocument looks like a real Document to the framework.
 | SetData(self, data) Sets the data that the ChildDocument contains.
 | SetParentDocument(self, parentDocument) Sets the parent Document of the ChildDocument.

Method Details

GetData(self)

Returns the data that the ChildDocument contains.

GetParentDocument(self)

Returns the parent Document of the ChildDocument.

OnOpenDocument(self, filename)

Called when the ChildDocument is opened and does the minimum such that the ChildDocument looks like a real Document to the framework.

Overrides:
wx.lib.docview.Document.OnOpenDocument

OnSaveDocument(self, filename)

Called when the ChildDocument is saved and does the minimum such that the ChildDocument looks like a real Document to the framework.

Overrides:
wx.lib.docview.Document.OnSaveDocument

Save(self)

Called when the ChildDocument is saved and does the minimum such that the ChildDocument looks like a real Document to the framework.

Overrides:
wx.lib.docview.Document.Save

SaveAs(self)

Called when the ChildDocument is saved and does the minimum such that the ChildDocument looks like a real Document to the framework.

Overrides:
wx.lib.docview.Document.SaveAs

SetData(self, data)

Sets the data that the ChildDocument contains.

SetParentDocument(self, parentDocument)

Sets the parent Document of the ChildDocument.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:04 2005 http://epydoc.sf.net


wx.lib.pydocview.DocApp

Package wx :: Package lib :: Module pydocview :: Class DocApp
[frames | no frames]

Type DocApp

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
             PyApp --+
                     |
                   App --+
                         |
               PySimpleApp --+
                             |
                            DocApp

The DocApp class serves as the base class for pydocview applications and offers functionality such as services, creation of SDI and MDI frames, show tips, and a splash screen.

Method Summary
 | CloseChildDocuments(self, parentDocument) Closes the child windows of a Document.
 | CloseSplash(self) Closes the splash window.
 | CreateChildDocument(self, parentDocument, documentType, objectToEdit, path) Creates a child window of a document that edits an object.
 | CreateDocumentFrame(self, view, doc, flags, id, title, pos, size, style) Called by the DocManager to create and return a new Frame for a Document.
 | CreateMDIDocumentFrame(self, doc, view, id, title, pos, size, style) Creates and returns an MDI Document Frame.
 | CreateSDIDocumentFrame(self, doc, view, id, title, pos, size, style) Creates and returns an SDI Document Frame.
 | CreateTabbedDocumentFrame(self, doc, view, id, title, pos, size, style) Creates and returns an MDI Document Frame for a Tabbed MDI view
 | DoBackgroundListenAndLoad(self) Open any files specified in the given command line argument passed in via shared memory
 | GetDebug(self) Returns True if the application is in debug mode.
 | GetDefaultDocManagerFlags(self) Returns the default flags to use when creating the DocManager.
 | GetDefaultIcon(self) Returns the application's default icon.
 | GetDocumentManager(self) Returns the document manager associated to the DocApp.
 | GetEditMenu(self, frame) Utility method that finds the Edit menu within the menubar of a frame.
 | GetService(self, type) Returns the instance of a particular type of service that has been installed into the DocApp.
 | GetServices(self) Returns the DocService instances that have been installed into the DocApp.
 | GetSingleInstance(self) Returns True if the application is in single instance mode.
 | GetUseTabbedMDI(self) Returns True if Windows MDI should use folder tabs instead of child windows.
 | InstallService(self, service) Installs an instance of a DocService into the DocApp.
 | IsMDI(self) Returns True if the application is in MDI mode.
 | IsSDI(self) Returns True if the application is in SDI mode.
 | OnCloseChildWindow(self, event) Called when an MDI Child Frame is closed.
 | OnCloseMainWindow(self, event) Called when the MDI Parent Frame is closed.
 | OnExit(self) Called when the DocApp is exited, enables the installed DocServices to exit and saves the DocManager's file history.
 | OnInit(self) Initializes the DocApp.
 | OpenCommandLineArgs(self) Called to open files that have been passed to the application from the command line.
 | OpenMainFrame(self)
 | ProcessEvent(self, event) Processes an event, searching event tables and calling zero or more suitable event handler function(s).
 | ProcessEventBeforeWindows(self, event) Enables services to process an event before the main window has a chance to process the window.
 | ProcessUpdateUIEvent(self, event) Processes a UI event, searching event tables and calling zero or more suitable event handler function(s).
 | ProcessUpdateUIEventBeforeWindows(self, event) Enables services to process a UI event before the main window has a chance to process the window.
 | SaveMDIDocumentFrameMaximizedState(self, maximized) Remember in the config whether the MDI Frame is maximized so that it can be restored on open.
 | SetDebug(self, debug) Sets the application's debug mode.
 | SetDefaultIcon(self, icon) Sets the application's default icon.
 | SetDocumentManager(self, docManager) Sets the document manager associated with the DocApp and loads the DocApp's file history into the document manager.
 | SetSingleInstance(self, singleInstance) Sets application's single instance mode.
 | SetUseTabbedMDI(self, useTabbedMDI) Set to True if Windows MDI should use folder tabs instead of child windows.
 | ShowSplash(self, image) Shows a splash window with the given image.
 | ShowTip(self, frame, tipProvider) Shows the tip window, generally this is called when an application starts.

Instance Method Details

CloseChildDocuments(self, parentDocument)

Closes the child windows of a Document.

CloseSplash(self)

Closes the splash window.

CreateChildDocument(self, parentDocument, documentType, objectToEdit, path='')

Creates a child window of a document that edits an object. The child window is managed by the parent document frame, so it will be prompted to close if its parent is closed, etc. Child Documents are useful when there are complicated Views of a Document and users will need to tunnel into the View.

CreateDocumentFrame(self, view, doc, flags, id=-1, title='', pos=wx.Point(-1, -1), size=wx.Size(-1, -1), style=541072960)

Called by the DocManager to create and return a new Frame for a Document. Chooses whether to create an MDIChildFrame or SDI Frame based on the DocManager's flags.

CreateMDIDocumentFrame(self,
          doc,
          view,
          id=-1,
          title='',
          pos=wx.Point(-1, -1),
          size=wx.Size(-1, -1),
          style=541072960)

Creates and returns an MDI Document Frame.

CreateSDIDocumentFrame(self,
          doc,
          view,
          id=-1,
          title='',
          pos=wx.Point(-1, -1),
          size=wx.Size(-1, -1),
          style=541072960)

Creates and returns an SDI Document Frame.

CreateTabbedDocumentFrame(self,
          doc,
          view,
          id=-1,
          title='',
          pos=wx.Point(-1, -1),
          size=wx.Size(-1, -1),
          style=541072960)

Creates and returns an MDI Document Frame for a Tabbed MDI view

DoBackgroundListenAndLoad(self)

Open any files specified in the given command line argument passed in via shared memory

GetDebug(self)

Returns True if the application is in debug mode.

GetDefaultDocManagerFlags(self)

Returns the default flags to use when creating the DocManager.

GetDefaultIcon(self)

Returns the application's default icon.

GetDocumentManager(self)

Returns the document manager associated to the DocApp.

GetEditMenu(self, frame)

Utility method that finds the Edit menu within the menubar of a frame.

GetService(self, type)

Returns the instance of a particular type of service that has been installed into the DocApp. For example, "wx.GetApp().GetService(pydocview.OptionsService)" returns the isntance of the OptionsService that is running within the DocApp.

GetServices(self)

Returns the DocService instances that have been installed into the DocApp.

GetSingleInstance(self)

Returns True if the application is in single instance mode. Used to determine if multiple instances of the application is allowed to launch.

GetUseTabbedMDI(self)

Returns True if Windows MDI should use folder tabs instead of child windows.

InstallService(self, service)

Installs an instance of a DocService into the DocApp.

IsMDI(self)

Returns True if the application is in MDI mode.

IsSDI(self)

Returns True if the application is in SDI mode.

OnCloseChildWindow(self, event)

Called when an MDI Child Frame is closed. Calls SaveMDIDocumentFrameMaximizedState to remember whether the MDI Frame is maximized so that it can be restored on open.

OnCloseMainWindow(self, event)

Called when the MDI Parent Frame is closed. Remembers whether the MDI Parent Frame is maximized.

OnExit(self)

Called when the DocApp is exited, enables the installed DocServices to exit and saves the DocManager's file history.

OnInit(self)

Initializes the DocApp.

Overrides:
wx.PySimpleApp.OnInit

OpenCommandLineArgs(self)

Called to open files that have been passed to the application from the command line.

ProcessEvent(self, event)

Processes an event, searching event tables and calling zero or more suitable event handler function(s). Note that the ProcessEvent method is called from the wxPython docview framework directly since wxPython does not have a virtual ProcessEvent function.

Overrides:
wx.EvtHandler.ProcessEvent

ProcessEventBeforeWindows(self, event)

Enables services to process an event before the main window has a chance to process the window.

ProcessUpdateUIEvent(self, event)

Processes a UI event, searching event tables and calling zero or more suitable event handler function(s). Note that the ProcessEvent method is called from the wxPython docview framework directly since wxPython does not have a virtual ProcessEvent function.

ProcessUpdateUIEventBeforeWindows(self, event)

Enables services to process a UI event before the main window has a chance to process the window.

SaveMDIDocumentFrameMaximizedState(self, maximized)

Remember in the config whether the MDI Frame is maximized so that it can be restored on open.

SetDebug(self, debug)

Sets the application's debug mode.

SetDefaultIcon(self, icon)

Sets the application's default icon.

SetDocumentManager(self, docManager)

Sets the document manager associated with the DocApp and loads the DocApp's file history into the document manager.

SetSingleInstance(self, singleInstance)

Sets application's single instance mode.

SetUseTabbedMDI(self, useTabbedMDI)

Set to True if Windows MDI should use folder tabs instead of child windows.

ShowSplash(self, image)

Shows a splash window with the given image. Input parameter 'image' can either be a wx.Bitmap or a filename.

ShowTip(self, frame, tipProvider)

Shows the tip window, generally this is called when an application starts. A wx.TipProvider must be passed.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:33 2005 http://epydoc.sf.net


wx.lib.pydocview.DocFrameMixIn

Package wx :: Package lib :: Module pydocview :: Class DocFrameMixIn
[frames | no frames]

Class DocFrameMixIn

Known Subclasses:
DocMDIParentFrame, DocSDIFrame, DocTabbedParentFrame

Class with common code used by DocMDIParentFrame, DocTabbedParentFrame, and DocSDIFrame.

Method Summary
 | CreateDefaultMenuBar(self, sdi) Creates the default MenuBar.
 | CreateDefaultStatusBar(self) Creates the default StatusBar.
 | CreateDefaultToolBar(self) Creates the default ToolBar.
 | GetDocumentManager(self) Returns the document manager associated with the DocMDIParentFrame.
 | InitializePrintData(self) Initializes the PrintData that is used when printing.
 | OnAbout(self, event) Invokes the about dialog.
 | OnFileSaveAll(self, event) Saves all of the currently open documents.
 | OnUpdateViewStatusBar(self, event) Updates the View StatusBar menu item.
 | OnUpdateViewToolBar(self, event) Updates the View ToolBar menu item.
 | OnViewStatusBar(self, event) Toggles whether the StatusBar is visible.
 | OnViewToolBar(self, event) Toggles whether the ToolBar is visible.
 | UpdateStatus(self, message) Updates the StatusBar.

Method Details

CreateDefaultMenuBar(self, sdi=False)

Creates the default MenuBar. Contains File, Edit, View, Tools, and Help menus.

CreateDefaultStatusBar(self)

Creates the default StatusBar.

CreateDefaultToolBar(self)

Creates the default ToolBar.

GetDocumentManager(self)

Returns the document manager associated with the DocMDIParentFrame.

InitializePrintData(self)

Initializes the PrintData that is used when printing.

OnAbout(self, event)

Invokes the about dialog.

OnFileSaveAll(self, event)

Saves all of the currently open documents.

OnUpdateViewStatusBar(self, event)

Updates the View StatusBar menu item.

OnUpdateViewToolBar(self, event)

Updates the View ToolBar menu item.

OnViewStatusBar(self, event)

Toggles whether the StatusBar is visible.

OnViewToolBar(self, event)

Toggles whether the ToolBar is visible.

UpdateStatus(self, message=u'Ready')

Updates the StatusBar.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:00 2005 http://epydoc.sf.net


wx.lib.pydocview.DocMDIChildFrame

Package wx :: Package lib :: Module pydocview :: Class DocMDIChildFrame
[frames | no frames]

Type DocMDIChildFrame

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
        TopLevelWindow --+
                         |
                     Frame --+
                             |
                 MDIChildFrame --+
                                 |
                                DocMDIChildFrame

The wxDocMDIChildFrame class provides a default frame for displaying documents on separate windows. This class can only be used for MDI child frames.

The class is part of the document/view framework supported by wxWindows, and cooperates with the wxView, wxDocument, wxDocManager and wxDocTemplate classes.

Method Summary
 | __init__(self, doc, view, frame, id, title, pos, size, style, name) Constructor.
 | Activate(self) Activates the current view.
 | GetDocument(self) Returns the document associated with this frame.
 | GetView(self) Returns the view associated with this frame.
 | OnActivate(self, event) Sets the currently active view to be the frame's view.
 | OnCloseWindow(self, event) Closes and deletes the current view and document.
 | ProcessEvent(event) Processes an event, searching event tables and calling zero or more suitable event handler function(s).
 | SetDocument(self, document) Sets the document for this frame.
 | SetView(self, view) Sets the view for this frame.

Instance Method Details

__init__(self, doc, view, frame, id, title, pos=wx.Point(-1, -1), size=wx.Size(-1, -1), style=541072960, name='frame')
(Constructor)

Constructor. Note that the event table must be rebuilt for the frame since the EvtHandler is not virtual.

Overrides:
wx.MDIChildFrame.__init__

Activate(self)

Activates the current view.

Overrides:
wx.MDIChildFrame.Activate

GetDocument(self)

Returns the document associated with this frame.

GetView(self)

Returns the view associated with this frame.

OnActivate(self, event)

Sets the currently active view to be the frame's view. You may need to override (but still call) this function in order to set the keyboard focus for your subwindow.

OnCloseWindow(self, event)

Closes and deletes the current view and document.

ProcessEvent(event)

Processes an event, searching event tables and calling zero or more suitable event handler function(s). Note that the ProcessEvent method is called from the wxPython docview framework directly since wxPython does not have a virtual ProcessEvent function.

Overrides:
wx.EvtHandler.ProcessEvent

SetDocument(self, document)

Sets the document for this frame.

SetView(self, view)

Sets the view for this frame.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:17 2005 http://epydoc.sf.net


wx.lib.pydocview.DocMDIParentFrame

Package wx :: Package lib :: Module pydocview :: Class DocMDIParentFrame
[frames | no frames]

Type DocMDIParentFrame

                     DocFrameMixIn --+
                                     |
object --+                           |
         |                           |
    Object --+                       |
             |                       |
    EvtHandler --+                   |
                 |                   |
            Window --+               |
                     |               |
        TopLevelWindow --+           |
                         |           |
                     Frame --+       |
                             |       |
                MDIParentFrame --+   |
                                 |   |
                 DocMDIParentFrame --+
                                     |
            DocMDIParentFrameMixIn --+
                                     |
                                    DocMDIParentFrame

The DocMDIParentFrame is the primary frame which the DocApp uses to host MDI child windows. It offers features such as a default menubar, toolbar, and status bar, and a mechanism to manage embedded windows on the edges of the DocMDIParentFrame.

Method Summary
 | __init__(self, docManager, parent, id, title, pos, size, style, name, embeddedWindows) Initializes the DocMDIParentFrame with the default menubar, toolbar, and status bar.
 | OnCloseWindow(self, event) Called when the DocMDIParentFrame is closed.
 | OnSize(self, event) Called when the DocMDIParentFrame is resized and lays out the MDI client window.
 | ProcessEvent(self, event) Processes an event, searching event tables and calling zero or more suitable event handler function(s).
 | ProcessUpdateUIEvent(self, event) Processes a UI event, searching event tables and calling zero or more suitable event handler function(s).
 | UpdateWindowMenu(self) Updates the WindowMenu on Windows platforms.

Instance Method Details

__init__(self, docManager, parent, id, title, pos=wx.Point(-1, -1), size=wx.Size(-1, -1), style=541072960, name='DocMDIFrame', embeddedWindows=0)
(Constructor)

Initializes the DocMDIParentFrame with the default menubar, toolbar, and status bar. Use the optional embeddedWindows parameter with the embedded window constants to create embedded windows around the edges of the DocMDIParentFrame.

Overrides:
wx.lib.docview.DocMDIParentFrame.__init__

OnCloseWindow(self, event)

Called when the DocMDIParentFrame is closed. Remembers the frame size.

Overrides:
wx.lib.docview.DocMDIParentFrame.OnCloseWindow

OnSize(self, event)

Called when the DocMDIParentFrame is resized and lays out the MDI client window.

ProcessEvent(self, event)

Processes an event, searching event tables and calling zero or more suitable event handler function(s). Note that the ProcessEvent method is called from the wxPython docview framework directly since wxPython does not have a virtual ProcessEvent function.

Overrides:
wx.lib.docview.DocMDIParentFrame.ProcessEvent

ProcessUpdateUIEvent(self, event)

Processes a UI event, searching event tables and calling zero or more suitable event handler function(s). Note that the ProcessEvent method is called from the wxPython docview framework directly since wxPython does not have a virtual ProcessEvent function.

Overrides:
wx.lib.docview.DocMDIParentFrame.ProcessUpdateUIEvent

UpdateWindowMenu(self)

Updates the WindowMenu on Windows platforms.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:25 2005 http://epydoc.sf.net


wx.lib.pydocview.DocMDIParentFrameMixIn

Package wx :: Package lib :: Module pydocview :: Class DocMDIParentFrameMixIn
[frames | no frames]

Class DocMDIParentFrameMixIn

Known Subclasses:
DocMDIParentFrame, DocTabbedParentFrame

Class with common code used by DocMDIParentFrame and DocTabbedParentFrame.

Method Summary
 | CreateEmbeddedWindows(self, windows) Create the specified embedded windows around the edges of the frame.
 | GetEmbeddedWindow(self, loc) Returns the instance of the embedded window specified by the embedded window location constant.
 | HideEmbeddedWindow(self) Hides the embedded window specified by the embedded window location constant.
 | ProcessEvent(self, event) Processes an event, searching event tables and calling zero or more suitable event handler function(s).
 | ProcessUpdateUIEvent(self, event) Processes a UI event, searching event tables and calling zero or more suitable event handler function(s).
 | SaveEmbeddedWindowSizes(self) Saves the sizes of the embedded windows.
 | ShowEmbeddedWindow(self, window, show) Shows or hides the embedded window specified by the embedded window location constant.

Method Details

CreateEmbeddedWindows(self, windows=0)

Create the specified embedded windows around the edges of the frame.

GetEmbeddedWindow(self, loc)

Returns the instance of the embedded window specified by the embedded window location constant.

HideEmbeddedWindow(self)

Hides the embedded window specified by the embedded window location constant.

ProcessEvent(self, event)

Processes an event, searching event tables and calling zero or more suitable event handler function(s). Note that the ProcessEvent method is called from the wxPython docview framework directly since wxPython does not have a virtual ProcessEvent function.

ProcessUpdateUIEvent(self, event)

Processes a UI event, searching event tables and calling zero or more suitable event handler function(s). Note that the ProcessEvent method is called from the wxPython docview framework directly since wxPython does not have a virtual ProcessEvent function.

SaveEmbeddedWindowSizes(self)

Saves the sizes of the embedded windows.

ShowEmbeddedWindow(self, window, show=True)

Shows or hides the embedded window specified by the embedded window location constant.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:00 2005 http://epydoc.sf.net


wx.lib.pydocview.DocOptionsService

Package wx :: Package lib :: Module pydocview :: Class DocOptionsService
[frames | no frames]

Type DocOptionsService

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
        DocService --+
                     |
                    DocOptionsService

A service that implements an options menu item and an options dialog with notebook tabs. New tabs can be added by other services by calling the "AddOptionsPanel" method.

Method Summary
 | __init__(self, showGeneralOptions, supportedModes) Initializes the options service with the option of suppressing the default general options pane that is included with the options service by setting showGeneralOptions to False.
 | AddOptionsPanel(self, optionsPanel) Adds an options panel to the options dialog.
 | ClearOptionsPanels(self) Clears all of the options panels that have been added into the options dialog.
 | GetSupportedModes(self) Return the modes supported by the application.
 | InstallControls(self, frame, menuBar, toolBar, statusBar, document) Installs a "Tools" menu with an "Options" menu item.
 | OnOptions(self, event) Shows the options dialog, called when the "Options" menu item is selected.
 | ProcessEvent(self, event) Checks to see if the "Options" menu item has been selected.
 | SetSupportedModes(self, _supportedModessupportedModes) Sets the modes supported by the application.

Method Details

__init__(self, showGeneralOptions=True, supportedModes=0)
(Constructor)

Initializes the options service with the option of suppressing the default general options pane that is included with the options service by setting showGeneralOptions to False. It allowModeChanges is set to False, the default general options pane will allow users to change the document interface mode between SDI and MDI modes.

Overrides:
wx.lib.pydocview.DocService.__init__

AddOptionsPanel(self, optionsPanel)

Adds an options panel to the options dialog.

ClearOptionsPanels(self)

Clears all of the options panels that have been added into the options dialog.

GetSupportedModes(self)

Return the modes supported by the application. Use docview.DOC_SDI and docview.DOC_MDI flags to check if SDI and/or MDI modes are supported.

InstallControls(self,
          frame,
          menuBar=None,
          toolBar=None,
          statusBar=None,
          document=None)

Installs a "Tools" menu with an "Options" menu item.

Overrides:
wx.lib.pydocview.DocService.InstallControls

OnOptions(self, event)

Shows the options dialog, called when the "Options" menu item is selected.

ProcessEvent(self, event)

Checks to see if the "Options" menu item has been selected.

Overrides:
wx.lib.pydocview.DocService.ProcessEvent

SetSupportedModes(self, _supportedModessupportedModes)

Sets the modes supported by the application. Use docview.DOC_SDI and docview.DOC_MDI flags to set if SDI and/or MDI modes are supported.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:45 2005 http://epydoc.sf.net


wx.lib.pydocview.DocSDIFrame

Package wx :: Package lib :: Module pydocview :: Class DocSDIFrame
[frames | no frames]

Type DocSDIFrame

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
        TopLevelWindow --+
                         |
                     Frame --+
                             |
                 DocChildFrame --+
                                 |
                 DocFrameMixIn --+
                                 |
                                DocSDIFrame

The DocSDIFrame host DocManager Document windows. It offers features such as a default menubar, toolbar, and status bar.

Method Summary
 | __init__(self, doc, view, parent, id, title, pos, size, style, name) Initializes the DocSDIFrame with the default menubar, toolbar, and status bar.
 | OnCloseWindow(self, event) Called when the window is saved.
 | OnExit(self, event) Called when the application is exitting.
 | OnMRUFile(self, event) Opens the appropriate file when it is selected from the file history menu.
 | ProcessEvent(self, event) Processes an event, searching event tables and calling zero or more suitable event handler function(s).
 | ProcessUpdateUIEvent(self, event) Processes a UI event, searching event tables and calling zero or more suitable event handler function(s).

Instance Method Details

__init__(self, doc, view, parent, id, title, pos=wx.Point(-1, -1), size=wx.Size(-1, -1), style=541072960, name='DocSDIFrame')
(Constructor)

Initializes the DocSDIFrame with the default menubar, toolbar, and status bar.

Overrides:
wx.lib.docview.DocChildFrame.__init__

OnCloseWindow(self, event)

Called when the window is saved. Enables services to help close the frame.

Overrides:
wx.lib.docview.DocChildFrame.OnCloseWindow

OnExit(self, event)

Called when the application is exitting.

OnMRUFile(self, event)

Opens the appropriate file when it is selected from the file history menu.

ProcessEvent(self, event)

Processes an event, searching event tables and calling zero or more suitable event handler function(s). Note that the ProcessEvent method is called from the wxPython docview framework directly since wxPython does not have a virtual ProcessEvent function.

Overrides:
wx.lib.docview.DocChildFrame.ProcessEvent

ProcessUpdateUIEvent(self, event)

Processes a UI event, searching event tables and calling zero or more suitable event handler function(s). Note that the ProcessEvent method is called from the wxPython docview framework directly since wxPython does not have a virtual ProcessEvent function.

Overrides:
wx.lib.docview.DocChildFrame.ProcessUpdateUIEvent

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:22 2005 http://epydoc.sf.net


wx.lib.pydocview.DocService

Package wx :: Package lib :: Module pydocview :: Class DocService
[frames | no frames]

Type DocService

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
                DocService

Known Subclasses:
AboutService, DocOptionsService, FilePropertiesService, WindowMenuService

An abstract class used to add reusable services to a docview application.

Method Summary
 | __init__(self) Initializes the DocService.
 | GetDocumentManager(self) Returns the DocManager for the docview application.
 | GetMenuItemPos(self, menu, id) Utility method used to find the position of a menu item so that services can easily find where to insert a menu item in InstallControls.
 | GetView(self) Called by WindowMenuService to get views for services that don't have dedicated documents such as the Outline Service.
 | InstallControls(self, frame, menuBar, toolBar, statusBar, document) Called to install controls into the menubar and toolbar of a SDI or MDI window.
 | OnCloseFrame(self, event) Called when the a docview frame is being closed.
 | OnExit(self) Called when the the docview application is being closed.
 | ProcessEvent(self, event) Processes an event, searching event tables and calling zero or more suitable event handler function(s).
 | ProcessEventBeforeWindows(self, event) Processes an event before the main window has a chance to process the window.
 | ProcessUpdateUIEvent(self, event) Processes a UI event, searching event tables and calling zero or more suitable event handler function(s).
 | ProcessUpdateUIEventBeforeWindows(self, event) Processes a UI event before the main window has a chance to process the window.
 | SetDocumentManager(self, docManager) Sets the DocManager for the docview application.

Method Details

__init__(self)
(Constructor)

Initializes the DocService.

Overrides:
wx.EvtHandler.__init__

GetDocumentManager(self)

Returns the DocManager for the docview application.

GetMenuItemPos(self, menu, id)

Utility method used to find the position of a menu item so that services can easily find where to insert a menu item in InstallControls.

GetView(self)

Called by WindowMenuService to get views for services that don't have dedicated documents such as the Outline Service.

InstallControls(self,
          frame,
          menuBar=None,
          toolBar=None,
          statusBar=None,
          document=None)

Called to install controls into the menubar and toolbar of a SDI or MDI window. Override this method for a particular service.

OnCloseFrame(self, event)

Called when the a docview frame is being closed. Override this method so a service can either do cleanup or veto the frame being closed by returning false.

OnExit(self)

Called when the the docview application is being closed. Override this method so a service can either do cleanup or veto the frame being closed by returning false.

ProcessEvent(self, event)

Processes an event, searching event tables and calling zero or more suitable event handler function(s). Note that the ProcessEvent method is called from the wxPython docview framework directly since wxPython does not have a virtual ProcessEvent function.

Overrides:
wx.EvtHandler.ProcessEvent

ProcessEventBeforeWindows(self, event)

Processes an event before the main window has a chance to process the window. Override this method for a particular service.

ProcessUpdateUIEvent(self, event)

Processes a UI event, searching event tables and calling zero or more suitable event handler function(s). Note that the ProcessEvent method is called from the wxPython docview framework directly since wxPython does not have a virtual ProcessEvent function.

ProcessUpdateUIEventBeforeWindows(self, event)

Processes a UI event before the main window has a chance to process the window. Override this method for a particular service.

SetDocumentManager(self, docManager)

Sets the DocManager for the docview application.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:05 2005 http://epydoc.sf.net


wx.lib.pydocview.DocTabbedChildFrame

Package wx :: Package lib :: Module pydocview :: Class DocTabbedChildFrame
[frames | no frames]

Type DocTabbedChildFrame

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
                 Panel --+
                         |
                        DocTabbedChildFrame

The wxDocMDIChildFrame class provides a default frame for displaying documents on separate windows. This class can only be used for MDI child frames.

The class is part of the document/view framework supported by wxWindows, and cooperates with the wxView, wxDocument, wxDocManager and wxDocTemplate classes.

Method Summary
 | __init__(self, doc, view, frame, id, title, pos, size, style, name) Constructor.
 | Activate(self) Activates the current view.
 | Destroy(self) Removes the current notebook page.
 | GetDocument(self) Returns the document associated with this frame.
 | GetIcon(self) Dummy method since the icon of tabbed frames are managed by the notebook.
 | GetTitle(self) Returns the frame's title.
 | GetView(self) Returns the view associated with this frame.
 | ProcessEvent(event) Processes an event, searching event tables and calling zero or more suitable event handler function(s).
 | SetDocument(self, document) Sets the document for this frame.
 | SetFocus(self) Activates the current notebook page.
 | SetIcon(self, icon) Dummy method since the icon of tabbed frames are managed by the notebook.
 | SetTitle(self, title) Sets the frame's title.
 | SetView(self, view) Sets the view for this frame.

Instance Method Details

__init__(self, doc, view, frame, id, title, pos=wx.Point(-1, -1), size=wx.Size(-1, -1), style=541072960, name='frame')
(Constructor)

Constructor. Note that the event table must be rebuilt for the frame since the EvtHandler is not virtual.

Overrides:
wx.Panel.__init__

Activate(self)

Activates the current view.

Destroy(self)

Removes the current notebook page.

Overrides:
wx.Window.Destroy

GetDocument(self)

Returns the document associated with this frame.

GetIcon(self)

Dummy method since the icon of tabbed frames are managed by the notebook.

GetTitle(self)

Returns the frame's title.

Overrides:
wx.Window.GetTitle

GetView(self)

Returns the view associated with this frame.

ProcessEvent(event)

Processes an event, searching event tables and calling zero or more suitable event handler function(s). Note that the ProcessEvent method is called from the wxPython docview framework directly since wxPython does not have a virtual ProcessEvent function.

Overrides:
wx.EvtHandler.ProcessEvent

SetDocument(self, document)

Sets the document for this frame.

SetFocus(self)

Activates the current notebook page.

Overrides:
wx.Panel.SetFocus

SetIcon(self, icon)

Dummy method since the icon of tabbed frames are managed by the notebook.

SetTitle(self, title)

Sets the frame's title.

Overrides:
wx.Window.SetTitle

SetView(self, view)

Sets the view for this frame.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:27 2005 http://epydoc.sf.net


wx.lib.pydocview.DocTabbedParentFrame

Package wx :: Package lib :: Module pydocview :: Class DocTabbedParentFrame
[frames | no frames]

Type DocTabbedParentFrame

             DocFrameMixIn --+
                             |
    DocMDIParentFrameMixIn --+
                             |
object --+                   |
         |                   |
    Object --+               |
             |               |
    EvtHandler --+           |
                 |           |
            Window --+       |
                     |       |
        TopLevelWindow --+   |
                         |   |
                     Frame --+
                             |
                            DocTabbedParentFrame

The DocTabbedParentFrame class provides a default top-level frame for applications using the document/view framework. This class can only be used for MDI parent frames that use a tabbed interface.

It cooperates with the wxView, wxDocument, wxDocManager and wxDocTemplate classes.

Method Summary
 | __init__(self, docManager, frame, id, title, pos, size, style, name, embeddedWindows) Constructor.
 | ActivateNotebookPage(self, panel) Sets the notebook to the specified panel.
 | AddNotebookPage(self, panel, title) Adds a document page to the notebook.
 | CreateNotebook(self) Creates the notebook to use for the tabbed document interface.
 | GetActiveChild(self) Returns the active notebook page, which to the framework is treated as a document frame.
 | GetNotebook(self) Returns the notebook used by the tabbed document interface.
 | GetNotebookPageIndex(self, panel) Returns the index of particular notebook panel.
 | GetNotebookPageTitle(self, panel)
 | OnCloseWindow(self, event) Called when the frame is closed.
 | OnExit(self, event) Called when File/Exit is chosen and closes the window.
 | OnMRUFile(self, event) Opens the appropriate file when it is selected from the file history menu.
 | OnNotebookMouseOver(self, event)
 | OnNotebookPageChanged(self, event) Activates a notebook page's view when it is selected.
 | OnNotebookRightClick(self, event) Handles right clicks for the notebook, enabling users to either close a tab or select from the available documents if the user clicks on the notebook's white space.
 | OnSize(self, event) Called when the frame is resized and lays out the client window.
 | ProcessEvent(self, event) Processes an event, searching event tables and calling zero or more suitable event handler function(s).
 | ProcessUpdateUIEvent(self, event) Processes a UI event, searching event tables and calling zero or more suitable event handler function(s).
 | RemoveNotebookPage(self, panel) Removes a document page from the notebook.
 | SetNotebookPageTitle(self, panel, title)

Instance Method Details

__init__(self, docManager, frame, id, title, pos=wx.Point(-1, -1), size=wx.Size(-1, -1), style=541072960, name='DocTabbedParentFrame', embeddedWindows=0)
(Constructor)

Constructor. Note that the event table must be rebuilt for the frame since the EvtHandler is not virtual.

Overrides:
wx.Frame.__init__

ActivateNotebookPage(self, panel)

Sets the notebook to the specified panel.

AddNotebookPage(self, panel, title)

Adds a document page to the notebook.

CreateNotebook(self)

Creates the notebook to use for the tabbed document interface.

GetActiveChild(self)

Returns the active notebook page, which to the framework is treated as a document frame.

GetNotebook(self)

Returns the notebook used by the tabbed document interface.

GetNotebookPageIndex(self, panel)

Returns the index of particular notebook panel.

OnCloseWindow(self, event)

Called when the frame is closed. Remembers the frame size.

OnExit(self, event)

Called when File/Exit is chosen and closes the window.

OnMRUFile(self, event)

Opens the appropriate file when it is selected from the file history menu.

OnNotebookPageChanged(self, event)

Activates a notebook page's view when it is selected.

OnNotebookRightClick(self, event)

Handles right clicks for the notebook, enabling users to either close a tab or select from the available documents if the user clicks on the notebook's white space.

OnSize(self, event)

Called when the frame is resized and lays out the client window.

ProcessEvent(self, event)

Processes an event, searching event tables and calling zero or more suitable event handler function(s). Note that the ProcessEvent method is called from the wxPython docview framework directly since wxPython does not have a virtual ProcessEvent function.

Overrides:
wx.EvtHandler.ProcessEvent

ProcessUpdateUIEvent(self, event)

Processes a UI event, searching event tables and calling zero or more suitable event handler function(s). Note that the ProcessEvent method is called from the wxPython docview framework directly since wxPython does not have a virtual ProcessEvent function.

Overrides:
wx.lib.pydocview.DocMDIParentFrameMixIn.ProcessUpdateUIEvent

RemoveNotebookPage(self, panel)

Removes a document page from the notebook.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:21 2005 http://epydoc.sf.net


wx.lib.pydocview.FilePropertiesDialog

Package wx :: Package lib :: Module pydocview :: Class FilePropertiesDialog
[frames | no frames]

Type FilePropertiesDialog

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
        TopLevelWindow --+
                         |
                    Dialog --+
                             |
                            FilePropertiesDialog

Dialog that shows the properties of a file. Invoked by the PropertiesService.

Method Summary
__init__(self, parent, filename)
Initializes the properties dialog.

Instance Method Details

__init__(self, parent, filename)
(Constructor)

Initializes the properties dialog.

Overrides:
wx.Dialog.__init__

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:17 2005 http://epydoc.sf.net


wx.lib.pydocview.FilePropertiesService

Package wx :: Package lib :: Module pydocview :: Class FilePropertiesService
[frames | no frames]

Type FilePropertiesService

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
        DocService --+
                     |
                    FilePropertiesService

Service that installs under the File menu to show the properties of the file associated with the current document.

Method Summary
 | __init__(self) Initializes the PropertyService.
 | AddCustomEventHandler(self, handler) Adds a custom event handlers for the PropertyService.
 | chopPath(self, text, length) Simple version of textwrap.
 | GetCustomEventHandlers(self) Returns the custom event handlers for the PropertyService.
 | InstallControls(self, frame, menuBar, toolBar, statusBar, document) Installs a File/Properties menu item.
 | ProcessEvent(self, event) Detects when the File/Properties menu item is selected.
 | ProcessUpdateUIEvent(self, event) Updates the File/Properties menu item.
 | RemoveCustomEventHandler(self, handler) Removes a custom event handler from the PropertyService.
 | ShowPropertiesDialog(self, filename) Shows the PropertiesDialog for the specified file.

Class Variable Summary
int PROPERTIES_ID = 130

Method Details

__init__(self)
(Constructor)

Initializes the PropertyService.

Overrides:
wx.lib.pydocview.DocService.__init__

AddCustomEventHandler(self, handler)

Adds a custom event handlers for the PropertyService. A custom event handler enables a different dialog to be provided for a particular file.

chopPath(self, text, length=36)

Simple version of textwrap. textwrap.fill() unfortunately chops lines at spaces and creates odd word boundaries. Instead, we will chop the path without regard to spaces, but pay attention to path delimiters.

GetCustomEventHandlers(self)

Returns the custom event handlers for the PropertyService.

InstallControls(self,
          frame,
          menuBar=None,
          toolBar=None,
          statusBar=None,
          document=None)

Installs a File/Properties menu item.

Overrides:
wx.lib.pydocview.DocService.InstallControls

ProcessEvent(self, event)

Detects when the File/Properties menu item is selected.

Overrides:
wx.lib.pydocview.DocService.ProcessEvent

ProcessUpdateUIEvent(self, event)

Updates the File/Properties menu item.

Overrides:
wx.lib.pydocview.DocService.ProcessUpdateUIEvent

RemoveCustomEventHandler(self, handler)

Removes a custom event handler from the PropertyService.

ShowPropertiesDialog(self, filename=None)

Shows the PropertiesDialog for the specified file.

Class Variable Details

PROPERTIES_ID

Type:
int
Value:
130

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:13 2005 http://epydoc.sf.net


wx.lib.pydocview.GeneralOptionsPanel

Package wx :: Package lib :: Module pydocview :: Class GeneralOptionsPanel
[frames | no frames]

Type GeneralOptionsPanel

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
                 Panel --+
                         |
                        GeneralOptionsPanel

A general options panel that is used in the OptionDialog to configure the generic properties of a pydocview application, such as "show tips at startup" and whether to use SDI or MDI for the application.

Method Summary
 | __init__(self, parent, id) Initializes the panel by adding an "Options" folder tab to the parent notebook and populating the panel with the generic properties of a pydocview application.
 | OnOK(self, optionsDialog) Updates the config based on the selections in the options panel.

Instance Method Details

__init__(self, parent, id)
(Constructor)

Initializes the panel by adding an "Options" folder tab to the parent notebook and populating the panel with the generic properties of a pydocview application.

Overrides:
wx.Panel.__init__

OnOK(self, optionsDialog)

Updates the config based on the selections in the options panel.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:59 2005 http://epydoc.sf.net


wx.lib.pydocview.OptionsDialog

Package wx :: Package lib :: Module pydocview :: Class OptionsDialog
[frames | no frames]

Type OptionsDialog

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
        TopLevelWindow --+
                         |
                    Dialog --+
                             |
                            OptionsDialog

A default options dialog used by the OptionsService that hosts a notebook tab of options panels.

Method Summary
 | __init__(self, parent, optionsPanelClasses, docManager) Initializes the options dialog with a notebook page that contains new instances of the passed optionsPanelClasses.
 | DoRefresh(self) wxBug: On Windows XP when using a multiline notebook the default page doesn't get drawn, but it works when using a single line notebook.
 | GetDocManager(self) Returns the document manager passed to the OptionsDialog constructor.
 | OnOK(self, event) Calls the OnOK method of all of the OptionDialog's embedded panels

Instance Method Details

__init__(self, parent, optionsPanelClasses, docManager)
(Constructor)

Initializes the options dialog with a notebook page that contains new instances of the passed optionsPanelClasses.

Overrides:
wx.Dialog.__init__

DoRefresh(self)

wxBug: On Windows XP when using a multiline notebook the default page doesn't get drawn, but it works when using a single line notebook.

GetDocManager(self)

Returns the document manager passed to the OptionsDialog constructor.

OnOK(self, event)

Calls the OnOK method of all of the OptionDialog's embedded panels

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:47 2005 http://epydoc.sf.net


wx.lib.pydocview.WindowMenuService

Package wx :: Package lib :: Module pydocview :: Class WindowMenuService
[frames | no frames]

Type WindowMenuService

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
        DocService --+
                     |
                    WindowMenuService

The WindowMenuService is a service that implements a standard Window menu that is used by the DocSDIFrame. The MDIFrame automatically includes a Window menu and does not use the WindowMenuService.

Method Summary
 | __init__(self) Initializes the WindowMenu and its globals.
 | BuildWindowMenu(self, currentFrame) Builds the Window menu and adds menu items for all of the open documents in the DocManager.
 | InstallControls(self, frame, menuBar, toolBar, statusBar, document) Installs the Window menu.
 | OnArrangeWindows(self, event) Called by Window/Arrange and tiles the frames on the desktop.
 | OnSelectMoreWindows(self, event) Called when the "Window/Select More Windows..." menu item is selected and enables user to select from the Frames that do not in the Window list.
 | OnSelectWindowMenu(self, event) Called when the Window menu item representing a Frame is selected and brings the selected Frame to the front of the desktop.
 | ProcessEvent(self, event) Processes a Window menu event.
 | ProcessUpdateUIEvent(self, event) Updates the Window menu items.

Method Details

__init__(self)
(Constructor)

Initializes the WindowMenu and its globals.

Overrides:
wx.lib.pydocview.DocService.__init__

BuildWindowMenu(self, currentFrame)

Builds the Window menu and adds menu items for all of the open documents in the DocManager.

InstallControls(self,
          frame,
          menuBar=None,
          toolBar=None,
          statusBar=None,
          document=None)

Installs the Window menu.

Overrides:
wx.lib.pydocview.DocService.InstallControls

OnArrangeWindows(self, event)

Called by Window/Arrange and tiles the frames on the desktop.

OnSelectMoreWindows(self, event)

Called when the "Window/Select More Windows..." menu item is selected and enables user to select from the Frames that do not in the Window list. Useful when there are more than 10 open frames in the application.

OnSelectWindowMenu(self, event)

Called when the Window menu item representing a Frame is selected and brings the selected Frame to the front of the desktop.

ProcessEvent(self, event)

Processes a Window menu event.

Overrides:
wx.lib.pydocview.DocService.ProcessEvent

ProcessUpdateUIEvent(self, event)

Updates the Window menu items.

Overrides:
wx.lib.pydocview.DocService.ProcessUpdateUIEvent

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:11 2005 http://epydoc.sf.net


wx.lib.pydocview

Package wx :: Package lib :: Module pydocview

Module wx.lib.pydocview

Classes
AboutDialog | Opens an AboutDialog.
AboutService | About Dialog Service that installs under the Help menu to show the properties of the current application.
ChildDocTemplate | A ChildDocTemplate is a DocTemplate subclass that enables the creation of ChildDocuments that represents a portion of a Document.
ChildDocument | A ChildDocument is a document that represents a portion of a Document.
DocApp | The DocApp class serves as the base class for pydocview applications and offers functionality such as services, creation of SDI and MDI frames, show tips, and a splash screen.
DocFrameMixIn | Class with common code used by DocMDIParentFrame, DocTabbedParentFrame, and DocSDIFrame.
DocMDIChildFrame | The wxDocMDIChildFrame class provides a default frame for displaying documents on separate windows.
DocMDIParentFrame | The DocMDIParentFrame is the primary frame which the DocApp uses to host MDI child windows.
DocMDIParentFrameMixIn | Class with common code used by DocMDIParentFrame and DocTabbedParentFrame.
DocOptionsService | A service that implements an options menu item and an options dialog with notebook tabs.
DocSDIFrame | The DocSDIFrame host DocManager Document windows.
DocService | An abstract class used to add reusable services to a docview application.
DocTabbedChildFrame | The wxDocMDIChildFrame class provides a default frame for displaying documents on separate windows.
DocTabbedParentFrame | The DocTabbedParentFrame class provides a default top-level frame for applications using the document/view framework.
FilePropertiesDialog | Dialog that shows the properties of a file.
FilePropertiesService | Service that installs under the File menu to show the properties of the file associated with the current document.
GeneralOptionsPanel | A general options panel that is used in the OptionDialog to configure the generic properties of a pydocview application, such as "show tips at startup" and whether to use SDI or MDI for the application.
OptionsDialog | A default options dialog used by the OptionsService that hosts a notebook tab of options panels.
WindowMenuService | The WindowMenuService is a service that implements a standard Window menu that is used by the DocSDIFrame.

Function Summary
 | getBlankBitmap()
 | getBlankData()
 | getBlankIcon()
 | getBlankImage()
 | getCopyBitmap()
 | getCopyData()
 | getCopyImage()
 | getCutBitmap()
 | getCutData()
 | getCutImage()
 | getNewBitmap()
 | getNewData()
 | getNewImage()
 | getOpenBitmap()
 | getOpenData()
 | getOpenImage()
 | getPasteBitmap()
 | getPasteData()
 | getPasteImage()
 | getPrintBitmap()
 | getPrintData()
 | getPrintImage()
 | getPrintPreviewBitmap()
 | getPrintPreviewData()
 | getPrintPreviewImage()
 | getRedoBitmap()
 | getRedoData()
 | getRedoImage()
 | getSaveAllBitmap()
 | getSaveAllData()
 | getSaveAllImage()
 | getSaveBitmap()
 | getSaveData()
 | getSaveImage()
 | getUndoBitmap()
 | getUndoData()
 | getUndoImage()

Variable Summary
int | EMBEDDED_WINDOW_ALL = 255
int | EMBEDDED_WINDOW_BOTTOM = 2
int | EMBEDDED_WINDOW_BOTTOMLEFT = 32
int | EMBEDDED_WINDOW_BOTTOMRIGHT = 128
int | EMBEDDED_WINDOW_LEFT = 4
int | EMBEDDED_WINDOW_RIGHT = 8
int | EMBEDDED_WINDOW_TOP = 1
int | EMBEDDED_WINDOW_TOPLEFT = 16
int | EMBEDDED_WINDOW_TOPRIGHT = 64
int | SAVEALL_ID = 129
int | VIEW_STATUSBAR_ID = 128
int | VIEW_TOOLBAR_ID = 127
int | WINDOW_MENU_NUM_ITEMS = 9

Variable Details

EMBEDDED_WINDOW_ALL

Type:
int
Value:
255

EMBEDDED_WINDOW_BOTTOM

Type:
int
Value:
2

EMBEDDED_WINDOW_BOTTOMLEFT

Type:
int
Value:
32

EMBEDDED_WINDOW_BOTTOMRIGHT

Type:
int
Value:
128

EMBEDDED_WINDOW_LEFT

Type:
int
Value:
4

EMBEDDED_WINDOW_RIGHT

Type:
int
Value:
8

EMBEDDED_WINDOW_TOP

Type:
int
Value:
1

EMBEDDED_WINDOW_TOPLEFT

Type:
int
Value:
16

EMBEDDED_WINDOW_TOPRIGHT

Type:
int
Value:
64

SAVEALL_ID

Type:
int
Value:
129

VIEW_STATUSBAR_ID

Type:
int
Value:
128

VIEW_TOOLBAR_ID

Type:
int
Value:
127

WINDOW_MENU_NUM_ITEMS

Type:
int
Value:
9

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:46 2005 http://epydoc.sf.net


wx.lib.pyshell.FauxFile

Package wx :: Package lib :: Module pyshell :: Class FauxFile
[frames | no frames]

Class FauxFile

Method Summary
 | __init__(self, psw, style)
 | flush(self)
 | write(self, text)
 | writelines(self, lst)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:07 2005 http://epydoc.sf.net


wx.lib.pyshell.PyShellWindow

Package wx :: Package lib :: Module pyshell :: Class PyShellWindow
[frames | no frames]

Type PyShellWindow

    InteractiveInterpreter --+
                             |
object --+                   |
         |                   |
    Object --+               |
             |               |
    EvtHandler --+           |
                 |           |
            Window --+       |
                     |       |
               Control --+   |
                         |   |
            StyledTextCtrl --+
                             |
                            PyShellWindow

Method Summary
 | __init__(self, parent, ID, pos, size, style, locals, properties, banner)
 | GetLocals(self)
 | GetProperties(self)
 | OnKey(self, evt)
 | OnStyle(self, evt)
 | OnUpdateUI(self, evt)
 | Prompt(self)
 | PushLine(self, text)
 | runsource(self, source)
 | SetLocals(self, locals)
 | SetProperties(self, properties)
 | showsyntaxerror(self, filename) Display the syntax error that just occurred.
 | showtraceback(self) Display the exception that just occurred.
 | UpdateProperties(self) Reset the editor and other settings based on the contents of the current properties dictionary.
 | writeTrace(self, text)

Instance Method Details

showsyntaxerror(self, filename=None)

Display the syntax error that just occurred.

This doesn't display a stack trace because there isn't one.

If a filename is given, it is stuffed in the exception instead of what was there before (because Python's parser always uses "<string>" when reading from a string).

The output is written by self.write(), below.

Overrides:
code.InteractiveInterpreter.showsyntaxerror (inherited documentation)

showtraceback(self)

Display the exception that just occurred.

We remove the first stack item because it is our own code.

The output is written by self.write(), below.

Overrides:
code.InteractiveInterpreter.showtraceback (inherited documentation)

UpdateProperties(self)

Reset the editor and other settings based on the contents of the current properties dictionary.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:52 2005 http://epydoc.sf.net


wx.lib.pyshell

Package wx :: Package lib :: Module pyshell

Module wx.lib.pyshell

PyShellWindow is a class that provides an Interactive Interpreter running inside a wxStyledTextCtrl, similar to the Python shell windows found in IDLE and PythonWin.

There is still much to be done to improve this class, such as line buffering/recall, autoindent, calltips, autocomplete, fixing the colourizer, etc... But it's a good start.

8-10-2001 THIS MODULE IS NOW DEPRECATED. Please see the most excellent
PyCrust package instead.
Classes
FauxFile
PyShellWindow

Variable Summary
str warningmsg = '\\\n\n####################################...

Variable Details

warningmsg

Type:
str
Value:
'''\\

########################################\\
# THIS MODULE IS NOW DEPRECATED         |
#                                       |
# Please see the most excellent PyCrust |
# package instead.                      |
########################################/
...

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:59 2005 http://epydoc.sf.net


wx.lib.rcsizer.RowColSizer

Package wx :: Package lib :: Module rcsizer :: Class RowColSizer
[frames | no frames]

Type RowColSizer

object --+
         |
    Object --+
             |
         Sizer --+
                 |
           PySizer --+
                     |
                    RowColSizer

Method Summary
 | __init__(self)
 | Add(self, item, option, flag, border, row, col, rowspan, colspan, pos, size)
 | AddGrowableCol(self, idx)
 | AddGrowableRow(self, idx)
 | AddSpacer(self, width, height, option, flag, border, row, col, rowspan, colspan, pos, size)
 | CalcMin(self)
 | RecalcSizes(self)
 | SetItemBounds(self, item, x, y, w, h)

Class Variable Summary
int | col_w = 10
int | row_h = 22

Class Variable Details

col_w

Type:
int
Value:
10

row_h

Type:
int
Value:
22

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:26 2005 http://epydoc.sf.net


wx.lib.rcsizer

Package wx :: Package lib :: Module rcsizer

Module wx.lib.rcsizer

A pure-Python Sizer that lays out items in a grid similar to wx.FlexGridSizer but item position is not implicit but explicitly specified by row and col, and row/col spanning is supported.

Adapted from code by Niki Spahiev.

NOTE: There is now a C++ version of this class that has been wrapped as wx.GridBagSizer. It is quicker and more capable so you are encouraged to switch.

Classes
RowColSizer

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:48 2005 http://epydoc.sf.net


wx.lib.rightalign.RightTextCtrl

Package wx :: Package lib :: Module rightalign :: Class RightTextCtrl
[frames | no frames]

Type RightTextCtrl

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
               Control --+
                         |
                  TextCtrl --+
                             |
                            RightTextCtrl

Method Summary
 | __init__(self, parent, id, *args, **kwargs)
 | OnKillFocus(self, event)
 | OnPaint(self, event)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:17 2005 http://epydoc.sf.net


wx.lib.rightalign

Package wx :: Package lib :: Module rightalign

Module wx.lib.rightalign

Some time ago, I asked about how to right-align wxTextCtrls. Answer was that it is not supported. I forgot it.

Just a week ago, one of my clients asked me to have numbers right aligned. (Indeed it was that numbers MUST be right aligned).

So the game begun. Hacking, hacking, ...

At last, i succeed. Here is some code that someone may find useful. ubRightTextCtrl is right-aligned when you are not editing, but left-aligned if it has focus.

Hope this can help someone, as much as this list helps me.

Josu Oyanguren Ubera Servicios Informaticos.

P.S. This only works well on wxMSW.

Classes
RightTextCtrl

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:07 2005 http://epydoc.sf.net


wx.lib.scrolledpanel.ScrolledPanel

Package wx :: Package lib :: Module scrolledpanel :: Class ScrolledPanel
[frames | no frames]

Type ScrolledPanel

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
                 Panel --+
                         |
            ScrolledWindow --+
                             |
              PyScrolledWindow --+
                                 |
                                ScrolledPanel

ScrolledPanel fills a "hole" in the implementation of wx.ScrolledWindow, providing automatic scrollbar and scrolling behavior and the tab traversal management that wxScrolledWindow lacks. This code was based on the original demo code showing how to do this, but is now available for general use as a proper class (and the demo is now converted to just use it.)

It is assumed that the ScrolledPanel will have a sizer, as it is used to calculate the minimal virtual size of the panel and etc.

Method Summary
 | __init__(self, parent, id, pos, size, style, name)
 | OnChildFocus(self, evt)
 | SetupScrolling(self, scroll_x, scroll_y, rate_x, rate_y) This function sets up the event handling necessary to handle scrolling properly.

Instance Method Details

SetupScrolling(self,
          scroll_x=True,
          scroll_y=True,
          rate_x=20,
          rate_y=20)

This function sets up the event handling necessary to handle scrolling properly. It should be called within the __init__ function of any class that is derived from ScrolledPanel, once the controls on the panel have been constructed and thus the size of the scrolling area can be determined.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:10 2005 http://epydoc.sf.net


wx.lib.scrolledpanel

Package wx :: Package lib :: Module scrolledpanel

Module wx.lib.scrolledpanel

Classes
ScrolledPanel ScrolledPanel fills a "hole" in the implementation of wx.ScrolledWindow, providing automatic scrollbar and scrolling behavior and the tab traversal management that wxScrolledWindow lacks.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:17 2005 http://epydoc.sf.net


wx.lib.sheet.CCellEditor

Package wx :: Package lib :: Module sheet :: Class CCellEditor
[frames | no frames]

Type CCellEditor

    object --+
             |
GridCellEditor --+
                 |
  PyGridCellEditor --+
                     |
                    CCellEditor

Custom cell editor

Method Summary
 | __init__(self, grid)
 | BeginEdit(self, row, col, grid) Fetch the value from the table and prepare edit control to begin editing.
 | Clone(self) Create a new object which is the copy of this one.
 | Create(self, parent, id, evtHandler) Create the actual edit control.
 | Destroy(self) Final cleanup NOTE: There is no need to everride this if you don't need to do something out of the ordingary.
 | EndEdit(self, row, col, grid) Commit editing the current cell.
 | IsAcceptedKey(self, evt) Return True to allow the given key to start editing.
 | PaintBackground(self, rect, attr) Draws the part of the cell not occupied by the edit control.
 | Reset(self) Reset the value in the control back to its starting value.
 | SetSize(self, rect) Position/size the edit control within the cell rectangle.
 | Show(self, show, attr) Show or hide the edit control.
 | StartingClick(self) If the editor is enabled by clicking on the cell, this method will be called to allow the editor to simulate the click on the control.
 | StartingKey(self, evt) If the editor is enabled by pressing keys on the grid, this will be called to let the editor react to that first key.

Method Details

BeginEdit(self, row, col, grid)

Fetch the value from the table and prepare edit control to begin editing. Set the focus to the edit control. Must Override.

Overrides:
wx.grid.GridCellEditor.BeginEdit

Clone(self)

Create a new object which is the copy of this one. Must Override.

Overrides:
wx.grid.GridCellEditor.Clone

Create(self, parent, id, evtHandler)

Create the actual edit control. Must derive from wxControl. Must Override

Overrides:
wx.grid.GridCellEditor.Create

Destroy(self)

Final cleanup
NOTE: There is no need to everride this if you don't need
      to do something out of the ordingary.
Overrides:
wx.grid.GridCellEditor.Destroy

EndEdit(self, row, col, grid)

Commit editing the current cell. Returns True if the value has changed. If necessary, the control may be destroyed. Must Override.

Overrides:
wx.grid.GridCellEditor.EndEdit

IsAcceptedKey(self, evt)

Return True to allow the given key to start editing. The base class version only checks that the event has no modifiers. F2 is special and will always start the editor.

Overrides:
wx.grid.GridCellEditor.IsAcceptedKey

PaintBackground(self, rect, attr)

Draws the part of the cell not occupied by the edit control.  The
base class version just fills it with background colour from the
attribute.
NOTE: There is no need to everride this if you don't need
      to do something out of the ordingary.
Overrides:
wx.grid.GridCellEditor.PaintBackground

Reset(self)

Reset the value in the control back to its starting value. Must Override.

Overrides:
wx.grid.GridCellEditor.Reset

SetSize(self, rect)

Position/size the edit control within the cell rectangle.

Overrides:
wx.grid.GridCellEditor.SetSize

Show(self, show, attr)

Show or hide the edit control.  Use the attr (if not None)
to set colors or fonts for the control.
NOTE: There is no need to everride this if you don't need
      to do something out of the ordingary.
Overrides:
wx.grid.GridCellEditor.Show

StartingClick(self)

If the editor is enabled by clicking on the cell, this method will be called to allow the editor to simulate the click on the control.

Overrides:
wx.grid.GridCellEditor.StartingClick

StartingKey(self, evt)

If the editor is enabled by pressing keys on the grid, this will be called to let the editor react to that first key.

Overrides:
wx.grid.GridCellEditor.StartingKey

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:26 2005 http://epydoc.sf.net


wx.lib.sheet.CSheet

Package wx :: Package lib :: Module sheet :: Class CSheet

Type CSheet

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
                 Panel --+
                         |
            ScrolledWindow --+
                             |
                          Grid --+
                                 |
                                CSheet

Method Summary
 | __init__(self, parent)
 | Clear(self) Clear the currently selected cells
 | Copy(self) Copy the currently selected cells to the clipboard
 | OnCellChange(self, event)
 | OnColSize(self, event)
 | OnGridSelectCell(self, event) Track cell selections
 | OnLeftClick(self, event) Override left-click behavior to prevent left-click edit initiation
 | OnLeftDoubleClick(self, event) Initiate the cell editor on a double-click
 | OnRangeSelect(self, event) Track which cells are selected so that copy/paste behavior can be implemented
 | OnRightClick(self, event) Move grid cursor when a cell is right-clicked
 | OnRowSize(self, event)
 | Paste(self) Paste the contents of the clipboard into the currently selected cells
 | SetNumberCols(self, numCols) Set the number of columns in the sheet
 | SetNumberRows(self, numRows) Set the number of rows in the sheet

Class Variable Summary

Instance Method Details

Clear(self)

Clear the currently selected cells

Copy(self)

Copy the currently selected cells to the clipboard

OnGridSelectCell(self, event)

Track cell selections

OnLeftClick(self, event)

Override left-click behavior to prevent left-click edit initiation

OnLeftDoubleClick(self, event)

Initiate the cell editor on a double-click

OnRangeSelect(self, event)

Track which cells are selected so that copy/paste behavior can be implemented

OnRightClick(self, event)

Move grid cursor when a cell is right-clicked

Paste(self)

Paste the contents of the clipboard into the currently selected cells

SetNumberCols(self, numCols=1)

Set the number of columns in the sheet

SetNumberRows(self, numRows=1)

Set the number of rows in the sheet

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:02 2005 http://epydoc.sf.net


wx.lib.sheet.CTextCellEditor

Package wx :: Package lib :: Module sheet :: Class CTextCellEditor
[frames | no frames]

Type CTextCellEditor

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
               Control --+
                         |
                  TextCtrl --+
                             |
                            CTextCellEditor

Custom text control for cell editing

Method Summary
 | __init__(self, parent, id, grid)
 | OnChar(self, evt) Customizes char events

Instance Method Details

OnChar(self, evt)

Customizes char events

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:10:49 2005 http://epydoc.sf.net


wx.lib.sheet

Package wx :: Package lib :: Module sheet

Module wx.lib.sheet

Classes
CCellEditor | Custom cell editor
CSheet |
CTextCellEditor | Custom text control for cell editing

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:18 2005 http://epydoc.sf.net


wx.lib.shell.PyShell

Package wx :: Package lib :: Module shell :: Class PyShell

Type PyShell

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
                 Panel --+
                         |
                        PyShell

interactive Python shell with wxPython interface

Method Summary
 | __init__(self, parent, globals, locals, id, pos, size, style, name) create PyShell window
 | OnSetFocus(self, event)
 | OnSize(self, event)
 | ShowException(self) display the traceback for the latest exception
 | ShowSyntaxError(self) display message about syntax error (no traceback here)
 | TryExec(self, source, symbol) Compile and run some source in the interpreter.

Instance Method Details

__init__(self,
          parent,
          globals={'PyShellOutput': <class 'wx.lib.shell.PyShellOutput'>, '...,
          locals={},
          id=-1,
          pos=wx.Point(-1, -1),
          size=wx.Size(-1, -1),
          style=524288,
          name='shell')
(Constructor)

create PyShell window

Overrides:
wx.Panel.__init__

ShowException(self)

display the traceback for the latest exception

ShowSyntaxError(self)

display message about syntax error (no traceback here)

TryExec(self, source, symbol='single')

Compile and run some source in the interpreter.

borrowed from code.InteractiveInterpreter().runsource() as i said above, i would rather like to inherit from that class

returns 1 if more input is required, or 0, otherwise

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:11 2005 http://epydoc.sf.net


wx.lib.shell.PyShellInput

Package wx :: Package lib :: Module shell :: Class PyShellInput
[frames | no frames]

Type PyShellInput

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
                 Panel --+
                         |
                        PyShellInput

PyShell input window

Method Summary
 | __init__(self, parent, shell, id) Create input window
 | Clear(self, event) reset input state
 | OnChar(self, event) called on CHARevent.
 | OnSetFocus(self, event)

Class Variable Summary
str | PS1 = ' Enter Command:'
str | PS2 = '... continue:'

Instance Method Details

__init__(self, parent, shell, id=-1)
(Constructor)

Create input window

shell must be a PyShell object. it is used for exception handling, eval() namespaces, and shell.output is used for output (print's go to overridden stdout)

Overrides:
wx.Panel.__init__

Clear(self, event=None)

reset input state

OnChar(self, event)

called on CHARevent. executes input on newline

Class Variable Details

PS1

Type:
str
Value:
' Enter Command:'

PS2

Type:
str
Value:
'... continue:'

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:05 2005 http://epydoc.sf.net


wx.lib.shell.PyShellOutput

Package wx :: Package lib :: Module shell :: Class PyShellOutput
[frames | no frames]

Type PyShellOutput

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
                 Panel --+
                         |
                        PyShellOutput

PyShell output window

for now, it is based on simple wxTextCtrl, but i'm looking at HTML classes to provide colorized output

Method Summary
 | __init__(self, parent, id)
 | AddText(self, text, style) write text to output window
 | BeginBatch(self) do not refresh display till EndBatch()
 | EndBatch(self) end batch; start updating display immediately
 | flush(self, style) write out all that was left in line buffer
 | OnIdle(self, event) when there's nothing to do, we can update display
 | OnSize(self, event)
 | UpdWindow(self) sync display with text buffer
 | write(self, str, style) stdout-like interface
 | write_exc(self, str, style) write text in "exception" style
 | write_in(self, str, style) write text in "input" style

Class Variable Summary
tuple | erefs = (('&', '&amp;'), ('>', '&gt;'), ('<', '&lt;'), (...
tuple | exc_style = ('<font color="#FF0000"><tt>', '</tt></font>...
int | html_debug = 0
tuple | in_style = (' <font color="#000080"><tt>&gt;&gt;&gt;&nbs...
str | intro = '<H3>wxPython Interactive Shell</H3>\n'
tuple | out_style = ('<tt>', '</tt>\n', '<br>\n')

Instance Method Details

AddText(self, text, style=None)

write text to output window

BeginBatch(self)

do not refresh display till EndBatch()

EndBatch(self)

end batch; start updating display immediately

flush(self, style=None)

write out all that was left in line buffer

OnIdle(self, event)

when there's nothing to do, we can update display

UpdWindow(self)

sync display with text buffer

write(self, str, style=None)

stdout-like interface

write_exc(self, str, style=None)

write text in "exception" style

write_in(self, str, style=None)

write text in "input" style

Class Variable Details

erefs

Type:
tuple
Value:
(('&', '&amp;'), ('>', '&gt;'), ('<', '&lt;'), ('  ', '&nbsp; '))

exc_style

Type:
tuple
Value:
('<font color="#FF0000"><tt>', '</tt></font>\n', '<br>\n')

html_debug

Type:
int
Value:
0

in_style

Type:
tuple
Value:
(' <font color="#000080"><tt>&gt;&gt;&gt;&nbsp;',
 '</tt></font><br>\n',
 '<br>\n...&nbsp;')

intro

Type:
str
Value:
'''<H3>wxPython Interactive Shell</H3>
'''

out_style

Type:
tuple
Value:
('<tt>', '</tt>\n', '<br>\n')

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:39 2005 http://epydoc.sf.net


wx.lib.shell

Package wx :: Package lib :: Module shell

Module wx.lib.shell

wxPython interactive shell

Copyright (c) 1999 SIA "ANK"

this module is free software.  it may be used under same terms as Python itself

Notes:
i would like to use command completion (see rlcompleter library module),
but i cannot load it because i don't have readline...

History:
03-oct-1999 [als] created
04-oct-1999 [als] PyShellOutput.intro moved from __init__ parameters
                  to class attributes; html debug disabled
04-oct-1999 [als] fixed bug with class attributes
                  input prompts and output styles added to customized demo
                  some html cleanups
04-oct-1999 [rpd] Changed to use the new sizers
05-oct-1999 [als] changes inspired by code.InteractiveInterpreter()
                  from Python Library.  if i knew about this class earlier,
                  i would rather inherit from it.
                  renamed to wxPyShell.py since i've renounced the 8.3 scheme

8-10-2001         THIS MODULE IS NOW DEPRECATED.  Please see the most excellent
                  PyCrust package instead.

Classes
PyShell | interactive Python shell with wxPython interface
PyShellInput | PyShell input window
PyShellOutput | PyShell output window

Variable Summary
str | __version__ = '$Revision: 1.5 $'
str | warningmsg = '\\\n\n####################################...

Variable Details

__version__

Type:
str
Value:
'$Revision: 1.5 $'

warningmsg

Type:
str
Value:
'''\\

########################################\\
# THIS MODULE IS NOW DEPRECATED         |
#                                       |
# Please see the most excellent PyCrust |
# package instead.                      |
########################################/
...

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:21 2005 http://epydoc.sf.net


wx.lib.splashscreen.SplashScreen

Package wx :: Package lib :: Module splashscreen :: Class SplashScreen
[frames | no frames]

Type SplashScreen

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
        TopLevelWindow --+
                         |
                     Frame --+
                             |
                            SplashScreen

Method Summary
 | __init__(self, parent, ID, title, style, duration, bitmapfile, callback) parent, ID, title, style -- see wx.Frame...
 | OnCloseWindow(self, event)
 | OnEraseBG(self, event)
 | OnMouseClick(self, event)
 | OnPaint(self, event)
 | OnSplashExitDefault(self, event)

Instance Method Details

__init__(self,
          parent,
          ID=-1,
          title='SplashScreen',
          style=33587200,
          duration=1500,
          bitmapfile='bitmaps/splashscreen.bmp',
          callback=None)
(Constructor)

parent, ID, title, style -- see wx.Frame
duration -- milliseconds to display the splash screen
bitmapfile -- absolute or relative pathname to image file
callback -- if specified, is called when timer completes, callback is
            responsible for closing the splash screen
Overrides:
wx.Frame.__init__

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:38 2005 http://epydoc.sf.net


wx.lib.splashscreen

Package wx :: Package lib :: Module splashscreen

Module wx.lib.splashscreen

A Splash Screen implemented in Python.

NOTE: Now that wxWindows has a wxSplashScrren class and it is wrapped in wxPython this class is deprecated. See the docs for more details.

Classes
SplashScreen

Variable Summary
str warningmsg = "\\\n\n####################################...

Variable Details

warningmsg

Type:
str
Value:
"""\\

#####################################################\\
# THIS MODULE IS NOW DEPRECATED                      |
#                                                    |
# The core wx library now contains an implementation |
# of the 'real' wx.SpashScreen.                      |
#####################################################/
...

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:23 2005 http://epydoc.sf.net


wx.lib.statbmp.GenStaticBitmap

Package wx :: Package lib :: Module statbmp :: Class GenStaticBitmap
[frames | no frames]

Type GenStaticBitmap

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
               Control --+
                         |
                 PyControl --+
                             |
                            GenStaticBitmap

Method Summary
 | __init__(self, parent, ID, bitmap, pos, size, style, name)
 | AcceptsFocus(self) Overridden base class virtual.
 | DoGetBestSize(self) Overridden base class virtual.
 | GetBitmap(self)
 | GetDefaultAttributes(self) Overridden base class virtual.
 | OnEraseBackground(self, event)
 | OnPaint(self, event)
 | SetBitmap(self, bitmap)
 | ShouldInheritColours(self) Overridden base class virtual.

Class Variable Summary
int labelDelta = 1

Instance Method Details

AcceptsFocus(self)

Overridden base class virtual.

Overrides:
wx.Window.AcceptsFocus

DoGetBestSize(self)

Overridden base class virtual. Determines the best size of the control based on the bitmap size.

GetDefaultAttributes(self)

Overridden base class virtual. By default we should use the same font/colour attributes as the native StaticBitmap.

Overrides:
wx.Window.GetDefaultAttributes

ShouldInheritColours(self)

Overridden base class virtual. If the parent has non-default colours then we want this control to inherit them.

Overrides:
wx.Window.ShouldInheritColours

Class Variable Details

labelDelta

Type:
int
Value:
1

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:07 2005 http://epydoc.sf.net


wx.lib.statbmp

Package wx :: Package lib :: Module statbmp

Module wx.lib.statbmp

Classes
GenStaticBitmap

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:18 2005 http://epydoc.sf.net


wx.lib.stattext.GenStaticText

Package wx :: Package lib :: Module stattext :: Class GenStaticText
[frames | no frames]

Type GenStaticText

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
               Control --+
                         |
                 PyControl --+
                             |
                            GenStaticText

Known Subclasses:
HyperLinkCtrl
Method Summary
 | __init__(self, parent, ID, label, pos, size, style, name)
 | AcceptsFocus(self) Overridden base class virtual.
 | DoGetBestSize(self) Overridden base class virtual.
 | GetDefaultAttributes(self) Overridden base class virtual.
 | OnEraseBackground(self, event)
 | OnPaint(self, event)
 | SetFont(self, font) Sets the static text font and updates the control's size to exactly fit the label unless the control has wx.ST_NO_AUTORESIZE flag.
 | SetLabel(self, label) Sets the static text label and updates the control's size to exactly fit the label unless the control has wx.ST_NO_AUTORESIZE flag.
 | ShouldInheritColours(self) Overridden base class virtual.

Class Variable Summary
int labelDelta = 1

Instance Method Details

AcceptsFocus(self)

Overridden base class virtual.

Overrides:
wx.Window.AcceptsFocus

DoGetBestSize(self)

Overridden base class virtual. Determines the best size of the control based on the label size and the current font.

GetDefaultAttributes(self)

Overridden base class virtual. By default we should use the same font/colour attributes as the native StaticText.

Overrides:
wx.Window.GetDefaultAttributes

SetFont(self, font)

Sets the static text font and updates the control's size to exactly fit the label unless the control has wx.ST_NO_AUTORESIZE flag.

Overrides:
wx.Window.SetFont

SetLabel(self, label)

Sets the static text label and updates the control's size to exactly fit the label unless the control has wx.ST_NO_AUTORESIZE flag.

Overrides:
wx.Control.SetLabel

ShouldInheritColours(self)

Overridden base class virtual. If the parent has non-default colours then we want this control to inherit them.

Overrides:
wx.Window.ShouldInheritColours

Class Variable Details

labelDelta

Type:
int
Value:
1

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:03 2005 http://epydoc.sf.net


wx.lib.stattext

Package wx :: Package lib :: Module stattext

Module wx.lib.stattext

Classes
GenStaticText

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:09 2005 http://epydoc.sf.net


wx.lib.throbber.Throbber

Package wx :: Package lib :: Module throbber :: Class Throbber
[frames | no frames]

Type Throbber

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
                 Panel --+
                         |
                   PyPanel --+
                             |
                            Throbber

The first argument is either the name of a file that will be split into frames (a composite image) or a list of strings of image names that will be treated as individual frames. If a single (composite) image is given, then additional information must be provided: the number of frames in the image and the width of each frame. The first frame is treated as the "at rest" frame (it is not shown during animation, but only when Throbber.Rest() is called. A second, single image may be optionally specified to overlay on top of the animation. A label may also be specified to show on top of the animation.

Method Summary
 | __init__(self, parent, id, bitmap, pos, size, frameDelay, frames, frameWidth, label, overlay, reverse, style, name)
 | DoGetBestSize(self)
 | Draw(self, dc)
 | OnDestroyWindow(self, event)
 | OnPaint(self, event)
 | OnTimer(self, event)
 | Rest(self) Stop the animation and return to frame 0
 | Reverse(self) Change the direction of the animation
 | Rotate(self, event)
 | Running(self) Returns True if the animation is running
 | SetFont(self, font) Set the font for the label
 | SetFrameDelay(self, frameDelay) Delay between each frame
 | SetLabel(self, label) Change the text of the label
 | Start(self) Start the animation
 | Stop(self) Stop the animation
 | ToggleLabel(self, state) Toggle the label
 | ToggleOverlay(self, state) Toggle the overlay image

Instance Method Details

Rest(self)

Stop the animation and return to frame 0

Reverse(self)

Change the direction of the animation

Running(self)

Returns True if the animation is running

SetFont(self, font)

Set the font for the label

Overrides:
wx.Window.SetFont

SetFrameDelay(self, frameDelay=0.050000000000000003)

Delay between each frame

SetLabel(self, label)

Change the text of the label

Overrides:
wx.Window.SetLabel

Start(self)

Start the animation

Stop(self)

Stop the animation

ToggleLabel(self, state=None)

Toggle the label

ToggleOverlay(self, state=None)

Toggle the overlay image

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:27 2005 http://epydoc.sf.net


wx.lib.throbber.UpdateThrobberEvent

Package wx :: Package lib :: Module throbber :: Class UpdateThrobberEvent
[frames | no frames]

Type UpdateThrobberEvent

object --+
         |
    Object --+
             |
         Event --+
                 |
           PyEvent --+
                     |
                    UpdateThrobberEvent

Method Summary
__init__(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:11 2005 http://epydoc.sf.net


wx.lib.throbber

Package wx :: Package lib :: Module throbber

Module wx.lib.throbber

A throbber displays an animated image that can be started, stopped, reversed, etc. Useful for showing an ongoing process (like most web browsers use) or simply for adding eye-candy to an application.

Throbbers utilize a wxTimer so that normal processing can continue unencumbered.

Classes
Throbber | The first argument is either the name of a file that will be split into frames (a composite image) or a list of strings of image names that will be treated as individual frames.
UpdateThrobberEvent |

Variable Summary
PyEventBinder | EVT_UPDATE_THROBBER = <wx._core.PyEventBinder object at ...
int | THROBBER_EVENT = 10290

Variable Details

EVT_UPDATE_THROBBER

Type:
PyEventBinder
Value:
<wx._core.PyEventBinder object at 0xb78896cc>

THROBBER_EVENT

Type:
int
Value:
10290

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:36 2005 http://epydoc.sf.net


wx.lib.ticker.Ticker

Package wx :: Package lib :: Module ticker :: Class Ticker

Type Ticker

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
               Control --+
                         |
                 PyControl --+
                             |
                            Ticker

Method Summary
 | __init__(self, parent, id, text, fgcolor, bgcolor, start, ppf, fps, direction, pos, size, style, name)
 | AcceptsFocus(self) Non-interactive, so don't accept focus
 | DoGetBestSize(self) Width we don't care about, height is either -1, or the character height of our text with a little extra padding
 | DrawText(self, dc) Draws the ticker text at the current offset using the provided DC
 | GetDirection(self)
 | GetFPS(self) Update speed of the ticker
 | GetPPF(self) Pixels per frame
 | GetText(self)
 | IsTicking(self) Is the ticker ticking? ie, is the text moving?
 | OnErase(self, evt) Noop because of double buffering
 | OnPaint(self, evt)
 | OnTick(self, evt)
 | SetDirection(self, dir) Sets the direction of the ticker: right to left(rtl) or left to right (ltr)
 | SetFont(self, font)
 | SetFPS(self, fps) Adjust the update speed of the ticker
 | SetPPF(self, ppf) Set the number of pixels per frame the ticker moves - ie, how "jumpy" it is
 | SetText(self, text) Set the ticker text.
 | ShouldInheritColours(self) Don't get colours from our parent...
 | Start(self) Starts the text moving
 | Stop(self) Stop moving the text
 | UpdateExtent(self, dc) Updates the cached text extent if needed

Instance Method Details

AcceptsFocus(self)

Non-interactive, so don't accept focus

Overrides:
wx.Window.AcceptsFocus

DoGetBestSize(self)

Width we don't care about, height is either -1, or the character height of our text with a little extra padding

DrawText(self, dc)

Draws the ticker text at the current offset using the provided DC

GetFPS(self)

Update speed of the ticker

GetPPF(self)

Pixels per frame

IsTicking(self)

Is the ticker ticking? ie, is the text moving?

OnErase(self, evt)

Noop because of double buffering

SetDirection(self, dir)

Sets the direction of the ticker: right to left(rtl) or left to right (ltr)

SetFPS(self, fps)

Adjust the update speed of the ticker

SetPPF(self, ppf)

Set the number of pixels per frame the ticker moves - ie, how "jumpy" it is

SetText(self, text)

Set the ticker text.

ShouldInheritColours(self)

Don't get colours from our parent...

Overrides:
wx.Window.ShouldInheritColours

Start(self)

Starts the text moving

Stop(self)

Stop moving the text

UpdateExtent(self, dc)

Updates the cached text extent if needed

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:10 2005 http://epydoc.sf.net


wx.lib.ticker_xrc.wxTickerXmlHandler

Package wx :: Package lib :: Module ticker_xrc :: Class wxTickerXmlHandler
[frames | no frames]

Type wxTickerXmlHandler

    object --+
             |
        Object --+
                 |
XmlResourceHandler --+
                     |
                    wxTickerXmlHandler

Method Summary
 | __init__(self)
 | CanHandle(self, node)
 | DoCreateResource(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:11 2005 http://epydoc.sf.net


wx.lib.ticker_xrc

Package wx :: Package lib :: Module ticker_xrc

Module wx.lib.ticker_xrc

Classes
wxTickerXmlHandler

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:40 2005 http://epydoc.sf.net


wx.lib.ticker

Package wx :: Package lib :: Module ticker

Module wx.lib.ticker

News-ticker style scrolling text control

Can scroll from right to left or left to right.
Speed of the ticking is controlled by two parameters:
    Frames per Second(FPS): How many times per second the ticker updates
    Pixels per Frame(PPF): How many pixels the text moves each update
Low FPS with high PPF will result in "jumpy" text, lower PPF with higher FPS
is smoother (but blurrier and more CPU intensive) text.
Classes
Ticker

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:17 2005 http://epydoc.sf.net


wx.lib.vtk

Package wx :: Package lib :: Module vtk

Module wx.lib.vtk

VTK is now including a package for using VTK with wxPython, so this module is now officially nothing but ancient history. If for some strange reason you really need this code (I don't know why, it didn't work all that well anyway,) then just remove the triple quotes below. I'm told that the module from Kitware is excellent and so you should really use it. See the URL below to get a copy from CVS.

http://public.kitware.com/cgi-bin/cvsweb.cgi/VTK/Wrapping/Python/vtk/wx/

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:18 2005 http://epydoc.sf.net


wx.lib.wxPlotCanvas.PlotCanvas

Package wx :: Package lib :: Module wxPlotCanvas :: Class PlotCanvas
[frames | no frames]

Type PlotCanvas

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
                    PlotCanvas

Method Summary
 | __init__(self, parent, id, pos, size, style, name)
 | clear(self)
 | draw(self, graphics, xaxis, yaxis, dc)
 | OnPaint(self, event)
 | reconfigure(self, event)
 | redraw(self, dc)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:11 2005 http://epydoc.sf.net


wx.lib.wxPlotCanvas.PlotGraphics

Package wx :: Package lib :: Module wxPlotCanvas :: Class PlotGraphics
[frames | no frames]

Class PlotGraphics

Method Summary
 | __init__(self, objects)
 | __getitem__(self, item)
 | __len__(self)
 | boundingBox(self)
 | draw(self, canvas)
 | scaleAndShift(self, scale, shift)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:07 2005 http://epydoc.sf.net


wx.lib.wxPlotCanvas.PolyLine

Package wx :: Package lib :: Module wxPlotCanvas :: Class PolyLine
[frames | no frames]

Class PolyLine

PolyPoints --+
             |
            PolyLine

Method Summary
 | __init__(self, points, **attr)
 | draw(self, dc)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:51 2005 http://epydoc.sf.net


wx.lib.wxPlotCanvas.PolyMarker

Package wx :: Package lib :: Module wxPlotCanvas :: Class PolyMarker
[frames | no frames]

Class PolyMarker

PolyPoints --+
             |
            PolyMarker

Method Summary
 | __init__(self, points, **attr)
 | draw(self, dc)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:51 2005 http://epydoc.sf.net


wx.lib.wxPlotCanvas.PolyPoints

Package wx :: Package lib :: Module wxPlotCanvas :: Class PolyPoints
[frames | no frames]

Class PolyPoints

Known Subclasses:
PolyLine, PolyMarker
Method Summary
 | __init__(self, points, attr)
 | boundingBox(self)
 | scaleAndShift(self, scale, shift)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:23 2005 http://epydoc.sf.net


wx.lib.wxPlotCanvas

Package wx :: Package lib :: Module wxPlotCanvas

Module wx.lib.wxPlotCanvas

This is a port of Konrad Hinsen's tkPlotCanvas.py plotting module. After thinking long and hard I came up with the name "wxPlotCanvas.py".

This file contains two parts; first the re-usable library stuff, then, after a "if __name__=='__main__'" test, a simple frame and a few default plots for testing.

Harm van der Heijden, feb 1999

Original comment follows below: # This module defines a plot widget for Tk user interfaces. # It supports only elementary line plots at the moment. # See the example at the end for documentation... # # Written by Konrad Hinsen <hinsen@cnrs-orleans.fr> # With contributions from RajGopal Srinivasan <raj@cherubino.med.jhmi.edu> # Last revision: 1998-7-28 #

Classes
PlotCanvas
PlotGraphics
PolyLine
PolyMarker
PolyPoints

Variable Summary
str warningmsg = '\\\n\nTHIS MODULE IS NOW DEPRECATED\n\nThi...

Variable Details

warningmsg

Type:
str
Value:
'''\\

THIS MODULE IS NOW DEPRECATED

This module has been replaced by wxPyPlot, which in wxPython
can be found in wx.lib.plot.py.

'''

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:34 2005 http://epydoc.sf.net


wx.lib.wxpTag.wxpTagHandler

Package wx :: Package lib :: Module wxpTag :: Class wxpTagHandler
[frames | no frames]

Type wxpTagHandler

object --+
         |
    Object --+
             |
HtmlTagHandler --+
                 |
 HtmlWinTagHandler --+
                     |
                    wxpTagHandler

Method Summary
 | __init__(self)
 | GetSupportedTags(self)
 | HandleParamTag(self, tag)
 | HandleTag(self, tag)
 | HandleWxpTag(self, tag)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:31 2005 http://epydoc.sf.net


wx.lib.wxpTag

Package wx :: Package lib :: Module wxpTag

Module wx.lib.wxpTag

wxPython.lib.wxpTag

This module contains a wxHtmlTagHandler that knows how to build and place wxPython widgets onto wxHtmlWindow web pages.

You don't need to use anything in this module directly, just importing it will create the tag handler and add it to any wxHtmlWinParsers created from that time forth.

Tags of the following form are recognised:

<WXP class="classname" [module="modulename"] [width="num"] [height="num"]>
<PARAM name="parameterName" value="parameterValue> ...

</WXP>

where modulename is the name of a module (possibly in package notation) to import and classname is the name of a class in that module to create an instance of. If the module tag-attribute is not given or is an empty string, then wx is used. The width and height attributes are expected to be integers and will be passed to the __init__ method of the class as a wxSize object named size. However, if the width attribute ends with the percent (%) symbol then the value will be used as a percentage of the available width and the wxHtmlWindow will manage the size.

The name-value pairs in all the nested PARAM tags are packaged up as strings into a python dictionary and passed to the __init__ method of the class as keyword arguments. This means that they are all accessible from the __init__ method as regular parameters, or you use the special Python **kw syntax in your __init__ method to get the dictionary directly.

Some parameter values are special and if they are present then they will be converted from strings to alternate datatypes. They are:

id If the value of id can be converted to an integer, it will
be. Otherwise it is assumed to be the name of an integer variable in the module.
colours Any value of the form "#123ABC" will automatically be
converted to a wxColour object.
Py Types Any value begining with "(", "[" or "{" are expected to
be a Python tuple, list, or dictionary and eval() will be used to convert them to that type. If the eval() fails then the original string value will be preserved.
wx Types Any value begining with "wx" is expected to be an attempt
to create a wxPython object, such as a wxSize, etc. The eval() will be used to try and construct the object and if it fails then the original string value will be used instead.

An example:

<wxp module="wx" class="Button">
<param name="label" value="Click here"> <param name="id" value="ID_OK">

</wxp>

Both the begining and ending WXP tags are required.

In the future support will be added for another tag that can be embedded between the two begining and ending WXP tags and will facilitate calling methods of the widget to help initialize it. Additionally, support may be added to fetch the module from a web server as is done with java applets.

Classes
wxpTagHandler

Variable Summary
str | PARAMTAG = 'PARAM'
str | WXPTAG = 'WXP'

Variable Details

PARAMTAG

Type:
str
Value:
'PARAM'

WXPTAG

Type:
str
Value:
'WXP'

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:51 2005 http://epydoc.sf.net


wx.lib

Package wx :: Package lib

Package wx.lib

Submodules
  • analogclock: AnalogClockWindow is a simple analog clock class.
  • analogclockopts: A configuration dialog (frame actually) for the AnalogClockWindow
  • anchors: LayoutAnchors is a class that implements Delphi's Anchors using wx.LayoutConstraints.
  • buttons: This module implements various forms of generic buttons, meaning that they are not built on native controls but are self-drawn.
  • calendar
  • CDate
  • ClickableHtmlWindow: sorry no documentation...
  • colourchooser: PyColourChooser Copyright (C) 2002 Michael Gilfix <mgilfix@eecs.tufts.edu>
  • colourdb: Load addition color names/values into the wx colour database.
  • colourselect: Provides a ColourSelect button that, when clicked, will display a colour selection dialog.
  • dialogs
  • docview
  • editor
  • evtmgr: A module that allows multiple handlers to respond to single wxWidgets events.
  • fancytext: FancyText -- methods for rendering XML specified text
  • filebrowsebutton
  • floatbar: wish, but be warned that dealing with any consequences is entirly up to you.
  • floatcanvas: This is the floatcanvas package.
  • foldmenu
  • foldpanelbar: The FoldPanelBar is a control that contains multiple panels (of type FoldPanelItem) that can be expanded or collapsed.
  • gestures: This is a class to add Mouse Gestures to a program.
  • gridmovers
  • grids: In this module you will find PyGridSizer and PyFlexGridSizer.
  • hyperlink: HyperLinkCtrl is a control for wxPython that acts like a hyper link in a typical browser.
  • imagebrowser
  • imageutils
  • infoframe: infoframe.py Released under wxWindows license etc.
  • intctrl
  • layoutf
  • masked
  • mixins
  • multisash
  • mvctree: MVCTree is a control which handles hierarchical data.
  • newevent: Easy generation of new events classes and binder objects
  • ogl: The Object Graphics Library provides for simple drawing and manipulation of 2D objects.
  • plot: This is a simple light weight plotting module that can be used with Boa or easily integrated into your own wxPython application.
  • popupctl
  • printout
  • pubsub: This module provides a publish-subscribe component that allows listeners to subcribe to messages of a given topic.
  • pydocview
  • pyshell: PyShellWindow is a class that provides an Interactive Interpreter running inside a wxStyledTextCtrl, similar to the Python shell windows found in IDLE and PythonWin.
  • rcsizer: A pure-Python Sizer that lays out items in a grid similar to wx.FlexGridSizer but item position is not implicit but explicitly specified by row and col, and row/col spanning is supported.
  • rightalign: Some time ago, I asked about how to right-align wxTextCtrls.
  • scrolledpanel
  • sheet
  • shell: wxPython interactive shell Copyright (c) 1999 SIA "ANK" this module is free software.
  • splashscreen: A Splash Screen implemented in Python.
  • statbmp
  • stattext
  • throbber: A throbber displays an animated image that can be started, stopped, reversed, etc.
  • ticker: News-ticker style scrolling text control Can scroll from right to left or left to right.
  • ticker_xrc
  • vtk: VTK is now including a package for using VTK with wxPython, so this module is now officially nothing but ancient history.
  • wxPlotCanvas: This is a port of Konrad Hinsen's tkPlotCanvas.py plotting module.
  • wxpTag: wxPython.lib.wxpTag

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:11 2005 http://epydoc.sf.net


wx.Listbook

Package wx :: Class Listbook

Type Listbook

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
               Control --+
                         |
              BookCtrlBase --+
                             |
                            Listbook

Proxy of C++ Listbook class

Method Summary
Listbook | __init__(self, parent, id, pos, size, style, name)
 | __repr__(self)
bool | Create(self, parent, id, pos, size, style, validator, name) Do the 2nd phase and create the GUI control.
ListView | GetListView(self)
bool | IsVertical(self)

Instance Method Details

Create(self,
          parent,
          id=-1,
          pos=DefaultPosition,
          size=DefaultSize,
          style=0,
          name=EmptyString)

Do the 2nd phase and create the GUI control.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

validator
(type=Validator)

name
(type=String)

Returns:
bool
Overrides:
wx.Control.Create (inherited documentation)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:46 2005 http://epydoc.sf.net


wx.ListbookEvent

Package wx :: Class ListbookEvent

Type ListbookEvent

object --+
         |
    Object --+
             |
         Event --+
                 |
      CommandEvent --+
                     |
           NotifyEvent --+
                         |
         BookCtrlBaseEvent --+
                             |
                            ListbookEvent

Proxy of C++ ListbookEvent class

Method Summary
NotifyEvent | __init__(self, commandType, winid) An instance of this class (or one of its derived classes) is sent from a control when the control's state is being changed and the control allows that change to be prevented from happening.
 | __repr__(self)

Method Details

__init__(self,
          commandType=wxEVT_NULL,
          id=0,
          nSel=-1,
          nOldSel=-1)
(Constructor)

An instance of this class (or one of its derived classes) is sent from a control when the control's state is being changed and the control allows that change to be prevented from happening. The event handler can call Veto or Allow to tell the control what to do.

Parameters:
commandType
(type=wxEventType)

winid
(type=int)

Returns:
NotifyEvent
Overrides:
wx.BookCtrlBaseEvent.__init__ (inherited documentation)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:38 2005 http://epydoc.sf.net


wx.ListBox

Package wx :: Class ListBox

Type ListBox

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
               Control --+
                         |
            object --+   |
                     |   |
         ItemContainer --+
                         |
          ControlWithItems --+
                             |
                            ListBox

Known Subclasses:
CheckListBox

Proxy of C++ ListBox class

Method Summary
ListBox | __init__(self, parent, id, pos, size, choices, style, validator, name)
 | __repr__(self)
 | AppendAndEnsureVisible(self, s)
bool | Create(self, parent, id, pos, size, style, validator, name) Do the 2nd phase and create the GUI control.
 | Deselect(self, n)
 | DeselectAll(self, itemToLeaveSelected)
 | EnsureVisible(self, n)
VisualAttributes | GetClassDefaultAttributes(variant) Get the default attributes for this class. (Static method)
PyObject | GetSelections(self)
 | Insert(self, item, pos, clientData) Insert an item into the control before the item at the pos index, optionally associating some data object with the item.
 | InsertItems(self, items, pos)
bool | IsSelected(self, n)
bool | IsSorted(self)
 | Select(self, n) This is the same as SetSelection and exists only because it is slightly more natural for controls which support multiple selection.
 | Set(self, items)
 | SetFirstItem(self, n)
 | SetFirstItemStr(self, s)
 | SetItemBackgroundColour(self, item, c)
 | SetItemFont(self, item, f)
 | SetItemForegroundColour(self, item, c)
 | SetSelection(self, n) Sets the item at index 'n' to be the selected item.
bool | SetStringSelection(self, s, select)

Instance Method Details

Create(self,
          parent,
          id=-1,
          pos=DefaultPosition,
          size=DefaultSize,
          choices=wxPyEmptyStringArray,
          style=0,
          validator=DefaultValidator,
          name=ListBoxNameStr)

Do the 2nd phase and create the GUI control.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

validator
(type=Validator)

name
(type=String)

Returns:
bool
Overrides:
wx.Control.Create (inherited documentation)

Insert(self, item, pos, clientData=None)

Insert an item into the control before the item at the pos index, optionally associating some data object with the item.

Parameters:
item
(type=String)

pos
(type=int)

clientData
(type=PyObject)

Overrides:
wx.ItemContainer.Insert

Select(self, n)

This is the same as SetSelection and exists only because it is slightly more natural for controls which support multiple selection.

Parameters:
n
(type=int)

Overrides:
wx.ItemContainer.Select

SetSelection(self, n, select=True)

Sets the item at index 'n' to be the selected item.

Parameters:
n
(type=int)

Overrides:
wx.ItemContainer.SetSelection (inherited documentation)

Static Method Details

GetClassDefaultAttributes(variant=WINDOW_VARIANT_NORMAL)

Get the default attributes for this class. This is useful if you want to use the same font or colour in your own control as in a standard control -- which is a much better idea than hard coding specific colours or fonts which might look completely out of place on the user's system, especially if it uses themes.

The variant parameter is only relevant under Mac currently and is ignore under other platforms. Under Mac, it will change the size of the returned font. See wx.Window.SetWindowVariant for more about this.

Parameters:
variant
(type=int)

Returns:
VisualAttributes

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:10:49 2005 http://epydoc.sf.net


wx.ListCtrl

Package wx :: Class ListCtrl

Type ListCtrl

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
               Control --+
                         |
                        ListCtrl

Known Subclasses:
ListView

Proxy of C++ ListCtrl class

Method Summary
Control | __init__(self, parent, id, pos, size, style, validator, name) Create a Control.
 | __repr__(self)
 | Append(self, entry) Append an item to the list control.
bool | Arrange(self, flag)
 | AssignImageList(self, imageList, which)
 | ClearAll(self)
 | ClearColumnImage(self, col)
bool | Create(self, parent, id, pos, size, style, validator, name) Do the 2nd phase and create the GUI control.
bool | DeleteAllColumns(self)
bool | DeleteAllItems(self)
bool | DeleteColumn(self, col)
bool | DeleteItem(self, item)
 | EditLabel(self, item)
bool | EnsureVisible(self, item)
long | FindItem(self, start, str, partial)
long | FindItemAtPos(self, start, pt, direction)
long | FindItemData(self, start, data)
 | Focus(self, idx) Focus and show the given item
VisualAttributes | GetClassDefaultAttributes(variant) Get the default attributes for this class. (Static method)
ListItem | GetColumn(self, col)
int | GetColumnCount(self)
int | GetColumnWidth(self, col)
int | GetCountPerPage(self)
 | GetFirstSelected(self, *args) return first selected item, or -1 when none
 | GetFocusedItem(self) get the currently focused item or -1 if none
ImageList | GetImageList(self, which)
ListItem | GetItem(self, itemId, col)
Colour | GetItemBackgroundColour(self, item)
int | GetItemCount(self)
long | GetItemData(self, item)
Point | GetItemPosition(self, item)
Rect | GetItemRect(self, item, code)
Size | GetItemSpacing(self)
int | GetItemState(self, item, stateMask)
String | GetItemText(self, item)
Colour | GetItemTextColour(self, item)
Window | GetMainWindow(self)
long | GetNextItem(self, item, geometry, state)
 | GetNextSelected(self, item) return subsequent selected items, or -1 when no more
int | GetSelectedItemCount(self)
Colour | GetTextColour(self)
long | GetTopItem(self)
Rect | GetViewRect(self)
(item, where) | HitTest(point) in the second return value (see wx.LIST_HITTEST flags.)
bool | InReportView(self)
long | InsertColumn(self, col, heading, format, width)
long | InsertColumnInfo(self, col, info)
long | InsertColumnItem(self, col, info)
long | InsertImageItem(self, index, imageIndex)
long | InsertImageStringItem(self, index, label, imageIndex)
long | InsertItem(self, info)
long | InsertStringItem(self, index, label)
 | IsSelected(self, idx) return True if the item is selected
bool | IsVirtual(self)
 | RefreshItem(self, item)
 | RefreshItems(self, itemFrom, itemTo)
bool | ScrollList(self, dx, dy)
 | Select(self, idx, on) [de]select an item
bool | SetBackgroundColour(self, col) Sets the background colour of the window.
bool | SetColumn(self, col, item)
 | SetColumnImage(self, col, image)
bool | SetColumnWidth(self, col, width)
bool | SetForegroundColour(self, col) Sets the foreground colour of the window.
 | SetImageList(self, imageList, which)
bool | SetItem(self, info)
 | SetItemBackgroundColour(self, item, col)
 | SetItemCount(self, count)
bool | SetItemData(self, item, data)
bool | SetItemImage(self, item, image, selImage)
bool | SetItemPosition(self, item, pos)
 | SetItemSpacing(self, spacing, isSmall)
bool | SetItemState(self, item, state, stateMask)
 | SetItemText(self, item, str)
 | SetItemTextColour(self, item, col)
 | SetSingleStyle(self, style, add)
long | SetStringItem(self, index, col, label, imageId)
 | SetTextColour(self, col)
 | SetWindowStyleFlag(self, style) Sets the style of the window.
bool | SortItems(self, func)

Instance Method Details

__init__(self,
          parent,
          id=-1,
          pos=DefaultPosition,
          size=DefaultSize,
          style=LC_ICON,
          validator=DefaultValidator,
          name=ListCtrlNameStr)
(Constructor)

Create a Control. Normally you should only call this from a subclass' __init__ as a plain old wx.Control is not very useful.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

validator
(type=Validator)

name
(type=String)

Returns:
Control
Overrides:
wx.Control.__init__ (inherited documentation)

Append(self, entry)

Append an item to the list control. The entry parameter should be a sequence with an item for each column

Create(self,
          parent,
          id=-1,
          pos=DefaultPosition,
          size=DefaultSize,
          style=LC_ICON,
          validator=DefaultValidator,
          name=ListCtrlNameStr)

Do the 2nd phase and create the GUI control.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

validator
(type=Validator)

name
(type=String)

Returns:
bool
Overrides:
wx.Control.Create

Focus(self, idx)

Focus and show the given item

GetFirstSelected(self, *args)

return first selected item, or -1 when none

GetFocusedItem(self)

get the currently focused item or -1 if none

GetNextSelected(self, item)

return subsequent selected items, or -1 when no more

HitTest(point)

Determines which item (if any) is at the specified point, giving
in the second return value (see wx.LIST_HITTEST flags.)
Parameters:
point
(type=Point)

Returns:
(item, where)
Overrides:
wx.Window.HitTest

IsSelected(self, idx)

return True if the item is selected

Select(self, idx, on=1)

[de]select an item

SetBackgroundColour(self, col)

Sets the background colour of the window. Returns True if the colour was changed. The background colour is usually painted by the default EVT_ERASE_BACKGROUND event handler function under Windows and automatically under GTK. Using wx.NullColour will reset the window to the default background colour.

Note that setting the background colour may not cause an immediate refresh, so you may wish to call ClearBackground or Refresh after calling this function.

Using this function will disable attempts to use themes for this window, if the system supports them. Use with care since usually the themes represent the appearance chosen by the user to be used for all applications on the system.

Parameters:
col
(type=Colour)

Returns:
bool
Overrides:
wx.Window.SetBackgroundColour

SetForegroundColour(self, col)

Sets the foreground colour of the window. Returns True is the colour was changed. The interpretation of foreground colour is dependent on the window class; it may be the text colour or other colour, or it may not be used at all.

Parameters:
col
(type=Colour)

Returns:
bool
Overrides:
wx.Window.SetForegroundColour

SetWindowStyleFlag(self, style)

Sets the style of the window. Please note that some styles cannot be changed after the window creation and that Refresh() might need to be called after changing the others for the change to take place immediately.

Parameters:
style
(type=long)

Overrides:
wx.Window.SetWindowStyleFlag

Static Method Details

GetClassDefaultAttributes(variant=WINDOW_VARIANT_NORMAL)

Get the default attributes for this class. This is useful if you want to use the same font or colour in your own control as in a standard control -- which is a much better idea than hard coding specific colours or fonts which might look completely out of place on the user's system, especially if it uses themes.

The variant parameter is only relevant under Mac currently and is ignore under other platforms. Under Mac, it will change the size of the returned font. See wx.Window.SetWindowVariant for more about this.

Parameters:
variant
(type=int)

Returns:
VisualAttributes

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:16 2005 http://epydoc.sf.net


wx.ListEvent

Package wx :: Class ListEvent

Type ListEvent

object --+
         |
    Object --+
             |
         Event --+
                 |
      CommandEvent --+
                     |
           NotifyEvent --+
                         |
                        ListEvent

Proxy of C++ ListEvent class

Method Summary
NotifyEvent | __init__(self, commandType, winid) An instance of this class (or one of its derived classes) is sent from a control when the control's state is being changed and the control allows that change to be prevented from happening.
 | __repr__(self)
long | GetCacheFrom(self)
long | GetCacheTo(self)
int | GetCode(self)
int | GetColumn(self)
long | GetData(self)
int | GetImage(self)
long | GetIndex(self)
ListItem | GetItem(self)
int | GetKeyCode(self)
String | GetLabel(self)
long | GetMask(self)
Point | GetPoint(self)
Point | GetPosition(self)
String | GetText(self)
bool | IsEditCancelled(self)
 | SetEditCanceled(self, editCancelled)

Property Summary
 | m_code
 | m_col
 | m_item
 | m_itemIndex
 | m_oldItemIndex
 | m_pointDrag

Method Details

__init__(self, commandType=wxEVT_NULL, id=0)
(Constructor)

An instance of this class (or one of its derived classes) is sent from a control when the control's state is being changed and the control allows that change to be prevented from happening. The event handler can call Veto or Allow to tell the control what to do.

Parameters:
commandType
(type=wxEventType)

winid
(type=int)

Returns:
NotifyEvent
Overrides:
wx.NotifyEvent.__init__ (inherited documentation)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:40 2005 http://epydoc.sf.net


wx.ListItemAttr

Package wx :: Class ListItemAttr

Type ListItemAttr

object --+
         |
        ListItemAttr

Proxy of C++ ListItemAttr class

Method Summary
ListItemAttr | __init__(self, colText, colBack, font)
 | __repr__(self)
 | Destroy(self)
Colour | GetBackgroundColour(self)
Font | GetFont(self)
Colour | GetTextColour(self)
bool | HasBackgroundColour(self)
bool | HasFont(self)
bool | HasTextColour(self)
 | SetBackgroundColour(self, colBack)
 | SetFont(self, font)
 | SetTextColour(self, colText)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:50 2005 http://epydoc.sf.net


wx.ListItem

Package wx :: Class ListItem

Type ListItem

object --+
         |
    Object --+
             |
            ListItem

Proxy of C++ ListItem class

Method Summary
ListItem | __init__(self)
 | __del__(self)
 | __repr__(self)
 | Clear(self)
 | ClearAttributes(self)
int | GetAlign(self)
ListItemAttr | GetAttributes(self)
Colour | GetBackgroundColour(self)
int | GetColumn(self)
long | GetData(self)
Font | GetFont(self)
long | GetId(self)
int | GetImage(self)
long | GetMask(self)
long | GetState(self)
String | GetText(self)
Colour | GetTextColour(self)
int | GetWidth(self)
bool | HasAttributes(self)
 | SetAlign(self, align)
 | SetBackgroundColour(self, colBack)
 | SetColumn(self, col)
 | SetData(self, data)
 | SetFont(self, font)
 | SetId(self, id)
 | SetImage(self, image)
 | SetMask(self, mask)
 | SetState(self, state)
 | SetStateMask(self, stateMask)
 | SetText(self, text)
 | SetTextColour(self, colText)
 | SetWidth(self, width)

Property Summary
 | m_col
 | m_data
 | m_format
 | m_image
 | m_itemId
 | m_mask
 | m_state
 | m_stateMask
 | m_text
 | m_width

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:18 2005 http://epydoc.sf.net


wx.ListView

Package wx :: Class ListView

Type ListView

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
               Control --+
                         |
                  ListCtrl --+
                             |
                            ListView

Proxy of C++ ListView class

Method Summary
Control | __init__(self, parent, id, pos, size, style, validator, name) Create a Control.
 | __repr__(self)
 | ClearColumnImage(self, col)
bool | Create(self, parent, id, pos, size, style, validator, name) Do the 2nd phase and create the GUI control.
 | Focus(self, index)
long | GetFirstSelected(self)
long | GetFocusedItem(self)
long | GetNextSelected(self, item)
bool | IsSelected(self, index)
 | Select(self, n, on)
 | SetColumnImage(self, col, image)

Instance Method Details

__init__(self,
          parent,
          id=-1,
          pos=DefaultPosition,
          size=DefaultSize,
          style=LC_REPORT,
          validator=DefaultValidator,
          name=ListCtrlNameStr)
(Constructor)

Create a Control. Normally you should only call this from a subclass' __init__ as a plain old wx.Control is not very useful.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

validator
(type=Validator)

name
(type=String)

Returns:
Control
Overrides:
wx.ListCtrl.__init__ (inherited documentation)

Create(self,
          parent,
          id=-1,
          pos=DefaultPosition,
          size=DefaultSize,
          style=LC_REPORT,
          validator=DefaultValidator,
          name=ListCtrlNameStr)

Do the 2nd phase and create the GUI control.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

validator
(type=Validator)

name
(type=String)

Returns:
bool
Overrides:
wx.ListCtrl.Create

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:10:54 2005 http://epydoc.sf.net


wx.Locale

Package wx :: Class Locale

Type Locale

object --+
         |
        Locale

Proxy of C++ Locale class

Method Summary
Locale | __init__(self, language, flags)
 | __del__(self)
 | __nonzero__(self)
 | __repr__(self)
bool | AddCatalog(self, szDomain)
 | AddCatalogLookupPathPrefix(prefix) (Static method)
 | AddLanguage(info) (Static method)
LanguageInfo | FindLanguageInfo(locale) (Static method)
String | GetCanonicalName(self)
int | GetLanguage(self)
LanguageInfo | GetLanguageInfo(lang) (Static method)
String | GetLanguageName(lang) (Static method)
String | GetLocale(self)
String | GetName(self)
String | GetString(self, szOrigString, szDomain)
String | GetSysName(self)
int | GetSystemEncoding() (Static method)
String | GetSystemEncodingName() (Static method)
int | GetSystemLanguage() (Static method)
 | Init(self, *_args, **_kwargs)
bool | Init1(self, szName, szShort, szLocale, bLoadDefault, bConvertEncoding)
bool | Init2(self, language, flags)
bool | IsLoaded(self, szDomain)
bool | IsOk(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:12 2005 http://epydoc.sf.net


wx.LogChain

Package wx :: Class LogChain

Type LogChain

object --+
         |
       Log --+
             |
            LogChain

Proxy of C++ LogChain class

Method Summary
LogChain | __init__(self, logger)
 | __repr__(self)
Log | GetOldLog(self)
bool | IsPassingMessages(self)
 | PassMessages(self, bDoPass)
 | SetLog(self, logger)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:27 2005 http://epydoc.sf.net


wx.Log

Package wx :: Class Log

Type Log

object --+
         |
        Log

Known Subclasses:
LogChain, LogGui, LogStderr, LogTextCtrl, LogWindow, PyLog

Proxy of C++ Log class

Method Summary
Log | __init__(self)
 | __repr__(self)
 | AddTraceMask(str) (Static method)
 | ClearTraceMasks() (Static method)
 | Destroy(self)
 | DontCreateOnDemand() (Static method)
bool | EnableLogging(doIt) (Static method)
 | Flush(self)
 | FlushActive() (Static method)
Log | GetActiveTarget() (Static method)
wxLogLevel | GetLogLevel() (Static method)
wxChar | GetTimestamp() (Static method)
wxTraceMask | GetTraceMask() (Static method)
wxArrayString | GetTraceMasks() (Static method)
bool | GetVerbose() (Static method)
bool | IsAllowedTraceMask(mask) (Static method)
bool | IsEnabled() (Static method)
 | OnLog(level, szString, t) (Static method)
 | RemoveTraceMask(str) (Static method)
 | Resume() (Static method)
Log | SetActiveTarget(pLogger) (Static method)
 | SetLogLevel(logLevel) (Static method)
 | SetTimestamp(ts) (Static method)
 | SetTraceMask(ulMask) (Static method)
 | SetVerbose(bVerbose) (Static method)
 | Suspend() (Static method)
String | TimeStamp() (Static method)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:33 2005 http://epydoc.sf.net


wx.LogGui

Package wx :: Class LogGui

Type LogGui

object --+
         |
       Log --+
             |
            LogGui

Proxy of C++ LogGui class

Method Summary
LogGui | __init__(self)
 | __repr__(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:51 2005 http://epydoc.sf.net


wx.LogNull

Package wx :: Class LogNull

Type LogNull

object --+
         |
        LogNull

Proxy of C++ LogNull class

Method Summary
LogNull | __init__(self)
 | __del__(self)
 | __repr__(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:38 2005 http://epydoc.sf.net


wx.LogStderr

Package wx :: Class LogStderr

Type LogStderr

object --+
         |
       Log --+
             |
            LogStderr

Proxy of C++ LogStderr class

Method Summary
LogStderr | __init__(self)
 | __repr__(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:59 2005 http://epydoc.sf.net


wx.LogTextCtrl

Package wx :: Class LogTextCtrl

Type LogTextCtrl

object --+
         |
       Log --+
             |
            LogTextCtrl

Proxy of C++ LogTextCtrl class

Method Summary
LogTextCtrl | __init__(self, pTextCtrl)
 | __repr__(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:45 2005 http://epydoc.sf.net


wx.LogWindow

Package wx :: Class LogWindow

Type LogWindow

object --+
         |
       Log --+
             |
            LogWindow

Proxy of C++ LogWindow class

Method Summary
LogWindow | __init__(self, pParent, szTitle, bShow, bPassToOld)
 | __repr__(self)
wxFrame | GetFrame(self)
Log | GetOldLog(self)
bool | IsPassingMessages(self)
 | PassMessages(self, bDoPass)
 | Show(self, bShow)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:03 2005 http://epydoc.sf.net


wx.Mask

Package wx :: Class Mask

Type Mask

object --+
         |
    Object --+
             |
            Mask

This class encapsulates a monochrome mask bitmap, where the masked area is black and the unmasked area is white. When associated with a bitmap and drawn in a device context, the unmasked area of the bitmap will be drawn, and the masked area will not be drawn.

A mask may be associated with a wx.Bitmap. It is used in wx.DC.DrawBitmap or wx.DC.Blit when the source device context is a wx.MemoryDC with a wx.Bitmap selected into it that contains a mask.

Method Summary
Mask | __init__(self, bitmap, colour) Constructs a mask from a wx.Bitmap and a wx.Colour in that bitmap that indicates the transparent portions of the mask.
 | __repr__(self)

Method Details

__init__(self, bitmap, colour=NullColour)
(Constructor)

Constructs a mask from a wx.Bitmap and a wx.Colour in that bitmap that indicates the transparent portions of the mask. In other words, the pixels in bitmap that match colour will be the transparent portions of the mask. If no colour or an invalid colour is passed then BLACK is used.

Parameters:
bitmap
(type=Bitmap)

colour
(type=Colour)

Returns:
Mask
Overrides:
wx.Object.__init__

See Also:

wx.Bitmap, wx.Colour

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:02 2005 http://epydoc.sf.net


wx.MaximizeEvent

Package wx :: Class MaximizeEvent

Type MaximizeEvent

object --+
         |
    Object --+
             |
         Event --+
                 |
                MaximizeEvent

An EVT_MAXIMIZE event is sent when a frame is maximized or restored.

Method Summary
MaximizeEvent | __init__(self, id) An EVT_MAXIMIZE event is sent when a frame is maximized or restored.
 | __repr__(self)

Method Details

__init__(self, id=0)
(Constructor)

An EVT_MAXIMIZE event is sent when a frame is maximized or restored.

Parameters:
id
(type=int)

Returns:
MaximizeEvent
Overrides:
wx.Event.__init__

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:17 2005 http://epydoc.sf.net


wx.MDIChildFrame

Package wx :: Class MDIChildFrame

Type MDIChildFrame

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
        TopLevelWindow --+
                         |
                     Frame --+
                             |
                            MDIChildFrame

Known Subclasses:
DocMDIChildFrame, DocMDIChildFrame

Proxy of C++ MDIChildFrame class

Method Summary
MDIChildFrame | __init__(self, parent, id, title, pos, size, style, name)
 | __repr__(self)
 | Activate(self)
bool | Create(self, parent, id, pos, size, style, name) Create the GUI part of the Window for 2-phase creation mode.
 | Maximize(self, maximize)
 | Restore(self)

Instance Method Details

Create(self,
          parent,
          id=-1,
          title=EmptyString,
          pos=DefaultPosition,
          size=DefaultSize,
          style=DEFAULT_FRAME_STYLE,
          name=FrameNameStr)

Create the GUI part of the Window for 2-phase creation mode.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

name
(type=String)

Returns:
bool
Overrides:
wx.Frame.Create (inherited documentation)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:22 2005 http://epydoc.sf.net


wx.MDIClientWindow

Package wx :: Class MDIClientWindow

Type MDIClientWindow

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
                    MDIClientWindow

Proxy of C++ MDIClientWindow class

Method Summary
Window | __init__(self, parent, id, pos, size, style, name) Construct and show a generic Window.
 | __repr__(self)
bool | Create(self, parent, id, pos, size, style, name) Create the GUI part of the Window for 2-phase creation mode.

Instance Method Details

__init__(self, parent, style=0)
(Constructor)

Construct and show a generic Window.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

name
(type=String)

Returns:
Window
Overrides:
wx.Window.__init__ (inherited documentation)

Create(self, parent, style=0)

Create the GUI part of the Window for 2-phase creation mode.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

name
(type=String)

Returns:
bool
Overrides:
wx.Window.Create (inherited documentation)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:10:49 2005 http://epydoc.sf.net


wx.MDIParentFrame

Package wx :: Class MDIParentFrame

Type MDIParentFrame

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
        TopLevelWindow --+
                         |
                     Frame --+
                             |
                            MDIParentFrame

Known Subclasses:
DocMDIParentFrame

Proxy of C++ MDIParentFrame class

Method Summary
MDIParentFrame | __init__(self, parent, id, title, pos, size, style, name)
 | __repr__(self)
 | ActivateNext(self)
 | ActivatePrevious(self)
 | ArrangeIcons(self)
 | Cascade(self)
bool | Create(self, parent, id, pos, size, style, name) Create the GUI part of the Window for 2-phase creation mode.
MDIChildFrame | GetActiveChild(self)
MDIClientWindow | GetClientWindow(self)
Window | GetToolBar(self)
 | Tile(self, orient)

Instance Method Details

Create(self,
          parent,
          id=-1,
          title=EmptyString,
          pos=DefaultPosition,
          size=DefaultSize,
          style=wxDEFAULT_FRAME_STYLE|wxVSCROLL|wxHSCROLL,
          name=FrameNameStr)

Create the GUI part of the Window for 2-phase creation mode.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

name
(type=String)

Returns:
bool
Overrides:
wx.Frame.Create (inherited documentation)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:16 2005 http://epydoc.sf.net


wx.media.MediaCtrl

Package wx :: Module media :: Class MediaCtrl

Type MediaCtrl

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
               Control --+
                         |
                        MediaCtrl

Proxy of C++ MediaCtrl class

Method Summary
Control | __init__(self, parent, id, pos, size, style, validator, name) Create a Control.
 | __repr__(self)
bool | Create(self, parent, id, pos, size, style, validator, name) Do the 2nd phase and create the GUI control.
double | GetPlaybackRate(self)
int | GetState(self)
double | GetVolume(self)
wxFileOffset | Length(self)
bool | Load(self, fileName)
bool | LoadFromURI(self, location)
bool | Pause(self)
bool | Play(self)
wxFileOffset | Seek(self, where, mode)
bool | SetPlaybackRate(self, dRate)
bool | SetVolume(self, dVolume)
bool | Stop(self)
wxFileOffset | Tell(self)

Instance Method Details

__init__(self,
          parent,
          id=-1,
          fileName=EmptyString,
          pos=DefaultPosition,
          size=DefaultSize,
          style=0,
          szBackend=EmptyString,
          validator=DefaultValidator,
          name=MediaCtrlNameStr)
(Constructor)

Create a Control. Normally you should only call this from a subclass' __init__ as a plain old wx.Control is not very useful.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

validator
(type=Validator)

name
(type=String)

Returns:
Control
Overrides:
wx.Control.__init__ (inherited documentation)

Create(self,
          parent,
          id=-1,
          fileName=EmptyString,
          pos=DefaultPosition,
          size=DefaultSize,
          style=0,
          szBackend=EmptyString,
          validator=DefaultValidator,
          name=MediaCtrlNameStr)

Do the 2nd phase and create the GUI control.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

validator
(type=Validator)

name
(type=String)

Returns:
bool
Overrides:
wx.Control.Create (inherited documentation)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:46 2005 http://epydoc.sf.net


wx.media.MediaEvent

Package wx :: Module media :: Class MediaEvent

Type MediaEvent

object --+
         |
    Object --+
             |
         Event --+
                 |
      CommandEvent --+
                     |
           NotifyEvent --+
                         |
                        MediaEvent

Proxy of C++ MediaEvent class

Method Summary
NotifyEvent | __init__(self, commandType, winid) An instance of this class (or one of its derived classes) is sent from a control when the control's state is being changed and the control allows that change to be prevented from happening.
 | __repr__(self)

Method Details

__init__(self, commandType=wxEVT_NULL, id=0)
(Constructor)

An instance of this class (or one of its derived classes) is sent from a control when the control's state is being changed and the control allows that change to be prevented from happening. The event handler can call Veto or Allow to tell the control what to do.

Parameters:
commandType
(type=wxEventType)

winid
(type=int)

Returns:
NotifyEvent
Overrides:
wx.NotifyEvent.__init__ (inherited documentation)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:05 2005 http://epydoc.sf.net


wx.media

Package wx :: Module media

Module wx.media

Classes for a media player control

Classes
MediaCtrl | Proxy of C++ MediaCtrl class
MediaEvent | Proxy of C++ MediaEvent class

Function Summary
MediaCtrl PreMediaCtrl()

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:10 2005 http://epydoc.sf.net


wx.MemoryDC

Package wx :: Class MemoryDC

Type MemoryDC

object --+
         |
    Object --+
             |
            DC --+
                 |
                MemoryDC

Known Subclasses:
BitmapBuffer, BufferedDC

A memory device context provides a means to draw graphics onto a bitmap. A bitmap must be selected into the new memory DC before it may be used for anything. Typical usage is as follows:

dc = wx.MemoryDC()
dc.SelectObject(bitmap)
# draw on the dc usign any of the Draw methods
dc.SelectObject(wx.NullBitmap)
# the bitmap now contains wahtever was drawn upon it

Note that the memory DC must be deleted (or the bitmap selected out of it) before a bitmap can be reselected into another memory DC.

Method Summary
MemoryDC | __init__(self) Constructs a new memory device context.
 | __repr__(self)
 | SelectObject(self, bitmap) Selects the bitmap into the device context, to use as the memory bitmap.

Method Details

__init__(self)
(Constructor)

Constructs a new memory device context.

Use the Ok member to test whether the constructor was successful in creating a usable device context. Don't forget to select a bitmap into the DC before drawing on it.

Returns:
MemoryDC
Overrides:
wx.DC.__init__

See Also:

MemoryDCFromDC

SelectObject(self, bitmap)

Selects the bitmap into the device context, to use as the memory bitmap. Selecting the bitmap into a memory DC allows you to draw into the DC, and therefore the bitmap, and also to use Blit to copy the bitmap to a window.

If the argument is wx.NullBitmap (or some other uninitialised wx.Bitmap) the current bitmap is selected out of the device context, and the original bitmap restored, allowing the current bitmap to be destroyed safely.

Parameters:
bitmap
(type=Bitmap)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:10:54 2005 http://epydoc.sf.net


wx.MemoryFSHandler

Package wx :: Class MemoryFSHandler

Type MemoryFSHandler

          object --+
                   |
CPPFileSystemHandler --+
                       |
                      MemoryFSHandler

Proxy of C++ MemoryFSHandler class

Method Summary
MemoryFSHandler | __init__(self)
 | __repr__(self)
 | AddFile(filename, dataItem, imgType) Add 'file' to the memory filesystem. (Static method)
bool | CanOpen(self, location)
String | FindFirst(self, spec, flags)
String | FindNext(self)
FSFile | OpenFile(self, fs, location)
 | RemoveFile(filename) (Static method)

Static Method Details

AddFile(filename, dataItem, imgType=-1)

Add 'file' to the memory filesystem. The dataItem parameter can either be a wx.Bitmap, wx.Image or a string that can contain arbitrary data. If a bitmap or image is used then the imgType parameter should specify what kind of image file it should be written as, wx.BITMAP_TYPE_PNG, etc.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:10:53 2005 http://epydoc.sf.net


wx.MenuBar

Package wx :: Class MenuBar

Type MenuBar

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
                    MenuBar

Proxy of C++ MenuBar class

Method Summary
Window | __init__(self, parent, id, pos, size, style, name) Construct and show a generic Window.
 | __repr__(self)
bool | Append(self, menu, title)
 | Attach(self, frame)
 | Check(self, id, check)
 | Detach(self)
bool | Enable(self, enable) Enable or disable the window for user input.
 | EnableTop(self, pos, enable)
MenuItem | FindItemById(self, id)
int | FindMenu(self, title)
int | FindMenuItem(self, menu, item)
wxFrame | GetFrame(self)
String | GetHelpString(self, id)
String | GetLabel(self) Generic way of getting a label from any window, for identification purposes.
String | GetLabelTop(self, pos)
Menu | GetMenu(self, pos)
size_t | GetMenuCount(self)
bool | Insert(self, pos, menu, title)
bool | IsAttached(self)
bool | IsChecked(self, id)
bool | IsEnabled(self) Returns true if the window is enabled for input, false otherwise.
bool | IsEnabledTop(self, pos)
Menu | Remove(self, pos)
Menu | Replace(self, pos, menu, title)
 | SetHelpString(self, id, helpString)
 | SetLabel(self, label) Set the text which the window shows in its label if applicable.
 | SetLabelTop(self, pos, label)

Instance Method Details

__init__(self, style=0)
(Constructor)

Construct and show a generic Window.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

name
(type=String)

Returns:
Window
Overrides:
wx.Window.__init__ (inherited documentation)

Enable(self, id, enable)

Enable or disable the window for user input. Note that when a parent window is disabled, all of its children are disabled as well and they are reenabled again when the parent is. Returns true if the window has been enabled or disabled, false if nothing was done, i.e. if the window had already been in the specified state.

Parameters:
enable
(type=bool)

Returns:
bool
Overrides:
wx.Window.Enable (inherited documentation)

GetLabel(self, id)

Generic way of getting a label from any window, for identification purposes. The interpretation of this function differs from class to class. For frames and dialogs, the value returned is the title. For buttons or static text controls, it is the button text. This function can be useful for meta-programs such as testing tools or special-needs access programs)which need to identify windows by name.

Returns:
String
Overrides:
wx.Window.GetLabel (inherited documentation)

IsEnabled(self, id)

Returns true if the window is enabled for input, false otherwise.

Returns:
bool
Overrides:
wx.Window.IsEnabled (inherited documentation)

SetLabel(self, id, label)

Set the text which the window shows in its label if applicable.

Parameters:
label
(type=String)

Overrides:
wx.Window.SetLabel (inherited documentation)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:04 2005 http://epydoc.sf.net


wx.Menu

Package wx :: Class Menu

Type Menu

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
                Menu

Known Subclasses:
PopupDivisionMenu

Proxy of C++ Menu class

Method Summary
Menu | __init__(self, title, style)
 | __repr__(self)
MenuItem | Append(self, id, text, help, kind)
MenuItem | AppendCheckItem(self, id, text, help)
MenuItem | AppendItem(self, item)
MenuItem | AppendMenu(self, id, text, submenu, help)
MenuItem | AppendRadioItem(self, id, text, help)
MenuItem | AppendSeparator(self)
 | Attach(self, menubar)
 | Break(self)
 | Check(self, id, check)
bool | Delete(self, id)
bool | DeleteItem(self, item)
 | Destroy(self) Deletes the C++ object this Python object is a proxy for.
bool | DestroyId(self, id) Deletes the C++ object this Python object is a proxy for.
bool | DestroyItem(self, item) Deletes the C++ object this Python object is a proxy for.
 | Detach(self)
 | Enable(self, id, enable)
int | FindItem(self, item)
MenuItem | FindItemById(self, id)
MenuItem | FindItemByPosition(self, position)
EvtHandler | GetEventHandler(self)
String | GetHelpString(self, id)
Window | GetInvokingWindow(self)
String | GetLabel(self, id)
MenuBar | GetMenuBar(self)
size_t | GetMenuItemCount(self)
PyObject | GetMenuItems(self)
Menu | GetParent(self)
long | GetStyle(self)
String | GetTitle(self)
MenuItem | Insert(self, pos, id, text, help, kind)
MenuItem | InsertCheckItem(self, pos, id, text, help)
MenuItem | InsertItem(self, pos, item)
MenuItem | InsertMenu(self, pos, id, text, submenu, help)
MenuItem | InsertRadioItem(self, pos, id, text, help)
MenuItem | InsertSeparator(self, pos)
bool | IsAttached(self)
bool | IsChecked(self, id)
bool | IsEnabled(self, id)
MenuItem | Prepend(self, id, text, help, kind)
MenuItem | PrependCheckItem(self, id, text, help)
MenuItem | PrependItem(self, item)
MenuItem | PrependMenu(self, id, text, submenu, help)
MenuItem | PrependRadioItem(self, id, text, help)
MenuItem | PrependSeparator(self)
MenuItem | Remove(self, id)
MenuItem | RemoveItem(self, item)
 | SetEventHandler(self, handler)
 | SetHelpString(self, id, helpString)
 | SetInvokingWindow(self, win)
 | SetLabel(self, id, label)
 | SetParent(self, parent)
 | SetTitle(self, title)
 | UpdateUI(self, source)

Method Details

Destroy(self)

Deletes the C++ object this Python object is a proxy for.

Overrides:
wx.Object.Destroy

DestroyId(self, id)

Deletes the C++ object this Python object is a proxy for.

Parameters:
id
(type=int)

Returns:
bool

DestroyItem(self, item)

Deletes the C++ object this Python object is a proxy for.

Parameters:
item
(type=MenuItem)

Returns:
bool

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:44 2005 http://epydoc.sf.net


wx.MenuEvent

Package wx :: Class MenuEvent

Type MenuEvent

object --+
         |
    Object --+
             |
         Event --+
                 |
                MenuEvent

This class is used for a variety of menu-related events. Note that these do not include menu command events, which are handled by sending wx.CommandEvent objects.

The default handler for wx.EVT_MENU_HIGHLIGHT displays menu item help text in the first field of the status bar.

Events

wx.EVT_MENU_OPEN | A menu is about to be opened. On Windows, this is only sent once for each navigation of the menubar (up until all menus have closed).
wx.EVT_MENU_CLOSE | A menu has been just closed.
wx.EVT_MENU_HIGHLIGHT | Sent when the menu item with the specified id has been highlighted: used by default to show help prompts in the wx.Frame's status bar.
wx.EVT_MENU_HIGHLIGHT_ALL | Can be used to catch the menu highlight event for all menu items.
Method Summary
MenuEvent | __init__(self, type, winid, menu) Constructor
 | __repr__(self)
Menu | GetMenu(self) Returns the menu which is being opened or closed.
int | GetMenuId(self) Returns the menu identifier associated with the event.
bool | IsPopup(self) Returns True if the menu which is being opened or closed is a popup menu, False if it is a normal one.

Method Details

__init__(self,
          type=wxEVT_NULL,
          winid=0,
          menu=None)
(Constructor)

Constructor

Parameters:
type
(type=wxEventType)

winid
(type=int)

menu
(type=Menu)

Returns:
MenuEvent
Overrides:
wx.Event.__init__

GetMenu(self)

Returns the menu which is being opened or closed. This method should only be used with the OPEN and CLOSE events.

Returns:
Menu

GetMenuId(self)

Returns the menu identifier associated with the event. This method should be only used with the HIGHLIGHT events.

Returns:
int

IsPopup(self)

Returns True if the menu which is being opened or closed is a popup menu, False if it is a normal one. This method should only be used with the OPEN and CLOSE events.

Returns:
bool

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:32 2005 http://epydoc.sf.net


wx.MenuItem

Package wx :: Class MenuItem

Type MenuItem

object --+
         |
    Object --+
             |
            MenuItem

Proxy of C++ MenuItem class

Method Summary
MenuItem | __init__(self, parentMenu, id, text, help, kind, subMenu)
 | __repr__(self)
 | Check(self, check)
 | Enable(self, enable)
AcceleratorEntry | GetAccel(self)
Colour | GetBackgroundColour(self)
Bitmap | GetBitmap(self)
int | GetDefaultMarginWidth() (Static method)
Bitmap | GetDisabledBitmap(self)
Font | GetFont(self)
String | GetHelp(self)
int | GetId(self)
int | GetKind(self)
String | GetLabel(self)
String | GetLabelFromText(text) (Static method)
int | GetMarginWidth(self)
Menu | GetMenu(self)
Menu | GetSubMenu(self)
String | GetText(self)
Colour | GetTextColour(self)
bool | IsCheckable(self)
bool | IsChecked(self)
bool | IsEnabled(self)
bool | IsOwnerDrawn(self)
bool | IsSeparator(self)
bool | IsSubMenu(self)
 | ResetOwnerDrawn(self)
 | SetAccel(self, accel)
 | SetBackgroundColour(self, colBack)
 | SetBitmap(self, bitmap)
 | SetBitmaps(self, bmpChecked, bmpUnchecked)
 | SetCheckable(self, checkable)
 | SetDisabledBitmap(self, bmpDisabled)
 | SetFont(self, font)
 | SetHelp(self, str)
 | SetId(self, id)
 | SetKind(self, kind)
 | SetMarginWidth(self, nWidth)
 | SetMenu(self, menu)
 | SetOwnerDrawn(self, ownerDrawn)
 | SetSubMenu(self, menu)
 | SetText(self, str)
 | SetTextColour(self, colText)
 | Toggle(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:38 2005 http://epydoc.sf.net


wx.MessageDialog

Package wx :: Class MessageDialog

Type MessageDialog

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
        TopLevelWindow --+
                         |
                    Dialog --+
                             |
                            MessageDialog

This class provides a simple dialog that shows a single or multi-line message, with a choice of OK, Yes, No and/or Cancel buttons.

Window Styles

wx.OK | Show an OK button.
wx.CANCEL | Show a Cancel button.
wx.YES_NO | Show Yes and No buttons.
wx.YES_DEFAULT | Used with wxYES_NO, makes Yes button the default - which is the default behaviour.
wx.NO_DEFAULT | Used with wxYES_NO, makes No button the default.
wx.ICON_EXCLAMATION | Shows an exclamation mark icon.
wx.ICON_HAND | Shows an error icon.
wx.ICON_ERROR | Shows an error icon - the same as wxICON_HAND.
wx.ICON_QUESTION | Shows a question mark icon.
wx.ICON_INFORMATION | Shows an information (i) icon.
wx.STAY_ON_TOP | The message box stays on top of all other window, even those of the other applications (Windows only).
Method Summary
MessageDialog | __init__(self, parent, message, caption, style, pos) Constructor, use ShowModal to display the dialog.
 | __repr__(self)

Instance Method Details

__init__(self, parent, message, caption=MessageBoxCaptionStr, style=wxOK|wxCANCEL|wxCENTRE, pos=DefaultPosition)
(Constructor)

Constructor, use ShowModal to display the dialog.

Parameters:
parent
(type=Window)

message
(type=String)

caption
(type=String)

style
(type=long)

pos
(type=Point)

Returns:
MessageDialog
Overrides:
wx.Dialog.__init__

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:45 2005 http://epydoc.sf.net


wx.MetaFile

Package wx :: Class MetaFile

Type MetaFile

object --+
         |
    Object --+
             |
            MetaFile

Proxy of C++ MetaFile class

Method Summary
MetaFile | __init__(self, filename)
 | __repr__(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:12 2005 http://epydoc.sf.net


wx.MetafileDataObject

Package wx :: Class MetafileDataObject

Type MetafileDataObject

  object --+
           |
  DataObject --+
               |
DataObjectSimple --+
                   |
                  MetafileDataObject

Proxy of C++ MetafileDataObject class

Method Summary
DataObjectSimple | __init__(self, format) Constructor accepts the supported format (none by default) which may also be set later with SetFormat.
 | __repr__(self)

Class Variable Summary

Method Details

__init__(self)
(Constructor)

Constructor accepts the supported format (none by default) which may also be set later with SetFormat.

Parameters:
format
(type=DataFormat)

Returns:
DataObjectSimple
Overrides:
wx.DataObjectSimple.__init__ (inherited documentation)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:09 2005 http://epydoc.sf.net


wx.MetaFileDC

Package wx :: Class MetaFileDC

Type MetaFileDC

object --+
         |
    Object --+
             |
            DC --+
                 |
                MetaFileDC

Proxy of C++ MetaFileDC class

Method Summary
MetaFileDC | __init__(self, filename, width, height, description)
 | __repr__(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:17 2005 http://epydoc.sf.net


wx.MimeTypesManager

Package wx :: Class MimeTypesManager

Type MimeTypesManager

object --+
         |
        MimeTypesManager

Proxy of C++ MimeTypesManager class

Method Summary
MimeTypesManager | __init__(self)
 | __del__(self)
 | __repr__(self)
 | AddFallback(self, ft)
FileType | Associate(self, ftInfo)
 | ClearData(self)
PyObject | EnumAllFileTypes(self)
FileType | GetFileTypeFromExtension(self, ext)
FileType | GetFileTypeFromMimeType(self, mimeType)
 | Initialize(self, mailcapStyle, extraDir)
bool | IsOfType(mimeType, wildcard) (Static method)
bool | ReadMailcap(self, filename, fallback)
bool | ReadMimeTypes(self, filename)
bool | Unassociate(self, ft)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:48 2005 http://epydoc.sf.net


wx.MiniFrame

Package wx :: Class MiniFrame

Type MiniFrame

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
        TopLevelWindow --+
                         |
                     Frame --+
                             |
                            MiniFrame

Proxy of C++ MiniFrame class

Method Summary
MiniFrame | __init__(self, parent, id, title, pos, size, style, name)
 | __repr__(self)
bool | Create(self, parent, id, pos, size, style, name) Create the GUI part of the Window for 2-phase creation mode.

Instance Method Details

Create(self,
          parent,
          id=-1,
          title=EmptyString,
          pos=DefaultPosition,
          size=DefaultSize,
          style=DEFAULT_FRAME_STYLE,
          name=FrameNameStr)

Create the GUI part of the Window for 2-phase creation mode.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

name
(type=String)

Returns:
bool
Overrides:
wx.Frame.Create (inherited documentation)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:46 2005 http://epydoc.sf.net


wx.MirrorDC

Package wx :: Class MirrorDC

Type MirrorDC

object --+
         |
    Object --+
             |
            DC --+
                 |
                MirrorDC

wx.MirrorDC is a simple wrapper class which is always associated with a real wx.DC object and either forwards all of its operations to it without changes (no mirroring takes place) or exchanges x and y coordinates which makes it possible to reuse the same code to draw a figure and its mirror -- i.e. reflection related to the diagonal line x == y.

Method Summary
MirrorDC | __init__(self, dc, mirror) Creates a mirrored DC associated with the real dc.
 | __repr__(self)

Method Details

__init__(self, dc, mirror)
(Constructor)

Creates a mirrored DC associated with the real dc. Everything drawn on the wx.MirrorDC will appear on the dc, and will be mirrored if mirror is True.

Parameters:
dc
(type=DC)

mirror
(type=bool)

Returns:
MirrorDC
Overrides:
wx.DC.__init__

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:03 2005 http://epydoc.sf.net


wx.MouseCaptureChangedEvent

Package wx :: Class MouseCaptureChangedEvent

Type MouseCaptureChangedEvent

object --+
         |
    Object --+
             |
         Event --+
                 |
                MouseCaptureChangedEvent

An mouse capture changed event (EVT_MOUSE_CAPTURE_CHANGED) is sent to a window that loses its mouse capture. This is called even if wx.Window.ReleaseMouse was called by the application code. Handling this event allows an application to cater for unexpected capture releases which might otherwise confuse mouse handling code.

This event is implemented under Windows only.

Method Summary
MouseCaptureChangedEvent | __init__(self, winid, gainedCapture) Constructor
 | __repr__(self)
Window | GetCapturedWindow(self) Returns the window that gained the capture, or None if it was a non-wxWidgets window.

Method Details

__init__(self, winid=0, gainedCapture=None)
(Constructor)

Constructor

Parameters:
winid
(type=int)

gainedCapture
(type=Window)

Returns:
MouseCaptureChangedEvent
Overrides:
wx.Event.__init__

GetCapturedWindow(self)

Returns the window that gained the capture, or None if it was a non-wxWidgets window.

Returns:
Window

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:44 2005 http://epydoc.sf.net


wx.MouseEvent

Package wx :: Class MouseEvent

Type MouseEvent

object --+
         |
    Object --+
             |
         Event --+
                 |
                MouseEvent

This event class contains information about the events generated by the mouse: they include mouse buttons press and release events and mouse move events.

All mouse events involving the buttons use wx.MOUSE_BTN_LEFT for the left mouse button, wx.MOUSE_BTN_MIDDLE for the middle one and wx.MOUSE_BTN_RIGHT for the right one. Note that not all mice have a middle button so a portable application should avoid relying on the events from it.

Note the difference between methods like LeftDown and LeftIsDown: the former returns true when the event corresponds to the left mouse button click while the latter returns true if the left mouse button is currently being pressed. For example, when the user is dragging the mouse you can use LeftIsDown to test whether the left mouse button is (still) depressed. Also, by convention, if LeftDown returns true, LeftIsDown will also return true in wxWidgets whatever the underlying GUI behaviour is (which is platform-dependent). The same applies, of course, to other mouse buttons as well.

Events

EVT_LEFT_DOWN | Left mouse button down event. The handler of this event should normally call event.Skip() to allow the default processing to take place as otherwise the window under mouse wouldn't get the focus.
EVT_LEFT_UP | Left mouse button up event
EVT_LEFT_DCLICK | Left mouse button double click event
EVT_MIDDLE_DOWN | Middle mouse button down event
EVT_MIDDLE_UP | Middle mouse button up event
EVT_MIDDLE_DCLICK | Middle mouse button double click event
EVT_RIGHT_DOWN | Right mouse button down event
EVT_RIGHT_UP | Right mouse button up event
EVT_RIGHT_DCLICK | Right mouse button double click event
EVT_MOTION | Event sent when the mouse is moving
EVT_ENTER_WINDOW | Event sent when the mouse enters the boundaries of a window.
EVT_LEAVE_WINDOW | Sent when the mouse leaves the window's bounds
EVT_MOUSEWHEEL | Mouse scroll wheel event
EVT_MOUSE_EVENTS | Binds all mouse events at once.
Method Summary
MouseEvent | __init__(self, mouseType) Constructs a wx.MouseEvent.
 | __repr__(self)
bool | AltDown(self) Returns true if the Alt key was down at the time of the event.
bool | Button(self, button) Returns true if the identified mouse button is changing state.
bool | ButtonDClick(self, but) If the argument is omitted, this returns true if the event was any mouse double click event.
bool | ButtonDown(self, but) If the argument is omitted, this returns true if the event was any mouse button down event.
bool | ButtonIsDown(self, but)
bool | ButtonUp(self, but) If the argument is omitted, this returns true if the event was any mouse button up event.
bool | CmdDown(self) "Cmd" is a pseudo key which is the same as Control for PC and Unix platforms but the special "Apple" (a.k.a as "Command") key on Macs.
bool | ControlDown(self) Returns true if the control key was down at the time of the event.
bool | Dragging(self) Returns true if this was a dragging event (motion while a button is depressed).
bool | Entering(self) Returns true if the mouse was entering the window.
int | GetButton(self) Returns the mouse button which generated this event or wx.MOUSE_BTN_NONE if no button is involved (for mouse move, enter or leave event, for example).
int | GetLinesPerAction(self) Returns the configured number of lines (or whatever) to be scrolled per wheel action.
Point | GetLogicalPosition(self, dc) Returns the logical mouse position in pixels (i.e.
Point | GetPosition(self) Returns the pixel position of the mouse in window coordinates when the event happened.
(x,y) | GetPositionTuple() Returns the pixel position of the mouse in window coordinates when the event happened.
int | GetWheelDelta(self) Get wheel delta, normally 120.
int | GetWheelRotation(self) Get wheel rotation, positive or negative indicates direction of rotation.
int | GetX(self) Returns X coordinate of the physical mouse event position.
int | GetY(self) Returns Y coordinate of the physical mouse event position.
bool | IsButton(self) Returns true if the event was a mouse button event (not necessarily a button down event - that may be tested using ButtonDown).
bool | IsPageScroll(self) Returns true if the system has been setup to do page scrolling with the mouse wheel instead of line scrolling.
bool | Leaving(self) Returns true if the mouse was leaving the window.
bool | LeftDClick(self) Returns true if the event was a left button double click.
bool | LeftDown(self) Returns true if the left mouse button state changed to down.
bool | LeftIsDown(self) Returns true if the left mouse button is currently down, independent of the current event type.
bool | LeftUp(self) Returns true if the left mouse button state changed to up.
bool | MetaDown(self) Returns true if the Meta key was down at the time of the event.
bool | MiddleDClick(self) Returns true if the event was a middle button double click.
bool | MiddleDown(self) Returns true if the middle mouse button state changed to down.
bool | MiddleIsDown(self) Returns true if the middle mouse button is currently down, independent of the current event type.
bool | MiddleUp(self) Returns true if the middle mouse button state changed to up.
bool | Moving(self) Returns true if this was a motion event and no mouse buttons were pressed.
bool | RightDClick(self) Returns true if the event was a right button double click.
bool | RightDown(self) Returns true if the right mouse button state changed to down.
bool | RightIsDown(self) Returns true if the right mouse button is currently down, independent of the current event type.
bool | RightUp(self) Returns true if the right mouse button state changed to up.
bool | ShiftDown(self) Returns true if the Shift key was down at the time of the event.

Property Summary
 | m_altDown
 | m_controlDown
 | m_leftDown
 | m_linesPerAction
 | m_metaDown
 | m_middleDown
 | m_rightDown
 | m_shiftDown
 | m_wheelDelta
 | m_wheelRotation
 | m_x
 | m_y

Method Details

__init__(self, mouseType=wxEVT_NULL)
(Constructor)

Constructs a wx.MouseEvent. Valid event types are:

  • wxEVT_ENTER_WINDOW
  • wxEVT_LEAVE_WINDOW
  • wxEVT_LEFT_DOWN
  • wxEVT_LEFT_UP
  • wxEVT_LEFT_DCLICK
  • wxEVT_MIDDLE_DOWN
  • wxEVT_MIDDLE_UP
  • wxEVT_MIDDLE_DCLICK
  • wxEVT_RIGHT_DOWN
  • wxEVT_RIGHT_UP
  • wxEVT_RIGHT_DCLICK
  • wxEVT_MOTION
  • wxEVT_MOUSEWHEEL
Parameters:
mouseType
(type=wxEventType)

Returns:
MouseEvent
Overrides:
wx.Event.__init__

AltDown(self)

Returns true if the Alt key was down at the time of the event.

Returns:
bool

Button(self, button)

Returns true if the identified mouse button is changing state. Valid values of button are:

wx.MOUSE_BTN_LEFT | check if left button was pressed
wx.MOUSE_BTN_MIDDLE | check if middle button was pressed
wx.MOUSE_BTN_RIGHT | check if right button was pressed
wx.MOUSE_BTN_ANY | check if any button was pressed
Parameters:
button
(type=int)

Returns:
bool

ButtonDClick(self, but=MOUSE_BTN_ANY)

If the argument is omitted, this returns true if the event was any mouse double click event. Otherwise the argument specifies which double click event to check for (see Button for the possible values).

Parameters:
but
(type=int)

Returns:
bool

ButtonDown(self, but=MOUSE_BTN_ANY)

If the argument is omitted, this returns true if the event was any mouse button down event. Otherwise the argument specifies which button-down event shold be checked for (see Button for the possible values).

Parameters:
but
(type=int)

Returns:
bool

ButtonUp(self, but=MOUSE_BTN_ANY)

If the argument is omitted, this returns true if the event was any mouse button up event. Otherwise the argument specifies which button up event to check for (see Button for the possible values).

Parameters:
but
(type=int)

Returns:
bool

CmdDown(self)

"Cmd" is a pseudo key which is the same as Control for PC and Unix platforms but the special "Apple" (a.k.a as "Command") key on Macs. It often makes sense to use it instead of, say, ControlDown because Cmd key is used for the same thing under Mac as Ctrl elsewhere. The Ctrl key still exists, it's just not used for this purpose. So for non-Mac platforms this is the same as ControlDown and Macs this is the same as MetaDown.

Returns:
bool

ControlDown(self)

Returns true if the control key was down at the time of the event.

Returns:
bool

Dragging(self)

Returns true if this was a dragging event (motion while a button is depressed).

Returns:
bool

Entering(self)

Returns true if the mouse was entering the window.

Returns:
bool

GetButton(self)

Returns the mouse button which generated this event or wx.MOUSE_BTN_NONE if no button is involved (for mouse move, enter or leave event, for example). Otherwise wx.MOUSE_BTN_LEFT is returned for the left button down, up and double click events, wx.MOUSE_BTN_MIDDLE and wx.MOUSE_BTN_RIGHT for the same events for the middle and the right buttons respectively.

Returns:
int

GetLinesPerAction(self)

Returns the configured number of lines (or whatever) to be scrolled per wheel action. Defaults to three.

Returns:
int

GetLogicalPosition(self, dc)

Returns the logical mouse position in pixels (i.e. translated according to the translation set for the DC, which usually indicates that the window has been scrolled).

Parameters:
dc
(type=DC)

Returns:
Point

GetPosition(self)

Returns the pixel position of the mouse in window coordinates when the event happened.

Returns:
Point

GetPositionTuple()

Returns the pixel position of the mouse in window coordinates when the event happened.

Returns:
(x,y)

GetWheelDelta(self)

Get wheel delta, normally 120. This is the threshold for action to be taken, and one such action (for example, scrolling one increment) should occur for each delta.

Returns:
int

GetWheelRotation(self)

Get wheel rotation, positive or negative indicates direction of rotation. Current devices all send an event when rotation is equal to +/-WheelDelta, but this allows for finer resolution devices to be created in the future. Because of this you shouldn't assume that one event is equal to 1 line or whatever, but you should be able to either do partial line scrolling or wait until +/-WheelDelta rotation values have been accumulated before scrolling.

Returns:
int

GetX(self)

Returns X coordinate of the physical mouse event position.

Returns:
int

GetY(self)

Returns Y coordinate of the physical mouse event position.

Returns:
int

IsButton(self)

Returns true if the event was a mouse button event (not necessarily a button down event - that may be tested using ButtonDown).

Returns:
bool

IsPageScroll(self)

Returns true if the system has been setup to do page scrolling with the mouse wheel instead of line scrolling.

Returns:
bool

Leaving(self)

Returns true if the mouse was leaving the window.

Returns:
bool

LeftDClick(self)

Returns true if the event was a left button double click.

Returns:
bool

LeftDown(self)

Returns true if the left mouse button state changed to down.

Returns:
bool

LeftIsDown(self)

Returns true if the left mouse button is currently down, independent of the current event type.

Please notice that it is not the same as LeftDown which returns true if the left mouse button was just pressed. Rather, it describes the state of the mouse button before the event happened.

This event is usually used in the mouse event handlers which process "move mouse" messages to determine whether the user is (still) dragging the mouse.

Returns:
bool

LeftUp(self)

Returns true if the left mouse button state changed to up.

Returns:
bool

MetaDown(self)

Returns true if the Meta key was down at the time of the event.

Returns:
bool

MiddleDClick(self)

Returns true if the event was a middle button double click.

Returns:
bool

MiddleDown(self)

Returns true if the middle mouse button state changed to down.

Returns:
bool

MiddleIsDown(self)

Returns true if the middle mouse button is currently down, independent of the current event type.

Returns:
bool

MiddleUp(self)

Returns true if the middle mouse button state changed to up.

Returns:
bool

Moving(self)

Returns true if this was a motion event and no mouse buttons were pressed. If any mouse button is held pressed, then this method returns false and Dragging returns true.

Returns:
bool

RightDClick(self)

Returns true if the event was a right button double click.

Returns:
bool

RightDown(self)

Returns true if the right mouse button state changed to down.

Returns:
bool

RightIsDown(self)

Returns true if the right mouse button is currently down, independent of the current event type.

Returns:
bool

RightUp(self)

Returns true if the right mouse button state changed to up.

Returns:
bool

ShiftDown(self)

Returns true if the Shift key was down at the time of the event.

Returns:
bool

Property Details

m_altDown

Get Method:
MouseEvent_m_altDown_get(...)
Set Method:
MouseEvent_m_altDown_set(...)

m_controlDown

Get Method:
MouseEvent_m_controlDown_get(...)
Set Method:
MouseEvent_m_controlDown_set(...)

m_leftDown

Get Method:
MouseEvent_m_leftDown_get(...)
Set Method:
MouseEvent_m_leftDown_set(...)

m_linesPerAction

Get Method:
MouseEvent_m_linesPerAction_get(...)
Set Method:
MouseEvent_m_linesPerAction_set(...)

m_metaDown

Get Method:
MouseEvent_m_metaDown_get(...)
Set Method:
MouseEvent_m_metaDown_set(...)

m_middleDown

Get Method:
MouseEvent_m_middleDown_get(...)
Set Method:
MouseEvent_m_middleDown_set(...)

m_rightDown

Get Method:
MouseEvent_m_rightDown_get(...)
Set Method:
MouseEvent_m_rightDown_set(...)

m_shiftDown

Get Method:
MouseEvent_m_shiftDown_get(...)
Set Method:
MouseEvent_m_shiftDown_set(...)

m_wheelDelta

Get Method:
MouseEvent_m_wheelDelta_get(...)
Set Method:
MouseEvent_m_wheelDelta_set(...)

m_wheelRotation

Get Method:
MouseEvent_m_wheelRotation_get(...)
Set Method:
MouseEvent_m_wheelRotation_set(...)

m_x

Get Method:
MouseEvent_m_x_get(...)
Set Method:
MouseEvent_m_x_set(...)

m_y

Get Method:
MouseEvent_m_y_get(...)
Set Method:
MouseEvent_m_y_set(...)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:11 2005 http://epydoc.sf.net


wx.MoveEvent

Package wx :: Class MoveEvent

Type MoveEvent

object --+
         |
    Object --+
             |
         Event --+
                 |
                MoveEvent

This event object is sent for EVT_MOVE event bindings when a window is moved to a new position.

Method Summary
MoveEvent | __init__(self, pos, winid) Constructor.
 | __repr__(self)
Point | GetPosition(self) Returns the position of the window generating the move change event.
Rect | GetRect(self)
 | SetPosition(self, pos)
 | SetRect(self, rect)

Property Summary
 | m_pos
 | m_rect

Method Details

__init__(self, pos=DefaultPosition, winid=0)
(Constructor)

Constructor.

Parameters:
pos
(type=Point)

winid
(type=int)

Returns:
MoveEvent
Overrides:
wx.Event.__init__

GetPosition(self)

Returns the position of the window generating the move change event.

Returns:
Point

Property Details

m_pos

Get Method:
GetPosition(self)
Set Method:
SetPosition(self, pos)

m_rect

Get Method:
GetRect(self)
Set Method:
SetRect(self, rect)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:45 2005 http://epydoc.sf.net


wx.MultiChoiceDialog

Package wx :: Class MultiChoiceDialog

Type MultiChoiceDialog

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
        TopLevelWindow --+
                         |
                    Dialog --+
                             |
                            MultiChoiceDialog

A simple dialog with a multi selection listbox.

Method Summary
MultiChoiceDialog | __init__(self, parent, message, caption, choices, style, pos) Constructor.
 | __repr__(self)
[selections] | GetSelections() Returns a list of integers representing the items that are selected.
 | SetSelections(selections) Specify the items in the list that should be selected, using a list of integers.

Instance Method Details

__init__(self, parent, message, caption, choices=EmptyList, style=CHOICEDLG_STYLE, pos=DefaultPosition)
(Constructor)

Constructor. Use the ShowModal method to show the dialog.

Parameters:
parent - The parent window.
(type=Window)

message - Text to display above the list of selections.
(type=String)

caption - Text to use in the title bar of the dialog.
(type=String)

choices - A list of strings or unicode objects that the user is allowed to choose from.
(type=List)

style - Styles to apply to the dialog. The default value is equivallent to wx.DEFAULT_DIALOG_STYLE|wx.RESIZE_BORDER|wx.OK|wx.CANCEL|wx.CENTER.
(type=long)

pos - Where to position the dialog (not used on Windows)
(type=Point)

Returns:
MultiChoiceDialog
Overrides:
wx.Dialog.__init__

GetSelections()

Returns a list of integers representing the items that are selected. If an item is selected then its index will appear in the list.

Returns:
[selections]

SetSelections(selections)

Specify the items in the list that should be selected, using a list of integers. The list should specify the indexes of the items that should be selected.

Parameters:
selections
(type=List)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:03 2005 http://epydoc.sf.net


wx.MutexGuiLocker

Package wx :: Class MutexGuiLocker

Type MutexGuiLocker

object --+
         |
        MutexGuiLocker

Proxy of C++ MutexGuiLocker class

Method Summary
MutexGuiLocker | __init__(self)
 | __del__(self)
 | __repr__(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:46 2005 http://epydoc.sf.net


wx.NativeEncodingInfo

Package wx :: Class NativeEncodingInfo

Type NativeEncodingInfo

object --+
         |
        NativeEncodingInfo

Proxy of C++ NativeEncodingInfo class

Method Summary
NativeEncodingInfo | __init__(self)
 | __del__(self)
 | __repr__(self)
bool | FromString(self, s)
String | ToString(self)

Property Summary
 | encoding
 | facename

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:39 2005 http://epydoc.sf.net


wx.NativeFontInfo

Package wx :: Class NativeFontInfo

Type NativeFontInfo

object --+
         |
        NativeFontInfo

Proxy of C++ NativeFontInfo class

Method Summary
NativeFontInfo | __init__(self)
 | __del__(self)
 | __repr__(self)
String | __str__(self)
bool | FromString(self, s)
bool | FromUserString(self, s)
int | GetEncoding(self)
String | GetFaceName(self)
int | GetFamily(self)
int | GetPointSize(self)
int | GetStyle(self)
bool | GetUnderlined(self)
int | GetWeight(self)
 | Init(self)
 | InitFromFont(self, font)
 | SetEncoding(self, encoding)
 | SetFaceName(self, facename)
 | SetFamily(self, family)
 | SetPointSize(self, pointsize)
 | SetStyle(self, style)
 | SetUnderlined(self, underlined)
 | SetWeight(self, weight)
String | ToString(self)
String | ToUserString(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:48 2005 http://epydoc.sf.net


wx.NavigationKeyEvent

Package wx :: Class NavigationKeyEvent

Type NavigationKeyEvent

object --+
         |
    Object --+
             |
         Event --+
                 |
                NavigationKeyEvent

EVT_NAVIGATION_KEY events are used to control moving the focus between widgets, otherwise known as tab-traversal. You woudl normally not catch navigation events in applications as there are already appropriate handlers in wx.Dialog and wx.Panel, but you may find it useful to send navigation events in certain situations to change the focus in certain ways, although it's probably easier to just call wx.Window.Navigate.

Method Summary
NavigationKeyEvent | __init__(self)
 | __repr__(self)
Window | GetCurrentFocus(self) Returns the child window which currenty has the focus.
bool | GetDirection(self) Returns True if the direction is forward, False otherwise.
bool | IsFromTab(self) Returns True if the navigation event is originated from the Tab key.
bool | IsWindowChange(self) Returns True if window change is allowed.
 | SetCurrentFocus(self, win) Set the window that has the focus.
 | SetDirection(self, forward) Specify the direction that the navigation should take.
 | SetFlags(self, flags) Set the navigation flags to a combination of the following:
 | SetFromTab(self, bIs) Set to true under MSW if the event was generated using the tab key.
 | SetWindowChange(self, ischange) Specify if the navigation should be able to change parent windows.

Class Variable Summary
int | FromTab = 4
int | IsBackward = 0
int | IsForward = 1
int | WinChange = 2

Method Details

GetCurrentFocus(self)

Returns the child window which currenty has the focus. May be None.

Returns:
Window

GetDirection(self)

Returns True if the direction is forward, False otherwise.

Returns:
bool

IsFromTab(self)

Returns True if the navigation event is originated from the Tab key.

Returns:
bool

IsWindowChange(self)

Returns True if window change is allowed.

Returns:
bool

SetCurrentFocus(self, win)

Set the window that has the focus.

Parameters:
win
(type=Window)

SetDirection(self, forward)

Specify the direction that the navigation should take. Usually the difference between using Tab and Shift-Tab.

Parameters:
forward
(type=bool)

SetFlags(self, flags)

Set the navigation flags to a combination of the following:

  • wx.NavigationKeyEvent.IsBackward
  • wx.NavigationKeyEvent.IsForward
  • wx.NavigationKeyEvent.WinChange
  • wx.NavigationKeyEvent.FromTab
Parameters:
flags
(type=long)

SetFromTab(self, bIs)

Set to true under MSW if the event was generated using the tab key. This is required for proper navogation over radio buttons.

Parameters:
bIs
(type=bool)

SetWindowChange(self, ischange)

Specify if the navigation should be able to change parent windows. For example, changing notebook pages, etc. This is usually implemented by using Control-Tab.

Parameters:
ischange
(type=bool)

Class Variable Details

FromTab

Type:
int
Value:
4

IsBackward

Type:
int
Value:
0

IsForward

Type:
int
Value:
1

WinChange

Type:
int
Value:
2

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:10:54 2005 http://epydoc.sf.net


wx.NcPaintEvent

Package wx :: Class NcPaintEvent

Type NcPaintEvent

object --+
         |
    Object --+
             |
         Event --+
                 |
                NcPaintEvent

Proxy of C++ NcPaintEvent class

Method Summary
NcPaintEvent | __init__(self, winid)
 | __repr__(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:26 2005 http://epydoc.sf.net


wx.Notebook

Package wx :: Class Notebook

Type Notebook

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
               Control --+
                         |
              BookCtrlBase --+
                             |
                            Notebook

Known Subclasses:
EditorNotebook, EditorShellNotebook

Proxy of C++ Notebook class

Method Summary
Notebook | __init__(self, parent, id, pos, size, style, name)
 | __repr__(self)
Size | CalcSizeFromPage(self, sizePage)
bool | Create(self, parent, id, pos, size, style, validator, name) Do the 2nd phase and create the GUI control.
VisualAttributes | GetClassDefaultAttributes(variant) Get the default attributes for this class. (Static method)
int | GetRowCount(self)
Colour | GetThemeBackgroundColour(self)
(tab, where) | HitTest(pt) Returns the tab which is hit, and flags indicating where using wx.NB_HITTEST flags.
 | SetPadding(self, padding)
 | SetTabSize(self, sz)

Instance Method Details

Create(self,
          parent,
          id=-1,
          pos=DefaultPosition,
          size=DefaultSize,
          style=0,
          name=NotebookNameStr)

Do the 2nd phase and create the GUI control.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

validator
(type=Validator)

name
(type=String)

Returns:
bool
Overrides:
wx.Control.Create (inherited documentation)

HitTest(pt)

Returns the tab which is hit, and flags indicating where using wx.NB_HITTEST flags.

Parameters:
pt
(type=Point)

Returns:
(tab, where)
Overrides:
wx.Window.HitTest

Static Method Details

GetClassDefaultAttributes(variant=WINDOW_VARIANT_NORMAL)

Get the default attributes for this class. This is useful if you want to use the same font or colour in your own control as in a standard control -- which is a much better idea than hard coding specific colours or fonts which might look completely out of place on the user's system, especially if it uses themes.

The variant parameter is only relevant under Mac currently and is ignore under other platforms. Under Mac, it will change the size of the returned font. See wx.Window.SetWindowVariant for more about this.

Parameters:
variant
(type=int)

Returns:
VisualAttributes

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:46 2005 http://epydoc.sf.net


wx.NotebookEvent

Package wx :: Class NotebookEvent

Type NotebookEvent

object --+
         |
    Object --+
             |
         Event --+
                 |
      CommandEvent --+
                     |
           NotifyEvent --+
                         |
         BookCtrlBaseEvent --+
                             |
                            NotebookEvent

Proxy of C++ NotebookEvent class

Method Summary
NotifyEvent | __init__(self, commandType, winid) An instance of this class (or one of its derived classes) is sent from a control when the control's state is being changed and the control allows that change to be prevented from happening.
 | __repr__(self)

Method Details

__init__(self,
          commandType=wxEVT_NULL,
          id=0,
          nSel=-1,
          nOldSel=-1)
(Constructor)

An instance of this class (or one of its derived classes) is sent from a control when the control's state is being changed and the control allows that change to be prevented from happening. The event handler can call Veto or Allow to tell the control what to do.

Parameters:
commandType
(type=wxEventType)

winid
(type=int)

Returns:
NotifyEvent
Overrides:
wx.BookCtrlBaseEvent.__init__ (inherited documentation)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:03 2005 http://epydoc.sf.net


wx.NotebookPage

Package wx :: Class NotebookPage

Type NotebookPage

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
                 Panel --+
                         |
                        NotebookPage

There is an old (and apparently unsolvable) bug when placing a window with a nonstandard background colour in a wx.Notebook on wxGTK1, as the notbooks's background colour would always be used when the window is refreshed. The solution is to place a panel in the notbook and the coloured window on the panel, sized to cover the panel. This simple class does that for you, just put an instance of this in the notebook and make your regular window a child of this one and it will handle the resize for you.

Method Summary
 | __init__(self, parent, id, pos, size, style, name)
 | OnSize(self, evt)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:26 2005 http://epydoc.sf.net


wx.NotebookSizer

Package wx :: Class NotebookSizer

Type NotebookSizer

object --+
         |
    Object --+
             |
         Sizer --+
                 |
                NotebookSizer

Proxy of C++ NotebookSizer class

Method Summary
 | __init__(*args, **kwargs) NotebookSizer is no longer needed.
 | __repr__(self)
Size | CalcMin(self) This method is where the sizer will do the actual calculation of its children's minimal sizes.
Notebook | GetNotebook(self)
 | RecalcSizes(self) Using the sizes calculated by CalcMin reposition and resize all the items managed by this sizer.

Method Details

__init__(*args, **kwargs)
(Constructor)

NotebookSizer is no longer needed.

CalcMin(self)

This method is where the sizer will do the actual calculation of its children's minimal sizes. You should not need to call this directly as it is called by Layout.

Returns:
Size
Overrides:
wx.Sizer.CalcMin

RecalcSizes(self)

Using the sizes calculated by CalcMin reposition and resize all the items managed by this sizer. You should not need to call this directly as it is called by Layout.

Overrides:
wx.Sizer.RecalcSizes

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:00 2005 http://epydoc.sf.net


wx.NotifyEvent

Package wx :: Class NotifyEvent

Type NotifyEvent

object --+
         |
    Object --+
             |
         Event --+
                 |
      CommandEvent --+
                     |
                    NotifyEvent

Known Subclasses:
BookCtrlBaseEvent, GridEvent, GridRangeSelectEvent, GridSizeEvent, ListEvent, MediaEvent, SpinEvent, SplitterEvent, TreeEvent, WizardEvent

An instance of this class (or one of its derived classes) is sent from a control when the control's state is being changed and the control allows that change to be prevented from happening. The event handler can call Veto or Allow to tell the control what to do.

Method Summary
NotifyEvent | __init__(self, commandType, winid) An instance of this class (or one of its derived classes) is sent from a control when the control's state is being changed and the control allows that change to be prevented from happening.
 | __repr__(self)
 | Allow(self) This is the opposite of Veto: it explicitly allows the event to be processed.
bool | IsAllowed(self) Returns true if the change is allowed (Veto hasn't been called) or false otherwise (if it was).
 | Veto(self) Prevents the change announced by this event from happening.

Method Details

__init__(self, commandType=wxEVT_NULL, winid=0)
(Constructor)

An instance of this class (or one of its derived classes) is sent from a control when the control's state is being changed and the control allows that change to be prevented from happening. The event handler can call Veto or Allow to tell the control what to do.

Parameters:
commandType
(type=wxEventType)

winid
(type=int)

Returns:
NotifyEvent
Overrides:
wx.CommandEvent.__init__

Allow(self)

This is the opposite of Veto: it explicitly allows the event to be processed. For most events it is not necessary to call this method as the events are allowed anyhow but some are forbidden by default (this will be mentioned in the corresponding event description).

IsAllowed(self)

Returns true if the change is allowed (Veto hasn't been called) or false otherwise (if it was).

Returns:
bool

Veto(self)

Prevents the change announced by this event from happening.

It is in general a good idea to notify the user about the reasons for vetoing the change because otherwise the applications behaviour (which just refuses to do what the user wants) might be quite surprising.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:44 2005 http://epydoc.sf.net


wx.Object

Package wx :: Class Object

Type Object

object --+
         |
        Object

Known Subclasses:
AcceleratorTable, AnimationBase, AnimationPlayer, BrushList, BusyInfo, Clipboard, Colour, ColourData, ColourDatabase, Command, CommandProcessor, ContextHelp, DC, DocTemplate, DragImage, Effects, EncodingConverter, Event, EvtHandler, FileHistory, FileSystem, FindReplaceData, FontData, FontList, FSFile, GDIObject, GLContext, GridTableBase, HtmlCell, HtmlDCRenderer, HtmlEasyPrinting, HtmlFilter, HtmlHelpController, HtmlLinkInfo, HtmlParser, HtmlTag, HtmlTagHandler, Image, ImageHandler, ImageList, IndividualLayoutConstraint, LayoutAlgorithm, LayoutConstraints, ListItem, Mask, MenuItem, MetaFile, PageSetupDialog, PageSetupDialogData, PenList, PrintData, PrintDialog, PrintDialogData, Printer, Printout, PrintPreview, RegionIterator, Sizer, SizerItem, SystemOptions, ToolBarToolBase, ToolTip, TreeListColumnInfo, XmlDocument, XmlResource, XmlResourceHandler

The base class for most wx objects, although in wxPython not much functionality is needed nor exposed.

Method Summary
 | __init__(self)
 | __repr__(self)
 | Destroy(self) Deletes the C++ object this Python object is a proxy for.
String | GetClassName(self) Returns the class name of the C++ class using wxRTTI.

Method Details

Destroy(self)

Deletes the C++ object this Python object is a proxy for.

GetClassName(self)

Returns the class name of the C++ class using wxRTTI.

Returns:
String

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:52 2005 http://epydoc.sf.net


wx.OutputStream

Package wx :: Class OutputStream

Type OutputStream

object --+
         |
        OutputStream

Proxy of C++ OutputStream class

Method Summary
 | __init__(self)
 | __repr__(self)
 | write(self, obj)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:05 2005 http://epydoc.sf.net


wx.PageSetupDialog

Package wx :: Class PageSetupDialog

Type PageSetupDialog

object --+
         |
    Object --+
             |
            PageSetupDialog

Proxy of C++ PageSetupDialog class

Method Summary
PageSetupDialog | __init__(self, parent, data)
 | __repr__(self)
PageSetupDialogData | GetPageSetupData(self)
PageSetupDialogData | GetPageSetupDialogData(self)
int | ShowModal(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:34 2005 http://epydoc.sf.net


wx.PageSetupDialogData

Package wx :: Class PageSetupDialogData

Type PageSetupDialogData

object --+
         |
    Object --+
             |
            PageSetupDialogData

Proxy of C++ PageSetupDialogData class

Method Summary
PageSetupDialogData | __init__(self) __init__(self, PageSetupDialogData data) -> PageSetupDialogData __init__(self, PrintData data) -> PageSetupDialogData
 | __del__(self)
 | __nonzero__(self)
 | __repr__(self)
 | CalculateIdFromPaperSize(self)
 | CalculatePaperSizeFromId(self)
 | EnableHelp(self, flag)
 | EnableMargins(self, flag)
 | EnableOrientation(self, flag)
 | EnablePaper(self, flag)
 | EnablePrinter(self, flag)
bool | GetDefaultInfo(self)
bool | GetDefaultMinMargins(self)
bool | GetEnableHelp(self)
bool | GetEnableMargins(self)
bool | GetEnableOrientation(self)
bool | GetEnablePaper(self)
bool | GetEnablePrinter(self)
Point | GetMarginBottomRight(self)
Point | GetMarginTopLeft(self)
Point | GetMinMarginBottomRight(self)
Point | GetMinMarginTopLeft(self)
int | GetPaperId(self)
Size | GetPaperSize(self)
PrintData | GetPrintData(self)
bool | Ok(self)
 | SetDefaultInfo(self, flag)
 | SetDefaultMinMargins(self, flag)
 | SetMarginBottomRight(self, pt)
 | SetMarginTopLeft(self, pt)
 | SetMinMarginBottomRight(self, pt)
 | SetMinMarginTopLeft(self, pt)
 | SetPaperId(self, id)
 | SetPaperSize(self, size)
 | SetPrintData(self, printData)

Method Details

__init__(self)
(Constructor)

__init__(self, PageSetupDialogData data) -> PageSetupDialogData __init__(self, PrintData data) -> PageSetupDialogData

Returns:
PageSetupDialogData
Overrides:
wx.Object.__init__

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:59 2005 http://epydoc.sf.net


wx.PaintDC

Package wx :: Class PaintDC

Type PaintDC

object --+
         |
    Object --+
             |
            DC --+
                 |
                PaintDC

A wx.PaintDC must be constructed if an application wishes to paint on the client area of a window from within an EVT_PAINT event handler. This should normally be constructed as a temporary stack object; don't store a wx.PaintDC object. If you have an EVT_PAINT handler, you must create a wx.PaintDC object within it even if you don't actually use it.

Using wx.PaintDC within EVT_PAINT handlers is important because it automatically sets the clipping area to the damaged area of the window. Attempts to draw outside this area do not appear.

To draw on a window from outside EVT_PAINT handlers, construct a wx.ClientDC object.

Method Summary
PaintDC | __init__(self, win) Constructor.
 | __repr__(self)

Method Details

__init__(self, win)
(Constructor)

Constructor. Pass the window on which you wish to paint.

Parameters:
win
(type=Window)

Returns:
PaintDC
Overrides:
wx.DC.__init__

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:44 2005 http://epydoc.sf.net


wx.PaintEvent

Package wx :: Class PaintEvent

Type PaintEvent

object --+
         |
    Object --+
             |
         Event --+
                 |
                PaintEvent

A paint event is sent when a window's contents needs to be repainted. Note that in an EVT_PAINT handler the application must always create a wx.PaintDC object, even if you do not use it. Otherwise MS Windows assumes that the window has not been painted yet and will send the event again, causing endless refreshes.

You can optimize painting by retrieving the rectangles that have been damaged using wx.Window.GetUpdateRegion and/or wx.RegionIterator, and only repainting these rectangles. The rectangles are in terms of the client area, and are unscrolled, so you will need to do some calculations using the current view position to obtain logical, scrolled units.

Method Summary
PaintEvent | __init__(self, Id)
 | __repr__(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:17 2005 http://epydoc.sf.net


wx.PaletteChangedEvent

Package wx :: Class PaletteChangedEvent

Type PaletteChangedEvent

object --+
         |
    Object --+
             |
         Event --+
                 |
                PaletteChangedEvent

An EVT_PALETTE_CHANGED event is sent when the system palette has changed, thereby giving each window a chance to redo their own to match.

This event is implemented under Windows only.

Method Summary
PaletteChangedEvent | __init__(self, id) An EVT_PALETTE_CHANGED event is sent when the system palette has changed, thereby giving each window a chance to redo their own to match.
 | __repr__(self)
Window | GetChangedWindow(self)
 | SetChangedWindow(self, win)

Method Details

__init__(self, id=0)
(Constructor)

An EVT_PALETTE_CHANGED event is sent when the system palette has changed, thereby giving each window a chance to redo their own to match.

This event is implemented under Windows only.

Parameters:
id
(type=int)

Returns:
PaletteChangedEvent
Overrides:
wx.Event.__init__

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:57 2005 http://epydoc.sf.net


wx.Palette

Package wx :: Class Palette

Type Palette

object --+
         |
    Object --+
             |
     GDIObject --+
                 |
                Palette

Proxy of C++ Palette class

Method Summary
__init__(self, *args, **kwargs)
__init__(self, int n, unsigned char red, unsigned char green, unsigned char blue) -> Palette
__del__(self)
__nonzero__(self)
__repr__(self)
int | GetColoursCount(self)
int | GetPixel(self, red, green, blue)
(R,G,B) | GetRGB(self, pixel)
bool | Ok(self)

Method Details

__init__(self, *args, **kwargs)
(Constructor)

__init__(self, int n, unsigned char red, unsigned char green, unsigned char blue) -> Palette

Overrides:
wx.GDIObject.__init__

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:10:48 2005 http://epydoc.sf.net


wx.Panel

Package wx :: Class Panel

Type Panel

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
                    Panel

Known Subclasses:
DocTabbedChildFrame, EditableListBox, FileBrowseButton, FloatCanvas, FoldPanelBar, FoldPanelItem, GeneralOptionsPanel, NavCanvas, NotebookPage, PreviewControlBar, PyColourBox, PyColourChooser, PyPanel, PyShell, PyShellInput, PyShellOutput, ScrolledWindow, VScrolledWindow, WizardPage

Proxy of C++ Panel class

Method Summary
Window | __init__(self, parent, id, pos, size, style, name) Construct and show a generic Window.
 | __repr__(self)
bool | Create(self, parent, id, pos, size, style, name) Create the GUI part of the Window for 2-phase creation mode.
VisualAttributes | GetClassDefaultAttributes(variant) Get the default attributes for this class. (Static method)
 | InitDialog(self) Sends an EVT_INIT_DIALOG event, whose handler usually transfers data to the dialog via validators.
 | SetFocus(self) Overrides wx.Window.SetFocus.
 | SetFocusIgnoringChildren(self) In contrast to SetFocus (see above) this will set the focus to the panel even of there are child windows in the panel.

Instance Method Details

__init__(self,
          parent,
          id=-1,
          pos=DefaultPosition,
          size=DefaultSize,
          style=wxTAB_TRAVERSAL|wxNO_BORDER,
          name=PanelNameStr)
(Constructor)

Construct and show a generic Window.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

name
(type=String)

Returns:
Window
Overrides:
wx.Window.__init__ (inherited documentation)

Create(self,
          parent,
          id=-1,
          pos=DefaultPosition,
          size=DefaultSize,
          style=wxTAB_TRAVERSAL|wxNO_BORDER,
          name=PanelNameStr)

Create the GUI part of the Window for 2-phase creation mode.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

name
(type=String)

Returns:
bool
Overrides:
wx.Window.Create

InitDialog(self)

Sends an EVT_INIT_DIALOG event, whose handler usually transfers data to the dialog via validators.

Overrides:
wx.Window.InitDialog

SetFocus(self)

Overrides wx.Window.SetFocus. This method uses the (undocumented) mix-in class wxControlContainer which manages the focus and TAB logic for controls which usually have child controls. In practice, if you call this method and the panel has at least one child window, then the focus will be given to the child window. :see: wx.FocusEvent, wx.Window.SetFocus, SetFocusIgnoringChildren

Overrides:
wx.Window.SetFocus

SetFocusIgnoringChildren(self)

In contrast to SetFocus (see above) this will set the focus to the panel even of there are child windows in the panel. This is only rarely needed.

Static Method Details

GetClassDefaultAttributes(variant=WINDOW_VARIANT_NORMAL)

Get the default attributes for this class. This is useful if you want to use the same font or colour in your own control as in a standard control -- which is a much better idea than hard coding specific colours or fonts which might look completely out of place on the user's system, especially if it uses themes.

The variant parameter is only relevant under Mac currently and is ignore under other platforms. Under Mac, it will change the size of the returned font. See wx.Window.SetWindowVariant for more about this.

Parameters:
variant
(type=int)

Returns:
VisualAttributes

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:07 2005 http://epydoc.sf.net


wx.PasswordEntryDialog

Package wx :: Class PasswordEntryDialog

Type PasswordEntryDialog

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
        TopLevelWindow --+
                         |
                    Dialog --+
                             |
               TextEntryDialog --+
                                 |
                                PasswordEntryDialog

Proxy of C++ PasswordEntryDialog class

Method Summary
TextEntryDialog | __init__(self, parent, message, caption, defaultValue, style, pos) Constructor.
 | __repr__(self)

Instance Method Details

__init__(self, parent, message, caption=GetPasswordFromUserPromptStr, value=EmptyString, style=TextEntryDialogStyle, pos=DefaultPosition)
(Constructor)

Constructor. Use ShowModal method to show the dialog.

Parameters:
parent
(type=Window)

message
(type=String)

caption
(type=String)

defaultValue
(type=String)

style
(type=long)

pos
(type=Point)

Returns:
TextEntryDialog
Overrides:
wx.TextEntryDialog.__init__ (inherited documentation)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:12 2005 http://epydoc.sf.net


wx.PCXHandler

Package wx :: Class PCXHandler

Type PCXHandler

object --+
         |
    Object --+
             |
  ImageHandler --+
                 |
                PCXHandler

A wx.ImageHandler for PCX imager files.

Method Summary
PCXHandler | __init__(self) A wx.ImageHandler for PCX imager files.
 | __repr__(self)

Method Details

__init__(self)
(Constructor)

A wx.ImageHandler for PCX imager files.

Returns:
PCXHandler
Overrides:
wx.ImageHandler.__init__

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:23 2005 http://epydoc.sf.net


wx.Pen

Package wx :: Class Pen

Type Pen

object --+
         |
    Object --+
             |
     GDIObject --+
                 |
                Pen

Proxy of C++ Pen class

Method Summary
Pen | __init__(self, colour, width, style)
 | __del__(self)
bool | __eq__(self, other)
bool | __ne__(self, other)
 | __nonzero__(self)
 | __repr__(self)
int | GetCap(self)
Colour | GetColour(self)
int | GetDashCount(self)
PyObject | GetDashes(self)
int | GetJoin(self)
int | GetStyle(self)
int | GetWidth(self)
bool | Ok(self)
 | SetCap(self, cap_style)
 | SetColour(self, colour)
 | SetDashes(self, dashes) Associate a list of dash lengths with the Pen.
 | SetJoin(self, join_style)
 | SetStyle(self, style)
 | SetWidth(self, width)

Method Details

SetDashes(self, dashes)

Associate a list of dash lengths with the Pen.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:56 2005 http://epydoc.sf.net


wx.PenList

Package wx :: Class PenList

Type PenList

object --+
         |
    Object --+
             |
            PenList

Proxy of C++ PenList class

Method Summary
 | __init__(self)
 | __repr__(self)
 | AddPen(self, pen)
Pen | FindOrCreatePen(self, colour, width, style)
int | GetCount(self)
 | RemovePen(self, pen)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:48 2005 http://epydoc.sf.net


wx.PNGHandler

Package wx :: Class PNGHandler

Type PNGHandler

object --+
         |
    Object --+
             |
  ImageHandler --+
                 |
                PNGHandler

A wx.ImageHandler for PNG image files.

Method Summary
PNGHandler | __init__(self) A wx.ImageHandler for PNG image files.
 | __repr__(self)

Method Details

__init__(self)
(Constructor)

A wx.ImageHandler for PNG image files.

Returns:
PNGHandler
Overrides:
wx.ImageHandler.__init__

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:11 2005 http://epydoc.sf.net


wx.PNMHandler

Package wx :: Class PNMHandler

Type PNMHandler

object --+
         |
    Object --+
             |
  ImageHandler --+
                 |
                PNMHandler

A wx.ImageHandler for PNM image files.

Method Summary
PNMHandler | __init__(self) A wx.ImageHandler for PNM image files.
 | __repr__(self)

Method Details

__init__(self)
(Constructor)

A wx.ImageHandler for PNM image files.

Returns:
PNMHandler
Overrides:
wx.ImageHandler.__init__

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:45 2005 http://epydoc.sf.net


wx.Point2D

Package wx :: Class Point2D

Type Point2D

object --+
         |
        Point2D

wx.Point2Ds represent a point or a vector in a 2d coordinate system with floating point values.

Method Summary
Point2D | __init__(self, x, y) Create a w.Point2D object.
bool | __eq__(self, pt) Test for equality
 | __getitem__(self, index)
Point2D | __iadd__(self, pt)
Point2D | __idiv__(self, pt)
Point2D | __imul__(self, pt)
Point2D | __isub__(self, pt)
 | __len__(self)
bool | __ne__(self, pt) Test for inequality
Point2D | __neg__(self) the reflection of this point
 | __nonzero__(self)
 | __reduce__(self)
 | __repr__(self)
 | __setitem__(self, index, val)
 | __str__(self)
 | asTuple(*args, **kwargs) asTuple is deprecated, use Get instead
(x,y) | Get() Return x and y properties as a tuple.
double | GetCrossProduct(self, vec)
double | GetDistance(self, pt)
double | GetDistanceSquare(self, pt)
double | GetDotProduct(self, vec)
(x,y) | GetFloor() Convert to integer
(x,y) | GetRounded() Convert to integer
double | GetVectorAngle(self)
double | GetVectorLength(self)
 | Normalize(self)
 | Set(self, x, y)
 | SetPolarCoordinates(self, angle, length)
 | SetVectorAngle(self, degrees)
 | SetVectorLength(self, length)

Property Summary
 | x
 | y

Class Variable Summary
bool __safe_for_unpickling__ = True

Method Details

__init__(self, x=0.0, y=0.0)
(Constructor)

Create a w.Point2D object.

Parameters:
x
(type=double)

y
(type=double)

Returns:
Point2D
Overrides:
__builtin__.object.__init__

__eq__(self, pt)
(Equality operator)

Test for equality

Parameters:
pt
(type=Point2D)

Returns:
bool

__ne__(self, pt)

Test for inequality

Parameters:
pt
(type=Point2D)

Returns:
bool

__neg__(self)

the reflection of this point

Returns:
Point2D

asTuple(*args, **kwargs)

asTuple is deprecated, use Get instead

Get()

Return x and y properties as a tuple.

Returns:
(x,y)

GetFloor()

Convert to integer

Returns:
(x,y)

GetRounded()

Convert to integer

Returns:
(x,y)

Property Details

x

Get Method:
Point2D_x_get(...)
Set Method:
Point2D_x_set(...)

y

Get Method:
Point2D_y_get(...)
Set Method:
Point2D_y_set(...)

Class Variable Details

__safe_for_unpickling__

Type:
bool
Value:
True

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:52 2005 http://epydoc.sf.net


wx.Point

Package wx :: Class Point

Type Point

object --+
         |
        Point

A data structure for representing a point or position with integer x and y properties. Most places in wxPython that expect a wx.Point can also accept a (x,y) tuple.

Method Summary
Point | __init__(self, x, y) Create a wx.Point object
Point | __add__(self, pt) Add pt's proprties to this and return the result.
 | __del__(self)
bool | __eq__(self, pt) Test for equality of wx.Point objects.
 | __getitem__(self, index)
Point | __iadd__(self, pt) Add pt to this object.
Point | __isub__(self, pt) Subtract pt from this object.
 | __len__(self)
bool | __ne__(self, pt) Test for inequality of wx.Point objects.
 | __nonzero__(self)
 | __reduce__(self)
 | __repr__(self)
 | __setitem__(self, index, val)
 | __str__(self)
Point | __sub__(self, pt) Subtract pt's proprties from this and return the result
 | asTuple(*args, **kwargs) asTuple is deprecated, use Get instead
(x,y) | Get() Return the x and y properties as a tuple.
 | Set(self, x, y) Set both the x and y properties

Property Summary
 | x
 | y

Class Variable Summary
bool __safe_for_unpickling__ = True

Method Details

__init__(self, x=0, y=0)
(Constructor)

Create a wx.Point object

Parameters:
x
(type=int)

y
(type=int)

Returns:
Point
Overrides:
__builtin__.object.__init__

__add__(self, pt)
(Addition operator)

Add pt's proprties to this and return the result.

Parameters:
pt
(type=Point)

Returns:
Point

__eq__(self, pt)
(Equality operator)

Test for equality of wx.Point objects.

Parameters:
pt
(type=Point)

Returns:
bool

__iadd__(self, pt)

Add pt to this object.

Parameters:
pt
(type=Point)

Returns:
Point

__isub__(self, pt)

Subtract pt from this object.

Parameters:
pt
(type=Point)

Returns:
Point

__ne__(self, pt)

Test for inequality of wx.Point objects.

Parameters:
pt
(type=Point)

Returns:
bool

__sub__(self, pt)
(Subtraction operator)

Subtract pt's proprties from this and return the result

Parameters:
pt
(type=Point)

Returns:
Point

asTuple(*args, **kwargs)

asTuple is deprecated, use Get instead

Get()

Return the x and y properties as a tuple.

Returns:
(x,y)

Set(self, x, y)

Set both the x and y properties

Parameters:
x
(type=long)

y
(type=long)

Property Details

x

Get Method:
Point_x_get(...)
Set Method:
Point_x_set(...)

y

Get Method:
Point_y_get(...)
Set Method:
Point_y_set(...)

Class Variable Details

__safe_for_unpickling__

Type:
bool
Value:
True

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:45 2005 http://epydoc.sf.net


wx.PopupTransientWindow

Package wx :: Class PopupTransientWindow

Type PopupTransientWindow

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
           PopupWindow --+
                         |
                        PopupTransientWindow

Known Subclasses:
TipWindow

Proxy of C++ PopupTransientWindow class

Method Summary
Window | __init__(self, parent, id, pos, size, style, name) Construct and show a generic Window.
 | __repr__(self)
 | Dismiss(self)
 | Popup(self, focus)

Instance Method Details

__init__(self, parent, style=BORDER_NONE)
(Constructor)

Construct and show a generic Window.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

name
(type=String)

Returns:
Window
Overrides:
wx.PopupWindow.__init__ (inherited documentation)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:15 2005 http://epydoc.sf.net


wx.PopupWindow

Package wx :: Class PopupWindow

Type PopupWindow

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
                    PopupWindow

Known Subclasses:
FoldOutWindow, PopupTransientWindow

Proxy of C++ PopupWindow class

Method Summary
Window | __init__(self, parent, id, pos, size, style, name) Construct and show a generic Window.
 | __repr__(self)
bool | Create(self, parent, id, pos, size, style, name) Create the GUI part of the Window for 2-phase creation mode.
 | Position(self, ptOrigin, size)

Instance Method Details

__init__(self, parent, flags=BORDER_NONE)
(Constructor)

Construct and show a generic Window.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

name
(type=String)

Returns:
Window
Overrides:
wx.Window.__init__ (inherited documentation)

Create(self, parent, flags=BORDER_NONE)

Create the GUI part of the Window for 2-phase creation mode.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

name
(type=String)

Returns:
bool
Overrides:
wx.Window.Create (inherited documentation)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:09 2005 http://epydoc.sf.net


wx.PostScriptDC

Package wx :: Class PostScriptDC

Type PostScriptDC

object --+
         |
    Object --+
             |
            DC --+
                 |
                PostScriptDC

This is a wx.DC that can write to PostScript files on any platform.

Method Summary
PostScriptDC | __init__(self, printData) Constructs a PostScript printer device context from a wx.PrintData object.
 | __repr__(self)
wxPrintData | GetPrintData(self)
int | GetResolution() Return resolution used in PostScript output. (Static method)
 | SetPrintData(self, data)
 | SetResolution(ppi) Set resolution (in pixels per inch) that will be used in PostScript output. (Static method)

Instance Method Details

__init__(self, printData)
(Constructor)

Constructs a PostScript printer device context from a wx.PrintData object.

Parameters:
printData
(type=wxPrintData)

Returns:
PostScriptDC
Overrides:
wx.DC.__init__

Static Method Details

GetResolution()

Return resolution used in PostScript output.

Returns:
int

SetResolution(ppi)

Set resolution (in pixels per inch) that will be used in PostScript output. Default is 720ppi.

Parameters:
ppi
(type=int)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:10 2005 http://epydoc.sf.net


wx.PreviewCanvas

Package wx :: Class PreviewCanvas

Type PreviewCanvas

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
                 Panel --+
                         |
            ScrolledWindow --+
                             |
                            PreviewCanvas

Proxy of C++ PreviewCanvas class

Method Summary
Window | __init__(self, parent, id, pos, size, style, name) Construct and show a generic Window.
 | __repr__(self)

Instance Method Details

__init__(self, preview, parent, pos=DefaultPosition, size=DefaultSize, style=0, name=PreviewCanvasNameStr)
(Constructor)

Construct and show a generic Window.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

name
(type=String)

Returns:
Window
Overrides:
wx.ScrolledWindow.__init__ (inherited documentation)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:41 2005 http://epydoc.sf.net


wx.PreviewControlBar

Package wx :: Class PreviewControlBar

Type PreviewControlBar

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
                 Panel --+
                         |
                        PreviewControlBar

Known Subclasses:
PyPreviewControlBar

Proxy of C++ PreviewControlBar class

Method Summary
Window | __init__(self, parent, id, pos, size, style, name) Construct and show a generic Window.
 | __repr__(self)
PrintPreview | GetPrintPreview(self)
int | GetZoomControl(self)
 | OnFirst(self)
 | OnGoto(self)
 | OnLast(self)
 | OnNext(self)
 | OnPrevious(self)
 | SetZoomControl(self, zoom)

Instance Method Details

__init__(self, preview, buttons, parent, pos=DefaultPosition, size=DefaultSize, style=TAB_TRAVERSAL, name=PanelNameStr)
(Constructor)

Construct and show a generic Window.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

name
(type=String)

Returns:
Window
Overrides:
wx.Panel.__init__ (inherited documentation)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:21 2005 http://epydoc.sf.net


wx.PreviewFrame

Package wx :: Class PreviewFrame

Type PreviewFrame

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
        TopLevelWindow --+
                         |
                     Frame --+
                             |
                            PreviewFrame

Known Subclasses:
PyPreviewFrame

Proxy of C++ PreviewFrame class

Method Summary
PreviewFrame | __init__(self, preview, parent, title, pos, size, style, name)
 | __repr__(self)
 | CreateCanvas(self)
 | CreateControlBar(self)
PreviewControlBar | GetControlBar(self)
 | Initialize(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:04 2005 http://epydoc.sf.net


wx.PrintData

Package wx :: Class PrintData

Type PrintData

object --+
         |
    Object --+
             |
            PrintData

Proxy of C++ PrintData class

Method Summary
PrintData | __init__(self) __init__(self, PrintData data) -> PrintData
 | __del__(self)
 | __nonzero__(self)
 | __repr__(self)
int | GetBin(self)
bool | GetCollate(self)
bool | GetColour(self)
int | GetDuplex(self)
String | GetFilename(self)
String | GetFontMetricPath(self)
int | GetNoCopies(self)
int | GetOrientation(self)
int | GetPaperId(self)
Size | GetPaperSize(self)
String | GetPreviewCommand(self)
String | GetPrinterCommand(self)
String | GetPrinterName(self)
String | GetPrinterOptions(self)
double | GetPrinterScaleX(self)
double | GetPrinterScaleY(self)
long | GetPrinterTranslateX(self)
long | GetPrinterTranslateY(self)
int | GetPrintMode(self)
PyObject | GetPrivData(self)
int | GetQuality(self)
bool | Ok(self)
 | SetBin(self, bin)
 | SetCollate(self, flag)
 | SetColour(self, colour)
 | SetDuplex(self, duplex)
 | SetFilename(self, filename)
 | SetFontMetricPath(self, path)
 | SetNoCopies(self, v)
 | SetOrientation(self, orient)
 | SetPaperId(self, sizeId)
 | SetPaperSize(self, sz)
 | SetPreviewCommand(self, command)
 | SetPrinterCommand(self, command)
 | SetPrinterName(self, name)
 | SetPrinterOptions(self, options)
 | SetPrinterScaleX(self, x)
 | SetPrinterScaleY(self, y)
 | SetPrinterScaling(self, x, y)
 | SetPrinterTranslateX(self, x)
 | SetPrinterTranslateY(self, y)
 | SetPrinterTranslation(self, x, y)
 | SetPrintMode(self, printMode)
 | SetPrivData(self, data)
 | SetQuality(self, quality)

Method Details

__init__(self)
(Constructor)

__init__(self, PrintData data) -> PrintData

Returns:
PrintData
Overrides:
wx.Object.__init__

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:11 2005 http://epydoc.sf.net


wx.PrintDialog

Package wx :: Class PrintDialog

Type PrintDialog

object --+
         |
    Object --+
             |
            PrintDialog

Proxy of C++ PrintDialog class

Method Summary
PrintDialog | __init__(self, parent, data)
 | __repr__(self)
PrintData | GetPrintData(self)
DC | GetPrintDC(self)
PrintDialogData | GetPrintDialogData(self)
int | ShowModal(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:09 2005 http://epydoc.sf.net


wx.PrintDialogData

Package wx :: Class PrintDialogData

Type PrintDialogData

object --+
         |
    Object --+
             |
            PrintDialogData

Proxy of C++ PrintDialogData class

Method Summary
PrintDialogData | __init__(self) __init__(self, PrintData printData) -> PrintDialogData __init__(self, PrintDialogData printData) -> PrintDialogData
 | __del__(self)
 | __nonzero__(self)
 | __repr__(self)
 | EnableHelp(self, flag)
 | EnablePageNumbers(self, flag)
 | EnablePrintToFile(self, flag)
 | EnableSelection(self, flag)
bool | GetAllPages(self)
bool | GetCollate(self)
bool | GetEnableHelp(self)
bool | GetEnablePageNumbers(self)
bool | GetEnablePrintToFile(self)
bool | GetEnableSelection(self)
int | GetFromPage(self)
int | GetMaxPage(self)
int | GetMinPage(self)
int | GetNoCopies(self)
PrintData | GetPrintData(self)
bool | GetPrintToFile(self)
bool | GetSelection(self)
bool | GetSetupDialog(self)
int | GetToPage(self)
bool | Ok(self)
 | SetAllPages(self, flag)
 | SetCollate(self, flag)
 | SetFromPage(self, v)
 | SetMaxPage(self, v)
 | SetMinPage(self, v)
 | SetNoCopies(self, v)
 | SetPrintData(self, printData)
 | SetPrintToFile(self, flag)
 | SetSelection(self, flag)
 | SetSetupDialog(self, flag)
 | SetToPage(self, v)

Method Details

__init__(self)
(Constructor)

__init__(self, PrintData printData) -> PrintDialogData __init__(self, PrintDialogData printData) -> PrintDialogData

Returns:
PrintDialogData
Overrides:
wx.Object.__init__

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:10 2005 http://epydoc.sf.net


wx.Printer

Package wx :: Class Printer

Type Printer

object --+
         |
    Object --+
             |
            Printer

Proxy of C++ Printer class

Method Summary
Printer | __init__(self, data)
 | __del__(self)
 | __repr__(self)
Window | CreateAbortWindow(self, parent, printout)
bool | GetAbort(self)
int | GetLastError() (Static method)
PrintDialogData | GetPrintDialogData(self)
bool | Print(self, parent, printout, prompt)
DC | PrintDialog(self, parent)
 | ReportError(self, parent, printout, message)
bool | Setup(self, parent)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:23 2005 http://epydoc.sf.net


wx.PrinterDC

Package wx :: Class PrinterDC

Type PrinterDC

object --+
         |
    Object --+
             |
            DC --+
                 |
                PrinterDC

Proxy of C++ PrinterDC class

Method Summary
PrinterDC | __init__(self, printData)
 | __repr__(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:36 2005 http://epydoc.sf.net


wx.Printout

Package wx :: Class Printout

Type Printout

object --+
         |
    Object --+
             |
            Printout

Known Subclasses:
DocPrintout, HtmlPrintout, PlotPrintout, SetPrintout

Proxy of C++ Printout class

Method Summary
Printout | __init__(self, title)
 | __repr__(self)
(minPage, maxPage, pageFrom, pageTo) | base_GetPageInfo()
bool | base_HasPage(self, page)
bool | base_OnBeginDocument(self, startPage, endPage)
 | base_OnBeginPrinting(self)
 | base_OnEndDocument(self)
 | base_OnEndPrinting(self)
 | base_OnPreparePrinting(self)
DC | GetDC(self)
(w, h) | GetPageSizeMM()
(w, h) | GetPageSizePixels()
(x,y) | GetPPIPrinter()
(x,y) | GetPPIScreen()
String | GetTitle(self)
bool | IsPreview(self)
 | SetDC(self, dc)
 | SetIsPreview(self, p)
 | SetPageSizeMM(self, w, h)
 | SetPageSizePixels(self, w, h)
 | SetPPIPrinter(self, x, y)
 | SetPPIScreen(self, x, y)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:51 2005 http://epydoc.sf.net


wx.PrintPreview

Package wx :: Class PrintPreview

Type PrintPreview

object --+
         |
    Object --+
             |
            PrintPreview

Known Subclasses:
PyPrintPreview

Proxy of C++ PrintPreview class

Method Summary
PrintPreview __init__(self, printout, printoutForPrinting, data)
__init__(self, Printout printout, Printout printoutForPrinting, PrintData data) -> PrintPreview
__nonzero__(self)
__repr__(self)
AdjustScrollbars(self, canvas)
DetermineScaling(self)
bool | DrawBlankPage(self, canvas, dc)
PreviewCanvas | GetCanvas(self)
int | GetCurrentPage(self)
Frame | GetFrame(self)
int | GetMaxPage(self)
int | GetMinPage(self)
PrintDialogData | GetPrintDialogData(self)
Printout | GetPrintout(self)
Printout | GetPrintoutForPrinting(self)
int | GetZoom(self)
bool | Ok(self)
bool | PaintPage(self, canvas, dc)
bool | Print(self, interactive)
bool | RenderPage(self, pageNum)
SetCanvas(self, canvas)
bool | SetCurrentPage(self, pageNum)
SetFrame(self, frame)
SetOk(self, ok)
SetPrintout(self, printout)
SetZoom(self, percent)

Method Details

__init__(self, printout, printoutForPrinting, data=None)
(Constructor)

__init__(self, Printout printout, Printout printoutForPrinting, PrintData data) -> PrintPreview

Parameters:
printout
(type=Printout)

printoutForPrinting
(type=Printout)

data
(type=PrintDialogData)

Returns:
PrintPreview
Overrides:
wx.Object.__init__

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:46 2005 http://epydoc.sf.net


wx.Process

Package wx :: Class Process

Type Process

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
                Process

Proxy of C++ Process class

Method Summary
Process | __init__(self, parent, id)
 | __repr__(self)
 | base_OnTerminate(self, pid, status)
 | CloseOutput(self)
 | Detach(self)
bool | Exists(pid) (Static method)
InputStream | GetErrorStream(self)
InputStream | GetInputStream(self)
OutputStream | GetOutputStream(self)
bool | IsErrorAvailable(self)
bool | IsInputAvailable(self)
bool | IsInputOpened(self)
bool | IsRedirected(self)
int | Kill(pid, sig, flags) (Static method)
Process | Open(cmd, flags) (Static method)
 | Redirect(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:06 2005 http://epydoc.sf.net


wx.ProcessEvent

Package wx :: Class ProcessEvent

Type ProcessEvent

object --+
         |
    Object --+
             |
         Event --+
                 |
                ProcessEvent

Proxy of C++ ProcessEvent class

Method Summary
ProcessEvent | __init__(self, id, pid, exitcode)
 | __repr__(self)
int | GetExitCode(self)
int | GetPid(self)

Property Summary
 | m_exitcode
 | m_pid

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:12 2005 http://epydoc.sf.net


wx.ProgressDialog

Package wx :: Class ProgressDialog

Type ProgressDialog

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
        TopLevelWindow --+
                         |
                     Frame --+
                             |
                            ProgressDialog

A dialog that shows a short message and a progress bar. Optionally, it can display an ABORT button.

Window Styles

wx.PD_APP_MODAL | Make the progress dialog modal. If this flag is not given, it is only "locally" modal - that is the input to the parent window is disabled, but not to the other ones.
wx.PD_AUTO_HIDE | Causes the progress dialog to disappear from screen as soon as the maximum value of the progress meter has been reached.
wx.PD_CAN_ABORT | This flag tells the dialog that it should have a "Cancel" button which the user may press. If this happens, the next call to Update() will return false.
wx.PD_ELAPSED_TIME | This flag tells the dialog that it should show elapsed time (since creating the dialog).
wx.PD_ESTIMATED_TIME | This flag tells the dialog that it should show estimated time.
wx.PD_REMAINING_TIME | This flag tells the dialog that it should show remaining time.
wx.PD_SMOOTH | Uses the wx.GA_SMOOTH style on the embedded wx.Gauge widget.
Method Summary
ProgressDialog | __init__(self, title, message, maximum, parent, style) Constructor.
 | __repr__(self)
 | Resume(self) Can be used to continue with the dialog, after the user had chosen to abort.
bool | Update(self, value, newmsg) Updates the dialog, setting the progress bar to the new value and, if given changes the message above it.

Instance Method Details

__init__(self, title, message, maximum=100, parent=None, style=wxPD_AUTO_HIDE|wxPD_APP_MODAL)
(Constructor)

Constructor. Creates the dialog, displays it and disables user input for other windows, or, if wx.PD_APP_MODAL flag is not given, for its parent window only.

Parameters:
title
(type=String)

message
(type=String)

maximum
(type=int)

parent
(type=Window)

style
(type=int)

Returns:
ProgressDialog
Overrides:
wx.Frame.__init__

Resume(self)

Can be used to continue with the dialog, after the user had chosen to abort.

Update(self, value, newmsg=EmptyString)

Updates the dialog, setting the progress bar to the new value and, if given changes the message above it. The value given should be less than or equal to the maximum value given to the constructor and the dialog is closed if it is equal to the maximum. Returns True unless the Cancel button has been pressed.

If false is returned, the application can either immediately destroy the dialog or ask the user for the confirmation and if the abort is not confirmed the dialog may be resumed with Resume function.

Parameters:
value
(type=int)

newmsg
(type=String)

Returns:
bool
Overrides:
wx.Window.Update

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:06 2005 http://epydoc.sf.net


wx.PropagateOnce

Package wx :: Class PropagateOnce

Type PropagateOnce

object --+
         |
        PropagateOnce

A helper class that will temporarily lower propagation level of an event. Simply create an instance of this class and then whe it is destroyed the propogation of the event will be restored.

Method Summary
PropagateOnce | __init__(self, event) A helper class that will temporarily lower propagation level of an event.
 | __del__(self)
 | __repr__(self)

Method Details

__init__(self, event)
(Constructor)

A helper class that will temporarily lower propagation level of an event. Simply create an instance of this class and then whe it is destroyed the propogation of the event will be restored.

Parameters:
event
(type=Event)

Returns:
PropagateOnce
Overrides:
__builtin__.object.__init__

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:09 2005 http://epydoc.sf.net


wx.PropagationDisabler

Package wx :: Class PropagationDisabler

Type PropagationDisabler

object --+
         |
        PropagationDisabler

Helper class to temporarily change an event not to propagate. Simply create an instance of this class and then whe it is destroyed the propogation of the event will be restored.

Method Summary
PropagationDisabler | __init__(self, event) Helper class to temporarily change an event not to propagate.
 | __del__(self)
 | __repr__(self)

Method Details

__init__(self, event)
(Constructor)

Helper class to temporarily change an event not to propagate. Simply create an instance of this class and then whe it is destroyed the propogation of the event will be restored.

Parameters:
event
(type=Event)

Returns:
PropagationDisabler
Overrides:
__builtin__.object.__init__

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:02 2005 http://epydoc.sf.net


wx.py.buffer.Buffer

Package wx :: Package py :: Module buffer :: Class Buffer

Class Buffer

Buffer class.

Method Summary
 | __init__(self, filename) Create a Buffer instance.
 | addEditor(self, editor) Add an editor.
 | hasChanged(self) Return True if text in editor has changed since last save.
 | new(self, filepath) New empty buffer.
 | open(self, filename) Open file into buffer.
 | overwriteConfirm(filepath) Confirm overwriting an existing file.
 | save(self) Save buffer.
 | saveAs(self, filename) Save buffer.
 | updateNamespace(self) Update the namespace for autocompletion and calltips.

Class Variable Summary
int id = 0

Method Details

__init__(self, filename=None)
(Constructor)

Create a Buffer instance.

addEditor(self, editor)

Add an editor.

hasChanged(self)

Return True if text in editor has changed since last save.

new(self, filepath)

New empty buffer.

open(self, filename)

Open file into buffer.

overwriteConfirm(filepath)

Confirm overwriting an existing file.

save(self)

Save buffer.

saveAs(self, filename)

Save buffer.

updateNamespace(self)

Update the namespace for autocompletion and calltips.

Return True if updated, False if there was an error.

Class Variable Details

id

Type:
int
Value:
0

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:21 2005 http://epydoc.sf.net


wx.py.buffer

Package wx :: Package py :: Module buffer

Module wx.py.buffer

Buffer class.

Classes
Buffer Buffer class.

Variable Summary
str | __author__ = "Patrick K. O'Brien <pobrien@orbtech.com>"
str | __cvsid__ = '$Id: buffer.py,v 1.5 2004/02/13 02:47:58 PK...
str | __revision__ = '1.5'

Variable Details

__author__

Type:
str
Value:
"Patrick K. O'Brien <pobrien@orbtech.com>"

__cvsid__

Type:
str
Value:
'$Id: buffer.py,v 1.5 2004/02/13 02:47:58 PKO Exp $'

__revision__

Type:
str
Value:
'1.5'

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:43 2005 http://epydoc.sf.net


wx.py.crust.Calltip

Package wx :: Package py :: Module crust :: Class Calltip

Type Calltip

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
               Control --+
                         |
                  TextCtrl --+
                             |
                            Calltip

Text control containing the most recent shell calltip.

Method Summary
 | __init__(self, parent, id)
 | display(self, calltip) Receiver for Shell.calltip signal.

Instance Method Details

display(self, calltip)

Receiver for Shell.calltip signal.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:09 2005 http://epydoc.sf.net


wx.py.crust.Crust

Package wx :: Package py :: Module crust :: Class Crust

Type Crust

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
        SplitterWindow --+
                         |
                        Crust

Crust based on SplitterWindow.

Method Summary
__init__(self, parent, id, pos, size, style, name, rootObject, rootLabel, rootIsNamespace, intro, locals, InterpClass, *args, **kwds)
Create Crust instance.

Class Variable Summary
str | name = 'Crust'
str | revision = '1.9'

Instance Method Details

__init__(self,
          parent,
          id=-1,
          pos=wx.Point(-1, -1),
          size=wx.Size(-1, -1),
          style=768,
          name='Crust Window',
          rootObject=None,
          rootLabel=None,
          rootIsNamespace=True,
          intro='',
          locals=None,
          InterpClass=None,
          *args,
          **kwds)
(Constructor)

Create Crust instance.

Overrides:
wx.SplitterWindow.__init__

Class Variable Details

name

Type:
str
Value:
'Crust'

revision

Type:
str
Value:
'1.9'

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:16 2005 http://epydoc.sf.net


wx.py.crust.CrustFrame

Package wx :: Package py :: Module crust :: Class CrustFrame

Type CrustFrame

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
        TopLevelWindow --+
                         |
                     Frame --+
                             |
                         Frame --+
                                 |
                                CrustFrame

Frame containing all the PyCrust components.

Method Summary
 | __init__(self, parent, id, title, pos, size, style, rootObject, rootLabel, rootIsNamespace, locals, InterpClass, *args, **kwds) Create CrustFrame instance.
 | OnAbout(self, event) Display an About window.
 | OnClose(self, event) Event handler for closing.

Class Variable Summary
str | name = 'CrustFrame'
str | revision = '1.9'

Instance Method Details

__init__(self,
          parent=None,
          id=-1,
          title='PyCrust',
          pos=wx.Point(-1, -1),
          size=wx.Size(-1, -1),
          style=541072960,
          rootObject=None,
          rootLabel=None,
          rootIsNamespace=True,
          locals=None,
          InterpClass=None,
          *args,
          **kwds)
(Constructor)

Create CrustFrame instance.

Overrides:
wx.py.frame.Frame.__init__

OnAbout(self, event)

Display an About window.

Overrides:
wx.py.frame.Frame.OnAbout

OnClose(self, event)

Event handler for closing.

Overrides:
wx.py.frame.Frame.OnClose

Class Variable Details

name

Type:
str
Value:
'CrustFrame'

revision

Type:
str
Value:
'1.9'

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:11 2005 http://epydoc.sf.net


wx.py.crust.DispatcherListing

Package wx :: Package py :: Module crust :: Class DispatcherListing
[frames | no frames]

Type DispatcherListing

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
               Control --+
                         |
                  TextCtrl --+
                             |
                            DispatcherListing

Text control containing all dispatches for session.

Method Summary
 | __init__(self, parent, id)
 | spy(self, signal, sender) Receiver for Any signal from Any sender.

Instance Method Details

spy(self, signal, sender)

Receiver for Any signal from Any sender.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:10 2005 http://epydoc.sf.net


wx.py.crust.Display

Package wx :: Package py :: Module crust :: Class Display

Type Display

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
               Control --+
                         |
            StyledTextCtrl --+
                             |
                    EditWindow --+
                                 |
                                Display

STC used to display an object using Pretty Print.

Method Summary
 | __init__(self, parent, id, pos, size, style, static) Create Display instance.
 | push(self, command, more) Receiver for Interpreter.push signal.
 | Refresh(self)
 | setItem(self, item) Set item to pretty print in the notebook Display tab.

Class Variable Summary

Instance Method Details

__init__(self,
          parent,
          id=-1,
          pos=wx.Point(-1, -1),
          size=wx.Size(-1, -1),
          style=138412032,
          static=False)
(Constructor)

Create Display instance.

Overrides:
wx.py.editwindow.EditWindow.__init__

push(self, command, more)

Receiver for Interpreter.push signal.

setItem(self, item)

Set item to pretty print in the notebook Display tab.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:01 2005 http://epydoc.sf.net


wx.py.crust.SessionListing

Package wx :: Package py :: Module crust :: Class SessionListing
[frames | no frames]

Type SessionListing

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
               Control --+
                         |
                  TextCtrl --+
                             |
                            SessionListing

Text control containing all commands for session.

Method Summary
 | __init__(self, parent, id)
 | push(self, command, more) Receiver for Interpreter.push signal.

Instance Method Details

push(self, command, more)

Receiver for Interpreter.push signal.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:10 2005 http://epydoc.sf.net


wx.py.crust

Package wx :: Package py :: Module crust

Module wx.py.crust

Crust combines the shell and filling into one control.

Classes
Calltip | Text control containing the most recent shell calltip.
Crust | Crust based on SplitterWindow.
CrustFrame | Frame containing all the PyCrust components.
DispatcherListing | Text control containing all dispatches for session.
Display | STC used to display an object using Pretty Print.
SessionListing | Text control containing all commands for session.

Variable Summary
str | __author__ = "Patrick K. O'Brien <pobrien@orbtech.com>"
str | __cvsid__ = '$Id: crust.py,v 1.9 2004/10/15 20:31:23 RD ...
str | __revision__ = '1.9'

Variable Details

__author__

Type:
str
Value:
"Patrick K. O'Brien <pobrien@orbtech.com>"

__cvsid__

Type:
str
Value:
'$Id: crust.py,v 1.9 2004/10/15 20:31:23 RD Exp $'

__revision__

Type:
str
Value:
'1.9'

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:51 2005 http://epydoc.sf.net


wx.py.dispatcher.BoundMethodWeakref

Package wx :: Package py :: Module dispatcher :: Class BoundMethodWeakref
[frames | no frames]

Class BoundMethodWeakref

BoundMethodWeakref class.

Method Summary
 | __init__(self, boundMethod) Return a weak-reference-like instance for a bound method.
 | __call__(self) Return a strong reference to the bound method.
 | __repr__(self) Return the closest representation.

Method Details

__init__(self, boundMethod)
(Constructor)

Return a weak-reference-like instance for a bound method.

__call__(self)
(Call operator)

Return a strong reference to the bound method.

__repr__(self)
(Representation operator)

Return the closest representation.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:15 2005 http://epydoc.sf.net


wx.py.dispatcher.DispatcherError

Package wx :: Package py :: Module dispatcher :: Class DispatcherError
[frames | no frames]

Class DispatcherError

Exception --+
            |
           DispatcherError

Method Summary
__init__(self, args)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:34 2005 http://epydoc.sf.net


wx.py.dispatcher.Parameter

Package wx :: Package py :: Module dispatcher :: Class Parameter
[frames | no frames]

Class Parameter

Used to represent default parameter values.

Method Summary
__repr__(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:11 2005 http://epydoc.sf.net


wx.py.dispatcher

Package wx :: Package py :: Module dispatcher

Module wx.py.dispatcher

Provides global signal dispatching services.

Classes
BoundMethodWeakref | BoundMethodWeakref class.
Parameter | Used to represent default parameter values.

Exceptions
DispatcherError

Function Summary
 | connect(receiver, signal, sender, weak) Connect receiver to sender for signal.
 | disconnect(receiver, signal, sender, weak) Disconnect receiver from sender for signal.
 | safeRef(object) Return a safe weak reference to a callable object.
 | send(signal, sender, **kwds) Send signal from sender to all connected receivers.

Variable Summary
str | __author__ = "Patrick K. O'Brien <pobrien@orbtech.com>"
str | __cvsid__ = '$Id: dispatcher.py,v 1.5 2004/02/13 02:47:5...
str | __revision__ = '1.5'
Anonymous | Anonymous = Anonymous
Any | Any = Any
dict | connections = {}
dict | senders = {}

Function Details

connect(receiver,
          signal=Any,
          sender=Any,
          weak=True)

Connect receiver to sender for signal.

If sender is Any, receiver will receive signal from any sender.
If signal is Any, receiver will receive any signal from sender.
If sender is None, receiver will receive signal from Anonymous.
If signal is Any and sender is None, receiver will receive any
    signal from Anonymous.
If signal is Any and sender is Any, receiver will receive any
    signal from any sender.
If weak is true, weak references will be used.

disconnect(receiver,
          signal=Any,
          sender=Any,
          weak=True)

Disconnect receiver from sender for signal.

Disconnecting is not required. The use of disconnect is the same as for connect, only in reverse. Think of it as undoing a previous connection.

safeRef(object)

Return a safe weak reference to a callable object.

send(signal, sender=Anonymous, **kwds)

Send signal from sender to all connected receivers.

Return a list of tuple pairs [(receiver, response), ... ]. If sender is not specified, signal is sent anonymously.

Variable Details

__author__

Type:
str
Value:
"Patrick K. O'Brien <pobrien@orbtech.com>"

__cvsid__

Type:
str
Value:
'$Id: dispatcher.py,v 1.5 2004/02/13 02:47:58 PKO Exp $'

__revision__

Type:
str
Value:
'1.5'

Anonymous

Type:
Anonymous
Value:
Anonymous

Any

Type:
Any
Value:
Any

connections

Type:
dict
Value:
{}

senders

Type:
dict
Value:
{}

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:02 2005 http://epydoc.sf.net


wx.py.document.Document

Package wx :: Package py :: Module document :: Class Document
[frames | no frames]

Class Document

Document class.

Method Summary
 | __init__(self, filename) Create a Document instance.
 | read(self) Return contents of file.
 | write(self, text) Write text to file.

Method Details

__init__(self, filename=None)
(Constructor)

Create a Document instance.

read(self)

Return contents of file.

write(self, text)

Write text to file.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:51 2005 http://epydoc.sf.net


wx.py.document

Package wx :: Package py :: Module document

Module wx.py.document

Document class.

Classes
Document Document class.

Variable Summary
str | __author__ = "Patrick K. O'Brien <pobrien@orbtech.com>"
str | __cvsid__ = '$Id: document.py,v 1.5 2004/02/13 02:47:58 ...
str | __revision__ = '1.5'

Variable Details

__author__

Type:
str
Value:
"Patrick K. O'Brien <pobrien@orbtech.com>"

__cvsid__

Type:
str
Value:
'$Id: document.py,v 1.5 2004/02/13 02:47:58 PKO Exp $'

__revision__

Type:
str
Value:
'1.5'

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:51 2005 http://epydoc.sf.net


wx.py.editor.DialogResults

Package wx :: Package py :: Module editor :: Class DialogResults
[frames | no frames]

Class DialogResults

DialogResults class.

Method Summary
 | __init__(self, returned) Create wrapper for results returned by dialog.
 | __repr__(self)

Method Details

__init__(self, returned)
(Constructor)

Create wrapper for results returned by dialog.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:38 2005 http://epydoc.sf.net


wx.py.editor.Editor

Package wx :: Package py :: Module editor :: Class Editor

Class Editor

Editor having an EditWindow.

Method Summary
 | __init__(self, parent, id, pos, size, style) Create Editor instance.
 | autoCallTipShow(self, command) Display argument spec and docstring in a popup window.
 | autoCompleteShow(self, command) Display auto-completion popup list.
 | clearAll(self)
 | destroy(self) Destroy all editor objects.
 | emptyUndoBuffer(self)
 | getStatus(self) Return (filepath, line, column) status tuple.
 | getText(self) Return contents of editor.
 | hasChanged(self) Return True if contents have changed.
 | OnChar(self, event) Keypress event handler.
 | OnKeyDown(self, event) Key down event handler.
 | setFocus(self) Set the input focus to the editor window.
 | setSavePoint(self)
 | setText(self, text) Set contents of editor.

Method Details

__init__(self, parent, id=-1, pos=wx.Point(-1, -1), size=wx.Size(-1, -1), style=138412032)
(Constructor)

Create Editor instance.

autoCallTipShow(self, command)

Display argument spec and docstring in a popup window.

autoCompleteShow(self, command)

Display auto-completion popup list.

destroy(self)

Destroy all editor objects.

getStatus(self)

Return (filepath, line, column) status tuple.

getText(self)

Return contents of editor.

hasChanged(self)

Return True if contents have changed.

OnChar(self, event)

Keypress event handler.

Only receives an event if OnKeyDown calls event.Skip() for the corresponding event.

OnKeyDown(self, event)

Key down event handler.

setFocus(self)

Set the input focus to the editor window.

setText(self, text)

Set contents of editor.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:04 2005 http://epydoc.sf.net


wx.py.editor.EditorFrame

Package wx :: Package py :: Module editor :: Class EditorFrame
[frames | no frames]

Type EditorFrame

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
        TopLevelWindow --+
                         |
                     Frame --+
                             |
                         Frame --+
                                 |
                                EditorFrame

Known Subclasses:
EditorNotebookFrame

Frame containing one editor.

Method Summary
 | __init__(self, parent, id, title, pos, size, style, filename) Create EditorFrame instance.
 | bufferClose(self) Close buffer.
 | bufferCreate(self, filename) Create new buffer.
 | bufferDestroy(self) Destroy the current buffer.
 | bufferHasChanged(self) Return True if buffer has changed since last save.
 | bufferNew(self) Create new buffer.
 | bufferOpen(self) Open file in buffer.
 | bufferSave(self) Save buffer to its file.
 | bufferSaveAs(self) Save buffer to a new filename.
 | bufferSuggestSave(self) Suggest saving changes.
 | hasBuffer(self) Return True if there is a current buffer.
 | OnAbout(self, event) Display an About window.
 | OnClose(self, event) Event handler for closing.
 | OnIdle(self, event) Event handler for idle time.
 | setEditor(self, editor)
 | updateNamespace(self) Update the buffer namespace for autocompletion and calltips.

Class Variable Summary

Instance Method Details

__init__(self,
          parent=None,
          id=-1,
          title='PyAlaCarte',
          pos=wx.Point(-1, -1),
          size=(800, 600),
          style=541072960,
          filename=None)
(Constructor)

Create EditorFrame instance.

Overrides:
wx.py.frame.Frame.__init__

bufferClose(self)

Close buffer.

bufferCreate(self, filename=None)

Create new buffer.

bufferDestroy(self)

Destroy the current buffer.

bufferHasChanged(self)

Return True if buffer has changed since last save.

bufferNew(self)

Create new buffer.

bufferOpen(self)

Open file in buffer.

bufferSave(self)

Save buffer to its file.

bufferSaveAs(self)

Save buffer to a new filename.

bufferSuggestSave(self)

Suggest saving changes. Return True if user selected Cancel.

hasBuffer(self)

Return True if there is a current buffer.

OnAbout(self, event)

Display an About window.

Overrides:
wx.py.frame.Frame.OnAbout

OnClose(self, event)

Event handler for closing.

Overrides:
wx.py.frame.Frame.OnClose

OnIdle(self, event)

Event handler for idle time.

updateNamespace(self)

Update the buffer namespace for autocompletion and calltips.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:05 2005 http://epydoc.sf.net


wx.py.editor.EditorNotebook

Package wx :: Package py :: Module editor :: Class EditorNotebook
[frames | no frames]

Type EditorNotebook

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
               Control --+
                         |
              BookCtrlBase --+
                             |
                      Notebook --+
                                 |
                                EditorNotebook

A notebook containing a page for each editor.

Method Summary
 | __init__(self, parent) Create EditorNotebook instance.
 | OnIdle(self, event) Event handler for idle time.
 | OnPageChanged(self, event) Page changed event handler.
 | OnPageChanging(self, event) Page changing event handler.

Instance Method Details

__init__(self, parent)
(Constructor)

Create EditorNotebook instance.

Overrides:
wx.Notebook.__init__

OnIdle(self, event)

Event handler for idle time.

OnPageChanged(self, event)

Page changed event handler.

OnPageChanging(self, event)

Page changing event handler.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:51 2005 http://epydoc.sf.net


wx.py.editor.EditorNotebookFrame

Package wx :: Package py :: Module editor :: Class EditorNotebookFrame
[frames | no frames]

Type EditorNotebookFrame

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
        TopLevelWindow --+
                         |
                     Frame --+
                             |
                         Frame --+
                                 |
                       EditorFrame --+
                                     |
                                    EditorNotebookFrame

Known Subclasses:
EditorShellNotebookFrame

Frame containing one or more editors in a notebook.

Method Summary
 | __init__(self, parent, id, title, pos, size, style, filename) Create EditorNotebookFrame instance.
 | bufferCreate(self, filename) Create new buffer.
 | bufferDestroy(self) Destroy the current buffer.
 | bufferNew(self) Create new buffer.
 | bufferOpen(self) Open file in buffer.
 | OnAbout(self, event) Display an About window.

Class Variable Summary

Instance Method Details

__init__(self,
          parent=None,
          id=-1,
          title='PyAlaMode',
          pos=wx.Point(-1, -1),
          size=(800, 600),
          style=541072960,
          filename=None)
(Constructor)

Create EditorNotebookFrame instance.

Overrides:
wx.py.editor.EditorFrame.__init__

bufferCreate(self, filename=None)

Create new buffer.

Overrides:
wx.py.editor.EditorFrame.bufferCreate

bufferDestroy(self)

Destroy the current buffer.

Overrides:
wx.py.editor.EditorFrame.bufferDestroy

bufferNew(self)

Create new buffer.

Overrides:
wx.py.editor.EditorFrame.bufferNew

bufferOpen(self)

Open file in buffer.

Overrides:
wx.py.editor.EditorFrame.bufferOpen

OnAbout(self, event)

Display an About window.

Overrides:
wx.py.editor.EditorFrame.OnAbout

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:46 2005 http://epydoc.sf.net


wx.py.editor.EditorShellNotebook

Package wx :: Package py :: Module editor :: Class EditorShellNotebook
[frames | no frames]

Type EditorShellNotebook

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
               Control --+
                         |
              BookCtrlBase --+
                             |
                      Notebook --+
                                 |
                                EditorShellNotebook

A notebook containing an editor page and a shell page.

Method Summary
 | __init__(self, parent, filename) Create EditorShellNotebook instance.
 | OnPageChanged(self, event) Page changed event handler.
 | SetFocus(self)

Instance Method Details

__init__(self, parent, filename=None)
(Constructor)

Create EditorShellNotebook instance.

Overrides:
wx.Notebook.__init__

OnPageChanged(self, event)

Page changed event handler.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:06 2005 http://epydoc.sf.net


wx.py.editor.EditorShellNotebookFrame

Package wx :: Package py :: Module editor :: Class EditorShellNotebookFrame
[frames | no frames]

Type EditorShellNotebookFrame

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
        TopLevelWindow --+
                         |
                     Frame --+
                             |
                         Frame --+
                                 |
                       EditorFrame --+
                                     |
                   EditorNotebookFrame --+
                                         |
                                        EditorShellNotebookFrame

Frame containing a notebook containing EditorShellNotebooks.

Method Summary
 | __init__(self, parent, id, title, pos, size, style, filename, singlefile) Create EditorShellNotebookFrame instance.
 | bufferCreate(self, filename) Create new buffer.
 | bufferDestroy(self) Destroy the current buffer.
 | bufferNew(self) Create new buffer.
 | bufferOpen(self) Open file in buffer.
 | OnAbout(self, event) Display an About window.

Class Variable Summary

Instance Method Details

__init__(self,
          parent=None,
          id=-1,
          title='PyAlaModeTest',
          pos=wx.Point(-1, -1),
          size=(600, 400),
          style=541072960,
          filename=None,
          singlefile=False)
(Constructor)

Create EditorShellNotebookFrame instance.

Overrides:
wx.py.editor.EditorNotebookFrame.__init__

bufferCreate(self, filename=None)

Create new buffer.

Overrides:
wx.py.editor.EditorNotebookFrame.bufferCreate

bufferDestroy(self)

Destroy the current buffer.

Overrides:
wx.py.editor.EditorNotebookFrame.bufferDestroy

bufferNew(self)

Create new buffer.

Overrides:
wx.py.editor.EditorNotebookFrame.bufferNew

bufferOpen(self)

Open file in buffer.

Overrides:
wx.py.editor.EditorNotebookFrame.bufferOpen

OnAbout(self, event)

Display an About window.

Overrides:
wx.py.editor.EditorNotebookFrame.OnAbout

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:25 2005 http://epydoc.sf.net


wx.py.editor.EditWindow

Package wx :: Package py :: Module editor :: Class EditWindow
[frames | no frames]

Type EditWindow

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
               Control --+
                         |
            StyledTextCtrl --+
                             |
                    EditWindow --+
                                 |
                                EditWindow

EditWindow based on StyledTextCtrl.

Method Summary
__init__(self, editor, parent, id, pos, size, style)
Create EditWindow instance.

Class Variable Summary

Instance Method Details

__init__(self, editor, parent, id=-1, pos=wx.Point(-1, -1), size=wx.Size(-1, -1), style=138412032)
(Constructor)

Create EditWindow instance.

Overrides:
wx.py.editwindow.EditWindow.__init__

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:42 2005 http://epydoc.sf.net


wx.py.editor

Package wx :: Package py :: Module editor

Module wx.py.editor

PyAlaCarte and PyAlaMode editors.

Classes
DialogResults | DialogResults class.
Editor | Editor having an EditWindow.
EditorFrame | Frame containing one editor.
EditorNotebook | A notebook containing a page for each editor.
EditorNotebookFrame | Frame containing one or more editors in a notebook.
EditorShellNotebook | A notebook containing an editor page and a shell page.
EditorShellNotebookFrame | Frame containing a notebook containing EditorShellNotebooks.
EditWindow | EditWindow based on StyledTextCtrl.

Function Summary
 | directory(parent, message, path, style, pos, size) Dir dialog wrapper function.
 | fileDialog(parent, title, directory, filename, wildcard, style) File dialog wrapper function.
 | messageDialog(parent, message, title, style, pos) Message dialog wrapper function.
 | openMultiple(parent, title, directory, filename, wildcard, style) File dialog wrapper function.
 | openSingle(parent, title, directory, filename, wildcard, style) File dialog wrapper function.
 | saveSingle(parent, title, directory, filename, wildcard, style) File dialog wrapper function.

Variable Summary
str | __author__ = "Patrick K. O'Brien <pobrien@orbtech.com>"
str | __cvsid__ = '$Id: editor.py,v 1.7 2004/06/14 20:17:31 RD...
str | __revision__ = '1.7'

Function Details

directory(parent=None,
          message='Choose a directory',
          path='',
          style=0,
          pos=wx.Point(-1, -1),
          size=wx.Size(-1, -1))

Dir dialog wrapper function.

fileDialog(parent=None,
          title='Open',
          directory='',
          filename='',
          wildcard='All Files (*.*)|*.*',
          style=33)

File dialog wrapper function.

messageDialog(parent=None,
          message='',
          title='Message box',
          style=1051,
          pos=wx.Point(-1, -1))

Message dialog wrapper function.

openMultiple(parent=None,
          title='Open',
          directory='',
          filename='',
          wildcard='All Files (*.*)|*.*',
          style=33)

File dialog wrapper function.

openSingle(parent=None,
          title='Open',
          directory='',
          filename='',
          wildcard='All Files (*.*)|*.*',
          style=1)

File dialog wrapper function.

saveSingle(parent=None,
          title='Save',
          directory='',
          filename='',
          wildcard='All Files (*.*)|*.*',
          style=14)

File dialog wrapper function.

Variable Details

__author__

Type:
str
Value:
"Patrick K. O'Brien <pobrien@orbtech.com>"

__cvsid__

Type:
str
Value:
'$Id: editor.py,v 1.7 2004/06/14 20:17:31 RD Exp $'

__revision__

Type:
str
Value:
'1.7'

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:55 2005 http://epydoc.sf.net


wx.py.editwindow.EditWindow

Package wx :: Package py :: Module editwindow :: Class EditWindow
[frames | no frames]

Type EditWindow

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
               Control --+
                         |
            StyledTextCtrl --+
                             |
                            EditWindow

Known Subclasses:
Display, EditWindow, FillingText, Shell

EditWindow based on StyledTextCtrl.

Method Summary
 | __init__(self, parent, id, pos, size, style) Create EditWindow instance.
 | CanCopy(self) Return True if text is selected and can be copied.
 | CanCut(self) Return True if text is selected and can be cut.
 | CanEdit(self) Return True if editing should succeed.
 | CanPaste(self) Return True if pasting should succeed.
 | OnUpdateUI(self, event) Check for matching braces.
 | setStyles(self, faces) Configure font size, typeface and color for lexer.

Class Variable Summary
str revision = '1.10'

Instance Method Details

__init__(self, parent, id=-1, pos=wx.Point(-1, -1), size=wx.Size(-1, -1), style=138412032)
(Constructor)

Create EditWindow instance.

Overrides:
wx.stc.StyledTextCtrl.__init__

CanCopy(self)

Return True if text is selected and can be copied.

CanCut(self)

Return True if text is selected and can be cut.

CanEdit(self)

Return True if editing should succeed.

CanPaste(self)

Return True if pasting should succeed.

Overrides:
wx.stc.StyledTextCtrl.CanPaste

OnUpdateUI(self, event)

Check for matching braces.

setStyles(self, faces)

Configure font size, typeface and color for lexer.

Class Variable Details

revision

Type:
str
Value:
'1.10'

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:10 2005 http://epydoc.sf.net


wx.py.editwindow

Package wx :: Package py :: Module editwindow

Module wx.py.editwindow

EditWindow class.

Classes
EditWindow EditWindow based on StyledTextCtrl.

Variable Summary
str | __author__ = "Patrick K. O'Brien <pobrien@orbtech.com>"
str | __cvsid__ = '$Id: editwindow.py,v 1.10 2004/03/26 19:26:...
str | __revision__ = '1.10'

Variable Details

__author__

Type:
str
Value:
"Patrick K. O'Brien <pobrien@orbtech.com>"

__cvsid__

Type:
str
Value:
'$Id: editwindow.py,v 1.10 2004/03/26 19:26:34 RD Exp $'

__revision__

Type:
str
Value:
'1.10'

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:51 2005 http://epydoc.sf.net


wx.py.filling.App

Package wx :: Package py :: Module filling :: Class App

Type App

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
             PyApp --+
                     |
                   App --+
                         |
                        App

Known Subclasses:
App

PyFilling standalone application.

Method Summary
OnInit(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:02 2005 http://epydoc.sf.net


wx.py.filling.Filling

Package wx :: Package py :: Module filling :: Class Filling

Type Filling

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
        SplitterWindow --+
                         |
                        Filling

Filling based on wxSplitterWindow.

Method Summary
__init__(self, parent, id, pos, size, style, name, rootObject, rootLabel, rootIsNamespace, static)
Create a Filling instance.

Class Variable Summary
str | name = 'Filling'
str | revision = '1.5'

Instance Method Details

__init__(self,
          parent,
          id=-1,
          pos=wx.Point(-1, -1),
          size=wx.Size(-1, -1),
          style=768,
          name='Filling Window',
          rootObject=None,
          rootLabel=None,
          rootIsNamespace=False,
          static=False)
(Constructor)

Create a Filling instance.

Overrides:
wx.SplitterWindow.__init__

Class Variable Details

name

Type:
str
Value:
'Filling'

revision

Type:
str
Value:
'1.5'

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:42 2005 http://epydoc.sf.net


wx.py.filling.FillingFrame

Package wx :: Package py :: Module filling :: Class FillingFrame
[frames | no frames]

Type FillingFrame

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
        TopLevelWindow --+
                         |
                     Frame --+
                             |
                            FillingFrame

Frame containing the namespace tree component.

Method Summary
__init__(self, parent, id, title, pos, size, style, rootObject, rootLabel, rootIsNamespace, static)
Create FillingFrame instance.

Class Variable Summary
str | name = 'Filling Frame'
str | revision = '1.5'

Instance Method Details

__init__(self,
          parent=None,
          id=-1,
          title='PyFilling',
          pos=wx.Point(-1, -1),
          size=(600, 400),
          style=541072960,
          rootObject=None,
          rootLabel=None,
          rootIsNamespace=False,
          static=False)
(Constructor)

Create FillingFrame instance.

Overrides:
wx.Frame.__init__

Class Variable Details

name

Type:
str
Value:
'Filling Frame'

revision

Type:
str
Value:
'1.5'

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:46 2005 http://epydoc.sf.net


wx.py.filling.FillingText

Package wx :: Package py :: Module filling :: Class FillingText
[frames | no frames]

Type FillingText

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
               Control --+
                         |
            StyledTextCtrl --+
                             |
                    EditWindow --+
                                 |
                                FillingText

FillingText based on StyledTextCtrl.

Method Summary
 | __init__(self, parent, id, pos, size, style, static) Create FillingText instance.
 | push(self, command, more) Receiver for Interpreter.push signal.
 | SetText(self, *args, **kwds)

Class Variable Summary
str | name = 'Filling Text'
str | revision = '1.5'

Instance Method Details

__init__(self,
          parent,
          id=-1,
          pos=wx.Point(-1, -1),
          size=wx.Size(-1, -1),
          style=4194304,
          static=False)
(Constructor)

Create FillingText instance.

Overrides:
wx.py.editwindow.EditWindow.__init__

push(self, command, more)

Receiver for Interpreter.push signal.

Class Variable Details

name

Type:
str
Value:
'Filling Text'

revision

Type:
str
Value:
'1.5'

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:11 2005 http://epydoc.sf.net


wx.py.filling.FillingTree

Package wx :: Package py :: Module filling :: Class FillingTree
[frames | no frames]

Type FillingTree

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
               Control --+
                         |
                  TreeCtrl --+
                             |
                            FillingTree

FillingTree based on TreeCtrl.

Method Summary
 | __init__(self, parent, id, pos, size, style, rootObject, rootLabel, rootIsNamespace, static) Create FillingTree instance.
 | addChildren(self, item)
 | display(self)
 | getFullName(self, item, partial) Return a syntactically proper name for item.
 | objGetChildren(self, obj) Return dictionary with attributes or contents of object.
 | objHasChildren(self, obj) Return true if object has children.
 | OnItemActivated(self, event) Launch a DirFrame.
 | OnItemCollapsed(self, event) Remove all children from the item.
 | OnItemExpanding(self, event) Add children to the item.
 | OnSelChanged(self, event) Display information about the item.
 | push(self, command, more) Receiver for Interpreter.push signal.
 | setStatusText(self, text) Display status information.
 | setText(self, text) Display information about the current selection.

Class Variable Summary
str | name = 'Filling Tree'
str | revision = '1.5'

Instance Method Details

__init__(self,
          parent,
          id=-1,
          pos=wx.Point(-1, -1),
          size=wx.Size(-1, -1),
          style=5,
          rootObject=None,
          rootLabel=None,
          rootIsNamespace=False,
          static=False)
(Constructor)

Create FillingTree instance.

Overrides:
wx.TreeCtrl.__init__

getFullName(self, item, partial='')

Return a syntactically proper name for item.

objGetChildren(self, obj)

Return dictionary with attributes or contents of object.

objHasChildren(self, obj)

Return true if object has children.

OnItemActivated(self, event)

Launch a DirFrame.

OnItemCollapsed(self, event)

Remove all children from the item.

OnItemExpanding(self, event)

Add children to the item.

OnSelChanged(self, event)

Display information about the item.

push(self, command, more)

Receiver for Interpreter.push signal.

setStatusText(self, text)

Display status information.

setText(self, text)

Display information about the current selection.

Class Variable Details

name

Type:
str
Value:
'Filling Tree'

revision

Type:
str
Value:
'1.5'

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:32 2005 http://epydoc.sf.net


wx.py.filling

Package wx :: Package py :: Module filling

Module wx.py.filling

Filling is the gui tree control through which a user can navigate the local namespace or any object.

Classes
App | PyFilling standalone application.
Filling | Filling based on wxSplitterWindow.
FillingFrame | Frame containing the namespace tree component.
FillingText | FillingText based on StyledTextCtrl.
FillingTree | FillingTree based on TreeCtrl.

Variable Summary
str | __author__ = "Patrick K. O'Brien <pobrien@orbtech.com>"
str | __cvsid__ = '$Id: filling.py,v 1.5 2004/02/13 02:47:58 P...
str | __revision__ = '1.5'
list | COMMONTYPES = [<type 'bool'>, <type 'buffer'>, <type 'bu...
tuple | DOCTYPES = ('BuiltinFunctionType', 'BuiltinMethodType', ...
list | SIMPLETYPES = [<type 'bool'>, <type 'buffer'>, <type 'co...

Variable Details

__author__

Type:
str
Value:
"Patrick K. O'Brien <pobrien@orbtech.com>"

__cvsid__

Type:
str
Value:
'$Id: filling.py,v 1.5 2004/02/13 02:47:58 PKO Exp $'

__revision__

Type:
str
Value:
'1.5'

COMMONTYPES

Type:
list
Value:
[<type 'bool'>,
 <type 'buffer'>,
 <type 'builtin_function_or_method'>,
 <type 'builtin_function_or_method'>,
 <type 'code'>,
 <type 'complex'>,
 <type 'dictproxy'>,
 <type 'dict'>,
...

DOCTYPES

Type:
tuple
Value:
('BuiltinFunctionType',
 'BuiltinMethodType',
 'ClassType',
 'FunctionType',
 'GeneratorType',
 'InstanceType',
 'LambdaType',
 'MethodType',
...

SIMPLETYPES

Type:
list
Value:
[<type 'bool'>,
 <type 'buffer'>,
 <type 'code'>,
 <type 'complex'>,
 <type 'dictproxy'>,
 <type 'dict'>,
 <type 'dict'>,
 <type 'ellipsis'>,
...

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:56 2005 http://epydoc.sf.net


wx.py.frame.Frame

Package wx :: Package py :: Module frame :: Class Frame

Type Frame

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
        TopLevelWindow --+
                         |
                     Frame --+
                             |
                            Frame

Known Subclasses:
CrustFrame, EditorFrame, ShellFrame

Frame with standard menu items.

Method Summary
 | __init__(self, parent, id, title, pos, size, style) Create a Frame instance.
 | OnAbout(self, event) Display an About window.
 | OnAutoCompleteDouble(self, event)
 | OnAutoCompleteMagic(self, event)
 | OnAutoCompleteShow(self, event)
 | OnAutoCompleteSingle(self, event)
 | OnCallTipsShow(self, event)
 | OnClear(self, event)
 | OnClose(self, event) Event handler for closing.
 | OnCopy(self, event)
 | OnCopyPlus(self, event)
 | OnCut(self, event)
 | OnExit(self, event)
 | OnFileClose(self, event)
 | OnFileNew(self, event)
 | OnFileOpen(self, event)
 | OnFilePrint(self, event)
 | OnFileRevert(self, event)
 | OnFileSave(self, event)
 | OnFileSaveAs(self, event)
 | OnFileUpdateNamespace(self, event)
 | OnPaste(self, event)
 | OnPastePlus(self, event)
 | OnRedo(self, event)
 | OnSelectAll(self, event)
 | OnUndo(self, event)
 | OnUpdateMenu(self, event) Update menu items based on current status and context.
 | OnUseAA(self, event)
 | OnWrap(self, event)

Class Variable Summary
str revision = '1.6'

Instance Method Details

__init__(self,
          parent=None,
          id=-1,
          title='Editor',
          pos=wx.Point(-1, -1),
          size=wx.Size(-1, -1),
          style=541072960)
(Constructor)

Create a Frame instance.

Overrides:
wx.Frame.__init__

OnAbout(self, event)

Display an About window.

OnClose(self, event)

Event handler for closing.

OnUpdateMenu(self, event)

Update menu items based on current status and context.

Class Variable Details

revision

Type:
str
Value:
'1.6'

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:04 2005 http://epydoc.sf.net


wx.py.frame

Package wx :: Package py :: Module frame

Module wx.py.frame

Base frame with menu.

Classes
Frame Frame with standard menu items.

Variable Summary
str | __author__ = "Patrick K. O'Brien <pobrien@orbtech.com>"
str | __cvsid__ = '$Id: frame.py,v 1.6 2004/02/23 22:36:20 RD ...
str | __revision__ = '1.6'
int | ID_ABOUT = 5013
int | ID_AUTOCOMP = 104
int | ID_AUTOCOMP_DOUBLE = 108
int | ID_AUTOCOMP_MAGIC = 106
int | ID_AUTOCOMP_SHOW = 105
int | ID_AUTOCOMP_SINGLE = 107
int | ID_CALLTIPS = 109
int | ID_CALLTIPS_SHOW = 110
int | ID_CLEAR = 5033
int | ID_CLOSE = 5001
int | ID_COPY = 5031
int | ID_COPY_PLUS = 111
int | ID_CUT = 5030
int | ID_EXIT = 5006
int | ID_NAMESPACE = 112
int | ID_NEW = 5002
int | ID_OPEN = 5000
int | ID_PASTE = 5032
int | ID_PASTE_PLUS = 113
int | ID_PRINT = 5010
int | ID_REDO = 5008
int | ID_REVERT = 5005
int | ID_SAVE = 5003
int | ID_SAVEAS = 5004
int | ID_SELECTALL = 5036
int | ID_UNDO = 5007
int | ID_USEAA = 115
int | ID_WRAP = 114

Variable Details

__author__

Type:
str
Value:
"Patrick K. O'Brien <pobrien@orbtech.com>"

__cvsid__

Type:
str
Value:
'$Id: frame.py,v 1.6 2004/02/23 22:36:20 RD Exp $'

__revision__

Type:
str
Value:
'1.6'

ID_ABOUT

Type:
int
Value:
5013

ID_AUTOCOMP

Type:
int
Value:
104

ID_AUTOCOMP_DOUBLE

Type:
int
Value:
108

ID_AUTOCOMP_MAGIC

Type:
int
Value:
106

ID_AUTOCOMP_SHOW

Type:
int
Value:
105

ID_AUTOCOMP_SINGLE

Type:
int
Value:
107

ID_CALLTIPS

Type:
int
Value:
109

ID_CALLTIPS_SHOW

Type:
int
Value:
110

ID_CLEAR

Type:
int
Value:
5033

ID_CLOSE

Type:
int
Value:
5001

ID_COPY

Type:
int
Value:
5031

ID_COPY_PLUS

Type:
int
Value:
111

ID_CUT

Type:
int
Value:
5030

ID_EXIT

Type:
int
Value:
5006

ID_NAMESPACE

Type:
int
Value:
112

ID_NEW

Type:
int
Value:
5002

ID_OPEN

Type:
int
Value:
5000

ID_PASTE

Type:
int
Value:
5032

ID_PASTE_PLUS

Type:
int
Value:
113

ID_PRINT

Type:
int
Value:
5010

ID_REDO

Type:
int
Value:
5008

ID_REVERT

Type:
int
Value:
5005

ID_SAVE

Type:
int
Value:
5003

ID_SAVEAS

Type:
int
Value:
5004

ID_SELECTALL

Type:
int
Value:
5036

ID_UNDO

Type:
int
Value:
5007

ID_USEAA

Type:
int
Value:
115

ID_WRAP

Type:
int
Value:
114

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:09 2005 http://epydoc.sf.net


wx.py.images

Package wx :: Package py :: Module images

Module wx.py.images

Support for icons.

Function Summary
 | getPyBitmap()
 | getPyData()
 | getPyIcon()
 | getPyImage()

Variable Summary
str | __author__ = "Patrick K. O'Brien <pobrien@orbtech.com>"
str | __cvsid__ = '$Id: images.py,v 1.4 2003/11/12 21:28:54 RD...
str | __revision__ = '1.4'

Variable Details

__author__

Type:
str
Value:
"Patrick K. O'Brien <pobrien@orbtech.com>"

__cvsid__

Type:
str
Value:
'$Id: images.py,v 1.4 2003/11/12 21:28:54 RD Exp $'

__revision__

Type:
str
Value:
'1.4'

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:01 2005 http://epydoc.sf.net


wx.py.interpreter.InterpreterAlaCarte

Package wx :: Package py :: Module interpreter :: Class InterpreterAlaCarte
[frames | no frames]

Class InterpreterAlaCarte

InteractiveInterpreter --+
                         |
               Interpreter --+
                             |
                            InterpreterAlaCarte

Demo Interpreter.

Method Summary
__init__(self, locals, rawin, stdin, stdout, stderr, ps1, ps2)
Create an interactive interpreter object.

Class Variable Summary

Method Details

__init__(self, locals, rawin, stdin, stdout, stderr, ps1='main prompt', ps2='continuation prompt')
(Constructor)

Create an interactive interpreter object.

Overrides:
wx.py.interpreter.Interpreter.__init__

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:16 2005 http://epydoc.sf.net


wx.py.interpreter.Interpreter

Package wx :: Package py :: Module interpreter :: Class Interpreter
[frames | no frames]

Class Interpreter

InteractiveInterpreter --+
                         |
                        Interpreter

Known Subclasses:
InterpreterAlaCarte

Interpreter based on code.InteractiveInterpreter.

Method Summary
 | __init__(self, locals, rawin, stdin, stdout, stderr) Create an interactive interpreter object.
 | getAutoCompleteKeys(self) Return list of auto-completion keycodes.
 | getAutoCompleteList(self, command, *args, **kwds) Return list of auto-completion options for a command.
 | getCallTip(self, command, *args, **kwds) Return call tip text for a command.
 | push(self, command) Send command to the interpreter to be executed.
 | runsource(self, source) Compile and run source code in the interpreter.

Class Variable Summary
str revision = '1.6'

Method Details

__init__(self,
          locals=None,
          rawin=None,
          stdin=<epydoc.imports._DevNull instance at 0xb7bbcccc>,
          stdout=<epydoc.imports._DevNull instance at 0xb7bbcccc>,
          stderr=<epydoc.imports._DevNull instance at 0xb7bbcccc>)
(Constructor)

Create an interactive interpreter object.

Overrides:
code.InteractiveInterpreter.__init__

getAutoCompleteKeys(self)

Return list of auto-completion keycodes.

getAutoCompleteList(self, command='', *args, **kwds)

Return list of auto-completion options for a command.

The list of options will be based on the locals namespace.

getCallTip(self, command='', *args, **kwds)

Return call tip text for a command.

Call tip information will be based on the locals namespace.

push(self, command)

Send command to the interpreter to be executed.

Because this may be called recursively, we append a new list onto the commandBuffer list and then append commands into that. If the passed in command is part of a multi-line command we keep appending the pieces to the last list in commandBuffer until we have a complete command. If not, we delete that last list.

runsource(self, source)

Compile and run source code in the interpreter.

Overrides:
code.InteractiveInterpreter.runsource

Class Variable Details

revision

Type:
str
Value:
'1.6'

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:25 2005 http://epydoc.sf.net


wx.py.interpreter

Package wx :: Package py :: Module interpreter

Module wx.py.interpreter

Interpreter executes Python commands.

Classes
Interpreter | Interpreter based on code.InteractiveInterpreter.
InterpreterAlaCarte | Demo Interpreter.

Variable Summary
str | __author__ = "Patrick K. O'Brien <pobrien@orbtech.com>"
str | __cvsid__ = '$Id: interpreter.py,v 1.6 2005/03/25 20:34:...
str | __revision__ = '1.6'

Variable Details

__author__

Type:
str
Value:
"Patrick K. O'Brien <pobrien@orbtech.com>"

__cvsid__

Type:
str
Value:
'$Id: interpreter.py,v 1.6 2005/03/25 20:34:52 RD Exp $'

__revision__

Type:
str
Value:
'1.6'

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:51 2005 http://epydoc.sf.net


wx.py.introspect

Package wx :: Package py :: Module introspect

Module wx.py.introspect

Provides a variety of introspective-type support functions for things like call tips and command auto completion.

Function Summary
 | getAllAttributeNames(object) Return dict of all attributes, including inherited, for an object.
 | getAttributeNames(object, includeMagic, includeSingle, includeDouble) Return list of unique attributes, including inherited, for object.
 | getAutoCompleteList(command, locals, includeMagic, includeSingle, includeDouble) Return list of auto-completion options for command.
 | getBaseObject(object) Return base object and dropSelf indicator for an object.
 | getCallTip(command, locals) For a command, return a tuple of object name, argspec, tip text.
 | getConstructor(object) Return constructor for class object, or None if there isn't one.
 | getRoot(command, terminator) Return the rightmost root portion of an arbitrary Python command.
 | getTokens(command) Return list of token tuples for command.
 | hasattrAlwaysReturnsTrue(object)
 | rtrimTerminus(command, terminator) Return command minus anything that follows the final terminator.

Variable Summary
str | __author__ = "Patrick K. O'Brien <pobrien@orbtech.com>"
str | __cvsid__ = '$Id: introspect.py,v 1.11 2005/03/25 20:34:...
str | __revision__ = '1.11'

Function Details

getAllAttributeNames(object)

Return dict of all attributes, including inherited, for an object.

Recursively walk through a class and all base classes.

getAttributeNames(object,
          includeMagic=1,
          includeSingle=1,
          includeDouble=1)

Return list of unique attributes, including inherited, for object.

getAutoCompleteList(command='',
          locals=None,
          includeMagic=1,
          includeSingle=1,
          includeDouble=1)

Return list of auto-completion options for command.

The list of options will be based on the locals namespace.

getBaseObject(object)

Return base object and dropSelf indicator for an object.

getCallTip(command='', locals=None)

For a command, return a tuple of object name, argspec, tip text.

The call tip information will be based on the locals namespace.

getConstructor(object)

Return constructor for class object, or None if there isn't one.

getRoot(command, terminator=None)

Return the rightmost root portion of an arbitrary Python command.

Return only the root portion that can be eval()'d without side effects. The command would normally terminate with a '(' or '.'. The terminator and anything after the terminator will be dropped.

getTokens(command)

Return list of token tuples for command.

rtrimTerminus(command, terminator=None)

Return command minus anything that follows the final terminator.

Variable Details

__author__

Type:
str
Value:
"Patrick K. O'Brien <pobrien@orbtech.com>"

__cvsid__

Type:
str
Value:
'$Id: introspect.py,v 1.11 2005/03/25 20:34:52 RD Exp $'

__revision__

Type:
str
Value:
'1.11'

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:51 2005 http://epydoc.sf.net


wx.py.pseudo.PseudoFile

Package wx :: Package py :: Module pseudo :: Class PseudoFile
[frames | no frames]

Class PseudoFile

Known Subclasses:
PseudoFileErr, PseudoFileIn, PseudoFileOut
Method Summary
 | __init__(self) Create a file-like object.
 | flush(self)
 | isatty(self)
 | readline(self)
 | write(self, s)
 | writelines(self, l)

Method Details

__init__(self)
(Constructor)

Create a file-like object.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:46 2005 http://epydoc.sf.net


wx.py.pseudo.PseudoFileErr

Package wx :: Package py :: Module pseudo :: Class PseudoFileErr
[frames | no frames]

Class PseudoFileErr

PseudoFile --+
             |
            PseudoFileErr

Method Summary
 | __init__(self, write)
 | isatty(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:16 2005 http://epydoc.sf.net


wx.py.pseudo.PseudoFileIn

Package wx :: Package py :: Module pseudo :: Class PseudoFileIn
[frames | no frames]

Class PseudoFileIn

PseudoFile --+
             |
            PseudoFileIn

Method Summary
 | __init__(self, readline, readlines)
 | isatty(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:46 2005 http://epydoc.sf.net


wx.py.pseudo.PseudoFileOut

Package wx :: Package py :: Module pseudo :: Class PseudoFileOut
[frames | no frames]

Class PseudoFileOut

PseudoFile --+
             |
            PseudoFileOut

Method Summary
 | __init__(self, write)
 | isatty(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:47 2005 http://epydoc.sf.net


wx.py.pseudo.PseudoKeyword

Package wx :: Package py :: Module pseudo :: Class PseudoKeyword
[frames | no frames]

Class PseudoKeyword

A callable class that calls a method passed as a parameter.

Good for creating a pseudo keyword in the python runtime environment. The keyword is really an object that has a repr() that calls itself which calls the method that was passed in the init of the object. All this just to avoid having to type in the closing parens on a method. So, for example:

>>> quit = PseudoKeyword(SomeObject.someMethod)
>>> quit

SomeObject.someMethod gets executed as if it had been called directly and the user didn't have to type the parens, like 'quit()'. This technique is most applicable for pseudo keywords like quit, exit and help.

If SomeObject.someMethod can take parameters, they can still be passed by using the keyword in the traditional way with parens.

Method Summary
 | __init__(self, method) Create a callable object that executes method when called.
 | __call__(self, *args, **kwds)
 | __repr__(self)

Method Details

__init__(self, method)
(Constructor)

Create a callable object that executes method when called.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:46 2005 http://epydoc.sf.net


wx.py.pseudo

Package wx :: Package py :: Module pseudo

Module wx.py.pseudo

Provides a variety of classes to create pseudo keywords and pseudo files.

Classes
PseudoFile |
PseudoFileErr |
PseudoFileIn |
PseudoFileOut |
PseudoKeyword | A callable class that calls a method passed as a parameter.

Variable Summary
str | __author__ = "Patrick K. O'Brien <pobrien@orbtech.com>"
str | __cvsid__ = '$Id: pseudo.py,v 1.5 2004/02/13 02:47:58 PK...
str | __revision__ = '1.5'

Variable Details

__author__

Type:
str
Value:
"Patrick K. O'Brien <pobrien@orbtech.com>"

__cvsid__

Type:
str
Value:
'$Id: pseudo.py,v 1.5 2004/02/13 02:47:58 PKO Exp $'

__revision__

Type:
str
Value:
'1.5'

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:10:53 2005 http://epydoc.sf.net


wx.py.PyAlaCarte.App

Package wx :: Package py :: Module PyAlaCarte :: Class App

Type App

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
             PyApp --+
                     |
                   App --+
                         |
                        App

PyAlaCarte standalone application.

Method Summary
 | __init__(self, filename)
 | OnInit(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:10:48 2005 http://epydoc.sf.net


wx.py.PyAlaCarte

Package wx :: Package py :: Module PyAlaCarte

Module wx.py.PyAlaCarte

PyAlaCarte is a simple programmer's editor.

Classes
App PyAlaCarte standalone application.

Function Summary
main(filename)

Variable Summary
str | __author__ = "Patrick K. O'Brien <pobrien@orbtech.com>"
str | __cvsid__ = '$Id: PyAlaCarte.py,v 1.6 2004/03/15 13:42:3...
str | __revision__ = '1.6'

Variable Details

__author__

Type:
str
Value:
"Patrick K. O'Brien <pobrien@orbtech.com>"

__cvsid__

Type:
str
Value:
'$Id: PyAlaCarte.py,v 1.6 2004/03/15 13:42:37 PKO Exp $'

__revision__

Type:
str
Value:
'1.6'

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:16 2005 http://epydoc.sf.net


wx.py.PyAlaMode.App

Package wx :: Package py :: Module PyAlaMode :: Class App

Type App

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
             PyApp --+
                     |
                   App --+
                         |
                        App

PyAlaMode standalone application.

Method Summary
 | __init__(self, filename)
 | OnInit(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:27 2005 http://epydoc.sf.net


wx.py.PyAlaMode

Package wx :: Package py :: Module PyAlaMode

Module wx.py.PyAlaMode

PyAlaMode is a programmer's editor.

Classes
App PyAlaMode standalone application.

Function Summary
main(filename)

Variable Summary
str | __author__ = "Patrick K. O'Brien <pobrien@orbtech.com>"
str | __cvsid__ = '$Id: PyAlaMode.py,v 1.6 2004/03/15 13:42:37...
str | __revision__ = '1.6'

Variable Details

__author__

Type:
str
Value:
"Patrick K. O'Brien <pobrien@orbtech.com>"

__cvsid__

Type:
str
Value:
'$Id: PyAlaMode.py,v 1.6 2004/03/15 13:42:37 PKO Exp $'

__revision__

Type:
str
Value:
'1.6'

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:40 2005 http://epydoc.sf.net


wx.py.PyAlaModeTest.App

Package wx :: Package py :: Module PyAlaModeTest :: Class App
[frames | no frames]

Type App

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
             PyApp --+
                     |
                   App --+
                         |
                        App

PyAlaModeTest standalone application.

Method Summary
 | __init__(self, filename)
 | OnInit(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:33 2005 http://epydoc.sf.net


wx.py.PyAlaModeTest

Package wx :: Package py :: Module PyAlaModeTest

Module wx.py.PyAlaModeTest

PyAlaModeTest is a programmer's editor.

Classes
App PyAlaModeTest standalone application.

Function Summary
main(filename)

Variable Summary
str | __author__ = "Patrick K. O'Brien <pobrien@orbtech.com>"
str | __cvsid__ = '$Id: PyAlaModeTest.py,v 1.4 2004/03/15 13:4...
str | __revision__ = '1.4'

Variable Details

__author__

Type:
str
Value:
"Patrick K. O'Brien <pobrien@orbtech.com>"

__cvsid__

Type:
str
Value:
'$Id: PyAlaModeTest.py,v 1.4 2004/03/15 13:42:37 PKO Exp $'

__revision__

Type:
str
Value:
'1.4'

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:47 2005 http://epydoc.sf.net


wx.py.PyCrust.App

Package wx :: Package py :: Module PyCrust :: Class App

Type App

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
             PyApp --+
                     |
                   App --+
                         |
                        App

PyCrust standalone application.

Method Summary
OnInit(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:39 2005 http://epydoc.sf.net


wx.py.PyCrust

Package wx :: Package py :: Module PyCrust

Module wx.py.PyCrust

PyCrust is a python shell and namespace browser application.

Classes
App PyCrust standalone application.

Function Summary
main()
The main function for the PyCrust program.

Variable Summary
str | __author__ = "Patrick K. O'Brien <pobrien@orbtech.com>"
str | __cvsid__ = '$Id: PyCrust.py,v 1.7 2004/03/15 13:42:37 P...
str | __revision__ = '1.7'
list | original = ['__builtins__', '__name__', '__file__', '__d...

Function Details

main()

The main function for the PyCrust program.

Variable Details

__author__

Type:
str
Value:
"Patrick K. O'Brien <pobrien@orbtech.com>"

__cvsid__

Type:
str
Value:
'$Id: PyCrust.py,v 1.7 2004/03/15 13:42:37 PKO Exp $'

__revision__

Type:
str
Value:
'1.7'

original

Type:
list
Value:
['__builtins__', '__name__', '__file__', '__doc__', 'cli']

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:41 2005 http://epydoc.sf.net


wx.py.PyFilling.App

Package wx :: Package py :: Module PyFilling :: Class App

Type App

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
             PyApp --+
                     |
                   App --+
                         |
                       App --+
                             |
                            App

Method Summary
OnInit(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:22 2005 http://epydoc.sf.net


wx.py.PyFilling

Package wx :: Package py :: Module PyFilling

Module wx.py.PyFilling

PyFilling is a python namespace inspection application.

Classes
App

Function Summary
main()
Create and run the application.

Variable Summary
str | __author__ = "Patrick K. O'Brien <pobrien@orbtech.com>"
str | __cvsid__ = '$Id: PyFilling.py,v 1.5 2004/02/13 02:47:58...
str | __revision__ = '1.5'
NoneType | app = None

Function Details

main()

Create and run the application.

Variable Details

__author__

Type:
str
Value:
"Patrick K. O'Brien <pobrien@orbtech.com>"

__cvsid__

Type:
str
Value:
'$Id: PyFilling.py,v 1.5 2004/02/13 02:47:58 PKO Exp $'

__revision__

Type:
str
Value:
'1.5'

app

Type:
NoneType
Value:
None

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:08 2005 http://epydoc.sf.net


wx.py.PyShell.App

Package wx :: Package py :: Module PyShell :: Class App

Type App

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
             PyApp --+
                     |
                   App --+
                         |
                        App

PyShell standalone application.

Method Summary
OnInit(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:10:47 2005 http://epydoc.sf.net


wx.py.PyShell

Package wx :: Package py :: Module PyShell

Module wx.py.PyShell

PyShell is a python shell application.

Classes
App PyShell standalone application.

Function Summary
main()
The main function for the PyShell program.

Variable Summary
str | __author__ = "Patrick K. O'Brien <pobrien@orbtech.com>"
str | __cvsid__ = '$Id: PyShell.py,v 1.7 2004/03/15 13:42:37 P...
str | __revision__ = '1.7'
list | original = ['__builtins__', '__name__', '__file__', '__d...

Function Details

main()

The main function for the PyShell program.

Variable Details

__author__

Type:
str
Value:
"Patrick K. O'Brien <pobrien@orbtech.com>"

__cvsid__

Type:
str
Value:
'$Id: PyShell.py,v 1.7 2004/03/15 13:42:37 PKO Exp $'

__revision__

Type:
str
Value:
'1.7'

original

Type:
list
Value:
['__builtins__', '__name__', '__file__', '__doc__', 'cli']

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:03 2005 http://epydoc.sf.net


wx.py.PyWrap

Package wx :: Package py :: Module PyWrap

Module wx.py.PyWrap

PyWrap is a command line utility that runs a wxPython program with additional runtime-tools, such as PyCrust.

Function Summary
 | main(modulename)
 | wrap(app)

Variable Summary
str | __author__ = "Patrick K. O'Brien <pobrien@orbtech.com>"
str | __cvsid__ = '$Id: PyWrap.py,v 1.6 2004/03/15 13:42:37 PK...
str | __revision__ = '1.6'

Variable Details

__author__

Type:
str
Value:
"Patrick K. O'Brien <pobrien@orbtech.com>"

__cvsid__

Type:
str
Value:
'$Id: PyWrap.py,v 1.6 2004/03/15 13:42:37 PKO Exp $'

__revision__

Type:
str
Value:
'1.6'

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:40 2005 http://epydoc.sf.net


wx.py.shell.Shell

Package wx :: Package py :: Module shell :: Class Shell

Type Shell

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
               Control --+
                         |
            StyledTextCtrl --+
                             |
                    EditWindow --+
                                 |
                                Shell

Shell based on StyledTextCtrl.

Method Summary
 | __init__(self, parent, id, pos, size, style, introText, locals, InterpClass, *args, **kwds) Create Shell instance.
 | about(self) Display information about Py.
 | addHistory(self, command) Add command to the command history.
 | ask(self, prompt) Get response from the user using a dialog box.
 | autoCallTipShow(self, command) Display argument spec and docstring in a popup window.
 | autoCompleteShow(self, command) Display auto-completion popup list.
 | CanCut(self) Return true if text is selected and can be cut.
 | CanEdit(self) Return true if editing should succeed.
 | CanPaste(self) Return true if a paste should succeed.
 | clear(self) Delete all text from the shell.
 | clearCommand(self) Delete the current, unexecuted command.
 | Copy(self) Copy selection and place it on the clipboard.
 | CopyWithPrompts(self) Copy selection, including prompts, and place it on the clipboard.
 | CopyWithPromptsPrefixed(self) Copy selection, including prompts prefixed with four spaces, and place it on the clipboard.
 | Cut(self) Remove selection and place it on the clipboard.
 | destroy(self)
 | execStartupScript(self, startupScript) Execute the user's PYTHONSTARTUP script if they have one.
 | fixLineEndings(self, text) Return text with line endings replaced by OS-specific endings.
 | getCommand(self, text, rstrip) Extract a command from text which may include a shell prompt.
 | getMultilineCommand(self, rstrip) Extract a multi-line command from the editor.
 | insertLineBreak(self) Insert a new line break.
 | lstripPrompt(self, text) Return text without a leading prompt.
 | OnChar(self, event) Keypress event handler.
 | OnHistoryInsert(self, step) Insert the previous/next command from the history buffer.
 | OnHistoryReplace(self, step) Replace with the previous/next command from the history buffer.
 | OnHistorySearch(self) Search up the history buffer for the text in front of the cursor.
 | OnIdle(self, event) Free the CPU to do other things.
 | OnKeyDown(self, event) Key down event handler.
 | Paste(self) Replace selection with clipboard contents.
 | PasteAndRun(self) Replace selection with clipboard contents, run commands.
 | pause(self) Halt execution pending a response from the user.
 | processLine(self) Process the line of text at which the user hit Enter.
 | prompt(self) Display proper prompt for the context: ps1, ps2 or ps3.
 | push(self, command) Send command to the interpreter for execution.
 | quit(self) Quit the application.
 | raw_input(self, prompt) Return string based on user input.
 | readline(self) Replacement for stdin.readline().
 | readlines(self) Replacement for stdin.readlines().
 | redirectStderr(self, redirect) If redirect is true then sys.stderr will go to the shell.
 | redirectStdin(self, redirect) If redirect is true then sys.stdin will come from the shell.
 | redirectStdout(self, redirect) If redirect is true then sys.stdout will go to the shell.
 | replaceFromHistory(self, step) Replace selection with command from the history buffer.
 | run(self, command, prompt, verbose) Execute command as if it was typed in directly.
 | runfile(self, filename) Execute all commands in file as if they were typed into the shell.
 | setBuiltinKeywords(self) Create pseudo keywords as part of builtins.
 | setFocus(self) Set focus to the shell.
 | setLocalShell(self) Add 'shell' to locals as reference to ShellFacade instance.
 | setStatusText(self, text) Display status information.
 | showIntro(self, text) Display introductory text in the shell.
 | wrap(self, wrap) Sets whether text is word wrapped.
 | write(self, text) Display text in the shell.
 | writeErr(self, text) Replacement for stderr.
 | writeOut(self, text) Replacement for stdout.
 | zoom(self, points) Set the zoom level.

Class Variable Summary
str | name = 'Shell'
str | revision = '1.9'

Instance Method Details

__init__(self, parent, id=-1, pos=wx.Point(-1, -1), size=wx.Size(-1, -1), style=4194304, introText='', locals=None, InterpClass=None, *args, **kwds)
(Constructor)

Create Shell instance.

Overrides:
wx.py.editwindow.EditWindow.__init__

about(self)

Display information about Py.

addHistory(self, command)

Add command to the command history.

ask(self, prompt='Please enter your response:')

Get response from the user using a dialog box.

autoCallTipShow(self, command)

Display argument spec and docstring in a popup window.

autoCompleteShow(self, command)

Display auto-completion popup list.

CanCut(self)

Return true if text is selected and can be cut.

Overrides:
wx.py.editwindow.EditWindow.CanCut

CanEdit(self)

Return true if editing should succeed.

Overrides:
wx.py.editwindow.EditWindow.CanEdit

CanPaste(self)

Return true if a paste should succeed.

Overrides:
wx.py.editwindow.EditWindow.CanPaste

clear(self)

Delete all text from the shell.

clearCommand(self)

Delete the current, unexecuted command.

Copy(self)

Copy selection and place it on the clipboard.

Overrides:
wx.stc.StyledTextCtrl.Copy

CopyWithPrompts(self)

Copy selection, including prompts, and place it on the clipboard.

CopyWithPromptsPrefixed(self)

Copy selection, including prompts prefixed with four spaces, and place it on the clipboard.

Cut(self)

Remove selection and place it on the clipboard.

Overrides:
wx.stc.StyledTextCtrl.Cut

execStartupScript(self, startupScript)

Execute the user's PYTHONSTARTUP script if they have one.

fixLineEndings(self, text)

Return text with line endings replaced by OS-specific endings.

getCommand(self, text=None, rstrip=True)

Extract a command from text which may include a shell prompt.

The command may not necessarily be valid Python syntax.

getMultilineCommand(self, rstrip=True)

Extract a multi-line command from the editor.

The command may not necessarily be valid Python syntax.

insertLineBreak(self)

Insert a new line break.

lstripPrompt(self, text)

Return text without a leading prompt.

OnChar(self, event)

Keypress event handler.

Only receives an event if OnKeyDown calls event.Skip() for the corresponding event.

OnHistoryInsert(self, step)

Insert the previous/next command from the history buffer.

OnHistoryReplace(self, step)

Replace with the previous/next command from the history buffer.

OnHistorySearch(self)

Search up the history buffer for the text in front of the cursor.

OnIdle(self, event)

Free the CPU to do other things.

OnKeyDown(self, event)

Key down event handler.

Paste(self)

Replace selection with clipboard contents.

Overrides:
wx.stc.StyledTextCtrl.Paste

PasteAndRun(self)

Replace selection with clipboard contents, run commands.

pause(self)

Halt execution pending a response from the user.

processLine(self)

Process the line of text at which the user hit Enter.

prompt(self)

Display proper prompt for the context: ps1, ps2 or ps3.

If this is a continuation line, autoindent as necessary.

push(self, command)

Send command to the interpreter for execution.

quit(self)

Quit the application.

raw_input(self, prompt='')

Return string based on user input.

readline(self)

Replacement for stdin.readline().

readlines(self)

Replacement for stdin.readlines().

redirectStderr(self, redirect=True)

If redirect is true then sys.stderr will go to the shell.

redirectStdin(self, redirect=True)

If redirect is true then sys.stdin will come from the shell.

redirectStdout(self, redirect=True)

If redirect is true then sys.stdout will go to the shell.

replaceFromHistory(self, step)

Replace selection with command from the history buffer.

run(self, command, prompt=True, verbose=True)

Execute command as if it was typed in directly. >>> shell.run('print "this"') >>> print "this" this >>>

runfile(self, filename)

Execute all commands in file as if they were typed into the shell.

setBuiltinKeywords(self)

Create pseudo keywords as part of builtins.

This sets close, exit and quit to a helpful string.

setFocus(self)

Set focus to the shell.

setLocalShell(self)

Add 'shell' to locals as reference to ShellFacade instance.

setStatusText(self, text)

Display status information.

showIntro(self, text='')

Display introductory text in the shell.

wrap(self, wrap=True)

Sets whether text is word wrapped.

write(self, text)

Display text in the shell.

Replace line endings with OS-specific endings.

writeErr(self, text)

Replacement for stderr.

writeOut(self, text)

Replacement for stdout.

zoom(self, points=0)

Set the zoom level.

This number of points is added to the size of all fonts. It may be positive to magnify or negative to reduce.

Class Variable Details

name

Type:
str
Value:
'Shell'

revision

Type:
str
Value:
'1.9'

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:16 2005 http://epydoc.sf.net


wx.py.shell.ShellFacade

Package wx :: Package py :: Module shell :: Class ShellFacade
[frames | no frames]

Class ShellFacade

Simplified interface to all shell-related functionality.

This is a semi-transparent facade, in that all attributes of other are accessible, even though only some are visible to the user.

Method Summary
 | __init__(self, other) Create a ShellFacade instance.
 | __getattr__(self, name)
 | __setattr__(self, name, value)
 | help(self) Display some useful information about how to use the shell.

Class Variable Summary
str | name = 'Shell Interface'
str | revision = '1.9'

Method Details

__init__(self, other)
(Constructor)

Create a ShellFacade instance.

help(self)

Display some useful information about how to use the shell.

Class Variable Details

name

Type:
str
Value:
'Shell Interface'

revision

Type:
str
Value:
'1.9'

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:57 2005 http://epydoc.sf.net


wx.py.shell.ShellFrame

Package wx :: Package py :: Module shell :: Class ShellFrame

Type ShellFrame

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
        TopLevelWindow --+
                         |
                     Frame --+
                             |
                         Frame --+
                                 |
                                ShellFrame

Frame containing the shell component.

Method Summary
 | __init__(self, parent, id, title, pos, size, style, locals, InterpClass, *args, **kwds) Create ShellFrame instance.
 | OnAbout(self, event) Display an About window.
 | OnClose(self, event) Event handler for closing.

Class Variable Summary
str | name = 'Shell Frame'
str | revision = '1.9'

Instance Method Details

__init__(self,
          parent=None,
          id=-1,
          title='PyShell',
          pos=wx.Point(-1, -1),
          size=wx.Size(-1, -1),
          style=541072960,
          locals=None,
          InterpClass=None,
          *args,
          **kwds)
(Constructor)

Create ShellFrame instance.

Overrides:
wx.py.frame.Frame.__init__

OnAbout(self, event)

Display an About window.

Overrides:
wx.py.frame.Frame.OnAbout

OnClose(self, event)

Event handler for closing.

Overrides:
wx.py.frame.Frame.OnClose

Class Variable Details

name

Type:
str
Value:
'Shell Frame'

revision

Type:
str
Value:
'1.9'

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:46 2005 http://epydoc.sf.net


wx.py.shell

Package wx :: Package py :: Module shell

Module wx.py.shell

Shell is an interactive text control in which a user types in commands to be sent to the interpreter. This particular shell is based on wxPython's wxStyledTextCtrl.

Sponsored by Orbtech - Your source for Python programming expertise.

Classes
Shell | Shell based on StyledTextCtrl.
ShellFacade | Simplified interface to all shell-related functionality.
ShellFrame | Frame containing the shell component.

Variable Summary
str | __author__ = "Patrick K. O'Brien <pobrien@orbtech.com>"
str | __cvsid__ = '$Id: shell.py,v 1.9 2004/10/15 20:31:23 RD ...
str | __revision__ = '1.9'
tuple | NAVKEYS = (314, 316, 318, 317, 319, 312, 313)

Variable Details

__author__

Type:
str
Value:
"Patrick K. O'Brien <pobrien@orbtech.com>"

__cvsid__

Type:
str
Value:
'$Id: shell.py,v 1.9 2004/10/15 20:31:23 RD Exp $'

__revision__

Type:
str
Value:
'1.9'

NAVKEYS

Type:
tuple
Value:
(314, 316, 318, 317, 319, 312, 313)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:02 2005 http://epydoc.sf.net


wx.py.version

Package wx :: Package py :: Module version

Module wx.py.version

Provides an object representing the current 'version' or 'release' of Py as a whole. Individual classes, such as the shell, filling and interpreter, each have a revision property based on the CVS Revision.

Variable Summary
str | __author__ = "Patrick K. O'Brien <pobrien@orbtech.com>"
str | __cvsid__ = '$Id: version.py,v 1.5 2004/01/25 23:37:41 P...
str | __revision__ = '1.5'
str | VERSION = '0.9.4'

Variable Details

__author__

Type:
str
Value:
"Patrick K. O'Brien <pobrien@orbtech.com>"

__cvsid__

Type:
str
Value:
'$Id: version.py,v 1.5 2004/01/25 23:37:41 PKO Exp $'

__revision__

Type:
str
Value:
'1.5'

VERSION

Type:
str
Value:
'0.9.4'

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:22 2005 http://epydoc.sf.net


wx.PyApp

Package wx :: Class PyApp

Type PyApp

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
                PyApp

Known Subclasses:
App

The wx.PyApp class is an implementation detail, please use the wx.App class (or some other derived class) instead.

Method Summary
PyApp | __init__(self) Create a new application object, starting the bootstrap process.
 | __del__(self)
 | __repr__(self)
bool | Dispatch(self) Process the first event in the event queue (blocks until an event appears if there are none currently)
 | Exit(self) Exit the main loop thus terminating the application.
 | ExitMainLoop(self) Exit the main GUI loop during the next iteration of the main loop, (i.e.
String | GetAppName(self) Get the application name.
int | GetAssertMode(self) Get the current OnAssert behaviour setting.
String | GetClassName(self) Get the application's class name.
int | GetComCtl32Version() Returns 400, 470, 471, etc. (Static method)
bool | GetExitOnFrameDelete(self) Get the current exit behaviour setting.
long | GetMacAboutMenuItemId() (Static method)
long | GetMacExitMenuItemId() (Static method)
String | GetMacHelpMenuTitleName() (Static method)
long | GetMacPreferencesMenuItemId() (Static method)
bool | GetMacSupportPCMenuShortcuts() (Static method)
int | GetPrintMode(self)
Window | GetTopWindow(self) Return the main top level window (if it hadn't been set previously with SetTopWindow(), will return just some top level window and, if there not any, will return None)
wxAppTraits | GetTraits(self) Return (and create if necessary) the app traits object to which we delegate for everything which either should be configurable by the user (then he can change the default behaviour simply by overriding CreateTraits() and returning his own traits object) or which is GUI/console dependent as then wx.AppTraits allows us to abstract the differences behind the common facade.
bool | GetUseBestVisual(self) Get current UseBestVisual setting.
String | GetVendorName(self) Get the application's vendor name.
bool | IsActive(self) Return True if our app has focus.
bool | IsMainLoopRunning() Returns True if we're running the main loop, i.e. (Static method)
int | MainLoop(self) Execute the main GUI loop, the function doesn't normally return until all top level windows have been closed and destroyed.
bool | Pending(self) Returns True if there are unprocessed events in the event queue.
bool | ProcessIdle(self) Called from the MainLoop when the application becomes idle (there are no pending events) and sends a wx.IdleEvent to all interested parties.
 | ProcessPendingEvents(self) Process all events in the Pending Events list -- it is necessary to call this function to process posted events.
bool | SendIdleEvents(self, win, event) Send idle event to window and all subwindows.
 | SetAppName(self, name) Set the application name.
 | SetAssertMode(self, mode) Set the OnAssert behaviour for debug and hybrid builds.The following flags may be or'd together:
 | SetClassName(self, name) Set the application's class name.
 | SetExitOnFrameDelete(self, flag) Control the exit behaviour: by default, the program will exit the main loop (and so, usually, terminate) when the last top-level program window is deleted.
 | SetMacAboutMenuItemId(val) (Static method)
 | SetMacExitMenuItemId(val) (Static method)
 | SetMacHelpMenuTitleName(val) (Static method)
 | SetMacPreferencesMenuItemId(val) (Static method)
 | SetMacSupportPCMenuShortcuts(val) (Static method)
 | SetPrintMode(self, mode)
 | SetTopWindow(self, win) Set the main top level window
 | SetUseBestVisual(self, flag) Set whether the app should try to use the best available visual on systems where more than one is available, (Sun, SGI, XFree86 4, etc.)
 | SetVendorName(self, name) Set the application's vendor name.
 | WakeUpIdle(self) Make sure that idle events are sent again.
bool | Yield(self, onlyIfNeeded) Process all currently pending events right now, instead of waiting until return to the event loop.

Instance Method Details

__init__(self)
(Constructor)

Create a new application object, starting the bootstrap process.

Returns:
PyApp
Overrides:
wx.EvtHandler.__init__

Dispatch(self)

Process the first event in the event queue (blocks until an event appears if there are none currently)

Returns:
bool

Exit(self)

Exit the main loop thus terminating the application. :see: wx.Exit

ExitMainLoop(self)

Exit the main GUI loop during the next iteration of the main loop, (i.e. it does not stop the program immediately!)

GetAppName(self)

Get the application name.

Returns:
String

GetAssertMode(self)

Get the current OnAssert behaviour setting.

Returns:
int

GetClassName(self)

Get the application's class name.

Returns:
String
Overrides:
wx.Object.GetClassName

GetExitOnFrameDelete(self)

Get the current exit behaviour setting.

Returns:
bool

GetTopWindow(self)

Return the main top level window (if it hadn't been set previously with SetTopWindow(), will return just some top level window and, if there not any, will return None)

Returns:
Window

GetTraits(self)

Return (and create if necessary) the app traits object to which we delegate for everything which either should be configurable by the user (then he can change the default behaviour simply by overriding CreateTraits() and returning his own traits object) or which is GUI/console dependent as then wx.AppTraits allows us to abstract the differences behind the common facade.

Returns:
wxAppTraits

To Do:

Add support for overriding CreateAppTraits in wxPython.

GetUseBestVisual(self)

Get current UseBestVisual setting.

Returns:
bool

GetVendorName(self)

Get the application's vendor name.

Returns:
String

IsActive(self)

Return True if our app has focus.

Returns:
bool

MainLoop(self)

Execute the main GUI loop, the function doesn't normally return until all top level windows have been closed and destroyed.

Returns:
int

Pending(self)

Returns True if there are unprocessed events in the event queue.

Returns:
bool

ProcessIdle(self)

Called from the MainLoop when the application becomes idle (there are no pending events) and sends a wx.IdleEvent to all interested parties. Returns True if more idle events are needed, False if not.

Returns:
bool

ProcessPendingEvents(self)

Process all events in the Pending Events list -- it is necessary to call this function to process posted events. This normally happens during each event loop iteration.

Overrides:
wx.EvtHandler.ProcessPendingEvents

SendIdleEvents(self, win, event)

Send idle event to window and all subwindows. Returns True if more idle time is requested.

Parameters:
win
(type=Window)

event
(type=IdleEvent)

Returns:
bool

SetAppName(self, name)

Set the application name. This value may be used automatically by wx.Config and such.

Parameters:
name
(type=String)

SetAssertMode(self, mode)

Set the OnAssert behaviour for debug and hybrid builds.The following flags may be or'd together:

wx.PYAPP_ASSERT_SUPPRESS | Don't do anything
wx.PYAPP_ASSERT_EXCEPTION | Turn it into a Python exception if possible (default)
wx.PYAPP_ASSERT_DIALOG | Display a message dialog
wx.PYAPP_ASSERT_LOG | Write the assertion info to the wx.Log
Parameters:
mode
(type=int)

SetClassName(self, name)

Set the application's class name. This value may be used for X-resources if applicable for the platform

Parameters:
name
(type=String)

SetExitOnFrameDelete(self, flag)

Control the exit behaviour: by default, the program will exit the main loop (and so, usually, terminate) when the last top-level program window is deleted. Beware that if you disable this behaviour (with SetExitOnFrameDelete(False)), you'll have to call ExitMainLoop() explicitly from somewhere.

Parameters:
flag
(type=bool)

SetTopWindow(self, win)

Set the main top level window

Parameters:
win
(type=Window)

SetUseBestVisual(self, flag)

Set whether the app should try to use the best available visual on systems where more than one is available, (Sun, SGI, XFree86 4, etc.)

Parameters:
flag
(type=bool)

SetVendorName(self, name)

Set the application's vendor name. This value may be used automatically by wx.Config and such.

Parameters:
name
(type=String)

WakeUpIdle(self)

Make sure that idle events are sent again. :see: wx.WakeUpIdle

Yield(self, onlyIfNeeded=False)

Process all currently pending events right now, instead of waiting until return to the event loop. It is an error to call Yield recursively unless the value of onlyIfNeeded is True.

Parameters:
onlyIfNeeded
(type=bool)

Returns:
bool

Warning:

This function is dangerous as it can lead to unexpected reentrancies (i.e. when called from an event handler it may result in calling the same event handler again), use with extreme care or, better, don't use at all!

See Also:

wx.Yield, wx.YieldIfNeeded, wx.SafeYield

Static Method Details

GetComCtl32Version()

Returns 400, 470, 471, etc. for comctl32.dll 4.00, 4.70, 4.71 or 0 if it wasn't found at all. Raises an exception on non-Windows platforms.

Returns:
int

IsMainLoopRunning()

Returns True if we're running the main loop, i.e. if the events can currently be dispatched.

Returns:
bool

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:47 2005 http://epydoc.sf.net


wx.PyAssertionError

Package wx :: Class PyAssertionError

Class PyAssertionError

Exception --+
            |
StandardError --+
                |
   AssertionError --+
                    |
                   PyAssertionError

Method Summary

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:38 2005 http://epydoc.sf.net


wx.PyBitmapDataObject

Package wx :: Class PyBitmapDataObject

Type PyBitmapDataObject

  object --+
           |
  DataObject --+
               |
DataObjectSimple --+
                   |
    BitmapDataObject --+
                       |
                      PyBitmapDataObject

wx.PyBitmapDataObject is a version of wx.BitmapDataObject that is Python-aware and knows how to reflect calls to its C++ virtual methods to methods in the Python derived class. To be able to provide bitmap data on demand derive from this class and overload GetBitmap.

Method Summary
PyBitmapDataObject | __init__(self, bitmap) wx.PyBitmapDataObject is a version of wx.BitmapDataObject that is Python-aware and knows how to reflect calls to its C++ virtual methods to methods in the Python derived class.
 | __repr__(self)

Class Variable Summary

Method Details

__init__(self, bitmap=wxNullBitmap)
(Constructor)

wx.PyBitmapDataObject is a version of wx.BitmapDataObject that is Python-aware and knows how to reflect calls to its C++ virtual methods to methods in the Python derived class. To be able to provide bitmap data on demand derive from this class and overload GetBitmap.

Parameters:
bitmap
(type=Bitmap)

Returns:
PyBitmapDataObject
Overrides:
wx.BitmapDataObject.__init__

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:46 2005 http://epydoc.sf.net


wx.PyCommandEvent

Package wx :: Class PyCommandEvent

Type PyCommandEvent

object --+
         |
    Object --+
             |
         Event --+
                 |
      CommandEvent --+
                     |
                    PyCommandEvent

Known Subclasses:
CaptionBarEvent, ColourSelectEvent, GenButtonEvent, GridColMoveEvent, GridRowMoveEvent, HyperLinkEvent, IntUpdatedEvent, MaskedComboBoxSelectEvent, MVCTreeEvent, NumberUpdatedEvent, TimeUpdatedEvent

wx.PyCommandEvent can be used as a base class for implementing custom event types in Python, where the event shoudl travel up to parent windows looking for a handler. You should derived from this class instead of wx.CommandEvent because this class is Python-aware and is able to transport its Python bits safely through the wxWidgets event system and have them still be there when the event handler is invoked.

See Also:

wx.PyEvent

Method Summary
CommandEvent | __init__(self, commandType, winid) This event class contains information about command events, which originate from a variety of simple controls, as well as menus and toolbars.
 | __del__(self)
 | __repr__(self)

Method Details

__init__(self, eventType=wxEVT_NULL, id=0)
(Constructor)

This event class contains information about command events, which originate from a variety of simple controls, as well as menus and toolbars.

Parameters:
commandType
(type=wxEventType)

winid
(type=int)

Returns:
CommandEvent
Overrides:
wx.CommandEvent.__init__ (inherited documentation)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:12 2005 http://epydoc.sf.net


wx.PyControl

Package wx :: Class PyControl

Type PyControl

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
               Control --+
                         |
                        PyControl

Known Subclasses:
Calendar, GenButton, GenStaticBitmap, GenStaticText, PopButton, PopupControl, Ticker

Proxy of C++ PyControl class

Method Summary
Control | __init__(self, parent, id, pos, size, style, validator, name) Create a Control.
 | __repr__(self)
bool | base_AcceptsFocus(self)
bool | base_AcceptsFocusFromKeyboard(self)
 | base_AddChild(self, child)
Size | base_DoGetBestSize(self)
(width, height) | base_DoGetClientSize()
(x,y) | base_DoGetPosition()
(width, height) | base_DoGetSize()
Size | base_DoGetVirtualSize(self)
 | base_DoMoveWindow(self, x, y, width, height)
 | base_DoSetClientSize(self, width, height)
 | base_DoSetSize(self, x, y, width, height, sizeFlags)
 | base_DoSetVirtualSize(self, x, y)
VisualAttributes | base_GetDefaultAttributes(self)
Size | base_GetMaxSize(self)
 | base_InitDialog(self)
 | base_RemoveChild(self, child)
bool | base_ShouldInheritColours(self)
bool | base_TransferDataFromWindow(self)
bool | base_TransferDataToWindow(self)
bool | base_Validate(self)
bool | DoEraseBackground(self, dc)
 | SetBestSize(self, size)

Instance Method Details

__init__(self,
          parent,
          id=-1,
          pos=DefaultPosition,
          size=DefaultSize,
          style=0,
          validator=DefaultValidator,
          name=ControlNameStr)
(Constructor)

Create a Control. Normally you should only call this from a subclass' __init__ as a plain old wx.Control is not very useful.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

validator
(type=Validator)

name
(type=String)

Returns:
Control
Overrides:
wx.Control.__init__ (inherited documentation)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:26 2005 http://epydoc.sf.net


wx.PyDataObjectSimple

Package wx :: Class PyDataObjectSimple

Type PyDataObjectSimple

  object --+
           |
  DataObject --+
               |
DataObjectSimple --+
                   |
                  PyDataObjectSimple

wx.PyDataObjectSimple is a version of wx.DataObjectSimple that is Python-aware and knows how to reflect calls to its C++ virtual methods to methods in the Python derived class. You should derive from this class and overload GetDataSize, GetDataHere and SetData when you need to create your own simple single-format type of wx.DataObject.

Here is a simple example:

class MyDataObject(wx.PyDataObjectSimple):
    def __init__(self):
        wx.PyDataObjectSimple.__init__(
            self, wx.CustomDataFormat('MyDOFormat'))
        self.data = ''

    def GetDataSize(self):
        return len(self.data)
    def GetDataHere(self):
        return self.data  # returns a string
    def SetData(self, data):
        self.data = data
        return True

Note that there is already a wx.CustomDataObject class that behaves very similarly to this example. The value of creating your own derived class like this is to be able to do additional things when the data is requested or given via the clipboard or drag and drop operation, such as generate the data value or decode it into needed data structures.

Method Summary
PyDataObjectSimple | __init__(self, format) wx.PyDataObjectSimple is a version of wx.DataObjectSimple that is Python-aware and knows how to reflect calls to its C++ virtual methods to methods in the Python derived class.
 | __repr__(self)

Class Variable Summary

Method Details

__init__(self, format=FormatInvalid)
(Constructor)

wx.PyDataObjectSimple is a version of wx.DataObjectSimple that is Python-aware and knows how to reflect calls to its C++ virtual methods to methods in the Python derived class. You should derive from this class and overload GetDataSize, GetDataHere and SetData when you need to create your own simple single-format type of wx.DataObject.

Here is a simple example:

class MyDataObject(wx.PyDataObjectSimple):
    def __init__(self):
        wx.PyDataObjectSimple.__init__(
            self, wx.CustomDataFormat('MyDOFormat'))
        self.data = ''

    def GetDataSize(self):
        return len(self.data)
    def GetDataHere(self):
        return self.data  # returns a string
    def SetData(self, data):
        self.data = data
        return True

Note that there is already a wx.CustomDataObject class that behaves very similarly to this example. The value of creating your own derived class like this is to be able to do additional things when the data is requested or given via the clipboard or drag and drop operation, such as generate the data value or decode it into needed data structures.

Parameters:
format
(type=DataFormat)

Returns:
PyDataObjectSimple
Overrides:
wx.DataObjectSimple.__init__

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:10 2005 http://epydoc.sf.net


wx.PyDeadObjectError

Package wx :: Class PyDeadObjectError

Class PyDeadObjectError

Exception --+
            |
StandardError --+
                |
   AttributeError --+
                    |
                   PyDeadObjectError

Method Summary

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:16 2005 http://epydoc.sf.net


wx.PyEventBinder

Package wx :: Class PyEventBinder

Type PyEventBinder

object --+
         |
        PyEventBinder

Instances of this class are used to bind specific events to event handlers.

Method Summary
 | __init__(self, evtType, expectedIDs)
 | __call__(self, *args) For backwards compatibility with the old EVT_* functions.
 | Bind(self, target, id1, id2, function) Bind this set of event types to target.
 | Unbind(self, target, id1, id2) Remove an event binding.

Method Details

__call__(self, *args)
(Call operator)

For backwards compatibility with the old EVT_* functions. Should be called with either (window, func), (window, ID, func) or (window, ID1, ID2, func) parameters depending on the type of the event.

Bind(self, target, id1, id2, function)

Bind this set of event types to target.

Unbind(self, target, id1, id2)

Remove an event binding.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:43 2005 http://epydoc.sf.net


wx.PyEvent

Package wx :: Class PyEvent

Type PyEvent

object --+
         |
    Object --+
             |
         Event --+
                 |
                PyEvent

Known Subclasses:
UpdateThrobberEvent

wx.PyEvent can be used as a base class for implementing custom event types in Python. You should derived from this class instead of wx.Event because this class is Python-aware and is able to transport its Python bits safely through the wxWidgets event system and have them still be there when the event handler is invoked.

See Also:

wx.PyCommandEvent

Method Summary
PyEvent | __init__(self, winid, eventType)
 | __del__(self)
 | __repr__(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:06 2005 http://epydoc.sf.net


wx.PyLog

Package wx :: Class PyLog

Type PyLog

object --+
         |
       Log --+
             |
            PyLog

Proxy of C++ PyLog class

Method Summary
PyLog | __init__(self)
 | __repr__(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:00 2005 http://epydoc.sf.net


wx.py

Package wx :: Package py

Package wx.py

The py package, formerly the PyCrust package.

Submodules
  • buffer: Buffer class.
  • crust: Crust combines the shell and filling into one control.
  • dispatcher: Provides global signal dispatching services.
  • document: Document class.
  • editor: PyAlaCarte and PyAlaMode editors.
  • editwindow: EditWindow class.
  • filling: Filling is the gui tree control through which a user can navigate the local namespace or any object.
  • frame: Base frame with menu.
  • images: Support for icons.
  • interpreter: Interpreter executes Python commands.
  • introspect: Provides a variety of introspective-type support functions for things like call tips and command auto completion.
  • pseudo: Provides a variety of classes to create pseudo keywords and pseudo files.
  • PyAlaCarte: PyAlaCarte is a simple programmer's editor.
  • PyAlaMode: PyAlaMode is a programmer's editor.
  • PyAlaModeTest: PyAlaModeTest is a programmer's editor.
  • PyCrust: PyCrust is a python shell and namespace browser application.
  • PyFilling: PyFilling is a python namespace inspection application.
  • PyShell: PyShell is a python shell application.
  • PyWrap: PyWrap is a command line utility that runs a wxPython program with additional runtime-tools, such as PyCrust.
  • shell: Shell is an interactive text control in which a user types in commands to be sent to the interpreter.
  • version: Provides an object representing the current 'version' or 'release' of Py as a whole.

Variable Summary
str | __author__ = "Patrick K. O'Brien <pobrien@orbtech.com>"
str | __cvsid__ = '$Id: __init__.py,v 1.3 2003/11/12 21:28:55 ...
str | __revision__ = '1.3'

Variable Details

__author__

Type:
str
Value:
"Patrick K. O'Brien <pobrien@orbtech.com>"

__cvsid__

Type:
str
Value:
'$Id: __init__.py,v 1.3 2003/11/12 21:28:55 RD Exp $'

__revision__

Type:
str
Value:
'1.3'

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:44 2005 http://epydoc.sf.net


wx.PyNoAppError

Package wx :: Class PyNoAppError

Class PyNoAppError

Exception --+
            |
StandardError --+
                |
     RuntimeError --+
                    |
                   PyNoAppError

Method Summary

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:38 2005 http://epydoc.sf.net


wx.PyOnDemandOutputWindow

Package wx :: Class PyOnDemandOutputWindow

Class PyOnDemandOutputWindow

A class that can be used for redirecting Python's stdout and stderr streams. It will do nothing until something is wrriten to the stream at which point it will create a Frame with a text area and write the text there.

Method Summary
 | __init__(self, title)
 | close(self)
 | CreateOutputWindow(self, st)
 | flush(self)
 | OnCloseWindow(self, event)
 | SetParent(self, parent) Set the window to be used as the popup Frame's parent.
 | write(self, text) Create the output window if needed and write the string to it.

Method Details

SetParent(self, parent)

Set the window to be used as the popup Frame's parent.

write(self, text)

Create the output window if needed and write the string to it. If not called in the context of the gui thread then uses CallAfter to do the work there.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:12 2005 http://epydoc.sf.net


wx.PyPanel

Package wx :: Class PyPanel

Type PyPanel

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
                 Panel --+
                         |
                        PyPanel

Known Subclasses:
Throbber

Proxy of C++ PyPanel class

Method Summary
Window | __init__(self, parent, id, pos, size, style, name) Construct and show a generic Window.
 | __repr__(self)
bool | base_AcceptsFocus(self)
bool | base_AcceptsFocusFromKeyboard(self)
 | base_AddChild(self, child)
Size | base_DoGetBestSize(self)
(width, height) | base_DoGetClientSize()
(x,y) | base_DoGetPosition()
(width, height) | base_DoGetSize()
Size | base_DoGetVirtualSize(self)
 | base_DoMoveWindow(self, x, y, width, height)
 | base_DoSetClientSize(self, width, height)
 | base_DoSetSize(self, x, y, width, height, sizeFlags)
 | base_DoSetVirtualSize(self, x, y)
VisualAttributes | base_GetDefaultAttributes(self)
Size | base_GetMaxSize(self)
 | base_InitDialog(self)
 | base_RemoveChild(self, child)
bool | base_ShouldInheritColours(self)
bool | base_TransferDataFromWindow(self)
bool | base_TransferDataToWindow(self)
bool | base_Validate(self)
bool | DoEraseBackground(self, dc)
 | SetBestSize(self, size)

Instance Method Details

__init__(self,
          parent,
          id=-1,
          pos=DefaultPosition,
          size=DefaultSize,
          style=0,
          name=PanelNameStr)
(Constructor)

Construct and show a generic Window.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

name
(type=String)

Returns:
Window
Overrides:
wx.Panel.__init__ (inherited documentation)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:10:54 2005 http://epydoc.sf.net


wx.PyPreviewControlBar

Package wx :: Class PyPreviewControlBar

Type PyPreviewControlBar

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
                 Panel --+
                         |
         PreviewControlBar --+
                             |
                            PyPreviewControlBar

Proxy of C++ PyPreviewControlBar class

Method Summary
Window | __init__(self, parent, id, pos, size, style, name) Construct and show a generic Window.
 | __repr__(self)
 | base_CreateButtons(self)
 | base_SetZoomControl(self, zoom)
 | SetPrintPreview(self, preview)

Instance Method Details

__init__(self, preview, buttons, parent, pos=DefaultPosition, size=DefaultSize, style=0, name=PanelNameStr)
(Constructor)

Construct and show a generic Window.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

name
(type=String)

Returns:
Window
Overrides:
wx.PreviewControlBar.__init__ (inherited documentation)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:04 2005 http://epydoc.sf.net


wx.PyPreviewFrame

Package wx :: Class PyPreviewFrame

Type PyPreviewFrame

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
        TopLevelWindow --+
                         |
                     Frame --+
                             |
                  PreviewFrame --+
                                 |
                                PyPreviewFrame

Proxy of C++ PyPreviewFrame class

Method Summary
PyPreviewFrame | __init__(self, preview, parent, title, pos, size, style, name)
 | __repr__(self)
 | base_CreateCanvas(self)
 | base_CreateControlBar(self)
 | base_Initialize(self)
 | SetControlBar(self, bar)
 | SetPreviewCanvas(self, canvas)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:23 2005 http://epydoc.sf.net


wx.PyPrintPreview

Package wx :: Class PyPrintPreview

Type PyPrintPreview

object --+
         |
    Object --+
             |
  PrintPreview --+
                 |
                PyPrintPreview

Proxy of C++ PyPrintPreview class

Method Summary
PyPrintPreview __init__(self, printout, printoutForPrinting, data)
__init__(self, Printout printout, Printout printoutForPrinting, PrintData data) -> PyPrintPreview
__repr__(self)
base_DetermineScaling(self)
bool | base_DrawBlankPage(self, canvas, dc)
bool | base_PaintPage(self, canvas, dc)
bool | base_Print(self, interactive)
bool | base_RenderPage(self, pageNum)
bool | base_SetCurrentPage(self, pageNum)
base_SetZoom(self, percent)

Method Details

__init__(self, printout, printoutForPrinting, data=None)
(Constructor)

__init__(self, Printout printout, Printout printoutForPrinting, PrintData data) -> PyPrintPreview

Parameters:
printout
(type=Printout)

printoutForPrinting
(type=Printout)

data
(type=PrintDialogData)

Returns:
PyPrintPreview
Overrides:
wx.PrintPreview.__init__

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:40 2005 http://epydoc.sf.net


wx.PyScrolledWindow

Package wx :: Class PyScrolledWindow

Type PyScrolledWindow

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
                 Panel --+
                         |
            ScrolledWindow --+
                             |
                            PyScrolledWindow

Known Subclasses:
ScrolledPanel

Proxy of C++ PyScrolledWindow class

Method Summary
Window | __init__(self, parent, id, pos, size, style, name) Construct and show a generic Window.
 | __repr__(self)
bool | base_AcceptsFocus(self)
bool | base_AcceptsFocusFromKeyboard(self)
 | base_AddChild(self, child)
Size | base_DoGetBestSize(self)
(width, height) | base_DoGetClientSize()
(x,y) | base_DoGetPosition()
(width, height) | base_DoGetSize()
Size | base_DoGetVirtualSize(self)
 | base_DoMoveWindow(self, x, y, width, height)
 | base_DoSetClientSize(self, width, height)
 | base_DoSetSize(self, x, y, width, height, sizeFlags)
 | base_DoSetVirtualSize(self, x, y)
VisualAttributes | base_GetDefaultAttributes(self)
Size | base_GetMaxSize(self)
 | base_InitDialog(self)
 | base_RemoveChild(self, child)
bool | base_ShouldInheritColours(self)
bool | base_TransferDataFromWindow(self)
bool | base_TransferDataToWindow(self)
bool | base_Validate(self)
bool | DoEraseBackground(self, dc)
 | SetBestSize(self, size)

Instance Method Details

__init__(self,
          parent,
          id=-1,
          pos=DefaultPosition,
          size=DefaultSize,
          style=0,
          name=PanelNameStr)
(Constructor)

Construct and show a generic Window.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

name
(type=String)

Returns:
Window
Overrides:
wx.ScrolledWindow.__init__ (inherited documentation)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:18 2005 http://epydoc.sf.net


wx.PySimpleApp

Package wx :: Class PySimpleApp

Type PySimpleApp

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
             PyApp --+
                     |
                   App --+
                         |
                        PySimpleApp

Known Subclasses:
DocApp

A simple application class. You can just create one of these and then then make your top level windows later, and not have to worry about OnInit. For example:

app = wx.PySimpleApp()
frame = wx.Frame(None, title='Hello World')
frame.Show()
app.MainLoop()

See Also:

wx.App

Method Summary
 | __init__(self, redirect, filename, useBestVisual, clearSigInt)
 | OnInit(self)

Instance Method Details

__init__(self,
          redirect=False,
          filename=None,
          useBestVisual=False,
          clearSigInt=True)
(Constructor)

Overrides:
wx.App.__init__

See Also:

wx.App.__init__

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:05 2005 http://epydoc.sf.net


wx.PySizer

Package wx :: Class PySizer

Type PySizer

object --+
         |
    Object --+
             |
         Sizer --+
                 |
                PySizer

Known Subclasses:
PyGridSizer, RowColSizer

wx.PySizer is a special version of wx.Sizer that has been instrumented to allow the C++ virtual methods to be overloaded in Python derived classes. You would derive from this class if you are wanting to implement a custom sizer in Python code. Simply implement CalcMin and RecalcSizes in the derived class and you're all set. For example:

class MySizer(wx.PySizer):
     def __init__(self):
         wx.PySizer.__init__(self)

     def CalcMin(self):
         for item in self.GetChildren():
              # calculate the total minimum width and height needed
              # by all items in the sizer according to this sizer's
              # layout algorithm.
              ...
         return wx.Size(width, height)

      def RecalcSizes(self):
          # find the space allotted to this sizer
          pos = self.GetPosition()
          size = self.GetSize()
          for item in self.GetChildren():
              # Recalculate (if necessary) the position and size of
              # each item and then call item.SetDimension to do the
              # actual positioning and sizing of the items within the
              # space alloted to this sizer.
              ...
              item.SetDimension(itemPos, itemSize)

When Layout is called it first calls CalcMin followed by RecalcSizes so you can optimize a bit by saving the results of CalcMin and reusing them in RecalcSizes.

See Also:

wx.SizerItem, wx.Sizer.GetChildren

Method Summary
PySizer | __init__(self) Creates a wx.PySizer.
 | __repr__(self)

Method Details

__init__(self)
(Constructor)

Creates a wx.PySizer. Must be called from the __init__ in the derived class.

Returns:
PySizer
Overrides:
wx.Sizer.__init__

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:59 2005 http://epydoc.sf.net


wx.PyTextDataObject

Package wx :: Class PyTextDataObject

Type PyTextDataObject

  object --+
           |
  DataObject --+
               |
DataObjectSimple --+
                   |
      TextDataObject --+
                       |
                      PyTextDataObject

wx.PyTextDataObject is a version of wx.TextDataObject that is Python-aware and knows how to reflect calls to its C++ virtual methods to methods in the Python derived class. You should derive from this class and overload GetTextLength, GetText, and SetText when you want to be able to provide text on demand instead of preloading it into the data object.

Method Summary
PyTextDataObject | __init__(self, text) wx.PyTextDataObject is a version of wx.TextDataObject that is Python-aware and knows how to reflect calls to its C++ virtual methods to methods in the Python derived class.
 | __repr__(self)

Class Variable Summary

Method Details

__init__(self, text=EmptyString)
(Constructor)

wx.PyTextDataObject is a version of wx.TextDataObject that is Python-aware and knows how to reflect calls to its C++ virtual methods to methods in the Python derived class. You should derive from this class and overload GetTextLength, GetText, and SetText when you want to be able to provide text on demand instead of preloading it into the data object.

Parameters:
text
(type=String)

Returns:
PyTextDataObject
Overrides:
wx.TextDataObject.__init__

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:18 2005 http://epydoc.sf.net


wx.PyTimer

Package wx :: Class PyTimer

Type PyTimer

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
             Timer --+
                     |
                    PyTimer

Method Summary
 | __init__(self, notify)
 | Notify(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:17 2005 http://epydoc.sf.net


wx.PyTipProvider

Package wx :: Class PyTipProvider

Type PyTipProvider

 object --+
          |
TipProvider --+
              |
             PyTipProvider

Proxy of C++ PyTipProvider class

Method Summary
PyTipProvider | __init__(self, currentTip)
 | __repr__(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:19 2005 http://epydoc.sf.net


wx.PyUnbornObjectError

Package wx :: Class PyUnbornObjectError

Class PyUnbornObjectError

Exception --+
            |
StandardError --+
                |
   AttributeError --+
                    |
                   PyUnbornObjectError

Method Summary

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:38 2005 http://epydoc.sf.net


wx.PyValidator

Package wx :: Class PyValidator

Type PyValidator

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
         Validator --+
                     |
                    PyValidator

Known Subclasses:
IntValidator

Proxy of C++ PyValidator class

Method Summary
PyValidator | __init__(self)
 | __repr__(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:18 2005 http://epydoc.sf.net


wx.PyWidgetTester

Package wx :: Class PyWidgetTester

Type PyWidgetTester

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
             PyApp --+
                     |
                   App --+
                         |
                        PyWidgetTester

Method Summary
 | __init__(self, size)
 | OnInit(self)
 | SetWidget(self, widgetClass, *args, **kwargs)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:16 2005 http://epydoc.sf.net


wx.PyWindow

Package wx :: Class PyWindow

Type PyWindow

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
                    PyWindow

Known Subclasses:
AnalogClockWindow

Proxy of C++ PyWindow class

Method Summary
Window | __init__(self, parent, id, pos, size, style, name) Construct and show a generic Window.
 | __repr__(self)
bool | base_AcceptsFocus(self)
bool | base_AcceptsFocusFromKeyboard(self)
 | base_AddChild(self, child)
Size | base_DoGetBestSize(self)
(width, height) | base_DoGetClientSize()
(x,y) | base_DoGetPosition()
(width, height) | base_DoGetSize()
Size | base_DoGetVirtualSize(self)
 | base_DoMoveWindow(self, x, y, width, height)
 | base_DoSetClientSize(self, width, height)
 | base_DoSetSize(self, x, y, width, height, sizeFlags)
 | base_DoSetVirtualSize(self, x, y)
VisualAttributes | base_GetDefaultAttributes(self)
Size | base_GetMaxSize(self)
 | base_InitDialog(self)
 | base_RemoveChild(self, child)
bool | base_ShouldInheritColours(self)
bool | base_TransferDataFromWindow(self)
bool | base_TransferDataToWindow(self)
bool | base_Validate(self)
bool | DoEraseBackground(self, dc)
 | SetBestSize(self, size)

Instance Method Details

__init__(self,
          parent,
          id=-1,
          pos=DefaultPosition,
          size=DefaultSize,
          style=0,
          name=PanelNameStr)
(Constructor)

Construct and show a generic Window.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

name
(type=String)

Returns:
Window
Overrides:
wx.Window.__init__ (inherited documentation)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:22 2005 http://epydoc.sf.net


wx.Quantize

Package wx :: Class Quantize

Type Quantize

object --+
         |
        Quantize

Performs quantization, or colour reduction, on a wxImage.

Method Summary
 | __init__(self)
 | __repr__(self)
bool | Quantize(src, dest, desiredNoColours, flags) Reduce the colours in the source image and put the result into the destination image, setting the palette in the destination if needed. (Static method)

Static Method Details

Quantize(src, dest, desiredNoColours=236, flags=wxQUANTIZE_INCLUDE_WINDOWS_COLOURS|wxQUANTIZE_FILL_DESTIN...)

Reduce the colours in the source image and put the result into the destination image, setting the palette in the destination if needed. Both images may be the same, to overwrite the source image. :todo: Create a version that returns the wx.Palette used.

Parameters:
src
(type=Image)

dest
(type=Image)

desiredNoColours
(type=int)

flags
(type=int)

Returns:
bool

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:25 2005 http://epydoc.sf.net


wx.QueryLayoutInfoEvent

Package wx :: Class QueryLayoutInfoEvent

Type QueryLayoutInfoEvent

object --+
         |
    Object --+
             |
         Event --+
                 |
                QueryLayoutInfoEvent

Proxy of C++ QueryLayoutInfoEvent class

Method Summary
QueryLayoutInfoEvent | __init__(self, id)
 | __repr__(self)
int | GetAlignment(self)
int | GetFlags(self)
int | GetOrientation(self)
int | GetRequestedLength(self)
Size | GetSize(self)
 | SetAlignment(self, align)
 | SetFlags(self, flags)
 | SetOrientation(self, orient)
 | SetRequestedLength(self, length)
 | SetSize(self, size)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:40 2005 http://epydoc.sf.net


wx.QueryNewPaletteEvent

Package wx :: Class QueryNewPaletteEvent

Type QueryNewPaletteEvent

object --+
         |
    Object --+
             |
         Event --+
                 |
                QueryNewPaletteEvent

An EVT_QUERY_NEW_PALETE event indicates the window is getting keyboard focus and should re-do its palette.

This event is implemented under Windows only.

Method Summary
QueryNewPaletteEvent | __init__(self, winid) Constructor.
 | __repr__(self)
bool | GetPaletteRealized(self)
 | SetPaletteRealized(self, realized) App should set this if it changes the palette.

Method Details

__init__(self, winid=0)
(Constructor)

Constructor.

Parameters:
winid
(type=int)

Returns:
QueryNewPaletteEvent
Overrides:
wx.Event.__init__

SetPaletteRealized(self, realized)

App should set this if it changes the palette.

Parameters:
realized
(type=bool)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:09 2005 http://epydoc.sf.net


wx.RadioBox

Package wx :: Class RadioBox

Type RadioBox

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
               Control --+
                         |
                        RadioBox

Proxy of C++ RadioBox class

Method Summary
Control | __init__(self, parent, id, pos, size, style, validator, name) Create a Control.
 | __repr__(self)
bool | Create(self, parent, id, pos, size, style, validator, name) Do the 2nd phase and create the GUI control.
 | EnableItem(self, n, enable)
int | FindString(self, s)
VisualAttributes | GetClassDefaultAttributes(variant) Get the default attributes for this class. (Static method)
int | GetColumnCount(self)
int | GetCount(self)
String | GetItemLabel(self, n)
int | GetNextItem(self, item, dir, style)
int | GetRowCount(self)
int | GetSelection(self)
String | GetString(self, n)
String | GetStringSelection(self)
 | SetItemLabel(self, n, label)
 | SetSelection(self, n)
 | SetString(self, n, label)
bool | SetStringSelection(self, s)
 | ShowItem(self, n, show)

Instance Method Details

__init__(self,
          parent,
          id=-1,
          label=EmptyString,
          pos=DefaultPosition,
          size=DefaultSize,
          choices=wxPyEmptyStringArray,
          majorDimension=0,
          style=RA_HORIZONTAL,
          validator=DefaultValidator,
          name=RadioBoxNameStr)
(Constructor)

Create a Control. Normally you should only call this from a subclass' __init__ as a plain old wx.Control is not very useful.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

validator
(type=Validator)

name
(type=String)

Returns:
Control
Overrides:
wx.Control.__init__ (inherited documentation)

Create(self,
          parent,
          id=-1,
          label=EmptyString,
          pos=DefaultPosition,
          size=DefaultSize,
          choices=wxPyEmptyStringArray,
          majorDimension=0,
          style=RA_HORIZONTAL,
          validator=DefaultValidator,
          name=RadioBoxNameStr)

Do the 2nd phase and create the GUI control.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

validator
(type=Validator)

name
(type=String)

Returns:
bool
Overrides:
wx.Control.Create (inherited documentation)

Static Method Details

GetClassDefaultAttributes(variant=WINDOW_VARIANT_NORMAL)

Get the default attributes for this class. This is useful if you want to use the same font or colour in your own control as in a standard control -- which is a much better idea than hard coding specific colours or fonts which might look completely out of place on the user's system, especially if it uses themes.

The variant parameter is only relevant under Mac currently and is ignore under other platforms. Under Mac, it will change the size of the returned font. See wx.Window.SetWindowVariant for more about this.

Parameters:
variant
(type=int)

Returns:
VisualAttributes

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:17 2005 http://epydoc.sf.net


wx.RadioButton

Package wx :: Class RadioButton

Type RadioButton

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
               Control --+
                         |
                        RadioButton

Proxy of C++ RadioButton class

Method Summary
Control | __init__(self, parent, id, pos, size, style, validator, name) Create a Control.
 | __repr__(self)
bool | Create(self, parent, id, pos, size, style, validator, name) Do the 2nd phase and create the GUI control.
VisualAttributes | GetClassDefaultAttributes(variant) Get the default attributes for this class. (Static method)
bool | GetValue(self)
 | SetValue(self, value)

Instance Method Details

__init__(self,
          parent,
          id=-1,
          label=EmptyString,
          pos=DefaultPosition,
          size=DefaultSize,
          style=0,
          validator=DefaultValidator,
          name=RadioButtonNameStr)
(Constructor)

Create a Control. Normally you should only call this from a subclass' __init__ as a plain old wx.Control is not very useful.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

validator
(type=Validator)

name
(type=String)

Returns:
Control
Overrides:
wx.Control.__init__ (inherited documentation)

Create(self,
          parent,
          id=-1,
          label=EmptyString,
          pos=DefaultPosition,
          size=DefaultSize,
          style=0,
          validator=DefaultValidator,
          name=RadioButtonNameStr)

Do the 2nd phase and create the GUI control.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

validator
(type=Validator)

name
(type=String)

Returns:
bool
Overrides:
wx.Control.Create (inherited documentation)

Static Method Details

GetClassDefaultAttributes(variant=WINDOW_VARIANT_NORMAL)

Get the default attributes for this class. This is useful if you want to use the same font or colour in your own control as in a standard control -- which is a much better idea than hard coding specific colours or fonts which might look completely out of place on the user's system, especially if it uses themes.

The variant parameter is only relevant under Mac currently and is ignore under other platforms. Under Mac, it will change the size of the returned font. See wx.Window.SetWindowVariant for more about this.

Parameters:
variant
(type=int)

Returns:
VisualAttributes

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:39 2005 http://epydoc.sf.net


wx.RealPoint

Package wx :: Class RealPoint

Type RealPoint

object --+
         |
        RealPoint

A data structure for representing a point or position with floating point x and y properties. In wxPython most places that expect a wx.RealPoint can also accept a (x,y) tuple.

Method Summary
RealPoint | __init__(self, x, y) Create a wx.RealPoint object
RealPoint | __add__(self, pt) Add pt's proprties to this and return the result.
 | __del__(self)
bool | __eq__(self, pt) Test for equality of wx.RealPoint objects.
 | __getitem__(self, index)
 | __len__(self)
bool | __ne__(self, pt) Test for inequality of wx.RealPoint objects.
 | __nonzero__(self)
 | __reduce__(self)
 | __repr__(self)
 | __setitem__(self, index, val)
 | __str__(self)
RealPoint | __sub__(self, pt) Subtract pt's proprties from this and return the result
 | asTuple(*args, **kwargs) asTuple is deprecated, use Get instead
(x,y) | Get() Return the x and y properties as a tuple.
 | Set(self, x, y) Set both the x and y properties

Property Summary
 | x
 | y

Class Variable Summary
bool __safe_for_unpickling__ = True

Method Details

__init__(self, x=0.0, y=0.0)
(Constructor)

Create a wx.RealPoint object

Parameters:
x
(type=double)

y
(type=double)

Returns:
RealPoint
Overrides:
__builtin__.object.__init__

__add__(self, pt)
(Addition operator)

Add pt's proprties to this and return the result.

Parameters:
pt
(type=RealPoint)

Returns:
RealPoint

__eq__(self, pt)
(Equality operator)

Test for equality of wx.RealPoint objects.

Parameters:
pt
(type=RealPoint)

Returns:
bool

__ne__(self, pt)

Test for inequality of wx.RealPoint objects.

Parameters:
pt
(type=RealPoint)

Returns:
bool

__sub__(self, pt)
(Subtraction operator)

Subtract pt's proprties from this and return the result

Parameters:
pt
(type=RealPoint)

Returns:
RealPoint

asTuple(*args, **kwargs)

asTuple is deprecated, use Get instead

Get()

Return the x and y properties as a tuple.

Returns:
(x,y)

Set(self, x, y)

Set both the x and y properties

Parameters:
x
(type=double)

y
(type=double)

Property Details

x

Get Method:
RealPoint_x_get(...)
Set Method:
RealPoint_x_set(...)

y

Get Method:
RealPoint_y_get(...)
Set Method:
RealPoint_y_set(...)

Class Variable Details

__safe_for_unpickling__

Type:
bool
Value:
True

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:39 2005 http://epydoc.sf.net


wx.Rect

Package wx :: Class Rect

Type Rect

object --+
         |
        Rect

A class for representing and manipulating rectangles. It has x, y, width and height properties. In wxPython most palces that expect a wx.Rect can also accept a (x,y,width,height) tuple.

Method Summary
Rect | __init__(self, x, y, width, height) Create a new Rect object.
Rect | __add__(self, rect) Add the properties of rect to this rectangle and return the result.
 | __del__(self)
bool | __eq__(self, rect) Test for equality.
 | __getitem__(self, index)
Rect | __iadd__(self, rect) Add the properties of rect to this rectangle, updating this rectangle.
 | __len__(self)
bool | __ne__(self, rect) Test for inequality.
 | __nonzero__(self)
 | __reduce__(self)
 | __repr__(self)
 | __setitem__(self, index, val)
 | __str__(self)
 | asTuple(*args, **kwargs) asTuple is deprecated, use Get instead
Rect | Deflate(self, dx, dy) Decrease the rectangle size.
(x,y,width,height) | Get() Return the rectangle properties as a tuple.
int | GetBottom(self)
Point | GetBottomRight(self)
int | GetHeight(self)
int | GetLeft(self)
Point | GetPosition(self)
int | GetRight(self)
Size | GetSize(self)
int | GetTop(self)
Point | GetTopLeft(self)
int | GetWidth(self)
int | GetX(self)
int | GetY(self)
Rect | Inflate(self, dx, dy) Increases the size of the rectangle.
bool | Inside(self, pt) Return True if the point is (not strcitly) inside the rect.
bool | InsideXY(self, x, y) Return True if the point is (not strcitly) inside the rect.
Rect | Intersect(self, rect) Returns the intersectsion of this rectangle and rect.
bool | Intersects(self, rect) Returns True if the rectangles have a non empty intersection.
bool | IsEmpty(self)
 | Offset(self, pt) Same as OffsetXY but uses dx,dy from Point
 | OffsetXY(self, dx, dy) Moves the rectangle by the specified offset.
 | Set(self, x, y, width, height) Set all rectangle properties.
 | SetBottom(self, bottom)
 | SetBottomRight(self, p)
 | SetHeight(self, h)
 | SetLeft(self, left)
 | SetPosition(self, p)
 | SetRight(self, right)
 | SetSize(self, s)
 | SetTop(self, top)
 | SetTopLeft(self, p)
 | SetWidth(self, w)
 | SetX(self, x)
 | SetY(self, y)
Rect | Union(self, rect) Returns the union of this rectangle and rect.

Property Summary
 | bottom
 | height
 | left
 | position
 | right
 | size
 | top
 | width
 | x
 | y

Class Variable Summary
bool __safe_for_unpickling__ = True

Method Details

__init__(self,
          x=0,
          y=0,
          width=0,
          height=0)
(Constructor)

Create a new Rect object.

Parameters:
x
(type=int)

y
(type=int)

width
(type=int)

height
(type=int)

Returns:
Rect
Overrides:
__builtin__.object.__init__

__add__(self, rect)
(Addition operator)

Add the properties of rect to this rectangle and return the result.

Parameters:
rect
(type=Rect)

Returns:
Rect

__eq__(self, rect)
(Equality operator)

Test for equality.

Parameters:
rect
(type=Rect)

Returns:
bool

__iadd__(self, rect)

Add the properties of rect to this rectangle, updating this rectangle.

Parameters:
rect
(type=Rect)

Returns:
Rect

__ne__(self, rect)

Test for inequality.

Parameters:
rect
(type=Rect)

Returns:
bool

asTuple(*args, **kwargs)

asTuple is deprecated, use Get instead

Deflate(self, dx, dy)

Decrease the rectangle size. This method is the opposite of Inflate in that Deflate(a,b) is equivalent to Inflate(-a,-b). Please refer to Inflate for a full description.

Parameters:
dx
(type=int)

dy
(type=int)

Returns:
Rect

Get()

Return the rectangle properties as a tuple.

Returns:
(x,y,width,height)

Inflate(self, dx, dy)

Increases the size of the rectangle.

The left border is moved farther left and the right border is moved farther right by dx. The upper border is moved farther up and the bottom border is moved farther down by dy. (Note the the width and height of the rectangle thus change by 2*dx and 2*dy, respectively.) If one or both of dx and dy are negative, the opposite happens: the rectangle size decreases in the respective direction.

The change is made to the rectangle inplace, if instead you need a copy that is inflated, preserving the original then make the copy first:

copy = wx.Rect(*original)
copy.Inflate(10,15)

Inflating and deflating behaves naturally. Defined more precisely, that means:

  • Real inflates (that is, dx and/or dy >= 0) are not constrained. Thus inflating a rectangle can cause its upper left corner to move into the negative numbers. (The versions prior to 2.5.4 forced the top left coordinate to not fall below (0, 0), which implied a forced move of the rectangle.)
  • Deflates are clamped to not reduce the width or height of the rectangle below zero. In such cases, the top-left corner is nonetheless handled properly. For example, a rectangle at (10, 10) with size (20, 40) that is inflated by (-15, -15) will become located at (20, 25) at size (0, 10). Finally, observe that the width and height are treated independently. In the above example, the width is reduced by 20, whereas the height is reduced by the full 30 (rather than also stopping at 20, when the width reached zero).
Parameters:
dx
(type=int)

dy
(type=int)

Returns:
Rect

See Also:

Deflate

Inside(self, pt)

Return True if the point is (not strcitly) inside the rect.

Parameters:
pt
(type=Point)

Returns:
bool

InsideXY(self, x, y)

Return True if the point is (not strcitly) inside the rect.

Parameters:
x
(type=int)

y
(type=int)

Returns:
bool

Intersect(self, rect)

Returns the intersectsion of this rectangle and rect.

Parameters:
rect
(type=Rect)

Returns:
Rect

Intersects(self, rect)

Returns True if the rectangles have a non empty intersection.

Parameters:
rect
(type=Rect)

Returns:
bool

Offset(self, pt)

Same as OffsetXY but uses dx,dy from Point

Parameters:
pt
(type=Point)

OffsetXY(self, dx, dy)

Moves the rectangle by the specified offset. If dx is positive, the rectangle is moved to the right, if dy is positive, it is moved to the bottom, otherwise it is moved to the left or top respectively.

Parameters:
dx
(type=int)

dy
(type=int)

Set(self,
          x=0,
          y=0,
          width=0,
          height=0)

Set all rectangle properties.

Parameters:
x
(type=int)

y
(type=int)

width
(type=int)

height
(type=int)

Union(self, rect)

Returns the union of this rectangle and rect.

Parameters:
rect
(type=Rect)

Returns:
Rect

Property Details

bottom

Get Method:
GetBottom(self)
Set Method:
SetBottom(self, bottom)

height

Get Method:
Rect_height_get(...)
Set Method:
Rect_height_set(...)

left

Get Method:
GetLeft(self)
Set Method:
SetLeft(self, left)

position

Get Method:
GetPosition(self)
Set Method:
SetPosition(self, p)

right

Get Method:
GetRight(self)
Set Method:
SetRight(self, right)

size

Get Method:
GetSize(self)
Set Method:
SetSize(self, s)

top

Get Method:
GetTop(self)
Set Method:
SetTop(self, top)

width

Get Method:
Rect_width_get(...)
Set Method:
Rect_width_set(...)

x

Get Method:
Rect_x_get(...)
Set Method:
Rect_x_set(...)

y

Get Method:
Rect_y_get(...)
Set Method:
Rect_y_set(...)

Class Variable Details

__safe_for_unpickling__

Type:
bool
Value:
True

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:09 2005 http://epydoc.sf.net


wx.Region

Package wx :: Class Region

Type Region

object --+
         |
    Object --+
             |
     GDIObject --+
                 |
                Region

Proxy of C++ Region class

Method Summary
Region | __init__(self, x, y, width, height)
 | __del__(self)
 | __repr__(self)
 | Clear(self)
int | Contains(self, x, y)
int | ContainsPoint(self, pt)
int | ContainsRect(self, rect)
int | ContainsRectDim(self, x, y, w, h)
Bitmap | ConvertToBitmap(self)
Rect | GetBox(self)
bool | Intersect(self, x, y, width, height)
bool | IntersectRect(self, rect)
bool | IntersectRegion(self, region)
bool | IsEmpty(self)
bool | Offset(self, x, y)
bool | Subtract(self, x, y, width, height)
bool | SubtractRect(self, rect)
bool | SubtractRegion(self, region)
bool | Union(self, x, y, width, height)
bool | UnionBitmap(self, bmp)
bool | UnionBitmapColour(self, bmp, transColour, tolerance)
bool | UnionRect(self, rect)
bool | UnionRegion(self, region)
bool | Xor(self, x, y, width, height)
bool | XorRect(self, rect)
bool | XorRegion(self, region)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:40 2005 http://epydoc.sf.net


wx.RegionIterator

Package wx :: Class RegionIterator

Type RegionIterator

object --+
         |
    Object --+
             |
            RegionIterator

Proxy of C++ RegionIterator class

Method Summary
RegionIterator | __init__(self, region)
 | __del__(self)
bool | __nonzero__(self)
 | __repr__(self)
int | GetH(self)
int | GetHeight(self)
Rect | GetRect(self)
int | GetW(self)
int | GetWidth(self)
int | GetX(self)
int | GetY(self)
bool | HaveRects(self)
 | Next(self)
 | Reset(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:15 2005 http://epydoc.sf.net


wx.SashEvent

Package wx :: Class SashEvent

Type SashEvent

object --+
         |
    Object --+
             |
         Event --+
                 |
      CommandEvent --+
                     |
                    SashEvent

Proxy of C++ SashEvent class

Method Summary
CommandEvent | __init__(self, commandType, winid) This event class contains information about command events, which originate from a variety of simple controls, as well as menus and toolbars.
 | __repr__(self)
Rect | GetDragRect(self)
int | GetDragStatus(self)
int | GetEdge(self)
 | SetDragRect(self, rect)
 | SetDragStatus(self, status)
 | SetEdge(self, edge)

Method Details

__init__(self, id=0, edge=SASH_NONE)
(Constructor)

This event class contains information about command events, which originate from a variety of simple controls, as well as menus and toolbars.

Parameters:
commandType
(type=wxEventType)

winid
(type=int)

Returns:
CommandEvent
Overrides:
wx.CommandEvent.__init__ (inherited documentation)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:06 2005 http://epydoc.sf.net


wx.SashLayoutWindow

Package wx :: Class SashLayoutWindow

Type SashLayoutWindow

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
            SashWindow --+
                         |
                        SashLayoutWindow

Proxy of C++ SashLayoutWindow class

Method Summary
Window | __init__(self, parent, id, pos, size, style, name) Construct and show a generic Window.
 | __repr__(self)
bool | Create(self, parent, id, pos, size, style, name) Create the GUI part of the Window for 2-phase creation mode.
int | GetAlignment(self)
int | GetOrientation(self)
 | SetAlignment(self, alignment)
 | SetDefaultSize(self, size)
 | SetOrientation(self, orientation)

Instance Method Details

__init__(self,
          parent,
          id=-1,
          pos=DefaultPosition,
          size=DefaultSize,
          style=wxCLIP_CHILDREN|wxSW_3D,
          name=SashLayoutNameStr)
(Constructor)

Construct and show a generic Window.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

name
(type=String)

Returns:
Window
Overrides:
wx.SashWindow.__init__ (inherited documentation)

Create(self,
          parent,
          id=-1,
          pos=DefaultPosition,
          size=DefaultSize,
          style=wxCLIP_CHILDREN|wxSW_3D,
          name=SashLayoutNameStr)

Create the GUI part of the Window for 2-phase creation mode.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

name
(type=String)

Returns:
bool
Overrides:
wx.SashWindow.Create (inherited documentation)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:56 2005 http://epydoc.sf.net


wx.SashWindow

Package wx :: Class SashWindow

Type SashWindow

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
                    SashWindow

Known Subclasses:
SashLayoutWindow

Proxy of C++ SashWindow class

Method Summary
Window | __init__(self, parent, id, pos, size, style, name) Construct and show a generic Window.
 | __repr__(self)
bool | Create(self, parent, id, pos, size, style, name) Create the GUI part of the Window for 2-phase creation mode.
int | GetDefaultBorderSize(self)
int | GetEdgeMargin(self, edge)
int | GetExtraBorderSize(self)
int | GetMaximumSizeX(self)
int | GetMaximumSizeY(self)
int | GetMinimumSizeX(self)
int | GetMinimumSizeY(self)
bool | GetSashVisible(self, edge)
bool | HasBorder(self, edge)
int | SashHitTest(self, x, y, tolerance)
 | SetDefaultBorderSize(self, width)
 | SetExtraBorderSize(self, width)
 | SetMaximumSizeX(self, max)
 | SetMaximumSizeY(self, max)
 | SetMinimumSizeX(self, min)
 | SetMinimumSizeY(self, min)
 | SetSashBorder(self, edge, border)
 | SetSashVisible(self, edge, sash)
 | SizeWindows(self)

Instance Method Details

__init__(self,
          parent,
          id=-1,
          pos=DefaultPosition,
          size=DefaultSize,
          style=wxCLIP_CHILDREN|wxSW_3D,
          name=SashNameStr)
(Constructor)

Construct and show a generic Window.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

name
(type=String)

Returns:
Window
Overrides:
wx.Window.__init__ (inherited documentation)

Create(self,
          parent,
          id=-1,
          pos=DefaultPosition,
          size=DefaultSize,
          style=wxCLIP_CHILDREN|wxSW_3D,
          name=SashNameStr)

Create the GUI part of the Window for 2-phase creation mode.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

name
(type=String)

Returns:
bool
Overrides:
wx.Window.Create (inherited documentation)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:32 2005 http://epydoc.sf.net


wx.ScreenDC

Package wx :: Class ScreenDC

Type ScreenDC

object --+
         |
    Object --+
             |
            DC --+
                 |
                ScreenDC

A wxScreenDC can be used to paint anywhere on the screen. This should normally be constructed as a temporary stack object; don't store a wxScreenDC object.

Method Summary
ScreenDC | __init__(self) A wxScreenDC can be used to paint anywhere on the screen.
 | __repr__(self)
bool | EndDrawingOnTop(self) Use this in conjunction with StartDrawingOnTop or StartDrawingOnTopWin to ensure that drawing to the screen occurs on top of existing windows.
bool | StartDrawingOnTop(self, rect) Specify that the area is the given rectangle, or the whole screen if None is passed.
bool | StartDrawingOnTopWin(self, window) Specify that the area of the screen to be drawn upon coincides with the given window.

Method Details

__init__(self)
(Constructor)

A wxScreenDC can be used to paint anywhere on the screen. This should normally be constructed as a temporary stack object; don't store a wxScreenDC object.

Returns:
ScreenDC
Overrides:
wx.DC.__init__

EndDrawingOnTop(self)

Use this in conjunction with StartDrawingOnTop or StartDrawingOnTopWin to ensure that drawing to the screen occurs on top of existing windows. Without this, some window systems (such as X) only allow drawing to take place underneath other windows.

You might use this pair of functions when implementing a drag feature, for example as in the wx.SplitterWindow implementation.

These functions are probably obsolete since the X implementations allow drawing directly on the screen now. However, the fact that this function allows the screen to be refreshed afterwards may be useful to some applications.

Returns:
bool

StartDrawingOnTop(self, rect=None)

Specify that the area is the given rectangle, or the whole screen if None is passed.

Parameters:
rect
(type=Rect)

Returns:
bool

See Also:

EndDrawingOnTop

StartDrawingOnTopWin(self, window)

Specify that the area of the screen to be drawn upon coincides with the given window.

Parameters:
window
(type=Window)

Returns:
bool

See Also:

EndDrawingOnTop

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:27 2005 http://epydoc.sf.net


wx.ScrollBar

Package wx :: Class ScrollBar

Type ScrollBar

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
               Control --+
                         |
                        ScrollBar

Proxy of C++ ScrollBar class

Method Summary
Control | __init__(self, parent, id, pos, size, style, validator, name) Create a Control.
 | __repr__(self)
bool | Create(self, parent, id, pos, size, style, validator, name) Do the 2nd phase and create the GUI control.
VisualAttributes | GetClassDefaultAttributes(variant) Get the default attributes for this class. (Static method)
int | GetPageSize(self)
int | GetRange(self)
int | GetThumbLength(self)
int | GetThumbPosition(self)
int | GetThumbSize(self)
bool | IsVertical(self)
 | SetScrollbar(self, orientation, position, thumbSize, range, refresh)
 | SetThumbPosition(self, viewStart)

Instance Method Details

__init__(self,
          parent,
          id=-1,
          pos=DefaultPosition,
          size=DefaultSize,
          style=SB_HORIZONTAL,
          validator=DefaultValidator,
          name=ScrollBarNameStr)
(Constructor)

Create a Control. Normally you should only call this from a subclass' __init__ as a plain old wx.Control is not very useful.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

validator
(type=Validator)

name
(type=String)

Returns:
Control
Overrides:
wx.Control.__init__ (inherited documentation)

Create(self,
          parent,
          id=-1,
          pos=DefaultPosition,
          size=DefaultSize,
          style=SB_HORIZONTAL,
          validator=DefaultValidator,
          name=ScrollBarNameStr)

Do the 2nd phase and create the GUI control.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

validator
(type=Validator)

name
(type=String)

Returns:
bool
Overrides:
wx.Control.Create

SetScrollbar(self, position, thumbSize, range, pageSize, refresh=True)

Sets the scrollbar properties of a built-in scrollbar.
Parameters:
orientation - Determines the scrollbar whose page size is to be set. May be wx.HORIZONTAL or wx.VERTICAL.
(type=int)

position - The position of the scrollbar in scroll units.
(type=int)

thumbSize - The size of the thumb, or visible portion of the scrollbar, in scroll units.
(type=int)

range - The maximum position of the scrollbar.
(type=int)

refresh - True to redraw the scrollbar, false otherwise.
(type=bool)

Overrides:
wx.Window.SetScrollbar (inherited documentation)

Static Method Details

GetClassDefaultAttributes(variant=WINDOW_VARIANT_NORMAL)

Get the default attributes for this class. This is useful if you want to use the same font or colour in your own control as in a standard control -- which is a much better idea than hard coding specific colours or fonts which might look completely out of place on the user's system, especially if it uses themes.

The variant parameter is only relevant under Mac currently and is ignore under other platforms. Under Mac, it will change the size of the returned font. See wx.Window.SetWindowVariant for more about this.

Parameters:
variant
(type=int)

Returns:
VisualAttributes

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:59 2005 http://epydoc.sf.net


wx.ScrolledWindow

Package wx :: Class ScrolledWindow

Type ScrolledWindow

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
                 Panel --+
                         |
                        ScrolledWindow

Known Subclasses:
Editor, Grid, HtmlWindow, MVCTree, PreviewCanvas, PrintTableDraw, PyScrolledWindow, ShapeCanvas, SplitterScrolledWindow

Proxy of C++ ScrolledWindow class

Method Summary
Window __init__(self, parent, id, pos, size, style, name)
Construct and show a generic Window.
__repr__(self)
AdjustScrollbars(self)
Point CalcScrolledPosition(self, pt)
CalcScrolledPosition(int x, int y) -> (sx, sy)
int | CalcScrollInc(self, event)
Point CalcUnscrolledPosition(self, pt)
CalcUnscrolledPosition(int x, int y) -> (ux, uy)
bool Create(self, parent, id, pos, size, style, name)
Create the GUI part of the Window for 2-phase creation mode.
DoPrepareDC(self, dc)
Normally what is called by PrepareDC.
EnableScrolling(self, x_scrolling, y_scrolling)
VisualAttributes GetClassDefaultAttributes(variant)
Get the default attributes for this class. (Static method)
double | GetScaleX(self)
double | GetScaleY(self)
int | GetScrollPageSize(self, orient)
(xUnit, yUnit) GetScrollPixelsPerUnit()
Get the size of one logical unit in physical units.
Window | GetTargetWindow(self)
(x,y) GetViewStart()
Get the view start
Scroll(self, x, y)
SetScale(self, xs, ys)
SetScrollbars(self, pixelsPerUnitX, pixelsPerUnitY, noUnitsX, noUnitsY, xPos, yPos, noRefresh)
SetScrollPageSize(self, orient, pageSize)
SetScrollRate(self, xstep, ystep)
SetTargetWindow(self, target)

Instance Method Details

__init__(self,
          parent,
          id=-1,
          pos=DefaultPosition,
          size=DefaultSize,
          style=wxHSCROLL|wxVSCROLL,
          name=PanelNameStr)
(Constructor)

Construct and show a generic Window.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

name
(type=String)

Returns:
Window
Overrides:
wx.Panel.__init__ (inherited documentation)

CalcScrolledPosition(self, pt)

CalcScrolledPosition(int x, int y) -> (sx, sy)

Translate between scrolled and unscrolled coordinates.

Parameters:
pt
(type=Point)

Returns:
Point

CalcUnscrolledPosition(self, pt)

CalcUnscrolledPosition(int x, int y) -> (ux, uy)

Translate between scrolled and unscrolled coordinates.

Parameters:
pt
(type=Point)

Returns:
Point

Create(self,
          parent,
          id=-1,
          pos=DefaultPosition,
          size=DefaultSize,
          style=wxHSCROLL|wxVSCROLL,
          name=PanelNameStr)

Create the GUI part of the Window for 2-phase creation mode.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

name
(type=String)

Returns:
bool
Overrides:
wx.Panel.Create

DoPrepareDC(self, dc)

Normally what is called by PrepareDC.

Parameters:
dc
(type=DC)

GetScrollPixelsPerUnit()

Get the size of one logical unit in physical units.

Returns:
(xUnit, yUnit)

GetViewStart()

Get the view start

Returns:
(x,y)

Static Method Details

GetClassDefaultAttributes(variant=WINDOW_VARIANT_NORMAL)

Get the default attributes for this class. This is useful if you want to use the same font or colour in your own control as in a standard control -- which is a much better idea than hard coding specific colours or fonts which might look completely out of place on the user's system, especially if it uses themes.

The variant parameter is only relevant under Mac currently and is ignore under other platforms. Under Mac, it will change the size of the returned font. See wx.Window.SetWindowVariant for more about this.

Parameters:
variant
(type=int)

Returns:
VisualAttributes

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:42 2005 http://epydoc.sf.net


wx.ScrollEvent

Package wx :: Class ScrollEvent

Type ScrollEvent

object --+
         |
    Object --+
             |
         Event --+
                 |
      CommandEvent --+
                     |
                    ScrollEvent

A scroll event holds information about events sent from stand-alone scrollbars and sliders. Note that scrolled windows do not send instnaces of this event class, but send the wx.ScrollWinEvent instead.

Events

EVT_SCROLL | Used to bind all scroll events
EVT_SCROLL_TOP | scroll-to-top events (minimum position)
EVT_SCROLL_BOTTOM | scroll-to-bottom events (maximum position)
EVT_SCROLL_LINEUP | line up events
EVT_SCROLL_LINEDOWN | line down events
EVT_SCROLL_PAGEUP | page up events
EVT_SCROLL_PAGEDOWN | page down events
EVT_SCROLL_THUMBTRACK | thumbtrack events (frequent events sent as the user drags the 'thumb')
EVT_SCROLL_THUMBRELEASE | thumb release events.
EVT_SCROLL_ENDSCROLL | End of scrolling

Note

The EVT_SCROLL_THUMBRELEASE event is only emitted when actually dragging the thumb using the mouse and releasing it (This EVT_SCROLL_THUMBRELEASE event is also followed by an EVT_SCROLL_ENDSCROLL event).

The EVT_SCROLL_ENDSCROLL event also occurs when using the keyboard to change the thumb position, and when clicking next to the thumb (In all these cases the EVT_SCROLL_THUMBRELEASE event does not happen).

In short, the EVT_SCROLL_ENDSCROLL event is triggered when scrolling/ moving has finished. The only exception (unfortunately) is that changing the thumb position using the mousewheel does give a EVT_SCROLL_THUMBRELEASE event but NOT an EVT_SCROLL_ENDSCROLL event.

Method Summary
CommandEvent | __init__(self, commandType, winid) This event class contains information about command events, which originate from a variety of simple controls, as well as menus and toolbars.
 | __repr__(self)
int | GetOrientation(self) Returns wx.HORIZONTAL or wx.VERTICAL, depending on the orientation of the scrollbar.
int | GetPosition(self) Returns the position of the scrollbar.
 | SetOrientation(self, orient)
 | SetPosition(self, pos)

Method Details

__init__(self,
          commandType=wxEVT_NULL,
          winid=0,
          pos=0,
          orient=0)
(Constructor)

This event class contains information about command events, which originate from a variety of simple controls, as well as menus and toolbars.

Parameters:
commandType
(type=wxEventType)

winid
(type=int)

Returns:
CommandEvent
Overrides:
wx.CommandEvent.__init__ (inherited documentation)

GetOrientation(self)

Returns wx.HORIZONTAL or wx.VERTICAL, depending on the orientation of the scrollbar.

Returns:
int

GetPosition(self)

Returns the position of the scrollbar.

Returns:
int

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:10:47 2005 http://epydoc.sf.net


wx.ScrollWinEvent

Package wx :: Class ScrollWinEvent

Type ScrollWinEvent

object --+
         |
    Object --+
             |
         Event --+
                 |
                ScrollWinEvent

A wx.ScrollWinEvent holds information about scrolling and is sent from scrolling windows.

Events

EVT_SCROLLWIN | Used to bind all scrolled window scroll events
EVT_SCROLLWIN_TOP | scroll-to-top events (minimum position)
EVT_SCROLLWIN_BOTTOM | scroll-to-bottom events (maximum position)
EVT_SCROLLWIN_LINEUP | line up events
EVT_SCROLLWIN_LINEDOWN | line down events
EVT_SCROLLWIN_PAGEUP | page up events
EVT_SCROLLWIN_PAGEDOWN | page down events
EVT_SCROLLWIN_THUMBTRACK | thumbtrack events (frequent events sent as the user drags the 'thumb')
EVT_SCROLLWIN_THUMBRELEASE | thumb release events.
EVT_SCROLLWIN_ENDSCROLL | End of scrolling

See Also:

wx.ScrollEvent

Method Summary
ScrollWinEvent | __init__(self, commandType, pos, orient) A wx.ScrollWinEvent holds information about scrolling and is sent from scrolling windows.
 | __repr__(self)
int | GetOrientation(self) Returns wx.HORIZONTAL or wx.VERTICAL, depending on the orientation of the scrollbar.
int | GetPosition(self) Returns the position of the scrollbar for the thumb track and release events.
 | SetOrientation(self, orient)
 | SetPosition(self, pos)

Method Details

__init__(self,
          commandType=wxEVT_NULL,
          pos=0,
          orient=0)
(Constructor)

A wx.ScrollWinEvent holds information about scrolling and is sent from scrolling windows.

Events

EVT_SCROLLWIN | Used to bind all scrolled window scroll events
EVT_SCROLLWIN_TOP | scroll-to-top events (minimum position)
EVT_SCROLLWIN_BOTTOM | scroll-to-bottom events (maximum position)
EVT_SCROLLWIN_LINEUP | line up events
EVT_SCROLLWIN_LINEDOWN | line down events
EVT_SCROLLWIN_PAGEUP | page up events
EVT_SCROLLWIN_PAGEDOWN | page down events
EVT_SCROLLWIN_THUMBTRACK | thumbtrack events (frequent events sent as the user drags the 'thumb')
EVT_SCROLLWIN_THUMBRELEASE | thumb release events.
EVT_SCROLLWIN_ENDSCROLL | End of scrolling
Parameters:
commandType
(type=wxEventType)

pos
(type=int)

orient
(type=int)

Returns:
ScrollWinEvent
Overrides:
wx.Event.__init__

See Also:

wx.ScrollEvent

GetOrientation(self)

Returns wx.HORIZONTAL or wx.VERTICAL, depending on the orientation of the scrollbar.

Returns:
int

GetPosition(self)

Returns the position of the scrollbar for the thumb track and release events. Note that this field can't be used for the other events, you need to query the window itself for the current position in that case.

Returns:
int

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:10:50 2005 http://epydoc.sf.net


wx.SetCursorEvent

Package wx :: Class SetCursorEvent

Type SetCursorEvent

object --+
         |
    Object --+
             |
         Event --+
                 |
                SetCursorEvent

A SetCursorEvent is generated when the mouse cursor is about to be set as a result of mouse motion. This event gives the application the chance to perform specific mouse cursor processing based on the current position of the mouse within the window. Use the SetCursor method to specify the cursor you want to be displayed.

Method Summary
SetCursorEvent | __init__(self, x, y) Construct a new wx.SetCursorEvent.
 | __repr__(self)
Cursor | GetCursor(self) Returns a reference to the cursor specified by this event.
int | GetX(self) Returns the X coordinate of the mouse in client coordinates.
int | GetY(self) Returns the Y coordinate of the mouse in client coordinates.
bool | HasCursor(self) Returns true if the cursor specified by this event is a valid cursor.
 | SetCursor(self, cursor) Sets the cursor associated with this event.

Method Details

__init__(self, x=0, y=0)
(Constructor)

Construct a new wx.SetCursorEvent.

Parameters:
x
(type=int)

y
(type=int)

Returns:
SetCursorEvent
Overrides:
wx.Event.__init__

GetCursor(self)

Returns a reference to the cursor specified by this event.

Returns:
Cursor

GetX(self)

Returns the X coordinate of the mouse in client coordinates.

Returns:
int

GetY(self)

Returns the Y coordinate of the mouse in client coordinates.

Returns:
int

HasCursor(self)

Returns true if the cursor specified by this event is a valid cursor.

Returns:
bool

SetCursor(self, cursor)

Sets the cursor associated with this event.

Parameters:
cursor
(type=Cursor)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:05 2005 http://epydoc.sf.net


wx.ShowEvent

Package wx :: Class ShowEvent

Type ShowEvent

object --+
         |
    Object --+
             |
         Event --+
                 |
                ShowEvent

An EVT_SHOW event is sent when a window is shown or hidden.

Method Summary
ShowEvent | __init__(self, winid, show) An EVT_SHOW event is sent when a window is shown or hidden.
 | __repr__(self)
bool | GetShow(self)
 | SetShow(self, show)

Method Details

__init__(self, winid=0, show=False)
(Constructor)

An EVT_SHOW event is sent when a window is shown or hidden.

Parameters:
winid
(type=int)

show
(type=bool)

Returns:
ShowEvent
Overrides:
wx.Event.__init__

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:51 2005 http://epydoc.sf.net


wx.SimpleHelpProvider

Package wx :: Class SimpleHelpProvider

Type SimpleHelpProvider

  object --+
           |
HelpProvider --+
               |
              SimpleHelpProvider

wx.SimpleHelpProvider is an implementation of wx.HelpProvider which supports only plain text help strings, and shows the string associated with the control (if any) in a tooltip.

Method Summary
SimpleHelpProvider | __init__(self) wx.SimpleHelpProvider is an implementation of wx.HelpProvider which supports only plain text help strings, and shows the string associated with the control (if any) in a tooltip.
 | __repr__(self)

Instance Method Details

__init__(self)
(Constructor)

wx.SimpleHelpProvider is an implementation of wx.HelpProvider which supports only plain text help strings, and shows the string associated with the control (if any) in a tooltip.

Returns:
SimpleHelpProvider
Overrides:
wx.HelpProvider.__init__

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:23 2005 http://epydoc.sf.net


wx.SingleChoiceDialog

Package wx :: Class SingleChoiceDialog

Type SingleChoiceDialog

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
        TopLevelWindow --+
                         |
                    Dialog --+
                             |
                            SingleChoiceDialog

A simple dialog with a single selection listbox.

Method Summary
SingleChoiceDialog | __init__(parent, message, caption, choices, style, pos) Constructor.
 | __repr__(self)
int | GetSelection(self) Get the index of teh currently selected item.
String | GetStringSelection(self) Returns the string value of the currently selected item
 | SetSelection(self, sel) Set the current selected item to sel

Instance Method Details

__init__(parent, message, caption, choices=EmptyList, style=CHOICEDLG_STYLE, pos=DefaultPosition)
(Constructor)

Constructor. Use ShowModal method to show the dialog.

Parameters:
parent
(type=Window)

message
(type=String)

caption
(type=String)

choices
(type=List)

style
(type=long)

pos
(type=Point)

Returns:
SingleChoiceDialog
Overrides:
wx.Dialog.__init__

GetSelection(self)

Get the index of teh currently selected item.

Returns:
int

GetStringSelection(self)

Returns the string value of the currently selected item

Returns:
String

SetSelection(self, sel)

Set the current selected item to sel

Parameters:
sel
(type=int)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:41 2005 http://epydoc.sf.net


wx.SingleInstanceChecker

Package wx :: Class SingleInstanceChecker

Type SingleInstanceChecker

object --+
         |
        SingleInstanceChecker

Proxy of C++ SingleInstanceChecker class

Method Summary
SingleInstanceChecker | __init__(self, name, path)
 | __del__(self)
 | __repr__(self)
bool | Create(self, name, path)
bool | IsAnotherRunning(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:46 2005 http://epydoc.sf.net


wx.Size

Package wx :: Class Size

Type Size

object --+
         |
        Size

wx.Size is a useful data structure used to represent the size of something. It simply contians integer width and height proprtites. In most places in wxPython where a wx.Size is expected a (width, height) tuple can be used instead.

Method Summary
Size | __init__(self, w, h) Creates a size object.
Size | __add__(self, sz) Add sz's proprties to this and return the result.
 | __del__(self)
bool | __eq__(self, sz) Test for equality of wx.Size objects.
 | __getitem__(self, index)
 | __len__(self)
bool | __ne__(self, sz) Test for inequality.
 | __nonzero__(self)
 | __reduce__(self)
 | __repr__(self)
 | __setitem__(self, index, val)
 | __str__(self)
Size | __sub__(self, sz) Subtract sz's properties from this and return the result.
 | asTuple(*args, **kwargs) asTuple is deprecated, use Get instead
 | DecTo(self, sz) Decrements this object so that both of its dimensions are not greater than the corresponding dimensions of the size.
(width,height) | Get() Returns the width and height properties as a tuple.
int | GetHeight(self)
int | GetWidth(self)
 | IncTo(self, sz) Increments this object so that both of its dimensions are not less than the corresponding dimensions of the size.
bool | IsFullySpecified(self) Returns True if both components of the size are non-default values.
 | Set(self, w, h) Set both width and height.
 | SetDefaults(self, size) Combine this size with the other one replacing the default components of this object (i.e.
 | SetHeight(self, h)
 | SetWidth(self, w)

Property Summary
 | height
 | width
 | x
 | y

Class Variable Summary
bool __safe_for_unpickling__ = True

Method Details

__init__(self, w=0, h=0)
(Constructor)

Creates a size object.

Parameters:
w
(type=int)

h
(type=int)

Returns:
Size
Overrides:
__builtin__.object.__init__

__add__(self, sz)
(Addition operator)

Add sz's proprties to this and return the result.

Parameters:
sz
(type=Size)

Returns:
Size

__eq__(self, sz)
(Equality operator)

Test for equality of wx.Size objects.

Parameters:
sz
(type=Size)

Returns:
bool

__ne__(self, sz)

Test for inequality.

Parameters:
sz
(type=Size)

Returns:
bool

__sub__(self, sz)
(Subtraction operator)

Subtract sz's properties from this and return the result.

Parameters:
sz
(type=Size)

Returns:
Size

asTuple(*args, **kwargs)

asTuple is deprecated, use Get instead

DecTo(self, sz)

Decrements this object so that both of its dimensions are not greater than the corresponding dimensions of the size.

Parameters:
sz
(type=Size)

Get()

Returns the width and height properties as a tuple.

Returns:
(width,height)

IncTo(self, sz)

Increments this object so that both of its dimensions are not less than the corresponding dimensions of the size.

Parameters:
sz
(type=Size)

IsFullySpecified(self)

Returns True if both components of the size are non-default values.

Returns:
bool

Set(self, w, h)

Set both width and height.

Parameters:
w
(type=int)

h
(type=int)

SetDefaults(self, size)

Combine this size with the other one replacing the default components of this object (i.e. equal to -1) with those of the other.

Parameters:
size
(type=Size)

Property Details

height

Get Method:
Size_height_get(...)
Set Method:
Size_height_set(...)

width

Get Method:
Size_width_get(...)
Set Method:
Size_width_set(...)

x

Get Method:
Size_width_get(...)
Set Method:
Size_width_set(...)

y

Get Method:
Size_height_get(...)
Set Method:
Size_height_set(...)

Class Variable Details

__safe_for_unpickling__

Type:
bool
Value:
True

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:39 2005 http://epydoc.sf.net


wx.SizeEvent

Package wx :: Class SizeEvent

Type SizeEvent

object --+
         |
    Object --+
             |
         Event --+
                 |
                SizeEvent

A size event holds information about size change events. The EVT_SIZE handler function will be called when the window it is bound to has been resized.

Note that the size passed is of the whole window: call wx.Window.GetClientSize for the area which may be used by the application.

When a window is resized, usually only a small part of the window is damaged and and that area is all that is in the update region for the next paint event. However, if your drawing depends on the size of the window, you may need to clear the DC explicitly and repaint the whole window. In which case, you may need to call wx.Window.Refresh to invalidate the entire window.

Method Summary
SizeEvent | __init__(self, sz, winid) Construct a new wx.SizeEvent.
 | __repr__(self)
Rect | GetRect(self)
Size | GetSize(self) Returns the entire size of the window generating the size change event.
 | SetRect(self, rect)
 | SetSize(self, size)

Property Summary
 | m_rect
 | m_size

Method Details

__init__(self, sz=DefaultSize, winid=0)
(Constructor)

Construct a new wx.SizeEvent.

Parameters:
sz
(type=Size)

winid
(type=int)

Returns:
SizeEvent
Overrides:
wx.Event.__init__

GetSize(self)

Returns the entire size of the window generating the size change event.

Returns:
Size

Property Details

m_rect

Get Method:
SizeEvent_m_rect_get(...)
Set Method:
SizeEvent_m_rect_set(...)

m_size

Get Method:
SizeEvent_m_size_get(...)
Set Method:
SizeEvent_m_size_set(...)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:47 2005 http://epydoc.sf.net


wx.Sizer

Package wx :: Class Sizer

Type Sizer

object --+
         |
    Object --+
             |
            Sizer

Known Subclasses:
BookCtrlSizer, BoxSizer, GridSizer, NotebookSizer, PySizer

wx.Sizer is the abstract base class used for laying out subwindows in a window. You cannot use wx.Sizer directly; instead, you will have to use one of the sizer classes derived from it such as wx.BoxSizer, wx.StaticBoxSizer, wx.NotebookSizer, wx.GridSizer, wx.FlexGridSizer and wx.GridBagSizer.

The concept implemented by sizers in wxWidgets is closely related to layout tools in other GUI toolkits, such as Java's AWT, the GTK toolkit or the Qt toolkit. It is based upon the idea of the individual subwindows reporting their minimal required size and their ability to get stretched if the size of the parent window has changed. This will most often mean that the programmer does not set the original size of a dialog in the beginning, rather the dialog will assigned a sizer and this sizer will be queried about the recommended size. The sizer in turn will query its children, which can be normal windows or contorls, empty space or other sizers, so that a hierarchy of sizers can be constructed. Note that wxSizer does not derive from wxWindow and thus do not interfere with tab ordering and requires very little resources compared to a real window on screen.

What makes sizers so well fitted for use in wxWidgets is the fact that every control reports its own minimal size and the algorithm can handle differences in font sizes or different window (dialog item) sizes on different platforms without problems. If for example the standard font as well as the overall design of Mac widgets requires more space than on Windows, then the initial size of a dialog using a sizer will automatically be bigger on Mac than on Windows.

Sizers may also be used to control the layout of custom drawn items on the window. The Add, Insert, and Prepend functions return a pointer to the newly added wx.SizerItem. Just add empty space of the desired size and attributes, and then use the wx.SizerItem.GetRect method to determine where the drawing operations should take place.

Note:

If you wish to create a custom sizer class in wxPython you should derive the class from wx.PySizer in order to get Python-aware capabilities for the various virtual methods.

See Also:

wx.SizerItem

To Do:

More dscriptive text here along with some pictures...

Method Summary
 | __init__(self)
 | __repr__(self)
wx.SizerItem | Add(self, item, proportion, flag, border, userData) Appends a child item to the sizer.
 | AddItem(self, item) Adds a wx.SizerItem to the sizer.
 | AddMany(self, items) AddMany is a convenience method for adding several items to a sizer at one time.
 | AddSizer(self, *args, **kw) Compatibility alias for Add.
 | AddSpacer(self, *args, **kw) Compatibility alias for Add.
 | AddWindow(self, *args, **kw) Compatibility alias for Add.
Size | CalcMin(self) This method is where the sizer will do the actual calculation of its children's minimal sizes.
 | Clear(self, deleteWindows) Clear all items from the sizer, optionally destroying the window items as well.
 | DeleteWindows(self) Destroy all windows managed by the sizer.
bool | Detach(self, item) Detaches an item from the sizer without destroying it.
Size | Fit(self, window) Tell the sizer to resize the window to match the sizer's minimal size.
 | FitInside(self, window) Tell the sizer to resize the virtual size of the window to match the sizer's minimal size.
list | GetChildren(self) Returns a list of all the wx.SizerItem objects managed by the sizer.
wx.SizerItem | GetItem(self, item) Returns the wx.SizerItem which holds the item given.
Size | GetMinSize(self) Returns the minimal size of the sizer.
 | GetMinSizeTuple(self)
Point | GetPosition(self) Returns the current position of the sizer's managed space.
 | GetPositionTuple(self)
Size | GetSize(self) Returns the current size of the space managed by the sizer.
 | GetSizeTuple(self)
 | Hide(self, item, recursive) A convenience method for Show (item, False, recursive).
wx.SizerItem | Insert(self, before, item, proportion, flag, border, userData) Inserts a new item into the list of items managed by this sizer before the item at index before.
 | InsertItem(self, index, item) Inserts a wx.SizerItem to the sizer at the position given by index.
 | InsertSizer(self, *args, **kw) Compatibility alias for Insert.
 | InsertSpacer(self, *args, **kw) Compatibility alias for Insert.
 | InsertWindow(self, *args, **kw) Compatibility alias for Insert.
 | IsShown(self, item) Determines if the item is currently shown.
 | Layout(self) This method will force the recalculation and layout of the items controlled by the sizer using the current space allocated to the sizer.
wx.SizerItem | Prepend(self, item, proportion, flag, border, userData) Adds a new item to the begining of the list of sizer items managed by this sizer.
 | PrependItem(self, item) Prepends a wx.SizerItem to the sizer.
 | PrependSizer(self, *args, **kw) Compatibility alias for Prepend.
 | PrependSpacer(self, *args, **kw) Compatibility alias for Prepend.
 | PrependWindow(self, *args, **kw) Compatibility alias for Prepend.
 | RecalcSizes(self) Using the sizes calculated by CalcMin reposition and resize all the items managed by this sizer.
bool | Remove(self, item) Removes an item from the sizer and destroys it.
 | RemovePos(self, *args, **kw) Compatibility alias for Remove.
 | RemoveSizer(self, *args, **kw) Compatibility alias for Remove.
 | RemoveWindow(self, *args, **kw) Compatibility alias for Remove.
 | SetDimension(self, x, y, width, height) Call this to force the sizer to take the given dimension and thus force the items owned by the sizer to resize themselves according to the rules defined by the parameter in the Add, Insert or Prepend methods.
 | SetItemMinSize(self, item, size) Sets the minimum size that will be allocated for an item in the sizer.
 | SetMinSize(self, size) Call this to give the sizer a minimal size.
 | SetSizeHints(self, window) Tell the sizer to set (and Fit) the minimal size of the window to match the sizer's minimal size.
 | SetVirtualSizeHints(self, window) Tell the sizer to set the minimal size of the window virtual area to match the sizer's minimal size.
bool | Show(self, item, show, recursive) Shows or hides an item managed by the sizer.
 | ShowItems(self, show) Recursively call wx.SizerItem.Show on all sizer items.

Method Details

Add(self,
          item,
          proportion=0,
          flag=0,
          border=0,
          userData=None)

Appends a child item to the sizer.

Parameters:
item - The item can be one of three kinds of objects:

  • window: A wx.Window to be managed by the sizer. Its minimal size (either set explicitly by the user or calculated internally when constructed with wx.DefaultSize) is interpreted as the minimal size to use when laying out item in the sizer. This is particularly useful in connection with wx.Window.SetSizeHints.
  • sizer: The (child-)sizer to be added to the sizer. This allows placing a child sizer in a sizer and thus to create hierarchies of sizers (typically a vertical box as the top sizer and several horizontal boxes on the level beneath).
  • size: A wx.Size or a 2-element sequence of integers that represents the width and height of a spacer to be added to the sizer. Adding spacers to sizers gives more flexibility in the design of dialogs; imagine for example a horizontal box with two buttons at the bottom of a dialog: you might want to insert a space between the two buttons and make that space stretchable using the proportion value and the result will be that the left button will be aligned with the left side of the dialog and the right button with the right side - the space in between will shrink and grow with the dialog.

proportion - Although the meaning of this parameter is undefined in wx.Sizer, it is used in wx.BoxSizer to indicate if a child of a sizer can change its size in the main orientation of the wx.BoxSizer - where 0 stands for not changeable and a value of more than zero is interpreted relative (a proportion of the total) to the value of other children of the same wx.BoxSizer. For example, you might have a horizontal wx.BoxSizer with three children, two of which are supposed to change their size with the sizer. Then the two stretchable windows should each be given proportion value of 1 to make them grow and shrink equally with the sizer's horizontal dimension. But if one of them had a proportion value of 2 then it would get a double share of the space available after the fixed size items are positioned.
(type=int)

flag - This parameter can be used to set a number of flags which can be combined using the binary OR operator |. Two main behaviours are defined using these flags. One is the border around a window: the border parameter determines the border width whereas the flags given here determine which side(s) of the item that the border will be added. The other flags determine how the sizer item behaves when the space allotted to the sizer changes, and is somewhat dependent on the specific kind of sizer used.

  • wx.TOP
  • wx.BOTTOM
  • wx.LEFT
  • wx.RIGHT
  • wx.ALL
 These flags are used to specify which side(s) of the sizer item that the border width will apply to.
  • wx.EXPAND
 The item will be expanded to fill the space allotted to the item.
  • wx.SHAPED
 The item will be expanded as much as possible while also maintaining its aspect ratio
  • wx.FIXED_MINSIZE
 Normally wx.Sizers will use wx.Window.GetMinSize or wx.Window.GetBestSize to determine what the minimal size of window items should be, and will use that size to calculate the layout. This allows layouts to adjust when an item changes and it's best size becomes different. If you would rather have a window item stay the size it started with then use wx.FIXED_MINSIZE.
  • wx.ALIGN_CENTER
  • wx.ALIGN_LEFT
  • wx.ALIGN_RIGHT
  • wx.ALIGN_TOP
  • wx.ALIGN_BOTTOM
  • wx.ALIGN_CENTER_VERTICAL
  • wx.ALIGN_CENTER_HORIZONTAL
 The wx.ALIGN flags allow you to specify the alignment of the item within the space allotted to it by the sizer, ajusted for the border if any.

(type=int)

border - Determines the border width, if the flag parameter is set to include any border flag.
(type=int)

userData - Allows an extra object to be attached to the sizer item, for use in derived classes when sizing information is more complex than the proportion and flag will allow for.
(type=PyObject)

Returns:
wx.SizerItem

AddItem(self, item)

Adds a wx.SizerItem to the sizer.

Parameters:
item
(type=SizerItem)

AddMany(self, items)

AddMany is a convenience method for adding several items to a sizer at one time. Simply pass it a list of tuples, where each tuple consists of the parameters that you would normally pass to the Add method.

AddSizer(self, *args, **kw)

Compatibility alias for Add.

AddSpacer(self, *args, **kw)

Compatibility alias for Add.

AddWindow(self, *args, **kw)

Compatibility alias for Add.

CalcMin(self)

This method is where the sizer will do the actual calculation of its children's minimal sizes. You should not need to call this directly as it is called by Layout.

Returns:
Size

Clear(self, deleteWindows=False)

Clear all items from the sizer, optionally destroying the window items as well.

Parameters:
deleteWindows
(type=bool)

DeleteWindows(self)

Destroy all windows managed by the sizer.

Detach(self, item)

Detaches an item from the sizer without destroying it. This method does not cause any layout or resizing to take place, call Layout to do so. The item parameter can be either a window, a sizer, or the zero-based index of the item to be detached. Returns True if the child item was found and detached.

Returns:
bool

Fit(self, window)

Tell the sizer to resize the window to match the sizer's minimal size. This is commonly done in the constructor of the window itself in order to set its initial size to match the needs of the children as determined by the sizer. Returns the new size.

For a top level window this is the total window size, not the client size.

Parameters:
window
(type=Window)

Returns:
Size

FitInside(self, window)

Tell the sizer to resize the virtual size of the window to match the sizer's minimal size. This will not alter the on screen size of the window, but may cause the addition/removal/alteration of scrollbars required to view the virtual area in windows which manage it.

Parameters:
window
(type=Window)

See Also:

wx.ScrolledWindow.SetScrollbars, SetVirtualSizeHints

GetChildren(self)

Returns a list of all the wx.SizerItem objects managed by the sizer.

Returns:
list

GetItem(self, item)

Returns the wx.SizerItem which holds the item given. The item parameter can be either a window, a sizer, or the zero-based index of the item to be detached.

Returns:
wx.SizerItem

GetMinSize(self)

Returns the minimal size of the sizer. This is either the combined minimal size of all the children and their borders or the minimal size set by SetMinSize, depending on which is bigger.

Returns:
Size

GetPosition(self)

Returns the current position of the sizer's managed space.

Returns:
Point

GetSize(self)

Returns the current size of the space managed by the sizer.

Returns:
Size

Hide(self, item, recursive=False)

A convenience method for Show (item, False, recursive).

Insert(self, before, item, proportion=0, flag=0, border=0, userData=None)

Inserts a new item into the list of items managed by this sizer before the item at index before. See Add for a description of the parameters.

Parameters:
before
(type=int)

proportion
(type=int)

flag
(type=int)

border
(type=int)

userData
(type=PyObject)

Returns:
wx.SizerItem

InsertItem(self, index, item)

Inserts a wx.SizerItem to the sizer at the position given by index.

Parameters:
index
(type=int)

item
(type=SizerItem)

InsertSizer(self, *args, **kw)

Compatibility alias for Insert.

InsertSpacer(self, *args, **kw)

Compatibility alias for Insert.

InsertWindow(self, *args, **kw)

Compatibility alias for Insert.

IsShown(self, item)

Determines if the item is currently shown. sizer. To make a sizer item disappear or reappear, use Show followed by Layout. The item parameter can be either a window, a sizer, or the zero-based index of the item.

Layout(self)

This method will force the recalculation and layout of the items controlled by the sizer using the current space allocated to the sizer. Normally this is called automatically from the owning window's EVT_SIZE handler, but it is also useful to call it from user code when one of the items in a sizer change size, or items are added or removed.

Prepend(self,
          item,
          proportion=0,
          flag=0,
          border=0,
          userData=None)

Adds a new item to the begining of the list of sizer items managed by this sizer. See Add for a description of the parameters.

Parameters:
proportion
(type=int)

flag
(type=int)

border
(type=int)

userData
(type=PyObject)

Returns:
wx.SizerItem

PrependItem(self, item)

Prepends a wx.SizerItem to the sizer.

Parameters:
item
(type=SizerItem)

PrependSizer(self, *args, **kw)

Compatibility alias for Prepend.

PrependSpacer(self, *args, **kw)

Compatibility alias for Prepend.

PrependWindow(self, *args, **kw)

Compatibility alias for Prepend.

RecalcSizes(self)

Using the sizes calculated by CalcMin reposition and resize all the items managed by this sizer. You should not need to call this directly as it is called by Layout.

Remove(self, item)

Removes an item from the sizer and destroys it. This method does not cause any layout or resizing to take place, call Layout to update the layout on screen after removing a child from the sizer. The item parameter can be either a window, a sizer, or the zero-based index of an item to remove. Returns True if the child item was found and removed.

Returns:
bool

Note:

For historical reasons calling this method with a wx.Window parameter is depreacted, as it will not be able to destroy the window since it is owned by its parent. You should use Detach instead.

RemovePos(self, *args, **kw)

Compatibility alias for Remove.

RemoveSizer(self, *args, **kw)

Compatibility alias for Remove.

RemoveWindow(self, *args, **kw)

Compatibility alias for Remove.

SetDimension(self, x, y, width, height)

Call this to force the sizer to take the given dimension and thus force the items owned by the sizer to resize themselves according to the rules defined by the parameter in the Add, Insert or Prepend methods.

Parameters:
x
(type=int)

y
(type=int)

width
(type=int)

height
(type=int)

SetItemMinSize(self, item, size)

Sets the minimum size that will be allocated for an item in the sizer. The item parameter can be either a window, a sizer, or the zero-based index of the item. If a window or sizer is given then it will be searched for recursivly in subsizers if neccessary.

Parameters:
size
(type=Size)

SetMinSize(self, size)

Call this to give the sizer a minimal size. Normally, the sizer will calculate its minimal size based purely on how much space its children need. After calling this method GetMinSize will return either the minimal size as requested by its children or the minimal size set here, depending on which is bigger.

Parameters:
size
(type=Size)

SetSizeHints(self, window)

Tell the sizer to set (and Fit) the minimal size of the window to match the sizer's minimal size. This is commonly done in the constructor of the window itself if the window is resizable (as are many dialogs under Unix and frames on probably all platforms) in order to prevent the window from being sized smaller than the minimal size required by the sizer.

Parameters:
window
(type=Window)

SetVirtualSizeHints(self, window)

Tell the sizer to set the minimal size of the window virtual area to match the sizer's minimal size. For windows with managed scrollbars this will set them appropriately.

Parameters:
window
(type=Window)

See Also:

wx.ScrolledWindow.SetScrollbars

Show(self, item, show=True, recursive=false)

Shows or hides an item managed by the sizer. To make a sizer item disappear or reappear, use Show followed by Layout. The item parameter can be either a window, a sizer, or the zero-based index of the item. Use the recursive parameter to show or hide an item in a subsizer. Returns True if the item was found.

Parameters:
show
(type=bool)

recursive
(type=bool)

Returns:
bool

ShowItems(self, show)

Recursively call wx.SizerItem.Show on all sizer items.

Parameters:
show
(type=bool)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:23 2005 http://epydoc.sf.net


wx.SizerItem

Package wx :: Class SizerItem

Type SizerItem

object --+
         |
    Object --+
             |
            SizerItem

Known Subclasses:
GBSizerItem

The wx.SizerItem class is used to track the position, size and other attributes of each item managed by a wx.Sizer. In normal usage user code should never need to deal directly with a wx.SizerItem, but custom classes derived from wx.PySizer will probably need to use the collection of wx.SizerItems held by wx.Sizer when calculating layout.

See Also:

wx.Sizer, wx.GBSizerItem

Method Summary
SizerItem | __init__(self) Constructs an empty wx.SizerItem.
 | __repr__(self)
Size | CalcMin(self) Calculates the minimum desired size for the item, including any space needed by borders.
 | DeleteWindows(self) Destroy the window or the windows in a subsizer, depending on the type of item.
 | DetachSizer(self) Enable deleting the SizerItem without destroying the contained sizer.
int | GetBorder(self) Get the border value for this item.
int | GetFlag(self) Get the flag value for this item.
Size | GetMinSize(self) Get the minimum size needed for the item.
Size | GetMinSizeWithBorder(self) Get the minimum size needed for the item with space for the borders added, if needed.
 | GetOption(*args, **kwargs) Please use GetProportion instead.
Point | GetPosition(self) Returns the current position of the item, as set in the last Layout.
int | GetProportion(self) Get the proportion value for this item.
float | GetRatio(self) Set the ratio item attribute.
Rect | GetRect(self) Returns the rectangle that the sizer item should occupy
Size | GetSize(self) Get the current size of the item, as set in the last Layout.
Sizer | GetSizer(self) Get the subsizer (if any) that is managed by this sizer item.
Size | GetSpacer(self) Get the size of the spacer managed by this sizer item.
PyObject | GetUserData(self) Returns the userData associated with this sizer item, or None if there isn't any.
Window | GetWindow(self) Get the window (if any) that is managed by this sizer item.
bool | IsShown(self) Is the item to be shown in the layout?
bool | IsSizer(self) Is this sizer item a subsizer?
bool | IsSpacer(self) Is this sizer item a spacer?
bool | IsWindow(self) Is this sizer item a window?
 | SetBorder(self, border) Set the border value for this item.
 | SetDimension(self, pos, size) Set the position and size of the space allocated for this item by the sizer, and adjust the position and size of the item (window or subsizer) to be within that space taking alignment and borders into account.
 | SetFlag(self, flag) Set the flag value for this item.
 | SetInitSize(self, x, y)
 | SetOption(*args, **kwargs) Please use SetProportion instead.
 | SetProportion(self, proportion) Set the proportion value for this item.
 | SetRatio(self, ratio) Set the ratio item attribute.
 | SetRatioSize(self, size) Set the ratio item attribute.
 | SetRatioWH(self, width, height) Set the ratio item attribute.
 | SetSizer(self, sizer) Set the subsizer to be managed by this sizer item.
 | SetSpacer(self, size) Set the size of the spacer to be managed by this sizer item.
 | SetWindow(self, window) Set the window to be managed by this sizer item.
 | Show(self, show) Set the show item attribute, which sizers use to determine if the item is to be made part of the layout or not.

Method Details

__init__(self)
(Constructor)

Constructs an empty wx.SizerItem. Either a window, sizer or spacer size will need to be set before this item can be used in a Sizer.

You will probably never need to create a wx.SizerItem directly as they are created automatically when the sizer's Add, Insert or Prepend methods are called.

Returns:
SizerItem
Overrides:
wx.Object.__init__

See Also:

wx.SizerItemSpacer, wx.SizerItemWindow, wx.SizerItemSizer

CalcMin(self)

Calculates the minimum desired size for the item, including any space needed by borders.

Returns:
Size

DeleteWindows(self)

Destroy the window or the windows in a subsizer, depending on the type of item.

DetachSizer(self)

Enable deleting the SizerItem without destroying the contained sizer.

GetBorder(self)

Get the border value for this item.

Returns:
int

GetFlag(self)

Get the flag value for this item.

Returns:
int

GetMinSize(self)

Get the minimum size needed for the item.

Returns:
Size

GetMinSizeWithBorder(self)

Get the minimum size needed for the item with space for the borders added, if needed.

Returns:
Size

GetOption(*args, **kwargs)

Please use GetProportion instead.

GetPosition(self)

Returns the current position of the item, as set in the last Layout.

Returns:
Point

GetProportion(self)

Get the proportion value for this item.

Returns:
int

GetRatio(self)

Set the ratio item attribute.

Returns:
float

GetRect(self)

Returns the rectangle that the sizer item should occupy

Returns:
Rect

GetSize(self)

Get the current size of the item, as set in the last Layout.

Returns:
Size

GetSizer(self)

Get the subsizer (if any) that is managed by this sizer item.

Returns:
Sizer

GetSpacer(self)

Get the size of the spacer managed by this sizer item.

Returns:
Size

GetUserData(self)

Returns the userData associated with this sizer item, or None if there isn't any.

Returns:
PyObject

GetWindow(self)

Get the window (if any) that is managed by this sizer item.

Returns:
Window

IsShown(self)

Is the item to be shown in the layout?

Returns:
bool

IsSizer(self)

Is this sizer item a subsizer?

Returns:
bool

IsSpacer(self)

Is this sizer item a spacer?

Returns:
bool

IsWindow(self)

Is this sizer item a window?

Returns:
bool

SetBorder(self, border)

Set the border value for this item.

Parameters:
border
(type=int)

SetDimension(self, pos, size)

Set the position and size of the space allocated for this item by the sizer, and adjust the position and size of the item (window or subsizer) to be within that space taking alignment and borders into account.

Parameters:
pos
(type=Point)

size
(type=Size)

SetFlag(self, flag)

Set the flag value for this item.

Parameters:
flag
(type=int)

SetOption(*args, **kwargs)

Please use SetProportion instead.

SetProportion(self, proportion)

Set the proportion value for this item.

Parameters:
proportion
(type=int)

SetRatio(self, ratio)

Set the ratio item attribute.

Parameters:
ratio
(type=float)

SetRatioSize(self, size)

Set the ratio item attribute.

Parameters:
size
(type=Size)

SetRatioWH(self, width, height)

Set the ratio item attribute.

Parameters:
width
(type=int)

height
(type=int)

SetSizer(self, sizer)

Set the subsizer to be managed by this sizer item.

Parameters:
sizer
(type=Sizer)

SetSpacer(self, size)

Set the size of the spacer to be managed by this sizer item.

Parameters:
size
(type=Size)

SetWindow(self, window)

Set the window to be managed by this sizer item.

Parameters:
window
(type=Window)

Show(self, show)

Set the show item attribute, which sizers use to determine if the item is to be made part of the layout or not. If the item is tracking a window then it is shown or hidden as needed.

Parameters:
show
(type=bool)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:35 2005 http://epydoc.sf.net


wx.Slider

Package wx :: Class Slider

Type Slider

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
               Control --+
                         |
                        Slider

Proxy of C++ Slider class

Method Summary
Control | __init__(self, parent, id, pos, size, style, validator, name) Create a Control.
 | __repr__(self)
 | ClearSel(self)
 | ClearTicks(self)
bool | Create(self, parent, id, pos, size, style, validator, name) Do the 2nd phase and create the GUI control.
VisualAttributes | GetClassDefaultAttributes(variant) Get the default attributes for this class. (Static method)
int | GetLineSize(self)
int | GetMax(self)
int | GetMin(self)
int | GetPageSize(self)
int | GetSelEnd(self)
int | GetSelStart(self)
int | GetThumbLength(self)
int | GetTickFreq(self)
int | GetValue(self)
 | SetLineSize(self, lineSize)
 | SetMax(self, maxValue)
 | SetMin(self, minValue)
 | SetPageSize(self, pageSize)
 | SetRange(self, minValue, maxValue)
 | SetSelection(self, min, max)
 | SetThumbLength(self, lenPixels)
 | SetTick(self, tickPos)
 | SetTickFreq(self, n, pos)
 | SetValue(self, value)

Instance Method Details

__init__(self,
          parent,
          id=-1,
          value=0,
          minValue=0,
          maxValue=100,
          pos=DefaultPosition,
          size=DefaultSize,
          style=SL_HORIZONTAL,
          validator=DefaultValidator,
          name=SliderNameStr)
(Constructor)

Create a Control. Normally you should only call this from a subclass' __init__ as a plain old wx.Control is not very useful.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

validator
(type=Validator)

name
(type=String)

Returns:
Control
Overrides:
wx.Control.__init__ (inherited documentation)

Create(self,
          parent,
          id=-1,
          value=0,
          minValue=0,
          maxValue=100,
          pos=DefaultPosition,
          size=DefaultSize,
          style=SL_HORIZONTAL,
          validator=DefaultValidator,
          name=SliderNameStr)

Do the 2nd phase and create the GUI control.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

validator
(type=Validator)

name
(type=String)

Returns:
bool
Overrides:
wx.Control.Create (inherited documentation)

Static Method Details

GetClassDefaultAttributes(variant=WINDOW_VARIANT_NORMAL)

Get the default attributes for this class. This is useful if you want to use the same font or colour in your own control as in a standard control -- which is a much better idea than hard coding specific colours or fonts which might look completely out of place on the user's system, especially if it uses themes.

The variant parameter is only relevant under Mac currently and is ignore under other platforms. Under Mac, it will change the size of the returned font. See wx.Window.SetWindowVariant for more about this.

Parameters:
variant
(type=int)

Returns:
VisualAttributes

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:03 2005 http://epydoc.sf.net


wx.Sound

Package wx :: Class Sound

Type Sound

object --+
         |
        Sound

Proxy of C++ Sound class

Method Summary
Sound | __init__(self, fileName)
__del__(self)
__nonzero__(self)
__repr__(self)
bool | Create(self, fileName)
bool | CreateFromData(self, data)
bool | IsOk(self)
Play(*args, **kwargs)
Play(self, unsigned int flags=SOUND_ASYNC) -> bool
PlaySound(*args, **kwargs)
PlaySound(String filename, unsigned int flags=SOUND_ASYNC) -> bool (Static method)
Stop()
(Static method)

Instance Method Details

Play(*args, **kwargs)

Play(self, unsigned int flags=SOUND_ASYNC) -> bool

Static Method Details

PlaySound(*args, **kwargs)

PlaySound(String filename, unsigned int flags=SOUND_ASYNC) -> bool

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:16 2005 http://epydoc.sf.net


wx.SpinButton

Package wx :: Class SpinButton

Type SpinButton

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
               Control --+
                         |
                        SpinButton

Proxy of C++ SpinButton class

Method Summary
Control | __init__(self, parent, id, pos, size, style, validator, name) Create a Control.
 | __repr__(self)
bool | Create(self, parent, id, pos, size, style, validator, name) Do the 2nd phase and create the GUI control.
VisualAttributes | GetClassDefaultAttributes(variant) Get the default attributes for this class. (Static method)
int | GetMax(self)
int | GetMin(self)
int | GetValue(self)
bool | IsVertical(self)
 | SetMax(self, maxVal)
 | SetMin(self, minVal)
 | SetRange(self, minVal, maxVal)
 | SetValue(self, val)

Instance Method Details

__init__(self,
          parent,
          id=-1,
          pos=DefaultPosition,
          size=DefaultSize,
          style=SP_HORIZONTAL,
          name=SPIN_BUTTON_NAME)
(Constructor)

Create a Control. Normally you should only call this from a subclass' __init__ as a plain old wx.Control is not very useful.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

validator
(type=Validator)

name
(type=String)

Returns:
Control
Overrides:
wx.Control.__init__ (inherited documentation)

Create(self,
          parent,
          id=-1,
          pos=DefaultPosition,
          size=DefaultSize,
          style=SP_HORIZONTAL,
          name=SPIN_BUTTON_NAME)

Do the 2nd phase and create the GUI control.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

validator
(type=Validator)

name
(type=String)

Returns:
bool
Overrides:
wx.Control.Create (inherited documentation)

Static Method Details

GetClassDefaultAttributes(variant=WINDOW_VARIANT_NORMAL)

Get the default attributes for this class. This is useful if you want to use the same font or colour in your own control as in a standard control -- which is a much better idea than hard coding specific colours or fonts which might look completely out of place on the user's system, especially if it uses themes.

The variant parameter is only relevant under Mac currently and is ignore under other platforms. Under Mac, it will change the size of the returned font. See wx.Window.SetWindowVariant for more about this.

Parameters:
variant
(type=int)

Returns:
VisualAttributes

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:10:55 2005 http://epydoc.sf.net


wx.SpinCtrl

Package wx :: Class SpinCtrl

Type SpinCtrl

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
               Control --+
                         |
                        SpinCtrl

Proxy of C++ SpinCtrl class

Method Summary
Control | __init__(self, parent, id, pos, size, style, validator, name) Create a Control.
 | __repr__(self)
bool | Create(self, parent, id, pos, size, style, validator, name) Do the 2nd phase and create the GUI control.
VisualAttributes | GetClassDefaultAttributes(variant) Get the default attributes for this class. (Static method)
int | GetMax(self)
int | GetMin(self)
int | GetValue(self)
 | SetRange(self, minVal, maxVal)
 | SetSelection(self, from, to)
 | SetValue(self, value)
 | SetValueString(self, text)

Instance Method Details

__init__(self,
          parent,
          id=-1,
          value=EmptyString,
          pos=DefaultPosition,
          size=DefaultSize,
          style=SP_ARROW_KEYS,
          min=0,
          max=100,
          initial=0,
          name=SpinCtrlNameStr)
(Constructor)

Create a Control. Normally you should only call this from a subclass' __init__ as a plain old wx.Control is not very useful.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

validator
(type=Validator)

name
(type=String)

Returns:
Control
Overrides:
wx.Control.__init__ (inherited documentation)

Create(self,
          parent,
          id=-1,
          value=EmptyString,
          pos=DefaultPosition,
          size=DefaultSize,
          style=SP_ARROW_KEYS,
          min=0,
          max=100,
          initial=0,
          name=SpinCtrlNameStr)

Do the 2nd phase and create the GUI control.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

validator
(type=Validator)

name
(type=String)

Returns:
bool
Overrides:
wx.Control.Create (inherited documentation)

Static Method Details

GetClassDefaultAttributes(variant=WINDOW_VARIANT_NORMAL)

Get the default attributes for this class. This is useful if you want to use the same font or colour in your own control as in a standard control -- which is a much better idea than hard coding specific colours or fonts which might look completely out of place on the user's system, especially if it uses themes.

The variant parameter is only relevant under Mac currently and is ignore under other platforms. Under Mac, it will change the size of the returned font. See wx.Window.SetWindowVariant for more about this.

Parameters:
variant
(type=int)

Returns:
VisualAttributes

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:46 2005 http://epydoc.sf.net


wx.SpinEvent

Package wx :: Class SpinEvent

Type SpinEvent

object --+
         |
    Object --+
             |
         Event --+
                 |
      CommandEvent --+
                     |
           NotifyEvent --+
                         |
                        SpinEvent

Proxy of C++ SpinEvent class

Method Summary
NotifyEvent | __init__(self, commandType, winid) An instance of this class (or one of its derived classes) is sent from a control when the control's state is being changed and the control allows that change to be prevented from happening.
 | __repr__(self)
int | GetPosition(self)
 | SetPosition(self, pos)

Method Details

__init__(self, commandType=wxEVT_NULL, winid=0)
(Constructor)

An instance of this class (or one of its derived classes) is sent from a control when the control's state is being changed and the control allows that change to be prevented from happening. The event handler can call Veto or Allow to tell the control what to do.

Parameters:
commandType
(type=wxEventType)

winid
(type=int)

Returns:
NotifyEvent
Overrides:
wx.NotifyEvent.__init__ (inherited documentation)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:11 2005 http://epydoc.sf.net


wx.SplashScreen

Package wx :: Class SplashScreen

Type SplashScreen

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
        TopLevelWindow --+
                         |
                     Frame --+
                             |
                            SplashScreen

Proxy of C++ SplashScreen class

Method Summary
SplashScreen | __init__(self, bitmap, splashStyle, milliseconds, parent, id, pos, size, style)
 | __repr__(self)
long | GetSplashStyle(self)
SplashScreenWindow | GetSplashWindow(self)
int | GetTimeout(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:51 2005 http://epydoc.sf.net


wx.SplashScreenWindow

Package wx :: Class SplashScreenWindow

Type SplashScreenWindow

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
                    SplashScreenWindow

Proxy of C++ SplashScreenWindow class

Method Summary
Window | __init__(self, parent, id, pos, size, style, name) Construct and show a generic Window.
 | __repr__(self)
Bitmap | GetBitmap(self)
 | SetBitmap(self, bitmap)

Instance Method Details

__init__(self, bitmap, parent, id, pos=DefaultPosition, size=DefaultSize, style=NO_BORDER)
(Constructor)

Construct and show a generic Window.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

name
(type=String)

Returns:
Window
Overrides:
wx.Window.__init__ (inherited documentation)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:45 2005 http://epydoc.sf.net


wx.SplitterEvent

Package wx :: Class SplitterEvent

Type SplitterEvent

object --+
         |
    Object --+
             |
         Event --+
                 |
      CommandEvent --+
                     |
           NotifyEvent --+
                         |
                        SplitterEvent

This class represents the events generated by a splitter control.

Method Summary
SplitterEvent | __init__(self, type, splitter) This class represents the events generated by a splitter control.
 | __repr__(self)
int | GetSashPosition(self) Returns the new sash position while in EVT_SPLITTER_SASH_POS_CHANGING and EVT_SPLITTER_SASH_POS_CHANGED events.
Window | GetWindowBeingRemoved(self) Returns a pointer to the window being removed when a splitter window is unsplit.
int | GetX(self) Returns the x coordinate of the double-click point in a EVT_SPLITTER_DCLICK event.
int | GetY(self) Returns the y coordinate of the double-click point in a EVT_SPLITTER_DCLICK event.
 | SetSashPosition(self, pos) This function is only meaningful during EVT_SPLITTER_SASH_POS_CHANGING and EVT_SPLITTER_SASH_POS_CHANGED events.

Method Details

__init__(self, type=wxEVT_NULL, splitter=(wxSplitterWindow *) NULL)
(Constructor)

This class represents the events generated by a splitter control.

Parameters:
type
(type=wxEventType)

splitter
(type=SplitterWindow)

Returns:
SplitterEvent
Overrides:
wx.NotifyEvent.__init__

GetSashPosition(self)

Returns the new sash position while in EVT_SPLITTER_SASH_POS_CHANGING and EVT_SPLITTER_SASH_POS_CHANGED events.

Returns:
int

GetWindowBeingRemoved(self)

Returns a pointer to the window being removed when a splitter window is unsplit.

Returns:
Window

GetX(self)

Returns the x coordinate of the double-click point in a EVT_SPLITTER_DCLICK event.

Returns:
int

GetY(self)

Returns the y coordinate of the double-click point in a EVT_SPLITTER_DCLICK event.

Returns:
int

SetSashPosition(self, pos)

This function is only meaningful during EVT_SPLITTER_SASH_POS_CHANGING and EVT_SPLITTER_SASH_POS_CHANGED events. In the case of _CHANGED events, sets the the new sash position. In the case of _CHANGING events, sets the new tracking bar position so visual feedback during dragging will represent that change that will actually take place. Set to -1 from the event handler code to prevent repositioning.

Parameters:
pos
(type=int)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:06 2005 http://epydoc.sf.net


wx.SplitterWindow

Package wx :: Class SplitterWindow

Type SplitterWindow

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
                    SplitterWindow

Known Subclasses:
Crust, Filling, ThinSplitterWindow

wx.SplitterWindow manages up to two subwindows or panes, with an optional vertical or horizontal split which can be used with the mouse or programmatically.

Styles

wx.SP_3D | Draws a 3D effect border and sash.
wx.SP_3DSASH | Draws a 3D effect sash.
wx.SP_3DBORDER | Synonym for wxSP_BORDER.
wx.SP_BORDER | Draws a standard border.
wx.SP_NOBORDER | No border (default).
wx.SP_NO_XP_THEME | Under Windows XP, switches off the attempt to draw the splitter using Windows XP theming, so the borders and sash will take on the pre-XP look.
wx.SP_PERMIT_UNSPLIT | Always allow to unsplit, even with the minimum pane size other than zero.
wx.SP_LIVE_UPDATE | Don't draw XOR line but resize the child windows immediately.

Events

EVT_SPLITTER_SASH_POS_CHANGING | The sash position is in the process of being changed. May be used to modify the position of the tracking bar to properly reflect the position that would be set if the drag were to be completed at this point.
EVT_SPLITTER_SASH_POS_CHANGED | The sash position was changed. May be used to modify the sash position before it is set, or to prevent the change from taking place.
EVT_SPLITTER_UNSPLIT | The splitter has been just unsplit.
EVT_SPLITTER_DCLICK | The sash was double clicked. The default behaviour is to unsplit the window when this happens (unless the minimum pane size has been set to a value greater than zero.)
Method Summary
SplitterWindow | __init__(self, parent, id, pos, size, style, name) Constructor.
 | __repr__(self)
bool | Create(self, parent, id, pos, size, style, name) Create the GUI part of the SplitterWindow for the 2-phase create.
int | GetBorderSize(self) Gets the border size
VisualAttributes | GetClassDefaultAttributes(variant) Get the default attributes for this class. (Static method)
int | GetMinimumPaneSize(self) Gets the minimum pane size in pixels.
bool | GetNeedUpdating(self)
double | GetSashGravity(self) Gets the sash gravity.
int | GetSashPosition(self) Returns the surrent sash position.
int | GetSashSize(self) Gets the sash size
int | GetSplitMode(self) Gets the split mode
Window | GetWindow1(self) Gets the only or left/top pane.
Window | GetWindow2(self) Gets the right/bottom pane.
 | Initialize(self, window) Initializes the splitter window to have one pane.
bool | IsSplit(self) Is the window split?
bool | ReplaceWindow(self, winOld, winNew) This function replaces one of the windows managed by the SplitterWindow with another one.
bool | SashHitTest(self, x, y, tolerance) Tests for x, y over the sash
 | SetBorderSize(self, width) Sets the border size.
 | SetMinimumPaneSize(self, min) Sets the minimum pane size in pixels.
 | SetNeedUpdating(self, needUpdating)
 | SetSashGravity(self, gravity) Set the sash gravity.
 | SetSashPosition(self, position, redraw) Sets the sash position, in pixels.
 | SetSashSize(self, width) Sets the sash size.
 | SetSplitMode(self, mode) Sets the split mode.
 | SizeWindows(self) Resizes subwindows
bool | SplitHorizontally(self, window1, window2, sashPosition) Initializes the top and bottom panes of the splitter window.
bool | SplitVertically(self, window1, window2, sashPosition) Initializes the left and right panes of the splitter window.
bool | Unsplit(self, toRemove) Unsplits the window.
 | UpdateSize(self) Causes any pending sizing of the sash and child panes to take place immediately.

Instance Method Details

__init__(self,
          parent,
          id=-1,
          pos=DefaultPosition,
          size=DefaultSize,
          style=SP_3D,
          name=SplitterNameStr)
(Constructor)

Constructor. Creates and shows a SplitterWindow.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

name
(type=String)

Returns:
SplitterWindow
Overrides:
wx.Window.__init__

Create(self,
          parent,
          id=-1,
          pos=DefaultPosition,
          size=DefaultSize,
          style=SP_3D,
          name=SplitterNameStr)

Create the GUI part of the SplitterWindow for the 2-phase create.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

name
(type=String)

Returns:
bool
Overrides:
wx.Window.Create

GetBorderSize(self)

Gets the border size

Returns:
int

GetMinimumPaneSize(self)

Gets the minimum pane size in pixels.

Returns:
int

GetSashGravity(self)

Gets the sash gravity.

Returns:
double

See Also:

SetSashGravity

GetSashPosition(self)

Returns the surrent sash position.

Returns:
int

GetSashSize(self)

Gets the sash size

Returns:
int

GetSplitMode(self)

Gets the split mode

Returns:
int

GetWindow1(self)

Gets the only or left/top pane.

Returns:
Window

GetWindow2(self)

Gets the right/bottom pane.

Returns:
Window

Initialize(self, window)

Initializes the splitter window to have one pane. This should be called if you wish to initially view only a single pane in the splitter window. The child window is shown if it is currently hidden.

Parameters:
window
(type=Window)

IsSplit(self)

Is the window split?

Returns:
bool

ReplaceWindow(self, winOld, winNew)

This function replaces one of the windows managed by the SplitterWindow with another one. It is in general better to use it instead of calling Unsplit() and then resplitting the window back because it will provoke much less flicker. It is valid to call this function whether the splitter has two windows or only one.

Both parameters should be non-None and winOld must specify one of the windows managed by the splitter. If the parameters are incorrect or the window couldn't be replaced, False is returned. Otherwise the function will return True, but please notice that it will not Destroy the replaced window and you may wish to do it yourself.

Parameters:
winOld
(type=Window)

winNew
(type=Window)

Returns:
bool

SashHitTest(self, x, y, tolerance=5)

Tests for x, y over the sash

Parameters:
x
(type=int)

y
(type=int)

tolerance
(type=int)

Returns:
bool

SetBorderSize(self, width)

Sets the border size. Currently a NOP.

Parameters:
width
(type=int)

SetMinimumPaneSize(self, min)

Sets the minimum pane size in pixels.

The default minimum pane size is zero, which means that either pane can be reduced to zero by dragging the sash, thus removing one of the panes. To prevent this behaviour (and veto out-of-range sash dragging), set a minimum size, for example 20 pixels. If the wx.SP_PERMIT_UNSPLIT style is used when a splitter window is created, the window may be unsplit even if minimum size is non-zero.

Parameters:
min
(type=int)

SetSashGravity(self, gravity)

Set the sash gravity. Gravity is a floating-point factor between 0.0 and 1.0 which controls position of sash while resizing the wx.SplitterWindow. The gravity specifies how much the left/top window will grow while resizing.

Example values:

0.0 | Only the bottom or right window is automaticaly resized.
0.5 | Both windows grow equally.
1.0 | Only left/top window grows.

The default value of sash gravity is 0.0. That value is compatible with the previous (before gravity was introduced) behaviour of the wx.SplitterWindow.

Parameters:
gravity
(type=double)

SetSashPosition(self, position, redraw=True)

Sets the sash position, in pixels. If redraw is Ttrue then the panes are resized and the sash and border are redrawn.

Parameters:
position
(type=int)

redraw
(type=bool)

SetSashSize(self, width)

Sets the sash size.

Parameters:
width
(type=int)

SetSplitMode(self, mode)

Sets the split mode. The mode can be wx.SPLIT_VERTICAL or wx.SPLIT_HORIZONTAL. This only sets the internal variable; does not update the display.

Parameters:
mode
(type=int)

SizeWindows(self)

Resizes subwindows

SplitHorizontally(self, window1, window2, sashPosition=0)

Initializes the top and bottom panes of the splitter window. The child windows are shown if they are currently hidden.

Returns True if successful, False otherwise (the window was already split).

SplitHorizontally should be called if you wish to initially view two panes. It can also be called at any subsequent time, but the application should check that the window is not currently split using IsSplit.

Parameters:
window1 - The top pane.
(type=Window)

window2 - The bottom pane.
(type=Window)

sashPosition - The initial position of the sash. If this value is positive, it specifies the size of the upper pane. If it is negative, its absolute value gives the size of the lower pane. Finally, specify 0 (default) to choose the default position (half of the total window height).
(type=int)

Returns:
bool

SplitVertically(self, window1, window2, sashPosition=0)

Initializes the left and right panes of the splitter window. The child windows are shown if they are currently hidden.

Returns True if successful, False otherwise (the window was already split).

SplitVertically should be called if you wish to initially view two panes. It can also be called at any subsequent time, but the application should check that the window is not currently split using IsSplit.

Parameters:
window1 - The left pane.
(type=Window)

window2 - The right pane.
(type=Window)

sashPosition - The initial position of the sash. If this value is positive, it specifies the size of the left pane. If it is negative, its absolute value gives the size of the right pane. Finally, specify 0 (default) to choose the default position (half of the total window width).
(type=int)

Returns:
bool

Unsplit(self, toRemove=None)

Unsplits the window. Pass the pane to remove, or None to remove the right or bottom pane. Returns True if successful, False otherwise (the window was not split).

This function will not actually delete the pane being removed; it sends EVT_SPLITTER_UNSPLIT which can be handled for the desired behaviour. By default, the pane being removed is only hidden.

Parameters:
toRemove
(type=Window)

Returns:
bool

UpdateSize(self)

Causes any pending sizing of the sash and child panes to take place immediately.

Such resizing normally takes place in idle time, in order to wait for layout to be completed. However, this can cause unacceptable flicker as the panes are resized after the window has been shown. To work around this, you can perform window layout (for example by sending a size event to the parent window), and then call this function, before showing the top-level window.

Static Method Details

GetClassDefaultAttributes(variant=WINDOW_VARIANT_NORMAL)

Get the default attributes for this class. This is useful if you want to use the same font or colour in your own control as in a standard control -- which is a much better idea than hard coding specific colours or fonts which might look completely out of place on the user's system, especially if it uses themes.

The variant parameter is only relevant under Mac currently and is ignore under other platforms. Under Mac, it will change the size of the returned font. See wx.Window.SetWindowVariant for more about this.

Parameters:
variant
(type=int)

Returns:
VisualAttributes

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:18 2005 http://epydoc.sf.net


wx.StandardPaths

Package wx :: Class StandardPaths

Type StandardPaths

object --+
         |
        StandardPaths

wx.StandardPaths returns the standard locations in the file system and should be used by the programs to find their data files in a portable way.

In the description of the methods below, the example return values are given for the Unix, Windows and Mac OS X systems, however please note that these are just the examples and the actual values may differ. For example, under Windows: the system administrator may change the standard directories locations, i.e. the Windows directory may be named W:Win2003 instead of the default C:Windows.

The strings appname and username should be replaced with the value returned by wx.App.GetAppName and the name of the currently logged in user, respectively. The string prefix is only used under Unix and is /usr/local by default but may be changed using SetInstallPrefix.

The directories returned by the methods of this class may or may not exist. If they don't exist, it's up to the caller to create them, wxStandardPaths doesn't do it.

Finally note that these functions only work with standardly packaged applications. I.e. under Unix you should follow the standard installation conventions and under Mac you should create your application bundle according to the Apple guidelines. Again, this class doesn't help you to do it.

Method Summary
 | __init__(self)
 | __repr__(self)
StandardPaths | Get() Return the global standard paths singleton (Static method)
String | GetConfigDir(self) Return the directory with system config files: /etc under Unix, 'c:Documents and SettingsAll UsersApplication Data' under Windows, /Library/Preferences for Mac
String | GetDataDir(self) Return the location of the application's global, (i.e.
String | GetInstallPrefix(self) Get the program installation prefix.
String | GetLocalDataDir(self) Return the location for application data files which are host-specific.
String | GetPluginsDir(self) Return the directory where the loadable modules (plugins) live: prefix/lib/appname under Unix, program directory under Windows and Contents/Plugins app bundle subdirectory under Mac
String | GetUserConfigDir(self) Return the directory for the user config files: $HOME under Unix, 'c:Documents and Settingsusername' under Windows, and ~/Library/Preferences under Mac
String | GetUserDataDir(self) Return the directory for the user-dependent application data files: $HOME/.appname under Unix, c:Documents and SettingsusernameApplication Datappname under Windows and ~/Library/Application Support/appname under Mac
String | GetUserLocalDataDir(self) Return the directory for user data files which shouldn't be shared with the other machines
 | SetInstallPrefix(self, prefix) Set the program installation directory which is /usr/local by default.

Instance Method Details

GetConfigDir(self)

Return the directory with system config files: /etc under Unix, 'c:Documents and SettingsAll UsersApplication Data' under Windows, /Library/Preferences for Mac

Returns:
String

GetDataDir(self)

Return the location of the application's global, (i.e. not user-specific,) data files: prefix/share/appname under Unix, 'c:Program Filesppname' under Windows, appname.app/Contents/SharedSupport app bundle directory under Mac.

Returns:
String

GetInstallPrefix(self)

Get the program installation prefix. The default is the prefix where Python is installed. (This function only has meaning on Unix systems.)

Returns:
String

GetLocalDataDir(self)

Return the location for application data files which are host-specific. Same as GetDataDir except under Unix where it is /etc/appname

Returns:
String

GetPluginsDir(self)

Return the directory where the loadable modules (plugins) live: prefix/lib/appname under Unix, program directory under Windows and Contents/Plugins app bundle subdirectory under Mac

Returns:
String

GetUserConfigDir(self)

Return the directory for the user config files: $HOME under Unix, 'c:Documents and Settingsusername' under Windows, and ~/Library/Preferences under Mac

Only use this if you have a single file to put there, otherwise GetUserDataDir is more appropriate

Returns:
String

GetUserDataDir(self)

Return the directory for the user-dependent application data files: $HOME/.appname under Unix, c:Documents and SettingsusernameApplication Datappname under Windows and ~/Library/Application Support/appname under Mac

Returns:
String

GetUserLocalDataDir(self)

Return the directory for user data files which shouldn't be shared with the other machines

Same as GetUserDataDir for all platforms except Windows where it is the 'Local SettingsApplication Datappname' directory.

Returns:
String

SetInstallPrefix(self, prefix)

Set the program installation directory which is /usr/local by default. This value will be used by other methods such as GetDataDir and GetPluginsDir as the prefix for what they return. (This function only has meaning on Unix systems.)

Parameters:
prefix
(type=String)

Static Method Details

Get()

Return the global standard paths singleton

Returns:
StandardPaths

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:09 2005 http://epydoc.sf.net


wx.StaticBitmap

Package wx :: Class StaticBitmap

Type StaticBitmap

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
               Control --+
                         |
                        StaticBitmap

Known Subclasses:
StaticFancyText

Proxy of C++ StaticBitmap class

Method Summary
Control | __init__(self, parent, id, pos, size, style, validator, name) Create a Control.
 | __repr__(self)
bool | Create(self, parent, id, pos, size, style, validator, name) Do the 2nd phase and create the GUI control.
Bitmap | GetBitmap(self)
VisualAttributes | GetClassDefaultAttributes(variant) Get the default attributes for this class. (Static method)
 | SetBitmap(self, bitmap)
 | SetIcon(self, icon)

Instance Method Details

__init__(self,
          parent,
          id=-1,
          bitmap=wxNullBitmap,
          pos=DefaultPosition,
          size=DefaultSize,
          style=0,
          name=StaticBitmapNameStr)
(Constructor)

Create a Control. Normally you should only call this from a subclass' __init__ as a plain old wx.Control is not very useful.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

validator
(type=Validator)

name
(type=String)

Returns:
Control
Overrides:
wx.Control.__init__ (inherited documentation)

Create(self,
          parent,
          id=-1,
          bitmap=wxNullBitmap,
          pos=DefaultPosition,
          size=DefaultSize,
          style=0,
          name=StaticBitmapNameStr)

Do the 2nd phase and create the GUI control.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

validator
(type=Validator)

name
(type=String)

Returns:
bool
Overrides:
wx.Control.Create (inherited documentation)

Static Method Details

GetClassDefaultAttributes(variant=WINDOW_VARIANT_NORMAL)

Get the default attributes for this class. This is useful if you want to use the same font or colour in your own control as in a standard control -- which is a much better idea than hard coding specific colours or fonts which might look completely out of place on the user's system, especially if it uses themes.

The variant parameter is only relevant under Mac currently and is ignore under other platforms. Under Mac, it will change the size of the returned font. See wx.Window.SetWindowVariant for more about this.

Parameters:
variant
(type=int)

Returns:
VisualAttributes

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:22 2005 http://epydoc.sf.net


wx.StaticBox

Package wx :: Class StaticBox

Type StaticBox

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
               Control --+
                         |
                        StaticBox

Proxy of C++ StaticBox class

Method Summary
Control | __init__(self, parent, id, pos, size, style, validator, name) Create a Control.
 | __repr__(self)
bool | Create(self, parent, id, pos, size, style, validator, name) Do the 2nd phase and create the GUI control.
VisualAttributes | GetClassDefaultAttributes(variant) Get the default attributes for this class. (Static method)

Instance Method Details

__init__(self,
          parent,
          id=-1,
          label=EmptyString,
          pos=DefaultPosition,
          size=DefaultSize,
          style=0,
          name=StaticBoxNameStr)
(Constructor)

Create a Control. Normally you should only call this from a subclass' __init__ as a plain old wx.Control is not very useful.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

validator
(type=Validator)

name
(type=String)

Returns:
Control
Overrides:
wx.Control.__init__ (inherited documentation)

Create(self,
          parent,
          id=-1,
          label=EmptyString,
          pos=DefaultPosition,
          size=DefaultSize,
          style=0,
          name=StaticBoxNameStr)

Do the 2nd phase and create the GUI control.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

validator
(type=Validator)

name
(type=String)

Returns:
bool
Overrides:
wx.Control.Create (inherited documentation)

Static Method Details

GetClassDefaultAttributes(variant=WINDOW_VARIANT_NORMAL)

Get the default attributes for this class. This is useful if you want to use the same font or colour in your own control as in a standard control -- which is a much better idea than hard coding specific colours or fonts which might look completely out of place on the user's system, especially if it uses themes.

The variant parameter is only relevant under Mac currently and is ignore under other platforms. Under Mac, it will change the size of the returned font. See wx.Window.SetWindowVariant for more about this.

Parameters:
variant
(type=int)

Returns:
VisualAttributes

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:17 2005 http://epydoc.sf.net


wx.StaticBoxSizer

Package wx :: Class StaticBoxSizer

Type StaticBoxSizer

object --+
         |
    Object --+
             |
         Sizer --+
                 |
          BoxSizer --+
                     |
                    StaticBoxSizer

wx.StaticBoxSizer derives from and functions identically to the wx.BoxSizer and adds a wx.StaticBox around the items that the sizer manages. Note that this static box must be created separately and passed to the sizer constructor.

Method Summary
StaticBoxSizer | __init__(self, box, orient) Constructor.
 | __repr__(self)
StaticBox | GetStaticBox(self) Returns the static box associated with this sizer.

Method Details

__init__(self, box, orient=HORIZONTAL)
(Constructor)

Constructor. It takes an associated static box and the orientation orient as parameters - orient can be either of wx.VERTICAL or wx.HORIZONTAL.

Parameters:
box
(type=StaticBox)

orient
(type=int)

Returns:
StaticBoxSizer
Overrides:
wx.BoxSizer.__init__

GetStaticBox(self)

Returns the static box associated with this sizer.

Returns:
StaticBox

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:11 2005 http://epydoc.sf.net


wx.StaticLine

Package wx :: Class StaticLine

Type StaticLine

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
               Control --+
                         |
                        StaticLine

Proxy of C++ StaticLine class

Method Summary
Control | __init__(self, parent, id, pos, size, style, validator, name) Create a Control.
 | __repr__(self)
bool | Create(self, parent, id, pos, size, style, validator, name) Do the 2nd phase and create the GUI control.
VisualAttributes | GetClassDefaultAttributes(variant) Get the default attributes for this class. (Static method)
int | GetDefaultSize() (Static method)
bool | IsVertical(self)

Instance Method Details

__init__(self,
          parent,
          id=-1,
          pos=DefaultPosition,
          size=DefaultSize,
          style=LI_HORIZONTAL,
          name=StaticTextNameStr)
(Constructor)

Create a Control. Normally you should only call this from a subclass' __init__ as a plain old wx.Control is not very useful.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

validator
(type=Validator)

name
(type=String)

Returns:
Control
Overrides:
wx.Control.__init__ (inherited documentation)

Create(self,
          parent,
          id=-1,
          pos=DefaultPosition,
          size=DefaultSize,
          style=LI_HORIZONTAL,
          name=StaticTextNameStr)

Do the 2nd phase and create the GUI control.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

validator
(type=Validator)

name
(type=String)

Returns:
bool
Overrides:
wx.Control.Create (inherited documentation)

Static Method Details

GetClassDefaultAttributes(variant=WINDOW_VARIANT_NORMAL)

Get the default attributes for this class. This is useful if you want to use the same font or colour in your own control as in a standard control -- which is a much better idea than hard coding specific colours or fonts which might look completely out of place on the user's system, especially if it uses themes.

The variant parameter is only relevant under Mac currently and is ignore under other platforms. Under Mac, it will change the size of the returned font. See wx.Window.SetWindowVariant for more about this.

Parameters:
variant
(type=int)

Returns:
VisualAttributes

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:05 2005 http://epydoc.sf.net


wx.StaticText

Package wx :: Class StaticText

Type StaticText

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
               Control --+
                         |
                        StaticText

Proxy of C++ StaticText class

Method Summary
Control | __init__(self, parent, id, pos, size, style, validator, name) Create a Control.
 | __repr__(self)
bool | Create(self, parent, id, pos, size, style, validator, name) Do the 2nd phase and create the GUI control.
VisualAttributes | GetClassDefaultAttributes(variant) Get the default attributes for this class. (Static method)

Instance Method Details

__init__(self,
          parent,
          id=-1,
          label=EmptyString,
          pos=DefaultPosition,
          size=DefaultSize,
          style=0,
          name=StaticTextNameStr)
(Constructor)

Create a Control. Normally you should only call this from a subclass' __init__ as a plain old wx.Control is not very useful.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

validator
(type=Validator)

name
(type=String)

Returns:
Control
Overrides:
wx.Control.__init__ (inherited documentation)

Create(self,
          parent,
          id=-1,
          label=EmptyString,
          pos=DefaultPosition,
          size=DefaultSize,
          style=0,
          name=StaticTextNameStr)

Do the 2nd phase and create the GUI control.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

validator
(type=Validator)

name
(type=String)

Returns:
bool
Overrides:
wx.Control.Create (inherited documentation)

Static Method Details

GetClassDefaultAttributes(variant=WINDOW_VARIANT_NORMAL)

Get the default attributes for this class. This is useful if you want to use the same font or colour in your own control as in a standard control -- which is a much better idea than hard coding specific colours or fonts which might look completely out of place on the user's system, especially if it uses themes.

The variant parameter is only relevant under Mac currently and is ignore under other platforms. Under Mac, it will change the size of the returned font. See wx.Window.SetWindowVariant for more about this.

Parameters:
variant
(type=int)

Returns:
VisualAttributes

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:21 2005 http://epydoc.sf.net


wx.StatusBar

Package wx :: Class StatusBar

Type StatusBar

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
                    StatusBar

Proxy of C++ StatusBar class

Method Summary
Window | __init__(self, parent, id, pos, size, style, name) Construct and show a generic Window.
 | __repr__(self)
bool | Create(self, parent, id, pos, size, style, name) Create the GUI part of the Window for 2-phase creation mode.
int | GetBorderX(self)
int | GetBorderY(self)
VisualAttributes | GetClassDefaultAttributes(variant) Get the default attributes for this class. (Static method)
Rect | GetFieldRect(self, i)
int | GetFieldsCount(self)
String | GetStatusText(self, number)
 | PopStatusText(self, number)
 | PushStatusText(self, text, number)
 | SetFieldsCount(self, number)
 | SetMinHeight(self, height)
 | SetStatusStyles(self, styles)
 | SetStatusText(self, text, number)
 | SetStatusWidths(self, widths)

Instance Method Details

__init__(self, parent, id=-1, style=DEFAULT_STATUSBAR_STYLE, name=StatusLineNameStr)
(Constructor)

Construct and show a generic Window.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

name
(type=String)

Returns:
Window
Overrides:
wx.Window.__init__ (inherited documentation)

Create(self,
          parent,
          id=-1,
          style=ST_SIZEGRIP,
          name=StatusLineNameStr)

Create the GUI part of the Window for 2-phase creation mode.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

name
(type=String)

Returns:
bool
Overrides:
wx.Window.Create (inherited documentation)

Static Method Details

GetClassDefaultAttributes(variant=WINDOW_VARIANT_NORMAL)

Get the default attributes for this class. This is useful if you want to use the same font or colour in your own control as in a standard control -- which is a much better idea than hard coding specific colours or fonts which might look completely out of place on the user's system, especially if it uses themes.

The variant parameter is only relevant under Mac currently and is ignore under other platforms. Under Mac, it will change the size of the returned font. See wx.Window.SetWindowVariant for more about this.

Parameters:
variant
(type=int)

Returns:
VisualAttributes

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:18 2005 http://epydoc.sf.net


wx.stc.StyledTextCtrl

Package wx :: Module stc :: Class StyledTextCtrl

Type StyledTextCtrl

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
               Control --+
                         |
                        StyledTextCtrl

Known Subclasses:
EditWindow, PyShellWindow

Proxy of C++ StyledTextCtrl class

Method Summary
Control | __init__(self, parent, id, pos, size, style, validator, name) Create a Control.
 | __repr__(self)
 | AddRefDocument(self, docPointer) Extend life of document.
 | AddStyledText(self, data) Add array of cells to document.
 | AddText(self, text) Add text to the document at current position.
 | AddTextRaw(self, text) Add text to the document at current position.
 | AddTextUTF8(self, text) Add UTF8 encoded text to the document at the current position.
 | Allocate(self, bytes) Enlarge the document to a particular size of text bytes.
 | AppendText(self, text) Append a string to the end of the document without changing the selection.
 | AppendTextRaw(self, text) Append a string to the end of the document without changing the selection.
 | AppendTextUTF8(self, text) Append a UTF8 string to the end of the document without changing the selection.
bool | AutoCompActive(self) Is there an auto-completion list visible?
 | AutoCompCancel(self) Remove the auto-completion list from the screen.
 | AutoCompComplete(self) User has selected an item so remove the list and insert the selection.
bool | AutoCompGetAutoHide(self) Retrieve whether or not autocompletion is hidden automatically when nothing matches.
bool | AutoCompGetCancelAtStart(self) Retrieve whether auto-completion cancelled by backspacing before start.
bool | AutoCompGetChooseSingle(self) Retrieve whether a single item auto-completion list automatically choose the item.
int | AutoCompGetCurrent(self) Get currently selected item position in the auto-completion list
bool | AutoCompGetDropRestOfWord(self) Retrieve whether or not autocompletion deletes any word characters after the inserted text upon completion.
bool | AutoCompGetIgnoreCase(self) Retrieve state of ignore case flag.
int | AutoCompGetSeparator(self) Retrieve the auto-completion list separator character.
int | AutoCompGetTypeSeparator(self) Retrieve the auto-completion list type-separator character.
int | AutoCompPosStart(self) Retrieve the position of the caret when the auto-completion list was displayed.
 | AutoCompSelect(self, text) Select the item in the auto-completion list that starts with a string.
 | AutoCompSetAutoHide(self, autoHide) Set whether or not autocompletion is hidden automatically when nothing matches.
 | AutoCompSetCancelAtStart(self, cancel) Should the auto-completion list be cancelled if the user backspaces to a position before where the box was created.
 | AutoCompSetChooseSingle(self, chooseSingle) Should a single item auto-completion list automatically choose the item.
 | AutoCompSetDropRestOfWord(self, dropRestOfWord) Set whether or not autocompletion deletes any word characters after the inserted text upon completion.
 | AutoCompSetFillUps(self, characterSet) Define a set of characters that when typed will cause the autocompletion to choose the selected item.
 | AutoCompSetIgnoreCase(self, ignoreCase) Set whether case is significant when performing auto-completion searches.
 | AutoCompSetSeparator(self, separatorCharacter) Change the separator character in the string setting up an auto-completion list.
 | AutoCompSetTypeSeparator(self, separatorCharacter) Change the type-separator character in the string setting up an auto-completion list.
 | AutoCompShow(self, lenEntered, itemList) Display a auto-completion list.
 | AutoCompStops(self, characterSet) Define a set of character that when typed cancel the auto-completion list.
 | BackTab(self) Dedent the selected lines.
 | BeginUndoAction(self) Start a sequence of actions that is undone and redone as a unit.
 | BraceBadLight(self, pos) Highlight the character at a position indicating there is no matching brace.
 | BraceHighlight(self, pos1, pos2) Highlight the characters at two positions.
int | BraceMatch(self, pos) Find the position of a matching brace or INVALID_POSITION if no match.
bool | CallTipActive(self) Is there an active call tip?
 | CallTipCancel(self) Remove the call tip from the screen.
int | CallTipPosAtStart(self) Retrieve the position where the caret was before displaying the call tip.
 | CallTipSetBackground(self, back) Set the background colour for the call tip.
 | CallTipSetForeground(self, fore) Set the foreground colour for the call tip.
 | CallTipSetForegroundHighlight(self, fore) Set the foreground colour for the highlighted part of the call tip.
 | CallTipSetHighlight(self, start, end) Highlight a segment of the definition.
 | CallTipShow(self, pos, definition) Show a call tip containing a definition near position pos.
 | Cancel(self) Cancel any modes such as call tip or auto-completion list display.
bool | CanPaste(self) Will a paste succeed?
bool | CanRedo(self) Are there any redoable actions in the undo history?
bool | CanUndo(self) Are there any undoable actions in the undo history?
 | CharLeft(self) Move caret left one character.
 | CharLeftExtend(self) Move caret left one character extending selection to new caret position.
 | CharLeftRectExtend(self) Move caret left one character, extending rectangular selection to new caret position.
 | CharRight(self) Move caret right one character.
 | CharRightExtend(self) Move caret right one character extending selection to new caret position.
 | CharRightRectExtend(self) Move caret right one character, extending rectangular selection to new caret position.
 | ChooseCaretX(self) Set the last x chosen value to be the caret x position.
 | Clear(self) Clear the selection.
 | ClearAll(self) Delete all text in the document.
 | ClearDocumentStyle(self) Set all style bytes to 0, remove all folding information.
 | ClearRegisteredImages(self) Clear all the registered images.
 | CmdKeyAssign(self, key, modifiers, cmd) When key+modifier combination km is pressed perform msg.
 | CmdKeyClear(self, key, modifiers) When key+modifier combination km is pressed do nothing.
 | CmdKeyClearAll(self) Drop all key mappings.
 | CmdKeyExecute(self, cmd) Perform one of the operations defined by the wx.stc.STC_CMD_* constants.
 | Colourise(self, start, end) Colourise a segment of the document using the current lexing language.
 | ConvertEOLs(self, eolMode) Convert all line endings in the document to one mode.
 | Copy(self) Copy the selection to the clipboard.
 | CopyRange(self, start, end) Copy a range of text to the clipboard.
 | CopyText(self, length, text) Copy argument text to the clipboard.
bool | Create(self, parent, id, pos, size, style, validator, name) Do the 2nd phase and create the GUI control.
void | CreateDocument(self) Create a new document object.
 | Cut(self) Cut the selection to the clipboard.
 | DeleteBack(self) Delete the selection or if no selection, the character before the caret.
 | DeleteBackNotLine(self) Delete the selection or if no selection, the character before the caret.
 | DelLineLeft(self) Delete back from the current position to the start of the line.
 | DelLineRight(self) Delete forwards from the current position to the end of the line.
 | DelWordLeft(self) Delete the word to the left of the caret.
 | DelWordRight(self) Delete the word to the right of the caret.
int | DocLineFromVisible(self, lineDisplay) Find the document line of a display line taking hidden lines into account.
 | DocumentEnd(self) Move caret to last position in document.
 | DocumentEndExtend(self) Move caret to last position in document extending selection to new caret position.
 | DocumentStart(self) Move caret to first position in document.
 | DocumentStartExtend(self) Move caret to first position in document extending selection to new caret position.
int | DoDragOver(self, x, y, def) Allow for simulating a DnD DragOver.
bool | DoDropText(self, x, y, data) Allow for simulating a DnD DropText.
 | EditToggleOvertype(self) Switch from insert to overtype mode or the reverse.
 | EmptyUndoBuffer(self) Delete the undo history.
 | EndUndoAction(self) End a sequence of actions that is undone and redone as a unit.
 | EnsureCaretVisible(self) Ensure the caret is visible.
 | EnsureVisible(self, line) Ensure a particular line is visible by expanding any header line hiding it.
 | EnsureVisibleEnforcePolicy(self, line) Ensure a particular line is visible by expanding any header line hiding it.
int | FindColumn(self, line, column) Find the position of a column on a line taking into account tabs and multi-byte characters.
int | FindText(self, minPos, maxPos, text, flags) Find some text in the document.
int | FormatRange(self, doDraw, startPos, endPos, draw, target, renderRect, pageRect) On Windows, will draw the document into a display context such as a printer.
 | FormFeed(self) Insert a Form Feed character.
int | GetAnchor(self) Returns the position of the opposite end of the selection to the caret.
bool | GetBackSpaceUnIndents(self) Does a backspace pressed when caret is within indentation unindent?
bool | GetBufferedDraw(self) Is drawing done first into a buffer or direct to the screen?
Colour | GetCaretForeground(self) Get the foreground colour of the caret.
Colour | GetCaretLineBack(self) Get the colour of the background of the line containing the caret.
bool | GetCaretLineVisible(self) Is the background of the line containing the caret in a different colour?
int | GetCaretPeriod(self) Get the time in milliseconds that the caret is on and off.
int | GetCaretWidth(self) Returns the width of the insert mode caret.
int | GetCharAt(self, pos) Returns the character byte at the position.
int | GetCodePage(self) Get the code page used to interpret the bytes of the document as characters.
int | GetColumn(self, pos) Retrieve the column number of a position, taking tab width into account.
int | GetControlCharSymbol(self) Get the way control characters are displayed.
(text, pos) | GetCurLine(self) Retrieve the text of the line containing the caret, and also theindex of the caret on the line.
(text, index) | GetCurLineRaw() Retrieve the text of the line containing the caret, and also the index of the caret on the line.
 | GetCurLineUTF8(self) Retrieve the UTF8 text of the line containing the caret, and also the index of the caret on the line.
int | GetCurrentLine(self) Returns the line number of the line with the caret.
int | GetCurrentPos(self) Returns the position of the caret.
void | GetDocPointer(self) Retrieve a pointer to the document object.
Colour | GetEdgeColour(self) Retrieve the colour used in edge indication.
int | GetEdgeColumn(self) Retrieve the column number which text should be kept within.
int | GetEdgeMode(self) Retrieve the edge highlight mode.
int | GetEndAtLastLine(self) Retrieve whether the maximum scroll position has the last line at the bottom of the view.
int | GetEndStyled(self) Retrieve the position of the last correctly styled character.
int | GetEOLMode(self) Retrieve the current end of line mode - one of CRLF, CR, or LF.
int | GetFirstVisibleLine(self) Retrieve the display line at the top of the display.
bool | GetFoldExpanded(self, line) Is a header line expanded?
int | GetFoldLevel(self, line) Retrieve the fold level of a line.
int | GetFoldParent(self, line) Find the parent line of a child line.
int | GetHighlightGuide(self) Get the highlighted indentation guide column.
int | GetIndent(self) Retrieve indentation size.
bool | GetIndentationGuides(self) Are the indentation guides visible?
int | GetLastChild(self, line, level) Find the last child line of a header line.
bool | GetLastKeydownProcessed(self)
int | GetLayoutCache(self) Retrieve the degree of caching of layout information.
int | GetLength(self) Returns the number of characters in the document.
int | GetLexer(self) Retrieve the lexing language of the document.
String | GetLine(self, line) Retrieve the contents of a line.
int | GetLineCount(self) Returns the number of lines in the document.
int | GetLineEndPosition(self, line) Get the position after the last visible characters on a line.
int | GetLineIndentation(self, line) Retrieve the number of columns that a line is indented.
int | GetLineIndentPosition(self, line) Retrieve the position before the first non indentation character on a line.
wxCharBuffer | GetLineRaw(self, line) Retrieve the contents of a line.
int | GetLineSelEndPosition(self, line) Retrieve the position of the end of the selection at the given line (INVALID_POSITION if no selection on this line).
int | GetLineSelStartPosition(self, line) Retrieve the position of the start of the selection at the given line (INVALID_POSITION if no selection on this line).
int | GetLineState(self, line) Retrieve the extra styling information for a line.
 | GetLineUTF8(self, line) Retrieve the contents of a line as UTF8.
bool | GetLineVisible(self, line) Is a line visible?
int | GetMarginLeft(self) Returns the size in pixels of the left margin.
int | GetMarginMask(self, margin) Retrieve the marker mask of a margin.
int | GetMarginRight(self) Returns the size in pixels of the right margin.
bool | GetMarginSensitive(self, margin) Retrieve the mouse click sensitivity of a margin.
int | GetMarginType(self, margin) Retrieve the type of a margin.
int | GetMarginWidth(self, margin) Retrieve the width of a margin in pixels.
int | GetMaxLineState(self) Retrieve the last line number that has line state.
int | GetModEventMask(self) Get which document modification events are sent to the container.
bool | GetModify(self) Is the document different from when it was last saved?
bool | GetMouseDownCaptures(self) Get whether mouse gets captured.
int | GetMouseDwellTime(self) Retrieve the time the mouse must sit still to generate a mouse dwell event.
bool | GetOvertype(self) Returns true if overtype mode is active otherwise false is returned.
int | GetPrintColourMode(self) Returns the print colour mode.
int | GetPrintMagnification(self) Returns the print magnification.
int | GetPrintWrapMode(self) Is printing line wrapped?
bool | GetReadOnly(self) In read-only mode?
int | GetScrollWidth(self) Retrieve the document width assumed for scrolling.
int | GetSearchFlags(self) Get the search flags used by SearchInTarget.
String | GetSelectedText(self) Retrieve the selected text.
wxCharBuffer | GetSelectedTextRaw(self) Retrieve the selected text.
 | GetSelectedTextUTF8(self) Retrieve the selected text as UTF8.
(startPos, endPos) | GetSelection(self) Retrieve the start and end positions of the current selection.
int | GetSelectionEnd(self) Returns the position at the end of the selection.
int | GetSelectionMode(self) Get the mode of the current selection.
int | GetSelectionStart(self) Returns the position at the start of the selection.
int | GetStatus(self) Get error status.
int | GetSTCCursor(self) Get cursor type.
bool | GetSTCFocus(self) Get internal focus flag.
int | GetStyleAt(self, pos) Returns the style byte at the position.
int | GetStyleBits(self) Retrieve number of bits in style bytes used to hold the lexical state.
wxMemoryBuffer | GetStyledText(self, startPos, endPos) Retrieve a buffer of cells.
bool | GetTabIndents(self) Does a tab pressed when caret is within indentation indent?
int | GetTabWidth(self) Retrieve the visible size of a tab.
int | GetTargetEnd(self) Get the position that ends the target.
int | GetTargetStart(self) Get the position that starts the target.
String | GetText(self) Retrieve all the text in the document.
int | GetTextLength(self) Retrieve the number of characters in the document.
String | GetTextRange(self, startPos, endPos) Retrieve a range of text.
wxCharBuffer | GetTextRangeRaw(self, startPos, endPos) Retrieve a range of text.
 | GetTextRangeUTF8(self, startPos, endPos) Retrieve a range of text as UTF8.
wxCharBuffer | GetTextRaw(self) Retrieve all the text in the document.
 | GetTextUTF8(self) Retrieve all the text in the document as UTF8.
bool | GetTwoPhaseDraw(self) Is drawing done in two phases with backgrounds drawn before foregrounds?
bool | GetUndoCollection(self) Is undo history being collected?
bool | GetUseAntiAliasing(self) Returns the current UseAntiAliasing setting.
bool | GetUseHorizontalScrollBar(self) Is the horizontal scroll bar visible?
bool | GetUseTabs(self) Retrieve whether tabs will be used in indentation.
bool | GetUseVerticalScrollBar(self) Is the vertical scroll bar visible?
bool | GetViewEOL(self) Are the end of line characters visible?
int | GetViewWhiteSpace(self) Are white space characters currently visible? Returns one of SCWS_* constants.
int | GetWrapMode(self) Retrieve whether text is word wrapped.
int | GetWrapStartIndent(self) Retrive the start indent for wrapped lines.
int | GetWrapVisualFlags(self) Retrive the display mode of visual flags for wrapped lines.
int | GetWrapVisualFlagsLocation(self) Retrive the location of visual flags for wrapped lines.
int | GetXOffset(self)
int | GetZoom(self) Retrieve the zoom level.
 | GotoLine(self, line) Set caret to start of a line and ensure it is visible.
 | GotoPos(self, pos) Set caret to a position and ensure it is visible.
 | HideLines(self, lineStart, lineEnd) Make a range of lines invisible.
 | HideSelection(self, normal) Draw the selection in normal style or with selection highlighted.
 | Home(self) Move caret to first position on line.
 | HomeDisplay(self) Move caret to first position on display line.
 | HomeDisplayExtend(self) Move caret to first position on display line extending selection to new caret position.
 | HomeExtend(self) Move caret to first position on line extending selection to new caret position.
 | HomeRectExtend(self) Move caret to first position on line, extending rectangular selection to new caret position.
 | HomeWrap(self) These are like their namesakes Home(Extend)?, LineEnd(Extend)?, VCHome(Extend)? except they behave differently when word-wrap is enabled: They go first to the start / end of the display line, like (Home|LineEnd)Display The difference is that, the cursor is already at the point, it goes on to the start or end of the document line, as appropriate for (Home|LineEnd|VCHome)(Extend)?.
 | HomeWrapExtend(self)
Colour | IndicatorGetForeground(self, indic) Retrieve the foreground colour of an indicator.
int | IndicatorGetStyle(self, indic) Retrieve the style of an indicator.
 | IndicatorSetForeground(self, indic, fore) Set the foreground colour of an indicator.
 | IndicatorSetStyle(self, indic, style) Set an indicator to plain, squiggle or TT.
 | InsertText(self, pos, text) Insert string at a position.
 | InsertTextRaw(self, pos, text) Insert string at a position.
 | InsertTextUTF8(self, pos, text) Insert UTF8 encoded text at a position.
 | LineCopy(self) Copy the line containing the caret.
 | LineCut(self) Cut the line containing the caret.
 | LineDelete(self) Delete the line containing the caret.
 | LineDown(self) Move caret down one line.
 | LineDownExtend(self) Move caret down one line extending selection to new caret position.
 | LineDownRectExtend(self) Move caret down one line, extending rectangular selection to new caret position.
 | LineDuplicate(self) Duplicate the current line.
 | LineEnd(self) Move caret to last position on line.
 | LineEndDisplay(self) Move caret to last position on display line.
 | LineEndDisplayExtend(self) Move caret to last position on display line extending selection to new caret position.
 | LineEndExtend(self) Move caret to last position on line extending selection to new caret position.
 | LineEndRectExtend(self) Move caret to last position on line, extending rectangular selection to new caret position.
 | LineEndWrap(self)
 | LineEndWrapExtend(self)
int | LineFromPosition(self, pos) Retrieve the line containing a position.
int | LineLength(self, line) How many characters are on a line, not including end of line characters?
 | LineScroll(self, columns, lines) Scroll horizontally and vertically.
 | LineScrollDown(self) Scroll the document down, keeping the caret visible.
 | LineScrollUp(self) Scroll the document up, keeping the caret visible.
 | LinesJoin(self) Join the lines in the target.
int | LinesOnScreen(self) Retrieves the number of lines completely visible.
 | LinesSplit(self, pixelWidth) Split the lines in the target into lines that are less wide than pixelWidth where possible.
 | LineTranspose(self) Switch the current line with the previous.
 | LineUp(self) Move caret up one line.
 | LineUpExtend(self) Move caret up one line extending selection to new caret position.
 | LineUpRectExtend(self) Move caret up one line, extending rectangular selection to new caret position.
bool | LoadFile(self, filename) Load the contents of filename into the editor
 | LowerCase(self) Transform the selection to lower case.
int | MarkerAdd(self, line, markerNumber) Add a marker to a line, returning an ID which can be used to find or delete the marker.
 | MarkerDefine(self, markerNumber, markerSymbol, foreground, background) Set the symbol used for a particular marker number, and optionally the fore and background colours.
 | MarkerDefineBitmap(self, markerNumber, bmp) Define a marker from a bitmap
 | MarkerDelete(self, line, markerNumber) Delete a marker from a line.
 | MarkerDeleteAll(self, markerNumber) Delete all markers with a particular number from all lines.
 | MarkerDeleteHandle(self, handle) Delete a marker.
int | MarkerGet(self, line) Get a bit mask of all the markers set on a line.
int | MarkerLineFromHandle(self, handle) Retrieve the line number at which a particular marker is located.
int | MarkerNext(self, lineStart, markerMask) Find the next line after lineStart that includes a marker in mask.
int | MarkerPrevious(self, lineStart, markerMask) Find the previous line before lineStart that includes a marker in mask.
 | MarkerSetBackground(self, markerNumber, back) Set the background colour used for a particular marker number.
 | MarkerSetForeground(self, markerNumber, fore) Set the foreground colour used for a particular marker number.
 | MoveCaretInsideView(self) Move the caret inside current view if it's not there already.
 | NewLine(self) Insert a new line, may use a CRLF, CR or LF depending on EOL mode.
 | PageDown(self) Move caret one page down.
 | PageDownExtend(self) Move caret one page down extending selection to new caret position.
 | PageDownRectExtend(self) Move caret one page down, extending rectangular selection to new caret position.
 | PageUp(self) Move caret one page up.
 | PageUpExtend(self) Move caret one page up extending selection to new caret position.
 | PageUpRectExtend(self) Move caret one page up, extending rectangular selection to new caret position.
 | ParaDown(self) Move caret between paragraphs (delimited by empty lines).
 | ParaDownExtend(self)
 | ParaUp(self)
 | ParaUpExtend(self)
 | Paste(self) Paste the contents of the clipboard into the document replacing the selection.
Point | PointFromPosition(self, pos) Retrieve the point in the window where a position is displayed.
int | PositionAfter(self, pos) Given a valid document position, return the next position taking code page into account.
int | PositionBefore(self, pos) Given a valid document position, return the previous position taking code page into account.
int | PositionFromLine(self, line) Retrieve the position at the start of a line.
int | PositionFromPoint(self, pt) Find the position from a point within the window.
int | PositionFromPointClose(self, x, y) Find the position from a point within the window but return INVALID_POSITION if not close to text.
 | Redo(self) Redoes the next action on the undo history.
 | RegisterImage(self, type, bmp) Register an image for use in autocompletion lists.
 | ReleaseDocument(self, docPointer) Release a reference to the document, deleting document if it fades to black.
 | ReplaceSelection(self, text) Replace the selected text with the argument text.
int | ReplaceTarget(self, text) Replace the target text with the argument text.
int | ReplaceTargetRE(self, text) Replace the target text with the argument text after d processing.
bool | SaveFile(self, filename) Write the contents of the editor to filename
 | ScrollToColumn(self, column) Scroll enough to make the given column visible
 | ScrollToLine(self, line) Scroll enough to make the given line visible.
 | SearchAnchor(self) Sets the current caret position to be the search anchor.
int | SearchInTarget(self, text) Search for a counted string in the target and set the target to the found range.
int | SearchNext(self, flags, text) Find some text starting at the search anchor.
int | SearchPrev(self, flags, text) Find some text starting at the search anchor and moving backwards.
 | SelectAll(self) Select all the text in the document.
bool | SelectionIsRectangle(self) Is the selection rectangular? The alternative is the more common stream selection.
long | SendMsg(self, msg, wp, lp) Send a message to Scintilla.
 | SetAnchor(self, posAnchor) Set the selection anchor to a position.
 | SetBackSpaceUnIndents(self, bsUnIndents) Sets whether a backspace pressed when caret is within indentation unindents.
 | SetBufferedDraw(self, buffered) If drawing is buffered then each line of text is drawn into a bitmap buffer before drawing it to the screen to avoid flicker.
 | SetCaretForeground(self, fore) Set the foreground colour of the caret.
 | SetCaretLineBack(self, back) Set the colour of the background of the line containing the caret.
 | SetCaretLineVisible(self, show) Display the background of the line containing the caret in a different colour.
 | SetCaretPeriod(self, periodMilliseconds) Get the time in milliseconds that the caret is on and off.
 | SetCaretWidth(self, pixelWidth) Set the width of the insert mode caret.
 | SetCharsDefault(self) Reset the set of characters for whitespace and word characters to the defaults.
 | SetCodePage(self, codePage) Set the code page used to interpret the bytes of the document as characters.
 | SetControlCharSymbol(self, symbol) Change the way control characters are displayed: If symbol is < 32, keep the drawn way, else, use the given character.
 | SetCurrentPos(self, pos) Sets the position of the caret.
 | SetDocPointer(self, docPointer) Change the document object used.
 | SetEdgeColour(self, edgeColour) Change the colour used in edge indication.
 | SetEdgeColumn(self, column) Set the column number of the edge.
 | SetEdgeMode(self, mode) The edge may be displayed by a line (EDGE_LINE) or by highlighting text that goes beyond it (EDGE_BACKGROUND) or not displayed at all (EDGE_NONE).
 | SetEndAtLastLine(self, endAtLastLine) Sets the scroll range so that maximum scroll position has the last line at the bottom of the view (default).
 | SetEOLMode(self, eolMode) Set the current end of line mode.
 | SetFoldExpanded(self, line, expanded) Show the children of a header line.
 | SetFoldFlags(self, flags) Set some style options for folding.
 | SetFoldLevel(self, line, level) Set the fold level of a line.
 | SetFoldMarginColour(self, useSetting, back) Set the colours used as a chequerboard pattern in the fold margin
 | SetFoldMarginHiColour(self, useSetting, fore)
 | SetHighlightGuide(self, column) Set the highlighted indentation guide column.
 | SetHotspotActiveBackground(self, useSetting, back) Set a back colour for active hotspots.
 | SetHotspotActiveForeground(self, useSetting, fore) Set a fore colour for active hotspots.
 | SetHotspotActiveUnderline(self, underline) Enable / Disable underlining active hotspots.
 | SetHotspotSingleLine(self, singleLine) Limit hotspots to single line so hotspots on two lines don't merge.
 | SetHScrollBar(self, bar) Set the horizontal scrollbar to use instead of the ont that's built-in.
 | SetIndent(self, indentSize) Set the number of spaces used for one level of indentation.
 | SetIndentationGuides(self, show) Show or hide indentation guides.
 | SetKeyWords(self, keywordSet, keyWords) Set up the key words used by the lexer.
 | SetLastKeydownProcessed(self, val)
 | SetLayoutCache(self, mode) Sets the degree of caching of layout information.
 | SetLexer(self, lexer) Set the lexing language of the document.
 | SetLexerLanguage(self, language) Set the lexing language of the document based on string name.
 | SetLineIndentation(self, line, indentSize) Change the indentation of a line to a number of columns.
 | SetLineState(self, line, state) Used to hold extra styling information for each line.
 | SetMarginLeft(self, pixelWidth) Sets the size in pixels of the left margin.
 | SetMarginMask(self, margin, mask) Set a mask that determines which markers are displayed in a margin.
 | SetMarginRight(self, pixelWidth) Sets the size in pixels of the right margin.
 | SetMargins(self, left, right) Set the left and right margin in the edit area, measured in pixels.
 | SetMarginSensitive(self, margin, sensitive) Make a margin sensitive or insensitive to mouse clicks.
 | SetMarginType(self, margin, marginType) Set a margin to be either numeric or symbolic.
 | SetMarginWidth(self, margin, pixelWidth) Set the width of a margin to a width expressed in pixels.
 | SetModEventMask(self, mask) Set which document modification events are sent to the container.
 | SetMouseDownCaptures(self, captures) Set whether the mouse is captured when its button is pressed.
 | SetMouseDwellTime(self, periodMilliseconds) Sets the time the mouse must sit still to generate a mouse dwell event.
 | SetOvertype(self, overtype) Set to overtype (true) or insert mode.
 | SetPrintColourMode(self, mode) Modify colours when printing for clearer printed text.
 | SetPrintMagnification(self, magnification) Sets the print magnification added to the point size of each style for printing.
 | SetPrintWrapMode(self, mode) Set printing to line wrapped (SC_WRAP_WORD) or not line wrapped (SC_WRAP_NONE).
 | SetProperty(self, key, value) Set up a value that may be used by a lexer for some optional feature.
 | SetReadOnly(self, readOnly) Set to read only or read write.
 | SetSavePoint(self) Remember the current position in the undo history as the position at which the document was saved.
 | SetScrollWidth(self, pixelWidth) Sets the document width assumed for scrolling.
 | SetSearchFlags(self, flags) Set the search flags used by SearchInTarget.
 | SetSelBackground(self, useSetting, back) Set the background colour of the selection and whether to use this setting.
 | SetSelection(self, start, end) Select a range of text.
 | SetSelectionEnd(self, pos) Sets the position that ends the selection - this becomes the currentPosition.
 | SetSelectionMode(self, mode) Set the selection mode to stream (SC_SEL_STREAM) or rectangular (SC_SEL_RECTANGLE) or by lines (SC_SEL_LINES).
 | SetSelectionStart(self, pos) Sets the position that starts the selection - this becomes the anchor.
 | SetSelForeground(self, useSetting, fore) Set the foreground colour of the selection and whether to use this setting.
 | SetStatus(self, statusCode) Change error status - 0 = OK.
 | SetSTCCursor(self, cursorType) Sets the cursor to one of the SC_CURSOR* values.
 | SetSTCFocus(self, focus) Change internal focus flag.
 | SetStyleBits(self, bits) Divide each styling byte into lexical class bits (default: 5) and indicator bits (default: 3).
 | SetStyleBytes(self, length, styleBytes) Set the styles for a segment of the document.
 | SetStyling(self, length, style) Change style from current styling position for length characters to a style and move the current styling position to after this newly styled segment.
 | SetTabIndents(self, tabIndents) Sets whether a tab pressed when caret is within indentation indents.
 | SetTabWidth(self, tabWidth) Change the visible size of a tab to be a multiple of the width of a space character.
 | SetTargetEnd(self, pos) Sets the position that ends the target which is used for updating the document without affecting the scroll position.
 | SetTargetStart(self, pos) Sets the position that starts the target which is used for updating the document without affecting the scroll position.
 | SetText(self, text) Replace the contents of the document with the argument text.
 | SetTextRaw(self, text) Replace the contents of the document with the argument text.
 | SetTextUTF8(self, text) Replace the contents of the document with the UTF8 text given.
 | SetTwoPhaseDraw(self, twoPhase) In twoPhaseDraw mode, drawing is performed in two phases, first the background and then the foreground.
 | SetUndoCollection(self, collectUndo) Choose between collecting actions into the undo history and discarding them.
 | SetUseAntiAliasing(self, useAA) Specify whether anti-aliased fonts should be used.
 | SetUseHorizontalScrollBar(self, show) Show or hide the horizontal scroll bar.
 | SetUseTabs(self, useTabs) Indentation will only use space characters if useTabs is false, otherwise it will use a combination of tabs and spaces.
 | SetUseVerticalScrollBar(self, show) Show or hide the vertical scroll bar.
 | SetViewEOL(self, visible) Make the end of line characters visible or invisible.
 | SetViewWhiteSpace(self, viewWS) Make white space characters invisible, always visible or visible outside indentation.
 | SetVisiblePolicy(self, visiblePolicy, visibleSlop) Set the way the display area is determined when a particular line is to be moved to by Find, FindNext, GotoLine, etc.
 | SetVScrollBar(self, bar) Set the vertical scrollbar to use instead of the one that's built-in.
 | SetWhitespaceBackground(self, useSetting, back) Set the background colour of all whitespace and whether to use this setting.
 | SetWhitespaceChars(self, characters) Set the set of characters making up whitespace for when moving or selecting by word.
 | SetWhitespaceForeground(self, useSetting, fore) Set the foreground colour of all whitespace and whether to use this setting.
 | SetWordChars(self, characters) Set the set of characters making up words for when moving or selecting by word.
 | SetWrapMode(self, mode) Sets whether text is word wrapped.
 | SetWrapStartIndent(self, indent) Set the start indent for wrapped lines.
 | SetWrapVisualFlags(self, wrapVisualFlags) Set the display mode of visual flags for wrapped lines.
 | SetWrapVisualFlagsLocation(self, wrapVisualFlagsLocation) Set the location of visual flags for wrapped lines.
 | SetXCaretPolicy(self, caretPolicy, caretSlop) Set the way the caret is kept visible when going sideway.
 | SetXOffset(self, newOffset) Get and Set the xOffset (ie, horizonal scroll position).
 | SetYCaretPolicy(self, caretPolicy, caretSlop) Set the way the line the caret is on is kept visible.
 | SetZoom(self, zoom) Set the zoom level.
 | ShowLines(self, lineStart, lineEnd) Make a range of lines visible.
 | StartRecord(self) Start notifying the container of all key presses and commands.
 | StartStyling(self, pos, mask) Set the current styling position to pos and the styling mask to mask.
 | StopRecord(self) Stop notifying the container of all key presses and commands.
 | StutteredPageDown(self) Move caret to bottom of page, or one page down if already at bottom of page.
 | StutteredPageDownExtend(self) Move caret to bottom of page, or one page down if already at bottom of page, extending selection to new caret position.
 | StutteredPageUp(self) Move caret to top of page, or one page up if already at top of page.
 | StutteredPageUpExtend(self) Move caret to top of page, or one page up if already at top of page, extending selection to new caret position.
 | StyleClearAll(self) Clear all the styles and make equivalent to the global default style.
 | StyleResetDefault(self) Reset the default style to its state at startup
 | StyleSetBackground(self, style, back) Set the background colour of a style.
 | StyleSetBold(self, style, bold) Set a style to be bold or not.
 | StyleSetCase(self, style, caseForce) Set a style to be mixed case, or to force upper or lower case.
 | StyleSetChangeable(self, style, changeable) Set a style to be changeable or not (read only).
 | StyleSetCharacterSet(self, style, characterSet) Set the character set of the font in a style.
 | StyleSetEOLFilled(self, style, filled) Set a style to have its end of line filled or not.
 | StyleSetFaceName(self, style, fontName) Set the font of a style.
 | StyleSetFont(self, styleNum, font) Set style size, face, bold, italic, and underline attributes from the attributes of a wx.Font.
 | StyleSetFontAttr(self, styleNum, size, faceName, bold, italic, underline, encoding) Set all font style attributes at once.
 | StyleSetFontEncoding(self, style, encoding) Set the font encoding to be used by a style.
 | StyleSetForeground(self, style, fore) Set the foreground colour of a style.
 | StyleSetHotSpot(self, style, hotspot) Set a style to be a hotspot or not.
 | StyleSetItalic(self, style, italic) Set a style to be italic or not.
 | StyleSetSize(self, style, sizePoints) Set the size of characters of a style.
 | StyleSetSpec(self, styleNum, spec) Extract style settings from a spec-string which is composed of one or more of the following comma separated elements:
 | StyleSetUnderline(self, style, underline) Set a style to be underlined or not.
 | StyleSetVisible(self, style, visible) Set a style to be visible or not.
 | Tab(self) If selection is empty or all on one line replace the selection with a tab character.
 | TargetFromSelection(self) Make the target range start and end be the same as the selection range start and end.
int | TextHeight(self, line) Retrieve the height of a particular line of text in pixels.
int | TextWidth(self, style, text) Measure the pixel width of some text in a particular style.
 | ToggleFold(self, line) Switch a header line between expanded and contracted.
 | Undo(self) Undo one action in the undo history.
 | UpperCase(self) Transform the selection to upper case.
 | UsePopUp(self, allowPopUp) Set whether a pop up menu is displayed automatically when the user presses the wrong mouse button.
 | UserListShow(self, listType, itemList) Display a list of strings and send notification when user chooses one.
 | VCHome(self) Move caret to before first visible character on line.
 | VCHomeExtend(self) Like VCHome but extending selection to new caret position.
 | VCHomeRectExtend(self) Move caret to before first visible character on line.
 | VCHomeWrap(self)
 | VCHomeWrapExtend(self)
int | VisibleFromDocLine(self, line) Find the display line of a document line taking hidden lines into account.
int | WordEndPosition(self, pos, onlyWordCharacters) Get position of end of word.
 | WordLeft(self) Move caret left one word.
 | WordLeftEnd(self) Move caret left one word, position cursor at end of word.
 | WordLeftEndExtend(self) Move caret left one word, position cursor at end of word, extending selection to new caret position.
 | WordLeftExtend(self) Move caret left one word extending selection to new caret position.
 | WordPartLeft(self) Move to the previous change in capitalisation.
 | WordPartLeftExtend(self) Move to the previous change in capitalisation extending selection to new caret position.
 | WordPartRight(self) Move to the change next in capitalisation.
 | WordPartRightExtend(self) Move to the next change in capitalisation extending selection to new caret position.
 | WordRight(self) Move caret right one word.
 | WordRightEnd(self) Move caret right one word, position cursor at end of word.
 | WordRightEndExtend(self) Move caret right one word, position cursor at end of word, extending selection to new caret position.
 | WordRightExtend(self) Move caret right one word extending selection to new caret position.
int | WordStartPosition(self, pos, onlyWordCharacters) Get position of start of word.
 | ZoomIn(self) Magnify the displayed text by increasing the sizes by 1 point.
 | ZoomOut(self) Make the displayed text smaller by decreasing the sizes by 1 point.

Instance Method Details

__init__(self,
          parent,
          id=ID_ANY,
          pos=DefaultPosition,
          size=DefaultSize,
          style=0,
          name=STCNameStr)
(Constructor)

Create a Control. Normally you should only call this from a subclass' __init__ as a plain old wx.Control is not very useful.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

validator
(type=Validator)

name
(type=String)

Returns:
Control
Overrides:
wx.Control.__init__ (inherited documentation)

AddRefDocument(self, docPointer)

Extend life of document.

Parameters:
docPointer
(type=void)

AddStyledText(self, data)

Add array of cells to document.

Parameters:
data
(type=wxMemoryBuffer)

AddText(self, text)

Add text to the document at current position.

Parameters:
text
(type=String)

AddTextRaw(self, text)

Add text to the document at current position. The text should be utf-8 encoded on unicode builds of wxPython, or can be any 8-bit text in ansi builds.

Parameters:
text
(type=char)

AddTextUTF8(self, text)

Add UTF8 encoded text to the document at the current position. Works 'natively' in a unicode build of wxPython, and will also work in an ansi build if the UTF8 text is compatible with the current encoding.

Allocate(self, bytes)

Enlarge the document to a particular size of text bytes.

Parameters:
bytes
(type=int)

AppendText(self, text)

Append a string to the end of the document without changing the selection.

Parameters:
text
(type=String)

AppendTextRaw(self, text)

Append a string to the end of the document without changing the selection. The text should be utf-8 encoded on unicode builds of wxPython, or can be any 8-bit text in ansi builds.

Parameters:
text
(type=char)

AppendTextUTF8(self, text)

Append a UTF8 string to the end of the document without changing the selection. Works 'natively' in a unicode build of wxPython, and will also work in an ansi build if the UTF8 text is compatible with the current encoding.

AutoCompActive(self)

Is there an auto-completion list visible?

Returns:
bool

AutoCompCancel(self)

Remove the auto-completion list from the screen.

AutoCompComplete(self)

User has selected an item so remove the list and insert the selection.

AutoCompGetAutoHide(self)

Retrieve whether or not autocompletion is hidden automatically when nothing matches.

Returns:
bool

AutoCompGetCancelAtStart(self)

Retrieve whether auto-completion cancelled by backspacing before start.

Returns:
bool

AutoCompGetChooseSingle(self)

Retrieve whether a single item auto-completion list automatically choose the item.

Returns:
bool

AutoCompGetCurrent(self)

Get currently selected item position in the auto-completion list

Returns:
int

AutoCompGetDropRestOfWord(self)

Retrieve whether or not autocompletion deletes any word characters after the inserted text upon completion.

Returns:
bool

AutoCompGetIgnoreCase(self)

Retrieve state of ignore case flag.

Returns:
bool

AutoCompGetSeparator(self)

Retrieve the auto-completion list separator character.

Returns:
int

AutoCompGetTypeSeparator(self)

Retrieve the auto-completion list type-separator character.

Returns:
int

AutoCompPosStart(self)

Retrieve the position of the caret when the auto-completion list was displayed.

Returns:
int

AutoCompSelect(self, text)

Select the item in the auto-completion list that starts with a string.

Parameters:
text
(type=String)

AutoCompSetAutoHide(self, autoHide)

Set whether or not autocompletion is hidden automatically when nothing matches.

Parameters:
autoHide
(type=bool)

AutoCompSetCancelAtStart(self, cancel)

Should the auto-completion list be cancelled if the user backspaces to a position before where the box was created.

Parameters:
cancel
(type=bool)

AutoCompSetChooseSingle(self, chooseSingle)

Should a single item auto-completion list automatically choose the item.

Parameters:
chooseSingle
(type=bool)

AutoCompSetDropRestOfWord(self, dropRestOfWord)

Set whether or not autocompletion deletes any word characters after the inserted text upon completion.

Parameters:
dropRestOfWord
(type=bool)

AutoCompSetFillUps(self, characterSet)

Define a set of characters that when typed will cause the autocompletion to choose the selected item.

Parameters:
characterSet
(type=String)

AutoCompSetIgnoreCase(self, ignoreCase)

Set whether case is significant when performing auto-completion searches.

Parameters:
ignoreCase
(type=bool)

AutoCompSetSeparator(self, separatorCharacter)

Change the separator character in the string setting up an auto-completion list. Default is space but can be changed if items contain space.

Parameters:
separatorCharacter
(type=int)

AutoCompSetTypeSeparator(self, separatorCharacter)

Change the type-separator character in the string setting up an auto-completion list. Default is '?' but can be changed if items contain '?'.

Parameters:
separatorCharacter
(type=int)

AutoCompShow(self, lenEntered, itemList)

Display a auto-completion list. The lenEntered parameter indicates how many characters before the caret should be used to provide context.

Parameters:
lenEntered
(type=int)

itemList
(type=String)

AutoCompStops(self, characterSet)

Define a set of character that when typed cancel the auto-completion list.

Parameters:
characterSet
(type=String)

BackTab(self)

Dedent the selected lines.

BeginUndoAction(self)

Start a sequence of actions that is undone and redone as a unit. May be nested.

BraceBadLight(self, pos)

Highlight the character at a position indicating there is no matching brace.

Parameters:
pos
(type=int)

BraceHighlight(self, pos1, pos2)

Highlight the characters at two positions.

Parameters:
pos1
(type=int)

pos2
(type=int)

BraceMatch(self, pos)

Find the position of a matching brace or INVALID_POSITION if no match.

Parameters:
pos
(type=int)

Returns:
int

CallTipActive(self)

Is there an active call tip?

Returns:
bool

CallTipCancel(self)

Remove the call tip from the screen.

CallTipPosAtStart(self)

Retrieve the position where the caret was before displaying the call tip.

Returns:
int

CallTipSetBackground(self, back)

Set the background colour for the call tip.

Parameters:
back
(type=Colour)

CallTipSetForeground(self, fore)

Set the foreground colour for the call tip.

Parameters:
fore
(type=Colour)

CallTipSetForegroundHighlight(self, fore)

Set the foreground colour for the highlighted part of the call tip.

Parameters:
fore
(type=Colour)

CallTipSetHighlight(self, start, end)

Highlight a segment of the definition.

Parameters:
start
(type=int)

end
(type=int)

CallTipShow(self, pos, definition)

Show a call tip containing a definition near position pos.

Parameters:
pos
(type=int)

definition
(type=String)

Cancel(self)

Cancel any modes such as call tip or auto-completion list display.

CanPaste(self)

Will a paste succeed?

Returns:
bool

CanRedo(self)

Are there any redoable actions in the undo history?

Returns:
bool

CanUndo(self)

Are there any undoable actions in the undo history?

Returns:
bool

CharLeft(self)

Move caret left one character.

CharLeftExtend(self)

Move caret left one character extending selection to new caret position.

CharLeftRectExtend(self)

Move caret left one character, extending rectangular selection to new caret position.

CharRight(self)

Move caret right one character.

CharRightExtend(self)

Move caret right one character extending selection to new caret position.

CharRightRectExtend(self)

Move caret right one character, extending rectangular selection to new caret position.

ChooseCaretX(self)

Set the last x chosen value to be the caret x position.

Clear(self)

Clear the selection.

ClearAll(self)

Delete all text in the document.

ClearDocumentStyle(self)

Set all style bytes to 0, remove all folding information.

ClearRegisteredImages(self)

Clear all the registered images.

CmdKeyAssign(self, key, modifiers, cmd)

When key+modifier combination km is pressed perform msg.

Parameters:
key
(type=int)

modifiers
(type=int)

cmd
(type=int)

CmdKeyClear(self, key, modifiers)

When key+modifier combination km is pressed do nothing.

Parameters:
key
(type=int)

modifiers
(type=int)

CmdKeyClearAll(self)

Drop all key mappings.

CmdKeyExecute(self, cmd)

Perform one of the operations defined by the wx.stc.STC_CMD_* constants.

Parameters:
cmd
(type=int)

Colourise(self, start, end)

Colourise a segment of the document using the current lexing language.

Parameters:
start
(type=int)

end
(type=int)

ConvertEOLs(self, eolMode)

Convert all line endings in the document to one mode.

Parameters:
eolMode
(type=int)

Copy(self)

Copy the selection to the clipboard.

CopyRange(self, start, end)

Copy a range of text to the clipboard. Positions are clipped into the document.

Parameters:
start
(type=int)

end
(type=int)

CopyText(self, length, text)

Copy argument text to the clipboard.

Parameters:
length
(type=int)

text
(type=String)

Create(self,
          parent,
          id=ID_ANY,
          pos=DefaultPosition,
          size=DefaultSize,
          style=0,
          name=wxSTCNameStr)

Do the 2nd phase and create the GUI control.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

validator
(type=Validator)

name
(type=String)

Returns:
bool
Overrides:
wx.Control.Create (inherited documentation)

CreateDocument(self)

Create a new document object. Starts with reference count of 1 and not selected into editor.

Returns:
void

Cut(self)

Cut the selection to the clipboard.

DeleteBack(self)

Delete the selection or if no selection, the character before the caret.

DeleteBackNotLine(self)

Delete the selection or if no selection, the character before the caret. Will not delete the character before at the start of a line.

DelLineLeft(self)

Delete back from the current position to the start of the line.

DelLineRight(self)

Delete forwards from the current position to the end of the line.

DelWordLeft(self)

Delete the word to the left of the caret.

DelWordRight(self)

Delete the word to the right of the caret.

DocLineFromVisible(self, lineDisplay)

Find the document line of a display line taking hidden lines into account.

Parameters:
lineDisplay
(type=int)

Returns:
int

DocumentEnd(self)

Move caret to last position in document.

DocumentEndExtend(self)

Move caret to last position in document extending selection to new caret position.

DocumentStart(self)

Move caret to first position in document.

DocumentStartExtend(self)

Move caret to first position in document extending selection to new caret position.

DoDragOver(self, x, y, def)

Allow for simulating a DnD DragOver.

Parameters:
x
(type=int)

y
(type=int)

def
(type=int)

Returns:
int

DoDropText(self, x, y, data)

Allow for simulating a DnD DropText.

Parameters:
x
(type=long)

y
(type=long)

data
(type=String)

Returns:
bool

EditToggleOvertype(self)

Switch from insert to overtype mode or the reverse.

EmptyUndoBuffer(self)

Delete the undo history.

EndUndoAction(self)

End a sequence of actions that is undone and redone as a unit.

EnsureCaretVisible(self)

Ensure the caret is visible.

EnsureVisible(self, line)

Ensure a particular line is visible by expanding any header line hiding it.

Parameters:
line
(type=int)

EnsureVisibleEnforcePolicy(self, line)

Ensure a particular line is visible by expanding any header line hiding it. Use the currently set visibility policy to determine which range to display.

Parameters:
line
(type=int)

FindColumn(self, line, column)

Find the position of a column on a line taking into account tabs and multi-byte characters. If beyond end of line, return line end position.

Parameters:
line
(type=int)

column
(type=int)

Returns:
int

FindText(self, minPos, maxPos, text, flags=0)

Find some text in the document.

Parameters:
minPos
(type=int)

maxPos
(type=int)

text
(type=String)

flags
(type=int)

Returns:
int

FormatRange(self, doDraw, startPos, endPos, draw, target, renderRect, pageRect)

On Windows, will draw the document into a display context such as a printer.

Parameters:
doDraw
(type=bool)

startPos
(type=int)

endPos
(type=int)

draw
(type=DC)

target
(type=DC)

renderRect
(type=Rect)

pageRect
(type=Rect)

Returns:
int

FormFeed(self)

Insert a Form Feed character.

GetAnchor(self)

Returns the position of the opposite end of the selection to the caret.

Returns:
int

GetBackSpaceUnIndents(self)

Does a backspace pressed when caret is within indentation unindent?

Returns:
bool

GetBufferedDraw(self)

Is drawing done first into a buffer or direct to the screen?

Returns:
bool

GetCaretForeground(self)

Get the foreground colour of the caret.

Returns:
Colour

GetCaretLineBack(self)

Get the colour of the background of the line containing the caret.

Returns:
Colour

GetCaretLineVisible(self)

Is the background of the line containing the caret in a different colour?

Returns:
bool

GetCaretPeriod(self)

Get the time in milliseconds that the caret is on and off.

Returns:
int

GetCaretWidth(self)

Returns the width of the insert mode caret.

Returns:
int

GetCharAt(self, pos)

Returns the character byte at the position.

Parameters:
pos
(type=int)

Returns:
int

GetCodePage(self)

Get the code page used to interpret the bytes of the document as characters.

Returns:
int

GetColumn(self, pos)

Retrieve the column number of a position, taking tab width into account.

Parameters:
pos
(type=int)

Returns:
int

GetControlCharSymbol(self)

Get the way control characters are displayed.

Returns:
int

GetCurLine(self)

Retrieve the text of the line containing the caret, and also theindex of the caret on the line.

Returns:
(text, pos)

GetCurLineRaw()

Retrieve the text of the line containing the caret, and also the index of the caret on the line. The returned value is a utf-8 encoded string in unicode builds of wxPython, or raw 8-bit text otherwise.

Returns:
(text, index)

GetCurLineUTF8(self)

Retrieve the UTF8 text of the line containing the caret, and also the index of the caret on the line. In an ansi build of wxPython the text retrieved from the document is assumed to be in the current default encoding.

GetCurrentLine(self)

Returns the line number of the line with the caret.

Returns:
int

GetCurrentPos(self)

Returns the position of the caret.

Returns:
int

GetDocPointer(self)

Retrieve a pointer to the document object.

Returns:
void

GetEdgeColour(self)

Retrieve the colour used in edge indication.

Returns:
Colour

GetEdgeColumn(self)

Retrieve the column number which text should be kept within.

Returns:
int

GetEdgeMode(self)

Retrieve the edge highlight mode.

Returns:
int

GetEndAtLastLine(self)

Retrieve whether the maximum scroll position has the last line at the bottom of the view.

Returns:
int

GetEndStyled(self)

Retrieve the position of the last correctly styled character.

Returns:
int

GetEOLMode(self)

Retrieve the current end of line mode - one of CRLF, CR, or LF.

Returns:
int

GetFirstVisibleLine(self)

Retrieve the display line at the top of the display.

Returns:
int

GetFoldExpanded(self, line)

Is a header line expanded?

Parameters:
line
(type=int)

Returns:
bool

GetFoldLevel(self, line)

Retrieve the fold level of a line.

Parameters:
line
(type=int)

Returns:
int

GetFoldParent(self, line)

Find the parent line of a child line.

Parameters:
line
(type=int)

Returns:
int

GetHighlightGuide(self)

Get the highlighted indentation guide column.

Returns:
int

GetIndent(self)

Retrieve indentation size.

Returns:
int

GetIndentationGuides(self)

Are the indentation guides visible?

Returns:
bool

GetLastChild(self, line, level)

Find the last child line of a header line.

Parameters:
line
(type=int)

level
(type=int)

Returns:
int

GetLayoutCache(self)

Retrieve the degree of caching of layout information.

Returns:
int

GetLength(self)

Returns the number of characters in the document.

Returns:
int

GetLexer(self)

Retrieve the lexing language of the document.

Returns:
int

GetLine(self, line)

Retrieve the contents of a line.

Parameters:
line
(type=int)

Returns:
String

GetLineCount(self)

Returns the number of lines in the document. There is always at least one.

Returns:
int

GetLineEndPosition(self, line)

Get the position after the last visible characters on a line.

Parameters:
line
(type=int)

Returns:
int

GetLineIndentation(self, line)

Retrieve the number of columns that a line is indented.

Parameters:
line
(type=int)

Returns:
int

GetLineIndentPosition(self, line)

Retrieve the position before the first non indentation character on a line.

Parameters:
line
(type=int)

Returns:
int

GetLineRaw(self, line)

Retrieve the contents of a line. The returned value is a utf-8 encoded string in unicode builds of wxPython, or raw 8-bit text otherwise.

Parameters:
line
(type=int)

Returns:
wxCharBuffer

GetLineSelEndPosition(self, line)

Retrieve the position of the end of the selection at the given line (INVALID_POSITION if no selection on this line).

Parameters:
line
(type=int)

Returns:
int

GetLineSelStartPosition(self, line)

Retrieve the position of the start of the selection at the given line (INVALID_POSITION if no selection on this line).

Parameters:
line
(type=int)

Returns:
int

GetLineState(self, line)

Retrieve the extra styling information for a line.

Parameters:
line
(type=int)

Returns:
int

GetLineUTF8(self, line)

Retrieve the contents of a line as UTF8. In an ansi build of wxPython the text retrieved from the document is assumed to be in the current default encoding.

GetLineVisible(self, line)

Is a line visible?

Parameters:
line
(type=int)

Returns:
bool

GetMarginLeft(self)

Returns the size in pixels of the left margin.

Returns:
int

GetMarginMask(self, margin)

Retrieve the marker mask of a margin.

Parameters:
margin
(type=int)

Returns:
int

GetMarginRight(self)

Returns the size in pixels of the right margin.

Returns:
int

GetMarginSensitive(self, margin)

Retrieve the mouse click sensitivity of a margin.

Parameters:
margin
(type=int)

Returns:
bool

GetMarginType(self, margin)

Retrieve the type of a margin.

Parameters:
margin
(type=int)

Returns:
int

GetMarginWidth(self, margin)

Retrieve the width of a margin in pixels.

Parameters:
margin
(type=int)

Returns:
int

GetMaxLineState(self)

Retrieve the last line number that has line state.

Returns:
int

GetModEventMask(self)

Get which document modification events are sent to the container.

Returns:
int

GetModify(self)

Is the document different from when it was last saved?

Returns:
bool

GetMouseDownCaptures(self)

Get whether mouse gets captured.

Returns:
bool

GetMouseDwellTime(self)

Retrieve the time the mouse must sit still to generate a mouse dwell event.

Returns:
int

GetOvertype(self)

Returns true if overtype mode is active otherwise false is returned.

Returns:
bool

GetPrintColourMode(self)

Returns the print colour mode.

Returns:
int

GetPrintMagnification(self)

Returns the print magnification.

Returns:
int

GetPrintWrapMode(self)

Is printing line wrapped?

Returns:
int

GetReadOnly(self)

In read-only mode?

Returns:
bool

GetScrollWidth(self)

Retrieve the document width assumed for scrolling.

Returns:
int

GetSearchFlags(self)

Get the search flags used by SearchInTarget.

Returns:
int

GetSelectedText(self)

Retrieve the selected text.

Returns:
String

GetSelectedTextRaw(self)

Retrieve the selected text. The returned value is a utf-8 encoded string in unicode builds of wxPython, or raw 8-bit text otherwise.

Returns:
wxCharBuffer

GetSelectedTextUTF8(self)

Retrieve the selected text as UTF8. In an ansi build of wxPython the text retrieved from the document is assumed to be in the current default encoding.

GetSelection(self)

Retrieve the start and end positions of the current selection.

Returns:
(startPos, endPos)

GetSelectionEnd(self)

Returns the position at the end of the selection.

Returns:
int

GetSelectionMode(self)

Get the mode of the current selection.

Returns:
int

GetSelectionStart(self)

Returns the position at the start of the selection.

Returns:
int

GetStatus(self)

Get error status.

Returns:
int

GetSTCCursor(self)

Get cursor type.

Returns:
int

GetSTCFocus(self)

Get internal focus flag.

Returns:
bool

GetStyleAt(self, pos)

Returns the style byte at the position.

Parameters:
pos
(type=int)

Returns:
int

GetStyleBits(self)

Retrieve number of bits in style bytes used to hold the lexical state.

Returns:
int

GetStyledText(self, startPos, endPos)

Retrieve a buffer of cells.

Parameters:
startPos
(type=int)

endPos
(type=int)

Returns:
wxMemoryBuffer

GetTabIndents(self)

Does a tab pressed when caret is within indentation indent?

Returns:
bool

GetTabWidth(self)

Retrieve the visible size of a tab.

Returns:
int

GetTargetEnd(self)

Get the position that ends the target.

Returns:
int

GetTargetStart(self)

Get the position that starts the target.

Returns:
int

GetText(self)

Retrieve all the text in the document.

Returns:
String

GetTextLength(self)

Retrieve the number of characters in the document.

Returns:
int

GetTextRange(self, startPos, endPos)

Retrieve a range of text.

Parameters:
startPos
(type=int)

endPos
(type=int)

Returns:
String

GetTextRangeRaw(self, startPos, endPos)

Retrieve a range of text. The returned value is a utf-8 encoded string in unicode builds of wxPython, or raw 8-bit text otherwise.

Parameters:
startPos
(type=int)

endPos
(type=int)

Returns:
wxCharBuffer

GetTextRangeUTF8(self, startPos, endPos)

Retrieve a range of text as UTF8. In an ansi build of wxPython the text retrieved from the document is assumed to be in the current default encoding.

GetTextRaw(self)

Retrieve all the text in the document. The returned value is a utf-8 encoded string in unicode builds of wxPython, or raw 8-bit text otherwise.

Returns:
wxCharBuffer

GetTextUTF8(self)

Retrieve all the text in the document as UTF8. In an ansi build of wxPython the text retrieved from the document is assumed to be in the current default encoding.

GetTwoPhaseDraw(self)

Is drawing done in two phases with backgrounds drawn before foregrounds?

Returns:
bool

GetUndoCollection(self)

Is undo history being collected?

Returns:
bool

GetUseAntiAliasing(self)

Returns the current UseAntiAliasing setting.

Returns:
bool

GetUseHorizontalScrollBar(self)

Is the horizontal scroll bar visible?

Returns:
bool

GetUseTabs(self)

Retrieve whether tabs will be used in indentation.

Returns:
bool

GetUseVerticalScrollBar(self)

Is the vertical scroll bar visible?

Returns:
bool

GetViewEOL(self)

Are the end of line characters visible?

Returns:
bool

GetViewWhiteSpace(self)

Are white space characters currently visible? Returns one of SCWS_* constants.

Returns:
int

GetWrapMode(self)

Retrieve whether text is word wrapped.

Returns:
int

GetWrapStartIndent(self)

Retrive the start indent for wrapped lines.

Returns:
int

GetWrapVisualFlags(self)

Retrive the display mode of visual flags for wrapped lines.

Returns:
int

GetWrapVisualFlagsLocation(self)

Retrive the location of visual flags for wrapped lines.

Returns:
int

GetZoom(self)

Retrieve the zoom level.

Returns:
int

GotoLine(self, line)

Set caret to start of a line and ensure it is visible.

Parameters:
line
(type=int)

GotoPos(self, pos)

Set caret to a position and ensure it is visible.

Parameters:
pos
(type=int)

HideLines(self, lineStart, lineEnd)

Make a range of lines invisible.

Parameters:
lineStart
(type=int)

lineEnd
(type=int)

HideSelection(self, normal)

Draw the selection in normal style or with selection highlighted.

Parameters:
normal
(type=bool)

Home(self)

Move caret to first position on line.

HomeDisplay(self)

Move caret to first position on display line.

HomeDisplayExtend(self)

Move caret to first position on display line extending selection to new caret position.

HomeExtend(self)

Move caret to first position on line extending selection to new caret position.

HomeRectExtend(self)

Move caret to first position on line, extending rectangular selection to new caret position.

HomeWrap(self)

These are like their namesakes Home(Extend)?, LineEnd(Extend)?, VCHome(Extend)? except they behave differently when word-wrap is enabled: They go first to the start / end of the display line, like (Home|LineEnd)Display The difference is that, the cursor is already at the point, it goes on to the start or end of the document line, as appropriate for (Home|LineEnd|VCHome)(Extend)?.

IndicatorGetForeground(self, indic)

Retrieve the foreground colour of an indicator.

Parameters:
indic
(type=int)

Returns:
Colour

IndicatorGetStyle(self, indic)

Retrieve the style of an indicator.

Parameters:
indic
(type=int)

Returns:
int

IndicatorSetForeground(self, indic, fore)

Set the foreground colour of an indicator.

Parameters:
indic
(type=int)

fore
(type=Colour)

IndicatorSetStyle(self, indic, style)

Set an indicator to plain, squiggle or TT.

Parameters:
indic
(type=int)

style
(type=int)

InsertText(self, pos, text)

Insert string at a position.

Parameters:
pos
(type=int)

text
(type=String)

InsertTextRaw(self, pos, text)

Insert string at a position. The text should be utf-8 encoded on unicode builds of wxPython, or can be any 8-bit text in ansi builds.

Parameters:
pos
(type=int)

text
(type=char)

InsertTextUTF8(self, pos, text)

Insert UTF8 encoded text at a position. Works 'natively' in a unicode build of wxPython, and will also work in an ansi build if the UTF8 text is compatible with the current encoding.

LineCopy(self)

Copy the line containing the caret.

LineCut(self)

Cut the line containing the caret.

LineDelete(self)

Delete the line containing the caret.

LineDown(self)

Move caret down one line.

Overrides:
wx.Window.LineDown

LineDownExtend(self)

Move caret down one line extending selection to new caret position.

LineDownRectExtend(self)

Move caret down one line, extending rectangular selection to new caret position.

LineDuplicate(self)

Duplicate the current line.

LineEnd(self)

Move caret to last position on line.

LineEndDisplay(self)

Move caret to last position on display line.

LineEndDisplayExtend(self)

Move caret to last position on display line extending selection to new caret position.

LineEndExtend(self)

Move caret to last position on line extending selection to new caret position.

LineEndRectExtend(self)

Move caret to last position on line, extending rectangular selection to new caret position.

LineFromPosition(self, pos)

Retrieve the line containing a position.

Parameters:
pos
(type=int)

Returns:
int

LineLength(self, line)

How many characters are on a line, not including end of line characters?

Parameters:
line
(type=int)

Returns:
int

LineScroll(self, columns, lines)

Scroll horizontally and vertically.

Parameters:
columns
(type=int)

lines
(type=int)

LineScrollDown(self)

Scroll the document down, keeping the caret visible.

LineScrollUp(self)

Scroll the document up, keeping the caret visible.

LinesJoin(self)

Join the lines in the target.

LinesOnScreen(self)

Retrieves the number of lines completely visible.

Returns:
int

LinesSplit(self, pixelWidth)

Split the lines in the target into lines that are less wide than pixelWidth where possible.

Parameters:
pixelWidth
(type=int)

LineTranspose(self)

Switch the current line with the previous.

LineUp(self)

Move caret up one line.

Overrides:
wx.Window.LineUp

LineUpExtend(self)

Move caret up one line extending selection to new caret position.

LineUpRectExtend(self)

Move caret up one line, extending rectangular selection to new caret position.

LoadFile(self, filename)

Load the contents of filename into the editor

Parameters:
filename
(type=String)

Returns:
bool

LowerCase(self)

Transform the selection to lower case.

MarkerAdd(self, line, markerNumber)

Add a marker to a line, returning an ID which can be used to find or delete the marker.

Parameters:
line
(type=int)

markerNumber
(type=int)

Returns:
int

MarkerDefine(self, markerNumber, markerSymbol, foreground=wxNullColour, background=wxNullColour)

Set the symbol used for a particular marker number, and optionally the fore and background colours.

Parameters:
markerNumber
(type=int)

markerSymbol
(type=int)

foreground
(type=Colour)

background
(type=Colour)

MarkerDefineBitmap(self, markerNumber, bmp)

Define a marker from a bitmap

Parameters:
markerNumber
(type=int)

bmp
(type=Bitmap)

MarkerDelete(self, line, markerNumber)

Delete a marker from a line.

Parameters:
line
(type=int)

markerNumber
(type=int)

MarkerDeleteAll(self, markerNumber)

Delete all markers with a particular number from all lines.

Parameters:
markerNumber
(type=int)

MarkerDeleteHandle(self, handle)

Delete a marker.

Parameters:
handle
(type=int)

MarkerGet(self, line)

Get a bit mask of all the markers set on a line.

Parameters:
line
(type=int)

Returns:
int

MarkerLineFromHandle(self, handle)

Retrieve the line number at which a particular marker is located.

Parameters:
handle
(type=int)

Returns:
int

MarkerNext(self, lineStart, markerMask)

Find the next line after lineStart that includes a marker in mask.

Parameters:
lineStart
(type=int)

markerMask
(type=int)

Returns:
int

MarkerPrevious(self, lineStart, markerMask)

Find the previous line before lineStart that includes a marker in mask.

Parameters:
lineStart
(type=int)

markerMask
(type=int)

Returns:
int

MarkerSetBackground(self, markerNumber, back)

Set the background colour used for a particular marker number.

Parameters:
markerNumber
(type=int)

back
(type=Colour)

MarkerSetForeground(self, markerNumber, fore)

Set the foreground colour used for a particular marker number.

Parameters:
markerNumber
(type=int)

fore
(type=Colour)

MoveCaretInsideView(self)

Move the caret inside current view if it's not there already.

NewLine(self)

Insert a new line, may use a CRLF, CR or LF depending on EOL mode.

PageDown(self)

Move caret one page down.

Overrides:
wx.Window.PageDown

PageDownExtend(self)

Move caret one page down extending selection to new caret position.

PageDownRectExtend(self)

Move caret one page down, extending rectangular selection to new caret position.

PageUp(self)

Move caret one page up.

Overrides:
wx.Window.PageUp

PageUpExtend(self)

Move caret one page up extending selection to new caret position.

PageUpRectExtend(self)

Move caret one page up, extending rectangular selection to new caret position.

ParaDown(self)

Move caret between paragraphs (delimited by empty lines).

Paste(self)

Paste the contents of the clipboard into the document replacing the selection.

PointFromPosition(self, pos)

Retrieve the point in the window where a position is displayed.

Parameters:
pos
(type=int)

Returns:
Point

PositionAfter(self, pos)

Given a valid document position, return the next position taking code page into account. Maximum value returned is the last position in the document.

Parameters:
pos
(type=int)

Returns:
int

PositionBefore(self, pos)

Given a valid document position, return the previous position taking code page into account. Returns 0 if passed 0.

Parameters:
pos
(type=int)

Returns:
int

PositionFromLine(self, line)

Retrieve the position at the start of a line.

Parameters:
line
(type=int)

Returns:
int

PositionFromPoint(self, pt)

Find the position from a point within the window.

Parameters:
pt
(type=Point)

Returns:
int

PositionFromPointClose(self, x, y)

Find the position from a point within the window but return INVALID_POSITION if not close to text.

Parameters:
x
(type=int)

y
(type=int)

Returns:
int

Redo(self)

Redoes the next action on the undo history.

RegisterImage(self, type, bmp)

Register an image for use in autocompletion lists.

Parameters:
type
(type=int)

bmp
(type=Bitmap)

ReleaseDocument(self, docPointer)

Release a reference to the document, deleting document if it fades to black.

Parameters:
docPointer
(type=void)

ReplaceSelection(self, text)

Replace the selected text with the argument text.

Parameters:
text
(type=String)

ReplaceTarget(self, text)

Replace the target text with the argument text. Text is counted so it can contain NULs. Returns the length of the replacement text.

Parameters:
text
(type=String)

Returns:
int

ReplaceTargetRE(self, text)

Replace the target text with the argument text after d processing. Text is counted so it can contain NULs. Looks for d where d is between 1 and 9 and replaces these with the strings matched in the last search operation which were surrounded by ( and ). Returns the length of the replacement text including any change caused by processing the d patterns.

Parameters:
text
(type=String)

Returns:
int

SaveFile(self, filename)

Write the contents of the editor to filename

Parameters:
filename
(type=String)

Returns:
bool

ScrollToColumn(self, column)

Scroll enough to make the given column visible

Parameters:
column
(type=int)

ScrollToLine(self, line)

Scroll enough to make the given line visible.

Parameters:
line
(type=int)

SearchAnchor(self)

Sets the current caret position to be the search anchor.

SearchInTarget(self, text)

Search for a counted string in the target and set the target to the found range. Text is counted so it can contain NULs. Returns length of range or -1 for failure in which case target is not moved.

Parameters:
text
(type=String)

Returns:
int

SearchNext(self, flags, text)

Find some text starting at the search anchor. Does not ensure the selection is visible.

Parameters:
flags
(type=int)

text
(type=String)

Returns:
int

SearchPrev(self, flags, text)

Find some text starting at the search anchor and moving backwards. Does not ensure the selection is visible.

Parameters:
flags
(type=int)

text
(type=String)

Returns:
int

SelectAll(self)

Select all the text in the document.

SelectionIsRectangle(self)

Is the selection rectangular? The alternative is the more common stream selection.

Returns:
bool

SendMsg(self, msg, wp=0, lp=0)

Send a message to Scintilla.

Parameters:
msg
(type=int)

wp
(type=long)

lp
(type=long)

Returns:
long

SetAnchor(self, posAnchor)

Set the selection anchor to a position. The anchor is the opposite end of the selection from the caret.

Parameters:
posAnchor
(type=int)

SetBackSpaceUnIndents(self, bsUnIndents)

Sets whether a backspace pressed when caret is within indentation unindents.

Parameters:
bsUnIndents
(type=bool)

SetBufferedDraw(self, buffered)

If drawing is buffered then each line of text is drawn into a bitmap buffer before drawing it to the screen to avoid flicker.

Parameters:
buffered
(type=bool)

SetCaretForeground(self, fore)

Set the foreground colour of the caret.

Parameters:
fore
(type=Colour)

SetCaretLineBack(self, back)

Set the colour of the background of the line containing the caret.

Parameters:
back
(type=Colour)

SetCaretLineVisible(self, show)

Display the background of the line containing the caret in a different colour.

Parameters:
show
(type=bool)

SetCaretPeriod(self, periodMilliseconds)

Get the time in milliseconds that the caret is on and off. 0 = steady on.

Parameters:
periodMilliseconds
(type=int)

SetCaretWidth(self, pixelWidth)

Set the width of the insert mode caret.

Parameters:
pixelWidth
(type=int)

SetCharsDefault(self)

Reset the set of characters for whitespace and word characters to the defaults.

SetCodePage(self, codePage)

Set the code page used to interpret the bytes of the document as characters.

Parameters:
codePage
(type=int)

SetControlCharSymbol(self, symbol)

Change the way control characters are displayed: If symbol is < 32, keep the drawn way, else, use the given character.

Parameters:
symbol
(type=int)

SetCurrentPos(self, pos)

Sets the position of the caret.

Parameters:
pos
(type=int)

SetDocPointer(self, docPointer)

Change the document object used.

Parameters:
docPointer
(type=void)

SetEdgeColour(self, edgeColour)

Change the colour used in edge indication.

Parameters:
edgeColour
(type=Colour)

SetEdgeColumn(self, column)

Set the column number of the edge. If text goes past the edge then it is highlighted.

Parameters:
column
(type=int)

SetEdgeMode(self, mode)

The edge may be displayed by a line (EDGE_LINE) or by highlighting text that goes beyond it (EDGE_BACKGROUND) or not displayed at all (EDGE_NONE).

Parameters:
mode
(type=int)

SetEndAtLastLine(self, endAtLastLine)

Sets the scroll range so that maximum scroll position has the last line at the bottom of the view (default). Setting this to false allows scrolling one page below the last line.

Parameters:
endAtLastLine
(type=bool)

SetEOLMode(self, eolMode)

Set the current end of line mode.

Parameters:
eolMode
(type=int)

SetFoldExpanded(self, line, expanded)

Show the children of a header line.

Parameters:
line
(type=int)

expanded
(type=bool)

SetFoldFlags(self, flags)

Set some style options for folding.

Parameters:
flags
(type=int)

SetFoldLevel(self, line, level)

Set the fold level of a line. This encodes an integer level along with flags indicating whether the line is a header and whether it is effectively white space.

Parameters:
line
(type=int)

level
(type=int)

SetFoldMarginColour(self, useSetting, back)

Set the colours used as a chequerboard pattern in the fold margin

Parameters:
useSetting
(type=bool)

back
(type=Colour)

SetHighlightGuide(self, column)

Set the highlighted indentation guide column. 0 = no highlighted guide.

Parameters:
column
(type=int)

SetHotspotActiveBackground(self, useSetting, back)

Set a back colour for active hotspots.

Parameters:
useSetting
(type=bool)

back
(type=Colour)

SetHotspotActiveForeground(self, useSetting, fore)

Set a fore colour for active hotspots.

Parameters:
useSetting
(type=bool)

fore
(type=Colour)

SetHotspotActiveUnderline(self, underline)

Enable / Disable underlining active hotspots.

Parameters:
underline
(type=bool)

SetHotspotSingleLine(self, singleLine)

Limit hotspots to single line so hotspots on two lines don't merge.

Parameters:
singleLine
(type=bool)

SetHScrollBar(self, bar)

Set the horizontal scrollbar to use instead of the ont that's built-in.

Parameters:
bar
(type=wxScrollBar)

SetIndent(self, indentSize)

Set the number of spaces used for one level of indentation.

Parameters:
indentSize
(type=int)

SetIndentationGuides(self, show)

Show or hide indentation guides.

Parameters:
show
(type=bool)

SetKeyWords(self, keywordSet, keyWords)

Set up the key words used by the lexer.

Parameters:
keywordSet
(type=int)

keyWords
(type=String)

SetLayoutCache(self, mode)

Sets the degree of caching of layout information.

Parameters:
mode
(type=int)

SetLexer(self, lexer)

Set the lexing language of the document.

Parameters:
lexer
(type=int)

SetLexerLanguage(self, language)

Set the lexing language of the document based on string name.

Parameters:
language
(type=String)

SetLineIndentation(self, line, indentSize)

Change the indentation of a line to a number of columns.

Parameters:
line
(type=int)

indentSize
(type=int)

SetLineState(self, line, state)

Used to hold extra styling information for each line.

Parameters:
line
(type=int)

state
(type=int)

SetMarginLeft(self, pixelWidth)

Sets the size in pixels of the left margin.

Parameters:
pixelWidth
(type=int)

SetMarginMask(self, margin, mask)

Set a mask that determines which markers are displayed in a margin.

Parameters:
margin
(type=int)

mask
(type=int)

SetMarginRight(self, pixelWidth)

Sets the size in pixels of the right margin.

Parameters:
pixelWidth
(type=int)

SetMargins(self, left, right)

Set the left and right margin in the edit area, measured in pixels.

Parameters:
left
(type=int)

right
(type=int)

SetMarginSensitive(self, margin, sensitive)

Make a margin sensitive or insensitive to mouse clicks.

Parameters:
margin
(type=int)

sensitive
(type=bool)

SetMarginType(self, margin, marginType)

Set a margin to be either numeric or symbolic.

Parameters:
margin
(type=int)

marginType
(type=int)

SetMarginWidth(self, margin, pixelWidth)

Set the width of a margin to a width expressed in pixels.

Parameters:
margin
(type=int)

pixelWidth
(type=int)

SetModEventMask(self, mask)

Set which document modification events are sent to the container.

Parameters:
mask
(type=int)

SetMouseDownCaptures(self, captures)

Set whether the mouse is captured when its button is pressed.

Parameters:
captures
(type=bool)

SetMouseDwellTime(self, periodMilliseconds)

Sets the time the mouse must sit still to generate a mouse dwell event.

Parameters:
periodMilliseconds
(type=int)

SetOvertype(self, overtype)

Set to overtype (true) or insert mode.

Parameters:
overtype
(type=bool)

SetPrintColourMode(self, mode)

Modify colours when printing for clearer printed text.

Parameters:
mode
(type=int)

SetPrintMagnification(self, magnification)

Sets the print magnification added to the point size of each style for printing.

Parameters:
magnification
(type=int)

SetPrintWrapMode(self, mode)

Set printing to line wrapped (SC_WRAP_WORD) or not line wrapped (SC_WRAP_NONE).

Parameters:
mode
(type=int)

SetProperty(self, key, value)

Set up a value that may be used by a lexer for some optional feature.

Parameters:
key
(type=String)

value
(type=String)

SetReadOnly(self, readOnly)

Set to read only or read write.

Parameters:
readOnly
(type=bool)

SetSavePoint(self)

Remember the current position in the undo history as the position at which the document was saved.

SetScrollWidth(self, pixelWidth)

Sets the document width assumed for scrolling.

Parameters:
pixelWidth
(type=int)

SetSearchFlags(self, flags)

Set the search flags used by SearchInTarget.

Parameters:
flags
(type=int)

SetSelBackground(self, useSetting, back)

Set the background colour of the selection and whether to use this setting.

Parameters:
useSetting
(type=bool)

back
(type=Colour)

SetSelection(self, start, end)

Select a range of text.

Parameters:
start
(type=int)

end
(type=int)

SetSelectionEnd(self, pos)

Sets the position that ends the selection - this becomes the currentPosition.

Parameters:
pos
(type=int)

SetSelectionMode(self, mode)

Set the selection mode to stream (SC_SEL_STREAM) or rectangular (SC_SEL_RECTANGLE) or by lines (SC_SEL_LINES).

Parameters:
mode
(type=int)

SetSelectionStart(self, pos)

Sets the position that starts the selection - this becomes the anchor.

Parameters:
pos
(type=int)

SetSelForeground(self, useSetting, fore)

Set the foreground colour of the selection and whether to use this setting.

Parameters:
useSetting
(type=bool)

fore
(type=Colour)

SetStatus(self, statusCode)

Change error status - 0 = OK.

Parameters:
statusCode
(type=int)

SetSTCCursor(self, cursorType)

Sets the cursor to one of the SC_CURSOR* values.

Parameters:
cursorType
(type=int)

SetSTCFocus(self, focus)

Change internal focus flag.

Parameters:
focus
(type=bool)

SetStyleBits(self, bits)

Divide each styling byte into lexical class bits (default: 5) and indicator bits (default: 3). If a lexer requires more than 32 lexical states, then this is used to expand the possible states.

Parameters:
bits
(type=int)

SetStyleBytes(self, length, styleBytes)

Set the styles for a segment of the document.

Parameters:
length
(type=int)

styleBytes
(type=char)

SetStyling(self, length, style)

Change style from current styling position for length characters to a style and move the current styling position to after this newly styled segment.

Parameters:
length
(type=int)

style
(type=int)

SetTabIndents(self, tabIndents)

Sets whether a tab pressed when caret is within indentation indents.

Parameters:
tabIndents
(type=bool)

SetTabWidth(self, tabWidth)

Change the visible size of a tab to be a multiple of the width of a space character.

Parameters:
tabWidth
(type=int)

SetTargetEnd(self, pos)

Sets the position that ends the target which is used for updating the document without affecting the scroll position.

Parameters:
pos
(type=int)

SetTargetStart(self, pos)

Sets the position that starts the target which is used for updating the document without affecting the scroll position.

Parameters:
pos
(type=int)

SetText(self, text)

Replace the contents of the document with the argument text.

Parameters:
text
(type=String)

SetTextRaw(self, text)

Replace the contents of the document with the argument text. The text should be utf-8 encoded on unicode builds of wxPython, or can be any 8-bit text in ansi builds.

Parameters:
text
(type=char)

SetTextUTF8(self, text)

Replace the contents of the document with the UTF8 text given. Works 'natively' in a unicode build of wxPython, and will also work in an ansi build if the UTF8 text is compatible with the current encoding.

SetTwoPhaseDraw(self, twoPhase)

In twoPhaseDraw mode, drawing is performed in two phases, first the background and then the foreground. This avoids chopping off characters that overlap the next run.

Parameters:
twoPhase
(type=bool)

SetUndoCollection(self, collectUndo)

Choose between collecting actions into the undo history and discarding them.

Parameters:
collectUndo
(type=bool)

SetUseAntiAliasing(self, useAA)

Specify whether anti-aliased fonts should be used. Will have no effect on some platforms, but on some (wxMac for example) can greatly improve performance.

Parameters:
useAA
(type=bool)

SetUseHorizontalScrollBar(self, show)

Show or hide the horizontal scroll bar.

Parameters:
show
(type=bool)

SetUseTabs(self, useTabs)

Indentation will only use space characters if useTabs is false, otherwise it will use a combination of tabs and spaces.

Parameters:
useTabs
(type=bool)

SetUseVerticalScrollBar(self, show)

Show or hide the vertical scroll bar.

Parameters:
show
(type=bool)

SetViewEOL(self, visible)

Make the end of line characters visible or invisible.

Parameters:
visible
(type=bool)

SetViewWhiteSpace(self, viewWS)

Make white space characters invisible, always visible or visible outside indentation.

Parameters:
viewWS
(type=int)

SetVisiblePolicy(self, visiblePolicy, visibleSlop)

Set the way the display area is determined when a particular line is to be moved to by Find, FindNext, GotoLine, etc.

Parameters:
visiblePolicy
(type=int)

visibleSlop
(type=int)

SetVScrollBar(self, bar)

Set the vertical scrollbar to use instead of the one that's built-in.

Parameters:
bar
(type=wxScrollBar)

SetWhitespaceBackground(self, useSetting, back)

Set the background colour of all whitespace and whether to use this setting.

Parameters:
useSetting
(type=bool)

back
(type=Colour)

SetWhitespaceChars(self, characters)

Set the set of characters making up whitespace for when moving or selecting by word. Should be called after SetWordChars.

Parameters:
characters
(type=String)

SetWhitespaceForeground(self, useSetting, fore)

Set the foreground colour of all whitespace and whether to use this setting.

Parameters:
useSetting
(type=bool)

fore
(type=Colour)

SetWordChars(self, characters)

Set the set of characters making up words for when moving or selecting by word. First sets deaults like SetCharsDefault.

Parameters:
characters
(type=String)

SetWrapMode(self, mode)

Sets whether text is word wrapped.

Parameters:
mode
(type=int)

SetWrapStartIndent(self, indent)

Set the start indent for wrapped lines.

Parameters:
indent
(type=int)

SetWrapVisualFlags(self, wrapVisualFlags)

Set the display mode of visual flags for wrapped lines.

Parameters:
wrapVisualFlags
(type=int)

SetWrapVisualFlagsLocation(self, wrapVisualFlagsLocation)

Set the location of visual flags for wrapped lines.

Parameters:
wrapVisualFlagsLocation
(type=int)

SetXCaretPolicy(self, caretPolicy, caretSlop)

Set the way the caret is kept visible when going sideway. The exclusion zone is given in pixels.

Parameters:
caretPolicy
(type=int)

caretSlop
(type=int)

SetXOffset(self, newOffset)

Get and Set the xOffset (ie, horizonal scroll position).

Parameters:
newOffset
(type=int)

SetYCaretPolicy(self, caretPolicy, caretSlop)

Set the way the line the caret is on is kept visible. The exclusion zone is given in lines.

Parameters:
caretPolicy
(type=int)

caretSlop
(type=int)

SetZoom(self, zoom)

Set the zoom level. This number of points is added to the size of all fonts. It may be positive to magnify or negative to reduce.

Parameters:
zoom
(type=int)

ShowLines(self, lineStart, lineEnd)

Make a range of lines visible.

Parameters:
lineStart
(type=int)

lineEnd
(type=int)

StartRecord(self)

Start notifying the container of all key presses and commands.

StartStyling(self, pos, mask)

Set the current styling position to pos and the styling mask to mask. The styling mask can be used to protect some bits in each styling byte from modification.

Parameters:
pos
(type=int)

mask
(type=int)

StopRecord(self)

Stop notifying the container of all key presses and commands.

StutteredPageDown(self)

Move caret to bottom of page, or one page down if already at bottom of page.

StutteredPageDownExtend(self)

Move caret to bottom of page, or one page down if already at bottom of page, extending selection to new caret position.

StutteredPageUp(self)

Move caret to top of page, or one page up if already at top of page.

StutteredPageUpExtend(self)

Move caret to top of page, or one page up if already at top of page, extending selection to new caret position.

StyleClearAll(self)

Clear all the styles and make equivalent to the global default style.

StyleResetDefault(self)

Reset the default style to its state at startup

StyleSetBackground(self, style, back)

Set the background colour of a style.

Parameters:
style
(type=int)

back
(type=Colour)

StyleSetBold(self, style, bold)

Set a style to be bold or not.

Parameters:
style
(type=int)

bold
(type=bool)

StyleSetCase(self, style, caseForce)

Set a style to be mixed case, or to force upper or lower case.

Parameters:
style
(type=int)

caseForce
(type=int)

StyleSetChangeable(self, style, changeable)

Set a style to be changeable or not (read only). Experimental feature, currently buggy.

Parameters:
style
(type=int)

changeable
(type=bool)

StyleSetCharacterSet(self, style, characterSet)

Set the character set of the font in a style. Converts the Scintilla wx.stc.STC_CHARSET_* set values to a wxFontEncoding.

Parameters:
style
(type=int)

characterSet
(type=int)

StyleSetEOLFilled(self, style, filled)

Set a style to have its end of line filled or not.

Parameters:
style
(type=int)

filled
(type=bool)

StyleSetFaceName(self, style, fontName)

Set the font of a style.

Parameters:
style
(type=int)

fontName
(type=String)

StyleSetFont(self, styleNum, font)

Set style size, face, bold, italic, and underline attributes from the attributes of a wx.Font.

Parameters:
styleNum
(type=int)

font
(type=Font)

StyleSetFontAttr(self, styleNum, size, faceName, bold, italic, underline, encoding=wxFONTENCODING_DEFAULT)

Set all font style attributes at once.

Parameters:
styleNum
(type=int)

size
(type=int)

faceName
(type=String)

bold
(type=bool)

italic
(type=bool)

underline
(type=bool)

encoding
(type=int)

StyleSetFontEncoding(self, style, encoding)

Set the font encoding to be used by a style.

Parameters:
style
(type=int)

encoding
(type=int)

StyleSetForeground(self, style, fore)

Set the foreground colour of a style.

Parameters:
style
(type=int)

fore
(type=Colour)

StyleSetHotSpot(self, style, hotspot)

Set a style to be a hotspot or not.

Parameters:
style
(type=int)

hotspot
(type=bool)

StyleSetItalic(self, style, italic)

Set a style to be italic or not.

Parameters:
style
(type=int)

italic
(type=bool)

StyleSetSize(self, style, sizePoints)

Set the size of characters of a style.

Parameters:
style
(type=int)

sizePoints
(type=int)

StyleSetSpec(self, styleNum, spec)

Extract style settings from a spec-string which is composed of one or more of the following comma separated elements:

bold                    turns on bold
italic                  turns on italics
fore:[name or #RRGGBB]  sets the foreground colour
back:[name or #RRGGBB]  sets the background colour
face:[facename]         sets the font face name to use
size:[num]              sets the font size in points
eol                     turns on eol filling
underline               turns on underlining
Parameters:
styleNum
(type=int)

spec
(type=String)

StyleSetUnderline(self, style, underline)

Set a style to be underlined or not.

Parameters:
style
(type=int)

underline
(type=bool)

StyleSetVisible(self, style, visible)

Set a style to be visible or not.

Parameters:
style
(type=int)

visible
(type=bool)

Tab(self)

If selection is empty or all on one line replace the selection with a tab character. If more than one line selected, indent the lines.

TargetFromSelection(self)

Make the target range start and end be the same as the selection range start and end.

TextHeight(self, line)

Retrieve the height of a particular line of text in pixels.

Parameters:
line
(type=int)

Returns:
int

TextWidth(self, style, text)

Measure the pixel width of some text in a particular style. NUL terminated text argument. Does not handle tab or control characters.

Parameters:
style
(type=int)

text
(type=String)

Returns:
int

ToggleFold(self, line)

Switch a header line between expanded and contracted.

Parameters:
line
(type=int)

Undo(self)

Undo one action in the undo history.

UpperCase(self)

Transform the selection to upper case.

UsePopUp(self, allowPopUp)

Set whether a pop up menu is displayed automatically when the user presses the wrong mouse button.

Parameters:
allowPopUp
(type=bool)

UserListShow(self, listType, itemList)

Display a list of strings and send notification when user chooses one.

Parameters:
listType
(type=int)

itemList
(type=String)

VCHome(self)

Move caret to before first visible character on line. If already there move to first character on line.

VCHomeExtend(self)

Like VCHome but extending selection to new caret position.

VCHomeRectExtend(self)

Move caret to before first visible character on line. If already there move to first character on line. In either case, extend rectangular selection to new caret position.

VisibleFromDocLine(self, line)

Find the display line of a document line taking hidden lines into account.

Parameters:
line
(type=int)

Returns:
int

WordEndPosition(self, pos, onlyWordCharacters)

Get position of end of word.

Parameters:
pos
(type=int)

onlyWordCharacters
(type=bool)

Returns:
int

WordLeft(self)

Move caret left one word.

WordLeftEnd(self)

Move caret left one word, position cursor at end of word.

WordLeftEndExtend(self)

Move caret left one word, position cursor at end of word, extending selection to new caret position.

WordLeftExtend(self)

Move caret left one word extending selection to new caret position.

WordPartLeft(self)

Move to the previous change in capitalisation.

WordPartLeftExtend(self)

Move to the previous change in capitalisation extending selection to new caret position.

WordPartRight(self)

Move to the change next in capitalisation.

WordPartRightExtend(self)

Move to the next change in capitalisation extending selection to new caret position.

WordRight(self)

Move caret right one word.

WordRightEnd(self)

Move caret right one word, position cursor at end of word.

WordRightEndExtend(self)

Move caret right one word, position cursor at end of word, extending selection to new caret position.

WordRightExtend(self)

Move caret right one word extending selection to new caret position.

WordStartPosition(self, pos, onlyWordCharacters)

Get position of start of word.

Parameters:
pos
(type=int)

onlyWordCharacters
(type=bool)

Returns:
int

ZoomIn(self)

Magnify the displayed text by increasing the sizes by 1 point.

ZoomOut(self)

Make the displayed text smaller by decreasing the sizes by 1 point.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:36 2005 http://epydoc.sf.net


wx.stc.StyledTextEvent

Package wx :: Module stc :: Class StyledTextEvent

Type StyledTextEvent

object --+
         |
    Object --+
             |
         Event --+
                 |
      CommandEvent --+
                     |
                    StyledTextEvent

Proxy of C++ StyledTextEvent class

Method Summary
CommandEvent | __init__(self, commandType, winid) This event class contains information about command events, which originate from a variety of simple controls, as well as menus and toolbars.
 | __del__(self)
 | __repr__(self)
Event | Clone(self)
bool | GetAlt(self)
bool | GetControl(self)
bool | GetDragAllowMove(self)
int | GetDragResult(self)
String | GetDragText(self)
int | GetFoldLevelNow(self)
int | GetFoldLevelPrev(self)
int | GetKey(self)
int | GetLength(self)
int | GetLine(self)
int | GetLinesAdded(self)
int | GetListType(self)
int | GetLParam(self)
int | GetMargin(self)
int | GetMessage(self)
int | GetModificationType(self)
int | GetModifiers(self)
int | GetPosition(self)
bool | GetShift(self)
String | GetText(self)
int | GetWParam(self)
int | GetX(self)
int | GetY(self)
 | SetDragAllowMove(self, val)
 | SetDragResult(self, val)
 | SetDragText(self, val)
 | SetFoldLevelNow(self, val)
 | SetFoldLevelPrev(self, val)
 | SetKey(self, k)
 | SetLength(self, len)
 | SetLine(self, val)
 | SetLinesAdded(self, num)
 | SetListType(self, val)
 | SetLParam(self, val)
 | SetMargin(self, val)
 | SetMessage(self, val)
 | SetModificationType(self, t)
 | SetModifiers(self, m)
 | SetPosition(self, pos)
 | SetText(self, t)
 | SetWParam(self, val)
 | SetX(self, val)
 | SetY(self, val)

Method Details

__init__(self, commandType=0, id=0)
(Constructor)

This event class contains information about command events, which originate from a variety of simple controls, as well as menus and toolbars.

Parameters:
commandType
(type=wxEventType)

winid
(type=int)

Returns:
CommandEvent
Overrides:
wx.CommandEvent.__init__ (inherited documentation)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:51 2005 http://epydoc.sf.net


wx.stc

Package wx :: Module stc

Module wx.stc

The StyledTextCtrl provides a text editor that can used as a syntax highlighting source code editor, or similar. Lexers for several programming languages are built-in.

Classes
StyledTextCtrl | Proxy of C++ StyledTextCtrl class
StyledTextEvent | Proxy of C++ StyledTextEvent class

Function Summary
StyledTextCtrl PreStyledTextCtrl()

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:59 2005 http://epydoc.sf.net


wx.StdDialogButtonSizer

Package wx :: Class StdDialogButtonSizer

Type StdDialogButtonSizer

object --+
         |
    Object --+
             |
         Sizer --+
                 |
          BoxSizer --+
                     |
                    StdDialogButtonSizer

A special sizer that knows how to order and position standard buttons in order to conform to the current platform's standards. You simply need to add each wx.Button to the sizer, and be sure to create the buttons using the standard ID's. Then call Realize and the sizer will take care of the rest.

Method Summary
BoxSizer | __init__(self, orient) Constructor for a wx.BoxSizer.
 | __repr__(self)
 | AddButton(self, button) Use this to add the buttons to this sizer.
wxButton | GetAffirmativeButton(self)
wxButton | GetApplyButton(self)
wxButton | GetCancelButton(self)
wxButton | GetHelpButton(self)
wxButton | GetNegativeButton(self)
 | Realize(self) This funciton needs to be called after all the buttons have been added to the sizer.
 | SetAffirmativeButton(self, button)
 | SetCancelButton(self, button)
 | SetNegativeButton(self, button)

Method Details

__init__(self)
(Constructor)

Constructor for a wx.BoxSizer. orient may be one of wx.VERTICAL or wx.HORIZONTAL for creating either a column sizer or a row sizer.

Parameters:
orient
(type=int)

Returns:
BoxSizer
Overrides:
wx.BoxSizer.__init__ (inherited documentation)

AddButton(self, button)

Use this to add the buttons to this sizer. Do not use the Add method in the base class.

Parameters:
button
(type=wxButton)

Realize(self)

This funciton needs to be called after all the buttons have been added to the sizer. It will reorder them and position them in a platform specifc manner.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:05 2005 http://epydoc.sf.net


wx.StopWatch

Package wx :: Class StopWatch

Type StopWatch

object --+
         |
        StopWatch

Proxy of C++ StopWatch class

Method Summary
StopWatch | __init__(self)
 | __repr__(self)
 | Pause(self)
 | Resume(self)
 | Start(self, t0)
long | Time(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:17 2005 http://epydoc.sf.net


wx.SysColourChangedEvent

Package wx :: Class SysColourChangedEvent

Type SysColourChangedEvent

object --+
         |
    Object --+
             |
         Event --+
                 |
                SysColourChangedEvent

This class is used for EVT_SYS_COLOUR_CHANGED, which are generated when the user changes the colour settings using the control panel. This is only applicable under Windows.

The default event handler for this event propagates the event to child windows, since Windows only sends the events to top-level windows. If intercepting this event for a top-level window, remember to call Skip so the the base class handler will still be executed, or to pass the event on to the window's children explicitly.

Method Summary
SysColourChangedEvent | __init__(self) Constructor
 | __repr__(self)

Method Details

__init__(self)
(Constructor)

Constructor

Returns:
SysColourChangedEvent
Overrides:
wx.Event.__init__

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:32 2005 http://epydoc.sf.net


wx.SystemOptions

Package wx :: Class SystemOptions

Type SystemOptions

object --+
         |
    Object --+
             |
            SystemOptions

Proxy of C++ SystemOptions class

Method Summary
SystemOptions | __init__(self)
 | __repr__(self)
String | GetOption(name) (Static method)
int | GetOptionInt(name) (Static method)
bool | HasOption(name) (Static method)
bool | IsFalse(name) (Static method)
 | SetOption(name, value) (Static method)
 | SetOptionInt(name, value) (Static method)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:58 2005 http://epydoc.sf.net


wx.SystemSettings

Package wx :: Class SystemSettings

Type SystemSettings

object --+
         |
        SystemSettings

Proxy of C++ SystemSettings class

Method Summary
 | __init__(self)
 | __repr__(self)
Colour | GetColour(index) (Static method)
Font | GetFont(index) (Static method)
int | GetMetric(index, win) (Static method)
int | GetScreenType() (Static method)
bool | HasFeature(index) (Static method)
 | SetScreenType(screen) (Static method)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:04 2005 http://epydoc.sf.net


wx.TaskBarIcon

Package wx :: Class TaskBarIcon

Type TaskBarIcon

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
                TaskBarIcon

Proxy of C++ TaskBarIcon class

Method Summary
TaskBarIcon | __init__(self)
 | __nonzero__(self)
 | __repr__(self)
 | Destroy(self) Deletes the C++ object this Python object is a proxy for.
bool | IsIconInstalled(self)
bool | IsOk(self)
bool | PopupMenu(self, menu)
bool | RemoveIcon(self)
bool | SetIcon(self, icon, tooltip)

Method Details

Destroy(self)

Deletes the C++ object this Python object is a proxy for.

Overrides:
wx.Object.Destroy

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:10:53 2005 http://epydoc.sf.net


wx.TaskBarIconEvent

Package wx :: Class TaskBarIconEvent

Type TaskBarIconEvent

object --+
         |
    Object --+
             |
         Event --+
                 |
                TaskBarIconEvent

Proxy of C++ TaskBarIconEvent class

Method Summary
TaskBarIconEvent | __init__(self, evtType, tbIcon)
 | __repr__(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:31 2005 http://epydoc.sf.net


wx.TextAttr

Package wx :: Class TextAttr

Type TextAttr

object --+
         |
        TextAttr

Proxy of C++ TextAttr class

Method Summary
TextAttr | __init__(self, colText, colBack, font, alignment)
 | __del__(self)
 | __repr__(self)
TextAttr | Combine(attr, attrDef, text) (Static method)
int | GetAlignment(self)
Colour | GetBackgroundColour(self)
long | GetFlags(self)
Font | GetFont(self)
long | GetLeftIndent(self)
long | GetLeftSubIndent(self)
long | GetRightIndent(self)
wxArrayInt | GetTabs(self)
Colour | GetTextColour(self)
bool | HasAlignment(self)
bool | HasBackgroundColour(self)
bool | HasFlag(self, flag)
bool | HasFont(self)
bool | HasLeftIndent(self)
bool | HasRightIndent(self)
bool | HasTabs(self)
bool | HasTextColour(self)
 | Init(self)
bool | IsDefault(self)
 | SetAlignment(self, alignment)
 | SetBackgroundColour(self, colBack)
 | SetFlags(self, flags)
 | SetFont(self, font, flags)
 | SetLeftIndent(self, indent, subIndent)
 | SetRightIndent(self, indent)
 | SetTabs(self, tabs)
 | SetTextColour(self, colText)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:04 2005 http://epydoc.sf.net


wx.TextCtrl

Package wx :: Class TextCtrl

Type TextCtrl

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
               Control --+
                         |
                        TextCtrl

Known Subclasses:
BaseMaskedTextCtrl, Calltip, CTextCellEditor, DispatcherListing, IntCtrl, RightTextCtrl, SessionListing

Proxy of C++ TextCtrl class

Method Summary
Control __init__(self, parent, id, pos, size, style, validator, name)
Create a Control.
__repr__(self)
AppendText(self, text)
bool | CanCopy(self)
bool | CanCut(self)
bool | CanPaste(self)
bool | CanRedo(self)
bool | CanUndo(self)
Clear(self)
Copy(self)
bool Create(self, parent, id, pos, size, style, validator, name)
Do the 2nd phase and create the GUI control.
Cut(self)
DiscardEdits(self)
bool | EmulateKeyPress(self, event)
VisualAttributes GetClassDefaultAttributes(variant)
Get the default attributes for this class. (Static method)
TextAttr | GetDefaultStyle(self)
long | GetInsertionPoint(self)
long | GetLastPosition(self)
int | GetLineLength(self, lineNo)
String | GetLineText(self, lineNo)
int | GetNumberOfLines(self)
String | GetRange(self, from, to)
(from, to) GetSelection()
If the return values from and to are the same, there is no selection.
String | GetString(self, from, to)
String | GetStringSelection(self)
bool | GetStyle(self, position, style)
String | GetValue(self)
(result, col, row) HitTest(pt)
Find the row, col coresponding to the character at the point given in pixels.
(result, position) HitTestPos(pt)
Find the character position in the text coresponding to the point given in pixels.
bool | IsEditable(self)
bool | IsModified(self)
bool | IsMultiLine(self)
bool | IsSingleLine(self)
bool | LoadFile(self, file)
MarkDirty(self)
Paste(self)
(x, y) | PositionToXY(pos)
Redo(self)
Remove(self, from, to)
Replace(self, from, to, value)
bool | SaveFile(self, file)
SelectAll(self)
bool | SetDefaultStyle(self, style)
SetEditable(self, editable)
SetInsertionPoint(self, pos)
SetInsertionPointEnd(self)
SetMaxLength(*args, **kwargs)
SetMaxLength(self, unsigned long len)
SetSelection(self, from, to)
bool | SetStyle(self, start, end, style)
SetValue(self, value)
ShowPosition(self, pos)
Undo(self)
write(self, text)
WriteText(self, text)
long | XYToPosition(self, x, y)

Instance Method Details

__init__(self,
          parent,
          id=-1,
          value=EmptyString,
          pos=DefaultPosition,
          size=DefaultSize,
          style=0,
          validator=DefaultValidator,
          name=TextCtrlNameStr)
(Constructor)

Create a Control. Normally you should only call this from a subclass' __init__ as a plain old wx.Control is not very useful.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

validator
(type=Validator)

name
(type=String)

Returns:
Control
Overrides:
wx.Control.__init__ (inherited documentation)

Create(self,
          parent,
          id=-1,
          value=EmptyString,
          pos=DefaultPosition,
          size=DefaultSize,
          style=0,
          validator=DefaultValidator,
          name=TextCtrlNameStr)

Do the 2nd phase and create the GUI control.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

validator
(type=Validator)

name
(type=String)

Returns:
bool
Overrides:
wx.Control.Create (inherited documentation)

GetSelection()

If the return values from and to are the same, there is no selection.

Returns:
(from, to)

HitTest(pt)

Find the row, col coresponding to the character at the point given in pixels. NB: pt is in device coords but is not adjusted for the client area origin nor scrolling.

Parameters:
pt
(type=Point)

Returns:
(result, col, row)
Overrides:
wx.Window.HitTest

HitTestPos(pt)

Find the character position in the text coresponding to the point given in pixels. NB: pt is in device coords but is not adjusted for the client area origin nor scrolling.

Parameters:
pt
(type=Point)

Returns:
(result, position)

SetMaxLength(*args, **kwargs)

SetMaxLength(self, unsigned long len)

Static Method Details

GetClassDefaultAttributes(variant=WINDOW_VARIANT_NORMAL)

Get the default attributes for this class. This is useful if you want to use the same font or colour in your own control as in a standard control -- which is a much better idea than hard coding specific colours or fonts which might look completely out of place on the user's system, especially if it uses themes.

The variant parameter is only relevant under Mac currently and is ignore under other platforms. Under Mac, it will change the size of the returned font. See wx.Window.SetWindowVariant for more about this.

Parameters:
variant
(type=int)

Returns:
VisualAttributes

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:42 2005 http://epydoc.sf.net


wx.TextDataObject

Package wx :: Class TextDataObject

Type TextDataObject

  object --+
           |
  DataObject --+
               |
DataObjectSimple --+
                   |
                  TextDataObject

Known Subclasses:
PyTextDataObject

wx.TextDataObject is a specialization of wx.DataObject for text data. It can be used without change to paste data into the wx.Clipboard or a wx.DropSource.

Alternativly, you may wish to derive a new class from the wx.PyTextDataObject class for providing text on-demand in order to minimize memory consumption when offering data in several formats, such as plain text and RTF, because by default the text is stored in a string in this class, but it might as well be generated on demand when requested. For this, GetTextLength and GetText will have to be overridden.

Method Summary
TextDataObject | __init__(self, text) Constructor, may be used to initialise the text (otherwise SetText should be used later).
 | __repr__(self)
String | GetText(self) Returns the text associated with the data object.
size_t | GetTextLength(self) Returns the data size.
 | SetText(self, text) Sets the text associated with the data object.

Class Variable Summary

Method Details

__init__(self, text=EmptyString)
(Constructor)

Constructor, may be used to initialise the text (otherwise SetText should be used later).

Parameters:
text
(type=String)

Returns:
TextDataObject
Overrides:
wx.DataObjectSimple.__init__

GetText(self)

Returns the text associated with the data object.

Returns:
String

GetTextLength(self)

Returns the data size. By default, returns the size of the text data set in the constructor or using SetText. This can be overridden (via wx.PyTextDataObject) to provide text size data on-demand. It is recommended to return the text length plus 1 for a trailing zero, but this is not strictly required.

Returns:
size_t

SetText(self, text)

Sets the text associated with the data object. This method is called when the data object receives the data and, by default, copies the text into the member variable. If you want to process the text on the fly you may wish to override this function (via wx.PyTextDataObject.)

Parameters:
text
(type=String)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:10 2005 http://epydoc.sf.net


wx.TextDropTarget

Package wx :: Class TextDropTarget

Type TextDropTarget

object --+
         |
DropTarget --+
             |
            TextDropTarget

Proxy of C++ TextDropTarget class

Method Summary
TextDropTarget | __init__(self)
 | __repr__(self)
int | base_OnData(self, x, y, def)
int | base_OnDragOver(self, x, y, def)
bool | base_OnDrop(self, x, y)
int | base_OnEnter(self, x, y, def)
 | base_OnLeave(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:33 2005 http://epydoc.sf.net


wx.TextEntryDialog

Package wx :: Class TextEntryDialog

Type TextEntryDialog

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
        TopLevelWindow --+
                         |
                    Dialog --+
                             |
                            TextEntryDialog

Known Subclasses:
PasswordEntryDialog

A dialog with text control, [ok] and [cancel] buttons

Method Summary
TextEntryDialog | __init__(self, parent, message, caption, defaultValue, style, pos) Constructor.
 | __repr__(self)
String | GetValue(self) Returns the text that the user has entered if the user has pressed OK, or the original value if the user has pressed Cancel.
 | SetValue(self, value) Sets the default text value.

Instance Method Details

__init__(self, parent, message, caption=GetTextFromUserPromptStr, defaultValue=EmptyString, style=TextEntryDialogStyle, pos=DefaultPosition)
(Constructor)

Constructor. Use ShowModal method to show the dialog.

Parameters:
parent
(type=Window)

message
(type=String)

caption
(type=String)

defaultValue
(type=String)

style
(type=long)

pos
(type=Point)

Returns:
TextEntryDialog
Overrides:
wx.Dialog.__init__

GetValue(self)

Returns the text that the user has entered if the user has pressed OK, or the original value if the user has pressed Cancel.

Returns:
String

SetValue(self, value)

Sets the default text value.

Parameters:
value
(type=String)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:26 2005 http://epydoc.sf.net


wx.TextUrlEvent

Package wx :: Class TextUrlEvent

Type TextUrlEvent

object --+
         |
    Object --+
             |
         Event --+
                 |
      CommandEvent --+
                     |
                    TextUrlEvent

Proxy of C++ TextUrlEvent class

Method Summary
CommandEvent | __init__(self, commandType, winid) This event class contains information about command events, which originate from a variety of simple controls, as well as menus and toolbars.
 | __repr__(self)
MouseEvent | GetMouseEvent(self)
long | GetURLEnd(self)
long | GetURLStart(self)

Method Details

__init__(self, winid, evtMouse, start, end)
(Constructor)

This event class contains information about command events, which originate from a variety of simple controls, as well as menus and toolbars.

Parameters:
commandType
(type=wxEventType)

winid
(type=int)

Returns:
CommandEvent
Overrides:
wx.CommandEvent.__init__ (inherited documentation)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:17 2005 http://epydoc.sf.net


wx.TIFFHandler

Package wx :: Class TIFFHandler

Type TIFFHandler

object --+
         |
    Object --+
             |
  ImageHandler --+
                 |
                TIFFHandler

A wx.ImageHandler for TIFF image files.

Method Summary
TIFFHandler | __init__(self) A wx.ImageHandler for TIFF image files.
 | __repr__(self)

Method Details

__init__(self)
(Constructor)

A wx.ImageHandler for TIFF image files.

Returns:
TIFFHandler
Overrides:
wx.ImageHandler.__init__

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:03 2005 http://epydoc.sf.net


wx.Timer

Package wx :: Class Timer

Type Timer

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
                Timer

Known Subclasses:
PyTimer

Proxy of C++ Timer class

Method Summary
Timer | __init__(self, owner, id)
 | __del__(self)
 | __repr__(self)
 | Destroy(self) NO-OP: Timers must be destroyed by normal refrence counting
int | GetId(self)
int | GetInterval(self)
EvtHandler | GetOwner(self)
bool | IsOneShot(self)
bool | IsRunning(self)
 | SetOwner(self, owner, id)
bool | Start(self, milliseconds, oneShot)
 | Stop(self)

Method Details

Destroy(self)

NO-OP: Timers must be destroyed by normal refrence counting

Overrides:
wx.Object.Destroy

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:15 2005 http://epydoc.sf.net


wx.TimerEvent

Package wx :: Class TimerEvent

Type TimerEvent

object --+
         |
    Object --+
             |
         Event --+
                 |
                TimerEvent

Proxy of C++ TimerEvent class

Method Summary
TimerEvent | __init__(self, timerid, interval)
 | __repr__(self)
int | GetInterval(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:56 2005 http://epydoc.sf.net


wx.TimerRunner

Package wx :: Class TimerRunner

Type TimerRunner

object --+
         |
        TimerRunner

Proxy of C++ TimerRunner class

Method Summary
TimerRunner __init__(self, timer)
__init__(self, wxTimer timer, int milli, bool oneShot=False) -> TimerRunner
__del__(self)
__repr__(self)
Start(self, milli, oneShot)

Method Details

__init__(self, timer)
(Constructor)

__init__(self, wxTimer timer, int milli, bool oneShot=False) -> TimerRunner

Parameters:
timer
(type=wxTimer)

Returns:
TimerRunner
Overrides:
__builtin__.object.__init__

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:10:47 2005 http://epydoc.sf.net


wx.TimeSpan

Package wx :: Class TimeSpan

Type TimeSpan

object --+
         |
        TimeSpan

Proxy of C++ TimeSpan class

Method Summary
TimeSpan | __init__(self, hours, minutes, seconds, milliseconds)
TimeSpan | __add__(self, other)
 | __del__(self)
bool | __eq__(self, other)
bool | __ge__(self, other)
bool | __gt__(self, other)
TimeSpan | __iadd__(self, diff)
TimeSpan | __imul__(self, n)
TimeSpan | __isub__(self, diff)
bool | __le__(self, other)
bool | __lt__(self, other)
TimeSpan | __mul__(self, n)
bool | __ne__(self, other)
TimeSpan | __neg__(self)
 | __repr__(self)
TimeSpan | __rmul__(self, n)
 | __str__(self)
TimeSpan | __sub__(self, other)
TimeSpan | Abs(self)
TimeSpan | Add(self, diff)
TimeSpan | Day() (Static method)
TimeSpan | Days(days) (Static method)
String | Format(self, format)
int | GetDays(self)
int | GetHours(self)
wxLongLong | GetMilliseconds(self)
int | GetMinutes(self)
wxLongLong | GetSeconds(self)
int | GetWeeks(self)
TimeSpan | Hour() (Static method)
TimeSpan | Hours(hours) (Static method)
bool | IsEqualTo(self, ts)
bool | IsLongerThan(self, ts)
bool | IsNegative(self)
bool | IsNull(self)
bool | IsPositive(self)
bool | IsShorterThan(self, t)
TimeSpan | Minute() (Static method)
TimeSpan | Minutes(min) (Static method)
TimeSpan | Multiply(self, n)
TimeSpan | Neg(self)
TimeSpan | Second() (Static method)
TimeSpan | Seconds(sec) (Static method)
TimeSpan | Subtract(self, diff)
TimeSpan | Week() (Static method)
TimeSpan | Weeks(days) (Static method)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:10:55 2005 http://epydoc.sf.net


wx.TipProvider

Package wx :: Class TipProvider

Type TipProvider

object --+
         |
        TipProvider

Known Subclasses:
PyTipProvider

Proxy of C++ TipProvider class

Method Summary
 | __init__(self)
 | __del__(self)
 | __repr__(self)
size_t | GetCurrentTip(self)
String | GetTip(self)
String | PreprocessTip(self, tip)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:58 2005 http://epydoc.sf.net


wx.TipWindow

Package wx :: Class TipWindow

Type TipWindow

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
           PopupWindow --+
                         |
      PopupTransientWindow --+
                             |
                            TipWindow

Proxy of C++ TipWindow class

Method Summary
Window | __init__(self, parent, id, pos, size, style, name) Construct and show a generic Window.
 | __repr__(self)
 | Close(self) This function simply generates a EVT_CLOSE event whose handler usually tries to close the window.
 | SetBoundingRect(self, rectBound)

Instance Method Details

__init__(self, parent, text, maxLength=100, rectBound=None)
(Constructor)

Construct and show a generic Window.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

name
(type=String)

Returns:
Window
Overrides:
wx.PopupTransientWindow.__init__ (inherited documentation)

Close(self)

This function simply generates a EVT_CLOSE event whose handler usually tries to close the window. It doesn't close the window itself, however. If force is False (the default) then the window's close handler will be allowed to veto the destruction of the window. Usually Close is only used with the top level windows (wx.Frame and wx.Dialog classes) as the others are not supposed to have any special EVT_CLOSE logic.

The close handler should check whether the window is being deleted forcibly, using wx.CloseEvent.GetForce, in which case it should destroy the window using wx.Window.Destroy.

Note that calling Close does not guarantee that the window will be destroyed; but it provides a way to simulate a manual close of a window, which may or may not be implemented by destroying the window. The default EVT_CLOSE handler for wx.Dialog does not necessarily delete the dialog, since it will simply simulate an wxID_CANCEL event which is handled by the appropriate button event handler and may do anything at all.

To guarantee that the window will be destroyed, call wx.Window.Destroy instead.

Overrides:
wx.Window.Close

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:17 2005 http://epydoc.sf.net


wx.ToggleButton

Package wx :: Class ToggleButton

Type ToggleButton

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
               Control --+
                         |
                        ToggleButton

Proxy of C++ ToggleButton class

Method Summary
Control | __init__(self, parent, id, pos, size, style, validator, name) Create a Control.
 | __repr__(self)
bool | Create(self, parent, id, pos, size, style, validator, name) Do the 2nd phase and create the GUI control.
VisualAttributes | GetClassDefaultAttributes(variant) Get the default attributes for this class. (Static method)
bool | GetValue(self)
 | SetLabel(self, label) Sets the item's text.
 | SetValue(self, value)

Instance Method Details

__init__(self,
          parent,
          id=-1,
          label=EmptyString,
          pos=DefaultPosition,
          size=DefaultSize,
          style=0,
          validator=DefaultValidator,
          name=ToggleButtonNameStr)
(Constructor)

Create a Control. Normally you should only call this from a subclass' __init__ as a plain old wx.Control is not very useful.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

validator
(type=Validator)

name
(type=String)

Returns:
Control
Overrides:
wx.Control.__init__ (inherited documentation)

Create(self,
          parent,
          id=-1,
          label=EmptyString,
          pos=DefaultPosition,
          size=DefaultSize,
          style=0,
          validator=DefaultValidator,
          name=ToggleButtonNameStr)

Do the 2nd phase and create the GUI control.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

validator
(type=Validator)

name
(type=String)

Returns:
bool
Overrides:
wx.Control.Create (inherited documentation)

SetLabel(self, label)

Sets the item's text.

Parameters:
label
(type=String)

Overrides:
wx.Control.SetLabel

Static Method Details

GetClassDefaultAttributes(variant=WINDOW_VARIANT_NORMAL)

Get the default attributes for this class. This is useful if you want to use the same font or colour in your own control as in a standard control -- which is a much better idea than hard coding specific colours or fonts which might look completely out of place on the user's system, especially if it uses themes.

The variant parameter is only relevant under Mac currently and is ignore under other platforms. Under Mac, it will change the size of the returned font. See wx.Window.SetWindowVariant for more about this.

Parameters:
variant
(type=int)

Returns:
VisualAttributes

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:51 2005 http://epydoc.sf.net


wx.ToolBarBase

Package wx :: Class ToolBarBase

Type ToolBarBase

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
               Control --+
                         |
                        ToolBarBase

Known Subclasses:
ToolBar

Proxy of C++ ToolBarBase class

Method Summary
__init__(self)
__repr__(self)
AddCheckLabelTool(self, id, label, bitmap, bmpDisabled, shortHelp, longHelp, clientData)
Add a check tool, i.e.
AddCheckTool(self, id, bitmap, bmpDisabled, shortHelp, longHelp, clientData)
Add a check tool, i.e.
ToolBarToolBase | AddControl(self, control)
AddLabelTool(self, id, label, bitmap, bmpDisabled, kind, shortHelp, longHelp, clientData)
The full AddTool() function.
AddRadioLabelTool(self, id, label, bitmap, bmpDisabled, shortHelp, longHelp, clientData)
Add a radio tool, i.e.
AddRadioTool(self, id, bitmap, bmpDisabled, shortHelp, longHelp, clientData)
Add a radio tool, i.e.
ToolBarToolBase | AddSeparator(self)
AddSimpleTool(self, id, bitmap, shortHelpString, longHelpString, isToggle)
Old style method to add a tool to the toolbar.
AddTool(self, id, bitmap, pushedBitmap, isToggle, clientData, shortHelpString, longHelpString)
Old style method to add a tool to the toolbar.
ToolBarToolBase | AddToolItem(self, tool)
ClearTools(self)
bool | DeleteTool(self, id)
bool | DeleteToolByPos(self, pos)
ToolBarToolBase | DoAddTool(self, id, label, bitmap, bmpDisabled, kind, shortHelp, longHelp, clientData)
ToolBarToolBase | DoInsertTool(self, pos, id, label, bitmap, bmpDisabled, kind, shortHelp, longHelp, clientData)
EnableTool(self, id, enable)
ToolBarToolBase | FindById(self, toolid)
Control | FindControl(self, id)
ToolBarToolBase | FindToolForPosition(self, x, y)
Size | GetMargins(self)
int | GetMaxCols(self)
int | GetMaxRows(self)
Size | GetToolBitmapSize(self)
PyObject | GetToolClientData(self, id)
bool | GetToolEnabled(self, id)
String | GetToolLongHelp(self, id)
Size | GetToolMargins(self)
int | GetToolPacking(self)
int | GetToolPos(self, id)
int | GetToolSeparation(self)
String | GetToolShortHelp(self, id)
Size | GetToolSize(self)
bool | GetToolState(self, id)
ToolBarToolBase | InsertControl(self, pos, control)
InsertLabelTool(self, pos, id, label, bitmap, bmpDisabled, kind, shortHelp, longHelp, clientData)
Insert the new tool at the given position, if pos == GetToolsCount(), it is equivalent to AddTool()
ToolBarToolBase | InsertSeparator(self, pos)
InsertSimpleTool(self, pos, id, bitmap, shortHelpString, longHelpString, isToggle)
Old style method to insert a tool in the toolbar.
InsertTool(self, pos, id, bitmap, pushedBitmap, isToggle, clientData, shortHelpString, longHelpString)
Old style method to insert a tool in the toolbar.
ToolBarToolBase | InsertToolItem(self, pos, tool)
bool | IsVertical(self)
bool | Realize(self)
ToolBarToolBase | RemoveTool(self, id)
SetMargins(self, size)
SetMarginsXY(self, x, y)
SetMaxRowsCols(self, rows, cols)
SetRows(self, nRows)
SetToggle(self, id, toggle)
SetToolBitmapSize(self, size)
SetToolClientData(self, id, clientData)
SetToolLongHelp(self, id, helpString)
SetToolPacking(self, packing)
SetToolSeparation(self, separation)
SetToolShortHelp(self, id, helpString)
ToggleTool(self, id, toggle)

Instance Method Details

AddCheckLabelTool(self, id, label, bitmap, bmpDisabled=wxPython wrapper for UNBORN object! (The C++ object is no..., shortHelp='', longHelp='', clientData=None)

Add a check tool, i.e. a tool which can be toggled

AddCheckTool(self, id, bitmap, bmpDisabled=wxPython wrapper for UNBORN object! (The C++ object is no..., shortHelp='', longHelp='', clientData=None)

Add a check tool, i.e. a tool which can be toggled

AddLabelTool(self, id, label, bitmap, bmpDisabled=wxPython wrapper for UNBORN object! (The C++ object is no..., kind=0, shortHelp='', longHelp='', clientData=None)

The full AddTool() function.

If bmpDisabled is wx.NullBitmap, a shadowed version of the normal bitmap is created and used as the disabled image.

AddRadioLabelTool(self, id, label, bitmap, bmpDisabled=wxPython wrapper for UNBORN object! (The C++ object is no..., shortHelp='', longHelp='', clientData=None)

Add a radio tool, i.e. a tool which can be toggled and releases any other toggled radio tools in the same group when it happens

AddRadioTool(self, id, bitmap, bmpDisabled=wxPython wrapper for UNBORN object! (The C++ object is no..., shortHelp='', longHelp='', clientData=None)

Add a radio tool, i.e. a tool which can be toggled and releases any other toggled radio tools in the same group when it happens

AddSimpleTool(self, id, bitmap, shortHelpString='', longHelpString='', isToggle=0)

Old style method to add a tool to the toolbar.

AddTool(self,
          id,
          bitmap,
          pushedBitmap=wxPython wrapper for UNBORN object! (The C++ object is no...,
          isToggle=0,
          clientData=None,
          shortHelpString='',
          longHelpString='')

Old style method to add a tool to the toolbar.

InsertLabelTool(self, pos, id, label, bitmap, bmpDisabled=wxPython wrapper for UNBORN object! (The C++ object is no..., kind=0, shortHelp='', longHelp='', clientData=None)

Insert the new tool at the given position, if pos == GetToolsCount(), it is equivalent to AddTool()

InsertSimpleTool(self, pos, id, bitmap, shortHelpString='', longHelpString='', isToggle=0)

Old style method to insert a tool in the toolbar.

InsertTool(self, pos, id, bitmap, pushedBitmap=wxPython wrapper for UNBORN object! (The C++ object is no..., isToggle=0, clientData=None, shortHelpString='', longHelpString='')

Old style method to insert a tool in the toolbar.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:16 2005 http://epydoc.sf.net


wx.ToolBar

Package wx :: Class ToolBar

Type ToolBar

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
               Control --+
                         |
               ToolBarBase --+
                             |
                            ToolBar

Known Subclasses:
FloatBar

Proxy of C++ ToolBar class

Method Summary
ToolBar | __init__(self, parent, id, pos, size, style, name)
 | __repr__(self)
bool | Create(self, parent, id, pos, size, style, validator, name) Do the 2nd phase and create the GUI control.
ToolBarToolBase | FindToolForPosition(self, x, y)
VisualAttributes | GetClassDefaultAttributes(variant) Get the default attributes for this class. (Static method)

Instance Method Details

Create(self,
          parent,
          id=-1,
          pos=DefaultPosition,
          size=DefaultSize,
          style=wxNO_BORDER|wxTB_HORIZONTAL,
          name=wxPyToolBarNameStr)

Do the 2nd phase and create the GUI control.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

validator
(type=Validator)

name
(type=String)

Returns:
bool
Overrides:
wx.Control.Create (inherited documentation)

Static Method Details

GetClassDefaultAttributes(variant=WINDOW_VARIANT_NORMAL)

Get the default attributes for this class. This is useful if you want to use the same font or colour in your own control as in a standard control -- which is a much better idea than hard coding specific colours or fonts which might look completely out of place on the user's system, especially if it uses themes.

The variant parameter is only relevant under Mac currently and is ignore under other platforms. Under Mac, it will change the size of the returned font. See wx.Window.SetWindowVariant for more about this.

Parameters:
variant
(type=int)

Returns:
VisualAttributes

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:10:50 2005 http://epydoc.sf.net


wx.ToolBarToolBase

Package wx :: Class ToolBarToolBase

Type ToolBarToolBase

object --+
         |
    Object --+
             |
            ToolBarToolBase

Proxy of C++ ToolBarToolBase class

Method Summary
 | __init__(self)
 | __repr__(self)
 | Attach(self, tbar)
bool | CanBeToggled(self)
 | Detach(self)
bool | Enable(self, enable)
Bitmap | GetBitmap(self)
Bitmap | GetBitmap1(self)
Bitmap | GetBitmap2(self)
PyObject | GetClientData(self)
Control | GetControl(self)
Bitmap | GetDisabledBitmap(self)
int | GetId(self)
int | GetKind(self)
String | GetLabel(self)
String | GetLongHelp(self)
Bitmap | GetNormalBitmap(self)
String | GetShortHelp(self)
int | GetStyle(self)
ToolBarBase | GetToolBar(self)
int | IsButton(self)
int | IsControl(self)
bool | IsEnabled(self)
int | IsSeparator(self)
bool | IsToggled(self)
 | SetBitmap1(self, bmp)
 | SetBitmap2(self, bmp)
 | SetClientData(self, clientData)
 | SetDisabledBitmap(self, bmp)
 | SetLabel(self, label)
bool | SetLongHelp(self, help)
 | SetNormalBitmap(self, bmp)
bool | SetShortHelp(self, help)
bool | SetToggle(self, toggle)
 | Toggle(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:22 2005 http://epydoc.sf.net


wx.tools.dbg.Logger

Package wx :: Package tools :: Module dbg :: Class Logger

Class Logger

Method Summary
 | __init__(self, name)
 | __call__(self, *args, **kwargs) This function provides a useful framework for generating optional debugging output that can be displayed at an arbitrary level of indentation.
 | dbg(self, *args, **kwargs) This function provides a useful framework for generating optional debugging output that can be displayed at an arbitrary level of indentation.
 | IsEnabled()
 | IsSuspended()
 | log(self, *args, **kwargs) This function provides a useful framework for generating optional debugging output that can be displayed at an arbitrary level of indentation.
 | msg(self, *args, **kwargs) This function provides a useful framework for generating optional debugging output that can be displayed at an arbitrary level of indentation.
 | SetEnabled(self, value)
 | SetIndent(self, value)
 | SetStream(self, value)
 | SetSuspend(self, value)
 | SetWxLog(self, value)

Method Details

__call__(self, *args, **kwargs)
(Call operator)

This function provides a useful framework for generating optional debugging output that can be displayed at an arbitrary level of indentation.

dbg(self, *args, **kwargs)

This function provides a useful framework for generating optional debugging output that can be displayed at an arbitrary level of indentation.

log(self, *args, **kwargs)

This function provides a useful framework for generating optional debugging output that can be displayed at an arbitrary level of indentation.

msg(self, *args, **kwargs)

This function provides a useful framework for generating optional debugging output that can be displayed at an arbitrary level of indentation.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:16 2005 http://epydoc.sf.net


wx.tools.dbg

Package wx :: Package tools :: Module dbg

Module wx.tools.dbg

This module provides a useful debugging framework that supports
showing nesting of function calls and allows a program to contain
lots of debugging print statements that can easily be turned on
or off to debug the code.  It also supports the ability to
have each function indent the debugging statements contained
within it, including those of any other function called within
its scope, thus allowing you to see in what order functions are
being called, and from where.

This capability is particularly useful in wxPython applications,
where exactly events occur that cause functions to be called is
not entirely clear, and because wxPython programs can't be run
from inside other debugging environments that have their own
message loops.

This module defines a Logger class, responsible for managing
debugging output.  Each Logger instance can be given a name
at construction; if this is done, '<name>:' will precede each
logging output made by that Logger instance.

The log() function this class provides takes a set of positional
arguments that are printed in order if debugging is enabled
(just like print does), followed by a set of keyword arguments
that control the behavior of the log() function itself on subsequent
calls.  The current keyword arguments are:

indent
    When set to a value of 1, this increments the current
    indentation level, causing all subsequent dbg() outputs to be
    indented by 3 more spaces.  When set to a value of 0,
    this process is reversed, causing the indent to decrease by
    3 spaces.  The default indentation level is 0.

enable
    When set to a value of 1, this turns on dbg() output for
    for program importing this module, until told to do otherwise.
    When set to a value of 0, dbg output is turned off.  (dbg
    output is off by default.)

suspend
    When set to a value of 1, this increments the current
    "suspension" level.  This makes it possible for a function
    to temporarily suspend its and any of its dependents'
    potential outputs that use the same Logger instance.
    When set to a value of 0, the suspension level is
    decremented.  When the value goes back to 0, potential
    logging is resumed (actual output depends on the
    "enable" status of the Logger instance in question.)

wxlog
    When set to a value of 1, the output will be sent to the
    active wxLog target.

stream
    When set to a non-None value, the current output stream
    (default of sys.stdout) is pushed onto a stack of streams,
    and is replaced in the dbg system with the specified stream.
    When called with a value of None, the previous stream will
    be restored (if stacked.)  If set to None without previously
    changing it will result in no action being taken.

You can also call the log function implicitly on the Logger
instance, ie. you can type:
    from wxPython.tools.dbg import Logger
    dbg = Logger()
    dbg('something to print')

Using this fairly simple mechanism, it is possible to get fairly
useful debugging output in a program.  Consider the following
code example:

>>> d = {1:'a', 2:'dictionary', 3:'of', 4:'words'}
>>> dbg = dbg.Logger('module')
>>> dbg(enable=1)
module: dbg enabled
>>> def foo(d):
...     dbg('foo', indent=1)
...     bar(d)
...     dbg('end of foo', indent=0)
...
>>> def bar(d):
...     dbg('bar', indent=1)
...     dbg('contents of d:', indent=1)
...     l = d.items()
...     l.sort()
...     for key, value in l:
...         dbg('%d =' % key, value)
...     dbg(indent=0)
...     dbg('end of bar', indent=0)
...
>>> foo(d)
module: foo
   module: bar
      module: contents of d:
         module: 1 = a
         module: 2 = dictionary
         module: 3 = of
         module: 4 = words
      module: end of bar
   module: end of foo
>>>
Classes
Logger

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:16 2005 http://epydoc.sf.net


wx.tools.helpviewer

Package wx :: Package tools :: Module helpviewer

Module wx.tools.helpviewer

helpviewer.py -- Displays HTML Help in a wxHtmlHelpController window.

Usage:

helpviewer [--cache=path] helpfile [helpfile(s)...]

Where helpfile is the path to either a .hhp file or a .zip file which contians a .hhp file. The .hhp files are the same as those used by Microsoft's HTML Help Workshop for creating CHM files.

Function Summary
main(args)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:10 2005 http://epydoc.sf.net


wx.tools.img2img

Package wx :: Package tools :: Module img2img

Module wx.tools.img2img

Function Summary
 | convert(file, maskClr, outputDir, outputName, outType, outExt)
 | main(args, outType, outExt, doc)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:17 2005 http://epydoc.sf.net


wx.tools.img2png

Package wx :: Package tools :: Module img2png

Module wx.tools.img2png

img2png.py -- convert several image formats to PNG format.

Usage:

img2png.py [options] image_files...

Options:

-o <dir> The directory to place the .png file(s), defaults to the current directory.
-m <#rrggbb> If the original image has a mask or transparency defined
it will be used by default. You can use this option to override the default or provide a new mask by specifying a colour in the image to mark as transparent.
-n <name> A filename to write the .png data to. Defaults to the basename of the image file + '.png' This option overrides the -o option.
Function Summary
main()

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:52 2005 http://epydoc.sf.net


wx.tools.img2py

Package wx :: Package tools :: Module img2py

Module wx.tools.img2py

img2py.py -- Convert an image to PNG format and embed it in a Python
module with appropriate code so it can be loaded into a program at runtime. The benefit is that since it is Python source code it can be delivered as a .pyc or 'compiled' into the program using freeze, py2exe, etc.

Usage:

img2py.py [options] image_file python_file

Options:

-m <#rrggbb> If the original image has a mask or transparency defined
it will be used by default. You can use this option to override the default or provide a new mask by specifying a colour in the image to mark as transparent.
-n <name> | Normally generic names (getBitmap, etc.) are used for the image access functions. If you use this option you can specify a name that should be used to customize the access fucntions, (getNameBitmap, etc.)
-c | Maintain a catalog of names that can be used to reference images. Catalog can be accessed via catalog and index attributes of the module. If the -n <name> option is specified then <name> is used for the catalog key and index value, otherwise the filename without any path or extension is used as the key.
-a | This flag specifies that the python_file should be appended to instead of overwritten. This in combination with -n will allow you to put multiple images in one Python source file.
-u | Don't use compression. Leaves the data uncompressed.
-i | Also output a function to return the image as a wxIcon.
Function Summary
 | crunch_data(data, compressed)
 | main(args)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:10:55 2005 http://epydoc.sf.net


wx.tools.img2xpm

Package wx :: Package tools :: Module img2xpm

Module wx.tools.img2xpm

img2xpm.py -- convert several image formats to XPM.

Usage:

img2xpm.py [options] image_files...

Options:

-o <dir> The directory to place the .xpm file(s), defaults to the current directory.
-m <#rrggbb> If the original image has a mask or transparency defined
it will be used by default. You can use this option to override the default or provide a new mask by specifying a colour in the image to mark as transparent.
-n <name> A filename to write the .xpm data to. Defaults to the basename of the image file + '.xpm' This option overrides the -o option.
Function Summary
main()

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:04 2005 http://epydoc.sf.net


wx.tools

Package wx :: Package tools

Package wx.tools

Some useful tools and utilities for wxPython.

Submodules
  • dbg: This module provides a useful debugging framework that supports showing nesting of function calls and allows a program to contain lots of debugging print statements that can easily be turned on or off to debug the code.
  • helpviewer: helpviewer.py -- Displays HTML Help in a wxHtmlHelpController window.
  • img2img
  • img2png: img2png.py -- convert several image formats to PNG format.
  • img2py: module with appropriate code so it can be loaded into a program at runtime.
  • img2xpm: img2xpm.py -- convert several image formats to XPM.

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:04 2005 http://epydoc.sf.net


wx.ToolTip

Package wx :: Class ToolTip

Type ToolTip

object --+
         |
    Object --+
             |
            ToolTip

Proxy of C++ ToolTip class

Method Summary
ToolTip | __init__(self, tip)
 | __repr__(self)
 | Enable(flag) (Static method)
String | GetTip(self)
Window | GetWindow(self)
 | SetDelay(milliseconds) (Static method)
 | SetTip(self, tip)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:17 2005 http://epydoc.sf.net


wx.TopLevelWindow

Package wx :: Class TopLevelWindow

Type TopLevelWindow

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
                    TopLevelWindow

Known Subclasses:
Dialog, Frame

Proxy of C++ TopLevelWindow class

Method Summary
 | __init__(self)
 | __repr__(self)
Icon | GetIcon(self)
String | GetTitle(self) Gets the window's title.
 | Iconize(self, iconize)
bool | IsActive(self)
bool | IsFullScreen(self)
bool | IsIconized(self)
bool | IsMaximized(self)
bool | MacGetMetalAppearance(self)
 | MacSetMetalAppearance(self, on)
 | Maximize(self, maximize)
 | RequestUserAttention(self, flags)
 | Restore(self)
 | SetIcon(self, icon)
 | SetIcons(self, icons)
bool | SetShape(self, region)
 | SetTitle(self, title) Sets the window's title.
bool | ShowFullScreen(self, show, style)

Instance Method Details

GetTitle(self)

Gets the window's title. Applicable only to frames and dialogs.

Returns:
String
Overrides:
wx.Window.GetTitle

SetTitle(self, title)

Sets the window's title. Applicable only to frames and dialogs.

Parameters:
title
(type=String)

Overrides:
wx.Window.SetTitle

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:51 2005 http://epydoc.sf.net


wx.TreeCtrl

Package wx :: Class TreeCtrl

Type TreeCtrl

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
               Control --+
                         |
                        TreeCtrl

Known Subclasses:
FillingTree, RemotelyScrolledTreeCtrl

Proxy of C++ TreeCtrl class

Method Summary
Control __init__(self, parent, id, pos, size, style, validator, name)
Create a Control.
__repr__(self)
TreeItemId | AddRoot(self, text, image, selectedImage, data)
TreeItemId | AppendItem(self, parent, text, image, selectedImage, data)
AssignImageList(self, imageList)
AssignStateImageList(self, imageList)
Collapse(self, item)
CollapseAndReset(self, item)
bool Create(self, parent, id, pos, size, style, validator, name)
Do the 2nd phase and create the GUI control.
Delete(self, item)
DeleteAllItems(self)
DeleteChildren(self, item)
EditLabel(self, item)
EnsureVisible(self, item)
Expand(self, item)
PyObject | GetBoundingRect(self, item, textOnly)
size_t | GetChildrenCount(self, item, recursively)
VisualAttributes GetClassDefaultAttributes(variant)
Get the default attributes for this class. (Static method)
size_t | GetCount(self)
TextCtrl | GetEditControl(self)
PyObject | GetFirstChild(self, item)
TreeItemId | GetFirstVisibleItem(self)
ImageList | GetImageList(self)
unsigned int | GetIndent(self)
Colour | GetItemBackgroundColour(self, item)
TreeItemData | GetItemData(self, item)
Font | GetItemFont(self, item)
int | GetItemImage(self, item, which)
TreeItemId | GetItemParent(self, item)
PyObject | GetItemPyData(self, item)
String | GetItemText(self, item)
Colour | GetItemTextColour(self, item)
TreeItemId | GetLastChild(self, item)
PyObject | GetNextChild(self, item, cookie)
TreeItemId | GetNextSibling(self, item)
TreeItemId | GetNextVisible(self, item)
TreeItemId | GetPrevSibling(self, item)
TreeItemId | GetPrevVisible(self, item)
PyObject | GetPyData(self, item)
TreeItemId | GetRootItem(self)
TreeItemId | GetSelection(self)
PyObject | GetSelections(self)
unsigned int | GetSpacing(self)
ImageList | GetStateImageList(self)
(item, where) HitTest(point)
Determine which item (if any) belongs the given point.
TreeItemId | InsertItem(self, parent, idPrevious, text, image, selectedImage, data)
TreeItemId | InsertItemBefore(self, parent, index, text, image, selectedImage, data)
bool | IsBold(self, item)
bool | IsExpanded(self, item)
bool | IsSelected(self, item)
bool | IsVisible(self, item)
bool | ItemHasChildren(self, item)
TreeItemId | PrependItem(self, parent, text, image, selectedImage, data)
ScrollTo(self, item)
SelectItem(self, item, select)
SetImageList(self, imageList)
SetIndent(*args, **kwargs)
SetIndent(self, unsigned int indent)
SetItemBackgroundColour(self, item, col)
SetItemBold(self, item, bold)
SetItemData(self, item, data)
SetItemDropHighlight(self, item, highlight)
SetItemFont(self, item, font)
SetItemHasChildren(self, item, has)
SetItemImage(self, item, image, which)
SetItemPyData(self, item, obj)
SetItemText(self, item, text)
SetItemTextColour(self, item, col)
SetPyData(self, item, obj)
SetSpacing(*args, **kwargs)
SetSpacing(self, unsigned int spacing)
SetStateImageList(self, imageList)
SortChildren(self, item)
Toggle(self, item)
ToggleItemSelection(self, item)
Unselect(self)
UnselectAll(self)
UnselectItem(self, item)

Instance Method Details

__init__(self,
          parent,
          id=-1,
          pos=DefaultPosition,
          size=DefaultSize,
          style=TR_DEFAULT_STYLE,
          validator=DefaultValidator,
          name=TreeCtrlNameStr)
(Constructor)

Create a Control. Normally you should only call this from a subclass' __init__ as a plain old wx.Control is not very useful.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

validator
(type=Validator)

name
(type=String)

Returns:
Control
Overrides:
wx.Control.__init__ (inherited documentation)

Create(self,
          parent,
          id=-1,
          pos=DefaultPosition,
          size=DefaultSize,
          style=TR_DEFAULT_STYLE,
          validator=DefaultValidator,
          name=TreeCtrlNameStr)

Do the 2nd phase and create the GUI control.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

validator
(type=Validator)

name
(type=String)

Returns:
bool
Overrides:
wx.Control.Create

HitTest(point)

Determine which item (if any) belongs the given point. The coordinates specified are relative to the client area of tree ctrl and the where return value is set to a bitmask of wxTREE_HITTEST_xxx constants.

Parameters:
point
(type=Point)

Returns:
(item, where)
Overrides:
wx.Window.HitTest

SetIndent(*args, **kwargs)

SetIndent(self, unsigned int indent)

SetSpacing(*args, **kwargs)

SetSpacing(self, unsigned int spacing)

Static Method Details

GetClassDefaultAttributes(variant=WINDOW_VARIANT_NORMAL)

Get the default attributes for this class. This is useful if you want to use the same font or colour in your own control as in a standard control -- which is a much better idea than hard coding specific colours or fonts which might look completely out of place on the user's system, especially if it uses themes.

The variant parameter is only relevant under Mac currently and is ignore under other platforms. Under Mac, it will change the size of the returned font. See wx.Window.SetWindowVariant for more about this.

Parameters:
variant
(type=int)

Returns:
VisualAttributes

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:33 2005 http://epydoc.sf.net


wx.TreeEvent

Package wx :: Class TreeEvent

Type TreeEvent

object --+
         |
    Object --+
             |
         Event --+
                 |
      CommandEvent --+
                     |
           NotifyEvent --+
                         |
                        TreeEvent

Proxy of C++ TreeEvent class

Method Summary
NotifyEvent | __init__(self, commandType, winid) An instance of this class (or one of its derived classes) is sent from a control when the control's state is being changed and the control allows that change to be prevented from happening.
 | __repr__(self)
TreeItemId | GetItem(self)
int | GetKeyCode(self)
KeyEvent | GetKeyEvent(self)
String | GetLabel(self)
TreeItemId | GetOldItem(self)
Point | GetPoint(self)
String | GetToolTip(self)
bool | IsEditCancelled(self)
 | SetEditCanceled(self, editCancelled)
 | SetItem(self, item)
 | SetKeyEvent(self, evt)
 | SetLabel(self, label)
 | SetOldItem(self, item)
 | SetPoint(self, pt)
 | SetToolTip(self, toolTip)

Method Details

__init__(self, commandType=wxEVT_NULL, id=0)
(Constructor)

An instance of this class (or one of its derived classes) is sent from a control when the control's state is being changed and the control allows that change to be prevented from happening. The event handler can call Veto or Allow to tell the control what to do.

Parameters:
commandType
(type=wxEventType)

winid
(type=int)

Returns:
NotifyEvent
Overrides:
wx.NotifyEvent.__init__ (inherited documentation)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:25 2005 http://epydoc.sf.net


wx.TreeItemData

Package wx :: Class TreeItemData

Type TreeItemData

object --+
         |
        TreeItemData

Proxy of C++ TreeItemData class

Method Summary
TreeItemData | __init__(self, obj)
 | __repr__(self)
 | Destroy(self)
PyObject | GetData(self)
TreeItemId | GetId(self)
 | SetData(self, obj)
 | SetId(self, id)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:11 2005 http://epydoc.sf.net


wx.TreeItemId

Package wx :: Class TreeItemId

Type TreeItemId

object --+
         |
        TreeItemId

Proxy of C++ TreeItemId class

Method Summary
TreeItemId | __init__(self)
 | __del__(self)
bool | __eq__(self, other)
bool | __ne__(self, other)
 | __nonzero__(self)
 | __repr__(self)
bool | IsOk(self)
bool | Ok(self)

Property Summary
m_pItem

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:05 2005 http://epydoc.sf.net


wx.UpdateUIEvent

Package wx :: Class UpdateUIEvent

Type UpdateUIEvent

object --+
         |
    Object --+
             |
         Event --+
                 |
      CommandEvent --+
                     |
                    UpdateUIEvent

This class is used for EVT_UPDATE_UI pseudo-events which are sent by wxWidgets to give an application the chance to update various user interface elements.

Without update UI events, an application has to work hard to check/uncheck, enable/disable, and set the text for elements such as menu items and toolbar buttons. The code for doing this has to be mixed up with the code that is invoked when an action is invoked for a menu item or button.

With update UI events, you define an event handler to look at the state of the application and change UI elements accordingly. wxWidgets will call your handler functions in idle time, so you don't have to worry where to call this code. In addition to being a clearer and more declarative method, it also means you don't have to worry whether you're updating a toolbar or menubar identifier. The same handler can update a menu item and toolbar button, if the ID values are the same.

Instead of directly manipulating the menu or button, you call functions in the event object, such as Check. wxWidgets will determine whether such a call has been made, and which UI element to update.

These events will work for popup menus as well as menubars. Just before a menu is popped up, wx.Menu.UpdateUI is called to process any UI events for the window that owns the menu.

If you find that the overhead of UI update processing is affecting your application, you can do one or both of the following:

  1. Call wx.UpdateUIEvent.SetMode with a value of wx.UPDATE_UI_PROCESS_SPECIFIED, and set the extra style wx.WS_EX_PROCESS_UPDATE_EVENTS for every window that should receive update events. No other windows will receive update events.
  2. Call wx.UpdateUIEvent.SetUpdateInterval with a millisecond value to set the delay between updates. You may need to call wx.Window.UpdateWindowUI at critical points, for example when a dialog is about to be shown, in case the user sees a slight delay before windows are updated.

Note that although events are sent in idle time, defining a EVT_IDLE handler for a window does not affect this because the events are sent from an internal idle handler.

wxWidgets tries to optimize update events on some platforms. On Windows and GTK+, events for menubar items are only sent when the menu is about to be shown, and not in idle time.

Method Summary
UpdateUIEvent | __init__(self, commandId) Constructor
 | __repr__(self)
bool | CanUpdate(win) Returns True if it is appropriate to update (send UI update events to) this window. (Static method)
 | Check(self, check) Check or uncheck the UI element.
 | Enable(self, enable) Enable or disable the UI element.
bool | GetChecked(self) Returns True if the UI element should be checked.
bool | GetEnabled(self) Returns True if the UI element should be enabled.
int | GetMode() Returns a value specifying how wxWidgets will send update events: to all windows, or only to those which specify that they will process the events. (Static method)
bool | GetSetChecked(self) Returns True if the application has called Check.
bool | GetSetEnabled(self) Returns True if the application has called Enable.
bool | GetSetText(self) Returns True if the application has called SetText.
String | GetText(self) Returns the text that should be set for the UI element.
long | GetUpdateInterval() Returns the current interval between updates in milliseconds. (Static method)
 | ResetUpdateTime() Used internally to reset the last-updated time to the current time. (Static method)
 | SetMode(mode) Specify how wxWidgets will send update events: to all windows, or only to those which specify that they will process the events. (Static method)
 | SetText(self, text) Sets the text for this UI element.
 | SetUpdateInterval(updateInterval) Sets the interval between updates in milliseconds. (Static method)

Instance Method Details

__init__(self, commandId=0)
(Constructor)

Constructor

Parameters:
commandId
(type=int)

Returns:
UpdateUIEvent
Overrides:
wx.CommandEvent.__init__

Check(self, check)

Check or uncheck the UI element.

Parameters:
check
(type=bool)

Enable(self, enable)

Enable or disable the UI element.

Parameters:
enable
(type=bool)

GetChecked(self)

Returns True if the UI element should be checked.

Returns:
bool

GetEnabled(self)

Returns True if the UI element should be enabled.

Returns:
bool

GetSetChecked(self)

Returns True if the application has called Check. For wxWidgets internal use only.

Returns:
bool

GetSetEnabled(self)

Returns True if the application has called Enable. For wxWidgets internal use only.

Returns:
bool

GetSetText(self)

Returns True if the application has called SetText. For wxWidgets internal use only.

Returns:
bool

GetText(self)

Returns the text that should be set for the UI element.

Returns:
String

SetText(self, text)

Sets the text for this UI element.

Parameters:
text
(type=String)

Static Method Details

CanUpdate(win)

Returns True if it is appropriate to update (send UI update events to) this window.

This function looks at the mode used (see wx.UpdateUIEvent.SetMode), the wx.WS_EX_PROCESS_UPDATE_EVENTS flag in window, the time update events were last sent in idle time, and the update interval, to determine whether events should be sent to this window now. By default this will always return true because the update mode is initially wx.UPDATE_UI_PROCESS_ALL and the interval is set to 0; so update events will be sent as often as possible. You can reduce the frequency that events are sent by changing the mode and/or setting an update interval.

Parameters:
win
(type=Window)

Returns:
bool

GetMode()

Returns a value specifying how wxWidgets will send update events: to all windows, or only to those which specify that they will process the events.

Returns:
int

GetUpdateInterval()

Returns the current interval between updates in milliseconds. -1 disables updates, 0 updates as frequently as possible.

Returns:
long

ResetUpdateTime()

Used internally to reset the last-updated time to the current time. It is assumed that update events are normally sent in idle time, so this is called at the end of idle processing.

SetMode(mode)

Specify how wxWidgets will send update events: to all windows, or only to those which specify that they will process the events.

The mode may be one of the following values:

wxUPDATE_UI_PROCESS_ALL | Send UI update events to all windows. This is the default setting.
wxUPDATE_UI_PROCESS_SPECIFIED | Send UI update events only to windows that have the wx.WS_EX_PROCESS_UI_UPDATES extra style set.
Parameters:
mode
(type=int)

SetUpdateInterval(updateInterval)

Sets the interval between updates in milliseconds. Set to -1 to disable updates, or to 0 to update as frequently as possible. The default is 0.

Use this to reduce the overhead of UI update events if your application has a lot of windows. If you set the value to -1 or greater than 0, you may also need to call wx.Window.UpdateWindowUI at appropriate points in your application, such as when a dialog is about to be shown.

Parameters:
updateInterval
(type=long)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:45 2005 http://epydoc.sf.net


wx.URLDataObject

Package wx :: Class URLDataObject

Type URLDataObject

     object --+
              |
     DataObject --+
                  |
DataObjectComposite --+
                      |
                     URLDataObject

This data object holds a URL in a format that is compatible with some browsers such that it is able to be dragged to or from them.

Method Summary
URLDataObject | __init__(self) This data object holds a URL in a format that is compatible with some browsers such that it is able to be dragged to or from them.
 | __repr__(self)
String | GetURL(self) Returns a string containing the current URL.
 | SetURL(self, url) Set the URL.

Class Variable Summary

Method Details

__init__(self)
(Constructor)

This data object holds a URL in a format that is compatible with some browsers such that it is able to be dragged to or from them.

Returns:
URLDataObject
Overrides:
wx.DataObjectComposite.__init__

GetURL(self)

Returns a string containing the current URL.

Returns:
String

SetURL(self, url)

Set the URL.

Parameters:
url
(type=String)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:05 2005 http://epydoc.sf.net


wx.Validator

Package wx :: Class Validator

Type Validator

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
                Validator

Known Subclasses:
PyValidator

Proxy of C++ Validator class

Method Summary
Validator | __init__(self)
 | __repr__(self)
Validator | Clone(self)
Window | GetWindow(self)
bool | IsSilent() (Static method)
 | SetBellOnError(doIt) (Static method)
 | SetWindow(self, window)
bool | TransferFromWindow(self)
bool | TransferToWindow(self)
bool | Validate(self, parent)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:04 2005 http://epydoc.sf.net


wx.VideoMode

Package wx :: Class VideoMode

Type VideoMode

object --+
         |
        VideoMode

A simple struct containing video mode parameters for a display

Method Summary
VideoMode | __init__(self, width, height, depth, freq) A simple struct containing video mode parameters for a display
 | __del__(self)
bool | __eq__(self, other)
bool | __ne__(self, other)
 | __nonzero__(self)
 | __repr__(self)
int | GetDepth(self) Returns the screen's bits per pixel (e.g.
int | GetHeight(self) Returns the screen width in pixels (e.g.
int | GetWidth(self) Returns the screen width in pixels (e.g.
bool | IsOk(self) returns true if the object has been initialized
bool | Matches(self, other) Returns true if this mode matches the other one in the sense that all non zero fields of the other mode have the same value in this one (except for refresh which is allowed to have a greater value)

Property Summary
 | bpp
 | h
 | refresh
 | w

Method Details

__init__(self,
          width=0,
          height=0,
          depth=0,
          freq=0)
(Constructor)

A simple struct containing video mode parameters for a display

Parameters:
width
(type=int)

height
(type=int)

depth
(type=int)

freq
(type=int)

Returns:
VideoMode
Overrides:
__builtin__.object.__init__

GetDepth(self)

Returns the screen's bits per pixel (e.g. 32), 1 is monochrome and 0 means unspecified/known

Returns:
int

GetHeight(self)

Returns the screen width in pixels (e.g. 640*480), 0 means unspecified

Returns:
int

GetWidth(self)

Returns the screen width in pixels (e.g. 640*480), 0 means unspecified

Returns:
int

IsOk(self)

returns true if the object has been initialized

Returns:
bool

Matches(self, other)

Returns true if this mode matches the other one in the sense that all non zero fields of the other mode have the same value in this one (except for refresh which is allowed to have a greater value)

Parameters:
other
(type=VideoMode)

Returns:
bool

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:38 2005 http://epydoc.sf.net


wx.VisualAttributes

Package wx :: Class VisualAttributes

Type VisualAttributes

object --+
         |
        VisualAttributes

struct containing all the visual attributes of a control

Method Summary
VisualAttributes | __init__(self) struct containing all the visual attributes of a control
 | __del__(self)
 | __repr__(self)

Property Summary
 | colBg
 | colFg
 | font

Method Details

__init__(self)
(Constructor)

struct containing all the visual attributes of a control

Returns:
VisualAttributes
Overrides:
__builtin__.object.__init__

Property Details

colBg

Get Method:
VisualAttributes_colBg_get(...)
Set Method:
VisualAttributes_colBg_set(...)

colFg

Get Method:
VisualAttributes_colFg_get(...)
Set Method:
VisualAttributes_colFg_set(...)

font

Get Method:
VisualAttributes_font_get(...)
Set Method:
VisualAttributes_font_set(...)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:40 2005 http://epydoc.sf.net


wx.VListBox

Package wx :: Class VListBox

Type VListBox

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
                 Panel --+
                         |
           VScrolledWindow --+
                             |
                            VListBox

Known Subclasses:
HtmlListBox

Proxy of C++ VListBox class

Method Summary
Window __init__(self, parent, id, pos, size, style, name)
Construct and show a generic Window.
__repr__(self)
Clear(self)
bool Create(self, parent, id, pos, size, style, name)
Create the GUI part of the Window for 2-phase creation mode.
bool | DeselectAll(self)
PyObject | GetFirstSelected(self)
size_t | GetItemCount(self)
Point | GetMargins(self)
GetNextSelected(*args, **kwargs)
GetNextSelected(self, unsigned long cookie) -> PyObject
size_t | GetSelectedCount(self)
int | GetSelection(self)
Colour | GetSelectionBackground(self)
bool | HasMultipleSelection(self)
bool | IsCurrent(self, item)
bool | IsSelected(self, item)
bool | Select(self, item, select)
bool | SelectAll(self)
bool | SelectRange(self, from, to)
SetItemCount(self, count)
SetMargins(self, pt)
SetMarginsXY(self, x, y)
SetSelection(self, selection)
SetSelectionBackground(self, col)
Toggle(self, item)

Instance Method Details

__init__(self,
          parent,
          id=ID_ANY,
          pos=DefaultPosition,
          size=DefaultSize,
          style=0,
          name=VListBoxNameStr)
(Constructor)

Construct and show a generic Window.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

name
(type=String)

Returns:
Window
Overrides:
wx.VScrolledWindow.__init__ (inherited documentation)

Create(self,
          parent,
          id=ID_ANY,
          pos=DefaultPosition,
          size=DefaultSize,
          style=0,
          name=VListBoxNameStr)

Create the GUI part of the Window for 2-phase creation mode.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

name
(type=String)

Returns:
bool
Overrides:
wx.VScrolledWindow.Create (inherited documentation)

GetNextSelected(*args, **kwargs)

GetNextSelected(self, unsigned long cookie) -> PyObject

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:01 2005 http://epydoc.sf.net


wx.VScrolledWindow

Package wx :: Class VScrolledWindow

Type VScrolledWindow

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
                 Panel --+
                         |
                        VScrolledWindow

Known Subclasses:
VListBox

Proxy of C++ VScrolledWindow class

Method Summary
Window | __init__(self, parent, id, pos, size, style, name) Construct and show a generic Window.
 | __repr__(self)
bool | Create(self, parent, id, pos, size, style, name) Create the GUI part of the Window for 2-phase creation mode.
size_t | GetFirstVisibleLine(self)
size_t | GetLastVisibleLine(self)
size_t | GetLineCount(self)
size_t | GetVisibleBegin(self)
size_t | GetVisibleEnd(self)
int | HitTest(self, pt) Test where the given (in client coords) point lies
int | HitTestXY(self, x, y) Test where the given (in client coords) point lies
bool | IsVisible(self, line)
 | RefreshAll(self)
 | RefreshLine(self, line)
 | RefreshLines(self, from, to)
bool | ScrollLines(self, lines) If the platform and window class supports it, scrolls the window by the given number of lines down, if lines is positive, or up if lines is negative.
bool | ScrollPages(self, pages) If the platform and window class supports it, scrolls the window by the given number of pages down, if pages is positive, or up if pages is negative.
bool | ScrollToLine(self, line)
 | SetLineCount(self, count)

Instance Method Details

__init__(self,
          parent,
          id=ID_ANY,
          pos=DefaultPosition,
          size=DefaultSize,
          style=0,
          name=PanelNameStr)
(Constructor)

Construct and show a generic Window.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

name
(type=String)

Returns:
Window
Overrides:
wx.Panel.__init__ (inherited documentation)

Create(self,
          parent,
          id=ID_ANY,
          pos=DefaultPosition,
          size=DefaultSize,
          style=0,
          name=PanelNameStr)

Create the GUI part of the Window for 2-phase creation mode.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

name
(type=String)

Returns:
bool
Overrides:
wx.Panel.Create (inherited documentation)

HitTest(self, pt)

Test where the given (in client coords) point lies

Parameters:
pt
(type=Point)

Returns:
int
Overrides:
wx.Window.HitTest

HitTestXY(self, x, y)

Test where the given (in client coords) point lies

Parameters:
x
(type=int)

y
(type=int)

Returns:
int
Overrides:
wx.Window.HitTestXY

ScrollLines(self, lines)

If the platform and window class supports it, scrolls the window by the given number of lines down, if lines is positive, or up if lines is negative. Returns True if the window was scrolled, False if it was already on top/bottom and nothing was done.

Parameters:
lines
(type=int)

Returns:
bool
Overrides:
wx.Window.ScrollLines

ScrollPages(self, pages)

If the platform and window class supports it, scrolls the window by the given number of pages down, if pages is positive, or up if pages is negative. Returns True if the window was scrolled, False if it was already on top/bottom and nothing was done.

Parameters:
pages
(type=int)

Returns:
bool
Overrides:
wx.Window.ScrollPages

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:56 2005 http://epydoc.sf.net


wx.webkit.WebKitCtrl

Package wx :: Module webkit :: Class WebKitCtrl

Type WebKitCtrl

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
               Control --+
                         |
                        WebKitCtrl

Proxy of C++ WebKitCtrl class

Method Summary
Control | __init__(self, parent, id, pos, size, style, validator, name) Create a Control.
 | __repr__(self)
bool | CanGetPageSource(self)
bool | CanGoBack(self)
bool | CanGoForward(self)
bool | Create(self, parent, id, pos, size, style, validator, name) Do the 2nd phase and create the GUI control.
String | GetPageSource(self)
String | GetPageTitle(self)
String | GetPageURL(self)
bool | GoBack(self)
bool | GoForward(self)
 | LoadURL(self, url)
 | Reload(self)
 | SetPageSource(self, source, baseUrl)
 | Stop(self)

Instance Method Details

__init__(self,
          parent,
          winID=-1,
          strURL=EmptyString,
          pos=DefaultPosition,
          size=DefaultSize,
          style=0,
          validator=DefaultValidator,
          name=WebKitNameStr)
(Constructor)

Create a Control. Normally you should only call this from a subclass' __init__ as a plain old wx.Control is not very useful.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

validator
(type=Validator)

name
(type=String)

Returns:
Control
Overrides:
wx.Control.__init__ (inherited documentation)

Create(self,
          parent,
          winID=-1,
          strURL=EmptyString,
          pos=DefaultPosition,
          size=DefaultSize,
          style=0,
          validator=DefaultValidator,
          name=WebKitNameStr)

Do the 2nd phase and create the GUI control.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

validator
(type=Validator)

name
(type=String)

Returns:
bool
Overrides:
wx.Control.Create (inherited documentation)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:43 2005 http://epydoc.sf.net


wx.webkit.WebKitStateChangedEvent

Package wx :: Module webkit :: Class WebKitStateChangedEvent

Type WebKitStateChangedEvent

object --+
         |
    Object --+
             |
         Event --+
                 |
      CommandEvent --+
                     |
                    WebKitStateChangedEvent

Proxy of C++ WebKitStateChangedEvent class

Method Summary
CommandEvent | __init__(self, commandType, winid) This event class contains information about command events, which originate from a variety of simple controls, as well as menus and toolbars.
 | __repr__(self)
int | GetState(self)
String | GetURL(self)
 | SetState(self, state)
 | SetURL(self, url)

Method Details

__init__(self, win=None)
(Constructor)

This event class contains information about command events, which originate from a variety of simple controls, as well as menus and toolbars.

Parameters:
commandType
(type=wxEventType)

winid
(type=int)

Returns:
CommandEvent
Overrides:
wx.CommandEvent.__init__ (inherited documentation)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:05 2005 http://epydoc.sf.net


wx.webkit

Package wx :: Module webkit

Module wx.webkit

wx.webkit.WebKitCtrl for Mac OSX.

Classes
WebKitCtrl | Proxy of C++ WebKitCtrl class
WebKitStateChangedEvent | Proxy of C++ WebKitStateChangedEvent class

Function Summary
WebKitCtrl PreWebKitCtrl()

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:05 2005 http://epydoc.sf.net


wx.Window

Package wx :: Class Window

Type Window

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
                Window

Known Subclasses:
Canvas, CaptionBar, ColDragWindow, Control, DynamicSashWindow, EmptyChild, GLCanvas, ImageView, MDIClientWindow, MenuBar, MultiClient, MultiCloser, MultiCreator, MultiSash, MultiSizer, MultiSplit, MultiViewLeaf, Panel, PlotCanvas, PlotCanvas, PopupWindow, PyWindow, RowDragWindow, SashWindow, SplashScreenWindow, SplitterWindow, StatusBar, TopLevelWindow, TreeCompanionWindow

wx.Window is the base class for all windows and represents any visible object on the screen. All controls, top level windows and so on are wx.Windows. Sizers and device contexts are not however, as they don't appear on screen themselves.

Styles

wx.SIMPLE_BORDER | Displays a thin border around the window.
wx.DOUBLE_BORDER | Displays a double border. Windows and Mac only.
wx.SUNKEN_BORDER | Displays a sunken border.
wx.RAISED_BORDER | Displays a raised border.
wx.STATIC_BORDER | Displays a border suitable for a static control. Windows only.
wx.NO_BORDER | Displays no border, overriding the default border style for the window.
wx.TRANSPARENT_WINDOW | The window is transparent, that is, it will not receive paint events. Windows only.
wx.TAB_TRAVERSAL | Use this to enable tab traversal for non-dialog windows.
wx.WANTS_CHARS | Use this to indicate that the window wants to get all char/key events for all keys - even for keys like TAB or ENTER which are usually used for dialog navigation and which wouldn't be generated without this style. If you need to use this style in order to get the arrows or etc., but would still like to have normal keyboard navigation take place, you should create and send a wxNavigationKeyEvent in response to the key events for Tab and Shift-Tab.
wx.NO_FULL_REPAINT_ON_RESIZE | Disables repainting the window completely when its size is changed. You will have to repaint the new window area manually if you use this style. As of version 2.5.1 this style is on by default. Use wx.FULL_REPAINT_ON_RESIZE to deactivate it.
wx.VSCROLL | Use this style to enable a vertical scrollbar.
wx.HSCROLL | Use this style to enable a horizontal scrollbar.
wx.ALWAYS_SHOW_SB | If a window has scrollbars, disable them instead of hiding them when they are not needed (i.e. when the size of the window is big enough to not require the scrollbars to navigate it). This style is currently only implemented for wxMSW and wxUniversal and does nothing on the other platforms.
wx.CLIP_CHILDREN | Use this style to eliminate flicker caused by the background being repainted, then children being painted over them. Windows only.
wx.FULL_REPAINT_ON_RESIZE | Use this style to force a complete redraw of the window whenever it is resized instead of redrawing just the part of the window affected by resizing. Note that this was the behaviour by default before 2.5.1 release and that if you experience redraw problems with the code which previously used to work you may want to try this.

Extra Styles

wx.WS_EX_VALIDATE_RECURSIVELY | By default, Validate/TransferDataTo/FromWindow() only work on direct children of the window (compatible behaviour). Set this flag to make them recursively descend into all subwindows.
wx.WS_EX_BLOCK_EVENTS | wx.CommandEvents and the objects of the derived classes are forwarded to the parent window and so on recursively by default. Using this flag for the given window allows to block this propagation at this window, i.e. prevent the events from being propagated further upwards. Dialogs have this flag on by default.
wx.WS_EX_TRANSIENT | Don't use this window as an implicit parent for the other windows: this must be used with transient windows as otherwise there is the risk of creating a dialog/frame with this window as a parent which would lead to a crash if the parent is destroyed before the child.
wx.WS_EX_PROCESS_IDLE | This window should always process idle events, even if the mode set by wx.IdleEvent.SetMode is wx.IDLE_PROCESS_SPECIFIED.
wx.WS_EX_PROCESS_UI_UPDATES | This window should always process UI update events, even if the mode set by wx.UpdateUIEvent.SetMode is wxUPDATE_UI_PROCESS_SPECIFIED.
Method Summary
Window | __init__(self, parent, id, pos, size, style, name) Construct and show a generic Window.
 | __repr__(self)
bool | AcceptsFocus(self) Can this window have focus?
bool | AcceptsFocusFromKeyboard(self) Can this window be given focus by keyboard navigation? if not, the only way to give it focus (provided it accepts it at all) is to click it.
 | AddChild(self, child) Adds a child window.
 | AssociateHandle(self, handle) Associate the window with a new native handle
 | CacheBestSize(self, size) Cache the best size so it doesn't need to be calculated again, (at least until some properties of the window change.)
 | CaptureMouse(self) Directs all mouse input to this window.
 | Center(self, direction) Centers the window.
 | CenterOnParent(self, dir) Center with respect to the the parent window
 | CenterOnScreen(self, dir) Center on screen (only works for top level windows)
 | Centre(self, direction) Centers the window.
 | CentreOnParent(self, dir) Center with respect to the the parent window
 | CentreOnScreen(self, dir) Center on screen (only works for top level windows)
 | ClearBackground(self) Clears the window by filling it with the current background colour.
Point | ClientToScreen(self, pt) Converts to screen coordinates from coordinates relative to this window.
(x,y) | ClientToScreenXY(x, y) Converts to screen coordinates from coordinates relative to this window.
bool | Close(self, force) This function simply generates a EVT_CLOSE event whose handler usually tries to close the window.
Point | ConvertDialogPointToPixels(self, pt) Converts a point or size from dialog units to pixels.
Size | ConvertDialogSizeToPixels(self, sz) Converts a point or size from dialog units to pixels.
Point | ConvertPixelPointToDialog(self, pt)
Size | ConvertPixelSizeToDialog(self, sz)
bool | Create(self, parent, id, pos, size, style, name) Create the GUI part of the Window for 2-phase creation mode.
bool | Destroy(self) Destroys the window safely.
bool | DestroyChildren(self) Destroys all children of a window.
bool | Disable(self) Disables the window, same as Enable(false).
 | DissociateHandle(self) Dissociate the current native handle from the window
Point | DLG_PNT(self, pt) Converts a point or size from dialog units to pixels.
Size | DLG_SZE(self, sz) Converts a point or size from dialog units to pixels.
 | DragAcceptFiles(self, accept) Enables or disables eligibility for drop file events, EVT_DROP_FILES.
bool | Enable(self, enable) Enable or disable the window for user input.
Window | FindFocus() Returns the window or control that currently has the keyboard focus, or None. (Static method)
Window | FindWindowById(self, winid) Find a chld of this window by window ID
Window | FindWindowByName(self, name) Find a child of this window by name
 | Fit(self) Sizes the window so that it fits around its subwindows.
 | FitInside(self) Similar to Fit, but sizes the interior (virtual) size of a window.
 | Freeze(self) Freezes the window or, in other words, prevents any updates from taking place on screen, the window is not redrawn at all.
AcceleratorTable | GetAcceleratorTable(self) Gets the accelerator table for this window.
Size | GetAdjustedBestSize(self) This method is similar to GetBestSize, except in one thing.
bool | GetAutoLayout(self) Returns the current autoLayout setting
Colour | GetBackgroundColour(self) Returns the background colour of the window.
int | GetBackgroundStyle(self) Returns the background style of the window.
Size | GetBestFittingSize(self) This function will merge the window's best size into the window's minimum size, giving priority to the min size components, and returns the results.
Size | GetBestSize(self) This function returns the best acceptable minimal size for the window, if applicable.
(width, height) | GetBestSizeTuple() This function returns the best acceptable minimal size for the window, if applicable.
Size | GetBestVirtualSize(self) Return the largest of ClientSize and BestSize (as determined by a sizer, interior children, or other means)
int | GetBorder(self, flags) GetBorder(self) -> int
Window | GetCapture() Returns the window which currently captures the mouse or None (Static method)
Caret | GetCaret(self) Returns the caret associated with the window.
int | GetCharHeight(self) Get the (average) character size for the current font.
int | GetCharWidth(self) Get the (average) character size for the current font.
PyObject | GetChildren(self) Returns a list of the window's children.
VisualAttributes | GetClassDefaultAttributes(variant) Get the default attributes for this class. (Static method)
Point | GetClientAreaOrigin(self) Get the origin of the client area of the window relative to the window's top left corner (the client area may be shifted because of the borders, scrollbars, other decorations...)
Rect | GetClientRect(self) Get the client area position and size as a wx.Rect object.
Size | GetClientSize(self) This gets the size of the window's 'client area' in pixels.
(width, height) | GetClientSizeTuple() This gets the size of the window's 'client area' in pixels.
LayoutConstraints | GetConstraints(self) Returns a pointer to the window's layout constraints, or None if there are none.
Sizer | GetContainingSizer(self) Return the sizer that this window is a member of, if any, otherwise None.
Cursor | GetCursor(self) Return the cursor associated with this window.
VisualAttributes | GetDefaultAttributes(self) Get the default attributes for an instance of this class.
Window | GetDefaultItem(self) Get the default child of this parent, i.e.
DropTarget | GetDropTarget(self) Returns the associated drop target, which may be None.
EvtHandler | GetEventHandler(self) Returns the event handler for this window.
long | GetExtraStyle(self) Returns the extra style bits for the window.
Font | GetFont(self) Returns the default font used for this window.
Colour | GetForegroundColour(self) Returns the foreground colour of the window.
(width, height, descent, externalLeading) | GetFullTextExtent(string, font) Get the width, height, decent and leading of the text using the current or specified font.
Window | GetGrandParent(self) Returns the parent of the parent of this window, or None if there isn't one.
long | GetHandle(self) Returns the platform-specific handle (as a long integer) of the physical window.
String | GetHelpText(self) Gets the help text to be used as context-sensitive help for this window.
int | GetId(self) Returns the identifier of the window.
String | GetLabel(self) Generic way of getting a label from any window, for identification purposes.
int | GetMaxHeight(self)
Size | GetMaxSize(self)
int | GetMaxWidth(self)
int | GetMinHeight(self)
Size | GetMinSize(self)
int | GetMinWidth(self)
String | GetName(self) Returns the windows name.
Window | GetParent(self) Returns the parent window of this window, or None if there isn't one.
Point | GetPosition(self) Get the window's position.
(x,y) | GetPositionTuple() Get the window's position.
Rect | GetRect(self) Returns the size and position of the window as a wx.Rect object.
int | GetScrollPos(self, orientation) Returns the built-in scrollbar position.
int | GetScrollRange(self, orientation) Returns the built-in scrollbar range.
int | GetScrollThumb(self, orientation) Returns the built-in scrollbar thumb size.
Size | GetSize(self) Get the window size.
Sizer | GetSizer(self) Return the sizer associated with the window by a previous call to SetSizer or None if there isn't one.
(width, height) | GetSizeTuple() Get the window size.
(width, height) | GetTextExtent(string) Get the width and height of the text using the current font.
bool | GetThemeEnabled(self) Return the themeEnabled flag.
String | GetTitle(self) Gets the window's title.
ToolTip | GetToolTip(self) get the associated tooltip or None if none
Rect | GetUpdateClientRect(self) Get the update rectangle region bounding box in client coords.
Region | GetUpdateRegion(self) Returns the region specifying which parts of the window have been damaged.
Validator | GetValidator(self) Returns a pointer to the current validator for the window, or None if there is none.
Size | GetVirtualSize(self) Get the the virtual size of the window in pixels.
(width, height) | GetVirtualSizeTuple() Get the the virtual size of the window in pixels.
long | GetWindowStyle(self) Gets the window style that was passed to the constructor or Create method.
long | GetWindowStyleFlag(self) Gets the window style that was passed to the constructor or Create method.
int | GetWindowVariant(self)
bool | HasCapture(self) Returns true if this window has the current mouse capture.
bool | HasFlag(self, flag) Test if the given style is set for this window.
bool | HasScrollbar(self, orient) Does the window have the scrollbar for this orientation?
bool | HasTransparentBackground(self) Returns True if this window's background is transparent (as, for example, for wx.StaticText) and should show the parent window's background.
bool | Hide(self) Equivalent to calling Show(False).
int | HitTest(self, pt) Test where the given (in client coords) point lies
int | HitTestXY(self, x, y) Test where the given (in client coords) point lies
 | InheritAttributes(self) This function is (or should be, in case of custom controls) called during window creation to intelligently set up the window visual attributes, that is the font and the foreground and background colours.
bool | InheritsBackgroundColour(self)
 | InitDialog(self) Sends an EVT_INIT_DIALOG event, whose handler usually transfers data to the dialog via validators.
 | InvalidateBestSize(self) Reset the cached best size value so it will be recalculated the next time it is needed.
bool | IsBeingDeleted(self) Is the window in the process of being deleted?
bool | IsEnabled(self) Returns true if the window is enabled for input, false otherwise.
bool | IsExposed(self, x, y, w, h) Returns true if the given point or rectangle area has been exposed since the last repaint.
bool | IsExposedPoint(self, pt) Returns true if the given point or rectangle area has been exposed since the last repaint.
bool | IsExposedRect(self, rect) Returns true if the given point or rectangle area has been exposed since the last repaint.
bool | IsRetained(self) Returns true if the window is retained, false otherwise.
bool | IsShown(self) Returns true if the window is shown, false if it has been hidden.
bool | IsTopLevel(self) Returns true if the given window is a top-level one.
bool | Layout(self) Invokes the constraint-based layout algorithm or the sizer-based algorithm for this window.
bool | LineDown(self) This is just a wrapper for ScrollLines(1).
bool | LineUp(self) This is just a wrapper for ScrollLines(-1).
 | Lower(self) Lowers the window to the bottom of the window hierarchy if it is a managed window (dialog or frame).
 | MakeModal(self, modal) Disables all other windows in the application so that the user can only interact with this window.
 | Move(self, pt, flags) Moves the window to the given position.
 | MoveAfterInTabOrder(self, win) Moves this window in the tab navigation order after the specified sibling window.
 | MoveBeforeInTabOrder(self, win) Same as MoveAfterInTabOrder except that it inserts this window just before win instead of putting it right after it.
 | MoveXY(self, x, y, flags) Moves the window to the given position.
bool | Navigate(self, flags) Does keyboard navigation from this window to another, by sending a wx.NavigationKeyEvent.
int | NewControlId() Generate a control id for the controls which were not given one. (Static method)
int | NextControlId(winid) Get the id of the control following the one with the given autogenerated) id (Static method)
bool | PageDown(self) This is just a wrapper for ScrollPages(1).
bool | PageUp(self) This is just a wrapper for ScrollPages(-1).
EvtHandler | PopEventHandler(self, deleteHandler) Removes and returns the top-most event handler on the event handler stack.
bool | PopupMenu(self, menu, pos) Pops up the given menu at the specified coordinates, relative to this window, and returns control when the user has dismissed the menu.
bool | PopupMenuXY(self, menu, x, y) Pops up the given menu at the specified coordinates, relative to this window, and returns control when the user has dismissed the menu.
 | PostCreate(self, pre) Phase 3 of the 2-phase create <wink!> Call this method after precreating the window with the 2-phase create method.
 | PrepareDC(self, dc) Call this function to prepare the device context for drawing a scrolled image.
int | PrevControlId(winid) Get the id of the control preceding the one with the given autogenerated) id (Static method)
 | PushEventHandler(self, handler) Pushes this event handler onto the event handler stack for the window.
 | Raise(self) Raises the window to the top of the window hierarchy if it is a managed window (dialog or frame).
 | Refresh(self, eraseBackground, rect) Mark the specified rectangle (or the whole window) as "dirty" so it will be repainted.
 | RefreshRect(self, rect, eraseBackground) Redraws the contents of the given rectangle: the area inside it will be repainted.
bool | RegisterHotKey(self, hotkeyId, modifiers, keycode) Registers a system wide hotkey.
 | ReleaseMouse(self) Releases mouse input captured with wx.Window.CaptureMouse.
 | RemoveChild(self, child) Removes a child window.
bool | RemoveEventHandler(self, handler) Find the given handler in the event handler chain and remove (but not delete) it from the event handler chain, return True if it was found and False otherwise (this also results in an assert failure so this function should only be called when the handler is supposed to be there.)
bool | Reparent(self, newParent) Reparents the window, i.e the window will be removed from its current parent window (e.g.
Point | ScreenToClient(self, pt) Converts from screen to client window coordinates.
(x,y) | ScreenToClientXY(x, y) Converts from screen to client window coordinates.
bool | ScrollLines(self, lines) If the platform and window class supports it, scrolls the window by the given number of lines down, if lines is positive, or up if lines is negative.
bool | ScrollPages(self, pages) If the platform and window class supports it, scrolls the window by the given number of pages down, if pages is positive, or up if pages is negative.
 | ScrollWindow(self, dx, dy, rect) Physically scrolls the pixels in the window and move child windows accordingly.
 | SetAcceleratorTable(self, accel) Sets the accelerator table for this window.
 | SetAutoLayout(self, autoLayout) Determines whether the Layout function will be called automatically when the window is resized.
bool | SetBackgroundColour(self, colour) Sets the background colour of the window.
bool | SetBackgroundStyle(self, style) Returns the background style of the window.
 | SetBestFittingSize(self, size) A 'Smart' SetSize that will fill in default size components with the window's best size values.
 | SetCaret(self, caret) Sets the caret associated with the window.
 | SetClientRect(self, rect) This sets the size of the window client area in pixels.
 | SetClientSize(self, size) This sets the size of the window client area in pixels.
 | SetClientSizeWH(self, width, height) This sets the size of the window client area in pixels.
 | SetConstraints(self, constraints) Sets the window to have the given layout constraints.
 | SetContainingSizer(self, sizer) This normally does not need to be called by application code.
bool | SetCursor(self, cursor) Sets the window's cursor.
Window | SetDefaultItem(self, child) Set this child as default, return the old default.
 | SetDimensions(self, x, y, width, height, sizeFlags) Sets the position and size of the window in pixels.
 | SetDropTarget(self, dropTarget) Associates a drop target with this window.
 | SetEventHandler(self, handler) Sets the event handler for this window.
 | SetExtraStyle(self, exStyle) Sets the extra style bits for the window.
 | SetFocus(self) Set's the focus to this window, allowing it to receive keyboard input.
 | SetFocusFromKbd(self) Set focus to this window as the result of a keyboard action.
bool | SetFont(self, font) Sets the font for this window.
bool | SetForegroundColour(self, colour) Sets the foreground colour of the window.
 | SetHelpText(self, text) Sets the help text to be used as context-sensitive help for this window.
 | SetHelpTextForId(self, text) Associate this help text with all windows with the same id as this one.
 | SetId(self, winid) Sets the identifier of the window.
 | SetLabel(self, label) Set the text which the window shows in its label if applicable.
 | SetMaxSize(self, maxSize) A more convenient method than SetSizeHints for setting just the max size.
 | SetMinSize(self, minSize) A more convenient method than SetSizeHints for setting just the min size.
 | SetName(self, name) Sets the window's name.
 | SetOwnBackgroundColour(self, colour)
 | SetOwnFont(self, font)
 | SetOwnForegroundColour(self, colour)
 | SetPosition(self, pt, flags) Moves the window to the given position.
 | SetRect(self, rect, sizeFlags) Sets the position and size of the window in pixels using a wx.Rect.
 | SetScrollbar(self, orientation, position, thumbSize, range, refresh)
 | SetScrollPos(self, orientation, pos, refresh) Sets the position of one of the built-in scrollbars.
 | SetSize(self, size) Sets the size of the window in pixels.
 | SetSizeHints(self, minW, minH, maxW, maxH, incW, incH) Allows specification of minimum and maximum window sizes, and window size increments.
 | SetSizeHintsSz(self, minSize, maxSize, incSize) Allows specification of minimum and maximum window sizes, and window size increments.
 | SetSizer(self, sizer, deleteOld) Sets the window to have the given layout sizer.
 | SetSizerAndFit(self, sizer, deleteOld) The same as SetSizer, except it also sets the size hints for the window based on the sizer's minimum size.
 | SetSizeWH(self, width, height) Sets the size of the window in pixels.
 | SetThemeEnabled(self, enableTheme) code to draw the windows' background instead if its own background drawing code.
 | SetTitle(self, title) Sets the window's title.
 | SetTmpDefaultItem(self, win) Set this child as temporary default
 | SetToolTip(self, tip) Attach a tooltip to the window.
 | SetToolTipString(self, tip) Attach a tooltip to the window.
 | SetValidator(self, validator) Deletes the current validator (if any) and sets the window validator, having called wx.Validator.Clone to create a new validator of this type.
 | SetVirtualSize(self, size) Set the the virtual size of a window in pixels.
 | SetVirtualSizeHints(self, minW, minH, maxW, maxH) Allows specification of minimum and maximum virtual window sizes.
 | SetVirtualSizeHintsSz(self, minSize, maxSize) Allows specification of minimum and maximum virtual window sizes.
 | SetVirtualSizeWH(self, w, h) Set the the virtual size of a window in pixels.
 | SetWindowStyle(self, style) Sets the style of the window.
 | SetWindowStyleFlag(self, style) Sets the style of the window.
 | SetWindowVariant(self, variant) Sets the variant of the window/font size to use for this window, if the platform supports variants, for example, wxMac.
bool | ShouldInheritColours(self) Return true from here to allow the colours of this window to be changed by InheritAttributes, returning false forbids inheriting them from the parent window.
bool | Show(self, show) Shows or hides the window.
 | Thaw(self) Reenables window updating after a previous call to Freeze.
bool | TransferDataFromWindow(self) Transfers values from child controls to data areas specified by their validators.
bool | TransferDataToWindow(self) Transfers values to child controls from data areas specified by their validators.
bool | UnregisterHotKey(self, hotkeyId) Unregisters a system wide hotkey.
 | Update(self) Calling this method immediately repaints the invalidated area of the window instead of waiting for the EVT_PAINT event to happen, (normally this would usually only happen when the flow of control returns to the event loop.) Notice that this function doesn't refresh the window and does nothing if the window has been already repainted.
 | UpdateWindowUI(self, flags) This function sends EVT_UPDATE_UI events to the window.
bool | UseBgCol(self)
bool | Validate(self) Validates the current values of the child controls using their validators.
 | WarpPointer(self, x, y) Moves the pointer to the given position on the window.

Instance Method Details

__init__(self,
          parent,
          id=-1,
          pos=DefaultPosition,
          size=DefaultSize,
          style=0,
          name=PanelNameStr)
(Constructor)

Construct and show a generic Window.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

name
(type=String)

Returns:
Window
Overrides:
wx.EvtHandler.__init__

AcceptsFocus(self)

Can this window have focus?

Returns:
bool

AcceptsFocusFromKeyboard(self)

Can this window be given focus by keyboard navigation? if not, the only way to give it focus (provided it accepts it at all) is to click it.

Returns:
bool

AddChild(self, child)

Adds a child window. This is called automatically by window creation functions so should not be required by the application programmer.

Parameters:
child
(type=Window)

AssociateHandle(self, handle)

Associate the window with a new native handle

Parameters:
handle
(type=long)

CacheBestSize(self, size)

Cache the best size so it doesn't need to be calculated again, (at least until some properties of the window change.)

Parameters:
size
(type=Size)

CaptureMouse(self)

Directs all mouse input to this window. Call wx.Window.ReleaseMouse to release the capture.

Note that wxWindows maintains the stack of windows having captured the mouse and when the mouse is released the capture returns to the window which had had captured it previously and it is only really released if there were no previous window. In particular, this means that you must release the mouse as many times as you capture it.

Center(self, direction=BOTH)

Centers the window. The parameter specifies the direction for cetering, and may be wx.HORIZONTAL, wx.VERTICAL or wx.BOTH. It may also include wx.CENTER_ON_SCREEN flag if you want to center the window on the entire screen and not on its parent window. If it is a top-level window and has no parent then it will always be centered relative to the screen.

Parameters:
direction
(type=int)

CenterOnParent(self, dir=BOTH)

Center with respect to the the parent window

Parameters:
dir
(type=int)

CenterOnScreen(self, dir=BOTH)

Center on screen (only works for top level windows)

Parameters:
dir
(type=int)

Centre(self, direction=BOTH)

Centers the window. The parameter specifies the direction for cetering, and may be wx.HORIZONTAL, wx.VERTICAL or wx.BOTH. It may also include wx.CENTER_ON_SCREEN flag if you want to center the window on the entire screen and not on its parent window. If it is a top-level window and has no parent then it will always be centered relative to the screen.

Parameters:
direction
(type=int)

CentreOnParent(self, dir=BOTH)

Center with respect to the the parent window

Parameters:
dir
(type=int)

CentreOnScreen(self, dir=BOTH)

Center on screen (only works for top level windows)

Parameters:
dir
(type=int)

ClearBackground(self)

Clears the window by filling it with the current background colour. Does not cause an erase background event to be generated.

ClientToScreen(self, pt)

Converts to screen coordinates from coordinates relative to this window.

Parameters:
pt
(type=Point)

Returns:
Point

ClientToScreenXY(x, y)

Converts to screen coordinates from coordinates relative to this window.

Parameters:
x
(type=int)

y
(type=int)

Returns:
(x,y)

Close(self, force=False)

This function simply generates a EVT_CLOSE event whose handler usually tries to close the window. It doesn't close the window itself, however. If force is False (the default) then the window's close handler will be allowed to veto the destruction of the window. Usually Close is only used with the top level windows (wx.Frame and wx.Dialog classes) as the others are not supposed to have any special EVT_CLOSE logic.

The close handler should check whether the window is being deleted forcibly, using wx.CloseEvent.GetForce, in which case it should destroy the window using wx.Window.Destroy.

Note that calling Close does not guarantee that the window will be destroyed; but it provides a way to simulate a manual close of a window, which may or may not be implemented by destroying the window. The default EVT_CLOSE handler for wx.Dialog does not necessarily delete the dialog, since it will simply simulate an wxID_CANCEL event which is handled by the appropriate button event handler and may do anything at all.

To guarantee that the window will be destroyed, call wx.Window.Destroy instead.

Parameters:
force
(type=bool)

Returns:
bool

ConvertDialogPointToPixels(self, pt)

Converts a point or size from dialog units to pixels. Dialog units are used for maintaining a dialog's proportions even if the font changes. For the x dimension, the dialog units are multiplied by the average character width and then divided by 4. For the y dimension, the dialog units are multiplied by the average character height and then divided by 8.

Parameters:
pt
(type=Point)

Returns:
Point

ConvertDialogSizeToPixels(self, sz)

Converts a point or size from dialog units to pixels. Dialog units are used for maintaining a dialog's proportions even if the font changes. For the x dimension, the dialog units are multiplied by the average character width and then divided by 4. For the y dimension, the dialog units are multiplied by the average character height and then divided by 8.

Parameters:
sz
(type=Size)

Returns:
Size

Create(self,
          parent,
          id=-1,
          pos=DefaultPosition,
          size=DefaultSize,
          style=0,
          name=PanelNameStr)

Create the GUI part of the Window for 2-phase creation mode.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

name
(type=String)

Returns:
bool

Destroy(self)

Destroys the window safely. Frames and dialogs are not destroyed immediately when this function is called -- they are added to a list of windows to be deleted on idle time, when all the window's events have been processed. This prevents problems with events being sent to non-existent windows.

Returns True if the window has either been successfully deleted, or it has been added to the list of windows pending real deletion.

Returns:
bool
Overrides:
wx.Object.Destroy

DestroyChildren(self)

Destroys all children of a window. Called automatically by the destructor.

Returns:
bool

Disable(self)

Disables the window, same as Enable(false).

Returns:
bool

DissociateHandle(self)

Dissociate the current native handle from the window

DLG_PNT(self, pt)

Converts a point or size from dialog units to pixels. Dialog units are used for maintaining a dialog's proportions even if the font changes. For the x dimension, the dialog units are multiplied by the average character width and then divided by 4. For the y dimension, the dialog units are multiplied by the average character height and then divided by 8.

Parameters:
pt
(type=Point)

Returns:
Point

DLG_SZE(self, sz)

Converts a point or size from dialog units to pixels. Dialog units are used for maintaining a dialog's proportions even if the font changes. For the x dimension, the dialog units are multiplied by the average character width and then divided by 4. For the y dimension, the dialog units are multiplied by the average character height and then divided by 8.

Parameters:
sz
(type=Size)

Returns:
Size

DragAcceptFiles(self, accept)

Enables or disables eligibility for drop file events, EVT_DROP_FILES. Only functional on Windows.

Parameters:
accept
(type=bool)

Enable(self, enable=True)

Enable or disable the window for user input. Note that when a parent window is disabled, all of its children are disabled as well and they are reenabled again when the parent is. Returns true if the window has been enabled or disabled, false if nothing was done, i.e. if the window had already been in the specified state.

Parameters:
enable
(type=bool)

Returns:
bool

FindWindowById(self, winid)

Find a chld of this window by window ID

Parameters:
winid
(type=long)

Returns:
Window

FindWindowByName(self, name)

Find a child of this window by name

Parameters:
name
(type=String)

Returns:
Window

Fit(self)

Sizes the window so that it fits around its subwindows. This function won't do anything if there are no subwindows and will only really work correctly if sizers are used for the subwindows layout. Also, if the window has exactly one subwindow it is better (faster and the result is more precise as Fit adds some margin to account for fuzziness of its calculations) to call window.SetClientSize(child.GetSize()) instead of calling Fit.

FitInside(self)

Similar to Fit, but sizes the interior (virtual) size of a window. Mainly useful with scrolled windows to reset scrollbars after sizing changes that do not trigger a size event, and/or scrolled windows without an interior sizer. This function similarly won't do anything if there are no subwindows.

Freeze(self)

Freezes the window or, in other words, prevents any updates from taking place on screen, the window is not redrawn at all. Thaw must be called to reenable window redrawing. Calls to Freeze/Thaw may be nested, with the actual Thaw being delayed until all the nesting has been undone.

This method is useful for visual appearance optimization (for example, it is a good idea to use it before inserting large amount of text into a wxTextCtrl under wxGTK) but is not implemented on all platforms nor for all controls so it is mostly just a hint to wxWindows and not a mandatory directive.

GetAcceleratorTable(self)

Gets the accelerator table for this window.

Returns:
AcceleratorTable

GetAdjustedBestSize(self)

This method is similar to GetBestSize, except in one thing. GetBestSize should return the minimum untruncated size of the window, while this method will return the largest of BestSize and any user specified minimum size. ie. it is the minimum size the window should currently be drawn at, not the minimal size it can possibly tolerate.

Returns:
Size

GetAutoLayout(self)

Returns the current autoLayout setting

Returns:
bool

GetBackgroundColour(self)

Returns the background colour of the window.

Returns:
Colour

GetBackgroundStyle(self)

Returns the background style of the window.

Returns:
int

See Also:

SetBackgroundStyle

GetBestFittingSize(self)

This function will merge the window's best size into the window's minimum size, giving priority to the min size components, and returns the results.

Returns:
Size

GetBestSize(self)

This function returns the best acceptable minimal size for the window, if applicable. For example, for a static text control, it will be the minimal size such that the control label is not truncated. For windows containing subwindows (suzh aswx.Panel), the size returned by this function will be the same as the size the window would have had after calling Fit.

Returns:
Size

GetBestSizeTuple()

This function returns the best acceptable minimal size for the window, if applicable. For example, for a static text control, it will be the minimal size such that the control label is not truncated. For windows containing subwindows (suzh aswx.Panel), the size returned by this function will be the same as the size the window would have had after calling Fit.

Returns:
(width, height)

GetBestVirtualSize(self)

Return the largest of ClientSize and BestSize (as determined by a sizer, interior children, or other means)

Returns:
Size

GetBorder(self, flags)

GetBorder(self) -> int

Get border for the flags of this window

Parameters:
flags
(type=long)

Returns:
int

GetCaret(self)

Returns the caret associated with the window.

Returns:
Caret

GetCharHeight(self)

Get the (average) character size for the current font.

Returns:
int

GetCharWidth(self)

Get the (average) character size for the current font.

Returns:
int

GetChildren(self)

Returns a list of the window's children. NOTE: Currently this is a copy of the child window list maintained by the window, so the return value of this function is only valid as long as the window's children do not change.

Returns:
PyObject

GetClientAreaOrigin(self)

Get the origin of the client area of the window relative to the window's top left corner (the client area may be shifted because of the borders, scrollbars, other decorations...)

Returns:
Point

GetClientRect(self)

Get the client area position and size as a wx.Rect object.

Returns:
Rect

GetClientSize(self)

This gets the size of the window's 'client area' in pixels. The client area is the area which may be drawn on by the programmer, excluding title bar, border, scrollbars, etc.

Returns:
Size

GetClientSizeTuple()

This gets the size of the window's 'client area' in pixels. The client area is the area which may be drawn on by the programmer, excluding title bar, border, scrollbars, etc.

Returns:
(width, height)

GetConstraints(self)

Returns a pointer to the window's layout constraints, or None if there are none.

Returns:
LayoutConstraints

GetContainingSizer(self)

Return the sizer that this window is a member of, if any, otherwise None.

Returns:
Sizer

GetCursor(self)

Return the cursor associated with this window.

Returns:
Cursor

GetDefaultAttributes(self)

Get the default attributes for an instance of this class. This is useful if you want to use the same font or colour in your own control as in a standard control -- which is a much better idea than hard coding specific colours or fonts which might look completely out of place on the user's system, especially if it uses themes.

Returns:
VisualAttributes

GetDefaultItem(self)

Get the default child of this parent, i.e. the one which is activated by pressing <Enter> such as the OK button on a wx.Dialog.

Returns:
Window

GetDropTarget(self)

Returns the associated drop target, which may be None.

Returns:
DropTarget

GetEventHandler(self)

Returns the event handler for this window. By default, the window is its own event handler.

Returns:
EvtHandler

GetExtraStyle(self)

Returns the extra style bits for the window.

Returns:
long

GetFont(self)

Returns the default font used for this window.

Returns:
Font

GetForegroundColour(self)

Returns the foreground colour of the window. The interpretation of foreground colour is dependent on the window class; it may be the text colour or other colour, or it may not be used at all.

Returns:
Colour

GetFullTextExtent(string, font=None)

Get the width, height, decent and leading of the text using the current or specified font.

Parameters:
string
(type=String)

font
(type=Font)

Returns:
(width, height, descent, externalLeading)

GetGrandParent(self)

Returns the parent of the parent of this window, or None if there isn't one.

Returns:
Window

GetHandle(self)

Returns the platform-specific handle (as a long integer) of the physical window. Currently on wxMac it returns the handle of the toplevel parent of the window.

Returns:
long

GetHelpText(self)

Gets the help text to be used as context-sensitive help for this window. Note that the text is actually stored by the current wxHelpProvider implementation, and not in the window object itself.

Returns:
String

GetId(self)

Returns the identifier of the window. Each window has an integer identifier. If the application has not provided one (or the default Id -1 is used) then an unique identifier with a negative value will be generated.

Returns:
int

GetLabel(self)

Generic way of getting a label from any window, for identification purposes. The interpretation of this function differs from class to class. For frames and dialogs, the value returned is the title. For buttons or static text controls, it is the button text. This function can be useful for meta-programs such as testing tools or special-needs access programs)which need to identify windows by name.

Returns:
String

GetName(self)

Returns the windows name. This name is not guaranteed to be unique; it is up to the programmer to supply an appropriate name in the window constructor or via wx.Window.SetName.

Returns:
String

GetParent(self)

Returns the parent window of this window, or None if there isn't one.

Returns:
Window

GetPosition(self)

Get the window's position.

Returns:
Point

GetPositionTuple()

Get the window's position.

Returns:
(x,y)

GetRect(self)

Returns the size and position of the window as a wx.Rect object.

Returns:
Rect

GetScrollPos(self, orientation)

Returns the built-in scrollbar position.

Parameters:
orientation
(type=int)

Returns:
int

GetScrollRange(self, orientation)

Returns the built-in scrollbar range.

Parameters:
orientation
(type=int)

Returns:
int

GetScrollThumb(self, orientation)

Returns the built-in scrollbar thumb size.

Parameters:
orientation
(type=int)

Returns:
int

GetSize(self)

Get the window size.

Returns:
Size

GetSizer(self)

Return the sizer associated with the window by a previous call to SetSizer or None if there isn't one.

Returns:
Sizer

GetSizeTuple()

Get the window size.

Returns:
(width, height)

GetTextExtent(string)

Get the width and height of the text using the current font.

Parameters:
string
(type=String)

Returns:
(width, height)

GetThemeEnabled(self)

Return the themeEnabled flag.

Returns:
bool

GetTitle(self)

Gets the window's title. Applicable only to frames and dialogs.

Returns:
String

GetToolTip(self)

get the associated tooltip or None if none

Returns:
ToolTip

GetUpdateClientRect(self)

Get the update rectangle region bounding box in client coords.

Returns:
Rect

GetUpdateRegion(self)

Returns the region specifying which parts of the window have been damaged. Should only be called within an EVT_PAINT handler.

Returns:
Region

GetValidator(self)

Returns a pointer to the current validator for the window, or None if there is none.

Returns:
Validator

GetVirtualSize(self)

Get the the virtual size of the window in pixels. For most windows this is just the client area of the window, but for some like scrolled windows it is more or less independent of the screen window size.

Returns:
Size

GetVirtualSizeTuple()

Get the the virtual size of the window in pixels. For most windows this is just the client area of the window, but for some like scrolled windows it is more or less independent of the screen window size.

Returns:
(width, height)

GetWindowStyle(self)

Gets the window style that was passed to the constructor or Create method.

Returns:
long

GetWindowStyleFlag(self)

Gets the window style that was passed to the constructor or Create method.

Returns:
long

HasCapture(self)

Returns true if this window has the current mouse capture.

Returns:
bool

HasFlag(self, flag)

Test if the given style is set for this window.

Parameters:
flag
(type=int)

Returns:
bool

HasScrollbar(self, orient)

Does the window have the scrollbar for this orientation?

Parameters:
orient
(type=int)

Returns:
bool

HasTransparentBackground(self)

Returns True if this window's background is transparent (as, for example, for wx.StaticText) and should show the parent window's background.

This method is mostly used internally by the library itself and you normally shouldn't have to call it. You may, however, have to override it in your custom control classes to ensure that background is painted correctly.

Returns:
bool

Hide(self)

Equivalent to calling Show(False).

Returns:
bool

HitTest(self, pt)

Test where the given (in client coords) point lies

Parameters:
pt
(type=Point)

Returns:
int

HitTestXY(self, x, y)

Test where the given (in client coords) point lies

Parameters:
x
(type=int)

y
(type=int)

Returns:
int

InheritAttributes(self)

This function is (or should be, in case of custom controls) called during window creation to intelligently set up the window visual attributes, that is the font and the foreground and background colours.

By 'intelligently' the following is meant: by default, all windows use their own default attributes. However if some of the parent's attributes are explicitly changed (that is, using SetFont and not SetOwnFont) and if the corresponding attribute hadn't been explicitly set for this window itself, then this window takes the same value as used by the parent. In addition, if the window overrides ShouldInheritColours to return false, the colours will not be changed no matter what and only the font might.

This rather complicated logic is necessary in order to accommodate the different usage scenarios. The most common one is when all default attributes are used and in this case, nothing should be inherited as in modern GUIs different controls use different fonts (and colours) than their siblings so they can't inherit the same value from the parent. However it was also deemed desirable to allow to simply change the attributes of all children at once by just changing the font or colour of their common parent, hence in this case we do inherit the parents attributes.

InitDialog(self)

Sends an EVT_INIT_DIALOG event, whose handler usually transfers data to the dialog via validators.

InvalidateBestSize(self)

Reset the cached best size value so it will be recalculated the next time it is needed.

IsBeingDeleted(self)

Is the window in the process of being deleted?

Returns:
bool

IsEnabled(self)

Returns true if the window is enabled for input, false otherwise.

Returns:
bool

IsExposed(self, x, y, w=1, h=1)

Returns true if the given point or rectangle area has been exposed since the last repaint. Call this in an paint event handler to optimize redrawing by only redrawing those areas, which have been exposed.

Parameters:
x
(type=int)

y
(type=int)

w
(type=int)

h
(type=int)

Returns:
bool

IsExposedPoint(self, pt)

Returns true if the given point or rectangle area has been exposed since the last repaint. Call this in an paint event handler to optimize redrawing by only redrawing those areas, which have been exposed.

Parameters:
pt
(type=Point)

Returns:
bool

IsExposedRect(self, rect)

Returns true if the given point or rectangle area has been exposed since the last repaint. Call this in an paint event handler to optimize redrawing by only redrawing those areas, which have been exposed.

Parameters:
rect
(type=Rect)

Returns:
bool

IsRetained(self)

Returns true if the window is retained, false otherwise. Retained windows are only available on X platforms.

Returns:
bool

IsShown(self)

Returns true if the window is shown, false if it has been hidden.

Returns:
bool

IsTopLevel(self)

Returns true if the given window is a top-level one. Currently all frames and dialogs are always considered to be top-level windows (even if they have a parent window).

Returns:
bool

Layout(self)

Invokes the constraint-based layout algorithm or the sizer-based algorithm for this window. See SetAutoLayout: when auto layout is on, this function gets called automatically by the default EVT_SIZE handler when the window is resized.

Returns:
bool

LineDown(self)

This is just a wrapper for ScrollLines(1).

Returns:
bool

LineUp(self)

This is just a wrapper for ScrollLines(-1).

Returns:
bool

Lower(self)

Lowers the window to the bottom of the window hierarchy if it is a managed window (dialog or frame).

MakeModal(self, modal=True)

Disables all other windows in the application so that the user can only interact with this window. Passing False will reverse this effect.

Parameters:
modal
(type=bool)

Move(self, pt, flags=SIZE_USE_EXISTING)

Moves the window to the given position.

Parameters:
pt
(type=Point)

flags
(type=int)

MoveAfterInTabOrder(self, win)

Moves this window in the tab navigation order after the specified sibling window. This means that when the user presses the TAB key on that other window, the focus switches to this window.

The default tab order is the same as creation order. This function and MoveBeforeInTabOrder allow to change it after creating all the windows.

Parameters:
win
(type=Window)

MoveBeforeInTabOrder(self, win)

Same as MoveAfterInTabOrder except that it inserts this window just before win instead of putting it right after it.

Parameters:
win
(type=Window)

MoveXY(self, x, y, flags=SIZE_USE_EXISTING)

Moves the window to the given position.

Parameters:
x
(type=int)

y
(type=int)

flags
(type=int)

Navigate(self, flags=NavigationKeyEvent.IsForward)

Does keyboard navigation from this window to another, by sending a wx.NavigationKeyEvent.

One situation in which you may wish to call this method is from a text control custom keypress handler to do the default navigation behaviour for the tab key, since the standard default behaviour for a multiline text control with the wx.TE_PROCESS_TAB style is to insert a tab and not navigate to the next control.

Parameters:
flags - A combination of the IsForward or IsBackward and the WinChange values in the wx.NavigationKeyEvent class, which determine if the navigation should be in forward or reverse order, and if it should be able to cross parent window boundaries, such as between notebook pages or MDI child frames. Typically the status of the Shift key (for forward or backward) or the Control key (for WinChange) would be used to determine how to set the flags.
(type=int)

Returns:
bool

PageDown(self)

This is just a wrapper for ScrollPages(1).

Returns:
bool

PageUp(self)

This is just a wrapper for ScrollPages(-1).

Returns:
bool

PopEventHandler(self, deleteHandler=False)

Removes and returns the top-most event handler on the event handler stack. If deleteHandler is True then the wx.EvtHandler object will be destroyed after it is popped.

Parameters:
deleteHandler
(type=bool)

Returns:
EvtHandler

PopupMenu(self, menu, pos=DefaultPosition)

Pops up the given menu at the specified coordinates, relative to this window, and returns control when the user has dismissed the menu. If a menu item is selected, the corresponding menu event is generated and will be processed as usual. If the default position is given then the current position of the mouse cursor will be used.

Parameters:
menu
(type=Menu)

pos
(type=Point)

Returns:
bool

PopupMenuXY(self, menu, x=-1, y=-1)

Pops up the given menu at the specified coordinates, relative to this window, and returns control when the user has dismissed the menu. If a menu item is selected, the corresponding menu event is generated and will be processed as usual. If the default position is given then the current position of the mouse cursor will be used.

Parameters:
menu
(type=Menu)

x
(type=int)

y
(type=int)

Returns:
bool

PostCreate(self, pre)

Phase 3 of the 2-phase create <wink!> Call this method after precreating the window with the 2-phase create method.

PrepareDC(self, dc)

Call this function to prepare the device context for drawing a scrolled image. It sets the device origin according to the current scroll position.

Parameters:
dc
(type=DC)

PushEventHandler(self, handler)

Pushes this event handler onto the event handler stack for the window. An event handler is an object that is capable of processing the events sent to a window. By default, the window is its own event handler, but an application may wish to substitute another, for example to allow central implementation of event-handling for a variety of different window classes.

wx.Window.PushEventHandler allows an application to set up a chain of event handlers, where an event not handled by one event handler is handed to the next one in the chain. Use wx.Window.PopEventHandler to remove the event handler.

Parameters:
handler
(type=EvtHandler)

Raise(self)

Raises the window to the top of the window hierarchy if it is a managed window (dialog or frame).

Refresh(self, eraseBackground=True, rect=None)

Mark the specified rectangle (or the whole window) as "dirty" so it will be repainted. Causes an EVT_PAINT event to be generated and sent to the window.

Parameters:
eraseBackground
(type=bool)

rect
(type=Rect)

RefreshRect(self, rect, eraseBackground=True)

Redraws the contents of the given rectangle: the area inside it will be repainted. This is the same as Refresh but has a nicer syntax.

Parameters:
rect
(type=Rect)

eraseBackground
(type=bool)

RegisterHotKey(self, hotkeyId, modifiers, keycode)

Registers a system wide hotkey. Every time the user presses the hotkey registered here, this window will receive a hotkey event. It will receive the event even if the application is in the background and does not have the input focus because the user is working with some other application. To bind an event handler function to this hotkey use EVT_HOTKEY with an id equal to hotkeyId. Returns True if the hotkey was registered successfully.

Parameters:
hotkeyId
(type=int)

modifiers
(type=int)

keycode
(type=int)

Returns:
bool

ReleaseMouse(self)

Releases mouse input captured with wx.Window.CaptureMouse.

RemoveChild(self, child)

Removes a child window. This is called automatically by window deletion functions so should not be required by the application programmer.

Parameters:
child
(type=Window)

RemoveEventHandler(self, handler)

Find the given handler in the event handler chain and remove (but not delete) it from the event handler chain, return True if it was found and False otherwise (this also results in an assert failure so this function should only be called when the handler is supposed to be there.)

Parameters:
handler
(type=EvtHandler)

Returns:
bool

Reparent(self, newParent)

Reparents the window, i.e the window will be removed from its current parent window (e.g. a non-standard toolbar in a wxFrame) and then re-inserted into another. Available on Windows and GTK. Returns True if the parent was changed, False otherwise (error or newParent == oldParent)

Parameters:
newParent
(type=Window)

Returns:
bool

ScreenToClient(self, pt)

Converts from screen to client window coordinates.

Parameters:
pt
(type=Point)

Returns:
Point

ScreenToClientXY(x, y)

Converts from screen to client window coordinates.

Parameters:
x
(type=int)

y
(type=int)

Returns:
(x,y)

ScrollLines(self, lines)

If the platform and window class supports it, scrolls the window by the given number of lines down, if lines is positive, or up if lines is negative. Returns True if the window was scrolled, False if it was already on top/bottom and nothing was done.

Parameters:
lines
(type=int)

Returns:
bool

ScrollPages(self, pages)

If the platform and window class supports it, scrolls the window by the given number of pages down, if pages is positive, or up if pages is negative. Returns True if the window was scrolled, False if it was already on top/bottom and nothing was done.

Parameters:
pages
(type=int)

Returns:
bool

ScrollWindow(self, dx, dy, rect=None)

Physically scrolls the pixels in the window and move child windows accordingly. Use this function to optimise your scrolling implementations, to minimise the area that must be redrawn. Note that it is rarely required to call this function from a user program.

Parameters:
dx - Amount to scroll horizontally.
(type=int)

dy - Amount to scroll vertically.
(type=int)

rect - Rectangle to invalidate. If this is None, the whole window is invalidated. If you pass a rectangle corresponding to the area of the window exposed by the scroll, your painting handler can optimize painting by checking for the invalidated region.
(type=Rect)

SetAcceleratorTable(self, accel)

Sets the accelerator table for this window.

Parameters:
accel
(type=AcceleratorTable)

SetAutoLayout(self, autoLayout)

Determines whether the Layout function will be called automatically when the window is resized. It is called implicitly by SetSizer but if you use SetConstraints you should call it manually or otherwise the window layout won't be correctly updated when its size changes.

Parameters:
autoLayout
(type=bool)

SetBackgroundColour(self, colour)

Sets the background colour of the window. Returns True if the colour was changed. The background colour is usually painted by the default EVT_ERASE_BACKGROUND event handler function under Windows and automatically under GTK. Using wx.NullColour will reset the window to the default background colour.

Note that setting the background colour may not cause an immediate refresh, so you may wish to call ClearBackground or Refresh after calling this function.

Using this function will disable attempts to use themes for this window, if the system supports them. Use with care since usually the themes represent the appearance chosen by the user to be used for all applications on the system.

Parameters:
colour
(type=Colour)

Returns:
bool

SetBackgroundStyle(self, style)

Returns the background style of the window. The background style indicates how the background of the window is drawn.

wx.BG_STYLE_SYSTEM | The background colour or pattern should be determined by the system
wx.BG_STYLE_COLOUR | The background should be a solid colour
wx.BG_STYLE_CUSTOM | The background will be implemented by the application.

On GTK+, use of wx.BG_STYLE_CUSTOM allows the flicker-free drawing of a custom background, such as a tiled bitmap. Currently the style has no effect on other platforms.

Parameters:
style
(type=int)

Returns:
bool

See Also:

GetBackgroundStyle, SetBackgroundColour

SetBestFittingSize(self, size=DefaultSize)

A 'Smart' SetSize that will fill in default size components with the window's best size values. Also set's the minsize for use with sizers.

Parameters:
size
(type=Size)

SetCaret(self, caret)

Sets the caret associated with the window.

Parameters:
caret
(type=Caret)

SetClientRect(self, rect)

This sets the size of the window client area in pixels. Using this function to size a window tends to be more device-independent than wx.Window.SetSize, since the application need not worry about what dimensions the border or title bar have when trying to fit the window around panel items, for example.

Parameters:
rect
(type=Rect)

SetClientSize(self, size)

This sets the size of the window client area in pixels. Using this function to size a window tends to be more device-independent than wx.Window.SetSize, since the application need not worry about what dimensions the border or title bar have when trying to fit the window around panel items, for example.

Parameters:
size
(type=Size)

SetClientSizeWH(self, width, height)

This sets the size of the window client area in pixels. Using this function to size a window tends to be more device-independent than wx.Window.SetSize, since the application need not worry about what dimensions the border or title bar have when trying to fit the window around panel items, for example.

Parameters:
width
(type=int)

height
(type=int)

SetConstraints(self, constraints)

Sets the window to have the given layout constraints. If an existing layout constraints object is already owned by the window, it will be deleted. Pass None to disassociate and delete the window's current constraints.

You must call SetAutoLayout to tell a window to use the constraints automatically in its default EVT_SIZE handler; otherwise, you must handle EVT_SIZE yourself and call Layout() explicitly. When setting both a wx.LayoutConstraints and a wx.Sizer, only the sizer will have effect.

Parameters:
constraints
(type=LayoutConstraints)

SetContainingSizer(self, sizer)

This normally does not need to be called by application code. It is called internally when a window is added to a sizer, and is used so the window can remove itself from the sizer when it is destroyed.

Parameters:
sizer
(type=Sizer)

SetCursor(self, cursor)

Sets the window's cursor. Notice that the window cursor also sets it for the children of the window implicitly.

The cursor may be wx.NullCursor in which case the window cursor will be reset back to default.

Parameters:
cursor
(type=Cursor)

Returns:
bool

SetDefaultItem(self, child)

Set this child as default, return the old default.

Parameters:
child
(type=Window)

Returns:
Window

SetDimensions(self, x, y, width, height, sizeFlags=SIZE_AUTO)

Sets the position and size of the window in pixels. The sizeFlags parameter indicates the interpretation of the other params if they are equal to -1.

wx.SIZE_AUTO | A -1 indicates that a class-specific default should be used.
wx.SIZE_USE_EXISTING | Axisting dimensions should be used if -1 values are supplied.
wxSIZE_ALLOW_MINUS_ONE | Allow dimensions of -1 and less to be interpreted as real dimensions, not default values.
Parameters:
x
(type=int)

y
(type=int)

width
(type=int)

height
(type=int)

sizeFlags
(type=int)

SetDropTarget(self, dropTarget)

Associates a drop target with this window. If the window already has a drop target, it is deleted.

Parameters:
dropTarget
(type=DropTarget)

SetEventHandler(self, handler)

Sets the event handler for this window. An event handler is an object that is capable of processing the events sent to a window. By default, the window is its own event handler, but an application may wish to substitute another, for example to allow central implementation of event-handling for a variety of different window classes.

It is usually better to use wx.Window.PushEventHandler since this sets up a chain of event handlers, where an event not handled by one event handler is handed to the next one in the chain.

Parameters:
handler
(type=EvtHandler)

SetExtraStyle(self, exStyle)

Sets the extra style bits for the window. Extra styles are the less often used style bits which can't be set with the constructor or with SetWindowStyleFlag()

Parameters:
exStyle
(type=long)

SetFocus(self)

Set's the focus to this window, allowing it to receive keyboard input.

SetFocusFromKbd(self)

Set focus to this window as the result of a keyboard action. Normally only called internally.

SetFont(self, font)

Sets the font for this window.

Parameters:
font
(type=Font)

Returns:
bool

SetForegroundColour(self, colour)

Sets the foreground colour of the window. Returns True is the colour was changed. The interpretation of foreground colour is dependent on the window class; it may be the text colour or other colour, or it may not be used at all.

Parameters:
colour
(type=Colour)

Returns:
bool

SetHelpText(self, text)

Sets the help text to be used as context-sensitive help for this window. Note that the text is actually stored by the current wxHelpProvider implementation, and not in the window object itself.

Parameters:
text
(type=String)

SetHelpTextForId(self, text)

Associate this help text with all windows with the same id as this one.

Parameters:
text
(type=String)

SetId(self, winid)

Sets the identifier of the window. Each window has an integer identifier. If the application has not provided one, an identifier will be generated. Normally, the identifier should be provided on creation and should not be modified subsequently.

Parameters:
winid
(type=int)

SetLabel(self, label)

Set the text which the window shows in its label if applicable.

Parameters:
label
(type=String)

SetMaxSize(self, maxSize)

A more convenient method than SetSizeHints for setting just the max size.

Parameters:
maxSize
(type=Size)

SetMinSize(self, minSize)

A more convenient method than SetSizeHints for setting just the min size.

Parameters:
minSize
(type=Size)

SetName(self, name)

Sets the window's name. The window name is used for ressource setting in X, it is not the same as the window title/label

Parameters:
name
(type=String)

SetPosition(self, pt, flags=SIZE_USE_EXISTING)

Moves the window to the given position.

Parameters:
pt
(type=Point)

flags
(type=int)

SetRect(self, rect, sizeFlags=SIZE_AUTO)

Sets the position and size of the window in pixels using a wx.Rect.

Parameters:
rect
(type=Rect)

sizeFlags
(type=int)

SetScrollbar(self, orientation, position, thumbSize, range, refresh=True)

Sets the scrollbar properties of a built-in scrollbar.
Parameters:
orientation - Determines the scrollbar whose page size is to be set. May be wx.HORIZONTAL or wx.VERTICAL.
(type=int)

position - The position of the scrollbar in scroll units.
(type=int)

thumbSize - The size of the thumb, or visible portion of the scrollbar, in scroll units.
(type=int)

range - The maximum position of the scrollbar.
(type=int)

refresh - True to redraw the scrollbar, false otherwise.
(type=bool)

SetScrollPos(self, orientation, pos, refresh=True)

Sets the position of one of the built-in scrollbars.

Parameters:
orientation
(type=int)

pos
(type=int)

refresh
(type=bool)

SetSize(self, size)

Sets the size of the window in pixels.

Parameters:
size
(type=Size)

SetSizeHints(self, minW, minH, maxW=-1, maxH=-1, incW=-1, incH=-1)

Allows specification of minimum and maximum window sizes, and window size increments. If a pair of values is not set (or set to -1), the default values will be used. If this function is called, the user will not be able to size the window outside the given bounds (if it is a top-level window.) Sizers will also inspect the minimum window size and will use that value if set when calculating layout.

The resizing increments are only significant under Motif or Xt.

Parameters:
minW
(type=int)

minH
(type=int)

maxW
(type=int)

maxH
(type=int)

incW
(type=int)

incH
(type=int)

See Also:

GetMinSize, GetMaxSize, SetMinSize, SetMaxSize

SetSizeHintsSz(self, minSize, maxSize=DefaultSize, incSize=DefaultSize)

Allows specification of minimum and maximum window sizes, and window size increments. If a pair of values is not set (or set to -1), the default values will be used. If this function is called, the user will not be able to size the window outside the given bounds (if it is a top-level window.) Sizers will also inspect the minimum window size and will use that value if set when calculating layout.

The resizing increments are only significant under Motif or Xt.

Parameters:
minSize
(type=Size)

maxSize
(type=Size)

incSize
(type=Size)

See Also:

GetMinSize, GetMaxSize, SetMinSize, SetMaxSize

SetSizer(self, sizer, deleteOld=True)

Sets the window to have the given layout sizer. The window will then own the object, and will take care of its deletion. If an existing layout sizer object is already owned by the window, it will be deleted if the deleteOld parameter is true. Note that this function will also call SetAutoLayout implicitly with a True parameter if the sizer is non-None, and False otherwise.

Parameters:
sizer
(type=Sizer)

deleteOld
(type=bool)

SetSizerAndFit(self, sizer, deleteOld=True)

The same as SetSizer, except it also sets the size hints for the window based on the sizer's minimum size.

Parameters:
sizer
(type=Sizer)

deleteOld
(type=bool)

SetSizeWH(self, width, height)

Sets the size of the window in pixels.

Parameters:
width
(type=int)

height
(type=int)

SetThemeEnabled(self, enableTheme)

This function tells a window if it should use the system's "theme"
code to draw the windows' background instead if its own background drawing code. This will only have an effect on platforms that support the notion of themes in user defined windows. One such platform is GTK+ where windows can have (very colourful) backgrounds defined by a user's selected theme.

Dialogs, notebook pages and the status bar have this flag set to true by default so that the default look and feel is simulated best.

Parameters:
enableTheme
(type=bool)

SetTitle(self, title)

Sets the window's title. Applicable only to frames and dialogs.

Parameters:
title
(type=String)

SetTmpDefaultItem(self, win)

Set this child as temporary default

Parameters:
win
(type=Window)

SetToolTip(self, tip)

Attach a tooltip to the window.

Parameters:
tip
(type=ToolTip)

SetToolTipString(self, tip)

Attach a tooltip to the window.

Parameters:
tip
(type=String)

SetValidator(self, validator)

Deletes the current validator (if any) and sets the window validator, having called wx.Validator.Clone to create a new validator of this type.

Parameters:
validator
(type=Validator)

SetVirtualSize(self, size)

Set the the virtual size of a window in pixels. For most windows this is just the client area of the window, but for some like scrolled windows it is more or less independent of the screen window size.

Parameters:
size
(type=Size)

SetVirtualSizeHints(self, minW, minH, maxW=-1, maxH=-1)

Allows specification of minimum and maximum virtual window sizes. If a pair of values is not set (or set to -1), the default values will be used. If this function is called, the user will not be able to size the virtual area of the window outside the given bounds.

Parameters:
minW
(type=int)

minH
(type=int)

maxW
(type=int)

maxH
(type=int)

SetVirtualSizeHintsSz(self, minSize, maxSize=DefaultSize)

Allows specification of minimum and maximum virtual window sizes. If a pair of values is not set (or set to -1), the default values will be used. If this function is called, the user will not be able to size the virtual area of the window outside the given bounds.

Parameters:
minSize
(type=Size)

maxSize
(type=Size)

SetVirtualSizeWH(self, w, h)

Set the the virtual size of a window in pixels. For most windows this is just the client area of the window, but for some like scrolled windows it is more or less independent of the screen window size.

Parameters:
w
(type=int)

h
(type=int)

SetWindowStyle(self, style)

Sets the style of the window. Please note that some styles cannot be changed after the window creation and that Refresh() might need to be called after changing the others for the change to take place immediately.

Parameters:
style
(type=long)

SetWindowStyleFlag(self, style)

Sets the style of the window. Please note that some styles cannot be changed after the window creation and that Refresh() might need to be called after changing the others for the change to take place immediately.

Parameters:
style
(type=long)

SetWindowVariant(self, variant)

Sets the variant of the window/font size to use for this window, if the platform supports variants, for example, wxMac. Variant values are:

wx.WINDOW_VARIANT_NORMAL | Normal size
wx.WINDOW_VARIANT_SMALL | Smaller size (about 25 % smaller than normal)
wx.WINDOW_VARIANT_MINI | Mini size (about 33 % smaller than normal)
wx.WINDOW_VARIANT_LARGE | Large size (about 25 % larger than normal)
Parameters:
variant
(type=int)

ShouldInheritColours(self)

Return true from here to allow the colours of this window to be changed by InheritAttributes, returning false forbids inheriting them from the parent window.

The base class version returns false, but this method is overridden in wxControl where it returns true.

Returns:
bool

Show(self, show=True)

Shows or hides the window. You may need to call Raise for a top level window if you want to bring it to top, although this is not needed if Show is called immediately after the frame creation. Returns True if the window has been shown or hidden or False if nothing was done because it already was in the requested state.

Parameters:
show
(type=bool)

Returns:
bool

Thaw(self)

Reenables window updating after a previous call to Freeze. Calls to Freeze/Thaw may be nested, so Thaw must be called the same number of times that Freeze was before the window will be updated.

TransferDataFromWindow(self)

Transfers values from child controls to data areas specified by their validators. Returns false if a transfer failed. If the window has wx.WS_EX_VALIDATE_RECURSIVELY extra style flag set, the method will also call TransferDataFromWindow() of all child windows.

Returns:
bool

TransferDataToWindow(self)

Transfers values to child controls from data areas specified by their validators. If the window has wx.WS_EX_VALIDATE_RECURSIVELY extra style flag set, the method will also call TransferDataToWindow() of all child windows.

Returns:
bool

UnregisterHotKey(self, hotkeyId)

Unregisters a system wide hotkey.

Parameters:
hotkeyId
(type=int)

Returns:
bool

Update(self)

Calling this method immediately repaints the invalidated area of the window instead of waiting for the EVT_PAINT event to happen, (normally this would usually only happen when the flow of control returns to the event loop.) Notice that this function doesn't refresh the window and does nothing if the window has been already repainted. Use Refresh first if you want to immediately redraw the window (or some portion of it) unconditionally.

UpdateWindowUI(self, flags=UPDATE_UI_NONE)

This function sends EVT_UPDATE_UI events to the window. The particular implementation depends on the window; for example a wx.ToolBar will send an update UI event for each toolbar button, and a wx.Frame will send an update UI event for each menubar menu item. You can call this function from your application to ensure that your UI is up-to-date at a particular point in time (as far as your EVT_UPDATE_UI handlers are concerned). This may be necessary if you have called wx.UpdateUIEvent.SetMode or wx.UpdateUIEvent.SetUpdateInterval to limit the overhead that wxWindows incurs by sending update UI events in idle time. The flags should be a bitlist of one or more of the following values:

wx.UPDATE_UI_NONE | No particular value
wx.UPDATE_UI_RECURSE | Call the function for descendants
wx.UPDATE_UI_FROMIDLE | Invoked from OnIdle

If you are calling this function from an OnIdle function, make sure you pass the wx.UPDATE_UI_FROMIDLE flag, since this tells the window to only update the UI elements that need to be updated in idle time. Some windows update their elements only when necessary, for example when a menu is about to be shown. The following is an example of how to call UpdateWindowUI from an idle function:

def OnIdle(self, evt):
    if wx.UpdateUIEvent.CanUpdate(self):
        self.UpdateWindowUI(wx.UPDATE_UI_FROMIDLE);
Parameters:
flags
(type=long)

Validate(self)

Validates the current values of the child controls using their validators. If the window has wx.WS_EX_VALIDATE_RECURSIVELY extra style flag set, the method will also call Validate() of all child windows. Returns false if any of the validations failed.

Returns:
bool

WarpPointer(self, x, y)

Moves the pointer to the given position on the window.

NOTE: This function is not supported under Mac because Apple Human Interface Guidelines forbid moving the mouse cursor programmatically.

Parameters:
x
(type=int)

y
(type=int)

Static Method Details

FindFocus()

Returns the window or control that currently has the keyboard focus, or None.

Returns:
Window

GetCapture()

Returns the window which currently captures the mouse or None

Returns:
Window

GetClassDefaultAttributes(variant=WINDOW_VARIANT_NORMAL)

Get the default attributes for this class. This is useful if you want to use the same font or colour in your own control as in a standard control -- which is a much better idea than hard coding specific colours or fonts which might look completely out of place on the user's system, especially if it uses themes.

The variant parameter is only relevant under Mac currently and is ignore under other platforms. Under Mac, it will change the size of the returned font. See wx.Window.SetWindowVariant for more about this.

Parameters:
variant
(type=int)

Returns:
VisualAttributes

NewControlId()

Generate a control id for the controls which were not given one.

Returns:
int

NextControlId(winid)

Get the id of the control following the one with the given autogenerated) id

Parameters:
winid
(type=int)

Returns:
int

PrevControlId(winid)

Get the id of the control preceding the one with the given autogenerated) id

Parameters:
winid
(type=int)

Returns:
int

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:58 2005 http://epydoc.sf.net


wx.WindowCreateEvent

Package wx :: Class WindowCreateEvent

Type WindowCreateEvent

object --+
         |
    Object --+
             |
         Event --+
                 |
      CommandEvent --+
                     |
                    WindowCreateEvent

The EVT_WINDOW_CREATE event is sent as soon as the window object (the underlying GUI object) exists.

Method Summary
WindowCreateEvent | __init__(self, win) The EVT_WINDOW_CREATE event is sent as soon as the window object (the underlying GUI object) exists.
 | __repr__(self)
Window | GetWindow(self) Returns the window that this event refers to.

Method Details

__init__(self, win=None)
(Constructor)

The EVT_WINDOW_CREATE event is sent as soon as the window object (the underlying GUI object) exists.

Parameters:
win
(type=Window)

Returns:
WindowCreateEvent
Overrides:
wx.CommandEvent.__init__

GetWindow(self)

Returns the window that this event refers to.

Returns:
Window

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:56 2005 http://epydoc.sf.net


wx.WindowDC

Package wx :: Class WindowDC

Type WindowDC

object --+
         |
    Object --+
             |
            DC --+
                 |
                WindowDC

A wx.WindowDC must be constructed if an application wishes to paint on the whole area of a window (client and decorations). This should normally be constructed as a temporary stack object; don't store a wx.WindowDC object.

Method Summary
WindowDC | __init__(self, win) Constructor.
 | __repr__(self)

Method Details

__init__(self, win)
(Constructor)

Constructor. Pass the window on which you wish to paint.

Parameters:
win
(type=Window)

Returns:
WindowDC
Overrides:
wx.DC.__init__

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:57 2005 http://epydoc.sf.net


wx.WindowDestroyEvent

Package wx :: Class WindowDestroyEvent

Type WindowDestroyEvent

object --+
         |
    Object --+
             |
         Event --+
                 |
      CommandEvent --+
                     |
                    WindowDestroyEvent

The EVT_WINDOW_DESTROY event is sent right before the window is destroyed.

Method Summary
WindowDestroyEvent | __init__(self, win) The EVT_WINDOW_DESTROY event is sent right before the window is destroyed.
 | __repr__(self)
Window | GetWindow(self) Returns the window that this event refers to.

Method Details

__init__(self, win=None)
(Constructor)

The EVT_WINDOW_DESTROY event is sent right before the window is destroyed.

Parameters:
win
(type=Window)

Returns:
WindowDestroyEvent
Overrides:
wx.CommandEvent.__init__

GetWindow(self)

Returns the window that this event refers to.

Returns:
Window

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:23 2005 http://epydoc.sf.net


wx.WindowDisabler

Package wx :: Class WindowDisabler

Type WindowDisabler

object --+
         |
        WindowDisabler

Proxy of C++ WindowDisabler class

Method Summary
WindowDisabler | __init__(self, winToSkip)
 | __del__(self)
 | __repr__(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:27 2005 http://epydoc.sf.net


wx.wizard.PyWizardPage

Package wx :: Module wizard :: Class PyWizardPage

Type PyWizardPage

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
                 Panel --+
                         |
                WizardPage --+
                             |
                            PyWizardPage

Proxy of C++ PyWizardPage class

Method Summary
PyWizardPage | __init__(self, parent, bitmap, resource)
 | __repr__(self)
bool | base_AcceptsFocus(self)
bool | base_AcceptsFocusFromKeyboard(self)
 | base_AddChild(self, child)
Size | base_DoGetBestSize(self)
(width, height) | base_DoGetClientSize()
(x,y) | base_DoGetPosition()
(width, height) | base_DoGetSize()
Size | base_DoGetVirtualSize(self)
 | base_DoMoveWindow(self, x, y, width, height)
 | base_DoSetClientSize(self, width, height)
 | base_DoSetSize(self, x, y, width, height, sizeFlags)
 | base_DoSetVirtualSize(self, x, y)
Size | base_GetMaxSize(self)
 | base_InitDialog(self)
 | base_RemoveChild(self, child)
bool | base_TransferDataFromWindow(self)
bool | base_TransferDataToWindow(self)
bool | base_Validate(self)
bool | Create(self, parent, id, pos, size, style, name) Create the GUI part of the Window for 2-phase creation mode.

Instance Method Details

Create(self, parent, bitmap=wxNullBitmap, resource=EmptyString)

Create the GUI part of the Window for 2-phase creation mode.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

name
(type=String)

Returns:
bool
Overrides:
wx.wizard.WizardPage.Create (inherited documentation)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:01 2005 http://epydoc.sf.net


wx.wizard.Wizard

Package wx :: Module wizard :: Class Wizard

Type Wizard

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
        TopLevelWindow --+
                         |
                    Dialog --+
                             |
                            Wizard

Proxy of C++ Wizard class

Method Summary
Wizard | __init__(self, parent, id, title, bitmap, pos, style)
 | __repr__(self)
bool | Create(self, parent, id, pos, size, style, name) Create the GUI part of the Window for 2-phase creation mode.
 | FitToPage(self, firstPage)
WizardPage | GetCurrentPage(self)
Sizer | GetPageAreaSizer(self)
Size | GetPageSize(self)
bool | HasNextPage(self, page)
bool | HasPrevPage(self, page)
 | Init(self)
bool | IsRunning(self)
bool | RunWizard(self, firstPage)
 | SetBorder(self, border)
 | SetPageSize(self, size)
bool | ShowPage(self, page, goingForward)

Instance Method Details

Create(self,
          parent,
          id=-1,
          title=EmptyString,
          bitmap=wxNullBitmap,
          pos=DefaultPosition)

Create the GUI part of the Window for 2-phase creation mode.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

name
(type=String)

Returns:
bool
Overrides:
wx.Dialog.Create (inherited documentation)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:05 2005 http://epydoc.sf.net


wx.wizard.WizardEvent

Package wx :: Module wizard :: Class WizardEvent

Type WizardEvent

object --+
         |
    Object --+
             |
         Event --+
                 |
      CommandEvent --+
                     |
           NotifyEvent --+
                         |
                        WizardEvent

Proxy of C++ WizardEvent class

Method Summary
NotifyEvent | __init__(self, commandType, winid) An instance of this class (or one of its derived classes) is sent from a control when the control's state is being changed and the control allows that change to be prevented from happening.
 | __repr__(self)
bool | GetDirection(self)
WizardPage | GetPage(self)

Method Details

__init__(self,
          type=wxEVT_NULL,
          id=-1,
          direction=True,
          page=None)
(Constructor)

An instance of this class (or one of its derived classes) is sent from a control when the control's state is being changed and the control allows that change to be prevented from happening. The event handler can call Veto or Allow to tell the control what to do.

Parameters:
commandType
(type=wxEventType)

winid
(type=int)

Returns:
NotifyEvent
Overrides:
wx.NotifyEvent.__init__ (inherited documentation)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:28 2005 http://epydoc.sf.net


wx.wizard.WizardPage

Package wx :: Module wizard :: Class WizardPage

Type WizardPage

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
                 Panel --+
                         |
                        WizardPage

Known Subclasses:
PyWizardPage, WizardPageSimple

Proxy of C++ WizardPage class

Method Summary
 | __init__(self)
 | __repr__(self)
bool | Create(self, parent, id, pos, size, style, name) Create the GUI part of the Window for 2-phase creation mode.
Bitmap | GetBitmap(self)
WizardPage | GetNext(self)
WizardPage | GetPrev(self)

Instance Method Details

Create(self, parent, bitmap=wxNullBitmap, resource=EmptyString)

Create the GUI part of the Window for 2-phase creation mode.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

name
(type=String)

Returns:
bool
Overrides:
wx.Panel.Create (inherited documentation)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:16 2005 http://epydoc.sf.net


wx.wizard.WizardPageSimple

Package wx :: Module wizard :: Class WizardPageSimple

Type WizardPageSimple

object --+
         |
    Object --+
             |
    EvtHandler --+
                 |
            Window --+
                     |
                 Panel --+
                         |
                WizardPage --+
                             |
                            WizardPageSimple

Proxy of C++ WizardPageSimple class

Method Summary
WizardPageSimple | __init__(self, parent, prev, next, bitmap, resource)
 | __repr__(self)
 | Chain(first, second) (Static method)
bool | Create(self, parent, id, pos, size, style, name) Create the GUI part of the Window for 2-phase creation mode.
 | SetNext(self, next)
 | SetPrev(self, prev)

Instance Method Details

Create(self,
          parent=None,
          prev=None,
          next=None,
          bitmap=wxNullBitmap,
          resource=None)

Create the GUI part of the Window for 2-phase creation mode.

Parameters:
parent
(type=Window)

id
(type=int)

pos
(type=Point)

size
(type=Size)

style
(type=long)

name
(type=String)

Returns:
bool
Overrides:
wx.wizard.WizardPage.Create (inherited documentation)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:56 2005 http://epydoc.sf.net


wx.wizard

Package wx :: Module wizard

Module wx.wizard

Wizard is a dialog class that guides the user through a sequence of steps, or pages.

Classes
PyWizardPage | Proxy of C++ PyWizardPage class
Wizard | Proxy of C++ Wizard class
WizardEvent | Proxy of C++ WizardEvent class
WizardPage | Proxy of C++ WizardPage class
WizardPageSimple | Proxy of C++ WizardPageSimple class

Function Summary
PyWizardPage | PrePyWizardPage()
Wizard | PreWizard()
WizardPageSimple | PreWizardPageSimple()
 | WizardPageSimple_Chain(first, second)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:58 2005 http://epydoc.sf.net


wx.XPMHandler

Package wx :: Class XPMHandler

Type XPMHandler

object --+
         |
    Object --+
             |
  ImageHandler --+
                 |
                XPMHandler

A wx.ImageHandler for XPM image.

Method Summary
XPMHandler | __init__(self) A wx.ImageHandler for XPM image.
 | __repr__(self)

Method Details

__init__(self)
(Constructor)

A wx.ImageHandler for XPM image.

Returns:
XPMHandler
Overrides:
wx.ImageHandler.__init__

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:47 2005 http://epydoc.sf.net


wx.xrc.XmlDocument

Package wx :: Module xrc :: Class XmlDocument

Type XmlDocument

object --+
         |
    Object --+
             |
            XmlDocument

Proxy of C++ XmlDocument class

Method Summary
XmlDocument | __init__(self, filename, encoding)
 | __del__(self)
 | __repr__(self)
String | GetFileEncoding(self)
XmlNode | GetRoot(self)
String | GetVersion(self)
bool | IsOk(self)
bool | Load(self, filename, encoding)
bool | LoadFromStream(self, stream, encoding)
bool | Save(self, filename)
bool | SaveToStream(self, stream)
 | SetFileEncoding(self, encoding)
 | SetRoot(self, node)
 | SetVersion(self, version)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:05 2005 http://epydoc.sf.net


wx.xrc.XmlNode

Package wx :: Module xrc :: Class XmlNode

Type XmlNode

object --+
         |
        XmlNode

Proxy of C++ XmlNode class

Method Summary
XmlNode | __init__(self, parent, type, name, content, props, next)
 | __del__(self)
 | __repr__(self)
 | AddChild(self, child)
 | AddProperty(self, prop)
 | AddPropertyName(self, name, value)
bool | DeleteProperty(self, name)
XmlNode | GetChildren(self)
String | GetContent(self)
String | GetName(self)
XmlNode | GetNext(self)
XmlNode | GetParent(self)
XmlProperty | GetProperties(self)
String | GetPropVal(self, propName, defaultVal)
int | GetType(self)
bool | HasProp(self, propName)
 | InsertChild(self, child, before_node)
bool | RemoveChild(self, child)
 | SetChildren(self, child)
 | SetContent(self, con)
 | SetName(self, name)
 | SetNext(self, next)
 | SetParent(self, parent)
 | SetProperties(self, prop)
 | SetType(self, type)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:01 2005 http://epydoc.sf.net


wx.xrc.XmlProperty

Package wx :: Module xrc :: Class XmlProperty

Type XmlProperty

object --+
         |
        XmlProperty

Proxy of C++ XmlProperty class

Method Summary
XmlProperty | __init__(self, name, value, next)
 | __repr__(self)
String | GetName(self)
XmlProperty | GetNext(self)
String | GetValue(self)
 | SetName(self, name)
 | SetNext(self, next)
 | SetValue(self, value)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:38 2005 http://epydoc.sf.net


wx.xrc.XmlResource

Package wx :: Module xrc :: Class XmlResource

Type XmlResource

object --+
         |
    Object --+
             |
            XmlResource

Proxy of C++ XmlResource class

Method Summary
XmlResource | __init__(self, filemask, flags)
 | __del__(self)
 | __repr__(self)
 | AddHandler(self, handler)
 | AddSubclassFactory(factory) (Static method)
bool | AttachUnknownControl(self, name, control, parent)
 | ClearHandlers(self)
int | CompareVersion(self, major, minor, release, revision)
XmlResource | Get() (Static method)
int | GetFlags(self)
long | GetVersion(self)
int | GetXRCID(str_id) (Static method)
 | InitAllHandlers(self)
 | InsertHandler(self, handler)
bool | Load(self, filemask)
Bitmap | LoadBitmap(self, name)
wxDialog | LoadDialog(self, parent, name)
wxFrame | LoadFrame(self, parent, name)
bool | LoadFromString(self, data)
Icon | LoadIcon(self, name)
Menu | LoadMenu(self, name)
MenuBar | LoadMenuBar(self, name)
MenuBar | LoadMenuBarOnFrame(self, parent, name)
Object | LoadObject(self, parent, name, classname)
bool | LoadOnDialog(self, dlg, parent, name)
bool | LoadOnFrame(self, frame, parent, name)
bool | LoadOnObject(self, instance, parent, name, classname)
bool | LoadOnPanel(self, panel, parent, name)
wxPanel | LoadPanel(self, parent, name)
wxToolBar | LoadToolBar(self, parent, name)
XmlResource | Set(res) (Static method)
 | SetFlags(self, flags)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:11:42 2005 http://epydoc.sf.net


wx.xrc.XmlResourceHandler

Package wx :: Module xrc :: Class XmlResourceHandler

Type XmlResourceHandler

object --+
         |
    Object --+
             |
            XmlResourceHandler

Known Subclasses:
wxTickerXmlHandler

Proxy of C++ XmlResourceHandler class

Method Summary
XmlResourceHandler | __init__(self)
 | __repr__(self)
 | AddStyle(self, name, value)
 | AddWindowStyles(self)
 | CreateChildren(self, parent, this_hnd_only)
 | CreateChildrenPrivately(self, parent, rootnode)
Object | CreateResFromNode(self, node, parent, instance)
Object | CreateResource(self, node, parent, instance)
Bitmap | GetBitmap(self, param, defaultArtClient, size)
bool | GetBool(self, param, defaultv)
String | GetClass(self)
Colour | GetColour(self, param)
FileSystem | GetCurFileSystem(self)
int | GetDimension(self, param, defaultv)
Font | GetFont(self, param)
Icon | GetIcon(self, param, defaultArtClient, size)
int | GetID(self)
Object | GetInstance(self)
long | GetLong(self, param, defaultv)
String | GetName(self)
XmlNode | GetNode(self)
String | GetNodeContent(self, node)
XmlNode | GetParamNode(self, param)
String | GetParamValue(self, param)
Object | GetParent(self)
Window | GetParentAsWindow(self)
Point | GetPosition(self, param)
XmlResource | GetResource(self)
Size | GetSize(self, param)
int | GetStyle(self, param, defaults)
String | GetText(self, param, translate)
bool | HasParam(self, param)
bool | IsOfClass(self, node, classname)
 | SetParentResource(self, res)
 | SetupWindow(self, wnd)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:34 2005 http://epydoc.sf.net


wx.xrc.XmlSubclassFactory_Python

Package wx :: Module xrc :: Class XmlSubclassFactory_Python

Type XmlSubclassFactory_Python

        object --+
                 |
XmlSubclassFactory --+
                     |
                    XmlSubclassFactory_Python

Method Summary
 | __init__(self)
 | Create(self, className)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:12:34 2005 http://epydoc.sf.net


wx.xrc.XmlSubclassFactory

Package wx :: Module xrc :: Class XmlSubclassFactory

Type XmlSubclassFactory

object --+
         |
        XmlSubclassFactory

Known Subclasses:
XmlSubclassFactory_Python

Proxy of C++ XmlSubclassFactory class

Method Summary
XmlSubclassFactory | __init__(self)
 | __repr__(self)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:14:10 2005 http://epydoc.sf.net


wx.xrc

Package wx :: Module xrc

Module wx.xrc

The XmlResource class allows program resources defining menus, layout of controls on a panel, etc. to be loaded from an XML file.

Classes
XmlDocument | Proxy of C++ XmlDocument class
XmlNode | Proxy of C++ XmlNode class
XmlProperty | Proxy of C++ XmlProperty class
XmlResource | Proxy of C++ XmlResource class
XmlResourceHandler | Proxy of C++ XmlResourceHandler class
XmlSubclassFactory | Proxy of C++ XmlSubclassFactory class
XmlSubclassFactory_Python |

Function Summary
XmlDocument | EmptyXmlDocument()
XmlResource | EmptyXmlResource(flags)
XmlDocument | XmlDocumentFromStream(stream, encoding)
XmlNode | XmlNodeEasy(type, name, content)
 | XmlResource_AddSubclassFactory(factory)
XmlResource | XmlResource_Get()
int | XmlResource_GetXRCID(str_id)
XmlResource | XmlResource_Set(res)
 | XRCCTRL(window, str_id, *ignoreargs)
 | XRCID(str_id)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:10:49 2005 http://epydoc.sf.net


wx.ZipFSHandler

Package wx :: Class ZipFSHandler

Type ZipFSHandler

          object --+
                   |
CPPFileSystemHandler --+
                       |
                      ZipFSHandler

Proxy of C++ ZipFSHandler class

Method Summary
ZipFSHandler | __init__(self)
 | __repr__(self)
bool | CanOpen(self, location)
String | FindFirst(self, spec, flags)
String | FindNext(self)
FSFile | OpenFile(self, fs, location)

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:03 2005 http://epydoc.sf.net


wx

Package wx

Package wx

Submodules
  • animate: Simple animation player classes, including GIFAnimationCtrl for displaying animated GIF files
  • build: This package provides the config module, which is used by wxPython's setup.py distutils script.
  • calendar: Classes for an interactive Calendar control.
  • gizmos: Various gizmo classes: DynamicSashWindow, EditableListBox, LEDNumberCtrl, TreeListCtrl, etc.
  • glcanvas: GLCanvas provides an OpenGL Context on a wx.Window.
  • grid: Classes for implementing a spreadsheet-like control.
  • html: Classes for a simple HTML rendering window, HTML Help Window, etc.
  • lib
  • media: Classes for a media player control
  • py: The py package, formerly the PyCrust package.
  • stc: The StyledTextCtrl provides a text editor that can used as a syntax highlighting source code editor, or similar.
  • tools: Some useful tools and utilities for wxPython.
  • webkit: wx.webkit.WebKitCtrl for Mac OSX.
  • wizard: Wizard is a dialog class that guides the user through a sequence of steps, or pages.
  • xrc: The XmlResource class allows program resources defining menus, layout of controls on a panel, etc.

Classes
AcceleratorEntry | A class used to define items in an wx.AcceleratorTable.
AcceleratorTable | An accelerator table allows the application to specify a table of keyboard shortcuts for menus or other commands.
ActivateEvent | An activate event is sent when a top-level window or the entire application is being activated or deactivated.
ANIHandler | A wx.ImageHandler for *.ani animated cursor files.
App | The wx.App class represents the application and is used to:
ArtProvider | The wx.ArtProvider class is used to customize the look of wxWidgets application.
Bitmap | The wx.Bitmap class encapsulates the concept of a platform-dependent bitmap.
BitmapButton | A Button that contains a bitmap.
BitmapDataObject | wx.BitmapDataObject is a specialization of wxDataObject for bitmap data.
BMPHandler | A wx.ImageHandler for *.bmp bitmap files.
BookCtrlBase | Proxy of C++ BookCtrlBase class
BookCtrlBaseEvent | Proxy of C++ BookCtrlBaseEvent class
BookCtrlSizer | Proxy of C++ BookCtrlSizer class
BoxSizer | The basic idea behind a box sizer is that windows will most often be laid out in rather simple basic geometry, typically in a row or a column or nested hierarchies of either.
Brush | A brush is a drawing tool for filling in areas.
BrushList | Proxy of C++ BrushList class
BufferedDC | This simple class provides a simple way to avoid flicker: when drawing on it, everything is in fact first drawn on an in-memory buffer (a wx.Bitmap) and then copied to the screen only once, when this object is destroyed.
BufferedPaintDC | This is a subclass of wx.BufferedDC which can be used inside of an EVT_PAINT event handler.
BusyCursor | Proxy of C++ BusyCursor class
BusyInfo | Proxy of C++ BusyInfo class
Button | A button is a control that contains a text string, and is one of the most common elements of a GUI.
CalculateLayoutEvent | Proxy of C++ CalculateLayoutEvent class
Caret | Proxy of C++ Caret class
CheckBox | A checkbox is a labelled box which by default is either on (the checkmark is visible) or off (no checkmark).
CheckListBox | Proxy of C++ CheckListBox class
ChildFocusEvent | wx.ChildFocusEvent notifies the parent that a child has received the focus.
Choice | A Choice control is used to select one of a list of strings.
Choicebook | Proxy of C++ Choicebook class
ChoicebookEvent | Proxy of C++ ChoicebookEvent class
ClientDC | A wx.ClientDC must be constructed if an application wishes to paint on the client area of a window from outside an EVT_PAINT event.
Clipboard | wx.Clipboard represents the system clipboard and provides methods to copy data to it or paste data from it.
ClipboardLocker | A helpful class for opening the clipboard and automatically closing it when the locker is destroyed.
CloseEvent | This event class contains information about window and session close events.
Color | A colour is an object representing a combination of Red, Green, and Blue (RGB) intensity values, and is used to determine drawing colours, window colours, etc.
Colour | A colour is an object representing a combination of Red, Green, and Blue (RGB) intensity values, and is used to determine drawing colours, window colours, etc.
ColourData | This class holds a variety of information related to the colour chooser dialog, used to transfer settings and results to and from the wx.ColourDialog.
ColourDatabase | Proxy of C++ ColourDatabase class
ColourDialog | This class represents the colour chooser dialog.
ComboBox | A combobox is like a combination of an edit control and a listbox.
CommandEvent | This event class contains information about command events, which originate from a variety of simple controls, as well as menus and toolbars.
Config | This ConfigBase-derived class will use the registry on Windows, and will be a wx.FileConfig on other platforms.
ConfigBase | wx.ConfigBase class defines the basic interface of all config classes.
ConfigPathChanger | A handy little class which changes current path to the path of given entry and restores it in the destructoir: so if you declare a local variable of this type, you work in the entry directory and the path is automatically restored when the function returns.
ContextHelp | This class changes the cursor to a query and puts the application into a 'context-sensitive help mode'.
ContextHelpButton | Instances of this class may be used to add a question mark button that when pressed, puts the application into context-help mode.
ContextMenuEvent | This class is used for context menu events (EVT_CONTECT_MENU,) sent to give the application a chance to show a context (popup) menu.
Control | This is the base class for a control or 'widget'.
ControlWithItems | wx.ControlWithItems combines the wx.ItemContainer class with the wx.Control class, and is used for the base class of various controls that have items.
CPPFileSystemHandler | Proxy of C++ CPPFileSystemHandler class
CURHandler | A wx.ImageHandler for *.cur cursor files.
Cursor | A cursor is a small bitmap usually used for denoting where the mouse pointer is, with a picture that might indicate the interpretation of a mouse click.
CustomDataObject | wx.CustomDataObject is a specialization of wx.DataObjectSimple for some application-specific data in arbitrary format.
DataFormat | A wx.DataFormat is an encapsulation of a platform-specific format handle which is used by the system for the clipboard and drag and drop operations.
DataObject | A wx.DataObject represents data that can be copied to or from the clipboard, or dragged and dropped.
DataObjectComposite | wx.DataObjectComposite is the simplest wx.DataObject derivation which may be sued to support multiple formats.
DataObjectSimple | wx.DataObjectSimple is a wx.DataObject which only supports one format.
DateEvent | This event class holds information about a date change event and is used together with wx.DatePickerCtrl.
DatePickerCtrl | This control allows the user to select a date.
DateSpan | Proxy of C++ DateSpan class
DateTime | Proxy of C++ DateTime class
DC | A wx.DC is a device context onto which graphics and text can be drawn.
Dialog | Proxy of C++ Dialog class
DirDialog | wx.DirDialog allows the user to select a directory by browising the file system.
DirFilterListCtrl | Proxy of C++ DirFilterListCtrl class
Display | Represents a display/monitor attached to the system
DisplayChangedEvent | An EVT_DISPLAY_CHANGED event is sent to all windows when the display resolution has changed.
DragImage | Proxy of C++ DragImage class
DropFilesEvent | This class is used for drop files events, that is, when files have been dropped onto the window.
DropSource | Proxy of C++ DropSource class
DropTarget | Proxy of C++ DropTarget class
Effects | Proxy of C++ Effects class
EncodingConverter | Proxy of C++ EncodingConverter class
EraseEvent | An erase event is sent whenever the background of a window needs to be repainted.
Event | An event is a structure holding information about an event passed to a callback or member function.
EventLoop | Proxy of C++ EventLoop class
EvtHandler | Proxy of C++ EvtHandler class
FileConfig | This config class will use a file for storage on all platforms.
FileDataObject | wx.FileDataObject is a specialization of wx.DataObjectSimple for file names.
FileDialog | wx.FileDialog allows the user to select one or more files from the filesystem.
FileDropTarget | Proxy of C++ FileDropTarget class
FileHistory | Proxy of C++ FileHistory class
FileSystem | Proxy of C++ FileSystem class
FileSystemHandler | Proxy of C++ FileSystemHandler class
FileType | Proxy of C++ FileType class
FileTypeInfo | Proxy of C++ FileTypeInfo class
FindDialogEvent | Events for the FindReplaceDialog
FindReplaceData | wx.FindReplaceData holds the data for wx.FindReplaceDialog.
FindReplaceDialog | wx.FindReplaceDialog is a standard modeless dialog which is used to allow the user to search for some text (and possibly replace it with something else).
FlexGridSizer | A flex grid sizer is a sizer which lays out its children in a two-dimensional table with all table cells in one row having the same height and all cells in one column having the same width, but all rows or all columns are not necessarily the same height or width as in the wx.GridSizer.
FocusEvent | A focus event is sent when a window's focus changes.
Font | A font is an object which determines the appearance of text.
FontData | This class holds a variety of information related to font dialogs and is used to transfer settings to and results from a wx.FontDialog.
FontDialog | wx.FontDialog allows the user to select a system font and its attributes.
FontEnumerator | Proxy of C++ FontEnumerator class
FontList | Proxy of C++ FontList class
FontMapper | Proxy of C++ FontMapper class
Frame | Proxy of C++ Frame class
FSFile | Proxy of C++ FSFile class
FutureCall | A convenience class for wx.Timer, that calls the given callable object once after the given amount of milliseconds, passing any positional or keyword args.
Gauge | Proxy of C++ Gauge class
GBPosition | This class represents the position of an item in a virtual grid of rows and columns managed by a wx.GridBagSizer.
GBSizerItem | The wx.GBSizerItem class is used to track the additional data about items in a wx.GridBagSizer such as the item's position in the grid and how many rows or columns it spans.
GBSpan | This class is used to hold the row and column spanning attributes of items in a wx.GridBagSizer.
GDIObject | Proxy of C++ GDIObject class
GenericDirCtrl | Proxy of C++ GenericDirCtrl class
GIFHandler | A wx.ImageHandler for GIF image files.
GridBagSizer | A wx.Sizer that can lay out items in a virtual grid like a wx.FlexGridSizer but in this case explicit positioning of the items is allowed using wx.GBPosition, and items can optionally span more than one row and/or column using wx.GBSpan.
GridSizer | A grid sizer is a sizer which lays out its children in a two-dimensional table with all cells having the same size.
HelpEvent | A help event is sent when the user has requested context-sensitive help.
HelpProvider | wx.HelpProvider is an abstract class used by a program implementing context-sensitive help to show the help text for the given window.
HtmlListBox | Proxy of C++ HtmlListBox class
ICOHandler | A wx.ImageHandler for *.ico icon files.
Icon | Proxy of C++ Icon class
IconBundle | Proxy of C++ IconBundle class
IconizeEvent | An EVT_ICONIZE event is sent when a frame is iconized (minimized) or restored.
IconLocation | Proxy of C++ IconLocation class
IdleEvent | This class is used for EVT_IDLE events, which are generated and sent when the application becomes idle.
Image | A platform-independent image class.
ImageHandler | This is the base class for implementing image file loading/saving, and image creation from data.
ImageHistogram | Proxy of C++ ImageHistogram class
ImageList | Proxy of C++ ImageList class
IndividualLayoutConstraint | Objects of this class are stored in the wx.LayoutConstraints class as one of eight possible constraints that a window can be involved in.
InitDialogEvent | A wx.InitDialogEvent is sent as a dialog is being initialised, or for any window when wx.Window.InitDialog is called.
InputStream | Proxy of C++ InputStream class
InternetFSHandler | Proxy of C++ InternetFSHandler class
ItemContainer | The wx.ItemContainer class defines an interface which is implemented by all controls which have string subitems, each of which may be selected, such as wx.ListBox, wx.CheckListBox, wx.Choice as well as wx.ComboBox which implements an extended interface deriving from this one.
Joystick | Proxy of C++ Joystick class
JoystickEvent | Proxy of C++ JoystickEvent class
JPEGHandler | A wx.ImageHandler for JPEG/JPG image files.
KeyEvent | This event class contains information about keypress and character events.
LanguageInfo | Proxy of C++ LanguageInfo class
LayoutAlgorithm | Proxy of C++ LayoutAlgorithm class
LayoutConstraints | Note: constraints are now deprecated and you should use sizers instead.
Listbook | Proxy of C++ Listbook class
ListbookEvent | Proxy of C++ ListbookEvent class
ListBox | Proxy of C++ ListBox class
ListCtrl | Proxy of C++ ListCtrl class
ListEvent | Proxy of C++ ListEvent class
ListItem | Proxy of C++ ListItem class
ListItemAttr | Proxy of C++ ListItemAttr class
ListView | Proxy of C++ ListView class
Locale | Proxy of C++ Locale class
Log | Proxy of C++ Log class
LogChain | Proxy of C++ LogChain class
LogGui | Proxy of C++ LogGui class
LogNull | Proxy of C++ LogNull class
LogStderr | Proxy of C++ LogStderr class
LogTextCtrl | Proxy of C++ LogTextCtrl class
LogWindow | Proxy of C++ LogWindow class
Mask | This class encapsulates a monochrome mask bitmap, where the masked area is black and the unmasked area is white.
MaximizeEvent | An EVT_MAXIMIZE event is sent when a frame is maximized or restored.
MDIChildFrame | Proxy of C++ MDIChildFrame class
MDIClientWindow | Proxy of C++ MDIClientWindow class
MDIParentFrame | Proxy of C++ MDIParentFrame class
MemoryDC | A memory device context provides a means to draw graphics onto a bitmap.
MemoryFSHandler | Proxy of C++ MemoryFSHandler class
Menu | Proxy of C++ Menu class
MenuBar | Proxy of C++ MenuBar class
MenuEvent | This class is used for a variety of menu-related events.
MenuItem | Proxy of C++ MenuItem class
MessageDialog | This class provides a simple dialog that shows a single or multi-line message, with a choice of OK, Yes, No and/or Cancel buttons.
MetaFile | Proxy of C++ MetaFile class
MetafileDataObject | Proxy of C++ MetafileDataObject class
MetaFileDC | Proxy of C++ MetaFileDC class
MimeTypesManager | Proxy of C++ MimeTypesManager class
MiniFrame | Proxy of C++ MiniFrame class
MirrorDC | wx.MirrorDC is a simple wrapper class which is always associated with a real wx.DC object and either forwards all of its operations to it without changes (no mirroring takes place) or exchanges x and y coordinates which makes it possible to reuse the same code to draw a figure and its mirror -- i.e.
MouseCaptureChangedEvent | An mouse capture changed event (EVT_MOUSE_CAPTURE_CHANGED) is sent to a window that loses its mouse capture.
MouseEvent | This event class contains information about the events generated by the mouse: they include mouse buttons press and release events and mouse move events.
MoveEvent | This event object is sent for EVT_MOVE event bindings when a window is moved to a new position.
MultiChoiceDialog | A simple dialog with a multi selection listbox.
MutexGuiLocker | Proxy of C++ MutexGuiLocker class
NativeEncodingInfo | Proxy of C++ NativeEncodingInfo class
NativeFontInfo | Proxy of C++ NativeFontInfo class
NavigationKeyEvent | EVT_NAVIGATION_KEY events are used to control moving the focus between widgets, otherwise known as tab-traversal.
NcPaintEvent | Proxy of C++ NcPaintEvent class
Notebook | Proxy of C++ Notebook class
NotebookEvent | Proxy of C++ NotebookEvent class
NotebookPage | There is an old (and apparently unsolvable) bug when placing a window with a nonstandard background colour in a wx.Notebook on wxGTK1, as the notbooks's background colour would always be used when the window is refreshed.
NotebookSizer | Proxy of C++ NotebookSizer class
NotifyEvent | An instance of this class (or one of its derived classes) is sent from a control when the control's state is being changed and the control allows that change to be prevented from happening.
Object | The base class for most wx objects, although in wxPython not much functionality is needed nor exposed.
OutputStream | Proxy of C++ OutputStream class
PageSetupDialog | Proxy of C++ PageSetupDialog class
PageSetupDialogData | Proxy of C++ PageSetupDialogData class
PaintDC | A wx.PaintDC must be constructed if an application wishes to paint on the client area of a window from within an EVT_PAINT event handler.
PaintEvent | A paint event is sent when a window's contents needs to be repainted.
Palette | Proxy of C++ Palette class
PaletteChangedEvent | An EVT_PALETTE_CHANGED event is sent when the system palette has changed, thereby giving each window a chance to redo their own to match.
Panel | Proxy of C++ Panel class
PasswordEntryDialog | Proxy of C++ PasswordEntryDialog class
PCXHandler | A wx.ImageHandler for PCX imager files.
Pen | Proxy of C++ Pen class
PenList | Proxy of C++ PenList class
PNGHandler | A wx.ImageHandler for PNG image files.
PNMHandler | A wx.ImageHandler for PNM image files.
Point | A data structure for representing a point or position with integer x and y properties.
Point2D | wx.Point2Ds represent a point or a vector in a 2d coordinate system with floating point values.
PopupTransientWindow | Proxy of C++ PopupTransientWindow class
PopupWindow | Proxy of C++ PopupWindow class
PostScriptDC | This is a wx.DC that can write to PostScript files on any platform.
PreviewCanvas | Proxy of C++ PreviewCanvas class
PreviewControlBar | Proxy of C++ PreviewControlBar class
PreviewFrame | Proxy of C++ PreviewFrame class
PrintData | Proxy of C++ PrintData class
PrintDialog | Proxy of C++ PrintDialog class
PrintDialogData | Proxy of C++ PrintDialogData class
Printer | Proxy of C++ Printer class
PrinterDC | Proxy of C++ PrinterDC class
Printout | Proxy of C++ Printout class
PrintPreview | Proxy of C++ PrintPreview class
Process | Proxy of C++ Process class
ProcessEvent | Proxy of C++ ProcessEvent class
ProgressDialog | A dialog that shows a short message and a progress bar.
PropagateOnce | A helper class that will temporarily lower propagation level of an event.
PropagationDisabler | Helper class to temporarily change an event not to propagate.
PyApp | The wx.PyApp class is an implementation detail, please use the wx.App class (or some other derived class) instead.
PyBitmapDataObject | wx.PyBitmapDataObject is a version of wx.BitmapDataObject that is Python-aware and knows how to reflect calls to its C++ virtual methods to methods in the Python derived class.
PyCommandEvent | wx.PyCommandEvent can be used as a base class for implementing custom event types in Python, where the event shoudl travel up to parent windows looking for a handler.
PyControl | Proxy of C++ PyControl class
PyDataObjectSimple | wx.PyDataObjectSimple is a version of wx.DataObjectSimple that is Python-aware and knows how to reflect calls to its C++ virtual methods to methods in the Python derived class.
PyDropTarget | Proxy of C++ DropTarget class
PyEvent | wx.PyEvent can be used as a base class for implementing custom event types in Python.
PyEventBinder | Instances of this class are used to bind specific events to event handlers.
PyLog | Proxy of C++ PyLog class
PyOnDemandOutputWindow | A class that can be used for redirecting Python's stdout and stderr streams.
PyPanel | Proxy of C++ PyPanel class
PyPreviewControlBar | Proxy of C++ PyPreviewControlBar class
PyPreviewFrame | Proxy of C++ PyPreviewFrame class
PyPrintPreview | Proxy of C++ PyPrintPreview class
PyScrolledWindow | Proxy of C++ PyScrolledWindow class
PySimpleApp | A simple application class.
PySizer | wx.PySizer is a special version of wx.Sizer that has been instrumented to allow the C++ virtual methods to be overloaded in Python derived classes.
PyTextDataObject | wx.PyTextDataObject is a version of wx.TextDataObject that is Python-aware and knows how to reflect calls to its C++ virtual methods to methods in the Python derived class.
PyTimer |
PyTipProvider | Proxy of C++ PyTipProvider class
PyValidator | Proxy of C++ PyValidator class
PyWidgetTester |
PyWindow | Proxy of C++ PyWindow class
Quantize | Performs quantization, or colour reduction, on a wxImage.
QueryLayoutInfoEvent | Proxy of C++ QueryLayoutInfoEvent class
QueryNewPaletteEvent | An EVT_QUERY_NEW_PALETE event indicates the window is getting keyboard focus and should re-do its palette.
RadioBox | Proxy of C++ RadioBox class
RadioButton | Proxy of C++ RadioButton class
RealPoint | A data structure for representing a point or position with floating point x and y properties.
Rect | A class for representing and manipulating rectangles.
Region | Proxy of C++ Region class
RegionIterator | Proxy of C++ RegionIterator class
SashEvent | Proxy of C++ SashEvent class
SashLayoutWindow | Proxy of C++ SashLayoutWindow class
SashWindow | Proxy of C++ SashWindow class
ScreenDC | A wxScreenDC can be used to paint anywhere on the screen.
ScrollBar | Proxy of C++ ScrollBar class
ScrolledWindow | Proxy of C++ ScrolledWindow class
ScrollEvent | A scroll event holds information about events sent from stand-alone scrollbars and sliders.
ScrollWinEvent | A wx.ScrollWinEvent holds information about scrolling and is sent from scrolling windows.
SetCursorEvent | A SetCursorEvent is generated when the mouse cursor is about to be set as a result of mouse motion.
ShowEvent | An EVT_SHOW event is sent when a window is shown or hidden.
SimpleHelpProvider | wx.SimpleHelpProvider is an implementation of wx.HelpProvider which supports only plain text help strings, and shows the string associated with the control (if any) in a tooltip.
SingleChoiceDialog | A simple dialog with a single selection listbox.
SingleInstanceChecker | Proxy of C++ SingleInstanceChecker class
Size | wx.Size is a useful data structure used to represent the size of something.
SizeEvent | A size event holds information about size change events.
Sizer | wx.Sizer is the abstract base class used for laying out subwindows in a window.
SizerItem | The wx.SizerItem class is used to track the position, size and other attributes of each item managed by a wx.Sizer.
Slider | Proxy of C++ Slider class
Sound | Proxy of C++ Sound class
SpinButton | Proxy of C++ SpinButton class
SpinCtrl | Proxy of C++ SpinCtrl class
SpinEvent | Proxy of C++ SpinEvent class
SplashScreen | Proxy of C++ SplashScreen class
SplashScreenWindow | Proxy of C++ SplashScreenWindow class
SplitterEvent | This class represents the events generated by a splitter control.
SplitterWindow | wx.SplitterWindow manages up to two subwindows or panes, with an optional vertical or horizontal split which can be used with the mouse or programmatically.
StandardPaths | wx.StandardPaths returns the standard locations in the file system and should be used by the programs to find their data files in a portable way.
StaticBitmap | Proxy of C++ StaticBitmap class
StaticBox | Proxy of C++ StaticBox class
StaticBoxSizer | wx.StaticBoxSizer derives from and functions identically to the wx.BoxSizer and adds a wx.StaticBox around the items that the sizer manages.
StaticLine | Proxy of C++ StaticLine class
StaticText | Proxy of C++ StaticText class
StatusBar | Proxy of C++ StatusBar class
StdDialogButtonSizer | A special sizer that knows how to order and position standard buttons in order to conform to the current platform's standards.
StopWatch | Proxy of C++ StopWatch class
SysColourChangedEvent | This class is used for EVT_SYS_COLOUR_CHANGED, which are generated when the user changes the colour settings using the control panel.
SystemOptions | Proxy of C++ SystemOptions class
SystemSettings | Proxy of C++ SystemSettings class
TaskBarIcon | Proxy of C++ TaskBarIcon class
TaskBarIconEvent | Proxy of C++ TaskBarIconEvent class
TextAttr | Proxy of C++ TextAttr class
TextCtrl | Proxy of C++ TextCtrl class
TextDataObject | wx.TextDataObject is a specialization of wx.DataObject for text data.
TextDropTarget | Proxy of C++ TextDropTarget class
TextEntryDialog | A dialog with text control, [ok] and [cancel] buttons
TextUrlEvent | Proxy of C++ TextUrlEvent class
TIFFHandler | A wx.ImageHandler for TIFF image files.
Timer | Proxy of C++ Timer class
TimerEvent | Proxy of C++ TimerEvent class
TimerRunner | Proxy of C++ TimerRunner class
TimeSpan | Proxy of C++ TimeSpan class
TipProvider | Proxy of C++ TipProvider class
TipWindow | Proxy of C++ TipWindow class
ToggleButton | Proxy of C++ ToggleButton class
ToolBar | Proxy of C++ ToolBar class
ToolBarBase | Proxy of C++ ToolBarBase class
ToolBarToolBase | Proxy of C++ ToolBarToolBase class
ToolTip | Proxy of C++ ToolTip class
TopLevelWindow | Proxy of C++ TopLevelWindow class
TreeCtrl | Proxy of C++ TreeCtrl class
TreeEvent | Proxy of C++ TreeEvent class
TreeItemData | Proxy of C++ TreeItemData class
TreeItemId | Proxy of C++ TreeItemId class
UpdateUIEvent | This class is used for EVT_UPDATE_UI pseudo-events which are sent by wxWidgets to give an application the chance to update various user interface elements.
URLDataObject | This data object holds a URL in a format that is compatible with some browsers such that it is able to be dragged to or from them.
Validator | Proxy of C++ Validator class
VideoMode | A simple struct containing video mode parameters for a display
VisualAttributes | struct containing all the visual attributes of a control
VListBox | Proxy of C++ VListBox class
VScrolledWindow | Proxy of C++ VScrolledWindow class
Window | wx.Window is the base class for all windows and represents any visible object on the screen.
WindowCreateEvent | The EVT_WINDOW_CREATE event is sent as soon as the window object (the underlying GUI object) exists.
WindowDC | A wx.WindowDC must be constructed if an application wishes to paint on the whole area of a window (client and decorations).
WindowDestroyEvent | The EVT_WINDOW_DESTROY event is sent right before the window is destroyed.
WindowDisabler | Proxy of C++ WindowDisabler class
XPMHandler | A wx.ImageHandler for XPM image.
ZipFSHandler | Proxy of C++ ZipFSHandler class

Exceptions
PyAssertionError
PyDeadObjectError
PyNoAppError
PyUnbornObjectError

Function Summary
App_CleanUp()
For internal use only, it is used to cleanup after wxWidgets when Python shuts down.
App_GetComCtl32Version(...)
App_GetMacAboutMenuItemId(...)
App_GetMacExitMenuItemId(...)
App_GetMacHelpMenuTitleName(...)
App_GetMacPreferencesMenuItemId(...)
App_GetMacSupportPCMenuShortcuts(...)
App_SetMacAboutMenuItemId(...)
App_SetMacExitMenuItemId(...)
App_SetMacHelpMenuTitleName(...)
App_SetMacPreferencesMenuItemId(...)
App_SetMacSupportPCMenuShortcuts(...)
Bitmap ArtProvider_GetBitmap(id, client, size)
Query the providers for bitmap with given ID and return it.
Icon ArtProvider_GetIcon(id, client, size)
Query the providers for icon with given ID and return it.
Size ArtProvider_GetSizeHint(client, platform_dependent)
Get the size hint of an icon from a specific Art Client, queries the topmost provider if platform_dependent = false
bool ArtProvider_PopProvider()
Remove latest added provider and delete it.
ArtProvider_PushProvider(provider)
Add new provider to the top of providers stack.
bool ArtProvider_RemoveProvider(provider)
Remove provider.
BeginBusyCursor(cursor)
Bell()
Bitmap BitmapFromBits(bits, width, height, depth)
Creates a bitmap from an array of bits.
Bitmap BitmapFromIcon(icon)
Create a new bitmap from a wx.Icon object.
Bitmap BitmapFromImage(image, depth)
Creates bitmap object from a wx.Image.
Bitmap BitmapFromXPMData(listOfStrings)
Construct a Bitmap from a list of strings formatted as XPM data.
VisualAttributes BookCtrlBase_GetClassDefaultAttributes(variant)
Get the default attributes for this class.
Brush BrushFromBitmap(stippleBitmap)
Constructs a stippled brush using a bitmap.
VisualAttributes Button_GetClassDefaultAttributes(variant)
Get the default attributes for this class.
Size Button_GetDefaultSize()
Returns the default button size for this platform.
CallAfter(callable, *args, **kw)
Call the specified function after the current and pending event handlers have been completed.
int | Caret_GetBlinkTime()
Caret_SetBlinkTime(milliseconds)
VisualAttributes CheckBox_GetClassDefaultAttributes(variant)
Get the default attributes for this class.
VisualAttributes Choice_GetClassDefaultAttributes(variant)
Get the default attributes for this class.
(x, y, width, height) | ClientDisplayRect()
Clipboard Clipboard_Get()
Returns global instance (wxTheClipboard) of the object.
ColorRGB(*args, **kwargs)
ColourRGB(unsigned long colRGB) -> Colour
bool | ColourDisplay()
ColourRGB(*args, **kwargs)
ColourRGB(unsigned long colRGB) -> Colour
VisualAttributes ComboBox_GetClassDefaultAttributes(variant)
Get the default attributes for this class.
ConfigBase ConfigBase_Create()
Create and return a new global config object.
ConfigBase_DontCreateOnDemand()
Should Get() try to create a new log object if there isn't a current one?
ConfigBase ConfigBase_Get(createOnDemand)
Returns the current global config object, creating one if neccessary.
ConfigBase ConfigBase_Set(config)
Sets the global config object (the one returned by Get) and returns a reference to the previous global config object.
VisualAttributes Control_GetClassDefaultAttributes(variant)
Get the default attributes for this class.
TipProvider | CreateFileTipProvider(filename, currentTip)
Cursor CursorFromImage(image)
Constructs a cursor from a wx.Image.
DataFormat CustomDataFormat(format)
Constructs a data format object for a custom format identified by its name.
DateSpan | DateSpan_Day()
DateSpan | DateSpan_Days(days)
DateSpan | DateSpan_Month()
DateSpan | DateSpan_Months(mon)
DateSpan | DateSpan_Week()
DateSpan | DateSpan_Weeks(weeks)
DateSpan | DateSpan_Year()
DateSpan | DateSpan_Years(years)
int | DateTime_ConvertYearToBC(year)
DateTime_GetAmPmStrings(*args, **kwargs)
GetAmPmStrings() -> (am, pm)
DateTime | DateTime_GetBeginDST(year, country)
int | DateTime_GetCentury(year)
int | DateTime_GetCountry()
int | DateTime_GetCurrentMonth(cal)
int | DateTime_GetCurrentYear(cal)
DateTime | DateTime_GetEndDST(year, country)
String | DateTime_GetMonthName(month, flags)
int | DateTime_GetNumberOfDaysInMonth(month, year, cal)
int | DateTime_GetNumberOfDaysinYear(year, cal)
String | DateTime_GetWeekDayName(weekday, flags)
bool | DateTime_IsDSTApplicable(year, country)
bool | DateTime_IsLeapYear(year, cal)
bool | DateTime_IsWestEuropeanCountry(country)
DateTime | DateTime_Now()
DateTime_SetCountry(country)
DateTime | DateTime_SetToWeekOfYear(year, numWeek, weekday)
DateTime | DateTime_Today()
DateTime | DateTime_UNow()
DateTime | DateTimeFromDMY(day, month, year, hour, minute, second, millisec)
DateTime | DateTimeFromHMS(hour, minute, second, millisec)
DateTime | DateTimeFromJDN(jdn)
DateTime | DateTimeFromTimeT(timet)
VisualAttributes Dialog_GetClassDefaultAttributes(variant)
Get the default attributes for this class.
String | DirSelector(message, defaultPath, style, pos, parent)
size_t Display_GetCount()
Return the number of available displays.
int Display_GetFromPoint(pt)
Find the display where the given point lies, return wx.NOT_FOUND if it doesn't belong to any display
int Display_GetFromWindow(window)
Find the display where the given window lies, return wx.NOT_FOUND if it is not shown at all.
int | DisplayDepth()
(width, height) | DisplaySize()
(width, height) | DisplaySizeMM()
DLG_PNT(win, point_or_x, y)
Convenience function for converting a Point or (x,y) in dialog units to pixel units.
DLG_SZE(win, size_width, height)
Convenience function for converting a Size or (w,h) in dialog units to pixel units.
DragImage | DragIcon(image, cursor)
DragImage | DragListItem(listCtrl, id)
DragImage | DragString(str, cursor)
DragImage | DragTreeItem(treeCtrl, id)
bool | DrawWindowOnDC(window, dc)
DROP_ICON(filename)
Returns either a wx.Cursor or wx.Icon created from the image file filename.
Bitmap EmptyBitmap(width, height, depth)
Creates a new bitmap of the given size.
Icon | EmptyIcon()
Image EmptyImage(width, height, clear)
Construct an empty image of a given size, optionally setting all pixels to black.
EnableTopLevelWindows(enable)
bool | EncodingConverter_CanConvert(encIn, encOut)
wxFontEncodingArray | EncodingConverter_GetAllEquivalents(enc)
wxFontEncodingArray | EncodingConverter_GetPlatformEquivalents(enc, platform)
EndBusyCursor()
EventLoop | EventLoop_GetActive()
EventLoop_SetActive(loop)
long | Execute(command, flags, process)
Exit()
Force an exit of the application.
String ExpandEnvVars(sz)
Replace environment variables ($SOMETHING) with their values.
Font FFont(pointSize, family, flags, face, encoding)
A bit of a simpler way to create a wx.Font using flags instead of individual attribute settings.
Font FFontFromPixelSize(pixelSize, family, flags, face, encoding)
Creates a font using a size in pixels rather than points.
String | FileSelector(message, default_path, default_filename, default_extension, wildcard, flags, parent, x, y)
FileSystem_AddHandler(handler)
FileSystem_CleanUpHandlers()
String | FileSystem_FileNameToURL(filename)
String | FileSystem_URLToFileName(url)
String | FileType_ExpandCommand(command, filename, mimetype)
FileTypeInfo | FileTypeInfoSequence(sArray)
Window | FindWindowAtPoint(pt)
Window FindWindowById(id, parent)
Find the first window in the application with the given id.
Window FindWindowByLabel(label, parent)
Find a window by its label.
Window FindWindowByName(name, parent)
Find a window by its name (as given in a window constructor or Create function call).
Font2(*args, **kwargs)
Use wx.FFont instead.
int Font_GetDefaultEncoding()
Returns the encoding used for all fonts created with an encoding of wx.FONTENCODING_DEFAULT.
Font_SetDefaultEncoding(encoding)
Sets the default font encoding.
Font FontFromNativeInfo(info)
Construct a wx.Font from a wx.NativeFontInfo object.
Font FontFromNativeInfoString(info)
Construct a wx.Font from the string representation of a wx.NativeFontInfo object.
Font FontFromPixelSize(pixelSize, family, style, weight, underlined, face, encoding)
Creates a font using a size in pixels rather than points.
FontMapper | FontMapper_Get()
String | FontMapper_GetDefaultConfigPath()
int | FontMapper_GetEncoding(n)
String | FontMapper_GetEncodingDescription(encoding)
int | FontMapper_GetEncodingFromName(name)
String | FontMapper_GetEncodingName(encoding)
size_t | FontMapper_GetSupportedEncodingsCount()
FontMapper | FontMapper_Set(mapper)
VisualAttributes Frame_GetClassDefaultAttributes(variant)
Get the default attributes for this class.
VisualAttributes Gauge_GetClassDefaultAttributes(variant)
Get the default attributes for this class.
GBSizerItem GBSizerItemSizer(sizer, pos, span, flag, border, userData)
Construct a wx.GBSizerItem for a sizer
GBSizerItem GBSizerItemSpacer(width, height, pos, span, flag, border, userData)
Construct a wx.GBSizerItem for a spacer.
GBSizerItem GBSizerItemWindow(window, pos, span, flag, border, userData)
Construct a wx.GBSizerItem for a window.
Window | GenericFindWindowAtPoint(pt)
AcceleratorEntry | GetAccelFromString(label)
Window | GetActiveWindow()
PyApp GetApp()
Return a reference to the current wx.App object.
Rect | GetClientDisplayRect()
long | GetCurrentId()
long | GetCurrentTime()
string GetDefaultPyEncoding()
Gets the current encoding that wxPython will use when it needs to convert a Python string or unicode object to or from a wxString.
int | GetDisplayDepth()
Size | GetDisplaySize()
Size | GetDisplaySizeMM()
long | GetElapsedTime(resetTimer)
String | GetEmailAddress()
long | GetFreeMemory()
String | GetFullHostName()
String | GetHomeDir()
String | GetHostName()
bool GetKeyState(key)
Get the state of a key (true if pressed or toggled on, false if not.) This is generally most useful getting the state of the modifier or toggle keys.
Locale | GetLocale()
long | GetLocalTime()
wxLongLong | GetLocalTimeMillis()
(x,y) | GetMousePosition()
NativeEncodingInfo | GetNativeFontEncoding(encoding)
long | GetNumberFromUser(message, prompt, caption, value, min, max, parent, pos)
String | GetOsDescription()
(platform, major, minor) | GetOsVersion()
String | GetPasswordFromUser(message, caption, default_value, parent)
unsigned long | GetProcessId()
String | GetSingleChoice(message, caption, choices, parent, x, y, centre, width, height)
int | GetSingleChoiceIndex(message, caption, choices, parent, x, y, centre, width, height)
String | GetStockLabel(id, withCodes, accelerator)
String | GetTextFromUser(message, caption, default_value, parent, x, y, centre)
Window | GetTopLevelParent(win)
PyObject GetTopLevelWindows()
Returns a list of the the application's top-level windows, (frames, dialogs, etc.) NOTE: Currently this is a copy of the list maintained by wxWidgets, and so it is only valid as long as no top-level windows are closed or new top-level windows are created.
String GetTranslation(str)
GetTranslation(String str, String strPlural, size_t n) -> String
String | GetUserHome(user)
String | GetUserId()
String | GetUserName()
long | GetUTCTime()
void GetXDisplay()
Returns a swigified pointer to the X11 display.
HelpProvider HelpProvider_Get()
Return the current application-wide help provider.
HelpProvider HelpProvider_Set(helpProvider)
Sset the current, application-wide help provider.
IconBundle | IconBundleFromFile(file, type)
IconBundle | IconBundleFromIcon(icon)
Icon | IconFromBitmap(bmp)
Icon | IconFromLocation(loc)
Icon | IconFromXPMData(listOfStrings)
bool IdleEvent_CanSend(win)
Returns True if it is appropriate to send idle events to this window.
int IdleEvent_GetMode()
Static method returning a value specifying how wxWidgets will send idle events: to all windows, or only to those which specify that they will process the events.
IdleEvent_SetMode(mode)
Static method for specifying how wxWidgets will send idle events: to all windows, or only to those which specify that they will process the events.
Image_AddHandler(handler)
bool Image_CanRead(filename)
Returns True if the image handlers can read this file.
bool Image_CanReadStream(stream)
Returns True if the image handlers can read an image file from the data currently on the input stream, or a readable Python file-like object.
int Image_GetImageCount(filename, type)
If the image file contains more than one image and the image handler is capable of retrieving these individually, this function will return the number of available images.
String Image_GetImageExtWildcard()
Iterates all registered wxImageHandler objects, and returns a string containing file extension masks suitable for passing to file open/save dialog boxes.
Image_InsertHandler(handler)
bool | Image_RemoveHandler(name)
Image ImageFromBitmap(bitmap)
Construct an Image from a wx.Bitmap.
Image ImageFromData(width, height, data)
Construct an Image from a buffer of RGB bytes.
Image ImageFromDataWithAlpha(width, height, data, alpha)
Construct an Image from a buffer of RGB bytes with an Alpha channel.
Image ImageFromMime(name, mimetype, index)
Loads an image from a file, using a MIME type string (such as 'image/jpeg') to specify image type.
Image ImageFromStream(stream, type, index)
Loads an image from an input stream, or any readable Python file-like object.
Image ImageFromStreamMime(stream, mimetype, index)
Loads an image from an input stream, or any readable Python file-like object, specifying the image format with a MIME type string.
unsigned long ImageHistogram_MakeKey(r, g, b)
Get the key in the histogram for the given RGB values
InitAllImageHandlers()
The former functionality of InitAllImageHanders is now done internal to the _core_ extension module and so this function has become a simple NOP.
Rect IntersectRect(r1, r2)
Calculate and return the intersection of r1 and r2.
bool | IsBusy()
bool | IsDragResultOk(res)
bool | IsStockID(id)
bool | IsStockLabel(id, label)
int | Kill(pid, sig, rc, flags)
bool LaunchDefaultBrowser(url)
Launches the user's default browser and tells it to open the location at url.
VisualAttributes ListBox_GetClassDefaultAttributes(variant)
Get the default attributes for this class.
VisualAttributes ListCtrl_GetClassDefaultAttributes(variant)
Get the default attributes for this class.
String | LoadFileSelector(what, extension, default_name, parent)
Locale_AddCatalogLookupPathPrefix(prefix)
Locale_AddLanguage(info)
LanguageInfo | Locale_FindLanguageInfo(locale)
LanguageInfo | Locale_GetLanguageInfo(lang)
String | Locale_GetLanguageName(lang)
int | Locale_GetSystemEncoding()
String | Locale_GetSystemEncodingName()
int | Locale_GetSystemLanguage()
Log_AddTraceMask(str)
Log_ClearTraceMasks()
Log_DontCreateOnDemand()
bool | Log_EnableLogging(doIt)
Log_FlushActive()
Log | Log_GetActiveTarget()
wxLogLevel | Log_GetLogLevel()
wxChar | Log_GetTimestamp()
wxTraceMask | Log_GetTraceMask()
wxArrayString | Log_GetTraceMasks()
bool | Log_GetVerbose()
bool | Log_IsAllowedTraceMask(mask)
bool | Log_IsEnabled()
Log_OnLog(level, szString, t)
Log_RemoveTraceMask(str)
Log_Resume()
Log | Log_SetActiveTarget(pLogger)
Log_SetLogLevel(logLevel)
Log_SetTimestamp(ts)
Log_SetTraceMask(ulMask)
Log_SetVerbose(bVerbose)
Log_Suspend()
String | Log_TimeStamp()
LogDebug(msg)
LogError(msg)
LogFatalError(msg)
LogGeneric(*args, **kwargs)
LogGeneric(unsigned long level, String msg)
LogInfo(msg)
LogMessage(msg)
LogStatus(msg)
LogStatusFrame(pFrame, msg)
LogSysError(msg)
LogTrace(*args)
LogTrace(unsigned long mask, String msg) LogTrace(String mask, String msg)
LogVerbose(msg)
LogWarning(msg)
MaskColour(*args, **kwargs)
wx.MaskColour is deprecated, use wx.Mask instead.
MemoryDC MemoryDCFromDC(oldDC)
Creates a DC that is compatible with the oldDC.
MemoryFSHandler_AddFile(filename, dataItem, imgType)
Add 'file' to the memory filesystem.
MemoryFSHandler_RemoveFile(filename)
int | MenuItem_GetDefaultMarginWidth()
String | MenuItem_GetLabelFromText(text)
int | MessageBox(message, caption, style, parent, x, y)
MicroSleep(*args, **kwargs)
MicroSleep(unsigned long microseconds)
MilliSleep(*args, **kwargs)
MilliSleep(unsigned long milliseconds)
bool | MimeTypesManager_IsOfType(mimeType, wildcard)
MutexGuiEnter()
MutexGuiLeave()
Colour NamedColor(colorName)
Constructs a colour object using a colour name listed in wx.TheColourDatabase.
Colour NamedColour(colorName)
Constructs a colour object using a colour name listed in wx.TheColourDatabase.
wxEventType | NewEventType()
long | NewId()
VisualAttributes Notebook_GetClassDefaultAttributes(variant)
Get the default attributes for this class.
String | Now()
FileTypeInfo | NullFileTypeInfo()
VisualAttributes Panel_GetClassDefaultAttributes(variant)
Get the default attributes for this class.
Point2D Point2DCopy(pt)
Create a w.Point2D object.
Point2D Point2DFromPoint(pt)
Create a w.Point2D object.
PostEvent(dest, event)
Send an event to a window or other wx.EvtHandler to be processed later.
int PostScriptDC_GetResolution()
Return resolution used in PostScript output.
PostScriptDC_SetResolution(ppi)
Set resolution (in pixels per inch) that will be used in PostScript output.
BitmapButton PreBitmapButton()
Precreate a BitmapButton for 2-phase creation.
Button PreButton()
Precreate a Button for 2-phase creation.
CheckBox PreCheckBox()
Precreate a CheckBox for 2-phase creation.
CheckListBox | PreCheckListBox()
Choice PreChoice()
Precreate a Choice control for 2-phase creation.
Choicebook | PreChoicebook()
ComboBox PreComboBox()
Precreate a ComboBox control for 2-phase creation.
Control PreControl()
Precreate a Control control for 2-phase creation
DatePickerCtrl PreDatePickerCtrl()
Precreate a DatePickerCtrl for use in 2-phase creation.
Dialog | PreDialog()
DirFilterListCtrl | PreDirFilterListCtrl()
FindReplaceDialog PreFindReplaceDialog()
Precreate a FindReplaceDialog for 2-phase creation
Frame | PreFrame()
Gauge | PreGauge()
GenericDirCtrl | PreGenericDirCtrl()
HtmlListBox | PreHtmlListBox()
Listbook | PreListbook()
ListBox | PreListBox()
ListCtrl | PreListCtrl()
ListView | PreListView()
MDIChildFrame | PreMDIChildFrame()
MDIClientWindow | PreMDIClientWindow()
MDIParentFrame | PreMDIParentFrame()
MiniFrame | PreMiniFrame()
Notebook | PreNotebook()
Panel | PrePanel()
PopupTransientWindow | PrePopupTransientWindow()
PopupWindow | PrePopupWindow()
PyControl | PrePyControl()
PyPanel | PrePyPanel()
PyScrolledWindow | PrePyScrolledWindow()
PyWindow | PrePyWindow()
RadioBox | PreRadioBox()
RadioButton | PreRadioButton()
SashLayoutWindow | PreSashLayoutWindow()
SashWindow | PreSashWindow()
ScrollBar | PreScrollBar()
ScrolledWindow | PreScrolledWindow()
SingleInstanceChecker | PreSingleInstanceChecker()
Slider | PreSlider()
SpinButton | PreSpinButton()
SpinCtrl | PreSpinCtrl()
SplitterWindow PreSplitterWindow()
Precreate a SplitterWindow for 2-phase creation.
StaticBitmap | PreStaticBitmap()
StaticBox | PreStaticBox()
StaticLine | PreStaticLine()
StaticText | PreStaticText()
StatusBar | PreStatusBar()
TextCtrl | PreTextCtrl()
ToggleButton | PreToggleButton()
ToolBar | PreToolBar()
TreeCtrl | PreTreeCtrl()
VListBox | PreVListBox()
VScrolledWindow | PreVScrolledWindow()
Window PreWindow()
Precreate a Window for 2-phase creation.
int | Printer_GetLastError()
bool | Process_Exists(pid)
int | Process_Kill(pid, sig, flags)
Process | Process_Open(cmd, flags)
int PyApp_GetComCtl32Version()
Returns 400, 470, 471, etc.
long | PyApp_GetMacAboutMenuItemId()
long | PyApp_GetMacExitMenuItemId()
String | PyApp_GetMacHelpMenuTitleName()
long | PyApp_GetMacPreferencesMenuItemId()
bool | PyApp_GetMacSupportPCMenuShortcuts()
bool PyApp_IsMainLoopRunning()
Returns True if we're running the main loop, i.e.
PyApp_SetMacAboutMenuItemId(val)
PyApp_SetMacExitMenuItemId(val)
PyApp_SetMacHelpMenuTitleName(val)
PyApp_SetMacPreferencesMenuItemId(val)
PyApp_SetMacSupportPCMenuShortcuts(val)
bool Quantize_Quantize(src, dest, desiredNoColours, flags)
Reduce the colours in the source image and put the result into the destination image, setting the palette in the destination if needed.
VisualAttributes RadioBox_GetClassDefaultAttributes(variant)
Get the default attributes for this class.
VisualAttributes RadioButton_GetClassDefaultAttributes(variant)
Get the default attributes for this class.
Rect RectPP(topLeft, bottomRight)
Create a new Rect object from Points representing two corners.
Rect RectPS(pos, size)
Create a new Rect from a position and size.
Rect RectS(size)
Create a new Rect from a size only.
Region | RegionFromBitmap(bmp)
Region | RegionFromBitmapColour(bmp, transColour, tolerance)
Region | RegionFromPoints(points, fillStyle)
RegisterId(id)
SafeShowMessage(title, text)
bool SafeYield(win, onlyIfNeeded)
This function is similar to wx.Yield, except that it disables the user input to all program windows before calling wx.Yield and re-enables it again afterwards.
String | SaveFileSelector(what, extension, default_name, parent)
VisualAttributes ScrollBar_GetClassDefaultAttributes(variant)
Get the default attributes for this class.
VisualAttributes ScrolledWindow_GetClassDefaultAttributes(variant)
Get the default attributes for this class.
SetCursor(cursor)
SetDefaultPyEncoding(encoding)
Sets the encoding that wxPython will use when it needs to convert a Python string or unicode object to or from a wxString.
bool | Shell(command)
bool | ShowTip(parent, tipProvider, showAtStartup)
bool | Shutdown(wFlags)
SizerItem SizerItemSizer(sizer, proportion, flag, border, userData)
Constructs a wx.SizerItem for tracking a subsizer
SizerItem SizerItemSpacer(width, height, proportion, flag, border, userData)
Constructs a wx.SizerItem for tracking a spacer.
SizerItem SizerItemWindow(window, proportion, flag, border, userData)
Constructs a wx.SizerItem for tracking a window.
Sleep(secs)
VisualAttributes Slider_GetClassDefaultAttributes(variant)
Get the default attributes for this class.
Sound_PlaySound(*args, **kwargs)
Sound_PlaySound(String filename, unsigned int flags=SOUND_ASYNC) -> bool
Sound_Stop()
Sound | SoundFromData(data)
VisualAttributes SpinButton_GetClassDefaultAttributes(variant)
Get the default attributes for this class.
VisualAttributes SpinCtrl_GetClassDefaultAttributes(variant)
Get the default attributes for this class.
VisualAttributes SplitterWindow_GetClassDefaultAttributes(variant)
Get the default attributes for this class.
StandardPaths StandardPaths_Get()
Return the global standard paths singleton
StartTimer()
VisualAttributes StaticBitmap_GetClassDefaultAttributes(variant)
Get the default attributes for this class.
VisualAttributes StaticBox_GetClassDefaultAttributes(variant)
Get the default attributes for this class.
VisualAttributes StaticLine_GetClassDefaultAttributes(variant)
Get the default attributes for this class.
int | StaticLine_GetDefaultSize()
VisualAttributes StaticText_GetClassDefaultAttributes(variant)
Get the default attributes for this class.
VisualAttributes StatusBar_GetClassDefaultAttributes(variant)
Get the default attributes for this class.
Cursor StockCursor(id)
Create a cursor using one of the stock cursors.
String | StripMenuCodes(in)
unsigned long | SysErrorCode()
SysErrorMsg(*args, **kwargs)
SysErrorMsg(unsigned long nErrCode=0) -> String
String | SystemOptions_GetOption(name)
int | SystemOptions_GetOptionInt(name)
bool | SystemOptions_HasOption(name)
bool | SystemOptions_IsFalse(name)
SystemOptions_SetOption(name, value)
SystemOptions_SetOptionInt(name, value)
Colour | SystemSettings_GetColour(index)
Font | SystemSettings_GetFont(index)
int | SystemSettings_GetMetric(index, win)
int | SystemSettings_GetScreenType()
bool | SystemSettings_HasFeature(index)
SystemSettings_SetScreenType(screen)
bool | TestFontEncoding(info)
TextAttr | TextAttr_Combine(attr, attrDef, text)
VisualAttributes TextCtrl_GetClassDefaultAttributes(variant)
Get the default attributes for this class.
bool | Thread_IsMain()
TimeSpan | TimeSpan_Day()
TimeSpan | TimeSpan_Days(days)
TimeSpan | TimeSpan_Hour()
TimeSpan | TimeSpan_Hours(hours)
TimeSpan | TimeSpan_Minute()
TimeSpan | TimeSpan_Minutes(min)
TimeSpan | TimeSpan_Second()
TimeSpan | TimeSpan_Seconds(sec)
TimeSpan | TimeSpan_Week()
TimeSpan | TimeSpan_Weeks(days)
VisualAttributes ToggleButton_GetClassDefaultAttributes(variant)
Get the default attributes for this class.
VisualAttributes ToolBar_GetClassDefaultAttributes(variant)
Get the default attributes for this class.
ToolTip_Enable(flag)
ToolTip_SetDelay(milliseconds)
Trap()
VisualAttributes TreeCtrl_GetClassDefaultAttributes(variant)
Get the default attributes for this class.
bool UpdateUIEvent_CanUpdate(win)
Returns True if it is appropriate to update (send UI update events to) this window.
int UpdateUIEvent_GetMode()
Returns a value specifying how wxWidgets will send update events: to all windows, or only to those which specify that they will process the events.
long UpdateUIEvent_GetUpdateInterval()
Returns the current interval between updates in milliseconds.
UpdateUIEvent_ResetUpdateTime()
Used internally to reset the last-updated time to the current time.
UpdateUIEvent_SetMode(mode)
Specify how wxWidgets will send update events: to all windows, or only to those which specify that they will process the events.
UpdateUIEvent_SetUpdateInterval(updateInterval)
Sets the interval between updates in milliseconds.
Usleep(*args, **kwargs)
MilliSleep(unsigned long milliseconds)
bool | Validator_IsSilent()
Validator_SetBellOnError(doIt)
WakeUpIdle()
Cause the message queue to become empty again, so idle events will be sent.
WakeUpMainThread()
Window Window_FindFocus()
Returns the window or control that currently has the keyboard focus, or None.
Window_FromHWND(*args, **kwargs)
Window_FromHWND(Window parent, unsigned long _hWnd) -> Window
Window Window_GetCapture()
Returns the window which currently captures the mouse or None
VisualAttributes Window_GetClassDefaultAttributes(variant)
Get the default attributes for this class.
int Window_NewControlId()
Generate a control id for the controls which were not given one.
int Window_NextControlId(winid)
Get the id of the control following the one with the given autogenerated) id
int Window_PrevControlId(winid)
Get the id of the control preceding the one with the given autogenerated) id
bool Yield()
Yield to other apps/messages.
bool YieldIfNeeded()
Yield to other apps/messages.

Function Details

App_CleanUp()

For internal use only, it is used to cleanup after wxWidgets when Python shuts down.

ArtProvider_GetBitmap(id, client=ART_OTHER, size=DefaultSize)

Query the providers for bitmap with given ID and return it. Return wx.NullBitmap if no provider provides it.

Parameters:
id
(type=String)

client
(type=String)

size
(type=Size)

Returns:
Bitmap

ArtProvider_GetIcon(id, client=ART_OTHER, size=DefaultSize)

Query the providers for icon with given ID and return it. Return wx.NullIcon if no provider provides it.

Parameters:
id
(type=String)

client
(type=String)

size
(type=Size)

Returns:
Icon

ArtProvider_GetSizeHint(client, platform_dependent=False)

Get the size hint of an icon from a specific Art Client, queries the topmost provider if platform_dependent = false

Parameters:
client
(type=String)

platform_dependent
(type=bool)

Returns:
Size

ArtProvider_PopProvider()

Remove latest added provider and delete it.

Returns:
bool

ArtProvider_PushProvider(provider)

Add new provider to the top of providers stack.

Parameters:
provider
(type=ArtProvider)

ArtProvider_RemoveProvider(provider)

Remove provider. The provider must have been added previously! The provider is _not_ deleted.

Parameters:
provider
(type=ArtProvider)

Returns:
bool

BitmapFromBits(bits, width, height, depth=1)

Creates a bitmap from an array of bits. You should only use this function for monochrome bitmaps (depth 1) in portable programs: in this case the bits parameter should contain an XBM image. For other bit depths, the behaviour is platform dependent.

Parameters:
bits
(type=PyObject)

width
(type=int)

height
(type=int)

depth
(type=int)

Returns:
Bitmap

BitmapFromIcon(icon)

Create a new bitmap from a wx.Icon object.

Parameters:
icon
(type=Icon)

Returns:
Bitmap

BitmapFromImage(image, depth=-1)

Creates bitmap object from a wx.Image. This has to be done to actually display a wx.Image as you cannot draw an image directly on a window. The resulting bitmap will use the provided colour depth (or that of the current screen colour depth if depth is -1) which entails that a colour reduction may have to take place.

Parameters:
image
(type=Image)

depth
(type=int)

Returns:
Bitmap

BitmapFromXPMData(listOfStrings)

Construct a Bitmap from a list of strings formatted as XPM data.

Parameters:
listOfStrings
(type=PyObject)

Returns:
Bitmap

BookCtrlBase_GetClassDefaultAttributes(variant=WINDOW_VARIANT_NORMAL)

Get the default attributes for this class. This is useful if you want to use the same font or colour in your own control as in a standard control -- which is a much better idea than hard coding specific colours or fonts which might look completely out of place on the user's system, especially if it uses themes.

The variant parameter is only relevant under Mac currently and is ignore under other platforms. Under Mac, it will change the size of the returned font. See wx.Window.SetWindowVariant for more about this.

Parameters:
variant
(type=int)

Returns:
VisualAttributes

BrushFromBitmap(stippleBitmap)

Constructs a stippled brush using a bitmap.

Parameters:
stippleBitmap
(type=Bitmap)

Returns:
Brush

Button_GetClassDefaultAttributes(variant=WINDOW_VARIANT_NORMAL)

Get the default attributes for this class. This is useful if you want to use the same font or colour in your own control as in a standard control -- which is a much better idea than hard coding specific colours or fonts which might look completely out of place on the user's system, especially if it uses themes.

The variant parameter is only relevant under Mac currently and is ignore under other platforms. Under Mac, it will change the size of the returned font. See wx.Window.SetWindowVariant for more about this.

Parameters:
variant
(type=int)

Returns:
VisualAttributes

Button_GetDefaultSize()

Returns the default button size for this platform.

Returns:
Size

CallAfter(callable, *args, **kw)

Call the specified function after the current and pending event handlers have been completed. This is also good for making GUI method calls from non-GUI threads. Any extra positional or keyword args are passed on to the callable when it is called.

See Also:

wx.FutureCall

CheckBox_GetClassDefaultAttributes(variant=WINDOW_VARIANT_NORMAL)

Get the default attributes for this class. This is useful if you want to use the same font or colour in your own control as in a standard control -- which is a much better idea than hard coding specific colours or fonts which might look completely out of place on the user's system, especially if it uses themes.

The variant parameter is only relevant under Mac currently and is ignore under other platforms. Under Mac, it will change the size of the returned font. See wx.Window.SetWindowVariant for more about this.

Parameters:
variant
(type=int)

Returns:
VisualAttributes

Choice_GetClassDefaultAttributes(variant=WINDOW_VARIANT_NORMAL)

Get the default attributes for this class. This is useful if you want to use the same font or colour in your own control as in a standard control -- which is a much better idea than hard coding specific colours or fonts which might look completely out of place on the user's system, especially if it uses themes.

The variant parameter is only relevant under Mac currently and is ignore under other platforms. Under Mac, it will change the size of the returned font. See wx.Window.SetWindowVariant for more about this.

Parameters:
variant
(type=int)

Returns:
VisualAttributes

Clipboard_Get()

Returns global instance (wxTheClipboard) of the object.

Returns:
Clipboard

ColorRGB(*args, **kwargs)

ColourRGB(unsigned long colRGB) -> Colour

Constructs a colour from a packed RGB value.

ColourRGB(*args, **kwargs)

ColourRGB(unsigned long colRGB) -> Colour

Constructs a colour from a packed RGB value.

ComboBox_GetClassDefaultAttributes(variant=WINDOW_VARIANT_NORMAL)

Get the default attributes for this class. This is useful if you want to use the same font or colour in your own control as in a standard control -- which is a much better idea than hard coding specific colours or fonts which might look completely out of place on the user's system, especially if it uses themes.

The variant parameter is only relevant under Mac currently and is ignore under other platforms. Under Mac, it will change the size of the returned font. See wx.Window.SetWindowVariant for more about this.

Parameters:
variant
(type=int)

Returns:
VisualAttributes

ConfigBase_Create()

Create and return a new global config object. This function will create the "best" implementation of wx.Config available for the current platform.

Returns:
ConfigBase

ConfigBase_DontCreateOnDemand()

Should Get() try to create a new log object if there isn't a current one?

ConfigBase_Get(createOnDemand=True)

Returns the current global config object, creating one if neccessary.

Parameters:
createOnDemand
(type=bool)

Returns:
ConfigBase

ConfigBase_Set(config)

Sets the global config object (the one returned by Get) and returns a reference to the previous global config object.

Parameters:
config
(type=ConfigBase)

Returns:
ConfigBase

Control_GetClassDefaultAttributes(variant=WINDOW_VARIANT_NORMAL)

Get the default attributes for this class. This is useful if you want to use the same font or colour in your own control as in a standard control -- which is a much better idea than hard coding specific colours or fonts which might look completely out of place on the user's system, especially if it uses themes.

The variant parameter is only relevant under Mac currently and is ignore under other platforms. Under Mac, it will change the size of the returned font. See wx.Window.SetWindowVariant for more about this.

Parameters:
variant
(type=int)

Returns:
VisualAttributes

CursorFromImage(image)

Constructs a cursor from a wx.Image. The mask (if any) will be used for setting the transparent portions of the cursor. In MSW the cursor is resized to 32x32 if it was larger.

In GTK the cursor will be displayed at the size of the image.

On MacOS the cursor is resized to 16x16 if it was larger.

Parameters:
image
(type=Image)

Returns:
Cursor

CustomDataFormat(format)

Constructs a data format object for a custom format identified by its name.

Parameters:
format
(type=String)

Returns:
DataFormat

DateTime_GetAmPmStrings(*args, **kwargs)

GetAmPmStrings() -> (am, pm)

Get the AM and PM strings in the current locale (may be empty)

Dialog_GetClassDefaultAttributes(variant=WINDOW_VARIANT_NORMAL)

Get the default attributes for this class. This is useful if you want to use the same font or colour in your own control as in a standard control -- which is a much better idea than hard coding specific colours or fonts which might look completely out of place on the user's system, especially if it uses themes.

The variant parameter is only relevant under Mac currently and is ignore under other platforms. Under Mac, it will change the size of the returned font. See wx.Window.SetWindowVariant for more about this.

Parameters:
variant
(type=int)

Returns:
VisualAttributes

Display_GetCount()

Return the number of available displays.

Returns:
size_t

Display_GetFromPoint(pt)

Find the display where the given point lies, return wx.NOT_FOUND if it doesn't belong to any display

Parameters:
pt
(type=Point)

Returns:
int

Display_GetFromWindow(window)

Find the display where the given window lies, return wx.NOT_FOUND if it is not shown at all.

Parameters:
window
(type=Window)

Returns:
int

DLG_PNT(win, point_or_x, y=None)

Convenience function for converting a Point or (x,y) in dialog units to pixel units.

DLG_SZE(win, size_width, height=None)

Convenience function for converting a Size or (w,h) in dialog units to pixel units.

DROP_ICON(filename)

Returns either a wx.Cursor or wx.Icon created from the image file filename. This function is useful with the wx.DropSource class which, depending on platform accepts either a icon or a cursor.

EmptyBitmap(width, height, depth=-1)

Creates a new bitmap of the given size. A depth of -1 indicates the depth of the current screen or visual. Some platforms only support 1 for monochrome and -1 for the current colour setting.

Parameters:
width
(type=int)

height
(type=int)

depth
(type=int)

Returns:
Bitmap

EmptyImage(width=0, height=0, clear=True)

Construct an empty image of a given size, optionally setting all pixels to black.

Parameters:
width
(type=int)

height
(type=int)

clear
(type=bool)

Returns:
Image

See Also:

wx.Image

Exit()

Force an exit of the application. Convenience for wx.GetApp().Exit()

ExpandEnvVars(sz)

Replace environment variables ($SOMETHING) with their values. The format is $VARNAME or ${VARNAME} where VARNAME contains alphanumeric characters and '_' only. '$' must be escaped ('$') in order to be taken literally.

Parameters:
sz
(type=String)

Returns:
String

FFont(pointSize,
          family,
          flags=FONTFLAG_DEFAULT,
          face=EmptyString,
          encoding=FONTENCODING_DEFAULT)

A bit of a simpler way to create a wx.Font using flags instead of individual attribute settings. The value of flags can be a combination of the following:

wx.FONTFLAG_DEFAULT
wx.FONTFLAG_ITALIC
wx.FONTFLAG_SLANT
wx.FONTFLAG_LIGHT
wx.FONTFLAG_BOLD
wx.FONTFLAG_ANTIALIASED
wx.FONTFLAG_NOT_ANTIALIASED
wx.FONTFLAG_UNDERLINED
wx.FONTFLAG_STRIKETHROUGH
Parameters:
pointSize
(type=int)

family
(type=int)

flags
(type=int)

face
(type=String)

encoding
(type=int)

Returns:
Font

See Also:

wx.Font.__init__

FFontFromPixelSize(pixelSize,
          family,
          flags=FONTFLAG_DEFAULT,
          face=wxEmptyString,
          encoding=FONTENCODING_DEFAULT)

Creates a font using a size in pixels rather than points. If there is platform API support for this then it is used, otherwise a font with the closest size is found using a binary search.

Parameters:
pixelSize
(type=Size)

family
(type=int)

flags
(type=int)

face
(type=String)

encoding
(type=int)

Returns:
Font

See Also:

wx.Font.__init__, wx.FFont

FindWindowById(id, parent=None)

Find the first window in the application with the given id. If parent is None, the search will start from all top-level frames and dialog boxes; if non-None, the search will be limited to the given window hierarchy. The search is recursive in both cases.

Parameters:
id
(type=long)

parent
(type=Window)

Returns:
Window

FindWindowByLabel(label, parent=None)

Find a window by its label. Depending on the type of window, the label may be a window title or panel item label. If parent is None, the search will start from all top-level frames and dialog boxes; if non-None, the search will be limited to the given window hierarchy. The search is recursive in both cases.

Parameters:
label
(type=String)

parent
(type=Window)

Returns:
Window

FindWindowByName(name, parent=None)

Find a window by its name (as given in a window constructor or Create function call). If parent is None, the search will start from all top-level frames and dialog boxes; if non-None, the search will be limited to the given window hierarchy. The search is recursive in both cases.

If no window with such name is found, wx.FindWindowByLabel is called.

Parameters:
name
(type=String)

parent
(type=Window)

Returns:
Window

Font2(*args, **kwargs)

Use wx.FFont instead.

Font_GetDefaultEncoding()

Returns the encoding used for all fonts created with an encoding of wx.FONTENCODING_DEFAULT.

Returns:
int

Font_SetDefaultEncoding(encoding)

Sets the default font encoding.

Parameters:
encoding
(type=int)

FontFromNativeInfo(info)

Construct a wx.Font from a wx.NativeFontInfo object.

Parameters:
info
(type=NativeFontInfo)

Returns:
Font

FontFromNativeInfoString(info)

Construct a wx.Font from the string representation of a wx.NativeFontInfo object.

Parameters:
info
(type=String)

Returns:
Font

FontFromPixelSize(pixelSize, family, style, weight, underlined=False, face=wxEmptyString, encoding=FONTENCODING_DEFAULT)

Creates a font using a size in pixels rather than points. If there is platform API support for this then it is used, otherwise a font with the closest size is found using a binary search.

Parameters:
pixelSize
(type=Size)

family
(type=int)

style
(type=int)

weight
(type=int)

underlined
(type=bool)

face
(type=String)

encoding
(type=int)

Returns:
Font

See Also:

wx.Font.__init__

Frame_GetClassDefaultAttributes(variant=WINDOW_VARIANT_NORMAL)

Get the default attributes for this class. This is useful if you want to use the same font or colour in your own control as in a standard control -- which is a much better idea than hard coding specific colours or fonts which might look completely out of place on the user's system, especially if it uses themes.

The variant parameter is only relevant under Mac currently and is ignore under other platforms. Under Mac, it will change the size of the returned font. See wx.Window.SetWindowVariant for more about this.

Parameters:
variant
(type=int)

Returns:
VisualAttributes

Gauge_GetClassDefaultAttributes(variant=WINDOW_VARIANT_NORMAL)

Get the default attributes for this class. This is useful if you want to use the same font or colour in your own control as in a standard control -- which is a much better idea than hard coding specific colours or fonts which might look completely out of place on the user's system, especially if it uses themes.

The variant parameter is only relevant under Mac currently and is ignore under other platforms. Under Mac, it will change the size of the returned font. See wx.Window.SetWindowVariant for more about this.

Parameters:
variant
(type=int)

Returns:
VisualAttributes

GBSizerItemSizer(sizer, pos, span, flag, border, userData=None)

Construct a wx.GBSizerItem for a sizer

Parameters:
sizer
(type=Sizer)

pos
(type=GBPosition)

span
(type=GBSpan)

flag
(type=int)

border
(type=int)

userData
(type=PyObject)

Returns:
GBSizerItem

GBSizerItemSpacer(width, height, pos, span, flag, border, userData=None)

Construct a wx.GBSizerItem for a spacer.

Parameters:
width
(type=int)

height
(type=int)

pos
(type=GBPosition)

span
(type=GBSpan)

flag
(type=int)

border
(type=int)

userData
(type=PyObject)

Returns:
GBSizerItem

GBSizerItemWindow(window, pos, span, flag, border, userData=None)

Construct a wx.GBSizerItem for a window.

Parameters:
window
(type=Window)

pos
(type=GBPosition)

span
(type=GBSpan)

flag
(type=int)

border
(type=int)

userData
(type=PyObject)

Returns:
GBSizerItem

GetApp()

Return a reference to the current wx.App object.

Returns:
PyApp

GetDefaultPyEncoding()

Gets the current encoding that wxPython will use when it needs to convert a Python string or unicode object to or from a wxString.

Returns:
string

GetKeyState(key)

Get the state of a key (true if pressed or toggled on, false if not.) This is generally most useful getting the state of the modifier or toggle keys. On some platforms those may be the only keys that work.

Parameters:
key
(type=int)

Returns:
bool

GetTopLevelWindows()

Returns a list of the the application's top-level windows, (frames, dialogs, etc.) NOTE: Currently this is a copy of the list maintained by wxWidgets, and so it is only valid as long as no top-level windows are closed or new top-level windows are created.

Returns:
PyObject

GetTranslation(str)

GetTranslation(String str, String strPlural, size_t n) -> String

Parameters:
str
(type=String)

Returns:
String

GetXDisplay()

Returns a swigified pointer to the X11 display. Returns None on other platforms.

Returns:
void

HelpProvider_Get()

Return the current application-wide help provider.

Returns:
HelpProvider

HelpProvider_Set(helpProvider)

Sset the current, application-wide help provider. Returns the previous one. Unlike some other classes, the help provider is not created on demand. This must be explicitly done by the application.

Parameters:
helpProvider
(type=HelpProvider)

Returns:
HelpProvider

IdleEvent_CanSend(win)

Returns True if it is appropriate to send idle events to this window.

This function looks at the mode used (see wx.IdleEvent.SetMode), and the wx.WS_EX_PROCESS_IDLE style in window to determine whether idle events should be sent to this window now. By default this will always return True because the update mode is initially wx.IDLE_PROCESS_ALL. You can change the mode to only send idle events to windows with the wx.WS_EX_PROCESS_IDLE extra window style set.

Parameters:
win
(type=Window)

Returns:
bool

IdleEvent_GetMode()

Static method returning a value specifying how wxWidgets will send idle events: to all windows, or only to those which specify that they will process the events.

Returns:
int

IdleEvent_SetMode(mode)

Static method for specifying how wxWidgets will send idle events: to all windows, or only to those which specify that they will process the events.

The mode can be one of the following values:

wx.IDLE_PROCESS_ALL | Send idle events to all windows
wx.IDLE_PROCESS_SPECIFIED | Send idle events only to windows that have the wx.WS_EX_PROCESS_IDLE extra style flag set.
Parameters:
mode
(type=int)

Image_CanRead(filename)

Returns True if the image handlers can read this file.

Parameters:
filename
(type=String)

Returns:
bool

Image_CanReadStream(stream)

Returns True if the image handlers can read an image file from the data currently on the input stream, or a readable Python file-like object.

Parameters:
stream
(type=InputStream)

Returns:
bool

Image_GetImageCount(filename, type=BITMAP_TYPE_ANY)

If the image file contains more than one image and the image handler is capable of retrieving these individually, this function will return the number of available images.

Parameters:
filename
(type=String)

type
(type=long)

Returns:
int

Image_GetImageExtWildcard()

Iterates all registered wxImageHandler objects, and returns a string containing file extension masks suitable for passing to file open/save dialog boxes.

Returns:
String

ImageFromBitmap(bitmap)

Construct an Image from a wx.Bitmap.

Parameters:
bitmap
(type=Bitmap)

Returns:
Image

See Also:

wx.Image

ImageFromData(width, height, data)

Construct an Image from a buffer of RGB bytes. Accepts either a string or a buffer object holding the data and the length of the data must be width*height*3.

Parameters:
width
(type=int)

height
(type=int)

data
(type=buffer)

Returns:
Image

See Also:

wx.Image

ImageFromDataWithAlpha(width, height, data, alpha)

Construct an Image from a buffer of RGB bytes with an Alpha channel. Accepts either a string or a buffer object holding the data and the length of the data must be width*height*3 bytes, and the length of the alpha data must be width*height bytes.

Parameters:
width
(type=int)

height
(type=int)

data
(type=buffer)

alpha
(type=buffer)

Returns:
Image

See Also:

wx.Image

ImageFromMime(name, mimetype, index=-1)

Loads an image from a file, using a MIME type string (such as 'image/jpeg') to specify image type.

Parameters:
name
(type=String)

mimetype
(type=String)

index
(type=int)

Returns:
Image

See Also:

wx.Image

ImageFromStream(stream, type=BITMAP_TYPE_ANY, index=-1)

Loads an image from an input stream, or any readable Python file-like object.

Parameters:
stream
(type=InputStream)

type
(type=long)

index
(type=int)

Returns:
Image

See Also:

wx.Image

ImageFromStreamMime(stream, mimetype, index=-1)

Loads an image from an input stream, or any readable Python file-like object, specifying the image format with a MIME type string.

Parameters:
stream
(type=InputStream)

mimetype
(type=String)

index
(type=int)

Returns:
Image

See Also:

wx.Image

ImageHistogram_MakeKey(r, g, b)

Get the key in the histogram for the given RGB values

Parameters:
r
(type=byte)

g
(type=byte)

b
(type=byte)

Returns:
unsigned long

InitAllImageHandlers()

The former functionality of InitAllImageHanders is now done internal to the _core_ extension module and so this function has become a simple NOP.

IntersectRect(r1, r2)

Calculate and return the intersection of r1 and r2.

Parameters:
r1
(type=Rect)

r2
(type=Rect)

Returns:
Rect

LaunchDefaultBrowser(url)

Launches the user's default browser and tells it to open the location at url. Returns True if the application was successfully launched.

Parameters:
url
(type=String)

Returns:
bool

ListBox_GetClassDefaultAttributes(variant=WINDOW_VARIANT_NORMAL)

Get the default attributes for this class. This is useful if you want to use the same font or colour in your own control as in a standard control -- which is a much better idea than hard coding specific colours or fonts which might look completely out of place on the user's system, especially if it uses themes.

The variant parameter is only relevant under Mac currently and is ignore under other platforms. Under Mac, it will change the size of the returned font. See wx.Window.SetWindowVariant for more about this.

Parameters:
variant
(type=int)

Returns:
VisualAttributes

ListCtrl_GetClassDefaultAttributes(variant=WINDOW_VARIANT_NORMAL)

Get the default attributes for this class. This is useful if you want to use the same font or colour in your own control as in a standard control -- which is a much better idea than hard coding specific colours or fonts which might look completely out of place on the user's system, especially if it uses themes.

The variant parameter is only relevant under Mac currently and is ignore under other platforms. Under Mac, it will change the size of the returned font. See wx.Window.SetWindowVariant for more about this.

Parameters:
variant
(type=int)

Returns:
VisualAttributes

LogGeneric(*args, **kwargs)

LogGeneric(unsigned long level, String msg)

LogTrace(*args)

LogTrace(unsigned long mask, String msg) LogTrace(String mask, String msg)

MaskColour(*args, **kwargs)

wx.MaskColour is deprecated, use wx.Mask instead.

MemoryDCFromDC(oldDC)

Creates a DC that is compatible with the oldDC.

Parameters:
oldDC
(type=DC)

Returns:
MemoryDC

MemoryFSHandler_AddFile(filename, dataItem, imgType=-1)

Add 'file' to the memory filesystem. The dataItem parameter can either be a wx.Bitmap, wx.Image or a string that can contain arbitrary data. If a bitmap or image is used then the imgType parameter should specify what kind of image file it should be written as, wx.BITMAP_TYPE_PNG, etc.

MicroSleep(*args, **kwargs)

MicroSleep(unsigned long microseconds)

MilliSleep(*args, **kwargs)

MilliSleep(unsigned long milliseconds)

NamedColor(colorName)

Constructs a colour object using a colour name listed in wx.TheColourDatabase.

Parameters:
colorName
(type=String)

Returns:
Colour

NamedColour(colorName)

Constructs a colour object using a colour name listed in wx.TheColourDatabase.

Parameters:
colorName
(type=String)

Returns:
Colour

Notebook_GetClassDefaultAttributes(variant=WINDOW_VARIANT_NORMAL)

Get the default attributes for this class. This is useful if you want to use the same font or colour in your own control as in a standard control -- which is a much better idea than hard coding specific colours or fonts which might look completely out of place on the user's system, especially if it uses themes.

The variant parameter is only relevant under Mac currently and is ignore under other platforms. Under Mac, it will change the size of the returned font. See wx.Window.SetWindowVariant for more about this.

Parameters:
variant
(type=int)

Returns:
VisualAttributes

Panel_GetClassDefaultAttributes(variant=WINDOW_VARIANT_NORMAL)

Get the default attributes for this class. This is useful if you want to use the same font or colour in your own control as in a standard control -- which is a much better idea than hard coding specific colours or fonts which might look completely out of place on the user's system, especially if it uses themes.

The variant parameter is only relevant under Mac currently and is ignore under other platforms. Under Mac, it will change the size of the returned font. See wx.Window.SetWindowVariant for more about this.

Parameters:
variant
(type=int)

Returns:
VisualAttributes

Point2DCopy(pt)

Create a w.Point2D object.

Parameters:
pt
(type=Point2D)

Returns:
Point2D

Point2DFromPoint(pt)

Create a w.Point2D object.

Parameters:
pt
(type=Point)

Returns:
Point2D

PostEvent(dest, event)

Send an event to a window or other wx.EvtHandler to be processed later.

Parameters:
dest
(type=EvtHandler)

event
(type=Event)

PostScriptDC_GetResolution()

Return resolution used in PostScript output.

Returns:
int

PostScriptDC_SetResolution(ppi)

Set resolution (in pixels per inch) that will be used in PostScript output. Default is 720ppi.

Parameters:
ppi
(type=int)

PreBitmapButton()

Precreate a BitmapButton for 2-phase creation.

Returns:
BitmapButton

PreButton()

Precreate a Button for 2-phase creation.

Returns:
Button

PreCheckBox()

Precreate a CheckBox for 2-phase creation.

Returns:
CheckBox

PreChoice()

Precreate a Choice control for 2-phase creation.

Returns:
Choice

PreComboBox()

Precreate a ComboBox control for 2-phase creation.

Returns:
ComboBox

PreControl()

Precreate a Control control for 2-phase creation

Returns:
Control

PreDatePickerCtrl()

Precreate a DatePickerCtrl for use in 2-phase creation.

Returns:
DatePickerCtrl

PreFindReplaceDialog()

Precreate a FindReplaceDialog for 2-phase creation

Returns:
FindReplaceDialog

PreSplitterWindow()

Precreate a SplitterWindow for 2-phase creation.

Returns:
SplitterWindow

PreWindow()

Precreate a Window for 2-phase creation.

Returns:
Window

PyApp_GetComCtl32Version()

Returns 400, 470, 471, etc. for comctl32.dll 4.00, 4.70, 4.71 or 0 if it wasn't found at all. Raises an exception on non-Windows platforms.

Returns:
int

PyApp_IsMainLoopRunning()

Returns True if we're running the main loop, i.e. if the events can currently be dispatched.

Returns:
bool

Quantize_Quantize(src, dest, desiredNoColours=236, flags=wxQUANTIZE_INCLUDE_WINDOWS_COLOURS|wxQUANTIZE_FILL_DESTIN...)

Reduce the colours in the source image and put the result into the destination image, setting the palette in the destination if needed. Both images may be the same, to overwrite the source image. :todo: Create a version that returns the wx.Palette used.

Parameters:
src
(type=Image)

dest
(type=Image)

desiredNoColours
(type=int)

flags
(type=int)

Returns:
bool

RadioBox_GetClassDefaultAttributes(variant=WINDOW_VARIANT_NORMAL)

Get the default attributes for this class. This is useful if you want to use the same font or colour in your own control as in a standard control -- which is a much better idea than hard coding specific colours or fonts which might look completely out of place on the user's system, especially if it uses themes.

The variant parameter is only relevant under Mac currently and is ignore under other platforms. Under Mac, it will change the size of the returned font. See wx.Window.SetWindowVariant for more about this.

Parameters:
variant
(type=int)

Returns:
VisualAttributes

RadioButton_GetClassDefaultAttributes(variant=WINDOW_VARIANT_NORMAL)

Get the default attributes for this class. This is useful if you want to use the same font or colour in your own control as in a standard control -- which is a much better idea than hard coding specific colours or fonts which might look completely out of place on the user's system, especially if it uses themes.

The variant parameter is only relevant under Mac currently and is ignore under other platforms. Under Mac, it will change the size of the returned font. See wx.Window.SetWindowVariant for more about this.

Parameters:
variant
(type=int)

Returns:
VisualAttributes

RectPP(topLeft, bottomRight)

Create a new Rect object from Points representing two corners.

Parameters:
topLeft
(type=Point)

bottomRight
(type=Point)

Returns:
Rect

RectPS(pos, size)

Create a new Rect from a position and size.

Parameters:
pos
(type=Point)

size
(type=Size)

Returns:
Rect

RectS(size)

Create a new Rect from a size only.

Parameters:
size
(type=Size)

Returns:
Rect

SafeYield(win=None, onlyIfNeeded=False)

This function is similar to wx.Yield, except that it disables the user input to all program windows before calling wx.Yield and re-enables it again afterwards. If win is not None, this window will remain enabled, allowing the implementation of some limited user interaction.

Parameters:
win
(type=Window)

onlyIfNeeded
(type=bool)

Returns:

the result of the call to wx.Yield.

(type=bool)

ScrollBar_GetClassDefaultAttributes(variant=WINDOW_VARIANT_NORMAL)

Get the default attributes for this class. This is useful if you want to use the same font or colour in your own control as in a standard control -- which is a much better idea than hard coding specific colours or fonts which might look completely out of place on the user's system, especially if it uses themes.

The variant parameter is only relevant under Mac currently and is ignore under other platforms. Under Mac, it will change the size of the returned font. See wx.Window.SetWindowVariant for more about this.

Parameters:
variant
(type=int)

Returns:
VisualAttributes

ScrolledWindow_GetClassDefaultAttributes(variant=WINDOW_VARIANT_NORMAL)

Get the default attributes for this class. This is useful if you want to use the same font or colour in your own control as in a standard control -- which is a much better idea than hard coding specific colours or fonts which might look completely out of place on the user's system, especially if it uses themes.

The variant parameter is only relevant under Mac currently and is ignore under other platforms. Under Mac, it will change the size of the returned font. See wx.Window.SetWindowVariant for more about this.

Parameters:
variant
(type=int)

Returns:
VisualAttributes

SetDefaultPyEncoding(encoding)

Sets the encoding that wxPython will use when it needs to convert a Python string or unicode object to or from a wxString.

The default encoding is the value of locale.getdefaultlocale()[1] but please be aware that the default encoding within the same locale may be slightly different on different platforms. For example, please see http://www.alanwood.net/demos/charsetdiffs.html for differences between the common latin/roman encodings.

Parameters:
encoding
(type=string)

SizerItemSizer(sizer, proportion, flag, border, userData=None)

Constructs a wx.SizerItem for tracking a subsizer

Parameters:
sizer
(type=Sizer)

proportion
(type=int)

flag
(type=int)

border
(type=int)

userData
(type=PyObject)

Returns:
SizerItem

SizerItemSpacer(width, height, proportion, flag, border, userData=None)

Constructs a wx.SizerItem for tracking a spacer.

Parameters:
width
(type=int)

height
(type=int)

proportion
(type=int)

flag
(type=int)

border
(type=int)

userData
(type=PyObject)

Returns:
SizerItem

SizerItemWindow(window, proportion, flag, border, userData=None)

Constructs a wx.SizerItem for tracking a window.

Parameters:
window
(type=Window)

proportion
(type=int)

flag
(type=int)

border
(type=int)

userData
(type=PyObject)

Returns:
SizerItem

Slider_GetClassDefaultAttributes(variant=WINDOW_VARIANT_NORMAL)

Get the default attributes for this class. This is useful if you want to use the same font or colour in your own control as in a standard control -- which is a much better idea than hard coding specific colours or fonts which might look completely out of place on the user's system, especially if it uses themes.

The variant parameter is only relevant under Mac currently and is ignore under other platforms. Under Mac, it will change the size of the returned font. See wx.Window.SetWindowVariant for more about this.

Parameters:
variant
(type=int)

Returns:
VisualAttributes

Sound_PlaySound(*args, **kwargs)

Sound_PlaySound(String filename, unsigned int flags=SOUND_ASYNC) -> bool

SpinButton_GetClassDefaultAttributes(variant=WINDOW_VARIANT_NORMAL)

Get the default attributes for this class. This is useful if you want to use the same font or colour in your own control as in a standard control -- which is a much better idea than hard coding specific colours or fonts which might look completely out of place on the user's system, especially if it uses themes.

The variant parameter is only relevant under Mac currently and is ignore under other platforms. Under Mac, it will change the size of the returned font. See wx.Window.SetWindowVariant for more about this.

Parameters:
variant
(type=int)

Returns:
VisualAttributes

SpinCtrl_GetClassDefaultAttributes(variant=WINDOW_VARIANT_NORMAL)

Get the default attributes for this class. This is useful if you want to use the same font or colour in your own control as in a standard control -- which is a much better idea than hard coding specific colours or fonts which might look completely out of place on the user's system, especially if it uses themes.

The variant parameter is only relevant under Mac currently and is ignore under other platforms. Under Mac, it will change the size of the returned font. See wx.Window.SetWindowVariant for more about this.

Parameters:
variant
(type=int)

Returns:
VisualAttributes

SplitterWindow_GetClassDefaultAttributes(variant=WINDOW_VARIANT_NORMAL)

Get the default attributes for this class. This is useful if you want to use the same font or colour in your own control as in a standard control -- which is a much better idea than hard coding specific colours or fonts which might look completely out of place on the user's system, especially if it uses themes.

The variant parameter is only relevant under Mac currently and is ignore under other platforms. Under Mac, it will change the size of the returned font. See wx.Window.SetWindowVariant for more about this.

Parameters:
variant
(type=int)

Returns:
VisualAttributes

StandardPaths_Get()

Return the global standard paths singleton

Returns:
StandardPaths

StaticBitmap_GetClassDefaultAttributes(variant=WINDOW_VARIANT_NORMAL)

Get the default attributes for this class. This is useful if you want to use the same font or colour in your own control as in a standard control -- which is a much better idea than hard coding specific colours or fonts which might look completely out of place on the user's system, especially if it uses themes.

The variant parameter is only relevant under Mac currently and is ignore under other platforms. Under Mac, it will change the size of the returned font. See wx.Window.SetWindowVariant for more about this.

Parameters:
variant
(type=int)

Returns:
VisualAttributes

StaticBox_GetClassDefaultAttributes(variant=WINDOW_VARIANT_NORMAL)

Get the default attributes for this class. This is useful if you want to use the same font or colour in your own control as in a standard control -- which is a much better idea than hard coding specific colours or fonts which might look completely out of place on the user's system, especially if it uses themes.

The variant parameter is only relevant under Mac currently and is ignore under other platforms. Under Mac, it will change the size of the returned font. See wx.Window.SetWindowVariant for more about this.

Parameters:
variant
(type=int)

Returns:
VisualAttributes

StaticLine_GetClassDefaultAttributes(variant=WINDOW_VARIANT_NORMAL)

Get the default attributes for this class. This is useful if you want to use the same font or colour in your own control as in a standard control -- which is a much better idea than hard coding specific colours or fonts which might look completely out of place on the user's system, especially if it uses themes.

The variant parameter is only relevant under Mac currently and is ignore under other platforms. Under Mac, it will change the size of the returned font. See wx.Window.SetWindowVariant for more about this.

Parameters:
variant
(type=int)

Returns:
VisualAttributes

StaticText_GetClassDefaultAttributes(variant=WINDOW_VARIANT_NORMAL)

Get the default attributes for this class. This is useful if you want to use the same font or colour in your own control as in a standard control -- which is a much better idea than hard coding specific colours or fonts which might look completely out of place on the user's system, especially if it uses themes.

The variant parameter is only relevant under Mac currently and is ignore under other platforms. Under Mac, it will change the size of the returned font. See wx.Window.SetWindowVariant for more about this.

Parameters:
variant
(type=int)

Returns:
VisualAttributes

StatusBar_GetClassDefaultAttributes(variant=WINDOW_VARIANT_NORMAL)

Get the default attributes for this class. This is useful if you want to use the same font or colour in your own control as in a standard control -- which is a much better idea than hard coding specific colours or fonts which might look completely out of place on the user's system, especially if it uses themes.

The variant parameter is only relevant under Mac currently and is ignore under other platforms. Under Mac, it will change the size of the returned font. See wx.Window.SetWindowVariant for more about this.

Parameters:
variant
(type=int)

Returns:
VisualAttributes

StockCursor(id)

Create a cursor using one of the stock cursors. Note that not all stock cursors are available on all platforms.

Parameters:
id
(type=int)

Returns:
Cursor

SysErrorMsg(*args, **kwargs)

SysErrorMsg(unsigned long nErrCode=0) -> String

TextCtrl_GetClassDefaultAttributes(variant=WINDOW_VARIANT_NORMAL)

Get the default attributes for this class. This is useful if you want to use the same font or colour in your own control as in a standard control -- which is a much better idea than hard coding specific colours or fonts which might look completely out of place on the user's system, especially if it uses themes.

The variant parameter is only relevant under Mac currently and is ignore under other platforms. Under Mac, it will change the size of the returned font. See wx.Window.SetWindowVariant for more about this.

Parameters:
variant
(type=int)

Returns:
VisualAttributes

ToggleButton_GetClassDefaultAttributes(variant=WINDOW_VARIANT_NORMAL)

Get the default attributes for this class. This is useful if you want to use the same font or colour in your own control as in a standard control -- which is a much better idea than hard coding specific colours or fonts which might look completely out of place on the user's system, especially if it uses themes.

The variant parameter is only relevant under Mac currently and is ignore under other platforms. Under Mac, it will change the size of the returned font. See wx.Window.SetWindowVariant for more about this.

Parameters:
variant
(type=int)

Returns:
VisualAttributes

ToolBar_GetClassDefaultAttributes(variant=WINDOW_VARIANT_NORMAL)

Get the default attributes for this class. This is useful if you want to use the same font or colour in your own control as in a standard control -- which is a much better idea than hard coding specific colours or fonts which might look completely out of place on the user's system, especially if it uses themes.

The variant parameter is only relevant under Mac currently and is ignore under other platforms. Under Mac, it will change the size of the returned font. See wx.Window.SetWindowVariant for more about this.

Parameters:
variant
(type=int)

Returns:
VisualAttributes

TreeCtrl_GetClassDefaultAttributes(variant=WINDOW_VARIANT_NORMAL)

Get the default attributes for this class. This is useful if you want to use the same font or colour in your own control as in a standard control -- which is a much better idea than hard coding specific colours or fonts which might look completely out of place on the user's system, especially if it uses themes.

The variant parameter is only relevant under Mac currently and is ignore under other platforms. Under Mac, it will change the size of the returned font. See wx.Window.SetWindowVariant for more about this.

Parameters:
variant
(type=int)

Returns:
VisualAttributes

UpdateUIEvent_CanUpdate(win)

Returns True if it is appropriate to update (send UI update events to) this window.

This function looks at the mode used (see wx.UpdateUIEvent.SetMode), the wx.WS_EX_PROCESS_UPDATE_EVENTS flag in window, the time update events were last sent in idle time, and the update interval, to determine whether events should be sent to this window now. By default this will always return true because the update mode is initially wx.UPDATE_UI_PROCESS_ALL and the interval is set to 0; so update events will be sent as often as possible. You can reduce the frequency that events are sent by changing the mode and/or setting an update interval.

Parameters:
win
(type=Window)

Returns:
bool

UpdateUIEvent_GetMode()

Returns a value specifying how wxWidgets will send update events: to all windows, or only to those which specify that they will process the events.

Returns:
int

UpdateUIEvent_GetUpdateInterval()

Returns the current interval between updates in milliseconds. -1 disables updates, 0 updates as frequently as possible.

Returns:
long

UpdateUIEvent_ResetUpdateTime()

Used internally to reset the last-updated time to the current time. It is assumed that update events are normally sent in idle time, so this is called at the end of idle processing.

UpdateUIEvent_SetMode(mode)

Specify how wxWidgets will send update events: to all windows, or only to those which specify that they will process the events.

The mode may be one of the following values:

wxUPDATE_UI_PROCESS_ALL | Send UI update events to all windows. This is the default setting.
wxUPDATE_UI_PROCESS_SPECIFIED | Send UI update events only to windows that have the wx.WS_EX_PROCESS_UI_UPDATES extra style set.
Parameters:
mode
(type=int)

UpdateUIEvent_SetUpdateInterval(updateInterval)

Sets the interval between updates in milliseconds. Set to -1 to disable updates, or to 0 to update as frequently as possible. The default is 0.

Use this to reduce the overhead of UI update events if your application has a lot of windows. If you set the value to -1 or greater than 0, you may also need to call wx.Window.UpdateWindowUI at appropriate points in your application, such as when a dialog is about to be shown.

Parameters:
updateInterval
(type=long)

Usleep(*args, **kwargs)

MilliSleep(unsigned long milliseconds)

WakeUpIdle()

Cause the message queue to become empty again, so idle events will be sent.

Window_FindFocus()

Returns the window or control that currently has the keyboard focus, or None.

Returns:
Window

Window_FromHWND(*args, **kwargs)

Window_FromHWND(Window parent, unsigned long _hWnd) -> Window

Window_GetCapture()

Returns the window which currently captures the mouse or None

Returns:
Window

Window_GetClassDefaultAttributes(variant=WINDOW_VARIANT_NORMAL)

Get the default attributes for this class. This is useful if you want to use the same font or colour in your own control as in a standard control -- which is a much better idea than hard coding specific colours or fonts which might look completely out of place on the user's system, especially if it uses themes.

The variant parameter is only relevant under Mac currently and is ignore under other platforms. Under Mac, it will change the size of the returned font. See wx.Window.SetWindowVariant for more about this.

Parameters:
variant
(type=int)

Returns:
VisualAttributes

Window_NewControlId()

Generate a control id for the controls which were not given one.

Returns:
int

Window_NextControlId(winid)

Get the id of the control following the one with the given autogenerated) id

Parameters:
winid
(type=int)

Returns:
int

Window_PrevControlId(winid)

Get the id of the control preceding the one with the given autogenerated) id

Parameters:
winid
(type=int)

Returns:
int

Yield()

Yield to other apps/messages. Convenience for wx.GetApp().Yield()

Returns:
bool

YieldIfNeeded()

Yield to other apps/messages. Convenience for wx.GetApp().Yield(True)

Returns:
bool

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:21 2005 http://epydoc.sf.net


wxversion.VersionError

Module wxversion :: Class VersionError

Class VersionError

Exception --+
            |
           VersionError

Method Summary

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:10:54 2005 http://epydoc.sf.net


wxversion

Module wxversion

Module wxversion

If you have more than one version of wxPython installed this module allows your application to choose which version of wxPython will be imported when it does 'import wx'. The main function of this module is select and you use it like this:

import wxversion
wxversion.select('2.4')
import wx

Or additional build options can also be selected, although they will not be required if they are not installed, like this:

import wxversion
wxversion.select('2.5.3-unicode')
import wx

Or you can require an exact match on the build options like this:

import wxversion
wxversion.select('2.5.3-unicode', optionsRequired=True)
import wx

Finally you can also specify a collection of versions that are allowed by your application, like this:

import wxversion
wxversion.select(['2.5.4', '2.5.5', '2.6'])
import wx

Of course the default wxPython version can also be controlled by setting PYTHONPATH or by editing the wx.pth path configuration file, but using wxversion will allow an application to manage the version selection itself rather than depend on the user to setup the environment correctly.

It works by searching the sys.path for directories matching wx-* and then comparing them to what was passed to the select function. If a match is found then that path is inserted into sys.path.

NOTE: If you are making a 'bundle' of your application with a tool like py2exe then you should not use the wxversion module since it looks at the filesystem for the directories on sys.path, it will fail in a bundled environment. Instead you should simply ensure that the version of wxPython that you want is found by default on the sys.path when making the bundled version by setting PYTHONPATH. Then that version will be included in your bundle and your app will work as expected. Py2exe and the others usually have a way to tell at runtime if they are running from a bundle or running raw, so you can check that and only use wxversion if needed. For example, for py2exe:

if not hasattr(sys, 'frozen'):
    import wxversion
    wxversion.select('2.5')
import wx

More documentation on wxversion and multi-version installs can be found at: http://wiki.wxpython.org/index.cgi/MultiVersionInstalls

Exceptions
VersionError

Function Summary
 | checkInstalled(versions, optionsRequired) Check if there is a version of wxPython installed that matches one of the versions given.
 | ensureMinimal(minVersion, optionsRequired) Checks to see if the default version of wxPython is greater-than or equal to minVersion.
 | getInstalled() Returns a list of strings representing the installed wxPython versions that are found on the system.
 | select(versions, optionsRequired) Search for a wxPython installation that matches version.

Variable Summary
str UPDATE_URL = 'http://wxPython.org/'

Function Details

checkInstalled(versions, optionsRequired=False)

Check if there is a version of wxPython installed that matches one of the versions given. Returns True if so, False if not. This can be used to determine if calling select will succeed or not.

Parameters:
versions - Same as in select, either a string or a list of strings specifying the version(s) to check for.

optionsRequired - Same as in select.

ensureMinimal(minVersion, optionsRequired=False)

Checks to see if the default version of wxPython is greater-than or equal to minVersion. If not then it will try to find an installed version that is >= minVersion. If none are available then a message is displayed that will inform the user and will offer to open their web browser to the wxPython downloads page, and will then exit the application.

getInstalled()

Returns a list of strings representing the installed wxPython versions that are found on the system.

select(versions, optionsRequired=False)

Search for a wxPython installation that matches version. If one is found then sys.path is modified so that version will be imported with a 'import wx', otherwise a VersionError exception is raised. This funciton should only be caled once at the begining of the application before wxPython is imported.

Parameters:
versions - Specifies the version to look for, it can either be a string or a list of strings. Each string is compared to the installed wxPythons and the best match is inserted into the sys.path, allowing an 'import wx' to find that version.

The version string is composed of the dotted version number (at least 2 of the 4 components) optionally followed by hyphen ('-') separated options (wx port, unicode/ansi, flavour, etc.) A match is determined by how much of the installed version matches what is given in the version parameter. If the version number components don't match then the score is zero, otherwise the score is increased for every specified optional component that is specified and that matches.

Please note, however, that it is possible for a match to be selected that doesn't exactly match the versions requested. The only component that is required to be matched is the version number. If you need to require a match on the other components as well, then please use the optional optionsRequired parameter described next.

optionsRequired - Allows you to specify that the other components of the version string (such as the port name or character type) are also required to be present for an installed version to be considered a match. Using this parameter allows you to change the selection from a soft, as close as possible match to a hard, exact match.

Variable Details

UPDATE_URL

Type:
str
Value:
'http://wxPython.org/'

Home Trees Index Help

wxPython

Generated by Epydoc 2.1.20050511.rpd on Mon May 30 12:13:51 2005 http://epydoc.sf.net